Part 6


Test Drive�Microsoft Exchange





�
Microsoft Exchange Test Drive Setup


Test Drive Prerequisites


To successfully setup a test drive of Microsoft Exchange, working knowledge of the following will be helpful:


Installing and configuring Microsoft® Windows NT™ Server


Creating accounts, policies, and user rights


Test Drive Requirements


This test drive requires a minimum of two computers. Install and configure all computers using the information and instructions that follow.





Notes


Instructions for adding a second server are included as an optional task given the availability of additional hardware for test drive.


All hardware must be on the Windows NT version 3.51 Hardware Compatibility List.














Computer 1 (ServerX)


Hardware


66 Mhz 80486 or higher CPU


Minimum of 24 MB RAM (32 to 48 MB of RAM is recommended for best performance)


Minimum of 250 MB free hard disk space (multiple disk drives are recommended)


Mouse


Network Adapter Card and related cables


VGA, SVGA, or XGA display adapter and monitor


CD-ROM Drive


3.5-inch 1.44 MB floppy disk drive





Software


Microsoft Windows NT Server 3.51


Service Pack 4 provided on the Exchange Server CD-ROM


Microsoft Exchange Server 4.0





Computer 2 (Client Machine)








Hardware


50 Mhz 80486 or higher CPU


Minimum of 12 MB RAM (16 recommended)


Minimum of 20 MB hard drive


Mouse


Network Adapter Card and related cables


VGA, SVGA, or XGA display adapter and monitor


CD-ROM Drive (optional)


3.5-inch 1.44 MB floppy disk drive (optional)





Software


Microsoft Windows 95 


Microsoft Exchange client software 


Exchange Forms Designer








(Optional) Computer 3 (ServerY)


Hardware


66 Mhz 80486 or higher CPU 


Minimum of 24 MB RAM (32 to 48 of RAM is recommended for best performance)


Minimum of 250 MB free hard disk space (multiple disk drives are recommended)


Mouse


Network Adapter Card and related cables


VGA, SVGA, or XGA display adapter and monitor


CD-ROM Drive


3.5-inch 1.44 MB floppy disk drive





Software


Microsoft Windows NT Server 3.51 


Service Pack 4 included in the Microsoft Exchange Server 4.0 CD-ROM


Microsoft Exchange 4.0


Notes


The above requirements are always the minimum requirements or recommended configurations. For a minimum requirements please see the documentation provided in the product.





Reference Material


The following materials should be available:


Microsoft Exchange Server Planning and Concepts Guide


Microsoft Exchange Server Administrator’s Guide





Setup Instructions


The test drive requires a minimum of two computers. Computers will be configured according to their roles. Optional 2nd server installation instructions are included also.





Note	These lab exercises are predicated on two computers networked together with one of the following network protocols: IPX/SPX, TCP/IP, or NetBEUI. A MicroHub can be used to isolate the two test drive systems from other networks..





Before You Begin


Read this documentation before you begin configuring the computers.


All computers will reside in the same Windows NT domain.


Computer 1’s Windows NT Server computer name will be ServerX. The domain name will be EXCHDOM1.


Computer 2’s Windows 95 computer name will be Wksta1. The domain name will be EXCHDOM1.


Computer 3, if used, will be a Windows NT Server and computername will be Server Y.  This will be a backup domain controller (BDC) in the EXCHDOM1 domain.





Note


You are certainly free to use whatever existing machine names and structures that you currently have in place.  These names have been established and tested for purposes of the test drive scenarios but are not mandatory.  For further information on naming conventions and requirements, refer to the Planning and Concepts Guide.





The Administrator account on the Windows NT ServerX must be created using password for the account password. 


The computer name of the Windows NT Server is used by Exchange Server, therefore you should not use any punctuation in the name. For example: ServerX, ServerY, ServerZ.


t





Computer 1 (ServerX) Setup


Use the following instructions to set up ServerX.


To set up the hardware


Set up the hardware according to the manufacturer’s instructions. (Refer to the hardware requirements.)


To install and configure the software


Install the Windows NT Server 3.51 using the computer name ServerX. This server will be the Primary Domain Controller for the WindowsNT Server domain named EXCHDOM1.


Create the Administrator account using “password” for the account password.


Install Service Pack 4 that is on the Exchange Server CD-ROM. In order to do this, run the UPDATE.EXE program from the appropriate directory inside the PATCHES directory on the Exchange Server Enterprise Edition CD-ROM.





Computer 2 (wksta1) Setup


Use the following instructions to set up ServerY.


To set up the hardware


Set up the hardware according to the manufacturer’s instructions. (Refer to the hardware requirements.)


To install and configure the software





Note


Computer 2 (Wksta1) will be used for the test drive of the Microsoft Exchange Client software.  This machine will run Windows 95 shipping version.





Install the Windows 95 using the computer name Wksta1. The domain name will be EXCHDOM1.


Optional Computer 3 (ServerY) Setup


Use the following instructions to set up ServerY.


To set up the hardware


Set up the hardware according to the manufacturer’s instructions. (Refer to the hardware requirements.)


To install and configure the software


Install the Windows NT Server 3.51 using the computer name ServerY. This server will be the Backup Domain Controller for the Windows NT Server domain named EXCHDOM1.


Create the Administrator account using “password” for the account password.


Install Service Pack 4 that is on the Exchange Server CD-ROM. In order to do this, run the UPDATE.EXE program from the appropriate directory inside the PATCHES directory on the Exchange Server Enterprise Edition CD-ROM.


�
Setup Task 1: Installing and Verifying a Microsoft Exchange server


Objectives


After completing these tasks you will have successfully:


Installed a Microsoft Exchange Server.


Verified the installation.





Before You Begin





Note


Perform these tasks on Serverx.





The following tables contains information to assist you during the installation process:


When this information is required�
Use�
�
�
�
�
Source Installation Path�
Exchange Server Enterprise Edition CD-ROM: SETUP\I386\SETUP.EXE�
�
Destination Installation Path�
C:\EXCHSRVR�
�
Organization Name�
MSFT�
�
Site Name�
SITE1�
�
Server Name�
ServerX�
�






ct


Estimated time to complete this task: 40 minutes





Exercise 1 � Installing Microsoft Exchange Server


In this exercise, you will install the Microsoft Exchange Server on a Windows NT Server computer.


To install Microsoft Exchange


Log on to the EXCHDOM1 domain as Administrator using password for the password.,


Start File Manager, and then select the Source installation path.


Start SETUP.EXE to begin installing Microsoft Exchange.


A Microsoft Exchange Server Setup message box appears.


Choose OK.


The Microsoft Exchange Server Setup dialog box appears.


Choose Complete/Custom.


The Microsoft Exchange Server Setup - Complete/Custom dialog box appears.


Verify all options are selected, and then choose Continue.


In the Choose Licensing Mode dialog box, select the client licensing mode and choose Continue. For Per Server Licensing, enter the number of clients you are planning to connect to this server.





Note


If you select Per Server License, enter a value greater than 0 for concurrent connections. Otherwise Microsoft Exchange clients are unable to connect to the Microsoft Exchange Server computer.





Check I agree and then choose OK in the licensing information box.


In the Exchange Site dialog box, verify the Create a new site option is selected.


Type in the following information to identify your Exchange Site:





Note


If you choose not to use the names provided in the previous  table, please refer to the planning and concepts guide before proceeding.  By default, some names in Exchange will become part of the addressing name space and so careful consideration should be given to these names.





Organization:		MSFT 


Site:					Site1


Choose OK.


A Microsoft Exchange Server Setup message appears prompting to confirm creation of a new site.


Choose Yes.


A Site Services Account dialog box appears.


In the Service Account Password box, type password and then choose OK.


Files are copied as Microsoft Exchange is installed locally. 





Note  


If you choose to do so you can create a separate Service Account in your Windows NT domain.  The permission and right requirements of the service account is discussed in more detail in the documentation provided with the Exchange Server. By default, Microsoft Exchange Server Setup program, gives the account you are logged on as, the correct rights to be a service account.





A Microsoft Exchange Server Setup message appears indicating Microsoft Exchange Setup has completed successfully. At this point, if you choose to the Performance Optimizer can be executed to optimize the layout of the Exchange Server components on your hardware for better performance.


Choose Exit Setup.


Program Manager appears with the Microsoft Exchange program group open and displaying five icons: Microsoft Exchange Optimizer, Microsoft Exchange Administrator, Microsoft Exchange Migration Wizard, Microsoft Exchange Setup Editor, and Books Online.


Shutdown and restart the computer. 





Note  


Rebooting the server right after setup completion ensures path and other variables are updated.





Exercise 2�Verifying the Installation


In this exercise, you will verify the necessary services for Microsoft Exchange have started successfully.


To validate service initialization


Log on at ServerX as administrator using password for the password.


Using Control Panel Services, Server Manager, or a command prompt, verify the following Microsoft Exchange services are installed, started and set to Automatic startup:


Microsoft Exchange Directory


Microsoft Exchange Information Store	


Microsoft Exchange Message Transfer Agent


Microsoft Exchange System Attendant 


Also verify the following Windows NT Server services are installed, started and set to Automatic startup. These services are installed by default during the Windows NT Server setup and are required services for Microsoft Exchange Server:


EventLog


OLE


NT LM Security Support Provider


Server


Workstation


Remote Procedure Call (RPC) Locator


Remote Procedure Call (RPC) Service


Also verify the following Microsoft Exchange services are installed:


Microsoft Exchange Directory Synchronization


Microsoft Exchange Internet Mail Connector


MS Mail Connector Interchange


MS Schedule+ Free/Busy Connector


The following services may need to be started if you are planning to test the Microsoft Mail connectivity and Internet mail connectivity:


Microsoft Exchange Internet Mail Connector


Microsoft® Mail Connector Interchange





Note  


By stopping and setting  these last two services to Manual startup, you may save on used RAM during the test drive.





Summary





This objective...�
Was met by...�
�
�
�
�
�
�
�
Install a Microsoft Exchange Server.�
Using SETUP.EXE to install Microsoft Exchange Server on the local Windows NT Server PDC.�
�
Verify the Installation.�
Using Control Panel Services, Server Manager, or a command prompt to verify the appropriate Microsoft Exchange services has started successfully.�
�



Congratulations, you have successfully installed your first Microsoft Exchange Server!  You will notice the ease of setup and yet you have established a naming convention for the entire organization of users which will be inherited when additional servers are added.  In addition, you have established the first site of the organization and set the stage for adding additional resources to the organization.  You have also established the initial interface to the Internet and to Microsoft Mail for PC Networks.  All in about 40 minutes.  Well done!  You are now prepared to move onto the next phase of the test drive.


�
Optional Setup Task 2: Adding a Microsoft Exchange server�to a Messaging Site


Objectives


After completing this test drive, you will have successfully completed:


Adding a Microsoft Exchange Server to a messaging site.


Verifying the installation.





Before You Begin





Note


Perform this lab, Adding an Exchange Server to a Messaging Site, on ServerY to join ServerX’s site.





Obtain the following information from ServerX:


When this information is required�
Use�
�
�
�
�
Source installation path�
Exchange Server Enterprise Edition CD-ROM: SETUP\I386\SETUP.EXE�
�
Computer Name�
ServerX�
�
Site Name�
SITE1�
�
Organization Name�
MSFT�
�
Service Account Password�
password�
�



Estimated time to complete this lab: 40 minutes








Exercise 1 �Adding a Microsoft Exchange Server to a Site 


In this exercise, you will install Microsoft Exchange Server on a Windows NT Server backup domain controller and join the existing messaging site.





Note


Perform this lab on ServerY only.





Log on to EXCHDOM1 domain as Administrator with no password.


Start File Manager, and then select the Source installation path.


Start SETUP.EXE to begin installing Microsoft Exchange.


A Microsoft Exchange Server Setup message box appears.


Choose OK.


The Microsoft Exchange Server Setup dialog box appears.


Choose Minimum.


Verify that the right options are selected and then choose Continue.


In the Choose Licensing Mode dialog box, select the client licensing mode and choose Continue. For Per Server Licensing, enter the number of clients you are planning to connect to this server.





Note


If you select Per Server License, enter a value greater than 0 for concurrent connections. Otherwise Microsoft Exchange clients are unable to connect to the Microsoft Exchange Server computer.





Check I agree and then choose OK in the licensing information box.


In the Exchange Site dialog box, select Join An Existing Site, and then in the Existing Server box, type ServerX.


Choose OK to continue.


The Confirm Exchange Site and Organization dialog box appears.


Verify the Server, Organization, and Site information is correct, and then choose Yes.


A Site Services Account dialog box appears.


In the Service Account Password box, type password and then choose OK.


Files are copied as Microsoft Exchange is installed locally. 





Note  


If you choose to do so you can create a separate Service Account in your Windows NT domain.  The permission and right requirements of the service account is discussed in more detail in the documentation provided with the Exchange Server. By default, Microsoft Exchange Server Setup program, gives the account you are logged on as, the correct rights to be a service account.





A Microsoft Exchange Server Setup message appears indicating Microsoft Exchange Setup has completed successfully. At this point, if you choose to the Performance Optimizer can be executed to optimize the layout of the Exchange Server components on your hardware for better performance.


Choose Exit Setup.


A Microsoft Exchange Server Setup message box appears indicating Replication within the site has been initiated.


Program Manager appears with the Microsoft Exchange program group open and displaying the Microsoft Exchange Administrator, Microsoft Exchange Optimizer, Microsoft Exchange Migration Tool and Microsoft Exchange Setup Editor icons.


Shutdown and restart the computer.





Note  


Rebooting the server right after setup completion ensures path and other variables are updated.





Exercise 2 �Verifying the Installation


In this exercise, you will verify the necessary services for Microsoft Exchange Server are started.


Log on as Administrator using password for the password.


Using Control Panel Services, Server Manager, or a command prompt, verify the following Microsoft Exchange services are installed, started and set to Automatic startup:


Microsoft Exchange Directory


Microsoft Exchange Information Store	


Microsoft Exchange Message Transfer Agent


Microsoft Exchange System Attendant 


Also verify the following Windows NT Server services are installed, started and set to Automatic startup. These services are installed by default during the Windows NT Server setup and are required services for Microsoft Exchange Server:


EventLog


OLE


NT LM Security Support Provider


Server


Workstation


Remote Procedure Call (RPC) Locator


Remote Procedure Call (RPC) Service





�
Summary


This objective...�
Was met by...�
�
�
�
�
Add a Microsoft Exchange Server to a messaging site.�
Using SETUP.EXE to install Microsoft Exchange Server on the local Windows NT Server, and selecting to join an existing site during the installation process.�
�
Verify the installation.�
Using Control Panel Services, Server Manager, or a command prompt to verify the appropriate Microsoft Exchange services have started successfully.�
�



Congratulations!  You have successfully added a second Microsoft Exchange server to your existing organization and site.  This can be further verified by starting the Microsoft Exchange Server Administration program in the site now.  Expand the tree in the left window pane by clicking on the SITE1 object.  In the right window pane you will find an object called Servers and if you expand upon this you will that you now have the ability to select either ServerX or ServerY in your site.  


By merely installing the second Microsoft Exchange Server in the site, you will notice that the servers have found each other and directory replication has taken place automatically without an administrator.  No need to create a complex grid of schedules, drive paths, network locations or even network addresses.  As you continue the test drive your will notice that creating a new user will cause that new users to automatically appear at every server in the site.  If you follow this thread and install additional servers in the site, those servers will establish themselves in the exact same manner.  You are now prepared to move onto the next phase of the test drive or to continue along the optional installation test drive track.


�
Optional Setup Task 3: Connecting to Microsoft Mail 3.x


Objectives


After completing this test drive, you will have successfully:


Configured the Microsoft Mail Connector.


Rebuilt the routing table.


Configured a Microsoft Mail 3.x postoffice to communicate with Microsoft Exchange Server.


Send mail from a Microsoft Mail 3.x MS-DOS client to a Microsoft Microsoft Exchange Client for Windows 95.





Before You Begin





Note


Perform this lab on ServerX.  You will need to have installed, on the same network as ServerX or on ServerX, an Microsoft Mail 3.x Postoffice which is valid to connect to other Postoffices.  Caution, if the serial number of your installed Microsoft Mail Postoffice begins with 0799, it must be upgraded as it cannot connect to any other gateway or Microsoft Exchange Server connector. 


The instructions below assume that you have installed Microsoft Mail 3.x on ServerX and used po1data and po1exe as the data and executable directories.








Estimated time to complete this lab: 30 minutes








Exercise 1 �Configuring the Microsoft Mail Connector 


In this exercise, you will use Microsoft Exchange Administrator to configure the Microsoft Mail Connector.





Note


Perform this exercise from ServerX.





Log on as Administrator using password for the password.


From the Microsoft Exchange program group, start Microsoft Exchange Administrator.


In the Organization Hierarchy pane, double-click your site, double-click the Configuration container, and then double-click Connections.


In the right pane, double-click Microsoft Mail Connector for your server.


The Microsoft Mail Connector dialog box appears.


Choose Change.


The Administrator’s Mailbox dialog box appears.


Select Microsoft Exchange User 1 and choose OK.


Select the Connections tab and choose Create.


The Create Connection dialog box appears.


Verify the LAN option is selected and then choose Change.


The Postoffice Path dialog box appears.


In the Path box, type \\ServerX\po1data and then choose OK.


The Create Connection dialog box appears.


Verify the network and postoffice names are correct, and then choose OK.


Choose OK when prompted to apply connection changes.


Choose Yes when prompted to recalculate routing.


Choose OK when the message appears stating the new routing information will take several minutes to replicate across the site and take effect.


Select the Connector MTAs tab and then choose New.


The New Microsoft Mail Connector (PC) MTA Service dialog box appears.


Type the following information: (press the tab key to move through the fields)


Service Name:			Connector MTA


Check for mail every:	1 minute


Choose OK.


In the Microsoft Mail Connector dialog box, choose List.


The Serviced LAN Postoffices dialog box appears.


In the Available LAN Postoffices box, select your postoffice, and choose Add.


Choose OK.


Choose Apply in the Microsoft Mail Connector dialog box.


Select the Local Postoffice tab and write down the following information:


Note: The names here by default are the organization name and the site name from the setup of Microsoft Exchange Server.


Network:  	______________________________


Postoffice:	_______________________________


Choose OK.





Exercise 2�Recalculating the Routing Table and Starting the Connector MTA Service





Note


Perform this exercise from ServerX.





In the Microsoft Exchange Administrator Organization Hierarchy pane, double-click Servers, and then double-click ServerX.


Double-click Message Transfer Agent in the right pane.


The Message Transfer Agent dialog box appears.


Choose Recalculate Routing.


Choose OK when the message appears stating the new routing information will take several minutes to replicate across the site and take effect.


Choose OK.


Using the Services applet in Control Panel, start the MS Mail Connector (PC) MTA service.


Choose Exit from the Services dialog box and choose File, Exit from the Control Panel.


In the Microsoft Exchange Administrator dialog box, choose Exit from the File menu.


Exercise 3�Configuring a Microsoft Mail Postoffice to Connect to Microsoft Exchange.





Tip


You will need to connect your workstation to the executable share under a dos shell to run the Microsoft Mail 3.x administrator program to be successful in this exercise.





In this exercise, you will use the Microsoft Mail 3.2 Administrator program to configure the Microsoft Mail 3.x postoffice.





Note


Perform this exercise from ServerY. While logged on as Administrator, use the Services applet in Control Panel to stop the System Attendant service.





Logon as user1 using password for the password.


Start a MS-DOS session window.


At the C:>, type the following commands:


net use f:\\ServerX\po1exe


net use m:\\ServerX\po1data


Switch to network drive F.


Type administrator and press ENTER.


When you are prompted for a mailbox, type administrator and press ENTER.  Type password for the password and press ENTER.


The main Administrator screen appears.


Press E to choose External-Administrator, and then C to choose Create.


Type in the Network name you obtained in Exercise 1 and then press ENTER.


Type in the Postoffice name you obtained in Exercise 1 and then press ENTER.


Press ENTER to select the Direct Route type.


Press D to select the MS-DOS Drive option.


Press ENTER when prompted to create.


Press ESC twice to exit the Administrator program and press ENTER to choose Yes when prompted to quit.


Exercise 4 �Sending Mail from the Microsoft Mail 3.2 MS-DOS Client 


In this exercise, you will use the Microsoft Mail 3.2 MS-DOS client to send mail to a Microsoft Windows 95-based Microsoft Exchange Client.





Note


Perform this exercise from a MS-DOS shell connected to the po1data and po1exe directories of ServerX.





At the F:\client prompt, type mail and press ENTER.


When you are prompted for a mailbox, type administrator and press ENTER.  Type password for the password and press ENTER.


Press C to compose.


Press ENTER to display the Postoffice Address List.


Press LEFT ARROW to display the list of available Address Lists.


Select the Postoffice Network List and press ENTER.


Select your Network name obtained in Exercise 1.


Type user1 when prompted for a mailbox name and press ENTER.


Press DOWN ARROW to move to the Subject box, press ENTER, and then type External Microsoft Mail 3.2.


Use DOWN ARROW to move to the message body and then type a message.


Press ESC, press T to Transmit and then press ENTER when prompted to transmit.


Press ESC until prompted to quit.  Choose Yes to exit.


At the F:\client prompt, type exit and press ENTER.





Note


The message that you just sent will need to go through several Exchange services.  Since you emulating the existence of several different systems running simultaneously, the delivery of this message will take a few minutes.








Exercise 5 �Viewing Messages using the Microsoft Exchange Client for WindowsNT


In this exercise, you will use the Microsoft Exchange Client for Windows 95to view the message you sent in the last exercise.





Note


Perform this exercise from machine running Windows 95 software and Exchange client software program.





From the Microsoft Exchange program group, start Microsoft Exchange.


The Microsoft Exchange client program will appear.


Check your Inbox for the message you sent to User1.





Note


If the message is not in your Inbox, stop and restart the Connector MTA service on ServerX.





When you are finished reading the message, choose Reply from the toolbar and type Reply to PC Mail from Microsoft Exchange.  Choose Send from the toolbar. 


Exercise 6 �Viewing Messages using the Microsoft Mail 3.2 MS-DOS-based Client 


In this exercise, you will use the Microsoft Mail 3.2 MS-DOS client to view the message you sent in the last exercise.





Note


Perform this exercise from a MS-DOS shell connected to the po1data and po1exe directories on ServerX.





At the C:> prompt, switch to F:\client, type mail, and press ENTER.


Sign in as Administrator using password for the password.


You will see a message from user1.


Press R for read, select the message and then press ENTER.


You will see the message that you replied to in the last exercise.


Exit from the MS-DOS client.


At the F:\client prompt, type exit and press ENTER.


Exit from Windows NT.


Summary


This objective...�
Was met by...�
�
�
�
�
Configure the Microsoft Mail Connector.�
Selecting the Microsoft Mail Connector in your Organization hierarchy and configuring Connections and the Connector MTA.�
�
Recalculate routing table.�
Selecting the Message Transfer Agent in your organization hierarchy, choosing the Recalculate Routing and then starting the necessary Microsoft Exchange services.�
�
Configure a Microsoft Mail 3.2 postoffice to communicate with Microsoft Exchange.�
Using the Mail 3.x Administrator program to configure a connection to Microsoft Exchange.�
�
Send mail from a Microsoft Mail 3.2     MS-DOS client to a Microsoft Exchange Client for WindowsNT.�
Using the Microsoft Mail 3.x for MS-DOS and Microsoft Exchange Clients for Windows 95 to send and receive mail.�
�



Congratulations!  You have successfully installed and configured the Microsoft Mail Connector to Microsoft Mail 3.x systems.  You also added the Microsoft Exchange hierarchy to the Network/Postoffice scheme of Microsoft Mail 3.x by merely adding another postoffice definition to Microsoft Mail 3.x using the existing administrator tools.  The rest of the configuration and control rest with the Exchange graphical administration interface for ease of use.  The Microsoft Mail connector components are part of the normal Exchange hierarchy and as such are easily viewed and configured from a single seat in the Organization.  Your are now prepared to continue the test drive.


�
Setup Task 4: Creating a Mailbox


Objectives


After completing this test drive task you will have successfully:





Created a Microsoft Exchange mailbox using User Manager for Domains.


Created a Microsoft Exchange mailbox using Microsoft Exchange Administrator.





Before You Begin





Note


Perform this lab on ServerX.


Per


This information is provided to speed your installation progress:


When this information is required�
Use�
�
�
�
�
User Account�
User1�
�



Estimated time to complete this lab: 20 minutes





Exercise 1 �Using User Manager for Domains to Create an Exchange Mailbox 


In this exercise, you will use User Manager for Domains to add a user to both Windows NT Server and Microsoft Exchange Server.


To create a Windows NT user account


Log on as administrator using password for the password.


From the Administrative Tools group, start User Manager for Domains.


From the User menu, choose New User.


Complete the New User dialog box using the following information:


User name:	user1


Full name:	Microsoft Exchange User1


Description: Microsoft Exchange Test User1


Password:	password


Confirm Password: password


Clear User Must Change Password at Next Logon.


The Mailbox Microsoft Exchange User1 Properties dialog box appears.


Notice that the Display name, Alias name, and Home Site Server information are inherited from Windows NT User Manager for Domains.  You may fill in additional properties as needed and continue.


From the Mailbox Microsoft Exchange User1 Properties dialog box, choose OK.


Choose Close in the New User dialog box.


From the Policies menu, choose User Rights.


In the Right box, choose Log on locally from the drop-down list.


Choose Add.


Choose Show Users.


Select User1 and choose Add.


Choose OK.


Choose OK.


Exit the User Manager.


Exercise 2 �Using Microsoft Exchange Administrator to Create an Exchange Mailbox


In this exercise, you will use Microsoft Exchange Administrator to add a Microsoft Exchange mailbox to an existing Windows NT user.


To start Microsoft Exchange Administrator


From the Microsoft Exchange group, start Microsoft Exchange Administrator.


The Connect to server Browser dialog box appears prompting for a server to connect to.


Choose Browse and select your server name.


Select Set As Default, and then choose OK.


To create a mailbox


In this procedure, you will create a mailbox for the Windows NT Administrator account.


From the File menu, choose New Mailbox.


A Microsoft Exchange Server message box appears prompting to switch to the Recipients container.


Choose OK.


Complete the mailbox creation by typing the following information:


In this box�
You type�
�
�
�
First�
Admin�
�
Last�
A�
�



Notice that an alias is automatically created for this mailbox. The alias creation algorithm can be specified in the Options dialog box in the Tools menu.


You will be prompted for the Primary Windows NT Account, and will be given the choice to create a Windows NT account or select an existing account.


From the Primary Windows NT Account dialog box, Select an existing Windows NT Account, and choose OK. 


The Add User or Group dialog box appears.


Under Names, select Administrator and choose Add, and then OK.


Choose OK.


Exit the Microsoft Exchange Administrator.


Summary


Summary This objective...�
Was met by...�
�
�
�
�
Create a Microsoft Exchange mailbox using User Manager for Domains.�
Using User Manager for Domains to create a user account, and then the mailbox for the user User1.�
�
Create a Microsoft Exchange mailbox using Microsoft Exchange Administrator.�
Using Microsoft Exchange Administrator to create an Exchange mailbox for the Windows NT Administrator account.�
�



Congratulations!  You have now completed the second phase of the test drive installation.  The idea here is to exercise the ability to create accounts for Microsoft Exchange through the Windows NT user account manager for domains to view the integration between the two Microsoft BackOffice products.  You also saw how the two can be totally separate functions as well by using the Microsoft Exchange Administrator program to add mailbox rights to an existing Windows NT account.  You are now prepared to move to phase three of the installation test drive.


�
Setup Task 5: Installing a Microsoft Exchange Client for Windows 95 and Schedule + 7.0


Objectives


After completing this test drive, you will have successfully:


Installed a Microsoft Exchange Client for Windows 95.


Installed a Schedule + 7.0 client.


Sent and received mail using the Microsoft Exchange Client for Windows 95.





Estimated time to complete this lab: 10 minutes





Exercise 1 �Installing the Microsoft Exchange Client for Windows 95


In this exercise, you will install the Microsoft Exchange Client for Windows 95.


Boot to Windows 95.


Log on as User1 with a password of password.


From within the appropriate directory in the Microsoft Exchange Clients CD-ROM, run SETUP.EXE.


The Microsoft Exchange Setup dialog box appears.


Choose Continue.


The Name and Organization Information dialog box appears prompting for registration information.


Type in the following information.


Name:			user1


Organization:	MSFT


Choose OK.


A confirmation dialog box appears.


Choose OK.


A Microsoft Exchange Setup dialog box appears displaying a default directory.


Choose Change Directory.


In the Path box, select C:\PROGRAM FILES\EXCHANGE  and then choose OK.


Choose Yes to confirm creation of the new directory.  


The Microsoft Exchange Setup dialog box appears.


Choose OK.


The Microsoft Exchange Setup dialog box appears listing installation types.


Choose Custom.


The Microsoft Exchange - Custom dialog box appears.


Verify that both Microsoft Exchange and Schedule+ are selected, and then choose Continue.


A Microsoft Exchange Setup message box appears indicating setup was completed successfully.


Choose OK to continue.





To create a profile


If you are running Microsoft Exchange on this Windows 95 computer for the first time, you will be prompted by the Profile Creation Wizard.


If you already have a user profile created on this computer before, you need to create a new profile for this lab. In order to do this, bring up Microsoft Exchange properties dialog box, by right mouse clicking on the Inbox shortcut on your Windows 95 desktop.


Make sure the new profile you create contains the following:


Microsoft Exchange Server: Server Name = “ServerX”, User Name = “User1”


Also make sure that this new profile is used next time the client software is started.


Start the Microsoft Exchange client.


Exercise 2�Sending, Receiving and Reading a Message


In this exercise, you will send and receive a mail message using the Microsoft Exchange Client for Windows 95.


To create and send a mail message


From the Taskbar, choose Start.


The Start menu appears.


Choose Programs.


A new menu displaying program choices appears.


Choose Microsoft Exchange.


A menu of Microsoft Exchange options appears.


Choose Microsoft Exchange.


NOTE:  Set up your profile through the Microsoft Wizard.


The Microsoft Exchange client starts.


From the Compose menu, choose New Message. (You can also compose a new message by choosing the Compose button from the toolbar, or by pressing CTRL+N.)


Choose To.


The Address Book dialog box appears.


Select your user name, and then choose To.


Choose OK.


In the Subject box, type Welcome to Microsoft Exchange from Microsoft Exchange Client for Windows 95.


Type a short message, and then choose Send to send the message.


The message is sent, and the Exchange client indicates that it has received new mail.


To read the new message


In the following procedure, you will read the newly received mail message, and then exit the Microsoft Exchange Client for Windows 95.


Highlight the new message in the right pane.


From the File menu, choose Open.


From the File menu, choose Close. 


From the File menu, choose Exit and Log Off.





Summary





This objective...�
Was met by...�
�
�
�
�
Install a Microsoft Windows 95 Exchange client.�
Using SETUP.EXE to install the Microsoft Exchange Client for Windows 95 on a Windows 95 client computer.�
�
Send and receive mail using a Microsoft Windows 95 Exchange client.�
Using the Microsoft Exchange Client for Windows 95 to create, send, receive and display a message.�
�



Congratulations!  You have successfully completed phase three of the installation test drive. You have verified that the installation of the Microsoft Exchange Client for Windows 95 was successful and is working with the Microsoft Exchange Server previously installed and configured.  You are now ready for the next phase of the test drive.  You may proceed to the Test Drive section of the guide or continue with the optional Installation test drive section.


�
Setup Task 6: Creating and Configuring Public Folders 


Objectives


After completing this test drive, you will have successfully:


Created and configured a public folder.


Sent mail to a public folder.





Before You Begin





Note


Perform this lab using client logged into ServerX.





Estimated time to complete this lab: 10 minutes








Exercise 1 �Creating and Configuring a Public Folder 


In this exercise, you will use the Microsoft Exchange Client for Windows 95 to create and design a public folder.





Note


You should perform this task while logged into ServerX as User1. If you are using Optional second ServerY those instructions are in parenthesis.





To create a public folder


Verify that you are logged on as user1 from ServerX with a password of password. (Log on as Administrator from ServerZ with a password of password.)


Start Microsoft Exchange client.


The Microsoft Exchange window appears.


Open Public Folders, select All Public Folders, and then from the File menu, choose New Folder.


The New Folder dialog box appears.


In the New Folder box, type 


From ServerY�
(From ServerZ)�
�
�
�
�
PUBLIC FOLDER - User1�
(PUBLIC FOLDER - Administrator)�
�



Choose OK.


The Microsoft Exchange window appears displaying the new folder in the right window pane.


To configure a public folder


Select the Public Folder that you created, and then from the File menu, choose Properties.


The Properties for PUBLIC FOLDER dialog box appears.


Select the Administration tab, and then click on Personal Address Book to add the folder address to it..


Choose OK.


Exercise 2�Using the Public Folder


In this exercise, you will send and view mail messages using the Microsoft Exchange Client for Windows 95 and the new public folder.


From the Compose menu, choose New Message.


A blank Microsoft Exchange mail message form appears.


Choose To.


The Address Book dialog box appears.


Select Personal Address Book, select your public folder name, and then choose To.


Choose OK to return to the message.


In the Subject box, type Test message 1.


Type a short message, and the choose Send.


Send another message to your public folder with a subject of Test message 2.


Open your public folder.


Open Test message 1.


From the View menu, choose Previous. 


Test message 2 appears.


From the File menu, choose Close.


While the public folder is highlighted, select Add to Favorites from the File menu.  This will add the public folder to your favorites list.  As the public folder tree in your organization grows, you will find the favorites useful in quickly getting to the public folder you use most frequently.


From the File menu, choose Exit and Log Off.





Summary





This objective...�
Was met by...�
�
�
�
�
Create and configure a public folder.�
Creating a public folder from a Microsoft Exchange Client for Windows 95 and then configuring it as the default view for each client.�
�
Send mail to a public folder.�
Using the Microsoft Exchange Client for Windows 95 to create, send, receive and display a message sent to the public folder.�
�



Congratulations!  You have successfully created and configured your first Microsoft Exchange Public Folder.  Notice that this did not require any special programming, macro language or administration type program.  Within the Microsoft Exchange Client for Windows 95 interface you were able to create and configure the public folder and make it visible by default to all the users within your Microsoft Exchange organization.  You are now the proud owner of a public folder and prepared to continue with the test drive.


�
Setup Task 7: Using Schedule+


Objectives


Upon completion of this test drive task you will have successfully used the scheduling component of Microsoft Exchange to:


Request a meeting.


Accept a meeting request.


Assign delegate access.





Before You Begin





Note - These instructions assume you are using two different servers, X and Y.


Perform this lab from ServerX and ServerY.  You may complete this task on a single server (X) by attaching a second client machine to the network and installing another Microsoft Exchange client for the Administrator this time instead of User1.  This will allow you to complete these tasks with one server and two clients.  You can also complete this task by using only two machines total.  In this case, you will need to log out as User1 and login as administrator and create a separate profile that identifies administrator with appropriate settings for local calendar information and private folders.








Estimated time to complete this lab: 20 minutes





Exercise 1 �Requesting a Meeting


In this exercise, you will create and send a meeting request using the Microsoft Schedule+ 7.0 in Microsoft Exchange Client for Windows 95.





Note


Perform this exercise from ServerX as User1. Complete this exercise as a group.





Log on as user1 from ServerX with a password of password.


Start Microsoft Schedule+.


The Microsoft Schedule+ Introduction screen appears.


Choose to create a new Schedule+ file.


The Select Local Schedule dialog box appears.


Choose a filenmae for the Schedule+ file and choose Save.


The Microsoft Schedule+ client program appears.


To create and send a meeting request


In the following procedure, you will create and send a meeting request to Administrator.


From the Insert menu, choose Appointment.


The Appointment dialog box appears.


In the Start box, type X:00 PM. (Make sure you use a time later than your machine time.)


In the End box, type X:00 PM.


In the Description box, type: Meeting to discuss Exchange deployment.


In the Where box, type Building cafe.


Select the Attendees tab, choose Invite Others.


The Meeting Attendees dialog box appears.


Select Administrator, choose Required and then choose OK.


Select the Planner tab, verify that Microsoft Exchange User1 and Administrator are in the Attendees box and then choose OK.


The Meeting Request dialog box appears.


Type some text in the message body and then from the Insert menu, choose File.


The Attach dialog box appears.


In the File Name box, type C:\AUTOEXEC.BAT and then choose OK.


Choose Send.





Exercise 2 �Accepting a Meeting Request


In this exercise, you will view and accept the meeting request.





Note


Perform this exercise from ServerY as Administrator.





To accept a meeting request


In the following procedure, you will accept the meeting request from User1 and verify that the meeting is recorded in your Schedule+ file.


Log on as Administrator from ServerY using password for the password.


From the Microsoft Exchange program group, start Microsoft Exchange.


From the Inbox, select the message with the subject, Meeting to discuss Exchange deployment.


Choose Accept.


The Meeting Response window appears.


Choose Send.


From the File menu, choose Exit and Log Off.


From the Microsoft Exchange program group, start Microsoft Schedule+.


You should see the appointment you just accepted.





Note


If you do not see the scheduled appointment, from the Tools menu choose Options, and then choose Synchronize Now.





Exercise 3 �Assigning Delegate Access Permission


In this exercise, you will assign delegate access permission to User1 and verify that User1 has received the permission.





Note


Perform this exercise from ServerY as Administrator.





From the Tools menu, choose Set Access Permissions.


The Set Access Permission dialog box appears.


Choose Add.


The Add Users dialog box appears.


Select Microsoft Exchange User1, choose Users and then choose OK.


In the Set Access Permission dialog box, select Microsoft Exchange User1 in the User box.


In the User role box, choose Delegate from the drop-down list and then choose OK.


From the File menu, choose Exit and Log Off.


Log off from Windows NT.





Note


Perform the next set of steps from ServerX as User1.





To verify delegate access permission


In the following procedure, you will verify that User1 has received delegate access permission.


Start Microsoft Schedule+.


The Microsoft Schedule+ client program will appear.


From File menu, choose Open and then choose Other’s Appointment Book.


The Open Other’s Appt. Book dialog box appears.


Select Administrator and then choose OK.


The Administrator Microsoft Schedule+ window appears.


From the Insert menu, select Appointment.


The Appointment dialog box appears.


In the Start box, type X:00 PM.


In the End box, type X:00 PM.


In the Description box, type Meeting to discuss Microsoft BackOffice deployment.


In the Where box, type Building cafe.


Select the Attendees tab, choose Invite Others.


The Meeting Attendees dialog box appears.


Select Microsoft Exchange User1, choose Required and then choose OK.


Select the Planner tab, verify that Microsoft Exchange User1 and Administrator are in the attendees box and then choose OK.


The Meeting Request dialog box appears.


Type some text in the message body and then choose Send.


Choose Yes when prompted to book this appointment on your own schedule.


Minimize the Administrator Schedule+ window. 


You should see the appointment you just created in your own Schedule+ window.





Summary


This objective...�
Was met by...�
�
�
�
�
Request a meeting.�
Creating and sending a meeting request.�
�
Accept a meeting.�
Reading the meeting request in your Inbox, and choosing Accept.�
�
Assign delegate access.�
Assigning User1 the Delegate User role.�
�






Congratulations!  You have successfully verified the installation and operation of the scheduling component that is part of the Microsoft Exchange server family.  In addition to the personal information management (PIM) features, you can now add the ability to use the existing network to create, manage, and participate in scheduling meetings for the entire organization.  You are now prepared to move onto the next phase of the test drive or continue along with optional installation test drives.


�
Test Drive Section One - Microsoft Exchange Server Administrator


In this section of the test drive, we will lay out a set of tasks that will allow you to explore the administrative capabilities of Microsoft Exchange.  You may feel free to exercise other options as you discover them as this section is designed to be a pointer to some of the more interesting areas of administration in Microsoft Exchange.


Administrator Program


We begin our tour of Microsoft Exchange Server with the Administration program.  In the Microsoft Exchange Program Group, you will notice five icons.  Let’s take a look at each one.





Microsoft Exchange Performance Optimizer - this utility examines your Windows NT server hardware configuration and makes adjustments and recommendations on maximizing the system in order for the best performance when running Microsoft Exchange Server.  Try this on your system configuration and view the log created. 


Microsoft Exchange Migration Wizard - this tool is built into Microsoft Exchange Server to allow for moving users from other systems to the Exchange server environment in a user friendly way.  This tool can be used to move users from an existing Microsoft Mail for PC Networks postoffice, or a cc:Mail postoffice to Microsoft Exchange server.  In addition the Migration Wizard can use the output of any of the Source Extractors provided in Microsoft Exchange Server. Exchange Server includes the Source Extractors for IBM PROFS/OV DEC ALL-IN-1, Verimation Memo, and Microsoft Mail for AppleTalk Networks. Depending upon your environment, select one of the appropriate options and migrate some users.  Further demonstration of Microsoft Exchange integration with Windows NT server is available by viewing the event log prior to and after running this utility to see the way processes in Microsoft Exchange report.


Microsoft Exchange Setup Editor - this utility allows the administrator to control the installation of Microsoft Exchange clients.  The administrator can accept the defaults provided or customize the client setup by modifying setup program options, presetting user options and expediting the installation process.  Without leaving your desk and prior to installing a single desktop, you can set a variety of items for each client by viewing and changing the default settings for user options.  You can control where the software is installed from, and even the users default options.  Try this out on your system and see what we mean.  What?  No more INI file editing?


Books Online - discusses, in-depth, the concepts for planning a Microsoft Exchange Server system.  It includes an overview of the product’s features and complete installation instructions.  System administrators are strongly recommended to use this book to help plan their Microsoft Exchange Server systems.


Microsoft Exchange Administrator - Saving the best for last, this is the program that does the work in a Microsoft Exchange Organization.  This program is a view into the Exchange directory and as such, provides a single seat view of all the replicated objects within the entire Exchange Organization.  Let’s walk through the directory hierarchy and I will provide you some pointers of interest for you to try out.


Open Administrator and you will notice the hierarchy of your messaging topology appears.  Expand the hierarchy and you will see an ever increasing level of granularity.  Each part of the hierarchy provides its own set of properties that can be set by the administrator.


Select the top level icon and pull down the File menu and select Properties.  You will see the properties that you have access to view and modify.  In the organization properties, you can change the display name and the permissions.  View the properties on other objects in the hierarchy.


Select the Recipients icon and view its Properties. You can view the inherited permissions of the certain Windows NT accounts, as well as setting new permissions (as you could above).  Close this page and continue.


Below  the Site container highlight Configuration.  On the right side find DS Site Configuration and view its properties to see the power of the Microsoft Exchange Administration interface. Select the Offline Address Book tab and you can choose a server in the site to provide address book synchronization services and the address list for the process to use.  This allows for users who work off-line to have access to a global address list in Microsoft Exchange, even when working off-line from the server.  Select the recipients container and select Generate Offline Address Book Now.. Select OK to continue.  Still watching over the system processes, the program now alerts you to the fact that the process you requested is completed and notifies you of errors, if any.   Select OK to continue.


If you chose to utilize the optional ServerY installation test drive, then you will see two servers in your site under the SERVERS container.  You can select ServerX and expand to see a list of objects that you can manage.  You will notice that all the services that you verified were running during the installation test drive now appear.


Select Private Information Store found under Site, Configuration, Server, and server name.  View the properties that can be managed by the administrator.  Since the Information Store is an active process and not a set of files on a server that are shared, a greater degree of control is available to the administrator of Microsoft Exchange.  The tabs are self explanatory so feel free to select the tabs.  The Logons tab shows you a list of accounts that are using the information store.  Notice that you can select the columns button and change the order of the columns.  Make note of the sort order of your columns, make a change and then apply the change to see an example of being able to customize the administrator view of properties in Microsoft Exchange.


Select the Diagnostics Logging property page and you will see the powerful logging functions available to the administrator of Microsoft Exchange servers.


Close the Private Information Store and Select the Server recipients container.  This container will show you a list of locally defined users as opposed to the Organization recipients container which is essentially a global list of recipients.


Select the administrator mailbox’s Properties and you will see the familiar Mailbox property page.  This is where the administrator exercises control over the mailbox objects in Microsoft Exchange.   Cancel your view here and let’s continue with a look at one of the most requested functions for a messaging system.


Pull down the File menu and select New Other, Server Monitor.  We will create a monitor for our server(s).  Since you are creating a process to run within the context of Microsoft Exchange Server and Windows NT server, you will need to name your process.  Call it Monitor of ServerX and make the display name the same.


Select the Servers tab and add a server to the monitored server list.  Check the services button to display the list of available services to monitor.  You will notice the integration again with Windows NT server.  By default, the Microsoft Exchange services will be shown and you can add other services.  Select OK or add a few of your own and continue.


Now select the Actions tab and you will see the settings of actions when a service is stopped. If a service being monitored is missing, you can take a set of specific actions at each of three levels.  Feel free to experiment here.  Notice you can generate a warning message prior to restarting a service or computer.  Apply this and go on to the Notification tab.


Select New and read the choices.  Upon finding a problem, the monitor can proactively create an alert in the form of a mail message, a Windows NT alert or by launching a process.  Feel free to experiment with this functionality to send e-mail to the administrator or an alert to another system through the Windows NT alerter service.  Once you have completed setting up the monitor you will have a new object in the monitor container.  You will need to pull down the Tools menu and select start monitor.


Now you may minimize that monitor and create and start others.  Feel free to continue to explore the power of the Microsoft Exchange Administrator program.  





Windows NT Integration with Microsoft Exchange Administration


In this part of the test drive, we will explore the integration between Windows NT server and Microsoft Exchange.  We will cover use of the User Manager for Domains, Event Monitoring and the performance monitor in conjunction with Microsoft Exchange management and administration.  Follow along with the text and, as always, feel free to explore on your own.





User Manager for Domains - This program is used for Windows NT server administration of user accounts in the Domain.  Let’s explore this a bit before heading off onto the other components:


Open the User Manager for Domains on your system and you will see that the menu contains an Exchange item.  If you pull down this menu and select Options you will notice that there are some default settings that are administrator controllable.  These settings manage the interface between the Microsoft Exchange directory service and the Windows NT server security account database.  Experiment with these settings and note the changes they have on the system.  Return to the main screen in User Manager and select an existing account.  Pull down the Exchange menu item and select Properties. Up will come the Microsoft Exchange mailbox property sheet that we have seen several times in our test drive so far.  You are now administering an Microsoft Exchange mailbox and when you exit this screen you will return to the User Manager.  Essentially you can use the Windows NT User Manager for Domains as the tool for adding/deleting users from Microsoft Exchange as part of your administration scheme.  Let’s look at some of the other Windows NT integration.





Windows NT Event Viewer - A set of logs for capturing information reported by Windows NT and any registered services and sub systems such as security or applications.


Open the Event Viewer and pull down the Log menu item and select Application.  You will notice there are a number of Microsoft Exchange Server entries if the Microsoft Exchange Server is running on the server being monitored.  All the Microsoft Exchange services report different levels of information to the Event Monitor and it provides a powerful tool for determining the status of the Exchange services.  You can pull down the View menu and select Filter Events.  This will allow you to quickly set the focus on a particular Microsoft Exchange service during a specific time period and view only those service events of interest.  Set the source view to filter to MSExchangeMTA and select a time period.  Note the results.  You can select the event in question and gain additional information about a process and its status in this way.  Try selecting an MTA event or viewing a sequence of events at startup to determine the different processes and threads that are established at startup.  For purposes of the test drive, it may be appropriate to adjust the log sizes by using the Log Settings found in the Log menu to change settings and limit the size of the log file or allow overwrite as needed.





Windows NT Performance Monitor - This service allows the administrator to setup a graphical view of the system events to be monitored.  Microsoft Exchange services can be added to the charts as well as those services that are used most by Microsoft Exchange.


Open Performance Monitor and from File Menu, select New Chart.  From Edit Menu,  select Add to Chart and insure you are viewing your Microsoft Exchange Server machine.  In the Object box, select any or all of the Microsoft Exchange services and create a chart to monitor the services.  Note the results in the normal mode of operation and then use the LOADSIM utility to generate a load on the server and watch the monitor chart reporting the changes. (LOADSIM is the load simulator utility provided in the Microsoft Exchange Enterprise Edition CD-ROM, under \SUPPORT\LOADSIM\). You should also choose one particular Microsoft Exchange service, such as the MTA and create a chart to monitor a number of different items on one service.  Again, use LOADSIM to generate a load and observe the results.  





Summary


That concludes our test drive of the Administration of Microsoft Exchange Server.  We touched lightly on the more interesting capabilities of the administrator tools included with Microsoft Exchange Server.  You will find the interface to be a very powerful viewer into the directory of Microsoft Exchange. When the administrator program makes a change it is really manipulating objects in the Microsoft Exchange directory.  These changes are then automatically replicated to other servers in the Site, which you experienced if you installed a second server during this part of the test drive.  From here, it is on to the Microsoft Exchange desktop in Windows 95 to look at the powerful user interface.


�
Test Drive Section Two - Microsoft Exchange Desktop


In this section of the test drive, we will lay out a set of tasks that will allow you to explore the productivity enhancing capabilities of the Microsoft Exchange desktop.  Please feel free to exercise other options as you discover them in order to experience the powerful feature set in Microsoft Exchange.


Messages


We begin our tour of the Microsoft Exchange desktop with the message capabilities. We will go through a list of client software tasks that emphasis the desktop management capabilities in the Microsoft Exchange desktop.





Open the Microsoft Exchange Client program on the desktop and begin by creating your own environment for desktop messaging.I suggest that you customize the toolbar to expedite the functions that you most often use in your messaging desktop before continuing.  You may also want to jump ahead to the View section and modify your inbox/folder views before filling your mailbox with messages.





The following is a list of the types of messages that you should create and send to experience the multitude of message preparation options available in Microsoft Exchange:





To a single recipient, with standard text


To a single recipient, with rich text (with the exception of the Microsoft Exchange Dos-based Client)


To multiple recipients a simple text message, addressed individually and to distribution lists


To a single recipient, with an attachment


To multiple recipients, with an attachment


To single and multiple recipients, with multiple attachments


To a distribution list, with an attachment


To single and multiple recipients, with delivery report


To single and multiple recipients, with return receipt


To an invalid recipient


To your public folders (if you created them)


Using the customized toolbar, you can select Schedule +  for the following:


Meeting requests to single and multiple recipients


Move meeting requests to single and multiple recipients


Cancel meeting requests to single and multiple recipients





Verify that all messages are received and are readable on all clients. Verify read receipts and delivery reports.


Reply to all message types.


Reply all to messages sent to multiple recipients.


Forward several messages to single and multiple recipients across your test configuration.


For Schedule+ meeting requests: accept, decline, and tentative responses. View and reply from Windows and MS-DOS clients.


Verify that messages can be replied to and forwarded.


Create some private folders and move some messages and documents from your workstation into the folders.  Notice that you can create a number of different views.


Storage


Now that you have created some messages and exercised the sending and receiving capabilities, let us take a closer look at managing the client by exploring some of the storage mechanisms in the Microsoft Exchange Client and Schedule+.





Create several private folders in your Microsoft Exchange information store and personal folders store (.PST file)


Move 10 messages of various types (plain text, messages with attachments, and so forth) from the server to your personal information store. Verify that the messages are moved and are accessible.


Move 10 messages from your server to each of the private folders you have created. Verify that the messages are moved and are accessible.


Copy 10 messages from your server to each of the private folders you have created. Verify that the messages are copied and are accessible.


Delete several messages from all stores.


Create several public folders from each client. Verify that the public folders are accessible by all clients used on that server. If you have public folders replicating in your server environment, verify that public folders are accessible by all clients in your site.


Move messages from your server to each of the public folders you have created.


Copy some messages from your server to each of the public folders you have created.


Move messages from your personal information store to each of the public folders you created. Verify that all messages moved or copied to public folders are accessible.


Delete messages from public folders, and verify that they are removed.


Information Organization


In this part of the test drive, we will look at the unique capability of the Microsoft Exchange Client to allow each user to modify the way they view information without any need to touch the actual information.  Rather than impose a data structure on each user, the strategy in Microsoft Exchange is to provide the data and allow the view of the data to be modified.  We will look at the functionality that is built in to the Microsoft Exchange Client in conjunction with the Microsoft Exchange Server.


Profiles


Profiles allow a user to better manage their desktop by specifying the type and order of services that their desktop will use.  Profiles are set at installation time and are another tool that can be used to customize the environment.  For instance, it is the profile that controls the way the client accesses services such as the server store, in our case an Microsoft Exchange server.  This contains the server name and the user account information that allows the user to gain access to the server.


Profiles also allow for several users to use the same machine and yet be viewed by the services as different users with different privileges and services available to them.  Particularly in Windows 95, the roving user scenario can be managed quite well by moving the local user information to the server so that when someone logs in to the server, their identity and preferences are established by the server as opposed to the local machine registry.





To your existing profile with the Microsoft Exchange Server provides, add a personal address book service, and personal folder store service.  Use the SAMPAPPS.PST as the personal folder store service.  SAMPAPPS.PST can be found on the Microsoft Exchange Server CD-ROM, in the SETUP\SAMPAPPS\CLIENT directory. This will be used later when test driving the sample applications. 


Log on as that user, and verify the profile. Log off.


Change the default store to the personal folder store, log on as the above user, and verify that the PST is your default store. Make sure that your Inbox location is set to the default information store from the Profile Options property sheet.


Create profiles for different users to access Microsoft Exchange from the same computer.





Grouping


Group the messages you received based on Subject.


Group the messages you received based on From.


Group the messages you received based on Sent To.


Group the messages you received based on Priority.


Create a grouping of messages that have up to four levels (for example, group messages on subject and within that priority).





Filter


Filters allow for unique, on the fly message viewing management.  Imagine an inbox or folder with hundreds of messages and you have only a few minutes to find messages addressed directly to you before the review meeting.  Rather than having to scan through the entire container for mail, you can quickly set a filter and the system will display only those messages of interest to you.  Try some of the following as well:





Filter the messages you received based on Subject.


Filter the messages you received based on From.


Filter the messages you received based on Sent To.


Filter the messages you received based on Time Sent.





Inbox Assistant


Server based rules allow for automatically organizing information in a number of different ways.  The most important criteria is flexibility since no two users are the same in their requirements.  The Inbox Assistant allows for a number of interesting functions.  Try some of the ones listed below, as well as others on your own.





Set a criteria on From to move messages to another folder.


Set a criteria on Subject to display an alert dialog box when a message with that subject is received.


Combine the two above to create a move and a notification.


Views


Views can be set on containers and are very powerful tools for organizing information accordingly.  The information itself is never changed.  Only the view of the information is assigned and can be modified to suit the specific needs of a user, of a creator of the information, or both.  I may create a public folder and assign a default view that will display the information in the manner I think is most appropriate.  You may choose to reorganize that view from being document specific to user specific.  Try some of the views below to experiment.





Define a folder view to sort on the From field and verify.


Save this folder view. 


Define a personal view to filter by subject and verify. Save this personal view. Apply that view to public folder.


Offline Folders (a.k.a. Local Replication)


Offline folders are one of the options Microsoft Exchange provides to mobile users.  They allow users to take a copy of the private or public folders on their local machine, and perform bi-directional synchronization with the server copy whenever they want.  Lets try this on your Microsoft Exchange system.





In the Microsoft Exchange client, select your Inbox on your Microsoft Exchange server. Right mouse click on the Inbox and select Properties.


In the Properties dialog box, select the Synchronize tab.


Verify that this folder should be available “when offline and online”.


You will be prompted to create an Offline Store file.  Microsoft Exchange uses the Offline Store filde (.OST) to make the offline folders available and synchronize when initiated by the user. Choose OK to create the .OST file.


With the Inbox highlighted, select Synchronize This Folder from the Tools menu.  This will transfer all the current information into your offline Inbox.


Now highlight one of the public folders in your Favorites list, and right mouse click on the folder and bring up the Properties dialog box. Just like with the Inbox, make this folder available to you offline.  Then synchronize this folder for the first time.


Select Exit and Log off from the File menu.


Using the Profile Editor, which can be brought up by right mouse clicking on the Inbox shortcut in your Windows 95 desktop, reconfigure the Microsoft Exchange Server provider to “Choose the connection type when starting”.


Start the Exchange client back up. You will be prompted by the Choose Connection Type dialog box.  Choose “Offline”.


When the client software launches, notice that although you are working offline - not connected to the server - the information in the folders that you made available to yourself offline, can be used.


Add new information to any of the offline folders, and then synchronize these folders by selecting the Synchronize options in the Tools menu.


Exit and log off from the Microsoft Exchange client.


Restart the client and connect to your server.  Now you’re looking at the server copy of these folders.  Notice that the new information you synchronized while offline, is available on the server as well.  Note that, if there was no network connection, Microsoft Exchange would have tried to dial-up to your server using the dial-up-networking settings you have specified.


Schedule+ 7.0


In addition to the Schedule+ 7.0 messaging listed earlier, you will find an entire new world of functionality in scheduling.  Some of the more interesting things to look at are listed here as part of the test drive.  





Verify view free/busy functionality.  As user1, you have already verified some interoperability with other users as part of the test drive installation.  Now you can expand upon that to include other users.


Verify that you can open others’ appointment books and test all the different access rights (View, Modify, Delete, and so forth).


If you have previous versions of Schedule +, you can convert these older, calendar files into 7.0 format using the Schedule+ 7.0 File menu.


Notice the new viewing capability.  You can drag and drop appointments from the daily, weekly, or monthly views and watch the update take place.  You can mix and match daily, weekly and monthly views on the screen to view calendar information in the manner you wish.


Build a list of contacts, chock full of information about customers including pertinent dates, and watch them posted to your to do list.  The To Do list is greatly expanded and you are encouraged to check out the new functional and organizational capabilities here too.  


Build a project from start to finish by using Schedule + 7.0 to assign the start date, work periods, completion thresholds, and completion dates.  As part of the project, set up meetings with others and use the expanded capabilities to add a document to the meeting request that outlines the project and the action items for the meeting and have that sent via the Microsoft Exchange Server to the attendees.  You will notice that the meeting request allows the creator to specify whose attendance is mandatory or optional.


Create a list of projects and manipulate the view for the most efficient view of your projects.  


�
Test Drive Section Three - Microsoft Exchange Electronic Forms Designer and the Sample Applications


In this section of the test drive, we will lay out a set of tasks that will allow you to explore the extensibility of Microsoft Exchange.  You may feel free to exercise other options as you discover them as this section is designed to be a pointer to some of the more interesting areas of extensibility in Microsoft Exchange.





In order to use Microsoft Exchange Forms Designer, you need to first install it. You can install the Microsoft Exchange Forms Designer by running SETUP.EXE in the \{language}\EFDSETUP directory on the Microsoft Exchange Clients CD-ROM. Make sure that the destination directory for installation is in the Microsoft Exchange client directory on your hard disk.


Microsoft Exchange Forms Designer (EFD)


The EFD in Microsoft Exchange is designed to expedite the development of applications that use the messaging service provided by the Microsoft Exchange Server family.  The designer allows the user to participate in the development process without the need for a programming background.  EFD creates forms and packages them as Visual Basic code that can then be modified and extended by the programming team.  In addition, other code can be packaged with the forms and distributed by the Microsoft Exchange public folder system across the organization without the need of touching each desktop.





Let’s take a quick tour of the forms designer by editing an existing form:





Start the Microsoft Exchange Forms Designer.


From the Microsoft Exchange Forms Designer dialog box, verify that the Form Template Wizard is selected, and choose Next.


From the Forms Designer- Form Template Wizard dialog box, verify that To another user (Send) is selected, and choose Next.


Verify To Send information is selected, and choose Next.


Choose One Window for the number of windows in your form, and choose Next.


Type “Weekly Company Picnic” for the Form Name and add a brief Description, and choose Next.


Choose Finish.


From the Microsoft Exchange Forms Designer window choose View, and select Show Window Header.


From the vertical Tool Bar select Label Field and position the Label Field near the upper left hand corner of the Form.  Using the left mouse button elongate horizontally the Label box to the center of the Form.  Again, using the left mouse button select the Label Field and type, Weekly Company Picnic.


From the vertical Tool Bar select the Option button field and position the Option button below the Label Field that you created in the previous step of this exercise. Type Will Attend for this option.


From the vertical Tool Bar select Label Field and position the Label Field on the upper right side of the Form.  Using the left mouse button elongate horizontally the Label1 box to the right edge of the Form. Again, using the left mouse button select the Label Field and type, Preferred Beverage.


From the vertical Tool Bar select Check Box and position the Check Box directly below the Label Field located on the right side of the Form.  Using the left mouse button select the Check Box and type, Beer.





Note


Repeat the Check Box procedure from the previous step  to add additional Check Boxes using Wine and Soda for the Check Box text.





From the Microsoft Exchange Forms Designer windows choose File, and select Install.  Choose OK.


In the Save As dialog box, select the subdirectory that you created earlier in this lab exercise.  In the File Name box, type your user�_name, and choose OK.





Note


Wait approximately 3 minutes for the compiling process to be completed.





From the Set Library To dialog box, verify that the Form Library is selected, and choose OK.


From the Form Properties dialog box, type your user_name in the Contact field, and choose OK.


Choose File and select Exit from the Microsoft Exchange Form Designer.


Switch to the Windows 95-based Microsoft Exchange client.


From the Compose menu select New Form, and double-click the category button until you see Weekly Company Picnic, and choose OK.


Post a Form to your Public Folder.





This brief test drive of the Electronic Forms Designer will give you an idea of the ease of use and power of this tool to expedite the development process.  The design team can now build a form and get the actual users to make changes prior to completion of the project.





Feel free to create some new forms and register them with the Microsoft Exchange Server to enable their use by all members of your server or Site.  You will notice that each desktop only needs to have the Microsoft Exchange desktop installed and not the entire forms designer package in order to use the forms that are created.  The Microsoft Exchange Server takes care of distributing the form depending upon how it was registered.  Again, no need to touch each workstation in a large organization to realize the power of forms.





Sample Applications


As a demonstration of the types of functionality that can be realized by using the Microsoft Exchange family of products, we will examine some of the sample applications that are shipped in Microsoft Exchange Exchange Server.  We have chosen to test drive a few of the more important samples, but encourage you to explore the full range of functionality.





Discussion and Response


Open the Discussion and Response Folder.  Much of what enables this folder is built right into Microsoft Exchange.  This folder displays the ability of the system to leverage basic functionality, such as custom views and sorting covered in the client test drive, along with conversational threading and custom forms. 


Select View and display Folder View Options.  You will notice the folder is organized by Season.  This was set as the predefined Folder View by the creator/owner of the Folder.  You have the ability here to change the way you view the information presented by using the Microsoft Exchange desktop capabilities.


Select Spring and display the custom icons.  The standard envelope icons have been replaced in this folder with custom icons that represent the Lead Thought or Response Form.  This allows the user to quickly identify the entries as new ideas or responses.


Open a Response Form.  You will notice that the Topic, Subtopic and Lead Issue fields are already filled in.  This form has inherited that information from the lead thought form.


Enter some data into the Response: field and post the message.  The message will be nested beneath the Lead Thought that it applies to as the system maintains the integrity of the thread automatically.


Discussion and Response allows for the freeform communication required by ad hoc workgroups. By providing for this discussion to occur in a folder, as opposed to your own inbox, the threads can be automatically maintained and the user does not need to filter through the individual mailbox.


Document Filer


A very powerful feature of Microsoft Exchange is the ability to organize random documents and provide an information repository often referred to as a library style application.  Rather than storing information randomly outside the system and then providing pointers to the shared directories, the Getting Started Guide organizes the information and views.  This allows the user to have a folder that contains different data types such as Word documents, Excel spreadsheets and Internet Messages.


Select Getting Started Guide.  You will see the items are organized for you.  We have also included a number of quick references, tips, and tricks to get you started quickly.  You can use a much richer set of properties to display and search on that is allowed by File Manager and we provide the owner of the Folder with the ability to define which of these the user will see and interact with.


If you have a question about something in Microsoft Exchange, select the folder, choose a relevant article, and open it.  Change your view of the data and experiment with the searching capabilities.


Survey Application


Using the survey application illustrates the power of Microsoft Exchange as an infrastructure for gathering and distributing information across a large organization using forms and folders.  The survey is an application designed to solicit feedback from other departments and groups within a company regardless of geographical boundaries.


Open the Survey Application.  Open an existing survey and you will see some of the various styles of questions available.  The survey can be forked, so users are channeled into a different set of questions based upon the answer to previous questions.  There is also rich support for different types of questions and answer types, as well as buttons, check boxes, slide bars, and others.


Close the application and actually look at the survey itself.  Answer the questions and notice that you can set an end point for the survey based on a number of different parameters such as number of responses or percentage of survey responses received.  You can also use the results of the survey in other applications.





This is an example of taking the basic system functionality, along with the EFD and Visual Basic, to create and distribute information, as well as gather and manipulate the results.





Summary


This concludes the guided portion of the test drive of Microsoft Exchange.  By now you have realized that it is only the beginning.  The Microsoft Exchange family of products provides a powerful, standards-based messaging infrastructure that is easy to setup and manage for both users and administrators.  It is also much more. By combining the best of messaging with a flexible and easy to use desktop client and by adding extensive tools for extending the basic feature set, Microsoft Exchange is uniquely positioned to serve organizations - large and small.


Thank you for taking the Microsoft Exchange test drive, it is a pleasure being your guide.


�
Appendix a


Other Sources of Information





�
Other Sources of Information


Microsoft Exchange Server Reviewer’s Guide is designed to server the purpose of a short, yet detailed guide to walk you through the evaluation process. You will find other tools and documentation in the Microsoft Exchange Server package. It is important that use consult to these sources of information as necessary throughout the evaluation process. Therefore here is a list of those tools and documents with a short description of each.


Microsoft Exchange Server Documentation


	�SYMBOL 38 \f "Wingdings"�


Installation Guide


Installing Microsoft Exchange software, including server, connector, and client software. Available on Microsoft Exchange Server CD-ROM.


	�SYMBOL 38 \f "Wingdings"�


Concepts and Planning Guide


Planning for and deploying a Microsoft Exchange Server organization.


	�SYMBOL 38 \f "Wingdings"�


Administrator’s Guide


Administering Microsoft Exchange, including maintenance, upgrading and troubleshooting.


	�SYMBOL 38 \f "Wingdings"�


Migration Guide


Migrating to Microsoft Exchange from other messaging systems. Available on Microsoft Exchange Server CD-ROM.


Microsoft Exchange Client Documentation


	�SYMBOL 49 \f "Wingdings"�


Getting Started Public Folder


Overview and tutorial for new users of Microsoft Exchange Client.


	�SYMBOL 38 \f "Wingdings"�


Getting Started Guide


Overview and tutorial for new users of Microsoft Exchange Client. Available on Microsoft Exchange Server CD-ROM.





	�SYMBOL 58 \f "Wingdings"�


Microsoft Exchange Client Help


How to use and customize Microsoft Exchange Client and Schedule+.


	�SYMBOL 38 \f "Wingdings"�


Application Designer's Guide


How to use the Forms Designer, including sample applications that include Help for creating and modifying forms for use with Microsoft Exchange.
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