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Introduction

Microsoft® Visio® 2000 Professional Edition
and Microsoft Visio 2000 Enterprise Edition
information technology (IT) products provide
an unprecedented suite of tools for streamlin-
ing the planning, implementation, and
management of your IT systems—networks,
databases, and software applications.

Professional Edition and Enterprise Edition
deliver industry-standard tools for quickly and
efficiently diagramming networks, databases,
and software applications. Enterprise Edition
offers all the features in Professional Edition,
plus automated tools for IT design and
documentation.

In this chapter

Getting started..........................................................................................................................................8

Introducing Professional Edition and Enterprise Edition......................................................................9

Comparing Professional Edition and Enterprise Edition .................................................................... 11

What’s new in the Microsoft Visio 2000 IT products ...........................................................................17
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Getting started

This guide covers the fundamentals of
Microsoft Visio 2000 Professional Edition and
Enterprise Edition, and focuses on the drawing
types and methods you’re likely to use most
often.

Installing Microsoft Visio 2000
Professional Edition or Enterprise
Edition
You must be running Microsoft Windows® 95,
Microsoft Windows 98, or Microsoft Windows
NT® 4.0 or later to install your Visio 2000 prod-
uct from the Microsoft Visio 2000 CD.

NOTE To prepare for installation, close all pro-
grams and turn off virus protection software to
prevent installation conflicts.

On most Windows-based systems, installation
starts automatically when you insert the
Microsoft Visio 2000 CD into your CD-ROM
drive. If installation does not start automati-
cally, you can install your Visio 2000 product
using the following procedure.

To install Microsoft Visio 2000

1 Insert the Microsoft Visio 2000 CD into
your CD-ROM drive.

2 From the Start menu, choose Run.

3 In the Run dialog box, type d:\setup, where d
is the letter assigned to your CD-ROM drive.

4 Click OK.

The Microsoft Visio Installation Manager
guides you through the installation process.

Visio on the Web
To reach the Visio Division of Microsoft
Corporation Web site and the Visio Knowledge
Base using the World Wide Web, in Visio 2000
choose Help > Visio On The Web.

The Visio Division Web site contains informa-
tion on service releases, support forums, and
training opportunities. The Visio Knowledge
Base offers the latest tips on using Visio 2000
products and articles that answer frequently
asked questions (FAQs).

To contact customer service or technical sup-
port, choose Help > Visio On The Web, and
then follow the links to locate support infor-
mation for your geographic area.
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Introducing Professional Edition and Enterprise Edition

With Microsoft Visio 2000 IT solutions, you’ll
be equipped to tackle your most challenging IT
projects: planning e-commerce infrastructures;
migrating to Microsoft Windows 2000; prepar-
ing for the convergence of voice/data networks;
implementing enterprise application integra-
tion; and more. Visio 2000 IT solutions deliver
unprecedented power for visualizing the key IT
domains—networks, databases, and software
applications.

E-commerce planning and
implementation
When a corporation adopts an e-commerce
strategy, the IT group bears the brunt of the
change, translating business requirements into
a supporting technology infrastructure. Web-
based applications display products for sale on
secure, private sites; applications run under-
neath to control transactions; databases store
customer and financial information; firewalls
provide security; and the site has to stay live 24
hours a day. Employees, consultants, and ser-
vice providers have to come up to speed on
new systems fast. Visio 2000 IT solutions can
help to

• Draw process and dataflow diagrams to see
how customers will navigate your site,
ensuring that the exchange is quick, easy,
secure, and profitable.

• Diagram the Web site, database, software,
and network architectures that support
the site.

• Use these diagrams as a central respository
for viewing and updating the e-commerce
site architecture.

• Give your e-commerce managers a view
into what’s happening at critical points in
the network infrastructure so they can pre-
vent hardware overload and system crashes.

Microsoft Windows 2000 and
Active Directory deployment
Visio 2000 IT solutions provide the tools to
visualize the planning, implementation, and
continuing maintenance of Windows 2000 and
the Active Directory™ directory service.

• Adapt the diagram of the existing architec-
ture to the planned Windows 2000 and
Active Directory configuration.

• Enterprise Edition only Use AutoDiscovery
technology to diagram all layer 2 (data
link), layer 3 (network layer) and frame
relay devices in your current network.

• Enterprise Edition only Create the directory
services database in your Visio product,
then export information from the diagram
to Active Directory through the LDIF
(Lightweight Directory Interchange
Format) file format.

You can run
Microsoft Visio 2000
from a Windows
Terminal Server so
your organization can
go to a thin client
model, with no need
to install the Visio
application on any
desktops. For details,
see the Network.wri
file in your Visio
folder.
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Voice and data network
convergence
As companies move to adapt new widescale
communications technologies, such as voice
over IP (VoIP), wireless, and computer tele-
phony integration (CTI), IT groups once again
face planning, managing, and sustaining signif-
icant changes to their existing infrastructures.
Use the Visio 2000 IT solutions to do the
following:

• Design high-level changes required for
switching to the VoIP network.

• Enterprise Edition only Automatically
document your existing IP networks with the
AutoDiscovery technology.

• Enterprise Edition only Create detailed
to-be plans with more than 18,000
manufacturer-specific Visio Network
Equipment Shapes.

Customer Relationship
Management implementation
Customer Relationship Management (CRM)
ensures that all employees who deal with cus-
tomers interact with and view the same
information about customers. Use Visio 2000
IT solutions to support this sort of complex
implementation as follows:

• Capture your current customer acquisition
and retention process with process flow dia-
grams that can give your CRM vendor and
systems integrators a picture of what you
need from a CRM system.

• Include before and after drawings when you
sign your CRM purchase agreement and
implementation arrangement letter to con-
firm and verify your and your vendor’s
assumptions and expectations.

• Capture business rules using natural lan-
guage, then jump-start the database coding
effort by using the resulting diagrams to
generate database schemas.

• Keep implementation participants in sync
by publishing a series of drawings that doc-
ument the overall hardware, software, and
database architecture.

• Train new users on the CRM system using
Visio 2000 process flow diagrams; docu-
ment revisions to the system in Visio 2000.

Enterprise application integration
Under pressure to support e-business while
keeping up with object-oriented programming,
many IS groups are moving toward integrating
multiple applications enterprisewide, rather
than relying on decentralized, department-
level approaches. Use Visio 2000 IT solutions
to support this high level of integration by

• Documenting the entire IT infrastructure
prior to planning for the new architecture,
capturing the people, business processes,
software, and hardware that drive the cur-
rent applications infrastructure.

• Reverse engineering existing applications
structures to see how existing databases
and software applications can best
be consolidated.

• Forward engineering database schemas from
entity relationship (ER) diagrams to jump-
start database development.

• Documenting existing and planned
network devices, including directory
services that support current and planned
software applications.
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Comparing Professional Edition and Enterprise Edition

Both Professional Edition and Enterprise Edi-
tion are aimed at IS/IT specialists. If you create
high-level overview diagrams and communi-
cate key information about your information
systems to others, choose Professional Edition.
If you design and document information on an
enterprise level, choose Enterprise Edition with

its powerful automated tools. (Enterprise
Edition includes all of the Professional Edition
functionality.) The following table provides a
complete list of the Visio 2000 IT solutions and
shows which come with Professional Edition,
Enterprise Edition, or both.

Networking solutions
Solution
description

Professional
Edition

Enterprise
Edition

Active Directory

Design accurate and efficient directory structures that are compliant with
Microsoft Active Directory schemas and Microsoft Windows 2000.

Yes Yes

Import existing tree views and export the diagram to a file that you can use
to update your network. No Yes

AutoDiscovery and Layout

Automatically locate all of the devices on your enterprise network, and then
create network diagrams that are easy to maintain.

No Yes

Conceptual Web Site

Create a high-level diagram of content on and navigation through a new
Web site, or reorganize an existing Web site.

Yes Yes

LDAP Directory

Create a general-purpose directory service network diagram.
Yes Yes

Import existing tree views and export the diagram to a file that you can
use to update your network.

No Yes

Logical Network Diagram

Create logical diagrams that describe the structure and scope of networks.
Yes Yes

Network Diagrams

Plan and document simple networks, and track equipment by associating
serial number and location data with shapes.

Yes Yes

Network Reports

Automatically create robust network documentation with network
reports on discovered data.

No Yes
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Novell Directory Services

Design existing Novell Directory Services® (NDS®) trees automatically.
Yes Yes

Import existing tree views, modify the structure, and then export the
diagram to a file that you can use to update your network.

No Yes

Visio Network Equipment Shapes

Access more than 18,000 manufacturer-specific network equipment
shapes to create network diagrams—such as a wiring closet, LAN, or
WAN.

Sampler
only

Yes

Web Site Map

Generate a site map of an existing Web site to analyze the details of the
site—such as the organization and navigation patterns—and classify the
content.

Yes Yes

Database modeling solutions
Solution
description

Professional
Edition

Enterprise
Edition

Bachman

Create entity relationship diagrams for data modeling in relational
databases and information systems design using Bachman notation.

Yes Yes

Chen ERD

Create entity relationship diagrams using Chen ERD notation.
Yes Yes

Database Model Diagram

Create relational and object-relational database models.
Yes Yes

ER Source Model

Create relational and object-relational database models in a team or
collaborative environment.

No Yes

Express-G

Create entity-level and schema-level diagrams using Express-G notation,
the graphical component of the Express formal information requirements
specification language.

Yes Yes

Martin ERD

Create object-oriented analysis and design diagrams using Martin ERD
notation.

Yes Yes

ORM Diagram

Create a conceptual data model using Object Role Modeling notation.
Yes No

ORM Source Model

Create conceptual models that are based on facts and business rules,
build logical models, and then map them to a physical database.

No Yes

Networking solutions (continued)
Solution
description

Professional
Edition

Enterprise
Edition
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Software modeling solutions
Solution
description

Professional
Edition

Enterprise
Edition

Booch OOD

Create object, class, timing, state, module, and process diagrams
using Booch object-oriented design notation.

Yes Yes

COM and OLE

Create COM (Component Object Model) objects, interfaces, and
system diagrams.

Yes Yes

Data Flow Model Diagram

Create data flow diagram models using Gane-Sarson notation.
Includes a model navigator, semantic error checking, and automatic
level balancing.

Yes Yes

Fusion

Create the diagram types included in Fusion methodology.
Yes Yes

Jackson

Create data and program structures using the Jackson software
design method.

Yes Yes

Jacobson Use Case

Create use case, state transition, interaction, and other diagrams
included in the Jacobson object-oriented software engineering
method.

Yes Yes

Nassi-Schneiderman

Represent sequence, selection, case, and repetition in program
structure charts.

Yes Yes

Program Structure

Create structural diagrams of programs and memory objects.
Yes Yes

ROOM

Create Real-Time Object-Oriented Modeling (ROOM) diagrams.
Yes Yes
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Rumbaugh OMT

Create object, dynamic, and functional diagrams using the Rumbaugh
Object Modeling Technique.

Yes Yes

Shlaer-Mellor

Create class diagrams, class structure charts, dependency diagrams,
and inheritance diagrams using Shlaer-Mellor notation.

Yes Yes

SSADM

Create logical data structures, data flow diagrams, entity life histories,
and other system analysis and design diagrams.

Yes Yes

System Structure

Create diagrams that represent Windows and Macintosh operating
systems and user interfaces.

Yes Yes

UML

Create integrated UML system models. Reverse engineer Microsoft
Visual C++®, Visual Basic®, and Visual J++® code; share models
through Microsoft Repository; generate code skeletons for C++, Java,
and Visual Basic; and create reports of UML models. Uses the entire
UML 1.2 notation and includes semantic error checking.

Modeling
and reverse
engineering

only

Yes

Windows User Interface

Develop, document, and prototype your user interface using elements
from the Microsoft Office and Windows.

Yes Yes

Yourdon and Coad

Create object state, data flow, and other diagrams included in the
Yourdon and Coad object-oriented analysis and design notation.

Yes Yes

Software modeling solutions (continued)
Solution
description

Professional
Edition

Enterprise
Edition
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Additional Visio solutions
Solution
description

Professional
Edition

Enterprise
Edition

Audit Flowcharts

Document and analyze processes that involve financial transactions or
inventory management.

Yes Yes

Basic Diagrams

Create drawings for brainstorming, planning, and communication.
Yes Yes

Block Diagrams

Create drawings for brainstorming, planning, and communication.
Create tree diagrams that represent hierarchies and onion diagrams.

Yes Yes

Block Diagrams with Perspective

Create drawings using geometric shapes that have a 3-D appearance.
Yes Yes

Calendars

Create a calendar for a month or the year on a single page.
Yes Yes

Cause-and-Effect Diagrams

Document all factors that contribute to or affect a given situation. Also
called Ishikawa, fishbone, or characteristic diagrams.

Yes Yes

Charts and Graphs

Create charts and graphs for presentations and reports.
Yes Yes

Cross-Functional Flowcharts

Show the relationship between a business process and the
organizational or functional units—such as departments—responsible
for that process.

Yes Yes

Data Flow Diagrams

Document the logical flow of data through a set of processes or
procedures.

Yes Yes

Directional Maps

Create easy-to-read maps that use clearly identifiable roadways, metro
routes, and landmarks.

Yes Yes

Flowcharts

Describe or analyze processes, document procedures, indicate work or
information flow, and track cost and efficiency.

Yes Yes

Form Design

Create business forms, such as invoices, product orders, customer
information profiles, and inventory records.

Yes Yes

Gantt Charts

Schedule, plan, and manage projects.
Yes Yes
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Geographic Maps

Create detailed maps of countries, continents, and regions with their
geographic entities—including lakes and rivers—in correct relationship
to one another.

Yes Yes

IDEF0 Diagrams

Model business and organizational processes.
Yes Yes

Marketing Diagrams

Create drawings for process modeling, benchmarking, simulation and
improvement, path routing, time and cost analysis, activity-based
costing, product portfolios, scope and marketing mix, product life and
adoption cycles, market and resource analysis, and pricing matrices.

Yes Yes

Mind Maps

Use to brainstorm and take notes.
Yes Yes

Office Layout Drawings

Draw floor plans for individual rooms or for entire floors of your
building—including the wall structure, building core, and electrical
symbols.

Yes Yes

Organization Charts

Graphically represent the interrelationships among people, operations,
functions, and activities in an organization.

Yes Yes

PERT Charts

Plan and monitor projects, organize tasks, establish timeframes, and
show tasks that are dependent on other tasks.

Yes Yes

SDL Flowcharts

Create object-oriented flowcharts that document communications and
telecommunications systems networks using a format designed to
International Telecommunications Union standards.

Yes Yes

Timelines

Create linear timelines that illustrate milestones and events over the life
of a project or process.

Yes Yes

TQM Flowcharts

Document processes graphically, compare current and ideal processes,
and understand how steps in the process work together.

Yes Yes

Work Flow Flowcharts

Describe, analyze, and document processes in an organization.
Yes Yes

Additional Visio solutions (continued)
Solution
description

Professional
Edition

Enterprise
Edition
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What’s new in the Microsoft Visio 2000 IT products

Microsoft Visio 2000 Professional Edition
and Enterprise Edition include powerful
additions to the Visio graphics engine and
feature enhancements to the IT-specific
solutions.

You can work efficiently using the following
enhanced features in the graphics engine that
all Visio 2000 products share.

• Easily create custom data for shapes that
you can later use for reports.

• Set tabs, margins, and hanging indents
using a text editing ruler.

• Nudge selected shapes using the arrow keys
for precise placement in your diagram.

• Easily navigate, rearrange, and rename
pages using page tabs.

• Edit groups the same way you edit regular
shapes.

• Edit stencils directly in the drawing
window.

• Customize menus and toolbars.

• Perform tasks right in the drawing window
using anchored windows.

The following tables list additions and
enhancements to the Visio IT-specific
solutions.

Network diagrams
Feature or
functionality

Professional
Edition

Enterprise
Edition

Create LAN, WAN, wiring closet, server room, and
telecommunications diagrams.

Yes Yes

Document and diagram Microsoft Active Directory, NDS, and LDAP
(Lightweight Directory Access Protocol) compliant directory services.

Yes Yes

Use the network-specific Custom Properties fields to create, store,
and report on data associated with the shapes in your diagram.

Yes Yes

Discover and document layer 2, layer 3, and frame relay network
environments. The Discovery Wizard lets you determine how much or
how little of your network is discovered.

No Yes

Automatically create hyperlinked network diagrams using the
AutoLayout feature. No Yes

Document existing directory trees using import and export tools. No Yes
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Database diagrams

UML diagrams

Internet diagrams

Data flow diagrams

Feature or
functionality

Professional
Edition

Enterprise
Edition

Create a detailed picture of leading database management systems
(DBMSs). Yes Yes

Reverse engineer databases using drivers for leading DBMS vendors,
such as Microsoft, IBM, Informix, Oracle, and more.

Yes Yes

Reverse engineer tables, views, relationships, primary or foreign keys,
and code, such as triggers, stored procedures, and check clauses.

Yes Yes

Merge multiple diagrams into a single database model using projects. No Yes

Automatically generate database schemas after capturing business rules
using Object Role Modeling. No Yes

Forward engineer databases from conceptual to logical to physical
schemas.

No Yes

Feature or
functionality

Professional
Edition

Enterprise
Edition

Document the entire software development process using any UML 1.2
diagram type. Yes Yes

Reverse engineer code into UML models from Microsoft Visual Basic,
Microsoft Visual C++, and Microsoft Visual J++.

Yes Yes

Generate code skeletons from UML models into Visual Basic, C++, and
Java.

No Yes

Create reports from UML static structure, activity, and deployment
diagrams.

No Yes

Feature or
functionality

Professional
Edition

Enterprise
Edition

Create high-level, conceptual diagrams of new Web sites to stimulate
discussion of the sites’ purpose, content, and overall structure.

Yes Yes

Generate maps of existing Web sites to analyze their organization. Yes Yes

Troubleshoot errors and missing hyperlinks. Yes Yes

Feature or
functionality

Professional
Edition

Enterprise
Edition

Basic diagram-only data flow diagramming. Yes Yes

Model-based data flow diagramming, including a model navigator,
optional error checking, and automatic level-balancing.

Yes Yes



C H A P T E R

1

Visio basics

While each Microsoft® Visio® 2000 Professional
Edition and Enterprise Edition template con-
tains a unique set of shapes, tools, and styles,
some tasks are common to creating all types of
Visio drawings or diagrams.

This chapter explains how to get your drawing
or diagram on the page in minutes, how to for-
mat your content quickly, and how to get it to
your audience, regardless of the type of draw-
ing or diagram you’re creating.

You’ll also learn about using the powerful
Visio graphics engine—a program platform
that enables the flexible, uniform behavior of
the shapes, stencils and templates you use to
create your diagrams—to draw your own
shapes and add behavior to them to make them
“smart.”

This chapter may be all you need to get started
working with Microsoft Visio 2000.

In this chapter

The Visio workspace ..............................................................................................................................20

Starting a diagram .................................................................................................................................23

Refining a diagram.................................................................................................................................28

Sharing your diagrams with others......................................................................................................31

Develop custom solutions: create shapes, stencils, and templates...................................................34

Microsoft Visio 2000
seamlessly integrates
with Microsoft Office.
With its Office-
compatible interface
elements, such as
functionally grouped
toolbars and tabbed
dialog boxes, the
Visio 2000 diagramming
environment is friendly,
intuitive, and familiar.
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The Visio workspace

The Microsoft Visio 2000 products share a core
set of features. This means that you can use the
same basic methods to work with all of the
Visio 2000 programs to create your diagrams.
The illustration below shows five steps that are

common to making any Visio 2000 diagram.
The following pages define the common ele-
ments of the Visio interface, explain how the
elements are organized, and show the actual
workspace you’ll use to create Visio diagrams.

Five steps to

making a Visio

diagram

1 Start a diagram by opening a
drawing type, or template.

2 Add shapes by dragging them from
the stencil and dropping them onto
the drawing page.

3 Connect the shapes in your
diagram.

4 Add text to shapes in your
diagram, and add independent text
for titles.

5 Publish your diagram to the Web, or print your diagram to share it with
others.
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Visio fundamentals

Visio concept Definition How it works in the Visio program

SmartShapes® symbol A predefined shape that is stored on a Visio
stencil. SmartShapes symbols are not static clip art
images or symbol libraries. Rather they are objects
programmed to behave appropriately within a
particular context.

To include a SmartShapes symbol in
a diagram, drag it from the stencil
and drop it onto the drawing page.

Stencil A storage mechanism where a solution’s
SmartShapes symbols are collected. You can drag
a SmartShapes symbol (or shape) from a stencil
onto the drawing page. You can also create
custom shapes and save them on stencils.

When you open a Visio 2000
template, you automatically open
one or more stencils. You can open
additional stencils by choosing File >
Stencils > Open Stencil.

Template A Visio 2000 file that opens one or more stencils
and windows and can contain specific styles and
settings (for example, scale and grid) appropriate
for a particular kind of diagram. Using a template
ensures consistency across your drawing files.

To open a template, choose File >
New, choose the solution you want,
then choose the template.

Solution An application that runs on top of the Visio
program, has specialized functionality, and
includes one or more templates related to a
particular solution area. For example, the UML
solution includes one template and a special UML
menu with commands for creating models,
running semantic error checks, and more.

To work in a solution, you open a
template. Choose File > New,
choose the solution you want, then
choose the template.
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The Visio

workspace

Each drawing type
opens with stencils,

shapes, and toolbars
appropriate to that

drawing type.

A Tools are grouped in functional sets on toolbars. You
can specify which toolbars you want to display by
choosing View > Toolbars.

B The drawing page opens with size, orientation,
scale, grid, and measurements appropriate for the
drawing type.

C You can find additional related tools by clicking the
arrows next to the button.

D You can use the drawing page grid to align shapes
to each other.

E ScreenTips appear when you pause the mouse
pointer over a toolbar button.

F Stencils, or collections of masters, dock to the left of
the drawing page, by default.

G When your diagram has multiple pages, you can
move the horizontal scroll bar to view all of the page
tabs.

H With page tabs you can quickly insert new pages,
navigate multiple-page diagrams, delete pages,
rename pages, and reorder pages.

I Masters are shapes you can add to your diagrams.
To quickly view information about a shape, pause
the mouse pointer over a shape.

CA EB D

F G H I
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Starting a diagram

When you base a diagram on a Visio drawing
type (also called a template) in Visio 2000, you
automatically get all the tools and features you
need to create that type of diagram.

For example, to create an organization chart,
open the Organization Chart drawing type.

To start a drawing

1 Start Microsoft Visio 2000. In the Welcome
To Microsoft Visio dialog box, click OK.

2 In the Choose Drawing Type dialog box,
click a category name, such as Block Dia-
gram.

You can see a preview of the drawing types
in the Drawing Type box.

3 In the Drawing Type box, double-click the
template you want to open, such as Basic
Diagram.

A drawing page appears, with the stencils
and tools you need to begin your diagram.

Working with stencils and shapes
When you start a new diagram by opening a
template, Visio 2000 opens one or more task-
related stencils. Stencils contain shapes you can
drag onto the drawing page to create your dia-
gram. You can move stencils in the drawing
window to create more workspace by floating,
minimizing, or docking them somewhere else.

You can float (make movable) or dock stencils to create
more workspace for your diagram.

TIP To open additional stencils, choose File >
Stencils > Open Stencil, choose the stencil you
want to open, and then click OK.

To add a shape to your diagram

1 On a stencil, point to the shape you want to
add to your diagram.

2 Hold down the mouse button and drag the
shape to the location you want on the draw-
ing page, and then release the mouse button.

To locate a specific
shape quickly, use
the Shape Explorer
window. Choose
Tools > Macros >
Shape Explorer.
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Using 1-D and 2-D shapes
Visio shapes can be one-dimensional (1-D) or
two-dimensional (2-D).

Aligning shapes with the
dynamic grid
You can use a dynamic grid (dashed lines) to
indicate the location for the next shape you
drag onto the page, based on the location of
shapes already on the page. As you move a
shape on the page you can place it precisely
using dynamic grid lines to align the shape
with other shapes in your diagram.

To turn on the dynamic grid

• Choose Tools > Snap & Glue, and then
check Dynamic Grid on the General tab.

When you drop a shape onto the drawing
page, Visio 2000 snaps the shape to the
nearest grid line so you can position it pre-
cisely in your diagram.

Using shape handles
Visio shapes have handles you can use to resize
or move the shape, or to change the shape’s
appearance, position, or behavior. You use
selection handles ( ) to resize shapes, and
control handles ( ) to perform actions that are
unique to the particular shapes on which they
appear.

For example, you might use a control handle to
adjust the position of a shape or move a line in
a shape.

1-D shapes behave like lines and display endpoints you
can drag to resize the shapes when you select them
with the pointer tool.

2-D shapes have corner handles you can drag to resize
the shapes proportionally, and side selection handles
you can drag to resize them horizontally or vertically.

The control handle looks
just like a selection
handle, but has darker
shading.

To see a ScreenTip for a
control handle, pause the
pointer over the control
handle.

Adjust line spacing
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Moving and resizing shapes
Moving Visio shapes is as easy as selecting the
shapes and then dragging the selection to the
new location in your diagram. You can resize
shapes quickly by simply dragging selection
handles.

NOTE When you drag a shape to move or resize
it, you can see exactly how the shape changes as
you drag. If the shape has text associated with it,
the text is repositioned accordingly.

To move or resize a shape

1 To move the shape, select the shape with the
pointer tool ( ), hold down the mouse but-
ton while dragging the shape to the location
you want in your diagram, and then release
the mouse button.

The pointer turns white when the shape
is movable.

2 To resize a selected shape, point to a selec-
tion handle ( ) until the pointer changes to
a four-headed arrow ( ), and then drag
the handle to change the size.

TIP To limit the movement of shapes to horizon-
tal or vertical, hold down the Shift key while you
drag the shapes.

Quick editing with anchored
windows
You can perform quick editing tasks such as
changing a shape’s size and position, or editing
a shape’s custom properties, directly in the
drawing window using anchored windows.

You can set anchored windows to AutoHide
when you’re not using them, and conveniently
tuck them away until you want to use them
again.

To open an anchored window

• Choose View > Windows, and then click
the name of the anchored window you want
to open.

To nudge a shape
slightly in one
direction, select the
shape, and then click
the up, down, left, or
right arrow key.

Anchored windows in Microsoft Visio 2000

Window Purpose

Pan & Zoom
window

Easily zoom in or out with
increased precision

Custom Properties
window

View and edit a shape’s
custom properties

Size & Position
window

Change a shape’s size,
position, or rotation

Drawing Explorer
window

View all of the elements
in your document
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Connecting shapes
Flowcharts, organization charts, block dia-
grams, and network diagrams are all connected
diagrams—diagrams that show relationships
between shapes.

You can use two types of connections in
Visio 2000: shape-to-shape and point-to-point.
The type of connection you use depends on
how much control you want over your
diagram.

With shape-to-shape connections, Visio 2000
maintains the most direct connection between
the actual connection points. This means that
the actual points of connection might change
when you move the connected shapes in rela-
tion to each other.

With point-to-point connections, the actual
points of connection stay the same no matter
how you move the connected shapes.

Shape-to-shape

connections

When you move shapes that have shape-to-shape connections, the connector attaches at the closest point between
the shapes, which might be different from the original connection points.

Point-to-point

connections

When you move shapes that have point-to-point connections, no matter how you arrange the shapes in relation to
each other on the drawing page, the shapes maintain their original connection points.
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To connect shapes automatically,

shape-to-shape

1 Click the connector tool ( ) on the
Standard toolbar.

2 Drag a shape from a stencil onto the
drawing page.

3 While the shape is still selected, drag
another shape from a stencil onto the
drawing page.

To connect shapes automatically, point-to-point

1 Use the pointer tool to drag two shapes,
one at a time, from a stencil onto the
drawing page.

2 On the Standard toolbar, click the connec-
tor tool, and then drag from a connection
point on the first shape to a connection
point on the second shape.

The connection points turn red and the
shapes are connected point-to-point.

NOTE Because of their specialized behavior,
certain shapes—such as those in the directory
services solutions—cannot be connected using
the point-to-point method. For details about a
shape’s behavior, right-click the shape and
choose Help.
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Refining a diagram

Using Microsoft Visio 2000, you can enhance
and modify diagrams by

• Adding text and color to shapes.

• Changing the direction of shapes by flip-
ping and rotating them.

• Creating groups of shapes you can move as
single units.

Adding and changing text
Text can clarify the meaning of your Visio dia-
grams, and you can use text to document
changes you or other Visio users make to a dia-
gram. You can turn on the text ruler to help
you format text in a shape as you edit it.

NOTE Because of their specialized behavior, you
cannot add text to certain shapes—such as those
in the UML solution—using the following meth-
ods. For details about a shape’s behavior, right-
click the shape and choose Help.

To add text to a shape

• Select the shape and type the text you want.

To edit existing text

• Double-click the shape to open the shape’s
text block, and then type.

To turn on the text ruler

1 Double-click a shape to open the shape’s
text block.

2 Right-click the shape with its text block
selected, and then choose Text Ruler from
the shortcut menu.

The text ruler appears above the shape.

You can quickly change the settings for the selected
text by dragging the tab stops and indent markers to the
location you want on its text ruler.

Visio
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Adding color and line styles
to shapes
You can add color to shapes and instantly
make your diagrams more visually dynamic.
You can also change the format of lines and
line ends in your diagrams. By applying line
ends, you can turn any line into an arrow.

To view the fill color palette

• Click the arrow next to the Fill Color button
on the Format toolbar.

Click More Fill Colors on the fill color palette for
additional colors.

To apply color to a shape

• Select the shape and choose the fill color
you want to use from the fill color palette.

To format a line style

• Select the shape and choose the Line
Weight, Line Pattern, and Line Ends but-
tons on the Format toolbar to select the for-
matting you want to use.

Flipping and rotating shapes
You can change the direction and angle shapes
face in your diagrams by flipping and rotating
them. Select shapes and then use commands
on the Tools menu or buttons on the Action
toolbar to flip and rotate shapes.

To view the Action toolbar

• Choose View > Toolbars > Action.

Grouping shapes
You can group shapes so they function as a
unit and so that you can regularly use them
together.

To create a group

1 Drag the shapes you want to group, one at a
time, from a stencil onto the drawing page.

2 Select the first shape, hold down the Shift
key, and then click to select the other shapes
one at a time.

3 Choose Shape > Grouping > Group.

Flip and rotate shapes with Action tools

Action Tool

Flip a shape horizontally

Flip a shape vertically

Rotate a shape right

Rotate a shape left

You can import a
graphic from another
program to use in
your diagram. Choose
Insert > Picture,
select the file format
or type the path and
name of the file you
want to import, and
then click Open.
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Adding information to shapes
A Visio diagram is more than a picture—you
can add information, called custom properties,
to shapes and generate reports from them.
Many Visio shapes come with custom property
fields already assigned, but you can also define
new custom property fields for shapes. You can
then add data to the custom property fields,
from which you can create and update reports.

To define and enter information for a new

custom property

1 Right-click the shape and then choose
Properties.

2 In the Custom Properties dialog box, click
Define.

3 Click New, and then enter information to
create a new custom property.

4 To enter information for a shape, right-
click the shape and then choose Shape >
Custom Properties. Enter the information
you want for the custom properties listed.

Saving and printing your
diagrams
The first time you save a diagram, Visio 2000
prompts you for document properties, such as
whether or not to save a preview (a small
thumbnail version of the diagram). The prop-
erties you specify appear in the Open dialog
box when you select the diagram file name.

To save a new diagram

1 Choose File > Save or Save As.

2 For File Name, type a name for the drawing
file.

3 For Save In, open the folder in which you
want to save the file, and then click Save.

4 In the Properties dialog box, enter the
information you want, and then click OK.

You can print your diagram by choosing File >
Print or clicking the Print button ( ) on the
toolbar.
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Sharing your diagrams with others

With Microsoft Visio 2000, you can add
hyperlinks to shapes to make your diagram a
launching point for users who want more
detail and related information.

If your diagram requires input from co-workers
or clients, you can use e-mail to route your dia-
gram to others for comment and additional
information.

Once your diagram is complete, publishing
your diagrams to the Internet or an intranet
site is as easy as saving a file. Visio 2000 auto-
matically adds the HTML codes necessary to
display the diagram in a Web browser, so all
you have to do is make sure your diagram
looks the way you want.

Adding hyperlinks to shapes and
pages
You can add one or more hyperlinks to Visio
shapes and drawing pages. A link can jump to
another page in the same Visio diagram,
another Visio diagram, or a non-Visio
document. For example, you can link a Process
shape in a flowchart to a Microsoft Word
document containing Total Quality
Management (TQM) documentation for
that process.

When you add hyperlinks to other pages in
the same Visio diagram, you can use them to
move among pages in the Visio diagram.

When you link a shape or page to a file, you
can decide whether the path to the link should
be a relative path or an absolute path.

Relative path A relative path describes the
location of the linked file in relation to the
Visio diagram, or to another path. You can
move the Visio diagram and the linked file
together (that is, move the entire path struc-
ture) without breaking the link, but if you
move the diagram or file separately, you break
the link.

NOTE To set a relative path that is not based on
the location of the Visio diagram, choose File >
Properties. On the Summary tab, for Hyperlink
Base, type the base path that you want.

Absolute path An absolute path spells out the
exact location of the linked file in terms of
drive, folder, and file name. You can move the
Visio drawing file without affecting the link,
but if you move the linked file, you must reset
the path.

You can view the
Professional Edition
and Enterprise Edition
User Guides in PDF
format, or view online
Help on the Microsoft
Visio 2000 Professional
Edition or Enterprise
Edition CD.
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To link a shape or page to another Visio

drawing page, a Web page, or a non-Visio file

1 Create or open a Visio diagram.

• To add a link to a page, display the page
with nothing selected.

• To add a link to a shape, select the shape.

NOTE If you are linking to a Visio 2000
diagram, make sure to save the diagram so
that you can open the source to which you
are linking.

2 Choose Insert > Hyperlinks.

3 Do one of the following:

To link to a Web site For Address, type the
Web site’s URL. If you don’t know the URL,
click Browse, and then choose Internet
Address to open your default Web browser.
Use you Web browser to locate the Web site
you want.

To link to a file For Address, click Browse,
and then click Local File. Navigate to the file
you want, and then click Open. (If necessary,
change the type of file in Files Of Type.)

If you are linking to a file and you want to
display a particular page, click Browse next
to Sub-Address, select the page you want,
and then click OK.

4 Under Description, type a name for the link
that identifies the location you’re linking to.

5 Do one of the following:

• To specify a relative path, leave Use
Relative Path For Hyperlink checked.

• To specify an absolute path, uncheck Use
Relative Path For Hyperlink.

6 Optional If you want to add another hyper-
link for the selected shape or page, click New,
and then repeat steps 3 through 5.

7 If you want to link to another page within
the current Visio document, or to a shape in
the document, click the Browse button to
the right of Sub-Address, specify the page,
shape, and zoom level you want, and then
click OK.
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Routing your diagrams for
comments
You can use e-mail to send a Visio diagram to
another user. For example, if you need infor-
mation from co-workers to complete your
diagram, you can route the diagram to them
electronically and ask for their comments.

The Visio program also lets you take advantage
of Microsoft Office routing features, including
sending diagrams to Microsoft Exchange fold-
ers, adding routing slips to diagrams you send
by means of e-mail, and adding journal entries
to Microsoft Outlook.

NOTE Visio products are compatible with e-mail
programs that support the Messaging Application
Programming Interface (MAPI) protocol.

To send a diagram with a routing slip

1 Display the diagram you want to send, and
then choose File > Send To > Routing
Recipient.

2 In the Routing Slip dialog box, click
Address to open your address list, select the
individuals or groups to which you want to
route your diagram, and then click OK.

3 If you want to route the diagram to people
in a specific order, select a person’s name,
and then click the up or down arrow in the
Move section to change that person’s posi-
tion in the list.

4 Under Route To Recipients, specify whether
to route the diagram to one person at a time
or to everyone at once.

5 Check Track Status to receive an update as
each person on the list passes the diagram to
the next person, or check Return When
Done if you’d rather not see the diagram
again until everyone has seen it.

6 Under Message Text, type the text you want
in the e-mail message, and then click Add
Slip.

7 Choose File > Send To > Next Routing
Recipient to send the diagram to the first
person on the routing list.

Converting diagrams to HTML
After you create Visio 2000 diagrams, you
can convert them into Web pages with links
to other Web pages by saving them as
HTML files.

To convert a diagram to an HTML file

1 Open the diagram you want to save as an
HTML file, and then choose File > Save As.

2 Type a name for the HTML file, choose
HTML Files (*.htm, *.html) for Save As
Type, and then click Save

3 In the Save As HTML dialog box, accept the
default settings, and then click OK.

You are prompted to view the HTML pages.

4 Click Yes to view the new Web pages in
your default browser.

NOTE Visio 2000 provides support for VML
(Vector Markup Language), which facilitates the
exchange, delivery, and editing of high-quality
vector graphics on the Web. You must have
Microsoft Internet Explorer 5.0 installed to save a
diagram in VML format.

If you receive a
routed diagram and
want to route it to the
next person, choose
File > Next Routing
Recipient.
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Develop custom solutions: create shapes, stencils, and templates

As well as providing you with ready-to-use
solutions, Microsoft Visio 2000 gives you the
flexibility to build your own. You can create
your own shapes, stencils, styles, and templates
that you and others can reuse. You can even
build your own toolbars and menus that con-
tain the tools and commands you use most
frequently.

Creating your own shapes
There are several ways you can create your own
shapes in Visio 2000. You can use Visio draw-
ing tools to create a shape from scratch, merge
a shape with other shapes to create a new
unique shape, or revise an existing shape.

To draw a shape from scratch using the Visio

drawing tools

• Choose a drawing tool from the Standard
toolbar, and then click and drag on the
drawing page to create the shape you want.

Click the arrow next to the rectangle tool and
the line tool to see more Visio drawing tools.

To merge existing shapes to create new shapes

1 Select the shapes in your diagram that you
want to use to create a new shape.

2 Choose Shape > Operations, and then
choose the appropriate command.

NOTE The new shape you create using any shape
operations command inherits the formatting of
the first shape you selected.
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Using shape operations commands

Command Result Example

Fragment Breaks a shape into smaller parts or creates new
shapes from intersecting lines or from 2-D shapes that
overlap.

Combine Creates a new shape from selected shapes. If the
selected shapes overlap, the area where they overlap
is cut out (discarded), creating a cookie-cutter effect.

Union Creates a new shape from the perimeter of two or
more overlapping shapes.

Subtract Creates a new shape by subtracting the area where
selections overlap from the primary selection.

Intersect Creates a new shape from the area where the
selected shapes overlap, eliminating non-overlapping
areas.

Offset Creates a set of parallel lines or curves to the right and
left of the original shape.

When you use the
pencil, line, rectangle,
or ellipse tool, try
holding down the
Shift key while you
draw, to see how that
constrains the
drawing behavior.
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Adding your own shapes to
stencils
If you want to reuse your own shapes the next
time you open a particular drawing type, you
can make them into masters by saving them to
existing stencils in your diagram, and then sav-
ing the file as a template (.vst).

You can also create a new stencil, and then add
your own shapes as well as any existing Visio
shapes you want to it. Then, you can save the
stencil in a template file, so that you and others
can reuse it in other diagrams.

To add your own shape to an existing stencil

1 Open the template containing the stencil
you want to add your own shape to.

2 Click the icon on the stencil title bar ( ),
and then choose Edit from the menu.

A red asterisk appears on the stencil icon
( ) to indicate that the stencil is editable.

3 Hold down the Ctrl key, and then drag your
own shape from the drawing page onto the
stencil.

A new icon representing your own shape
appears on the stencil with a generic name.

4 Click the new master on the stencil, click it
again, and then type the name you want for
the new master.

5 Click the stencil icon ( ), and then choose
File > Save As to open the Save As dialog
box. Navigate to the Solutions folder you
want to save the stencil in, and then type a
name for the stencil in the File Name box.
For Save As Type, choose Stencil (*.vss),
and then click Save to save your stencil.

To add your own shape to a new stencil

1 Choose File > Stencil > New Stencil.

The new stencil appears docked to the left
side of the drawing window, with a red
asterisk ( ) to indicate that it is editable.

2 Hold down the Ctrl key, and then drag your
own shapes, one at a time, from the drawing
page onto the new stencil.

3 Click the Save icon ( ) on the right side of
the stencil title bar.

4 In the Save As dialog box, navigate to the
folder where you want to save the stencil,
and then type a name for the stencil in the
File Name box. Check to make sure Save As
Type is Stencil (*.vss), and then click Save.
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Creating your own template
You might want to create your own template
when your diagrams

• Require customized settings such as page
size or scale, window size and position, or
shape or text styles.

• Often include a particular background or
set of layers.

To create and save your own template

1 Open your diagram or start a new diagram
based on the template you want to modify.

2 Open any additional stencils you want to
save with the template by choosing File >
Stencils > Open Stencil and then choosing
the stencil(s) you want.

3 Change drawing page settings and styles to
those you want to use in future drawings
that are based on this template.

4 Choose File > Save As, and then do the fol-
lowing:

• For Save As Type, select Template (*.vst).

• For File Name, type a name for your
template.

• For Save, make sure Workspace
is checked.

• For Save In, select the folder in which you
want to save the template.

5 Click Save.

Defining and editing styles
You can define styles that users can then apply
to shapes in the diagrams they create. A style in
Visio 2000 is a named collection of formatting
attributes that you can apply to shapes. You
can create styles that format the elements of a
shape: fill, line, and text. For example, you
might create a style that gives shapes a black
outline, a green fill, and black bold italic text.

When you define or edit styles in a drawing file,
the changes you make are available only in the
current diagram. To make a style available for
future diagrams, you can define or edit it in an
existing template. The style is then included in
every new diagram you create using that
template.

To define a new style

1 Choose Format > Define Styles, and then
type a name for the new style in the Style
list.

2 If you want to base the new style on an
existing style, select that style from the
Based On list.

3 Under Includes, check the attributes that
your style includes.

4 Under Change, click Text, Line, or Fill to
change the settings for each attribute you
included in Step 4.

5 Click Apply to add the new style and apply
it to selected shapes.

To show or hide
toolbars while you
work, choose View >
Toolbars, and then
click to add or
remove a check
mark next to the
toolbar you want to
show or hide.
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To change a style

1 Choose Format > Define Styles, and then
select the style you want to change in the
Style list.

2 To rename the style, click the Rename but-
ton, type a new name in the Rename Style
dialog box, and then click OK.

3 To change style settings, click the Change
button. When you finish changing the
attributes, do one of the following:

• Click Apply.

• Click Change to add the changes and
continue working in the dialog box.

Creating your own toolbars
You can create your own toolbars in
Visio 2000, so you can work more efficiently,
using only the tools you need as you create
your diagrams.

To create your own toolbar

1 Choose View > Toolbars > Customize.

2 On the Toolbars tab, click New, type a name
for the new custom toolbar, and then
click OK.

3 Click the Commands tab, and then from the
Categories list, select the category that con-
tains the command for which you want to
create a button.

4 Drag the commands you want to include,
one at a time, from the Commands list to
the toolbar.

To attach a custom menu or toolbar to the

drawing file so others can use it

1 Choose View > Toolbars > Customize, and
then click Attach.

2 In the Custom Toolbars list, select a toolbar
to include in the drawing file, and then click
Copy.

3 When all of the toolbars you want in the
drawing file are listed in the Toolbars In
Document list, click OK.

The network,
database, and
software solutions are
applications with
specialized
functionality that run
on the Visio engine.
For information on
developing your own
solutions, refer to
Developing Visio
Solutions, available in
PDF format on the
Visio 2000 Professional
Edition or Enterprise
Edition CD.
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Network and directory services
diagramming, design, and documentation

Whether you’re making an inventory of an
existing network, upgrading to Microsoft®

Windows® 2000 and Active Directory™, or
adapting new widescale communications tech-
nologies such as Voice over IP (VoIP) or
wireless, the Microsoft Visio® 2000 IT solutions
for networking can help you streamline the
planning, implementation, and management
of your networks.

You can visualize your existing network with the
industry-standard tools in Microsoft Visio 2000
Professional Edition for quickly and efficiently
diagramming high-level network topologies.
You can troubleshoot your network’s infrastruc-
ture with ease, because you have accurate and
detailed information to refer to.

Microsoft Visio 2000 Enterprise Edition offers
all of the diagramming features in Professional
Edition, plus powerful automated tools for net-
work design and documentation.

In this chapter

Comparing networking and directory services solutions in Professional Edition and
Enterprise Edition .............................................................................................................................40

Visualizing and planning your network................................................................................................42

Diagramming, designing, and documenting directory services ........................................................43

Automatically discovering, diagramming, and reporting on your network ......................................46

Using manufacturer-specific shapes for precise network diagrams..................................................49
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Comparing networking and directory services solutions in
Professional Edition and Enterprise Edition

The networking solutions in Microsoft Visio
2000 Professional Edition and Enterprise Edi-
tion offer powerful tools to assist you in the
design of robust, efficient networks.

Professional Edition provides tools for visualiz-
ing proposed or existing high-level LAN/WAN
topologies, and diagramming directory
services.

With Enterprise Edition you can automatically
generate network documentation using Auto-
Discovery™ technology and more than 18,000
vendor-specific device shapes, and import
directory services schemas and objects from
leading directory services vendors to plan for
changes or migrations.

The following tables can help you compare
Professional Edition with Enterprise Edition so
you can choose the edition that best suits your
organization’s needs.
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Networking solution
features

Professional
Edition

Enterprise
Edition

Generic network shapes

Create and manage physical and logical network diagrams and associate
data, such as manufacturer, product name, and model number, with
network shapes for tracking equipment and generating inventories or
bills of materials.

Yes Yes

Visio Network Equipment shapes

Choose from a library of more than 18,000 manufacturer-specific
shapes, from 375 network vendors, that you can use in your diagrams.
If you have Enterprise Edition, you can use these shapes in the diagrams
you create using the AutoDiscovery technology.

Sampler of
shapes

18,000+

AutoDiscovery technology

Use SNMP (Simple Network Management Protocol) to locate network
devices and automatically build a comprehensive database of layer 2
(data link), layer 3 (network layer), and frame relay network information.

No Yes

Inventory and materials reports

Populate ready-to-use network reports, with which you can automatically
turn network data into presentation-quality documentation.

Yes Yes

Automated reports

Choose from among 20 automated reports in the AutoDiscovery and
Layout solution to inventory IP addresses, summarize frame relay data,
and track changes to your network topology.

No Yes

Directory services
solution features

Professional
Edition

Enterprise
Edition

Directory services diagrams

Diagram Microsoft Active Directory, LDAP-based, and Novell Directory
Services® structures.

Yes Yes

Directory services import and export

Automatically document existing directory structures imported from
Microsoft Active Directory, LDAP-based vendors, and Novell Directory
Services. Export to an LDIF file that you can import to an LDAP-compliant
directory service.

No Yes
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Visualizing and planning your network

The Network Diagram solution simplifies the
process of designing and documenting LANs,
WANs, and telecommunications infrastruc-
tures. The solution includes

• Network shapes, most of which are
manufacturer-specific, representing
equipment made by Cisco Systems, 3Com,
Bay Networks, Cabletron, Hewlett Packard,
and others.

• Custom properties associated with shapes
to which you can add data and from which
you can produce reports and database
tables.

Use network diagrams to plan and document simple
networks and to track equipment by associating serial
number and location data with shapes.

To create a network diagram

1 Start Microsoft Visio 2000. In the Welcome
To Microsoft Visio dialog box, click OK.

2 Click Network Diagram, and then in the
Drawing Type box, double-click Logical
Network Diagram.

3 From the Logical Symbols stencil, drag an
Ethernet, ring, bus, or other network shape
onto the drawing page.

4 Drag workstation shapes and other shapes
onto the drawing page.

5 Select the ring, bus, or Ethernet shape, and
then place the pointer over a control han-
dle. When the pointer changes to a four-
headed arrow, drag it to a connection point
( ) on one of the surrounding shapes.

6 Repeat step 5 as necessary to connect the
shapes.

To enter custom property data for a shape

• Right-click the shape, and then choose
Properties from the shortcut menu.

To generate a report

1 Choose Tools > Property Report.

2 Follow the instructions in the Property
Reporting Wizard to generate your report.

You can use the Lay Out Shapes command to have
Visio 2000 position shapes in your network diagram
automatically. Open the network diagram you want to
lay out, and then choose Tools > Lay Out Shapes.
Experiment with the Placement settings to find a style,
direction, and depth you like.



M I C R O S O F T V I S I O 2 0 0 0 I T P R O D U C T S E V A L U A T I O N G U I D E 43
Diagramming, designing, and documenting directory services

With the directory services solutions in
Microsoft Visio 2000 Professional Edition and
Enterprise Edition, you can design new direc-
tories, create alternative designs for existing
directories, or create a plan for updating or
migrating your current network’s directory
services. You can plan and allocate current and
future network resources and design policies
and guidelines before the physical network
is in place.

Professional Edition: diagram
directory services
The Professional Edition directory services
solutions contain all the templates and objects
you need for creating quick and professional
directory service diagrams from the following:

• Microsoft Active Directory

• LDAP (Lightweight Directory Access
Protocol)

• Novell Directory Services (NDS)

A directory service
is a repository of
information about
network resources,
such as hardware,
software, users, or
policies. Each resource
is represented in the
solution by an icon,
called an object, which
contains specific
information about itself
and about its
relationship to other
objects.

Professional Edition and Enterprise Edition directory services solutions automatically open the Directory Navigator,
a separate window that displays the structure of the directory in a tree view as you add objects (also called views) to
the directory diagram. Here, the Country shape appears on the stencil (AAAA). After it is dragged from the stencil to the
drawing page it appears in both the Directory Navigator in the context of the directory’s structure (BBBB) and in the
diagram (CCCC).

A

B

C
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To create a directory services diagram

1 Start Microsoft Visio 2000. In the Welcome
To Microsoft Visio dialog box, click OK.

2 In the Choose Drawing Type dialog box,
click Network Diagram.

3 Choose the directory service you want to
document, and then click OK.

The solution opens with a default schema of
classes and properties for that service.

4 Drag shapes from the stencil onto the direc-
tory diagram to add the shapes to the dia-
gram and to the [Sub Tree] level of the
Directory Navigator.

Or, make a shape the child of an existing
object by dragging the shape from the sten-
cil and dropping it on top of the object you
want to be its parent in the directory dia-
gram. The shapes are connected in the
directory diagram with a Directory Connec-
tor ( ), and the relationship is added in
the Directory Navigator.

To modify an object by adding values and

extended properties

1 Right-click an object in the diagram or in
the Directory Navigator, and then choose
Edit Properties from the shortcut menu.

The Edit Properties dialog box opens with
the properties displayed for the object. The
object’s name appears at the top of the dia-
log box.

2 In the Edit Properties dialog box, do the fol-
lowing.

Show Optional Properties Check to show
the optional properties for the object.

Value field Enter a value for each property
to which you want to assign a value.

Show Extended Properties Check to show
the extended properties for this object.

Add Click to assign another extended
property.

Enterprise Edition: document
directory services
Enterprise Edition includes all of the directory
diagramming features in Professional Edition,
plus support for importing directly from a
directory service database. You can even filter
the objects you want to import, and then let
Enterprise Edition build the diagram for you as
you drag objects from the Directory Navigator.

In addition, Enterprise Edition supports
exporting directory diagrams as LDIF (LDAP
Data Interchange Format) files. LDIF is the
industry-standard file format for directories;
the LDIF file can be imported into a directory
service (Active Directory, LDAP, or NDS) or
third-party application.

NOTE You cannot import an LDIF file into a
directory service using Microsoft Visio 2000.
You must use that directory service’s importing
capabilities.

You can use the LDAP
solution to diagram
Netscape or
Microsoft Exchange
directories.
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Enterprise Edition only
To connect to a server and import

1 Start Microsoft Visio 2000 Enterprise
Edition, choose the directory service you
want to document, and then click OK.

2 In the Connect To Directory dialog box,
select Import From A Live Directory.

3 Click Browse to navigate to the server you
want to connect to.

4 Click OK to return to the Connect To
Directory dialog box.

The directory path of the object you are
selecting to import appears in the Directory
Object field. Reading from left to right, the
Directory Object field displays the location
of the object in the tree from the selected
object to the [Sub Tree] level.

5 In the Filter Options section, select the types
of classes you want to import.

All Classes Imports all classes.

Common Container Classes Imports a
predefined set of classes.

Selected Classes Gives you the common
containers and specific classes to import.

6 In the Import Depth section, enter a
value that indicates the import depth level
you want.

The import depth level indicates the num-
ber of subsequent child levels for the
selected directory object that you want to
import. For example, if you import an
Organizational Unit class and you enter 3
in the Import Depth field, you will import
all child objects down to and including
those that are three levels below the Organi-
zational Unit.

7 Click OK.

The Connect To Directory dialog box
closes. The [Sub Tree] icon appears in the
Directory Navigator along with a schema
based on the directory services solution you
selected. You can now manually model a
network by dragging objects onto your
directory diagram, add values to objects,
and rearrange the layout of the objects.

NOTE If you have not imported all objects from
a directory service, you can import additional
objects into the Directory Navigator.

To export your diagram to an LDIF file format

1 Choose Directory Services > Export To
LDIF > Export Entries or Export Changes.

NOTE The Export Entries command exports
the diagram in LDIF “Entry” format. The
Export Changes command exports the direc-
tory diagram in LDIF “Change” format.

2 Type a name for the file.

3 Select LDIF File*.ldf for Save As Type, and
then click Save.

The diagram is exported to an LDIF file
format.

NOTE Many directory services will not suc-
cessfully import the generated LDIF file unless
you have filled out the mandatory attributes
on any objects you’ve created.
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Enterprise Edition only
Automatically discovering, diagramming, and
reporting on your network

Microsoft Visio 2000 Enterprise Edition
includes the AutoDiscovery and Layout solu-
tion, a powerful set of tools that searches your
network, polls devices, gathers information
about the layer 2 and layer 3 devices, and then
creates a database with the information.

You can use the solution’s Discovery Wizard to
customize discovery to include only specific
networks or devices, to specify whether discov-
ery uses SNMP or PING to find devices, and to
determine the order in which SNMP commu-
nity strings are used.

The AutoDiscovery and Layout toolbar
appears when you open a network diagram
using the AutoDiscovery and Layout template
(AutoDiscovery and Layout.vst). You can also
right-click a device on the diagram to display a
shortcut menu with additional context-sensitive
commands, and choose commands from the
AutoDiscovery menu.

AutoDiscovery toolbar buttons

Button Name and action

Discovery Starts the Discovery Wizard
used to discover your network.

Add Networks Adds a network to the
drawing page to use as the starting
point of your diagram.

Add Devices Accesses the AutoLayout
feature used to create a hyperlinked
network diagram.

AutoLayout Automatically create simple
diagrams of your network and stores the
discovered data in an MSDE database.

Network Reporting Wizard Accesses the
Reporting feature, which allows you to
create reports using the discovered
network data.

Guided Update Starts the Guided
Updating™ feature and displays a
window that lists the devices,
interfaces, and networks that have
been added to, or changed on, your
network.

Database Viewer Opens the Database
Viewer, where you can delete and
rename objects in the database, set
the CIR (Committed Information Rate)
for DLCIs (Data Link Connection
Identifiers), set interface speeds, and
change a device class.

Network Diagramming Assistant
Accesses the Network Diagramming
Assistant for help on what to do next.
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Enterprise Edition only
To open the AutoDiscovery and

Layout template

1 Start Microsoft Visio 2000. In the Welcome
To Microsoft Visio dialog box, click OK.

2 In the Choose Drawing Type dialog box,
click Network Diagram, and then double-
click AutoDiscovery and Layout.

To use the Discovery Wizard

1 Choose File > New > Network Diagram >
AutoDiscovery And Layout.

2 Choose AutoDiscovery > Discovery >
Discovery, or click the Discovery button
( ) on the AutoDiscovery and Layout
toolbar.

3 Complete the wizard screens.

4 Create a diagram.

Updating the diagram with
network changes
You can view and incorporate network changes
by using the Guided Update command after
you rerun discovery to display a list of the com-
ponents on your network that were added,
modified, or deleted since the last time you dis-
covered the network.

The following changes are displayed in the
Guided Update window in a tree view.

Network Changes Shows devices added to or
deleted from the network.

Device Changes Shows new or deleted
interfaces.

New Objects Shows new network objects.

Connectivity Changes Shows new or deleted
data link connections.

In the Guided Update window, you can

• Apply the changes to your diagram immedi-
ately.

• Save the changes to a file to apply to your
diagram at another time. The next time you
run Guided Update, the new changes are
displayed in the Guided Update window,
and the previous changes are overwritten.
You can then open the saved file to apply
the previous changes.

• Load a previously saved file of network
changes.

To update your diagram

• Click the Guided Update button ( ) on
the AutoDiscovery and Layout toolbar.

Factors affecting discovery time

Factor Description

The number of
device types
discovery
looks for

The more options you select in
the Discovery Wizard, such as
types of devices to be
discovered and the number of
specified discovery domains,
the longer discovery will take.

The PING and
SNMP
timeout
settings

You can specify how long
discovery waits before timing
out if a device doesn’t respond
to a PING or SNMP request.
You can decrease the SNMP
timeout value if you have many
devices that don’t respond to
SNMP requests.

Link speeds WAN links take longer to
discover than LAN links.

ARP and
router table
size

The larger the tables, the
longer discovery will take.
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Enterprise Edition only
Reporting on your network
Using the AutoDiscovery and Layout solution,
you can quickly create tabular and textual
reports of your network’s status by extracting
your network data from the database. You can
quickly inventory IP addresses, summarize
frame relay data, track changes to your net-
work topology, and more. Reports are
generated as Visio drawing (.vsd) files, so you
can easily publish them to the Web.

To generate a network report on a device in

your diagram

1 Right-click the device you want to report on
and choose Generate Report.

2 In the Report Template field, choose a
report template from the list box.

3 Choose the Output Options for your report.

4 Click OK.

Sample

network report

Network Reports for Microsoft Visio
Devices by Manufacturer

HP and Sun
Device IP Address Description

Cisco Systems
Device IP Address Description

HP 10.1.1.200 HPJ3100B HP Switch 2000, revision B.03.01, ROM
sparc10c 10.75.50.31 SunOS sparc10c 5.5.1 Generic_103640-24 sun4m
sparc10b 10.75.50.29 SunOS sparc10b 5.6 Generic_105181-12 sun4m
hp6.lab.sssys.com 10.75.50.22 HP-UX hp6 B.10.20 A 9000/710 2005818370
hp5.lab.sssys.com 10.75.50.21 HP-UX hp5 B.10.20 A 9000/715 2003697940
hp4.lab.sssys.com 10.75.50.20 HP-UX hp4 B.11.00 A 9000/735 2011751462
Sparc2B 10.75.50.12 SunOS Sparc2B 5.5.1 Generic_103640-24 sun4c
hp2.lab.sssys.com 10.75.50.6 HP-UX hp2 B.10.20 A 9000/720 2010272657
sparc20 10.75.50.5 SunOS sparc20 5.7 Generic sun4m
hp3 10.75.50.3 HP-UX hp3 B.10.20 A 9000/715 2015119024

C1900-4 10.10.1.203 Cisco Systems Catalyst 1900
C1900-5 10.10.1.205 Cisco Systems Catalyst 1900
C2820 10.10.1.204 Cisco Systems Catalyst 2820
CAT2900-1 10.10.1.206 Cisco Systems WS-C2900
10.10.1.200 10.10.1.200 Cisco Systems WS-C5000
CAT2820-1 10.200.1.30 Cisco Systems Catalyst 2820
CAT3000-2 10.200.1.20 Cisco Catalyst System
LS1-C5000 10.20.1.12 Cisco Systems WS-C5000
LS1-C5500 10.20.1.11 Cisco Systems WS-C5500
LS2-C1900 10.20.1.123 Cisco Systems Catalyst 1900
LS2-1900 10.20.1.122 Cisco Systems Catalyst 1900
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Enterprise Edition only
Using manufacturer-specific shapes for precise network diagrams

The AutoDiscovery and Layout solution in
Enterprise Edition uses shapes that are
assigned to network objects by matching the
SysObjectID of the device to a shape found
on the stencils in the Microsoft Visio 2000
Network Diagram solution. A SysObjectID
is a value obtained using SNMP that vendors
use to identify their products.

Enterprise Edition also includes the Visio
Network Equipment solution, which is a
collection of over 18,000 detailed network
shapes from over 375 hardware manufacturers.
Every Visio Network Equipment shape also
includes a hardware-specific custom property
dialog box with tabs to store data on asset,
equipment, maintenance and network
properties. Some fields are even pre-populated
with AutoDiscovery data.

When you use these shapes in conjunction
with the AutoDiscovery and Layout solution,
Enterprise Edition maps network device types
to the correct Visio Network Equipment
shapes and automatically populates shape
properties with discovered data, such as name,
address, make, and speed. This information is
stored in the Visio Network Equipment data-
base and is continually updated with new
stencils. If a specific Visio Network Equipment
shape is not available for a discovered object, a
default shape is used.

You can also use shapes that you have created
or shapes from other stencils. The shapes you
specify to use for network and device mappings
take precedence over the AutoDiscovery and
Layout solution’s default mappings.

NOTE When you change the default shape map-
ping of a device type or network object, the new
mapping is used the next time that device is
imported into your diagram. It does not affect
shapes currently in a diagram.

This diagram uses Visio Network Equipment shapes
instead of AutoDiscovery and Layout shapes.
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Enterprise Edition only
To use other device shapes instead of the

default AutoDiscovery and Layout template

shapes

1 Choose AutoDiscovery > Configuration >
Map Shapes.

On the Default Shapes tab, do the following:

Default Object Types Choose a device type.

Stencils Choose Browse to locate a stencil
(.vss file) you want to use.

Shapes Select a shape to map to the device
type, and then click Map.

2 Click OK.

NOTE Enterprise Edition includes the Locate
Network Equipment utility, which you can use to
find shapes by keyword (such as name) or by cat-
egory (such as type, manufacturer, or product
line). You can locate only Visio Network Equip-
ment and logical network shapes with the Locate
Network Equipment utility.
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Database diagramming, design,
and documentation

The Microsoft® Visio® 2000 IT solutions for
database professionals provide you with the tools
to tackle today’s information management chal-
lenges, whether you’re supporting a transition to
e-commerce, implementing a Customer Rela-
tionship Management (CRM) system, or moving
from the decentralized, department-level use of
software to integration of multiple applications
enterprisewide.

With the easy-to-use, industry-standard tools
for rapid visualization in Microsoft Visio 2000
Professional Edition, you can diagram proposed
database structures using entity relationship
notation. You can also reverse engineer existing
systems from the leading client/server and data-
base vendors down to code-level detail.

Microsoft Visio 2000 Enterprise Edition offers all
of the features in Professional Edition, plus pow-
erful automated tools for synchronizing models
and databases, facilitating collaborative database
design, and generating models and schemas
from natural-language business rules.

In this chapter

Comparing database solutions in Professional Edition and Enterprise Edition ...............................52

Model-based database design ..............................................................................................................53

Reverse engineering a database to create a model ............................................................................54

Connecting to a database......................................................................................................................55

Working in a database model diagram ................................................................................................56

Refining a database model....................................................................................................................58

Creating a project to collaborate on database design ........................................................................63

Business rules based database design.................................................................................................66

Working with database code.................................................................................................................68

Updating and generating databases ....................................................................................................72

Validating and checking errors in a model ...........................................................................................74
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Comparing database solutions in Professional Edition
and Enterprise Edition

The database solutions in Professional Edition
and Enterprise Edition provide powerful tools
for designing databases. As the following table
shows, Professional Edition packs a wealth of
database diagramming features into one
affordable box. Enterprise Edition delivers a
complete, automated database design and

documentation solution for the development
and maintenance of reliable, flexible system
architectures.

For a complete list of the database solutions
in Professional Edition and Enterprise Edition,
see the table “Database modeling solutions” on
page 12.

You can view the
Professional Edition
and Enterprise
Edition user guides
in PDF format, or
view online Help,
on your Microsoft
Visio 2000 CD.

Database solution
features

Professional
Edition

Enterprise
Edition

Reverse engineering

Reverse engineer existing databases to visualize systems to code-level detail,
displaying views, triggers, check clauses, and stored procedures.

Yes Yes

Multiple notation support

Design new databases using relational, IDEF1X, or Crow’s Foot notation.
Yes Yes

Model and database synchronization

Model your database schema, and generate a database from the model. Keep
the model and database in sync by automatically comparing and updating each
with changes made to the other.

No Yes

Workgroup collaboration tools

Merge individual database diagrams into a single model.
No Yes

Database reports

Create customizable reports with complete information about database models.
No Yes

ORM Diagram template

Create conceptual Object Role Modeling (ORM) diagrams.
Yes No

Natural language business rules

Enter database information as natural language business rules using the ORM
Source Model template. Populate the model with real-world examples or
select items from a drop-down list to specify relationship constraints.

No Yes

Database schema generation

Map ORM diagrams to correctly normalized entity relationship models and
automatically generate database schemas.

No Yes

Error checking

Dynamically verify the correct use of the database notation. Check database
models for DBMS-specific errors.

No Yes

Microsoft Repository integration

Use Microsoft Repository to generate, reverse engineer, or update
Visio 2000 database models, enabling interaction with other tools, such
as Microsoft Visual Studio® or PLATINUM ERwin.

No Yes
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Model-based database design

Microsoft Visio 2000 Professional Edition and
Enterprise Edition provide powerful database
tools you can use to create conceptual, logical,
and physical model diagrams for relational and
object-relational databases.

A database model diagram can help you design
a complete, accurate, and efficient database by
graphically showing the relationships among
the objects, primary keys, and any errors in the
design.

With the Database solution in Microsoft Visio 2000 you
can reverse engineer a database to create a model;
create database model diagrams from scratch using
relational and object-relational (including Crow’s Foot)
or IDEF1X notation; or import an existing model from
VisioModeler, Visio 5.0, or PLATINUM ERwin.

Reverse engineer

Database schema
Microsoft Visio 2000

database model

ERwin .erx file
Visio Professional .vsd file

VisioModeler .imd file
Microsoft Visio 2000

database model

Import existing

model

Drag and drop

from stencil

Microsoft Visio 2000
stencil

Microsoft Visio 2000
database model
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Reverse engineering a database to create a model

You can create a model from a legacy database
using the Database Model Diagram solution in
Professional Edition or Enterprise Edition.

Reverse engineering, a widely used method for
creating models, allows you to improve,
enhance, document, and extend existing
databases.

In addition to a generic ODBC (Open Data-
base Connectivity) driver and a generic OLE
DB provider, Microsoft Visio 2000 includes its
own database drivers for the following DBMSs:

Desktop database drivers

• Corel Paradox 7, 8

• Inprise/Borland dBASE III, IV, 5;
Inprise/Borland Paradox 3, 4.x, 5

• Microsoft Access 2.0, 7.0, 97, 2000;
Microsoft FoxPro® 2.0, 2.5, 2.6;
Microsoft Visual FoxPro® 5.0, 6.0

Client/server database drivers

• IBM DB2 Universal Database 2.1.2, 5.0

• Informix Dynamic Server, with support for
the Universal Data Option;
INFORMIX–SE 5.0;
INFORMIX–OnLine 7.x;
INFORMIX–Universal Server

• Microsoft SQL Server 4.2, 6.0, 6.5, 7.0

• Oracle 7.x, 8

• Sybase Adaptive Server 10, 11.x (formerly
Sybase System);
Sybase Adaptive Server Anywhere 6.x;
Sybase SQL Anywhere 5.x

Microsoft Database Information Model driver

• Enterprise Edition only Microsoft DBM
Repository

When you reverse engineer a database, you
extract the schema from a database into a logi-
cal model. Your model can represent either
relational or object-relational databases, and
can use either IDEF1X or Relational notation.

To see how this process works, try using the
Reverse Engineer Wizard on any sample data-
base you have.

To reverse engineer a database

1 In Microsoft Visio 2000 Professional
Edition or Enterprise Edition, choose
File > New > Database > Database Model
Diagram.

2 Choose Database > Reverse Engineer to
start the Reverse Engineer Wizard.

3 Follow the instructions in the wizard.

4 Drag tables from the Tables window to the
diagram.
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Enterprise Edition only
Connecting to a database

The models you create with the database solu-
tions in Enterprise Edition are independent of
their implementation on any particular DBMS.
This independence allows you the flexibility to
implement a model on more than one DBMS,
or to reverse engineer a model from one
DBMS, modify it, and then implement it on a
different system. Enterprise Edition also pro-
vides full support for Microsoft Repository,
which you can use to share and exchange data-
base models.

When you reverse engineer a database to create
a model, generate a new database from a
model, or synchronize a model with a database
you must translate the portable information in
the model into a particular physical implemen-
tation for the target DBMS. When you perform
any of these tasks, you connect to the target
database using a Visio database driver, an asso-
ciated vendor-supplied ODBC driver, and a
data source. If you are storing your database in
Microsoft Repository, you can use the DBM
Repository driver.

The Visio database drivers are specially written
to access the features of leading DBMSs, and
are used in conjunction with standard vendor-
supplied 32-bit ODBC drivers, which manage
the actual connection to the database. The
Visio drivers contain information about a
DBMS’s physical implementation require-
ments, and they can extract code for views,
triggers, check clauses, and stored procedures.
Before you connect to a database, you must
associate a Visio driver with an ODBC driver.
For the association to work properly, you must
select drivers that are designed to support the
same DBMS.

A data source contains information about the
data you want to use and crucial information
about accessing it. You can create data sources
using the system-level Microsoft ODBC Data
Source Administrator, or you can create them
as you work in the Reverse Engineer Wizard,
Generate Wizard, Update Database Wizard, or
Refresh Model Wizard. Data sources you create
in Enterprise Edition can be managed using the
ODBC Data Source Administrator.
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Working in a database model diagram

When you create a database model in the
Database Model Diagram template, the shapes
in the diagram represent the elements you
want the database to store information about
and the relationships among those elements.
You can include other information in your
model, such as code for stored procedures,
although such information might not be visible
on the drawing page.

When you’re working in a database model,
you can customize its appearance. Microsoft
Visio 2000 Professional Edition and Enterprise
Edition support IDEF1X and Relational nota-
tion, and you can display relationships in either
notation using Crow’s Foot symbols. In addi-
tion to specifying notation for the entire
model, you can change the way individual ele-
ments in the model appear.

To choose display options

1 Choose Database > Options > Document.

2 Click the tabs in the Database Document
Options dialog box to view and select
options.

3 Click OK.

NOTE Depending on the Microsoft Visio 2000 IT
product and the options you select, Microsoft
Visio 2000 installs as many as seven templates in
the \Visio\Solutions\Database folder. The
Bachman, Chen ERD, Database Model
Diagram, Express-G, Martin ERD, and ORM
Diagram templates are installed with
Professional Edition. With the exception of the
ORM Diagram template, Enterprise Edition
includes all the above, along with the additional
templates ER Source Model and ORM Source
Model. This topic focuses on functionality in the
Database Model Diagram template, which is
available in both products. For details about
other templates installed in the Database folder,
see online Help. For details about which
templates come with which product, see
“Comparing Professional Edition and Enterprise
Edition” on page 11.

Enterprise Edition
includes seven differ-
ent preformatted
report types you can
use to create, print,
preview, and export
comprehensive
reports based on the
contents of your cur-
rent database model
diagram. Choose
Database > Report
to launch the New
Report Wizard.
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The Microsoft Visio

user interface for

creating database

models

A Choose commands for creating and refining models
from the Database menu.

B Drag shapes from stencils into the diagram to add
new elements to the model.

C Assemble shapes in the diagram to represent the
database model.

D Refine your model by working with elements in the
anchored windows.

A

B

C

B

D
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Refining a database model

Once you’ve created a database model diagram
in Professional Edition or Enterprise Edition,
you can add, modify, or delete elements such
as tables, columns, and relationships. In
Enterprise Edition, you can also set advanced
options such as custom data types and stored
code.

You can further refine a database model
diagram by using the anchored windows asso-
ciated with the template you’re working in.
Both Professional Edition and Enterprise
Edition include the Database Properties,
Tables, Code, Output, and Types windows.
Enterprise Edition also includes the Project
and Verbalizer windows.

Anchored windows

The Tables window (A),
Code window (B), and

other anchored
windows provide a
convenient way to
access advanced

options for refining a
database model

diagram. A

B
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To open the Database Properties window

• Double-click an element in the model
diagram.

TIP You can also right-click an element
and choose Database Properties from the
shortcut menu to display the Database
Properties window.

To open the other windows

• Choose Database > View, and then choose
the window you want to display.

Editing tables
Tables are the basic building blocks of a data-
base model, and represent the things about
which your database stores information. As
you refine a database, you might change a
table’s name, create or edit primary keys to
identify it more specifically, define indexes to
make searching quicker, or customize code
stored with the table in the form of triggers and
check clauses.

To add a new table to a database model

1 Open the drawing file that represents
your model.

2 From either the Entity Relationship or
Object Relational stencil, drag an Entity
shape onto the model diagram.

To edit the properties of a table

1 Double-click the table whose properties you
want to edit.

2 In the Database Properties window, click
the tab that contains the information you
want to edit, and make your changes.

The database model diagram is updated
automatically. You can choose Edit > Undo
to reverse the changes.

Here is a brief description of each tab and
the options it contains:

Definition Specify physical and conceptual
names for the table and whether to synchro-
nize the names. You can specify a name
space value for the table to distinguish it
from identically named tables in the model.
This tab also displays information reported
by the host database management system
(DBMS) about the database owner and the
path of the source database. The Defining
Type field is available only when a table is
empty, and it lists all composite data types
so that you can create a typed table.

Columns Add columns to a table and edit
the properties of columns in a table.

Primary ID Edit, define, or delete primary
keys from a list of available columns and
specify whether to create an index of pri-
mary keys.

Indexes Create, edit, define, rename, delete,
or set extended attributes for indexes. Use
this tab to specify the type of index you cre-
ate for a particular column.

Triggers Add, edit, remove, or preview the
code for triggers that are included in the
DDL (Data Definition Language) script cre-
ated when you use the Generate Wizard or
Update Database Wizard.
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Check Add, edit, remove, or preview the
code for check clauses that are included in
the DDL script created when you use the
Generate Wizard or Update Database Wiz-
ard.

Extended Set DBMS-specific extended
attributes for use with the Visio 2000 data-
base drivers.

Notes Type text to document the table.
Text you enter here appears in the Verbal-
izer window.

TIP You can use the Pushpin ( ) in the Data-
base Properties window to turn on Auto-Hide.
Auto-Hide minimizes the docked window when
you move your pointer outside of its border.
When the window is hidden, you must move the
pointer over the window bar to make the window
reappear.

To create or edit a primary key for a table

1 Double-click the table to which you want to
add a primary key. In the Database Proper-
ties window, click the Primary ID tab.

NOTE You can use the navigational arrows to
the right of the tabs to display additional tabs.

2 In the Available Columns list, select the col-
umn you want to be the primary key, and
use the Move button (>) to move it to the
Primary ID Columns list.

Optional Instead of clicking the Primary
ID tab, click the Columns tab, and then
check the PK box for each column you want
to include in the primary key.

Editing columns
Each table contains one or more columns that
represent specific attributes of the table; col-
umns are assigned specific data types. Each
table must have at least one primary key col-
umn that is used to uniquely identify the table.
In addition, columns can be identified as alter-
nate keys (unique attributes that have not been
defined as primary keys) or foreign keys (place-
holders or pointers to a column in a parent
table). As you refine a model, you may want to
add new columns to or delete columns from a
table, change a column’s name, or assign a dif-
ferent data type to a column.

To edit the properties of a column in a table

1 Double-click the table containing the col-
umn you want to edit, and then click the
Columns tab in the Database Properties
window.

2 Select a column you want to edit by clicking
its name, and then click Edit to open the
Column Properties dialog box.

3 In the Column Properties dialog box, click
the tab that contains the information you
want to edit, and then make your changes.

The database model diagram and the
Columns tab of the Database Properties
window are updated automatically. You can
choose Edit > Undo to reverse the changes.
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Here is a brief description of each tab and
the options it contains:

Definition Enter or edit a Physical Name to
control the column’s name in the database
or a Conceptual Name to control the col-
umn’s name as it appears in the model.
Check Allow NULL Values to make the col-
umn optional rather than mandatory.

Data Type Display either Portable Data
Types or Physical Data Types, and assign
Data Types to columns.

Collection Specify whether the column is a
single value or contains a collection of
information. Collections may be sets, lists,
or multiple values, and may only be used in
object-relational models.

Check Edit, add, remove, or preview check
clauses that are included in the DDL script
that you can create in the Generate Wizard
or Update Database Wizard.

Extended Set DBMS-specific extended
attributes for use with the Visio 2000 data-
base drivers.

Notes Type text to document the column.

4 Click OK to close the Column Properties
dialog box.

Editing relationships
Relationship shapes visually indicate how the
tables in a model interact. Editing the proper-
ties of a relationship allows you to control how
data is stored in and retrieved from a database.
When you define a relationship, you specify
which columns in a parent (originating) table
are inherited by the child (receiving) table. The
columns that are inherited become foreign
keys in the child table.

You can also specify both referential integrity
and cardinality settings when you define or edit
a relationship. Referential integrity settings
determine what happens to a foreign key when
the parent table is modified. Cardinality
defines the ratio of instances of a data value in a
child table relative to the parent table.

Relationship shapes show the relationship between
parent and child tables. In this example, Invoices (the
child table) has inherited CustomerID as a foreign key
from Customers (the parent table).
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To create a foreign key relationship

between tables

1 Open the drawing file that represents your
database model.

2 Add at least two table entities to your model
by dragging instances of the Entity shape
onto the diagram.

3 Add columns to each table by double-
clicking the table, clicking the Columns tab
in the Database Properties window, and
then clicking Add once for each column.
Assign a primary key by clicking in the PK
box for a column.

4 Define a foreign key relationship by drag-
ging a Relationship shape onto the diagram.
Drag the end of the Relationship shape that
indicates the parent to the parent table, and
release the mouse button when the table is
outlined in red. Connect the other end of
the Relationship shape to the child table in
the same way.

In ER notation, the arrowhead end of the
Relationship shape indicates the parent
table. In IDEF1X notation, the dot indicates
the child table.

Both connection points should appear red,
and any primary keys in the parent table are
added as foreign keys to the child table.

To edit the properties of a foreign key

relationship

1 Double-click the relationship whose prop-
erties you want to edit.

2 In the Database Properties window, click
the tab that contains the information you
want to edit, and make your changes.

The database model diagram is updated
automatically. You can choose Edit > Undo
to reverse the changes.

Here is a brief description of each tab and
the options it contains:

Definition Associate columns in the parent
and child tables and enter role names for
foreign keys.

Name Enter a Verb Phrase, Inverse Phrase,
Physical Name, or Notes about the relation-
ship.

Miscellaneous Specify the Cardinality type ,
the Relationship type (Identifying or Non-
identifying), and whether the relationship is
Optional.

Ref. Integrity Specify options that deter-
mine the effect on the child table when
information in the parent table is updated
or deleted.

As you refine your
database model, you
can validate it
periodically to ensure
it is free of logical
errors and is valid for
the target DBMS by
choosing Database >
Error Check.
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Enterprise Edition only
Creating a project to collaborate on database design

Microsoft Visio 2000 Enterprise Edition sup-
ports collaborative database design by
generating or forward engineering a database
schema from a project file. Projects can include
one or more source models, which can trans-
late into a collective logical or physical database
model. From that database model, you gener-
ate or forward engineer the database schema.

A project is a Visio document (.vsd file) created
with the Database Model Diagram template.
Project files

• Identify all the source models that compose
the project’s database model.

• Identify other, non-Visio documents relat-
ing to the database model, such as project
schedules or reports about the tables used in
the model.

• Contain the collective database model from
which you will generate your physical data-
base schema.

Source models are separate database model
diagram files you create in the ER Source
Model or ORM Source Model template. You
use source models to break a large database
model into smaller, more manageable parts so
that more than one person can work on the
project at a time. You can also create and edit
source models without including them in a
project, but you cannot use source models to
map changes to a database unless the source
models are part of a project.

How a project and its source models interact

A ER Source Model documents represent logical
database schemas.

B ORM Source Model documents represent
conceptual database schemas.

C Source models must be included in a project
before they can be used to generate a new
database or update an existing one.

D Database Model Diagram documents can contain
project information, including a collective model
that represents the source models included in the
project file.

E To migrate changes from a model to a database or
to generate a new database, you must work in a
Database Model Diagram document.

D
Project

File

E

C
Source Models

Database Model
Diagram

DBMS

ER Source
Model

A

ER Source
Model

A

ORM Source
Model

B
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Enterprise Edition only
Before you can map a source model to a physi-
cal database, you must first build the schema it
represents as part of a project’s logical or phys-
ical database model. Unlike conceptual
models, which aren’t concerned with how the
database design will be implemented, logical
and physical models assume the design will use
a particular data model, such as relational or
object-relational.

To create a project

1 Choose File > New > Database > Database
Model Diagram to open a new database
model diagram. Or, open an existing model
that was created by using the Database
Model Diagram template.

2 Choose Database > Project > Add Existing
Document.

3 In the Add Document To Project dialog
box, select the documents you want to add
to the project, and then click Open.

4 Optional To create a new source model
diagram and add it to the project, choose
New ER Source Model or New ORM Source
Model, enter a file name, and then click
Save.

5 In the project file, choose File > Save and
enter a name that identifies the project.

6 Optional Choose Database > View >
Project to open the Project window.

To remove a source model from a project

• Right-click the source model you want to
remove in the Project window, and then
choose Remove Document from the short-
cut menu.

Alternatively, choose Database > Project >
Remove Document, select the source model
you want to remove, and then click OK.

Each project contains a collective model that
represents all of the elements contained in
all of the source models for that project. After
building the collective model, you can connect
to a DBMS.

You can also add
source models to a
project by right-
clicking the project
name in the Project
window and then
choosing Add Existing
Document, New ER
Source Model, or
New ORM Source
Model from the
shortcut menu.
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Enterprise Edition only
To build a project’s collective model

1 In the project file, choose Database >
Project > Build.

NOTE If your project file already contains
model elements, choosing Build migrates the
elements in the model to one of the source
models. If the project’s collective model has
been built previously, choosing Build updates
the project’s collective model with changes
made in the source models.

2 All source models are automatically
checked for logical validity. If any of the
source models contain errors, the project
file cannot be built. Use the Output window
to locate and resolve any errors.

3 Drag tables and views from the Tables win-
dow onto the diagram.

To map saved changes from a source model to

the collective model

• In the project file, choose Database >
Project > Build.

Any changes made to the source models in the
project are reflected in the updated collective
model.

Building a project

When you choose
Database > Project >
Build from a project
file containing a list of
source models (A), the
source models in a
project are validated
(B) and then merged
into a collective
logical model in the
Database Model
Diagram project
file (C).

ER
Source
Model

ER
Source
Model

ORM
Source
Model

X

Y

Z

Z

X

Y

Model Validation

Collective Model
for the Project

Project Files

Database
Model

Diagram

A B C
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Enterprise Edition only
Business rules based database design

Not only does the Microsoft Visio 2000
Enterprise Edition database solution make it
easy to generate and re-engineer databases, it
also provides tools to help you communicate
effectively with end users during the develop-
ment process. To this end, the ORM Source
Model template in the database solution sup-
ports database design and re-engineering
through Object Role Modeling (ORM).

ORM notation

A Entity object types are drawn with solid lines.
B Value object types are drawn with dashed lines.
C External object types are drawn with shaded lines.
D Predicates appear as role boxes connected to

object types.

E Uniqueness constraints appear as arrows drawn
over role boxes, and indicate that every instance of
data for that role must be unique.

F Mandatory constraints are drawn as a dot where
the role connector attaches to an object type, and
require that every instance of that object play the
associated role.

B

S Date

Store!
(id)

Quantity

is partly identified by / partly identifies

is partly identified by / partly identifies

is made on / On...is...made

is for / is the amount of

Sale

has / is for

is partly identified by
/ partly identifies

A

Order Number

E

D

F

CTitle
(Title_id)

Payment
Terms
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Enterprise Edition only
By expressing a model in terms of natural
concepts, such as objects and roles, ORM
provides a conceptual approach to modeling.
The ORM approach views the application
domain as a collection of objects playing roles.
To build your data model, you create an ORM
model diagram, which the database solution
can automatically translate into a fully
normalized relational model. Unlike
traditional entity relationship notations,
ORM gives you the ability to capture business
rules with its extensive constraints and to
incorporate example populations to verify
your design.

When you include your ORM model in a data-
base model project, Enterprise Edition can
map your ORM model to a logical or physical
database model diagram in the project file. You
can then use the entities and attributes of a log-
ical or physical model to refine your design
before you implement it in the target DBMS.

The ORM Source Model template contains all
of the tools you need to create and refine ORM
models. You can choose to work directly with
shapes in the model diagram, or you can use
the Business Rules window and the Fact Editor
to create and modify facts and constraints. You
can also use the Verbalizer window to review
facts and constraints in a model stated in natu-
ral language.

To create an ORM model

• Choose File > New > Database > ORM
Source Model.

The ORM Source stencil (ORM Source.vss)
opens with a new drawing page.
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Working with database code

Professional Edition and Enterprise Edition
offer sophisticated handling of the code—such
as views, check clauses, triggers, stored proce-
dures, and raw DDL code—included in a
database. You can choose to extract code when

you reverse engineer a database, and you can
add new code as you work in a model. And
Enterprise Edition offers a Transfer command,
so you can easily migrate platform-specific
code from one DBMS to another.

The Code

window
Stored procedures User-defined functions

and other procedures that can be invoked with a
CALL statement and are stored in an executable
format in the database.

Functions Procedural code that returns a
value.

Triggers Code associated with specific
database tables that is invoked automatically
whenever rows of the associated table are
inserted, updated, or deleted.

Check clauses Code applied to a table or
column that enforces constraints.

View Definitions Code, usually containing
SELECT statements, that assigns the results of a
query to a named, tablelike structure called a view.

Raw DDL Other code that does not fall into
one of the above categories; for example,
synonyms or package constructs in an Oracle
database.
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The Code window lists all of the code associ-
ated with a particular database driver. Local
code is associated with a specific table or col-
umn in your model. Global code applies to the
model as a whole.

The Code Editor provides robust functionality
for editing the code stored in your model. You
can use the Code Editor to create new or edit
existing code.

How to work in the Code window

If you want to Do this

Remove code from
your model

Select an item in the list
and then click Delete.

Display only global
code

Right-click anywhere in
the window and then
choose Show Only
Global Code.

Create a new stored
procedure, function,
view definition, or
other DDL code

Click Global Code, click
New, and then work in
the Code Editor.

View an item in the
Code Editor

Select an item in the list
and then click Edit. Or
double-click the item.

How to work in the Code Editor

If you want to Do this

Automatically indent
lines as you enter code
to follow the scoping
rules of SQL

Right-click in the code
and then choose
Properties. On the
Language/Tabs tab,
select Follow Language
Scoping, and then click
OK.

Assign keyboard
shortcuts

Right-click in the code
and then choose
Properties. On the
Keyboard tab, select a
command, select a
new key assignment,
and then click OK.

Change spaces to tab
characters

Select the code, right-
click the selection, and
then choose Tabify
from the shortcut
menu.

Change keyword
colors in the code

Right-click in the code
and then choose
Properties. On the
Color/Font tab, select
an item, select a new
foreground or
background color, and
then click OK.
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To open code in the Code Editor

1 Choose Database > View > Code to open
the Code window, if it is not already open.

2 Click a code item in the list, and then click
Edit. Or double-click a code item in the list.

3 In the Code Editor, view and revise code on
the following tabs:

Body Enter and edit SQL statements. Use
the toolbar buttons, or right-click in the
code to see additional options.

Properties Enter or revise the code compo-
nent’s name, select the type of code it repre-
sents, and create a mirror file for saving the
code component externally.

Notes Add code comments that will be
generated in the DDL script for the model.

4 To set preferences for working in the Code
Editor, click the Window Properties button
( ). Or right-click in the code, and then
choose Properties from the shortcut menu.

5 In the Window Properties dialog box, select
options from the various tabs, and then
click OK.

6 Click OK to close the Code Editor.

To create a stored procedure, function, or other

global DDL code

1 If the Code window is not already open,
choose Database > View > Code.

2 Click Global Code, and then click New to
open the Code Editor.

3 In the Code Editor, do the following:

Body tab Enter SQL statements.

Properties tab Type a name for the code
item. Under Type, select Stored Procedure,
Function, or Raw DDL.

Notes tab Optional Enter comments for
the code.

4 Click OK to close the Code Editor.

The code is added to the Global Code list in
the Code window.
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Transferring code
The code you see in the Code window is plat-
form specific, but with Enterprise Edition, you
can transfer code from one target DBMS to
another. You can create as many platform spe-
cific copies of your code as you need—all
versions are stored with the model. As you
work, you can view different code versions by
changing the currently selected database driver.
You can then customize the code as necessary
for the intended platform by opening it in the
Code Editor.

To transfer code to a different DBMS platform

1 Open the Database Model Diagram or ER
Source Model template file that represents
your database model diagram.

2 Choose Database > Code > Transfer.

3 In the Transfer dialog box, under Opera-
tion, select Move to transfer all the code to
the new platform, or select Copy to transfer
a copy of the code and leave the original
implementation.

4 Under Source DBMS, select the database
you reverse engineered. Under Destination
DBMS, select the new platform for which
you want to generate the code.

5 Click OK.

When the transfer is complete, a message
appears in the Info tab of the Output
window.

Synchronizing code
With both Professional Edition and Enterprise
Edition, you can create a mirror file for each
piece of code included in your model that you
can store in your version control software.
And, in Enterprise Edition, you can edit the
mirror files outside of the model, and then syn-
chronize the model code with the mirror files.
Mirror files are synchronized individually for
maximum control.

To save code in a mirror file

1 Choose Database > View > Code to open
the Code window, if it is not already open.

2 In the Code window, select the code
you want to save, and then click Edit. Or
double-click the code.

3 In the Code Editor, click the Properties tab.

4 For File, enter a path and file name, click
Open, and then click OK to close the Code
Editor.
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Updating and generating databases

As you work in Professional Edition or
Enterprise Edition, you can use the Refresh
Model Wizard to update your model with
changes that have been made to the database
you reverse engineered.

In Enterprise Edition, from your completed
model, you can use the Update Database Wiz-
ardto connect to the original database and
modify it to reflect the changes in your model.
Or, you can use the Generate Wizard to either
generate a new database directly or create a
DDL script that the DBMS will implement.

When you use the Update Database Wizard,
Enterprise Edition performs a unique three-
way comparison that tracks differences
between the model, the original database
schema, and the current database schema.
When differences are discovered, you can
choose how to resolve them.

To refresh a model

1 Choose Database > Model > Refresh to
open the Refresh Model Wizard.

2 Follow the instructions in the wizard.

To update a database

1 Choose Database > Update to open the
Update Database Wizard.

2 Follow the instructions in the wizard.

To generate a database schema

1 Choose Database > Generate to open the
Generate Wizard.

2 Follow the instructions in the wizard.

NOTE These commands are available only when
you start a model using the Database Model Dia-
gram template. Only the Refresh Model Wizard
is available in Professional Edition.

Use this wizard To do this

The Refresh Model Wizard Ensure that your model reflects the current state of the database
from which it was extracted. This is helpful if the original database is
being modified by several people.

The Update Database Wizard Change the structure of your database to match the content of your
model. You can update the database directly, or create a DDL script.

The Generate Wizard Create a database schema for a particular DBMS using the
information in your model. You can generate the new database
directly, or create a DDL script.
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Enterprise Edition only
Working with DDL scripts
Both the Update Database Wizard and the
Generate Wizard include options for modify-
ing a database directly or for creating a DDL
script written in SQL code that can be imple-
mented by the target DBMS. Not all DBMSs
support direct modification through 32-bit
ODBC drivers, and therefore may require that
you work with DDL scripts. You should deter-
mine the requirements of your database before
you choose either option. DDL scripts are also
convenient if you want to manually review or
edit the script before implementing it; they can
be opened using any text editing program, such
as Notepad. Additionally, creating a DDL
script does not require the use of a 32-bit
ODBC data source.

To create a DDL script

1 Choose Database > Generate to begin
working in the Generate Wizard, or choose
Database > Update to begin working in the
Update Database Wizard.

2 On the first screen of the wizard, check
Generate A Text File Of The DDL Script,
enter a path and file name for the new script
in the File Name box, and then click Next.

3 Follow the instructions on the remaining
screens of the wizard.

When the wizard finishes, you are prompted to
view the generated DDL script. Be sure to
review the script carefully before you run it in
your DBMS.
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Enterprise Edition only
Validating and checking errors in a model

In Enterprise Edition, you can use the Error
Check command to check the validity of your
model at any time during the modeling pro-
cess, and validation is automatically performed
when you choose the Generate, Refresh Model,
Update Database, or Build command.

During logical validation the database solution
checks your model for adherence to generally
accepted database design standards. For exam-
ple, circular table relationships produce an
error during logical validation. During physical
validation, the database solution checks your
database model for compliance with DBMS-
specific requirements. For example, an Oracle
DBMS allows only one column in a table to use
the Long data type; if a table contains more
than one column using this data type, valida-
tion will generate an error. It is possible to have
a logically correct database model that contains
physical errors, especially if you are reverse
engineering a legacy database to a new DBMS.

To validate a database model

1 Open the drawing file that represents your
model.

2 Choose Database > Model > Error Check.

To correct an error or warning

1 In the Output window, double-click the
error or warning text.

The structure is selected in the model dia-
gram containing the error.

2 Right-click the error text in the Output win-
dow, then choose Get Help For Message
from the shortcut menu.

An explanation and solution for the error
are displayed.

3 Make the necessary correction.

4 Repeat steps 1–3 for each error or warning
in the Output window.



C H A P T E R

4

Software design and documentation

Microsoft® Visio® 2000 Professional Edition
and Enterprise Edition support the major
object-oriented and data-oriented
software modeling and design languages,
including the Unified Modeling Language
(UML). Professional Edition and Enterprise
Edition make it easy for you to share your soft-
ware designs and models and are excellent
tools for team-based development.

Using the range of software solutions available
in Professional Edition and Enterprise Edition,
you can

• Create integrated system models using the
UML. Reverse engineer information models
from source code created in Microsoft
Visual Studio® and generate code skeletons
into C++, Microsoft Visual Basic®, or Java
to speed up your development effort.

• Design and document software projects
using object-oriented methodologies, such
as Booch, Real-Time Object-Oriented Mod-
eling (ROOM), and Rumbaugh.

• Show the procedural components of pro-
grams using structured charts, such as
Nassi-Schneiderman charts.

In this chapter

Comparing software solutions in Professional Edition and Enterprise Edition ................................76

Software modeling solutions ................................................................................................................77

Creating software models with the UML..............................................................................................78
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The UML diagrams in a typical development process........................................................................85

Diagnosing and fixing semantic errors ................................................................................................91

Creating reports from a UML model ....................................................................................................92

Generating code skeletons from UML models ....................................................................................93

Storing and retrieving models: working with Microsoft Repository..................................................95
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Comparing software solutions in Professional Edition
and Enterprise Edition

Microsoft Visio 2000 Professional Edition
enables you to streamline your development
efforts by quickly creating software model dia-
grams using a wide range of design languages,
including the UML.

In addition, Enterprise Edition provides
powerful functionality to jumpstart your
development efforts once modeling is

completed. Generate code skeletons directly
from UML class diagrams. Enable other
developers to easily access diagrams by
exporting them to Microsoft Repository 2.0,
and from there to the CASE tool of their
choice.

The following table details the features
provided by each edition.

Software solution
features

Professional
Edition

Enterprise
Edition

Multiple software notation

Create models using Booch, Rumbaugh, Schlaer-Mellor,
Nassi-Schneiderman, ROOM, and other notations.

Yes Yes

UML notation

Create all UML 1.2 diagram types.
Yes Yes

Reverse engineering

Reverse engineer existing application code directly from Microsoft
Visual Basic, Visual C++®, and Visual J++® to produce UML class
diagrams.

Yes Yes

Semantic error checking

Identify and diagnose semantic errors in UML 1.2 diagrams.
No Yes

Code generation

Generate Visual Basic, C++, and Java code skeletons from UML class
diagrams. Or generate IDL code for conversion to other scripting
languages.

No Yes

UML reports

Generate customizable reports for UML static structure, deployment,
and activity diagrams.

No Yes

Microsoft Repository integration

Import models from and export them to Microsoft Repository 2.0 to
enable interaction with other tools such as PLATINUM ERwin or
Microsoft Visual Studio®.

No Yes
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Software modeling solutions

Each software modeling solution consists of
SmartShapes® symbols programmed to behave
according to the rules of the specific modeling
methodology.

To open a software modeling solution

1 Start Microsoft Visio 2000 Professional
Edition or Enterprise Edition.

2 Choose File > New > Software, and then
choose the solution you want to use.

The following table shows the software dia-
gram types included in Professional Edition
and Enterprise Edition.

Software solution and purpose

Booch OOD

Supports the creation of object, class, timing,
state, module, and process diagrams using Booch
object-oriented design notation.

COM and OLE

Supports the creation of COM (Component Object
Model) objects and interfaces and system
diagrams.

Data Flow Model

Supports the creation of data flow diagrams using
Gane-Sarson notation.

Fusion

Supports the creation of diagram types included in
the Fusion methodology.

Jackson

Supports the creation of data and program
structures using the Jackson software design
method.

Jacobson Use Cases

Supports the creation of use case, state transition,
interaction, and other diagrams included in the
Jacobson object-oriented software engineering
method.

Nassi-Schneiderman

Supports the representation of sequence,
selection, case, and repetition in program structure
charts.

Program Structure

Supports the creation of structural diagrams of
programs and memory objects.

ROOM

Supports the creation of Real-Time Object-
Oriented Modeling (ROOM) diagrams that show
the relationships among system components and
system responses to events.

Rumbaugh OMT

Supports the creation of object, dynamic, and
functional diagrams using the Object Modeling
Technique.

Shlaer-Mellor

Supports the creation of class diagrams, class
structure charts, dependency diagrams, and
inheritance diagrams using Shlaer-Mellor notation.

SSADM

Supports the creation of logical data structures,
data flow diagrams, entity life histories, and other
system analysis and design diagrams.

System Structure

Supports the creation of diagrams that represent
Microsoft Windows® and Macintosh operating
systems and user interfaces

UML

Supports the creation of integrated system models
based on the Unified Modeling Language (version
1.2) diagram types.

Windows User Interface

Supports users who need to develop, document,
or prototype Microsoft Windows and Microsoft
Office user interfaces.

Yourdon and Coad

Supports the creation of object state, data flow,
and other diagrams included in Yourdon and Coad
object-oriented analysis and design notation.

Software solution and purpose (continued)
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Creating software models with the UML

The UML is used to specify, construct, visual-
ize, and document the artifacts of a software-
intensive system. The vocabulary of the UML is
a notation—a set of shapes and symbols. Its
semantics indicates the meaning of the shapes
and the rules for their use.

The UML notation includes elements that sup-
port the creation of several diagram types. Each
diagram provides a different view of a model of
a software system.

The UML Model Diagram solution in
Professional Edition and Enterprise Edition
includes the following tools, shapes, and
functionality.

This section provides
a conceptual
overview of the Visio
approach to modeling
in the UML and leads
you through the basic
steps of building a
model from scratch.

Tool, shape,
or functionality

Professional
Edition

Enterprise
Edition

UML Navigator

Use the tree view to manage system models and navigate from one
view to another.

Yes Yes

Predefined shapes

Use to represent all the elements in the UML notation that support
the creation of all UML diagram types. The shapes are programmed
to behave in ways that are consistent with the UML semantics.

Yes Yes

UML Properties dialog boxes

Add attributes, operations, and other properties to UML elements.
Yes Yes

Reverse engineering

Reverse engineer projects from Microsoft Visual Studio to generate
UML static structure models.

Yes Yes

Semantic error checking

Identify and diagnose errors.
No Yes

Microsoft Repository support

Import and export information models, regardless of platform or tool.
No Yes

Code generation

Generate code skeletons from UML models to C++, Visual Basic,
or Java.

No Yes

Code checking utility

Check syntax in models to identify potential compilation errors.
No Yes

Report generation

Create reports from UML diagrams that you can preview, print, and
export as RTF files.

No Yes
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Using the UML solution interface
When you open the UML solution, you’ll see
the UML Navigator window, a Status window,
UML diagram stencils, and the drawing page.

Understanding the Visio 2000 approach to
modeling in the UML will help you work more
efficiently.

• One UML drawing file represents a system.
In the UML Model Diagram solution, the
models you develop for a system are con-
tained within one UML drawing file. System
model files are saved with a .vsd extension.

• A package is the basic organizing element of
a UML model. An element is owned by only
one package, but you can include a refer-
ence to the element in other packages.

• All the models for a system appear in the
same drawing file, and each model is visible
in the tree view. One system can include
many models.

• Each type of UML diagram presents a dif-
ferent view of a model. For example, use
case diagrams show the system from a user’s
perspective, while class static structure dia-
grams translate user requirements into soft-
ware classes and relationships.

• The tree view in the UML Navigator pro-
vides a comprehensive picture of the mod-
els of a system and of most elements in each
model.

Some elements, such as classes, use cases,
and components, might exist in a model
without appearing in a diagram.

The UML

drawing file

A Your system model appears in a tree view in this section
of the UML Navigator. As you add elements to the
model, corresponding icons appear in the tree view.

B When you drag shapes from the available UML stencils
onto the drawing page, many of the shapes also appear
as icons in the tree view.

C Property values associated with UML elements
appear on the Properties tab of the Status window.

D Documentation-tagged values associated with
UML elements appear on or can be added to the
Documentation tab of the Status window.

B

C
D

B

B

A



80 M I C R O S O F T V I S I O 2 0 0 0 I T P R O D U C T S E V A L U A T I O N G U I D E
• Properties are features associated with UML
model elements that become integral parts
of those elements. For example, you can
associate attributes, operations, and other
properties with classes in class static struc-
ture diagrams.

For any UML element on a diagram, you
have the option of showing or hiding spe-
cific properties.

Right-click a shape and choose Shape
Display Options to control which proper-
ties are displayed on a shape.

• Enterprise Edition only As you model a sys-
tem using the UML solution in Enterprise
Edition, a semantic error checker runs in
the background to identify and diagnose
errors. The semantic error checker locates
the shapes or icons that represent elements
that contain errors. Shapes turn red to indi-
cate a semantic error.

Error messages are displayed on the Errors
tab in the Status window. Double-clicking
the error selects both the icon in the tree view
and the corresponding shape on the page.

Models in the

tree view

A The Visio icon ( ) represents the UML Model
Diagram file as a container for all the systems you
want to model.

B The system icon ( ) represents the system you
are currently modeling.

C The green folder icon ( ) represents one model
of your system.

D The yellow folder icon ( ) represents the top
package in the use case model. Packages are
created automatically when you create a new
model.

E These packages contain the common BASIC, C++,
IDL, or Java data types.

E

A
B

C
D
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Modeling a system using the UML solution

When you use the UML Model Diagram solu-
tion to model a system, you perform these
iterative steps:

• Add a new model to the existing system.

• Start a new diagram within a model.

• Add UML elements to a model.

• Associate properties with UML elements.

• Diagnose and fix semantic errors.

Modeling a new system

To open the UML Model Diagram solution

1 Start Microsoft Visio 2000 Professional
Edition or Enterprise Edition.

2 Choose File > New > Software > UML
Model Diagram.

By default, a new system includes the com-
monly used C++, BASIC, IDL, and Java data
types. You can delete data types you don’t use
and add data types of your own.

NOTE If you delete a predefined data type (C++,
BASIC, Java, IDL) from the model, you will not
be able to add it back into the current document.
The best method for controlling the data types
available in a model is to select the data types you
want to use in the UML Options dialog box.

Adding a new model to an
existing system
When you open the UML Model Diagram
template, your system already includes one
model called the Static Model. You can add
new models that offer different perspectives
of your system, and delete models you no
longer need.

To add a new model

1 Open the UML Model Diagram file that
represents your system.

2 Choose UML > Models.

3 In the UML Models dialog box, click New.

4 Select the new package in the list, and then
click Properties.

5 In the UML Model Properties dialog box,
enter or choose values for the properties you
want. Click OK, and then click OK again.

To edit an existing model

1 Open the UML Model Diagram file that
represents your system.

2 Choose UML > Models.

3 In the UML Models dialog box, select the
model to edit, and then click Properties.

4 In the UML Model Properties dialog box,
enter or choose values for the properties
you want to change. Click OK, and then
click OK again.
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To delete a model

• Right-click the model’s icon in the tree
view, and then choose delete.

NOTE A system must include at least one
model, so the UML solution will prevent you
from deleting the last available model.

Starting a new diagram within
a model
The UML solution is designed to help you cre-
ate UML diagrams in the proper relationship
to one another. For example, you can create a
statechart or activity diagram only in relation
to a specific class or use case.

To start a new diagram

1 Open the UML Model Diagram file that
represents your system.

2 In the tree view, right-click the icon repre-
senting the package, class, or use case in
which you want to place the new diagram.

3 Choose New from the shortcut menu, and
then choose the type of diagram you want to
create.

Adding UML elements to a model
Elements, such as classes, use cases, and com-
ponents, might exist in a model without
appearing in a diagram.

When you add an element to a diagram by
dragging a shape from a stencil onto the draw-
ing page, the element is automatically added to
the tree view. However, when you add an ele-
ment directly to the tree view, the element does
not appear in a diagram. You must also drag
the icon from the tree view and drop it onto a
drawing page.

Similarly, if you delete a shape from a diagram,
that shape is not automatically deleted from
the tree view.

In addition, you can add different views of the
same element to different diagrams by drag-
ging the icon representing the element onto
different drawing pages.

To add a new element to a model

1 Open the UML Model Diagram file that
represents your system.

2 In the tree view, right-click the package or
class in which you want to create a new
element, and then choose New from the
shortcut menu.

3 Choose the kind of element you want to
create.

To add a new element to a diagram

1 In the tree view, double-click the icon that
represents the diagram to which you want
to add a new element.

The appropriate stencil and drawing page
appear.

2 Drag the shape representing the element
you want to add to a diagram from the
stencil and drop it onto the drawing page.

When you drop classifier shapes, such as
Class, Use Case, and Component shapes,
onto the drawing page, an icon is automati-
cally added to the tree view for each new
element.

To add a view of an existing element to a

diagram

• Drag the icon from the tree view onto the
diagram to which you want to add it.
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Reverse engineering source code into the UML

If you develop projects in Microsoft Visual
Basic, Visual C++, or Visual J++, you can use
the UML solution in Professional Edition or
Enterprise Edition to reverse engineer your
projects’ class definitions and then generate
UML static structure models.

The reverse engineering process automatically
generates a model from your source code in the
tree view of the UML Navigator. You can then
drag icons from the tree view onto a drawing
page to create static structure diagrams, and
you can access the properties of UML elements
by double-clicking an icon in the tree view or a
shape on the drawing page.

NOTE This solution supports reverse engineering
only for version 6.0 of Visual C++, Visual J++,
and Visual Basic. Service Pack 3.0 for Microsoft
Visual Studio must be installed for the Visio
UML Add-In to function properly.

To reverse engineer a project, you must first
customize your development tool (Visual C++,
Visual Basic, or Visual J++) with the Visio
UML Add-In, and then open the project that
contains the code you want to reverse engineer.
The following procedures use Visual Basic as
an example.

The installation of
Professional Edition
or Enterprise Edition
includes the DLL files
used to customize
Visual C++ 6.0, Visual
J++ 6.0, and Visual
Basic 6.0.

When you customize Visual C++, Visual J++, and
Visual Basic using the Visio UML Add-In, this toolbar
for reverse engineering to the UML solution becomes
available. Commands are also added to the Tools menu.
You can locate the commands by choosing Tools >
Visio UML Solution.

A Open Visio button Click to start Visio 2000 and
choose the solution you want to open.

B New Visio UML Document button Click to open
the UML Model Diagram solution.

C Reverse Engineer UML Model button Click to
reverse engineer the source code for a specific
project, open the UML Model Diagram solution,
and display the results as icons in the tree view.

D Visio UML Options button (Visual C++ only) Click
to set options for including or excluding MFC
classes, ATL classes, or standard Include files.

E Visio UML Help button Click to open the Visio
UML help topics on reverse engineering source
code.

Visio UML Add-In

toolbar

A B C D E
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To customize Microsoft Visual Basic with the

Visio UML Add-In

1 In Visual Basic, choose Add-Ins > Add-In
Manager.

2 In the Add-In Manager dialog box, select
Visio UML Add-In. For Load Behavior,
check Loaded/Unloaded and Load On
Startup, and then click OK.

To reverse engineer source code in Visual Basic

1 Customize Visual Basic, and then open the
project that contains the source code you
want to reverse engineer.

2 In Visual Basic, click the Reverse Engineer
UML Model button ( ) on the Visio
UML Add-In toolbar.

The Visio UML Model Diagram solution
opens with a blank static structure diagram
drawing page and a tree view in the UML
Navigator populated with icons that reflect
the class definitions in the source code.

3 In the UML Model Diagram solution, drag
icons from the tree view onto the drawing
page to create a static structure diagram.

Support language constructs

Language Constructs supported

Visual C++ • Classes

• User-defined types

• Enumerated types

• Member functions

• Member variables

• Method parameters

Visual Basic • Classes, modules, and
forms

• Functions and subroutines

• Functions and subroutine
parameters

• Constants

• Member variables

• Properties

• Events

Visual J++ • Packages

• Classes

• Interfaces

• Class and interface
methods

• Class attributes

• Method parameters
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The UML diagrams in a typical development process

The UML notation, and the UML solution in
Professional Edition and Enterprise Edition,
support the creation of models without recom-
mending any particular development process.

For the purpose of showing the diagrams in a
meaningful context, the following sections
organize the UML diagram types into models
that roughly correspond to the phases a devel-
opment process might follow.

To create a new UML diagram

1 Open the UML Model Diagram file that
represents your system.

2 In the tree view, right-click the icon
representing the elements that you want
to diagram, and then choose New >
[diagram type] from the shortcut menu.

For conceptual, package, and class diagrams,
choose New > Static Structure Diagram.

Use case model phase
Use cases are narrative process descriptions that
you create early in a development cycle. They
describe the interactions between external
actors and the system, and make the system
requirements and the terminology used in the
domain area more understandable.

Create use case
diagrams to describe
real-world activities
and motivations.
Creating a use case
diagram involves
establishing a system
boundary for a set of
use cases and
defining the lines of
communication
between a particular
actor and a use case.
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Domain model phase
Like the use case phase, the domain model
phase is an analysis phase in which you’re still
thinking more about objects and relationships
in the real world than about programming
concepts.

NOTE The diagrams in the following sections,
which illustrate a library information system,
originally appeared in object-oriented analysis
and design training materials written by Craig
Larman for ObjectSpace (www.objectspace.com).
The activity, component, and deployment dia-
grams originally appeared in the OMG Unified
Modeling Language Specification.

Use a conceptual
diagram—a type of

static structure
diagram—to

represent concepts
from the real world

and the relationships
among them. The

conceptual model
focuses on

relationships and
attributes rather than

methods, and helps
you understand the

terminology in the
domain.
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As your understand-
ing of the problem
domain increases,
your conceptual
model becomes more
complicated. You can
use packages—the
basic organizing
elements of UML
system models—to
divide your model
into smaller, more
manageable subsets,
or to define system
architecture.

Use a type of interac-
tion diagram called a
sequence diagram to
show the actors or
objects participating
in an interaction, and
the events they gener-
ate, arranged in a time
sequence. Often, a
sequence diagram
shows the events that
result from a particu-
lar instance of a use
case.
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Design model phase
In the design model phase, you apply the
knowledge gathered in the earlier phases and
come up with a programming solution.

Use collaboration diagrams to determine how
objects will communicate and class diagrams to
define the classes you will implement in the soft-
ware. To understand the life cycle of an object,
create a statechart or activity diagram in relation
to a particular class, concept, or use case.

Class diagrams are
static structure

diagrams that
decompose a software

system into its parts.
The parts are classes

that represent fully
defined software

entities. In addition to
attributes and

associations, a class
diagram also specifies

operations, methods,
interfaces, and
dependencies.

Use a collaboration
diagram to show how

a group of objects
collaborates with one

another for one system
event defined by one

use case. A
collaboration diagram

shows relationships
among object roles

related in a particular
context—a

collaboration—and an
interaction, which is
the set of messages

exchanged among the
objects to achieve an

operation or result.
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Create a statechart
diagram to represent a
state machine, or a
graph of states and
transitions that
describes the
response of an object
to outside stimuli. By
documenting events
and transitions for a
single class or use
case, a statechart
diagram shows the
sequence of states a
single object goes
through during its
lifetime.

An activity diagram is
a special case of a
statechart diagram in
which all of the states
are action states and
the transitions are
triggered by the
completion of actions
in the source state.
Related to a specific
class or use case, an
activity diagram
describes the internal
behavior of a method.
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Implementation model phase
The implementation model phase focuses on
the physical and component structures of the
development environment.

Use component
diagrams to show the
structure of the code

itself. A component
diagram consists of
components—such

as source code files,
binary code files,

executable files, or
dynamic-link libraries

(DLLs)—connected by
dependencies. Use a

component diagram to
partition a system into
cohesive components.

Use deployment
diagrams to show the

structure of the run-
time system. From a

deployment diagram,
you can understand

how the hardware and
software elements

that make up an
application will be

configured and
deployed. Deployment

diagrams consist of
nodes, components,

and the relationships
between them.
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Enterprise Edition only
Diagnosing and fixing semantic errors

As you create a model in Microsoft Visio 2000
Enterprise Edition, any relationships you have
defined that violate UML notation rules are
logged. In addition, Enterprise Edition identi-
fies any syntax errors that might be allowable
in UML notation but are likely to cause errors
in code generated in the selected language.

To diagnose and fix an error

1 Open the UML Model Diagram file that
represents your system.

2 In the Status window, click the Errors tab to
read a description of the error to diagnose
the problem.

3 Double-click an error to locate the icon or
shape that represents the UML element you
need to fix.

In the tree view, the selected element turns
gray. If the element is represented in a dia-
gram, the UML solution displays that dia-
gram and the shape has red error markings.

To turn semantic error checking off

• Choose UML > Options and click the UML
Add-on tab.

To locate and diagnose language-specific errors

• Choose UML > Code > Check.

The Code tab in the Status window identi-
fies target language-specific syntax errors
based on the language you have selected for
generating code.
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Enterprise Edition only
Creating reports from a UML model

At any point during the development process,
you can create, print, preview, and export a
report from a UML diagram to share informa-
tion with team members.

The UML solution offers preformatted reports
for static structure, activity, and deployment
diagrams.

To create a report from a UML diagram

1 Choose UML > Report.

2 In the UML Report dialog box, customize
the formatting options and data definitions
for each report using the Headers/Pagina-
tion tab and the Detail tab.

To preview a report before you print or export it

1 Choose UML > Report.

2 In the UML Report dialog box, click the
Preview button.

To export a report as a Rich Text Format

(RTF) file

1 Choose UML > Report.

2 In the UML Report dialog box, click Export.

3 In the Export To RTF dialog box, type a file
name and path and then click Save.
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Enterprise Edition only
Generating code skeletons from UML models

As you create UML model diagrams for a
system, you can get a head start on your devel-
opment efforts by generating code skeletons
into Visual Basic, C++, or Java for any diagram
in the model that contains class definitions.

When you generate code, you follow these gen-
eral steps:

1 Set language and project location, and then
set preferences for the parts of code to be
generated and code formatting.

2 Validate the UML model against the target
language to check for keywords and element
properties that might cause compilation
errors in the target language.

3 Select the desired classes and then generate
the code skeleton.

4 Open the resulting code skeleton files in the
target language using the development tool
of your choice.

Setting code generation
preferences
You set preferences for generated code using
the Code Generation Preferences dialog box.
The dialog box contains a tree view that
includes a view of global default preferences
for general element types in the model, and an
element-specific view of the current model.

When you select an option in the tree view, the
options in the right side of the Code Genera-
tion Preferences dialog box change based on
the current selection.

Default templates for
code formatting are
provided, and you can
edit these templates
or add new templates
to meet your needs.
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Enterprise Edition only
To set preferences for code generation

1 Open the UML system that includes the
class definition data for code generation,
and choose UML > Code > Preferences.

2 For Language, select the target language
from the list.

3 For Project Directory, type or browse to
specify the project directory for the gener-
ated code files.

4 To set default code formatting preferences,
under Options, expand the Global Default
Preferences folder.

Select a folder for an option to display its
preference settings.

Edit the settings for each option type and
then click OK when you are finished.

5 To set specific preferences that override
default settings for individual elements,
under Options, expand the Element Prefer-
ences folder.

Select the element for which you want to set
preferences that override the default set-
tings, and edit the settings for the element.

6 Click OK when you are finished.

Checking a UML model for
language-specific code errors
The UML solution can automatically check for
syntax and semantic errors specific to the
UML. However, some of the keywords and ele-
ment properties that are acceptable in the UML
might not be valid in the target language. You
can check for language-specific errors that will
prevent your generated code from compiling.

To check a UML model for language-specific

syntax errors

1 Open the UML system that includes the
class definition data for code generation,
and choose UML > Code > Check.

2 In the Status window, click the Code tab.

3 To locate an element associated with a code
error message, double-click the error mes-
sage on the Code tab.

The UML solution indicates the element by
selecting its icon in the tree view and, if a
view of the element exists, by displaying a
diagram and selecting its shape.

Generating code skeletons
When you generate the code, the following
types of files are created

• For Visual Basic .cls, .bas, and .frm files

• For C++ .cpp and .h files

• For Java .java files

You can open the resulting code skeleton files
in the target language using the development
tool of your choice.

To generate code skeletons from a UML model

1 Open the UML system that includes the
class definition data for code generation,
and choose UML > Code > Generate.

2 Type or browse to specify the project direc-
tory for the generated code files.

3 Select the target language.

4 Check the classes that you want to be
included in the generated code.

5 Click OK.

The UML solution
provides code
templates with
formatting for coding
conventions. You
have the option of
using the existing
templates, editing the
templates, or adding
new templates to
meet your specific
coding needs.
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Enterprise Edition only
Storing and retrieving models: working with Microsoft Repository

All of the components you need to store and
retrieve models in Microsoft Repository 2.0
are installed and registered when you install
Microsoft Visio 2000 Enterprise Edition.

When software components are stored in
Microsoft Repository as information models,
developers can access and use the components
regardless of which tool the components were
created in or on which platform they run.

The Microsoft Repository Type Information
Model supports the creation of UML informa-
tion models only for static structure data.
Therefore, only the static structure compo-
nents of models can be imported from or
exported to Microsoft Repository.

NOTE When you import a model, it appears in the
form of icons in the UML Navigator tree view.

The first time you export UML static structure data,
Enterprise Edition creates the UML information model in
Microsoft Repository that defines the objects UML
models can use. Through Microsoft Repository, you can
exchange UML models with any other visual modeling
program that also supports the UML information model.

Repository
Type Information

Model

ActiveX Interfaces

Repository Engine

Database

Object
Model

Information
Model

Visual Basic
Project

Information
Model

Database
Information

Model

UML
Model

UML
Model

UML
Information

Model

Visio
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UML
Support

Microsoft
Visual

Modeler

UML
Support

Rational
Rose

UML
Support

Other
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modeling
tool
UML

Support
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Enterprise Edition only
To import a model from Microsoft Repository

1 Choose File > New > Software > UML
Model Diagram.

2 Choose UML > Repository > Import. In the
Connect To MS Repository dialog box,
select the connection method.

Locate the Microsoft Repository database
that includes the model you want to import.

If necessary, type your user name and pass-
word, and then click OK to continue.

3 In the Repository Import dialog box, under
Models, select the name of the system model
you want to import, and then click OK.

The model is imported, and icons for its ele-
ments are added to the existing system in
the tree view.

To export data to Microsoft Repository

1 Open the UML system that includes the
static structure data you want to export.

2 Choose UML > Repository > Export to
create the new database.

In the Connect To MS Repository dialog
box, select the connection method and then
locate the model you want to export.

If necessary, type your user name and pass-
word, and then click OK to continue.

3 In the Repository Export dialog box, under
Models, select the name of the system
model you want to export, or type a new
model name, and then click OK.

If you export a model with the same name
as an existing model, you overwrite the
existing model.

NOTE When you choose the Export command,
the UML solution’s semantic error checking
automatically checks for errors that will cause
problems in the static structure data you export.
Errors are listed on the Errors tab in the Status
window.

When you export,
property data you
have added to the
UML elements is
exported along with
the elements
themselves.
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5

Business process design and
documentation

Microsoft® Visio® 2000 Professional Edition
and Enterprise Edition include a wide range of
tools for quickly and thoroughly designing and
documenting your business processes.

With Professional Edition or Enterprise
Edition, you can

• Use a variety of flowchart types, such as
cross-functional flowcharts, to analyze and
communicate information about how your
business organizations and processes relate.

• Create timelines to plan projects and
diagram processes, including tracking tasks,
milestones, dependencies, and resource
information.

• Create data flow diagrams using
Gane-Sarson notation to clarify how
data is generated and flows through your
business processes.

• Generate Web site maps to help you plan,
manage, and troubleshoot your Web site.

In this chapter

Using flowcharts to analyze your business..........................................................................................98

Creating a timeline for a project overview.........................................................................................102

Working with data flow model diagrams...........................................................................................103

Planning Web sites and troubleshooting links ..................................................................................106
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Using flowcharts to analyze your business

Using Microsoft Visio 2000 Professional
Edition or Enterprise Edition, you can diagram
complex business processes to make them easy
for others to understand. Flowcharts are visual
representations of a process. Managers often
create flowcharts to understand and communi-
cate how a process works and how it can be
improved.

Professional Edition and Enterprise Edition
provide a number of flowchart diagram types,
as shown in the following table.

Flowchart diagram types in Professional Edition and Enterprise Edition

Flowchart type Purpose

Audit Diagram Use to create auditing flowchart diagrams for accounting, financial
management, fiscal information tracking, money management, decision
flowcharts, and financial inventories.

Basic Flowchart Use for flowcharts, top-down drawings, information tracking drawings,
process planning drawings, and structure prediction diagrams.

Cause-And-Effect Diagram Use for drawings that illustrate problem-solving.

Cross-Functional
Flowchart

Use to create drawings that illustrate the relationships between process
and the organization.

Data Flow Diagram Use for process- or data-oriented models, data flowcharts, data process
diagrams, structured analysis diagrams, and information flow diagrams.

IDEF0 Diagram Use IDEF0 process charting models to create hierarchical diagrams for
model configuration management, needs and benefits analyses,
requirements definitions, and continuous improvement models.

SDL Diagram Use the Specification and Description Language (SDL) to create object-
oriented diagrams for communication and telecommunication systems and
networks.

TQM Diagram Create Total Quality Management (TQM) drawings for business process
re-engineering, total quality management, continuous improvement, and
quality solutions.

Work Flow Diagram Represent information flow, automation of business processes, business
process reengineering, accounting, management, and human resources
tasks in industry, business, and manufacturing.
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To draw a flowchart using the connector tool

1 Start Microsoft Visio 2000 Professional
Edition or Enterprise Edition. In the
Welcome To Microsoft Visio dialog box,
click OK.

2 Choose File > New > Flowchart > Basic
Flowchart.

3 Click the connector tool ( ) on the
Standard toolbar.

4 Drag a shape from the Basic Flowchart
Shapes stencil onto the drawing page.

5 Drag a second shape onto the drawing page.

The shapes connect.

6 Drag shapes to build the complete flow-
chart. Each new shape you drop connects to
the selected shape.

Working with large flowcharts
Professional Edition and Enterprise Edition
provide several useful methods for working
with multiple-page flowcharts. For example,
you can

• Use shape numbering to cross-reference
explanatory notes, or to indicate the
sequence of steps in a large business process.

• Use off-page reference shapes to navigate
pages in multiple-page flowcharts, or to link
to an existing page in your drawing.

To number shapes in your flowchart

1 With a flowchart open, choose Tools >
Macros > Visio Extras > Number Shapes.

2 On the General tab in the Number Shapes
dialog box, choose the options you want.

3 Click the Advanced tab and choose the
placement and numbering sequence
options you want, and then click OK.

To connect to a new or existing page in your

flowchart using the Off-Page Reference shape

1 From the Basic Flowchart Shapes stencil,
drag the Off-Page Reference shape onto the
drawing page.

2 In the Off-Page Reference dialog box, choose
the options you want, and then click OK.
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Creating horizontal or vertical
cross-functional flowcharts
In Professional Edition and Enterprise Edition,
you can create either horizontal or vertical
cross-functional flowcharts depending upon
which layout best conveys your information.

Cross-functional

flowchart

This cross-functional
flowchart uses

horizontal functional
bands to illustrate

how processes flow
through and affect

departments.
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To create a horizontal or vertical cross-

functional flowchart

1 Start Microsoft Visio 2000 Professional
Edition or Enterprise Edition. In the
Welcome To Microsoft Visio dialog box,
click OK.

2 Choose File > New > Flowchart >
Cross-Functional Flowchart to open the
Cross-Functional Flowchart solution.

3 Choose an orientation for the bands in your
flowchart, the number of bands (up to five),
and whether you want to add a title bar to
the top of the bands, and then click OK.

4 Click the title bar to select it and then type a
name for the process the drawing repre-
sents. Click each band label to select it and
then type a name for the band.

5 Drag a flowchart shape from the Basic
Flowchart Shapes stencil to the appropriate
location on a band or across bands to repre-
sent the first step in the process.

6 Click the connector tool ( ) on the
Standard toolbar. With the first shape still
selected, drag a second shape onto the
drawing page.

7 Drag shapes to build the complete flow-
chart. Each new shape you drop connects to
the selected shape.

Importing flowchart data from
other applications
You can use Professional Edition or Enterprise
Edition to automatically create a flowchart
from information in a text file or in Microsoft
Excel format. You can either import this infor-
mation from a program that supports
flowchart data export, or you can create a new
text file (.txt) or Excel file (.xls) using the
Import Flowchart Data Wizard, and then cre-
ate your flowchart from that data.

To import flowchart data

1 Choose Tools > Macros > Flowchart >
Import Flowchart Data Wizard.

2 Follow the instructions on the wizard
screens to

• Create a flowchart from imported data in
a text (.txt) or Excel (.xls) file.

• Create a new text file or Excel file
that you can use to create a
flowchart automatically.
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Creating a timeline for a project overview

If your job involves planning projects and
processes, you can use Microsoft Visio 2000
Professional Edition or Enterprise Edition dia-
grams to help you track project milestones,
task intervals, and overall project duration.

Using timeline diagrams, you can show tasks,
milestones, and resource information, such as
who is responsible for which tasks.

You can easily distribute your timeline to
co-workers or import it into another applica-
tion. For example, you could import it into
Microsoft PowerPoint® to use in a
presentation.

You can use timelines to communicate major project
milestones

To create a timeline

1 Start Microsoft Visio 2000 Professional Edi-
tion or Enterprise Edition. In the Welcome
To Microsoft Visio dialog box, click OK.

2 Choose File > New > Project Schedule >
Timeline.

3 From the Timeline Shapes stencil, drag a
Timeline shape onto the drawing page.

4 In the Configure Timeline dialog box, do
the following:

• Choose the timeline beginning and end
date, the time scale, and the date and time
scale formatting.

• To automatically update the dates on
your marker, milestone, and interval
shapes when you move them, check
Automatically Update Dates When
Markers Are Moved.

5 To add a right or left arrowhead to your
timeline, right-click the Timeline shape,
and then choose either Show Right Arrow-
head or Show Left Arrowhead.

To add a milestone

1 From the Timeline Shapes stencil, drag a
Milestone shape onto your timeline.

2 In the Configure Milestone dialog box,
choose the milestone date and the date for-
mat you want, and then click OK.

To add an interval

1 From the Timeline Shapes stencil, drag an
Interval shape onto your timeline.

2 In the Configure Interval dialog box, choose
the marker beginning date, end date, and
date format.

The Visio program positions the marker on
the timeline using the marker beginning
and end dates you chose.

To revise a timeline

1 Right-click the timeline, and then choose
Configure Timeline from the shortcut
menu.

2 In the Configure Timeline dialog box, revise
the timeline data, and then click OK.

You can easily add a
color scheme to your
diagram. Choose
Tools > Macros >
Visio Extras > Color
Schemes, and then
choose the color
scheme you want, or
create a new one.
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Working with data flow model diagrams

A data flow model diagram is a tool for func-
tional analysis that uses Gane-Sarson notation
to model the flow of information through a
system or program. For example, e-commerce
professionals can use Microsoft Visio 2000
Professional Edition or Enterprise Edition to
draw process and data flow model diagrams
that clarify how customers will navigate an
e-commerce site and how that site can make
purchasing quick, easy, secure, and profitable.

Use a top-down design strategy to create your data flow
model diagrams. Begin by creating the top-level
processes, then decompose each process into
subprocesses for more detail.

The Data Flow Model Diagram solution
includes the following features to facilitate
your creation of data flow diagrams:

• A stencil containing all the data flow shapes
necessary for modeling data flows using
Gane-Sarson notation

• The DFD Navigator that displays a tree
view of the entire data flow model, includ-
ing elements that have not been added to
any diagram

• The Status window, for automatic semantic
error checking

• Separate detail pages for each process you
decompose

• Automatic importing of data flows to
ensure equivalence of boundaries between
top-level and detail pages
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To create a data flow model diagram

1 Start Microsoft Visio 2000 Professional
Edition or Enterprise Edition. In the
Welcome To Microsoft Visio dialog box,
click OK.

2 Choose File > New > Software > Data Flow
Model Diagram.

3 Create the top-level detail page for the
diagram by dragging shapes from the
Gane-Sarson stencil onto the drawing page.

As you add the shapes to the page, icons
that represent the shapes appear in the DFD
Navigator.

4 Identify the elements in the model by
double-clicking the shapes and adding text.

5 Connect the shapes to each other using the
Data Flow connector shape on the Gane-
Sarson stencil.

6 Add a detail page for each process. Your
detail pages can include subprocesses that
require additional detail pages.

7 Continue adding detail pages for each pro-
cess until you have described the entire data
flow model system in sufficient detail.

Using the DFD Navigator
The DFD Navigator provides a hierarchical
tree view of the data flow model you create.
This tree view displays all the elements you
have included in your data flow model,
whether or not you have included the element
on a data flow diagram page.

You can add shapes to a diagram by dragging
icons onto the drawing page from the tree view
or from the stencil. When you drag a shape
from the stencil onto the drawing page, the
shape is automatically added to the tree view as
an icon. However, when you add an element to
the tree view, it is not automatically added to
the diagram.

Similarly, if you delete a shape from a diagram,
the corresponding icon is not automatically
deleted from the tree view.
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Automatic error checking
When you use the semantic error checking
option, as you add elements to the data flow
diagram, any elements with semantic or syn-
tactical errors appear red, and the descriptions
of these errors or warnings are displayed on the
Errors tab in the Status window.

To set options for a data flow model, including

turning the semantic error checking on or off

• Choose DFD > Options, check or select the
options you want, and then click OK.

Adding detail pages and
subprocesses
Detail pages represent the different levels in the
process your data flow model diagram repre-
sents. Once you’ve created the top level
processes of your data flow model, you can use
detail pages and subprocesses to decompose
each process to the level of detail you want.

To add a detail page

• Right-click a process shape on the page, and
then choose New Detail Page.

To navigate between levels of a data flow model

diagram

• Select a process shape, and then choose
DFD > Go To Detail Page.

Importing data flows to ensure
equivalence
When you add a detail page, any shapes
required to ensure equivalence at boundaries
to the detail page are automatically added.
Equivalence at boundaries requires that the
data flow elements affecting a process on a top-
level page also be included on the detail page
for that process, to balance the model.

If you then add one or more data flows to a
process on a higher level page, and that process
already has a detail page, you can import the
data flow(s) onto the detail page to ensure
equivalence at boundaries for that detail page.

To import a data flow to balance a detail page

1 From the detail page, choose DFD > Import
Data Flow.

2 Check each data flow you want to import,
and then click OK.
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Planning Web sites and troubleshooting links

Using the Internet Diagram solution in
Microsoft Visio 2000 Professional Edition or
Enterprise Edition, you can

• Create high-level, conceptual diagrams of
new Web sites to visualize the sites’ pur-
pose, content, and overall organization.

• Generate maps of existing Web sites to
analyze the sites’ organization and classify
their content.

• Troubleshoot broken links and the errors
that caused them using site maps and
log files.

Planning a new Web site

Begin in the Conceptual Web Site template by dragging
a Main Page shape onto the drawing page, and then
work your way down from there, dragging more shapes
onto the drawing page and connecting them as you go
to create navigation patterns.

To create a diagram of a new Web site

1 Start Microsoft Visio 2000 Professional
Edition or Enterprise Edition. In the
Welcome To Microsoft Visio dialog box,
click OK.

2 In the Choose Drawing Type dialog box,
click Internet Diagram.

3 In the Drawing Type box, double-click
Conceptual Web Site.

4 Click the connector tool ( ) on the
Standard toolbar, and then drag the Main
Page shape onto the drawing page from the
Conceptual Web Site Shapes stencil.

5 With the Main Page shape selected, drag
another shape onto the drawing page. The
shapes are automatically connected.

To annotate a shape with callouts

1 Drag a callout shape from the Callouts sten-
cil onto the drawing page.

2 Connect the shapes by dragging the end-
point ( ) of the callout shape to a connec-
tion point ( ) on the shape it is annotating.

The Internet Diagram
solution includes the
Conceptual Web Site
and Web Site Map
templates.
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Mapping an existing site
When you generate a map for your site using
the Internet Diagram solution, it creates a
shape for each link in your Web site that
includes information about the link, such as
the location and link type. The solution also
adds hyperlinks to shapes so you can jump
directly from the shape to the link the shape
represents.

The home page shape is positioned at the top of your
site map. The shapes connected to it represent the links
on the home page. The same model holds throughout
the map.

You can also specify what you want to include
in your site map—the maximum number of
levels, the maximum number of links, and the
kinds of links (for example, HTML pages, ASP
pages, image files, and so on).

To map an entire Web site

1 Choose File > New > Internet Diagram >
Web Site Map.

2 In the Generate Site Map dialog box, do one
of the following:

• If the site is on an HTTP server, in the
Address box type the address for the
Web site you want to document.

• If the site is on a network server or local
hard disk, click Browse, navigate to the
file you want at the root of your site map,
and then click Open.

3 Under Include, select Entire Web Site.

4 Enter the maximum number of levels you
want to search or accept the default. Enter
the maximum number of links you want to
search or accept the default. Click Options,
and on the Links tab, choose the type of
links you want to include in your site map.

5 Click OK to begin generating the site map.

The Internet Diagram solution examines
the HTML code for a page and searches for
attributes, such as HREF, USEMAP, and
SRC. It examines each attribute, and then
displays the links that match your specifica-
tions on the Links tab.

If the solution finds broken links on your
site, it writes that information to a log file.
Click OK to view the log file immediately,
or click Cancel to return to your site map.
You can view the log file at a later time by
choosing Web > View Log File.

NOTE When you’re mapping a site, it’s a good
idea to limit the search to improve performance
and clarity. For example, you might not want all
the links to images to appear in your site map.
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Using your site map to
troubleshoot your Web site
You can use your site map as a diagnostic tool
to locate and repair broken links on your
Web site.

When you use the Web Site Map template to
generate your site map, any errors it encoun-
ters when browsing for a link (for example,
Failed To Load) are written to a log file, and
your diagram displays a shape with an X
through it to indicate the link is broken.

After you repair the link on your Web site, you
can either turn off the error marking for a
shape or regenerate a portion of the site map
for all the links on a specific page.

Your Web site and site map are not dynami-
cally linked, so fixing the broken links on your
Web site does not update your site map and
vice versa. You must fix broken links on your
Web site and regenerate your site map
separately.

To remove error marking from a shape

1 Right-click the shape, and then choose
Properties from the shortcut menu.

2 In the Error box, choose None, and then
click OK.

To regenerate a part of your site map

1 Right-click the shape that represents the
HTML or ASP page whose links you want to
map again, and then choose Collapse
[Address].

2 Right-click the shape again, and then
choose Expand [Address] to regenerate that
portion of the site map.
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