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System i Access for Windows - Lab Worksheet
This worksheet contains names and addresses that you will need to complete the lab. Substitute the values
containing "xx" with your team number.  For example, caxx would be ca01 for Team 1.  Be sure to include a
leading zero if your team number is less than 10.

caxxpwdWindows Password  PC  
caxxWindows User Name  PC  
On your tent cardTeam NumberPC  
CAxxLIBTeam LibraryiSeries

\\<system name>\qibmInstall and Service
directoryiSeries

<provided by instructor>i5/OS NetServer Name  iSeries  
<provided by instructor>System (Server) Name  iSeries  
caxxpwdPassword  iSeries  
caxx   <on tent card>User ID  iSeries  
Value  Variable  Environment  
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Introduction
IBM's Windows product for PC to IBM System iTM client/server computing applications is System i Access for
Windows. V5R4 and V6R1 System i Access for Windows is designed for Windows 2000, XP Professional,
Windows Server 2003, Vista, and later Microsoft operating systems to offer them TCP/IP connectivity to N +
or - two releases.  This lab will introduce you to some of the advanced functions and features of this product.  It
is strongly recommended that you complete the lab:  “System i Access for Windows - Basic” or have a working
knowledge of System i Access for Windows before doing this lab.

Your lab administrators have prepared a worksheet with various system names and values that you will need to
complete the lab.  See "System i Access - Lab Worksheet" on page 2 of this document.  The instructors will
give you the values for each variable on the worksheet.  You will need the values on this worksheet throughout
the lab, so keep it handy! 

Please ask questions if you run into problems or need clarification at any time during the lab.

Good luck with the exercises!  

The exercises in this lab were originally developed by the IBM International Technical Support
Organization in Rochester, MN.  
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Lab 1. Configuring Secure Sockets Layer
System i Access for Windows is the first product in the the System i Access product line to implement Secure
Sockets Layer (SSL) as a means to encrypt data over connections to the IBM System iTM products.  For V5R3
and earlier releases, you needed to install a separate Client Encryption component on your PC.  Starting in
V5R4, the Client Encryption component is included with System i Access for Windows and is automatically a
part of the installable components.  In order to configure SSL, you must acquire a system certificate on the
iSeries.  Next, client PC applications must be enabled to use SSL.    System i Access for Windows using SSL
can then encrypt all information sent between System i Access applications and the iSeries.  Furthermore, it
offers the flexibility to choose what is encrypted.  For example, you may wish to encrypt data being transmitted
via Data Transfer, but find it unnecessary to encrypt data being sent to your PC printer via PC5250 printer
emulation.  

Task 1 walks you through acquiring a system certificate from the iSeries.  Task 2 gives a general overview of
using SSL with System i Access for Windows.  Later lab exercises show you how to enable SSL for specific
applications.  

Downloading a Certificate Authority
A certificate authority is a digital key required to communicate and encrypt data between your PC and the
iSeries.  Before adding the certificate to the default System i Access for Windows Key database, you must
download or copy a CA  (Certificate Authority) to the PC, or into a shared directory available for all PCs to be
enabled for SSL. The second method will avoid having to repeat the process on each PC.  A certificate can be
downloaded to the PC using one of two methods.  The first method involves using a function of System i
Navigator to obtain a certificate. The second method requires the use of the Digital Certificate Manager (DCM)
through a web browser.  In this next task we will use the first method to download a certificate since it is much
simpler.  

Task 1: Using System i Navigator to Download a CA to the PC
A new function is available through System i Navigator to simplify downloading the CA to the PC.  To
download a CA to your PC using System i Navigator, follow these steps:

1. Locate the System i Navigator icon on your desktop and double click on it.  System i Navigator should
start.  If prompted to create a new connection, create one using the iSeries system name on your
worksheet.  Enter the system name, click Next.  Select the default to Use default user ID, prompt as
needed and type in the user name from your worksheet.

2. On the System i Navigator window, under My Connections, find your system (the iSeries system name on
your worksheet).  Highlight this system by single-clicking on it.  Next, select File->Properties from the
File menu to see the properties for this system.  If you cannot find your system in the list, select My
Connections from the environment list and then File->Add connection from the menu.  Enter your
server name, click Next.  Use the default option to Use default user ID, prompt as needed and type in
the user name from your worksheet.
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3. Select the Secure Sockets tab on the properties panel.  Click the Download button to download the CA
to the PC and place it in the IBM Key Management Database.  Sign on to the iSeries using the user id and
password values from your worksheet, if necessary.  When prompted for a key database password, enter
the default password ca400 then click OK.  The final message should indicate that the CA was
downloaded successfully.

4. Click the Verify SSL Connection button to verify that your PC can successfully communicate with the
iSeries using SSL.  A verification dialog will show whether your PC can connect to all the iSeries host
servers using SSL or not.  It is okay if the Management Central server does not verify, but if any other
servers do not verify successfully, please raise your hand and one of the Lab instructors will assist you.  If
verification is successful your PC is now setup to use SSL to communicate with this iSeries.

5. Click OK to close the connection verification dialog.
6. Do not close the properties dialog for this system.  You will start here in the next task.

Task 2: Using SSL with System i Access for Windows
SSL can be implemented on all System i Access for Windows functions.  System i Access for Windows offers a
good granularity to enable SSL. It can be set for the following functions: 

w System i Navigator   

w PC5250 emulation   

w Data Transfer   

w ODBC 

w Custom Applications using System i Access APIs.

You can enable SSL for System i Navigator, PC5250 emulation, Data Transfer and ODBC at connection,
emulation session, transfer request and data source level respectively. Enabling SSL for PC5250 emulation,
Data Transfer and ODBC functions is made through a three option choice:   

w Do not use SSL   

w Use SSL   

w Use System i Navigator setting 

The default setting is the third option even if the client encryption for SSL is not installed on your PC. The
advantage of this default setting is to enable/disable all functions for a system at one time when SSL is
enabled/disabled from System i Navigator. If you only need a secure connection for few specific functions you
will implement the second option (Use SSL) for the concerned functions.  This lab will only discuss enabling
SSL for PC5250 emulation and Data Transfer.
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To enable SSL by default for all System i Access applications do the following:
1. If you completed Task 1 and System i Navigator is still open you may skip to step 5, otherwise
continue with step 2.
2. Start System i Navigator by double clicking on the System i Navigator icon on your desktop.
3. Select your iSeries server and sign on if necessary.
4. Select File->Properties from the menu.  This will display the properties for your iSeries server.  Click
the Secure Sockets tab on the properties panel.
5. Find the checkbox labeled Use Secure Sockets Layer(SSL) for connection.  Check this box to
activate SSL for System i Navigator and to turn on SSL for all System i Access for Windows applications
for this system by default.  Since later portions of the lab require that SSL be turned off by default, select
Cancel on the bottom of the properties panel.
6. Close System i Navigator by selecting File->Close from the menu.
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Lab 2. PC5250
PC5250 is the 5250 terminal emulation package shipped with System i Access for Windows.  There are a
number of customizations you can make to PC5250 to setup the product to match your personal preferences.
You can customize the settings for the display, keyboard, or toolbar; or work with Hotspots. During this lab, we
will work with features such as customizing the Toolbar, working with Hotspots, generic workstation IDs, and
using PC5250 over SSL.  The last task shows you how to create a PC5250 Script that runs a data transfer and
loads a downloaded file into Microsoft Excel.

Task 1: Customizing the Toolbar
You can customize the Toolbar to add icons that execute system-supplied functions and keystrokes; execute PC
applications, macros, or scripts; delete icons; edit the appearance of icons; create, save, and load Toolbars; or
reset the Toolbar to the default settings. To accomplish this: 

1. Right click on your Windows desktop and select New->iSeries Desktop Icon.  From the Application
drop list select PC5250 Emulator and select Next >. Enter your iSeries system name (found on your lab
worksheet)  if it is not already in the iSeries System drop list, and select Next >.  Leave the icon name
as-is and select Next > and then Finish.  This will place a new PC5250 Emulator icon on your desktop.

2. Double click on this new icon to start the PC5250 emulator.  Select OK on the Configure PC5250 panel.
The emulator will connect to the indicated iSeries.

3. Place the cursor on the Toolbar of the emulation window, and right click the mouse once. A pop-up panel
will appear.   

4. Select Toolbar Style. From here you can set the start-up characteristics of your Toolbar. When finished,
click OK.   

5. To create a new icon, right click on the Toolbar again and select Create Item. When the pop-up panel
appears, select the tab that represents the category of function you wish to add to the Toolbar. For this
exercise, select the Application tab.   

6. Type in the Application file name or use the List button to locate the application you desire to run. For
example, try specifying (or locating) calc.exe (Windows calculator).  Notice that Application parameters
may be specified here.  Calc.exe does not require any parameters, so leave this blank.     

7. To customize the icon label or graphic, select the Customize button. When finished, click OK.   
8. You can add icons for any of the other categories of functions by selecting the appropriate tab as

discussed in step 3. To save your customized Toolbar, right click on the Toolbar and select Save. 

Task 2: Working with Hotspots
Hotspots help you invoke certain functions by using mouse click (Point and Select) instead of using the
keyboard. You can choose to setup iSeries function keys, activate web browser support, or execute
macros/scripts. You can also set up Point and Select commands. 
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First let us examine one for these functions, activating web browser support. 
1. To run the Hotspot Setup, select the Edit pulldown menu from the emulation window, then select

Preferences->Hotspots. If the PFnn, FPnn, Fnn, or nn checkboxes are selected, deselect them for now.
We will look at these functions later.   

2. Select the Execute URL checkbox. Selecting this checkbox will invoke your default web browser under
Windows. (If you do not have a default web browser, you can still invoke a web browser by assigning its
paths name by selecting the Edit pulldown menu, then selecting Preferences->Web Browser...).   

3. You can also setup 3D buttons that highlight text strings to make them easier to locate. You only click
once on 3D hotspots while you need to double click non-3D hotspots. To enable this function, select the
3D checkbox.   

4. Select OK to save this setting, then sign-on to your existing session   
5. From the OS/400 command line, type GO WEBSITES. You should now see an iSeries menu with several

websites listed and highlighted in 3D. Use you mouse to click on one of the websites. This will cause
your default web browser to execute and attach to the listed URL. 

Now let us examine the set up of Point and Select commands. You can enable Enter at cursor position or Enter
string at cursor position functions with hotspots.   

6. Select the Edit pulldown menu from the emulation window, then select Preferences->Hotspots.
Deselect the Execute URL and 3D checkboxes. Then select the PFnn. FPnn, Fnn, and the 3D
checkboxes. Do not select the nn checkbox at this time. Click OK. Your function keys at the bottom of
the screen should now be highlighted in 3D. Try out these 3D function key hotspots by clicking on them.   
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7. Now let us enable the nn as menu items (not as iSeries function keys). You must be careful when
enabling nn as a hotspot because the iSeries will always interpret the values of 1 through 24 as iSeries
function keys first. For example, when you enable nn as a function key hotspot, you would normally
expect the hotspots surrounding the numbers for the menu items to relate to those menu items. But if you
click on the number 3 in front of menu item 3, the iSeries would interpret this as F3 key and exit the
display. To use nn as a menu item, you would not check nn as a hotspot but instead check the Enter
string at cursor position checkbox and click OK.   

8. Type GO MAIN (or other iSeries menu names you wish). Ensure your 5250 cursor is on the command
line, then double click on one of the menu items numbers. The string (number) is then read to the
command line at the cursor position and an ENTER keystroke is automatically appended to take you to
your intended function. Hence, the name Enter string at cursor position.

Task 3: Enabling SSL for PC5250 Sessions
To enable SSL for PC5250 emulation sessions, do the following: 

1. From the menu bar of the Emulation window, click Communication -> Configure...   
2. On the Configure PC5250 window click on the Properties button. 
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From the Connection panel, notice the status given in Security. Select the Use Secured Sockets Layer
(SSL) option.

3. On the Configure PC5250 panel, notice that the Port number changed from 23 to 992. The port used for
secured Telnet session is 992. If you use 23 and you enabled SSL, then the connection will fail.  Click
OK to connect to the iSeries over a secure connection using SSL.  The connection is established using
SSL. Notice the padlock with the encryption level (in this case, 128-bit) and the text in the status bar. 
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Task 4: Using Generic TCP/IP Workstation IDs
Generic Workstation ID support was greatly simplified starting in V5R1.  In previous releases of PC5250 you
were required to use special symbols to generate a generic workstation ID.  For example, entering
&USERN%= as a workstation ID produced a unique ID based on your user name, session type and session
number.  In V5R1, you no longer need to enter these codes in order to create a generic workstation ID.

The following steps show you how to configure generic workstation IDs with PC5250.

1. Create a new workstation profile by right clicking on your Windows desktop.  Select New->iSeries
Desktop icon.

2. Choose PC5250 Emulator as the application to start.  Click ‘Next’.

3. Enter the system name (from the lab worksheet).  Click ‘Next’.

4. Enter ‘Workstation ID Test’ as the icon text. Click ‘Next’.  Click ‘Finish’.  You should see a new
iSeries session icon appear on your desktop, named ‘Workstation ID Test’. Double click on your new
icon to open it.

5. Notice the options for Workstation IDs on the ‘Configure PC5250’ panel.  Select to ‘Use Windows
user name’ option.  Also select the ‘Add prefix to indicate printer or display’ and ‘Avoid
duplicate names on this workstation’ options.  Then press OK to close Configure PC5250.

6. Click ‘File->Save’ to save the workstation profile.  Then, choose ‘File->Exit’ to close the emulation
session.

7. Double click on your new icon again to open it.  After it has opened, double click on it again to open
another emulation session.  Notice the unique value in the Display field on the top right hand corner
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of each of the emulator signon screens.  They should contain an ‘S’ followed by your username
‘CAxx’,  followed by a unique letter (‘A’ for the first and ‘B’ for the second), all together SCAxxA,
and SCAxxB (where “xx” is your team number).

8. Close the PC5250 emulation sessions and proceed to the next task.

Task 5: Writing a PC5250 script
PC5250 contains a powerful scripting and macro language for automating common tasks.  The scripting
language supported by PC5250 is VBScript.  VBScript is a language developed by Microsoft for both PC and
web applications.  This task shows you how to write a very simple and useful script using PC5250 and other
ActiveX automation objects that are installed on your system.  ActiveX automation objects are programming
interfaces into PC applications.  These programming interfaces allow you to run various parts of applications
from “remote” with a program or script.  In this task you will use automation objects for Microsoft Excel and
automation objects for System i Access Data Transfer to download a file from the iSeries and then load that file
into Excel with the click of a button.  It will also use functions of PC5250 to read information from the
emulation screen for use in the script.

Lets get started!

1. Start an emulation session by double clicking on one of PC5250 Emulation session icons you created in
the previous tasks.  Be certain it connects to the iSeries.  If you do not have an available PC5250 session
create a new one by following steps one and two of Task 1.

2. Sign on to the iSeries with the user name and password values from your worksheet.  Hit ‘Enter’ until
the top of your screen reads ‘i5/OS Main Menu’. 

3. From the “Edit” menu, select ‘Preferences->Macro/Script...”. 

4. Click the “Customize...” button to start the script editor.

5. From the ‘File’ menu, select ‘New->VBScript’.

6. For your reference, the next page has the script programming statements.  Instead of entering the
statements in the  Script Statements editor, you can copy/paste the statements which we have prepared
for you.  To do this, load the PC file c:\download.mac into notepad by selecting ‘Start->Run’ from the
Start menu and type 'notepad c:\download.mac' as the program to open.  In notepad, select
‘Edit->Select All’, then ‘Edit->Copy’ from the menu.  In the PC5250 Customize Macro/Script screen,
select ‘Edit->Paste’ from the menu.  Code lines prefixed with a single quote character ( ‘ ) are
comments.  They describe what each line of code does.  Actual program statements (shown on the next
page) are in bold type.  
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'This constant is from cwbxvbs.inc.  This file is installed as part of the toolkit.

Const typeExcel5 = 15

'Call the download subroutine

subDownload_

Sub subDownload_()

  'Use the Personal Communications Host Access Class Library (ECL) objects to set the

  'current connection.  Use the PC5250 defined value in ThisSessionName for this session

  autECLSession.SetConnectionByName(ThisSessionName)

  'Get the system name from row 2, column 70 of our screen.  We must be on a screen

  'that has our system name at this screen position for the script to work.

  sysName = autECLSession.autECLPS.GetText(2, 70, 10)

  'Trim the whitespace from the system name or the download will fail

  sysName = Trim(sysName)

  'Get the name of the library/file to download (ex. QIWS/QCUSTCDT)

  fileName = InputBox("Enter the (library/file) to download:")

  'Get the name of the Excel file to download to (ex. c:\test.xls)

  pcFile = InputBox("Enter the name of the Excel file to download to:")

  'Create a new ActiveX data transfer object.  See the System i Access toolkit

  'documentation for a full list of System i Access objects that we can use.

  Set xfer = CreateObject("cwbx.DatabaseTransfer")

  'Download using system name, iSeries file name, PC file name to an Excel 5 file.

  xfer.Download sysName, fileName, pcFile, typeExcel5 

  'Create a Microsoft Excel Application ActiveX object   

  Set excel = CreateObject("Excel.Application")

  ' Make Excel visible through the Application object.  Otherwise, it stays hidden.

  excel.Application.Visible = True

  'Open the file we downloaded with Excel

  excel.Workbooks.Open pcFile

End Sub
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7. After you have copied the script code into the Script Statement editor, select ‘File->Save’ from the
File menu.  Type download.mac as the file name for the script.  In the Description box type
Download to Excel as the description.

8. Click ‘Save’ to save your script.

9. Select ‘File->Exit’ to close the Customize Macro/Script panel.  On Macro/Script Setup, press OK.
You are now ready to try out your script!

10. Make sure you are still on the OS/400 Main Menu screen in your PC5250 session.  Select
‘Actions->Start Playing Macro/Script’ from the Actions menu.  Select download as the script to
run and click ‘OK’.

11. If you receive errors while running your script, use the script editor to fix them.  If you need
assistance please raise your hand.

12. Enter QIWS/QCUSTCDT as the library/file to download.  Click ‘OK’.

13. Enter c:\download.xls as the Excel file to download to. Click ‘OK’.

14. Provided everything worked correctly, you should see Excel start and load your new file.

15. Exit Excel and sign off and close your emulation session.

This task was just a simple example of how easy it is to write a powerful script using PC5250.  Additional
information on scripting with VBScript in PC5250 can be found in the following locations:

PC5250 and ECL specific information can be obtained by searching the PC5250 online help using the
keyword VBScripting.

VBScript documentation can be found at the Microsoft Developer Network website at the following
URL:  http://msdn.microsoft.com/scripting/

System i Access ActiveX automation object information can be obtained by installing the Programmer’s
Toolkit (which is an installable component of System i Access for Windows) and also by accessing the
Tookit web page at the following URL: 
http://www.ibm.com/systems/i/software/access/windows/toolkit/
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Lab 3. Data Transfer
The Data Transfer application provides a mechanism to transfer data to and from the iSeries.  It uses the iSeries
SQL Database server to access source and data (SQL tables) physical files on the iSeries.  This lab shows you
some of the new features of Data Transfer and takes you through the process of building a simple query to
transfer specific data from an iSeries file.  The final task in this exercise shows you how to upload data to the
iSeries using the new upload add-in for Microsoft Excel.

Task 1: Creating a Custom Download Query Request
One of the most powerful features of Data Transfer is its capability to download specific data by building
custom SQL-like queries.  This task takes you through the process of building a custom query.

Task: From the customer database (QIWS/QCUSTCDT), you will display the customer number, name, and
address of all customers that have a balance greater than zero.  The data should also be ordered in decending
order by balance due.  

1. From your Windows desktop, open the System i Access for Windows folder and double click on the Data
Transfer From iSeries icon.

2. Enter the name of your iSeries system in the System name field (or select it) and enter
QIWS/QCUSTCDT (which is sample customer database file) into the iSeries File name field.  Make
certain your PC Output device is set to Display so that you can easily view the results of your download.

3. Click on the Data Options... button to display the Change Data Options panel.  Click Details... to
display the Receive Request Details panel.  The various tabs on this panel simplify the process of
building a custom query.

4. The Select tab allows you to choose the fields that you want to download from the iSeries.  Double click
on the fields to add them to the list of fields that will be transferred from the iSeries.  The fields you
should add are:  CUSNUM, LSTNAM, INIT, STREET, CITY, STATE, ZIPCOD, and BALDUE.

5. The Where tab allows you to place conditions on the data that you transfer from your iSeries system.
Select the Where tab and double click on BALDUE to add it to the condition.  Next, double click on  “>”
in the Test: list.  Enter 0 into the compare dialog and click OK.  This indicates that only records with a
balance due greater than zero should be transferred.

6. The Order By tab allows you to sort your data by specific fields.  Select the Order By tab and double
click on BALDUE from the field list to add it to the sort list.  Next, double click on “DESC” from the
Others list to indicate that the records should be sorted by balance due in descending order.

7. Click on OK to return to the Change Data Options panel.  Notice how the various statements are
generated for you.  Click on OK to return to the main Data Transfer window.  Your query should now be
ready.  Click on Transfer Data from iSeries to display the results of your download.
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8. Save your transfer request with the File menu using File->Save.  A dialog will display, asking you the
location and name of file to save as.  Enter a file name such as CUSTOM and specify a location on the C:
drive and click on Save.  Exit Data Transfer.

Task 2: Auto-Run Data Transfer
System i Access for Windows now allows you the ability to run Data Transfer automatically. This option
automatically runs a DTF or DTT transfer request when placed in the startup folder, double clicked on the
Desktop, from Windows Explorer, or if it is run directly using the Start or CWBTF from the command prompt.
When this option is selected, the transfer interface will display and the transfer request will automatically run.
To enable this option: 

1. From your Windows desktop, open the System i Access for Windows folder and double click on the Data
Transfer From iSeries icon.

2. Select the File menu and open the transfer request you saved in Task 1.  It should be listed on the menu
as one of the most recently used files.

3. Select File -> Properties. This will bring up the Properties panel. Click on the Startup tab and select the
Run transfer request automatically checkbox.   This will enable the transfer request to run immediately
after it is opened.  To have Data Transfer automatically close after the transfer request has completed
select Close on completion.  Select OK on the Properties panel.

4. Select File->Save As...  On the Save in: drop list on top of the Save As dialog select Desktop.  Click
Save to save your transfer request to the desktop.  After saving the request you should see a new Data
Transfer icon appear on your desktop with the same name as your transfer request.  Exit the Data Transfer
application.

5. Double click on this new icon to open and automatically run your transfer request.  Click OK on the
completion message dialog and then close the Data Transfer output window.

Note: To have a true auto-run request, you should also uncheck the “Display transfer completion message”
on the Display page of File->Properties.

Task 3: HTML Template Support
With System i Access for Windows, you can transfer an iSeries database table into a HTML template file. This
means you can dynamically update a table in a web page while leaving the rest of the page intact. To do so, you
need an existing HTML file with an embedded template tag. When the transfer is run, the template file is used
as a base for the new HTML file. The data received from the iSeries will be formatted and inserted in place of
the embedded template tag. Only the first matching tag found in the HTML document will be replaced. 

In this task, you will use the following files which are in the C:\ directory on your PC. 
w Template.htm   

w IBM logo.gif   

w picture.jpg 
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The figure below shows the html source of the template file. 

1. From your Windows desktop, open the System i Access for Windows icon and double click on Data
Transfer from iSeries.   

2. If you have completed the SSL lab, you may wish to use SSL in this exercise. In the Data Transfer from
iSeries window, open the Properties. Click on the Connection tab, select Use Secured Sockets Layer,
then click OK.  Data being transferred from the iSeries will now be encrypted.

3. Back in the Data transfer window, select the iSeries system from the drop-down list. Enter
QIWS/QCUSTCDT in the iSeries File name field.

4. Select Hyper Text Markup Language (HTML) in the PC Output Device field. Enter c:\customer.htm
in the PC File name field.   

5. Click on the Details Button. The HTML Details window appears.   
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6. Click on the Template tab. Select the Use HTML Template File option.   
7. Enter c:\template.htm in the Template file field. For the Embedded template tag field, if this field is

blank, enter the following:  <!-- TABLE1 -->  (note that there is one blank space before and after
"TABLE1").    Click OK. 

8. You are back to the Data Transfer from iSeries window. Click the Transfer data from iSeries button to
complete the transfer request.   

9. View the new html file (c:\customer.htm) using a web browser.    

Task 4: Uploading data with the Excel Add-in
In V5R1 of System i Access for Windows, the Data Transfer Add-In for Excel can be used to upload data to the
iSeries server.  In previous releases of System i Access for Windows (Client Access Express), only the
download function was available.  This task takes you through the process of uploading spreadsheet data to a
new iSeries table using this new function.

1. On your Windows desktop, click ‘Start->Programs->Microsoft Excel’ to start Microsoft Excel.

2. Select ‘File->Open’ from the file menu.  Open the file c:\upload.xls.

3. Highlight the entire range of data cells, including the column headings, by clicking on Name and
selecting down to 500 under the Balance column.

4. Select ‘Data->Transfer data to iSeries’ .  You’ll see the following panel.
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5. Since your data has column headings, select ‘First row is column headings(s)’.  Notice the starting and
ending cell positions contain the starting and ending cell positions of the range you highlighted.

6. Choose ‘Create new’ to create a new transfer request.

7. Click ‘OK’ to create a new upload request.

8. Review the Welcome panel and click ‘Next’.  Since we do not have a file on the iSeries to send our data
to, select ‘Create new file and member based on spreadsheet’.  Click ‘Next’.

9. On the File Description File page, enter ‘c:\upload.FDF’ as the File Description File to create.  Click
‘Next’.  Review the resulting message box and click ‘OK’.

10. Click the ‘Start Scan’ button on the Scan Spreadsheet page to scan the data in your spreadsheet.  Click
‘Next’ when the scan finishes.

11. Click ‘Next’ on the Contents of Spreadsheet page.  Notice that the Add-in found the correct column
names and column types.

12. Choose your iSeries on the System Name page.  Click ‘Next’.

13. Click ‘Next’ on the Customize Data Transfer panel.

14. Enter CAxxLIB/UPLOAD (where xx is your team number) as the iSeries Library and File.  Click
‘Next’.  Enter Excel Upload as the File Description Text on the following page.  Click ‘Next’.

15. Click ‘Next’ on the Confirm Create Options panel.

16. Click ‘Finish’ on the Save Request to file panel.

17. If you do not receive any error messages your data has been successfully uploaded to the iSeries!
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Lab 4. ODBC
Object Database Connectivity (ODBC) is an industry standard technology used to provide a common interface into
many different types of databases from a PC.  ODBC drivers are required to access these different databases.  For
example, there are ODBC drivers available to for Microsoft Excel files, Microsoft Access databases, Comma Delimited
files, Microsoft SQL server, Oracle, and most importantly, a driver to access the database on the iSeries.  Starting with
V5R1, System i Access for Windows had an ODBC driver that is ODBC version 3.5 compliant.  This means that it
supports many of the latest ODBC features available.  A PC may have multiple ODBC drivers.  These drivers are
maintained by an ODBC Driver Manager.  The driver manager keeps track of all the drivers on the system.  It also
works as a “proxy”.  Applications communicate with the driver manager and the driver manager communicates with
the appropriate driver.

Many “out-of-the-box” applications, such as Microsoft Access and Lotus Approach, allow you to use ODBC to
connect to remote databases, such as DB2.  In the following tasks you’ll see how easy it is to access data on the iSeries
with ODBC.

Task 1: Creating an ODBC DSN
To use ODBC with many common applications, you must create a Data Source Name or DSN.  A DSN is simply a
stored set of configuration options.  A DSN may contain, for example, the ODBC driver name, the system name to
connect to, the user to connect as, performance settings, and other options.  To create a DSN follow the following
steps:

1. From your Windows desktop, open the System i Access for Windows folder and double click on the ODBC
Administration icon.

2. Select the System DSN tab.  A system DSN is one that may be used by all users on the system.  Click the
‘Add...’ button to begin creating a new System DSN.

3. Select Client Access ODBC Driver from the list and click ‘Finish’.
4. You should see the System i Access for Windows ODBC Setup panel.  This panel allows you to configure

iSeries specific settings for your database connection.
5. On the General tab, enter ‘iSeries Database Connection’ as your Data source name.  You may change the

description if you’d like.
6. Select or type in your system name from the System dropdown.
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7. Press the ‘Connection Options...’ button.  Set the Default user ID option to ‘Use Windows user name’.  This
will tell the ODBC driver to use your Windows user name and password when connecting to the iSeries.

8. Click ‘OK’ to return to System i Access for Windows ODBC Setup. 
9. Select the Server tab.  Enter your library (CAxxLIB, where xx is your team number) In the Library list entry

field.  This will allow you to view tables in your team library.
10. Review the rest of the ODBC configuration options.  Please do not change them.  You’ll be using this DSN in

the next lab.
11. Click ‘OK’ to save your DSN.  You should see your DSN, ‘iSeries Database Connection’ appear in the System

DSN list.  Click ‘OK’ to close the ODBC Data Source Administrator.
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Task 2: Using a DSN with Microsoft Access
This task shows you how to locate and use your new DSN with Microsoft Access.  Microsoft Access is part of the
Microsoft Office suite, including Excel, Word, PowerPoint, and other applications.  The main function of Access is to
provide database capabilities on your PC.  Access supports many different types of database formats, including ODBC
Data Sources.  This means that the System i Access ODBC driver can be used with Microsoft Access to access
database information on the iSeries.

This task shows you how to use the DSN you created in the previous task to connect to the iSeries with Microsoft
Access.  To use your DSN follow these steps:

1. On your Windows desktop, click ‘Start->Programs->Microsoft Access’ to start Microsoft Access.

2. In Microsoft Access, choose ‘Cancel’ if asked to create a new database or open an existing database.

3. Select ‘File->Open’ from the Access menu.  On the Open panel, in the Files of type: dropdown list, choose
‘ODBC Databases()’.
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4. You should now be prompted to select your data source.  On the Select Data Source panel, select the
‘Machine Data Source’ tab.  Machine Data Sources are the same as System Data Sources (DSNs).  Select
‘iSeries Database Connection’ from this list and click ‘OK’.

5. On the Link Tables panel select the table ‘CAxxLIB.CUSTCDT’ (where xx is your team number) from the
list.  Notice that since you added library CAxxLIB to your DSN library list, tables from this library showed up
in your list of linkable tables.  Click ‘OK’.

6. Next, you have to select a Unique Record Identifier.  Choose the column ‘CUSNUM’ as your unique identifier.
Click ‘OK’.

7. You now have access to the iSeries table ‘CAxxLIB.CUSTCDT’ from Microsoft Access.

8. Select the table you specified (see the image below, ‘CAxxLIB_CUSTCDT’).  Click the ‘Open’ button to
view the data in the table.  Remember, this data is stored on the iSeries.

9. This task is now complete.  Close Microsoft Access and start on the next lab!
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Lab 5. Controlling Access to System i Access for
Windows Functions
There are often instances where you may not want certain users to use specific applications or to perform certain
functions on the PC or iSeries.  System i Access for Windows provides several methods for securing an number of its
applications on the PC.  A simple method of restricting the use of specific components of System i Access for
Windows is to use Selective Install to prevent those components from being installed.  For example, if you do not want
users to have access to the PC5250 emulator, you may choose to install System i Access for Windows without PC5250.
There may be situations where Selective Install is not a good solution.  Selective Install is not the answer when users
have access to System i Access for Windows install media and could install additional components themselves, or in
situations when more than one user shares a PC and certain users may use an application while others cannot, or if
certain users require specific functions of a product and must be restricted from using others.  

There are two other methods for implementing administrative control of System i Access for Windows and System i
Navigator functions.  First, the System i Access for Windows product provides a limited set of Microsoft system
policies.  However, the second method is what we recommend:  using System i Navigator Application Administration.
Here is an overview of each method.

Microsoft system policies
     Policies are PC driven, not dependent upon specific OS/400 or i5/OS releases. Policies can apply to 
     PCs, as well as Windows users. This means that users refer to the Windows user profile, not
     the iSeries user profile. Policies can be used to "configure" as well as to restrict. Policies
     typically will offer more granularity than Application Administration, and can offer a larger
     breadth of function. This is because a connection to the iSeries system is not needed to
     determine whether the user can use the function or not. Implementing policies is more
     complicated than implementing Application Administration because the use of the Microsoft
     system policy editor is required and PCs must be individually configured to download policies.

System i Navigator Application Administration 
     Application Administration associates data with the OS/400 or i5/OS user profile, instead of the
     Windows profile that Microsoft system policies associate with.  More granularity is
     available using policies, but Application Administration is easier to use as there is no
     complicated setup required. Application Administration uses the graphical user interface of
     System i Navigator to administer, which is much easier to use than Microsoft policy editor.
     Also, Application Administration information applies to the user regardless of which PC he signs on from.
     Particular functions within System i Navigator can be restricted. Application Administration
     is preferable if all of the functions you want to restrict are Application Administration-enabled.

Because we recommend System i Navigator Application Administration, this lab shows you how to use that method.  

Task 1: Using Application Administration
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The following steps show you how to restrict access to the PC5250 emulator using Application Administration.
1. Open System i Navigator.  One way to open it is Start->Programs->IBM System i Access for

Windows->System i Navigator. 
2. Right click on your system and select Application Administration->Local Settings from the context menu.  (If

you do not have the Local Settings choice, simply select Application Administration.)
3. Click on the Client Applications tab.
4. Click on the “+” next to System i Access for Windows to see the functions that can be controlled by Application

Administration.

5. 
Sel

ect 5250 Display and Printer Emulator.  Click in the checkbox of the All Object Access column to clear the
box.  Click on Customize. 
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6. From the Customize Access window, expand All Users and scroll down the list to find your userid.  Select your
userid and Add it to the Access Denied list.  

7. Click OK on the Customize Access window.  Click OK on the Application Administration window.
Application Administration will now prevent you from using the PC5250 emulator. 

8. In order for this restriction to take affect, you need to log off your PC and log back on.  Close System i
Navigator.  Then select Start from your Windows toolbar.  Select Shut Down.  Select “Log off <user>”, where
user is your user name.  Then click on OK.

9. Your PC will close anything you have running, and will log you off.  You will then be presented with a window
to log back on.

10. Enter your team name and password to log back on (from the worksheet on page 2).
11. Open the PC5250 emulator by double clicking on the desktop icon you created in a previous lab.  The

application administration restriction you added will prevent you from using the PC5250 emulator.  You will see
the message below.
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Congratulations! 

You have finished the System i Access for Windows Advanced lab. 
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Appendix A. Optional Labs
This section contains some additional labs that we thought might be useful to the more experienced or more
specialized System i Access for Windows user. The lab exercises are: 

w A.1 -  i5/OS NetServer

w A.2 - Exploring the System i Access for Windows Toolkit

If you have time and are interested in a topic, you can do these labs.
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Lab A.1 i5/OS NetServer
System i Access for Windows relies on i5/OS NetServer for file and print serving functions.  The
full name of iSeries Netserver is iSeries Support for Windows Network Neighborhood although
the name i5/OS NetServer is used everywhere.  i5/OS NetServer has been available since V4R2
of OS/400. It is not a part of System i Access for Windows but is part of OS/400 or i5/OS and is
not a separately installable option or product. 

i5/OS NetServer enables a System i to perform file and print serving in a Windows network
without the need to install additional hardware or software on the iSeries system. i5/OS
NetServer uses the Server Message Block (SMB) protocol to communicate with the network.
The underlying network protocol is NetBIOS over TCP/IP. 

In the System i Access for Windows Basic lab, we showed you how to share iSeries printers and
directories to your Windows network.  Here we will show you how to setup and configure  
NetServer on the iSeries, and manage i5/OS NetServer from within System i Navigator.   

Task 1: i5/OS NetServer Configuration
i5/OS NetServer has already been configured and started by the instructor. In a lab environment
we cannot let you modify the i5/OS NetServer configuration because the rest of the students are
using it. 

i5/OS NetServer uses NetBIOS over TCP/IP therefore we need to make sure that your client PC
can resolve the i5/OS NetServer NetBIOS name to an IP address. The simplest way to do that is
to put both the IP address and the NetBIOS name in the file LMHOSTS on your PC (LMHOSTS
is similar to the TCP/IP HOSTS file). An alternative method for the PC to resolve the NetServer
name is to add the NetServer name and IP address into your DNS configuration.  We assume that
TCP/IP is active and configured on your PC as well as on the iSeries. 

We will then try to access the i5/OS NetServer which should already be running. After that we
take a look at the configuration of i5/OS NetServer through System i Navigator.   In the
worksheet you received together with these instructions you can find all the names and addresses
you need for this task. 
Note: Please do not change any i5/OS NetServer properties as this may affect other students.
 

1. Locate the file LMHOSTS. Click Start->Search->For Files or Folders...   
2. In the field Named: enter lmhosts, then click Search Now.   
3. In the list of found files double click on lmhosts. Make sure you select the file without

extension! Use NOTEPAD to open the file.   
4. Search for a line that contains the i5/OS NetServer name and its IP address (we have

already added the NetServer name and address for you).
5. Close NOTEPAD and the Search application.   
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6. Open a Command Prompt (Start->Run then enter cmd.exe; press Enter. Enter the
command PING <i5/OS NetServer name>. PING should be able to find the i5/OS
NetServer. If it doesn't, there is a problem with your network setup and you will most
likely not be able to continue with the lab. In this case, see your lab instructor.   

7. Open My Network Places on your desktop and select Add Network Place.  Select the
“Browse...” Button.

8. Right click on My Network Places and select “Search for Computers”.
9. In the Computer Name: box, enter the i5/OS NetServer name, then click Search Now.
10. Find Computer should be able to locate the i5/OS NetServer and display it in the list.

Connect to it by double clicking on its name. 

11. Close the networking and search related Windows.
12. Start System i Navigator.   
13. Underneath the symbol for your iSeries, follow the path Network->Servers->TCP/IP.

You need to highlight TCP/IP. After a short moment you can see a list of all TCP/IP host
servers in the right window. 

14. Right click on i5/OS NetServer. 
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15. From the context menu that pops up select Create Shortcut. This will place an icon on
your desktop that you can use to directly access the i5/OS NetServer function of System i
Navigator for this specific iSeries.   

16. Right click on i5/OS NetServer again, select Properties.   
17. The i5/OS NetServer properties contains three pages. Take a look at each.   
18. Amongst other things, the General Properties page contains the i5/OS NetServer name

and its domain. The Advanced and WINS Configuration pages contain more configuration
information. At any time, if you want to know what a parameter is used for, click on the
question mark in the upper right corner of the properties dialog. The mouse pointer will
change to a pointer with a question mark.  Then click on a parameter you are interested in
and the corresponding help text will be displayed. 
Notice that on all three pages you can make no changes.   

19. On the General Properties page click Next Start. Another window opens. Here you could
change for example the i5/OS NetServer name. (Don't do it!). Click Cancel twice to come
back to the System i Navigator main window. If you had made any changes to the i5/OS
NetServer configuration, you would have to stop and then start the i5/OS NetServer in
order to make the changes effective.   

20. Back in the System i Navigator window, again right click on i5/OS NetServer. Notice
the option to Stop the server is black, while the option to Start or Reset and Start the server
are grayed out. Don't stop and start the server now, as you may affect other users! 

Task 2: Exploring i5/OS NetServer
Configuring i5/OS NetServer on the iSeries, managing shared resources, and displaying shared
resources can all be done from several different interfaces in System i Navigator.  In the previous
task, you learned how to change NetServer configuration settings by accessing the properties of
the NetServer item under Network ->Servers -> TCP/IP (or a shortcut to this item). In the basic
lab, we showed you how to set up sharing for directories and printers from context menus on the
items you wanted to share within File Systems -> Integrated File System and Basic
Operations->Printers.  We also showed you how to see all directories currently beign shared
through File Systems -> File Shares.  But in addition to performing these actions from these
separate locations, you can perform these tasks, and all NetServer administration from one
location:  The i5/OS NetServer window.  This interface also allows you to perform some
additional tasks that can’t easily be done from other locations.  The following tasks will show
you how to access the i5/OS NetServer window and perform various NetServer activities.
 

1. To open the i5/OS NetServer window, double click on the i5/OS NetServer shortcut you
created on your desktop in step 13 above. 

2. Right click on i5/OS NetServer in the left panel, and explore the various context menu
options.
NOTE:  Do NOT stop the NetServer since other students are using it.   

3. Click on the “+” in front of  Shared Objects to display the list of all dirctories and
printers on the iSeries currently being shared. 
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4. From the left panel, click on any shared object in the list.  If there are any active
connections currently accessing this object, they will be displayed in the right panel.

5. Right click on any shared object in the list and explore the options available from the
context menu.   
NOTE:  Do NOT stop sharing on any objects since other students might want to use them.
 

6. Click on the “+” in front of  Sessions to display the list of all active connections currently
accessing any shared objects from this iSeries.

7. If there are any sessions in the list, click on the session.  This will display the shared
objects being accessed by this session in the right panel.

8. Explore any other features of this window that are of interest to you.
9. Close the i5/OS NetServer window.
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Lab A.2 Exploring the System i Access for
Windows Toolkit
The latest toolkit that comes with System i Access for Windows has embraced more useful
components and information for programmers than ever. For example, IBM Toolbox for Java
and iSeries SDK for OLE DB and ActiveX Data Objects are now delivered as part of the toolkit.
It helps you develop applications that run over System i Access for Windows in a convenient
manner.

The Toolkit consists of two parts: 
w Components which are installed as part of the Toolkit are: 

Toolkit help files and other Windows help documentation   
C/C++ header file   
C import libraries   
ActiveX automation type libraries   
Visual Basic Wizards for the System i Access OLE DB provider

w Content that is delivered on the Internet through the System i Access Toolkit Web site, at
http://www.ibm.com/systems/i/software/access/windows/toolkit 

1. Open the System i Access for Windows folder on your desktop, select Programmer’s
Toolkit -> Programmer’s Toolkit.     Select any topic of your interest on the left side of
the window and you will see the topic expanded to show available subtopics. Detailed
information is displayed on the right side of the window at the same time as shown in the
following panel. 
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TRADEMARKS

The following are trademarks or registered trademarks of the IBM Corporation in the United States, other
countries, or both:

IBM   eServer   iSeries   OS/400   System i    System i5   iSeries   DB2   i5/OS  

Java and all Java-based trademarks and logos are trademarks of Sun Microsystems, Inc. in the United
States, other countries, or both. 

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in the United States, other
countries, or both.

Lotus is a registered trademarks of Lotus Development Corporation and/or IBM Corporation.

Other company, product, and service names may be trademarks or service marks of others.
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