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Notices

References in this publication to IBM products, programs, or services do not imply that IBM
intends to make these available in all countries in which IBM operates. Any reference to an IBM
licensed product, program, or service is not intended to state or imply that only IBM’s product,
program, or service may be used. Any functionally equivalent product, program, or service that
does not infringe any of IBM’s intellectual property rights may be used instead of the IBM product.
Evaluation and verification of operation in conjunction with other products, except those expressly
designated by IBM, is the user’s responsibility.

Any performance data contained in this document was obtained in a controlled environment based
on the use of specific data. The results that may be obtained in other operating environments may
vary significantly. Users of this document should verify the applicable data in their specific
environment. Therefore, such data does not constitute a performance guarantee or warranty.

IBM may have patents or pending patent applications covering subject matter in this document.
The furnishing of this document does not give you any license to these patents. You can send
license inquiries, in writing, to the IBM Corporation, IBM Director of Licensing, 208 Harbor Drive,
Stamford, Connecticut, United States, 06904.

JDOM License

Copyright (C) 2000-2002 Brett McLaughlin & Jason Hunter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted
provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions,
and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of
conditions, and the disclaimer that follows these conditions in the documentation and/or other
materials provided with the distribution.

3. The name "JDOM" must not be used to endorse or promote products derived from this
software without prior written permission. For written permission, please contact
license @jdom.org.

4. Products derived from this software may not be called "JDOM", nor may "JDOM" appear in
their name, without prior written permission from the JDOM Project Management
(pm@jdom.org).

THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
JDOM AUTHORS OR THE PROJECT CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

This product includes software developed by the JDOM Project (http://www.jdom.org/).



JETTY License

Preamble:

The intent of this document is to state the conditions under which the Jetty Package may be
copied, such that the Copyright Holder maintains some semblance of control over the
development of the package, while giving the users of the package the right to use, distribute and
make reasonable modifications to the Package in accordance with the goals and ideals of the
Open Source concept as described at http://www.opensource.org.

It is the intent of this license to allow commercial usage of the Jetty package, so long as the source
code is distributed or suitable visible credit given or other arrangements made with the copyright
holders.

Definitions:

e "Jetty" refers to the collection of Java classes that are distributed as a HTTP server with
servlet capabilities and associated utilities.

* "Package" refers to the collection of files distributed by the Copyright Holder, and derivatives
of that collection of files created through textual modification.

e "Standard Version" refers to such a Package if it has not been modified, or has been modified
in accordance with the wishes of the Copyright Holder.

e "Copyright Holder" is whoever is named in the copyright or copyrights for the package.
* Mort Bay Consulting Pty. Ltd. (Australia) is the "Copyright Holder" for the Jetty package.
e "You"is you, if you're thinking about copying or distributing this Package.

* "Reasonable copying fee" is whatever you can justify on the basis of media cost, duplication
charges, time of people involved, and so on. (You will not be required to justify it to the
Copyright Holder, but only to the computing community at large as a market that must bear the
fee.)

* "Freely Available" means that no fee is charged for the item itself, though there may be fees
involved in handling the item. It also means that recipients of the item may redistribute it under
the same conditions they received it.

0. The Jetty Package is Copyright (c) 1998 Mort Bay Consulting Pty. Ltd. (Australia) and others.
Individual files in this package may contain additional copyright notices. The javax.servlet
packages are copyright Sun Microsystems Inc.

The Standard Version of the Jetty package is available from http://www.mortbay.com.

2. You may make and distribute verbatim copies of the source form of the Standard Version of
this Package without restriction, provided that you include this license and all of the original
copyright notices and associated disclaimers.

3. You may make and distribute verbatim copies of the compiled form of the Standard Version of
this Package without restriction, provided that you include this license.

4. You may apply bug fixes, portability fixes and other modifications derived from the Public
Domain or from the Copyright Holder. A Package modified in such a way shall still be
considered the Standard Version.

5. You may otherwise modify your copy of this Package in any way, provided that you insert a
prominent notice in each changed file stating how and when you changed that file, and
provided that you do at least ONE of the following:

a. Place your modifications in the Public Domain or otherwise make them Freely Available,
such as by posting said modifications to Usenet or an equivalent medium, or placing the



10.

11.

12.

modifications on a major archive site such as ftp.uu.net, or by allowing the Copyright
Holder to include your modifications in the Standard Version of the Package.

b. Use the modified Package only within your corporation or organization.

c. Rename any non-standard classes so the names do not conflict with standard classes,
which must also be provided, and provide a separate manual page for each non-standard
class that clearly documents how it differs from the Standard Version.

d. Make other arrangements with the Copyright Holder.

You may distribute modifications or subsets of this Package in source code or compiled form,
provided that you do at least ONE of the following:

a. Distribute this license and all original copyright messages, together with instructions (in
the about dialog, manual page or equivalent) on where to get the complete Standard
Version.

b. Accompany the distribution with the machine-readable source of the Package with your
modifications. The modified package must include this license and all of the original
copyright notices and associated disclaimers, together with instructions on where to get
the complete Standard Version.

c. Make other arrangements with the Copyright Holder.

You may charge a reasonable copying fee for any distribution of this Package. You may
charge any fee you choose for support of this Package. You may not charge a fee for this
Package itself. However, you may distribute this Package in aggregate with other (possibly
commercial) programs as part of a larger (possibly commercial) software distribution provided
that you meet the other distribution requirements of this license.

Input to or the output produced from the programs of this Package do not automatically fall
under the copyright of this Package, but belong to whomever generated them, and may be
sold commercially, and may be aggregated with this Package.

Any program subroutines supplied by you and linked into this Package shall not be considered
part of this Package.

The name of the Copyright Holder may not be used to endorse or promote products derived
from this software without specific prior written permission.

This license may change with each release of a Standard Version of the Package. You may
choose to use the license associated with version you are using or the license of the latest
Standard Version.

THIS PACKAGE IS PROVIDED "AS I1S" AND WITHOUT ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
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1 Overview

The Printer Management Utility

The IBM* Printer Management Utility (PMU) allows you to organize all of the
printers in your office remotely in a single database, download software and
printer settings from a host computer with a single mouse click, and use a
virtual operator’s panel to configure printers in the same room or on the other
side of the world.

Requirements

* an IBM 6500/6400 Series Line Matrix or 6700/4400 Series Thermal
Printer

» the printer must be attached to the host system via a 10/100Base-T
Ethernet Interface or a wireless Ethernet Interface; if you do not have an
Ethernet Interface, see your dealer for an upgrade

* ahost computer running the Windows™* (95, 98, Me, NT, 2000, or XP) or
UNIX** (such as AIX*, Linux**, or Solaris**) operating system

* a host computer running a Java** 2 Platform, Standard Edition (J2SE**)
Java Runtime Environment (JRE) that is fully 1.4 compliant or higher.
Sun** Microsystems provides a 1.4 compliant J2SE JRE for Windows,
Linux, and Solaris at: http://java.sun.com/j2se/

NOTE: If you have another UNIX operating system, see your system
administrator.

» for Windows, a minimum hardware configuration of a 450MHz Pentium**
with 128 MB of RAM

To install and edit the database, it is not necessary to have the printers
connected. When starting a session with a printer, the printer must be
connected and turned on.

Installing the Software

The PMU is available only at the IBM web site at http://www.printers.ibm.com.

Follow the on-screen instructions to first install the J2SE JRE for your
platform, then the PMU.

11
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Your printer uses the diagnostic port to communicate with the remote
management software. The diagnostic port must be configured to interact with
the NIC. Follow the instructions below for your printer model to check the
diagnostic port setting.

6500 Series Line Matrix Printers

1.

e~ B T

0.
1.

On the printer control panel, press the STOP key to take the printer
offline.

Press RETURN and ENTER at the same time to unlock the ENTER key.
Press MENU. QUICK SETUP displays.

Press | SCROLL until PRINTER CONTROL displays.

Press ENTER. INTERFACE SELECTION displays.

Press | SCROLL until PRINTER MANAGEMENT PORT displays.

Press ENTER. DISABLE displays. If ETHERNET displays, go to step 10.
Press | SCROLL until ETHERNET displays.

Press ENTER. As asterisk (*) appears next to ETHERNET.

Press RETURN and ENTER at the same time to lock the ENTER key.
Press START to put the printer back online.

6400 Series Line Matrix Printers

1.

7.
8.
9.
10.

On the printer control panel, press the Stop key to take the printer offline.
Press Scroll T and Scroll | at the same time to unlock the Enter key.

Press Scroll T, Scroll |, Enter, and Return at the same time to enter the
SERVICE menu.

Press Scroll T or Scroll | until PRINTER MGMT displays.
Press Enter. DIAGNOSTIC PORT displays.

Press Enter. DIAGNOSTIC PORT (and the current diagnostic port
setting) displays. If DEBUT ETHERNET displays, go to step 9.

Press Scroll T until DEBUT ETHERNET displays.

Press Enter. As asterisk (*) appears next to DEBUG ETHERNET.
Press Scroll T and Scroll | at the same time to lock the Enter key.
Press Start to put the printer back online.
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6700 Series Thermal Printers

1. On the printer control panel, press the PAUSE key to take the printer
offline.

Press | and . at the same time to unlock the ! key.
Press +, -, |, and T at the same time to enter the Factory menu.
Press | until Diagnostic Port displays.

o M DN

If you have the internal PCI Ethernet Interface, press + until Debug
Ethernet displays. If you have the external Ethernet Interface, press +
until Debug Adapter displays.

o

Press I to select it.
Press | and ! at the same time to lock the ! key.
Press PAUSE twice to put the printer back online.

4400 Series Thermal Printers

1. On the printer control panel, press the PAUSE key to take the printer
offline.

Press | and . at the same time to unlock the ! key.

Press +, -, |, and T at the same time to enter the Factory menu.
Press | until Diagnostic Port displays.

Press + until Debug Ethernet displays.

Press I to select it.

Press | and . at the same time to lock the ! key.

© N o o b~ 0N

Press PAUSE twice to put the printer back online.

Set Password

See page 45 to learn how to set passwords.
If the password is unknown you must clear it first.

6500/6400 Series

Go into the SERVICE menu, then into the PRINTER MGMT menu.
Press | SCROLL until CLEAR PASSWORD displays. Unlock the ENTER
key, then press ENTER to clear the User and Supervisor passwords.

Under the Security tab in Printer Properties, delete any passwords that
already exist. Now you may set new passwords as described on page 45.

6700/4400 Series

Go into the Factory menu. Press T or | until Clear Password displays. Unlock
the  key, then press  to clear the User and Supervisor passwords.

Under the Security tab in Printer Properties, delete any passwords that
already exist. Now you may set new passwords as described on page 45.

13
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Set Telemetry Path (6700/4400 Series Only)

The following procedure enables you to collect data using the Data Validation
application.

1. On the control panel, press the PAUSE key to take the printer offline.

2. Press := to place the printer in Menu mode. QUICK SETUP displays on
the LCD.

Press | and ! at the same time to unlock the . key.
Press + until VALIDATOR displays.

Press | until Telemetry Path displays.

Press + or - until Network Port displays.

N o o Mo

Press . to activate it.

NOTE: Since only one port can be used at a time, DEACTIVATING HOST
SERIAL displays.

If you later change the setting to Serial Port or Disabled,
REACTIVATING HOST SERIAL will display.

8. Press | and ! at the same time to lock the ! key.
9. Press PAUSE twice to put the printer back online.
For more information, refer to the printer User’s Manual.

Check Port Number

Make sure your printer port number has the same setting as the NIC. To
check the port number using the remote management software, see page 18.

To check the port number on the printer, check the PRINTER MANAGER
PORT NO. under PRINTER MGMT in the SERVICE menu (6500/6400
Series) or the PMU Port Number in the Factory menu (6700/4400 Series).
The default port number is 3001.
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Getting Started

This section provides a short tutorial on how to set up and access a printer
using the remote management software.

1. This tutorial assumes the host computer running the remote management
software and the printer you want to access are connected by a network.
You must know the printer's IP Address and Port Number.

2. From your operating system, launch the remote management software.
Click the splash screen to see the main window of the printer database
more clearly. See Figure 1.

File Edit View Applications Status LHilities Help

=] o] o | [0 @] [ o] @] @] x| ot 1] A | | e =m0 1 [
‘= default.pdb
& E New_Printer (4 template)

Status and Error Log:

Figure 1. Printer Database Main Window
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D |
Identification | Security rCunnemiuns hnfurmatiun |

Hame {Unigque); ‘New_F'rinter |

Printer Description: ‘A template |

Onhy use characters A..Z, a..z, 0..9 for printer name and description.

| ok || cance

Figure 2. Printer Properties: Identification Tab
3. Double-click New_Printer (A template). The Printer Properties dialog
box opens. See Figure 2.

4. Assign a name to your printer. Delete the words New_Printer in the
Name (Unique) field, and then type Tutorial.

5. Assign a description to this printer. Delete the words A template in the
Printer Description field, and then type My First Connection.

16
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Printer Properties E

(Iderrtiﬁcatinn Security | Connections rIMDrmatinn |

User Password: | |

Superisor Password: | | [_] Supervisor Mode

Telnet Guest Password: | |

Telnet Root Passwaord: | |

Onhy use characters A..Z, a..z, 0.9 for passwords.

OK | | cancel

Figure 3. Printer Properties: Security Tab
Click the Security tab. See Figure 3.

If you are using the remote management software for the first time, it is
likely that no passwords are assigned to this printer. If you are unsure,
contact your system administrator.

» If no passwords are assigned, leave the password boxes empty.

e If a User password is necessary to access this printer, type the password
in the User Password field.

» If a Supervisor password is necessary to access this printer, type the
password in the Supervisor Password field, and check the Supervisor
Mode check box.

« If a Telnet Guest password is necessary to poll the status of the printer,
type the password in the Telnet Guest Password field. See “Security Tab”
on page 65.

» IfaTelnet Root password is necessary to update wireless printer settings,
type the password in the Telnet Root Password field. See “Security Tab”
on page 65.

In any case, an asterisk (*) character appears in the field after each letter
you type to preserve password secrecy.

For more details on setting up and changing passwords, see page 45.
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Printer Properties E

(Iderrtiﬁcatinn rSEcurity Connections | Information |

f Access Method r Metwork r SerialModem |

IP Address: |12?.EI.EI.1

Port Number: |3un1 | | Default |

Time Out (5..300 seconds): 15

OK | | cancel

Figure 4. Printer Properties: Connections Tab — Network Sub-Tab
Click the Connections tab. By default, the Network sub-tab displays.

Click the IP Address field and then type the IP Address of the printer you
want to access. Follow the format shown in Figure 4.

The Port Number field must be set to the same port as the printer. Leave

it set at 3001. Leave the Time Out (5..300 seconds) field set at 15
seconds.
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(Iderrtiﬁcatinn rSEcurity Connections | Information |

f Access Method r Metwork r SerialModem |

Access Method: | Ethernet -

Download Mode: |Access Method |

Printer Timeout on Firmware Download: | q inmte
Firmware Download Initial Delay (Seck: |

| ok || cance

Figure 5. Connections: Connections Tab — Access Method Sub-Tab

10. Click the Access Method sub-tab. See Figure 5.

The Access Method tells the remote management software how the host
computer communicates with the printer. Make sure it is set to Ethernet.
Ignore Download Mode and Download Timeout for now. These options
are described in “Access Method Sub-Tab” on page 68.

19
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11. Click OK. The Printer Properties dialog box closes and you return to the
printer database main window. Your printer is now set up in the remote
management software database.

File Edit Wiew Applications Status UHilities Help

=8 ctg]a[]2) [ 2] o] @) x| o= ] &5 o) wn) € n] = <)
K= default.pdb
@E Tutorial My First Connection)

Status and Error Log:

Figure 6. Printer Database Main Window

12. Try to access the printer’s virtual operator panel as a test to see if the
information you input is accurate. Follow this procedure:

a. Tutorial (My First Connection) should be highlighted in blue, as
shown in Figure 6. If it is not highlighted, click it to select it.

b. Select Applications » Operator Panel. The printer’s virtual operator
panel appears (see “Operator Panel” on page 98). If not, an error
message appears in the Status and Error Log pane. Check your
password to make sure it is correct. If the error continues, contact
your system administrator.

20



2 Printer Database

Overview

When you start the PMU, the printer database window appears first. The
printer database tool organizes and controls printers and Download files.
Figure 7 shows how the database looks when the PMU launches for the first
time.

Menu bar Toolbar Database Pane

File Edit View Applications Status Utilities Help,

B | o ot [P]0] [ 4[| @] @A =16 6|43 = =] em g =) |68

1= default.pdb
53 [ Mew_Printer (4 ternplate)

Status and Error Log:

N N\ ).
'\ \
Status and Error Log Pane
Status Bar Polling Indicator

Figure 7. Printer Database Main Window

The menu bar contains all the menus used to control the functions of the
program. The menus are described later in this chapter.

The toolbar contains buttons for the most commonly used menu functions.
See page 60 for descriptions of the toolbar buttons.

Use the Database pane to access and control your printers in a tree format.
The first line of the database tree displays the database file name. In Figure 7,
the default file name for this database is default.pdb. From there, your
database tree branches out to include printers, folders, and Download files,
which you can organize into groups. With a single mouse click, you can
download a file to several printers at once. In addition, you can use as many

21
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databases with the PMU as you want. Databases save as .pdb files on your
local hard drive.

NOTE: You can open only one printer database at a time.

The Status and Error Log scrolls status and error messages as you work
through the program. If the PMU does not function properly, look at this pane
for error messages. Use the scroll bar on the side of the pane to reference
previous status and error messages. The status and error messages relate to
the current PMU session, not to the specific database. When you exit the
PMU, these messages will be deleted.

The Status Bar displays brief status messages of the PMU, some of which
appear in the Status and Error Log.

The Polling Indicator turns green whenever printers are being polled.

The Menu Bar
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The printer database menu bar is located at the top of the window
(see Figure 7). Use the menu bar to access all the functions of the PMU.

The following are descriptions of the options located on the menu bar.

The File Menu
Eilel Edit View Applications 5tatus LUilities Help
New Ctrl-H w@ .}EE%}( Eﬂfﬁ
Open Ctrl-0
Save cil-s (WA template)
Save As
Preferences
Exit
Figure 8. File Menu
New

Creates a new database file. Since the PMU allows only one database file to
be open at a time, it asks if you want to save your changes to the current
database before it creates a new one.

Open

Opens a database file. Since the PMU allows only one database file to be
open at a time, it asks if you want to save your changes to the current
database before it opens a different one.
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Save

Saves the active database file using its current name.

Save As

Prompts you to enter a name for the current database file before the PMU
saves it. Use Save As if you do not want to overwrite the current database file.

Preferences

Opens the Preferences dialog box. See Figure 9.
Exit

Exits the PMU.

Preferences E |

i Printer Databhase r Configuration Editor r Servers |

Database File Name

|defau|t.pdb | | Browse |

Lease Time on Printer Connection: |3 %

Security

[_] Show message when the printer is not protected

OK | | Cancel

Figure 9. Preferences: Printer Database Tab

The Preferences dialog box has three tabs: Printer Database, Configuration
Editor, and Servers.

The Printer Database tab controls database features.

Database File Name: Enter the name of the default database file. The PMU
opens this database file when the program starts. To select a new default
database file, type it into the Database File Name field, or click Browse to
locate a file on your network.

Lease Time on Printer Connection: Enter an amount (in seconds) to set the
maximum amount of time a printer connection can remain open without any
communication. The default is three seconds.

Security: Check the Show message when the printer is not protected
check box to enable a warning message that informs you when a selected
printer does not have an assigned password.
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Preferences

rPrirrter Database IT Configuration Editor r Servers |

Editor keys
Hide Key: Unhide Key: Dec. Key: Inc. Key:
|Hh "’||Uu v||<, v||>_ -

OK | ‘ Cancel

Figure 10. Preferences: Configuration Editor Tab

The Configuration Editor tab controls features of the Configuration Editor
utility.

Hide Key/Unhide Key: Assigns which keys hide and unhide menu items in
the Configuration Editor menu tree (see page 73). The default for Hide is H h.
The default for Unhide is U u.

Dec./Inc. Key: Assigns which keys will decrement and increment menu items
in the Configuration Editor menu tree (see page 73). The default for
decrement is < ,. The default for increment is > ..
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Preferences E |

r Printer Database r Configuration Editor Servers
SHMP Trap Server

Port: | 45152 [_] Service Enabled

YWeb Server

Port: | 5080 [_] Service Enabled

XML Server

Port: | 2081 [C] Service Enabled

Mote: Restart program to use new settings.

ok || cancel

Figure 11. Preferences: Servers Tab

The Servers tab allows you to assign port values for the SNMP (Simple
Network Management Protocol) Trap Server, the Web Server, and the XML
Server. Click Service Enabled next to the corresponding server to turn it on.

NOTE: You must restart the PMU to use the new settings and enable the
servers.

SNMP Trap Server: The service that enables the PMU to receive alerts from
the printer when its status changes. Once the PMU receives the alert, the
PMU creates an instant status poll to reflect the change in the database pane.
For instance, if you turn the printer offline, the printer sends an alert to the
PMU causing it to change the printer status instantly. In the database pane,
the printer status changes to offline.

NOTE: The SNMP Trap Server works only if the printer's Ethernet Interface
is configured correctly using the Configure Print Servers utility. See
“Configure Print Servers” on page 54.

Web Server: Allows you to view the active PMU using a web browser. See
“Web Access” on page 112.

NOTE: If you want to use the Web Server service, you must also enable the
XML Server service.

XML Server: The PMU uses XML to communicate with its web server.
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The Edit Menu
File | Edit| View Applications Status Utilities Help
= Insert * Folder S4B === lE 0 ©
=T Cut Cirl-x | Printer
E{ Copy Cirl-C | Download File

Paste ctrlv | Paste Buffer

Delete

Include / Exclude

Figure 12. Edit Menu

Use the Edit option on the menu bar to build your database. The options in the
Edit menu are described below.

Insert

Adds a folder, printer, or Download file into your database. You must select an
existing database item to create a folder, printer, or file. You can also paste
the contents of the paste buffer (the last item that was copied or cut) into the
database. The new icon appears one level below the selected database item.
If there are items below the selected database item, the new item appears at
the end.

Inserting an item involves three steps:

1. Select a database item. (The new icon will appear below the item you
select.)

2. Define which type of icon you want to add. Select Edit » Insert » and then
select the item you want to add. Or click the £ (insert new folder),
g (insert new printer), or ﬂi (insert new Download file) icon.

A new icon appears in the database.
3. Define what printer, folder, or file this icon represents.
a. To define a printer, see “Defining Printer Properties” on page 63.

b. To define a folder, double-click New Folder. The Folder Name dialog
box opens. Type the name of the folder and click OK.

c. To define a Download file, see “File Download” on page 87.

Cut

Removes selected folders, printers, or files from the database and places it in
the paste buffer.

Copy

Copies selected folders, printers, or files from the database to the paste
buffer, leaving the original intact.

NOTE: You can select multiple database items by using the Ctrl or Shift key.
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Paste

Places the item in the paste buffer on the database tree. To paste, you must
select a database item. The pasted item appears on the same level as the
selected database item.

NOTE: If you select Edit » Paste, the pasted item appears on the same level
as the selected database item. However, if you select Edit » Insert »
Paste Buffer, the pasted item appears one level below the selected
database item.

Delete

Permanently removes a selected folder, printer, or file from the database.

Include/Exclude

Deactivates a selected folder, printer, or file. Inactive database items display a
red circle with a slash through it on top of the item’s icon.

You cannot send information to or receive information from excluded
database items using the following Applications, Status, and Utilities menu
options: Flash File Manager, File Download, Update Status, and Configure
Print Servers.

To activate a database item, select the inactive item and then select
Edit » Include/Exclude.

The View Menu

File Edit |View | Applications Status Utilities Help
E’;ﬁﬂ Collapse Tree m b @ R X =E g

(=4 default| E#pand Tree
@E M Style

Toolbar ' Horizontal Lines
' No Lines

b

® Angled Lines

Figure 13. View Menu

Collapse Tree

Collapses all folders on the database menu tree. Only the top level menu
items display.

Expand Tree

Expands all folders and printers on the database menu tree. All folders,
printers, and Download files display.
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Style

Angled Lines: Shows the links between database items using angled lines.

File Edit Yiew Applications Status LUtiliti

=B o & a2 O] | 4 || @)
) Clsample.pdh
@ =4 Building A
@ =3 Manufacturing
(D] C:\Printer Software A prg
@ Coblanufacturing Configs.ofg
@ Area 1 {north end of building)
£ Area 2 fwest end of building)
@ =3 Administration Office
(D] c\Printer Software B.pry
(D] chofiice Configs.cfy
€4 Yending Room
9 & Conference Roorm ()
@ CAConference Configs.cfy
@ £ Special Fonts
(D] cFonts. pff
@ Area 1 (north end of building)
€4 Yending Room §
(£ Building B

Horizontal Lines: Shows the links between folders using horizontal lines.

File Edit View Applications Status LHtiliti
=B e a2 o] 8=
= Chsample.pdb
@ &5 Building A
@ &5 Manufacturing
(D] C:iPrinter Software A prg
@ CAmanufacturing Configs.cfg
@ Area 1 (north end of buildinog
54 Area 2 (west end of building)
@ &5 Administration Office
(D] C:iPrinter Software B.prg
(D] ciofiice Configs.oig
54 Vending Roorm §
9 & Conference Roorm §
@ CAConference Configs.cf
@ & Special Fonts
(D] cFonts pff
@ Area 1 (north end of buildinog
g4 Vending Roorm §
[C] Building B
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No Lines: Shows no links between database items.

File Edit View Applications Status LHiliti

u

== of| ¢ e (BP9 | & BB

=

Chsample.pdh

@ S5 Building A

@ &5 Manufacturing

(D] C:\Printer Software A prg

@ CAmanufacturing Configs.cfg

@ Area 1 (north end of buildinog

64 Area 2 fwest end of building
@ &5 Administration Office

(D] c:Printer Software B.prg

(D] chofice Configs.cfy

£ vending Room

9 & Conference Room
@ CAConference Configs.cfy

@ £ Special Fonts

(D] coFonts. pff

@ Area 1 {north end of building)

£ Yending Room

(£ Building B
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Toolbar

Allows you to select which buttons display on the toolbar.

Customize Toolbar

]|

[v] = Open
vl B¥ Save

Clear Al

[v] =5 Folder
v g Printer
[v] @ Download File

Set Al

Derault

[vi D Edit
¥l {7 Include / Exclude

[v] % Cut

[v] B Copy

[v] (@, Paste

[v] 2, Paste Buffer
[v] ¥ Delete

[v] B=H Operator Panel

[vI 63 Information Capture

vi i configuration Editor

v &g File Download

[v] BE Data Validation

[v] B 0DV Quality Wizard

v Configure Print Servers
[v] EES0I Speed Keys

[v| ] Flash File Manager

[v| ¥ Update Status
[v] =] Discover Printers

V€% Job Capture

1% Help

Cancel
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The Applications Menu

File Edit View | Applications | Status Lhilities Help

35 [exfer| conmowraioneanor 3] @8] ] e/ 6]
= defaultpdb Flash File Manager
5 = Mew_Pri| File Download

Operator Panel

Information Capture
Data Yalidation
0DV Quality Wizard
Speed Keys

Joh Capture

Figure 14. Applications Menu

For an explanation of the Applications menu options, find the menu option in
Table 1 and go to the corresponding page.

Table 1. Applications Menu Options

Menu Option Page
Configuration Editor page 73
Flash File Manager page 83
File Download page 87
Operator Panel page 98
Information Capture page 101
Data Validation page 103
ODV Quality Wizard page 105
Speed Keys page 106
Job Capture page 107
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The Status Menu

File Edit View Applications §tatus| Litilities Help

@ [ole]a (9]0 vseowrrmers | /]
default.pdb Update Status
&3 B New_Printer (A termplatg Properties

Figure 15. Status Menu
Discover Printers

To search for printers on a network, select Status » Discover Printers, or
click the 'jE' Discover Printers button at the far right of the toolbar. The
results of the search display in the database pane.

Discover Printers searches for printers on a network based on the settings
specified in the Discovery tab of the Status Monitoring Properties dialog box.
The next section explains how to configure your search.
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Properties

Select Status » Properties to open the Status Monitoring Properties dialog
box. The dialog box contains three tabs: Discovery, Polling, and Alert
Delivery.

NOTE: To enable printer discovery, check the Enable Printer Discovery
check box.

Status Monitoring Properties E3

Discovery | Polling | Alert Delivery |

[¥] Enable Printer Discovery

( Print Server Discovery |/ Polled Discovery |/ Known Printers Discovery |

[¥] Enable Print Server Discovery  Response Wait (Seconds): (5

BroadcastIP | Subnet Mask | Return Gateway | | Add
255,255 155 255 0000 0.0.00

[ ramow |

o1 caroo || s

Figure 16. Status Monitoring Properties:
Discovery Tab — Print Server Discovery Sub-Tab

Discovery Tab

You can discover printers on a network in three ways:

1. Print Server Discovery: This option allows you to discover all IBM 6700/
6500/6400/4400 Series Ethernet Interface-equipped printers on a subnet.
To enable the option, check the Enable Print Server Discovery check
box in the Status Monitoring Properties dialog box (see Figure 16), then
click Apply or OK.

Response Wait (Seconds): To specify the time delay (in seconds) the
PMU waits for a printer response. By default, the value is set at 5
seconds.

Broadcast IP, Subnet Mask, and Return Gateway: These settings must
match your network configuration. See your system administrator.
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NOTE: To discover unconfigured NICs, you must enter the Gateway Address
and Subnet Mask in the Return Gateway field.

If Enable Print Server Discovery is enabled, a progress indicator displays
while the PMU discovers printers. See Figure 17.

File Edit Miew Applications Status LHilities Help

=E delal o[+ =ae x| = 4a a===d wn= G
‘4 default.pdb
538 B New_Printer (A ternplate)

£ Progress. ..

Discovery
Running Print Server Discovery
[ |

Status and Error Log:

Discovering printers:

Figure 17. Print Server Discovery in Progress
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Status Monitoring Properties E3

[ Discovery | Polling | Alert Delivery |

[¥l Enable Printer Discovery
( Print Server Discovery |/ Polled Discovery |/ Known Printers Discovery |
[¥] Enable Polled Discovery
First IP Address | LastIP Address | | Add
Remove
| ok || cancet || appy

Figure 18. Status Monitoring Properties:
Discovery Tab — Polled Discovery Sub-Tab

2. Polled Discovery: This option allows you to select a range of IP
addresses to poll. To enable the option, click the Polled Discovery tab
and check the Enable Polled Discovery check box, then click Add (see
Figure 18). In the First IP Address field, enter the first IP address of your
desired range. In the Last IP Address field, enter the last IP address. Click
Apply or OK. The PMU polls the printers within your specified range and
displays the results in the database pane.

If Polled Discovery is enabled, a progress indicator displays while the
PMU discovers printers. See Figure 19.

EEEE PR R E R I =T

‘= default.pdb
3 ] Mew_Printer (4 ternplate)

£ Progress...

%ﬁ Discovery
o Polling 10.22.1.112

Figure 19. Polled Discovery in Progress
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Status Monitoring Properties E

Discovery || Polling | Alert Delivery |

[l Enable Printer Discovery

f Print Server Discovery |/ Paolled Discovery |/ Known Printers Discovery |

[¥] Enable Known Printers Discovery

| Clear all
Delete

|_ox || cancer || apoy

Figure 20. Status Monitoring Properties:
Discovery Tab — Known Printers Discovery Sub-Tab

3. Known Printers Discovery: This option logs previously discovered
printer IP addresses. From this log, you can select and delete previously
polled discoveries to create a new polling list to target your printer search.
To enable the option, click the Known Printers Discovery tab and check
the Enable Known Printers Discovery check box (see Figure 20). From
the polled list of IP addresses, refine your search by keeping or deleting
found IP addresses. Click Apply or OK to start a new poll based on your
specification.

NOTE: You cannot manually add an IP address to this list. If you delete an IP
address, it is lost until it is rediscovered.

If Known Printers Discovery is enabled, a progress indicator displays
while the PMU discovers printers. See Figure 21.

| | || x| |30 )| & | | | 88 ] | x| o O o | 00 e | W] ) %

1=5 default.pdb
€A E New_Printer (4 template)

4 Progress...

ﬁﬁ Discovery
= Known Printers 10.22.5.22

[

Figure 21. Known Printers Discovery in Progress
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Polling Tab
Status Monitoring Properties
[ Discovery | Polling |  Alert Delivery |
[¥| Enable Status Monitoring SHMP Pacing (MS): |100
PrinterfFolder | FirstiP | LastiP | Enable | Initial Delay ‘ Add
Discovery: true a0

Folder: root true G0 Remove

4 [EE [ »

| OK H Cancel || Apphy

Figure 22. Status Monitoring Properties: Polling Tab

The Polling option allows you to control the way the PMU polls printers on the
network. For instance, you can create a timed interval for the PMU to poll
every 30 seconds or every two minutes. You can also specify a range of IP
addresses.

To enable the option, check the Enable Status Monitoring check box in the
Polling tab (see Figure 22). The SNMP Pacing (MS) value places a delay
between each SNMP request. This feature minimizes the network load. By
default, the value is set at 100 milliseconds (.1 second).

NOTE: If Discovery is enabled, then a discovery also occurs, based upon the
settings in the Discovery tab (see “Discovery Tab” on page 33).

Now you can set parameters to a new task. The parameters include:

Printer/Folder: To select which printer or folder you want the PMU to poll.
Click the field to select options from a drop-down menu.

First IP: To set the beginning IP address in a polling range. Use this option if
you select Range: as the Printer/Folder option.

Last IP: To set the last IP address in a polling range. Use this option if you
select Range: as the Printer/Folder option.
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Enable: To select whether or not you want to enable polling of a specific task.
If you want the PMU to poll the printers according to the specifications of your
first task, select true. Otherwise, select false.

Initial Delay (S): To specify the time delay from when the PMU starts to when
the PMU polls printers. The time delay is calculated in seconds.

Polled Interval (S): To poll printers automatically with timed intervals
calculated in seconds. Use this option to periodically poll for new printers
every few seconds.

Response Wait (MS): To specify the time delay the PMU waits between
SNMP responses. By default, the value is set at 300 milliseconds (.3
seconds).

NOTE: If you enter a low value for slow networks, you may receive no
response. In this case, increase the Response Wait (MS) value.
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Alert Delivery Tab

Status Monitoring Properties

 Discovery | Polling | Alert Delivery |

[¥l| Enable Motification

[ AlertLog | Email Alerts | Syslog Posting |

[¥] Enable Log File

LogFile | Size | Dewice | First | Last | of
alerts.log 1000 Folder: raot enahl

Add

Browse

Clear

tif

1B [ »

| OK H Cancel || Apphy

Figure 23. Status Monitoring Properties:
Alert Delivery Tab — Alert Log Sub-Tab

Select Status » Properties to open the Status Monitoring Properties dialog
box. Click the Alert Delivery tab. Check the Enable Notification check box
to enable the option. The Alert Delivery properties allow you to customize the
way the PMU notifies you of potential printer errors. Descriptions of the three
alert types follows:

1. Alert Log: Allows the PMU to log alerts to a file located in the PMU
directory. To log alerts, check the Enable Log File check box, then click
Add (see Figure 23). A task item adds to the log list. In the task item,
specify the following as applicable, then click Apply or OK.

Log File: To name the log file. The default file name is alerts.log.

Size: To set the maximum file size, in bytes. The default (and
minimum required) size is 1000 bytes.

Device: To choose a device item you want the PMU to monitor, such
as a folder, specific printer, or a range of IP addresses.

First: To set the beginning IP address in a polling range. Use this
option if you select Range: as the Device option.

Last: To set the last IP address in a polling range. Use this option if
you select Range: as the Device option.

39



Chapter 2 The Menu Bar

NOTE: In the remaining alert option fields, select enable or disable as
desired.

Offline, Warning, Media Input, Media Output, Media Path, Marker,
Cutter, Barcode, RFID, Scanner, Label, Intervention Needed,
Consumables, and Power Cart: For a description of the alert groups
and printer events, refer to “Alert Groups” in the SNMP Configuration
section of chapter three in the Ethernet Interface User’'s Manual. All
options are enabled by default.

Comment: Enter comments as needed.

Status Monitoring Properties

 Discovery | Polling | Alert Delivery |

[¥l| Enable Motification

[ AlertLog | Email Alerts | Syslog Posting |

[¥] Enable Email

Outgoing Mail (SMTP) Server @ | |
Email Subject : |Printer8‘[atu5 |

Email Sender : |printermanager@vuurcumpany.cum |

SMTP Email Server Port: |25

Email 4ddress | Dewice | First | Last | Ofﬂine| Add
Folder: root enable

[ »

| oK H Cancel || Apphy

Figure 24. Status Monitoring Properties:
Alert Delivery Tab — Email Alerts Sub-Tab

2. Email Alerts: The PMU sends you an alert
e-mail if a printer error occurs. To set up Email Alerts, check the Enable
Email check box. Enter information in the following fields:

Outgoing Mail (SMTP) Server: See your system administrator.
Email Subject: Enter the subject of e-mail.

Email Sender: Enter your e-mail address.

SMTP Email Server Port: See your system administrator.

40



The Menu Bar

Next, click Add to define a new task (see Figure 24). In the new task item,
specify the following information, then click Apply or OK.

NOTE:

Email Address: Enter the e-mail address where you want the PMU
to send the alert messages.

Device: To choose a device item you want the PMU to monitor, such
as a folder, specific printer, or a range of IP addresses.

First: To set the beginning IP address in a polling range. Use this
option if you select Range: as the Device option.

Last: To set the last IP address in a polling range. Use this option if
you select Range: as the Device option.

In the remaining alert option fields, select enable or disable as
desired.

Offline, Warning, Media Input, Media Output, Media Path, Marker,
Cutter, Barcode, RFID, Scanner, Label, Intervention Needed,
Consumables, and Power Cart: For a description of the alert groups
and printer events, refer to “Alert Groups” in the SNMP Configuration
section of chapter three in the Ethernet Interface User’'s Manual. All
options are enabled by default.

Comment: Enter comments as needed.

Status Monitoning Properties E3

 Discovery | Poliing | Alert Delivery |

[¢| Enable Notification

[ AlertLog | Email Alerts | Syslog Posting |

[¥] Enable Syslog

MachineAddress| Fort | Device | First | Last | Add

814 Folder: ront
Remove

|

[ »

| OK H Cancel || Apphy

Figure 25. Status Monitoring Properties:
Alert Delivery Tab — Syslog Posting Sub-Tab
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3. Syslog Posting: Used in a UNIX operating system, it allows the PMU to
log alerts to a file located in the PMU directory. To log alerts, check the
Enable Syslog check box, then click Add (see Figure 25). A task item
adds to the log list. In the task item, specify the following as applicable,
then click Apply or OK.

NOTE:

Machine Address: The UNIX IP Address.
Port: See your system administrator.

Device: To choose a device item that you want the PMU to monitor,
such as a folder, specific printer, or a range of IP addresses.

First: To set the beginning IP address in a polling range. Use this
option if you select Range: as the Device option.

Last: To set the last IP address in a polling range. Use this option if
you select Range: as the Device option.

In the remaining alert option fields, select enable or disable as
desired.

Offline, Warning, Media Input, Media Output, Media Path, Marker,
Cutter, Barcode, RFID, Scanner, Label, Intervention Needed,
Consumables, and Power Cart: For a description of the alert groups
and printer events, refer to “Alert Groups” in the SNMP Configuration
section of chapter three in the Ethernet Interface User's Manual. All
options are enabled by default.

Comment: Enter comments as needed.
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Update Status

Update Status shows the condition of the printer at the time the status is
checked. To update the status of a printer, select Status » Update Status, or
click the T___II (green flag) button at the right of the toolbar.

Figure 26 shows a printer with a wireless Ethernet Interface that uses two
ports. The | = (signal strength) icon represents the wireless port, while the

X (ethernet port) icon represents the ethernet port.

File Edit View Applications Status LUtilities Help

== oo P[0 s =ad x| =& a ¢ =& =g b=
default.pdb
@iagu T?__::l. Mew_Printer (& template) ORLINE:Batt 240.00 Hrs
@E@ = Mew Printer 1 {A termplate) OMLIME:Batt 240.00 Hrs

Figure 26. Update Status
When the printer status updates, the @ (printer) icon may change color:
» Green indicates the printer is functioning properly and can print
* Yellow indicates a warning, but the printer can print
* Red indicates the printer is not functioning properly and cannot print
» Grey indicates that the printer is not recognized

The message to the right of the printer description is identical to the message
on the front panel of the printer.

If you enable status polling, the printer status updates automatically.

The E (ribbon supply) icon indicates the amount of ribbon available on the
printer.

» Green indicates a full or nearly full ribbon supply
* Yellow indicates a moderate ribbon supply
* Red indicates a small or no ribbon supply

« Grey indicates that the ribbon supply feature is not supported on the
printer

NOTE: The following three icons appear only if the features are installed.
The T__: (signal strength) icon indicates the strength of the radio signal.
»  Green with three or four bars indicates a strong signal

* Yellow with two bars indicates a moderate signal

* Red with one bar indicates a weak or non-existent signal

The [ (ethernet port) icon always remains blue, since it represents an
ethernet connection.

The = (battery power) icon indicates the percentage of available battery
power.

» Green indicates the battery has 61% to 100% available power
* Yellow indicates the battery has 20% to 60% available power
* Red indicates the battery has less than 20% available power
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Place the pointer over the E T__: or = icon to obtain information about
the feature. See Figure 27, Figure 28, and Figure 29.

NOTE: No information displays if you place the pointer over the IE icon.

File Edit View Applications 5Status LUWilities Help

=B | cF|e| aF| |BP| @ | & | B @ & X | |=2|H| M| s

= default.pdb
@ﬁ?__::h Mew_Printer (4 template) OMNLINE:Batt 240.00 Hrs

| Ribbon rermaining 50% to 75% |

Figure 27. The Ribbon Supply Icon

File Edit View Applications Status LHilties Help

=B ci e ar PP @ & | B @R X| =8 M) s

= default.pdb
L= ‘T'%:I:I- Mew_Printer (A template) OMLINE:Batt 240.00 Hrs

Signal Strendth 94%

Figure 28. The Signal Strength Icon

File Edit View Applications Status LHilties Help

=B ci < ar PP @ & | B @R X| =8 M) s

Percent Charged: 94%
Battery Woltage: 12.1 Yalts
Current Draw; - 3.4 Amps
Time Remaining: 13.2 Haurs

Figure 29. The Battery Power Icon
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The Utilities Menu

File Edit Wiew Applications 5Status | Lhilities | Help

=B |cr ¢ a3 @] 3Bz Rewoot printer | @
=y defaultpdb Set Printer Password .
53 5 Mew_Printer (4 ternplate) SetWireless Properties
SHMP Browser

Assign IP Address
LockUnlock Menus
Configure Print Servers
Configure Wireless Printers

Figure 30. Utilities Menu

Reboot Printer

Reboots the selected printer.

Set Printer Password

The PMU does not allow passwords to change unless the Supervisor
password matches the password in the Printer Properties. See “Security Tab”
on page 65.

NOTE: If a password exists but is unknown, you must clear it first.

See “Set Password” on page 13.

To set the printer password in the database:

1.

o & D

Double-click the printer name. The Printer Properties dialog box opens.
Click the Security tab.

Type the User and Supervisor passwords.

Check the Supervisor Mode check box.

Click OK.
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To change the printer password:
1. Click the printer name to select it.

2. Select Utilities » Set Printer Password. The Change Password dialog
box opens.

Change Password E3 |

Enter new password:

[_| Supervisor Passworid:

Set Delete Cancel

3. Type the new password.

4. For a new Supervisor password, check the Supervisor Password check
box. For a new User password, leave this box unchecked.

Click Set.

If you entered a new Supervisor password, double-click the printer name.
The Printer Properties dialog box opens.

Click the Security tab.

Type the same password you entered in step 3 in the Supervisor
Password field.

9. Click OK.
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Set Wireless Properties

NOTE: For a more thorough description of these settings, refer to the
Ethernet Interface User’s Manual.

To set wireless properties, select a wireless printer from the printer database
then select Utilities » Set Wireless Properties.

The Wireless Properties dialog box contains four tabs: General, WEP
Encryption, Kerberos, and LEAP.

Wireless Properties
| General | WEP Encryption | LEAP |
SsiD: | | Sub-Channel:
Network Mode: | Infrastructure e | Transmit Power:
Antenna Diversity |F'riman.-' bt | Transmission Rate:
Power Saver Mode: | CAM hd | Preamble Length: Default hd
Authentication: |0pen hd |
[_] International Roaming Printer Settings:
Press Read Button For Current Settings Read
Close

Figure 31. Wireless Properties: General Tab

General Tab

You must click Read to obtain the printer’s settings before you can modify
them.

NOTE: If the Ethernet Interface has a password assigned to the user guest,
then a Telnet Guest Password is required. See “Security Tab” on
page 65.

SSID (Service Set Identifier): A 1 to 32 case sensitive character string that
identifies the SS network that the printer with a wireless Ethernet Interface is a
part of.

Network Mode: Determines if the client communicates using an access point
(Infrastructure) or other clients peer to peer (Ad Hoc).

Antenna Diversity: The Ethernet Interface supports a single (Primary and
Auxiliary) and dual (Diverse) antenna mode.

Power Saver Mode: Determines if the Ethernet Interface will go into a power
saving mode (Modes 1 through 5) or stay powered up (CAM: Continuous
Access Mode).

Authentication: Determines the authentication scheme: Open, Shared,
Kerberos, or LEAP.
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Open system authentication allows all devices that have the authentication
algorithm number for open system to authenticate.

Shared key authentication involves a four step process using secure or
encrypted text by means of WEP.

LEAP is to enable LEAP operation.
Kerberos is to enable Kerberos operation.

Sub-Channel: Determines the channel for the radio frequency card:
1 through 15 and Default.

Transmit Power: Determines the wattage of the transmission power: Max
(100 mW - Default), 50% (30 mW), 25% (15 mW), 10% (5 mW), and
1% (1 mW).

Transmission Rate: Currently unavailable. Determines the rate of data
transmission from the radio frequency card to the access point: 1 MHz, 2MHz,
5 MHz, 11 MHz, and Automatic.

Preamble Length: Determines the size of the packet header generated by
the access point: Long, Short, or Default (set by the access point).

International Roaming: Check this check box to enable roaming outside the
home country.

When you are finished, click Send to transmit the values to the printer.

NOTE: If the Ethernet Interface has a password assigned to the user root,
then a Telnet Root Password is required. See “Security Tab” on
page 65.

If you are not going to modify settings on any other tabs, you must update the
printer for the settings to take effect. Click Update to update the printer.

Make sure the settings match those configured in the Access Point.
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WEP Encryption Tab

Wireless Properties

( General | WEP Encryption | LEAP |

For 40 bit encryption (ASCIT)} use & characters
For 128 bit encryption {(ASCIT} use 13 characters
For 40 bit encryption {(Hex) use 10 characters
For 128 bit encryption (Hex) use 26 characters

® Key1 | | ASCI ® Hex
O Key2 | | ASCI @ Hex
O Key3 | | ASCI ® Hex
O Keya | | ASCI @ Hex

Figure 32. Wireless Properties: WEP Encryption Tab

You must click Read to obtain the printer’s settings before you can modify
them.

NOTE: If the Ethernet Interface has a password assigned to the user guest,
then a Telnet Guest Password is required. See “Security Tab” on
page 65.

Select which key you want to use for Wireless Equivalency Privacy (WEP)
encryption. Use the correct number and type of digits for your preferred
encryption strength (40 or 128 bit), then select ASCII or Hex.

Click Disable to disable WEP encryption for the selected printer.

Click Clear to clear all keys displayed on the WEP Encryption tab
simultaneously. (The keys stored in the Ethernet Interface are not affected.)

When you are finished, click Send to transmit the values to the printer. You
can transmit up to four keys at once, but only the selected key will become the
active key in the printer.

NOTE: If the Ethernet Interface has a password assigned to the user root,
then a Telnet Root Password is required. See “Security Tab” on
page 65.

NOTE: If the values are not in the selected format, or if the exact number of
characters required is not entered, an error message will appear.
Correct the problem, then click Send again.

If you are not going to modify settings on any other tabs, you must update the
printer for the settings to take effect. Click Update to update the printer.

Make sure the settings match those configured in the Access Point.
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Wireless Properties

| General | WEP Encryption | LEAP

User Hame:

Password:

Confirm Password:

| |

Figure 33. Wireless Properties: LEAP Tab

LEAP Tab

To use LEAP, you must set Authentication to LEAP in the General tab
(page 47).

This tab displays the information necessary for the Cisco** LEAP (Lightweight
Extensible Authentication Protocol) wireless security scheme. The Cisco

LEAP allows for a WEP key timeout that forces re-authentication, resulting in
the derivation of a new WEP key for the session.

Enter the User Name, Password, and Confirm Password corresponding to the
RADIUS (Remote Authentication Dial-In User Service) server, then click
Confirm to confirm the Password.

To enable LEAP in the Ethernet Interface, select the General tab. Make sure
LEAP is selected in the Authentication drop down menu. Click Send to
transmit the LEAP settings and the wireless properties defined in the General
tab.
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SNMP Browser

4. SNMP Browser

File

P | | om: [1.38121440 community: |public
| Get || wak || clear |

| »

1

Figure 34. SNMP Browser

The SNMP Browser enables you to view attribute values in the Printer MIB
managed by the Ethernet Interface. You can retrieve an attribute value of a
specific MIB Object ID (OID), or you can walk or traverse the MIB.

Three inputs are required before you can use the SNMP Browser:
1. IP: defines the IP address of the target printer.

2. OID: defines either the specific MIB object ID you want to view, or the
starting location for the MIB walk.

3. community: defines the access community defined in the Ethernet
Interface. The default is public.

The Get button retrieves the attribute and attribute value for the specific OID
entered. If the OID entered is invalid, you will receive the Error: SNMP error
message.

The Walk button traverses the MIB starting with the OID entered. The display
is in the format: OID=Attribute_Value.

The Clear button clears the current display.

The File menu allows you to open a previously saved SNMP Browser
session, save the current session to file, or send the current session to a
printer.
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Assign IP Address

El Azzign IP Address

Broadcast Address: |255.255.255.255 |

Hardware Address: | |

Hew IP Address: | |

Hew Mask: | |

Hew Gateway. | |

Assign Cancel

Figure 35. Assign IP Address

Allows you to assign IP addresses remotely to NICs that have not been
previously configured, or to reconfigure the Ethernet Interface settings. See
Figure 35.

This utility requires expert network knowledge. If you assign incorrect
network parameters to the printer, then other devices on the network
may operate improperly, possibly causing the whole network to be
unusable.

The Assign IP Address utility has five fields:

» Broadcast Address: To enter a subnet broadcast number or a direct IP
address to find the printer.

» Hardware Address: To enter the Machine Access Code (MAC) on the
Ethernet Interface.

* New IP Address: To assign the printer its new IP address. Make sure
this address is correct and do not enter an already existing IP address.

 New Mask: To enter the new mask address, if necessary. If you need the
same mask, type the mask number.

* New Gateway: To enter the gateway number the new printer uses.
Once you click Assign, the Ethernet Interface settings change immediately.

NOTE: To view the new settings on the operator panel, reset the Ethernet
Interface (refer to the Ethernet Interface User’'s Manual) or reboot the
printer: set the power switch to O (Off), wait 15 seconds, then set the
power switch to | (On).
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Lock/Unlock Menus

Lock/Unlock Menus |

ﬁ?} Please make a selection

Lock menus -

OK Cancel

Figure 36. Lock/Unlock Menus Dialog Box

The Lock/Unlock Menus dialog box allows you to lock or unlock menus on a
selected printer.

When you lock menus on a printer, the menu tree is disabled in the operator
panel (physical and virtual). Any key that affects the menu tree such as +, —,
T, 1, 4, UP, DOWN, NEXT, and PREV will not function. Also, any key that
goes to a menu, e.g., the JOB SELECT or TEST PRINT key, will not function.

NOTE: When some of the above listed keys are used in combination with
another to perform functions not related to the menu, they are not
disabled.

Other keys not disabled are those that perform a function, e.g., PAUSE,
FEED, ONLINE, PAPER ADVANCE, VIEW, SET TOF, PRT CONFIG, and
PAGE EJECT.
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Configure Print Servers

4 Configure Print Servers

Login: Password: | ] Aty

Printer ] Status | TrapPort | waming | omine [ Medialnput | Media Output |
New_Printer Ready Set ] [ [ ]

»

Press (Start) to configure the Print Servers Start Cancel

Figure 37. Configure Print Servers Window

To access the Configure Print Servers application, select one or several
printers from the printer database then select Utilities » Configure Print
Servers or click the @ Configure Print Servers button. The Configure Print
Servers window appears (see Figure 37).

The Configure Print Servers application allows you to set the trap port
according to the SNMP Trap Server setting (see page 25).

The Configure Print Servers application also allows you to select alert groups.
To select an alert group, click the check box(es) of the corresponding
option(s). The alert group options include:

*  Warning » Barcode

» Offline e RFID

* Media Input e Scanner

e Media Output e Intervention
* Media Path » Consumable
*  Marker e Label

e Cutter » Power Cart

Click Start to configure the print servers.

NOTE: Check the Automatic check box to have the PMU connect directly
with the printer.

Uncheck the check box to have the PMU make a Telnet connection
with the printer. Enter root in the Login field and the password for the
user root in the Password field.

When your printer encounters a problem that falls within the parameters of the
selected alert options, the corresponding alert message appears. Refer to the
Alert Groups Table in chapter three of the Ethernet Interface User's Manual
for descriptions of the alert message options.

NOTE: To check the print servers configuration, go to the Ethernet Interface
web page as discussed in chapter three of the Ethernet Interface
User’s Manual.
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Configure Wireless Printers

Selecting individual printers and modifying wireless parameters is time
consuming, especially when several printers need to be configured with the
same property values.

To simplify this, the PMU provides a batch mode operation. This involves
creating and modifying a wireless.xml file (which contains the batch mode
information), then sending this file to all the specified wireless printers.

Create the wireless.xml File

1. Make sure the printers you want to receive the batch processing are in
the printer database, and that their status has been updated. See “Update
Status” on page 43.

2. To be certain that the PMU knows the printers’ current settings, make
sure the printers have been read. See “Set Wireless Properties” on
page 47.

3. Select the wireless printers to be configured (or a folder of printers), then
select Utilities » Configure Wireless Printers.

NOTE: If you are prompted to overwrite an existing wireless.xml file, click
Yes, since you will be configuring a new set of printers.

A dialog box opens with the selected printers displayed. See Figure 38.

Wireless Properties

A wireless xml file has been created from
the wireless printers in your database.

Flease checkthe values and make any corrections
necessany in the wireless.xml file.

Printer Mame = Mew_Printer
IP Address=10.224 238

ireless Froperties

ESSID =101

Metwork mode = infrastructure
Fowver Saver mode = CAM
Antenna diversity = diverse
Transmission rate = auto

Suh Channel = default
FPreamble Length = default
Transmit Power =

1]

Start Cancel

Figure 38. Sample Wireless Properties
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The wireless.xml file has been created.

NOTE: If your printer selection includes a printer with a wireless Ethernet
Interface that uses both the "|_"_= wireless and I ethernet ports, the
generated wireless.xml file will list only the ethernet port as the
interface for sending wireless properties.

4. Click Cancel.

Modify the wireless.xml File

Locate and open the wireless.xml file, which is located in the PMU program
directory. See Figure 39.

<7uml version="1.0" encoding="UTF-8" 7=
- «<WirelessPrinters=

- <Printer enabled="false" name="A Printer" ipAddres=="0.0.0.0" iFHum="2">
<TelnetRootPassword password="" />
<WirelessProperties essid="101" networkMode="infrastructure"
powerSaverMode="CAM" antennabiversity="diverse" transmissionRate="auto"
subChannel="default" preambleLength="default" transmitPower="100"
internationalRoaming="false" /=
- <\WEP enabled="false" selectedkey="0"=

<kKeyl value="" type="Hex" /=
<kKey? value="" type="Hex" /=
<kKey3 value="" type="Hex" /=
<key4 value="" type="Hex" /=
< WEP=
</Printers
<MirelessPrinterss
Figure 39. The wireless.xml File

To modify this file, open it using a text editor. The following values can be set
for the attributes (the default item is listed first).

NOTE: The following information is automatically inserted near the beginning
of the wireless.xml file (as comments).

Printer

enabled: false, true (false causes the PMU to skip the printer update)
name: A Printer (the name of the printer in the printer database)
ipAddress: 0.0.0.0 (IP address of the printer)

iFNum: 2 (this setting must always be 2)

TelnetRootPassword

password: <null> (Ethernet Interface password)
NOTE: <null> indicates that there is nothing in the allotted space.
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WirelessProperties

essid: 101 (1 to 32 character string)

networkMode: infrastructure, adhoc, pseudo

powerSaverMode: CAM, 1 to 5 (CAM is Continuous Access Mode)
antennaDiversity: diverse, primary, auxiliary

transmissionRate: auto, 1, 2, 5, 11

subChannel: default, 1 to 15

preambleLength: default, long, short

transmitPower: 100 (figure is in percent, range is 1 to 100)
internationalRoaming: false, true

All the information in the wireless.xml file is sent as clear text during
batch mode operation. For security, send the following information to a
wireless printer using the IE ethernet port.

WEP

enabled: false, true (false causes the PMU to ignore the rest of the WEP
section)

selectedKey: 0, 1 to 4 (0 disables WEP encryption)
Key1-Key4:

value: <null>

For 40 bit encryption (ASCII) use 5 characters
For 128 bit encryption (ASCII) use 13 characters
For 40 bit encryption (Hex) use 10 characters
For 128 bit encryption (Hex) use 26 characters

type: Hex, ASCII

Kerberos

enabled: false, true (false causes the PMU to ignore the rest of the Kerberos
section)

activate: false, true (true causes the printer to use Kerberos when the printer
is using a wireless connection)

clockSkew: 300 (range is 60 seconds to 15 minutes)
clockSkewUnit: seconds, minutes

ticketLifetime: 43200 (range is 300 seconds to 3 days)
ticketUnit: seconds, minutes, hours, days

renewableLifetime: 0 (range is 300 seconds to 7 days; 0 means there is no
renew limit and the PMU ignores the renewableUnit value)

renewableUnit: seconds, minutes, hours, days

printServerName: <null> (maximum of 63 printable characters; in the
Windows environment, the user name defined in the Windows server must be
changed accordingly)
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The KDC settings must match those configured in the Access Point.
portKDC: <null> (range is 0 to 65535)

nameKDC: <null> (maximum of 127 printable characters)

realmKDC: <null> (maximum of 127 printable characters)

password: <null> (maximum of 40 printable characters, excluding
the " character)

When the values are correct, save the file as wireless.xml and place it in the
PMU program directory.

For security, limit access to the wireless.xml file, since it contains WEP
keys and Kerberos passwords.

Send the wireless.xml File to the Printers
1. Select Utilities » Configure Wireless Properties.

When you are prompted to overwrite an existing wireless.xml file, click
“No,” since you have just created and modified it.

2. Click Start.

The Start button will turn red and change to Stop. The PMU verifies the
wireless properties and any errors discovered will display.

If all data in the wireless.xml file are valid, they will be sent to all printers
specified in the file. Click Stop to abort the setting of the wireless
properties while in batch mode operation.

Aborting the batch mode operation will leave the printers’ wireless
properties in a mixed state, some new settings and some old settings.
Abort only if you want to make a value correction in the wireless.xml file.
Save the corrected file and start the batch mode operation again.
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When the data have been successfully sent, the Wireless Properties
dialog box will update. See Figure 40.

Wireless Properties |
To abort the batch mode process, press the Stop key. B

arning: If the batch process is aborted the printers may
end upin an unknown state.

Sending wireless properties to; Mew_Printer
IP Address: 10.224.2.38

Results:
ireless properties successiully set.

Infa: WEP element is disahled.

Rehoaoting printer.

Start Cancel

Figure 40. Wireless Properties Successfully Sent

The Help Menu

File Edit View Applications Status LHilities ﬂelp|

=B cf|¢| e (55| @ | & |Ba| @€ Avowt |F| | E
= default.pdb
58 ] Mew_Printer (A ternplate)

Figure 41. Help Menu

About

Displays the PMU About dialog box. The About dialog box shows the
program’s version information and part number, and the Java version
number.
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The Toolbar

The PMU toolbar contains buttons that perform functions. See below for a
description of each button. Refer to the specified page for a more detailed
description.

You can select which buttons display on the toolbar. See page 30.

Button Description

Open: Opens a different printer database.

Save: Saves the current printer database.

Folder: Inserts a new folder into the printer database
(page 26).

Printer: Inserts a new printer into the database
(page 26).

Download File: Inserts a new Download file into the
database (page 26).

Edit: Defines the properties of the selected item
(page 63).

Include/Exclude: Deactivates a selected folder, printer,
or file (page 27).

Cut: Removes a selected folder, printer, or file from the
database and places it in the paste buffer (page 26).

Copy: Copies a selected folder, printer, or file to the
paste buffer (page 26).

Paste After: Pastes the item in the paste buffer after the
selected item (page 27).

Paste Into: Pastes the item in the paste buffer into the
selected item (page 27).

Delete: Removes the selected item (page 27).

| x®@ @ & ~ 0% B & 0 AW

Operator Panel: Virtual control panel that allows you to
make selections via the PMU as if you are using the
actual printer control panel (page 98).

b

o
[ 1]

Information Capture: Allows the PMU to capture
information sent between the computer and the printer
(page 101).

Configuration Editor: Allows you to edit the data sent
from the computer to the printer before the printer
receives it (page 73).
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Button
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Description

File Download: Allows you to download a configuration,
firmware, or flash file to the printer (page 87).

Data Validation: Opens the Data Validation window
(page 103).

ODV Quality Wizard: Opens the ODV Quality Wizard
window (page 105).

Configure Print Servers: Opens the Configure Print
Servers window (page 54).

Speed Keys: Opens the Speed Keys window
(page 106).

Flash File Manager: Opens the Flash File Manager
window (page 83).

Update Status: Marks a printer or printers for status
updates (page 43).

Discover Printers: Searches for new printers (page 32).

Job Capture: Opens the Job Capture window
(page 107).

Help: Opens the Help window (page 59).
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Managing the Database

To organize your databases easily and effectively, use the Edit option on the
printer database menu bar. You can add, delete, and assign printers,
configuration files, and download files to your database tree. You can also
organize them using folders. All Edit menu functions have buttons on the
toolbar (see page 60).

Database Items

I:l Folder: Use folders to group the elements of your database.
@ Printer: See “Defining Printer Properties” on page 63.

@ Download file: A flash file or a configuration file (created in the
Configuration Editor which is described on page 73) stored on your
host computer.

A flash file contains information (e.g., the printer’s firmware file or a font
file) that you can download to the flash SIMM memory of a printer or
group of printers.

A configuration file contains user-defined printer configurations that you
can download to your printer using either the printer database or the
Configuration Editor.

For information about Download files, see “File Download” on page 87.
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Defining Printer Properties

Fle Edit View Applications Status Utilities Help
=8 o< al [Plo] &= e @ x| = 6/a) 4= =/ =g u <[4

= vetato
A Mew_Printen
Identification | Security rConnec‘tions rlnformatiun |

Name (Unigue): |New_Printer |

Printer Description: |A template |

Onhyuse characters A..Z, a.z, 0.9 for printer name and description.

Status and Error Log: Cancel

Figure 42. Defining Printer Properties

Before you can use any of the PMU applications, you must define the printer’s
properties. You must identify the printer and configure how the printer
communicates with the PMU. To define a printer, double-click the printer's
name or click the w (edit database entry) button. The first time you run the
PMU, double-click New_Printer (A template). The Printer Properties dialog
box opens. See Figure 42.

The Printer Properties dialog box contains four tabs: Identification, Security,
Connections, and Information, described in the next sections.
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Identification Tab

Pinter Properies &
[ dentification || Security | Connections | Information |

Mame {Unique): ‘New_F'rinter |

Printer Description: ‘ A template |

Onby use characters A..7, a..z, 0.9 for printer name and description.

oK | | Cancel

Figure 43. Printer Properties: Identification Tab

Name (Unique)/Printer Description: Assigns a name to your printer to
identify it in the printer database. You can also assign a printer description,
which appears in parentheses to the right of the printer name in the database.

When you assign a printer name and description, use only the alphanumeric
characters A-Z, a-z, and 0-9. Underscores and spaces may be used to
separate words.
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Security Tab

T S |

| Identification | Security | Connections | Information |

User Password: ‘ |

Superisor Password: ‘ | [_] Supervisor Mode

Telnet Guest Password: ‘ |

Telnet Root Password: ‘ |

Onhy use characters A..7, a..z, 0.9 for passwords.

oK | | Cancel

Figure 44. Printer Properties: Security Tab

User/Supervisor Password: Enter the printer's password, if appropriate.
The password feature restricts access to certain functions of the PMU. In
User mode, the PMU does not allow the following functions: downloading
files, configurations, or configuration names to the printer; clearing the error
log; and setting passwords. Supervisor mode allows unrestricted access to all
functions of the PMU.

User and Supervisor passwords are only recognized up to 9 characters, and
are displayed as *****, one * for each character typed. Use only the
alphanumeric characters A-Z, a-z, and 0-9 for passwords. Underscores and
spaces may be used to separate words. To set up a password, see page 45.

Telnet Guest Password: The PMU uses Telnet to poll the status of older
printers. If your printer reports a Telnet error (see Figure 45), enter the
password for the user guest. See your system administrator.

File Edit View Applications Status LUtilities Help

=B | x| 22 # |2 @ & X| =

default.pdb
ﬂg Mew_Printer (4 templated Telnet Error.Check =guest= passwaord

@ <3 =) =) 5]

Figure 45. Telnet Guest Password Error: Polling the Printer Status
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The PMU also uses Telnet to read wireless printer settings. If the PMU reports
a Telnet error when attempting to read wireless printer settings

(see Figure 46), enter the password for the user guest. See your system
administrator.

NOTE: After you enter the password for the user guest, you must click OK to
close the Printer Properties dialog box so that the PMU will recognize
the Telnet Guest password.

Wireless Properties

| General | WEP Encryption | LEAP |

SSID: | | Sub-Channel:

Metwork Mode: | Infrastructure o | Transmit Power:

& Mot A Wirelezz Printer E2

e Either this is not a wireless printer or a
connection to the printer cannot be obtained. -

Antenna Diversity

Power Saver Mod

Authentication: -

[_] International Roaming Printer Settings:

Fress Send Button To Change Propedies Read

Figure 46. Telnet Guest Password Error: Reading Wireless Settings
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Telnet Root Password: The PMU uses Telnet to update wireless printer
settings. If the PMU reports a Telnet error when attempting to update wireless
printer settings (see Figure 47), enter the password for the user root. See

your system administrator.

NOTE: After you enter the password for the user root, you must click OK to
close the Printer Properties dialog box so that the PMU will recognize

the Telnet Root password.

Wireless Properties

| General | WEP Encryption | LEAP |

SSID: |1 01 | Sub-Channel: |default
Failure Sending Wireless Properties
Metwork Mode: & < &
e Telnet error occurred while sending the new
Antenna Diversit, wireless properties to the printer.
Power Saver Mot Error: Failure occurred while setting the ssid.
Authentication: Please send the properties again.
[_] International |
Fress Stop Button To Abort Sending Propedies Read

Figure 47. Telnet Root Password Error

67



Chapter

2

Managing the Database

68

Connections Tab

Pinter Properies &
 Identification | Security | Connections |  Information |

" Access Method | Network | SerialModem |

Access Method: | Ethernet i

Download Mode: |Access Method |

Printer Timeout on Firmware Download: | 4 minute
211

Firmware Download Initial Delay (Sec):

oK | | Cancel

Figure 48. Printer Properties:
Connections Tab — Access Method Sub-Tab

The Connections tab contains three sub-tabs: Access Method, Network, and
Serial/Modem.

Access Method Sub-Tab

Access Method: |dentifies how the PMU accesses the printer. Refer to the
Ethernet Interface User’'s Manual to set up the Ethernet Interface for your
printer.

» Ethernet: To connect the host computer to the printer via the
Ethernet Interface.

* Network (TCP): To connect the host computer to the printer via a
network interface.

«  Printer Serial Port (Direct): To connect the host computer to the
printer directly via the serial port.

» Printer Debug Port (Direct): To connect the host computer to the
printer directly via the debug port.

» Printer Serial Port (Modem): To connect the host computer to the
printer via a modem and the serial port.

*  Printer Debug Port (Modem): To connect the host computer to the
printer via a modem and the debug port.

Download Mode: Identifies how the PMU downloads files and configurations
to the printer. Access Method is the only option available.

Printer Timeout on Firmware Download: Specifies the number of minutes
the printer waits for data while downloading a file from the host computer. If a
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stall lasts for more than the specified time, the printer times out and the
download terminates. If you have a slow connection between the PMU and
the printer, you may need to define a longer Download Timeout period.

The Download Timeout range is between 1 and 60 minutes. The default is
1 minute.

Firmware Download Initial Delay (Sec): Specifies the number of seconds
the PMU waits before sending files to the printer. If the printer is not ready
within the specified time, the download will terminate, and the Status and
Error Log will report “Connection Refused.”

If you receive this error message, increase the initial delay time. The default is
60 (seconds).

Network Sub-Tab

Printer Properties |

rlderrt'rﬁ[:aiiun rSEcurity Connections | Information |

r Access Method r Metwaork r SerialModem |

IP Address: |1 27.0.01

Port Number: |3nn1 | | Default |

Time Out (5..300 seconds): 15

| OK | | Cancel

Figure 49. Printer Properties: Connections — Network Sub-Tab

Enter the printer’s IP Address and Port Number. (Click Default to reset the
Port Number to 3001.) The Time Out option sets the amount of time, in
seconds, the PMU waits for a response from the printer after sending a
command. If there is no response in the specified amount of time, an error
message appears in the Status and Error Log pane. If you have a slow
connection between the PMU and the printer, you may need to define a
longer Time Out period. Define the Time Out between 5 and 300 seconds (the
default is 15 seconds).

NOTE: The Network settings must match the settings in the printer’s front
panel menu. See “ETHERNET PARAMS”, “ETHERNET ADDRESS”,
or “WIRELESS ADDRESS” in the printer's User’s Manual to check
the IP address. To check the port number, check PRINTER
MANAGER PORT NO. under PRINTER MGMT in the SERVICE
menu (6500/6400 Series), or PMU Port Number in the Factory menu
(6700/4400 Series). To access the SERVICE or Factory menu, see
“Printer Setup” on page 12.
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Serial/lModem Sub-Tab

The Serial/Modem tab contains two tabs: Serial Port Parameters and Modem
Control.

Serial Port Parameters

Pinter Properies &
 Identification | Security | Connections |  Information |

[ Access Method | Network | SerialModem |

| Serial Port Parameters | Modem Control |
Connect Using: |(COM 1 -
Speed: | 9600 Baud

Word Size: |8 Bits b

I

Parity: | Mone

Stop Bits: | 4 git -

oK | | Cancel

Figure 50. Printer Properties: Connections — Serial/Modem Sub-Tab
Serial Port Parameters

Connect Using: The serial port to use for connection. The default is COM1.
The range is COM1 to COM20.

Speed: The baud rate at which data transfers. This setting must match the
speed of the printer serial debug port in SERIAL under PRINTER MGMT in
the SERVICE menu (6500/6400 Series) or Baud Rate in the Factory menu
(6700/4400 Series). To access the SERVICE or Factory menu, see “Printer
Setup” on page 12.

Word Size: The number of data bits per character. Must be set to 8 bits.

Parity: Adds an error checking bit if set to Odd or Even. Since the word size
must be set to 8 for correct operation, parity should normally be set to None.

Stop Bits: Inter-character gap. Can be set to 1 or 2. The normal setting is 1.
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Modem Control

Pinter Properties ————__________________________[|
(Iderrtiﬁcatiun rSEcurity Connections | Information |

f Access Method r Metwork r SerialModem |

( Serial Port Parameters r Madem Control |

Phone Number:

[w] Wit for dial tone

[¥] Show status when dialing

Dial Method Call Back

% Tone O Pulse Number: [_] Enable

| ok || cance

Figure 51. Printer Properties: Connections — Serial/Modem Sub-Tab
Modem Control

Phone Number: Enter the phone number you wish to call.

Dial Method: Choose Tone or Pulse.

Call Back: Enter your phone number, and check Enable if you want to use it
as a call back number.
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Information Tab

Pinter Properties ————________________________[|
(Iderrtiﬁcatiun rSEcurity rCunnemiuns Information

Hardware Address: 00:30:72:.09:C8.F7
IP Mask: 255.0.0.0

Gateway: 10.22.1.254

Print Server Name: M_09C9F7

SMB Workgroup: WORKGROUP
Location: null

Serial lumber: 51703

oK | | cancel

Contains information about your printer. See the Ethernet Interface User’s
Manual for more information.
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Configuration Editor

4. Configuration Editor [New_Printer]

File Edit View Migration

EEIEEIE]

OFFLINE
Praotect Configs.: Disable

@ HOST INTERFACE: Auto Switching
ACTIVE IGP EMUIL: IGP/PGL

@ EMULATION

@ PRIMTER COMTROL

© ADVAMCED USER

Displayed Language Displayed Configuration Power-Up Configuration
| English ~ | | Factory ~ | | Factory -

Figure 52. Configuration Editor Window

To access the Configuration Editor application, select a printer from the
printer database and select Applications » Configuration Editor or click the
ﬂ (configuration editor) button. Select File » Upload From Printer to upload
configurations from the printer. The configurations upload from the printer and
the active configuration displays in the Configuration Editor window. See
Figure 52.

The Configuration Editor supports offline editing, allowing the editing of stored
configurations. If you start the Configuration Editor without connecting to a
printer, the screen will be blank. A configuration will not display until you load
a configuration file from a disk or computer.

The Configuration Editor allows you to upload, modify, and download eight
user-defined configurations and the factory default configuration (only if
modification of the factory configuration has been enabled; see the Note on
page 75). You may also save sets of configurations to your local hard drive so
that they can be easily downloaded to the printer at any time.

The Configuration Editor does not change the current configuration or the
active printer status until the configurations are downloaded to the printer.
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Menu Tree

The Configuration Editor displays the printer configurations in a tree format
(see Figure 52). The top level of the tree is the OFFLINE menu. From this
level, the tree branches into the printer's submenus. Menu items that have a
117,' or &&= (handle) next to them have further submenus below them. Click the
handle to expand or collapse the submenus below. (You may also use the
Expand Tree/Collapse Tree options in the View menu, but these options will
expand or collapse all submenus.)

The Configuration Editor has three drop-down menus at the bottom. The
Displayed Language option allows you to select from five or more different
languages to display the configuration information. The Displayed
Configuration option lets you choose between the available configurations to
display. The Power-Up Configuration allows you to assign which configuration
loads whenever the printer turns on.

Creating Configurations

Along with the factory configuration, your printer allows up to 8 user-defined
configurations that can be downloaded to your printer's memory. You may
create configurations using the printer’'s operator panel, or by using the
Configuration Editor.

To create a configuration using the Configuration Editor:

1. Select Edit » Copy From:. A list of configurations appears. Undefined
configurations appear gray. Choose one of the configurations.

2. Click Edit. (Notice that the configuration you chose in step 1 now appears
next to the Copy From: menu item.) Move your mouse down to Copy To.
A list of configurations appears. Choose the number of the configuration
you want to create. This new configuration is created with the settings
from the configuration you chose in step 1.

NOTE: If you choose to Copy To a configuration which already exists, that
configuration will be overwritten.

3. You may now edit the configuration settings. See “Changing
Configurations” on page 75.
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Changing Configurations

Configuration settings in the Configuration Editor can be changed two ways:
* make the changes directly on the menu tree
» use the Menu Editor

NOTE: Normally, the factory default configuration cannot be changed.
However, you can enable modification of the factory configuration.
Select Edit » Enable Factory Edit. It is strongly recommended that
you do not modify the factory default configuration. If you choose to
modify the factory configuration, you should first upload it from the
printer, and then save it. This way, you will have a backup copy of the
factory configuration. To disable modification of the factory
configuration, select Edit » Disable Factory Edit.

Making Changes on Menu Tree

1. Using the Displayed Configuration menu at the bottom of the window,
click the drop-down arrow to choose the configuration to change.

2. Expand the submenus until the configuration setting you want to change
displays.

3. Select the menu item you want to change. A selection box surrounds your
choice.

@ LinePrinter+
& Printer Protocol: P-Series
Qrientation: Portrait
&= ZPILPI Select

4. Use the < and > keys to toggle through the available options. (You may
change these keys in the printer database window: select
File » Preferences, then click the Configuration Editor tab.
See page 24.)

@ LinePrinter+
& Printer Protocaol: Epson Fi
Crientation: Portrait
& CPILPI Select
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Menu Editor
£ Menu Editor: Printer Protocol

Factory (0) Edit Off Configuration 1 Configuration 2
P-Series -
) Hidden

Configuration 3 Configuration 4 Configuration 5

Configuration 6 Configuration 7 Configuration &

HideAll || CopyFact | Ok || cCancel || appy |

Figure 53. Menu Editor

Double-click any menu item to open the Menu Editor window. Figure 53
shows the screen you see when you double-click the Printer Protocol option.
By using the Menu Editor, you may view and adjust the settings of all nine of
the printer configurations at once. To change a setting, click the drop-down
arrow underneath the corresponding configuration and choose an option.
Grayed out configuration names and settings do not exist; you must create
the configuration before you can edit it (see page 74).

To hide a menu item in the operator panel, select Hidden under a
configuration. Click Hide All to hide this menu item in all configurations. (For
more information on hiding, see page 77.)

Select Copy Fact (1-8) to set all configurations to the same value as the
factory or user-defined configuration currently selected under the
Edit » Copy From: menu in the Configuration Editor (see page 74).

Click Cancel to exit the Menu Editor without saving your changes.
Click Apply to save your changes without exiting the Menu Editor.
Click OK to save your changes and exit the Menu Editor.

Deleting Configurations

To delete any of the configurations (except the Factory Configuration), select
Edit » Delete » and choose the number of the configuration to be deleted.

Naming Configurations

You may name any of the eight user-defined configurations using an
alphanumeric string of 1 to 15 characters. Select Edit » Names to open the
Edit Configuration Names window.

Choose the configuration you want to name, then click OK to assign the name
change, Cancel to exit this window without saving your changes, or Reset to
restore the original configuration numbers.
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Hiding/Unhiding Menu ltems

4., Configuration Editor [Mew_Printer]

File Edit View Migration

ECIEEE

QOFFLINE
Protect Configs.: Disable
= HOST INTERFACE: Auto Switching
ACTIME IGP EMUL: IGPIPGL
@ EMULATION
@ CTHI: Standard
& |PDS
&= |GPGL
@ |GPIPGL
@ LinePrinter+
Q- Printer Protocol:
@ P-Series
B P-Series X0
@ Serial Matrix
® Proprinter XL
@ Fnson F
Displayed Language Displayed Configuration Power-Up Configuration
| English ~| |1 ~ | | Factory

Figure 54. Hiding a Menu Item

The Configuration Editor allows you to hide menus to make the operator
panel menus easier to use, or to restrict printer operators from accessing
certain printer configuration menu items. If you choose to hide a menu item in
the Configuration Editor, the hidden menu item still loads into the printer when
the configuration downloads to it. However, the hidden menu item does not
appear on the printer’s front panel.

The Configuration Editor displays hidden menus in gray on the menu tree.
When a menu item is hidden, all of its sub-menus are hidden as well. In
Figure 54, the Printer Protocol menu item is hidden. The Printer Protocol
menu item, as well as its sub-menus (P-Series, P-Series XQ, etc.) cannot be
changed from the printer’s operator panel.

Depending upon the active emulation, active interface, or hardware
attached to the printer, some menu items cannot be hidden on the

printer front panel, even though they may be defined as “hidden” in the
PMU.

You can still change hidden menu items using the Menu Editor.
You can hide or unhide menu items in three ways:

1. Inthe menu bar, select View » Hide/Unhide Menus. With this menu

option, you may hide or unhide individual items, sub-menus or the entire
configuration.

Using the Menu Editor. See page 76.

Using the keyboard. From the menu tree, select a menu item. A selection
box appears around the selected menu item. Press H to hide the menu
item or U to unhide the menu item. (To change these keys, select

File » Preferences in the printer database window. See page 24.)
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Saving Configuration Files

Normally, your printer can save only nine configurations in its memory. You
change these configurations through the printer’'s operator panel. However,
using the PMU, you can store a nearly unlimited number of configurations on
your host computer.

Once you have made your changes, you can save your configurations as a
.cfg file on your local hard drive. This way, you can open any set of
configurations from your host computer and download them into your printer
quickly and easily.

To save configurations to your local hard drive, select File » Save As. Be sure
to save your configuration as a .cfg file.

Opening Configuration Files

To open a configuration file, select File » Open. The Configuration Editor
loads the settings from the file you choose.

Remember, these settings do not affect the current configuration or the active
printer status until the configurations are downloaded to the printer.

NOTE: The Configuration Editor displays only one configuration file at a time.
Be sure to save any changes before opening another configuration file.

Downloading Configurations

You may use the Configuration Editor to download into your printer any
configurations you have created. Open the configuration file you want to use,
then select File » Download To Printer to send individual configurations, all
configurations, or just the configuration names.

Downloading a configuration overwrites the corresponding configuration
currently stored in the printer. If you want to save the configurations currently
stored in the printer before overwriting them, upload them into the
Configuration Editor first, and then save them as a .cfg file on your local hard
drive.

NOTE: Be sure to calibrate your thermal printer after you download a
configuration to it. See “Running Auto Calibrate” in the printer’s
User’s Manual.

Uploading Configurations

The Configuration Editor can upload configurations from a printer. Select
File » Upload From Printer. Once the configurations upload, you can save
them to a file. Now you can select another printer from the database and
upload its configurations. The PMU prompts you to save the previously
uploaded configuration before the new configuration uploads.
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Migration

Over time, menus and functions changed to reflect the new features of the
printers. Some printer features have been removed to provide better or more
complete printer features. Older saved configurations may have used these
removed features or contain settings that no longer exist or have been
modified in new printer firmware. This can cause potential problems when
downloading new printer firmware while preserving previously saved
configurations if the saved settings are not analyzed and adjusted to work
with the new firmware. This analysis and adjustment has been summarized
into one word: migration.

Transferring Saved Settings

Original Method

To ensure that your settings from the saved configuration are set correctly in
the printer: print out the old configurations, download the configurations to the
printer, print out the new configurations, and compare the old settings with the
new settings.

If you need to make changes: upload the configurations to the Configuration
Editor, make changes, and re-download to the printer.

Enhanced Method

Using the migration utility in the Configuration Editor, all these things can be
done without having to download the configurations to the printer until you
know they are correct. No migrated settings will be downloaded to your printer
until you download them. This way you can run the migration, view the results,
view the report, and make any necessary changes without affecting your
saved configurations or the configurations in the printer.
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How To Use The Migration Utility
STEP 1:

Load the configurations settings that need to be migrated into the
Configuration Editor before using the migration utility.

Migration Limitations

Only attempt to migrate saved configuration settings from printers of the same
model type and the same emulations. An example of a different printer model
type is a thermal printer configuration to a line matrix printer.

The printer that you are going to migrate the settings to should be a superset
of or contain the same emulations as the saved configurations. For example,
migrate saved settings that contain an ANSI emulation on a line matrix printer
to another line matrix printer that contains ANSI and PGL. Do not migrate
these same saved settings to a line matrix printer that does not contain ANSI.
The migration utility does not prevent you from doing this, but the results
would be useless and could cause problems if the migrated configurations
were downloaded and then loaded on a different printer type.

Make sure the printer model type and emulations of the saved
configurations match the printer model type and emulations of the
printer you want to migrate the settings to before attempting to migrate
the saved settings.

Loading Configuration Settings

The configuration settings to migrate can be opened using the Configuration
Editor in the following ways:
Loading From a File

Click the & (open configuration file) button or select File » Open. Choose
your configuration file and then click OK.

Loading From a Printer

Select a printer in the printer database. Click the ﬁ (upload configuration)
button or select the File » Upload From Printer to upload the settings.

STEP 2:

Select a printer and begin the migration of the saved configuration
settings.

Select a Printer to Use for Migration

Select a printer in the printer database. The printer you select must have new
printer firmware. If it does not, exit the Configuration Editor and download new
firmware to the selected printer (see “File Download” on page 87), then select
the printer in the printer database.
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Start the Migration

Click the ggj (migrate) button or select Migration » Run Migration. Several
messages will appear in the bottom left corner of the Configuration Editor that
indicate the progress of the migration.

STEP 3:

View the results using the Configuration Editor.
The results will display graphically in the Configuration Editor.

Several different icons will display depending on the migration. Hover the
pointer over an icon to display a short description. A icon can represent
several types of changes. The migration report details these changes
(page 82).

Select Migration » View Results to see the migration results.
This menu has the following submenus:

Original Configurations
All Menus: Displays the original configuration settings with the menus that
were removed from the original configurations.

Removed Menus: Displays only the menus that were removed from the
original configurations.

Migrated Configurations

All Menus: Displays the migrated configuration settings including all of the
menus that were modified.

Modified Menus: Displays only the menus that were modified by the
migration of the saved settings.

If you select Modified Menus and then select View » Expand Tree, all of the
menus that were affected by the migration will display in a simplified view.

Migration Icon Definitions

(a:k) Indicates a new menu or a new set of menus.

€D Indicates that the menu previously existed in the saved configurations and
was added to another menu.

© Indicates that the menu previously existed in the saved configurations and
was moved to another menu, or removed from the current menu but still exists
in the saved configurations.

¢ Indicates that the menu was completely removed from the saved
configurations.

h Indicates that this menu or a submenu has changed. The change can be
various things such as range or increment.

A\ Indicates that additional selections have been added to this menu.
A\ Indicates that selections have been removed from this menu.

ﬁ Indicates that this menu has been replaced with another menu or the
menu definition has changed.
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STEP 4:

View the results using the Migration Report Viewer.

Select Migration » View Report or double-click the @ Migration Report
icon (located at the top of the migrated configurations display) to open the
Migration Report Viewer.

The Migration Report Viewer displays a detailed textual report of the
information that displays graphically in the Configuration Editor. Use the
Migration Report Viewer to view, save, or print the report.

NOTE: It is recommended to use landscape mode when printing the
migration report.

The report contains the following types of messages:

Informational Messages: Menu settings that migrated without problems.
They display to inform you that there was a change during the migration.

Warning Messages: Menu settings that attempted to migrate to the new

configurations and were changed. Analyze these settings to determine if they

are desirable.

Intervention Messages: Menu settings that attempted to migrate to the new
configurations and were changed. Analyze these settings to determine if they

are desirable.

You must resolve intervention messages, or the printer may not operate

properly.

STEP 5:

Post-migration.

After you review the migrated configuration, save, delete, or download the
migrated configuration file to one or more printers using the PMU.
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Flash File Manager

4. Flash File Manager

Printer List Refresh File List

Warehouse - FFS Info Not Loaded | Get File Info

Manufacturing - FFS Info Not Loaded
Office - FFS Info Not Loaded
Lab - FFS Info Hot Loaded

FFS information not available for Warehouse®, use "Get File Info’ to upload.

Figure 55. Flash File Manager Window

With the Flash File Manager, you can view a list of the unprotected files
loaded in the printer’s flash memory. You can upload the files to the host
computer, save them for backup, and download them to another printer. You
can also delete the files.

Select Applications » Flash File Manager or click the @ (flash file
manager) button. See Figure 55.

The Printer List pane displays a list of printers that are selected in the printer
database. If you select one printer, it appears alone in the list. If you select a
folder, all active printers in the folder appear.

If you return to the printer database and select another printer or folder, click
Refresh to update the Flash File Manager and display the newly selected
printer(s).

NOTE: Cloned printers or different folders that link to the same printer do not
display. Only the original printer displays.
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Get File Info

Select a printer, and then click Get File Info to see a list of the unprotected
files loaded in the printer’s flash memory. Progress displays on the status bar
at the bottom of the window. After you retrieve the flash memory information,
the files appear in the File List pane. See Figure 56.

When complete, select another printer and click Get File Info to view its flash
memory information.

You can only view the flash memory information from one printer at a time,
but the Flash File Manager remembers what information has been retrieved.
For printers that have not had flash memory information loaded, the message
FFS (Flash File System) Info Not Loaded displays. See Figure 56.

NOTE: Although you have retrieved the flash memory information, the files
have not been uploaded. Notice the message data not loaded. To
upload the files, see “Upload” on page 85.

4. Flash File Manager

Printer List Refresh File List

Warehouse - Files found: 5 | Get File Info 9167 4.sf, 57858 bytes, data not loaded.

Manufacturing - FFS Info Not Loaded 00249.sf, 96922 hytes, data not loaded.
Office - Files found: 10 91059.sf, 56200 ytes, data not loaded.
Lah - FFS Info Hot Loaded —— 91060.sf, 55938 Intes, data not loaded.

Upload 9167 1.sf, 58130 bytes, data not loaded.

01880.sf, 70330 Iytes, data not loaded.

Delete 93008.5f, 57282 bytes, data not loaded.

’—Dm ote & Optimize | 03099.5F, 57282 bytes, data not loaded.
; 04072.5f, 107658 hytes, data not loaded.

94079.s1, 73346 vtes, data not loaded.

Last status for "Office’ - Get File Info Completed

Figure 56. Get File Info
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Upload

To upload unprotected files, select a printer, and then select the files you want
to upload from the File List. Click Upload to upload the unprotected files from
the flash memory. Progress displays on the status bar at the bottom of the
window.

After the files upload, they appear selected in the File List pane. See
Figure 57. Click Save As to save all the files together as one downloadable
file. Save the file with a .pff file extension.

& Flash File Manager

Printer List Refresh File List

Warehouse - Files found: 5 | Get File Info 91674.51, 57858 ntes, data loaded.
Manufacturing - FFS Info Not Loaded 90249.sf, 96922 bytes, data loaded.
Office - Getting File Data... 91059.sf, 56290 ytes, data loaded.
Lab - FFS Info Not Loaded —— |91060.sT, 55938 hytes, data loaded.

91671.5f, 52130 Iytes, data loaded.
91889.sf, 70330 bytes, data loaded.
Delete 93098.sf, 57282 hytes, data loaded.
’W 93000.sf, 57282 Mytes, data loaded.
; 94072.5f, 107658 hytes, data loaded,
Save s 94079.5f, 73316 bytes, data loaded.

Last status for "Office’ - Upload Completed

Figure 57. Uploaded Flash Files
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Or, you may use the Shift or Ctrl key to select single or multiple files.
See Figure 58. This way, only the selected files will save to the .pff file when
you click Save As.

NOTE: You can save only uploaded files to a downloadable file.

4. Flash File Manager

Printer List Refresh File List

Warehouse - Files found: 5 | Get File Info 91674.sf, 57858 bytes, data loaded.

Manufacturing - FFS Info Not Loaded 90249.sf, 96922 hytes, data loaded.
Office - Getting File Data... 91059.51, 56290 ytes, data loaded.
Lab - FFS Info Hot Loaded —— [91060.sf, 55938 ytes, data loaded.
9167 1.sf, 58130 hytes, data loaded.

91889.5f, 70330 bytes, data loaded.
Delete 93008.5f, 57282 Iytes, data loaded,
’—Dm ote & Optimize | £3099.5f, 57282 bytes, data loaded.
; 94072.5f, 107658 bytes, data loaded.
Save s 04079.5, 73316 bytes, data loaded.

Last status for "Office’ - Upload Completed

Figure 58. Selecting Multiple Files

Delete And Optimize

You can not undo a flash file deletion.

You can erase files from the printer’s flash memory. Select the files you want
to delete from the File List, then click Delete. To download files back to the
flash memory, see “File Download” on page 87.

Once you have deleted files, the flash memory is not optimized until you click
Optimize. Optimizing reclaims flash space from deleted flash files.

NOTE: The printer reboots after you Optimize.

To delete and optimize in one step, select the files you want to delete from the
File List, then click Delete & Optimize.
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File Download

NOTE: The terms download and upload as used here and in the software
indicate the printer’s point of view. Therefore, when you download a
file, you are sending information to the printer (the printer downloads).
When you upload a file, you are receiving information from the printer
(the printer uploads).

The File Download application allows you to download all file types (program
files, configuration files, and flash files) to either a single printer or to a group
of printers.

To download a file to a single printer, insert a (Download file) icon below
the printer (one level lower than the printer). To download a file to a group of
printers, insert the Download file icon on the same level as the printers (in the
same folder containing the printers). Use the printer database and insert
additional Download file icons to download as many files to as many printers
as you want.

NOTE: If you open a printer database that was saved using a previous
version of the PMU, alll icons will change to ([ icons.

After you insert Download files, you must define them:

1. Double-click @ New Download File. The Define Download File dialog
box opens. See Figure 59.

Click Browse. The Open dialog box opens.

Navigate to a program (firmware), configuration, or flash file, select i,
then click Open.

4. To make sure you have defined a valid file, click Test to test the file. A
message displays confirming whether or not you have defined a valid file.
Click OK to close the Download File Test window.

5. When you are finished, click OK. The database displays the path and
name of the program, configuration, or flash file.

Define Download File E |

This can be a printer program file, configuration file, or flash file.
It can he a software repasitory (CD or directond.

Download files are selected according to their hierarchical relationship to
the printer receiing the download files.

Mew Download File Browse

Test OK Cancel

Figure 59. Define Download File
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£ .File Download

Printar | Fitrware | Restore Config] Restare Flash| Canfig File| Flash Files]
Area 1 (10.224.2.86)
Area 2 (10.224.2.96)
Vending Room (10.224.2.95)
Conference Room (10.223.2.85)

ERI=E
EOOC
LYY
Hsl==
=D&

| Start || Update List |

Figure 60. File Download

After you define Download files in your database, you must download them to
your printer for them to affect the active print state.

NOTE: Each emulation used by the printer has its own list of valid flash files it
can use. Refer to the appropriate Programmer’s Reference Manual
for details about valid flash files.

To download a file that is on the same level or one level lower than the target
printer on your database tree, select the printer to receive the download and
select Applications » File Download. The File Download dialog box displays
the printers receiving the files and the types of files that will be sent. See
Figure 60.

NOTE: If you later select a different printer in the printer database without
closing the File Download dialog box, click Update List to update the
list of printers.

Whenever a printer downloads a program (firmware) file, the configurations
and flash memory are erased. You can choose whether or not to restore the
configurations and/or flash memory to what was previously loaded. Check or
uncheck the Restore Config check box for configurations and/or the Restore
Flash check box for flash files. By default, the configurations and flash
memory will restore.

If you uncheck Restore Config or Restore Flash, the configurations or
flash memory will erase when you initiate a program file download.

NOTE: If a download fails due to a power interrupt or a severed connection, the
configurations and flash files will be lost and will not restore. You can
still restore the printer using the recovery file, but only if Restore Config
and/or Restore Flash was checked. See “Recovery File” on page 97.

If you are downloading a program file and flash files, the Flash Files and
Restore Flash check boxes will be checked. The flash files will restore, but
they will be overwritten if the new flash files you are downloading have the
same name.

NOTE: You can double-click a field name (e.g., Firmware, Config File, etc.) to
check or uncheck the check boxes for all displayed printers at once.



File Download

IMPORTANT

4. File Download

Area 1({10.224.2 86): - Session message =» Connecting. - Please wait...

frea 2 (10.224.2.96): Presenving: saving flash file => 90249.sf

Vending Room {10.224.2.95): Preserving: saving flash file => 9167 1.sf

Conference Room {10.224.2.37): Uploading: configurations => Bytes uploaded = 63797

Figure 61. Download in Progress

Confirm that the correct files will be sent to the appropriate printers. Close the
dialog box to cancel the download and start over.

Click Start to begin the download. Once the download is in progress, click
Abort or close the dialog box to abort the download. See Figure 61.

Aborting a download may leave the printer in an unstable state.

NOTE: Be sure to calibrate your thermal printer after you download a
configuration to it. See “Running Auto Calibrate” in the printer’s
User’s Manual.

You can also download a series of files to several printers at once using
folders. Select a folder and select Applications » File Download. All of the
appropriate files inside the selected folder download to all of the printers
inside that folder.

NOTE: Downloading a configuration file does not immediately update the
printer’s active configuration. You must activate a downloaded
configuration using the Load Config. setting in the printer’s operator
panel. See the printer's User’'s Manual for details.

See page 90 for examples of using the printer database and the File
Download application to download files.
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Downloading Examples

Figure 62 shows a sample printer database.

File Edit View Applications Status LUilkties Help

=B e o ][R]0 | % || @] =
=] Clsample.pdb
@ =5 Building A
@ £ Manufacturing
(D] caPrinter Software A.prg
@ CAManufacturing Confins.cfo
@ @ET_—:D Area 1 dhermal) OMLIME Rbn =% E-MET READY
(D] c:iFonts.pff
@E T= Area 2 {line matriz) OMLINE PGLRIBBOM LIFE 98%
@ =3 Administration Office
(D] coPrinter Sofware B.prg
@ @E‘Jending Room {line matrix ORLINE  IPDS:RIBEBOM LIFE 99%
(0] cwending Configs.cfg
(D] coFonts.pi
@guau Conference Room (thermal) OMNLINE:ETHERMETMN GLILP+
@ =] Building B
@ =] Building C

@ @ @ = & ¢

Status and Error Log:

Figure 62. Sample Database

In the sample printer database, the printers are organized according to
different parts of the building. Each area contains its own printers and
Download files.

In the Manufacturing folder, two printers share the same program and

configuration Download files, the Area 1 printer has a flash Download file (in
this example, a fonts file), and the Area 2 printer has no flash Download file.

In the Administration Office folder, two printers share a program Download
file, the Vending Room printer has a configuration and a flash Download file,
and the Conference Room printer has no configuration or flash Download file.

The Building B and Building C folders are collapsed.
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In this example, the user selected the Conference Room printer, then
selected Applications » File Download or clicked the £ (file download)
button. The File Download dialog box opens. See Figure 63.

£ File Download

Printer | Firrmwvare | Festore Conﬂg|Resture Flash| Config File| Flash Files|
Conference Room (10.223.2.85) ] [v] vl [ [
| Stat | | Update List |

Figure 63. File Download: Conference Room Printer

The Conference Room printer will download a program (firmware) file, and the
configurations and flash memory will restore

If you uncheck Restore Config or Restore Flash, the configurations or
flash memory will erase when you initiate a program file download.
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Example 2

In this example, the user selected the Vending Room printer, then selected
Applications » File Download or clicked the @ (file download) button. The
File Download dialog box opens. See Figure 64.

£ File Download

Printer | Firrmwvare |Restore C...|Resture FI...| Config File | Flash Files |
hvending Raoaorm (10.224.2.95) [v] [} [v] [v] [v]
Stat | | Update List |

Figure 64. File Download: Vending Room Printer

The Vending Room printer will download a program (firmware), configuration,
and flash file, and the flash memory will be restored.



File Download

4. \Ipdate Properties for Yending Room

Summary

Dovwnload Program File: Yes
File: ¢:\Printer Software B.pryg
Restore User Files: Yes
Restore Configuration: No
Download User Files: Yes
l: ¢:\Fonts.pff
Dovwnlead Configuration: Yes
File: € :\Wending Configs.cfyg

Configuration Download

C:Nending Configs.cfg v|| Settings |

| ol || Cancel |

Figure 65. Update Properties for the Vending Room Printer

To see a summary of the files the printer will download, double-click the
printer or select the printer and click Properties. The Update Properties
dialog box opens. See Figure 65.

In this example, the Vending Room printer will download the Printer
Software B.prg program file, the Vending Configs.cfg configuration file, and
the Fonts.pff flash file.
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Configuration Download Settings E |

Configurations

Hame: Download: Power-Lp:
Factory Default ¥ ]

1 v

2 v (g

3 v o

4 v il

5 v )

6 v o

7 v [

8 v o

OK Cancel

Figure 66. Configuration Download Settings

Since the printer will download a configuration file, you can click Settings to
open the Configuration Download Settings dialog box. See Figure 65.

You can select or deselect specific configurations within the configuration file
you want to download. Only the selected configurations will download. You
can also select which of the configurations will be set as the Power-Up
configuration.

In this example, the printer will download all configurations, and the Power-Up
configuration will be set to configuration 4.
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Example 3

In this example, the user selected the Manufacturing folder, then selected
Applications » File Download or clicked the Eﬂ (file download) button. The
File Download dialog box opens. See Figure 67.

£ File Download

Printer | Firrmwvare | Festore Conﬂg| Restare Flash| Config File| Flash Files|
frea 1 (10.224.2 86) v [l ] ] v
Area 2 (10.224.2 98) v [ v [v] [
Stat | | Update List |

Figure 67. File Download: Manufacturing

In this example, the Area 1 and Area 2 printers will download the same
program (firmware) file and a configuration file, since both files are in the
same folder as the two printers (see Figure 62). In addition, the Area 1 printer
will download a flash file.

Both printers will have their flash memories restored.
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Example 4

In this example, the user selected the Building A folder, then selected

Applications » File Download or clicked the Eﬁ (file download) button. The

File Download dialog box opens. See Figure 68.

£ File Download

Printer | Firrmwvare | Festore Conﬂg| Restare Flash| Config File| Flash Files|

Area 1 (10.224.2.86) v _] v v v
Area 2 (10.224.2 98) v [ v [v] [
Vending Room ¢10.224.2 95) v [ V] V] V]
Conference Room (10.223.2.85) ] [v] Vi [ [

| Stat | | Update List |

Figure 68. File Download: Manufacturing and Administrative Office

In this example (see Figure 62):

» The Area 1 and Area 2 printers will download the same program
(firmware) and configuration files, and their flash memories will be
restored.

* The Area 1 printer will download a flash file.

» The Vending Room and Conference Room printers will download the
same program file.

* The Vending Room printer will download a configuration and a flash file,
and its flash memory will be restored.

» The Conference Room printer will not download a flash or configuration
file, but its configurations and flash memory will be restored.

IMPORTANT  Make sure the same printer is not listed more than once in the File
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Recovery File

Whenever a printer downloads a program (firmware) file, the configurations
and flash memory are erased. You can choose to restore the configurations
and/or flash memory, but if during the download the power interrupts or the
connection severs, the files will be lost and will not restore.

The PMU makes a recovery file of the configurations and flash memory
before they are erased. The recovery file is located in the PMU’s program
folder.

If a download fails, the Status and Error Log will display the location of the
recovery file. The file is named after the printer name in the printer database,
followed by a .par extension.

The .par file is a compressed zip file, and can be opened by any program that
can uncompress zip files.

The .par archive contains the configuration file, which is named after the
name of the printer in the printer database. The archive also contains the flash
files, which are named exactly as they appeared in the flash memory.

Once you uncompress the .par file, you can add the uncompressed files to
the printer database and download them using File Download to restore the
printer.
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Operator Panel

The PMU includes a virtual operator panel that simulates all the functions of
the actual operator panel on your printer. See Table 2 below which lists the

different virtual operator panels.

Table 2. Virtual Operator Panels

Figure Page Printer

Figure 69 | page 98 | 6500 Series line matrix

Figure 70 | page 99 | 6400 Series line matrix

Figure 71 | page 99 | 6700/4400 Series thermal

The layout of the operator panel changes to visually simulate the printer being
used (line matrix or thermal), but the keys and indicators function as
described on page 100, regardless of the type of printer used.

To access the operator panel, select the appropriate printer from the printer
database and then select Applications » Operator Panel or click the

[2=] (operator panel) button.

Secondary Operator Panel Window
Status Indicator
Operator Keys Message Display
4. Opeiator Panel [Hew_ F"rlnter] |
SCROLL
MENLY MICRO
- ‘REI!.D‘.‘E E-HET/IPDS 100%
SCROLL
CONFIG MICROW £TOP
- - e
LINE FORM  $ET TOP
RETURN ENTER FEED FEED OF FORM CANCEL EJECT START
_— / Disabled [N Busy JWON ——
//
Primary
Operator Keys Disabled/In Progress Indicators

Figure 69. 6500 Series Line Matrix Printer Operator Panel
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Operator Panel Window
Message Display

Operator Keys

&., Operator Panel [Confergnce Room] !E[E
PD_U,EJF READY TWINAX/ASCIT
|
Ready
-
Processing | |
Ling Farm
fvkaniu Seroll 4~ | Enter hicro 4~ | Feed Feed Start Cancel
- Con- Set Top Bect!
Atintlon figuration Seroll W | Retum icro W | ew of Fom Stop Restone

— Disabled [ Busy DN ——

Status Indicator Disabled/In Progress Indicators

Figure 70. 6400 Series Line Matrix Printer Operator Panel

.. Dperator Panel [Thermal P... [E E3

Message Display -

a0

DHLINE
ETHERHET fPGL fLP+

FRENE

Operator Keys

Disabled/In Progress
Indicators

Enable

Figure 71. 6700/4400 Series Thermal Printer Operator Panel
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Primary/Secondary Operator Keys

Clicking the primary and secondary operator keys in the operator panel
causes the printer to perform the same actions as if you were physically
pressing the keys on the printer’s operator panel. For example, when the
printer is online, click the STOP key (6700/6500 Series) or the PAUSE key
(6700/4400 Series) to take the printer offline. Click the START (or PAUSE)
key to place the printer back online.

Some functions require pressing multiple keys at the same time. To simulate
this, hold down the Shift key on your host keyboard as you select each key.
The selected keys change color to indicate that they are part of the multiple
key press. Release the Shift key, and the selected keys on the operator panel
activate as if they were pressed simultaneously.

For example, to unlock the ENTER () key, hold down the Shift key on your
keyboard, then click RETURN and ENTER (6500 Series), T and | (6400
Series), or | and ! (6700/4400 Series). Release the Shift key, and the
ENTER () key unlocks.

NOTE: For an explanation of the functions of each primary and secondary
operator key, see the printer's User’'s Manual.

Message Display

The message display shows what is displayed on the printer's LCD. Use the
message display to configure menu options and read error messages.

Status Indicator

The status indicator displays the current operating mode:
Online mode: The indicator displays bright green.
Offline mode: The indicator displays black.

Fault mode: The indicator flashes.

Disabled Indicator

Normally, when you control the printer via the operator panel, the Disabled
light is off, and the Enable button underneath the status indicator is grayed
out. While the PMU has control of the printer's operator panel, the message
PRINTER UNDER REMOTE CONTROL appears on the printer's LCD to alert
others that the printer is being controlled remotely.

However, if someone presses a key on the printer, the virtual operator panel
disables. The Disabled indicator lights up, and the Enable button activates.
Click the Enable button to give control of the printer back to the virtual
operator panel.

In Progress Indicator

This light flashes when the printer is working on a job or moving paper.



Information Capture

Information Capture

4. |nformation Capture [Area 2]

File Configuration Printout Error Log Directory

CURRENT CONFIGURATION |~
001 File Part Number [See Reference Number)

002 Reference MNuwher 366007

003 DC/PEC V2.05F 07-Jul-05 #3ee004

004 Ec/p7000 VZ.0iD ZZ-Jun-05 #365914

005 EBOOT/PPC VZ.00T Z3-Mar—-05 #365531

006 BUILD CONTENT CT/IPDS,/IGE/CODE V/ASCIT

007 FEATURES ENABLED 365108 [IPDS)

aos 365109 (TN}

009 365107 (ANST)

010 365105 [IGP/CODE V)

011 365122 (ALL LANGUAGES)

012 365126 [DEVELOFMENT)

013 SHUTTLE T¥FPE 1500

014 SHUTTLE PHASE 62 |
11 :
1 [

Figure 72. Information Capture Window

To access the Information Capture application, select a printer from the
printer database and select Applications » Information Capture or click the
(information capture) button. The Information Capture application allows
you to view the configurations or error logs saved in the printer's memory and
save them as a text file to your local hard drive.

Loading a configuration into the Information Capture does NOT change the
active configuration — this is a view only application. If you want to change
the active configuration, use the Configuration Editor (see page 73) or the
operator panel.
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The following are descriptions of the Information Capture menus.

File

Save As: Saves the configuration or error log displayed in the Information
Capture window as a .txt text file on your local hard drive. This .txt file can be
opened in any word processing program.

Print: Prints the text of the information captured to the host computer’s
default printer.

Clear Window: Clears the Information Capture window of any displayed
configurations or error logs.

Close: Closes the Information Capture window.

Configuration Printout

Current/Factory/Power-Up/All/1-8: Choose which configuration you want to
view. If you choose more than one configuration without clearing the window,
each additional configuration adds to the end of the display.

Error Log

All Errors: Displays the printer’s error log.
Clear: Clears all errors from the printer's memory.

NOTE: The printer’s error log and the Status and Error Log at the bottom of
the main printer database window of the PMU are separate. Clearing
the printer’s error log does not clear the Status and Error Log.

Directory

Flash File System: Displays the file system information for your printer.
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Data Validation

4. Data Yalidation Telemetry Yiewer [Hew Prnter]

View
Identifier Failure [ Deviation | Data
B 1 Pass | [5T]O0O[ST]
B12 Pass | [STIO0T[ET]
B1.3 Pass | [STI00ZIST]
L1.3 Pass (Lahel) =
Bz Pass | [ET]O0Z[ET]
B2z Pass | [STIO04[ET]
Bz3 Pass | [STI00SIST]
Lz3 Pass (Label)
B Pass | [ST]O0G[ST]
B3z Pass | [STI007IET]
B33 Pass | [STIODEIST]
La3 Pass (Label)
B4 Pass | [5T]O0E[ST]
B4z Pass | [STIOTOIET]
B43 Pass | [STIOT1IET]
L43 Pass (Label)
B5 1 Pa | [ET]012I5T] =
<k 1 1l

Connection Status: collecting [ Labels Onby [_] Auto Scroll

Figure 73. Data Validation Window

NOTE: To collect telemetry data, the printer's Telemetry Path (in the
VALIDATOR menu) must be set to Network Port. See “Set Telemetry
Path (6700/4400 Series Only)” on page 14.

NOTE: Your screens will contain less data than shown in Figure 73 if
Telemetry Data (in the VALIDATOR menu) is not set to Full Report or
Validation Mode. Your screens will contain less data than shown in
Figure 74 if Telemetry Data is not set to Full Report. See the Online
Data Validator User’s Manual.

Use the Data Validation application for printers equipped with a bar code
validator. Validation data transmits over an ethernet connection to the PMU,
which interprets the data and displays statistical information based on the
data received.

NOTE: Data Validation is printer specific, and not all printer models have
Data Validation support.

To access the Data Validation application, first select a printer from the printer
database that has a bar code validator. Then select Applications » Data
Validation or click the B Data Validation button.

Figure 73 shows an exam-ple of the Data Validation screen after a print job
runs. The printer sends the bar code report to the PMU.
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The Failure column indicates if each bar code passes validation standards. If
one does not, the reason for the failure appears. The Deviation column gives

a graphic representation of the bar code deviation. The Data column indicates
the bar code data.

Check the Labels Only check box to display label information only
(e.g., L1.3, L2.3, L3.3, etc.).

Check the Auto Scroll check box to automatically display the current bar
codes and labels.

For more information about a bar code or label, double-click it (or click it and
select View » Details of Selected Item). Figure 74 shows the details for bar
code 3 on label 4 from Figure 73.

NOTE: You cannot save validation data to a file.

4 Details for B4.3

104

Farameter Yalue
Type 3
ldentifier B4.3
CaptureDate Fridpr04 102510 PST 2003
Frinter Mame Mew_Printer
Frinter Address 10,224,231
Failure Caode 0
Failure Message Pass
Decoded Data [STIO11[ST]
Deviation 0
Symbalogy Code 349
Letter Grade B
Ref Decode true
Decodeability Avg 83 =

Figure 74. Bar Code Details Window
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ODV Quality Wizard

IMPORTANT

IMPORTANT

£. 0DV Quality Wizard [Area 1]

Print Intensity -3 -2 %

Print Speed 6 ips u%

Test Print

Settings Recommendation:
Earcode Code 39 Status:

Figure 75. ODV Quality Wizard Window

NOTE: To use the ODV (Online Data Validation) Quality Wizard, Telemetry
Data (in the VALIDATOR menu) must be set to Full Report or
Validation Mode.

The ODV Quality Wizard is a function that helps you select the best
combination of print speed and print intensity that will produce optimal bar
code output. It displays controls that allow you to select a print speed and a
print intensity.

Click the Test Print button to print and validate a test bar code pattern. Based
on the validation results, the ODV Quality Wizard provides setting
suggestions to optimize the bar code quality.

Do not follow any suggestions if “Barcode Code 39 Status” does not
display “Pass.”

Click OK to save these changes in Configuration 1. Configuration 1 then
becomes the Power-Up configuration (see page 73). Click Cancel to not save
the changes.

Clicking the x| Close button in the upper-right corner functions the
same as clicking OK.

NOTE: If Telemetry Data (in the VALIDATOR menu) is set to Short Report,
then

NOTE: The ODV Quality Wizard is printer specific, and not all printer models
have ODV Quality Wizard support. Printers without ODV Quality
Wizard support display the error message:
Operation not allowed on this type of printer.
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The Speed Keys are single buttons that allow you to perform a specific
operation without having to traverse the printer’s front panel menu structure.
The Speed Keys assist you in performing repetitive functions associated with
printer configuration or maintenance.

To access Speed Keys, select a printer then select Applications »
Speed Keys or click the [E5T] Speed Keys button. See Figure 76.

Changes made using Speed Keys are changed in the printer and saved in
Configuration 1. Configuration 1 then becomes the Power-Up configuration
(see page 73).

NOTE: Speed Keys are printer specific, and not all printer models have
Speed Key support. Printers without Speed Key support display the
error message:

Operation not allowed on this type of printer.

£ Speed Keys [Area 1]

Printout Quality Settings r Yalidator Settings
}r Physical Unit Setup r Media Sensor Calibration |

® Use Inches

' Use Millimeters

Figure 76. The Speed Keys Window
The Speed Keys are grouped according to their use:
e Physical Unit Setup
* Media Sensor Calibration
»  Printout Quality Settings
» Validator Settings

NOTE: For an explanation of the functions the Speed Keys perform, see the
printer's User’s Manual.
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Job Capture

Job Capture is an application that captures host datastreams through a
specified host interface. This aids in debugging and diagnosing printer errors
when working with technical specialists.

£ Job Capture [New_Printer]

File Search View Capture Triggers Options

EEIOE

Length: 0 Row: 1 Column; 1 [0: <EOF> [insert
Port: ParallelE Net Adapter In Capture: OfT [Recerved: 0 |saved: 0

Figure 77. Job Capture Window

To access the Job Capture application, select a printer from the printer
database and select Applications » Job Capture or click the

fﬁ (job capture) button.

Job Capture allows you to capture, modify, analyze, and save information to a
file.

To use Job Capture:

1. Be sure the computer running the PMU is connected to the printer using
the diagnostic port selected under PRINTER MGMT in the SERVICE
menu (6400 Series) or in the Factory menu (6700/4400 Series), or using
the ethernet port selected in the PRINTER MANAGEMENT PORT in the
PRINTER CONTROL menu (6500 Series). To access the SERVICE or
Factory menu, see “Printer Setup” on page 12.

2. Select Capture » Data From and then select the interface the printer will
use to receive the file you want to capture.

3. Select Capture » Start to place the PMU in capture mode. The interface
sends the information to the terminal window until you turn off capture
mode.

4. Select Capture » Stop to stop the capture.

The capture window displays the capture information in three formats: Text,
Hex, and Capstone. Select View » Display Format to choose the information
format. Select View » Display Control Codes to view the control codes
embedded in the file.
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Once you capture the file and choose the display options, you can save the
information to your local hard drive. Select File » Save As and enter a file
name. The PMU saves the captured information as a .cap text file. You can
open a .cap file in any word processing program.

Select File » Clear Window to clear all capture information from the terminal
window. Select File » Quit to close the Job Capture application.

Job Capture Features

File

Open
Opens a Job Capture file.

Save/Save As

You can save captured data to disk for later reference or for use in another
program. To save the captured data, select File » Save or File » Save As.
Data from Twinax sources can be saved in either Hex or Capstone format.

Clear Window

To erase captured data, select File » Clear Window. If you have not already
saved the data, a prompt appears and asks if the data should be erased
without saving.

Quit

Exits the Job Capture program.



Job Capture

Search
Learch |
Data to Find
pri nt er -
0 7R B9 BE 74 BSH T2
Options Direction
[_] lgnore Case @ Forward
" Backward
Scope Origin
® Global @ From Cursor
" Entire Scope
OK Cancel

Figure 78. Search Captured Data

Search Captured Data

You can search captured data for specific sequences. Select Search »
Search Captured Data. Enter the data as a hex or text string. Click OK, and
the matching data highlights.

To further refine your search, you can choose whether or not to ignore the
case, and specify the direction and origin of the search. If you have text
selected, you can also choose whether to search the selected text or all text
(Global). Use the down arrow in the upper-right corner to see a history of your
searches. See Figure 78.

Search Again

To continue searching, click Search Again. A message appears if the search
is unsuccessful.

View

Display Format

Data displays in three ways:
o Text

* Hex

» Capstone

Capstone is for Coax/Twinax applications. You can edit Capstone data in Hex
mode only.
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Display Command Codes

Normal: Codes do not display.
Dots: Dots represent the code.

Mnemonics: Codes display within brackets. For example, Line Feed is
<LF>, Carriage Return is <CR>, etc.

Capture

Start I
Starts the capture. You can also use the ’. | (start capture) button.

Stop

Stops the capture. You can also use the | (stop capture) button.

Data From

Selects the capture source of data. Options include:

Parallel/E-Net Adapter In
Serial In

Serial Out

Twinax Host Data

Coax Host Data

C/T Base Emulation

PCI Ethernet In

USB In

NOTE: The USB port is available only on 6700 Series printers.

Triggers

A Trigger allows a selective capture of host data. You need to specify two
triggers, a start trigger and an end trigger. Select Triggers » Configure.
See Figure 79.



Job Capture

Configure Trnggers B
Start Trigger

Trigger count: |1 % Bytes saved before start trigger: |0 % [_] lgnore Case

Stop Trigger

Trigger count: |1 % Bytes saved after stop trigger: |0 % [_] lgnore Case

[C] Limit saved data to: : vtes

| ok || cancel |

Figure 79. Configure Triggers Window

Enter triggers as text or hex strings with a maximum length of 256 characters.
Job Capture scans received data for the start trigger sequence. Once found,
data capture begins and continues until Job Capture finds the end trigger.

If you do not set a start trigger, all data is captured when the Job Capture
starts. If you do not set an end trigger, the data will continue to capture until
you stop it.

A second trigger option is a trigger count. You can set Job Capture to start or
stop once it finds a set number of start and/or stop triggers. The window that
displays captured data shows any lines containing start triggers and highlights
the start trigger strings. You can also use the Search feature to search
through captured data.

The Ignore Case check box allows character case to be ignored. Check the
box to search for a string regardless of character case, and the data will
capture once the string is found.

NOTE: You cannot apply triggers to Coax/Twinax and TCP/IPDS jobs.
Options
Disable Printing

Select Options » Disable Printing to capture data without printing.
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You can access your printers using a web browser. You can monitor the
status, open an operator panel, check the configurations, access Speed
Keys, open the ODV Quality Wizard, and access the printer web page.

NOTE: To access your printer using a web browser, you must enable the Web
Server and XML Server services (see page 25). Remember to exit
and restart the PMU to enable the service.

The PMU Web Site URL Address

Open a web browser. In the URL address field, type http://, followed by
the host name (computer name, not case-sensitive) or the host IP address of
the workstation running the PMU, followed by a colon (:), and then the port
number.

For example:

http://1ab21042:8080
or:

http://10.224.5.121:8080

NOTE: Make sure the port number does not conflict with another port number
designated for a different purpose.

Press Enter, and the web page for your designated printer appears. See
Figure 81.

(To find the host name using Windows, right-click Network Neighborhood
on your desktop and select Properties. The Network dialog box opens, and
the computer name appears in the Identification tab. See Figure 80.)

Metwork [viewing mode) HE

Services | Protocaols | &daphers |

YWindows uses the following information bo identify this
| computer on the network.

Computer Mame: |m321 04z

Damnair |DDMAIN

Cloze I (Earize] |

Figure 80. Finding Your Host Name In Windows
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Login To The PMU Web Site

User:

Password: N
Figure 81. The PMU Web Site

By default, three categories of login privileges are available. See Table 3 for a
list of categories and their corresponding user names and passwords.

Table 3. User Login Options

Login Category User name Password
Standard standard standard
Supervisor super super
Administrator admin admin

Type admin for the user name and password, then click Login. The Select
Desired Page web page appears. See Figure 82.

admin is Logged in - Please Select Desived Page

Frinter List Page

Change Fassword Fage

Figure 82. The Select Desired Page Web Page

Changing The User Password

You can change the default password. Click Change Password Page, and
the Change Password web page appears. See Figure 83.

Change Password

New Password: —
Retype Password: |

Change Password

Figure 83. The Change Password Web Page

Enter a new password in the New Password and Retype Password fields,
then Click Change Password. Your password changes and you return to the
Select Desired Page web page.
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The Printer List Page

Click Printer List Page. The Printer List web page appears and lists the same
printers found in the database pane. See Figure 84.

This page will refresh once a minute. Time: 15:11

Sort Printers by | Status (Errors) jﬂl
. ODY [Printer
Frinter Address | Status Message Configuration Operatar)Speed Cuality) Web
D Panel Keys .
Wizard Page
Thermal (Building 4
Thermal|10.224 2 35ERROR (OFFLINEPOWER SAVER Current COpen  DpenCpen Open
MODE
Line Line Matriz (Building B)
Matrix| 02222 PE NI INEETRERNETPGLLP--TENt  [Hpen  CpenCpen Open

Figure 84. The Printer List Web Page

By default, printers are sorted by Status (Errors). You can also sort printers by
Status (Warnings), Status (Online), Address (Ascending), and
Address (Descending).

In the above example, the thermal printer displays an error because it is
offline. Any printer not ready to print displays an error status.

For an explanation of the Printer List Page options, find the option in Table 4
and follow the corresponding reference.

Table 4. Printer List Page Options

Web Page Option

Referen

ce

Configuration

displays the printer’s current configuration

Operator Panel page 98
Speed Keys page 106
ODV Quality Wizard page 105

Printer Web Page

Manual

opens the Ethernet Interface Home Page; refer to
chapter three of the Ethernet Interface User’s

NOTE: Administrators and Supervisors can access all five options. Standard
users can access only Configuration and Printer Web Page.
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Changing User Settings, IP Addresses,
and IP Address Ranges

The PpmLogin.xml file, located in the PMU program directory, contains user
settings and the included/excluded IP addresses and IP address ranges. See
Figure 85.

To modify this file, open it using a text editor.
IMPORTANT  The PpmLogin.xml file should only be modified by expert users.

Incorrect entries in this file could render the Web Server service
unusable.

<tuml wersion="1.0" encoding="UTF-8" 7>
<IDOCTYPE ppmxML {\Wew Source for full doctype. .. )=

- <ppmsMLz
- =LoginDatabases=
<|-- For some user to access the printer information, they need to he
added by userid. -—=
«l-- The IP address of their machine also needs to he authorized. e
- «lserDatabasex
«<l-- L1l the user namwes, their privilege type [(Standard, super, admin)
needs to be added here -

<userid password="standard" privilege="standard">standard</userid=
<userid password="super" privilege="super'>super</userid=>
zuserid password="admin" privilege="admin">admin</userid=

</UserDatabasex
- «<MachineDatabasex=
«l-- TIndividual address can be included or excluded from accessing the
printer information. b
<l-- iphddressIncluded and ipiddressExcluded are used for individual
addresses. =

<ipaddressincluded=10.22.1.121</ipAddressincluded:
<ipAddressExcluded=100.100.100.100</ipAddressExcluded:=
«l-- Uze iphddrezssIncludeRange and its start and end attributes to
define the access range. PN
<ipaddressincludeRange start="00.00.00.00" end="255.255.255.255" />
«<l-- Uze iphddressExcludeRange and its start and end attributes to
define the invalid access range. Sl
<ipAddressExcludeRange start="00.00.00.00" end="00.00.00.1" />
</MachineDatabazex
</LoginDatabasex=
</ pprEhLls

Figure 85. The PpmLogin.xml File
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User Settings
The user name, password, and privilege category are defined in the
<UserDatabase> section of the file.
Password Privilege category User name
- zlserDatabase>
<l-- Rkll the user nsgnes, their privilege type (stgndard, super, admin)
needs to be added hege e

<userid password="standard" privilege="standard">=standard</userid=
<userid password="super" privilege="super'=super</;userid=
zuserd password="admin" priviege="admin">admin</userid=

= /UserDatabasex
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Figure 86. User Login Parameters

Password: Defines the password for the designated user name. When you
change the password using the Change Password web page, this information
updates.

Privilege Category: Defines the privilege for the designated user name. The
available options are: standard, super, and admin.

User name: Defines the user name. You can only change the user name by
modifying this attribute.

You can add additional users by duplicating the following line in the
<UserDatabase> section:

<userid password="standard" privilege="standard">
standard</userid>
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- =MachineDatabasex=

IP Addresses and IP Address Ranges

You can define which IP addresses are available to the PMU for access. Any
IP address not included or defined in the included range will be unavailable to
the PMU. In addition, any IP address excluded or defined in the excluded
range will also be unavailable. The included and excluded IP addresses are
defined in the <MachineDatabase> section of the file.

Included IP Address Included IP Address Range

«l-- Individual addres} can be included oy excluded from accessing the
printer information. T

«<l-- iphddressIncluded|and ipiddressExcluded are used for individual
addre=zzes=s. e \

<ipAddressincluded=10.22.1.121</ipAddressinclufed:
<ipsddressExcluded=100.100.100.100=</ipAddresgExcluded:

<l--

Tse ipAddressIT:ludeRange and its stgrt and end attributes to
define the access ra

e . s |

<ipAddressincludeRange| start="00.00.00.00" end="255.255.255.2558" /=

==iles

U=ze iphddressExcludeRange and its start and end attributes to

define the invalid slzcess range. e
<ipsddressExcludeRange start="00.00.00.00" end="00.00.00.1" /=
=/MachineDatabases | |

Excluded IP Address Excluded IP Address Range

Figure 87. Include/Exclude IP Address Options
Address Included: Defines which IP address to include.
Address Excluded: Defines which IP address to exclude.
Address Include Range: Defines the range of IP addresses to include.
Address Exclude Range: Defines the range of IP addresses to exclude.

You can add additional included/excluded IP addresses or IP address ranges
by duplicating the corresponding lines in the <MachineDatabase> section:

<ipAddressIncluded>10.22.1.121</ipAddressIncluded>
<ipAddressExcluded>100.100.100.100</ipAddressExcluded>

<ipAddressIncludeRange start="00.00.00.00"
end="255.255.255.255"></ipAddressIncludeRange>

<ipAddressExcludeRange start="00.00.00.00"
end="00.00.00.1"></ipAddressExcludeRange>

117



Chapter 3 Web Access

118



Index

A Configuration Printout, 102

Access Method sub-tab, 68 Confﬁgurat?ons, 78 _
Alert Delivery tab, 39 Configurations, downloading, 78, 87
Alert Log, 39 Configure Print Servers, 54
Alert. email. 40 Configure Wireless Printers, 55
Applications Connections tab, 68

Configuration Editor, 73 Copy item in database, 26

Data Validation, 103 Create
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F
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H
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