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Kickstart

�Ad Hoc Project Start-Up

�Structured Project Template

�Elements of a Productive Project Template
�Pre-defined Schema

�Pre-defined Link Strategy, Link Management, and Link Enforcement

�Pre-defined Document Framework

�Pre-defined Attributes and Attribute Types

�Pre-defined Views

�Baselines and Baseline Sets

�Report Generation using RPE

� Infrastructure for enterprise access to DXL scripts
�Central script repository
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How Do YOU Begin A Project in DOORS?

�How did you decide:

�What requirement documents to include in DOORS

� User? System? Subsystem? Component?

�What validation and verification documents to include in DOORS

� User Validation? System Verification? Subsystem Verification? Component 

Verification?

� Test  results?

�What other documents to include in DOORS

�What document/module naming convention to use

� How each document should be organized

�What link convention to use

� Top down? Bottom up?

�Which link module each linkset should reside in

� How to communicate above decisions to rest of project team
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What If…

� All of those decisions were already made for you by 

your process experts and DOORS experts

�Leveraging lessons learned on previous projects

� Your team was able to open a project in DOORS 

where the start-up infrastructure was waiting for you

�Named and organized correctly

�Set up to enforce allowed links and in correct link direction

�Set up to disallow links in the wrong direction and to wrong modules

�Your team could immediately begin capturing/flowing down/linking

requirements and tests
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Project Template - Schema

� Left side reflects requirements 

flowdown from the highest level 

at the top

� Right side reflects tests for 

compliance to requirements

� Lines reflect directional links

� Link color coding reflects link 

categories (requirements, tests, 

etc.)

� Link categories placed into  

separate link modules

�Facilitates accurate traceability
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Project Template – Schema Implementation in DOORS

�Restore archived Project Template to DOORS’

project workspace area, rename Project Template to 

Project Name
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Project Template – Link Strategy/Architecture

� All link 

modules 

placed 

into single 

‘Links’

folder

� Simplifies 

link 

manage-

ment
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Default DOORS Link Strategy 101

� If no link module 

preference defined for 

pairs of formal modules

(via File->Module 

Properties…, Linksets 

tab) – example shows 

preference defined

�User Default Link 

Module is used 

(DOORS Explorer, 

Tools->Options, 

Settings tab) as 

container of linkset
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Default DOORS Link Strategy 101

�Common Use Case:

�Precondition: User has not defined 

link module preference for 

Source/Target module pair

�Precondition: User has not altered 

the ‘User Default Link Module’

default, which is ‘DOORS Links’

�First link attempt between module 

pair results in prompt to user 

�‘Yes’ results in 2nd prompt to user
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Default DOORS Link Strategy 101

�Common Use Case - Result:

�Each individual DOORS folder and project contain a ‘DOORS Links’ link 

module, each containing one or more linksets 
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Default DOORS Link Strategy 101

�Common Use Case - Result:

�Each individual DOORS folder and project contain a ‘DOORS Links’ link 

module, each containing one or more linksets 

�Majority of project’s linksets reside in ‘DOORS Links’ link modules

�Requirements-only traceability impossible to show

�Test-only traceability impossible to show, etc.

�Traceability includes all categories of links, inhibiting role-specific view 

of data

�Requirement links distributed over multiple link modules, reducing 

likelihood of accurate traceability reports

�Same for all link categories (Test, etc.)
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�Prevent default DOORS link module behavior

DOORS Project Jumpstart Checklist
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Project Template – Link Management and Enforcement

�Management 

�Define link module 

preferences for 

Source/Target 

module pairs 
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Project Template – Link Management and Enforcement

�Management 

�Define link module 

preferences for 

Source/Target 

module pairs 

�Make preferences 

Mandatory, not 

able to be 

overridden
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Project Template – Link Management and Enforcement

�Management 

�Define link module 

preferences for 

Source/Target 

module pairs 

�Make preferences 

Mandatory, not 

able to be 

overridden 

�Enforcement –

check ‘Only allow 

outgoing links as 

specified in the 

above list’ box
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Enforcement Encourages Correct Linking

�Window below is displayed to users that try to create 

disallowed links

� Increases likelihood of accurate traceability reports 

for 

�Impact-of-change analysis

�Gap analysis

�Scope creep analysis

�Traceability analysis
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�Prevent default DOORS link module behavior

�Develop/enforce link strategy

DOORS Project Jumpstart Checklist
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Access Rights

�By project roles/groups

�Groups security hole

�Views

�Attributes/Types

IBM Rational Software Conference 2009

18

Access Rights by Project Role

�Project roles associated to ‘Groups’

GROUPS

ITEMS

Database  

Admin

Project 

Admin

Requirement

Author Reviewer
Everyone

Else

Database RMCDA R R R R/None

Folders of  

Projects
RMCDA R R R R/None

Projects RMCDA RC(MDA) R R R/None

Folders of  

Modules
RMCDA RMCDA R R R/None

Formal Modules RMCDA RMCDA RC(MD) RC(MD) R/None

Objects RMCDA RMCDA RCMD RCMD R/None

Protected Views RMCDA RMCDA R R R/None

Attribute/Type  

Definitions
RMCDA RMCDA R R R/None

Link Modules RMCDA RMC RM RM R/None
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�Prevent default DOORS link module behavior

�Develop/enforce link strategy

�Set up project ‘Groups’

�Set up project access rights

�Always grant via ‘Groups’

DOORS Project Jumpstart Checklist
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Access Rights – ‘Groups’ Security Hole

� ‘Groups’ access rights default to RMCDA for Everyone!
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Access Rights – ‘Groups’ Security Hole

� ‘Groups’ access rights default to RMCDA for Everyone!
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Access Rights – ‘Groups’ Security Hole

� ‘Groups’ access rights default to RMCDA for Everyone!
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Access Rights – ‘Groups’ Security Hole

� ‘Groups’ access rights default to RMCDA for Everyone!
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Access Rights – ‘Groups’ Security Hole

� ‘Groups’ access rights default to RMCDA for Everyone!



IBM Rational Software Conference 2009

25

Access Rights – ‘Groups’ Security Hole

� ‘Groups’ access rights default to RMCDA for Everyone!
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Access Rights – ‘Groups’ Security Hole

� ‘Groups’ access rights default to RMCDA for Everyone!
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Access Rights – ‘Groups’ Security Hole

� ‘Groups’ access rights default to RMCDA for Everyone!
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�Prevent default DOORS link module behavior

�Develop/enforce link strategy

�Set up project ‘Groups’

�Set up project access rights

�Always grant via ‘Groups’

�Plug ‘Groups’ security hole

DOORS Project Jumpstart Checklist
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Access Rights – Views

�Private views (View->Manage Views…->Access tab)
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Access Rights – Views

�Custom views
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Access Rights – Views

�Public views
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Access Rights – Views

� ‘Fix’ default access rights for collaborative views

� ‘Inherit from parent’ inherits rights from module
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Access Rights – Views

� ‘Fix’ default access rights for collaborative views

� ‘Inherit from parent’ inherits rights from module
File->Module Properties->Access tab View Access
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Access Rights – Views

� ‘Fix’ default access rights for collaborative views

� ‘Inherit from parent’ inherits rights from module
File->Module Properties->Access tab View Access
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�Prevent default DOORS link module behavior

�Develop/enforce link strategy

�Set up project ‘Groups’

�Set up project access rights

�Always grant via ‘Groups’

�Seal ‘Groups’ security hole

�Set access rights on ‘Groups’

�Set Public views to ‘Inherit from parent’ (ongoing ‘battle’)

DOORS Project Jumpstart Checklist
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Access Rights – Attributes/Types

�Attribute/type consistency/redundancy

Edit->Attributes…
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Access Rights – Attributes/Types

�Attribute consistency/redundancy
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Access Rights – Attributes/Types

�Attribute consistency/redundancy
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Access Rights – Attributes/Types

�Attribute consistency/redundancy

�Secure the Attribute Definition
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Access Rights – Attributes/Types

�Attribute Type consistency/redundancy

Edit->Types…
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Access Rights – Attributes/Types

�Attribute Type consistency/redundancy
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Access Rights – Attributes/Types

�Attribute Type consistency/redundancy

�Secure the Type 

Definition
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�Prevent default DOORS link module behavior

�Develop/enforce link strategy

�Set up project ‘Groups’

�Set up project access rights

�Always grant via ‘Groups’

�Seal ‘Groups’ security hole

�Set access rights on ‘Groups’

�Set Public views to ‘Inherit from parent’ (ongoing ‘battle’)

�Secure Attribute/Type Definitions

�Avoid granting access rights for individuals…

� For Projects/Folders/Modules/Edit Shareable Sections/Attributes/Types/Views

�Avoid access rights at granularity of object

DOORS Project Jumpstart Checklist
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OLEs

�Weigh cost/benefit of 

saving OLEs in history

�Every time OLE is opened, 

gets saved…DOORS can’t 

tell if it’s been changed

�Module size/performance 

impact

�DB will rapidly grow in size

�Very large OLEs impact 

module opening, saving, 

scrolling

Right click DB root, click Properties…
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�Prevent default DOORS link module behavior

�Develop/enforce link strategy

�Set up project ‘Groups’

�Set up project access rights
�Always grant via ‘Groups’

�Seal ‘Groups’ security hole

�Set access rights on ‘Groups’

�Set Public views to ‘Inherit from parent’ (ongoing ‘battle’)

�Secure Attribute/Type Definitions

�Avoid granting access rights for individuals…

� For Projects/Folders/Modules/Edit Shareable Sections/Attributes/Types/Views

�Avoid access rights at granularity of object

�Consider NOT saving OLE objects in attribute history

DOORS Project Jumpstart Checklist
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Project Template – Document Framework

�Example template for a 

Systems Requirements 

Specification

� Incorporate evolving 

business best practices 

into template

�Can discard contents in 

favor of project-preferred 

framework

�Import into module to take 

advantage of other pre-defines in 

module
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�Define document framework/structure

DOORS Project Jumpstart Checklist (continued)
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Project Template – Attribute Types

�Obtain consensus on core Attribute Types across 

business so everyone buys-in, benefits
� Add project-specific Attribute Types during project setup
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�Define document framework/structure

�Define attribute types

DOORS Project Jumpstart Checklist (continued)
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Project Template - Attributes

�Obtain consensus 

on core Attributes 

across business 

so everyone buys-

in, benefits

�Add project-

specific Attributes 

during project 

setup
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�Define document framework/structure

�Define attribute types

�Define attributes

DOORS Project Jumpstart Checklist (continued)
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Project Template - Views

�Universal Views – example: productivity views for 

flowdown, linking

�Place higher level document on left side of screen, lower level on right

�Easy to flowdown requirement

�Entire main column visible in both documents for immediate visual 

confirmation of accuracy of  linked objects and direction
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�Role-specific Views (note color-coding)
�Requirement authors

� Requirements change impact analysis

� Requirements flowdown gap analysis

� Requirements scope creep analysis

� Requirements traceability analysis

� Suspect links 

�Validation & Verification testers

� Requirements change impact to test analysis

� Test gap analysis

� Test scope creep analysis

� Test traceability analysis

� Suspect links

�Reviewers

�Designers

�Project Managers

Project Template - Views

�Marketing

�Quality

�Reliability

�Stakeholder

�Systems

�Subsystems
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Project Template - Views

�View containing Requirements Traceability column 

requires ‘Specific’ link module selection

In DOORS module: Analysis->Wizard…
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�Define document framework/structure

�Define attribute types

�Define attributes

�Define roles

�Define views

DOORS Project Jumpstart Checklist (continued)
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� A baseline is a reviewed and approved deliverable that constitutes an 
agreed basis for further evolution or development, and can be changed 
only through a formal change management procedure.

Baselines

Release 

Version 1.0

Release 

Version 1.1

Release 

Version 1.2

Release 

Version 2.0

Release 

Version 2.1



IBM Rational Software Conference 2009

57

Baselines

� Baseline behavior

� Links function differently

– Links are copied to baseline when linked modules are baselined outside a baseline set

– These “echoed links” can only be followed from baseline to current version of source or target 

module

– No corresponding link from current version to baseline
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Baselines

� Baseline behavior
� Data baselined

� Unidirectional links FROM baseline

TO current version – as current 

version data changes, relationship 

of linked baseline data may change

Baselines
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Baselines and Baseline Sets

� Baseline behavior
� Data baselined

� Unidirectional links FROM baseline

TO current version – as current 

version data changes, relationship 

of linked baseline data may change

Baselines Baseline Sets

� Baseline set behavior
� Snapshot of group of documents 

with relationships intact

� Data baselined

� Links baselined
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Baselines and Baseline Sets – frequent practice

� Normally, module baselines used

� Baseline Sets used much less frequently, if at all

� When Baseline Sets used, typically used once at end of project

Baselines Baseline Sets
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�Define document framework/structure

�Define attribute types

�Define attributes

�Define roles

�Define views

�Define baseline strategy/process

DOORS Project Jumpstart Checklist (continued)
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� Generate complete 

documents 

� Header and footers

� Attribute data

� Table of contents

� Cover Page

� Custom formats data

Report Generation Using RPE – Sample Scenario 
Rational Publishing Engine
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Rational Publishing Engine
Components

63

Document Studio 
for creating 
templates

Launcher for managing 
document production

Reports in multiple formats (e.g. MS Word, PDF, HTML, etc.)

Tool Integrations for 
commanding document 

generation from within tools 
(e.g. DOORS, Tau, Focal 

Point etc.)
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Moderated wiki for sharing templates and knowledge

http://www.ibm.com/developerworks/dwwi/jsp/WSLogin.jsphttp://www.ibm.com/developerworks/dwwi/jsp/WSLogin.jsp
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Guidance on use of RPE
� Advantages over DocExpress (DX)

� Runs on user’s desktop

� Eliminates need for beefy server

� Less fragile

� Does not use clipboard

� 20x faster

� Lower implementation and maintenance costs
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�Define document framework/structure

�Define attribute types

�Define attributes

�Define roles

�Define views

�Define baseline strategy/process

�Define report generation approach/templates

DOORS Project Jumpstart Checklist (continued)
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Productive Project Template

�Now have all elements identified for productive 

Project Template in DOORS

�Pre-defined Schema

�Pre-defined Link Strategy, Link Management, and Link Enforcement

�Pre-defined Document Framework

�Pre-defined Attributes and Attribute Types

�Pre-defined Views

�Groups security hole plugged

�Access rights strategy identified

�Report generation implications built in

�How do we leverage ALL of the infrastructure built-in 

to the Project Template on a new project?
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Productive Project Template

�Restore Project Template for new project

�Pros

� Simple to set up

� Easy to deploy to multiple projects

� All information contained in one file

�Cons

� Can’t include access control settings if archive used in different database
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Productive Project Template

�Schema updates

�Configuration control schema

�Vet all changes through change control board

�Regard as software development project – use same rigor

�Phase-in changes in non destructive manner

�Plan for managing mixed version environment

�Plan for upgrading existing projects
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Enterprise access to DXL scripts

�Allows single instance of scripts to be used by entire 

enterprise

�Host scripts in central script repository (CSR)
�Set DOORS clients to use DOORS remote addins: 

\\hostname.domain.com\DOORS\dxladdins or equivalent

�DOORS remote addins parameter points to CSR
�Edit Windows Registry (Start/Run->regedit) – BE CAREFUL!

� HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS\9.1\Config
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Summary

�Project Template Benefits

�Accelerates project ramp-up via well crafted infrastructure

� Product development less costly, shorter schedule => earlier market window

� Leverage internal DOORS guru expertise on every project

� Lower DOORS proficiency required of typical users

�Consistent Schema and Best Practices across the business

� Eliminates delay of each project developing and implementing their own 

schema

� Reduces learning curve as staff changes across projects

�Consistent language and expectations regarding Attributes

�Accurate Traceability information via enforced Link Architecture

� Products produced have higher quality (fewer defects) 

� Better regulatory compliance

�Business-specific document templates can be immediately leveraged


