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Preface

Welcome to the Commerce:Connection® Suite consisting of 
Commerce:Connection 6.2 and Gentran:Director® 5.4 

This guide provides information to help you understand the order 
of installation and configuration tasks and the information and 
resources you need before installing or upgrading.

This guide assumes that you are familiar with PCs and Microsoft® 
Windows operating system.

Product overview Gentran:Director for Windows comprises data translation, 
process control, and communication components. It is designed 
primarily for the translation and communication of EDI and other 
similar types of data.

Task overview If you are a new customer installing the Commerce:Connection 
Suite for the first time, follow the instructions in Chapter 1, 
Installation for New Customers.

If you are an existing customer upgrading your 
Commerce:Connection Suite, follow the instructions in 
Chapter 2, Upgrade for Existing Customers.
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What You Should Have Received

Product and
documentation

The Commerce:Connection and Gentran:Director products and 
documentation are provided either on CD-ROM or by 
downloading from the Electronic Software Distribution (ESD) 
Portal. 

If you elected to receive CD-ROMs, your package should include 
the following items:

■ Commerce:Connection Suite CD-ROM

■ Commerce:Connection Suite Documentation CD-ROM

■ Gentran:Director CD-ROM product keys (listed on the 
packing slip)

If you did not receive the following items, please contact Sterling 
Commerce at 1-800-GENTRAN or by e-mail at 
pcbasedsupport@stercomm.com. 

If you elected to use the ESD Portal, you will have received 
instructions for accessing the ESD Portal and your product key 
information. You will also need to follow the Downloading from 
the ESD Portal instructions on page 3.

Standards If you have purchased the Application, Forms, or TDF Integration 
software, your package will also include the following:

■ Gentran EDI Standards Installation card

■ Gentran EDI Standards CD-ROM

If you elected to use the ESD Portal, you will not receive a 
standards CD-ROM. Instead, you will need to use the Standards 
Installation card to download the standards.
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Downloading from the ESD Portal

Download the
product .zip file from

the ESD portal

To download the product from the ESD portal: 

1. Find the Gentran:Director product and click Download.
2. In the File Download dialog box, click Save.
3. When the Save As dialog box opens, save the zipped 

product file to the C:\ drive.
4. Unzip the product file.

Download
documentation

.zip file from the
ESD portal

To download the documentation from the ESD portal: 

1. Find Gentran:Director documentation and click Download.
2. In the File Download dialog box, click Save.
3. When the Save As dialog box opens, save the zipped 

documentation file to the C:\ drive.
4. Unzip the documentation file.
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Customer Support

Sterling Commerce provides a full range of customer support. 
Check your maintenance contract for details about the type of 
support you have purchased for your product.

Before contacting
customer support

Before contacting Sterling Commerce Customer Support, review 
the documentation provided with your product. The 
documentation may help you identify or resolve the problem you 
are experiencing.

Ensure that you have the following information ready when you 
contact customer support:

■ Your name and telephone number

■ Your company name

■ Your mailbox number (A mailbox number is assigned to 
customers who have a mailbox on the Sterling Commerce 
network.)

■ Your product name and version number

■ Your computer platform

■ A detailed description of the problem, including any error 
messages

■ What led to the problem

■ What actions you have  taken to try to diagnose or solve the 
problem
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Customer Support
phone numbers

To contact Customer Support by phone, please call the number 
listed below for your location:

Customer Support
Web site

The Sterling Commerce Customer Support Web site contains 
valuable information about getting support for Gentran:Director, 
including the following:

■ Scope of support services 
■ Customer support policies
■ Call prioritizing
■ Customer support phone directory 
■ Access to the Customer Support Forum 

To get to the Customer Support Web site, go to:

www.sterlingcommerce.com

and select Customer Support. 

Location Phone Number
Hours/Days 

Available

U.S. and 
Canada

1-800-GENTRAN 8:00am - 8:00pm
Monday - Friday

Europe +31 (0) 20 504 0603 9:00am - 5:30pm
Monday - Friday

Asia Pacific

Australia 1800 131415 8:30am - 5:30pm 
Sydney time, 
Sydney business 
days

Japan +81-3-5408-8500 9:00am - 5:30pm
Monday - Friday
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Support On Demand The Support On Demand Web site provides access to tools that 
allow you to gain up-to-the-minute information specific to your 
company. It allows you to access additional tools for 
troubleshooting or getting assistance and information about your 
Sterling Commerce software. It also gives you access to a 
knowledge base and case management system 24 hours per 
day, 7 days per week.  Use these online tools to check the status 
of your existing support cases and to open new cases.

To access Support On Demand, select Support On Demand on 
the Customer Support Web page.

Note
If you already have a user account, you can log in at this site. If 
you do not have an account, click the link to request a user 
account and follow the online instructions. Your confirmation will 
be e-mailed after you have registered.

The following table describes the features offered by the Support 
On Demand Web site.

Feature Description

Personal Profile ■ Displays your personal profile and 
allows you to modify your profile 
information.

■ Allows you to change your 
Support On Demand password.

Problem Reports Provides details about all technical 
support cases reported in the last 30 
days.

Report a Case Enables you to submit a technical 
support request for any problem or 
error that you might be experiencing 
with the product(s). 

Continued on next page
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Remote Installations
call for new

customers

With your Gentran:Director package, you have the option of 
consulting a member of the Sterling Commerce Remote 
Installations team on the phone while you complete your 
installation. A member of the Remote Installations team will 
contact you about setting a time to install Gentran:Director.

Note
If you have not heard from a Remote Installations team member 
within a week after receiving your product, please call Sterling 
Commerce Customer Support at 877-432-4300 and select 
option 5 to speak with a Remote Installations analyst and set up 
an appointment. 

Knowledge Base Enables you to troubleshoot problems 
and error messages and search for 
“how to” information.

Documentation Enables you to download the product 
documentation PDF files.

Downloads Allows you to download hot fixes for 
the product.

Solution Subscriber Allows you to register your e-mail 
address to receive notifications about 
solution-specific issues.

Educational 
Services

Allows you to view course descriptions 
and register online for training provided 
by the Sterling Commerce Educational 
Services team.

Feature Description
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Chapter 1

Installation for New Customers

Installation Roadmap

The following table describes the order of tasks to complete. 

Stage Description Section

1 Complete the three pre-installation 
checklists:

■ Hardware requirements

■ Software requirements

■ Trading partner 
information

Note
For instructions on determining the 
software requirements in the 
checklists, see Frequently Asked 
Questions beginning on page 75.

Getting Ready to 
Install on page 11

2 If your system does not have 
MDAC 2.8 installed, install it from 
the Commerce:Connection Suite 
CD-ROM.

Installing 
Microsoft Data 
Access 
Components on 
page 15

3 Install Gentran:Director. Installing 
Gentran:Director 
on page 17

Continued on next page
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4 Set up mailbox profiles. Setting Up 
Mailboxes on 
page 37

5 If you purchased the FTP Option, 
install the FTP Option 
communication scripts.
Otherwise, skip this step.

Installing the 
FTP Option 
Communication 
Scripts on 
page 30

6 If you installed Application 
Integration, Forms Integration, or 
TDF Integration, install the 
Gentran EDI Standards.
Otherwise, skip this step.

See the EDI 
Standards card for 
instructions.

7 Log on to Gentran:Director for the 
first time, using the default user ID 
and password. Change the default 
password. 

Changing the 
Default 
Password on 
page 43

8 Add users to the Gentran:Director 
system.

Adding Users to 
the System on 
page 45

9 Perform validation tests on the 
system.

Validating your 
system on 
page 48

Stage Description Section
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Getting Ready to Install

Before the installation, you must complete several prerequisites, 
such as installing or upgrading any third-party software to meet 
the minimum requirements for Gentran:Director. 

Pre-installation
checklists

The following categories of information need to be verified before 
installing Gentran:Director:

■ Hardware requirements

■ Software requirements

■ Trading partner information

Each of these areas is covered in the pre-installation checklists 
that follow. Complete each checklist and ensure that all 
requirements are met before you install Gentran:Director. 

Note
If you have questions about how to find some of the software 
information, see Frequently Asked Questions beginning on 
page 75.

Hardware
requirements

 

Hardware Requirements

Requirement met? ( )

150 MB free disk space Yes No 

Processor size and speed: See the 
Microsoft documentation or Web site 
for their recommendations for the 
operating system you are using. The 
Microsoft Web site is: 
http://www.microsoft.com.

Yes No 

Continued on next page
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RAM: See the Microsoft Web site for 
their recommendations for the 
operating system you are using. The 
Microsoft Web site is: 
http://www.microsoft.com.

Yes No 

Hayes®-compatible modem with 
MNP or V.42 support with a minimum 
baud rate of 28800 (higher rate 
recommended)
–or–
Dialup connection to an Internet 
Service Provider (ISP) or a LAN 
connection with ports 110 and 25 
open

Note
If you are planning to connect to a 
VAN other than Sterling Information 
Broker and do not know the protocol 
you need, please contact Customer 
Support. See Customer Support on 
page 4.

Yes No 

CD-ROM drive (Required for 
installation, optional for updates.)

Yes No 

DVD drive (Optional for installing 
Standards updates. You can also  
download them from the Sterling 
Commerce Support on Demand 
Web site.)

Yes No 

SVGA color monitor Yes No 

Mouse Yes No 

Hardware Requirements

Requirement met? ( )
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Software
requirements

Software Requirements

Requirement Met? ( )

Operating System:
Must be one of the following operating 
systems, at the version and service 
pack level listed.
■ Windows 2000 Professional, 

v. 5.0, SP4

■ Windows XP Professional, v. 1.0, 
SP2

Yes No 

Microsoft Data Access Components 
(MDAC) v. 2.8 or higher

Note
MDAC v. 2.8 is included on the 
Commerce:Connection Suite product 
CD-ROM. See Installing Microsoft 
Data Access Components on 
page 15 for installation instructions. 
To determine which version of MDAC 
you have, see Frequently Asked 
Questions beginning on page 75.

Yes No 

Microsoft Internet Explorer 5.0 or 
higher

Yes No 
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Trading partner
information

Information to get from your Trading Partner

Information Example
Requirement Met? 

( )

Trading Partner 
Name

ABC Company Yes No 

Document(s) you 
will be trading 
with this partner

850 Purchase Order 
or 810 Invoice

Yes No 

Standards ANSI, UCS, VICS, or 
EDIFACT

Yes No 

Template Version 3020, 3040, or 4010 Yes No 

Trading Partner 
EDI Qualifier

01, 12, 08, or ZZ Yes No 

Trading Partner 
EDI Code

Duns number or 
telephone number

Yes No 
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Installing Microsoft
Data Access

Components

To install the Microsoft Data Access Components v. 2.8, complete 
the following steps. 

Reference
If you are not sure whether you need to install v. 2.8, see How do 
I find out what version of MDAC is running on the computer? 
on page 76

Step Action

1 Turn on your PC and close any open applications.

Note
You may be prompted to reboot after the installation is 
complete.

2 Insert the Commerce:Connection product CD-ROM 
into your CD-ROM drive. 

System response
The Commerce:Connection splash screen is 
displayed. 

3 Navigate to the Mdac folder. 

4 Double-click the file named mdac_typ.exe. 

System response
The MDAC installation program End User License is 
displayed.

5 After reading the license, select the check box and 
click Next. 

System response
The setup program checks for available disk space 
and programs or files on your system that it will 
replace but that are currently in use by another 
program. 

Continued on next page
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Preparing for the
Remote Installations

Call

Once your system meets all the prerequisites, you are ready for 
your installation call with the Remote Installations group. If you 
have not set a date for the installation, please call the Remote 
Installations group at 877-432-4300 (option 5) to speak with a 
Remote Installations analyst and set up an appointment. 
The Remote Installations analyst may request that you fax your 
completed checklists. This allows them to review the checklists 
with you and become familiar with your system and software. The 
analyst will give you the fax number.

6 If Setup finds files that are in use, it will warn you that 
you need to reboot the PC after setup is complete. 
Click Next. 

System response
The Installing the Software screen is displayed.

7 Click Finish.

8 When the MDAC setup is complete, you are prompted 
to choose whether to let the Setup program reboot the 
system immediately or to end Setup and reboot 
manually later. 
Choose the option desired and click Finish.

9 If you chose to have Setup reboot the system now, the 
system is rebooted. Log on to the system as usual. 
If you chose to reboot the system yourself, the Setup 
program exits. 

Step Action
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Installing Gentran:Director 

Make sure you have
the following items

■ The Commerce:Connection Suite CD-ROM and the product 
keys (listed on the packing slip)

Note: 

If you downloaded Gentran:Director 5.4 from the ESD 
Portal, start with Step 4 in the procedure below. Also, 
your product key(s) were included in your e-mail from 
Sterling Commerce.

■ The completed pre-installation checklists from this guide

■ An ISP user ID and password (if applicable)

■ A Local Area Network ID(s) and password(s) (if applicable)

■ If you are upgrading, a Sterling Commerce mailbox ID and 
password

Procedure To install Gentran:Director, complete the following steps:

Step Action

1 Turn on your PC and close any open applications.
Note:
Gentran:Director is designed/licensed to be installed 
to a local drive. If you need to use Terminal Server or 
any other type of remote desktop tool to install or 
implement Gentran:Director, please contact your 
Sterling Commerce Sales Representative to discuss 
other Sterling Commerce products that are designed 
for you environment and needs. The use of any 
remote desktop tool with Gentran:Director could 
produce undesirable results which will impact your 
business and will suspend your support of 
Gentran:Director, from Sterling Commerce Customer 
Support, until the software is loaded in a supportable 
environment.

Continued on next page
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2 Insert the Commerce:Connection Suite product 
CD-ROM into your CD-ROM drive. 

System response
The Commerce:Connection Welcome screen is 
displayed.

Note
If the Welcome screen does not appear, go to step 4.

3 Click Next and go to step 5.

4 From the Start menu, select Run. In the field, type 
“<drive>:\setup” and click OK.

Note
<drive> is the letter associated with your CD-ROM 
drive. For example, D:\setup.

System response
Setup prepares the Wizard that guides you through 
the install program and displays the Welcome screen. 

Continued on next page

Step Action
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5 Click Next.

System response
The Choose Destination Location screen is displayed.

Continued on next page

Step Action
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6 Do you want to install Gentran:Director in the default 
folder?
■ If yes, click Next.

■ If no, click Browse to select the folder. Click OK to 
exit the Browse dialog box, and click Next.

System response
The Select Features screen is displayed.

7 Do the following:
■ Make sure both Commerce:Connection and 

Gentran:Director are selected.

■ If you have purchased the FTP Option, click the 
check box to its left and continue with Step 8. 
Otherwise, continue with Step 10.

Continued on next page

Step Action
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8 Click Next.

System response
The FTP Option Key Entry screen is displayed. 

9 Type the Key that you were assigned by Sterling 
Commerce.

Note
■ If you are installing from a CD-ROM, the key was 

sent to you on the packing list.

■ If you downloaded from the ESD Portal, the key 
was in your e-mail from Sterling Commerce.

Continued on next page

Step Action
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10 Click Next. 

System response
The Select Program Folder name screen is displayed. 

Continued on next page

Step Action
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11 Accept the default program folder name “COMMERCE 
Connection32” and click Next.

System response
The Select Features screen is displayed.

Continued on next page

Step Action
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12 For each feature you have purchased, click the box to 
the left and click Next.

System response
Each feature’s Key Entry screen is displayed, starting 
with the Gentran:Director core components. 

Continued on next page

Step Action
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13 Locate the Keys information that you received from 
Sterling Commerce.

Note
■ If you are installing from a CD-ROM, the key was 

sent to you on the packing list.

■ If you downloaded from the ESD Portal, they key 
was in your e-mail from Sterling Commerce.

For each feature that you have purchased, type the 
key and click Next. 

System response
After you have entered the keys for your features, the 
setup program installs Commerce:Connection and/or 
Gentran:Director and its components. The 
Commerce:Connection for the Internet Setup dialog 
box is displayed. 

Continued on next page

Step Action
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14 Do one of the following:
■ If you want to set up your mailbox, select Run the 

Mailbox Wizard and click Next. The Mailbox 
Wizard Welcome dialog box is displayed. 
Continue with Setting Up Mailboxes on page 37 
and then return here when that is complete.

■ If you do not want to set up your mailbox right 
now, select Skip Mailbox Setup and click Next. 
You can run the Wizard later using Connection 
Manager or Commerce:Mail®.

If you purchased the FTP Option, continue with 
Step 15. Otherwise, continue with Step 16.

15  Click Next.

System response
The setup looks for an existing version of Java.
■ If it finds an existing version, the following screen 

is displayed. 

Make a selection and click Next.

Continued on next page

Step Action
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■ If it does not find an existing version of Java, the 
following dialog is displayed. 

■ If you want to install Java now, click Yes. 

■ If you click No, another dialog is displayed 
telling you that you will need to manually 
install Java. Click OK. 

Note: 
You will not be able to use the FTP Option until a 
version of Java is install and your computer is 
restarted.

16 System response
The following screen is displayed. 

Continued on next page

Step Action



Installing Gentran:Director

28 October 2007 Commerce:Connection Suite/Gentran:Director Getting Started Guide

17 Click Finish. 

System response
If you are not automatically installing Java for the FTP 
Option, your installation is complete. Otherwise, the 
following License Agreement is displayed. 

18 Click Yes.

System response
The Choose Destination Location screen is displayed. 

Continued on next page

Step Action
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19 Keep the default or click Browse to select a new 
folder. Click Next.

System response
The Select Browsers screen is displayed. 

20 Select one of both of the browsers and click Next.

System response
The InstallShield Wizard Complete screen is 
displayed. 

21 Make a selection and click Finish.

Note:
The new version of Java will not be in effect until your 
computer is restarted.

Step Action
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Installing the FTP Option Communication Scripts

Introduction If you have purchased the FTP Option, you must install the 
Communication Scripts after completing the installation of 
Gentran:Director and Commerce:Connection.

Note:

The FTP Option Communication Scripts will only install 
if you have installed Gentran:Director 5.4 and the FTP 
Option.

Make sure you have
the following items

■ The  FTP Option Communication Scripts CD-ROM

Note: 

If you downloaded the Communication Scripts from the 
ESD Portal, start with Step 3 in the procedure below.

Procedure To install Gentran:Director, complete the following steps:

Step Action

1 Insert the FTP Option Communication Scripts 
CD-ROM into your CD-ROM drive. 

System response
The FTP Option Communication Scripts Welcome 
screen is displayed.

Note
If the Welcome screen does not appear, go to Step 3.

2 Click Next and go to Step 4.
Continued on next page
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3 From the Start menu, select Run. In the field, type 
“<drive>:\setup” and click OK.

Note
<drive> is the letter associated with your CD-ROM 
drive. For example, D:\setup.

System response
Setup prepares the wizard that guides you through the 
install program and displays the Welcome screen. 

Continued on next page

Step Action



Installing the FTP Option Communication Scripts

32 October 2007 Commerce:Connection Suite/Gentran:Director Getting Started Guide

4 Click Next.

System response
The Setup Type screen is displayed.

5 If you need to install the communication scripts for all 
of the VANs, select Complete. Continue with Step 8.
Otherwise, select Custom to install selected 
communication scripts. Continue with Step 6.

Continued on next page

Step Action
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6 Click Next.

System response
The Select Features screen is displayed.

Continued on next page

Step Action



Installing the FTP Option Communication Scripts

34 October 2007 Commerce:Connection Suite/Gentran:Director Getting Started Guide

7 Select your VAN(s) and click Next.

System response
The Key entry screen for your selected VAN is 
displayed. 

Continued on next page

Step Action
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8 Enter the Key for your VAN and click Next.

System response
The Ready to Install the Program screen is displayed.

Continued on next page

Step Action
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9 Click Next.

System response
The InstallShield Wizard Complete screen is 
displayed.

10 Click Finish.

Step Action



Setting Up Mailboxes

Commerce:Connection Suite/Gentran:Director Getting Started Guide October 2007 37

Setting Up Mailboxes 

Introduction After Gentran:Director and Commerce:Connection are installed, 
you can set up your mailbox profiles for Commerce:Mail and 
Gentran:Director using the Mailbox Wizard.

What is
Commerce:Mail?

Commerce:Mail is an e-mail application through which you can 
receive e-mail network reports. 

Selecting the
Mailbox Wizard

The Mailbox Wizard allows you to create a mailbox for 
Commerce:Mail and Gentran:Director. You can run the Mailbox 
Wizard from any one of the following locations:

■ The Commerce:Connection for the Internet setup dialog box 
that is displayed during product installation (For more 
information, see page 25.)

■ Connection Manager (For more information, see the 
application’s Online help.)

■ Commerce:Mail (For more information, see the application’s 
Online help.)

Creating mailbox
information

The following procedure describes how to use the Mailbox 
Wizard to create mailbox information within 
Commerce:Connection.

Important
Your mailbox information is assigned by Sterling Commerce 
Customer Support and provided to you on a separate form. If you 
do not have this information, please contact Sterling Commerce 
at 1-800-GENTRAN.
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To create mailbox information, complete the following steps:

Step Action

1 On the Mailbox Wizard Welcome dialog box, type 
the name of your new mailbox in the provided field 
and click Next.

System response
The Personal Information dialog box is displayed. 

Note
Each mailbox name must be unique and can 
contain up to 30 alphanumeric characters.

Continued on next page
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2 Note
Your e-mail address and user name are assigned 
by Sterling Commerce. Please see the Password 
card provided by Sterling Commerce Customer 
Support for more information. 

Do the following:
■ Type your user name in the Name field. 

■ Type your e-mail address in the E-Mail 
address field.

■ Click Next.

System response
The Internet Mail Server dialog box is displayed.

Continued on next page

Step Action
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3 Click the Primary Commerce:Exchange Mail 
Server list box and select one of the following from 
the list:
■ The primary server. This server handles all of 

your inbound and outbound data. Go to 
Step 5.

■ User-Defined. This indicates that you want to 
use an alternate server to send and receive 
data. Continue with Step 4.

Continued on next page

4 Click Next. 

System response
The User-Defined Mail Server dialog box is 
displayed. 

Continued on next page

Step Action
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5 Type the name of your primary Internet mail 
server in the Primary Mail Server field. If 
appropriate, type your secondary Internet mail 
server name in the Secondary Mail Server field.  
Click Next. 

System response
The User ID and Password dialog box is 
displayed. 

Continued on next page

Step Action
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6 Type your post office ID and password in the 
corresponding fields. Your ID and password work 
together to identify you to the mail server when it 
sends and retrieves your messages. Please see 
the Password card for more information. Click 
Next. 

System response
The Save New Mailbox dialog box is displayed.

7 Click Finish. 

System response
Your new mailbox has been created. If you were 
installing Gentran:Director, return to the procedure 
on page 26.

Step Action
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Changing the Default Password

System security is an important ongoing step in controlling who 
can log on to your system and which functions they can access. 
Security ensures the integrity of your data by limiting who can 
make changes to specific areas of the system. 

Recommendation
Change the default password for the system administrator login 
(ADMIN) as soon as possible to minimize security risks.

Complete the following steps to change the default system 
administrator password:

Step Description

1 Log on to Gentran:Director with the default system 
administrator login:
■ From the Start menu, select

Gentran Director\Gentran:Director.

■ Type ADMIN in the User Name box.

■ Type security in the Password box.

■ Click OK to log on to the system.

System response
The Gentran:Director EC Manager window is 
displayed.

2 From the Tools menu, select Preferences.

System response
The Preferences dialog is displayed.

Continued on next page
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3 Select the Change Password tab, as shown below: 

4 In the Old Password field, type security.

5 In the New Password field, type the new password.

6 In the Confirm New Password field, type the new 
password again. 

Note
If the Confirm New Password does not match the 
New Password, you will be prompted to type it 
again.

7 Once complete, click OK to save the changes.

System response
The system is updated and the next time you log on 
to the system using the ADMIN login, you must type 
the new password.

Step Description



Adding Users to the System

Commerce:Connection Suite/Gentran:Director Getting Started Guide October 2007 45

Adding Users to the System

You need to create a Gentran:Director login for anyone who 
needs to use the system.

Note
A new user can be set up only by a user with System 
Administration privileges. If you do not have these privileges, 
have your security administrator complete the setup.

Complete the following steps to add a new user:

Step Action

1 From the Gentran:Director Main Toolbar, select the 
System Configuration icon.

System response
The System Configuration dialog (System tab) is 
displayed.

Continued on next page
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2 Click the Users tab to access user options.

System response
The Users tab is displayed.

3 Click New.

System response
The Security Access dialog is displayed.

4 In the User ID box, type a unique logon identifier for 
this user.

Continued on next page

Step Action
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5 In the User Name box, type the name of this user.

6 In the Password box, type the user’s password.

7 In the Verify Password box, type the user’s 
password again.

8 In the Security Matrix section, select the areas of 
the system that the user needs to access.

9 Click OK to exit the Security Access dialog.

10 Click OK to exit the System Configuration program.

Step Action
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Validating your system

The Gentran:Director online help contains a section that 
describes the procedures you can use to validate your 
installation:  

Step Action

1 Log on to Gentran:Director.

2 Go to the EC Desktop.

3 Click the Help button on the lower right of the screen.

Note
You can also select Help from the main menu bar or 
press F1 at any time to display the online help.

4 Click the Contents tab.

5 Double-click Gentran:Director 5.4.

6 Double-click Getting Started.

7 Double-click Validating and Implementing 
Gentran:Director and complete the steps described.
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Reinstalling Gentran:Director

When to perform this
procedure

Perform this procedure only if you had problems with the 
installation or validation of your Gentran:Director release 5.4.

To reinstall
Gentran:Director

To reinstall Gentran:Director for Windows, complete the following 
steps:

Step Action

1 Complete the steps for Installing 
Gentran:Director on page 17.

Note
This procedure installs products to the folder you 
installed to previously. Sterling Commerce suggests 
that you accept the default folder shown on the 
Choose Destination Location window.

System Response
A message is displayed if the installation program 
detects existing Gentran:Director components 
already installed on your PC. 

2 To continue with installation and overwrite the 
Gentran:Director components that were detected, 
click Yes.

Note
To exit the installation program without completing 
the installation, click No.

System Response
If the Director Executive is running, a message 
asking if you want to stop the Director Executive is 
displayed. 

Continued on next page
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3 Click Yes to continue with the installation.

System Response
The setup program installs the 
Commerce:Connection and Gentran:Director 
software, and the Mailbox Wizard window is 
displayed. 

Reference
For information on setting up mailbox profiles, see 
Setting Up Mailboxes on page 37.

Step Action
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Chapter 2

Upgrade for Existing Customers

Installation Roadmap

The following table describes the order of tasks to complete.

Stage Description Section

1 Exit Commerce:Connection and 
Gentran:Director.

2 Backup your Gentran:Director 
database.

Backing up Your 
Gentran:Director 
System on page 
52

3 Stop the Gentran:Director 
Executive or the Gentran:Director 
Service.

Stopping the 
Gentran:Director 
Executive on 
page 61

4 Upgrade Commerce:Connection 
and Gentran:Director.

Upgrading 
Commerce:Conn
ection and 
Gentran:Director 
on page 62
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Backing up Your Gentran:Director System

This section provides instructions for backing up your entire 
Gentran:Director system. You should backup the database and 
stop Gentran:Director Executive before upgrading to 
Gentran:Director 5.4.

Before you begin Before you begin backing up your Gentran:Director database, 
complete the following:

When you are done creating the appropriate folders, you are 
ready to begin backing up Gentran:Director database.

Step Action

1 Create a folder on your hard drive. Name the folder 
C:\BackupGentran.

2 Create the following subfolders within the 
BackupGentran folder using the names indicated:
■ Partners

■ Templates

■ Scripts

■ Database

■ Documents

■ IntIn

■ IntOut

■ TransIn

■ Bin
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Backing up Your
Partner Profiles

Backing up
Translation Objects

Step Action

1 Log on to Gentran:Director and click Partners.

2 Click the name of a partner.

3 Click Export. The Export File Build screen displays.

4 Locate the File Name field and write down the name of 
the partner profile. The file name should end with .PAR.

5 Click Save.

Note
The .PAR files are saved to
C:\Program Files\COMMERCE Connection32\Partners

6 Repeat steps 2 – 5 for the remaining partner profiles.

7 When you have exported all of your partner profiles, 
copy these profiles to C:\BackupGentran\Partners or 
to a floppy disk.

Caution
Do not use the move function to perform this task.

Step Action

1 Click View > Translation Objects.

2 Click the name of a translation object.
Continued on next page



Backing up Your Gentran:Director System

54 October 2007 Commerce:Connection Suite/Gentran:Director Getting Started Guide

3 Click View to review the details associated with that 
translation object.

4 Locate the File Name field and write down the name of 
the translation object (for example, FIN162022.TPL).

Note
Some files may have extensions such as .t00, .t01, 
.t02, etc. When writing down the name, use the 
extension .TPL for all translation objects.

5 Repeat steps 2 – 4 for the remaining translation 
objects.

6 Click Close.

7 Click Tools > Configuration > Imports.
Continued on next page

Step Action
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Backing up
Communication

Ports, Profiles, and
Scripts

To backup your communication ports, profiles, and scripts, gather 
the following information:

Ports 

8 Write down the File Path and Translation Object 
Description. You can find the Translation Objects in 
View > Translation Objects. If you cannot find the 
description, complete the following:
a. Click Sort.
b. Clear the Hide System Translation Objects 

checkbox.
c. Click OK. 

This will display all of the system templates. Your 
system import template should now be listed. Repeat 
steps 2 – 4 to copy down all translation object file 
names.

Note
The .TPL files are saved to
C:\Program Files\COMMERCE Connection32\RegTransobj

9 Copy the files to C:\BackupGentran\Templates or to a 
floppy disk.

Caution
Do not use the move function to perform this task.

Step Action

Step Action

1 Click Tools > Communications > Ports.

2 Click the name of the port.

3 Click Setup.
Continued on next page
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Profiles 

4 Write down the port name and all associated settings.

5 Click Cancel.

6 Repeat steps 2 – 5 for all port profiles.

Step Action

1 Click Tools > Communications > Profiles.

2 Click the name of the profile.

3 Click Setup.

4 Write down the profile name and all associated 
settings, including:
■ Profile Type

■ Modem Number (if applicable)

■ Port Profile (if applicable)

■ File Copy Name (if applicable)

■ IP Address and Socket (if applicable)

5 Click Logon Script (if applicable).

6 Locate the file name on the title bar at the top of the 
window. Write down the file name using the extension 
.SCR.

7 Click Cancel.

8 Repeat steps 6 – 7 for Receive Only Script and Send 
Receive Script.

Continued on next page

Step Action
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9 Click Script Variables.

10 Write down the contents of all the variables that contain 
information.

11 Click Configure Exchange (if applicable).

12 Write down all settings indicated.

Note
If you use Commerce:Exchange, you may need to find 
or request a copy of your User ID and Password for 
your Commerce:Connection setup.

13 Click Advanced>>.

14 Write down all of the information for:
■ Pre-Processor (if applicable)

■ Pre-Post Processor (if applicable)

15 Repeat steps 2 – 14 for all profiles.

16 If you run CLEO bisynchronous communications, 
complete the following:
a. Navigate to

C:\Program Files\COMMERCE Connection32\Bin 
b. Double-click CFGBOOK.EXE.
c. Click each tab and write down the associated 

settings.
d. Click the STARTUP tab and write down the file 

name indicated for Configuration File Name.
e. Copy this file from the \Bin folder to 

C:\BackupGentran\Cleo or to a floppy disk.

Caution
Do not use the move function to perform this task.

Step Action
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Scripts 

Backing up the EDI
Data Received from

Trading Partner(s)

Step Action

1 Open the folder labeled C:\Program 
Files\COMMERCE Connection32\Bin\Commscr.

2 Verify that the folder contains the same names as those 
in your notes from Step 6 on page 56.

3 When you have verified folder contents, copy the .SCR 
files to C:\BackupGentran\Scripts or to a floppy disk.

Caution
Do not use the move function to perform this task.

Step Action

1 Open the folder labeled C:\Program 
Files\COMMERCE Connection32\TransIn.

2 Verify the folder contents.

3 When you have verified folder contents, copy the .EDI 
files to C:\BackupGentran\TransIn or to a floppy disk.

Caution
Do not use the move function to perform this task.
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Closing Programs

Backing up the
Access Database

(Optional)

You may want to back up your Access Database to retain 
document listings in the InDrawer, OutDrawer, and Interchanges. 

If you want to view the EDI data for the documents listed in the 
InDrawer, OutDrawer, and Interchanges, copy the folders and 
their contents to the corresponding C:\BackupGentran\ folder, 
as listed below:

■ C:\Program Files\CommerceConnection32\Documents
■ C:\Program Files\CommerceConnection32\IntIn
■ C:\Program Files\CommerceConnection32\IntOut

Note:
For instructions on backing up Process Control (Unattended) and 
Partner Tables, please contact Sterling Commerce Customer 
Support.

Step Action

1 Exit Gentran:Director and all other programs.

2 Stop Gentran:Director Executive. See Stopping the 
Gentran:Director Executive on page 61.

Step Action

1 Navigate to C:\Program Files\COMMERCE 
Connection32\Database.

2 Copy the Gentran:Director.mdb files to 
C:\BackupGentran\Database.

Caution
Do not use the move function to perform this task.
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Backing up the Bin
Directory

Stage Description

3 Navigate to C:\Program Files\COMMERCE 
Connection32\Bin.

4 Copy the contents of this directory to 
C:\BackupGentran\Bin.

Caution
Do not use the move function to perform this task.
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Stopping the Gentran:Director Executive

You must stop Gentran:Director Executive before you can install 
the Gentran:Director 5.4 upgrade. 

Step Action

1 Right-click the Gentran:Director Executive icon on 
your system tray.

2 Select Stop Director Executive.

3 Click Yes to stop the application.

System Response
The Executive icon no longer displays in the Windows 
toolbar.
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Upgrading Commerce:Connection and 
Gentran:Director

The installation program upgrades both Commerce:Connection 
and Gentran:Director.

Step Action

1 Insert the Commerce:Connection CD-ROM into your 
CD-ROM drive.

System Response
The installation program automatically starts.
If it does not automatically start, continue with step 2. 
Otherwise, continue with step 3.

2 If the installation program does not start, complete the 
following steps:
a. From the Start menu, click Run.
b. Enter <drive_letter>:\setup.exe

where: <drive_letter> is the drive letter for your 
CD-ROM drive (for example, D:\ ).

3 To complete the installation, do one of the following:
■ If Gentran:Director 5.3 and 

Commerce:Connection 6.1.4 are installed on your 
computer and you want to update both products, 
click Next until you have completed the installation 
process. 

■ If you do not have Commerce:Connection 6.1.4 
installed on your computer and want to install only 
Gentran:Director 5.4, on the Select Features 
screen, de-select Commerce:Connection and click 
Next until you have completed the installation 
process.



Restoring Your Gentran:Director System from Backup

Commerce:Connection Suite/Gentran:Director Getting Started Guide October 2007 63

Restoring Your Gentran:Director System from 
Backup

When to perform this
procedure

You do not need to perform a restore if the 
Commerce:Connection 6.2 and Gentran:Director 5.4 upgrade 
completes successfully. However, if you experienced problems 
completing the installation, you may need to restore your system 
to its original state. Perform the following procedures only if you 
experienced problems during installation.

Prerequisites Complete the following steps before restoring your database from 
backup. 

Step Action

1 Close Gentran:Director and stop Gentran:Director 
Executive. See Stopping the Gentran:Director 
Executive on page 61.

2 Rename the existing database to a new name (for 
example, Gentran:Director.old). However, if you do not 
want to maintain two copies of a database, you can 
delete the existing copy and then copy the backup 
database version to the database folder.

3 Navigate to C:\BackupGentran\.
Continued on next page
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Re-registering
Translation Objects

4 Copy the following backup folders and their contents 
from C:\BackupGentran\ to the associated folders 
located in the C:\Program Files\COMMERCE 
Connection32\ folder: 
■ C:\Program Files\COMMERCE 

Connection32\Database 
(one file GentranDirector.mdb)

■ C:\Program Files\COMMERCE 
Connection32\Documents

■ C:\Program Files\COMMERCE 
Connection32\IntIn

■ C:\Program Files\COMMERCE 
Connection32\IntOut

Note
You do not need to copy the contents of the folders 
back if you are re-installing the Gentran:Director 
software over an existing installation. Only restore 
folders on a fresh re-install, unless told otherwise by 
Sterling Commerce Customer Support.

Step Action

Step Action

1 Open Gentran:Director.

2 Click View > Translation Objects.

3 Click New.

4 Navigate to C:\BackupGentran\Templates.

5 Select all .TPL files and click Open.

6 Click Yes if you are prompted to overwrite any file.
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Rebuilding
Communications

Ports and Profiles

Ports 
If you are reinstalling to the same computer, you can recreate the 
ports exactly as they were originally. If you are re-installing to a 
different computer, you will need to determine the port(s) and 
associated modem(s) to modify the port information accordingly. 
You may also need to modify the initialization strings if the 
modem is different.

Step Action

1 Click Tools > Communications > Ports.

2 Click New.

3 Enter your port name.

Note
Use a port name from the list of port names you wrote 
down in the Ports procedure, Step 4 on page 56. This 
list should also have the settings required to complete 
step 5 of this procedure.

4 Click OK.

5 Enter the information for all of the settings.

6 Click OK.

7 Repeat steps 2 – 6 for all port entries.

8 When finished, click Close.
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Profiles and Scripts 

Step Action

1 Copy all .SCR files from:
C:\BackupGentran\Scripts
to:
C:\Program Files\COMMERCE 
Connection32\Bin\Commscr

2 Click Tools > Communications > Profiles.

3 Click New.

4 Enter your profile name.

Note
Use a profile name from the list of profile names you 
wrote down in the Profiles procedure, Step 4 on 
page 56. This list should also have the settings 
required to complete step 6 of this procedure.

5 Click OK.

6 Enter the information for all of the settings including the 
Advanced>> section.

7 Click Logon Script (if applicable).

8 Click Import and select the logon script file associated 
with that profile.

9 Click Open.

10 Click Save.

11 Click Receive Only Script (if applicable).
Continued on next page
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12 Click Import and select the receive only script file 
associated with that profile.

13 Click Open.

14 Click Save.

15 Click Send Receive Script (if applicable).

16 Click Import and select the send receive script file 
associated with that profile.

17 Click Open.

18 Click Save.

19 Click Script Variables (if applicable).

20 Type in the variables associated with that profile.

21 Click OK to save the profile.

22 Repeat steps 3 – 21 for all of the profiles.

23 Click Configure Exchange (if applicable).

24 Fill in all of the settings.

Note
Use the setting information you wrote down in the 
Profiles procedure, Step 12 on page 57.

Step Action
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If you use Bisync If you use Bisync, you also need to complete the following: 

Restoring Partners (if
applicable)

If you did not restore your database, complete the following steps 
to restore your partners: 

Step Action

1 Install the CLEO software directly into the \Bin folder.

2 Copy the configuration file from 
C:\BackupGentran\Cleo into the \Bin folder. 

Note:
Do not install the software to the subfolder \3780plus.

3 Restore the CFGBOOK.EXE settings you wrote down 
in the Profiles procedure, Step 16 on page 57. For 
more information on Bisync setup please contact 
Customer Support.

Step Action

1 Copy all .PAR files from:
C:\BackupGentran\Partners
to:
C:\Program Files \COMMERCE Connection32\Partners

2 Click Partners.

3 Click Import.

System Response
The Import File Select windows displays.

4 Select the partner you want to import and click Open.
Continued on next page
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Reprocessing Old
Data (if applicable)

For additional information, contact Sterling Commerce Customer 
Support.

5 Click Save.

6 Select the correct communication profile for that partner 
(if blank).

7 Click Save or press Enter until a window displays 
indicating the import process is complete.

8 Click OK.

9 Repeat steps 3 – 8 for all partners.

Step Action

Step Action

1 Click Commands > Process File in Director.

2 Browse to C:\BackupGentran\TransIn and select the 
file you want to reprocess.

3 Click Open.
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Upgrading Gentran:Director and Changing 
Systems

This section contains instructions for using the Gentran DataBase 
Computer Name Sync utility to change the computer name stored 
in the Gentran:Director database to the new computer name. 

When to perform this
procedure

Use this section only if you are moving your Gentran:Director 
system to a new computer as part of your upgrade process. 

Prerequisites You must complete the following tasks before running this utility:

■ Install Gentran:Director 5.4 on the new computer.

■ Complete the backup on the old Gentran:Director system. 

Reference
If you are not familiar with the backup and restore process, see 
the Knowledge Base on the Support On Demand Web site for 
more information. In Knowledge Base, you can use the Quick 
Search function to locate information about backup and restore 
procedures. For more information about Support On Demand, 
see Customer Support on page 4.
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Running the utility Complete the following steps to run the Gentran DataBase 
Computer Name Sync utility. 

Step Action

On the new computer (where Gentran:Director 5.4 is 
installed):

1 Navigate to the Gentran:Director Database folder. If 
you accepted the default paths during installation, this 
folder is:
C:\Program Files\COMMERCE Connection32\Database

2 Change the file named GentranDatabase.mdb to 
NEWGentranDatabase.mdb.

On the old computer (where your existing 
Gentran:Director system is located):

1 Exit Gentran:Director, if necessary. If the Director 
Executive is running, stop it (see Stopping the 
Gentran:Director Executive on page 61).

2 Navigate to the Gentran:Director Database folder on 
the Gentran:Director system. If you accepted the 
default paths during installation, this folder is:
C:\Program Files\COMMERCE Connection32\Database

3 Copy the file named GentranDatabase.mdb from the 
old computer to the Gentran:Director Database folder 
on the new computer. If you accepted the default 
paths during installation, this folder is:
C:\Program Files\COMMERCE Connection32\Database

Continued on next page
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On the new computer (where Gentran:Director 5.4 is 
installed):

1 Put the Commerce:Connection Suite CD-ROM in the 
CD-ROM drive of the new computer. 

2 Navigate to the Support Utilities directory on the 
CD-ROM and open the folder.

3 In the Support directory, double-click the executable 
file called GentranDBComputerNameSync.exe. 
A dialog box is displayed.

4 Click OK. 
The utility starts and the 
GentranDBComputerNameSync dialog box is 
displayed. 

5 Click the Sync Gentran DB with Computer Name 
button to run the utility.
When the utility is finished, the message Done! is 
displayed. 

6 Click Quit to close the message box, then click OK to 
exit the program. 

Continued on next page

Step Action



Upgrading Gentran:Director and Changing Systems

Commerce:Connection Suite/Gentran:Director Getting Started Guide October 2007 73

7 To test that the utility ran successfully, try running a 
Process Control session that includes a 
communication session.
■ If you do not receive an “Inconsistent computer 

names” message, the utility successfully updated 
the computer name in the Gentran database. 

■ If the “Inconsistent computer names” message is 
displayed after completing this procedure, call 
Gentran:Director Support for assistance. See 
Customer Support on page 4.

Step Action
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Appendix A

Frequently Asked Questions

This appendix contains answers to some frequently asked 
questions about installation, tasks in the Pre-installation 
Checklist, and other topics. 

For more questions and answers, see the Gentran:Director online 
help and the Sterling Commerce Support On Demand Web site 
located at www.sterlingcommerce.com. 

How do I find out
what version of

Windows is running
on the computer?

1. From the Windows Start menu, select Settings > Control 
Panel. 
(If you are using a Windows XP system, just select Control 
Panel.)

2. Double-click System. 

The System Properties window is displayed. It lists the 
name, version, and service pack level of the Windows 
software that is running on the computer.

3. Click Cancel to exit the System Properties window. 

How do I find out
what version of

Internet Explorer is
running on the

computer?

1. From the Windows Start menu, select Programs > Internet 
Explorer.

2. From the Internet Explorer Help menu, select About 
Internet Explorer.
The Help About is window displayed. It lists the Internet 
Explorer version and service pack level running on the 
computer.

3. Click OK to exit the Help About window. 
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How do I find out
what version of

MDAC is running on
the computer?

1. From the Windows Start menu, select Settings > Control 
Panel. 
(If you are using a Windows XP system, just select Control 
Panel.) 

2. Double-click Administrative Tools, then double-click 
ODBC. 

3. The ODBC Data Source Administrator window is displayed.

4.  Click the About tab. 

5. Locate the Administrator in the Description field. 
6. Find the version listed to the right of Administrator and 

compare that version to the ones in the following table. 

MDAC Versions

ODBC 
Administrator 

Version
Do you need to 

upgrade MDAC?

2.8 
(file version 
2.80.1022.3)
(product version 
5.50.4132.500)

3.525.1022.0 
(included on the 
Gentran:Director 
5.4 CD-ROM)

Can be used with 
Gentran:Director 5.4. 
You do not need to 
upgrade MDAC. 

2.7 RTM 
(2.70.7713.4)

3.520.7713.0 

2.6 SP1 
(2.61.7326.6)

3.520.7326.0 

Continued on next page
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7. Click Cancel to exit the Data Source Administrator window. 

How do I check if
ports 110 and 25 are

open?

Customers in the U.S.
To check port 110:

1. Make sure you are connected to the Internet.

2. From the Start menu, select Run. 

3. Type the following in the Open field:

telnet primary.gts.globalec.com 110

2.6 RTM 
(2.60.6526.3)

3.520.6526.0 Cannot be used with 
Gentran:Director 5.4. 
Requires upgrade.

See Installing 
Microsoft Data 
Access Components 
on page 15 for 
instructions. 

2.5 SP2 
(2.52.6019.0)

3.520.6019.0

2.5 SP1 
(2.51.5303.5)

3.520.5303.2

2.5 RTM 
(2.50.4403.12)

3.520.4403.2

2.1 SP2 
(2.1.2.4202.3)

3.510.4202.0

2.1 SP1a 
(2.1.1.3711.11)

3.510.3711.0

2.1 RTM 
(2.10.3513.2)

3.510.3513.0

2.0 sp2 3.510.3002.23

MDAC Versions

ODBC 
Administrator 

Version
Do you need to 

upgrade MDAC?
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4. Click OK.
A telnet session window is displayed. If you see the following 
message, port 110 is open:

+OK Welcome 

5. Close the window to exit.

To check port 25:

1. Make sure you are connected to the Internet.

2. From the Start menu, select Run. 

3. Type the following in the Open field:

telnet primary.gts.globalec.com 25

4. Click OK.

A telnet session window is displayed. If you see a message 
similar to the following, port 25 is open:

220 gts.globalec.com COMMERCE:Exchange 
ESMTP/POP3 Server version 1.0 Ready

5. Close the window to exit.

Customers in Canada: 
To check port 110:

1. Make sure you are connected to the Internet.

2. From the Start menu, select Run. 

3. Type the following in the Open field:

telnet primary.ca.globalec.com 110

4. Click OK.

A telnet session window is displayed. If a message 
beginning with “+OK” is displayed, port 110 is open.

5. Close the window to exit.
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To check port 25:

1. Make sure you are connected to the Internet.

2. From the Start menu, select Run. 

3. Type the following in the Open field:

telnet primary.ca.globalec.com 25

4. Click OK.

A telnet session window is displayed. If you see the 
following message, then port 25 is open.

220 tor1relaypri.ca.globalec.com ESMTP Server 
[current date and time and other information 
may also be displayed here] Ready

5. Close the window to exit.
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