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Preface

The IBM Sterling Gentran:Director Connection User Guide assumes knowledge of the 
Microsoft® Windows® operating system, including its applications, network, and 
environment. If you are not familiar with the Windows operating system, refer to the 
Windows library of manuals.

The guide also assumes you can perform basic tasks such as:

✦ Using Windows 98, Windows 2000, Windows XP, or Windows NT with the Start 
menu

✦ Understanding the meaning and usage of an icon, window, group, and button
✦ Selecting menu items from a shortcut menu
✦ Using a mouse to make menu item selections
If you are not familiar with some of these concepts or terms, refer to your Microsoft 
operating system documentation.

Overview
Welcome to IBM® Sterling Gentran:Director® Connection, the IBM® 32-bit 
Internet-enabled electronic mail (e-mail), file distribution, and communications software 
package. Sterling Gentran:Director Connection contains:

✦ IBM® Sterling Commerce:Mail is a Multipurpose Internet Mail Extension (MIME) 
enabled electronic mail application that allows you to send and receive e-mail 
messages with encrypted or decrypted attachments. Sterling Commerce:Mail blends 
conventional e-mail features with support for X.400 users, fax users, and the Internet. 
Sterling Commerce:Mail also allows you to create and edit dial-up connections and 
mailbox setups.

✦ IBM® Sterling Connection Manager allows you to establish a dial-up connection to 
the Internet through an Internet Service Provider (ISP), begin a communications 
session, set up the communications environment, view communications status, and 
send data via control files.
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32-bit Applications
A 32-bit application is a software application that runs in a 32-bit flat address space.

✦ Flat address space is an addressing scheme that segments memory into blocks of 32 
bits. Windows 98, Windows 2000, Windows XP, and Windows NT® are 32-bit 
operating systems running in a 32-bit flat address space.

✦ Segmented address space is an addressing scheme that segments memory into blocks 
of 16 bits. Microsoft Windows and MS-DOS® were written for 16-bit 
microprocessors with a segmented address space.

In general, 32-bit applications are bigger, have more features, and run as fast as or faster 
than their 16-bit counterparts.

Sterling Commerce:Mail
The MIME-enabled Sterling Commerce:Mail provides a computerized method of sending 
e-mail messages. For example, you can send memos, letters, spreadsheets, EDI data, and 
CAD/CAM specifications to recipients on the IBM® Sterling B2B Collaboration Network 
network. 

✦ E-mail messages are electronic documents made up of text plus any included 
attachments. You can encrypt any attachment, including EDI data. 

✦ EDI (Electronic Data Interchange) is the transfer of key business transaction 
information in a standard format from one PC application to another via a 
communications link.

Sterling Commerce:Mail sends messages using an SMTP connection and retrieves 
messages using a POP3 connection. Sterling Commerce:Mail allows you to choose whether 
to encrypt attachments.

The Sterling Commerce:Mail e-mail features allow you to: 

✦ Send messages using SMTP and support POP3 on message retrieval.
✦ Attach encrypted or decrypted PC files and EDI files to e-mail messages.
✦ Forward messages and attachments.
✦ Reply to a single sender or reply to all senders.
✦ Handle text or binary files and messages.
✦ Create your own address lists and update the address book with new addresses.
✦ Assign carbon copy, blind copy, and acknowledgment of messages.
✦ Open different attachment formats. With the Sterling Commerce:Mail viewer, you can 

cut, copy, and paste text and graphics. You can also resize, rotate, and manipulate 
images.
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Using Sterling Commerce:Mail to save time and money
Sterling Commerce:Mail saves time and money by cutting back on paperwork. For 
example, both a mass merchandiser and the merchandiser’s customs broker install Sterling 
Commerce:Mail. When products are ready for the merchandiser to pick up, the customs 
broker uses Sterling Commerce:Mail to forward a list of the products to the merchandiser’s 
inventory department. The merchandiser processes the product list and prepares the 
inventory department for receipt of the products. Once the inventory department is 
prepared, the merchandiser uses Sterling Commerce:Mail to forward the product list to 
shipping and receiving. Shipping and receiving prints the product list and picks up the 
products.

Sterling Connection Manager
Sterling Connection Manager allows you to establish a connection to the Internet through 
an ISP, begin a communications session, set up the communications environment, and view 
communications status. 

IBM® Sterling Gentran:Director® can quickly access Sterling Connection Manager and 
connect to a network. You can access Sterling Connection Manager by selecting:

✦ A menu or button from applications that use Sterling Connection Manager. For 
example, in Sterling Commerce:Mail, select the Sterling Connection Manager option 
from the Tools menu. 

✦ The Sterling Connection Manager application from Windows 98 (2nd edition), 
Windows 2000, Windows XP, or Windows NT. 

Once connected to the Internet, Sterling Connection Manager is used to monitor 
communications sessions.

Sterling Connection Manager saves you money. All user interaction is offline. Therefore, 
you do not pay for network time until you send data to or receive data from a network.

Minimum requirements
To be able to install and run Sterling Gentran:Director Connection, make sure your PC 
meets the following minimum requirements:

✦ Pentium® PC, 120 MHz or faster
✦ CD-ROM drive
✦ Color VGA or SVGA monitor
✦ Mouse

✦ Hayes®-compatible modem with MNP or V.42 support. 9600 minimum baud rate; 
28,800 baud rate or higher is recommended
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✦ Microsoft Windows 98, Windows 2000, Windows XP, or Windows NT 4.0 software 
installed (Windows NT 4.0 must have Service Pack 2 or later installed)

✦ Available disk space of 100 MB
✦ At least 32 MB RAM 

Starting Sterling Commerce:Mail or Sterling Connection 
Manager

To run Sterling Commerce:Mail or Sterling Connection Manager:

1. Start up the Windows operating system.
2. Select Programs from the Start menu, then click Sterling Gentran:Director 

Connection. The group selections display.
3. Select either Sterling Commerce:Mail or Sterling Connection Manager from the group 

selections. The application opens and the product copyright notice window appears. 
4. Click your mouse to begin using the program.

Navigation
Sterling Commerce:Mail and Sterling Connection Manager allow you to move around their 
menus, items, and windows in three ways, depending on your needs. Choose from the 
following navigation methods:

✦ Use your mouse to move the cursor to a menu, submenu, item, button, or field. Then 
click the mouse button to make your selection.

✦ Press the Alt key plus the underlined letter of the menu, item, button, or field.
✦ Highlight the menu, submenu, button, or field with the Tab or arrow keys. Then press 

Enter. To leave a menu, press Esc. 
For the sake of simplicity, the The IBM® Sterling Gentran:Director® Connection User 
Guide describes only mouse movements.

Sterling Gentran:Director Connection Documentation
The Sterling Gentran:Director Connection documentation consists of the following 
publications: 

✦ IBM® Sterling Gentran:Director® Connection Getting Started Guide describes how 
to install/upgrade Sterling Commerce:Mail and Sterling Connection Manager and 
provides an overview of how to complete the most common Sterling Commerce:Mail 
and Sterling Connection Manager tasks.



Preface

IBM Sterling Gentran:Director Connection User Guide ix

✦ IBM® Sterling Gentran:Director® Connection User Guide describes the procedures 
needed to understand and use Sterling Commerce:Mail and Sterling Connection 
Manager.

✦ Online Help explains how to use Sterling Commerce:Mail and Sterling Connection 
Manager online help. Online help for Sterling Commerce:Mail and Sterling 
Connection Manager is included on your installation CD and installed to your PC 
when you install the products.

Sterling Gentran:Director Connection User Guide structure 
It is not necessary to read this User Guide from cover to cover. This guide has been created 
to step you through each task. 

The IBM® Sterling Gentran:Director® Connection User Guide contains the following 
sections:
✦ Sterling Commerce:Mail 

The Sterling Commerce:Mail section describes how to:
Create and send messages with encrypted or decrypted attachments.
View and manipulate attachments.
Store and maintain messages in Folders.
View your Inbox folder to see a list of messages you have received.
View your Outbox folder to see a list of messages you have created that have not 
been sent.
Create and maintain addresses in the Address Book. An address book is a 
collection of e-mail addresses of the people to whom you regularly send 
messages. Use the address book to create address lists. 
Create and change addresses in address lists. An address list is a sublist of the 
address book. 
Create a Reply or Reply All message.
Forward a copy of a message to another person.
Go to the Next Message or Previous Message in any folder.
Delete messages from folders.

✦ Sterling Connection Manager
The Sterling Connection Manager section describes how to:

Specify mailbox and connection information that allows you to connect to the 
Internet.
View communications session information.
Dial a network and begin a send-and-receive session.

✦ Troubleshooting
The Troubleshooting section helps you with problems you may encounter while using 
Sterling Commerce:Mail or Sterling Connection Manager. The Troubleshooting 
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section and the User Guide can help solve any problem you encounter. If you need 
more help, call Customer Services.

✦ Glossary
The Glossary lists definitions of important terms used in the User Guide.

Online help
Sterling Commerce:Mail and Sterling Connection Manager provide you with 
context-sensitive online help, as well as an explanation of how to use this help. 

To access Sterling Commerce:Mail and Sterling Connection Manager online help:

✦ Press F1 at any time.
✦ Select the Help menu Help Topics item in Sterling Commerce:Mail or the Help menu 

Contents item in Sterling Connection Manager.
✦ Click the Help button that is found on some windows.
Regardless of the method used, the application then provides you with topic-specific 
information.

To see more information about a field or button in help, move your mouse to the window 

shown in the online help. When the hand  icon points to the field or button you need 
more information about, click the field or button. 

Getting Support
IBM® Sterling Customer Center provides a wealth of online resources that are available 
around the clock to enrich your business experience with IBM® Sterling Gentran®. By 
using Sterling Customer Center, you gain access to many self-support tools, including a 
Knowledge-Base, Documentation, Education, and Case Management. Access this site at: 
Sterling Customer Center.  (http://customer.sterlingcommerce.com)

Once logged in, select Support Center from the top navigation menu, and then locate 
Sterling Gentran product-specific support information from the left navigation menu.

Additionally, our Customer Support Reference Guide outlines our support hours, contact 
information, and key information that will enhance your support experience with us. For 
detailed information about Customer Support, please refer to the Customer Support 
Reference Guide accessible from the login page. (http://customer.sterlingcommerce.com).

http://customer.sterlingcommerce.com
http://customer.sterlingcommerce.com
http://customer.sterlingcommerce.com
http://customer.sterlingcommerce.com
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Chapter 1

Sterling Commerce:Mail

Sterling Commerce:Mail is an Internet-enabled product for sending e-mail, including 
memos, spreadsheets, and CAD/CAM specifications. You can also send messages with 
encrypted attachments, such as EDI documents. With Sterling Commerce:Mail, you no 
longer need to rely on conventional messages sent through the postal service or by fax. You 
also save money by keeping online interaction to a minimum.

Sterling Commerce:Mail Features
Sterling Commerce:Mail allows you to:

✦ Write and send messages that include encrypted attachments.
✦ Exchange messages that include encrypted attachments with users on IBM® Sterling 

B2B Collaboration Network.
✦ Read messages you have received.
✦ Read encrypted attachments you have received from other Sterling Commerce:Mail 

users.
✦ Reply to messages.
✦ View and create folders to store your messages.
✦ View, create, merge, and copy customized distribution lists of users you send mail to.
✦ Maintain a master address book containing all recipients.
✦ Add, delete, and change member information within a distribution list or the address 

book.
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Main Window
Sterling Commerce:Mail is designed to be easy to use. The following is an example of the 
Sterling Commerce:Mail Main window.

To see the Folder List view, select the View menu Folder List item. To return to the 
Shortcut Bar view, select the View menu Shortcut Bar item. 

The Menu Bar appears across the top of the Main window, above the toolbar. Each menu 
contains several selectable items. Click a menu to select it. You can use menus to perform 
the following functions:

✦ File — Create, save, retrieve, and send messages. You can also print information, set 
up your printer, empty your trash, exit the application, create folders, and read 
information you have placed in folders.

✦ Edit — Select all messages in a file, place messages in the trash, and mark messages 
as read.

✦ View — View the toolbar, status bar, preview, and header; switch views; specify 
mailbox, connectivity, and confirmations options.

✦ Message — Create, reply to, forward, delete, and copy or move messages to folders. 
✦ Folder — Read filed messages; create, rename, and delete folders; copy or move 

messages into folders; and search for messages within folders.
✦ Go — View a list of inbound, outbound, unread, sent, and filed messages. You can 

also read messages you have placed in the trash.

Note: Two views of the Sterling Commerce:Mail Main window are available. One view, the 
Shortcut Bar view, is displayed above on the left side of the window. The Folder List view 
is a standard tree view. Use the view you are more comfortable with.
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✦ Tools — Set up your address book and distribution lists, request a connection to 
Sterling B2B Collaboration Network, specify Sterling B2B Collaboration Network 
settings, go to Sterling Connection Manager, view communications information, and 
request network reports. 

✦ Help — View thorough, context-sensitive online help, as well as general product 
information.

Toolbar buttons
Use the toolbar at the top of the Main window to access Sterling Commerce:Mail windows 
and features.

Select from these toolbar buttons when using Sterling Commerce:Mail:

✦ Send Mail sends messages and attachments in the Outbox folder to their recipients.
✦ Send/Retrieve Mail sends messages and attachments in the Outbox folder and 

retrieves new messages and places them in the Inbox folder.
✦ Compose New Message creates a new message.
✦ Create creates a new folder for storing messages and attachments.
✦ Print prints a copy of a selected message or attachment.
✦ Delete moves messages and non-system folders into the trash folder. Once messages 

and non-system folders are placed in the trash folder, you can delete them permanently 
by emptying the trash (File menu Empty Trash item).

✦ Reply creates a message in response to a received message. The message goes only to 
the message sender and not to other recipients of the message.

✦ Reply To All creates a message in response to a received message. The message goes 
to all recipients of the received messages.

✦ Forward sends a copy of the selected message to the recipients you select.
✦ Previous Message opens the previous message in a selected folder.
✦ Next Message opens the next message in a selected folder.
✦ Inbox opens the Inbox folder.
✦ Outbox opens the Outbox folder. 
✦ Address Book opens the address book. The address book is a list of Sterling 

Commerce:Mail users you have set up to exchange information with. You can add 
users to or delete users from the address book. Anyone who sends you a message is 
automatically added to your address book. 

✦ Help accesses online help for more information about Sterling Commerce:Mail.
✦ Exit closes Sterling Commerce:Mail.
You can also access these features by using the available menu items.
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Status bar
Use the status bar at the bottom of the Main window to view mailbox and connection 
information

The status bar contains the following areas:

✦ Selected item shows basic information about the selected item, such as a folder or 
message.

✦ Unread/Total Messages shows the number of unread messages and the total number 
of messages in the selected folder.

✦ Mailbox Setup shows which mailbox Sterling Commerce:Mail uses as the default 
mailbox. You can change the default mailbox using the Options window Mailbox tab. 
Double-click the Mailbox Setup area and the Options window appears with the 
Mailbox tab selected by default. 
See Specifying mailbox defaults on page 74 for more information.

✦ Connection Setup shows which connection Sterling Commerce:Mail uses as the 
default Internet connection. You can change the default connection using the Options 
window Connectivity tab. Double-click the Connection Setup area and the Options 
window appears with the Connectivity tab selected by default.
See Specifying connectivity defaults on page 76 for more information.

✦ Schedule Mail access shows whether you have enabled an automatic 
send-and-receive mail schedule. If you enable a schedule, the word Auto appears in 
the area. The area also provides a quick way of accessing the Schedule Mail window. 
Using the Schedule Mail window, you can schedule automatic send-and-receive mail 
communications sessions. Double-click the Schedule Mail access area and the 
Schedule Mail window appears.
See Scheduling mail on page 71 for more information.

Messages
The following are key terms for understanding Sterling Commerce:Mail.

✦ Messages are electronic documents made up of sender and recipient names, subject, 
text, and any attachments.

✦ Attachments are files that the user includes with a message. For example, 
attachments can be EDI data, indexes, or distribution lists. Sterling Commerce:Mail 

Mailbox 
Setup

Schedule Mail 
access

Connection Setup

Unread/Total
Messages

Selected Item
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can encrypt attachments. However, only other Sterling Commerce:Mail users can 
decrypt and read these attachments. See Attachments on page 19 for more 
information.

Messages and their attachments can be either inbound or outbound.

✦ Inbound messages are messages sent by other Sterling Commerce:Mail users to you. 
They are stored automatically in the Inbox folder.

✦ Outbound messages are messages sent by you to other Sterling Commerce:Mail 
users. They are stored automatically in the Outbox folder. After you send messages, 
the messages are moved to the Sent folder.

Viewing message details
The Sterling Commerce:Mail Main window is split into two main areas:

✦ Folders
✦ Message Details

Folders
The Folders area is a list of folders on the left side of the Main window. The list contains 
main folders and subfolders. Main folders contain subfolders. Subfolders contain messages 
and attachments. The folders are listed as icons or in a tree structure, depending on the view 
you selected:

Click the icon in the Shortcut Bar view or click the plus sign (+) to the left of each main 
folder to drill down to the next level and display the subfolders in the Folder List view. 
Click a subfolder to display the messages it contains. The messages appear in the Message 
Details area, which is located on the right side of the Main window.

See Folders on page 59 for more information.

Shortcut Bar view Folder List view

Main Folder

Subfolders
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Message Details
The Message Details area displays information about messages contained in the subfolder 
you click in the Folders area. If the subfolder contains no messages, the Message Details 
area is empty. 

Specifying message details
Sterling Commerce:Mail allows you to specify the types of message details that appear in 
the Message Details area when you click a subfolder.

To specify message details:

1. Right-click a subfolder in the Folders area of the Main window. A popup menu 
appears.

2. From the popup menu, select Letter Details. The Letter Details window appears.

3. Click the desired check boxes in the Details to display area. These selections 
determine the type of information that appears in the Message Details area of the Main 
window. The selections are:

✦ To shows to whom messages were sent.
✦ From shows from whom messages were received.
✦ Received Date shows the date messages were received.
✦ Size shows the size of messages in bytes, including any attachments.
✦ Subject shows the subject line of messages.

4. Click OK to save your selections or Cancel to close the window without saving your 
changes.

You can specify different message details for each subfolder. 

Note: If you are in the Folder List view, you can use the Letter Details window or the 
corresponding menu items to select the details you wish to view. In the Shortcut Bar view, 
you can use only the Letter Details window; the corresponding menu items are disabled.
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Creating a message
You can send messages to anyone defined within your address book or distribution list. 
Messages can include encrypted or non-encrypted attachments.

✦ Encryption is the process of converting an attachment into complex algorithms so 
that the attachment is unreadable unless it is decrypted.

Only Sterling Commerce:Mail users can view attachments you have encrypted using 
Sterling Commerce:Mail.

To create a new message: 

1. Select one of the following methods:

Select the File menu Compose New Message item.

Select the Message menu Compose item.

Click Compose New Message on the toolbar. The Message window appears.

Note: Sterling Commerce:Mail will prompt you to save the message if you attempt to exit before 
the message is completed. If you want to exit Sterling Commerce:Mail for any reason while 
creating a message, be sure to save your message before exiting or the message will be lost.
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2. An address must be selected before the message can be sent. Click Address to specify 
who will receive the message. The Address window appears.

3. Type basic information identifying your message in the Subject field. This field is 
required. The subject you enter will display with your name in the recipient’s Inbox 
folder.

4. Click the needed confirmation check boxes to specify if you want to receive an 
acknowledgment:

Confirmation of Delivery (COD) indicates Sterling Gentran:Director 
Connection sends you a confirmation message when the recipient receives your 
message. This message receipt is returned to you the next time you retrieve your 
messages. To view the message receipt, double-click on the receipt in the Inbox 
folder. The message displays with the original subject and a date and time stamp. 

Confirmation of Receipt (COR) indicates Sterling Gentran:Director Connection 
sends you a message when the recipient opens your message. This message 
receipt is returned to you the next time you retrieve your messages. To view the 
message receipt, open it from the Folder menu Inbox item. The message is named 
Return Receipt from recipient(s), followed by the original subject of the message. 
The date and time the message was opened is also shown. 

Whether you specify COD or COR, Sterling Commerce:Mail files the message in the 
Outbox folder. 

5. Create the text of the message by typing information in the lower half of the screen. Or 
copy or cut text from another application and paste it in the message using the Paste 
toolbar button.
Use the scroll bar to the right of the view area to move through the message. You can 
also use the arrow keys and the Page Up and Page Down keys to navigate through the 
message.
If there is an attached archive file, the window shows what files it contains. 

You can... For more information, see...

Address the message. Addressing a message on page 9

Add addresses to your address book. Addressing a message on page 9

Create a distribution list. Creating and maintaining distribution lists on 
page 50

Note: If the provided address cannot be identified, you may receive a message indicating your 
message was undeliverable to certain recipients and the reasons why.

Note: Sterling Commerce:Mail allows you to select the Confirmation of Delivery and 
Confirmation of Receipt choices each time you create a message.
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6. Click the Priority list box and select the priority of the message. Select Low, Normal, 
or High from the list box.

7. As needed, attach files or other documents to your message by selecting the Message 
menu Attach File item or clicking the Attach button.
As you add attachments to the message, Sterling Commerce:Mail shows all the 
attachments in the Attachment list.
See Attaching a file to a message on page 20 for more information.

8. If needed, select the File menu Print item to print a hard copy of the message. See 
Printing a message on page 17 for more information.
For information on printing an attachment, see Printing an attachment on page 41.

9. To save the message as a draft, in the Message window select the File menu Save 
Draft item.

OR
To send the completed message to the Outbox folder, in the Message window select 
the File menu Send Message to Outbox item or click Send to Outbox on the toolbar. 
Once you have sent the message to the Outbox folder, you can send the message to its 
recipients by selecting the File menu Send Mail item or clicking Send Mail on the 
toolbar. After the message is sent or saved, Sterling Commerce:Mail returns you to the 
Main window.

Addressing a message
On the Message window, you can specify who will receive your message. You can send 
messages to anyone on Sterling B2B Collaboration Network. You can also create your own 
personal address books from which you can create distribution lists.

✦ Address book is a collection of people you regularly send messages to. After you 
create an address book, make distribution lists from it by selecting members from the 
address book and copying them to the distribution lists. If a member is not included in 
the address book, the member cannot be added to a distribution list. 

✦ Distribution list is a group of people you regularly send the same message to. A 
distribution list is a convenient way to mail messages to a group of people, rather than 
sending the same message to each individually. For example, you might create a 
distribution list containing all the people who want to stay current with your 
department’s news updates.

You can send messages to users if they are not in the address book. In addition, you can add 
any address to the address book by clicking Add. If you do not use the Add button, the 
address will not be added to the address book. Users who send you a message are 

Note: To view file information about an attachment, click the attachment in the Attachment list; 
then select the Attachment menu Details item. Or right-click the attachment in the 
Attachment list. See Specifying attachment details on page 21 for more information.
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automatically added to the address book. See Adding and editing addresses in the 
address book on page 44 for more information.

To address a message:

1. On the Message window, select the Message menu Address item or click the Address 
button. The Address window appears.

 

2. To select the recipients of your message, complete one of the following:

Type an e-mail address in the E-Mail address field. Use this field when you want 
to send a message to a recipient whose address is not in your address book. As 
needed, click Add to add the address to your address book. If you do not use the 
Add button, the address will not be stored in your address book.

Select a folder of recipients by clicking a folder in the Address list box. 

Select individual recipients within folders by clicking the plus sign (+) to the left 
of a folder in the Address list box. The folder contents appear. Click the 
recipient’s address.

3. Select how you want to send the message to the recipients you specified in step 2 by 
clicking the appropriate button:

TO sends a message directly to recipients.

CC carbon copies recipients. All those receiving the message will see the CC 
recipients’ names.

BCC blind carbon copies recipients. TO and CC recipients will not see BCC 
recipients’ names.

4. As needed, repeat steps 2 and 3 until all recipients for the message are selected. 
5. Click the Close button to return to the Message window.
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Opening a message
You can view messages in the Inbox, Outbox, Trash, Draft, and Sent folders or in any 
non-system folders you have created. See Creating a folder on page 65 for more 
information.

To open a message:

1. Click the Inbox, Outbox, Trash, Draft, or Sent folder or any non-system folder you 
have created from the Folders area in the Main window. 
The Message Details area in the Main window displays all the messages stored in the 
selected folder. See Viewing message details on page 5 for more information.

A closed envelope indicates you have not read the message.

An open envelope indicates you have read the message or marked the message as 
read by selecting the Edit menu Mark As Read item.

A paper clip indicates the message has one or more attachments.

2. Open the message you want to open from the message list by double-clicking it. You 
can select all the messages in the folder by selecting the Edit menu Select All item 
and then the File menu Open Message item. The Message window opens.

3. Select the File menu Close item or click Exit on the toolbar to exit the message.
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Previewing a message
You can view messages without opening them. 

To preview a message:

1. Click the Inbox, Outbox, Trash, Draft, or Sent folder or any non-system folder you 
have created from the Folders area in the Main window. 
The Message Details area in the Main window displays all the messages stored in the 
selected folder. See Viewing message details on page 5 for more information. An 
envelope icon indicates the status of the message:

A closed envelope indicates you have not read the message.

An open envelope indicates you have read the message or marked the message as 
read by selecting the Edit menu Mark As Read item.

A paper clip indicates the message has one or more attachments.

2. Select the message you want to open from the message list by clicking it once. 
3. Select the View menu Preview item. A pane at the bottom of the window displays the 

selected message.
4. To view the header information of the previewed message, select the View menu 

Header item. The sender, date, subject, and recipient information appear above the 
previewed message, as shown below.
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Navigating between messages

Viewing the next message
Select the Go menu Next Message item or click Next Message on the toolbar to go to the 
next message in a selected folder. This provides an easy way to browse through messages 
in the order they appear in the folder. When you have selected the item, Sterling 
Commerce:Mail opens the next message.

Viewing the previous message
Select the Go menu Previous Message item or click Previous Message on the toolbar to 
go to the previous message in a selected folder. Sterling Commerce:Mail opens the 
previous message. This provides an easy way to browse through messages in any folder.

Viewing the first unread message
Select the Go menu First Unread Message item to go to the first unread message in a 
selected folder. This provides an easy way to open only those messages you have not read. 
When you have selected the item, Sterling Commerce:Mail opens the first unread message.

Viewing the previous unread message
Select the Go menu Previous Unread Message item to go to the previous unread message 
in a selected folder. Sterling Commerce:Mail opens the previous unread message.

Saving a message
Select the File menu Save As item to save a message text and attachments. To save only an 
attachment, see Exporting an attachment on page 23. The Save As option is active only 
on certain windows.

Use Save As to:

✦ Save a message and its attachments to a different name, format, or location on your 
hard drive. The heading information is retained with the Subject, Addressee, and other 
identifying information. The original message remains untouched in your Inbox, 
Outbox, Trash, Draft, or Sent folder or in any folder you have created.

✦ Save a message and place it in the appropriate file folder: Inbox, Outbox, Trash, Draft, 
or Sent folder, or in any folder you have created.

✦ Save a message you have written, reopened, and edited. Your original message is 
replaced with the new version.

For a description of the fields on the Save As window, see Exporting an attachment on 
page 23.
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Sending and retrieving messages
You can send and retrieve messages in the same communications session. Only messages 
in the Outbox folder are sent when you use the Send Mail or the Send/Retrieve Mail menu 
options.

To retrieve messages only
To retrieve your messages, select the File menu Retrieve Mail item. Your messages are 
automatically retrieved and placed in the Inbox folder.

To send messages only
To send messages, select the File menu Send Mail item or click Send Mail on the toolbar. 
All messages in the Outbox folder are sent to the specified recipients.

To send and receive messages at the same time
Select the File menu Send/Retrieve Mail item or click Send/Retrieve Mail on the toolbar. 
Your inbound messages are retrieved and placed in the Inbox folder and all the messages 
you have in the Outbox folder are sent to the specified recipients.

Marking unread messages as read
Messages are marked as either read or unread. As needed, you can select an unread message 
and change it to a read message. You can do this without reading the message. 

✦ Read messages have an open envelope icon.
✦ Unread messages have a closed envelope icon.
To mark an unread message as read:

1. Select a message from the Inbox folder that you want to mark as read by clicking it 
once.

2. Select the Edit menu Mark As Read item. The message is marked as read with an 
open envelope icon.

To mark all messages in the Inbox folder as read
Select the Edit menu Mark All As Read item. All messages in the Inbox folder are marked 
as read with open envelope icons.

Note: Messages are sent to the Outbox folder when you select the File menu Send to Outbox 
item or click Send to Outbox on the toolbar.

Note: If the sender of the message selected Confirmation of Receipt (COR), when you mark the 
message as read Sterling Commerce:Mail sends a confirmation. This confirmation is sent 
regardless of whether you actually read the message.
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Replying to a message
After you have opened a message, you can respond to the sender or to the sender and other 
recipients of the message.

To reply to a message:

1. Open the message you want to reply to by clicking it once and selecting the File menu 
Open Message item or by double-clicking it.

OR
Select the message you want to reply to by clicking it once. You do not have to open a 
message to reply to it.

2. To reply to just the sender, select the Message menu Reply item or click Reply on the 
toolbar.

OR
To reply to the sender and the other recipients, select the Message menu Reply To All 
item or click Reply To All on the toolbar. For either option, the following window 
appears.

3. Click one of the following radio buttons. These choices determine what information 
from the message is copied and sent to the recipients.

Note copies only the original message into the reply message. Attachments are 
not included. The original message follows your new message.

Note and Attachments copies the original message and any attachments into the 
new message. The original message follows your new message. Attachments are 
included in the Attachment list.

None does not copy the original message or its attachments to the new message. 
Only your new message is sent.

4. Click OK to return to the Message window. Type your message in the view area. Add 
attachments as needed. If you do not want to respond to the sender, click Cancel 
instead.
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Forwarding a message
You can send a copy of a message and any attachments to another recipient.

To forward a message:

1. Highlight a message in a selected folder by clicking it once. Then select the Message 
menu Forward item or click Forward on the toolbar. The Message window appears. 

2. In the view area of the message, type any message you want to send with the original 
message you are forwarding.

3. Click Address and specify a recipient for the forwarded message.
See Addressing a message on page 9 for more information.

4. Select the File menu Send Message to Outbox item or click Send to Outbox on the 
toolbar to send the completed message to the Outbox folder. Sterling Commerce:Mail 
returns you to the Main window.

Deleting a message
You can select messages to be placed in the Trash folder. Once in the Trash folder, the 
messages are deleted permanently when you empty the Trash or exit Sterling 
Commerce:Mail.

You can also delete non-system folders. See Deleting a folder on page 70 for more 
information.

To place a message or messages in the trash:

1. In the Folders area, click the folder that contains the message you want to delete. The 
messages contained in the folder appear in the Message Details area. Click the 
message you want to delete. 
To delete a non-system folder, click the folder.

Note: Type the new message above the forward separator line.

Note: Once you have sent the message to the Outbox folder, you can send the message to its 
recipients by selecting the File menu Send Mail item.

Caution: Once you empty the Trash or exit Sterling Commerce:Mail, messages in the Trash 
folder are deleted permanently and cannot be recovered.
See Emptying the Trash folder on page 64 for more information.
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2. Select the Edit menu Delete item. The selected messages are placed in the Trash 
folder.

OR
To delete all messages in a folder, click a folder in the Folders area of the Main 
window. Then, select the Edit menu Select All item.

3. Select the File menu Empty Trash item or exit Sterling Commerce:Mail. All 
messages in the Trash folder are deleted.

Printing a message
To print a message:

1. Open the message you want to print. See Opening a message on page 11 for more 
information.

OR
Select the message you want to print by clicking it once. You do not have to open a 
message to print it. 

2. Select the File menu Print item or click Print on the toolbar. The Print window 
appears. 

3. As needed, click the Name list box and select the printer you want to use.
4. As needed, specify the print range, the number of copies, and whether you want copies 

collated. 
5. As needed, click Properties to specify the selected printer’s properties. The properties 

available depend on the features of the selected printer. For more information about 
specifying printer properties, see Specifying default printer setup and properties on 
page 79.

6. Click OK to begin printing.

Note: If you delete a folder, its messages are placed in the Trash folder. If you try to delete the 
Inbox, Outbox, Draft, or Sent subfolder, all messages inside the folder are placed in the 
Trash folder. The system subfolder is not deleted.
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Specifying message delivery preferences
From the Message window, you can specify message delivery notifications and priority 
defaults. 

To specify your preferences:

1. Select the Tools menu Preferences item. The following window appears.

2. Click the needed confirmation check boxes to specify if you want to receive an 
acknowledgment:

Confirmation of Delivery (COD) indicates Sterling Commerce:Mail sends you a 
confirmation message when the recipient receives your message.

Confirmation of Receipt (COR) indicates Sterling Commerce:Mail sends you a 
message when the recipient opens your message.

3. Click the Priority list box and select the priority of all new messages. Select Low, 
Normal, or High.

4. Click the Enable Message Formatting check box to format all messages with a hard 
return after each 70-character line of text.

5. Click OK to save your preferences or Cancel to exit without saving preferences.
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Chapter 2

Attachments

Two types of files can be attached to a message, binary and text.

✦ Binary file contains data in a machine-readable form that can be read only by a 
software application. For example, an executable file (.EXE) is in binary format.

✦ Text file contains only alphanumeric characters and symbols that are human-readable. 
For example, an ASCII file is in text format.

If you want to attach documents from other applications to your message, use the Attach 
File toolbar button on the Message window. When the recipient gets the message, the 
message will include any attachments you sent with it. There is no limit to the number of 
attachments a single message can have, except as determined by computer memory and 
disk space.

If you have problems sending and receiving attachments, check your anti-virus settings. 
You may need to lower them to allow attachments.

Outside In for Windows
Sterling Commerce:Mail includes viewer technology using the application Outside In® for 
Windows. This application, which is included with Sterling Commerce:Mail, allows you 
to:

✦ View MS-DOS®, Microsoft® Windows®, and Apple® Macintosh® files in Sterling 
Commerce:Mail.

✦ Paste text or graphics from Sterling Commerce:Mail into another application. The 
Windows Clipboard remembers all application formatting.

✦ Print any file in a supported format without having the application on your PC.
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Attaching a file to a message
To attach a file to a message:

1. On the Message window, select the Message menu Attach File item or click Attach 
File on the toolbar. The Open window appears.

2. Click the Look in list box and select the local or network drive that contains the file 
you want to attach. Select a location and the folders and files appear in the area below 
the Look in list box.

3. Highlight the folder containing the file you want to attach to your message by clicking 
it once. Click Open. The folder opens and its name appears in the Look in list box. 
The folder’s contents appear in the area below the Look in list box. 

4. Highlight the file you want to attach by clicking it once. Click Open. The Message 
window is displayed. 
The file you selected is attached to the current message and shown in the Attachment 
list. A file attached to a message is downloaded with the message when the recipient 
retrieves mail.

5. As needed, specify attachment information and encryption. See Specifying 
attachment details on page 21 for more information.

Note: Use the Files of type list box to specify a type of file you want to appear. If the file type is 
not contained in the folder, nothing appears.

Note: To delete an attachment from a message, highlight the attachment in the Attachment list by 
clicking it once. Then select the Edit menu Delete item or click Delete on the toolbar. You 
can also press the Del key.

Note: Both the Delete menu option and the Delete toolbar button delete the connection to the file. 
The file itself is not removed from your system.
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Specifying attachment details
On the Message window, you can view and specify an attachment’s description and 
encryption format.

To specify a description and encryption format for an attachment:

1. Create a new message. See Creating a message on page 7 for more information.
OR

Open an existing message. See Opening a message on page 11 for more information.
2. Select the Attachment menu Details item. You can also right-click the attachment in 

the Attachment list. The following window appears.

3. As needed, type a description of the attachment in the Description field.
4. As needed, select an attachment format from the Attachment Format list box. Your 

selection determines whether the attachment is encrypted when the message is sent.

5. Click OK to save the details or Cancel to exit without saving. Sterling 
Commerce:Mail returns you to the Message window.

To specify advanced details, click Advanced>>. See Specifying advanced attachment 
details on page 22.

Note: To specify a MIME type and subtype for the attachment, click the Advanced>> button. 
When you select the attachment format, Sterling Commerce:Mail selects the corresponding 
MIME type and subtype for you. It is recommended that you do not change this type unless 
it is necessary. See Specifying advanced attachment details on page 22 for more 
information.
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Specifying advanced attachment details
Use the Advanced>> button on the Details window to specify an attachment’s MIME type, 
delivery information, and location.

MIME type describes the format of the attachment when it is sent.

To specify advanced attachment details:

1. Access the Details window to view an attachment’s details. See Specifying 
attachment details on page 21 for more information.

2. Click Advanced>> on the Details window. The Details window expands:

3. Use the On Delivery fields to specify the following:

File Name allows you to specify the attachment’s destination file name.

Note: When you select the attachment format, Sterling Commerce:Mail selects the corresponding 
MIME type and subtype. It is recommended that you do not change this subtype unless it 
is necessary.

Caution: Unexpected results may occur if you change the MIME type and subtype settings.
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Destination allows you to specify the directory the attachment will be placed in 
when the recipient gets the message. If the directory does not exist on the 
recipient’s PC, the attachment is placed in the recipient’s Sterling Commerce:Mail 
Inbox folder.

Append allows you to add the attached file to the end of a file having the same 
name. Select this check box when you want to add information to an existing file 
rather than overwrite the file.

4. Select the appropriate Attributes check boxes to specify the following file properties:

Read Only allows the recipient to only read the file.

Hidden stops the file from appearing in a directory list.

Archive specifies the file to be backed up.

System specifies a file as an operating system file. System files are listed in a 
DOS or Windows directory. They are invisible to the recipient.

5. Select the appropriate MIME type from the Mime Type list box. 
To change the subtype, highlight the subtype and type a new subtype in the available 
field.

6. Click OK to save the details or Cancel to exit without saving. Sterling 
Commerce:Mail returns you to the Message window.

Exporting an attachment
On the Message window, you can save a message or attachment to another location. The 
original message or attachment remains in Sterling Commerce:Mail and a copy of the 
message or attachment is exported.

To export a message or attachment to a local or network drive:

1. Open the message. See Opening a message on page 11 for more information.
2. Highlight a message or attachment in the Attachment list. A message can be selected 

by highlighting the word Note in the Attachment list.
If you want to export more than one attachment, hold the CTRL key as you click each 
attachment. Sterling Commerce:Mail saves each attachment as a separate file.

Note: You must include a backslash (\) at the end of the destination you specify.

Note: If you select the Append check box, the Attributes check boxes are unavailable.
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3. Select the Attachment menu Export item. The Save As window appears. The 
attachment name and extension appear in the File name field.

4. As needed, change the name and extension. When the message or attachment is 
exported to the location you specify in the next step, this is its new name.

5. Click the Save in list box and select the local or network drive you want to export the 
message or attachment to. When you select a location, the folders and files appear in 
the view area located below the Save in list box.

6. Highlight the folder you want to export the message or attachment to by clicking it 
once and clicking Open. Or you can double-click the folder. All files within that 
folder, as well as any subfolders, appear in the view area below the list box.

7. Click Save to export the message or attachment or Cancel to cancel the export. 
Sterling Commerce:Mail returns you to the Message window.

Viewing an attachment
You can view any attachment by double-clicking it in the Attachment list on the Message 
window. The attachment appears in the view area of the Message window. Once an 
attachment appears in the view area, you can specify the attachment’s view, size, display, 
print and clipboard options by using the attachment shortcut menu.

See Using the attachment shortcut menu on page 25 for more information.
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To view an attachment from the Message window, double-click the attachment in the 
Attachment list. The attachment appears in the view area.

Using the attachment shortcut menu 
While viewing an attachment in the Message window, you can specify the attachment’s 
view style, size, display, print, and clipboard options by right-clicking in the Message 
window view area. The view area is located at the bottom of the Message window. 

For information on how to view an attachment, see Viewing an attachment on page 24.

When you right-click on a displayed attachment in the view area, an attachment shortcut 
menu appears. This shortcut menu contains frequently used options for attachments in the 
view area.

Note: The options on the attachment shortcut menu vary depending on the type of attachment 
being viewed. Also, some options may appear inactive depending on the type of attachment 
being viewed.
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Viewing an attachment using a full screen
On the Message window, you can use the attachment shortcut menu to view an attachment 
using the entire computer screen.

To view an attachment using the entire computer screen:

1. Open a message containing an attachment. See Opening a message on page 11 for 
more information.

2. In the Attachment list, double-click the attachment you want to view. The attachment 
appears in the Message window view area.

3. Right-click in the view area. The attachment shortcut menu appears. Click the Show 
Full Screen item. The attachment view expands to fill the entire computer screen.

4. Click the attachment to return to the Message window. The attachment remains 
displayed within the view area.

Specifying the view style of an attachment
On the Message window, you can use the attachment shortcut menu to specify the view 
style of an attachment in the view area.

To specify the view style of an attachment:

1. Open a message containing an attachment. See Opening a message on page 11 for 
more information.

2. In the Attachment list, double-click the attachment you want to view. The attachment 
appears in the Message window view area.

3. Right-click in the view area. The attachment shortcut menu appears. Select the View 
item. Three selections appear beside the View item.

Note: The items on the attachment shortcut menu will vary depending on the type of attachment 
being viewed.

Note: To return to the message the attachment is attached to, double-click Note in the Attachment 
list.

Note: The items on the attachment shortcut menu will vary depending on the type of attachment 
being viewed.

Note: The selections that appear will vary depending on the type of attachment being viewed. 
Also, some selections may appear inactive depending on the type of attachment being 
viewed.
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Choose one of the following:

Draft displays text files using the specified default font for your PC.

Normal displays text files using the fonts specified in the text file. Embedded 
graphic files are also displayed. 

Preview displays text files using headers, footers, footnotes, margins, embedded 
graphics and columns as specified in the text file.

Specifying attachment size
On the Message window, you can use the attachment shortcut menu to specify the size of 
an attachment in the view area.

To specify the size of an attachment:

1. Open a message containing an attachment. See Opening a message on page 11 for 
more information.

2. In the Attachment list, double-click the attachment you want to view. The attachment 
appears in the Message window view area.

3. Right-click in the view area. The attachment shortcut menu appears. Select the Size 
item. Selections appear beside the Size item. Choose one of the following:

Original Size sizes the attachment to the size it was in the original program. If the 
original size is large, you may have to use the scroll bars that appear to the side 
and below the view area to view the entire attachment.

Full Size sizes the attachment using the attachment’s original dimensions. If the 
original dimensions are large, you may have to use the scroll bars that appear to 
the side and below the view area to view the entire attachment.

Fit to Window sizes the attachment to conform to the size of the current view 
area. All proportions are maintained.

Fit to Window Height sizes the attachment so it is as tall as the current view area. 
All proportions are maintained. If the attachment is wide, you may have to use the 
scroll bar that appears at the bottom of the view area to view the entire attachment.

Fit to Window Width sizes the attachment so it is as wide as the current view 
area. All proportions are maintained. If the attachment is tall, you may have to use 

Note: To return to the message the attachment is attached to, double-click Note in the Attachment 
list.

Note: The items on the attachment shortcut menu will vary, depending on the type of attachment 
being viewed.
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the scroll bar that appears to the right of the view area to view the entire 
attachment.

Adding colors or grays to graphic attachments
On the Message window, you can use the attachment shortcut menu to add simulations of 
colors or grays contained in a graphic palette to a graphic image. 

Dithering can improve the quality of a graphic image by filling in or smoothing out the 
image. Generally, the higher your monitor resolution, the more obvious the results.

To add color or shade to a graphic:

1. Open a message containing an attachment. See Opening a message on page 11 for 
more information.

2. In the Attachment list, double-click the attachment you want to view. The attachment 
appears in the Message window view area.

3. Right-click in the view area. The attachment shortcut menu appears. Select Dither. 
Colors or grays are added to the image.

Rotating an attachment
On the Message window, you can use the attachment shortcut menu to rotate an attachment 
in increments of 90 degrees in the view area.

You commonly use the Rotation item to change the orientation of a graphic or to fix Fax 
images that were sent upside down.

Note: The selections that appear will vary depending on the type of attachment being viewed. 
Also, some selections may appear inactive depending on the type of attachment being 
viewed.

Note: To return to the message the attachment is attached to, double-click Note in the Attachment 
list.

Note: The items on the attachment shortcut menu will vary, depending on the type of attachment 
being viewed.

Note: To return to the message the attachment is attached to, double-click Note in the Attachment 
list.

Note: The items on the attachment shortcut menu will vary depending on the type of attachment 
being viewed.
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To rotate an attachment:

1. Open a message containing an attachment. See Opening a message on page 11 for 
more information.

2. In the Attachment list, double-click the attachment you want to view. The attachment 
appears in the Message window view area.
Right-click in the view area. The attachment shortcut menu appears. Select the 
Rotation item. Selections appear beside the Rotation item.

Choose one of the following:

90 degrees

180 degrees

270 degrees

None

Zooming in or out on an attachment
On the Message window, you can use the attachment shortcut menu to enlarge or decrease 
detail in the view of an attachment in the view area.

To zoom in or out on an attachment:

1. Open a message containing an attachment. See Opening a message on page 11 for 
more information.

2. In the Attachment list, double-click on the attachment you want to view. The 
attachment appears in the Message window view area.

3. Right-click in the view area. The attachment shortcut menu appears. Select the Zoom 
item. Selections appear beside the Zoom item.

Note: The selections that appear will vary depending on the type of attachment being viewed. 
Also, some selections may appear inactive depending on the type of attachment being 
viewed.

Note: To return to the message the attachment is attached to, double-click Note in the Attachment 
list.

Note: The items on the attachment shortcut menu will vary depending on the type of attachment 
being viewed.

Note: The selections that appear will vary depending on the type of attachment being viewed. 
Also, some selections may appear inactive depending on the type of attachment being 
viewed.
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Choose one of the following:

In enlarges detail within the view area. You might want to zoom in on an image 
with very fine detail to see it more closely.

Out decreases detail within the view area. You might want to zoom out on a large 
image to see the entire image.

Selection enlarges detail within a specified area of an image.

Reset returns the attachment to the size it had before you started zooming in or 
out.

Specifying attachment options
While viewing an attachment in the Message window, you can use the attachment shortcut 
menu to specify the attachment’s display, print, and clipboard options. 

The Option item selections are:

✦ Display allows you to specify how Sterling Commerce:Mail displays unknown files. 
An unknown file is an attachment created in an application not supported by the 
Outside In viewer. When the viewer tries to open an unknown file, a message 
indicates that the file is unreadable.
See Specifying display options on page 31 for more information.

✦ Print allows you to print an attachment with formatting that includes tables, bold, 
italic and fonts. The attachment will print even if you do not have on your PC the 
application that created the attachment. You can print any supported text, graphics, 
spreadsheet or database PC or Macintosh format using the Print feature.
See Specifying print options on page 34 for more information.

✦ Clipboard allows you to specify the document formats used when placing data in the 
Windows Clipboard. The Clipboard is a temporary storage location most often used 
when copying data from one document or application to another. 
See Specifying clipboard options on page 37 for more information.

Note: To specify an area, click an image. Without releasing the mouse button, specify an area to 
enlarge by moving the mouse. Release the mouse button. Right-click in the specified area 
and select the Zoom Item Selection selection.

Note: To return to the message the attachment is attached to, double-click Note in the Attachment 
list.

Note: The items on the attachment shortcut menu will vary depending on the type of attachment 
being viewed. The selections that appear will also vary depending on the type of 
attachment being viewed. Some selections may appear inactive depending on the type of 
attachment being viewed.
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Specifying display options
On the Message window, you can use the attachment shortcut menu to specify how Sterling 
Commerce:Mail displays unknown files.

Unknown file is an attachment created in an application not supported by the viewer. When 
the Outside In viewer attempts to open an unknown file, a message indicates that the file is 
unreadable.

To specify display options:

1. Create a new message. See Creating a message on page 7 for more information.
OR

Open an existing message. See Opening a message on page 11 for more information.
2. Double-click an attachment in the Attachment list. The attachment appears in the 

view area in the bottom portion of the Message window.
3. Right-click in the view area. The attachment shortcut menu appears. Select the 

Options item Display selection. The Display Options window appears.

4. The default font is listed in the Default font area. If you prefer a different font, click 
Change. See Specifying the default font on page 40 for more information.

5. Select from the View unknown files as choices. Choose from:

Text format contains only alphanumeric characters and symbols that are 
human-readable. For example, an ASCII file would be in text format. Text format 
includes several character choices.
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Japanese (ShiftJIS) is a double-byte character file format. Two bytes are used to 
represent each japanese character.

Chinese (Big 5) is a double-byte character file format. Two bytes are used to 
represent each text character.

Chinese (GB) is a double-byte character file format. Two bytes are used to 
represent each text character.

Korean (Hangul) is a double-byte character file format. Two bytes are used to 
represent each text character.

Hexadecimal is a numbering system that uses a base of 16. Unlike decimal 
numbers (base 10), hexadecimal numbers include 16 digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, 
9, A, B, C, D, E and F. Using hexadecimal numbers is a convenient way to 
represent binary numbers.

Do Not View any file if it is not in a recognized format. Sterling Commerce:Mail 
will not attempt to display any file with an unknown format.

6. Click OK to save your changes or Cancel to cancel your changes. Sterling 
Commerce:Mail returns you to the Message window.

OR
Click More to change spreadsheet, database, and archive options. See Specifying 
more display options on page 32 for more information.

Specifying more display options
Use the More button on the Display Options window to specify whether you want all 
spreadsheets and database gridlines to display.

Gridlines are lines drawn from the tick marks of a spreadsheet or database that make it 
easier to see the values associated with the data markers.

You can also indicate how files are archived.

To specify more display options:

1. Create a new message. See Creating a message on page 7 for more information.
OR

Open an existing message. See Opening a message on page 11 for more information.
2. Double-click on an attachment in the Attachment list. The attachment appears in the 

view area in the bottom portion of the Message window.
3. Right-click in the view area. The attachment shortcut menu appears. Select the 

Options item Display selection. The Display Options window appears.
For an example of the Display Options window, see Specifying display options on 
page 31.
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4. Click More on the Display Options window. The following window appears.

5. As needed, click the Spreadsheet Show Gridlines check box. If a check mark 
appears in the box, Sterling Commerce:Mail shows lines between columns in a 
spreadsheet program.

6. As needed, click the Database Show Gridlines check box. If a check mark appears in 
the box, Sterling Commerce:Mail shows lines between columns in a database 
program.

7. Select an Archive option to specify how files are shown on the Message window:

Don’t sort files specifies that files are not sorted at all.

Sort Files by name specifies that files are sorted alphabetically from A to Z.

Sort files by size specifies that files are sorted from the smallest file to the largest 
file.

Sort files by date and time specifies that files are sorted from the oldest file to 
the newest file.

8. Select a Sort Order option to specify whether files are sorted in ascending or 
descending order:

Ascending sorts files from A to Z based on the Archive radio button selected in 
step 7.

Descending sorts files from Z to A based on the Archive radio button selected in 
step 7.

9. Click OK to save your changes or Cancel to cancel your changes. Sterling 
Commerce:Mail returns you to the Display Options window. 
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Specifying print options
On the Message window, you can use the attachment shortcut menu to specify basic 
printing options for attachments—such as page margins—and to print an attachment.

You can print attachments even if you do not have the application that created the 
attachment. Also, any supported text, graphic, spreadsheet, or database format can be 
printed for both PC and Macintosh.

To specify print options:

1. Create a new message. See Creating a message on page 7 for more information.
OR

Open an existing message. See Opening a message on page 11 for more information.
2. Double-click an attachment in the Attachment list. The attachment appears in the 

view area in the bottom portion of the Message window.

3. Right-click in the view area. The attachment shortcut menu appears. Select the 
Options item Print selection. The Print Options window appears.

Note: The options you specify using the attachment shortcut menu Options item Print selection 
apply only when you are printing attachments.
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4. As needed, click Change to change the default font in the Default font area. The Font 
window appears. See Specifying the default font on page 40 for information about 
using the Font window.
This font will be used when the attachment is printed if you do not have the font 
originally specified for the attachment.

5. Click the Print header check box if you want Sterling Commerce:Mail to print a 
header on every page of the attachment. 
Print header is made up of the attachment title, page number, and a line. Headers 
print above the specified margin. 

6. As needed, click Change to change the default font in the Header & Header font 
area. The Font window appears. See Specifying the default font on page 40 for 
information about using the Font window.

7. Type the name of the job to print in the Job Name field. This name appears in the 
Print header. If no job name is specified, the file name prints instead.

8. Specify the page margins in the Default Page Margins area. The Sterling 
Commerce:Mail default is one inch. 

9. As needed, click More to change spreadsheet, database, bitmap, and drawing 
specifications. See Specifying more print options on page 35 for more information.

10. Click OK to save the print options or Cancel to cancel your changes. Sterling 
Commerce:Mail returns you to the Message window.

Specifying more print options
Use the More button on the Print Options window to specify bitmap and drawing options 
and whether gridlines are shown when spreadsheets and databases are printed. 

To specify more print options:

1. Create a new message. See Creating a message on page 7 for more information.
OR

Open an existing message. See Opening a message on page 11 for more information.
2. Double-click an attachment in the Attachment list. The attachment appears in the 

view area in the bottom portion of the Message window.

Note: The Sample area on the right side shows the selected margin sizes and how the printed page 
looks.

Note: To print, select the File menu Print item or click Print on the toolbar. You can also 
right-click the attachment in the Message window view area and select the attachment 
shortcut menu Print item.
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3. Right-click in the view area. The attachment shortcut menu appears. Select the 
Options item Print selection. The Print Options window appears.
For an example of the Print Options window, see Specifying print options on 
page 34.

4. Click More on the Print Options window. The following window appears.

5. Specify the Spreadsheet options by selecting one of the available check boxes: 

Print gridlines prints lines between the columns and rows of each line of the 
spreadsheet. Each cell is outlined.

Print row & column names prints numbers for the rows and letters for the 
columns in the spreadsheet.

Print fit to page resizes the spreadsheet by changing the font size of text so that 
all of the spreadsheet’s columns conform to the size of the page your printer uses.

6. Specify the Database options by selecting one of the available check boxes. These 
options are the same as the spreadsheet options except for:

Print field names prints the database spreadsheet with field names showing.
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7. Specify the Bitmap options by selecting one of the available radio buttons. You can 
also click the Print Border check box if needed.
A bitmap is an image made up of a pattern of dots. Select from: 

Original aspect ratio indicates the bitmap is printed in its original size and shape. 
This is the default.

Stretch to margins stretches the bitmap until the bitmap is as large as the margins 
allow. The original proportions of the bitmap may not be kept and the graphic may 
look distorted. 

Print border prints a thin line around the bitmap to show its outer edges.

8. Specify one or more of the Drawing options. The drawing options are the same as the 
Bitmap options. A drawing is defined as any vector graphic file. 

9. Click OK to save any changes or Cancel to cancel your changes. Sterling 
Commerce:Mail returns you to the Print Options window. 

Specifying clipboard options
On the Message window, you can use the attachment shortcut menu to specify the 
document formats used when placing data in the Windows Clipboard.

Format is the way information is structured by an application when it creates a file. A 
format that can be read by one application often cannot be read by another.

By allowing you to select formats from the Clipboard Options window, Sterling 
Commerce:Mail saves formatting associated with that file when it is placed in the 
Clipboard. Without this feature, you may lose application-specific formatting.

To specify Clipboard formatting options:

1. Create a new message. See Creating a message on page 7 for more information.
OR

Open an existing message. See Opening a message on page 11 for more information.
2. Double-click an attachment in the Attachment list. The attachment appears in the 

view area in the bottom portion of the Message window.



Chapter 2   Attachments

38 IBM Sterling Gentran:Director Connection User Guide

3. Right-click in the view area. The attachment shortcut menu appears. Select the 
Options item Clipboard selection. The Clipboard Options window appears.

4. Select the format or application you want to use when cutting, copying, and pasting 
from the Clipboard. Because of the space the formats take up in the Clipboard, select 
only those formats you need. Select from:

Text file contains only alphanumeric characters and symbols that are 
human-readable. For example, an ASCII file is in text format. 

Rich Text Format (RTF) is used to convert documents from one application to 
another on the PC, or to transfer documents between a PC and a Macintosh. If you 
select Rich Text Format, all formatting is converted to text instructions that other 
applications can read.

Bitmap is an image made up of a pattern of dots. A bitmap is used to save 
graphics and is dependent on your PC hardware configuration.

Device Independent Bitmap (DIB) is a specialized bitmap format that does not 
depend on your PC hardware configuration. Like a bitmap, it is also made up of 
dots.

Metafile is a graphics format used in Windows. A metafile combines the 
properties of both raster and vector formats.

Palette is a set of colors used in creating an image.

5. Click Change to change the default font. 
The default font is used when your PC does not have the font originally specified for 
the attachment or when there is no font information specified for the attachment. See 
Specifying the default font on page 40 for more information.
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6. Click OK to save any changes or Cancel to cancel your changes. Sterling 
Commerce:Mail returns you to the Clipboard Options window. 

OR
Click More to specify additional clipboard options. See Specifying more clipboard 
options on page 39 for more information.

Specifying more clipboard options
Use the More button on the Clipboard Options window to specify spreadsheet and database 
options. These specifications apply only when you are pasting data into the Clipboard and 
affected cells are formatted in the Clipboard.

Cell is an area where a row and a column meet in a table. A table is made up of cells.

To specify more Clipboard options:

1. Create a new message. See Creating a message on page 7 for more information.
OR

Open an existing message. See Opening a message on page 11 for more information.
2. Double-click an attachment in the Attachment list. The attachment appears in the 

view area in the bottom portion of the Message window.
3. Right-click in the view area. The attachment shortcut menu appears. Select the 

Options item Clipboard selection. The Clipboard Options window appears.
For an example of the Clipboard Options window, see Specifying clipboard options 
on page 37.

4. Click More on the Clipboard Options window. The following window appears.

5. Select any or none of the Spreadsheet options:

Copy as table saves the spreadsheet to the Clipboard as a table instead of as 
individual cells divided by tabs.
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Copy using optimized tabs converts the spreadsheet to text. Sterling 
Commerce:Mail puts a tab after cells that contain data. Any empty cells are 
skipped.

Copy using tabs converts the spreadsheet to text. Sterling Commerce:Mail puts a 
tab after each cell regardless of whether the cell contains data.

6. Select any or none of the Database options. These options include the Spreadsheet 
options defined in step 5, plus:

Include field names saves all database column and row headings to the 
Clipboard. If this option is not selected, only data is copied to the Clipboard and 
headings are not included. 

7. Click OK to save any changes or Cancel to cancel your changes. Sterling 
Commerce:Mail returns you to the Clipboard Options window.

Specifying the default font
Click Change on the Clipboard Options, Display Options, or Print Options window to 
select the font Sterling Commerce:Mail uses when you copy data to the Clipboard or view 
or print an attachment without a specified font. The default font is used only if the 
attachment has no specified font or Sterling Commerce:Mail cannot use the font specified 
in the attachment.

The Options windows can be accessed by the Display, Print, and Clipboard selections 
beside the attachment shortcut menu Options item. 

To change the default font:

1. Create a new message. See Creating a message on page 7 for more information.
OR

Open an existing message. See Opening a message on page 11 for more information.
2. Double-click an attachment in the Attachment list. The attachment appears in the 

view area in the bottom portion of the Message window.
3. Right-click in the view area. The attachment shortcut menu appears. Select the 

Options item.

4. Select either the Display, Print, or Clipboard selection beside the attachment shortcut 
menu Options item. 

Note: The items on the attachment shortcut menu vary depending on the type of attachment being 
viewed.
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5. Click Change on the window. The following window appears.

6. Select a font family in the Font list box. The fonts shown are those currently loaded 
on your PC.

7. Select a font style in the Font style list box. Font styles are determined by an 
individual font but often include regular, bold, italic and bold italic selections. 

8. Select a font size in the Size list box. The size shows the average number of characters 
for that font in one inch of text.

9. A representation of the font in the selected size, style, and family displays in the 
Sample area of the window. 

10. Click OK to save any changes or Cancel to cancel your changes. Sterling 
Commerce:Mail returns you to the Message window.

Printing an attachment
To print an attachment:

1. Open the attachment you want to print. See Viewing an attachment on page 24 for 
more information.

2. Right-click in the view area. The attachment shortcut menu appears. Select the Print 
item. The Print window appears.

Note: The items on the attachment shortcut menu vary depending on the type of attachment being 
viewed.
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3. As needed, click the Name list box and select the printer you want to use.
4. As needed, specify the print range, the number of copies, and whether you want copies 

collated. 
5. As needed, click Properties to specify the printer properties. The properties available 

depend on the features of the selected printer. See Specifying default printer setup 
and properties on page 79 for more information.

6. Click OK to begin printing.
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Chapter 3

Address Book

Use the Tools menu Address Book item to maintain lists of recipients and their addresses. 

Address Book toolbar button
Use the Address Book toolbar button to access the Address Book window without using 
the Tools menu. To select the toolbar button, click the button. 

There are no addresses prepackaged with Sterling Commerce:Mail. However, if you 
receive a message from another user, this sender is automatically added to your address 
book.

✦ Address book is a collection of people you regularly send messages to. After you 
create an address book, make distribution lists from it by selecting members from the 
address book and copying them to the distribution lists. If a member is not included in 
the address book, the member cannot be added to a distribution list. 

✦ Distribution list is a group of people you regularly send the same messages to. A 
distribution list is a convenient way to mail messages to a group of people, rather than 
sending the same messages to each individually. For example, you might create a 
distribution list containing all the people who want to stay current with your 
department’s news updates. The user must also be a Sterling Commerce:Mail user, or 
a user with an X.400 address, to be included on a distribution list.

Using the Address Book item, you can:

✦ Add, change and delete recipients to and from the address book.
✦ Print a list of address book recipients or distribution list recipients.
✦ Create and maintain distribution lists.
✦ Send distribution lists to others.
✦ Locate an address in the address book.

Note: All of the addresses in your address book are stored in the All folder, located in the 
Distribution List area of the Address Book window.
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✦ Import and export distribution lists.
✦ Specify import distribution list options.

Adding and editing addresses in the address book
On the Address Book window, you can use the New SMTP Address and New X.400 
Address items from the File menu to add new addresses to the address book. The menu item 
you use is determined by the type of address you are adding.

✦ SMTP address is a standard Internet address that identifies the recipient and the post 
office. SMTP stands for Simple Mail Transfer Protocol. For example, 
jsmith@abcompany.com is a SMTP address, where jsmith identifies the user and 
abcompany.com identifies the post office. 

✦ X.400 is a communications protocol that allows connectivity between electronic 
messaging systems. The X.400 address system is used by some companies to send 
information worldwide using non-proprietary standards. Because the X.400 system is 
worldwide, each X.400 user must have a unique mailing address. 
The following is a sample address:
C=us A=abcompany P=market O=writing S=smith G=bill

Adding or editing an SMTP address
To add or edit an SMTP address:

1. Select the Tools menu Address Book item or click Address Book on the toolbar. The 
Address Book window appears.

2. Do one of the following:

Select the File menu New SMTP Address item.

Double-click an existing SMTP address within the Address Book window.

Caution: The SMTP and X.400 addresses have distinctive addressing requirements. Do not 
specify an address without knowing what a company has predefined. Otherwise, your 
message will not be received.
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Click SMTP on the toolbar. The following window appears.

3. Type or edit information in the following fields:

4. Click OK to save the address in the All folder or Cancel to exit without saving. 
Sterling Commerce:Mail returns you to the Address Book window.

Field  Definition

Alias Name Full name of the person you want to add to the address book. Type a 
person’s full name because an e-mail address does not have to 
contain the name. 

E-Mail Name Recipient’s e-mail name. For example, jsmith is an e-mail name.

Domain Network region that handles sending and receiving messages for the 
person you are adding to the address book. For example, ibm.com is a 
domain.
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Adding or editing an X.400 address
To add or edit an X.400 address:

1. Select the Tools menu Address Book item or click Address Book on the toolbar. The 
Address Book window appears. Then select the File menu New X.400 Address item 
or click X.400 on the toolbar.

OR
Double-click an existing X.400 address within the Address Book window.
The following window appears. The X.400 Basic tab is selected by default.
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To select the X.400 Domain tab, click the tab label.

2. Type or edit information in the following fields.

Caution: You must type the X.400 address exactly as it is given to you by the user. Otherwise, 
your message will not be sent.

Field  Definition

X.400 Basic tab

Alias Name Full name of the person you want to add to the address book. Type a 
person’s full name because the e-mail address does not have to 
contain the name. 

Surname Up to 40 characters can be typed. A company may abbreviate this field 
as S when providing this information. The Surname appears in the Last 
Name field of the Address Book window.

Given Name Up to 16 characters can be typed. The Given Name appears in the first 
name field of the Address Book window. A company may abbreviate 
this field as G.

Initials Recipient’s initials. Up to five characters can be typed. Some users 
may not specify this information. A company may abbreviate this field 
as I.
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3. Click OK to save the X.400 address in the All folder or Cancel to exit without saving. 
Sterling Commerce:Mail returns you to the Address Book window.

DDA1, DDA2. 
DDA3 and DDA4

Domain Defined Attributes used to provide extra identifying information 
about a recipient. For example, you can type information such as a 
payroll number or a billing indicator. 
You can specify one or more of the four attributes. Up to eight 
characters can be typed in the DDA1 field. Up to 124 characters can be 
typed in the DDA2 field.

X.400 Domain tab

Country Country name where the person resides. Up to three characters can be 
typed. A company may abbreviate this field as C when providing you 
with this information.

ADMD Administrative domain. This identifies the public carrier, if you use one. 
Up to 24 characters can be typed. A company may abbreviate this field 
as A when providing this information.

PRMD Abbreviation for Private Management Domain and is the name of the 
company. This information ensures that the company is identifiable as 
a single entity to other users. This field is required. A company may 
abbreviate this field as P when providing this information.

Organization

Org Unit 1
Org Unit 2
Org Unit 3
Org Unit 4

Company-specific designation. For example, you might want to use the 
division name within your company. Up to 64 characters can be typed. 
A company may abbreviate this field as O.
To further identify a company, you can specify one or more of the Org 
Unit 1, 2, 3 and 4 fields. For example, you could type the person’s 
employee number in one field. Up to 32 characters can be typed in 
each Org Unit field.

A company may abbreviate this field as OU1, OU2, OU3 or OU4 
when providing this information.

Field  Definition
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Viewing, deleting, and printing the address book
Sterling Commerce:Mail organizes addresses alphabetically by given name and allows you 
to choose addresses from the address book when creating distribution lists.

To view, delete, and print the address book:

1. Select the Tools menu Address Book item or click Address Book on the toolbar. The 
following window appears.

2. Click the All folder. In the right side of the Address Book window, recipients’ 
addresses appear in the E-Mail Address field. Their names appear in the Alias Name 
field. To the left of the recipients’ names, icons indicate whether the recipients have 
SMTP or X400 addresses. 

To delete an address from the address book, click the address you want to delete. 
Then press the Del key or click Delete on the toolbar. Click Yes to confirm the 
deletion or No to cancel the deletion.

To print the address book, select the File menu Print item or click Print on the 
toolbar.

3. Select the File menu Close item to return to the Main window.

Caution: Deleting an address at this point deletes the address from Sterling Commerce:Mail 
permanently.
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Creating and maintaining distribution lists
On the Address Book window, you can create distribution lists. Distribution lists are groups 
of people you regularly send the same messages to.

Creating a distribution list
To create a distribution list:

1. Select the Tools menu Address Book item or click Address Book on the toolbar. The 
Address Book window appears.

2. Select the File menu New Distribution List item or click New List on the toolbar. A 
new distribution list folder appears in the Distribution List area. The new distribution 
list is highlighted and has the generic name List#.

3. Type a new name for the distribution list. 
4. Press Enter to save the distribution list.

Maintaining distribution lists
Once you create distribution lists, you will want to view, copy, and delete addresses to and 
from these distribution lists. Use the shortcut menu Copy, Move, Paste, and Delete items to 
complete these tasks. Sterling Commerce:Mail includes a drag-and-drop feature that allows 
you to move your addresses from list to list. The following table explains how to maintain 
distribution lists and addresses.

To Complete the following steps

Copy an address to an 
existing distribution list

1. In the Distribution List area, click the distribution list that 
contains the address you want to copy to another list. The 
addresses appear in the right side of the Address Book window.

2. Right-click the address you want to copy to another list. The 
shortcut menu appears.

3. Select the shortcut menu Copy item. This copies the address.

4. In the Distribution List area, right-click the distribution list you 
want to copy the address to. The shortcut menu appears.

5. Select the shortcut menu Paste item to copy the address to the 
selected distribution list. The distribution list opens and the 
address appears in the right side of the Address Book window.

Move an address to 
another distribution list

1. Click and hold the left mouse button on an address in a 
distribution list.

2. Using the mouse, drag the message to another distribution list.

3. When the mouse pointer is on the distribution list folder, release 
the left mouse button.
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Searching distribution lists for addresses
You can use the Find menu option to search through a distribution list for an address. 

To search a distribution list for an address:

1. In the Distribution list area of the Address Book window, click the distribution list 
you want search. All of the addresses in the selected list appear in the right side of the 
window.

Delete an address from a 
list

1. In the Distribution List area, click the distribution list you want to 
delete an address from. The addresses in this list appear in the 
right side of the Address Book window.

2. Click the address you want to delete. 

3. Select the Edit menu Delete item or click Delete on the toolbar 
to delete the address from the selected list.

Note: You can also delete an address from a distribution list by 
right-clicking the address. The shortcut menu appears. Select 
the Delete item to delete the address.

Delete a distribution list 1. In the Distribution List area, click the distribution list you want to 
delete.

2. Select the Edit menu Delete item or click Delete on the toolbar. 
The list is permanently deleted from Sterling Commerce:Mail. 
Once you delete a distribution list, there is no way to recover it. 
This action deletes only the distribution list. The addresses in 
the distribution list remain in the address book.

Print a distribution list 1. In the Distribution List area, click the distribution list you want to 
print.

2. Select the File menu Print item or click Print on the toolbar to 
print the distribution list. 

Note: The find feature searches only the selected distribution list. Sterling Commerce:Mail does 
not search every list to locate the address you are trying to find.

To Complete the following steps
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2. Select the Edit menu Find item. 
OR

Right-click a distribution list. The shortcut menu appears. Select the Find item.
The following window appears.

3. Click a radio button to select which search criteria you want to search with:

Alias searches for a match in the Alias Name area of an address. Sterling 
Commerce:Mail looks for addresses containing a part of or all of the name you 
enter. If you select the Alias radio button, in the Search String field, type a part or 
all of the person’s given name and surname you want to search for.

E-Mail Address searches for an e-mail address. Sterling Commerce:Mail looks 
for addresses containing a part of or all of the address you enter. If you select the 
E-mail Address radio button, in the Search String field, type a part or all of the 
e-mail address you want to search for.

4. Click OK to begin the search. Sterling Commerce:Mail searches for addresses 
matching the search string. When a match or matches are found, the messages are 
highlighted. Or click Cancel to cancel the search. Sterling Commerce:Mail returns 
you to the Address Book window.

Importing distribution lists
On the Address Book window, you can import a distribution list. This copies a distribution 
list from another location on your local or network drive to your address book.
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Import Address toolbar button

To import a distribution list:

1. Select the Tools menu Address Book item or click Address Book on the toolbar. The 
Address Book window appears. Then, select the Tools menu Import item to import a 
distribution list.

OR
Click Import Address on the toolbar to import an address.
The following window appears.

Distribution lists have an .ADR extension.
2. Click the Look in list box and select the local or network drive that contains the 

distribution list you want to import. Click a location to select it. Once you select a 
location, the folders and files the location contains appear in the area below the Look 
in list box.

3. Highlight the folder containing the distribution list you want to import by clicking it 
once. Click Open. The folder opens and its name appears in the Look in list box. The 
folder contents appear in the area below the Look in list box.

Note: The distribution list you import must have been created using Sterling Commerce:Mail.

Note: Use the Files of type list box to specify a type of file you want to appear. If the file type is 
not contained in the folder, nothing appears.
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4. Highlight the distribution list you want to import by clicking it once. Click Open to 
import the distribution list or Cancel to exit without importing. Sterling 
Commerce:Mail returns you to the Address Book window.
If you click Open, the distribution list appears in the Distribution List area. 

Specifying Import preferences
On the Address Book window, you can specify preferences for importing distribution lists. 
This feature allows you to indicate whether duplicate addresses are overwritten or ignored 
during the import process.

To specify import preferences:

1. Select the Tools menu Address Book item or click Address Book on the toolbar. The 
Address Book window appears.

2. Select the View menu Options item. The following window appears.

3. Select either Overwrite Duplicate Records or Ignore Duplicate Records. The 
default setting is to ignore all duplicate addresses when you import a distribution list.

4. Click OK to save your selection or Cancel to exit without saving. Sterling 
Commerce:Mail returns you to the Address Book window.

Note: To delete a distribution list, highlight the list in the Distribution List area by clicking it 
once. Then select the Edit menu Delete item or click Delete on the toolbar.

Note: Both the Edit menu Delete item and the Delete toolbar button delete the list from the 
address book. The list itself is not removed from your system.
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Exporting distribution lists
On the Address Book window, you can export a distribution list to another location. 
Exporting a distribution list moves a distribution list from your address book to another 
location on your local or network drive.

To export a distribution list:

1. Select the Tools menu Address Book item or click Address Book on the toolbar. The 
Address Book window appears.

2. In the Distribution List area, click the distribution list you want to export.
3. Select the Tools menu Export item to export a distribution list. The Save As window 

appears.

4. As needed, change the distribution list names in the File name field. When the 
distribution list is exported to the location you specify in the next step, this is its new 
name.

5. Click the Save in list box and select the local or network drive you want to export the 
distribution list to. When you select a location, all folders within that location, as well 
as any files, appear in the view area located below the Save in list box.

6. Highlight the folder you want to export the distribution list to by clicking it once. 
Click Open or double-click the folder. All files within that folder, as well as any 
subfolders, appear in the view area below the list box.

7. Click Save to export the distribution list or Cancel to cancel the export. Sterling 
Commerce:Mail returns you to the Address Book window.

Note: All distribution lists should be saved with an .ADR extension. Sterling Commerce:Mail 
defaults to using this extension.
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Sending distribution lists to others
On the Sterling Commerce:Mail Main window, you can use the Send Distribution List 
menu option to send distribution lists to others. This feature provides a way for Sterling 
Commerce:Mail users to receive and use distribution lists you have created. Recipients can 
use these distribution lists just like distribution lists they have created. In addition, 
addresses from the distribution lists you send are added to the recipients’ All folder.

To send a distribution list:

1. On the Sterling Commerce:Mail Main window, select the Tools menu Send 
Distribution List item. The following window appears.

2. In the List Name field, click the distribution list you want to send. Click OK to add 
the distribution list as a message attachment. The Message window appears. Or, click 
Cancel to return to the Sterling Commerce:Mail Main window.

Note: Only Sterling Commerce:Mail users can use distribution lists you send.



Sending distribution lists to others

IBM Sterling Gentran:Director Connection User Guide 57

3. Select the Address button to specify who will receive the message and distribution 
list. You must select an address before the message can be sent.
After you select the Address button, the Address window appears. On this window, do 
one of the following:

 

4. To send the completed message to the Outbox folder, on the Message window, select 
the File menu Send Message to Outbox item or click Send to Outbox on the toolbar. 
After the message is sent or saved, Sterling Commerce:Mail returns you to the Main 
window.

Receiving and using a distribution list
When you receive a distribution list, it is added to your list of available distribution lists. 
The distribution list retains the name the sender has assigned. In addition, any addresses not 
in your All folder are copied from the distribution list to your All folder. If you receive a 
distribution list having a name identical to that of a list you created, the addresses in the 
received list are added to the existing list. The received list does not overwrite an existing 
list.

To receive and use distribution lists:

1. Request a distribution list from another Sterling Commerce:Mail user.
2. Access the Sterling Commerce:Mail Main window and retrieve your messages by 

selecting the File menu Retrieve Mail item or Send/Retrieve Mail item or clicking 
Send/Retrieve Mail on the toolbar. 

You can For more information, see

Address the message Addressing a message on page 9

Add addresses to your address book Adding and editing addresses in the address 
book on page 44

Create a distribution list Creating and maintaining distribution lists on 
page 50

Note: Depending on the network, if the provided address cannot be identified, you may receive 
a message indicating your message was undeliverable to certain recipients and the reasons 
why.

Note: Be sure to save your message before exiting or the message will be lost. Once you have 
sent the message to the Outbox folder, you can send the message to its recipients by 
selecting the File menu Send Mail item or clicking Send Mail on the toolbar.

Note: To be received and used, the distribution list must have been created using Sterling 
Commerce:Mail. To use a distribution list you have just received, you must exit and 
re-enter Sterling Commerce:Mail.
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3. Open your new messages. If you have received a distribution list, exit Sterling 
Commerce:Mail by clicking Exit on the toolbar.

4. Access Sterling Commerce:Mail again.
5. Select the Tools menu Address Book item or click Address Book on the toolbar. The 

Address Book window appears. 

The Distribution List area now contains your new distribution list. Addresses in this list 
have been added to your address book.
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Chapter 4

Folders

Folders are storage places for messages and other folders, called subfolders.

✦ Message is an electronic document made up of a sender and recipient name, a subject 
and text, plus any attachments.

✦ Attachment is any text or binary file that the user includes with a message. 
Attachments can be EDI data, indexes or distribution lists, or any file, whether in PC 
or Macintosh format. Sterling Commerce:Mail can encrypt attachments. However, 
only other Sterling Commerce:Mail users can decrypt and read these attachments.

There are two types of folders:

✦ Main folder is a folder that contains subfolders. A main folder allows you to group 
related subfolders in one location.

✦ Subfolder is a folder that contains only messages and attachments. Sterling 
Commerce:Mail has five system subfolders. The system subfolders are a permanent 
part of Sterling Commerce:Mail and cannot be renamed, moved or deleted.

See System subfolders on page 60 for more information.

You can create your own main folders and subfolders. You can also rename, move, and 
delete the main folders and subfolders you have created.
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System Folders main folder
Sterling Commerce:Mail creates one main folder, called System Folders. 

The System Folders main folder contains the five system subfolders, which are folders 
created by Sterling Commerce:Mail. The Systems Folders main folder is a permanent 
fixture of Sterling Commerce:Mail and is located in the Folders area of the Main window.

System subfolders
Sterling Commerce:Mail has five system subfolders, which are folders created by Sterling 
Commerce:Mail. The system subfolders are:

✦ Draft
✦ Inbox
✦ Outbox
✦ Sent
✦ Trash 
System subfolders are located in the System Folders main folder. System subfolders are a 
permanent fixture of Sterling Commerce:Mail. Many of the procedures you perform 
involve using the system subfolders. For example, when you retrieve mail from your 
mailbox, Sterling Commerce:Mail places your mail in the Inbox folder.

Sterling Commerce:Mail also allows you to create your own main folders and subfolders. 
See Creating a folder on page 65 for more information.

Note: You cannot delete, move, or rename system subfolders. However, if you attempt to delete 
a system subfolder, all messages and attachments in the folder will be deleted and moved 
to the Trash folder.

System
subfolders

System
Folders
main
folder
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Using the Draft folder
Click Draft in the Folders area of the Main window to open the Draft folder. Use the Draft 
folder to store incomplete messages and messages you want to send again. 

Draft folder stores messages that are incomplete. Messages stay in the Draft folder until 
you delete them or move them to another folder.

If interrupted while creating a message, you can use the Draft folder to store your message 
without losing any of the information you have already included.

When you attempt to close a message without specifying its destination, Sterling 
Commerce:Mail will generate a prompt window asking you if you want to save your 
message as a draft. If you click Yes, the message is stored in the Draft folder.

You can also store messages in the Draft folder that you use as templates. For example, you 
might send a monthly message containing update information. The text of the message 
changes only slightly each month. Rather than create a new message each month, you can 
store the message in the Draft folder and update it.

Once you open the Draft folder, you can do any of the following:

Using the Inbox folder
Use the Go menu Inbox item or click Inbox on the toolbar to open the Inbox folder. You 
can also open the Inbox folder by clicking Inbox in the Folders area of the Main window.

Inbox folder stores messages you have received. Messages stay in the Inbox folder until 
you delete them or move them to another folder. 

You can For more information, see

Read a message Opening a message on page 11

Edit a message Opening a message on page 11 and then edit 
message information

Search for a message Searching a folder for messages on page 68

Store a message in a new or existing 
folder

Maintaining folders and messages in a folder on 
page 67

Delete a message Deleting a message on page 16

Print a message and any files attached to 
that message

Printing a message on page 17
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Once you have opened the Inbox folder, you can do any of the following:

Using the Outbox folder
Use the Go menu Outbox item or click Outbox on the toolbar to open the Outbox folder. 
You can also open the Outbox folder by clicking Outbox in the Folders area of the Main 
window.

Outbox folder stores messages you created and want to send to other users. Use the Outbox 
folder to review, change, or delete unsent messages. Messages must be stored in the Outbox 
folder before they can be sent to other users.

Rather than sending messages individually, one at a time, which would require you to 
initiate individual communications sessions with IBM® Sterling B2B Collaboration 
Network, you can store a group of messages in the Outbox folder and send them all at once.

When you send messages, Sterling Commerce:Mail moves the messages in the Outbox 
folder to the Sent folder.

You can For more information, see

Read a message Opening a message on page 11

Edit a message Opening a message on page 11 and then edit 
message information

Search for a message Searching a folder for messages on page 68

Store a message in a new or existing 
folder

Maintaining folders and messages in a folder on 
page 67

Delete a message Deleting a message on page 16

Print a message and any files attached to 
that message

Printing a message on page 17

Reply to a message Replying to a message on page 15
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Once you have opened the Outbox folder, you can do any of the following:

Using the Sent folder
Use the Go menu Sent item to open the Sent folder. You can also open the Sent folder by 
clicking Sent in the Folders area of the Main window.

Sent folder stores messages you have sent to other users. When you send a message, 
Sterling Commerce:Mail moves it from the Outbox folder to the Sent folder. Sent messages 
remain in the Sent folder until you move them or place them in the trash.

Once you have opened the Sent folder, you can do any of the following:

You can For more information, see

Read a message Opening a message on page 11

Edit a message Opening a message on page 11 and then edit 
message information

Search for a message Searching a folder for messages on page 68

Send a message Sending and retrieving messages on page 14

Store a message in a new or existing 
folder

Maintaining folders and messages in a folder on 
page 67

Delete a message Deleting a message on page 16

Print a message and any files attached to 
that message

Printing a message on page 17

Note: Messages that cannot be sent remain in the Outbox folder until you correct and send them, 
delete them, or move them to another folder.

You can For more information, see

Read a message Opening a message on page 11

Search for a message Searching a folder for messages on page 68

Store a message in a new or existing 
folder

Maintaining folders and messages in a folder on 
page 67

Delete a message Deleting a message on page 16

Print a message and any files attached to 
that message

Printing a message on page 17
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Using the Trash folder
Use the Go menu Trash item to open the Trash folder. You can also open the Trash folder 
by clicking Trash in the Folders area of the Main window.

Trash folder stores messages you want to delete permanently from Sterling 
Commerce:Mail. Messages appear in the Trash folder only when you have placed them 
there. 

Once you have opened the Trash folder, you can do any of the following:

Emptying the Trash folder
When you place a message in the Trash folder, it is not automatically deleted from Sterling 
Commerce:Mail. The message stays in the Trash folder until you empty the folder or exit 
Sterling Commerce:Mail. 

You can empty the Trash folder by doing either of the following:

✦ Selecting the File menu Empty Trash item.
✦ Exiting Sterling Commerce:Mail. All messages in the Trash folder are automatically 

deleted.

Removing a message from the Trash folder
To remove a message from the Trash folder:

1. Open the Trash folder by selecting the Go menu Trash item or clicking Trash in the 
Folders area of the Main window. Messages contained in the folder appear in the 
Message Details area.

You can For more information, see

Read a message Opening a message on page 11

Search for a message Searching a folder for messages on page 68

Store a message in a new or existing 
folder

Maintaining folders and messages in a folder on 
page 67

Delete a message Deleting a message on page 16

Print a message and any files attached to 
that message

Printing a message on page 17

Permanently delete all messages in the 
Trash folder

Emptying the Trash folder on page 64

Caution: You cannot recover messages once the Trash has been emptied.
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2. Click and hold the left mouse button on a message.
3. Using the mouse, drag the message to another folder.
4. When the mouse pointer is on the folder, release the left mouse button.

Creating a folder
You can use the Create or Create New Folder menu options to create new folders. Or you 
can click New Folder on the toolbar. Folders appear in the Folders area of the Main 
window and are used for storing and maintaining your Sterling Commerce:Mail messages 
and attachments. 

There are two types of folders:

✦ Main folder is a folder that contains subfolders. A main folder allows you to group 
related subfolders in one location.

✦ Subfolder is a folder that contains only messages and attachments.

Creating a main folder
To create a main folder:

1. Select the Folder menu Create item or the File menu Create New Folder item. The 
Create Folder window appears.

The Main Folder radio button is the default selection when the Create Folder window 
first appears.

2. Click OK to create a new main folder or Cancel to exit without saving the folder. 
If you click OK, Sterling Commerce:Mail returns you to the Main window and a new 
main folder appears in the Folders area of the Main window. The new folder is 

Note: You can also use the Message menu Move Messages and Copy Messages items to remove 
a message from the Trash folder. See Maintaining folders and messages in a folder on 
page 67 for more information.
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highlighted and has the generic name New Folder. You can keep the generic name or 
you can type a new name for the folder.

3. Press Enter to save the folder.

Creating a subfolder
To create a subfolder:

1. Select the Folder menu Create item or the File menu Create New Folder item. The 
Create Folder window appears.

2. Select the Subfolder option in the Folder Type area. The Main Folders list box 
becomes active.

3. Click the Main Folders list box and select which main folder to insert the subfolder 
into.

4. Click OK to create a new subfolder or Cancel to exit without saving the subfolder.
If you click OK, Sterling Commerce:Mail returns you to the Main window and a new 
subfolder appears in the Folders area of the Main window inside the main folder you 
selected in step 3. The subfolder is highlighted and has the generic name New Folder. 
You can keep the generic name or you can type a new name for the folder.

5. Press Enter to save the folder.

Renaming a folder
You can use the Rename Folder menu option to change the name of an existing folder.

To rename a folder:

Note: If you type a new name, the folder name is case sensitive and must be unique. Also, folder 
names cannot contain the following characters:

\ / : * ? “ < > | .

Note: If you type a new name, the folder name is case sensitive and must be unique. Also, folder 
names cannot contain the following characters:

\ / : * ? “ < > | .

Note: Sterling Commerce:Mail allows you to rename folders only you have created. You cannot 
rename the Sterling Commerce:Mail Inbox, Outbox, Trash, Draft, and Sent system 
subfolders.
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1. Click the folder you want to rename in the Folders area of the Main window. 
2. Select the Folder menu Rename Folder item or press the F2 key. This highlights the 

folder name.
3. Type the new folder name. The folder name is case sensitive and must be unique.

4. Press Enter to save the new name.

Maintaining folders and messages in a folder
Once you create folders, Sterling Commerce:Mail includes a drag-and-drop feature that 
allows you to move your subfolders to other main folders.

✦ Main folder is a folder that contains subfolders. A main folder allows you to group 
related subfolders in one location.

✦ Subfolder is a folder that contains only messages and attachments.

Once you create folders to store your messages, you will want to view, add, and delete 
messages to and from these folders. Use the Delete Message, Move Message, and Copy 
Message menu options to complete these tasks. You can also use the drag and drop 
capability to move messages.

The following table explains how to maintain folders and messages:

Note: Folder names cannot contain the following characters:

\ / : * ? “ < > | .

Note: You can move only subfolders. You cannot move a main folder into another main folder.

Note: Sterling Commerce:Mail allows you to move or copy a message to the Outbox or Draft 
folder only if you have created the message.

To Do the following

Move subfolders to a main 
folder

1. Click and hold the left mouse button on a subfolder you 
want to move. 

2. Using the mouse, drag the subfolder to a main folder.

3. When the mouse pointer is on the main folder, release the 
left mouse button. 
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Searching a folder for messages
You can use the Search menu option to search for a message in a folder.

To search through a folder:

1. Click the folder you want search in the Folders area of the Main window. All of the 
messages in the selected folder appear in the Message Details area of the window.

View messages in a folder 1. Double-click any message in the folder.

2. To view all the messages in the folder, select the Edit menu 
Select All item and then select the File menu Open 
Message item. The message or messages open.

Move messages to a folder 1. Click and hold the left mouse button on a message in a 
folder. 

2. Using the mouse, drag the message to another folder.

3. When the mouse pointer is on the folder, release the left 
mouse button. 

Note: You can also click a message and then select the 
Message menu Move Messages item. 

Copy messages to a folder 1. Press and hold the CTRL key.

2. Click and hold the left mouse button on a message in a 
folder. 

3. Using the mouse, drag the message to another folder. 

4. When the mouse pointer is on the folder, release the left 
mouse button.

Note: You can also click a message and then select the 
Message menu Copy Messages item.

Place messages in Trash 
folder and remove message 
permanently

1. Click the message you want to delete. To delete all 
messages in the folder, select the Edit menu Select All item.

2. Select the Edit menu Delete Message item or click the 
Delete toolbar button. The selected message or messages 
are placed in the Trash folder. 

3. Select the File menu Empty Trash item or exit Sterling 
Commerce:Mail. This action deletes all the messages in the 
Trash folder.

Note: The search feature searches through only the selected folder. Sterling Commerce:Mail does 
not look through every folder to locate the message you are trying to find.

To Do the following
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2. Select the Folder menu Search item. The Search Folder window appears.

3. Specify your search criteria in the following entry fields:

Subject searches for a match in message subject lines. Type alphanumeric 
characters. This field is not case sensitive. The search function automatically uses 
the information to perform a wildcard search.

Address searches for an address. Sterling Commerce:Mail looks for messages 
containing a part of or all of the address you enter.The search function 
automatically uses the information to perform a wildcard search.

Since mm/dd/yyyy searches for messages dated after the month, date and year 
you specify. Type the date in MM/DD/YYYY format or click the calendar button 
in the right side of the field to use the calendar to select a date. 

Read Messages searches for messages you have read or marked as read. 

Unread Messages searches for messages you have not read. 

4. Click Search to begin the search. Sterling Commerce:Mail searches for messages 
matching the search criteria. When a match or matches are found, the messages are 
highlighted. Or click Cancel to cancel the search. Sterling Commerce:Mail returns 
you to the Main window.

Selecting all messages in a folder
You can use the Select All menu option to select all messages in a folder to open or to place 
in the Trash folder.

To select all the messages in a folder:

1. Click a folder in the left side of the Main window. All messages in the selected folder 
display on the right side of the Main window. 

Note: You can combine any of the search criteria for a more specific search.



Chapter 4   Folders

70 IBM Sterling Gentran:Director Connection User Guide

2. Select the Edit menu Select All item. All of the messages in the folder are selected. 
Once you have selected all the messages in a folder, you can do any of the following:

Deleting a folder
You can use the Delete menu option to delete non-system folders. 

Non-system folders are folders you create.

To delete a folder:

1. Click the non-system folder you want to delete in the left side of the Main window.
2. Select the Folder menu Delete item. The selected non-system folder is deleted and the 

messages in the folder are moved to the Trash folder.

To delete the messages in the Trash folder, select the File menu Empty Trash item or exit 
Sterling Commerce:Mail. All messages in the Trash folder are deleted.

You can For more information, see

Open the messages Opening a message on page 11

Delete the messages Deleting a message on page 16 

Move the messages Maintaining folders and messages in a folder on page 67

Copy the messages Maintaining folders and messages in a folder on page 67

Caution: When you delete a folder, all messages within the folder are moved to the Trash. Once 
you delete a folder, the folder cannot be retrieved. Once you empty the Trash folder, the 
deleted messages cannot be retrieved. You cannot delete the Inbox, Outbox, Trash, 
Draft, or Sent system folders. You can only delete non-system folders. However, 
attempting to delete a system folder moves all messages in the folder to the Trash.
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Chapter 5

Utilities

Sterling Commerce:Mail has several utility features. These features allow you to customize 
Sterling Commerce:Mail to more closely match your business needs. Using these utility 
features, you can make Sterling Commerce:Mail more or less automated. The utility 
features allow you to:

✦ Create and edit rules for your mail.
✦ Create schedules for Sterling Commerce:Mail to send and retrieve your mail 

automatically.
✦ Set Windows printer options and to select printing specifications, including default 

printer and quality of printing.
✦ Specify your default printer and its setup.
✦ Create dial-up connections and mailboxes without opening Sterling Connection 

Manager.
✦ Open Sterling Connection Manager.
✦ Request status data about a particular mailslot.
✦ Restore EDI data to your mailbox when EDI data has not been retrieved successfully 

from IBM® Sterling B2B Collaboration Network.
✦ Specify mailbox, dial-up connection and confirmation defaults.
✦ Empty the trash.
✦ Exit Sterling Commerce:Mail.

Scheduling mail
You can schedule when Sterling Commerce:Mail sends and receives messages. Once you 
have set up the Schedule Mail feature, you do not have to be at your PC to send and receive 
messages. As long as your PC and modem are turned on and Sterling Commerce:Mail is 
running, Sterling Commerce:Mail can send and receive your messages.
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To create a send and receive schedule:

1. Select the Tools menu Schedule Mail item. The following window appears.

2. Specify whether you want to send and receive mail at an interval or at a specific time. 

At Scheduled Interval tells Sterling Commerce:Mail to send and receive 
messages at regular intervals. 

At Scheduled Times tells Sterling Commerce:Mail to send and receive messages 
at specific times. Sterling Commerce:Mail can send and receive messages up to 
three times in a 24-hour period.

3. Select one of the following:

If you selected At Scheduled Interval, in the Scheduled Interval area, select 
how many minutes you want between sending and receiving messages. You can 
select from once every three minutes to once every 180 minutes. 

If you selected At Scheduled Times, in the Scheduled Times area, select the 
exact times you want Sterling Commerce:Mail to dial the network. You can 
specify three separate times. Click the Enable check boxes to activate times. If a 
check box next to a time is unchecked, Sterling Commerce:Mail will not initiate a 
session for this time.

4. Click the Enable Scheduled Mail Delivery and Retrieval check box to send and 
receive messages as you have scheduled.

Note: Time is based on the time set by your computer. To specify hour and minutes, type the hour 
and minutes in the available fields or use the Up Arrow or Down Arrow key to scroll to 
the appropriate hour and minute.

Note: If this box is not checked, messages are not sent or received as requested. Sterling 
Commerce:Mail provides this feature so you can turn off your request without losing your 
settings.
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5. Click OK to save the settings or Cancel to cancel the settings. Sterling 
Commerce:Mail returns you to the Main window.

Using Sterling Connection Manager
You can use the Sterling Connection Manager/Comm Log menu option to access Sterling 
Connection Manager. 

To access Sterling Connection Manager:

1. Select the Tools menu Sterling Connection Manager item. The Sterling Connection 
Manager Main window appears.

2. Complete any appropriate Sterling Connection Manager tasks.
3. Exit Sterling Connection Manager by selecting the File menu Exit item. Sterling 

Connection Manager closes, returning you to the Sterling Commerce:Mail Main 
window.

See Sterling Connection Manager on page 113 for more information.

Setting up Internet connections
You can use the Connection Setup menu option to create, change, delete, or copy 
connections to the Internet.

Setting up mailboxes
You can use the Mailbox Setup menu option to specify the network mailbox and mailslot 
you want to use when sending and receiving information using Sterling Commerce:Mail. 
See Viewing and deleting mailboxes on page 122 for more information.

Note: After you click the Enable Scheduled Mail Delivery and Retrieval check box, Auto appears 
in the Status Bar at the bottom of the Main window to remind you that Schedule Mail is 
enabled.
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Specifying defaults
You can use the Options item to specify mailbox setup, dial-up connection, and 
confirmation window defaults.

To specify your defaults:

1. Select the View menu Options item.
OR

Double-click the Mailbox Setup area or the Connection Setup area in the status bar. 
See Status bar on page 4 for more information.

2. Select the following tabs to specify your defaults:

Mailbox to specify the mailbox setup you want Sterling Commerce:Mail to use 
when sending and retrieving mail. The mailbox setup must be specified before 
you can use Sterling Commerce:Mail. You can also specify the type of data 
Sterling Commerce:Mail retrieves. For example, you can specify that only e-mail 
is retrieved. See Specifying mailbox defaults on page 74 for more information.

Connectivity to specify the connection setup you want Sterling Commerce:Mail 
to use when connecting to the Internet. The connection setup must be specified 
before you can begin a communications session with the Internet. See Specifying 
connectivity defaults on page 76 for more information.

Confirmations to specify which confirmation windows appear after you request a 
certain action. For example, you can specify a confirmation to appear before 
exiting the program. See Specifying confirmation windows on page 78 for more 
information.

3. Click OK to save your changes or Cancel to cancel the changes. Sterling 
Commerce:Mail returns you to the Main window.

Specifying mailbox defaults
You can specify the mailbox setup Sterling Commerce:Mail uses when connecting to the 
Internet. The Options item allows you to change the selected mailbox setup if you are 
switching sessions. In addition, use this item to specify the type of data Sterling 
Commerce:Mail retrieves during a session.

Note: You need to create the mailbox setup using Sterling Connection Manager or Sterling 
Commerce:Mail before you can use Sterling Commerce:Mail. If you have created only one 
mailbox setup, Sterling Commerce:Mail uses that setup by default. See Creating a 
mailbox on page 119 for more information.
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To specify the default mailbox setup:

1. Select the View menu Options item. 
OR

Click the Mailbox Setup area in the status bar. See Status bar on page 4 for more 
information.
The following window appears. When the Options window first appears, the Mailbox 
tab is selected by default.

2. Click the Mailbox list box and select the mailbox you want Sterling Commerce:Mail 
to use when connecting to the Internet.

3. Click the Retrieve Data of Type list box and select which kind of data Sterling 
Commerce:Mail retrieves:

E-Mail indicates that you intend to receive only e-mail messages. This is the 
default selection. 

EDI Data indicates that you intend to receive only EDI data.

E-Mail and EDI Data indicates that you intend to receive e-mail and EDI data.

Caution: If you intend to use Sterling Commerce:Mail to receive EDI data and you do not have 
EDI Data selected, you will not receive any EDI data that has been sent to you.
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4. Click OK to save your selections or Cancel to cancel your selections. Sterling 
Commerce:Mail returns you to the Main window.
The next time you send or receive messages, this mailbox setup is used. 

Specifying connectivity defaults
You can specify the dial-up connection Sterling Commerce:Mail uses to connect to the 
Internet. The Options item allows you to change the selected dial-up connection if you are 
switching sessions. In addition, use this item to specify whether the Internet connection is 
automatically disconnected after your mail has been sent and retrieved.

To specify the default dial-up connection:

1. Select the View menu Options item. 
OR

Click the Connection Setup area in the status bar. See Status bar on page 4 for more 
information.
The Options window appears.

Caution: When you click OK, any changes you made to any other tabs on the Options window 
are also saved.

Note: If you do not specify a dial-up connection for Sterling Commerce:Mail to use, Sterling 
Commerce:Mail will use any existing connection you have.
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2. Click the Connectivity tab.

3. Click the Connect to the Internet as needed check box. The Dial-Up list box 
becomes active.

4. Click the Dial-Up list box and select the dial-up connection you want Sterling 
Commerce:Mail to use. If you have created only one dial-up connection, it is already 
selected by default.

5. The Disconnect following Send/Receive check box is selected by default. Click the 
check box if you want to deselect this option. 

6. Click OK to save your selections or Cancel to cancel you selections. Sterling 
Commerce:Mail returns you to the Main window. 
The next time you send or receive messages, this connection is used.

Note: If you deselect this check box, you will have to manually disconnect after each 
send/receive session. However, if you want to use your browser while sending and 
receiving mail, and you do not want your connection interrupted while browsing, you 
should deselect this check box.

Caution: When you click OK, any changes you made to any other tabs on the Options window 
are also saved.
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Specifying confirmation windows
You can specify the confirmation windows that appear when you perform certain actions. 
You can specify that confirmation windows appear or not appear. The Sterling 
Commerce:Mail default is to show the confirmation windows.

To specify confirmation windows:

1. Select the View menu Options item. The Options window appears.
2. Click the Confirmations tab.

3. Click the confirmation window check boxes to select or deselect confirmations. If a 
confirmation check box is checked, the confirmation window appears when the 
corresponding action is requested. If the check box is clear, the window does not 
appear. The check boxes are:

Exit Sterling Commerce:Mail to specify whether you view a window confirming 
your exit of Sterling Commerce:Mail.

Delete Message to specify whether you view a window confirming the placement 
of a message in the Trash folder.

Delete Folder to specify whether you view a window confirming the deletion of a 
folder and all messages in that folder.

Caution: If you deselect a check box for a confirmation window, when the corresponding action 
is requested, Sterling Commerce:Mail performs the requested action without a 
warning. For example, if you deselect the Empty Trash check box and you 
inadvertently empty the trash, there is no safeguard to prevent losing any messages 
contained in the Trash folder.
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Empty Trash to specify whether you view a window confirming the deletion of 
all messages in the Trash folder. When you empty the trash, all messages in the 
Trash folder are permanently deleted from your hard drive.

Copy/Move to Outbox/Draft to specify whether you view a window reminding 
you that only messages that you have created can be moved or copied to the 
Outbox and Draft subfolders.

4. Click OK to save changes or Cancel to cancel the changes. Sterling Commerce:Mail 
returns you to the Main window.

Printing/Setting up to print
Use the Print and Print Setup menu options to set Windows printer options and to select 
printing specifications, including default printer and quality of printing.

Some windows in Sterling Commerce:Mail have their own print buttons or menus. The 
print functionality on these windows is the same as that accessed through the Print or Print 
Setup menu options.

Printing information
To print:

1. Select the File menu Print item or click Print on the toolbar. The Print window 
appears. 

2. As needed, specify the print quality of the document, the number of copies you want 
to print, and if you want copies collated. 

3. As needed, click Properties to specify paper, graphics device options, and PostScript® 
properties. The Properties button also appears on the Print Setup window.
See Specifying default printer setup and properties on page 79 for more 
information.

4. Click OK to begin printing.

Specifying default printer setup and properties
To specify the default printer setup and properties:

1. Select the File menu Print Setup item. The Print Setup window appears. 
2. As needed, change the default printer, paper size, and orientation.

Caution: When you click OK, any changes you made to any other tabs on the Options window 
are also saved.



Chapter 5   Utilities

80 IBM Sterling Gentran:Director Connection User Guide

3. Click Properties to specify paper, graphics device options, and PostScript properties. 
The Properties button also appears on the Print window. The properties fields are:

Exiting Sterling Commerce:Mail
Select the File menu Exit item or click Exit on the toolbar to exit from Sterling 
Commerce:Mail and return to the Windows operating system.

Note: The selections that appear will vary, depending on the type of printer you are using.

Field  Definition

Paper size Paper sizes supported by your printer.

Layout Number of pages of your document to print on one sheet of 
paper.

Orientation Position of your document on the paper.

Paper source Location in the printer of the paper you want to use.

Copies Number of copies you want to print.

Resolution Dots per inch used when you print.

Halftoning Number of lines per inch and the angle you want to use for 
halftone screens.

Special Check box selections for printing a negative or mirror image of 
your document.

Scaling Sizing of your document for printing.

Printer features Features and their settings specific to your printer.

Change setting for Changes the value for the selected feature in the Printer 
features field.

PostScript output format Format for PostScript files.
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Chapter 6

Rules Agent

Use Rules Agent option from the Tools menu to create rules that control how Sterling 
Commerce:Mail responds when you receive messages. For example, you can create a rule 
specifying that you want to be notified about all incoming messages that contain the word 
Urgent in the Subject line of the message.

✦ Conditions define the circumstances under which Sterling Commerce:Mail performs 
an action.
Conditions apply to message variables and Sterling Commerce:Mail folders. For 
example, you can specify the following condition: all messages you receive whose 
Subject line contains the words Project X. 

✦ Actions notify you or perform a process when a rule’s conditions have been met.
Examples of actions are playing a sound file or displaying a notification window. You 
can also specify actions that instruct Sterling Commerce:Mail to perform a process 
when conditions are met. For example, you can create a rule instructing Sterling 
Commerce:Mail to copy a message to a specified folder.

Using the Rules option, you can:

✦ Name a rule and specify its details.
✦ Create a rule script by specifying its conditions and actions.
✦ Edit a rule by inserting conditions or replacing conditions.
✦ Edit a rule by inserting actions or replacing actions.
✦ Edit a rule by deleting conditions or actions.
✦ Delete a rule.
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Viewing the Rules Agent
The Rules Agent window is the storage place for your rules.

To view the Rules Agent:

✦ Select the Tools menu Rules Agent item. The Rules Agent window appears.

The Rules Agent window contains three areas. These areas contain information about your 
rules: 

✦ Description shows the rule description name. 
✦ Execute shows when the rule is executed.
✦ Active shows whether the rule is activated or not.

Naming a rule
Before you specify conditions and actions, you need to create a container for your rule. You 
do this by naming the rule and specifying its details. Details specify when a rule is executed 
and whether the rule is active or inactive. Once you name the rule and specify its details, 
you save it in the Rules Agent.

To specify conditions and actions for a rule, you must create a script for the rule. See 
Creating a script for a rule on page 84 for more information.

To name a rule and specify its details:

1. Click the Tools menu Rules Agent item. The Rules Agent window appears.
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2. Click New. The Rule Detail window appears:

3. Type a description for the rule in the Description field. This is the name that appears 
on the Rules Agent window, so the description should contain enough information to 
allow you to recognize what the rule is for.

4. Click the Execute list box and select one of the following:

On Retrieve executes the rule each time you retrieve your mail.

On Start executes the rule each time you start Sterling Commerce:Mail.

On Exit executes the rule each time you exit Sterling Commerce:Mail.

5. Click the Active check box to activate the rule. If you do not check this box, the rule is 
stored in the Rules Agent but does not execute.

6. Click Save to save the rule on the Rules Agent window or Close to exit without saving 
and return to the Rules Agent window.

Note: If you want to specify the conditions and actions for this rule before you save it, you can 
click Edit. The Rule Editor window appears. See Creating a script for a rule on page 84 
for more information.

Note: Even though you have named a rule and specified its details, the rule is useless until you 
specify conditions and actions for it. See Creating a script for a rule on page 84 for more 
information.
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Creating a script for a rule
A rule contains a script, which is made up of conditions and actions. When the conditions 
you specify for a rule are met, Sterling Commerce:Mail performs the actions you specify.

✦ Conditions define the circumstances under which Sterling Commerce:Mail performs 
an action.
See Specifying conditions for a rule on page 84 for more information.

✦ Actions notify you or perform a process when a rule’s conditions have been met. 
See Specifying actions for a rule on page 87 for more information.

Specifying conditions for a rule

You can specify conditions relating to message variables and Sterling Commerce:Mail 
folders. Message variables include the Subject line, To line and From line of messages. 
Sterling Commerce:Mail folders are all of the folders contained in the Folders area of the 
Sterling Commerce:Mail Main window. For example, you can specify a condition for all 
messages that contain Mr. Smith in the From line of the message and are in the Inbox 
folder. Each time Sterling Commerce:Mail retrieves a message from Mr. Smith and places 
it in the Inbox folder, the condition is met. Once the condition is met, Sterling 
Commerce:Mail initiates any associated actions you have specified. 

To specify conditions for a rule:

1. On the Rules Agent window, click the rule you want to specify conditions for.
2. Click Detail. The Rule Detail window appears.

Note: You can create a rule with only conditions or only actions. However, if you create only 
conditions or only actions, the script is incomplete. Sterling Commerce:Mail will be able 
to only recognize messages that meet conditions without performing an action or perform 
an action on all messages. For example, if you create a script with the action Print 
messages, but you do not create conditions, Sterling Commerce:Mail will print all the 
messages you receive.

Note: You should specify conditions for a rule before you specify actions. You can specify 
actions for a rule first, without specifying conditions, but if you forget to specify 
conditions, Sterling Commerce:Mail will use the rule on all messages you receive.
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3. Click Edit. The Rule Editor window appears with the Condition tab selected by 
default.

4. Click the Conditions list box and select a variable for the first line of your conditions. 
All of the variables are message variables except Message Folder. For example, if you 
want the rule to apply to the contents of the Subject line of a message, select Subject. 
The Message Folder variable refers to your folders in the Folders area of the Main 
window.

5. Click the Filter list box and select a filtering agent for the variable you selected in 
step 4. For example, if you want the rule to apply to the contents of the Subject line, 
select Contains.

If you did not select Priority or Message Folder in the Conditions list box, go to 
step 6.
If you did select Priority or Message Folder in the Conditions list box, go to 
step 7.

6. In the field, located below the Operator list box, type the dependent variable for the 
filtering agent you selected in step 5. This variable is not case sensitive. For example, 

Note: You use the Operator list box only for any additional condition lines.

Note: If you selected Priority or Message Folder in the Conditions list box in step 4, your 
selections in the Filter list box are limited to IS and IS NOT.
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if you want the rule to apply to the contents of the message Subject, type the word or 
words the Subject must contain for the rule to be applied to a message. Go to step 8.

7. Click the list box below the Operator list box:

If you selected Priority in the Conditions list box, select the dependent variable 
for the filtering agent you selected in step 5. The variables are all different levels 
of message priority.

If you selected Message Folder in the Conditions list box, select which of your 
Sterling Commerce:Mail folders will be the dependent variable for the filtering 
agent you selected in step 5.

8. Click Add. The condition line appears in the Script area.
9. As needed, add additional lines to your rule. Repeat steps 4 through 8, except that for 

each additional line you must first use the Operator list box to select AND or OR:

AND conditions are restrictive. If you select AND, the rule executes only if all 
AND conditions are met in addition to the condition defined in the first line of the 
rule. For example, if the first line of a rule defines a condition as Subject 
CONTAINS Project X and the second line defines a condition as AND Subject 
STARTS WITH Attention, the rule activates only if a Subject line contains 
Project X and starts with Attention.

OR conditions are not restrictive. If you select OR, the rule executes if any of the 
OR conditions are met. For example, if the first line of a rule defines a condition 
as Subject CONTAINS Project X and the second line defines a condition as OR 
Subject STARTS WITH Attention, the rule activates if a Subject line contains 
Project X or starts with Attention. Both conditions do not have to be present for 
the rule to activate.

10. Click OK to save the conditions or Cancel to exit without saving. Sterling 
Commerce:Mail returns you to the Rule Detail window.

Note: If you want to specify your actions for a rule before you save your conditions, you can click 
the Action tab. See Specifying actions for a rule on page 87 for more information.

Note: Even though you have specified conditions for the rule, the rule will not perform any 
actions until you specify the actions that occur when the conditions for a rule are met. See 
Specifying actions for a rule on page 87 for more information.
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Specifying actions for a rule

Once you create a rule and specify its conditions, you must specify actions that will occur 
once the conditions for a rule are met. An action can be a notification or a process.

✦ Notification actions notify you when the rule conditions have been met. For example, 
a sound plays or a notification window appears on your screen.

✦ Process actions perform a process. For example, a message is forwarded or copied.
You can specify both types of actions for a rule if you want Sterling Commerce:Mail to 
perform both types of actions when the conditions of a rule are met. For example, you can 
specify that Sterling Commerce:Mail notifies you by playing a sound and forwards the 
message to specified recipients.

Specifying actions
To specify actions for a rule:

1. On the Rules Agent window, click the rule you want to specify an action for. This 
highlights the rule. See Viewing the Rules Agent on page 82 for more information 
about the Rules Agent.

2. Click Detail. The Rule Detail window appears.

3. Click Edit. The Rule Editor window appears.

Note: You should always specify conditions for a rule before you specify actions. See Specifying 
conditions for a rule on page 84 for more information. You can specify actions for a rule 
first, but if you forget to specify conditions, Sterling Commerce:Mail will perform the 
action for every message you receive.
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4. Click the Action tab.

5. Click the Actions list box and select the action you want to occur if the conditions for 
a rule are met.

Note: When the Action tab first appears, the Play sound action is the default selection in the 
Actions list box. This selection determines that the Browse button and the Apply to area 
appears in the Action tab. For more information about this button and area, see Playing a 
sound when rule conditions are met on page 89.

If you select When the conditions of the rule are met

Play sound A sound file plays. See Playing a sound when rule 
conditions are met on page 89 for more information.

Open message The message opens.

Print message The message prints.

Notify user A notification window appears on your screen. See Specifying 
a notification message when rule conditions are met on 
page 91 for more information.

Forward message The message is forwarded to specified recipients. See 
Forwarding a message when rule conditions are met on 
page 92 for more information.

Reply using message A specified message is sent in reply. See Replying to a 
message when rule conditions are met on page 93 for more 
information.
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6. Click OK to save your information or the Cancel button to exit without saving.

Playing a sound when rule conditions are met

To specify that Sterling Commerce:Mail plays a sound when the rule conditions are met:

1. On the Action tab, click the Actions list box and select Play sound. The fields on the 
Action tab change to allow you to specify a sound.

2. Click Browse. The Open window appears. For information on using the Open 
window, see Selecting a sound on page 90.

3. Select an Apply to option:

Copy message to The message is copied to a specified location. See Copying a 
message when rule conditions are met on page 95 for more 
information.

Move message to The message is moved to a specified location. See Moving a 
message when rule conditions are met on page 96 for more 
information.

Delete message The message is deleted.

Note: Before specifying an action to occur when rule conditions are met, you should first name 
the rule and specify its conditions. See Naming a rule on page 82 and Specifying 
conditions for a rule on page 84.

If you select When the conditions of the rule are met
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Batch plays the sound once for all messages that meet conditions. For example, if 
you receive five messages during a communications session that meet conditions 
for playing a sound, the sound plays once.

Each Message plays the sound for every message that meets the conditions. For 
example, if you receive five messages during a communications session that meet 
conditions for playing a sound, the sound plays five times.

4. Click Add to add the action to the rule.The Play sound action appears in the Script 
area of the Action tab.

Selecting a sound
After selecting Play Sound in the Actions list box on the Action tab, you must select the 
sound file you want Sterling Commerce:Mail to play.

To select a sound:

1. In the Rule Editor window, click Browse. The Open window appears.

2. Click the Look in list box and select the local or network drive that contains the sound 
file you want to play when the rule conditions are met. Click a location to select it. 
Once you select a location, the folders and files the location contains appear in the 
area below the Look in list box.

3. Highlight the folder containing the sound file by clicking it once. Click the Open 
button. The folder opens and its name appears in the Look in list box. The folder 
contents appear in the area below the Look in list box.

Note: Use the Files of type list box to specify a type of file you want to appear. If the file type is 
not contained in the folder, nothing appears.
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4. Highlight the sound file you want to play by clicking it once. Click Open. Sterling 
Commerce:Mail returns you to the Action tab. 
The sound file you selected appears in the field to the left of the Browse button. When 
the conditions for the rule are met, Sterling Commerce:Mail plays this sound file.

Specifying a notification message when rule conditions are met

To specify that Sterling Commerce:Mail generates a notification window when the rule 
conditions are met:

1. On the Action tab, click the Actions list box and select Notify User. The fields on the 
Action tab change to allow you to specify this type of action.

2. Type the notification message text in the Enter notification text field. 
This is the text that will appear in the notification window, which appears on your 
screen when the conditions for the rule are met.

3. Click Add to add the action to the rule. The Notify user action appears in the Script 
area of the Action tab.

Note: Before specifying an action to occur when rule conditions are met, you should first name 
the rule and specify its conditions. See Naming a rule on page 82 and Specifying 
conditions for a rule on page 84.
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Forwarding a message when rule conditions are met

To specify that Sterling Commerce:Mail forwards a message when the rule conditions are 
met:

1. On the Action tab, click the Actions list box and select Forward message. The fields 
on the Action tab change to allow you to specify this type of action.

2. Click the Outgoing list box and select System Folders//Outbox. This specifies that 
when you receive a message that meets conditions for forwarding, Sterling 
Commerce:Mail will store the message in your Outbox folder.

3. Do one of the following:

If you want to specify who receives the message by typing an address, go to 
step 4.

If you want to specify who receives the message by using addresses from another 
message in a Sterling Commerce:Mail folder, go to step 5.

4. Select the To option and type the address of the recipient. Then go to step 6.

Note: Before specifying an action to occur when rule conditions are met, you should first name 
the rule and specify its conditions. See Naming a rule on page 82 and Specifying 
conditions for a rule on page 84.
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5. Select the Use Addresses From Message option. The Containing Subject field and 
From list box become active.

In the Containing Subject field, type the subject of the message that contains the 
addresses you want to use. The subject content must match exactly the subject of 
the message whose addresses you want to use. This field is not case sensitive.

Click the From list box and select the Sterling Commerce:Mail folder that 
contains the message whose addresses you want to use.

6. Click Add to add the action to the rule. The Forward message action appears in the 
Script area of the Action tab.

Replying to a message when rule conditions are met

To specify that Sterling Commerce:Mail replies to a message when the rule conditions are 
met:

1. On the Action tab, click the Actions list box and select Reply using message. The 
fields on the Action tab change to allow you to specify this type of action.

2. Click the Outgoing list box and select System Folders//Outbox. This specifies that 
when you receive a message that meets conditions for replying, Sterling 
Commerce:Mail will store the message you want to reply with in your Outbox folder.

Note: Any text in the message whose addresses you want to use will also be forwarded.

Note: Before specifying an action to occur when rule conditions are met, you should first name 
the rule and specify its conditions. See Naming a rule on page 82 and Specifying 
conditions for a rule on page 84.
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3. In the Containing Subject field, type the subject of the message that you want to 
reply with. The subject content must match exactly the subject of the message you 
want to reply with. This field is not case sensitive.

4. Click the From list box and select the Sterling Commerce:Mail folder that contains 
the message you want to reply with.

5. The Retain Message Items option determine what information from the message is 
copied and sent to the recipients. Select one of the options:

Note copies only the original message into the reply message. Attachments are 
not included. The original message follows your new message.

Note and Attachments copies the original message and any attachments into the 
new message. The original message follows your new message. Attachments are 
included in the Attachment list.

None does not copy the original message or its attachments to the new message. 
Only your new message is sent.

6. Click Add to add the action to the rule. The Reply using message action appears in the 
Script area of the Action tab.
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Copying a message when rule conditions are met

To specify that Sterling Commerce:Mail copies a message when the rule conditions are 
met:

1. On the Action tab, click the Actions list box and select Copy message to. The fields 
on the Action tab change to allow you to specify this type of action.

2. Click the list box to the right of the Actions list box and select which Sterling 
Commerce:Mail folder you want the message to be copied to. 

3. Click Add to add the action to the rule.The Copy message to action appears in the 
Script area of the Action tab.

Note: Before specifying an action to occur when rule conditions are met, you should first name 
the rule and specify its conditions. See Naming a rule on page 82 and Specifying 
conditions for a rule on page 84.
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Moving a message when rule conditions are met

To specify that Sterling Commerce:Mail moves a message when the rule conditions are 
met:

1. On the Action tab, click the Actions list box and select Move message to. The fields 
on the Action tab change to allow you to specify this type of action.

2. Click the list box to the right of the Actions list box and select which Sterling 
Commerce:Mail folder you want the message to be moved to. 

3. Click Add to add the action to the rule. The Move message to action appears in the 
Script area of the Action tab.

Editing rules
You can use the Edit button on the Rule Detail window to edit a rule once you name it and 
create a script for it.

Editing a rule includes all of the following tasks:

Note: Before specifying an action to occur when rule conditions are met, you should first name 
the rule and specify its conditions. See Naming a rule on page 82 and Specifying 
conditions for a rule on page 84.

You can For more information, see

Change a rule’s name and its details Changing a rule’s name and details on page 97

Delete a rule Deleting a rule on page 97
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Deleting a rule
To delete a rule from the Rules Agent:

1. Select the Tools menu Rules Agent item. The Rules Agent window appears.

2. Click the rule you want to delete. This highlights the rule.

3. Click Delete to delete the rule.

Changing a rule’s name and details
To change a rule name and its details:

1. Select the Tools menu Rules Agent item. The Rules Agent window appears.
2. Click the rule whose name and details you want to change. This highlights the rule.

Change conditions in a script Changing conditions in a script on page 98

Change actions in a script Changing actions in a script on page 100

Delete conditions Deleting conditions on page 102

Delete actions Deleting actions on page 103

Note: Carefully verify that the highlighted rule is the rule you want to delete. Once you delete a 
rule, you cannot restore it.

You can For more information, see
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3. Click Detail. The Rule Detail window appears.

4. As needed, type a description for the rule in the Description field. The description 
should contain enough information to allow you to recognize what the rule is for.

5. As needed, click the Execute list box and select one of the following:

On Retrieve executes the rule each time you retrieve your mail.

On Start executes the rule each time you start Sterling Commerce:Mail.

On Exit executes the rule each time you exit Sterling Commerce:Mail.

6. As needed, click the Active check box to activate the rule or deactivate it.

7. Click Save to save the changes or Close to exit without saving and return to the Rules 
Agent window.

Changing conditions in a script
To insert or replace conditions in a rule’s script:

1. On the Rules Agent window, click the rule whose script you want to change. This 
highlights the rule.

2. Click Detail. The Rule Detail window appears.

Note: If you do not check this box to activate the rule, the rule is stored in the Rules Agent, but 
does not execute.

Note: See Editing rules on page 96 for more information about other procedures you can do to 
edit your rules.
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3. Click Edit. The Rule Editor window appears with the Condition tab selected by 
default.

4. In the Script area on the Condition tab, select a condition:

If you are inserting a condition, the new condition will appear above this 
selection.

If you are replacing a condition, this selection will be deleted and replaced by 
the new condition.

5. As needed, click the Operator list box and select AND or OR:

AND conditions are restrictive. If you select AND, the rule executes only if all 
AND conditions are met in addition to the condition defined in the first line of the 
rule. For example, if the first line of a rule defines a condition as Subject 
CONTAINS Project X and the second line defines a condition as AND Subject 
STARTS WITH Attention, the rule activates only if a Subject line contains 
Project X and starts with Attention.

OR conditions are not restrictive. If you select OR, the rule executes if any of the 
OR conditions are met. For example, if the first line of a rule defines a condition 
as Subject CONTAINS Project X and the second line defines a condition as OR 
Subject STARTS WITH Attention, the rule activates if a Subject line contains 
Project X or starts with Attention. Both conditions do not have to be present for 
the rule to activate.

6. As needed, click the Conditions list box and select a variable for the first line of your 
conditions. All of the variables are message variables except Message Folder. For 
example, if you want the rule to apply to the contents of the Subject line of a message, 
select Subject. The Message Folder variable refers to your folders in the Folders area 
of the Main window.
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7. As needed, click the Filter list box and select a filtering agent for the variable you 
selected in step 6. For example, if you want the rule to apply to the contents of the 
Subject line, select Contains.

If you did not select Priority or Message Folder in the Conditions list box, go to 
step 8.
If you did select Priority or Message Folder in the Conditions list box, go to 
step 9.

8. In the field, located below the Operator list box, type the dependent variable for the 
filtering agent you selected in step 7. This variable is not case sensitive. For example, 
if you want the rule to apply to the contents of the message’s Subject, type the word or 
words the Subject must contain for the rule to be applied to a message. Then, go to 
step 10.

9. Click the list box below the Operator list box:

If you selected Priority in the Conditions list box, select the dependent variable 
for the filtering agent you selected in step 7. These variables are all different levels 
of message priority.

If you selected Message Folder in the Conditions list box, select which of your 
Sterling Commerce:Mail folders will be the dependent variable for the filtering 
agent you selected in step 7.

10. Click Insert to insert the condition above the condition you selected in step 4. Or click 
Replace to replace the condition you selected in step 4. The condition appears in the 
Script area.

Changing actions in a script
To insert or replace actions in a rule script:

1. On the Rules Agent window, click the rule whose script you want to change. This 
highlights the rule.

2. Click Detail. The Rule Detail window appears.
3. Click Edit. The Rule Editor window appears with the Condition tab selected by 

default. 

Note: If you selected Priority or Message Folder in the Conditions list box in step 6, your 
selections in the Filter list box are limited to IS and IS NOT.

Note: Click OK to save the conditions for the rule or Cancel to exit without saving. Sterling 
Commerce:Mail returns you to the Rule Detail window.

Note: See Editing rules on page 96 for information about other procedures you can do to edit 
your rules.
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4. Click the Action tab.

5. In the Script area on the Action tab, select an action:

If you are inserting an action, the new action will appear above this selection.

If you are replacing an action, this selection will be deleted and replaced by the 
new action.

6. As needed, click the Actions list box and select the action you want to occur if the 
conditions for a rule are met.

Note: When the Action tab first appears, the Play sound action is the default selection in the 
Actions list box. This selection determines that the Browse button and the Apply to area 
appears on the Action tab. For more information about this button and area, see Playing a 
sound when rule conditions are met on page 89.

If you select When the conditions of the rule are met

Play sound A sound file plays. See Adding copying a message to a 
rule’s actions on page 109 for more information.

Open message The message opens.

Print message The message prints.

Notify user A confirmation window notifies you. See Adding notifying a 
user to a rule’s actions on page 105 for more information.

Forward message The message is forwarded to specified recipients. See 
Adding forwarding a message to a rule’s actions on page 
106 for more information.
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7. Click OK to save your changes or Cancel to exit without saving.

Deleting conditions
To delete a condition from a rule script:

1. Select the Tools menu Rules Agent item. The Rules Agent window appears.
2. Click the rule whose conditions you want to delete. This highlights the rule.
3. Click Detail. The Rule Detail window appears.
4. Click Edit. The Rule Editor window appears with the Condition tab selected by 

default.

Reply using message A specified message is sent in reply. See Adding replying 
to a message to a rule’s actions on page 107 for more 
information.

Copy message to The message is copied to a specified location. See Adding 
copying a message to a rule’s actions on page 109 for 
more information.

Move message to The message is moved to a specified location. See Adding 
moving a message to a rule’s actions on page 110 for 
more information.

Delete message The message is deleted.

If you select When the conditions of the rule are met
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5. In the Script area in the bottom of the Condition tab, click the condition you want to 
delete. This highlights the condition.

6. Click Delete to delete the condition from the rule script.

Deleting actions
To delete an action from a rule script:

1. Select the Tools menu Rules Agent item. The Rules Agent window appears. 
2. Click the rule whose actions you want to delete. This highlights the rule.
3. Click Detail. The Rule Detail window appears.
4. Click Edit. The Rule Editor window appears with the Condition tab selected by 

default. 
5. Click the Action tab.

6. In the Script area in the bottom of the Action tab, click the action you want to delete. 
This highlights the action.

7. Click Delete to delete the action from the rule script.

Note: Verify that the highlighted condition is the condition you want to delete. Once you delete 
a condition, you cannot restore it.

Note: Verify that the highlighted action is the action you want to delete. Once you delete an 
action, you cannot restore it.
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Adding playing a sound to a rule’s actions

To add playing a sound to a rule’s actions:

1. In the Rule Editor window, select Play sound in the Actions list box in the Action tab. 
The fields in the Action tab change to allow you to specify a sound.

2. Click Browse. The Open window appears.
3. Select an Apply to option:

Batch plays the sound once for all messages that meet conditions. For example, if 
you receive five messages during a communications session that meet conditions 
for playing a sound, the sound plays once.

Each Message plays the sound for every message that meets the conditions. For 
example, if you receive five messages during a communications session that meet 
conditions for playing a sound, the sound plays five times.

4. Click Insert to insert the action or Replace to replace an action. The Play sound 
action appears in the Script area of the Action tab.

Note: When you add an action to a rule’s actions, you are editing a script which has already been 
created. If you are specifying an action for the first time, see Specifying actions for a rule 
on page 87.
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Adding notifying a user to a rule’s actions

To add notifying a user to a rule’s actions:

1. In the Rule Editor window, select Notify User in the Actions list box in the Action 
tab. The fields in the Action tab change to allow you to specify this type of action.

2. Type the notification message text in the Enter notification text field.
This is the text that will appear in the notification window which appears on your 
screen when the conditions for the rule are met.

3. Click Insert to insert the action or Replace to replace an action. The Notify user 
action appears in the Script area of the Action tab.

Note: When you add an action to a rule’s actions, you are editing a script which has already been 
created. If you are specifying an action for the first time, see Specifying actions for a rule 
on page 87.
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Adding forwarding a message to a rule’s actions

To add forwarding a message to a rule’s actions:

1. In the Rule Editor window, select Forward message in the Actions list box in the 
Action tab. The fields in the Action tab change to allow you to specify this type of 
action.

2. Click the Outgoing list box and select System Folders//Outbox from the list. This 
specifies that when you receive a message that meets conditions for forwarding, 
Sterling Commerce:Mail will store the message in your Outbox folder.

3. Do one of the following:

If you want to specify who receives the message by typing an address, go to 
step 4.

If you want to specify who receives the message by using addresses from another 
message in a Sterling Commerce:Mail folder, go to step 5.

4. Select the To option and type the address of the recipient. Then, go to step 6.
5. Select the Use Addresses From Message option. The Containing Subject field and 

From list box become active.

Note: When you add an action to a rule’s actions, you are editing a script which has already been 
created. If you are specifying an action for the first time, see Specifying actions for a rule 
on page 87.
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In the Containing Subject field, type the subject of the message that contains the 
addresses you want to use. The subject content must match exactly the subject of 
the message whose addresses you want to use. This field is not case sensitive.

Click the From list box and select the Sterling Commerce:Mail folder that 
contains the message whose addresses you want to use.

6. Click Insert to insert the action or Replace to replace an action. The Forward message 
action appears in the Script area of the Action tab.

Adding replying to a message to a rule’s actions

To add replying to a message to a rule’s actions:

1. In the Rule Editor window, select Reply using message in the Actions list box in the 
Action tab. The fields in the Action tab change to allow you to specify this type of 
action.

2. Click the Outgoing list box and select System Folders//Outbox from the list. This 
specifies that when you receive a message that meets conditions for replying, Sterling 
Commerce:Mail will store the message you want to reply with in your Outbox folder.

Note: Any text in the message whose addresses you want to use will also be forwarded.

Note: When you add an action to a rule’s actions, you are editing a script which has already been 
created. If you are specifying an action for the first time, see Specifying actions for a rule 
on page 87.
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3. In the Containing Subject field, type the subject of the message that you want to 
reply with. The subject content must match exactly the subject of the message you 
want to reply with. This field is not case sensitive.

4. Click the From list box and select the Sterling Commerce:Mail folder that contains 
the message you want to reply with.

5. The Retain Message Items options determine what information from the message is 
copied and sent to the recipients. Select one of the following:

Note copies only the original message into the new message. Attachments are not 
included. The original message follows your new message.

Note and Attachments copies the original message and any attachments into the 
new message. The original message follows your new message. Attachments are 
included in the Attachment list.

None does not copy the original message or its attachments to the new message. 
Only your new message is sent.

6. Click Insert to insert the action or Replace to replace an action. The Reply using 
message action appears in the Script area of the Action tab.
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Adding copying a message to a rule’s actions

To add copying a message to a rule’s actions:

1. In the Rule Editor window, select Copy message to in the Actions list box in the 
Action tab. The fields in the Action tab change to allow you to specify this type of 
action.

2. Click the list box to the right of the Actions list box and select which Sterling 
Commerce:Mail folder you want the message to be copied to.

3. Click Insert to insert the action or Replace to replace an action. The Copy message to 
action appears in the Script area of the Action tab.

Note: When you add an action to a rule’s actions, you are editing a script that has already been 
created. If you are specifying an action for the first time, see Specifying actions for a rule 
on page 87.
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Adding moving a message to a rule’s actions

To add moving a message to a rule’s actions:

1. In the Rule Editor window, select Move message to in the Actions list box in the 
Action tab. The fields in the Action tab change to allow you to specify this type of 
action.

2. Click the list box to the right of the Actions list box and select which Sterling 
Commerce:Mail folder you want the message to be moved to. 

3. Click Insert to insert the action or Replace to replace an action. The Move message to 
action appears in the Script area of the Action tab.

Importing a rule
Importing a rule copies a rule from another location on your local or network drive to your 
Rules Agent window.

To import a rule:

1. Select the Tools menu Rules Agent item. The Rules Agent window appears.

Note: When you add an action to a rule’s actions, you are editing a script that has already been 
created. If you are specifying an action for the first time, see Specifying actions for a rule 
on page 87.

Note: The rule you import must have been created using Sterling Commerce:Mail.
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2. Click Import to import a rule. The Open window appears.

3. Click the Look in list box and select the local or network drive that contains the rule 
you want to import. Click a location to select it. Once you select a location, the folders 
and files the location contains appear in the area below the Look in list box.

4. Highlight the folder containing the rule you want to import by clicking it once. Click 
Open. The folder opens and its name appears in the Look in list box. The folder 
contents appear in the area below the Look in list box. 

5. Highlight the rule you want to import by clicking it once. Click Open to import the 
rule or Cancel to exit without importing. Sterling Commerce:Mail returns you to the 
Address Book window. 
If you click Open, the rule appears in the Rules Agent window. 

Note: Rules have an .RUL# extension.

Note: Use the Files of type list box to specify a type of file you want to appear. If the file type is 
not contained in the folder, nothing appears.

Note: To delete a rule, highlight the rule in the Rules Agent window by clicking it once. Then 
click Delete.
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Chapter 7

Sterling Connection Manager

Use Sterling Connection Manager to establish a dial-up connection to the Internet through 
an Internet service provider (ISP), begin a communications session, set up the 
communications environment, and view communications status.

When you send information to the Internet, use Sterling Connection Manager to specify 
how the product interacts with your modem and dial-up connection. This interaction 
involves information such as baud rate, serial port, phone number, dial method, mailbox 
and password.

Main window
The following is an example of the Sterling Connection Manager Main window containing 
communications session information.
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The Main window is split into two areas. These areas contain the information about 
communications sessions:

✦ Sessions area is located in the left side of the Main window. The Sessions area shows 
the status of the communications session and whether the session succeeded or failed. 
It also shows the time, date, initiator of the session and which connection was used for 
the session.

✦ Session Details area is located in the right side of the Main window. The Session 
Details area shows the name of the connection, the network and the detailed 
information about the selected communications session.

To view a communications session details, click a session. The session details appear in the 
Session Details area.

Sorting and printing session details
To sort and print session details in the Communications Log:

1. Click one of the tabs in the Sessions area to determine how your communication 
details are sorted:

Status of the communications session. Status can be either:

• Success when the connection was established with the network and the 
transmission was completed. When you select Status, all failed transmissions 
appear first.

• Failure when Sterling Connection Manager did not complete the 
transmission. A failure can occur when the network line is busy, no dial tone 
is received, or a session is canceled. If a session has failed, you may want to 
resend the data.

Completed is date and time your system completed the communications session. 

2. Click a communications session in the Sessions area. The details for this session 
appear in the Session Details area.

3. Click Print on the toolbar to print a copy of the session details. Sterling Connection 
Manager uses the standard Windows print dialog. See Printing/Setting up to print 
on page 127 for more information.

Note: To view all of the Sessions area, use the scroll bar at the bottom of the area to scroll left and 
right.

Note: If needed, select the Log menu Purge item to delete all communications sessions older 
than 30 days. Sterling Connection Manager does not delete this information automatically. 
Purge your PC often to ensure that hard drive disk space is not taken up with 
communications session information. See Purging session information on page 126 for 
more information.



Main window

IBM Sterling Gentran:Director Connection User Guide 115

Using menus
The Main window has the following menus:

File menu
The File menu allows you to:

✦ Set up a printer and print report information.
✦ Establish or cancel a dial-up connection to the Internet.
✦ Exit Sterling Connection Manager.

Edit menu
The Edit menu allows you to:

✦ Copy and delete currently running and past sessions entries.
✦ Select all current and past sessions entries for copying or deleting.
✦ Delete all of the displayed sessions entries in the communications log.

Configure menu
The Configure menu allows you to:

✦ Create, change, delete, rename, or copy a connection to the Internet. You can set up 
multiple connections to a single network to specify access numbers, baud rates or 
other information.

✦ Create, change, delete, rename, or copy a mailbox setup to IBM® Sterling B2B 
Collaboration Network. You can set up multiple mailboxes.

✦ Perform EDI confirmation.

Log menu
The Log menu allows you to:

✦ Delete communications session information older than a specified number of days. 
The default is session information older than 30 days.

✦ Refresh updates the displayed data.

Help menu
The Help menu allows you to:

✦ Receive general information about Sterling Connection Manager.
✦ Access context-sensitive online help.
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Testing ports 110 and 25
To use the software, you need to have either a LAN or dial-up connection to the Internet 
with ports 110 and 25 open. 

Perform the following steps to determine if ports 110 and 25 are open:

1. Select Run from the Windows Start menu.
2. In the Open field, type telnet primary.gts.globalec.com 110 and press Enter.

If the port is open, you will receive a +Welcome message.
3. Close the window.
4. Select Run from the Windows Start menu again.
5. In the Open field, type telnet primary.gts.globalec.com 25 and press Enter.

If the port is open, you will receive the following message:
220 gts.globalec.com Commerce:Exchange ESMTP/POP3 Server 
version 1.0 Ready

If you have dial-up and you do not get these “Ready” messages, you will need to find a 
provider that has these ports open.

If you have a LAN and you do not get these “Ready” messages, talk to your IT department 
to open the ports.

Types of connections
Sterling Connection Manager allows you to create a dial-up connection to the Internet. 

✦ Dial-up connection uses your communications device, usually a modem, to dial up to 
the Internet.

To create a dial-up connection to the Internet using Sterling Connection Manager, you must 
create connection information. Once you have created this information, you can browse the 
Internet using the browser packaged with Sterling Gentran:Director Connection. However, 
if you want to use Sterling Commerce:Mail, you must also create mailbox information.

Note: If you are using a modem to dial up to the Internet, you need to establish that connection 
first.

Note: If you are unable to use port 25, try using port 2375. In that case, modify the command to 
telnet smtp2.gts.globalec.com 2375.
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If you already have a LAN connection to the Internet, you do not have to create a dial-up 
connection. You can browse the Internet using the browser packaged with Sterling 
Gentran:Director Connection using your LAN connection. 

✦ LAN connection is an established connection to the Internet on your local area 
network (LAN). This includes DSL, Cable Modem, T1, and T3.

However, if you want to use Sterling Commerce:Mail with your LAN connection, you must 
create mailbox information.

Using a LAN connection
If you already have a LAN connection to the Internet, you do not need to create a dial-up 
connection. You can browse the Internet using the browser that is packaged with Sterling 
Gentran:Director Connection. However, if you want to use Sterling Commerce:Mail, you 
must do one of the following:

✦ When you install Sterling Gentran:Director Connection, select the option to create 
mailbox information. The installation walks you through the Configure menu Mailbox 
wizard so you can specify your mailbox and mailslot information.

✦ Specify your mailbox information by selecting one of the following:
Configure menu Mailbox Wizard item

Configure menu Mailbox Setup item

Using a Dial-up connection
Use the Connection Setup option of the Configure menu to create, change, delete, or copy 
dial-up connections to your Internet Service Provider (ISP). Dial-up connections go 
through your modem. Use this item to create multiple dial-up connections to your ISP.

Mailboxes
Use the Mailbox Setup option of the Configure menu to create, change, delete, or copy 
mailboxes you want to use when sending and receiving information using Sterling 
Gentran:Director Connection.

Using the Mailbox Setup item, you can:

✦ Specify your mailbox.
✦ Enter your current password (from your password card).

Note: If you are using a LAN connection with Sterling Commerce:Mail, once you complete your 
mailbox setup, your setup procedure using Sterling Commerce:Mail and Sterling 
Connection Manager is complete. Once you create your mailbox, you are ready to use your 
LAN connection with Sterling Commerce:Mail.
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✦ Specify address and name information to identify you with the selected network (from 
your password card).

Mailbox Setup fields
The Mailbox Setup and Mailbox Wizard items display windows with common fields. The 
following table defines these fields, which you use to set up your mailbox.

Note: All mailbox information is obtained from your password card.

Field  Definition

E-Mail Address Used to identify data on Sterling B2B Collaboration 
Networkand in document tracking. (Given to you during 
implementation.)

Name Your full name as you want it to appear in Sterling 
Connection Manager. 

POP3 Port TCP/IP port used by the POP3 server. This is usually 110.

Caution: Do not change the POP3 port unless instructed 
by your system administrator.

Primary Sterling B2B 
Collaboration Network Mail 
Server

Mail server (where your mailbox resides) that handles your 
incoming and outgoing data. 

Primary Inbound Mail Server Server that handles your incoming mail. If you are using 
another server, you must type your server’s name in the 
field. This selection appears as Primary Mail Server when 
you are creating a new mailbox.

Secondary Inbound Mail Server If the primary inbound mail server is unavailable, this server 
handles your incoming mail. If you are using another server, 
you must type your server’s name in the field. This selection 
appears as Secondary Mail Server when you are creating a 
new mailbox.

Post Office ID ID given to you during implementation. The Post Office ID 
and Post Office Password work together to identify you to 
the server when it retrieves your data.

Post Office Password Password given to you during implementation. The Post 
Office ID and Post Office Password work together to identify 
you to the server when it retrieves your data.

Reply-To Address used to receive your messages. If you are using 
the Sterling Commerce:Mail mailbox, your e-mail address 
needs to be in the form of jdoe@abccompany.globalec.com.

Primary Outbound Mail Server Server that handles your outgoing mail. If you are using 
another server, you must type your server’s name in the 
field. This selection appears as Primary Mail Server when 
you are creating a new mailbox.
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Creating and editing mailboxes
Use the Mailbox Wizard and Mailbox Setup windows to create and edit mailboxes. 

Creating a mailbox
To create a mailbox:

1. Select the Configure menu Mailbox Wizard item.
OR

Select the Configure menu Mailbox Setup item and click New. The Welcome 
window appears.

2. You can type up to 30 alphanumeric characters. Each mailbox must have a unique 
name.

Secondary Outbound Mail Server If the primary outbound mail server is unavailable, this 
server handles your outgoing mail. If you are using another 
server, you must type your server’s name in the field. This 
selection appears as Secondary Mail Server when you are 
creating a new mailbox.

SMTP Port SMTP port used by the SMTP server. This is usually 25.

Caution: Do not change the SMTP port unless instructed 
by your system administrator.

Note: For field definitions for any window in this procedure, see Mailbox Setup fields on 
page 118.

Field  Definition
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3. Click Next. The Personal Information POP window appears.

4. Type your name in the Name field. (Get this from your password card.)
5. Type your e-mail address in the E-Mail Address field. (Get this from your password 

card.)

6. Click Next. The Internet Mail Server window appears.
7. Click the Primary Mail Server list box and select a primary server from the list. If 

you are using an alternate server to send and receive your mail, select User-Defined 
from this list.

If you selected User-Defined as your primary server, go to step 8.

If you did not select User-Defined as your primary server, go to step 11.

Note: Your e-mail address must be in the form of jdoe@stercomm.com.
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8. Click Next. The User-Defined Mail Server window appears.

9. Type your primary Internet mail server name in the Primary Mail Server field.
10. As needed, type your secondary Internet mail server name in the Secondary Mail 

Server field. 
11. Click Next. The User ID and Password window appears.

12. Type your ID in the Post Office ID field. (Get this from your password card.)
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13. Type your password in the Post Office Password field. (Get this from your password 
card.)
The post office ID and password work together to identify you to the server when it 
retrieves your messages.

14. Click Next. The Save New Mailbox window appears.
15. Click Finish to create your new mailbox setup or Cancel to return to the Main 

window without saving any of the new mailbox information.

Viewing and deleting mailboxes 
Use the Configure menu Mailbox Setup item to view and delete mailbox names. From the 
Mailbox Setup window you can also set up a new mailbox or rename an existing one.

To view and delete mailboxes:

1. Select the Configure menu Mailbox Setup item. The Mailbox Setup window 
appears.

2. If you want to delete a mailbox, click its name in the Mailbox field. Then click 
Delete.
Sterling Connection Manager removes the mailbox name and all associated network 
information. If another Sterling Gentran application is using this mailbox name, you 
must re-specify the mailbox in the affected application.

3. Click Close to leave the Mailbox Setup window and return to the Main window.

Editing mailbox information
Use the Configure menu Mailbox Setup item to edit your mailbox and mailslot information.

To edit mailbox information:

1. Select the Configure menu Mailbox Setup item on the Main window. The Mailbox 
Setup window appears.

Note: The Mailbox field contains the name of any existing mailboxes.
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2. Highlight the mailbox you want to edit and click Edit. The Edit Mailbox window 
appears.

3. Refer to the following sections for editing mailbox setup information:

Editing identity information on page 124

Editing network information on page 125

Note: For field definitions, see Mailbox Setup fields on page 118.
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Editing identity information
To edit identity information:

1. Click the Identity tab on the Edit Mailbox window. The Edit Mailbox window 
appears.

2. Edit the information on the window as needed. For field definitions, see Mailbox 
Setup fields on page 118.

3. As needed, change your name, e-mail, and reply-to address.
4. Click OK to save your changes or Cancel to keep the existing identity information. 

Sterling Connection Manager returns you to the Main window.

Note: To edit other mailbox information, click the corresponding tab on the Edit Mailbox 
window. Then edit the information.
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Editing network information

To edit information under the Network tab:

1. On the Edit Mailbox window, click the Network tab.
2. Edit the information on the window as needed. For field definitions, see Mailbox 

Setup fields on page 118.
3. As needed, change your inbound mail servers, post office ID, post office password, 

and outbound mail servers.
4. As needed, click Advanced to change your port information. See Editing port 

information on page 125 for more information.
5. Click OK to save your changes or Cancel to keep existing network information. 

Sterling Connection Manager returns you to the Main window.

Editing port information
Use the Set Mail Ports window to specify which ports your POP3 and SMTP servers use.

To specify port information:

1. On the Edit Mailbox window Network tab, click Advanced. The Set Mail Ports 
window appears.

2. As needed, change your port information. For field definitions, see Mailbox Setup 
fields on page 118. 

3. Click OK to save port changes or Cancel to exit without saving existing port 
information. Sterling Connection Manager returns you to the Edit Mailbox window.

Caution: You should not change the network information. However, if you need to, contact 
Customer Support first.

Note: To edit other mailbox information, click the corresponding tab on the Edit Mailbox 
window. Then edit the information.

Caution: Contact Customer Support before changing your mail ports.
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Copying mailboxes
Use the Copy Mailbox window to copy mailbox information to another mailbox. 

To copy mailbox information:

1. Select the Configure menu Mailbox Setup item on the Main window.
2. In the Mailbox field, click the mailbox you want to copy.
3. Click Copy. The Copy Mailbox window appears.
4. Type the name of the new mailbox you want to create in the Enter New Mailbox 

Name field. You can type up to 30 alphanumeric characters. Each mailbox must have 
a unique name.

5. Click OK to copy the mailbox setup or Cancel to exit without copying the mailbox. 
Sterling Connection Manager returns you to the Mailbox Setup window.

Renaming mailboxes
Use the Rename Mailbox window to change the name of a mailbox. 

To rename a mailbox:

1. On the Main window, select the Configure menu Mailbox Setup item.
2. In the Mailbox field, click the mailbox you want to rename.
3. Click Rename. The Rename Mailbox window appears.
4. Type the new name for the mailbox in the Enter New Mailbox Name field. You can 

type up to 30 alphanumeric characters. Each mailbox must have a unique name.
5. Click OK to rename the mailbox or Cancel to exit without saving the rename 

information. Sterling Connection Manager returns you to the Mailbox Setup window. 

Purging session information
Use the Log menu Purge item to delete communications session information older than a 
specified number of days. This feature provides you with an easy way to delete outdated 
and unneeded session information. The default setting is information older than 30 days.

Note: Purge your system often to ensure that hard drive disk space is not taken up with old 
communications session information.



Printing/Setting up to print

IBM Sterling Gentran:Director Connection User Guide 127

To purge communications session information:

1. Select the Log menu Purge item. The Purge window appears.

2. As needed, change the number of days. This number instructs Sterling Connection 
Manager to delete all information older than the specified number.
To delete all log entries, type 0 in the available field.

3. As needed, click the Automatically Purge on Startup check box to specify that 
Sterling Connection Manager performs a purge each time you start Sterling 
Connection Manager.

4. Click OK to purge the information or Cancel to exit without purging. Sterling 
Connection Manager returns you to the Main window.

Printing/Setting up to print
Use the Print and Print Setup items on the File menu to set Windows printer options and to 
select printing specifications, including default printer and quality of printing.

Some windows in Sterling Connection Manager have their own print buttons or menus. The 
print functionality on these windows is the same as that accessed through the Print or Print 
Setup items from the File menu.

Printing information
To print:

1. Select the File menu Print item or click Print on the toolbar. The Print window 
appears.

2. As needed, specify the print quality of the document, the number of copies you want 
to print, and if you want copies collated.

Caution: Verify that the number of days setting is correct before you click OK to perform the 
purge. Purging removes communications session information permanently from 
Sterling Connection Manager.
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3. As needed, click Properties to specify paper, graphics device options, and PostScript 
properties. The Properties button also appears on the Print Setup window.
See Specifying default printer setup and properties on page 128 for more 
information.

4. Select OK to begin printing.

Specifying default printer setup and properties
To specify the default printer setup and properties:

1. Select the File menu Print Setup item. The Print Setup window appears. 
2. As needed, change the default printer, paper size, and orientation.
3. Click Properties to specify paper, graphics device options, and PostScript properties. 

The Properties button also appears on the Print window. The properties fields are:

Exiting Sterling Connection Manager
Use the File menu Exit item to exit Sterling Connection Manager and return to Windows.

Field  Definition

Paper size Paper sizes supported by your printer.

Layout Number of pages of your document to print on one sheet of 
paper.

Orientation Position of your document on the paper.

Paper source Location in the printer of the paper you want to use.

Copies Number of copies you want to print.

Resolution Dots per inch used when you print.

Halftoning Number of lines per inch and the angle you want to use for 
halftone screens.

Special Check box selections for printing a negative or mirror image 
of your document.

Scaling Sizing of your document for printing.

Printer features Features and their settings specific to your printer.

Change setting for Changes the value for the selected feature in the Printer 
features field.

PostScript output format Format for PostScript files.
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Appendix A

Troubleshooting

The following table lists issues encountered when using Sterling Commerce:Mail or 
Sterling Connection Manager, as well as suggested actions. Use the table, together with the 
rest of the User Guide, to resolve an issue. If you cannot resolve the issue, contact 
Customer Support.

Issue User Action

Receive error when 
opening an attachment in 
Sterling Commerce:Mail

The file format may not be supported.
Sterling Commerce:Mail supports many file formats. However, 
some formats cannot be opened by the viewer technology. The 
file will be sent to the recipient but cannot be viewed within 
Sterling Commerce:Mail. If you have an application on your PC 
that supports the format, open the attachment from that 
application.

Receive reminder “You 
must specify a mailbox 
and connection setup 
before dialing”

Specify mailbox and connections.
1. Specify Mailbox Setup parameters in Sterling Connection 

Manager by selecting the Configure menu Mailbox Setup 
item.

2. Specify Connection Setup parameters in Sterling 
Connection Manager by selecting the Configure menu 
Connection Setup item.

OR
1. In Sterling Commerce:Mail, select the Tools menu Options 

item. The Options window appears.

2. Click the Mailbox tab. The Mailbox tab appears.

3. Specify the mailbox setup by selecting it from the list box.

4. Click the Connectivity tab. The Connectivity tab appears.

5. Specify the dial-up connection by selecting it from the list box.
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The following table lists common return code errors and the suggested actions to resolve 
them.

Unable to install products 
or out of memory

Check hardware requirements.
Sterling Commerce:Mail requires at least a 486 personal 
computer and Windows 98, Windows 2000, Windows XP, or 
Windows NT. 

Check for adequate disk space.
Successful installation of Sterling Commerce:Mail and Sterling 
Connection Manager requires 30 megabytes of disk space. If 
you are receiving a large file, you will need adequate disk storage 
for that file.

Error Description User Action

SMTP Host Return Codes

452: Requested action not taken: 
insufficient system storage

Using an ISP that does not allow outside 
e-mails to flow through their SMTP 
server.

Check your account access with 
your ISP provider.

501: Syntax error in parameters or 
arguments

Username or password for mailbox is 
incorrect or mailbox setup is corrupt.

Rebuild mailbox setup according to 
your Mailbox Password card 
supplied during implementation.
If you cannot find your Password 
card, or if you have verified the 
settings and you are still getting the 
error, contact Customer Support to 
verify your mailbox information.

553: Requested action not taken: 
mailbox name not allowed

Data is being changed or scanned as it is 
leaving the sender's network.
The IBM® Sterling B2B Collaboration 
Network servers cannot accept the data 
as is.

Lower anti-virus settings for 
SMTP/POP3 scans.

554: Transaction failed Send session is hitting an internal SMTP 
mail server instead of the Sterling B2B 
Collaboration Network server

Check with your network 
administration.

Sterling Gentran:Director Connection Return Codes

-161: SMTP_OPEN_ERROR Seen with 554 host return codes

-162: SMTP_MAIL_ERROR SMTP Mail command failed; seen with 
452 or 501 host return codes

-163: SMTP_RCPT_ERROR SMTP RCPT command failed; seen with 
553 host return code

Issue User Action
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-165: SMTP_DATAEND_ERROR An error was encountered after issuing 
the SMTP data terminator (.). 
The Sterling B2B Collaboration Network 
server is not receiving "end of data 
command."
Seen with Win32 error code -10054

-1061: SMTP_OPEN_ERROR SMTP Open Error—An attempt to 
connect to an SMTP server failed.  This 
is a Windows sockets or communication 
problem.

Check that settings are correct for a 
LAN connection.

POP3 Sterling Gentran:Director Connection Return Codes

-301: POP_ERROR A POP3 command did not succeed.  
Mailbox setting may be corrupt.

Check mailbox settings and rebuild 
your mailbox according to your 
Mailbox Password card supplied 
during implementation.  
If you cannot find your password 
card, or if you have verified the 
settings and you are still getting the 
error, contact Customer Support to 
verify your mailbox information.

-979: USER_CANCELLATION User cancelled session.

MIME Message Parser Return Codes

-102: NO_VALID_HEADERS Can only use defined addresses in 
Sterling Gentran:Director Connection.
Must be an option in the drop-down 
menu for these fields.

-131: FILE_OPEN_FAILED A call to open a file failed.  Might be 
missing files.

Reinstall software.

-132: FILE_CREATE_FAILED A call to create a file failed. Check that Windows user has (at 
least) unrestricted Power User 
rights.

Win32 Error Codes

-2008: The communications 
session was having a problem 
encrypting and attaching the EDI 
file before sending it to the 
network.

See the Support On Demand 
Knowledgebase for details.

-10038: An operation was 
attempted on something that is 
not a socket.

Check firewall and proxy software 
for issues.

-10050: A socket operation 
encountered a dead network.

Check locally installed firewall and 
proxy software for issues.

Error Description User Action
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-10057: A request to send or 
receive data was disallowed 
because the socket is not 
connected and (when sending on 
a datagram socket using a sendto 
call) no address was supplied.

Run telnet test; if necessary contact 
your network administration.

-10060: A connection attempt 
failed because the connected 
party did not properly respond 
after a period of time, or 
established connection failed 
because connected host has 
failed to respond.

Check with your network 
administration.

-10061: No connection could be 
made because the target machine 
actively refused it.

Mailbox might be corrupt, try 
rebuilding according to your Mailbox 
Password card supplied during 
implementation.
If you cannot find your password 
card, or if you have verified the 
settings and you are still getting the 
error, contact Customer Support to 
verify your mailbox information.

Error Description User Action



IBM Sterling Gentran:Director Connection User Guide 133

Notices

This information was developed for products and services offered in the U.S.A. 

IBM may not offer the products, services, or features discussed in this document in other 
countries. Consult your local IBM representative for information on the products and 
services currently available in your area. Any reference to an IBM product, program, or 
service is not intended to state or imply that only that IBM product, program, or service may 
be used. Any functionally equivalent product, program, or service that does not infringe any 
IBM intellectual property right may be used instead. However, it is the user's responsibility 
to evaluate and verify the operation of any non-IBM product, program, or service. 

IBM may have patents or pending patent applications covering subject matter described in 
this document. The furnishing of this document does not grant you any license to these 
patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive

Armonk, NY 10504-1785

U.S.A.

For license inquiries regarding double-byte character set (DBCS) information, contact the 
IBM Intellectual

Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing

Legal and Intellectual Property Law

IBM Japan Ltd.

1623-14, Shimotsuruma, Yamato-shi

Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other country 
where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS 
MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT 
WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT 
NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do 
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not allow disclaimer of express or implied warranties in certain transactions, therefore, this 
statement may not apply to you. 

This information could include technical inaccuracies or typographical errors. Changes are 
periodically made to the information herein; these changes will be incorporated in new 
editions of the publication. IBM may make improvements and/or changes in the product(s) 
and/or the program(s) described in this publication at any time without notice. 

Any references in this information to non-IBM Web sites are provided for convenience 
only and do not in any manner serve as an endorsement of those Web sites. The materials 
at those Web sites are not part of the materials for this IBM product and use of those Web 
sites is at your own risk. 

IBM may use or distribute any of the information you supply in any way it believes 
appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of 
enabling: (i) the exchange of information between independently created programs and 
other programs (including this one) and (ii) the mutual use of the information which has 
been exchanged, should contact:

IBM Corporation

J46A/G4

555 Bailey Avenue

San Jose, CA__95141-1003

U.S.A. 

Such information may be available, subject to appropriate terms and conditions, including 
in some cases, payment of a fee. 

The licensed program described in this document and all licensed material available for it 
are provided by IBM under terms of the IBM Customer Agreement, IBM International 
Program License Agreement or any equivalent agreement between us. 

Any performance data contained herein was determined in a controlled environment. 
Therefore, the results obtained in other operating environments may vary significantly. 
Some measurements may have been made on development-level systems and there is no 
guarantee that these measurements will be the same on generally available systems. 
Furthermore, some measurements may have been estimated through extrapolation. Actual 
results may vary. Users of this document should verify the applicable data for their specific 
environment. 

Information concerning non-IBM products was obtained from the suppliers of those 
products, their published announcements or other publicly available sources. IBM has not 
tested those products and cannot confirm the accuracy of performance, compatibility or any 
other claims related to non-IBM products. Questions on the capabilities of non-IBM 
products should be addressed to the suppliers of those products. 

All statements regarding IBM's future direction or intent are subject to change or 
withdrawal without notice, and represent goals and objectives only. 
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This information is for planning purposes only. The information herein is subject to change 
before the products described become available. This information contains examples of 
data and reports used in daily business operations. To illustrate them as completely as 
possible, the examples include the names of individuals, companies, brands, and products. 
All of these names are ficticious and any similarity to the names and addresses used by an 
actual business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate 
programming techniques on various operating platforms. You may copy, modify, and 
distribute these sample programs in any form without payment to IBM, for the purposes of 
developing, using, marketing or distributing application programs conforming to the 
application programming interface for the operating platform for which the sample 
programs are written. These examples have not been thoroughly tested under all conditions. 
IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these 
programs. The sample programs are provided "AS IS", without warranty of any kind. IBM 
shall not be liable for any damages arising out of your use of the sample programs. 

Each copy or any portion of these sample programs or any derivative work, must include a 
copyright notice as follows:

© IBM 2011. Portions of this code are derived from IBM Corp. Sample Programs. 
© Copyright IBM Corp. 2011.

If you are viewing this information softcopy, the photographs and color illustrations may 
not appear.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International 
Business Machines Corp., registered in many jurisdictions worldwide. Other product and 
service names might be trademarks of IBM or other companies. A current list of IBM 
trademarks is available on the Web at “Copyright and trademark information” at 
www.ibm.com/legal/copytrade.shtml.

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered trademarks 
or trademarks of Adobe Systems Incorporated in the United States, and/or other countries.

IT Infrastructure Library is a registered trademark of the Central Computer and 
Telecommunications Agency which is now part of the Office of Government Commerce.

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo, Celeron, 
Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or registered trademarks 
of Intel Corporation or its subsidiaries in the United States and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or 
both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft 
Corporation in the United States, other countries, or both.

http://www.ibm.com/legal/us/en/copytrade.shtml
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ITIL is a registered trademark, and a registered community trademark of the Office of 
Government Commerce, and is registered in the U.S. Patent and Trademark Office.

UNIX is a registered trademark of The Open Group in the United States and other 
countries.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of 
Oracle and/or its affiliates.

Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the United 
States, other countries, or both and is used under license therefrom.

Linear Tape-Open, LTO, the LTO Logo, Ultrium and the Ultrium Logo are trademarks of 
HP, IBM Corp. and Quantum in the U.S. and other countries.

Connect Control Center®, Connect:Direct®, Connect:Enterprise, Gentran®, 
Gentran:Basic®, Gentran:Control®, Gentran:Director®, Gentran:Plus®, 
Gentran:Realtime®, Gentran:Server®, Gentran:Viewpoint®, Sterling Commerce™, 
Sterling Information Broker®, and Sterling Integrator® are trademarks or registered 
trademarks of Sterling Commerce, Inc., an IBM Company.Other company, product, and 
service names may be trademarks or service marks of others.
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Glossary

The following pages describe terms used in the this guide.

A

Actions
Notify you or perform a process when rule conditions have been met.

Address book
A collection of people you regularly send messages to. After you create an address book, 
make distribution lists from it by selecting members from the address book and copying 
them to the distribution lists. If a member is not included in the address book, the member 
cannot be added to a distribution list.

Address List
A sublist of the address book. Group of people you regularly send the same message to. 
Also see Distribution List.

Attachment
Any text or binary file that the user includes with a message. Attachments can be EDI data, 
indexes or distribution lists, or any file, whether in PC or Macintosh format. Sterling 
Commerce:Mail can encrypt attachments. However, only other Sterling Commerce:Mail 
users can decrypt and read these attachments.
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B

BCC 
Blind carbon copies recipients. TO and CC recipients will not see BCC recipient names.

Binary
File contains data in a machine-readable form that can be read only by a software 
application. For example, an executable file (.EXE) is in binary format.

C

CC
Carbon copies recipients. All those receiving the message will see the CC recipient names.

Cell
An area where a row and a column meet in a table. A table is made up of cells.

Clipboard
Allows you to specify the document formats used when placing data in the Windows 
Clipboard. The Clipboard is a temporary storage location most often used when copying 
data from one document or application to another.

Conditions
Define the circumstances under which Sterling Commerce:Mail performs an action.

D

Dial-up
Connection uses your communications device, usually a modem, to dial up to the Internet.

Display
Allows you to specify how Sterling Commerce:Mail displays unknown files. An unknown 
file is an attachment created in an application not supported by the Outside In viewer. When 
the viewer tries to open an unknown file, a message indicates that the file is unreadable.
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Distribution list
Group of people you regularly send the same message to. A distribution list is a convenient 
way to mail messages to a group of people, rather than sending the same message to each 
individually. For example, you might create a distribution list containing all the people who 
want to stay current with your department’s news updates. The user must also be a Sterling 
Commerce:Mail user, or a user with an X.400 address, to be included on a distribution list.

Dithering
Improves the quality of a graphic image by filling in or smoothing out the image.

Draft folder
Stores messages that are incomplete. Messages stay in the Draft folder until you delete them 
or move them to another folder.

E

EDI (Electronic Data Interchange) 
The transfer of key business transaction information in a standard format from one PC 
application to another via a communications link.

E-mail message
An electronic document made up of text plus any included attachments. You can encrypt 
any attachment, including EDI data.

Encryption 
The process of converting an attachment into complex algorithms so that the attachment is 
unreadable unless it is decrypted.

F

Flat address space
An addressing scheme that segments memory into blocks of 32 bits.

Format
The way information is structured by an application when it creates a file. A format that can 
be read by one application often cannot be read by another.
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G

Gridlines 
Lines drawn from the tick marks of a spreadsheet or database that make it easier to see the 
values associated with the data markers.

I

Inbound messages 
Messages sent by other Sterling Commerce:Mail users to you. They are stored 
automatically in the Inbox folder.

Inbox folder
Stores messages you have received. Messages stay in the Inbox folder until you delete them 
or move them to another folder.

ISP
Internet Service Provider. Provides connection to the internet plus other services.

L

LAN connection 
An established connection to the Internet on your local area network (LAN).

M

Main folder 
A folder that contains subfolders. A main folder allows you to group related subfolders in 
one location.

Message 
An electronic document made up of a sender and recipient name, a subject and text, and any 
attachments.
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MIME
Multipurpose Internet Mail Extension. For SMTP.

MIME type 
Describes the format of the attachment when it is sent to a recipient.

N

Non-system folders 
Folders you create.

Notification actions 
Notify you when rule conditions have been met. For example, a sound plays or a 
notification window appears on your screen.

O

Outbound messages 
Messages sent by you to other Sterling Commerce:Mail users. They are stored 
automatically in the Outbox folder. After you send messages, the messages are moved to 
the Sent folder.

Outbox folder 
Stores messages you created and want to send to other users. Use the Outbox folder to 
review, change or delete unsent messages. Messages must be stored in the Outbox folder 
before they can be sent to other users.

P

Phonebook 
List of access numbers and direct dial numbers used to connect to IBM® Sterling B2B 
Collaboration Network and the Internet.
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Print 
Allows you to print an attachment with formatting that includes tables, bold, italic and 
fonts. The attachment will print even if you do not have on your PC the application that 
created the attachment. You can print any supported text, graphics, spreadsheet or database 
PC or Macintosh format using the Print feature.

Print header
Made up of the attachment title, page number, and a line. Headers print above the specified 
margin.

Process actions
Perform a process. For example, a message is forwarded or copied.

S

Segmented address space
An addressing scheme that segments memory into blocks of 16 bits.

Sent folder 
Stores messages you have sent to other users. When you send a message, Sterling 
Commerce:Mail moves it from the Outbox folder to the Sent folder. Sent messages remain 
in the Sent folder until you move them or place them in the trash.

SMTP address 
A standard Internet address that identifies the recipient and the post office. SMTP stands 
for Simple Mail Transfer Protocol. For example, jsmith@ster.com is a SMTP address, 
where jsmith identifies the user and ster.com identifies the post office.

Subfolder 
A folder that contains only messages and attachments. Sterling Commerce:Mail has five 
system subfolders. The system subfolders are a permanent part of Sterling Commerce:Mail 
and cannot be renamed, moved or deleted.
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T

Text 
File contains only alphanumeric characters and symbols that are human-readable. For 
example, an ASCII file would be in text format.

To
Sends a message directly to recipients.

Trash folder 
Stores messages you want to delete permanently from Sterling Commerce:Mail. Messages 
appear in the Trash folder only when you have placed them there.

U

Unknown file 
An attachment created in an application not supported by the viewer. When the Outside In 
viewer attempts to open an unknown file, a message indicates that the file is unreadable.

X

X.400 
A communications protocol that allows connectivity between electronic messaging 
systems. The X.400 address system is used by some companies to send information 
worldwide using non-proprietary standards. Because the X.400 system is worldwide, each 
X.400 user must have a unique mailing address.
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Index

A
Action tab

copy message to 95
forward message 92
move message to 96
notifying user 91
playing a sound 89
reply using message 93

Actions
changing 100
copying a message 95
definition 81
deleting 103
forwarding a message 92
moving a message 96
notification 87
notification message 91
Open window 90
playing a sound 89
process 87
replying to a message 93
specifying 87

Activating rules 83

Address 10

Address book
definition 43
overview 43
search window 52
toolbar button 43
window 49

Addressing a message 9

Attach File toolbar button 20

Attachment
adding colors or grays 28
binary, text 19
clipboard options 37
Clipboard Options window 38
default font 40
definition 4

Display Options window 31
exporting 24
Font window 41
full screen view 26
importing 20
more display options 32
More Display Options window 33
More Print Options window 36
options 30
print options 34
printing 41
rotating 28
Save As window 24
saving to a drive 24
shortcut menu 25
spreadsheet options 39
tabs 40
unknown 31
using the shortcut menu 25
view size 27
view style 26
viewing 24
zooming in or out on 29

Attachment shortcut menu
definition 25
Dither item 28
Options item 30
Rotation item 28
Show Full Screen item 26
Size item 27
View item 26
Zoom item 29

B
Binary definition 19

Bitmap 38

Blind copy (BCC) 10

Booting up viii
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C
Carbon copy (CC) 10

Cell definition 39

Change
actions 100
conditions 98
rule name 97

Clipboard
more options 39
options 38
overview 37

Clipboard Options window 38

Condition tab 85

Conditions
AND 86
definition 81
deleting 102
OR 86
specifying 84

Confirmation
windows 78

Confirmation of delivery (COD) 8

Confirmation of receipt (COR) 8

Confirmations Options tab 78

Connectivity Options tab 76

Copy
as table 39
attachments to drive 24

Copy Mailbox window 126

Copying mailboxes 126

Create
mailbox 119
Main folder 65
rule script 84
subfolder 66

Create Folder window 65

Creating a message 7

D
Database options 36

Default font options 41

Delete
actions 103
conditions 102
mailbox 122
message 16
rule 97

Delivery confirmations 8

Device Independent Bitmap (DIB) 38

Dial-up connection
definition 116

Disk space requirements viii

Display Options window 31, 32

Distribution list
creating 50
definition 9, 43
deleting 49
exporting 55
import preferences 54
importing 52
maintaining 50
Open window 52
Preferences window 54
printing 49
receiving 57
Save As window 55
search 52
sending 56
viewing 49
window 56

Distribution List window 56

Dithering an attachment 28

Draft folder 61

Drive, exporting attachments 24

E
Edit menu 2

Electronic Data Interchange (EDI) vi

E-mail vi

Emptying trash 64

Encryption 7

Exit toolbar button 80
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Exiting
Sterling Commerce:Mail 80
Sterling Connection Manager 128

Export
attachment 24
distribution list 55
message 24

F
File menu 2

Folder
Create Folder window 65
creating 65
Draft 61
emptying trash 64
Folders area 5
Inbox 61
Letter Details window 6
Main 59
maintaining 67
Message Details area 6
moving 67
Outbox 62
removing message from trash 64
renaming 67
searching 69
Sent 63
subfolder 59
system folders 60
system subfolders 60
Trash 64

Folder List view 2, 5

Folder menu 2

Folders area 5

Font window 41

Format
bitmap 38
definition 37
DIB 38
metafile 38
palette 38
RTF 38
text 38

Forwarding a message 16

G
Getting started

documentation viii

Glossary x

Go menu 2

Gridlines 32

H
Header 12

Help
online ix, x

Help menu 3

I
Identity tab 124

Import
attachment 20
distribution list 52

Import Address toolbar button 52

Inbound message 5

Inbox folder 61

Inbox toolbar button 61

Insert
action 100
condition 98

Installation
documentation viii
failure 130

Internet
dial-up connection 116
setting up connections 73
with Sterling Commerce:Mail vii
with Sterling Connection Manager vii

Internet Mail Server window 120

L
LAN connection

definition 116
using 117

Letter Details window 6
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Logging off
Sterling Commerce:Mail 80
Sterling Connection Manager 128

M
Mailbox

changing mail ports 125
Copy Mailbox window 126
copying 126
creating 119
deleting 122
editing 122
Identity tab 124
Internet Mail Server window 120
Mailbox Setup window 122
Network tab 125
Personal Information POP window 120
Rename Mailbox window 126
renaming 126
Set Mail Ports window 125
setting up 73
User ID and Password window 121
User-Defined Mail Server window 121
Welcome window 119

Mailbox and connection 129

Mailbox Options tab 74

Mailbox Setup window 122

Main folder 59

Main window
Sterling Connection Manager 113

Maintaining messages 67

Marking messages as read 14

Memory
out of 130

Memory requirements viii

Message
addressing 9
confirmation of delivery 8
confirmation of receipt 8
confirmations 78
copying 68
creating 7
definition 4
deleting 16, 68

exporting 24
forwarding 16
inbound definition 5
maintaining 67
Mark As Read 14
Marking All As Read 14
moving 68
opening 11
outbound definition 5
previewing 12
printing 79
read 69
removing from trash 64
Reply To 15
Reply To All 15
Save As 13
saving 13
searching for 69
send to types 10
sending and retrieving 14
specifying message details 6
Subject field 8
unread 69
window 2

Message Details area 6

Message menu 2

Message preview 12

Message window
Attachment area 24
attachment shortcut menu 25
View area 24

Metafile 38

MNP modem vii

Modem
V.42 support vii

Monitor requirements vii

More button 32

More Clipboard Options window 39

More Display Options window 33

More Print Options window 36

Mouse
navigation viii
requirement vii



Index

IBM Sterling Gentran:Director Connection User Guide 149

N
Naming a rule 82

Navigation
accessing menus, submenus viii
using a mouse viii

Network tab 125

Notification actions 87

O
Online help ix, x

Opening a message 11

Optimized tabs 40

Options window 78

Org unit 48

Out of memory 130

Outbound message 5

Outbox folder 62

Outbox toolbar button 62

OUTSIDE IN for Windows 19

P
Palette 38

Personal Information POP window 120

Preferences window 54

Previewing a message 12

Print toolbar button 79

Printing
attachment 41
information 79
overview 79
properties 79
setup 79

Process actions 87

Purge window 126

Purging session information 126

Q
Quitting

Sterling Commerce:Mail 80
Sterling Connection Manager 128

R
Read message 69

Receiving distribution lists 57

Rename Mailbox window 126

Renaming a folder 67

Replace
action 100, 101
condition 98

Replying to a message 15

Replying To All 15

Requirements vii

Retrieving messages 14

Rich Text Format (RTF) 38

Rotating an attachment 28

Rules
Action tab 88
activating 83
agent 82
AND conditions 86
changing details 97
changing name 97
copying a message 95
creating a script 84
deleting 97
deleting actions 103
deleting conditions 102
details 82
editing 96
forwarding a message 92
inserting actions 100
inserting conditions 98
moving a message 96
naming 82
notification message 91
OR conditions 86
overview 81
playing a sound 89
replacing actions 101
replacing conditions 98
replying to a message 93
Rules Detail window 82
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specifying actions 87
viewing 82

Rules Agent window 82

Rules Detail window 82

S
Save as 13

Save As window 24

Saving
attachment to a drive 24
message 13
message to a drive 24

Schedule Mail window 71

Scheduling mail 71

Search Folder window 69

Search window 52

Searching distribution lists 52

Sending
distribution list 56
messages 14

Sending and retrieving messages 14

Sent folder 63

Service Pack 2 requirements viii

Session Details area 114

Sessions
printing 114
purging 126
sorting 114
status 114

Sessions area 114

Set Mail Ports window 125

Shortcut Bar view 2, 5

Shortcut menus 25

SMTP address 44

SMTP window 44

Spreadsheet
attachment options 39
options 36

Starting applications viii

Status bar 4

Sterling Commerce:Mail
definition v
save time and money vii
with Internet vii
with LAN connection 117

Sterling Commerce:Mail Main window
Connection Setup area 4
Edit menu 2
File menu 2
Folder menu 2
Go menu 2
Help menu 3
Mailbox Setup area 4
Message menu 2
Schedule Mail Access area 4
Selected item area 4
status bar 4
toolbar buttons 3
Tools menu 3
Unread/Total Messages area 4
View menu 2

Sterling Connection Manager
definition v
exiting 128
Main window 113
starting in Sterling Commerce:Mail 73
with Internet vii

Subfolder 59

Subject field 8

System folders 60

System subfolders 60

T
Tabs 40

Text, definition 31, 38

To button 10

Toolbar button
Address Book 43
Attach File 20
Compose New Message 7
Delete 16
Exit 80
Forward 16
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Import Address 52
Inbox 61
New Folder 65
Outbox 62
overview 3
Print 79
Reply 15
Reply To All 15
Retrieve Mail 14
Send Mail 14

Tools menu 3

Trash folder
definition 64
emptying 64
removing message 64
using 64

Troubleshooting
overview ix

U
Unknown file 31

Unread message 69

User guide structure ix

User ID and Password window 121

User-Defined Mail Server window 121

Utilities
confirmation windows 78
connectivity defaults 76
exiting Sterling Commerce:Mail 80
mailbox defaults 74
printing 79
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