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Purpose 
The purpose of this document is to provide general troubleshooting steps for problems 
with documents failing to import into Gentran:Director. 
 
NOTE: This document is only applicable to imports that are using the system 
import templates provided with Gentran:Director. If the header template being 
used is not tdfhdr.tpl or tdfhdrx.tpl then the guidelines in this document may still 
be helpful but you may need to contact mapping support for assistance. 
 
NOTE: This document will not cover troubleshooting of data that imports with a 
status of “Not OK”. That is an issue with the document portion of the flat file. If 
you have a document import with a “Not OK” status, please check your flat file 
against the mapping report as there is a discrepancy.  
 
What You Need to Know About Importing 
 
The document being imported into Gentran:Director is known as a positional flat file. 
This is because the fields in the data must be in specific positions within the file. An EDI 
document is known as a delimited document. This is because characters known as 
“delimiters” are used to separate the different fields in the data from one another. 
 
The first line of a positional flat file is the “Header”. The header contains the information 
that Gentran:Director needs to locate the appropriate partner, relationship and template 
for that particular document. The header line will look something like this: 
 

   810   00000000000                                       TEST8104010                                              004010                       X                                             P 

 
The guidelines for creating a header are in the mapping report text document provided 
with every generic import template on the Sterling Library. See a copy of that section 
below. 
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Following this guide will result in a correctly formed long header. 
If a short header is required then simply stop the header after the application code is 
entered. For the remainder of this document the long header will be used. 
 
When setting up an import relationship within Gentran:Director one must be sure that 
the correct import header template is registered. If the header is 189 characters long 
ending with a T for test or P for production it is a long header. If the header is between 
58 and 72 characters long and ends with the Application Code it is a short header. A 
short header assumes that the file is production. 
 
Gentran:Director comes with two separate import header templates, “tdfhdr.tpl” and 
“tdfhdrx.tpl”. “Tdfhdr.tpl” is the short header template and “tdfhdrx.tpl” is the long header 
template.  To verify which one is in use: 
 

1) Go to View>Translation Objects.  
2) Click “Sort”  
3) Chose “Group by type” and uncheck “Hide system translation objects”  
4) Click “Ok”  
5) Scroll down to the type “System Import”  
6) Highlight “System Import TDF”  
7) Click “View”  
8) The filename is listed here. If the wrong header template is currently registered 

then close the view window 
9) Click “New”  
10)   Select the appropriate filename and click “Open”  
11)   Gentran:Director will say that a template is already registered with that 

description and ask if it is ok to overwrite the existing template. Click “Yes”. 
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Once the correct template is registered it is important to make sure that it is setup to be 
used properly within Gentran:Director Configuration Imports tab.  
 

 
 
This tab allows the use of multiple header templates depending on the filename being 
imported. By default the only listing should be “*.*’ using “System Import TDF”.  This 
means that any file imported will use the System Import TDF header template. If there 
are multiple entries here it is imperative that the file being imported matches the correct 
entry.  
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When a file is Imported Gentran:Director will verify the filename against the Imports tab 
in Configuration and use the selected translation object to translate the header. Within 
the header is a field known as the “Application Code”. This code can be anything as 
long as it matches the “Application Code” field in the partner definition. 
 

   810   00000000000                                       TEST8104010                                              004010                       X                                             P 

 

 
 
If these two fields match then Gentran:Director will know which partner to associate the 
data with. Once that is determined Gentran:Director will attempt to find a matching 
outbound relationship. To find the correct relationship the data must match with regard 
to document type, version, agency and test/production status.  
 

   810   00000000000                                       TEST8104010                                              004010                       X                                             P 
 

 
What to Look for When an Import Fails 
 
When an import process is run in Gentran:Director but no document appears to have 
imported then the import document does not match the import setup in Gentran:Director 
in some way. Whenever an import fails the very first place to look is the Audit Log. Any 
errors with the import will be listed here and will be the basis for further troubleshooting. 
 
As stated in the previous section of this document, Gentran:Director looks at the header 
of the flat file and first locates the partner, then the relationship and finally the import 
template being used. If any of these steps fail, the data will not import into 
Gentran:Director. The errors found in the Audit Log will indicate where this process 
failed. See the examples below. 
 
 
ERROR 1 
Translator: Relationship not found, TransactionSet: 810, Release: 0, TestMode: P 
Translator: Relationship not found for partner: , direction: Out, agency: X, version 004010 
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This error has no listing for the partner. This indicates that Gentran:Director was unable 
to locate the partner associated with this document. 
 
ERROR 2 
Translator: Relationship not found, TransactionSet: 810, Release: 0, TestMode: P 
Translator: Relationship not found for partner: TEST3, direction: Out, agency: X, version 
004011 
 
This error does list the partner (TEST3) but still cannot find the relationship. 
 
ERROR 3 
Translator: Invalid Translation Object File  
Translator: Translation Object file C:\Program Files\COMMERCE Connection32\RegTransObj\ 
not found 
 
This error indicates that Gentran:Director found the partner and the relationship, but the 
template to be used was not found. 
 
Troubleshooting the Errors 
 
ERROR 1 
Translator: Relationship not found, TransactionSet: 810, Release: 0, TestMode: P 
Translator: Relationship not found for partner: , direction: Out, agency: X, version 004010 
 
Gentran:Director was unable to locate the partner associated with the import document. 
It has already been stated that Gentran:Director uses the Application Code to associate 
the import document with a partner. The first thing to do is to check the header record of 
the import document to verify that the positioning is correct. Please see the guidelines 
on page 3 to verify the layout is correct. If the positioning is correct then the Application 
Code in the import document must not match the Application Code in the partner profile.  
 

1) Open the import document and make a note of the Application Code. This will be 
found starting in position 57 of the header record. (see below) 

 
   810   00000000000                                       TEST8104010                                              004010                       X                                             P 

 
2) In Gentran:Director, open the Partner Editor (Tools>Partner Editor), highlight the 

partner in question and click “Edit” 
3) Modify the Application Code here to match the Application Code found in the 

header record of the import document. (See screenshot below) 
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4) Once the change has been made and the two fields match try the import again. It 

may still fail, but the partner will now be known. 
 
 
 
ERROR 2 
Translator: Relationship not found, TransactionSet: 810, Release: 0, TestMode: P 
Translator: Relationship not found for partner: TEST3, direction: Out, agency: X, version 
004011 
 
Gentran:Director found the partner, but was unable to locate a matching relationship. 
There are a number of potential causes for this error and each one will need to be 
examined.  The first thing to do is to check the header record of the import document to 
verify that the positioning is correct. Please see the guidelines on page 3 to verify the 
layout is correct. If the layout is correct, the next step is to verify that the correct header 
template is being used and is setup properly within Gentran:Director Configuration. 
 

1) Go to View>Translation Objects.  
2) Click “Sort”  
3) Chose “Group by type” and uncheck “Hide system translation objects”  
4) Click “Ok”  
5) Scroll down to the type “System Import”  
6) Highlight “System Import TDF”  
7) Click “View”  
8) The filename is listed here.  
9) If a long header is being used the registered template should be “tdfhdrx.tpl”. If a 

short header is being used the registered template should be “tdfhdr.tpl”. If the 
wrong header template is currently registered then close the view window and 
proceed. 

10)   Click “New”  
11)   Select the appropriate filename and click “Open”  
12)   Gentran:Director will say that a template is already registered with that  

             description and ask if it is ok to overwrite the existing template. Click “Yes”. 
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Now that the correct header template is registered within Gentran:Director it must be 
setup correctly in the Gentran:Director Configuration Imports tab. 
 

1) Go to Tools>Configuration 
2) Go to the Imports tab 
3) Verify that there is an entry that corresponds to the filename of the flat file being 

imported. 
4) Verify that the Translation Object being used for that entry is “System Import 

TDF” 
5) Click Apply and Ok 
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If there was a problem with the import header template being used and it has now 
been corrected then the import should be tried again to see if that solved the 
problem.  If the error persists then the header record needs to be verified against the 
outbound relationship to make sure they match.  
 
1) Open the import document and note the document, version, agency and 

test/production indicator. 
 

   810   00000000000                                       TEST8104010                                              004010                       X                                             P 
 
2) In Gentran:Director, open the Partner Editor 
3) Highlight the partner in question and click “Outbound” 
4) Select the relationship in question from the drop down menu. If no relationship 

exists then that would be the reason for the error and one will need to be created. 
5) Click Advanced 
6) Verify that the Standard, Version, Transaction Set and Test/Production indicator 

all match the header record of the flat file. Note that it is recommended that all 
import data be flagged as production on this level and that the version must 
match the version field exactly. 
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7) Click “Translation” and verify that there is an import template selected for the 
relationship and that the Application Alias Value matches the first field in the 
header record (the document type or transaction set id) 

 
 
8) Click Save 
9) Click Save again and you will be told the save was successful 
10)   Click OK and Exit 
11)   Try the import again 

 
Once all these fields match and the correct header template is selected and setup 
properly in Configuration then Gentran:Director will be able to associate the import 
document with the correct partner and relationship. 
 
ERROR 3 
Translator: Invalid Translation Object File  
Translator: Translation Object file C:\Program Files\COMMERCE Connection32\RegTransObj\ 
not found 
 
This error indicates that Gentran:Director found the correct partner and relationship but 
that either no import template is selected or that the template selected was not found.  
 
If the error lists an actual filename (Translator: Translation Object file C:\Program 
Files\COMMERCE Connection32\RegTransObj\TDF26669.tpl not found) then the template is 
selected in the relationship but was not found.  
 

1) Open the Partner Editor (Tools>Partner Editor) 
2) Highlight the partner in question and click “Outbound” 
3) Select the relationship in question from the drop down menu 
4) Click “Translation” 
5) Make a note of the description of the template in the “Import” field 
6) Click Exit, Exit and Exit again to close the Partner Editor 
7) Go to View>Translation Objects 
8) Click on Sort 

Page 10 of 11 
© 2000 Sterling Commerce. All rights reserved. 



  
Gentran:Director for Windows      
 

9) Chose Group by Type and click OK 
10)   Locate the Import template you noted in step 5 
11)   Highlight it and click “View” 
12)   Make a note of the Filename 
13)   Minimize Gentran:Director  
14)   Browse to C:\Program Files\Commerce Connection 32\RegTransObj 
15)   Verify that the filename noted in step 12 exists in this directory 
16)   If it does not exist then the template should be registered 
17)   Bring Gentran:Director back up and go back to View>Translation Objects 
18)   Click New 
19)   Browse to the import template that you wish to register, highlight it and click     

             Open. 
20)   There may be a message that there is already a template with that description       

             and do you want to overwrite it. Click Yes 
21)   Close Translation Objects 
22)   Try the import again 

 
Once the template is registered properly the data should import without issue. 
 
If there is no filename listed (Translator: Translation Object file C:\Program 
Files\COMMERCE Connection32\RegTransObj\ not found) then there is most likely no 
import template selected in the relationship. 
 

1) Open the Partner Editor (Tools>Partner Editor) 
2) Highlight the partner in question and click “Outbound” 
3) Select the relationship in question from the drop down menu 
4) Click “Translation” 
5) Select the appropriate template from the “Import” drop down menu 
6) If no template is listed then the template has not been registered within 

Gentran:Director 
7) If the import template needs to be purchased, visit the Sterling Library at 

https://library.commerce.stercomm.com/SterlingLibrary/Forms/Account/Login.asp
x to purchase and download the needed template 

8) If the import template has simply not been registered follow steps 17-22 of the list 
above. 

 
If the data still doesn’t import into Gentran:Director after following the troubleshooting 
guidelines, please contact customer support: 
 
Online: at Support on Demand at www.sterlingcommerce.com
Email: pcbasedsupport@stercomm.com
Telephone: 1-800-GENTRAN 
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