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Purpose 
 
This whitepaper was created to explain the steps required in troubleshooting inbound 
documents with a Not OK status (Red Papers).  
 
Disclaimer 
 
While the reasons listed in this paper will cover the vast majority of issues it is not an 
exhaustive list and should not be treated as such. If, after reviewing this document, you 
still have trouble please contact customer support by opening a case on Support on 
Demand, sending an e-mail to pcbasedsupport@stercomm.com or by calling 1-800-
GENTRAN. 
 
Solution Steps 
 
There are generally seven reasons that data comes into the ?In Documents browser.  
 

1) The EDI Code (In the partner definition) does not match the sender’s ISA ID in 
the data 

2) The Test/Production flag in the data does not match the Test/Production flag in 
the document relationship 

3) No relationship exists for the inbound document and version 
4) The data contains non-printable characters 
5) There is a problem with the envelope structure of the data 
6) The data translated with errors 
7) There is a turnaround template selected that does not match the inbound print 

template and/or the outbound screen entry template 
 
Problem 1 – The EDI Code does not match the sender’s ISA ID 
 
Gentran:Director determines which partner to associate with the inbound data with by 
comparing the sender’s ID to the EDI Code field in the partner definition. If these two do 
not match then Gentran will not be able to determine which template to use to translate 
the data and it will be placed in the  ?In Documents browser as it will not be translated. 
 
NOTE: If you are using a multi-company break template you will need to match the EDI 
Code field against the sender and receiver ID’s together. 
 
To determine if this is the problem: 
 

1) Open the ?In Documents browser 
2) Highlight the entry in question and click “View” 
3) If the “Partner” field says “Unknown” than the EDI Code does not match 

the ID in the data. 
 
To check the sender’s ID in the data: 
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1) Open the Interchanges Drawer and maximize the window. Two new 
windows will open on the right 

2) Click on View>Interchanges>Data at the top of the screen. The data will 
now appear in the top right window 

3) Highlight the Unknown interchange on the left side of the screen  
4) Write down the ID in the ISA 04 segment (Highlighted Below) 

 

 
 

5) Open the Partner Editor 
      6)  Highlight the partner in question 
      7)  Click Edit 

8) Verify that the EDI Code matches the ID written down in step 4.  
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Once you have made certain that the EDI Code and the ID in the data match you should 
reprocess the data and look for further errors.  
 
Note: For the steps used to reprocess data please see the end of this document 
 
Problem 2 – The Test/Production flag in the inbound relationship does not match 
the Test/Production flag in the data 
 
To determine if this is the problem: 
 

1) Open the ?In Documents browser 
2) Highlight the entry in question and click “View” 
3) If the “Partner” is listed but the “Name” field says “Unknown” then this 

may be the problem. 
 
To check the Test/Production Indicator in the data: 
 

1) Open the Interchanges Drawer and maximize the window. Two new 
windows will open on the right 

2) Highlight the problem Interchange on the left side of the screen. 
3) Click on View>Interchanges>Data at the top of the screen. The data will 

now appear in the top right window 
4) Scroll to the end of the ISA line and note if the character fourth from the right is a T 

or a P (Highlighted Below) 
 

 
 

5) Open the Partner Editor and highlight the partner in question 
6) Click Inbound 
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7) Select the relationship for the document in question from the drop down menu 
8) Click Advanced 
9) At the bottom of this window verify that the Test/Production flag matches the 

Test/Production flag in the data (T for test P for production) 
 

 
 

10)  Click Save and then Exit 
 
Once you have made certain that the Test/Production flags match you should reprocess the data 
and look for further errors. 
 
Note: In order for an outbound 997 to be generated the inbound and outbound relationships must 
match exactly. Also, if you are using a Turnaround template, be aware that the relationship for the 
outbound document to be generated in the workspace must match the inbound document 
relationship exactly in standard, version and Test/Production indicator. Please verify that any 
outbound 997 relationship and any outbound relationship for documents being generated by a 
turnaround template is flagged as Test or Production accordingly. 
 

1) Open the Partner Editor and highlight the partner in question 
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2) Click Outbound 
3) Select the Outbound relationship 
4) Click Advanced 
5) Verify that the Test/Production indicator matches the inbound relationship  
6) Click Interchanges  
7) Click Edit.  
8) Click Envelope. Then change the test/production indicator to match (Note: This field is 
not required to match the inbound data. This only reflects what will be displayed in the 
outbound ISA envelope of the data you send to your partner. If you wish to leave this field 
as it is or change it at any time it will have not effect the processing of data in 
Gentran:Director) 
9) Click Save, Save, Select.  
10) Click Save, Ok and then Exit. 

 
Problem 3 – No relationship exists for the inbound document and version 
 
To determine if this is the problem: 
 

1) Open the ?In Documents browser 
2) Highlight the entry in question and click “View” 
3) If the “Partner” is listed but the “Name” field says “Unknown” then this 

may be the problem. 
4) The “Type” field will indicate the document for which a relationship is 

required. 
5) Open the Partner Editor  
6) Highlight the partner in question 
7) Click Inbound 
8) Click the Relationship Description drop down menu 
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9) If you do not see a relationship for this document type and version one 
will need to be created or the data will continue to come into the ?In 
Documents browser.  

 
Problem 4 - The data contains non-printable characters 
 
To determine if this is the problem: 
 

1) Process the data by receiving it, reprocessing it from the communications 
log or by using Commands>Process file 

2) Verify that the data did or did not come into the system by going to 
Interchanges and looking for it there 

3) If the data does not show up in Interchanges go to View>Audit log and 
look for an entry similar to the highlighted entry below 

 

 
 

4) If the data does show up in Interchanges then highlight it, maximize the 
Interchanges window and go to View>Interchanges>Data 

5) By viewing the raw data in the top right window you may be able to 
determine where the unprintable character is being used. The best place to 
look is the end of the ISA line as the delimiters are the usual culprit here. 

 
If you have a hex editor you can open the data file and determine what hex code is being 
used for the unprintable character. If not then you can either contact Sterling Commerce 
VAN support or your trading partner and they can tell you what character is being used. 
 
The best way to solve this problem is to contact your trading partner and request that they 
begin using printable ASCII characters in place of the unprintable characters. If they 
cannot or will not do so you can use the Xprocess command to modify or strip the 
character from the data. If you are using Sterling Commerce as your VAN then you also 
have the alternative of setting up overrides on your Mailslot that will force all inbound 
data to have the same delimiters.  
 
Note: For more information on placing an override on your Mailslot please contact 
support for the Sterling Information Broker Network at 1-877-432-4300. 
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Note: For more information on using the Xprocess command see the end of this 
document. 
 
Problem 5 - There is a problem with the envelope structure of the data 
 
To determine if this is the problem: 
 

1) Reprocess the data from the communications log or use 
Commands>Process file to process it manually 

2) Verify that the data did or did not come into the system by going to 
Interchanges and looking for it there 

3) If the data does not show up in Interchanges go to View>Audit log and 
look for any entry with a negative connotation or error listed.  

4) Also, look for the line saying “Splitter - completed processing: 0 
interchanges”. If it did not process any interchanges then the envelope is 
malformed to the extent that it is not recognizable data. This usually 
indicates that the ISA is either to long or to short. If you are not 
comfortable troubleshooting this on your own or if you want confirmation 
before talking to your trading partner please call support at 1-800-
GENTRAN and let them know what you have found. 

5) If the data does show up in Interchanges then maximize the Interchanges 
window, highlight the problem Interchange on the left side of the screen 
and go to View>Interchanges>Translator Report 

6) The Translator Report will be displayed in the lower right window. Take a 
look at what errors are reported.  

7) If you see an error message of “Control Total Incorrect” then your trading 
partner’s data simply has the wrong segment count in the SE, GE or IEA 
segment and you should call them and let them know or manually change 
the count if you are comfortable doing so.  

8) If you see a “Session Error” then the envelope structure is most likely 
incorrect, but not enough so as to be unreadable. If you are comfortable 
with troubleshooting this on your own go ahead. If not then you should 
contact support for assistance at 1-800-GENTRAN 

9) To view further information on the various Translator Report errors and 
their meanings go to Help>Help Index and search for “Translator Report 
Error Messages”. Help may also be reached by pressing the F1 key 

 
In this case the error may not be within your setup or with Gentran:Director but with the 
data that has been sent to you. If you call support they will be able to confirm the 
problem and help you identify it, but the fix will likely entail contacting your trading 
partner to have the data modified and resent correctly. 
 
Problem 6 - The data translated with errors 
 
To determine if this is the problem: 
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1) Open the ?In Documents browser 
2) Highlight the entry in question and click “View” 
3) If there are no “Unknown” fields highlight a document entry here and 

click View 
4) Choose Translator Report and click OK 
5) Scroll to the bottom and see how many errors are reported 
6) If there are errors reported then the data does not match the template you 

are using 
7) If there are no errors reported then please see Problem 5 as there is most 

likely an envelope problem with the data. 
 
There are a few steps involved in troubleshooting this issue:  
 

1) If you created the template yourself you should check it against the data 
and determine if changes need to be made 

2) If you require assistance with modification of the template please call the 
mapping department at 1-800-GENTRAN and following the mapping 
options. 

3) If you are using a template downloaded from the Sterling Commerce 
Library, verify that you are using the latest version of the template for this 
partner, document type and version by visiting the Sterling Commerce 
Library and checking for a newer template than the one you are using. 

4) If you are using the latest template available you should contact your 
trading partner with the contents of the translator report. You may want to 
send them a copy of this report. 

 
This is not a problem with the functionality of Gentran:Director or with your setup. It’s a 
matter of data being translated but failing to meet the requirements of the template. It can 
be fixed only by changing the data to match the template or the template to match the 
data. 
 
Problem 7 - There is a turnaround template selected that does not match the 
inbound print template and/or the outbound screen entry template 
 
To determine if this is the problem: 
 

This problem is hard to find as it may show itself in any number of ways. The best 
way to handle this is to rule out the other possibilities first before taking these 
steps. 

 
To verify that the templates are correct or incorrect: 

1) When the turnaround template was downloaded from the Sterling 
Commerce Library it was in the form of a compressed executable. When 
that executable was run two files were extracted, the template (.tpl) and a 
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text document. The text document will tell you what inbound and outbound 
template must be used. 

2) Open the Partner Editor 
3) Highlight the partner in question 
4) Click Inbound 
5) Select the inbound relationship being used for the turnaround 
6) Click Translation 
7) Make a note of the description of both the Turnaround and Print templates 
8) Click Exit and then Exit again to return to the Partner Editor 
9) Click Outbound 
10)  Select the outbound relationship for the document being created by the 

turnaround template 
11)  Click Translation 
12)  Make a note of the description of the Screen Entry template 
13)  Click Exit until the Partner Editor is closed 
14)  Go to View>Translation Objects 
15)  Locate the Turnaround, Print and Screen Entry templates being used based 

on the descriptions you noted earlier. 
16)  Highlight each in turn and click View 
17)  Make a note of the Filename for each of these. 
18)  The name of the text file that came with the turnaround template will 

match the filename of the turnaround template with a .txt extension. If you 
are not sure where this file was saved you can use this name to perform a 
search on your computer. 

19)  Open the text file and verify that the Filenames for the print and screen 
entry templates being used match the names listed therein. If they do not 
match you will need to download the appropriate templates. If they do 
match then this is not the problem and further troubleshooting may need to 
be done. 

 
NOTE: If you are unable to locate the text file please login to the Sterling 
Commerce Library and look under Available Downloads. If the turnaround 
template is still listed here simply download it and extract it again to get the text file. 
If it is not listed in Available Downloads please contact customer support by calling 
1-800-GENTRAN, using Support on Demand to open a support case or by sending 
an e-mail with you question to pcbasedsupport@stercomm.com
 
NOTE: If you are using templates that you created please contact mapping support 
at 1-800-GENTRAN. Follow the options for the mapping department. 
 
 
If, after going through these steps, you are unable to at least determine 
the cause of the problem please contact support at 1-800-GENTRAN for 
assistance. 
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How to reprocess data: 
 
1. Open Interchanges and verify the date and time that the problem data was received. 
2. Close Interchanges and go to Tools > Communications > Log. 
3. Find the communications session that matches the date and time of the downloaded interchange.  
4. Highlight the session, and then click Reprocess. 
5. Note that all data from that session will be reprocessed and you may need to delete any data you 
are not currently troubleshooting. 
 
How to use the xprocess utility: 
 

1. Copy xprocess.exe from the C:\program files\commerce connecton32\Bin 
directory to the directory where the data file resides.   

2. Open a DOS prompt.  

3. Change directories to the directory where the data file is located.  

4. Type "xprocess -# filename.txt" (without parentheses) where # is a number from 
1-13 indicating the xprocess command you want to use and filename.txt is the 
name of the file you want to process.  Hit the enter key and the xprocess 
command will run on the file. 

XPROCESS -1 [filename] 
appends the file specified to the beginning of the data. 
 
XPROCESS -2 
replaces tilde (~), carriage return (0D), and line feeds (0A) with carriage returns (0D). 
 
XPROCESS -3 
replaces all carriage returns (0D) with tildes (~) and drops any line feeds (0A). 
 
XPROCESS -4 
drops all carriage returns (0D) and line feeds (0A). 
 
XPROCESS -5 
drops all carriage returns (0D) and line feeds (0A) and adds hex 0x1A to the end of the file. 
 
XPROCESS -6 
removes all hex 0x1A from the data. 
 
XPROCESS -7 
adds GM header/trailer records and drops all carriage returns (0D) and line feeds (0A). 
 
XPROCESS -8 
replaces every tilde (~), carriage return (0D), and line feed (0A) with line feed (0A). 
 

Page 11 of 12 
© 2000 Sterling Commerce. All rights reserved. 



  
Gentran:Director for Windows      
 

XPROCESS -9 
replaces every line feed (0A) with tildes (~). 
 
XPROCESS -10 
replaces all carriage returns (0D) with carriage return (0D) and line feed (0A). 
 
XPROCESS -11 
replaces a string of hexadecimal characters with another string of hexadecimal characters. 
example: xprocess -11 0x7e0x0d0x0a 0x7e0x0d. 
 
XPROCESS -12 
removes all occurrences of a hexadecimal string from a file. 
example: xprocess -12 0x0d0x0a. 
 
XPROCESS -13 
inserts a hexadecimal string at the specified increment [Nbr bytes] in the input file 
(blocking streamed EDI data, for example). 
example: xprocess -13 40x0d0x0a. 
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