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Overview 0

Introduction

Features of the
VDA Standards

VDA, the German automotive standard, has several features that distinguish it from most 
other standards supported by Gentran:Server® for Windows®:

◗ It does not use a common set of interchange envelopes for all messages.
◗ It does not use functional groups.
◗ It uses a positional, nondelimited format.
◗ It uses looping but not composite elements.
◗ It uses a new control number (for the current transmission) and an old control number 

(for the previous one). As a result, control numbers do not need to be sequential.
◗ In some messages, it processes date formats differently.
◗ It uses a separate message to identify the communications protocol. A message is 

defined by a four-digit number, which doesn't appear in the data.
◗ The first record has six fields: version, customer, supplier, old transmission number, 

new transmission number, and transmission date.
◗ Each record begins with a three-byte record ID and a two-byte version number.

Intended audience The intended audience for this document is the staff responsible for exchanging business 
documents using the VDA standards.

Prerequisite
knowledge

The audience using this software should be familiar with Gentran:Server for Windows and 
the VDA standards.

Note
This manual is not intended to explain the VDA standard.
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VDA Standards The VDA standards are not included in the Gentran Standards Database. Instead, Sterling 
Commerce provides VDA support for Gentran:Server for Windows by providing file 
format definitions, or .ifd files, on a separate CD or diskette. You install the file format 
definitions using the install program on the CD or diskette. The install program places all 
the .ifd files, and build and break maps into the folder Gensrvnt\Maps\Vda; and all the .tpl 
files into the folder Gensrvnt\Transobj\Vda. The tutorial data files are stored in the 
Gensrvnt\Tutorial\Vda folder.

In addition, support for VDA requires the user to follow special procedures in setting up 
Trading Partners and in configuring Gentran:Server. This document describes these steps 
and provides a tutorial for processing a sample VDA message.

References
◗ For more information on the VDA standard, access this web site.

http://www.vda.de

◗ For more information on ordering VDA recommendations, access this web site:
http://www.vda.de/de/service/sonstige_veroeffentlichungen/
index.html

and select the “VDA-Empfehlungen” option.
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VDA Support in Gentran:Server

Supported
Message Types

Gentran:Server currently supports VDA message types 4905, 4906, 4907, 4908, 4913, and 
4915. 

To use VDA with Gentran:Server, you must make changes to three functions in the 
product: translation objects (compiled maps), Trading Partner definitions, and the 
Gentran:Server configuration. This section covers the changes to each of these functions.

VDA Maps Sterling Commerce provides the following map files to support VDA messages. Similar 
files are used to support the other message types.

Sterling Commerce provides an .ifd file (for example, 4908.ifd) for each supported VDA 
message type. As support is provided for additional messages, Sterling Commerce will 
update BrkTvda.map, BrkIvda.map, BldIvda.map and BldTvda.map.

Note
The CDA version of a specified message is part of the name of the .IFD file. For example, 
the name of file 4905_ED4_0496.IFD indicates that this file contains the VDA structure 
of the VDA message 4905 of edition 4, that is dated from April 1996.

Headers and
Trailers List

This table lists the headers and trailers for other supported VDA message types:

File Name Description

BrkIvda.map Interchange break map

BrkTvda.map Transaction break map

BldIvda.map Interchange build map

BldTvda.map Transaction build map

*.ifd VDA side of map

Message type Header Trailer

4905 511 519

4906 811 819

4907 911 919

4908 821 829

4913 711 719

4915 551 559
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Outbound VDA Envelope

Introduction Use the Outbound VDA Envelope dialog box to assign values to be used with specific 
headers in VDA messages.

When to use Use the Outbound VDA Envelope dialog box when you want to provide information to be 
included in the outbound interchange envelope using the Trading Partner information, 
rather than through the application file.

Outbound VDA
Envelope diagram

This diagram illustrates the Outbound VDA Envelope.

Fields, Field
Length, and
Description

This table describes the fields on the Outbound VDA Envelope dialog box, and the length 
and description of each field.

Dialog Box Field
Field 

Length Description

Supplier Number 9 An identification number assigned to a supplier by a 
customer. All fields of a record structure that contain 
the field Supplier Number are subject to data privacy 
protection. Data entries are left justified.

(Continued on next page)
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Customer 
Number

9 An identification number assigned to a customer by 
a supplier. All fields of a record structure that 
contain the field Customer Number are subject to 
data privacy protection. Data entries are left 
justified.

Sender Number 9 An identification number that the data sender 
arranges with the data receiver.

Receiver Number 9 An identification number that the data receiver 
arranges with the data sender.

Data Sender 9 An identification number that the data sender 
arranges with the data receiver.

Data Source 
Number

9 An identification number that the data source 
arranges with the data receiver.

Sub Suppliers 9 An identification number that is assigned to a sub 
supplier by a customer.

Sales Tax ID 
Recipient

20 An identification number of the national tax office 
for the recipient. This field is mandatory for delivery 
of goods within the European Union. Data entries 
are left justified.

Sales Tax ID 
Sender

20 An identification number of the national tax office 
for the sender. This field is mandatory for delivery of 
goods within the European Union. Data entries are 
left justified.

Payment 
Indication 
Number

6 A link between data transmission payment 
notification and real payments received. This 
includes the Check number and remittal number. 
Data entries are left justified.

Comp. Reg. 
Number

25 An identification of the National Register of 
Business Names (Commercial Register) for the 
supplier. This field is mandatory for some European 
countries.

Carrier Number 9 The carrier data number of VDA message 4920. If 
relevant, the contents of this field will be identical to 
the contents of the field in record type 712, position 
13.

Warehouse 
Keeper Code

1 A code that identifies the person who created the 
interchange.

Purpose Code 2 Not used in this release.

 (Contd)
Dialog Box Field

Field 
Length Description
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Fields and
Message Headers

This table shows the fields of the Outbound VDA Envelope and the VDA message 
headers that the field is used with. An X indicates that the field is used with that VDA 
message, and is required on the Outbound VDA Envelope dialog box.

Dialog Box Field

Message
Release Date

4905
1088

4905
0496

4906
0593

4907
0893

4908
0596

4913
1094

4915
1189

Supplier Number X X X X X X

Customer Number X X X X X X

Sender Number

Receiver Number

Data Sender X

Data Source Number X

Sub Suppliers X

Sales Tax ID Recipient X X

Sales Tax ID Sender X X

Payment Indication 
Number

X

Comp Reg. Number X

Carrier Number X

Warehouse Keeper 
Code

X

Purpose code
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Tutorial 0

Tutorial Overview

In this Tutorial This tutorial provides an example of how to set up Gentran:Server for Windows with 
VDA message 4908. In this tutorial, you will 

◗ Install the VDA Tutorial files, maps, and file format definitions
◗ Configure Gentran:Server for use with VDA standards
◗ Set up a Trading Partner mailbox 
◗ Import a VDA Trading Partner
◗ Compile and register maps
◗ Process a sample message, both inbound and outbound
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How to Install the VDA Tutorial Data

Before you begin Before you begin installing the VDA Tutorial data, ensure that you have installed 
Gentran:Server for Windows Release 5.2. 

Procedure Use this procedure to install the VDA tutorial data onto your Gentran:Server system.

Step Action

1 Insert the CD or diskette containing the VDA Tutorial data, maps, and file 
format definitions into the appropriate disk drive.

2 Start Windows Explorer and browse to the drive where you inserted the 
CD or diskette containing the VDA Tutorial data.

3 ◗ If you are installing from a diskette, double-click Setup.
◗ If you are installing from a CD, browse to the VDA folder and then 

double-click Setup.

System Response
Windows launches the installation program.

4 Click Next.

System Response
The Choose Destination Location dialog box is displayed.

5 Click Next to accept the default installation location.

6 Click OK to complete the installation procedure.
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Configuring Gentran:Server for VDA

Before you Begin Before you begin the tutorial, create a folder called Vda_out under the \Gensrvnt folder.

How to Register
the Tutorial
Translation

Objects

Use this procedure to register the translation objects provided with the tutorial data.

How to Set the
Import Path

Use this procedure to set the Gentran:Server Import Path.

Step Action

1 Start Gentran:Server and select Translation Objects from the View menu.

System Response

The EDI Translation Objects dialog is displayed.

2 Click New to open the Register Translation Object dialog box.

3 Browse to the Gensrvnt\Transobj\Vda folder and select the following files:

◗ BrkIvda.tpl
◗ BrkTvda.tpl
◗ BldIvda.tpl
◗ BldTvda.tpl

4 Click Open. 

The translation objects are now registered and can be used.

5 Click New to open the Register Translation Object dialog box.

6 Browse to the Gensrvnt\Tutorial\Vda folder and select the following 
files:

◗ VDA4908_IN.tpl
◗ VDA4908_OUT.tpl
◗ Sys_Import_Header.tpl

7 Click Open.

The translation objects are now registered and can be used.

Step Action

1 From the Windows Start menu, point to Gentran:Server and select 
Gentran Server Configuration.
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How to Create a
New Splitter Entry

Use this procedure to create a new entry in the splitter table.

2 Select the Imports tab.

3 In the File Path box, enter c:\gensrvnt\tutorial\vda\*.txt.

4 Select Sys Header – VDA from the Translation Object list.

5 Click Move Up so that the path you typed is moved to the top of the list 
and thus takes priority.

Step Action

Step Action

1 From the Windows Start menu, point to Gentran:Server and select 
Gentran Server Configuration.

2 Select the Splitter tab, and click New.

3 Select Positional from the Type list.

4 In the Start box, enter 821, the number for the header record in message 
4908. 

5 In the End box, enter 829, the number for the trailer record in message 
4908.

6 Select VDA Int Break from the Interchange Break list.

7 Select VDA Trn Break from the Transaction Set Break box.

8 Enter 500 in the Max length of End segment box.
(Continued on next page)
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9 Click Apply. 

System Response
The dialog box should now look like this.

10 Click OK to save your changes and leave Configuration.

Note
You must repeat this procedure for every VDA message type that you 
intend to use.

 (Contd)
Step Action
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How to Create a Trading Partner Mailbox

Procedure Use this procedure to create a Trading Partner mailbox.

Step Action

1 Select Mailbox from the Gentran:Server Tools menu.

System Response
The Mailbox Server Manager is displayed.

2 Double-click Gentran:Server Mailbox to expand it. 

Note
If the mailbox doesn't expand, the server has not been registered. To 
register it, follow these steps:

1. Right-click Gentran:Server Mailbox and select Register Server. The 
Register Server dialog box is displayed.

2. Enter the machine name of the of the primary system controller and 
click OK.

3 Double-click the name of the machine.

4 Right-click Mailboxes and select Create. 

System Response
The Create Mailbox Wizard is displayed.

5 Name the mailbox VDA Outfile.

Note
It is normal, but not required, to identify the partner in the mailbox. The 
sample VDA partner has not been created yet, so do not identify the 
partner.

System Response
The second Create Mailbox Wizard dialog box is displayed.

6 For the purposes of this tutorial, select Yes, use this mailbox as a 
gateway, and select File System as the type.

7 Click Next to see the summary screen, where you can verify the 
information for this mailbox. 

8 Click Finish. 

System Response
The File System Gateway properties dialog is displayed.

(Continued on next page)
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9 Select the Extraction tab to define the folder to which outbound VDA 
files are extracted.

10 Select Extract files from this mailbox, and enter the following path in the 
box below it: c:\gensrvnt\vda_out. 

11 Select Append all messages to a single file, and enter vda4908.out in the 
box below it.

12 Click OK to complete the process.

 (Contd)
Step Action
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How to Import the Tutorial Partner Profile

Introduction The Partner Profile defines the parameters that control the processing and structure of 
inbound and outbound data. For this tutorial, we have provided a sample Partner Profile.

Procedure Use this procedure to import the Partner Profile provided for this tutorial.

Step Action

1 Select Partner from the Desktop.

System Response
The Partner Editor is displayed.

2 Click Import.

System Response
The Import File Select dialog box is displayed.

3 Browse to the Gensrvnt\Tutorial\Vda folder, select VDAPART.PAR and 
click Open.

System Response
The Import dialog box is displayed.

4 Verify that the Partner to Import box shows VDAPART and click Save.

System Response
The system imports the partner details and displays the Partner Editor 
dialog box.

Note
Gentran:Server prompts you for any additional information that it needs 
by displaying the appropriate Partner Editor dialog box.

5 Click Save when you have finished entering information.

System Response
The system displays the message “Import Process Complete. Please note 
any warnings or errors.”

6 Click OK.

7 Click Exit.
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How to Create an Outbound VDA Map

Introduction The normal procedure for using VDA requires that when you create a new map for 
outbound messages, you import an .ifd file for the output side of the map. For the purpose 
of this tutorial you will use a map that we have already created.

Note
The CDA version of a specified message is part of the name of the .IFD file. For example, 
the name of file 4905_ED4_0496.IFD indicates that this file contains the VDA structure 
of the VDA message 4905 of edition 4, that is dated from April 1996.

Procedure Use this procedure to create an Outbound VDA Map.

Step Action

1 Open Gentran:Server Application Integration. 

2 Select Open from the File menu. 

3 Browse to the Gensrvnt\Tutorial\Vda folder and select 
VDA4908_Out.map.

System Response
The Output side of the map now looks like this:

4 Select the top row of the left side of the map, and select Expand All from 
the View menu.

(Continued on next page)

5 Repeat Step 4 for the right side of the map.

Note
If you do not see the link lines, select Preferences from the Options menu 
and click the Links tab. Select the Show links to or from all visible 
elements option.
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6 Select Details from the Edit menu.

System Response
The Translation Object Details dialog box is displayed.

Note
The entries in the Output section serve as the basis for defining the 
Trading Partner information.

 (Contd)
Step Action
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How to Compile and Register Tutorial Maps

Supplied Tutorial
Maps

The following maps are supplied with Gentran:Server for use with this tutorial:

Before you can use these maps, you must compile and register them.

Procedure Use this procedure to compile and register the tutorial maps.

Map Description

BrkIvda.map Interchange break map

BrkTvda.map Transaction break map

BldIvda.map Interchange build map

BldTvda.map Transaction build map

Step Action

1 To compile the maps, start Gentran:Server - Application Integration.

2 Select Open from the File menu.

3 Select a .map file and click OK.

4 Select Compile from the File menu. 

Note

The compiled maps (*.tpl files) are saved in the \TransObj folder.

Comment
You are now ready to register the translation objects.

5 Select Translation Objects from the Gentran:Server View menu.

Comment
The Translation Objects dialog box lists the templates that are already 
registered with Gentran:Server.

6 Click New to open the Register Translation Object dialog box.

7 Select the files to register, and click Open. 

Note
You can Control-click filenames to select multiple entries, or Shift-click to 
select contiguous entries.

The translation objects are now registered and can be used.
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How to Create an Outbound Relationship

Introduction You need to identify your partner with the outbound translation objects that you have 
registered.

Procedure Use this procedure to create an outbound Trading Partner Relationship.

Step Action

1 In Gentran:Server, click Partners to display the list of partners.

2 From the Partner Editor, click New. 

3 In the Profile ID box, enter VDAPART.

4 In the Name box, enter VDATEST.

5 In the EDI Code box and the Application Code box, enter VDATEST.

6 In the Mailbox list, select VDA Outfile or the name you gave when you 
created a mailbox.

7 Click Save to save the information and return to the Partner Editor.

8 Select the new partner and click Outbound to begin setting up the 
outbound relationship. 

System Response
The Outbound Relationship dialog box is displayed.

9 Click New

10 Enter Outbound 4908 in the Enter new description: box.

11 Click Save to return to the Outbound Relationship dialog box.

12 Select V-VDA from the Standard list.

13 Select 4908 from the Version and Transaction Set lists.

Note
These items are available here because you registered maps that contain 
this information in the Translation Objects Details dialog.

14 Click Groups and select <none>.

15 Click Translation to define the Outbound Translation Objects dialog box.

16 Select Sample App to 4908 from the Import list. 
(Continued on next page)
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17 Select VDA Trn Build from the Transaction list.

System Response
The Outbound Translation Objects dialog box should now look like this.

18 Click Save to save the information and return to the Outbound 
Relationship dialog box.

19 Click Interchanges from the Outbound Relationship dialog box to create 
an Outbound Interchange Entry.

20 Click New from the Outbound Interchange Select dialog box to create a 
new Outbound Interchange.

21 Notice the value in the Interchange Transl. Obj. box.

(Continued on next page)

 (Contd)
Step Action
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22 Click Envelope. 

System Response
The following dialog box is displayed.

23 Complete the fields as necessary and click Save.

Reference
See Outbound VDA Envelope on page 5 for more information about how 
to complete this dialog box.

24 Click Save until you have closed all dialog boxes.

Note
If you have problems setting up the partner, import the sample partner file 
(Partners\vdapart.par) included for use with this tutorial. Make sure you 
have registered all the compiled templates first.

 (Contd)
Step Action
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How to Create an Inbound VDA Map

Procedure Use this procedure to open, compile, and register the maps for inbound data.

Step Action

1 Open Gentran:Server Application Integration.

2 Select Open from the File menu.

3 Browse to Gensrvnt\Tutorial\Vda folder and select VDA4908_IN.map.

System Response
The Input side of the map now looks like this:

4 Select Compile from the File menu, and save the file as a .tpl file in the 
\TransObj folder.

(Continued on next page)
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5 To view the Translation Object Details, select Details from the Edit menu. 

System Response
The Translation Object Details dialog box should look like this.

6 Register the translation object.

Reference

See How to Compile and Register Tutorial Maps on page 18 for more 
information.

Step Action
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How to Create an Inbound Relationship 

Introduction You need to identify your trading partner with the inbound translation objects that you 
created, compiled, and registered.

Procedure Use this procedure to create an inbound Trading Partner Relationship.

Step Action

1 From the Partner Editor, select the VDA partner that you created earlier 
and click Inbound.

2 Click New.

3 Enter Inbound 4908 in the Enter new description box.

4 Click Save to return to the Inbound Relationship dialog box.

5 Select Inbound 4908 from the Relationship Description list. 

6 Select V-VDA from the Standard list.

7 Select 4908 from the Version and Transaction Set lists.

8 Click Groups and select <none>.

9 Click Interchanges. 

System Response
The Inbound Interchange Entry dialog box is displayed.

10 Click Translation to define the Inbound Translation Objects.

11 Select 4908 to Positional from the Export File list.

12 Select VDA Trn Break from the Transaction list. 

13 Click Save to save the information and return to the Inbound Relationship 
dialog box.

14 Click Interchanges from the Inbound Relationship dialog box to create an 
Inbound Interchange Entry. 

15 Click New to create a new Inbound Interchange. 

System Response

The following dialog box is displayed.
(Continued on next page)
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16 Select 821 from the Interchange ID list.

Note

821 is the header record in message 4908.

System Response
The Inbound Interchange Entry dialog box should look like this.

17 Click Save until you close all Partner Editor dialog boxes.

 (Contd)
Step Action
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Processing a Sample Application File: Outbound

Introduction The purpose of this section is to test your work in this tutorial by processing a file and 
sending it through the Gentran:Server system. Briefly, you will import an application file, 
post it, and send it.

We have provided a simple application file (Gensrvnt\Tutorial\Vda\VDA4908.vda) to 
serve as the basis for our test.

Procedure Use this procedure to test outbound processing.

Step Action

1 Open Gentran:Server and click Workspace. 

2 Click Import to import the application file.

3 Use the Application Files to Import dialog box to select the file 
VDA4908.vda in the Gensrvnt\Tutorial\Vda folder, and click Open. After 
a few seconds, the imported file appears in the Workspace.

4 To view the imported file, select it, click View, leave Raw EDI selected on 
the View Choice dialog box, and click OK. You can see that it has been 
translated to VDA format.

5 In the Workspace dialog box, select the imported file and click Post to 
send it to the Out box.

6 Click Close to close the Workspace.

7 Click Out on the Gentran:Server desktop. 

System Response

The Out Documents Summary is displayed.

8 Select VDAPART 4908 and click View to open the document-level Out 
Documents dialog box.

9 Select the document you posted, and click Send to send it to the Out 
Drawer.

10 After the communications session is opened and the document is sent, 
click Close twice to close both of the Document Summary dialog boxes.

(Continued on next page)
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11 Click Out Drawer on the Gentran:Server desktop. 

System Response

The Out Drawer Summary dialog box is displayed.

12 Select VDAPART 4908 and click View to open the document-level Out 
Drawer dialog box.

13 As indicated in the Status column, the VDAPART 4908 document has 
been sent.

 (Contd)
Step Action
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Processing a Sample Application File: Inbound

Introduction To test inbound processing, you will process the file that you transmitted and receive it as 
an inbound VDA file.

Procedure Use this procedure to process a VDA file and export it to your application format.

Step Action

1 Open Gentran:Server and select Process File from the Commands menu. 

2 In the Process File dialog box, select file VDA4908i.txt from the 
Gensrvnt\Tutorial\Vda folder and click Open.

System Response
The CommPost dialog box is displayed, indicating the progress of the 
translation.

3 Click In to open the In Documents Summary dialog box.

4 Select the VDAPART 4908 line and click View to open the document-
level In Documents dialog box.

5 Select the VDAPART 4908 document and click Export. 

System Response
The Select Export Method dialog box is displayed.

6 Select Export to Single File. 

7 Select the folder and file name for the export from the Choose file to 
Export document dialog box. 

System Response
A dialog box is displayed to show progress as Gentran:Server translates 
the VDA file into the application format.
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