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Using RND

About RND with Sterling Gentran:Server
This document contains reference information and step-by-step procedures
designed to assist you as you use IBM® Sterling Gentran:Server® for Microsoft
Windows to work with Rede Nacional de Dados (RND), a Brazilian automotive
standard, to exchange business documents.

The RND standard files are not included in the IBM Sterling Gentran® Standards
Database. Instead, IBM provides RND support for Sterling Gentran:Server by
providing data definition format files (.DDF files) on the Sterling Gentran
Standards DVD.

RND has several features that distinguish it from most other EDI standards:
v It does not use functional groups.
v It uses a positional, non-delimited format.
v It uses looping elements but not composite elements.
v In some messages, it processes date formats differently.
v It uses a separate message to identify the communications protocol. Each RND

message is defined by a three-digit number, which appears in the data.
v Each record begins with a three-byte record ID and a two-byte version number.

To use the RND standard with Sterling Gentran:Server, you must:
v Successfully install Sterling Gentran:Server.
v Be familiar with Sterling Gentran:Server and the RND standard.
v Have access to a Sterling Gentran:Server system administrator while you are

implementing RND, in case you need assistance with the configuration process.

RND Folder Files and Contents
Because the RND standard is not included in the Sterling Gentran Standards
Database, the Sterling Gentran Standards DVD contains standards files that enable
you to use RND with Sterling Gentran:Server.

The tutorial files enable you to quickly set up processing using RND. These files
are located in the GENSRVNT\RND Standard folder on your hard drive after you
install the RND standards from the Sterling Gentran Standards DVD.

The following files are located in the RND Standard folder on your hard drive:
v Standard Layouts or .DDF Files
v System Maps and Translation Objects
v Tutorial Files

Standard Layouts or .DDF Files
A standard layout (.DDF file) is a file definition that contains the RND standard
layout. The data definition format (.DDF) is an IBM format that contains an
XML-formatted description of the input or output side of a source map and has
the file name extension .DDF.
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The .DDF files include the hierarchical and looping structure of the data, the map
objects (groups, records, fields), and their attributes (for example, names,
descriptions, data types). A .DDF file can be loaded (imported) or created (for
export) from Application Integration. The .DDF files do not contain standard or
extended rules, links, or any other map information unrelated to the data, although
the one exception is the Use Code code lists. If the map references a Use Code
standard rule and instructs Sterling Gentran:Server to raise a compliance error if
the code is not found in the Use Code code list, Sterling Gentran:Server saves the
standard rule and the associated code list.

IBM provides a .DDF file for each supported message type. As support is provided
for additional messages, IBM will update the standard.

The GENSRVNT\RND Standard\FileDefinitions folder on your hard drive (after you
install the RND standards from the Sterling Gentran Standards DVD) contains the
.DDF files for the following RND standard layouts.

File Name For Business Document Type

RND001.DDF Material/Parts Schedule

RND002.DDF Need Diary Production

RND003.DDF Parts/Material Criticize

RND004.DDF Material/Parts Ship

RND005.DDF Material/Parts in Delay

RND006.DDF Answer of Delivery PGM

RND007.DDF Purchase Order

RND008.DDF Request of Alteration

RND010.DDF Solicitation of Quotation

RND012.DDF Daily Programming of Piece/Material

See About RND Maps for step-by-step instructions on how to use the .DDF files to
create maps.

System Maps and Translation Objects
The following system maps are included within the GENSRVNT\RND
Standard\SystemMaps folder on your hard drive (after you install the RND
standards from the Sterling Gentran Standards DVD):

Map Name Description

BrkIRND.map Interchange Break Map

BrkTRND.map Transaction Break Map

BldIRND.map Interchange Build Map

BldTRND.map Transaction Build Map

BrkTRND2.map Pass through Transaction Break Map

The following RND system translation objects (compiled maps) also are included
in the GENSRVNT\RND Standard\SystemMaps folder:

Map Name Description

2 IBM Sterling Gentran:Server for Windows: RND User Guide



BrkIRND.tpl Interchange Break Map

BrkTRND.tpl Transaction Break Map

BldIRND.tpl Interchange Build Map

BldTRND.tpl Transaction Build Map

BrkTRND2.tpl Pass through Transaction Break Map

See Registering System and Tutorial Translation Objects for step-by-step
instructions on how to register the system translation objects.

Tutorial Files
After you install the RND standards from the Sterling Gentran Standards DVD),
the tutorial files will reside in the GENSRVNT\RND Standard\Tutorial folder on your
hard drive.

RND tutorial files have been provided to assist you as you work with RND
Standards. These tutorial files enable you to view examples of RND maps and data
files. These files will help you break the inbound and outbound processes and
procedures into concise and understandable steps, using examples that enable you
to understand and master the tasks and processes required for you to implement
RND at your installation.

See Compiling the Tutorial Maps for more information on using these tutorial files.

RND Tutorial Maps

The following table describes the RND tutorial maps created for use with Sterling
Gentran:Server.

Map Name Business Document Type RND Transaction

RND_Sys_Import.map System import header map
for RND001o.map

RND001i.map Material/Parts Schedule 001

RND001o.map Material/Parts Schedule 001

RND001i2.map Material/Parts Schedule 001

Note: Custom maps are available through IBM Customer Support.

RND System Translation Objects

The following RND system translation objects (compiled maps) also are included
in the GENSRVNT\RND Standard\Tutorial folder:

Map Name Business Document Type RND Transaction

RND_Sys_Import.tpl System import header map
for RND001o.map

RND001i.tpl Material/Parts Schedule 001

RND001o.tpl Material/Parts Schedule 001

RND001i2.tpl Material/Parts Schedule 001
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Text Files

The following table describes the text files provided in the GENSRVNT\RND
Standard\Tutorial folder. These text files enable you to process the test data
through the system:

File Name Description

RND001i.txt Inbound data file for RND001i.map and RND001i2.map

RND001o.txt Outbound data file for RND001o.map

Partner File

The following table describes the trading partner file provided in the GENSRVNT\RND
Standard\Tutorial folder. This exported partner file enables you to process the test
data through the system:

File Used With

RNDTEST.par RND001i.map, RND001i2.map, and RND001o.map

Installing RND Standard Files to your Hard Drive
To use the RND standard with Sterling Gentran:Server, you must install the
standards files from the Sterling Gentran Standards DVD to your hard drive. If
you have installed Sterling Gentran:Server in a clustered environment, this is the
machine on which Application Integration is installed.

Before you begin

Before you begin installing the RND files, ensure that you have installed Sterling
Gentran:Server.

About this task

Use this procedure to install the RND standards files onto your hard drive:

Procedure
1. Insert the Sterling Gentran Standards DVD containing the RND tutorial data,

partner file, maps, translation objects, and data definition format (.DDF) files
into the appropriate drive on your machine.

2. Navigate to the drive where you inserted the Sterling Gentran Standards DVD.
3. Navigate to the RND\Windows folder and double-click Setup.exe.

Microsoft Windows launches the installation program.
4. Click Next to display the Choose Destination Location dialog.
5. Click Next to accept the default installation location.

Note: We recommend you accept the default to install the RND files under the
standard Sterling Gentran:Server installation folder on your hard drive
(GENSRVNT).

6. Click OK to complete the installation procedure.
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Compiling the Tutorial Maps
The Compile function compiles the map and creates a translation object. You use
the Compile function after the map is completed and saved.

About this task

The map that you create using Sterling Gentran:Server is a source map (the .MAP
file). When that source map is compiled, the result is a compiled translation object
(a .TPL file). This translation object must be registered with the Sterling
Gentran:Server system before you can use it.

Use this procedure to compile the RND tutorial maps and generate translation
objects:

Procedure
1. Within the Application Integration, select File > Open.
2. Browse to the GENSRVNT\RND Standard\Tutorial folder on your hard drive and

select the RND001i.map file.
3. Select File > Compile to display the Run-Time Translation Object Name dialog.

You are prompted to name the translation object the same name as the map file
with the file extension .TPL. For example, if the name of the map file is
RND001i.map, you are prompted with the translation object name RND001i.tpl.

4. Enter a name and click Save to accept the name and compile the map and
generate the translation object.

Note: Name the translation object (.TPL file) the same file name (one to eight
characters long) as the map (.MAP file). Preserving the same file name (with
different file extensions) will ensure that the relationship between the source
map and the compiled translation object remains evident.
The system displays the Compile Error dialog.

5. Verify that no errors occurred and click OK.
The date on which the translation object was compiled is automatically loaded
into the Compiled on box on the Translation Object Details dialog.

6. Select File > Save to save the source map with the "Compiled on" date.
7. Repeat steps 1 through 6 for each of the following tutorial maps:

v RND001i2.map

v RND001o.map

v RND_Sys_Import.map

Registering System and Tutorial Translation Objects
You need to register the provided RND translation objects in Sterling
Gentran:Server before you can use them.

About this task

Use this procedure to register the necessary translation objects.

Procedure
1. Within Sterling Gentran:Server, select View > Translation Objects to display

the EDI Translation Objects browser.
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2. Click New to display the Register Translation Object dialog box.
3. Browse to the GENSRVNT\RND Standard\SystemMaps folder on your hard drive

and select all of the following system translation objects:
v BrkIRND.tpl

v BrkTRND.tpl

v BldIRND.tpl

v BldTRND.tpl

v BrkTRND2.tpl

4. Click Open to register the translation objects.
5. Click New to display the Register Translation Object dialog box.
6. Browse to the GENSRVNT\RND Standard\Tutorial folder on your hard drive and

select all of the following tutorial translation objects:
v RND001i.tpl

v RND001i2.tpl

v RND001o.tpl

v RND_Sys_Import.tpl

7. Click Open to register the translation objects.

Creating an RND Splitter Entry
Create a splitter entry to identify and extract RND documents. Sterling
Gentran:Server uses splitters in the communications process to extract enveloped
data from a transmission file and determine which transaction break translation
objects should be used to process the data.

About this task

Use this procedure to create a splitter entry in the Sterling Gentran:Server System
Configuration to implement the RND standard with Sterling Gentran:Server.

Procedure
1. From your Microsoft Windows Start menu, select Programs > Gentran Server

> Gentran Server Configuration to access the System Configuration dialog
box.

2. Select Splitter.
3. Click New to define the RND splitter entry.
4. From the Type list, select Positional.
5. In the Start box, type ITP.
6. In the End box, type FTP.
7. In the Interchange Break list, select RND Interchange Break Template.
8. In the Functional Group Break list, verify that <none> is selected.
9. In the Transaction Set Break list, select RND Transaction Break Template.

10. In the Max length of end segment box, type 130.
11. Click Apply to add the splitter entry.
12. Click OK to exit the System Configuration dialog box.
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About RND Maps
Typically, when you are exchanging information with an RND trading partner, you
exchange information both inbound and outbound. Therefore, you will likely need
to create both an inbound map and an outbound map.

When you create a new RND map, you import the appropriate .DDF file from the
GENSRVNT\RND Standard\FileDefinitions folder to create the RND side of the map.
See the IBM Sterling Gentran:Server for Microsoft Windows Application Integration User
Guide for more information on using the .DDF files.

Note: Even though Application Integration uses .DDF files instead of .IFD files,
you do not need to recreate your maps even if you originally created them using
the .IFD files.

You cannot process an RND map until you have completed the preliminary
configuration steps.

Creating an Inbound RND Map
To create an inbound RND map, use Application Integration to import a .DDF file
to build the input side of the map (the input side consists of your positional
application file that you will need to build).

About this task

Use this procedure to create an inbound RND map:

Procedure
1. Within Application Integration, select File > New.
2. In the New Map wizard, enter the following information and click Next.

v Select Export as the type of map you are creating.
v Enter the unique name of the map. Application Integration adds the default

.MAP extension.
v Enter your name if it differs from the user name prompted by the New

Map wizard.

Note: The New Map wizard displays Input Format fields. You must complete
the format of the input side of the map. This is the format of the data that is
translated by Sterling Gentran:Server

3. In the Input Format window, select Create a new data format using this
syntax and select Positional.

4. Click Next.
5. In the Output Format window, select Create a new data format using this

syntax and select Positional.
6. Click Next.
7. Click Finish to create the map.

The map opens in Application Integration.
8. Select File > Save to save the map.

Note: Do not use spaces or apostrophes in the map name. To save a map as a
.map file, select File > Save As and then select Source Maps (*.map) as the
file type.
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9. Right-click the data format icon on the input side of the map and select Open
File Definition.
A warning message is displayed.

10. Click Yes to continue.
11. Browse to the GENSRVNT\RND Standard\FileDefinitions folder to locate the

appropriate .DDF file.
12. Click Open to open the selected file into the map.

Example

Now you need to create your application layout on the output side of the map,
create any necessary links, standard rules, and extended rules, and save and
compile the map. See the IBM Sterling Gentran:Server for Microsoft Windows
Application Integration Guide for more information on performing specific mapping
tasks.

Creating an Outbound RND Map
To create an outbound RND map, you will use Application Integration to import a
.DDF file to build the output side of the map (the input side consists of your
positional application file that you will need to build).

About this task

Note: When you create an outbound (import) map, you also need to create a
system import header map. A system import map is used by the system to find the
partner relationship for a document, to determine which import map is used to
translate the data. The system import map builds the key that the translator uses
to find the partner relationship. The sole function of the system import map is to
identify the appropriate partner relationship; the system import map does not map
any data.

See the IBM Sterling Gentran:Server for Microsoft Windows Application Integration User
Guide for more information on creating a system import header map.

Use this procedure to create an outbound RND map:

Procedure
1. Within Application Integration, select File > New.
2. In the New Map wizard, enter the following information and click Next.

v Select Import as the type of map you are creating.
v Enter the unique name of the map. Application Integration adds the default

.MAP extension.
v Enter your name if it differs from the user name prompted by the New

Map wizard.

Note: The New Map wizard displays Input Format fields. You must complete
the format of the input side of the map. This is the format of the data that is
translated by Sterling Gentran:Server.

3. In the Input Format window, select Create a new data format using this
syntax and select Positional.

4. Click Next.
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5. In the Output Format window, select Create a new data format using this
syntax and select Positional.

6. Click Next.
7. Click Finish to create the map.

The map opens in Application Integration.
8. Select File > Save to save the map.

Note: Do not use spaces or apostrophes in the map name. To save a map as a
.map file, select File > Save As and then select Source Maps (*.map) as the
file type.

9. Right-click the data format icon on the output side of the map and select
Open File Definition.
A warning message is displayed.

10. Click Yes to continue.
11. Browse to the GENSRVNT\RND Standard\FileDefinitions folder to locate the

appropriate .DDF file.
12. Click Open to open the selected file into the map.

What to do next

Now you need to create your application layout on the output side of the map,
create any necessary links, standard rules, and extended rules, and save and
compile the map. See the IBM Sterling Gentran:Server for Microsoft Windows
Application Integration Guide for more information on performing specific mapping
tasks.

About RND Trading Partners
To create an RND trading partner relationship, you need to create a partner profile.

If you are receiving and processing information from that trading partner, you
need to define an appropriate inbound relationship that is associated with that
partner profile.

If you are sending information to this trading partner, you need to define an
outbound relationship that is associated with that partner profile. The outbound
relationship includes the envelope definition.

You need to create a partner profile and the appropriate inbound and outbound
relationships for each partner with whom you are going to exchange data.

Note: If you are also using RosettaNet with Sterling Gentran:Server (in addition to
using RND), contact customer support for instructions on creating and managing
RND trading partners.

Importing the RND Tutorial Partner Profile
The tutorial partner profile (RNDTEST.par) is a sample RND partner profile. We
recommend that you import this partner profile and review it prior to creating
partner profiles for your own RND trading partners.

About this task

Use this procedure to import the tutorial partner profile:
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Procedure
1. Within Sterling Gentran:Server, select Tools > Partner Editor.
2. Click Import to access the Import File Select dialog box.
3. Browse to the GENSRVNT\RND Standard\Tutorial folder, select the RNDTEST.par

profile, and click Save to access the Import dialog box.
4. Verify that the Partner to Import box indicates RNDPART and click Save. The

system imports the partner details and displays the Partner Editor dialog boxes.

Note: Sterling Gentran:Server prompts you for any additional information that
is necessary by displaying the appropriate Partner Editor dialog box.

5. Click Save after you have entered the necessary information.
The system displays the message: Import Process Complete. Please note any
warnings or errors.

6. Click OK.
7. Click Exit.

Creating an Inbound Relationship
Before you begin

You must have already created a partner definition for this partner. See Creating a
New Partner Definition in the IBM Sterling Gentran:Server for Microsoft Windows
User Guide for more information.

The information required for this task should be provided to you by your trading
partner when this partner defines the details of the transactions they send you.

About this task

The contents of the lists in this task are displayed from the translation objects
registered in Sterling Gentran:Server. For example, if there are no translation
objects for RND001 version 06 registered with Sterling Gentran:Server, you will not
be able to select that version from this dialog box.

The lists display all of the translation objects that are registered in the system that
are appropriate for the type of translation object (such as Export and Print) and the
transaction set. If there are no translation objects displayed in the lists, no
translation objects of that type are registered for the version of the document
defined in the relationship.

Use this procedure to create an inbound relationship with your trading partner.

Procedure
1. Within Sterling Gentran:Server, select Tools > Partner Editor.
2. Select the partner profile for which you want to create an inbound

relationship and click Inbound.
The system displays the Inbound Relationship dialog box.

3. Click New.
The system displays the New Inbound Relationship dialog box.

4. In the Description box, type a unique relationship name (for example,
Inbound Invoice) and click Save.
The system creates a new inbound relationship.
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5. Select values for the following:
v Standard (select N for RND)
v Version
v Transaction Set

6. If you need to define parameters to comply with the processing needs of your
partner (such as Sequence Checking, Last Used Control, Duplicate Documents,
or Generate Acknowledgement), click Advanced and select the appropriate
values.

7. To select an inbound translation object, in the Inbound Relationship dialog
box, click Translation.
The system displays the Inbound Translation Object dialog box.

8. Select the translation objects that are required for this inbound relationship.
9. If you selected an Export File translation object and you want to export to a

specific file, type the universal naming convention (UNC) name of that file in
the Export File Name box.

10. To specify a mailbox and e-mail address so the output of the inbound
translation object can be delivered directly back to the Mailbox Server
Manager, select the Export to Mailbox check box and complete the
appropriate boxes.

11. Click Save to save your selections.
12. On the Inbound Relationship dialog box, verify that <none> is selected for

Groups.
13. Click Interchanges to display a list of existing interchanges.
14. If the required interchange is in the Interchanges list, select the interchange

and click Select. Continue with step 16.
15. If the required interchange is not in the Interchanges list, click New and do

the following:
a. In the Description box, type the interchange description.
b. In the Interchange ID box, type the identification of the interchange you

are specifying.

Note: If you have more complex requirements for processing the
interchange, click Advanced and select the appropriate values.

c. After you set up the required parameters in this dialog box, click Save to
store the information.

You return to the Inbound Interchange Select dialog box.
16. Highlight the new interchange and click Select.
17. On the Inbound Relationship dialog box, click Save to save the inbound

relationship.
18. Click Exit to return to the Partner Editor dialog box.

Creating an Outbound Relationship
Before you begin

You must have already created a partner definition for this partner.

The information required for this task should be provided to you by your trading
partner when this partner defines the details of the transactions it sends.
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About this task

The content of the lists in this task are displayed from the translation objects
registered in Sterling Gentran:Server. For example, if there are no translation
objects for RND001 version 06 registered with Sterling Gentran:Server, you will not
be able to select that version.

The lists display all the translation objects that are registered in the system that are
appropriate for the type of translation object (such as Import and Print) and the
transaction set. If there are no translation objects displayed in the lists, no
translation objects of that type are registered for the correct version of the
document defined in the relationship.

Use this procedure to create an inbound relationship with your trading partner.

Procedure
1. Select Tools> Partner Editor.
2. Select the partner profile for which you want to create an outbound

relationship and click Outbound.
The system displays the Outbound Relationship dialog box.

3. Click New.
The system displays the New Outbound Relationship dialog box.

4. In the Description box, type a unique relationship name and click Save.
The system creates a new outbound relationship and returns to the Outbound
Relationship dialog box.

5. Select values for the following:
v Standard (Select N for RND)
v Version
v Transaction Set

6. If you need to define parameters to comply with the processing needs of your
partner (for example, Last Used Control Number, Expect Acknowledgement,
Hours Overdue, Duplicate Documents, or Test Indicator), click Advanced.

7. On the Outbound Relationship dialog box, click Translation to display the
Outbound Translation Object dialog box.

8. From the lists, select the translation objects that are required for this outbound
relationship.

9. If you selected an Import translation object, you may need to define the
following:
v In the Application ID box, type the application identifier that indicates the

destination for the documents.
v In the Application Alias Value box, type criteria that the system will use to

distinguish this relationship from others during the application import
function.

10. Click Save to save your selections and return to the Outbound Relationship
dialog box.

11. Verify that <none> is selected for Groups.
12. Click Interchanges to display a list of existing interchanges.
13. If the required interchange is in the Interchanges list, select the interchange

and click Select. Continue with step 15.
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14. If the required interchange is not in the Interchanges list, click New and do
the following:
a. In the Outbound Interchange Entry dialog, type the interchange

description in the Description box.
b. In the Interchange ID box, type the identification of the interchange you

are specifying.

Note: The EDI standards define which interchange ID should be used for
each type of document.

c. On the Envelope dialog box, type the appropriate values into the following
fields:

Note: RND uses the Generic Interchange Envelope Fields dialog box for
the outbound interchange level of your partner setup. The table below lists
the fields on the Generic Interchange Envelope dialog box and indicates
the fields to which they correspond in the RND ITP Envelope.

Field
Mandatory/
Optional

Corresponding RND ITP
Envelope Field Field Length

Field 1 Mandatory Transmitter IRF code 14

Field 2 Optional Receiver IRF code 14

Field 3 Optional Internal Transmitter code 8

Field 4 Optional Internal Receiver 8

Field 5 Optional Transmitter name 25

Field 6 Optional Receiver name 25

d. In the Segment Terminator hex value box at the bottom of the dialog box,
type 0A.

e. Modify any other delimiters necessary.
f. Click Save to save the envelope information.
g. Click Exit to exit the Generic Interchange Envelope Fields dialog box.
h. If you have more complex requirements for processing the interchange,

click Advanced and select the appropriate values.

Note: Do not change the translation objects in the Interchange Transl. Obj.
and Acknowledge Transl. Obj. lists unless you have a specific reason to do
so.

i. To use the default Mailbox and e-mail Address, select the appropriate
mailbox from the Default Mailbox list or click New.
See the IBM Sterling Gentran:Server for Microsoft Windows Communications
User Guide for more information on creating mailboxes.

j. Click Save to store the information.
k. Click Save on the Outbound Interchange Entry dialog box.

15. Highlight the new interchange and click Select.
16. On the Outbound Relationship dialog box, click Save to save the outbound

relationship.
17. Click Exit to return to the Partner Editor dialog box.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive

Armonk, NY 10504-1785

U.S.A.

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing

Legal and Intellectual Property Law

IBM Japan Ltd.

19-21, Nihonbashi-Hakozakicho, Chuo-ku

Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
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incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation

J46A/G4

555 Bailey Avenue

San Jose, CA 95141-1003

U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.
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This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© IBM 2012. Portions of this code are derived from IBM Corp. Sample Programs. ©
Copyright IBM Corp. 2012.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks

IBM, the IBM logo, and ibm.com® are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “Copyright and
trademark information” at http://www.ibm.com/legal/copytrade.shtml.

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States,
and/or other countries.

IT Infrastructure Library is a registered trademark of the Central Computer and
Telecommunications Agency which is now part of the Office of Government
Commerce.

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,
Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.
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Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

ITIL is a registered trademark, and a registered community trademark of the Office
of Government Commerce, and is registered in the U.S. Patent and Trademark
Office.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java™ and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the
United States, other countries, or both and is used under license therefrom.

Linear Tape-Open, LTO, the LTO Logo, Ultrium and the Ultrium Logo are
trademarks of HP, IBM Corp. and Quantum in the U.S. and other countries.

Connect Control Center®, Connect:Direct®, Connect:Enterprise®, Gentran®,
Gentran:Basic®, Gentran:Control®, Gentran:Director®, Gentran:Plus®,
Gentran:Realtime®, Gentran:Server®, Gentran:Viewpoint®, Sterling Commerce™,
Sterling Information Broker®, and Sterling Integrator® are trademarks or registered
trademarks of Sterling Commerce®, Inc., an IBM Company.

Other company, product, and service names may be trademarks or service marks
of others.
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