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Chapter 1

Configure the Local Node

Configure the Connect:Direct Local Node
Before using Connect:Direct for Windows to transfer files, you have to configure the local node.

You can configure the local node using the Configuration Tool or with Connect:Direct Requester (also
called, simply, Requester). This set of topics provides instructions for using Requester. Requester is a
graphical user interface that enables you to define local nodes, user IDs, user authorities, and remote
user proxies.

With the Configuration Tool, you edit text files of user authorization and network map parameters,
and you can export these files. However, using the Configuration Tool requires that you understand
all the Connect:Direct keywords and their parameters. Requester makes it easier to define user
authorization parameters.

Note: The Configuration Tool also enables you to view or print a configuration. See Print and
View Node and Network Map Definitions under Define and Manage the Connect:Direct
Network.

To configure the local node using Requester, you:
1. Add a node definition for each server at the local site.
2. Add a user ID for each person who accesses one of the local servers.
3. Define the functions each local user can perform (functional authorities).
4. If necessary, configure user proxies for remote user access to the local node.

Add or Modify a Local Node Definition

To use Connect:Direct for Windows, you begin by configuring a local node for each server in the local
network. You identified a local node when you first installed Connect:Direct. Depending on the
configuration at your location, you can have more than one local node.

To add a local node definition for a server:

1. Select Node > Connection Settings > Insert Node.

2. Type the node name in the Name field or select a node in Active Directory Nodes if Active
Directory is enabled.

3. Optionally, select the default user ID to associate with the node in the Default User ID field.
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4. Select the operating system used by the node in the Operating System field. If any nodes are
registered in Active Directory, select Windows to display nodes registered in the Active Directory
Nodes field.

5. Enter the TCP/IP address in the Address field.

Note: See Specifying IP Addresses, Host Names, and Ports.

6. Type the port number in the Port field.

7. If this is the default node, select Set as the Default Node.

8. Click OK.

9. To modify a local node definition for a server at your site, double-click the node on the Nodes
tab of the Control Pad (left side of the Requester main window). Modify fields as required and
click OK.

Add a User

To add a new Connect:Direct user from Connect:Direct Requester:

1. If more than one local node is configured, on the Nodes tab of the Control Pad, highlight the
local node to which the user is to be added.

2. Select Node > Connection Settings > Edit Userids.

3. Click Insert.

4. Type information in the following fields:

• Name—Type the name of the new user. Either type the user name as defined in the
Windows setup, such as lmore, or type a fully qualified user name in the UPN format,
such as lmore@adtree.stercomm.com.

• Password—Type the password defined for the user.
• Verify Password—Retype the password defined for the user.

5. Click Remember Password to automatically reload the password when you attach as this user.

6. Click Set as the Default User if you want the new user to be the default user for the node.

7. Click OK.

8. If the verification password you typed does not match the initial password, you receive a message
indicating the passwords do not match when you click OK. Retype the verification password and
click OK.

9. Click OK on the User Properties window to save the settings, then click Close.

Attention: Changes made to node settings are not written to the Registry until you select OK.
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Modify a User ID

To modify a user ID from Connect:Direct Requester:

1. If more than one local node is configured, on the Nodes tab of the Control Pad, highlight the
local node for which the user is to be modified.

2. Select Node > Connection Settings > Edit Userids.

3. Double-click the user ID to modify.

4. Modify fields as necessary.

5. Click OK.

Delete a User

To delete a user from a node, from Connect:Direct Requester:

1. If more than one local node is configured, on the Nodes tab of the Control Pad, highlight the
local node from which the user is to be deleted.

2. Select Node > Connection Settings > Edit Userids.

3. Select the user you want to delete.

4. Select Delete, then Confirm.

The user is deleted.

Attach to a Local Node

After you configure the local node and define network users, you must attach to the local node. If a
user ID is set as the default and has the option Remember Password activated, the user is automatically
attached to the server.

1. Select Node > Attach.

2. Select a user ID from the Userid list.

3. In the Password field, type the password that corresponds to the user ID.

4. Click OK.

About Local Functional Authorities
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After you define a user ID for each user with access to the local node, you can limit the tasks a user
can perform by defining user authorities for each user ID. For example, you can permit a user to submit
Processes but not monitor or delete them. Define user authority as a default administrator or a general
user. Then define the directories where a user can perform functions. You can define authorities for
remote users, and you can group users under group authorities.

Define a Functional Authority Type
You can define two types of users: administrators and general users. Each user type has a set of default
privileges. The default administrator and general user definitions allow the user to perform basic
Connect:Direct tasks. You can use these templates to assign user authorities and restrict privileges.
The following table defines the default authorities of the administrator and the general user:

Authority Default Administrator Default General
User

View Processes in the TCQ yes yes

Issue the copy receive, copy send, run job, and run task
Process statements

yes yes

Issue the submit Process statement all yes

Monitor, submit, change, and delete all Processes yes no

Monitor, submit, change, and delete your own Processes yes yes

Run programs yes yes

Access Process statistics all yes

Upload and download files from any directory yes yes

Upload and download files to or from specific directories no no

Run programs from any directory yes yes

Run programs from specific directories yes no

Update the network map yes no

Update the translation table yes yes

Update local user authorities yes no

Update remote user secure point-of-entry proxies yes no

Stop Connect:Direct for Windows yes no

Invoke the refresh initialization parameters options yes yes

Use the trace tool or issue traceon and traceoff commands yes no

Override execution priority, including Hold, Retain, and
Plexclass status

all yes

User type can override the CRC status on off

Override Process options such as file attributes and remote
node ID

all yes

Define Directories Where Users Can Perform Tasks
You then define directories where a user can perform tasks. If you do not specify a directory for a
function, the user can perform it from any directory, regardless of whether the request is submitted
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from the PNODE or the SNODE; however, the remote user proxy can override the directory
specification. Directory restrictions for the Upload and Download directory can be bypassed if
restrictions are not also provided for the Process and Program directory paths. As a result, if the remote
user is allowed to use the Run Task and Run Job features to execute commands from any directory,
then they could perform operating system commands. These commands could include copy commands
to copy files to any directory, bypassing the Upload and Download restrictions.

To prevent this, set directory restrictions for the Process and program features using a separate directory
path from the Upload and Download directory path or disable the Run Job and Run Task for this user.
Programs that be run are defined in the Process and Program directories.

Define Remote User Proxies
You can define remote user proxies. A remote user proxy associates a remote user with a local user ID
and gives the remote user the authority to perform the same functions as the proxy. This is useful if
you want to give a remote user access to a server, but you do not want to define a user ID and user
authorities for the user. Defining a remote user proxy also provides the remote user access to the local
node without the need to remember password information.

Define User Authority

Use this procedure to restrict the functions that a user can perform and the directories where a function
can be performed.

To set user authorities:

1. Select Admin > Functional Authorities.

The User Authorities view is the default view.

2. Choose one of the following types of users:

• Click New Admin to create a new user authority with full privileges for Process controls
and functions.

• Click New Genusr to create a user authority with reduced privileges.

3. Type a name, from 1 to 50 alphanumeric characters, for the new user in the Name field. You can
use spaces.

Note: You can enter a user ID in UPN format such as user@csg.stercomm.com. The
UPN format allows you to identify both the user name and the domain.

4. Do one of the following:

• To save the new user authority with the default privileges, click OK.
• To modify the default user privileges, continue with the next step.

5. To restrict the control functions or statements a user is authorized to perform, change the value
of one or more of the fields on the Main tab to No to deny user authority for that privilege and
click OK.
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Field Name Definition Valid Values

Submit Grants access to the Process Monitor function.

Yes specifies that you can monitor your own Processes;
All specifies that you can monitor anyone’s Processes.

Yes | No

Monitor Grants access to the Process Monitor function.

Yes specifies that you can monitor your own Processes;
All specifies that you can monitor anyone’s Processes.

Yes | No | All

Change Grants authority to change Processes in the TCQ.

Yes specifies that you can change your own Processes;
All specifies that you can change anyone’s Processes.

Yes | No | All

Delete Grants authority to delete Processes from the TCQ.

Yes specifies that you can delete your own Processes;
All specifies that you can delete anyone’s Processes.

Yes | No | All

Statistics Grants authority to access Process statistics using the
Select Statistics command.

Yes specifies that you can access statistics for your own
Processes; All specifies that you can access statistics for
anyone’s Processes.

Yes | No | All

Copy Send Grants authority to submit copy Process statements. Yes | No

Copy Receive Grants authority to receive copy Process statements. Yes | No

Run Job Grants authority to submit run job Process statements. Yes | No

Run Task Grants authority to submit run task Process statements. Yes | No

Submit Grants authority to submit Processes from within another
Process.

Yes | No

6. To define directory restrictions, click the Directories tab.

7. To restrict a user’s access to directories, specify the directory from which the user can perform
a function, submit Processes, or run programs and click OK. Refer to the following table for the
Directory Restrictions functions:

Field Name Description

Upload Specifies the directory that the user can copy files from and use as a source.

Download Specifies the directory that the user can copy files to and use as a destination.

Process Specifies the directory from which the user can submit a Process.

Note: Setting a Process directory restriction here only restricts submit statements
within a Process. In other words, given an entry in this field, a user (or, in the
case of a group functional authority, a group) can use Requester to submit a
Process without restrictions on where the Process is submitted from, but a
Submit Process statement within the Process will run only from the directory
specified here.

Program Specifies the directory from which the user can run a program.

8. To define administrative privileges, click the Admin tab.

9. To give a user access to an administrative function, change the value to Yes and click OK. Refer
to the following table for Administrative functions:
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Field Name Definition Valid Values

Netmap Grants authority to update the network map. Yes | No

Translation Table Grants authority to update the translation tables. Yes | No

User Authorities Grants authority to update local user Connect:Direct
functional authorities.

Yes | No

User Proxy Grants authority to update user proxies. Yes | No

Stop Grants authority to stop Connect:Direct. Yes | No

Refresh Grants authority to refresh the Connect:Direct server
initialization parameters.

Yes | No

Trace Grants authority to access the Trace utility. Yes | No

10. Click the Override tab to define override authority.

11. To grant access to the override function, set any of the override privileges to Yes. Refer to the
following table for the override privilege functions:

Field Name Definition Valid Values

Execution Priority Grants authority to override the default execution priority in a
Process.

Yes | No | All

Remote Node ID Grants authority to use the remote node ID parameter on the
Process or when submitting the Process.

Yes | No

File Attributes Grants authority to override the system’s default file attributes when
creating files using a copy Process.

Yes | No

ACL Update Grants authority to define access–allowed and access–denied
entries in the Access Control List (ACL) for a file created using a
copy Process.

Yes | No

CRC Grants authority to override the CRC-enabled state in node and
Process statements.

ON | OFF | Blank

12. Click OK.

Modify a User Authority

To modify user authority information for Process statement and control functionality:

1. Select Admin > Functional Authorities.

2. Double-click the user authority to edit.

3. Change the user authorities as necessary.

4. Click OK.

Delete a User Authority

To delete a user authority:
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1. Select Admin > Functional Authorities.

2. Select the user you want to delete and click Delete.

Define a Group Authority

Use this procedure to create group authorities. Group authorities allow you to group users who exercise
the same level of functional authorities.

To define a group authority:

1. Select Admin > Functional Authorities.

2. Click the Group Authorities tab.

3. To add a group authority, do one of the following:

• Click New Admin to create a new group based on *Admin settings as the default.
• Click New Genusr to create a new group based on Genusr settings as the default.

4. Type the name, from 1 to 50 alphanumeric characters, for the new group. You can use spaces.

5. Define the group as either a local group or domain group by doing one of the following:

• If the group is local, click Local and enter the name of the group as defined by the
workstation administrator under My Computer/Manage/Local Users and Groups.

• If this is a domain group, click Domain Name, then enter the name of the group as defined
by the domain administrator, and the name of the domain on which the group is defined.

Note: Local groups are groups defined locally on the server using the O/S utility for
managing local users and groups. If your users are defined locally, use local groups.
If your users are not defined locally but in a domain, use domain groups. If you
have some users in local and some in domains, you can use both.

6. Do one of the following:

• To save the new group authority with default privileges, click OK.
• To modify the default group privileges, continue with the next step.

7. To restrict the control functions or statements users in the group are authorized to perform, change
the value of the fields on the available tab to No to deny authority for that privilege and click
OK.

Note: Refer to Define a User Authority for definitions of specific user authorities.

8. Click OK to finish defining the group authority.

Modify a Group Authority

To modify group authority information for Process statement and control functionality:
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1. Select Admin > Functional Authorities and click the Group Authorities tab.

2. Double-click the group authority to edit.

3. Change authorities for the group as necessary.

4. Click OK.

Sequence Group Authorities

A user can be a member of multiple groups, local and domain. Since each group authority defined can
contain different restrictions, the order of groups as they are checked for a match is important. More
restrictive groups should be checked before less restrictive groups.

To change a group's position in the order of group functional authorities:

1. On the Group Authorities tab of the Functional Authorities window, select the group functional
authority to move.

2. Move the group up in the order by clicking Move Up.

3. Move the group down in the order by clicking Move Down.

4. Click OK.

Delete a Group Authority

To delete a group authority:

1. Select Admin > Functional Authorities and click the Group Authorities tab.

2. Select the group you want to delete and click Delete.

Define Remote User Proxies
The secure point-of-entry proxies definition contains remote user information for operations initiated
from remote Connect:Direct nodes. It defines a proxy relationship between a user at a remote
Connect:Direct node and a local user ID. This relationship enables users at remote nodes to submit
work to their system that interacts with the Windows node without defining user IDs and passwords
for the specified Windows system in the Processes. Several proxies can use the same local user account
with overrides specific to each proxy.

Connect:Direct names each definition of this type according to the remote node and submitter ID. Each
definition contains the user ID and password for a local account to use when the specified remote user
submits Processes that interact with this node.

Note: When you update the password for the specified local user account on your Windows system,
you must update the corresponding Connect:Direct secure point-of-entry proxy as well. This
process is not automated.
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The user proxy definition specifies the following Connect:Direct remote user information:
• Remote Connect:Direct user ID and remote Connect:Direct node name. You can also set a

generic user ID called <ANY USER> and node name <ANY NODE> to allow all of your
remote users to connect through one proxy.

• Local user ID and password to use with submitted operations from the remote Connect:Direct
node.

• Any directory restrictions for Connect:Direct operations.

When a remote user submits a Connect:Direct Process that does not have a remote node security ID
specified, Connect:Direct for Windows accesses the proxy definition that corresponds to the specified
user and logs on to the Windows server using the account information specified in the proxy definition.
If a proxy definition is not available for a given remote node/submitter ID combination, the Process
must explicitly specify the user ID and password to use on the local node. Use the remote node ID
security parameter in the Process statement to provide the necessary security information to execute
Processes with this node.

Create or Modify a Remote User Proxy

To create a proxy for a remote user:

1. Select Admin > User Proxies.

2. Do one of the following:

• To add a new remote user proxy, click Insert.
• To modify a proxy, double-click the Remote User name to modify.

3. Add or modify the following information:
• For a new proxy, type the remote node user ID or select <ANY USER> to define a generic

user ID.
• Type the submitter ID, a specific node name, or select <ANY NODE> to define a generic

node.
• Type the local user ID to map to the remote node or a specific user ID in the Userid field.
• Type the password twice associated with the local user ID to which the proxy is mapped.

Note: You can enter a user ID in UPN format such as user@csg.stercomm.com.

4. If necessary, click the Directories tab to define the directory restrictions for the remote user.

5. Select whether the proxy user has permission to perform Copy Send or Copy Receive operations
or if the permissions for the proxy user are the same as for the real user (User).

6. Modify one or more of the following functions:

• Specify the directory the user can use to copy files from and use as a source directory in
the Upload field. If no directory is specified, the user can copy files from any directory.

• Specify the directory the user can use to copy files to and use a destination directory in
the Download field. If no directory is specified, the user can copy files to any directory.
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• Specify the directory containing the Processes the user has authority to submit in the
Process field. If no directory is specified, the user can submit Processes from any
directory.

• Specify the directory containing the programs the user has authority to run in the Program
field. If no directory is specified, the user can run programs from any directory.

• Specify whether the user can submit copy Process statements using the Copy Send field.
If you specify USER, this setting defaults to the proxy entry's local user's functional
authority setting.

• Specify whether the user can receive copy Process statements using the Copy Receive
field. If you specify USER, this setting defaults to the proxy entry's local user's functional
authority setting.

7. Click OK.

Delete a Remote User Proxy

Delete user proxy information for an existing remote Connect:Direct user.

1. Select Admin > User Proxies.

2. Select the remote user you want to delete.

3. Click Delete.

4. Click Close.
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Chapter 2

Define and Manage the Connect:Direct Network

Define and Manage the Connect:Direct Network
Connect:Direct uses a network map to identify the remote nodes that can communicate with the local
node. Two methods are available to update the network map:
• Connect:Direct Requester provides a graphical user interface to create network map entries.
• The Configuration Tool enables you to extract a Connect:Direct for Windows network map as

a text file from the Windows Registry. You can then update the network map and insert it into
the Registry to apply it.

About Defining the Network Map
You create a remote node entry in the network map for each remote node that the local node
communicates with. Each network map entry contains information about the remote node, such as the
remote node name, the operating system type, the communications mode, and the communications
path to use when connecting to the remote node. The communications mode and communications path
are separately defined information that can be associated with one or more remote nodes.

The remote node definition, the communications mode, and communications path definition are the
three components of each network map entry.

Note: The network map is not mandatory if the initialization parameter called netmap.check is set to
n and all remote nodes have TCP/IP paths that you identify by their IP address or host name.

Define Remote Node Information
You define a network map entry for each remote node that communicates with the local node. The
network map defines the following components:
• Remote node definition—Information about remote Connect:Direct nodes that the local node

communicates with, including retry parameters, maximum session connections, and network
information.

• Communications mode—Information relating to session characteristics for a protocol, such as
TCP/IP, APPC, or UDT mode information. A communications mode can be associated with
one or more communications paths or remote node definitions.
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• Communications path—Transport and protocol information about the available
communications paths and their attributes. The protocol information includes protocol type,
such as TCP/IP, and specific protocol type information, such as the name of the TCP mode for
TCP/IP protocols. The protocol information also includes the LU 6.2. protocol type and specific
protocol information, such as Net ID, PU Name, and LU name for LU 6.2 protocols. Each
communications path definition specifies a default communications mode.

Each remote node definition can be related optionally to one communications mode and can
be related to multiple communications paths, allowing multiple communications paths and
modes to be available for use when communicating with the named remote node. These
communications paths and modes can be shared with other remote nodes and are not specific
to one remote node definition. Communications paths are used when establishing sessions with
a remote Connect:Direct node. Connect:Direct tries each communications path named, in the
order in which it is listed, until either a session is established or all paths have been tried. You
must designate at least one path.

When defining, modifying, or deleting network map entries, be aware of the dependencies among the
three components and the manner in which they refer to each other. For example, before you name a
communications mode in your communications path definition, the communications mode must exist.

Create or Modify a Remote Node Definition

The remote node definitions contain information for remote Connect:Direct nodes that the local
Connect:Direct node communicates with.

To create or modify a remote node definition in the network map:

1. Select Admin > Netmap to open the network map.

2. Do one of the following:

• To add a node, select Netmap > Insert and type a node name in the Name field.
• To modify an existing node, double-click the node name in the Netmap window.

3. Define information in the following fields for the remote node you are configuring on the Main
tab. Refer to the following table for information on each field:

Field Name Description Valid Values

Name The name of the remote Connect:Direct node. If
you are modifying a node, this field cannot be
edited.

A 1- to 16-character alphanumeric
string

Operating System The operating system for the remote node. OpenVMS | OS/390 | OS/400 |
Tandem | UNIX | VM | VSE |
Windows

Max Pnode Sess The maximum concurrent connections for all
remote nodes when the local Connect:Direct
node originates the Process. This field is limited
to the lesser of the values defined in the
initialization parameters file and the network map
definition for a given node.

A numeric value from 0–255. The
default is 1. For a workstation version
of Connect:Direct for Windows, this
field is limited to 1.
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Field Name Description Valid Values

Max Snode Sess The maximum concurrent connections, where the
local Connect:Direct for Windows node is the
partner, or secondary, node cooperating with a
remote Connect:Direct node to execute a
Process. The maximum number of concurrent
sessions is limited to the lesser of the values
defined in the initialization parameters file and the
network map definition for a given node.

A numeric value from 0–255. The
default is 1. For a workstation version
of Connect:Direct for Windows,
maximum SNODE sessions are
limited to 2.

Default Class The default session class used to start session
managers. A Process executes on the specified
class or any higher session class. This value
overrides the equivalent value for this node in the
initialization parameters.

A numeric value from 1 to the value
of maximum concurrent local node
connections (sess.pnode.max). The
default value is 1. The value cannot
be greater than the maximum
number of local sessions with
primary control.

Short Term Retry
Attempts

The number of retry attempts if a short-term
connection failure occurs. Long-term retry
parameters are used after the number of short-
term attempts you specify has been reached.

A numeric value from 1–255. The
default is 10.

Short Term Retry
Interval

The amount of time to wait between each short-
term retry attempt.

A 24-hour time value formatted as
hh:mm:ss. The maximum value is
23:59:59. The default is 00:00:10 or
10 seconds.

Long Term Retry
Attempts

The number of retry attempts after all of the short-
term retry attempts are used.

A numeric value from 0–255. The
default is 0.

Long Term Retry
Interval

The amount of time to wait between each long-
term retry attempt.

A 24-hour time value formatted as
hh:mm:ss. The maximum value is
23:59:59. The default is 00:03:00, or
3 minutes.

4. To configure TCP/IP settings, click the TCP/IP tab and set the TCP/IP attributes. Refer to the
following table for definitions of the fields:

Field Name Description Valid Values

Host/IP Address The host name or IP address of the
remote node. Alias names are not
supported.

A numeric value in the format nnn.nnn.nnn.nnn
(IPv4) or
nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn
(IPv6) or the host name.

Port/Service The communications port number for
Connect:Direct if it differs from the
default value specified in the initialization
parameters.

A numeric value in the format nnnnn, where
nnnnn is a positive integer from 0–65535.

Mode Override Select the name of the network map
TCP/IP communications mode definition
record used when communicating with
this remote node. If this parameter is not
specified, its value defaults to the last
TCP/IP mode in the list.

Name of a defined TCP/IP communications
mode.
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Field Name Description Valid Values

Alt Comm Outbound The alternate communication address
(communication path) used for outbound
Processes. This parameter provides the
alternate addresses for a remote node
that has multiple NIC cards. When the
local node is the PNODE, the alternate
addresses are tried (starting with the first
IP address listed) if an initial attempt to
the primary address fails. After a
connection has been established, if the
connection is subsequently lost,
attempts to reestablish the connection
through the retry mechanism use the
same address as the initial connection.

When the local node is the SNODE, the
alternate addresses are used in the
Netmap check.
Note This parameter should not be

used in a outbound Process if
the SNODE is Connect:Direct/
Plex.

Fully qualified host name or IP address and port
number.

A comma separates the list of alternate
communication paths as shown in the following
example:

salmon;9400, 10.20.40.65;9500

The list is processed from the top down.

Alternate Comminfo Provides support for establishing
netmap-checked sessions with high-
availability (especially load balancing)
systems with multiple IP addresses,
such as Connect:Direct/Plex z/OS. Use
this parameter to list all IP addresses or
host names that are part of the multiple
IP address environment.

For Connect:Direct/Plex, this list should
include the address of each
Connect:Direct/Server with a different IP
address from the Connect:Direct/Plex
Manager.

If a remote node has more than one
outgoing IP address (as in a load
balancing environment), specify all of the
remote node’s possible outgoing
addresses in the Alternate Comminfo
field so that those outgoing IP addresses
are contained in the local node’s netmap
entry for that remote node. This
configuration allows netmap checking to
succeed when the remote node
connects to the local node using any of
the possible outgoing IP addresses
specified.

hostname1/IP address, hostname2/IP
address, hostname3/IP address

host name—Host name associated with the IP
address. For example:

hops (where hops is a machine on the local
domain)

hops.csg.stercomm.com (fully-qualified host
name)

nnn.nnn.nnn.nnn or
nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn
—IP address of a machine running
Connect:Direct

5. To configure UDT settings, click the UDT tab and set the UDT attributes. Refer to the following
table for definitions of the fields:

Field Name Description Valid Values

Host/IP Address The host name or IP address of the
remote node. Alias names are not
supported.

A numeric value in the format nnn.nnn.nnn.nnn
(IPv4) or
nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn
(IPv6) or the host name.
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Field Name Description Valid Values

Port/Service The communications port number for
Connect:Direct if it differs from the
default value specified in the initialization
parameters.

A numeric value in the format nnnnn, where
nnnnn is a positive integer from 0–65535.

Mode Override Select the name of the network map UDT
communications mode definition record
used when communicating with this
remote node. If this parameter is not
specified, its value defaults to the last
UDT mode in the list.

Name of a defined UDT communications mode.

Alt Comm Outbound The alternate communication address
(communication path) used for outbound
Processes. This parameter provides the
alternate addresses for a remote node
that has multiple NIC cards. When the
local node is the PNODE, the alternate
addresses are tried (starting with the first
IP address listed) if an initial attempt to
the primary address fails. After a
connection has been established, if the
connection is subsequently lost,
attempts to reestablish the connection
through the retry mechanism use the
same address as the initial connection.

When the local node is the SNODE, the
alternate addresses are used in the
Netmap check.
Note This parameter should not be

used in a outbound Process if
the SNODE is Connect:Direct/
Plex.

Fully qualified host name or IP address and port
number.

A comma separates the list of alternate
communication paths as shown in the following
example:

salmon;9400, 10.20.40.65;9500

The list is processed from the top down.
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Field Name Description Valid Values

Alternate Comminfo Provides support for establishing
netmap-checked sessions with high-
availability (especially load balancing)
systems with multiple IP addresses,
such as Connect:Direct/Plex z/OS. Use
this parameter to list all IP addresses or
host names that are part of the multiple
IP address environment.

For Connect:Direct/Plex, this list should
include the address of each
Connect:Direct/Server with a different IP
address from the Connect:Direct/Plex
Manager.

If a remote node has more than one
outgoing IP address (as in a load
balancing environment), specify all of the
remote node’s possible outgoing
addresses in the Alternate Comminfo
field so that those outgoing IP addresses
are contained in the local node’s netmap
entry for that remote node. This
configuration allows netmap checking to
succeed when the remote node
connects to the local node using any of
the possible outgoing IP addresses
specified.

hostname1/IP address, hostname2/IP
address, hostname3/IP address

host name—Host name associated with the IP
address. For example:

hops (where hops is a machine on the local
domain)

hops.csg.stercomm.com (fully-qualified host
name)

nnn.nnn.nnn.nnn or
nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn
—IP address of a machine running
Connect:Direct

6. To configure the APPC settings, click the APPC tab and set the APPC attributes. Refer to the
following table for a description of of the fields:

Field Name Description Valid Values

Network Name The name of the SNA network in which the remote
Connect:Direct node resides.

SNA network name

Partner LU The name of the partner node to be used as the
remote connection end point for the LU-to-LU
session. This is the VTAM APPLID for host
connections or partner LU name for LU 6.2 only.

A 1–8 character alphanumeric string

Mode Override The name of the network map APPC
communications mode definition record that is
used when communicating with this remote node.
If this parameter is not specified, its value defaults
to the last APPC mode in the list.

Name of a defined APPC
communications mode

7. To identify the communications path, click the Communication Paths tab.

8. Perform the following actions as required:

• To add a path defined in the network map, select a path name from the Available Paths
box and click the right arrow button.

• To view the properties of a path, select the path from the Available Paths box and click
Properties.

• To add a new path to the network map, click New.
• To delete a path, select the path in the Available Paths box and click Delete.
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• To select all available paths, click Add All.
• To remove a selected path, select the path in the Selected Paths box and click the left

arrow button.
• To remove all selected paths, click Remove All.

9. To add a description of the node, click the Description tab. Connect:Direct does not use this
information. Refer to the following table for a description of each field:

Field Name Description Valid Values

Name The name of the Connect:Direct administrator or
operator for the remote node.

A 1- to 49- character alphanumeric
string

Phone Number The phone number of the administrator or operator
for the remote node. Do not use blanks in this string.

A 1- to 39-character alphanumeric
string

Node Description Any additional information you want to include
specific to the remote node.

A 1- to 127-character alphanumeric
string

10. Click OK.

Add or Modify Communications Mode Settings

You can add or modify the settings for a communications mode object. These values override the values
in the initialization parameters file.

1. Select Admin > Netmap to open the network map.

2. Do one of the following

• To modify an existing mode definition, double-click the mode.
• To add a new mode definition, right-click in the mode box and click Insert.

3. Modify the mode settings as required. If you are defining a new object, select either TCP/IP or
APPC as the protocol to associate with the communications path. Refer to the following table
for the definitions, descriptions, and valid values for each field.

Field Name Description Valid Values

Name The name of the remote node and communications path
object types. If you are modifying settings for a remote
node, the Name field is not blank. You cannot change the
name.

A 1- to 48-character alphanumeric
string

Protocol The type of communications protocol. TCP/IP | APPC TCP/IP is the default
value.

4. To add or update TCP/IP settings, click the TCP/IP tab. Refer to the following table for a
description of each field:
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Field Name Description Valid Values

Buffersize The buffer size for transmitting data
to and from the remote
Connect:Direct node. This value
overrides the value in the
initialization parameters file.

A numeric value from 256–65536.

The default is 65535.

Pacing Send Count The number of send operations to
perform before automatically waiting
for a pacing response from the
remote Connect:Direct node. A value
of 0 indicates that there is no pacing.
This value overrides the value in the
initialization parameters file.

A numeric value from 0–63.

The default is 0.

Pacing Send Delay The amount of time Connect:Direct
waits before sending each outbound
data buffer to the remote node. This
can prevent flooding the network. A
value of 0 indicates that
Connect:Direct sends each data
buffer as soon as possible. This
value overrides the value in the
initialization parameters file.

An integer from 0–86400.

The default is 0.

CRC Specifies whether CRC checking is
turned on.

The default value for the local node
is OFF. The default value for the
remote node is blank.

The remote node defaults to blank to
simplify the use of the crc.override
parameter. When crc.override is
enabled in the initialization
parameter, only the nodes that
require a different configuration need
to be changed.

OFF | ON | blank

5. To add or update APPC settings, click the APPC tab and type the following values:
• A valid RU size between 256 and 4096 in the Max RU Size field. The default is 4096.
• The largest permissible pacing window size for sessions in this mode grouping in the Max

Pacing field. Connect:Direct sends this number of data buffers before waiting for an
acknowledgment from the remote node. A value of 0 indicates no pacing. The default is 7 and
the maximum is 63.

• The maximum sessions allowed in this mode group. The default is 8. Specify if you are using
dependent LUs as the communications path.

6. Click OK.

Create or Modify a Communications Path Definition

The communications path defines the physical communications path between the local Connect:Direct
node and one or more remote Connect:Direct nodes.
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If you install SNA software and select APPC support during installation, two communications path
objects are created in the Windows Registry: one for TCP/IP and one for APPC. If you do not have
APPC support, only a TCP/IP default communications path object is created.

1. Do one of the following:

• To modify a communications path definition, double-click the definition in the
CommPath window.

• To add a new communications path, right-click the CommPath box and click Insert.

2. To define a communications path, type the name of the communications path in the Name field,
and select the protocol to associate with it: TCP/IP, APPC, or UDT.

3. Define a new mode or assign an existing mode to the communications path.

4. To associate an existing mode with the communications path, select the mode from the Selected
Mode drop-down list.

5. To define a new mode to associate with the communications path:

• Click New.
• Type the name of the new mode in the Name field.
• Select the protocol to associate with the mode: TCP/IP, APPC, or UDT, and click OK.

6. To add or update TCP/IP settings, click the TCP/IP tab. Refer to the following table for the name,
definition, and valid values for each field.

Field Name Description Valid Values

Buffersize The buffer size for transmitting data to and from
the remote Connect:Direct node. This value
overrides the value in the initialization
parameters file.

A numeric value from 256–65536.

The default is 65535.

Pacing Send Count The number of send operations to perform
before automatically waiting for a pacing
response from the remote Connect:Direct node.
A value of 0 indicates that there is no pacing.
This value overrides the value in the
initialization parameters file.

A numeric value from 0–63.

The default is 0.

Pacing Send Delay The amount of time Connect:Direct waits before
sending each outbound data buffer to the
remote node. This can prevent flooding the
network. A value of 0 indicates that
Connect:Direct sends each data buffer as soon
as possible. This value overrides the value in
the initialization parameters file.

An integer from 0–86400.

The default is 0.

CRC Specifies whether CRC checking is turned on.

The default value for the local node is OFF. The
default value for the remote node is blank.

The remote node defaults to blank to simplify
the use of the crc.override parameter. When
crc.override is enabled in the initialization
parameter, only the nodes that require a
different configuration need to be changed.

OFF | ON | blank

Sterling Commerce, Inc.  29



Chapter 2 Define and Manage the Connect:Direct Network

7. To add or update APPC settings, click the APPC tab. The following table shows the name,
definition, and valid values for each field on the APPC tab.

Field Name Description Valid Values

Adapter Number Indicates whether the token ring adapter number to
be used for this connection is Primary or Alternate.

Primary | Alternate

Adapter Address The token ring address of the remote node. This
address consists of hexadecimal digits. Enter all
zeroes if the local node is the same as the remote
node.

Valid remote node token ring
address

Local SNA Network The SNA network name of the local Connect:Direct
node. This name must match the name of the SNA
network in which the local Connect:Direct node
resides.

Valid SNA network name

LU Name The name of a Local APPC LU configured within
Microsoft SNA Server. This parameter is required.

Valid LU alias name

8. To add or update UDT settings, click the UDT tab. The following table shows the name,
definition, and valid values for each field on the UDT tab.

Field Name Description Valid Values

Buffersize The buffer size for transmitting data to and from the
remote Connect:Direct node. This value overrides
the value in the initialization parameters file.

A numeric value in the range
256-65536.

UDT33 CRC Specifies whether CRC checking is turned on.

The default value for the local node is OFF. The
default value for the remote node is blank.

The remote node defaults to blank to simplify the
use of the crc.override parameter. When
crc.override is enabled in the initialization
parameter, only the nodes that require a different
configuration need to be changed.

OFF | ON | blank

9. Click OK.

Define a New Mode for a Communications Path

To define a new mode for a communications path:

1. Select Admin > Netmap to open the network map.

2. Right-click the CommPath box and click Insert.

3. Type the name of the communications path in the Name field.

4. Click New.

5. Type the name of the new mode in the Name field.

6. Select TCP/IP, APPC, or UDT to identify the protocol to associate with the mode.
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7. To add TCP/IP settings, click the TCP/IP tab. Refer to the following table for the name, definition,
and valid values for each field.

Field Name Description Valid Values

Buffersize The buffer size for transmitting data to and from the
remote Connect:Direct node. This value overrides the
value in the initialization parameters file.

A numeric value from 256–65536.

The default is 65535.

Pacing Send Count The number of send operations to perform before
automatically waiting for a pacing response from the
remote Connect:Direct node. A value of 0 indicates
that there is no pacing. This value overrides the value
in the initialization parameters file.

A numeric value from 0–63.

The default is 0.

Pacing Send Delay The amount of time Connect:Direct waits before
sending each outbound data buffer to the remote
node. This can prevent flooding the network. A value
of 0 indicates that Connect:Direct sends each data
buffer as soon as possible. This value overrides the
value in the initialization parameters file.

An integer from 0–86400.

The default is 0.

CRC Specifies whether CRC checking is turned on.

The default value for the local node is OFF. The
default value for the remote node is blank.

The remote node defaults to blank to simplify the use
of the crc.override parameter. When crc.override is
enabled in the initialization parameter, only the nodes
that require a different configuration need to be
changed.

OFF | ON | blank

8. To add UDT settings, click the UDT tab. Refer to the following table for the name, definition,
and valid values for each field.

Field Name Description Valid Values

Buffersize The buffer size for transmitting data to and from the
remote Connect:Direct node. This value overrides the
value in the initialization parameters file.

A numeric value from 256–65536.

The default is 65535.

UDT33 CRC Specifies whether UDT33 CRC checking is turned on.

The default value for the local node is OFF. The
default value for the remote node is blank.

The remote node defaults to blank to simplify the use
of the crc.override parameter. When crc.override is
enabled in the initialization parameter, only the nodes
that require a different configuration need to be
changed.

OFF | ON | blank

9. Click OK twice to close Mode Properties and Path Properties.

Delete a Network Map Entry

To delete a network map entry:

1. Select Admin > Netmap.
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2. Right-click the network map entry you want to delete and click Delete.

3. Click Yes to delete the entry. You are returned to the Netmap for Nodename dialog box, and the
entry is listed with a red bar to the left of it.

4. Right-click the dialog box and click Apply.

Validate a Network Map Entry

After you create a network map entry, you can validate the entry to ensure it was created correctly. For
example, if you typed an invalid entry in a field, or accidentally deleted a communications path, the
validation function generates an error message and explains why you received it.

To validate a network map entry:

1. Select Admin > Netmap.

2. Select the network map entry to validate.

3. Right-click the Netmap for Nodename window and click Validate.

4. After you validate the network map entry, close the Netmap for Nodename window.

View a Network Map as Text

To view a network map entry as text:

1. Select Admin > Netmap.

2. Select the network map entry you want to view as text.

3. Right-click the Netmap for Nodename window to open the shortcut menu and click Text View.

4. Right-click the window again and select List View to view the network map entry in its original
presentation.

Apply a Network Map

To apply a network map file to the node:

1. Select Admin > Netmap > Validate. If no errors are found, the output window contains the
message Netmap validation Successful.

2. Select Netmap > Apply.

3. Select the node name and click OK.
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Print and View Node and Network Map Definitions

After you set up a node and define a network map, use the Configuration Tool to extract the network
map and user authorization information from the Registry as plain text files. You can then update the
parameters in the extracted files for distribution to the nodes in an environment.

After you customize the files with site-specific parameters, you can insert them into the Windows
Registry where they are applied while the server is running, or you can apply them during a new
Connect:Direct installation.

1. Click Start and point to Programs > Sterling Commerce Connect:Direct v4.5.00 > CD
Configuration Tool.

2. Select File > Extract.

3. Click OK. The network map and User Authorization information for the node are extracted as
cascading windows named Map and User.

4. To save the extracted user authorization information:
• Click the User dialog box.
• Select File > Save As.
• Select the directory where you want to save the file.
• If necessary, type a different file name in the File name field and click Save.

5. To save the extracted network map information:
• Click the Map dialog box.
• Select File > Save As.
• Select the directory where you want to save the file.
• If necessary, type a different file name in the File name field and click Save.

View the Sample Configuration Files
To update configuration information, you can use the sample configuration files as a template. These
text files contain the valid keywords for a network map and user authorizations. You can customize
these files to configure nodes in an enterprise.

Note: To automate the installation of Connect:Direct for Windows, you can perform a silent
installation that requires no user interaction and that applies the User.cfg and Map.cfg
files during the installation.

Note: See the Connect:Direct for Windows Getting Started Guide for more information on
silent installations.

Two sample configuration files are included with the Configuration Tool:
• Map.cfg file—Network map objects are created in the Registry during installation. These

objects contain the remote node, communications path, and communications mode definitions.
You can update the network map on your nodes by customizing the sample Map.cfg file and
inserting it into the Windows Registry.
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• User.cfg file—Use the parameters in User.cfg to build user functional authorities and user
proxies. Connect:Direct applies the information in this file to authorize local and remote users
to issue commands and Process statements and to perform tasks. Use the Configuration Tool
to create authorizations for each user, including encrypted passwords for user proxies. After
you have created the user authorizations, you can insert the User.cfg file into the Windows
Registry.

Customize Configuration Files

You use the Configuration Utility to customize configuration files for your environment and prepare
them for rollout. You can edit configuration information using this tool. You can also use it to add
encrypted passwords to user proxies and validate the configuration files for use with Connect:Direct.

1. Select File > Open.

2. Select the drive and directory where the configuration file is located.

3. Select the file and click Open.

Note: To save the original file as a template for building future configuration files, save
the file with a different name before you alter any of the configuration information.

4. Edit the parameters as necessary.

5. Select File > Save.

Add An Encrypted Password for a User Proxy

You can set up and enable user proxies on the local Connect:Direct server that allow remote users to
log on to the local server without revealing their password. User proxies improve security on the remote
node by protecting remote users’ passwords.

The Configuration Utility can be used to insert encrypted passwords into the proxy section of the
USER.CFG file. When you enter a password, the Configuration Utility encrypts it for you.

To add a local user ID and encrypted password:

1. Open the User.cfg file.

2. Place the cursor on the line following the Proxy section header.

3. Select Tools > Password.

4. Type the user ID and password in the Userid and Password fields.

5. Retype the password in the Verify Password field.

6. Click OK. The encrypted password is inserted as the LocalPassword parameter value and the
User ID is inserted as the LocalUserid parameter.
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Validate Configuration Files for Use with Connect:Direct

After you have customized a file, validate the configuration to ensure that the file can be used with
Connect:Direct. When you validate a file, error messages describe any errors and each error is
highlighted so you can easily determine which information must be revised.

To validate a configuration file:

1. Open the configuration file to validate.

2. Select Tools > Validate. The file is validated.

• If no errors are detected, a message indicating this is displayed. Click OK to return to the
file.

• If errors are detected, an error message is displayed with the error identifier and an
explanation of the problem. The error is highlighted in the configuration file. Click OK
to close the error message.

3. Edit the configuration information to clear each error.

4. Repeat this procedure until no errors are returned.

Note: When you save a configuration file, the Configuration Utility automatically
validates it. You cannot save a file if it contains invalid information.

Apply Updated Configuration Information

You can update the network map and user authorizations by inserting the updated configuration files
in the Windows Registry. After the configuration files are inserted, the settings are applied when the
server is running.

Restriction: You cannot use cdconfig to change existing objects in the network map and user
authorizations. It can only be used to create new objects (netmap entry or user auth name).

To update configuration information, do one of the following:
• To insert the updated network map file into the Windows Registry, type the following command

at the command prompt, in the directory where Connect:Direct for Windows is installed:
cdconfig /q /nnodename /i /fmap.cfg

When inserting a file, the Configuration Utility uses the following switches:
• To extract a user configuration (user.cfg) file from a specified node, use the /u switch as shown

in the following sample:
cdconfig /nLinji3300 /u /fTestUser.cfg

• To extract the network map configuration file (map.cfg) from a specified node, use the /m
switch as shown in the following sample:
cdconfig /nLinji3300 /m /fTestMap.cfg
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Stop Connect:Direct for Windows
You can stop the Connect:Direct for Windows server in the following ways:
• Issue the Stop command from Connect:Direct Requester or the command line interface (CLI).
• Use the Services facility on the Windows Control Panel.
• Use the Admin Tool utility.

Stop Connect:Direct for Windows from Requester

To stop Connect:Direct for Windows from Requester:

1. Select Admin > Netmap to open the node you want to stop.

2. Select Admin > Stop Node.

3. Select one of the stop server options:

• Terminate processes at end of step—Stops Connect:Direct when all executing Process
steps are complete. Writes statistics records, closes files, and shuts down Connect:Direct.

• Quiesce after active processes complete—Stops the server when all executing Processes
are complete. No new Processes are started.

• Immediate orderly shutdown—Stops all activity, terminates Processes and connections,
writes statistic records, closes files, and shuts down Connect:Direct.

• Force termination now—Forcibly terminates Connect:Direct. No attempt is made to
terminate executing Processes or to write statistic records. All server resources are
released. This is the least desirable way to stop the server.

4. Click OK to stop the node. If the server is stopped, the icon in the Control Pad nodes view is
unavailable.

Stop Connect:Direct Using the Services Facility
To stop Connect:Direct for Windows from the Windows Services facility:
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1. Click Start > Settings > Control Panel >Administrative Tools > Services.

2. Select the Connect:Direct node you want to stop.

3. Click Stop. The display changes to indicate that Connect:Direct has stopped.

Note: Connect:Direct for Windows does not implement the Pause and Continue
functions on the Services applet.

Stop Connect:Direct Using the CLI

To stop Connect:Direct for Windows from the Connect:Direct for Windows CLI, issue the stop
command.

Stop Connect:Direct from the Admin Tool Utility

To stop Connect:Direct for Windows from the Admin Tool Utility:

1. Select the Connect:Direct for Windows server to stop.

2. Click the red traffic light icon on the toolbar.
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About Processes
A Process is a set of statements grouped together to perform a series of Connect:Direct tasks. You
define the tasks to perform and save the Process to a file. Finally, you use the Submit Process command
to execute all the tasks defined in the Process.

Processes allow you to automate routine tasks, execute multiple tasks with one command, save the
Process to a file for future use, and build blocks of work based on conditions. Before you build a
Process, decide what tasks you want to perform and what nodes you want to use.

Building a Process requires the following tasks:
• Creating a Process statement
• Building the group of tasks that perform the work by adding commands
• Setting command options
• Validating Process content
• Saving the Process file

Before creating a Process, you can establish preferences related to Processes and other Connect:Direct
Requester operations.

Establish Preferences

Throughout your session with Connect:Direct Requester, certain predefined preferences are in effect.
Connect:Direct establishes default user preferences during installation. You can modify preferences
at any time to more accurately reflect how you work. Preferences save you time, since preferences are
used for all instances, except when you override the values.

To establish preferences:

1. From the Connect:Direct Requester Main Window, select Tools > Options.

2. To set general preferences, change the values in the fields on the General tab of the Options panel.

Field Description

Reload last saved workspace at startup When selected, Connect:Direct Requester displays the last saved
workspace when you log in.
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Field Description

Track Processes in the execution status
window

To obtain summary information about a Process and display the
information in the Execution Status Window. This option establishes the
default for the Submit Process page.

Enable in-place editing To directly change the label field on the Program Definition Editor (PDE)
and eliminate the need to edit the labels through the Process Properties
page.

Activity log Use the options in this window to display the activity log in the Output
window, save the activity log to a file, append data to the log file, or
create a new log file every time you start Connect:Direct.

Check Enable the activity log in the Output window to display the activity
log there.

Check Write the activity output to a file and type the name of the file to
write the activity log to a file. Select the appropriate button to create a
new file every time you start Connect:Direct Requester or to append
activity to the existing log file at startup.

3. To set Process preferences, click the Process Defaults tab and change the values.

Field Description Valid Values

Hold To hold Processes in the Hold queue in HI (Held
Initially) status until explicitly released. A Process
submitted with Hold set to Yes is placed in the Hold
queue even if you specify a Start Time.

No—Execute a Process as soon as
resources are available.

Yes—Hold a Process.

Call—Hold a Process until the remote
node connects to the local node. At that
time, the Process is released for
execution.

Retain Processes are retained in the Hold queue in HR
(Held for Retain) status after execution. You can
release the Process for execution later through the
Process Monitor function or explicitly delete it.

No—Do not retain Processes after
execution.

Yes—Retain Processes after execution.

Initial—Retain Processes in the Hold
queue in HR status for automatic
execution every time the Process
Manager initializes. Do not provide a start
time parameter when you choose this
option.

Plexclass The class that directs the Process to only certain
servers in a Connect:Direct/Plex. This parameter
is only used in a Connect:Direct/Plex.

Name of the class.

CRC Specifies whether CRC checking is turned on.

The default value for the local node is OFF. The
default value for the remote node is blank.

The remote node defaults to blank to simplify the
use of the crc.override parameter. When
crc.override is enabled in the initialization
parameter, only the nodes that require a different
configuration need to be changed.

OFF | ON | blank

OFF—Do not perform CRC checking.

ON—Perform CRC checking.

blank—Use the value defined in
crc.override.
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Field Description Valid Values

Priority The preferred priority of a Process in the TCQ.
Connect:Direct uses the priority parameter for
Process selection. A Process with a higher priority
is selected for execution before a Process with a
lower priority.

The valid range is 1–15, where 15 is the
highest priority.

Class The preferred session class on which a Process
can execute. A Process can execute in the class
specified or any higher session class.

Values range from 1 to the maximum
number of local node sessions in the
network map definition.

Notify Userid The computer name of the user to receive Process
completion messages.

A valid computer name.

Accounting Data An arbitrary string used as the preferred
accounting information for the PNODE or the
SNODE or both nodes.

The maximum length of the string is 256
characters.

4. To set Work List preferences, click the Work List tab and change the values.

Field Description Valid Values

Track worklist is the worklist status
window

Determine if Work List statuses are
reported in the status window.

On or Off

Max Delay for Serial Execution Identifies the maximum amount of
time to wait. This parameter is useful
when the Process is submitted by a
batch file and you want to suspend
further execution of the batch file until
the submitted Process completes.

Unlimited—The command processor
waits until the Process completes
execution.

Time and hh:mm:ss—Select this
option and type the time to wait for a
Process to complete.

5. To set directory preferences, click the Directories tab and change the values.

Field Description

Processes To define the default directory for Process files

Work Lists To define the default directory for Work Lists.

Process Monitors To define the default directory for Process Monitor files.

Statistics Monitors To define the default directory for Statistics Monitors.

Start "Save as" in these directories Select this check box to make these directories the default when saving.

6. To set file type preferences, click the File Types tab and select the file extensions to associate
with Connect:Direct.

File Extension Description

.cdp Process Definitions

.cdw Work Lists

.cds Statistics Monitors

.cdm Process Monitors

.cdn Network Map

7. To set statistics preferences, click Select Stat Defaults and change the values.
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Field Description Valid Values

Monitor Determine if all statistics are monitored or only selected
statistics, based on criteria or for Step and Process
completion only. If you choose All, indicate the time range
for the selection.

All Statistics For Last _ hrs:min

Filter Using Selection Criteria Pages

Step and Process Completion
Statistics Only

Refresh Display Identify whether you want the Statistics Monitor display
to be refreshed. Specify the interval in minutes between
refreshes if you choose the Refresh every _ minutes.

Refresh every _ minutes

Refresh on open

Autoscroll—Display the latest
statistics

8. To set Process Monitor preferences, click Select Proc Defaults and change the values.

Field Description Valid Values

Monitor Determine if all Processes will be
monitored or only selected
Processes, based on selection
criteria.

All Processes

Filter Using Selection Criteria Page

Refresh Display Identify whether you want the
Process Monitor display to be
refreshed. Specify the interval in
seconds between refreshes if you
choose Refresh every _ seconds.

Refresh every _ seconds

Refresh on open

9. Click OK.

Create a Process

A Process begins with a Process statement that defines general information about the Process. When
you create a Process, the PEND statement is added to the end of the Process and is a required statement
that marks the end of a Process. Do not edit or delete the PEND statement.

1. Select File > New > Process.

2. Type a Process name, from 1 to 8 alphanumeric characters, in the Process Name field.

3. If all work will be performed on the PNODE, type or select the name of the PNODE in the
PNODE Name field.

4. To issue a warning message if an attempt is made to submit the Process on a different PNODE,
click Warn if submitted to a different node.

5. To issue a warning message if an attempt is made to submit the Process on a PNODE with a
different operating system, click Warn if submitted to a different operating system.

6. Specify the SNODE in one of the following ways:

• Select the node from the drop-down menu.
• Type the name of a Connect:Direct node.
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• Specify an IP address and port, using the following format:
hostname|IPaddress;portnumber|servicename

7. Click OK.

8. Add commands as necessary to the Process.

9. If desired, change the options for the Process.

Commands and Statements
You can add commands and conditional statements to a Process statement to perform various functions.
When you add a command to a Process, you use the preferences you defined or you set unique values
for each command.

The following table lists the commands you can insert in a Process.

Command Description

Copy The Copy statement transfers data between two nodes. The Copy statement identifies the
source files, applies any pre-transfer attributes such as compression or checkpointing,
transfers the file to the destination, and saves the file to the new file name.

Run Task You can run programs and commands by adding the Run Task command to a Process. The
Run Task command executes programs on the PNODE or the SNODE.

Run Job The Run Job command executes batch jobs or commands on the specified node. Jobs
submitted using the Run Job command run in the background. The return code associated
with the run job statement indicates the success of the Run Job command and not the success
of the batch job or command.

Use the Run Job command to perform the following types of tasks:

• Submit jobs in an z/OS environment to the internal reader, a facility that transfers jobs
to the job entry subsystem (JES).

• Submit a job at the OpenVMS node in an OpenVMS environment.

• Submit an OS/400 CL command to run as a separate job through the SBMJOB
command.

• Invoke a UNIX command shell and execute UNIX commands.

• Submit jobs through the VSE virtual reader, a facility that transfers jobs to VSE/
POWER.

• Start programs in the Windows environment.

Submit Process Submits a Process from within an executing Process on the PNODE or the SNODE. To use
the Submit statement, the Process must reside on the node you are submitting the Process
to. Use the Submit statement to execute a Process on the SNODE which would, in turn, submit
a Process to a third node.

You can use the following conditional statements to perform tasks based on conditions you establish.

Statement Description

If The If statement executes a block of statements based on the results of a previous statement.
The results are categorized by a return code. The If statement checks the value of the return
code and executes the block if the statement is true.

You must use the Eif statement (endif) with the If statement. If the conditions of the If statement
are not satisfied, use an Else statement to designate the execution of alternate instructions.
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Statement Description

Else The Else statement defines a block of statements that execute when the If statement is not true.
The Else statement is only valid when used in combination with the If statement.

Endif (Eif) The Endif statement (Eif) marks the end of the If statement and any statements based on the If
condition. The Endif statement is only valid when used in combination with the If statement.

Goto The Goto statement executes a jump to a specific statement that occurs later in a Process. This
statement cannot be used to loop to a statement earlier in the Process. Use the Goto statement
with the step label to define the location of the statement in the Process.

Exit The Exit statement bypasses all remaining steps in a Process and ends the Process.

Add a Copy Statement to a Process

Use the Copy statement to create a new file or append data to an existing file. To use the Copy statement
in a Process, identify the PNODE and the SNODE. Identify the source file and, if symbolic variables
are used, assign values to the variables or specify built-in variables before the Process is submitted.

Connect:Direct for Windows supports the string (*) and character (?) wildcards, allowing you to copy
multiple files from a source directory to a target directory with a single copy statement.

Note: The list of files to be copied is generated at the start of a wildcard copy. When a Process
restarts, in a wildcard copy statement, the step restarts with the first file that is not
completely copied. If you are using checkpointing, the statement restarts at the last
checkpoint of the file that is not completely copied.

1. Open a Process file.

2. Select Process > Insert > Copy.

3. To identify the step within the Process, type a label of up to 8 alphanumeric characters in Copy
Statement Label.

4. Select one of the following actions:

• To copy a file to the SNODE, select Send.
• To copy a file from the SNODE, select Receive.

5. Type the name of the source file in the Source Filename field.

6. Enter the name of the file in the Destination Filename field.

7. Select one of the following destination disposition options:

• NEW—To create a new file at the destination
• RPL—To replace the information in an existing file if it exists or to create a new file if

the file does not already exist.
• MOD—To append the transferred information to an existing file.

8. To enter compression and checkpoint restart options, click the Transfer tab and select from the
following options:
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• To use compression, select one of the following compression types in the Compression
window:

Compression Option Description Valid Values

None Turn on this option if you do not want
compression.

None

Primary Char Turn on this option to compress
repetitive characters. Specify the
primary character to compress. If the
character is repeated 2–63 times, the
characters are compressed to one
byte. If other characters are repeated
3–63 times in succession, the
characters are compressed to two
bytes.

The hex or character to compare

Extended Turn on this option to compress
repetitive strings. Extended
compression produces the best
compression results. Specify this type
of compression when lines are limited
and data is repetitive.

The Window value identifies the
compression for windows. The greater
the window size, the greater the
degree of compression. A window size
of 8 uses 1K of memory while a window
size of 15 uses 128K of memory.

Memory identifies how much virtual
memory is allocated to maintain the
internal compression state.

Comp Level—Select the level of
compression from 1–9.

Window—Select the window size
level from 9–15. The Default is 13.

Memory—Select a memory
compression from 1–9. The Default is
4.

• To use checkpoint restart, select one of the following options:
• Default—To use checkpoint restart options defined in the default Process.
• None—To turn off checkpoint restart.
• Check—To eliminate the need to retransmit an entire file in the event of a

transmission failure. If a copy procedure is interrupted, Connect:Direct restarts
that copy at the last checkpoint. If you turn on this option, type the interval at
which to mark a checkpoint restart and turn on either Kilobytes or Megabytes to
indicate the measurement to use.

9. To override the preferences or provide additional parameters to describe the sending and
receiving files, select one of the following:

• To define options for the sending file, click the From <Operating system> tab, and type
the sysopts parameters. Refer to the online help for more information.

• To define options for the receiving file, click the To <Operating system> tab, and type
the sysopts parameters. Refer to the online help for more information.

Note: These tabs reflect the operating system of the sending and receiving file location.

10. Click the Comment tab and add an optional description of the statement.

11. Click OK.
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Add a Submit Statement

Use the Submit statement to execute tasks defined in the Process.

To add a Submit statement:

1. Open a Process file.

2. Select Process > Insert > Submit.

3. Select the name of the node where the Process file is located in the Location field. You can submit
from the default node or select another node.

4. In the Filename field, type the full path and Process file name. If you are submitting a Process
on a Windows node, you can click the browse button to locate the Process file.

5. To override the Process name, type a 1- to 8-character alphanumeric string in the New Name
field.

6. If you want the Process to execute with a different SNODE, enter or select the SNODE in the
SNODE field. The SNODE you define here overrides the SNODE defined in the Process file.

7. Select Track Execution in Output Window to view activity during execution.

8. Continue defining the command.

Add a Run Task Statement

You can run programs and commands by adding the Run Task statement to a Process. The Run Task
statement executes programs on the PNODE or the SNODE.

To add a Run Task statement:

1. Open a Process file.

2. Select Process > Insert > Run Task.

3. To identify the step within the Process, type a label of up to 8 alphanumeric characters in Run
Task Statement Label.

4. Select the node where the program or command will execute in the Submit To field.

5. Type one of the following, based on the node type, in the Program field:

• Type Windows for a Windows node.
• Type UNIX for a UNIX node.
• For OS/400, type cmd(CL command) [parameter for OS/400 SBMJOB command] .
• For z/OS, type the name of the program to be attached as a subtask in uppercase letters.
• For HP NonStop, type the name of the object file.
• For VSE, type the name of the program to be attached as a subtask in uppercase letters.
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6. Use the Optional Parameters or Commands as necessary, for the operating system you selected
in Step 5. Refer to the Help for syntax.

7. Click the Comment tab and add a description of the command. This information is optional.

8. Click OK.

Add a Run Job Command

The Run Job command executes batch jobs or commands on the specified node.

Jobs submitted using the Run Job command run in the background. The return code associated with
the run job statement indicates the success of the Run Job command and not the success of the batch
job or command.

Restriction: You cannot execute Tandem commands using Run Job.

1. Open a Process statement.

2. Select Process > Insert > Run Job.

3. Type the statement label in the Run Job Statement Label field.

4. Select the node where the job will execute.

5. Type the Filename based on the operating system used by the node. This field is valid only for
the following operating systems:

• For Windows nodes, type Windows.
• For z/OS nodes, type the data set that contains the job in the format: DATASETNAME

| DATASETNAME(MEMBER). The data set and member must be in uppercase. If the
data set is a PDS, specify the member. The data set containing the job must exist on the
z/OS node where the job will execute. A data set containing JCL is limited to a record
length of 80 bytes.

• For i5 Series nodes, type i5 Series.
• For VSE nodes, type the name of the member in the LIBDEF source chain that contains

the job to be submitted in the format: | membertype(member). If the membertype is not
specified, this job must be cataloged with a membertype of J.

• For UNIX, type dummy.
• For OpenVMS, type PGM=VMS.

6. Type any Optional Parameters or Commands.

7. Click OK.

Add an If Statement
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The If statement executes a block of statements based on the results of a previous statement. The results
are categorized by a return code. The If statement checks the value of the return code and executes the
block if the statement is true.

You must use the Eif statement (endif) with the If statement. If the conditions of the If statement are
not satisfied, use an Else statement to designate the execution of alternate instructions.

1. Select Process > Insert > If.

2. Enter the statement label in the If Statement Label field.

3. Select a step label on which to base the operator and value.

4. Select the type of comparison statement in the Operator field.

5. Select one of the following return codes in the Value field:

Return Code Description

0 Indicates successful completion of the stop.

4 Indicates a warning.

8 Indicates an error condition.

16 Indicates a catastrophic error.

6. To add optional comments, click the Comments control tab.

7. Click OK to save the statement. The If statement is displayed in the Process window.

8. Create the block of statements that executes based on the If statement. You can add an Else
statement to execute a block of statements if the condition in the If statement is not satisfied.

9. Add an Eif statement to the end of the block to designate the end of the block of statements.

Add an Else Statement

The Else statement defines a block of statements that execute when the If statement is not true. The
Else statement is only valid when used in combination with the If statement.

To add an Else statement:

1. Select Process > Insert > Else.

2. Optionally, add a comment to the Process.

3. Click OK to save. The Else statement is displayed in the Process window.

Add an Endif Statement

The Endif statement (Eif) marks the end of the If statement and any statements based on the If condition.
The Endif statement is only valid when used in combination with the If statement.
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To use the Endif statement:

1. Select Process > Insert > End If.

2. Optionally, type a comment for the Process.

3. Click OK to save. The Endif statement is displayed in the Process window.

Add or Modify a Goto Statement

The Goto statement executes a jump to a specific statement that occurs later in a Process. This statement
cannot be used to loop to a statement earlier in the Process. Use the Goto statement with the step label
to define the location of the statement in the Process.

To add or modify a Goto statement:

1. Take one of the following actions:

• To create a new Goto statement, select Process > Insert > Goto and enter the statement
label in the Target Label field.

• To modify an existing statement, double-click the Goto statement in the Process window.

2. To add or modify optional comments, click the Comments tab and type the comment.

3. Click OK to save the Process. The Goto statement is displayed in the Process window.

Add an Exit Statement

To add an Exit statement to a Process:

1. Select Process > Insert > Exit.

2. Optionally, click the Comments tab and add a comment to the Process.

3. Click OK to save the Process and exit the Exit Statement dialog box. The Exit statement is
displayed in the Process window.

Process or Command Options
After you create a statement, you set Process options, including when the Process is submitted, how
the Process is handled in the TCQ, if a user is notified when a task is complete, who has access to the
Process, and any defining comments associated with it.

You can use one or more of the following options in a Process or command:
• Control functions identify how tasks are managed and how resources are allocated by defining

default options once. Then these values are used as the default values for each new command
or Process you define.

• Security options identify user IDs and passwords needed to access the SNODE and the PNODE.
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• Variable values assign values to all symbolic variables before execution. The values are then
substituted during execution whenever the symbolic variable is encountered.

• Accounting data as a free-form, user-defined field sets up accounting and tracking information
about Process execution and data transfers. You can track data transfers by cost centers,
department numbers, satellite locations, or any other type of code or identification that would
benefit the management of data tracking.

• Comments about the statement explain the context of the statement. When you view a Process
in text format, the comments appear before the associated statement.

Set Security Options

Use the Security options to specify the user IDs and passwords needed to access the PNODE and the
SNODE.

To set security options in the Requester:

1. Double-click the Process to open it and click the Security tab.

2. To set security for the PNODE, do the following:
• Type the PNODE user ID in the PNODE Userid fields.
• Type the PNODE password in the Password field.

3. To set security for the SNODE, do the following:
• Type the SNODE user ID in the Snode Userid field.
• Type the SNODE password in the Snode Password fields.
• To change the password for the user ID on the SNODE, type the new password in the New

Password field.
• Type the new password a second time in the Verify New Password field to validate the change.

4. Click OK to close the dialog box or click one of the other tabs to continue modifying Process
options.

Set Control Functions for a Command or Process

When you run a command or submit a Process, you can set many control functions to use as the default
values for each new command or Process you define.

To set control functions for a Process from the Requester:

1. Double-click the Process to open it and click the Control tab.

2. To specify a run date, select one of the following start dates:

• Today—If you want the program to run today.
• Date—To specify a date to run the Process. Click the selection arrow and click a date on

the calendar to specify the date.
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• Day—If want to run the Process on a certain day; then select a day of the week from the
drop-down box.

3. To specify the time to run the task, select one of the following:

• Immediate—To run the Process immediately. This option is only available if you selected
Today or Date in the Start Date field.

• Time—To run the Process at a specific time on the start date you selected. Type a time
to start the Process in the format hh:mm:ss.

4. To place the Process in the Hold queue, select one of the following options in the Hold field:

• Yes—To hold the Process in the queue in Held Initially status (HI) until explicitly
released.

• No—If you do not want to place the Process in the Hold queue. Process executes as
resources are available.

• Call—To hold the Process until a connection is established between the PNODE and the
SNODE. The Process executes if another Process establishes connection between the
nodes.

5. To place the Process in the Retain queue, select one of the following options in the Retain field:

• Yes—To retain the Process in the Hold queue in Hold Retain status (HR) after execution.
You can release the Process later from the Process Monitor.

• No—If you do not want to retain the Process after execution.
• Initial—To retain the Process in the Hold queue in HR status for automatic execution

every time the Process Manager initializes. Do not specify a start time with this option.

Note: If you select Yes for RETAIN and you specify a start time, HOLD status takes
precedence. If you set HOLD to No or Call, and set RETAIN to Yes, HOLD is
ignored.

6. If you are sending Processes to a location that supports CD Plexclass, type the class value of the
remote node, from 1 to 8 characters, in the Plexclass field.

7. In the CRC field, select one of the following options:

• Blank—To use the default value for the Process that was configured in the Initparms and
the Netmap entry for the remote node.

• OFF—To turn off CRC checking.
• ON—To turn on CRC checking.

8. To change the TCQ priority, type a value in the Priority field from 1 to 15, where 15 is the highest
priority.

9. To change the preferred session class, type the preferred session class in the Class field, from 1
to the maximum local sessions defined in the network map.

10. Type the user ID in the Notify Userid field.

11. Click OK to close the dialog box or click one of the other tabs to continue modifying Process
options.
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Assign Values to Symbolic Variables

Use symbolic variables to assign values to variables before execution. The values are then substituted
during execution whenever the symbolic variable is encountered.

To assign values to symbolic variables in a Process, from the Requester:

1. Double-click the Process to open it and click the Variables tab.

2. To create a new symbolic variable, type the symbolic variable name in the Variable Name field.
Symbolic variable names are case-sensitive. Enter the symbolic variable exactly as used in the
Process.

3. To change a symbolic variable, select the symbolic variable statement in the Variable list. If
necessary, edit the variable name.

4. Type the symbolic variable value or built-in variable enclosed in quotation marks in the Variable
Value field or edit the existing value.

Built-in Variable Value

%JDATE Specifies the date the Process was submitted in Julian format. The variable is resolved
as the submission date of the Process in the format yyyyddd. Among other uses, the
value returned is suitable for constructing a file name on the node receiving the file.

Note: The value of the variable is resolved at Process submit time. The value
will correspond to the date on which the Process was submitted,
regardless of when or how many times the Process is actually
executed.

%NUM1 Specifies the submission time of the Process in a 6-digit numeric-value format of
minutes, seconds, and hundredths of seconds.

%NUM2 Specifies the submitted time of a Process as 1 hex digit

%PNODE PNODE name where the submit occurs

%PRAND Pseudo-random number (6 hex digits)

%SUBDATE Specifies the date the Process was submitted in Gregorian format. The variable is
resolved as the submission date of the Process in the format cyymmdd where c is the
century indicator and is set to 0 for year 19yy or 1 for year 20yy. The value returned
can be used to create a file name on the node receiving the file.

%SUBDATE1 Use this parameter to substitute the submitted date in the yyyymmdd date format.

%SUBDATE2 Use this parameter to substitute the submitted date in the yyyymmdd date format.

%SUBDATE3 Use this parameter to substitute the submitted date in the yyyymmdd date format.

%SUBDATE4 Use this parameter to substitute the submitted date in the yyyymmdd date format.

%SUBTIME Specifies the time the Process was submitted. The variable is resolved as the
submission time of the Process in the format hhmmss. The return value can be used
to create a file name on the node receiving the file.
Note The value of the variable is resolved at Process submit time. The value will

correspond to the time at which the Process was submitted, regardless of
when or how many times the Process is actually executed.

%USER Specifies a variable that resolves to the user submitting the Process

5. To remove a symbolic variable, select the variable and click Delete.
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6. To save and add the variable to the Variable list, click Add.

7. Click OK to close the dialog box or click one of the other tabs to continue modifying Process
options.

Specify Accounting Data

Accounting Data is a free-form, user-defined field that sets up accounting and tracking information
about Process execution and data transfers. You can track data transfers by cost center, department
number, satellite location, or any other type of code or identification that would benefit the management
of data tracking.

To specify accounting data:

1. Double-click the Process in the Requester and click the Accounting tab.

2. Type the information in the PNODE field to specify accounting data for the PNODE. The
maximum length of the string is 256 characters.

3. Type the information in the SNODE field to specify accounting data for the SNODE. The
maximum length of the string is 256 characters.

4. Click Reset to Defaults to reset to values specified in the Process Defaults page of the Options
dialog.

5. Click OK to close the dialog, or click one of the other tabs to continue modifying Process options.

Add Comments

Use comments to explain the context of a statement. Adding comments is helpful to explain what the
statement does. This information is optional. When you view a Process in text format, comments appear
after the associated statement, except in the case of the process statement, when the comment appears
before the statement.

To add comments to a statement in a Process, from the Requester:

1. In the Process window, select the statement about which you want to add comments.

2. Select Process > Statement Properties.

3. Click the Comment tab.

4. Type the text in the Comment field.

5. Click OK to save the changes.

Validate Process Content
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When you finish creating or modifying a Process, validate the content of the Process.

Validating Process content checks the syntax for errors or missing information. Validation does not
check the content of the statements, only that they are formatted correctly. The Process validation sends
messages to the Output window. A Validation Successful message means that the syntax is formatted
correctly.

To validate the content of a Process:

1. Open the Process file.

2. Select Process > Validate.

3. View the messages displayed in the Output window. If messages indicate invalid statements, edit
the statements and validate the content of the Process again.

Save a Process

When you have finished creating or editing a Process, save the Process for future use. Processes are
stored in the Process directory.

1. Select File > Save.

2. Type a name for the Process including the .CDP extension.

Copy a Process

You can use a Process as a template by copying the Process, making changes to the copy, and saving
the copy to a new Process file.

To copy a Process:

1. Open the Process file.

2. Select File > Save As.

3. Save the Process with a new file name.

4. Change the Process statements. To change the Process statement, press Enter to access the Process
Properties dialog box.

5. To save the Process file with the changes, from the File menu, select Save.

Change a Submitted Process

You can change the following Process options once a Process is submitted:

• SNODE
• Hold
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• Execution
• Class
• Priority

To change Process options:

1. Right-click the open Process Monitor window and select Change Process. The Change Process
dialog box is displayed.

2. Make the necessary changes.

3. Click OK.

Manage Processes Using a Work List
The Work List is a document containing a sequential list of Process submit requests. It may contain
any of the commands that you can submit to the TCQ: send and receive file, submit a local or remote
Process, submit a local or remote program, and submit a remote batch job. When you create these
Processes, you can submit them directly to the TCQ or place them in a Work List for later submission.

You can use Work Lists in the following ways:

• Submit selected or all items in a Work List to the TCQ .
• Embed a Work List into another application and submit it using object linking and embedding

(OLE).
• Specify substitution variables at the time you submit the Work List.
• Create, update, monitor, edit, or validate a Work List.
• Cancel Work List operations.
• Insert a task into a Work List

Create a Work List

Using Work Lists saves you time and effort by automating routine or repetitive submission tasks. You
can build a Work List to periodically submit related work as a single work flow. Your Work List can
serve as a library of related or unrelated Processes.

To create a work list:

1. From the Connect:Direct Requester Main Window, select File > New > Work List.

2. Add Work List items as desired.

3. To establish an automatic status monitor for the Work List as it executes, perform the following
actions:
• Select WorkList > Work List Properties.
• Activate Auto Monitor.
• If you want the selected units of work to execute serially, turn on Serial Execution. This feature

causes the Submit action to wait until each unit of work is completed before submitting the
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next unit of work in the Work List. Processes are considered successfully completed if they
do not have a status of HI, PE, or EX.

4. To define substitution variables for the Work List, click the Variables tab. Select one of the
following actions:

• To add a new variable, type a name and value in the appropriate boxes and click Add.
• To modify a variable, double click the variable. Type a new name or value and click Add.
• To delete a variable, highlight the variable and click Delete.

5. To add a comment describing the Work List, click the Comment tab and type the information in
the dialog box provided.

6. Click OK.

Update a Work List

When you create a Process, a Send/Receive File Command, a Run Task Command, or a Run Job
Command, you can add the command to a Work List.

Use the Work List to define substitution variables, which you can set at submit time. All the variables
must have assigned or default values before the Work List is submitted.

To update a work list:

1. Add a command.

2. Select Add to Worklist from the command you are creating.

Submit a Work List

You can submit all or selected items of a Work List to execute.

To submit a work list:

1. Once you create a Work List, perform one of the following actions.

• To submit all items in the Work List, select WorkList > Submit.
• Highlight the items to submit and select WorkList > Submit Selected.

When you submit a Work List or a task from the Work List, the Work List or task is submitted
to the TCQ. If you activate Auto Monitor, a Work List status window displays the work items
as they are submitted.

Cancel Work List Operations

Although you cannot close a Work List until all of its tasks are executed, you can cancel the execution
of the tasks in a Work List.
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To cancel work list operations:

1. Select Work List > Cancel Execution.

The system stops waiting on Processes or programs and will not submit any more tasks. Any
tasks that have already started executing will finish, but no other tasks will execute.

Edit a Work List in Text Format

You can edit the text of a Work List to change command statements.

Caution: Editing the text of a Work List is a task for experienced users.

To edit a work list in text format:

1. Open the Work List that you want to edit.

2. Select Work List > Edit/View Text.

3. Edit the text as necessary using the following keyword and syntax rules. The Work List Edit/
View Text window enables you to see the full text of all tasks in a Work List. You can edit the
text directly if necessary. Put a keyword on a line by itself.

Keyword Description

Set Work Task List

Submit Ad Hoc Process Task

Submit File= Submit Process Task

Run Local Program Task

The following table lists the syntax types and restrictions:

Syntax Type Restrictions

Work List Task Syntax Must have the SET keyword

May have AutoMonitor and Serial Execution

May have variables

Local Program Task Syntax Must have the RUN keyword

Must have the FILE keyword

Must have arguments or a working directory

Submit File Task Syntax A Submit File task must have SUBMIT FILE= followed
by the file name

Submit Run Task Syntax Must have PEND at the end of the Run Task command

4. Close the window. The program displays a message asking if you want to save your work.

5. Click Yes. Your Work List is validated and saved. Any errors found during validation are
displayed at the bottom of your screen.
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Insert a Task into a Work List

To insert a task into a Work List:

1. Select Work List > Insert.

2. Select one of the following options to identify the task type to add to the Work List:

• Submit from File
• Send/Receive
• Run Task
• Run Job
• Local Program
• Comment

3. Type any arguments in the box.

4. Enter the information for the Process in its dialog box.

5. Click OK. The Work List window is displayed.

Validate a Work List

To validate a Work List:

1. Open the Work List that you want to validate.

2. Select the tasks you want to validate.

3. Select Work List > Validate. The validation information is displayed at the bottom of your screen.
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Manage Processes
Connect:Direct for Windows provides the following tools to manage Processes:
• Process Monitor—Enables you to view Processes in the TCQ, release held Processes, change

the status of a Process, and delete a Process. After you submit a Process, it is placed in the
Transmission Control Queue (TCQ).

• Process Notification Utility—Enables you to change the notification method. You define the
method of notifying users of Process execution when you install Connect:Direct for Windows.

• Windows Event Logging—Logs informational, warning, and error messages.
• Messages—If you need to troubleshoot the meaning of an error message, you can view more

information about an error message with the Message Lookup.
• SNMP—If you use Microsoft Windows SNMP to capture messages, you must identify the

messages you want to include and determine if messages are trapped or logged to the event
log.

• Activity Log—This document contains a list of Connect:Direct activities, including every
significant activity that you have requested from the time the activity log is opened until it is
closed. Each activity record logged is maintained with the significant data associated with it.
For example, when you save a file, the Save activity record is stored, with the file name of the
saved document.

The Activity Log is created at startup and is enabled by default. It can be viewed in the Output
window by clicking the Activity Log tab. You may create, save, open, close, and print Activity
logs. To save an activity log, you must specify that you want the activity log written to a file.
When you open a new activity log, the currently active Log is inactivated. You must close
Connect:Direct Requester in order to open an activity log.

Understanding the TCQ
After you submit Connect:Direct Processes, they are stored in the TCQ.

The TCQ controls Connect:Direct Process execution. As sessions are available, the TCQ releases
Processes to begin execution according to the scheduling parameter values and the class and priority
of each Process. Use the Process Monitor to manage and view the status of submitted Processes.
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TCQ at Server Startup
The initialization parameter tcq.start determines what the TCQ does with existing Processes. The
default value is tcq.start=w (warm start), which specifies that all existing Processes in the TCQ are
retained. A warm start restarts any Processes submitted with the Process statement parameter
retain=initial as well as any Process that was executing in the TCQ when the server was brought down.
You can change the parameter to tcq.start=c (cold start) to delete all existing Processes in the TCQ
when the server restarts.

TCQ Logical Queues
As Connect:Direct Processes are submitted, they are placed in one of the four TCQ logical queues:
Execution, Wait, Timer, and Hold.

As sessions are available, the TCQ releases Processes to begin execution according to the Process class
and priority, as shown in the following figure:

Each Process in the queue is assigned a status. The queues and status values are identified in the
following sections.

Execution Queue
Processes are placed in this queue after the connection to the SNODE occurs. Processes typically come
from the Wait queue, but also can be placed in the Execution queue by a submit command with
maxdelay= specified. After a Process successfully finishes, it is automatically deleted from the
Execution queue. When a session is interrupted, the Process moves from the Execution queue to the
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Timer queue, if retry values are specified. If connection is not made before the retry values are
exhausted or if retry values are not specified, the Process moves to the Hold queue with a status of HE.
The following table displays the status values assigned in the Execution queue:

Status Comment

EX Process is executing between two Connect:Direct nodes.

PE Processes waiting for Process start messages to be exchanged between the PNODE and the
SNODE. This is the initial queue status when a Process is submitted with maxdelay= specified.

Wait Queue
Processes are placed in the Wait queue while waiting for an available connection between the PNODE
and the SNODE. Processes can come to the Wait queue from the Hold queue or the Timer queue.
Processes also can be placed in the Wait queue by a submit command with no parameters specified,
submit with retain=no, or submit with hold=no. After the connection is made, Processes
automatically move to the Execution queue. The following table displays the status values assigned in
the Wait queue:

Status Comment

WC The Process is ready to execute, but no session is available. This Process runs as soon as a new
session is created or an existing session becomes available.

WR The Process is in retry status. The number of retries and intervals between retries is specified in
the network map for the remote node.

WA The initial queue status when a Process is submitted without HOLD or RETAIN specified. This
Process is ready to execute as soon as possible.

Hold Queue
Processes are placed in this queue while waiting for operator intervention before progressing to the
Wait queue. This queue enables operators of the PNODE and SNODE to coordinate and control Process
execution.

Processes are placed in the Hold queue by a submit command with retain=initial, retain=yes, or
hold=yes parameters specified. Processes submitted with hold=call also are placed in the Hold queue.
Processes are moved from the Timer queue to the Hold queue by a change process command with
hold=yes specified. Processes are moved from the Hold queue to the Execution queue by a change
process command with the release parameter specified.

The following table displays the status values assigned in the Hold queue:

Status Comment

HC The Process was submitted with hold=call specified. A session started from the remote node causes
the Process to be moved to the Wait queue in WC status. The Process is placed in the Execution
queue when the Process is selected for execution.

HI The Process was submitted with hold=yes. The Process can be released later by a change process
command with release or hold=no specified.

HE A session error or other abnormal condition occurred.

HO A change process command with hold=yes was specified.
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Status Comment

HR The Process was submitted with retain=yes or retain=initial specified and has already executed. The
Process can be released later by a change process command with release specified.

HS The Process was suspended due to a server shutdown.

Timer Queue
Processes are placed in this queue by a submit command with the startt parameter specified. Processes
in the Wait for Start Time (WS) status are waiting for the start time to arrive before moving to the Wait
queue. Processes also are placed in the Timer queue in Retry (WR) status after an error, such as a line
break or a lost connection. Connect:Direct automatically tries to execute the Process again based on
the number of times to retry and the delay between retries as specified in the submit command,
Process statement, network map parameters, or initialization parameters. Processes move from the
Timer queue to the Wait queue. A change process command with hold=yes specified moves the
specified Process from the Timer queue to the Hold queue.

The following table displays the status values assigned in the Timer queue:

Status Comment

RE The Process is in retry status. The number of retries and intervals between retries is specified in the
network map or initialization parameters.

WS The Process was submitted with a start time (startt) or date that has not expired. When startt is
reached, the Process is placed in the Wait queue for scheduling for execution.

View Processes in the TCQ
To view the Processes in the TCQ, use a Process Monitor.

You can use more than one monitor to view different queues or to look at Processes based on different
criteria. You can arrange Process Monitors and save the Workspace view so that when you enable that
view, the Monitors are automatically displayed. You can define how you want to display the Process
Monitor, what types of Processes you want to view, and what queues you want to view.

Create a Process Monitor

To create a process monitor:

1. Select File > New > Process Monitor.

2. Do one of the following:

• To monitor all Processes, select All Processes.
• To monitor only those Processes that meet certain criteria, select Filter Using Selection

Criteria Pages. Define the criteria based on the options on the remaining property pages.
• To refresh the monitor at specified intervals, select the Refresh every _ seconds option

and enter the interval from 1-999 seconds.
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• To monitor new data that was created since the Process Monitor was closed, select
Refresh on open.

3. Select the node on which to monitor Processes in the Node field.

4. Click OK.

Monitor Processes Based on Selection Criteria

You can monitor Processes based on selection criteria.

Select the criteria to use to include in a Process Monitor. Select one or more of the following filters:
the status of a Process in the queue, the remote nodes included in a Process, the user who submitted a
Process, or a Process name or number.

To identify what Processes to include in a Process Monitor:

1. Open a Process Monitor window.

2. Select Filter Using Selection Criteria Pages.

3. To include Processes in a Process Monitor based on TCQ queue:
• Click Status.
• Select the status types you want to monitor. You are not limited to the number of status types

you can request. The status types are defined in the following table:

Status Description

Execution Processes that are being serviced by the session manager.

Pending Execution The Process was submitted with the maximum delay option set to zero.

Waiting Connection The Process is ready to execute as soon as a session is available.

Waiting Start Time The Process is waiting in the Timer Queue because it was submitted with a start
time or date that has not expired. When the start time is reached, the Process is
placed in the Wait queue to schedule for execution.

Held Suspension The operator issued a delete process request with hold set to Yes.

Timer Retry The Process is waiting for a retry attempt.

Held for Call The Process was submitted with the Hold option set to Call. A session started
from either node moves the Process to the Wait queue in WC status. The Process
is placed in the Execution queue when the Process is selected for execution.

Held Due to Error A session error or other abnormal condition occurred.

Held Initially The Process was submitted with the Hold option set to Yes.

Held by Operator A change process request with hold set to Yes has been issued.

Held by Retain The Process was submitted with retention set to Yes or Initial.

Select All To monitor all status types.

Unselect All To deselect all status types.

4. To view Processes based on Process name:
• Click the Process tab.
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• Select the Queue to search in the Queue(s) field.
• To monitor a Process by name, click the New icon, type the name of the Process, and press

Enter. Repeat this step to add additional Process names.
• To monitor a Process by number, click the New icon, type the Process number, and press

Enter. Repeat this step to add additional Process numbers.

5. To view Processes based on a remote node:
• Click the Nodes tab.
• Choose one of the following:

• Select the network map node in the Netmap Nodes field.
• Click the right arrow or select All to select all network map nodes.
• To type a remote node name, click the New icon, type the remote node name, and

press Enter. Repeat this step to add remote node names.

6. To view Processes based on a user ID:
• Click the Submitter tab.
• Type the user ID or user proxy in the User field.
• Type the node name in the Node field and click Add. Continue entering node names and

clicking Add until you have added all user IDs you want to monitor.

7. Click OK.

Open a Process Monitor File

To open a Process Monitor file:

1. Select Files > Open.

2. From Files of Type, select Process Monitors (*.cdm) to display only Process Monitor files.

3. Locate and select the Process Monitor file to open.

Save a Process Monitor

Saving a Process Monitor to a file lets you use the same format and monitor criteria again. When you
save a Process Monitor, you are saving the criteria and the format of the Process Window; not the
Process information displayed at the time you save the monitor.

1. Select File > Save.

2. Type the name of the Process monitor with the extension .cdm.

3. Click OK.
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The Process Monitor Output
Each line in a Process Monitor is a summary record of the current status of the Process in the TCQ.
Depending on the status of the Process or the step being executed, some fields may be blank. The lines
are numbered sequentially. A "W" to the left of the sequence number indicates the Process has met the
warning conditions you established.

The following information is displayed:

Field Content

Name Process name.

Number Process number.

Step Name Process step name currently executing.

Status Current status of the Process.

Queue Logical queue where the Process is currently located (Execution, Hold, Wait, or Timer).

Byte Count Number of data bytes read or written.

Submit Node Node name from which the Process was submitted.

Submitter User ID of the person who submitted the Process.

Pnode Primary node in the Process.

Snode Remote or partner node in the Process.

Message Message associated with the current Process step.

Source File Name of the source file.

Submit Date/Time Date and time the Process was submitted.

Schedule Date/Time Date and time the Process was scheduled to be submitted.

Retain Identifies if the Process is to be retained in the TCQ for future submission.

Function Type of Process statement currently executing (COPY, RUNJOB, RUNTASK, SUBMIT).

CC Completion Code.

0—Success

4—Warning

8—Error

16—Severe error

FDBK Feedback code.

Message Text Message short text.

Message Data The substitution variables with their values for the short text.

Log Date/Time The date and time the Process record was created.

Hold The hold status of the Process.

Class Session class on which the Process is executing.

Priority TCQ priority of the Process.

Local Node Indicates whether the local node is the SNODE or the PNODE in the Process.

From Node Indicates whether the local or remote node is the FROM node in a COPY.

Compression Compression factor used in a copy step
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Field Content

Checkpoint Restart Indicates use of checkpointing in a copy step.

Restart Indicates whether the Process was restarted.

Source Disp 1 Source file disposition parameters.

Source Disp 2 Source file disposition parameters.

Source Disp 3 Source file disposition parameters.

Record Count Number of data records read or written.

Xmit Bytes Number of data bytes plus RU bytes sent

Xmit RUs Number of request/response units sent.

Dest File Name of the destination file.

Dest Disp 1 Destination file disposition parameters.

Dest Disp 2 Destination file disposition parameters.

Dest Disp 3 Destination file disposition parameters.

Use the Output Display

Through the output display, you can accomplish the following tasks:
• View details associated with a Process
• View the condition that caused a warning flag on a Process
• Change the order of fields displayed

To use the output display:

1. Do one of the following:

• To view the detail fields associated with a Process, double click the Process summary
line

• To view the condition which caused the warning flag on a Process, select the flagged
Process. The condition is posted at the bottom of the display.

Note: You cannot change the size of the rows.
• To change the order of the fields in your display, select the heading of the field you want

to move, point the mouse at the heading, and drag and drop the column to its new location.
You may move any column. After you close the reformatted display, that format becomes
your default format.

Notification
When you install Connect:Direct for Windows, you identify the method used to notify a user of Process
execution. If you want to change the method used to notify selected users when a Process executes,
use the Change Notification utility. This application updates the Registry entries used by
Connect:Direct to perform the specified notification.
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Notification Methods
Connect:Direct for Windows provides two notification methods:
• NT Broadcast—NT Broadcast notification is performed using the Windows msg command.
• SMTP—E-Mail notification is performed using Simple Mail Transfer Protocol (SMTP)

notification, a simple ASCII protocol.

NT Broadcast
Connect:Direct for Windows uses the msg command to accomplish notification through NT Broadcast.
The notification is sent to the specified user or users attached to a particular computer or domain on
behalf of the user context that Connect:Direct is running in.

After the notification ID is specified from within the Process Control Options category of the Process
Definition dialog box, Connect:Direct supplies the user as an argument in the msg command. If the
specified recipient cannot be located, or is not logged on, the notification fails and is not attempted
again.

SMTP Notification
Connect:Direct uses the SMTP notification method and exchanges E-Mail using TCP/IP and a message
transfer agent (MTA).

The SMTP standard is one of the most widely used upper layer protocols in the Internet Protocol stack.
This protocol defines how to transmit messages (mail) between two users. SMTP uses spooling to
allow mail to be sent from a local application to the SMTP application, which stores the mail in some
device or memory. Once the mail has arrived at the spool, it is queued. A server checks to see if any
messages are available and then attempts to deliver them. If the user is not available for delivery, the
server tries later. Eventually, if the mail cannot be delivered, it will be discarded or returned to the
sender.

Change Process Notification

To change the Process notification setup:

1. Validate that the Connect:Direct service has been stopped by selecting Start > Settings > Control
Panel > Administrative Tools > Services and making sure the Connect:Direct service is stopped.
If not, select the service and click Action > Stop.

2. Click Start > Programs > Sterling Commerce Connect:Direct v4.5.00 > CD Change Notification
Utility.

3. In the Node Name field, type or select the local node you are configuring. When you select a
node, the current method of notification is displayed in the Transport field.
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4. NT Broadcast is the default setting for the notification methods. If want to use SMTP as the
notification method, select SMTP in the Transport field and type the following information in
the fields provided:

• Host Address—The address of the SMTP server as either the DNS name or the IP address.
• Host Port—The port to use to connect to the SMTP server. The default is 25.
• Sender—The e-mail address you wish to use as the sender.
• If you want to activate authentication, turn on Authentication and provide a User ID and

password to use to sign on to the SMTP server.

5. Click Save.

6. Click OK.

View Process Statistics
Connect:Direct records the history of a Process in a single relational database. You can review this
information to examine details about server execution.

Connect:Direct for Windows also uses the Windows Event Logging facility to log certain messages
that the server generates during execution. Connect:Direct selects specific record IDs or event types
when logging statistics. Connect:Direct assigns these record IDs severities and passes them on to the
Windows Event Logging facility. The event.log initialization parameter controls the statistics IDs that
Connect:Direct sends to the Windows event log.

The statistics file stores information about all events that take place within the Connect:Direct server
for a specific period of time. The amount of time is determined by the value specified for the
stat.max.age initialization parameter. Each record within the statistics file consists of fields that contain
general information about the record and a field that contains the statistics or audit information to log.

In the fixed portion, the following fields are defined for the statistics files:

Field Description

EntryDateTime Date and time that the record was inserted into the statistics file. The format is YYYYMMDD
HHMMSSTTT.

SeqNum Sequence number.

RecID A 4-character ID that describes the type of record.

RecCat A 4-character ID that describes the category of record.

PrcName Name given to the Process when it is submitted.

PrcNumber Number assigned to the Process when it is submitted.

StartTime Start time of a Process step, if this is a Process step statistics record.

StopTime Stop time of a Process step, if this is a Process step statistics record.

SubmitterNode Node that the Process was submitted on.

SubmitterUserID User that submitted the Process.

RemoteNode Remote node for the Process.

ConditionCode Condition code for the statistics record.

AuditInfo Variable portion of the statistics record.
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If the existing statistics file cannot be extended, the server issues a message to the Windows event log
and terminates immediately. The server terminates all activity as if issuing a stop command with the
immediate parameter. Any statistics records that are usually written during stop immediate processing
are not created in this situation.

The Statistics Monitor Window
The Statistics Monitor window displays the following information:

Field Definition

Log Date/Time Specifies the date and time the statistics record was created.

Type Specifies whether the record is event or Process related.

CAEV indicates that the record is related to an event.

CAPR indicates that the record was related to a Process.

RecID Specifies the type of statistics record generated.

CC Specifies the completion code.

FDBK Specifies the feedback code for the module.

MSGID Specifies the Message ID.

PName Specifies the Process name.

PNum Specifies the Process number.

Step Name Name of the Process step.

Each row is a statistics record. Select the row to view statistics record details. You can also modify the
appearance of the Statistics Monitor window.

Delete Statistics Records
The server deletes statistics records based on the value specified for the statistics initialization
parameter stat.max.age.

The stat.max.age parameter controls the amount of time that the server retains the statistics record in
the database. When statistics records reach the value specified by the stat.max.age parameter, the server
automatically deletes them. To retain all of your records, back up your database regularly or set
stat.max.age= to disable automatic deletion.

Control Statistics File Content
Use the log.commands and log.select initialization parameters to control whether the statistics file logs
output from all commands and whether the file logs commands that select Processes and select
statistics.

See "Statistics Parameters" in the Change Connect:Direct Settings chapter (or section of help) for a
description of the statistics parameters.
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Create a Statistics Report

To create a statistics report:

1. To open a new statistics monitor, select File > New > Statistics Monitor.

2. To modify an existing statistics monitor, select File > Open and select from the Statistics Monitor
directory.

3. To view statistics for all Processes executed over a specific period of time:
• Select All Statistics for Last _ hrs.min.
• Enter the time period in hours and minutes.
• Click OK.

4. To view only those Processes that meet certain criteria:
• Select Filter Using Selection Criteria Pages.
• Define the criteria on the remaining property pages.

5. To view statistics based on step and Process completion only select Step and Process Completion
Statistics Only.

6. To refresh the monitor at specified intervals:
• Select Refresh every _ minutes.
• Type the interval in minutes (1–60).

7. To view new statistics that were created since the Statistics Monitor was closed, select Refresh
on open.

8. To view the last statistic as it occurs, select Autoscroll.

9. If necessary, select the node to monitor in the Node field.

10. Click OK.

Select Statistics Based on Process Name or Number

You can select statistics based on Process names or Process number.

The Process number is the number assigned by Connect:Direct when the Process is submitted.

To select statistics based on Process name or number:

1. Open or create a Statistics Monitor.

2. Select Filter Using Selection Criteria Pages.

3. Click Add.

4. To view statistics based on Process name:
• Click the Process tab.
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• Click the new icon.
• Type the Process name and press Enter.
• Continue the previous two steps until you have added all Process names to monitor.

5. To view Statistics based on Process number:
• Click the new icon.
• Type the Process number and press Enter.
• Repeat this step until you have added all Process numbers to monitor.

6. To view statistics based on a user ID:
• Click the Nodes tab.
• Click the new icon.
• Type the user ID or user proxy and press Enter.
• Repeat the previous two steps until you have added all user IDs to monitor.

7. To view statistics based on who submitted a Process:
• Click the Submitter tab.
• Type the user ID or user proxy.
• Type the node on which the user is located.
• Click Add.
• Repeat the previous three steps until you have added all submitters to monitor.

8. To view statistics based on a range of date or time:
• Click the Ranges tab.
• Activate the Date/Time Range option.
• Select one of the following options:

• Range—Type the time range to monitor in hours and minutes.
• Start and Stop—Type the beginning and ending date and time range or select the date

from the calendar in the Start and the Stop fields. Type the date in the format mmm/
dd/yyyy and the time in the format hh:mm:ss Xm.

• Start Only—Type the beginning date and time range or select the date from the
calendar in the Start field. Type the date in the format mmm/dd/yyyy and the time in
the format hh:mm:ss Xm.

• Stop Only—Type the ending date and time range or select the date from the calendar
in the Stop field. Type the date in the format mmm/dd/yyyy and the time in the format
hh:mm:ss Xm.

9. To select statistics based on a condition code, select the condition code on which the condition
is based and select a conditional operator as detailed in the following table:
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Option Description

Conditional Code
Range Delimiters

To limit the statistics based on error code values, select the condition code delimiters in
the first drop-down box including:

• Equal to

• Greater than or equal to

• Greater than

• Less than or equal to

• Less than

• Not equal to

Conditional Code
Range Error Codes

To limit the statistics to selected error codes, select the error code value from this drop-
down box including:

• 0

• 4

• 8

• 16

• Any

10. To generate statistics for specific source or destination files:
• Click the Files tab.
• Click the Add icon for the file type: either source or destination files.
• Type the name of the file including the full path name.
• Press Enter.
• Repeat this procedure until all files to monitor are identified.

11. To generate statistics based on record types:
• Click the Records tab.
• Select a record category from the drop down menu for the Record Category field.
• Select a record from list. To remove a selection, click the item again.
• To select all the records, click Select All.
• To clear all selections, click Unselect All.

12. To generate statistics based on user-defined records:
• From the Records tab, click Add in the User Defined Records dialog box.
• Type the first four characters of the message ID.
• Press Enter.
• Repeat the three previous steps until you have added all records you want to monitor.

13. Click OK.

Statistics Report Output
Each line in the Statistics report represents a statistics record. The following information is displayed
for each record type.
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Field Description

Log Date/Time The date and time the statistics record was created.

Type The record category.

CAEV—Specifies that the record is related to an event, such as a Connect:Direct shutdown.

CAPR—Specifies that the record is related to a Process.

Rec ID The type of statistics records, such as Copy Termination records or Connect:Direct
initialization event records. Identifiers are as follows:

Record ID Category

CHGP Event

COAC Event

CRHT Event

CSTP Event

CTRC Process

CTRM Event

CUKN Event

CXIT Event

DELP Event

FLSP Process

FMRV Process

FMSD Process

GPRC Process

IFED Process

LIEX Event

LIOK Event

LWEX Event

NAUH Event

NMOP Event

NUIC Event

NUTC Event

NUIS Event

NUTS Event

PERR Process

PFLS Process

PRED Process

PSAV Event

PSED Process

PSTR Process

RJED Process

RNCF Process
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Field Description

RTED Process

SBED Process

SELP Event

SELS Event

SEND Event

SERR Event

SHUD Event

SIGC Event

SSTR Event

STOP Event

SUBP Event

TRAC Event

UNKN Event

USEC Process

xxxx Event

Other fields displayed depend on the record type.

You can accomplish the following tasks through this display:
• To redefine the selection criteria, click the Criteria button.
• To see the detail fields associated with the Process, double-click on the Process summary line.
• To change the size of a field in your display, point the mouse at the boundary edge of the

heading of the field you want to change. While holding down the mouse button, move the
mouse horizontally until the width of the field is as desired.

• To change the width of a row, move the cursor to the line between any of the line numbers.
While holding down the mouse button, move the mouse vertically until the width of the row
is as desired.

• To change the order of the fields in the display, select the heading of the field you want to
move, press SHIFT, point the mouse at the heading, and drag and drop the column to its new
location. You can move any column.

After you close the reformatted display, that format becomes the default format.

Understand the Windows Event Logging Facility
Connect:Direct for Windows uses the Windows Event Logging facility to log informational, warning,
and error messages that the server generates during execution. A subset of the Connect:Direct statistics
records are also sent to the event log. The event.log initialization parameter determines which of these
records to log.

Merging this critical error information with the event log enables the system administrator to have a
single point of focus for error information from all Windows subsystems. The Event Logging facility
also allows for easy correlation of the various error messages that both Connect:Direct and Windows
generate.
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Note Connect:Direct can generate numerous event records. For control purposes, define a large event log,
use the event.log initialization parameter to reduce the number of events Connect:Direct generates, or
define the event log to be wraparound.

The event log receives the following information from Connect:Direct for Windows:

Information Connect:Direct Record IDs Windows Event Type

Server initialization/termination NUIC and NUTC Informational

Communications session start/end COAC and SEND Informational

Communications error SERR Error

Connect:Direct Process start/end PSTR and PRED Informational

Connect:Direct Process step
information

CTRC, PSED, RJED, RTED, and
SBED

Informational

Connect:Direct Process flush/error PERR and PFLS Warning

Control Event Log Content
Use the event.log initialization parameter to control the Connect:Direct statistics IDs that
Connect:Direct sends to the event log. It specifies the statistics IDs the system sends to the Windows
event log. You can specify a list of Connect:Direct Statistics IDs or the keyword All. If you specify
more than one statistics ID, use a comma to separate IDs in a list. The default is All.

The following sample uses the event.log initialization parameter to log Process start and stop, Process
flush, and Process errors to the event log.

event.log=PERR,PFLS,PRED,PSTR

View the Event Log

To view the Windows Event Log:

1. Select Start > Settings > Control Panel > Administrative Tools > Event Viewer.

2. Double-click the event in the list you want to view.

Note: The Event Detail fields are display only. They include the date and time, the
application that is the source of the event, the type of event, and the description
for the event ID generated.

3. Click the up or down arrow to continue viewing details of the list of events.

4. Click OK.

Filter the Event Log
The Windows Event Viewer utility also enables you to filter the event log.
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If you want to view a category of events in the log, you can sort the event log by using the Filter Events
option. You can filter the event log by specifying settings that control a range of events by date and
time. You can also filter the event log by particular event types, application source and category,
particular user, computer, and Event IDs. See the Windows documentation for more information on
the Event Viewer and the filter functionality.

Use the Connect:Direct Message Lookup Utility to assist you in troubleshooting. Enter a message ID
to access the short and long text explanations for Connect:Direct messages.

Note You can also view messages with the select message command from the CLI.

View Messages

Use the Connect:Direct Message Lookup Utility to view the short and long text explanations for error
messages.

1. Select Start > Programs >Sterling Commerce Connect:Direct Windows v4.5.00> CD Message
Lookup.

2. Enter the message ID in the Message ID field.

3. Click Lookup to display the short message text and long message text.

Send Messages to a SNMP Management System
The Simple Network Management Protocol (SNMP) defines a set of protocols that describe
management data and the protocols for exchanging that data between systems.

Connect:Direct for Windows provides an extension agent that works with Microsoft Windows SNMP
Extensible Agent to send traps to a configured Network Manager. See Microsoft documentation for
details on configuring the SNMP service to send traps.

Connect:Direct for Windows enables messages to be written to the event log. Traps are triggered by
Connect:Direct for Windows messages. Certain messages are associated with trap events. However,
you can also define any message to be a trap event. When Connect:Direct for Windows starts, it
processes the configuration file to create a table of trap-event messages. When a trap-event message
occurs, it is forwarded to the extension agent. The extension agent works with the Microsoft Windows
SNMP Extensible Agent to forward the trap to all configured network managers. The network managers
who receive the messages are defined when you install Microsoft SNMP.

To activate SNMP trapping, set the SNMP initialization parameter to Y. The default is N.

When a trap-event message occurs, Connect:Direct for Windows writes the message to the application
event log.

To activate event logging, set the initialization parameter called EVENTLOG to Y. The default is N.

The configuration file is used by both SNMP and event logging. It is specified by the SNMP.DSN
initialization parameter and the default file name is:

installation directory/snmp/snmp.ini
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where installation directory is the location where you installed Connect:Direct for Windows.

The configuration file enables you to customize the events that can be trapped. By default, all events
are enabled. If you want to disable some events or define other messages to be trap events, edit this
file with any standard editing tool.

Do one or more of the following to customize the configuration file:
• To turn off an event, set its value to N.
• To turn off all status traps, set sendStatusTraps=No.
• To turn off all alarm traps, set sendAlarmTraps=No.
• To define a list of Connect:Direct messages that will produce an alarm trap, use the following:

USERMESSAGEALARM = (message ID, message-list)
• To define a list of Connect:Direct messages that will produce a status trap, use the following:

USERMESSAGESTATUS = (message ID, message-list)

When the server is started, the SNMP and EVENTLOG initialization parameters are checked. If the
SNMP and EVENTLOG parameters are not specified, SNMP and event logging are not activated.

Identify the Trap Variables
Traps are defined as alarm or status alerts that enable the network manager to display the trap in the
appropriate color on the network manager console.

Alarm trap variables signal events that are critical to the operation of Connect:Direct for Windows.
Status trap variables signal events that are not critical to the operation of Connect:Direct for Windows
but show valuable information. The tables in the following sections describe the predefined traps, the
message that triggers the trap, and a description of the trap and associated text.

The categories for trap variables are as follows:
• Type events
• Initialization events
• Shutdown events
• API events
• Execution events
• License Key events
• Miscellaneous events

Valid values for all events are YES (or Y) to enable and NO (or N) to disable.

This section identifies the Connect:Direct traps supported and identifies the messages associated with
the trap. Connect:Direct traps are defined in two groups: status traps and alarm traps.
• Status traps are not critical to the operations of Connect:Direct for Windows but display

important information.
• Alarm traps are more serious, such as license expiration.

Following are lists of Connect:Direct for Windows specific or predefined traps and the message that
triggers the event. All traps are enabled by default. If any of the traps need to be disabled, specify them
in the SNMP.DSN parameter with the following syntax:

Trap-name= Yes / No (YES=Enable and NO=Disable)
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Initialization Events
The following table details status events that occur at initialization.

Trap Variable Description Trap Trigger

initializationComplete This node was initialized successfully. NUIC00I

snaNotAvailable The SNA support is temporarily unavailable because the
APPC/SNA feature could not be initialized.

LSNA003I

snaNowAvailable SNA/APPC has been successfully initialized. LSNA004I

tcpNotAvailable The TCP support is temporarily unavailable because the
TCP environment could not be initiated.

LTCP003I

tcpNowAvailable The connection to TCP/IP has been successful and all TCP
functions are supported.

LTCP004I

Shutdown Events
The following table details status events that occur at shutdown.

Trap Variable Description Trap Trigger

shutdownRequested A Connect:Direct for Windows Stop command has been
issued. Type can be QUIESCE, STEP, IMMEDIATE, or
FORCE.

LSMG421I

normalShutdownComplete Connect:Direct for Windows termination has been
completed successfully.

NUTC001I

The following table details the alarm event that occurs at shutdown:

Trap Variable Description Trap Trigger

abnormalShutdown An abnormal termination of
Connect:Direct for Windows has
occurred.

LSMG419I

API Events
The following table details the status event that occurs from the API.

Trap Variable Description Trap Trigger

maxUserReached MAX.API.CONNECTS has been reached. LCOA009I

Execution Events
The following table details status events that occur when a Process executes.
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Trap Variable Description Trap Trigger

processRetryExceeded The Process has exceeded the retry threshold and
has been placed in the Hold queue.

SVTM506I

tcqMovement A Connect:Direct for Windows Process has been
moved to the Hold queue due to errors during
Process execution.

LPMM001E

LSMG007E

SVTM105I

userMessageStatus A user defined Connect:Direct message has been
issued.

Any Connect:Direct message

The following table details alarm events that occur when a Process executes:

Trap Variable Description Trap Trigger

processFailure A Process failed with a return code greater than 4 due to
abnormal session termination, network map check failure, or
FM security failure.

LSMG420I

maxPnode The maximum number of PNODE Processes has been
reached.

LPMM055E

processNot Started Process was not started because session manager could not
be initialized.

LSMG418I

maxSnode The maximum number of SNODE Processes has been
reached.

LSMI013E

userMessageAlarm A user-defined Connect:Direct message has been issued. Any message ID

Miscellaneous Events
The following table details other status events.

Trap Variable Description Trap Trigger

tracesEnabled Connect:Direct traces enabled. STRA029I

netmapUpdate The Connect:Direct network map has been updated. SMUP192I

authFileUpdate Dynamic update of the Connect:Direct AUTH has occurred. SAFC006I

initparmRefresh Dynamic update of the Connect:Direct INITPARM has occurred. SITA993I

changeProcess A CHANGE PROCESS command has occurred. SOPB017I

deleteProcess A DELETE PROCESS command has occurred. SOPC011I

License Key Events
The following table details license key alarms events.

Trap Variable Description Trap Trigger

apInitFailure An initialization error occurred when processing the license
file.

APSM012E

apKeyValidFailure The license file is invalid. APSM008E
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Trap Variable Description Trap Trigger

emergencyKey The EMERGENCY-KEY is being used. APSM998I

productHasExpired The Connect:Direct product license has expired. APSM009E

APSM010E

productWillExpire The Connect:Direct product will expire in x number of days. APSM011E

generalAPFailure An unexpected failure has occurred while processing the
license file.

APSME

Using the Activity Log
This Activity Log contains a list of Connect:Direct activities, including every significant activity you
have requested from the time the activity log is opened until it is closed. Each activity record logged
is maintained with the significant data associated with it.

For example, when you save a file, the Save activity record is stored, with the file name of the saved
document. The Activity Log is created at startup. It is minimized and located in the lower left-hand
corner. You may create, save, open, close, and print Activity logs. When you open a new activity log,
the active Log that is already open is deactivated.

Opening an Activity Log
To open an activity log, click the Activity Log in the bottom pane of the Connect:Direct Requester
window.

Saving an Activity Log

The activity log information is lost when you close Connect:Direct Requester unless you set the activity
log information to write to a file.

1. Select Tools > Options.

2. To display the activity log in the output window, check Enable the activity log in the output
window.

3. To write the activity log to a file:
• Check Write the Activity Output to a File.
• Type the name of the file.
• To create a new activity log every time you start Requester, select Create New File at Startup.
• To append activity to the existing log file at start up, select Append to Existing Activity File.

4. Click OK.
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Type Events
Use the events in the following table to enable or disable all alarm or status events.

Trap Event Description Event

sendAlarmTraps NO—Disables all alarm trap variables regardless of individual
settings.

YES—Enables all alarm trap variables, allowing you to disable
individual alarm trap variables.

Alarm

sendStatusTraps NO—Disables all status trap variables regardless of individual
settings.

YES—Enables all status trap variables, allowing you to disable
individual status trap variables.

Status
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Manage a Connect:Direct Server

Manage a Connect:Direct Server
The Connect:Direct Admin Tool enables you modify a Connect:Direct server and databases. You
configured the server when you installed Connect:Direct for Windows. If you want to change the server
configuration or start or stop a Connect:Direct server, use the Admin Tool utility.

Start the Admin Tool Utility

1. Click Start > Programs.
2. Click Sterling Commerce Connect:Direct v4.5.00 > CD Admin Tool.

The main window contains an icon representing the local computer and a traffic light icon for each
Connect:Direct node on the computer. A running server is represented by a green light, a stopped server
is represented by a red light, and a server in the process of starting or stopping is represented by a
yellow light.

About the Toolbar
The Admin Tool toolbar provides icons to perform frequently performed actions. The Admin Tool
provides the following utility icons.

Select To

Start a server. The traffic light icon displays a green light when the server is starting or running.

Stop a server. The traffic light icon displays a red light indicating the server is not running.

Set general properties for a Connect:Direct for Windows server. Stop the server before setting general
properties.

Display the About Admin Tool dialog box.

Click on a menu bar item, or toolbar item, to access a description of its function. This action does not
work when a dialog box is open.
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Start and Stop a Connect:Direct Server

Use the Admin Tool utility to start and stop a Connect:Direct server.

To start a server:

1. Select the server to start.

2. Select Server > Start.

The server icon changes to yellow and then changes to green if the server is started. If the server
is unable to start, the light changes back to red.

Configure a Connect:Direct Server

To configure general, TCP/IP, SNA, and database properties for a server, use the Properties dialog
box.

Caution: You must stop the Connect:Direct service before you configure properties. Stopping the
service interrupts any Processes that are running.

To configure server properties:

1. Click the server to configure.

2. If the server is running, click the stop icon to stop the server.

3. Select Server > Initialization Properties.

4. Select one of the following Service Startup methods from the pull-down menu:

• Automatic to start Connect:Direct every time the system starts.
• Manual to start Connect:Direct manually.
• Disabled to prevent Connect:Direct from being started.

5. If necessary, change the settings on the General properties page. Refer to the following table for
a description of the fields:

Field Name Definition Valid Values

Max API Connections Specifies the maximum number of concurrent
client API connections permitted for the local node.
It defines the maximum number of connections by
different userids. API connections by a single user
ID has no limit.

A numeric value from 1–255. The
default is 10.

Max Pnode Sessions Specifies the maximum concurrent connections for
all remote nodes where the local Connect:Direct for
Windows server node is the originator of the
Process.

This field is limited to the lesser of the values
defined in the initialization parameters file and the
network map definition for a given node.

A numeric value from 1–255 for the
server version of Connect:Direct for
Windows. The default is 1 for the
server version. The workstation
version is limited to 1 PNODE
session.
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Field Name Definition Valid Values

Max Snode Sessions Specifies the maximum concurrent connections,
where the local Connect:Direct server node is the
partner node cooperating with a remote
Connect:Direct node to execute a Process.

This field is limited to the lesser of the values
defined in the initialization parameters file and the
network map definition for a given node.

A numeric value from 1–255 for the
server version of Connect:Direct for
Windows. The default is 1 for the
server version. The workstation
version of Connect:Direct for
Windows is limited to 2 SNODE
sessions.

TCQ Startup Specifies how the Connect:Direct server program
starts with respect to the TCQ.

Warm to retain all existing Processes
in the TCQ at server startup. If you
select a warm start, all Processes in
executing state when the server was
stopped will restart when the server
is restarted. Cold to delete all existing
Processes in the TCQ at startup.

TCQ Max Age Specifies the maximum number of days a Process
with Held due to Error (HE) status remains in the
TCQ before it is automatically deleted.

A numeric value from 0–30. The
default is 30 days. Connect:Direct
does not automatically delete
Processes when you specify 0.

Stat Max Age Specifies the maximum age (in days) that statistics
records are allowed to reach before the system
automatically deletes them.

A numeric value from 0–30. The
default is 7 days. Connect:Direct
does not automatically delete
statistics records when you specify 0.

6. Click the API tab. If necessary change the default values of API fields. Refer to the following
table for a description of the fields:

Field Name Definition Valid Values

Enable TCP/IP API
Support

Enables TCP/IP API support. enabled | disabled

API IP Address Specifies the IP address that the Connect:Direct
Requester or user-written API programs use to
establish client sessions with the Connect:Direct
server.

API Additional Addresses and Ports

A numeric value in the format
nnn.nnn.nnn.nnn (IPv4) or
nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:n
nnn:nnnn (IPv6), or the host name.

API Port Specifies the port number that the Requester or
user-written API programs use to establish client
sessions with this Connect:Direct server.

A numeric value in the format nnnn,
where nnnn is a positive integer from
0 to 65535.

The default is 1363.

API Additional
Addresses and Ports

Specifies additional addresses and ports that the
Connect:Direct Requester or user-written API
programs use to establish client sessions with this
Connect:Direct server. Multiple address/host
names (and combinations with port numbers) can
be specified in this field. The port is separated from
its corresponding address/host name with a semi-
colon (;), and each address/host name and port
combination is separated by a comma (,). A space
may be added after the comma for readability.

A numeric value in the format
nnn.nnn.nnn.nnn;nnnn (IPv4) or
nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:n
nnn;nnnn (IPv6), or the host
name;nnnn.

For example, 10.20.9.175;2363,
fd00:0:0:2014::7; 2364

This is an optional field.
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Field Name Definition Valid Values

Host Additional
Addresses and Ports

Specifies additional IP addresses and ports for
incoming communications from remote
Connect:Direct nodes to this Connect:Direct
server node. Multiple address/host names (and
combinations with port numbers) can be specified
in this field. The port is separated from its
corresponding address/host name with a semi-
colon (;), and each address/host name and port
combination is separated by a comma (,). A space
may be added after the comma for readability.

A numeric value in the format
nnn.nnn.nnn.nnn;nnnn (IPv4) or
nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:n
nnn;nnnn (IPv6), or the host
name;nnnn.

For example, 10.20.9.175:2364,
mdallas;1364

This is an optional field.

Enable Dynamic
Addressing (DHCP)

Enables dynamic addressing, so that the DHCP
server will assign an IP address when it is
requested for the Connect:Direct server node.

Disabled | Enabled

7. Click the TCP/IP tab. If necessary change the default values of TCP/IP fields. Refer to the
following table for a description of the fields:

Field Name Definition Valid Values

Enable TCP/IP Support Enables TCP/IP support. enabled | disabled

Host IP Address Specifies the IP address for incoming
communications from remote Connect:Direct
nodes to this Connect:Direct server node.

A numeric value in the format
nnn.nnn.nnn.nnn (IPv4) or
nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:n
nnn:nnnn (IPv6), or the host name.

Host Port Specifies the port number for incoming
communications from remote Connect:Direct
nodes to this Connect:Direct server node.

A numeric value in the format nnnn,
where nnnn is a positive integer from
0 to 65535.

The default is 1364.

Host Additional
Addresses and Ports

Specifies additional IP addresses and ports for
incoming communications from remote
Connect:Direct nodes to this Connect:Direct
server node. Multiple address/host names (and
combinations with port numbers) can be specified
in this field. The port is separated from its
corresponding address/host name with a semi-
colon (;), and each address/host name and port
combination is separated by a comma (,). A space
may be added after the comma for readability.

A numeric value in the format
nnn.nnn.nnn.nnn;nnnn (IPv4) or
nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:n
nnn;nnnn (IPv6), or the host
name;nnnn.

For example, 10.20.9.175:2364,
mdallas;1364

This is an optional field.

Buffer Size Specifies the data buffer size for transmitting data
to and from a remote Connect:Direct node if the
value is not in the network map entry. The value
entered in the Buffer Size field of the network map
TCP/IP Communication Mode object overrides
this value.

A numeric value from 256–65536.

The default is 65535.

Enable Dynamic
Addressing (DHCP)

Enables dynamic addressing, so that the DHCP
server will assign an IP address when it is
requested for the Connect:Direct server node.

Disabled | Enabled

8. Click the UDT tab. If necessary change the default values of UDT fields. Refer to the following
table for a description of the fields:

Field Name Definition Valid Values

Enable UDT33 Support Enables UDT33 support. enabled | disabled
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Field Name Definition Valid Values

Host IP Address Specifies the IP address for incoming
communications from remote Connect:Direct
nodes to this Connect:Direct server node.

A numeric value in the format
nnn.nnn.nnn.nnn (IPv4) or
nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:n
nnn:nnnn (IPv6), or the host name.

Host Port Specifies the port number for incoming
communications from remote Connect:Direct
nodes to this Connect:Direct server node.

A numeric value in the format nnnn,
where nnnn is a positive integer from
0 to 65535.

The default is 1364.

Host Additional
Addresses and Ports

Specifies additional IP addresses and ports for
incoming communications from remote
Connect:Direct nodes to this Connect:Direct
server node. Multiple address/host names (and
combinations with port numbers) can be specified
in this field. The port is separated from its
corresponding address/host name with a semi-
colon (;), and each address/host name and port
combination is separated by a comma (,). A space
may be added after the comma for readability.

A numeric value in the format
nnn.nnn.nnn.nnn;nnnn (IPv4) or
nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:n
nnn;nnnn (IPv6), or the host
name;nnnn.

For example, 10.20.9.175:2364,
mdallas;1364

This is an optional field.

Buffer Size Specifies the data buffer size for transmitting data
to and from a remote Connect:Direct node if the
value is not in the network map entry. The value
entered in the Buffer Size field of the network map
UDT Communication Mode object overrides this
value.

A numeric value from 256–65536.

The default is 65535.

Enable Dynamic
Addressing (DHCP)

Enables dynamic addressing, so that the DHCP
server will assign an IP address when it is
requested for the Connect:Direct server node.

Disabled | Enabled

9. Click the SNA tab. If necessary, change SNA field values. Refer to the following table for a
description of the SNA fields:

Field Name Definition Valid Values

Enable SNA Support Enables SNA support. Enabled or Disabled

If SNA is activated at installation, the
default value is enabled.

Local LU Name Specifies the Local LU name for the Connect:Direct
server node.

Local LU Name

If you want to monitor multiple LU’s,
leave this field blank. The default
value is the local LU name.

10. Click the Database tab.

11. Click Modify Settings to invoke the Database Wizard utility. Use the utility to configure the
ODBC and database environments.

12. Select one of the following database types:

• MySQL
• Microsoft SQL Server

13. If you selected MySQL as the database:
• Identify the TCQ/Stats data source in the TCQ/Stats Datasource field.
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• Identify the data source for message in the Message Datasource field.
• Identify the name of the database in the Database Name field.
• Identify the name of the host in the Host Name field.
• Identify the port number in the Port field.
• Type the system administrator login information including user ID and password in the fields

provided.
• Click Next.

14. If you selected Microsoft SQL server:
• Identify the TCQ/Stats data source in the TCQ/Stats Datasource field.
• Identify the data source for message in the Message Datasource field.
• Identify the database name in the Database Name field.
• Do one of the following to specify the SQL server:

• Type the name of the SQL server
• Select the name of the SQL server from the pull-down list. Any local instance names

found on the system are listed.
• Click (...) to select a SQL server from the network. Any SQL servers running in the

Windows domain are listed, which may include local instance names.

15. When you validate the information entered, click Finish.

16. Click Yes to build the database.

17. Click OK.

18. If you want to update the license management key:
• Click the License Management tab.
• Select the new license management key.

19. Click OK.

Work with Active Directory
When you install Connect:Direct on a computer, you can add the node to Active Directory during the
installation. However, you can use the Admin Tool to add or delete Active Directory entries after the
initial installation.

You can also view or print a report that lists all nodes that are registered in Active Directory. In order
to add or delete a node from Active Directory, you must be a member of the Enterprise Admins group.

Note: You can only add or delete Active Directory entries if Active Directory services have
been implemented in your environment.

Add an Active Directory Entry

To add a node entry to Active Directory:
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1. Start the Admin Tool utility.

2. Select Active Directory > Create.

3. Select the node to add and click Add.

Delete an Active Directory Entry

To delete a node entry from Active Directory:

1. Start the Admin Tool utility.

2. Select Active Directory > Delete.

3. Select the node to delete and click Remove.

Create an Active Directory Report

To create a report that identifies all nodes registered in Active Directory:

1. Start the Admin Tool utility.

2. Select Active Directory > Report.

The Active Directory Report is displayed.
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Troubleshoot Connect:Direct

Diagnose a Server Problem Using Traces
If you have a problem with a server, you can start a trace. A trace provides detailed information about
Connect:Direct activity and assists in diagnosing problems related to Connect:Direct operations. The
trace facility writes this information to a file. You can set the size of the output file and specify a wrap
if the file reaches its maximum size.

You can set a trace to one of the following levels:
• A basic trace to capture the function entry and exit only.
• An intermediate trace to capture the function argument and its start and stop.
• A full trace to capture internal control blocks and the function argument, start, and stop.

The trace timestamp is specified in microseconds to pinpoint server activity with greater precision.

You can create a trace using Requester or the CLI.

Refer to Traceoff Command and Traceon Command in the Submit a Process Using the Command Line
Interface section for instructions on using the CLI to define or turn off traces.

Define a Trace

To define a Connect:Direct trace:

1. Start Requester.

2. Select Admin > Tracing.

3. To set trace information for selected functions, turn on tracing for the specific Connect:Direct
events.

• CMGR—Capture the interaction between clients and the server.
• PMGR—Capture server Process changes.
• MAIN—Capture server initialization and termination.
• STAT—Capture statistics activity.
• SMGR—Capture the execution of Processes and the interaction of the server with other

nodes.
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• COMM—Capture interactions with external communications facilities invoked from
Session Manager.

4. To set tracing for all available events, click Full Tracing.

5. Generate a configuration report is selected by default. If you do not want to generate a
configuration report, turn off this option.

6. To specify output file information:
• Click the File tab.
• Enter the output file name. Do not select the name of an active trace file. A file can only be

used for one trace at a time. The default file name is CDTRACE.CDT.
• Enter the maximum file size allowed in the Max Size field. Select Kilobytes or Megabytes to

specify the size unit.
• Wrap tracing output when max file size is reached is selected by default. If you do not want

the tracing output to wrap when the maximum file size is reached, turn off this option.

7. Click OK.

Stop a Trace

To stop a trace:

1. Select Admin > Tracing.

2. Set the trace that you want to stop to OFF.

3. Click All Off to turn off all tracing.

4. Click OK.

Trace Startup Parameters
The following startup parameters for Connect:Direct traces are all optional:
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Parameter Description and Options

-ttyp= Specifies the type of trace to start during initialization. You must provide this parameter in
order to generate any trace output. Any combination of the following options is valid.

c — Starts a Command Manager trace. This trace affects all Command Managers started
on behalf of users logging in to the Connect:Direct for Windows server. It shows both the
command processing flow and the interactions between the server executable and the
Connect:Direct for Windows.

p — Starts a Process Manager trace. This trace shows all events related to the Process
Manager and to Session Manager startup by the main server executable.

s — Starts a Session Manager trace. This trace shows all Session Manager processing,
including file and communications API access, but does not display information that is sent
across the communications line. If you do not specify any further qualifying parameters,
the system traces all Session Managers.

o — Starts a Communications trace. This trace shows all the communications data that
flows across the network between the local and remote Connect:Direct Session Managers.

m — Starts a trace of the main-line logic that includes initialization and termination.

a — Starts a trace of the Statistics subsystem. This trace shows all records sent to the
Statistics thread.

x — Starts all trace types. Specifying a value of x is the same as specifying cpsoma.

-tlvl= Specifies the trace level. The values are:

b — Starts a basic trace that includes only module entry and exit records. This is the default.

i — Starts an intermediate trace that shows all trace data produced by b plus function
arguments.

f — Starts a full trace that shows all trace data produced by i plus certain Connect:Direct
control blocks and internal information.

-twrp Specifies that the trace file should wrap once it reaches its maximum size.

-tfil=filespec Specifies the fully qualified name of the trace file that receives output. The default is
CDTRACE.CDT in the directory where the Connect:Direct for Windows server executable
resides. Windows Services treats a backslash (\) as an escape character, so type two
backslashes for each backslash in the file path.

Example:

-tfil=c:\\users\\default\\trace.it

-tfsz= Specifies the maximum file size the trace file can reach before it wraps if -twrp is also
specified. If -twrp is not specified, -tfsz indicates that the trace file will terminate when it
reaches this size.

The default is -tfsz=100K.

bytes: You can specify the file size in bytes.

bytesK: You can specify the file size by using the K (x1000) suffix.

bytesM: You can specify the file size by using the M (x1000000) suffix.

For Session Manager (s) or Communications (o) trace types, the following parameters are also
available:
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Parameter Description Options

-tpnum= Requests a trace of up to eight Process numbers upon the initiation of the Process. If you
specify -tpnum, Connect:Direct will only trace the specified Processes.

pnum: Process number.

(pnum1,pnum2,...,pnum8): Trace of up to eight Process numbers.

-tpnam= Requests a trace of up to eight Process names upon the initiation of the Process. If you
specify -tpnam, Connect:Direct will only trace the specified Processes. Arguments are:

pnam: Process name.

(pnam1,pnam2,...,pnam8): Trace of up to eight Process names.

-tdest= Requests a trace of up to eight Connect:Direct remote node names that have interaction
with this local node. This parameter generates trace information when Connect:Direct
submits a Process that is destined for the specified remote node or when the specified
remote node establishes a sessionam with this local node. If you specify -tdest,
Connect:Direct will only trace the specified remote node names.

dest: Destination node name.

(dest1,dest2,...,dest8): Trace of up to eight destination node names.

-tlnode=

or

-tpnode=

Requests a trace of initiating node sessions only. This parameter modifies the effect of the
-tpnam, -tpnum, and -tdest parameters by allowing only traces of Processes submitted on
the local node.

Note: Connect:Direct for Windows also supports -tpnode in place of -tlnode.

-trnode=

or

-tsnode=

Requests a trace of remote node sessions only, that is, a session initiated by a remote
node. This parameter modifies the effect of the -tpnam, -tpnum, and -tdest parameters by
allowing only traces of Processes submitted on remote Connect:Direct nodes.
Note Connect:Direct for Windows also supports -tsnode in place of -trnode.

Recover from a Problem
Connect:Direct provides several ways to recover from a system malfunction, such as an abnormal
termination of a connection between local and remote Connect:Direct nodes. Process recovery enables
you to resume execution as quickly as possible and to minimize redundant data transmission after a
system failure.

Connect:Direct uses the following facilities to address errors for Process recovery:
• Process step restart
• Automatic session retry
• Checkpoint/restart
• Run Task restart

Process Step Restart
As a Process executes, Connect:Direct records the step that is executing in the TCQ. If Process
execution is interrupted, the Process is held in the TCQ in retry (RE) status, unless you explicitly delete
the Process with the Hold parameter set to No. After all attempts to restart have failed, the Process
goes into Held due to Error (HE) status. When a wildcard copy command restarts, it restarts at the file
that was being copied when the Process was interrupted.
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When you release the Process for execution, Connect:Direct automatically begins execution at the
beginning of that statement. No user specification is required for Process step restart. Connect:Direct
always performs Process step restart.

Automatic Session Retry
The network map remote node object has short-term and long-term connection retry parameters. If no
value is specified for these parameters, the default values are taken from the initialization parameters
file.

Short-term parameters allow a quick succession of retry attempts in the event of a short-term connection
failure. Long-term parameters are used after the number of short-term attempts you specify has been
reached. The assumption is that the connection problem cannot be fixed quickly; therefore,
Connect:Direct can retry infrequently to save the overhead of connection retry attempts.

If a session error occurs, the Process moves to the Timer queue in retry (RE) status and short-term and
long-term wait times begin. After short-term and long-term wait times expire, the Process is moved to
the Hold queue.

The tcq.max.age initialization parameter specifies the maximum number of days a Process with a Held
due to Error (HE) status remains in the TCQ before it is automatically deleted.

Checkpoint/Restart
Checkpoint/restart is specific to the Process copy statement. Connect:Direct records file positioning
checkpoint information at specified intervals during a copy operation. If a copy step is interrupted for
any reason, it can be restarted at the last checkpoint position.

Note: Connect:Direct must support checkpoint/restart on both the local and the remote node.

The file sender provides positioning information to the receiver when a checkpoint interval is reached.
The receiver stores this information, along with its destination file positioning information, in the
checkpoint file. The last four sets of positioning information are retained in the checkpoint file. At
restart, each set of information is used until the file is successfully repositioned. If repositioning fails,
then the entire file is retransmitted.

Checkpoint Parameter for the copy Statement
The checkpoint parameter in the Process copy statement specifies the byte interval at which checkpoints
are taken.

Note: See the Connect:Direct Process Guide for use of the checkpoint parameter in the copy
statement.

A checkpoint value of No disables checkpointing. If you do not specify a checkpoint value in the copy
statement, the default is defined by the checkpoint interval initialization parameter, ckpt.interval.

Restart during Run Task Operations
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Connect:Direct for Windows provides checkpoint/restart capabilities with the run task Process
statement. If a run task operation is executing on the SNODE and a session failure occurs, the PNODE
recognizes the session failure and puts the Process in the Timer queue for retry. The SNODE, however,
is still running the run task operation and is not notified of the session failure until the operation finishes.
The checkpoint/restart feature for run task ensures that when the Process restarts on the PNODE, the
run task operation does not execute a second time on the SNODE.

Restart Process Operations
If a run task Process step restarts, the node where the operation executes attempts to find the checkpoint
information in the TCQ header. If the run task step is still executing, the Process that is running for the
restart of the step waits for the run task operation to finish the first task and proceed to the next step of
the Process, if there is one.

When the first Process finishes, it determines that the session under which it was running has been lost
and terminates without logging statistics records that indicate a session failure. The second Process
records how the run task step that was still executing ended and proceeds to the next step in the Process.

Determine Reexecution of the Run Task Step
If Connect:Direct determines at restart that the run task operation ended because it finished before the
PNODE restarted the Process, then the run task step does not execute again. However, if the run task
operation did not finish and is not currently running, then the value of the runtask.restart initialization
parameter determines whether to restart the Process.

If runtask.restart=yes, Connect:Direct executes the program again. If runtask.restart=no, the Process
skips the run task step.

Note: For a full description of all run task statement parameters, go to the Connect:Direct
Processes Web site at http://www.sterlingcommerce.com/documentation/processes/
processhome.html.

Work with Sterling Commerce Support to Troubleshoot
Connect:Direct Problems
Before calling Sterling Commerce Support, gather information to help support personnel analyze and
troubleshoot your problem. Have the following information available when you call:
• Network map parameter definitions
• Initialization parameter definitions
• Statistics report
• For SNA sites, gather the following:

• If you are using Microsoft SNA software, type snacfg/print>snacfg.dat from a
command prompt.

• If you are using IBM Communications Server SNA software, open filename.acg, where
filename is the name specified during Communications Server installation.

If you are troubleshooting a Connect:Direct for z/OS server, gather the following information:
• Network map parameter definitions
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• Local Node source
• Remote Node source
• For SNA connectivity, provide the following:

• z/OS LU definition
• z/OS PU definition
• z/OS APPLID
• z/OS LOGMODE definition entry
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Worksheets

Network Map Communications Mode Object Worksheet
The communications mode object defines the protocol and characteristics of sessions that are
established using this mode group. Use the information on this worksheet when you create or modify
a Communication Mode in your network map.

Note: See Define and Manage the Connect:Direct Network for field content.
Make a copy of this worksheet for each communications mode in the network.

Commmunications Mode Information Needed

TCP/IP Communications Mode Name

Buffer Size

Pacing Send Count

Pacing Send Delay

CRC

UDT Communications Mode Name

Buffer Size

CRC

APPC Communications Mode Name

Max RU Size

Max Pacing Size

Max Sessions

Network Map Communications Path Object Worksheet
The communication path object defines the communications path between the local node and one or
more remote nodes. Use this worksheet when you create a communications path in your network map.

Note: See Define and Manage the Connect:Direct Network for field content.

Make a copy of this worksheet for each communications path in the network.
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Communications Path Information Needed

TCP/IP Communication Path Name

Communications Mode

UDT Communication Path Name

Communications Mode

APPC Communications Path Name

Communications Mode

Transport Type

Token Ring or Ethernet

• Adapter Number

• Primary

• Alternate

• Address

SDLC

• Local SNA Network

• LU Name

Network Map Remote Node Object Worksheet
The Remote Node object provides information about remote nodes to which the local node establishes
sessions or that establish sessions with the local node.

Use the information on this worksheet when you modify your network map. See Define and Manage
the Connect:Direct Network for field content.

Make a copy of this worksheet for each remote node.

Note: The components below correspond to the tabs on the Netmap Node Properties dialog
box.

Network Map
Component

Information Needed

Main Options Node Name

Operating System

Maximum Concurrent Local Node Session

Maximum Concurrent Remote Node Session

Default Class

Short Term Number of Retries

Interval (Time Between Retries)

Long Term Number of Retries

Interval (Time Between Retries)
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Network Map
Component

Information Needed

TCP/IP Information Host Name/IP Address

Port Number/Service Name

TCP/IP Communication Mode Name

Alt Comm Outbound (Alternate Outbound Addresses)

Alternate Comminfo (Alternate Netmap-Checked Addresses)

UDT Information Host Name/IP Address

Port Number/Service Name

UDT Communication Mode Name

Alt Comm Outbound (Alternate Outbound Addresses)

Alternate Comminfo (Alternate Netmap-Checked Addresses)

APPC Information Network Name

Partner LU Name

APPC Mode

Communications Path Communications Path Names

Note: You must designate at least one path.

Description Information Contact Name

Contact Phone Number

Comment different field names s- Node description

User Functional Authorization Worksheet
User Functional Authorizations control the user’s right to issue various Connect:Direct commands and
statements or perform tasks through the Connect:Direct Requester. Use this worksheet when making
updates to the functional user authorization object in the Registry.

See Configure the Local Node for field content. Make a copy of this worksheet for each Connect:Direct
user.

Type of Authorization
Information

Information Needed

Main Options Local User ID

Default User Type (choose one):

• General User

• Administrator

Administrative Indicate whether the administrator has the authority to update the following:

• User Authorizations

• Upload

• Remote User Proxies

• Download
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Type of Authorization
Information

Information Needed

Directory Restrictions Specify the directory where you are allowed to perform the specific tasks. If you
do not specify a directory, you can perform the specific task from any directory
to which the Windows security enables access. This authority is effective
regardless of whether the request is submitted from the local or remote system.
However, the remote user proxy can override the directory specification.

• Upload Directory

• Download Directory

• Process Directory

• Program Directory

Server Control Grants authority to perform the following tasks in Connect:Direct:

• Stop (Connect:Direct)

• Refresh (initialization parameters)

• Trace

• Update Network Map

• Update Translation Table

Statements Authorization Grants authority to use the following statements in Connect:Direct Processes:

• Trace

• Copy

• Run Job

• Run Task

• Submit

Process Control Submit Grants authority to manipulate and observe Processes in the TCQ.

No Yes All

Monitor

Change

Delete

Statistics

Overrides Authorization Grants authority to override the following Windows defaults:

• Execution Priority

• ACL Updates

• File Attributes

• Remote Node ID

• CRC

Remote User Proxy Worksheet
The Remote User Proxy object defines a relationship between a remote node and a local user ID.

Note: See Configure the Connect:Direct Local Node.
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Make a copy of this worksheet for each Connect:Direct Remote User Proxy you want to define.

Type of Authorization
Information

Information Needed

Main Options Remote Node Name

Remote User ID

Local User ID

Local User ID Password

Allow the remote user to:

• Upload

• Download

Directory Options Specify the directory where the remote user can perform tasks. The directory
properties allow you to restrict the Process directory and data directories that
remote users can access. If you do not specify a directory, the directories
specified in the functional authorization for the local user account will apply. If
there are no directories specified in the local user functional authorizations, the
remote user can perform the specific task from any directory that the server
security enables access to.

Upload Directory

Download Directory

Process Directory

Program Directory
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Change Connect:Direct Settings

Change Connect:Direct for Windows Settings
When you install Connect:Direct for Windows, initialization parameters are created in the Windows
registry and are used to determine settings at initialization. Initialization parameters (also called
initparms) set the default values of Connect:Direct functions.

Initparms determine how Connect:Direct behaves during operation. You can change the default
Connect:Direct for Windows settings by changing the value of these parameters.

Initialization parameters are organized in the following groups:

Category Description

Miscellaneous Miscellaneous commands describe server path, download and upload
directories, dialup entries, and security exits.

Statistics Information Statistics settings determine the maximum age that statistics records are kept
and what commands are logged in the statistics file.

TCQ Information TCQ settings determine default values for the Process file directory, remote
node run task operations, the length of time a Process is held in error, and how
the TCQ handles Processes during server startup.

Global Copy Parameters Global copy settings determine default checkpoint intervals, translation tables
and translation directories.

Local Node Characteristics Node settings define the name of the local node, and determine default values
for functions such as session class, maximum connections, maximum API
connections, buffer sizes, and short- and long-term attempts and retries.

Sample Initialization Parameters Format
The following figures illustrate the format of the initialization parameters. The initialization parameters
are listed in groups that are labeled in brackets.

The example below shows the miscellaneous parameters:
[Miscellaneous Commands]
server.path=C:\Program Files\Sterling Commerce\Connect Direct v4.5.00\Server\
proc.prio.default=10
exec.prio.default=7
license.management.key=LicEmerg.txt
download.dir=C:\Program Files\Sterling Commerce\Connect Direct v4.5.00\Server
\DOWNLOAD\
upload.dir=C:\Program Files\Sterling Commerce\Connect Direct v4.5.00\Server\UPLOAD\
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program.dir=C:\Program Files\Sterling Commerce\Connect Direct v4.5.00\Server
\PROGRAM\
restrict.cmd=N
security.exit=<None>
notify.level=A
file.exit=<None>
event.log=All 
snmp=N
snmp.eventlog=N
snmp.trapstat=Nsnmp.dsn=C:\Program Files\Sterling Commerce\Connect Direct 
v4.5.00\Server\snmp\snmp.ini

The example below shows the local node parameters:
[Local Node Characteristics]
max.api.connects=10
conn.retry.stwait=00:00:10
conn.retry.stattempts=10
conn.retry.ltwait=00:03:00
conn.retry.ltattempts=10
contact.name=not specified
contact.phone=not specified
descrip=no description specified
name=CDSWIFTNET-4500
sess.pnode.max=1
sess.snode.max=1
sess.default=1
netmap.check=Y
node.check=B
proxy.attempt=N
protocol=1
tcp.api.port=cdswiftnet;4463
tcp.host.port=cdswiftnet;4464
outgoing.address=<None>
tcp.src.ports=<None>
tcp.src.ports.list.iterations=1
comm.bufsize=65535
pacing.send.delay=00:00:00
pacing.send.count=0
tcp.crc=OFF
tcp.crc.override=N
tcp.max.time.to.wait=00:03:00
tcp.window.size=0
runstep.max.time.to.wait=00:00:00
active.directory.enabled=N
quiesce.resume=N

The example below shows the parameters related to the Transmission Control Queue (TCQ):
[TCQ Information]
tcq.max.age=30
tcq.start=W
process.dir=C:\PROGRAM FILES\STERLING COMMERCE\CONNECT DIRECT V4.5.00\SERVER
\PROCESS\
runtask.restart=N

The example below shows the Global Copy parameters:
[Global Copy Parameters]
ckpt.interval=10240K
xlate.dir=C:\PROGRAM FILES\STERLING COMMERCE\CONNECT DIRECT V4.5.00\SERVER\XLATE\
xlate.send=XLATESND.CDX
xlate.recv=XLATERCV.CDX
disable.cache=N
continue.on.exception=N
ecz.cmprlevel=1
ecz.windowsize=13
ecz.memlevel=4
strip.blanks=I
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record.wrap=N
retry.msgids=<None>
retry.codes=<None>

The example below shows the parameters related to statistical information:
[Statistics Information]
stat.max.age=7
log.select=N
log.commands=Y
stat.sort=Y

Change Initialization Parameters

You can change the Connect:Direct for Windows initialization settings by editing the initialization
parameters.

1. Click Start > Programs > Sterling Commerce Connect:Direct v4.5.00 > CD Requester.

2. In CD Requester, select Admin > Initialization Parameters. If you have not attached to
Connect:Direct, the Connect:Direct Attach dialog box is displayed.

3. Attach to the server.

4. In the initialization parameters file, place the cursor after the equal sign following the parameter
you want to change.

5. Type the new value. Refer to the parameters tables for the name, definition, and valid values for
each command parameter.

6. Select Apply from the Initparms menu to update and save changes.

7. Close the Initparms dialog box by clicking the X in the upper-right-hand corner.

Miscellaneous Parameters
The miscellaneous parameters determine the server path, default Process priority, event log values,
and various restricted directories.

The following table lists the miscellaneous commands parameters:

Parameter Name Description Valid Values

server.path The fully qualified path name to all
Connect:Direct files. Terminate the path name
with a trailing backslash (\).

If you do not provide this parameter, all
subdirectories necessary for Connect:Direct
operation must be located in the directory
where Connect:Direct for Windows was
installed.

Valid, fully qualified path name.
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Parameter Name Description Valid Values

proc.prio.default The default Connect:Direct Process priority
information to assign any time a Process is
submitted without the selection priority
parameter (selprty) on the Process statement.

A numeric value from 1 to 15,
where 15 is the highest priority.

The default is 10.

exec.prio.default The priority of the Process. The execution
priority parameter is used to influence the
Windows operating system priority given to the
Session Manager when it begins execution of
this Process. A Process with a higher priority
is assigned a higher operating system priority
and receives more system resources.
Note Scheduling Processes with a high

execution priority value can affect the
execution of other applications on the
system.

A numeric value from 1 to 15,
where 15 is the highest priority.

The default is 7.

These values are mapped to
Windows Process priority
classes and values.

license.management.key The name of the license file. If the value is set
to NA or is empty, the default of license.key is
used.

Name of key file | NA | empty
field

download.dir The default directory to copy the destination file
to if a copy statement does not specify a fully
qualified path.

Valid, fully-qualified path name.
The default is X:\installation
directory\DOWNLOAD

upload.dir The default directory that source files are
copied from if a copy statement does not
specify a fully qualified path.

Valid, fully-qualified path name.
The default is X:\installation
directory\UPLOAD

program.dir The default working directory for a program
started using a run task or run job statement
when a fully qualified path is not specified.

Valid, fully-qualified path name.
The default is X:\installation
directory\PROGRAM

restrict.cmd Restricts the use of operating system
commands in run task or run job statements by
preventing use of the “CMD” syntax in those
statements. In addition, it prevents the use of
the special characters: “&”, “|”, and “>”.

To enable running of cmd tasks and the use of
special characters, specify N.

Y | N

The default is N.

security.exit Specifies whether a security exit is
implemented as a user exit during Process
execution. See the Connect:Direct for
Windows SDK Guide for details as presented
in the sample user exit program
userexit_samp.c.

Valid, fully qualified path name
to a user-defined DLL. The
default is <NONE>.

notify.level The level of Process notification based on the
Process step return code. If you want
notification to occur regardless of the return
code, specify a value of A.

Specify a value of W for a warning-level return
code greater than 0. Specify a value of E for an
error-level return code greater than 4.

A | W | E

The default is A.
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Parameter Name Description Valid Values

file.exit The name of a user-written dynamic link library
(DLL) file. The DLL file opens a source or
destination file during processing of the COPY
statement and overrides the values specified
in the COPY statement. If the DLL file is not in
the search path, a fully qualified path name
must be specified.

Valid, fully qualified path name
to a user-defined DLL. The
default is <NONE>.

event.log The statistics IDs the system sends to the
Windows event log. Either specify a list of
statistics IDs or select All to log all IDs to the
event log. Use a comma to separate IDs in a
list.

Refer to View Process Statistics for a list of
statistics IDs.

statistics ID | All | (list)The
default is All.

snmp Causes the SNMP trap agent environment to
be initialized.

N | Y

The default is N.

snmp.eventlog Initializes the SNMP event logging
environment.

N |Y

The default is N.

snmp.dsn Defines the configuration file used to initialize
the default traps variables.

configuration file

The default is installation
directory\snmp\snmp.ini.

snmp.trapstat Defines the configuration file used to
determine if the SNMP traps are written to the
statistics file.

N | Y

The default is N.

Local Node Parameters
The local node characteristics parameters define the name of the local node and default information
used to communicate with a remote node.

The following table identifies the local node characteristics parameters:

Parameter Name Description Valid Values

max.api.connects The maximum number of concurrent API client
connections permitted for the local node by
different user IDS. There is no limit to the
number of API connections by a single user ID.

A numeric value from 1 to 255. The
default is 10.

conn.retry.stwait The time to wait between retries immediately
after a connection failure occurs. The value
entered in the Short Term Retry Interval field of
the network map remote node object overrides
this value.

A 24-hour time value formatted as
hh:mm:ss. The maximum value is
23:59:59. The default is 00:00:10, or
10 seconds.

conn.retry.stattempts The number of times to attempt connection after
a connection failure occurs. The value entered
in the Short Term Retry Count field of the
network map remote node object overrides this
value.

A numeric value from 0–9999. The
default is 10.
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Parameter Name Description Valid Values

conn.retry.ltwait The time to wait between long-term retry cycles.
This parameter is a long-term connection retry
parameter. The value entered in the Long Term
Retry Interval field of the network map remote
node object overrides this value.

A 24-hour time value formatted as
hh:mm:ss. The maximum value is
23:59:59. The default is 00:03:00, or
3 minutes.

conn.retry.ltattempts The number of times to attempt connection after
a connection failure occurs. This parameter is a
long-term connection retry parameter. The
value entered in the Long Term Retry Count
field of the network map remote node object
overrides this value.

A numeric value from 0–9999. The
default is 10.

contact.name The name of a contact. Any name description.

contact.phone A phone number to use to contact the contact
name.

Any valid phone number.

descrip The description of the local node. Any valid text string.

name The name of the local node used when
identifying the local server to remote nodes and
the server object name for which API programs
search when locating active Connect:Direct
servers. You cannot change the value of this
parameter. If you want to change the local node
name, you must reinstall Connect:Direct for
Windows.

A 1- to 16-character alphanumeric
string specified during installation.

sess.pnode.max The maximum concurrent connections for all
remote nodes where the local Connect:Direct
Windows server node is the originator of the
Connect:Direct Windows Process.

This field is limited to the lesser of the values
defined in the initialization parameters file and
the network map definition for a given node.

A numeric value from 1 to 255. The
default value is 1 or half of the
maximum sessions specified during
installation. The workstation version
of the product is limited to a maximum
of one PNODE session.

sess.snode.max The maximum concurrent connections for all
remote nodes where the local node is the
partner node of a Process.

This field is limited to the lesser of the values
defined in the initialization parameters file and
the network map definition for a given node.

A numeric value from 1 to 255. The
default value is 1 or half of the
maximum sessions specified during
installation. The workstation version
of the product is limited to a maximum
of two SNODE sessions.

sess.default The default session class for starting session
managers. A Process executes on the specified
class or any higher session class. If the value
specified exceeds sess.pnode.max, a warning
is issued and the value is reset to the default
value. The value entered in the Default Class
field of the remote node object overrides this
value.

A numeric value from 1 to the value
specified for sess.pnode.max.

The default is 1.
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Parameter Name Description Valid Values

netmap.check The level of network map checking that occurs
for each node that you communicate with.

• Y—Checks the network map for all
nodes that Connect:Direct will
communicate with to validate the node
name and the IP address.

• L—Checks the network map only for
nodes that the local Connect:Direct will
initiate sessions with.

• R—Checks the network map only for
remote nodes that will communicate
with this node.

• N—Does not validate any session
establishment requests in the network
map.

Y | L | R | N

The default is Y.

node.check The level of node checking.
A—Checks node address only.

B—Checks both node address and node name.

C—Checks node name only.

A | B | C

The default is B.

proxy.attempt Enables the use of a proxy user ID for a remote
node. The use of a proxy user ID offers
improved security because neither the local
system nor the remote system requires a real
user ID from the other side.

Y | N

The default is N.

protocol The communications protocol or protocols to be
used by the local node. If more than one,
separate entries with commas.

TCP | UDT33 | APPC

TCP—Specifies TCP/IP. This is the
default.

UDT33—Specifies UDT protocol.

APPC—Specifies APPC protocol.

tcp.api.port One or more IP addresses (or host name) and
optional port numbers used to establish client
sessions with this Connect:Direct node.

[IP address | hostname][;port
number]

The default port number is 1363.

See Specifying IP Addresses, Host
Names, and Ports.

tcp.host.port One or more IP addresses (or host name) and
port numbers that remote Connect:Direct nodes
will connect to for Process execution with this
local Connect:Direct for Windows node.

One or more IP addresses (or host names) and/
or port numbers that remote Connect:Direct
nodes will connect to for Process execution with
this local Connect:Direct for Windows node.
You can specify IP address/hostname, IP
address/hostname and port, or just a port.

[IP address | hostname][;port
number]

The default port number is 1364.

See Specifying IP Addresses, Host
Names, and Ports.

udt.host.port One or more IP addresses (or host name) and
port numbers that remote Connect:Direct nodes
will connect to for Process execution with this
local Connect:Direct for Windows node.

[IP address | hostname][;port
number]

The default port number is 1364.

See Specifying IP Addresses, Host
Names, and Ports.
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Parameter Name Description Valid Values

outgoing.address A virtual IP address for adjacent nodes in a
cluster (in a high-availability environment) to
use for netmap checking by the remote node.

In a Connect:Direct for Windows high-
availability cluster, each instance of
Connect:Direct for Windows has a separate IP
address and a virtual IP address assigned to the
cluster. After all of the Connect:Direct for
Windows high-availability nodes are configured
to bind to the virtual IP address, remote nodes
see the single virtual address during a session.
If a node in the cluster fails, another high-
availability node takes over. Any remote system
that is using netmap checking will still allow
communications with the high-availability
system.

Be sure remote nodes specify this virtual IP
address in their netmap entries for each node in
the high-availability cluster.

IP address | hostname

See Specifying IP Addresses, Host
Names, and Ports.

tcp.src.ports An IP address or multiple addresses and the
ports permitted for the address when going
through a packet-filtering firewall.

Valid IP address with an optional
mask for the upper boundary of the
IP address range and the associated
outgoing port number or range of port
numbers for the specified IP address,
for example:

(199.2.4.*, 1024), (fd00:0:0:2015:*::*,
2000-3000),
(199.2.4.0/255.255.255.0,
4000-5000),(fd00:0:0:2015::0/48,
6000, 7000)

See Specifying IP Addresses, Host
Names, and Ports.

A wildcard character (*) is supported
to define an IP address pattern. If the
wildcard character is used, the
optional mask is not valid.

udp.src.ports An IP address or multiple addresses and the
ports permitted for the address when going
through a packet-filtering firewall.

Valid IP address with an optional
mask for the upper boundary of the
IP address range and the associated
outgoing port number or range of port
numbers for the specified IP address,
for example:

(199.2.4.*, 1024), (fd00:0:0:2015:*::*,
2000-3000),
(199.2.4.0/255.255.255.0,
4000-5000),(fd00:0:0:2015::0/48,
6000, 7000)

See Specifying IP Addresses, Host
Names, and Ports.

A wildcard character (*) is supported
to define an IP address pattern. If the
wildcard character is used, the
optional mask is not valid.
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Parameter Name Description Valid Values

tcp.src.ports.list.iterations The number of times that Connect:Direct scans
the list of available ports defined in tcp.src.ports
to attempt a connection before going into a retry
state.

This parameter is automatically added to the
initialization parameter and is assigned a value
of 1. If desired, change this value.

A numeric value from 1–255. The
default value is 1.

udp.src.ports.list.iterations The number of times that Connect:Direct scans
the list of available ports defined in
udp.src.ports to attempt a connection before
going into a retry state.

This parameter is automatically added to the
initialization parameter and is assigned a value
of 1. If desired, change this value.

A numeric value from 1–255. The
default value is 1.

comm.bufsize The data buffer size for transmitting data to and
from a remote node. For TCP/IP, this value will
be overridden by the value in the Buffer Size
field of the TCP/IP Communications Mode
Object.

A numeric value from 256 to 65536.

The default is 65535.

pacing.send.delay The default time, in milliseconds, to wait
between send operations if the value is not in
the network map entry. The value entered in the
Pacing Send Delay field of the TCP/IP
Communication Mode object overrides this
value. A value of zero indicates that a data
buffer should be sent as soon as possible.

A numeric value from 0–86,400,000
(one day in milliseconds).

The default is 00.00.00.

pacing.send.count The default number of send operations to
perform before automatically waiting for a
pacing response from the remote node if the
value is not in the network map entry. The value
entered in the Pacing Send Count field of the
TCP/IP Communication Mode object overrides
this value. Specify zero for no pacing.

A numeric value from 0 to 32768.

The default is 0.

tcp.crc Globally turns on or off the CRC function for
TCP/IP processes.

ON | OFF

The default is OFF.

udp.crc Globally turns on or off the CRC function for
UDP processes.

ON | OFF

The default is OFF.

tcp.crc.override Determines whether node and Process
statement overrides for CRC checking are
allowed. If this value is set to n, setting overrides
for CRC checking will be ignored.

Y | N

The default is N.

udp.crc.override Determines whether node and Process
statement overrides for CRC checking are
allowed. If this value is set to n, setting overrides
for CRC checking will be ignored.

Y | N

The default is N.

tcp.max.time.to.wait The maximum time to wait for each pending
TCP/IP Read on node to node communications.
If the value is 0, Reads will not time out.

A 24-hour time value formatted as
hh:mm:ss. The maximum value is
23:59:59. The default is 00:03:00.

udp.max.time.to.wait The maximum time to wait for each pending
UDP Read on node to node communications. If
the value is 0, Reads will not time out.

A 24-hour time value formatted as
hh:mm:ss. The maximum value is
23:59:59. The default is 00:03:00.
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Parameter Name Description Valid Values

tcp.window.size The maximum amount of data in bytes that can
be sent without receiving an acknowledgement.
After a window size of data is sent without
acknowledgement, no more data can be sent
until an acknowledgement is received. When
tcp.window.size=0 (default), the system's
default value is used, which may be too low for
a high-latency, high-bandwidth connection,
causing slow data transfer rates. To improve
performance in this situation, the window size
configured for Connect:Direct for Windows
must be large enough to allow a packet to be
sent and its acknowledgement received without
triggering a wait for an acknowledgement. The
optimum window size is the smallest quantity of
data that does not trigger waits.

In order for this parameter to take effect, ensure
that the following criteria are met:

• RFC1323 support is enabled on the
system.

• The system's maximum TCP window
size is larger than the configured value.

The formula for determining the optimum
window size is as follows:

BDP (bytes) = 125 x <bandwidth (Mb/s)> x
<roundtrip delay in ms>
Note This system configuration must be

done on any Windows system
involved in the transfer, regardless of
whether it is a PNODE or an SNODE.

A numeric value from 0 to
2147483646.

The default is 0.

runstep.max.time.to.wait The maximum time to wait for each pending run
task or run job on node-to-node
communications on the remote node only. If the
value is 0, the run task or run job will not time
out. This parameter prevents a task from being
terminated when the tcp.max.time.to.wait value
is reached. When runstep.max.time.to.wait is
set to 0, tasks running on the remote node never
terminate. When this variable is set to a value,
a task is terminated if the remote task has not
finished the job at the time interval defined.
When a job is terminated, it is placed in the Hold
(HE) queue and no retry effort is attempted. The
statistics error reported is “FMH71 was not
received.”

A 24-hour time value formatted as
hh:mm:ss. The maximum value is
23:59:59. The default is 00:00:00.

active.directory.enabled Specifies whether Connect:Direct for Windows
updates its Active Directory entry at startup.
This parameter is set automatically at
installation. You do not need to update this
parameter unless a node is inserted into or
removed from the Active Directory after
installation.

Y | N

The default is N.
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Parameter Name Description Valid Values

quiesce.resume Specifies whether testing mode is enabled for
Connect:Direct for Windows. To enable the
testing mode, you must specify Y for this
parameter and have a valid NDMPXTBL
parameter table in the Server directory where
Connect:Direct for Windows is installed.

See Use Connect:Direct in Test Mode.

Y | N

The default is N.

tcp.api.inactivity.timeout The number of seconds of session inactivity to
wait before exiting a session. This helps prevent
maximum connections (api.max.connects)
being reached because of abrupt
disconnections that do not free up resources in
an orderly manner.

If you are using Sterling Control Center to
monitor your Connect:Direct for Windows
server, set this value to at least twice the value
of the Monitor Rest Time setting in Sterling
Control Center.

A numeric value from 0 to 32767.

The default is 0.

Transmission Control Queue Parameters
The Connect:Direct Transmission Control Queue (TCQ) holds submitted Processes. The TCQ
information parameters define information about the TCQ, such as the default Process directory.

See Manage Processes.

The following table identifies the TCQ information parameters:

Parameter Name Description Valid Values

tcq.max.age The maximum number of days a Process with
Held due to Error (HE) status remains in the TCQ
before it is automatically deleted. Processes are
not automatically deleted when you specify 0.

A numeric value from 0 to 999.

The default is 30 days.

tcq.start Specifies how to start the Connect:Direct node
with respect to the TCQ.

W | C

w (warm)—Retain all existing
Processes in the TCQ at startup. This
is the default.

c (cold)—Delete all existing
Processes in the TCQ at startup.

process.dir The default directory a Process runs from if a
submit statement does not specify a fully qualified
path.

Valid, fully qualified path name. The
default is X:\installation directory
\PROCESS.
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Parameter Name Description Valid Values

runtask.restart Specifies whether a run task operation executes
on a remote Windows node after a session failure.
If a run task operation is executing on the remote
node and a session failure occurs, the local node
recognizes the session failure and puts the
Process in the Timer queue for retry. The remote
node is not aware of the session failure until the
Process completes. The checkpoint/restart
feature for run task ensures that when the Process
restarts on the local node, the run task operation
does not execute again on the remote node.

Y | N

The default is N.

Global Copy Parameters
The global copy parameters define default information for the copy operation, such as the number of
bytes transmitted in a copy operation before a checkpoint is taken.

See the Connect:Direct Process Guide for a description of the copy Process statement.

Parameter Name Description Valid Values

ckpt.interval The default checkpoint interval used. The
interval is the number of bytes transmitted
before a checkpoint is taken. The maximum
possible value is gigabytes.

no | bytesK | bytesM

The default is 10240K bytes.

xlate.dir The default directory containing the
translation table. The default is the XLATE
subdirectory where Connect:Direct is
installed.

Valid, fully qualified path name. The
default is X:\installation directory
\XLATE.

xlate.send The name of the default translation table to
use when sending data to a remote node.

Valid name for the send translation
table. The default is
XLATESND.CDX

xlate.recv The name of the default translation table to
use when copying data from a remote node.

Valid name for the receive translation
table. The default is
XLATERCV.CDX

disable.cache Enables or disables the Windows file cache. Y | N

The default is N.

continue.on.exception Specifies whether a Process attempts to
continue processing or goes into HOLD
status if an abnormal termination occurs
during a Connect:Direct session.

Y—Attempt to continue processing.

N—Go into HOLD status.

Y | N

The default is N.

ecz.cmprlevel The compression level to use. Level 1 is the
fastest method and offers the least degree
of compression. Level 9 provides the
greatest degree of compression and is the
slowest method.

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9

The default is 1.
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Parameter Name Description Valid Values

ecz.windowsize The size of the compression window or
history buffer. The greater the window size,
the greater the degree of compression, and
the greater the amount of virtual memory
used.

9 | 10 | 11 | 12 | 13 | 14 | 15

The default is 13.

ecz.memlevel The amount of virtual memory allocated to
maintain the internal compression rate.
Memory level 1 uses the least amount of
memory, but slows processing and reduces
the degree of compression.

1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9

The default is 4.

strip.blanks Determines whether trailing blank
characters at the end of each record are
removed from a line of text before it is written
to the Windows text file or ignored (I). The
strip.blanks parameter is ignored when
datatype(binary) is specified.

Y | N | I

The default is I.

record.wrap Note: This parameter is needed
only in certain
circumstances because it
restructures the data.

Influences the way that a sending copy step
works when a logical record size (LRECL) is
specified for the remote platform.

If record.wrap is set to N, and a record length
greater than LRECL is encountered in the
source file, Connect:Direct for Windows
reports an error. This is the desired behavior
in most cases.

If record.wrap is set to Y, and a record length
greater than LRECL is encountered in the
source file, the record is broken into records
of length at most LRECLs before being sent
to the remote node.

Y | N

The default is N.

retry.msgids The message IDs to use to support a file
allocation retry attempt.

Since error codes can vary from one
operating system to another and the same
error code can have different meanings, use
message IDs to identify retry conditions
when communicating between two different
platforms. When a file allocation or open
error occurs on either the local or remote
node, the PNODE searches for the message
ID in the retry.msgids parameters. If the
message ID is found, the Process is retried.

You can perform retry attempts based on
codes only, message IDs only, or a
combination of the two.

When a retry condition is detected, the
session is terminated cleanly and the
Process is placed in the Timer queue.

Any of the valid file allocation retry
messages.
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Parameter Name Description Valid Values

retry.codes The codes to recognize as a file allocation
retry attempt. File allocation retry enables a
Process with a file allocation or open error
on either the local or remote node to run the
Process again, beginning at the copy step
where the error occurred. This feature
supports the ability to retry a Process that
failed when a file is already in use.

When a file allocation or open error occurs
on either the local or remote node, the
PNODE searches for the error or message
ID in the retry.codes and retry.msgids
parameters. If the error code or message ID
is found, the Process is retried.

Since error codes can vary from one
operating system to another and the same
error code can have different meanings, use
message IDs to identify retry conditions
when communicating between two different
platforms.

You can perform retry attempts based on
codes only, IDs only, or a combination of the
two.

When a retry condition is detected, the
session is terminated cleanly and the
Process is placed in the Timer queue.

Any valid error code

Statistics Parameters
The Connect:Direct statistics facility logs information about Connect:Direct operations. The statistics
information parameters define the characteristics of the statistics facility, such as the maximum age of
a statistics record.

The following table identifies the statistics information parameters.

Parameter Name Description Valid Values

stat.max.age How many days to store statistics before
automatically deleting them. If you set this value
to zero, no statistics records are deleted.

A numeric value from 0 to 365. The
default is 7 days.

log.select Specifies whether Connect:Direct logs the select
process and select statistics commands to the
statistics file. This specification does not affect
the logging of other Connect:Direct commands.

Y | N

The default is N.

stat.sort Determines whether statistics are sorted by
timestamp date.

Y | N

The default is Y.
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Parameter Name Description Valid Values

log.commands Specifies whether Connect:Direct logs all
commands issued from Connect:Direct for
Windows to the statistics file. This capability
enables you to review the statistics file and
determine who issued specific commands and
what the responses to those commands were.
You can override this parameter for the
commands that select Processes and statistics
with the log.select parameter.

Y | N

The default is Y.
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Specify an IP Address

Specify IP Addresses, Host Names, and Ports
Connect:Direct for Windows accepts both Internet Protocol version 4 (IPv4) and Internet Protocol
version 6 (IPv6) as well as host names.

You can enter IP addresses/host names and ports in several ways depending on the field you are
specifying:
• Address or host name only
• Port number only
• Address/host name with a port number
• Multiple address/host name and port combinations

IP Addresses
Connect:Direct for Windows accepts both IPv4 and IPv6 addresses. Wherever an IP address is specified
in Connect:Direct for Windows, you can use either IPv4 or an IPv6 addresses.

IPv4 Addresses

IPv4 supports 232 addresses written as 4 groups of dot-separated 3 decimal numbers (0 through 9), for
example, 10.23.107.5.

IPv6

IPv6 supports 2128 addresses written as 8 groups of colon-separated 4 hexadecimal digits, for example,
1001:0dc8:0:0:0:ff10:143e:57ab. The following guidelines apply to IPv6 addresses:
• If a four-digit group contains zeros (0000), the zeros may be omitted and replaced with two

colons (::), for example:
2001:0db8:85a3:0000:1319:8a2e:0370:1337

can be shortened as
• Any number of successive 0000 groups may be replaced with two colons (::), but only one set

of double colons (::) can be used in an address. For example:
001:0db8:0000:0000:0000:0000:1319:58ab 
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can be shortened as:
• Leading zeros in a four-zero group can be left out (0000 can be shortened to 0). For example:

2001:0db8:0000:0000::1319:58ab

can be shortened as:
• You can write a sequence of 4 bytes that occur at the end of an IPv6 address in decimal format

using dots as separators. For example:
::ffff:102:304

-or-

Can be written as:

This notation is useful for compatibility addresses.

Host Names
When you specify a host name rather than an IP address, Connect:Direct for Windows does a DNS
lookup to get the IP address from the operating system. The first IP address returned in the DNS lookup
is used regardless of whether it is in IPv4 or IPv6 format.

A host name (net, host, gateway, or domain name) is a text string of up to 24 characters comprised of
the alphabet (a-z and A–Z), digits (0–9), minus sign (-), and period (.), for example, msdallas-dt.

The following guidelines also apply:
• No blank or space characters are permitted as part of the name.
• Periods are allowed only when they are used to delimit components of domain-style names.
• Host names are not case sensitive.
• The first and last character must be a letter or digit.
• Single-character names or nicknames are not allowed.

Port Numbers
Port numbers can be appended to the end of IP/host addresses when they are preceded by a semicolon
(;), for example, 10.23.107.5;1364. This convention is specific to Connect:Direct for Windows and is
not an industry standard.

A port number must be in the range of 0 through 65535. Port numbers lower than 1024 are designated
as reserved and should not be used. The following examples show port numbers appended to IP/host
addresses using these conventions:
10.23.107.5;1364
fe00:0:0:2014::7;1364
msdallas-dt;1364 

Multiple Addresses, Host Names, and Ports
You can specify multiple IPv4 and IPv6 addresses and host names by separating them with a comma
(,).

A space can be added after the comma for readability. For example:
10.23.107.5, fe00:0:0:2014::7, msdallas-dt
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You can also specify a port number for each address or host name. The port is separated from its
corresponding address/host name with a semicolon (;), and each address/host name and port
combination is separated by a comma (,). A space may be added after the comma for readability. The
following example shows multiple address/host name and port combinations:
10.23.107.5;1364, fe00:0:0:2014::7;1364, msdallas-dt;1364

Multiple address/host names (and combinations with port numbers) are limited to 1024 characters.

Use Masks for IP Address Ranges
When you specify a value for the tcp.src.ports parameter in the initialization parameters file, you can
use masks to specify the upper boundary of a range of IP addresses that use a specific port, multiple
ports, or a range of ports.

Connect:Direct for Windows supports masks for both IPv4 and IPv6 addresses, as shown in the
following sample entry from the initparms.cfg file:
tcp.src.ports=(199.2.4.*, 1000), (fd00:0:0:2015:*::*, 2000-3000),
(199.2.4.0/255.255.255.0, 4000-5000),
(fd00:0:0:2015::0/48, 6000, 7000)

These sample addresses specify the following information:

(199.2.4.*, 1000)—Any IPv4 address that falls in the range from 199.2.4.0 through 199.2.4.255 and
uses only port 1000.

(fd00:0:0:2015:*::*, 2000-3000)—Any IPv6 address that falls in the range from fd00:0:0:2015:0:0:0:0
through fd00:0:0:2015:ffff:ffff:ffff:ffff and uses a port in the range of 2000 through 3000.

(199.2.4.0/255.255.255.0, 4000-5000)—Any IPv4 address that falls in the range from 199.2.4.0
through 199.2.255.255 and uses a port in the range of 4000 through 5000.

(fd00:0:0:2015::0/48, 6000, 7000)—Any IPv6 address that falls in the range from
fd00:0:0:2015:0:0:0:0 through fd00:0:0:ffff:ffff:ffff:ffff:ffff and uses port 6000 or port 7000.

As shown in the sample entry above, the wildcard character (*) is supported to define an IP address
pattern. You can specify up to 255 unique IP address patterns or up to 1024 characters in length, each
with its own list of valid source ports. If the wildcard character is used, the optional mask is not valid.

Restriction: Masks in hexadecimal format are not supported in Connect:Direct for Windows.
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Submit a Process Using the Command Line Interface

Submit Processes Using the CLI Command
The Command Line Interface (CLI) provides another tool to submit Process statements and commands
to the Connect:Direct server.

See the Create a Process section for instructions on using the Connect:Direct Requester to submit
Process statements.

If you prefer to use a command line interface, use the CLI to issue requests interactively, or you can
submit them automatically from batch files or command files. The CLI enables you to perform the
following tasks:
• Connect to the Connect:Direct server
• Issue Connect:Direct commands
• Submit a Process
• Change Processes
• Delete Processes
• Retrieve Process status information
• Retrieve Process statistics records

Create a Configuration File to Connect to a Server

If you want to connect to a Connect:Direct server using the CLI, use the Logon Connection utility.

This utility can be used to run batch-oriented jobs.

To use the Logon Connection Utility, first ensure that Java Runtime 1.3 or later is installed. Then, run
the LCU.bat file to configure the connection. This batch file enables you to identify the parameters
necessary to connect to a server. It then saves this information to a configuration file called cddef.bin
or whatever name you specify. If you do not identify a directory to save the file to, it is saved in the
root directory. Use the -f parameter to identify the location and file name for the configuration file.

After you create the configuration file, invoke the CLI and include the -f parameter. Before you can
use this utility, Java 1.3 must have been downloaded. Then define a user ID and password in the
Windows setup utility.

To create the configuration file:

Sterling Commerce, Inc.  125



Chapter 11 Submit a Process Using the Command Line Interface

1. Type the following command to run the LCU batch file:

LCU -fx:\directory\filename

where x:\directory is the location to save the configuration file and file name is the name of the
configuration file.

2. Enter the following information to identify the connection parameters for the server:

• IP Address of the Connect:Direct server
• Port number of the Connect:Direct server
• User ID to use to connect to the server
• User password of the user ID used to connect to the server.

The information is automatically saved to the file you identified in step with the x:\directory
\filename variable. If you do not enter this variable, the configuration file is saved in the root
directory to the file called cddef.bin.

Invoke the CLI

To invoke the CLI, use the direct command, as shown in the following example:
direct [-nNodeName -uUserid -pPassword -mn -x -zOutputfile.txt]

1. From a command prompt, navigate to the Common Utilities directory where the CLI is installed
or define the CLI's location in the user’s path.

2. Run the direct command including any of the following parameters you wish to specify:

Command Parameters Description

direct Invokes the Connect:Direct CLI.

-f[pathname and file] Identifies the configuration file to use to automatically connect
to a Connect:Direct server.

-n[NodeName] Identifies node name or IP address.

-u[Userid] Specifies the user ID to use to connect to the node.

-p[Password] Specifies the password with which to connect to the
Connect:Direct node.

-m[n] Specifies the number of lines to display before pausing the
statistics and Process information output. This is calculated
automatically if a number is not given with the parameter.

Do not use this option if the output is being piped to a file
because the output will be paused with no visible evidence on
the screen.

-x Echoes the command input on the display. The command
issued is written immediately before the output.

-z[filename] Copies command output to the file you specify as well as
displaying the output.

-? Provides help for the command line interface.
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Terminate the CLI

To terminate the CLI, use the quit command followed by a semicolon as shown in the following
example:
quit;

CLI Commands
The following table provides a summary of all available commands that can be used with the CLI.

Command Abbreviations Description

submit sub Submits a Process to the Connect:Direct node.

change process cha, chg, c Modifies the specified parameters for a nonexecuting
Process.

delete process del, d

pro, proc, procs, p

Deletes the specified Process from the TCQ.

select process sel

pro, proc, procs, p

Retrieves status information about the specified
Process.

select message sel

mes, msg, m

Retrieves the text explanation of any message
Connect:Direct issues.

select statistics sel

sta, stat, stats, st

Retrieves statistics records for the specified Process.

traceoff tof, troff Disables the trace facility.

traceon ton, tron Enables the trace facility.

help Lists the supported Connect:Direct commands.

quit qui, q Stops the Connect:Direct CLI.

stop sto Stops the Connect:Direct server.

Command Syntax
The following information describes the general conventions used in the command syntax:
• All commands must be followed by a semicolon.
• User names, passwords, and parameters are case sensitive.
• Command keywords are not case sensitive.
• File names, group names, user IDs, and passwords are defined as variable-length strings. Names

referring to objects on other nodes can be subject to restrictions imposed by the other node
type.

• Length restrictions for Connect:Direct node names are specific to type of field and data.
• If a parameter specifies the word generic as a parameter value, you can type a string that includes

an asterisk (*) or a question mark (?) to provide pattern matching or wildcard matching for
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parameter values. The asterisk matches zero or more characters, and the question mark matches
any single character.

• When list is a parameter value in the syntax definition, you can specify multiple parameter values by
enclosing the group in parentheses and separating values with commas. A list can also include generic
values. An example follows:

pname=(payproc,arproc,ivproc,a?prod5*)

• Most CLI commands can be entered using abbreviations. When abbreviations can be used in
place of a command, these abbreviations are identified in the command description table.

Piping Conventions
The Connect:Direct for Windows CLI supports the following piping conventions:
• <filename.ext uses the file for input
• >filename.ext uses the file for output

The following example demonstrates the Connect:Direct piping convention being used on a
COMMANDS.TXT file containing the Connect:Direct commands you want to issue.

submit
test     process snode=dsd.unix
cp       copy from (file=testfile.dat pnode)
to   (file=test.dat snode)
pend;
select statistics;
select process;
quit;

By typing the following command, you can execute all of the commands in the COMMANDS.TXT
file.

direct < commands.txt

Note: A batch file can also be created containing the direct < commands.txt line if you want
to execute these commands from a batch file.

Submit Process Command
Use the submit command to request that Connect:Direct execute the operations specified in the Process
being submitted.

Parameters override the same parameters specified in the Process statement. The submit command also
enables you to resolve symbolic parameters found in the Process.
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Parameter Description

file=filename The name of the Process file, up to 256 characters. If you specify the file
parameter, you must specify it before any other parameter. If you do not
specify this parameter, then the text of the Process must follow the submit
command.

class=nn| session number The node-to-node session on which a Process can execute. A Process can
execute in the class specified or any higher session class.

execprty=nn The operating system execution priority, from 1 to 15, of the Process. The
execution priority parameter is used to influence the priority given to the
Session Manager when it starts this Process. The higher the priority, the
higher the Session Manager priority and, therefore, the more system
resources. Scheduling Processes to run in the High priority class can have
an adverse effect on the execution of other applications in the system.

The values for the execution priority range from 1 to 15 and are mapped to
Windows Process priority classes and values. The highest priority is 15.

Only Connect:Direct for Windows supports the execution priority option.

hold=yes | no | call The TCQ hold status of the Process.

yes—Places the Process in the Hold queue in HI (Held Initial) status until
you explicitly release it by a change process command. When you specify
both hold=yes and a startt value, the hold specification takes precedence.
A Process with hold=yes is placed in the Hold queue even if you specify a
start time.

no—Does not place the Process in the Hold queue. The Process executes
as soon as resources are available.

call—Holds the Process until the SNODE connects to the PNODE. At that
time, the software releases the Process for execution. It also releases the
Process when another Process on the PNODE connects to the SNODE.

pacct=“pnode accounting data” A string, up to 256 characters, to be used as accounting data for the
PNODE. Enclose the string in double quotation marks.

pnodeid=(id , pswd) Security user IDs and passwords at the PNODE. The subparameters can
contain 1 to 48 alphanumeric characters. You must specify both the ID and
the password.

maxdelay=unlimited | hh:mm:ss | 0 Causes the command processor to wait until the submitted Process
completes execution or the specified time interval expires.

If the time interval expires, the command processor returns a warning status
code and message ID. The Process is not affected by the time interval
expiration and executes normally.

unlimited—Specifies that the submit command processor is to wait until the
Process completes execution.

hh:mm:ss—Specifies that the submit command is to wait for an interval no
longer than the specified hours (hh), minutes (mm), and seconds (ss).

0—Specifies that the submitted Process must begin execution immediately.
If the submitted Process cannot begin execution immediately, the submit
operation fails.

newname=new process name Specifies a new Process name, 1 to 8 alphanumeric characters long, to
override the name within the submitted Process.

notify=userid The user to receive Process completion messages.

sacct=“snode accounting data” Accounting data, from 1 to 256 characters, for the SNODE. Enclose the
string in double quotation marks.
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Parameter Description

retain=yes | no | initial Determines whether a copy of the Process is retained in the TCQ for re-
execution after the Process executes.

yes—Specifies that the software retains the Process in the Hold queue in
HR status after execution. Issue a change process command to release the
Process for execution.

no—Specifies that the software is to delete the Process after execution.

initial—Specifies that the software is to retain the Process in the Hold queue
in HR status for automatic execution every time Connect:Direct initializes.

If retain=yes, setting startt causes the Process to execute at regular
intervals based on the value of startt.

If retain=initial, do not use the startt parameter. This causes the submit
command to fail.

snode=[nodename] | [hostname |
IPaddress ; portnumber |
servicename]

Identifies the SNODE. The SNODE name is a 1- to 16-character
alphanumeric string. Specify the node either on the submit command or
Process statement. If you specify the node in this submit command, it
overrides the node specified in the Process statement.

nodename—Identifies the remote node object in the Connect:Direct
network map.

hostname | IPaddress ; portnumber | servicename—Specifies an IP
address for the SNODE. This is used for TCP/IP connectivity only.

Specify the host name or IP address, a semicolon, and the port number or
service name. For more information on specifying valid IPv4 and IPv6
addresses and ports, see Specifying IP Addresses, Host Names, and Ports.

If you specify an IP address, you must also specify netmap.check=r or
netmap.check=n in your initialization parameters.

If you use IPv6 temporary addresses for outbound connections, the
connection will fail unless you configure a well-known address for the
PNODE server or you disable temporary addresses for the SNODE.

snodeid=(id [,pswd [,newpswd]]) The security user IDs and security passwords on the SNODE. The
subparameters can contain one or more alphanumeric characters.

newpswd—Specifies a new password value. This subparameter is not
supported by all types of Connect:Direct nodes. On z/OS systems only, the
user password changes to the new value on the SNODE if the userid and
old password are correct. If the SNODE is a UNIX node, the password does
not change.

If you specify the password, you must also specify the ID. If you specify a
new password, you must also specify the existing password.

prty=nn The selection priority of the Process for execution. This priority parameter
is used for Process selection. A Process with a higher priority is selected
for execution before a Process with a lower priority. The priority value does
not affect the priority during transmission.

Values range from 0 to 15, where 15 is the highest priority.

130 Sterling Commerce, Inc.



Change Process Command

Parameter Description

startt=([date | day] [,time]) Identifies the specified date, day, or time to execute the Process. The
Process is placed in the Timer queue in WS status. The date, day, and time
are positional parameters. If you do not specify date or day, type a comma
before the time.

date—Specifies the day, month, and year, that you can code as mm/dd/
yyyy or mm-dd-yyyy. You can code month and day as one or two digits and
year as two or four digits. If you only specify date, the time defaults to
00:00:00. The current date is the default.

day—Specifies the day of the week. Values are today, tomorrow, Monday,
Tuesday, Wednesday, Thursday, Friday, Saturday, and Sunday.

time—Specifies the time of day in hh:mm[:ss] [am | pm] where hh is hours,
mm is minutes, and ss is seconds. Seconds are optional. You can specify
the hour in either 12- or 24-hour format. If you use the 12-hour format, then
you must specify am or pm. The default format is the 24-hour format.

If the time you specify has already passed, Connect:Direct schedules the
Process for the next valid date and time. For example, if you set the Process
to start daily at 5:00 PM, or startt=(, 17:00), and the Process submits at 5:30
PM, Connect:Direct schedules the Process to run the next day.

If you specify only the day value, the time defaults to midnight (00:00:00).
This means that if you submit a Process on Monday, with Monday as the
only startt parameter, the Process does not run until the following Monday
at midnight.

Do not set the startt parameter if retain=initial. This causes the submit
command to fail.

&symbolic name n=“variable string n” A symbolic parameter assigned a value. The value is substituted within the
Process when the software encounters the symbolic parameter. The
symbolic within the Process must be enclosed within quotes.

Examples
The following command submits the Process named payroll.cdp. Because the command specifies
retain=yes, the Process is retained in the TCQ after execution. The Process starts the next Monday at
00:00:00. The command specifies Process accounting data for the PNODE.
submit file=payroll.cdp retain=yes startt=monday pacct="2003,dept-27";

The following command submits the Process named copyfil.cdp. Because the command specifies startt,
the Process executes on the first day of January 2003 at 11:45 a.m.
submit file=copyfil.cdp snode=vmcent startt=(01/01/2003, 11:45:00 am);

Change Process Command
Use the change process command to modify specified parameters for a nonexecuting Process or
Processes in the TCQ.

Select the Processes to change by Process name, Process number, SNODE name, submitter ID, or a
combination of these.

Note: All changes affect the Process in the TCQ, not the original text of the Process as
submitted.
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The change process command performs the following functions:
• Changes the class, SNODE name, destination node, or priority of a Process
• Places a Process in the Hold queue or releases a Process from the Hold queue

The format for the change process command follows:

Command Parameters

change process /* Search Criteria */

[pname=Process name | generic | (list)]

[pnumber=Process number | (list)]

[snode=snode name | generic | (list)]

[submitter=(node name, userid) | generic | (list)]

/* The following parameters specify the characteristics
of Connect:Direct Processes that you can modify. */

class= | session number

execprty=nn

hold=yes | no | call

newsnode=new snode name

release

prty=nn

Search Parameters
Specify at least one of the following search criteria parameters:

Parameter Description

pname=Process name | generic | (list) The name of the Process or Processes. The name can
be 1 to 8 alphanumeric characters long.

pnumber=Process number | (list) The Process number of the Process. The Process
numbers are assigned when you submit the Process.
Valid Process numbers range from 1 to 99999.

snode=snode name | generic | (list) Searches for a Process or Processes by the SNODE
(partner) name. The SNODE name can contain 1 to 16
alphanumeric characters. You can use the IP address
of the SNODE as your SNODE name.

submitter=(node name, userid) | generic | (list) Searches for a Process or Processes by the node
specification and userid of the Process owner. The
maximum combined length, including the node name
and userid for this parameter, is 66 characters.

Change Parameters
You can change one or more of the following characteristics of a Connect:Direct Process:
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Parameter Description

class=nn | session number Changes the node-to-node session on which the Process can execute. A
Process can execute on the specified class or any higher session class.

execprty=nn The execution priority of the Process. The values for the execution priority
range from 1 to 15 and are mapped to Windows Process priority classes
and values. The highest priority is 15.

Only Connect:Direct for Windows supports the execution priority option.

hold=yes | no | call Moves the Process to the Hold or Wait queue.

yes—Places the Process in the Hold queue in HO (Held by Operator)
status until another change process command explicitly releases it.

no—Places the Process in the Wait queue in WC (Waiting for Connection)
status. The Process executes as soon as resources are available.

call—Places the Process in the Hold queue in HC (Held for Call) status
until the SNODE connects to the PNODE or another Process is submitted.
At that time, Connect:Direct releases the Process for execution.

newsnode=new snode name Specifies a new SNODE name to assign to the Process.

release Releases the Process from a held state. This parameter is equivalent to
Hold=no.

prty=nn The selection priority in the TCQ. This priority parameter is used for
Process selection. A Process with a higher priority is selected for execution
before a Process with a lower priority. The priority value does not affect
the priority during transmission.

Values range from 0 to 15 inclusive, where 15 is the highest priority.

Example
The following command changes the SNODE name for any nonexecuting Process named cdproc to a
new SNODE name, paris.
change process pname=cdproc newsnode=paris;

Delete Process Command
Use delete process to remove a Process from the TCQ.

You can select the Processes to delete by Process name, Process number, SNODE name, submitter, or
a combination of these. The format for the delete process command follows:

Command Parameters

delete process /* Search Criteria */

[pname=Process name | generic | (list)]

[pnumber=Process number | (list)]

[snode=snode name | generic | (list)]

[submitter=(node name, userid) | generic | (list)]

/* Processing Parameters */

[force=yes | no]
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Command Parameters

[hold=yes | no]

Search Parameters
Use the parameters to identify the Processes you want to delete. You can delete Processes by name,
number, node, or a combination of the criteria.

Parameter Description

pname=Process name | generic | (list) The name of the Processes, from 1–8 alphanumeric
characters, to delete.

pnumber=Process number | (list) The number of the Process to delete. The Process
number is assigned when the Process is submitted.

snode=snode name | generic | (list) The SNODE name of the Processes to delete. The
SNODE name can be 1 to 16 alphanumeric characters
long.

submitter=(node name, userid) | generic | (list) The submitter node name and user ID of the Processes
to delete. The maximum combined length, including the
node name and user ID, is 66 characters.

Processing Parameters
Define one or more of the following parameters to identify how the delete Processes are managed:

Parameter Description

force=yes | no Forcibly terminate an executing Process. Use this
parameter if a Process is in the executing state and is
waiting for unavailable resources.

yes—Forcibly and immediately terminates the Process
or Processes.

no—Notifies the partner node of the intent to terminate
and terminates the Processes. This is the default.

hold=yes | no Specifies whether the terminated Process is placed in
the Hold queue.

yes—Places the Process in the Hold queue in HS (Held
Due to Execution Suspension) status after termination.

no—Deletes the Process from the TCQ after
termination. This is the default.

Examples
The following command deletes all Processes submitted by userid cduser on node dallas. If the
Processes are executing, it stops and removes them from the TCQ.
delete process submitter=(dallas, cduser);

134 Sterling Commerce, Inc.



Select Process Command

The following command deletes all Processes named rome from the TCQ. If the Processes are
executing, the command forcibly terminates them.
delete process pname=rome force=yes;

Select Process Command
Use select process to display information about Processes in the TCQ. Select Processes by name,
number, queue, SNODE, status, submitter, or a combination of these.

Format
The format for the select process command follows:

Command Parameters

select process /* Selection Criteria */

[pname=Process name | generic | (list)]

[pnumber=Process number | (list)]

[queue=all | exec | hold | wait | timer]

[snode=snode name | generic | (list)]

[status=ex | hc | he | hi | ho | hr | hs | pe | re | wa | wc |
ws | (list)]

[submitter=(node name, userid) | generic | (list)]

/* Display option */

[detail=yes | no]

Selection Parameters
Specify one or more of the following selection parameters. If you do not specify one of the following
selection parameters, all Processes in the TCQ you are authorized to access are selected.

Parameter Description

pname=Process name | generic | (list) Identifies the Process name, up to 8 alphanumeric
characters long.

pnumber=Process number | (list) Identifies Processes numbers to select. The Process
number is assigned when you submit the Process. Valid
Process numbers range from 1–99999.

queue=all | exec | hold | wait | timer Identifies queue names to select.

all—Selects all queues. This is the default.

exec—Selects Processes from the Execution queue.

hold—Selects Processes from the Hold queue.

timer—Selects Processes from the Timer queue.

wait—Selects Processes from the Wait queue.
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Parameter Description

snode=snode name | generic | (list) Identifies the SNODE name, from 1 to 16 alphanumeric
characters, to select.

status=ex | hc | he | hi | ho | hr | hs | pe | re | wa | wc | ws
| (list)

Selects a Process status to select. If you do not specify
a status value, information is generated for all status
values.

ex—Selects Processes from the Execution queue.

hc—Selects Processes submitted with hold=call.

he—Selects Processes held due to a connection error.

hi—Selects Processes submitted with hold=yes.

ho—Selects Processes held by a change process
command issued with hold=yes.

hr—Selects Processes submitted with retain=yes.

hs—Selects Processes suspended by a delete process
command issued with hold=yes.

pe—Selects submitted Processes that are awaiting the
Session Manager. After the Session Manager initializes,
it places the Process in the Execution queue and
changes the status to EX.

re—Selects Processes that are waiting for restart after
session failure.

wa—Selects Processes that are eligible for execution
but not yet selected or running.

wc—Selects Processes that are ready for execution and
awaiting an available connection to the SNODE.

ws—Selects Processes waiting in the Timer Queue for
a start time.

submitter=(node name, userid) | generic |(list) Selects Processes by node name and user ID of the
submitter of each Process. The maximum combined
length, including the node name and userid, is 66
characters.

Display Parameter
The following display parameter generates a detailed report of the select process command.

Parameter Description

detail=yes | no Specifies the type of report generated for the selected
Process or Processes. The default is no.

yes—Generates a detailed report

no—Generates a short report

Examples
The following example shows the report information returned when specifying detail=yes.
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==================================================================
              SELECT PROCESS
==================================================================
Process Name        =>SAMPLE       Class          =>
Process Number      =>38           Priority       =>
Submitter Node      =>CSDPUBS      Pnode          CSGPUBS
Submitter           user1          Snode          CSGPUBS
Retain Process      =>N

Submit Time         =>09:54:33     Schedule Time  =>
Submit Date         =>10/30/2002   Schedule Date  =>

Queue               =>HOLD
Process Status      =>HI
Message Text        =>
--------------------------------------------------
Process Name        =>SAMPLE       Class          =>
Process Number      =>39           Priority       =>0
Submitter Node      =>CSGPUBS      Pnode          =>CSGPUBS
Submitter           user          Snode          =>CSGPUBS
Retain Process      =>N
Submit Date         =>09:54:35     Schedule Time  =>
Submit Date         =>10/30/2002   Schedule Date  =>
Queue               =>HOLD
Process Status      =>HI
Message Text        =>
--------------------------------------------------

The following example shows the report information returned when specifying detail=no or omitting
the detail parameter.

==================================================================
SELECT PROCESS
==================================================================
PROCESS NAME NUMBER USER       SUBMITTER NODE       QUEUE STATUS
----------------------------------------------------------------
SAMPLE        39    user       CSGPUBS               HOLD HI
SAMPLE          39    user       CSGPUBS                   HOLD HI

The following command returns status information for Process number 9.
select process pnumber=9;
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Select Message Command
Use select message to retrieve the text of any Connect:Direct message.

Format
The format for the select message command follows:

Command Parameters

select message Selection Criteria

msgid=message ID

The following parameter specifies the message IDs to display:

Parameter Description

msgid=message id The Connect:Direct message ID of the message
request. Do not use generic specifications. This
parameter is required.

Example
Type the following command at the CLI prompt to retrieve the text of Connect:Direct message
LCCC00I:
select message msgid=LCCC00I;

Select Statistics Command
Issue select statistics to examine records in the Connect:Direct statistics database. The type of
information in the output from this command includes such data as copy status and execution events.
The search criteria provide flexibility in selecting information you want to retrieve. Additional
parameters determine the form in which the information is presented.

When using select statistics, specify your selection criteria carefully to avoid displaying excessive
volumes of records. If you do not provide selection criteria, all records for the day are retrieved.

Format
The format for the select statistics command follows.

Command Parameters

select statistics /* Selection Criteria */

[ccode=(operator, code)]

[dfile=destination filename | (list)]

[pname=Process name | generic | (list)]
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Command Parameters

[pnumber=Process number | (list)]

[reccat=caev | capr | (caev,capr)]

[recids=record id | (list)]

[snode=snode name | generic | (list)]

[sfile=source filename | (list)]

[startt=([date | day][, hh:mm:ss[am|pm]])]

[stopt=([date | day][, hh:mm:ss[am|pm]])]

[submitter=(node name, userid) | generic | (list)]
Note To use a wildcard within the submitter parameter, you must have

administrator access.

/* Display option */

[detail=yes | no]

Parameters
Provide one or more of the following parameters to determine what statistics are returned:

Parameter Description

ccode=(operator, code) Select statistics records based on the completion code operator and return
code values associated with step termination. The condition code operator
default is eq. You must specify the return code.

Following are the valid completion code operators:

eq | = | == Equal (This is the default.)

ge | >= | => Greater than or equal

gt | > Greater than

le | <= | =< Less than or equal

lt | < Less than

ne | != Not equal

Following are the valid completion codes:

0—Successful execution of the Process.

4—A warning level error was encountered. The statement probably
completed normally but you should verify the execution results.

8—An error occurred during Process execution.

16—A Severe error occurred during Process execution.

dfile=destination filename | (list) Enables you to search all copy termination records (CAPR category, CTRC
record ID) to find those with a destination file name matching the filename
or list of filenames specified.

This parameter is not supported by Connect:Direct UNIX.

pname=Process name | generic |
(list)

Selects Process statistics by Process name, a generic name, or a list of
names. The name can be 1 to 8 alphanumeric characters long.

pnumber=Process number | (list) Selects statistics by Process number or a list of Process numbers. The
Process number is assigned when the Process is submitted.
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Parameter Description

reccat=caev | capr | (caev , capr) Selects statistics based on whether the record category is related to events
or to a Process.

The default for this keyword depends on the other search criteria specified.
If you specify Process characteristics, such as Process name, Process
number, or Submitter, the default is capr. If you perform a general search
using startt or stopt, the default is caev and capr.

caev—Specifies that the retrieved statistics file records should include those
related to Connect:Direct events, such as a Connect:Direct shutdown.

capr—Specifies that the retrieved statistics file records should include those
related to one or more Connect:Direct Processes.
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Parameter Description

recids=record id | (list) Specifies selection by record ID or a list of record IDs. This parameter
identifies particular types of statistics records, such as a copy termination
records or initialization event records. Following is a list of the record IDs:

APCK—Asset protection check

AUPR—Authorization file processing

CHGP—Change Process command issued

COAC—Communication activated

CMLT—CMGR listen thread terminated

CRHT—Connect:Direct copyright

CSTP—Child Process stopped

CTRC—Copy control record written

CTRM—Child Process terminated

CUKN—Child process unknown status

CXIT—Child process exited

DELP—Delete Process command issued

FLSP—Flush Process command issued

FMRV—Formatted Header (FMH) received

FMSD—Formatted Header (FMH) sent

GPRC—Get Process issued

IFED—If statement ended

IPPR—Initialization parameter processing

LIEX—License has expired

LIOK—Listen okay

LSST—The record ID of a step on the local node

LWEX—License will expire in 14 days

NAUH—Node Authorization check issued

NMOP—Network map file opened

NMPR—The network map is updated through Browser, Control Center, or
KQV Interface.

NUIC—Connect:Direct initialization complete

NUIS—Connect:Direct start initialization

NUT1—Connect:Direct phase one termination complete status

NUT1—Connect:Direct phase two termination complete status

NUTC—Connect:Direct termination complete

NUTR—Connect:Direct termination requested

PERR—Process error was detected

PFLS—Process was flushed

PMED—Process Manager ended

Sterling Commerce, Inc.  141



Chapter 11 Submit a Process Using the Command Line Interface

Parameter Description

recids=record id | (list) (continued) PMIP—Process Manager Initprocs thread initialized

PMMX—Process Manager Max Age thread initialized

PMRC—Process Manager release cell thread initialized

PMST—Process Manager started

PPER—Pipe error

PRED—Process ended

PRIN—Process interrupted

PSAV—Process was saved

PSED—Process step was detected

PSTR—Process has started

QCEX—A Process moved from another queue to the EXEC queue

QCHO—A Process moved from another queue to the HOLD queue

QCWA—A Process moved from another queue to the WAIT queue

QCTI—A Process moved from another queue to the TIMER queue

QCHO—A Process moved from another queue to the HOLD queue

RJED—Run Job command completed

RNCF—Remote Connect:Direct server call failed

RSST—The record ID of a step on the remote node

RTED—Run Task command completed

SBED—Submit complete

SELP—Select Process command issued

SELS—Select Statistics command issued

SEND—Session end issued

SERR—System error

SFSZ—Size of the file submitted

SHUD—Connect:Direct shutdown

SIGC—System error

SMED—Session Manager ended

SMST—Session Manager started

SNMP—SNMP

SSTR—Session start issued

STOP—Stop Connect:Direct command issued

SUBP—Submit command issued

TCPI—TCP started

TRAC—Trace command issued

TZDI—Time zone of the local node represented as the difference in seconds
between the time at the local node and the Coordinated Universal Time

UNKN—Unknown command issued

USEC—User Security check issued

xxxx—Record types identified by the first four characters of the message ID
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Parameter Description

snode=snode name | generic | (list) Selects statistics file records by SNODE name, a generic node name, or a
list of node names. The SNODE name can be 1 to 16 alphanumeric
characters long.

sfile=filename| (list) Enables you to search all copy termination records (CAPR category, CTRC
record ID) to find those with a destination file name matching the file name
or list of the file names specified.

This parameter is not supported by Connect:Direct for UNIX.

startt=([date | day] [, time]) Selects statistics starting with records logged since the specified date, day,
or time. The date, day, and time are positional parameters. If you do not
specify a date or day, type a comma before the time.

date—Specifies the day (dd), month (mm), and year (yy), which you can
code as mm/dd/yyyy or mm-dd-yyyy. If you only specify date, the time
defaults to 00:00:00. The current date is the default.

day—Specifies the day of the week. Values are today, yesterday, Monday,
Tuesday, Wednesday, Thursday, Friday, Saturday, and Sunday. If you
specify a day of the week, Connect:Direct uses the previous matching day.

time—Specifies the time of day coded as hh:mm:ss[am | pm] where hh is
hours, mm is minutes, and ss is seconds. You can specify the hour in either
12- or 24-hour format. If you use the 12-hour format, then you must specify
am or pm. The default format is the 24-hour format. The default value is
00:00:00, which indicates midnight. If you specify only the day value, the
time defaults to 00:00:00.

stopt=([date | day] [, time]) Retrieves statistics including records logged up to and including the
specified date, day, or time. The date, day, and time are positional
parameters. If you do not specify a date or a day, type a comma before the
time.

date—Specifies the day (dd), month (mm), and year (yy), that you can code
as mm/dd/yyyy or mm-dd-yyyy. If you only specify date, the time defaults to
00:00:00. The current date is the default.

day—Specifies the day of the week. Values are today, yesterday, Monday,
Tuesday, Wednesday, Thursday, Friday, Saturday, and Sunday. If you
specify a day of the week, Connect:Direct uses the previous matching day.

time—Specifies the time of day coded as hh:mm:ss[am | pm] where hh is
hours, mm is minutes, and ss is seconds. You can specify the hour in either
12- or 24-hour format. If you use the 12-hour format, then you must specify
am or pm. The default is the 24-hour format. The default value is 00:00:00,
which indicates midnight. If you specify only the day value, the time defaults
to 00:00:00.

submitter=(node name, userid) |
generic | (list)

Selects statistics by the node name and userid of the Process owner
(submitter). You can also specify a generic name and userid or a list of
names and userids. The maximum combined length, including the node
name and userid, is 66 characters for this parameter.

Display Parameter
Provide this optional parameter if you want to generate a report of the statistics that are generated:
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Parameter Description

detail=yes | no Specifies the type of report generated for the selected
Processes. The default is no.

yes—Generates a detailed report.

no—Generates a short report.

Example
The following example shows the report information returned when specifying detail=yes.

==================================================================
              SELECT STATISTICS
==================================================================
PROCESS RECORD   Record Id=>SUBP
Process Name     =>SAMPLE     Stat Log Time     =>09:54:33
Process Number   =>38         Stat Log Time     =>07/30/2003
Submitter Id     =>user1
Snode            =>CSGPUBS
Completion Code  =>0
Message Id       =>
Short Text       =>
---------------------------------------------------------
PROCESS RECORD   Record Id=>SUBp
Process Name     =>SAMPLE     Stat Log Time     =>09:54:33
Process Number   =>39         Stat Log Time     =>07/30/2003
Submitter Id     =>user1
Snode            =>CSGPUBS
Completion Code  =>0
Message Id       =>
Short Text       =>
---------------------------------------------------------

The following example shows the report information returned when specifying detail=no or omitting
the detail parameter.
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==================================================================
              SELECT STATISTICS
==================================================================
P RECID LOG TIME           PNAME PNUMBER STEPNAME CCOD FDBK MSGID
P RECID LOG TIME           MESSAGE TEXT
-----------------------------------------------------------------
P  SUBP  07/30/2003 09:54:33  SAMPLE  38    0  0
P  SUBP   07/30/2003  09:54:35   SAMPLE    39     0  0

The following command generates statistics output for Process number 7. The output consists of all
records for that Process starting with those generated on July 11, 2003.
select statistics pnumber=7 startt=(07/11/2003);

Traceoff Command
The Connect:Direct server provides a comprehensive trace facility that assists in the diagnosis of
problems relating to any facet of the operation of the server. Use the traceoff command to disable a
trace started with the traceon command.

Format
The format for the traceoff command follows.

Command Parameter

traceoff [file=filename]

[type=cmgr | pmgr | smgr | comm | (list)]

[dest=destination | (list)]

[pnode | snode]

[pname=process name | (list)]

[pnum=process number | (list)]

Note: The dest, pnode, pname, and pnum parameters are valid for smgr and comm traces only.

Specify one or more of the following parameters to identify the trace to turn off including the output
file of the trace, the type of trace, the destination, the node, and the Process name or number.

Parameter Description

file=filename The name of the trace output file. The default is
CDTRACE.CDT.
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Parameter Description

type=cmgr | pmgr | smgr | comm | (list) Disables traces by type.

cmgr—Traces events relating to the interaction of the
server with connected workstations and with the server
console.

pmgr—Traces events relating to the manipulation of
Connect:Direct Processes.

smgr—Traces events relating to the execution of
Connect:Direct Processes and the server’s interaction
with other Connect:Direct nodes.

comm—Traces only interactions with external
communications facilities invoked from Session
Manager threads and used to communicate with other
Connect:Direct nodes.

Additional Session Manager and Communications Trace
Parameters
The following parameters are valid for SMGR and COMM trace types only. The dest, pnode, snode,
pname, and pnum parameters are mutually exclusive.

Parameter Description

dest=destination | (list) The destination node name of the Process you want to stop tracing or a list of up
to four node names.

pnode | snode The PNODE or SNODE session managers.

pnode—Disables the trace of all PNODE session managers.

snode—Disables the trace of all SNODE session managers.

pname=process name | (list) The name of the Process or up to four names you want to stop tracing.

pnum=process number | (list) The Process number, up to four Processes, you want to stop tracing.

Example
The following command turns off the full SMGR trace for the Process named payroll.
traceoff type=smgr pname=payroll;

Traceon Command
Use the traceon command to enable the trace facility. The trace facility enables you to capture
information to assist in the diagnosis of Connect:Direct problems.

Format
The format for the traceon command follows:
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Command Parameters

traceon [file=filename]

[filesize=nnK | nnM | 0]

[level=basic | intermediate | full]

[type=cmgr | pmgr | smgr | comm | (list)]

[wrap=yes | no]

[dest=destination | (list)]

[pnode | snode]

[pname=process name | (list)]

[pnum=process number | (list)]

Note: The dest, pnode, pname, and pnum parameters are valid for smgr and comm traces only.

Parameters
Specify one or more of the following parameters to define the traces:

Parameter Description

file=filename The name of the output file if you want to write the trace
information to a file. The size of the name can range from
1 to 256 characters. The default is CDTRACE.CDT in
the Connect:Direct directory.

filesize=nnnK | nnnM | 0 The maximum file size as a number of kilobytes (K) or
megabytes (M). A value of 0 indicates that the file can
grow indefinitely.

level=basic | intermediate | full The level of trace detail.

basic—Produces a trace of function entry and exit.

intermediate—Produces a trace of function entry and
exit, plus arguments to functions.

full—Produces a trace with function entry/exit, function
argument display, plus display of selected internal
control blocks.
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Parameter Description

type=cmgr | pmgr | smgr | comm | (list) The type of event or a list of events to be traced.

cmgr—Traces events relating to the interaction of the
server with connected workstations and the server
console.

pmgr—Traces events relating to the manipulation of
Connect:Direct Processes. This trace type provides
information about the submission, update, deletion,
selection for processing, and termination of
Connect:Direct Processes.

smgr—Traces events relating to the execution of
Connect:Direct Processes and the server’s interaction
with other Connect:Direct nodes. Traces can be started
for specific Process numbers or names, for specific
destinations, or for all PNODE or SNODE Session
Managers.

comm—Traces only interactions with external
communications facilities invoked from Session
Manager threads and used to communicate with other
Connect:Direct nodes. You can start traces for specific
Process numbers or names, for specific destinations, or
for all PNODE or SNODE Session Managers.

wrap=yes | no Specifies whether you want your trace output to be a
wraparound file.

no—Requests a linear file that grows until either the
user–specified space restriction is reached or you run
out of disk space. Linear traces are useful when you can
qualify the trace criteria sufficiently or when it is
important to not miss any trace events.

yes—Requests a wraparound file that, when the user–
specified space restriction is reached, wraps back to the
beginning and overwrites the oldest records.
Wraparound traces are useful when the problem you are
trying to trace occurs intermittently or is very difficult to
reproduce.

Help Command
Use the help command to receive a list of the commands supported by the Connect:Direct CLI.

Any command with a –? or /? will display the syntax for the command's usage.

command /?;
or
command -?;

Stop Connect:Direct
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Use the stop command to initiate an orderly Connect:Direct server shutdown sequence or forcibly
terminate the software. Connect:Direct will not run new Processes and will not establish new
connections with remote systems. You can issue commands and users can sign on until the server
terminates. You must identify the type of stop or an error message is generated.

Format
The format for the stop command follows.

Command Parameters

stop [force | immediate | step| quiesce]

Parameters
Choose one of the following options listed in order of severity:

Parameter Description

force Forcibly terminates the Connect:Direct server with no
attempt to terminate executing Processes in an orderly
fashion or write statistics to disk. Connect:Direct
releases all server resources, including connections, LU
6.2 sessions, memory, and semaphores. It retains all
active Processes in the TCQ and restarts them when
you restart the Connect:Direct server.

immediate Begins an immediate, but orderly, shutdown of all
activity and terminates Connect:Direct. The software
terminates connections, writes statistics records, closes
files, and shuts down. It retains all active Processes in
the TCQ and restarts them when you restart the
Connect:Direct server.

step Shuts down Connect:Direct after all currently executing
Process steps complete. The software writes statistics
records, closes files, and shuts down. To restart
Processes at the next step the next time you start
Connect:Direct, set the tcq.start initialization parameter
to require a warm start.

quiesce Runs all executing Processes to completion.
Connect:Direct starts no new Processes.

Example
The following command forcibly terminates Connect:Direct and returns control to the operating
system.
stop force;
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Modify Translation Tables

Translation Tables
Connect:Direct translates data from one character set to a different character set, such as from ASCII
to EBCDIC, using character translation tables. These translation tables provide greater flexibility in
the translation of data when copying data to or from a Connect:Direct node.

Default translation tables are defined in the initialization parameters for the Connect:Direct node. You
also have the ability to specify a different translation table in the sysopts parameter with each Copy
statement. Connect:Direct provides two standard translation tables for use when sending or receiving
data to or from a remote Connect:Direct node:
• XLATERCV translates data from EBCDIC to ASCII.
• XLATESND translates data from ASCII to EBCDIC.

Translation is only performed when the data type is text. No translation is done if the data type is binary.

Modify a Translation Table Using Requester

Translation is performed if a data type of text is specified in the sysopts parameter of a copy statement.

1. Select Admin > Translation Table.

2. Type the name of the translation table file, or select one of the following default translation tables
from the drop-down list:

• XLATERCR.CDX
• XLATESND.CDX

3. Click OK.

Each cell stores the character value for the target character set. The source character set is used
as an index into the table. For example, an ASCII blank (Hex 0) would fetch the byte at offset
Hex 0 in the translation table. If the byte at location Hex 0 contains Hex code 40, that would
translate to an EBCDIC code indicating a blank character.

4. To view the shortcut menu, right-click in the Translation Table dialog box.

5. Select one of the following representations for the table element:
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• Hex
• Dec
• Oct

6. Select the elements in the table you want to modify and type in the new values.

7. Right-click to see the shortcut menu and click Apply to save your changes.

8. Click OK to save your changes to the selected Connect:Direct node.

152 Sterling Commerce, Inc.



Chapter 13

Edit Connection Settings

About the Client Connection Utility
Before you begin using the SDK to create your own programs or use Connect:Direct for Windows to
transfer files, you can use the Client Connection Utility to create connection settings for each user.

If you want to use Connect:Direct Requester, refer to the Defining and Managing the Connect:Direct
Network section for instructions.

The Connect:Direct for Windows client software uses the Microsoft Windows Registry to store its
configuration information. The Connect:Direct Client Connection Utility allows you to update the
connection settings within the Registry.

Caution: Use the Connect:Direct Client Connection Utility to update any Registry settings rather
than editing them directly.

You can view, edit, and update Connect:Direct for Windows connection settings in the Windows
Registry with the Client Connection Utility. These settings enable communication between the user
interfaces and the Connect:Direct server. You can set up and update connection settings in the following
ways:

• Add and delete a node
• Add and delete a user
• Configure node and user properties
• Define a default node or user

To facilitate updating connection settings on multiple servers, you can import and export connection
settings using the Client Connection Utility. After you configure the connection for a server, you can
export the server’s settings for use on other servers. You can then import the settings into the target
server’s Registry. You can also print connection settings.

Start the Client Connection Utility

To start the Client Connection Utility:

1. Click Start > Programs.

2. Click Sterling Commerce Connect Direct v4.5.00 > CD Client Connection Utility. The Client
Connection Utility main window is displayed.
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Add a Node

The Client Connection Utility lets you add new Connect:Direct nodes and identify the properties of
the nodes, such as node name, TCP/IP address, and port number. These properties establish a node so
you can access it from Connect:Direct Requester or the Command Line Interface (CLI).

1. Select File > New Node.

2. To add a node registered in the Active Directory, follow these steps:
• Select Windows in the Operating System field.
• Select the node to add from Active Directory Nodes.

Note: Click Refresh to update the address and port stored on the local computer with the
values from the Active Directory listing.

3. To add a node that is not registered in the Active Directory, follow these steps:
• In the Name field, type the name of the Connect:Direct node you want to add.
• If necessary, change the operating system value in the Operating System field.
• In the Address field, type the TCP/IP address of the new node.
• The Port field automatically defaults to 1363; if necessary, type in a different port number.

4. To specify the new node as the default node, click Set as the default node.

5. Click OK to save your settings and close Node Properties.

6. Select File > Save to save the new settings.

Attention: Changes made to the node settings are not written to the Registry until you select
Save.

Delete a Node

To delete a node:

1. In the Client Connection Utility main window, select the node you want to delete.

2. Select Edit > Delete.

3. Select File > Save to delete the node.

Attention: Changes made to the node settings are not written to the Registry until you select
Save.

Add a User with Client Connection Utility

To add a new Connect:Direct user from the Client Connection Utility:
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1. In the Client Connection Utility main window, select the node where you want to add a new user.

2. From the File menu, select New User. The User Properties dialog box is displayed.

3. Type information in the following fields:

• Name—Type the name of the new user. Either type the user name as defined in the
Windows setup, such as lmore or type a fully qualified user name in the UPN format,
such as lmore@adtree.stercomm.com

• Password—Type the password defined for the user.
• Verify Password—Retype the password defined for the user.

4. Click the Remember password check box to automatically reload the password when you attach
as this user.

5. Click the Set as the default user check box if you want the new user to be the default user for the
node.

6. Click OK.

7. If the verification password you typed does not match the initial password, you receive a message
indicating the passwords do not match when you click OK. Retype the verification password and
click OK.

8. From the File menu, select Save to save the settings.

Note: Changes made to the node settings are not written to the Registry until you select
Save.

Delete a User with the Client Connection Utility

To delete a user from the node using the Client Connection Utility:

1. Click the plus (+) sign next to the node containing the user you want to delete.

2. Select the user you want to delete.

3. From the Edit menu, select Delete.

4. From the File menu, select Save to delete the user.

Note: Changes made to the node settings are not written to the Registry until you select
Save.

Update a Node or User

To update node properties:

1. Do one of the following:

• To update a node, highlight the node you want to configure.
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• To update a user, highlight the user you want to configure.

2. Select File > Properties.

3. Select the fields you want to edit and make the appropriate changes.

4. Click OK to save your settings and return to Node Properties.

5. Select File > Save to save the settings.

Attention: Changes made to the node and user settings are not written to the Registry until
you select Save.

Define a Default Node or User

The Client Connection Utility allows you to define a default node or default user. The default node
and user will be used by the Connect:Direct Requester and the CLI.

1. Do one of the following:

• To define a default node, highlight the node you want to designate as the default.
• To define a default user, highlight the user you want to designate as the default.

2. Select File > Save to save the settings.

Attention: Changes made to the node and user settings are not written to the Registry until
you select Save.

Import Registry Settings

The Connect:Direct Client Connection Utility allows you to import and export connection settings to
a file. These settings can be saved and used on another computer or node.

1. Select the node to which to import the Registry settings.

2. Select File > Import.

Caution: Importing a Registry settings file causes all current changes to the selected node
to be lost if they have not been saved.

3. Select the Registry settings file you want to import (.REX extension) and click OK.

4. Select File > Save to save the settings.

Attention: Changes made to the node settings are not written to the Registry until you select
Save.

Export Registry Settings
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To export Registry settings:

1. From the Client Connection Utility main window, select the node containing the Registry settings
you want to export.

2. Select File > Export.

3. Name the exported Registry file with a REX extension and click OK. The Registry settings in
the file can now be imported to another computer or node.

Print Registry Settings

To print a report of Registry settings:

1. Select File > Print.

2. Configure the print settings and click OK. A report of all Registry settings is generated.

3. Select File > Print Preview to preview the Registry settings report.

4. Click Zoom In to enlarge the text and read the report.

5. Click Print to print the report, or click Close to close without printing the report.

Note: Additional node detail is provided if the node has been used at least once by the
client software.
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Use Connect:Direct for Windows in Test Mode

Use Connect:Direct in Test Mode
While testing is being conducted, only Processes, particularly file transfers, involved with the testing
activity are executed. No production data is transferred to applications being tested while at the same
time no test data is transferred to production applications.

You can enable test mode for production instances of Connect:Direct for Windows to perform the
following functions:
• Test new applications and customer connections
• Prevent future production work from executing until testing is complete after you have

terminated all active production work using the Flush Process command
• Resume regular production work after testing
• Control individual file transfers by application
• Enable and disable individual nodes and applications

Processing Flow of the Test Mode
You enable the testing mode using the quiesce.resume initialization parameter and specify which
Connect:Direct Processes to run and not run by storing your preferences as text records in a parameter
table named NDMPXTBL. A sample parameters file, NDMPXTBL.sample, is located in the /Server/
samples directory.

Note: You can modify the quiesce.resume initialization parameter while the server is active.
Moved the note in this text from another section.

You can specify the following criteria that are used to find matches for one or more Processes to include
(using the “I” command code) or exclude (“X” command code) from execution:
• A partial or full Process name
• A partial or full remote node name
• A partial or full Connect:Direct submitter ID and submitter node combination

In addition to telling Connect:Direct which Processes to run, you tell the system what to do with the
Processes which do not get executed. You can specify the following dispositions for Processes not
permitted to run:
• Place the Process in the Hold queue
• Place the Process in the Timer queue for session retry
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• Flush the Process from the queue

For more information on how the testing mode can be used, see Sample Test Scenarios in this section.

When the testing mode is enabled, Connect:Direct for Windows performs a syntax check on the
parameter table and fails initialization if the table is invalid. If the table is valid, Connect:Direct for
Windows scans it looking for a pattern that matches the Process that is about to execute. If a match is
found, the Process is permitted to execute if the “I” (Include) command code is in effect. If command
code “X” (Exclude) is in effect, the process is not permitted to execute. If a match is not found in the
table, the opposite processing occurs from the case where a match is found, that is, if no match is found
and command code “I” is in effect, the Process is not permitted to execute, whereas if command code
“X” is in effect, the Process is permitted to execute.

If a Process is not permitted to execute, the disposition specified in the NDMPXTBL parameter table
to either hold, retry, or flush the Process is implemented and a non-zero return code is returned. When
a Process is prevented from executing in testing mode, appropriate messages are issued and can be
viewed in the statistics log.

Note: For Processes initiated on remote nodes, the testing mode functions in the same manner
as it does for Processes submitted on the local Connect:Direct node except that the remote
node is the PNODE (Process owner) for that Process, and the local node is the SNODE
(secondary node). The NDMPXTBL Parameter Table is searched for a matching entry,
and the remotely-initiated Process is either permitted to execute or is excluded from
execution. Because the local node is the SNODE for this type of transfer, it cannot
enforce the Process disposition setting in the NDMPXTBL parameter table. The remote
PNODE determines how the Process is handled. Typically, the remote node places the
Process in the Hold queue with a status of “HE” (Held in Error).

Prepare the NDMPXTBL Parameter Table

You can create or update the parameter table file while the server is active. Any changes made to the
file take effect for sessions that begin after the changes are made.

1. To modify the sample NDMPXTBL parameter table supplied with Connect:Direct for Windows,
open any text editor.

2. Change the table using the following commands.

Note: Each table entry or record consists of a single-character command code in column
one. Most command codes have a parameter which begins in column two and
varies according to the command code function.

Command Code Description Subparameters/Examples

* Comment Line * Only run the following Processes.
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Command Code Description Subparameters/Examples

E Enables execution of Processes based on table
entries. Either “E” or “D” must be the first non-
comment entry in the table.

The second column in this entry must
contain one of the following values
which indicates the disposition of a
PNODE Process if it is not allowed to
run.

H—Places the Process in the Hold
queue

R—Places the Process in the Timer
queue in session retry

F—Flushes the Process from the
queue

D Disables the execution of all Processes regardless
of the contents of the parameter table and fails
Process execution with a non-zero (error) return
code and message LPRX003E. Either “E” or “D”
must be the first non-comment entry in the table

The parameter for command code
“E” can also be specified in column
two. This is a convenience to make it
easier to change from “E” to “D” and
vice versa without having to change
column two to a blank for command
code “D.”

P Matches Processes based on a full or partial
Process name. Supports the wild card trailing
asterisk (*). Can be used to enable or disable
Process execution for a particular application by
using naming conventions to match an application.

PCOPY—Matches a single Process

PACH*—Matches all Processes
beginning with “ACH”

P*—Matches all Processes

N Matches Processes based on a full or partial
remote node name. Supports the wild card trailing
asterisk (*).

NCD.NODE1—Matches a single
remote node name

NCD.NODEA*—Matches all remote
node names beginning with
“CD.NODEA” N*—Matches all
remote node names

S Matches Processes based on a full or wild card
Connect:Direct submitter ID and submitter node
combination. The format is <id>@<node>.

SACTQ0ACD@TPM002—Matches
a specific ID and node combination.

S*@TPM002—Matches all IDs from
node TPM002

SACTQ0ACD@*—Matches ID
ACTQ0ACD from all nodes

S*@*—Matches all IDs from any
node. This is another way to match all
Processes.

I Includes Processes for execution that match the
patterns in the table which follow this command
code. Either “I” or “X” must be the second non-
comment entry in the table. Processes which do not
match a pattern in the table are not executed.
Note To choose which command code to use

to select Processes, determine which
group is smaller and use the
corresponding command Code. For
example, if the number of Processes to be
executed is smaller than the number of
Processes to exclude from execution,
specify “I” as the command code and add
patterns to match that group of
Processes.

ER

I

NCD.BOSTON

Includes Processes for execution on
the CD.BOSTON node only.
Processes destined for all other
remote nodes are placed in the Timer
queue in session retry.
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Command Code Description Subparameters/Examples

X Excludes from execution those Processes that
match the patterns in the table which follow this
command code. Either “X” or “I” must be the second
non-comment entry in the table. Processes which
do not match a pattern in the table are executed.

EH

X

DALLASOPS@*

Excludes Processes for execution
submitted by the ID SDALLASOPS
from any node.

L Last entry in table.

3. When you update the parameter table, name it NDMPXTBL and save it to the Server directory
of the installation.

Sample Test Scenarios
The following examples show different applications of the test mode using the NDMPXTBL parameter
table to define which Connect:Direct Processes to run and not run.

Specify Which Processes Run
In this example, Connect:Direct executes all Processes that start with ACH or are named DITEST01
or DITEST02. All other Processes are placed in the Hold queue.
* Enable processing. Only permit processes matching one of the patterns
* to execute. Hold processes that don't execute.
EH
I
PACH*
PDITEST01
PDITEST02
L

Specify Which Processes to Exclude
In this example, Connect:Direct does not execute any Process that starts with ACH or is named
DITEST01 or DITEST02. All other Processes are executed.
* Exclude matching processes.  Permit all others to execute.
EH
X
PACH*
PDITEST01
PDITEST02
L

Permit Process Execution by Secondary Node and Submitter User
ID/Node
In this example, Connect:Direct executes all Processes that match one of the following criteria:
• The specific secondary node (SNODE) name is DI.NODE1
• An SNODE whose name starts with DI0017
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• Any Connect:Direct submitter ID from node DI0049
• The specific Connect:Direct submitter ID SACHAPP from any node

All Processes not matching one of the above criteria are flushed from the queue.
* Only permit matching processes to execute.  Flush those that do not.
EF
I
NDI.NODE1
NDI0017*
S*@DI0049
SACHAPP@*
L

Stop the Test Mode
In this example, no Processes will not be executed, and a non-zero return code will be displayed, which
signifies an error along with message ID LPRX003E. The remainder of the table is ignored (including
the “F” code to flush Processes from the queue), and all Processes are placed in the Hold queue.

To resume testing, change the “D” command code to an “E.”
* Execute no processes at all.  Put them in the hold queue and return.
DF
I
PACH*
PDITEST01
PDITEST02
L
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