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Chapter 1

What’s New with the Interface between
Sterling Integrator and Connect:Direct

What's New with the Interface between Sterling Integrator and
Connect:Direct

If your company uses both Sterling Integrator and Connect:Direct to perform business activities, route data,
and transfer files, you can configure the Connect:Direct Server adapter on the Sterling Integrator side to act
asthe primary node, that is, the node on which the process is being submitted or the secondary node that
interacts with the primary node during process execution. In Sterling Integrator version 5.1, you will find
the following updates to the product and documentation:

4 General Enhancements on page 1

Improvements to Documentation on page 3

New Documentation on the Connect: Direct Process Website on page 3
Connect: Direct Process Examples on page 4

Enhancements to Connect: Direct Server Adapter Documentation on page 4
Serling Integrator Business Process Examples on page 5

R

General Enhancements

In Sterling Integrator version 5.1, several enhancements are focused on making it easier to use the
Connect:Direct Server adapter (CDSA) and other related Connect:Direct Server services, such as the
CopyTo service used to transfer files between a Sterling Integrator CDSA node and other Connect:Direct
server nodes. Here' sa summary of the general enhancements:

4+ Connect:Direct Service Adapter upgrade now allows you to make changes to an existing netmap,
which take effect immediately without disabling and re-enabling the adapter. Simply edit the
configuration of the Connect:Direct Service Adapter that uses the modified netmap, click Next until
you reach the Confirm page, and then click Finish for the system to immediately recognize your
netmap changes.

4+ Sterling Integrator version 5.1 and later supports the most common set of parameters availablein the
Connect:Direct for z/OS Process Copy statement To clause to provide more functionality, such as
enhanced file alocation and disposition options for the destination file on the remote Connect:Direct
for Z/OS node. To ensure that business processes created in earlier versions of Sterling Integrator
continue to execute properly, parameters existing in versions 5.0 and earlier will still be supported.
However, these old parameters cannot be mixed with new parametersin the same CopyTo service. Itis
recommended that you use the new parameters when you create a new business process and that when
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you make changes to an existing CopyTo service that you upgrade and use the new parameters, as
well. For more information, see Connect: Direct Server CopyTo Service on the Working with
Connect:Direct page.

To reduce the number of instances business processes that terminate with an error because of PNODE
session limits, Sterling Integrator now places business processes in a suspend queue to await session
availability. When a session count frees up, it is assigned to the oldest suspended business process
which can use the newly available session. The business process then resumes and is allowed to try to
establish a session. For more information on this workflow suspension processing feature, see How
Sessions for Business Processes Are Established on page 155.

Connect:Direct Service Adapter upgrade now alows you to take advantage of the checkpoint restart
feature. This feature allows the automatic restarting of copy operations that fail in certain ways, for
example, due to network errors. The copy operation is resumed from a previously checkpointed
location rather than having to start over from the beginning of the file transfer. To implement this
feature, you must enable retry processing. For more information, see How Checkpoint Restart and
Retry Processing Works on page 158.

In earlier versions of Sterling Integrator, you had to specify aretry in the business processitself. In
addition, in Sterling Integrator version 5.1 and later, when a session is established the current retry
counts are reset to zero so that if the session subsequently fails, the system starts counting retries from
zero, which represents a departure from the earlier behavior.

The copy checkpoint retry feature is now governed by the same short-term and long-term retries
parametersthat control retriesfor initial session establishment. Prior to Sterling Integrator version 5.1,
there were three sets of parameters related to session establishment and retry processing:

+ Session establishment parameters that were used only for initial session establishment . These two
fields, Number of Retry attempts for establishing a session and Interval between session
establishment attempts, were configurable in both the Connect:Direct Service Adapter and
Connect:Direct Server Begin Session Service. These parameters did not affect session
re-establishment after a session failure during COPY processing.

+ Short-term session retry parameters that were only used when the adapter attempted to establish a
session but there was no PNODE session available. These two fields, Number of short-term
session retry attempts and Interval between short-term session retry attempts, were configurablein
both the Connect:Direct Service Adapter and Connect:Direct Server Begin Session Service. The
server in that scenario would perform a series of delays and retries to try to acquire afree session
count. These parameters controlled the retrying of the acquisition of a session count but had
nothing to do with establishing sessions. This functionality has been made obsolete by the
workflow suspension processing feature described above. With that feature, a business processis
put in a suspend queue when there are no available sessions to await for the next free session
count.

+  Checkpoint-based copy-restart parameters that were used only in CopyTo and CopyFrom
processing. These two fields, Number of Retry attempts for checkpoint-based copy-restart and
Interval between Retry attempts, were configurable in only the Connect:Direct Service
Adapter.When a COPY operation failed with a 'restartable’ error such as a session failure, these
parameters controlled the number of retries performed and the interval between retry attempts.
This retry count was a hard limit on the number of retries that could be done during agiven
communications session regardless of whether sessions were re-established and then subsequently
lost or whether a session failed and then could not be re-established. This set of parametersis now
obsolete as aresult of the enhanced copy checkpoint retry feature.

Session establishment and retry processing has been both simplified and enhanced in Sterling
Integrator version 5.1. There are now two sets of parameters (short-term and long-term) instead of
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three and the two sets apply throughout the session both to initial session establishment and also to
re-establishment after afailure. These two sets of parameters are configured in the Connect:Direct
Server adapter and can be overridden in the Connect:Direct Server Begin Session service:

+ Session establishment parameters, which are now the long-term session retry settings and apply
both to initial session establishment as well asto COPY steps when a session must be
re-established. When the default settings defined in the adapter configuration are overridden in the
Begin Session service, the new values are retained for the duration of the session and aso apply to
any subsequent COPY steps.

+ Short-term session retry parameters, which now work in conjunction with the long-term session
retry parameters. The valuesfor the short-term parameters are used first if defined, and if asession
has still not been established (or re-established) when they are exhausted, the long-term retry
values are used, if configured. If the short-term values are overridden in the Begin Session service,
the new values are retained for the duration of the session and also apply to any subsequent COPY
steps.

File Allocation Retry (FAR) processing allows the Connect:Direct Server adapter to retry a Copy

operation when one of a set of certain file allocation errors occurs in combination with a non-zero

return code. Thisis most useful when the Connect:Direct Server adapter initiates afile transfer with a

remote Connect:Direct for zZ/OS system. This feature only affects locally initiated (PNODE) sessions

that use the Connect:Direct Server CopyTo service or CopyFrom service. For more information, see

How File Allocation Retry Processing Works on page 159.

For interoperability with other Connect:Direct nodes in high-availability environmnents, the Alternate
Comm Info parameter in the Connect:Direct Server adapter Netmap allows you to specify alist of
alternate hostnames and | P addresses that are used for Netmap checking of inbound connection
requests to the adapter. For more information, see Alternate Comm Info on page 14.

Improvements to Documentation

Throughout information related to the Connect:Direct Server adapter and services, links to the following
information have been added to make information more accessible so you can find related information
quickly:

*

4

*

Working with Connect:Direct page (to access the main webpage listing Connect:Direct Server
adapter-related information)

Sterling Integrator documentation library (to access information about the general Sterling Integrator
product that the Connect:Direct Server adapter and related services are part of)

Connect:Direct Process L anguage Web Site (to access the MFT website for information on
Connect:Direct processes and how to write them to communicate with Sterling Integrator)

New Documentation on the Connect:Direct Process Website

Information about the syntax to use when creating Connect:Direct Processes to communicate with Sterling
Integrator has been provided on the Connect:Direct Process Guide web site. Refer to the following topics
on the Connect:Direct Process L anguage Web Site:

4

+ + 4

Transmitting Files between Connect:Direct and Sterling Integrator
COPY Statement Keywords for Communicating with Sterling Integrator
Sending to a Sterling Integrator Mailbox

Sending to a Sterling Integrator Business Process


http://www.sterlingcommerce.com/documentation/home/MFT/MFTHome.html
http://www.sterlingcommerce.com/Documentation/SI51/homepage.htm
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Retrieving from a Sterling Integrator Business Process

Retrieving from a Sterling Integrator Mailbox

Specifying File Formats using SY SOPTS

Submitting a Sterling Integrator Business Process from Connect:Direct

R

Connect:Direct Parameters for Communicating with Sterling Integrator

Connect:Direct Process Examples

Several Connect:Direct Process examples have been provided to illustrate the syntax for the various
platforms supported by Connect:Direct. Refer to the following topics on the Connect:Direct Process
Language Web Site:

Copying a File from Connect:Direct for z/OS to a Sterling Integrator Mailbox
Copying aFile from Connect:Direct for UNIX to a Sterling Integrator Mailbox

<+

Copying aFile from Connect:Direct for Windows to a Sterling Integrator Mailbox
Copying aFile from Connect:Direct HP NonStop to a Sterling Integrator Mailbox

Copying aFile from Connect:Direct i5/OS to a Sterling Integrator Mailbox

Copying aFile from Connect:Direct for zZ/OS to a Sterling Integrator Business Process
Copying aFile from Connect:Direct for UNIX to a Sterling Integrator Business Process
Copying aFile from Connect:Direct for Windows to a Sterling Integrator Business Process
Copying aFile from Connect:Direct HP NonStop to a Sterling Integrator Business Process
Copying aFile from Connect:Direct i5/0S to a Sterling Integrator Business Process
Retrieving aFile from a Sterling Integrator Business Process to Connect:Direct for zZ/OS
Retrieving a File from a Sterling Integrator Business Process to Connect:Direct for Windows
Retrieving aFile from a Sterling Integrator Business Process to Connect:Direct for UNIX
Retrieving aFile from a Sterling Integrator Business Process to Connect:Direct HP NonStop
Retrieving a File from a Sterling Integrator Business Process to Connect:Direct i5/0S
Retrieving a File from a Sterling Integrator Mailbox to Connect:Direct for z/OS

Retrieving aFile from a Sterling Integrator Mailbox to Connect:Direct for Windows
Retrieving aFile from a Sterling Integrator Mailbox to Connect:Direct for UNIX
Retrieving aFile from a Sterling Integrator Mailbox to Connect:Direct HP NonStop
Retrieving aFile from a Sterling Integrator Mailbox to Connect:Direct i5/0S

Submitting a Sterling Integrator Business Process from Connect:Direct for Z/OS
Submitting a Sterling Integrator Business Process from Connect:Direct for UNIX
Submitting a Sterling Integrator Business Process from Connect:Direct for Windows
Submitting a Sterling Integrator Business Process from Connect:Direct HP NonStop
Submitting a Sterling Integrator Business Process from Connect:Direct i5/0S

R R R IR IR SR SRR A R IR IR SR IR I R R R

Enhancements to Connect:Direct Server Adapter Documentation

The Connect: Direct Server Adapter User Guide was introduced in June 2009. With the release of Sterling
Integrator version 5.1, this basic documentation has been enhanced by adding the following information:
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4+ A procedure on setting up a Sterling Integrator mailbox and the advantages of using virtual roots. See
Create a Serling Integrator Mailbox on page 20.

4+ Detailed information on checkpoint restart and retry processing and how sessions for business
processes are established. After reading thisinformation, you may want to adjust your configuration
settings to fit your environment. See Session Establishment and Process Recovery on page 155.

4+ Five new Sterling Integrator business process examplesin Sample Business Processes on page 105.

4+ Existing sample business processes involving both Connect:Direct and Sterling Integrator processing,
have been enhanced by adding the Connect:Direct Process which precedes the activity on the Sterling
Integrator side. Explanations for examples have been sharpened by adding platform-specific
information, and more details about operations, nodes, and files being transferred. See Sample
Business Processes on page 105.

In addition, the documentation for the following Connect:Direct Server services has been updated:
4 Connect:Direct Server Begin Session Service

Note: In Connect:Direct Server Begin Session Service, the Using Obscured Password field was added and the
related business process example was enhanced.

Connect:Direct Server CopyFrom Service
Connect:Direct Server CopyTo Service
Connect:Direct Server End Session Service
Connect:Direct Server Run Job Service
Connect:Direct Server Run Task Service
Connect:Direct Server Submit Service

Asnoted in General Enhancements on page 1, several enhancements in Sterling Integrator version 5.1 are
focused on making it easier to use the Connect:Direct Server adapter (CDSA) and other related
Connect:Direct Server services. To use these products most efficiently, it is recommended that you use the
information on the Working with Connect:Direct page as the best practice. If you need to refer to
information related to earlier versions of Sterling Integrator, refer to the adapter and services information
Sterling Integrator documentation library.

+ e+

Sterling Integrator Business Process Examples

Several Sterling Integrator business process examples have been provided to illustrate the syntax for the
various platforms supported by Sterling Integrator and Connect:Direct. Refer to the following topics on the
Working with Connect:Direct page:

Use Connect: Direct to Copy a File to Serling Integrator on page 106

Use Connect:Direct to Retrieve a File from Serling Integrator on page 107

Use Serling Integrator to Copy a File to a Connect: Direct for zZOS Node on page 109
Use Serling Integrator to Copy a File to a Connect: Direct for Windows Node on page 111
Use Serling Integrator to Copy a File to a Connect: Direct for UNIX Node on page 113
Use Serling Integrator to Copy a File to a Connect: Direct HP NonSop Node on page 115
Use Serling Integrator to Copy a File to a Connect: Direct for i5/0S Node on page 118
Use Serling Integrator to Copy a File from Connect: Direct on page 120

R IR I R I
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Add Error Handling to the Business Process on page 122

Use Serling Integrator to Submit a Connect: Direct Process on page 124

Use Serling Integrator to Sart a Connect: Direct Run Job on page 126

Use Serling Integrator to Sart a Connect: Direct Run Task on page 128

Hide the Connect: Direct Password in the Business Process on page 130

Use Serling Integrator to Copy a File to Connect: Direct for zZ/OS (Advanced) on page 132

e e e+

Contact Us

Sterling Commerce wel comes your comments and suggestions for improvements to our product
documentation. Y ou can submit suggestions for improvements to ConnectDoc@stercomm.com.



Chapter 1

About Connect:Direct and Sterling Integrator
Interoperability

About Connect:Direct and Sterling Integrator Interoperability

Sterling Integrator (formerly known as Gentran Integration Suite) enables a business to define
business processes in a software application and route data between enterprise systems using
different protocols and formats.

Connect:Direct is a peer-to-peer data transfer application that uses a proprietary protocol to
exchange data between Connect:Direct servers.

The Connect:Direct Server adapter is a component of Sterling Integrator that allows Sterling
Integrator to act like a Connect:Direct server, sending and receiving data using the Connect:Direct
protocol. The Connect:Direct Server adapter enables you to use files from a Connect:Direct server
in aSterling Integrator business process and to create business processes that exchange fileswith a
Connect:Direct server.

Connect:Direct and Sterling Integrator Processes

Connect:Direct and Sterling Integrator each have their own version of a process. Connect:Direct
uses a Process statement to initiate a session with another Connect:Direct node and then uses
specific statements to perform tasks and make requests on that node.

Sterling Integrator uses business process services to initiate a session with another Connect:Direct
node to perform tasks and make requests on that node. It is possible to use Sterling Integrator
business processesto handle complex processes such as order fulfillment, invoicing, inventory, and
other processes that require data exchange and business integration.

These business processes enable you to transfer your files, or business documents, to interna
processing activities and to trading partners, exchanges, and customers.

Connect:Direct Server Adapter User Guide 7
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Business Processes and Mailboxes

Y ou can copy filesfrom a Connect:Direct node directly to a Sterling Integrator business process or
mailbox. Sterling Integrator business processes utilize services and adapters, such as the
Connect:Direct Server adapter and related services, in asequence of stepsto achieve businessgoals.
The Sterling Integrator Mailbox is a business document repository that enables you to organize,
store, and manage trading partner documents and transactions.

Although staging and scheduling of datatransmission is present to varying degrees in numerous
applications and infrastructure components, it is beneficial to centralize the definition, operation,
management, and control of this staging and scheduling. In Sterling Integrator, these capabilities
are centralized in the Mailbox.

Y ou can set up mailboxes within Sterling Integrator so that files copied over to Sterling Integrator
are stored and retrieved later. When the files are stored in a mailbox, they are referred to as
messages. Y ou can also use mailbox routing rules to initiate business processesin Sterling
Integrator based on messages that are stored in a mailbox. For more information on setting up
mailboxes, see Create a Serling Integrator Mailbox on page 20.

After you have set up a Sterling Integrator mailbox or business process to which you want to send
afile, you can create the Connect:Direct Process to perform the file transfer. For moreinformation
about the Connect:Direct Process language and how to tailor it to communicate with Sterling
Integrator, refer to Sterling Integrator Connect: Direct Server Adapter Syntax and Sterling
Integrator-Connect: Direct Server Adapter Exampleson the Connect: Direct Process L anguage Web

Sitein the MFT Connect:Direct documentation library.

Using Connect:Direct Server Adapter Services in a Business
Process

The Connect:Direct Server adapter provides a suite of B2B services to establish communication

between Sterling Integrator and Connect:Direct.

Using these services, you can create business processes to perform the same tasks performed with
Connect:Direct Processes and with Connect:Direct commands.

The Connect:Direct Server services correspond to the Connect:Direct Process Language. These
services work with the Connect:Direct Server adapter. All services (except for Connect:Direct
Server BP Response Service) are used when the Connect:Direct Server adapter isthe PNODE. The
Connect:Direct Server BP Response Service is used when the Connect:Direct Server adapter isthe
SNODE and Connect:Direct isretrieving afile from Sterling Integrator.

The services created specifically for use with Connect:Direct are described in sample workflowsin
this user guide. These workflows demonstrate how each service is used within a business process.

The Connect:Direct Server adapter supports the following services:
4+ Connect:Direct Server Begin Session Service

8 Connect:Direct Server Adapter User Guide
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Purpose of the User Guide

Connect:Direct Server BP Response Service
Connect:Direct Server CopyFrom Service
Connect:Direct Server CopyTo Service
Connect:Direct Server End Session Service
Connect:Direct Server Run Job Service
Connect:Direct Server Run Task Service
Connect:Direct Server Submit Service

Purpose of the User Guide

The User Guide describes how to perform common user tasks with the Sterling Integrator
Connect:Direct Server adapter and remote Connect:Direct servers. These tasks include:

R R R R IR SRR

Use Connect: Direct to Copy a File to a Serling Integrator Mailbox on page 23
Use Connect: Direct to Copy a File to a Serling Integrator Business Process on page 27
Use Connect:Direct to Pull a File from Serling Integrator on page 35

Use Serling Integrator to Copy a File to Connect: Direct on page 45

Use Serling Integrator to Copy a File from Connect: Direct on page 53

Add Error Handling to a Serling Integrator Business Process on page 61

Add Securet+ Option on page 69

Use Serling Integrator to Submit a Connect: Direct Process on page 75

Use Serling Integrator to Sart a Connect: Direct Run Job on page 83

Use Serling Integrator to Sart a Connect: Direct Run Task on page 89

Hide the Connect: Direct Password in the Business Process on page 97

Requirements

Interoperability between Sterling Integrator and Connect:Direct has the following system
reguirements:

Supported Connect:Direct Versions

The following versions of Connect:Direct support interoperability with Sterling Integrator:

4

¢+ 4+

Connect:Direct for Z/OS 4.6 or later
Connect:Direct for Windows 4.4 or later
Connect:Direct for UNIX 3.8 or later
Connect:Direct HP NonStop 3.4 or later
Connect:Direct i5/0S 3.6 or later
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Supported Sterling Integrator Versions

Sterling Integrator versions 4.2 or later support interoperability with Connect:Direct.

Licensing Requirements for Connect:Direct Interoperability

10

Y ou must have appropriate adapter licensing to use one or more instances of the Connect:Direct
Server adapter.

Activate your Sterling Integrator licensefile, if required, from the Sterling Commerce Self-Service
Licensing Web site at www.productupdates.stercomm.com.

The Sterling Integrator Mailbox option enables you to copy and storefilesin personal mailboxesin
Sterling Integrator for later retrieval or to initiate Sterling Integrator business processes. To usethe
Sterling Integrator Mailbox option, you must have appropriate mailbox licensing.

Connect:Direct Server Adapter User Guide
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Chapter 2

Setup Procedures

Setup Procedures

Before you can transfer files or initiate processes between Connect:Direct servers and the Sterling
Integrator Connect:Direct Server adapter, perform the following:

4+ Create Connect:Direct and Serling Integrator User IDs on page 11

4+ Configure a Serling Integrator Netmap Entry on page 12

4+ Configure a Serling Integrator Connect: Direct Server Adapter on page 16

4+ Add Connect:Direct Server Adapter Node to Connect: Direct Netmap on page 19

In addition, if you will be transferring files from Connect:Direct nodes to Sterling Integrator
mailboxes, follow the instructions in the procedure, Create a Serling Integrator Mailbox on page
20.

Create Connect:Direct and Sterling Integrator User IDs

Y our Sterling Integrator administrator must create a Sterling Integrator User 1D for you. The
administrator must give this User ID permission to execute Sterling Integrator business processes
that you copy filesto or from. When you create your Connect:Direct processes, use this Sterling
Integrator User 1D asthe SNODEID of the Process statement.

Y our Connect:Direct administrator must create a Connect:Direct user account and givethisaccount
permission to copy files, submit processes, perform Run Jobs, and perform Run Tasks on the
Connect:Direct node. When you create your Sterling Integrator business processes, use this
Connect:Direct user account as the remote Connect:Direct User ID.

Connect:Direct Server Adapter User Guide 11
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Configure a Sterling Integrator Netmap Entry

A nodeisaConnect:Direct server. Two Connect:Direct servers (local and remote) function together
to perform data transfers. Either node can initiate the work by submitting a Process.

When a session is established, the node that initiates the session is the PNODE regardless of the
direction of information flow. The other nodeisthe SNODE. The Process can specify work destined
for either the PNODE or SNODE.

Note: The Sterling Integrator Connect:Direct Server adapter can be aConnect:Direct local or remote node
and can function asa PNODE or an SNODE, depending on whether or not it initiates the connection
with aremote Connect:Direct node.

The Connect:Direct Server adapter configuration identifies the remote nodes that it can
communicate with through the use of a network map, called a netmap.

When you create a Connect:Direct Server adapter, you must specify a netmap.

In Sterling Integrator version 4.3 and earlier, the netmap is integrated with the Connect:Direct
Server adapter configuration. In Sterling Integrator version 5.0 and later, netmaps are configured as
separate objects which allows one netmap to be shared by more than one CDSA.

In Sterling Integrator version 5.0 and later, you can configure anetmap in Sterling Integrator from
the Administration menu by selecting Deployment > Adapter utilities > C:D Netmaps.

From this menu, you can configure:

4 Connect:Direct Nodes
4+ Connect:Direct Netmaps
4 Connect:Direct Netmap cross-references (X-REF)

Note: Updatesto the netmap are not done dynamically. If you make changes to an existing netmap,
Connect:Direct node, or Connect:Direct netmap cross-reference, you must refresh the configuration
of each CDSA that uses the netmap by opening the adapter’s configuration and re-saving it. In
version 5.1, refreshing a CDSA's configuration does not affect any active sessions. Click Save to
go to the Confirm page, and then click Finish to update the configuration. Your configuration
changes to netmap members take effect immediately.

Connect:Direct Nodes

12

Create a Connect:Direct node definition for each remote Connect:Direct node that communicates
with the Sterling Integrator Connect:Direct Server adapter. Thisisonly required for nodesyou plan
to connect to and for nodes that connect to the Connect:Direct Server adapter when you have
netmap checking enabled.

Use the following procedure to create a new Connect:Direct node:

1. From the Administration menu, select Deployment > Adapter Utilities > C:D Netmaps > C.D
Nodes.
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2. Inthe Create Nodes pane, click Go!. The Create Nodes page appears.

Field

Value to Enter

Description

Connect:Direct
Server Node Name

Type the node name for the
Connect:Direct server.

Name that will be used to identify the Connect:Direct
server. Required.

Connect:Direct
Server Host

Type the host name or IP address for
the Connect:Direct server.

host name—Host name associated with the IP
address. For example:

host01 (where host01 is a machine on the local
domain)

host01.proddomain.com (fully-qualified host name)

nnn.nnn.nnn.nnn or
nnnn:nnnn:nnNn:nnNn:nnNN:nnnN:nnnn:nnnn—IP
address of a machine running Connect:Direct.

IPV6 is supported for Connect:Direct for UNIX 4.0 and
Connect:Direct for Windows 4.4 or later.

Required.

Connect:Direct Port

Type the host port number for the
Connect:Direct server.

TCP/IP port number that Connect:Direct monitors for
requests from remote nodes. Required.

Note: If Sterling Integrator is installed on a UNIX
operating system, do not select ports in the
range 1-1024. These are normally reserved
by the operating system.

Max locally initiated
(pnode) sessions
allowed

During testing, set this value to 100 so
that you do not run out of sessions.

After testing, enter the estimated
number of sessions you require.
Otherwise, accept the default value of
5.

Maximum number of sessions initiated locally by the
Connect:Direct Server adapter that may be active at
any time. Optional. If omitted, the value defined
by the Connect:Direct Server adapter is used.

This setting overrides the Max locally initiated (pnode)
sessions allowed setting in the Connect:Direct Server
adapter configuration.

Valid value: Any number up to 9999. Minimum value is
1. Default is 5.

For more information on session limits, see How
Sessions for Business Processes Are Established on
page 155.

Max remotely
initiated (shode)
sessions allowed

During testing, set this value to 100 so
that you do not run out of sessions.

After testing, enter the estimated
number of sessions you require.
Otherwise, accept the default value of
5.

Maximum number of sessions initiated by the remote
node that may be active at any point of time. If
omitted, the value defined by the Connect:Direct
Server adapter is used.

This setting overrides the Max remotely initiated
(snode) sessions allowed setting in the Connect:Direct
Server adapter configuration.

Valid value: Any number up to 9999. Minimum value is
1. Default is 5.

Connect:Direct Server Adapter User Guide
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Field Value to Enter Description

Alternate Comm Leave this blank unless the inbound Provides support for establishing netmap-checked

Info Connect:Direct node has more than sessions with high-availability (especially load
one outgoing IP address. balancing) systems with multiple IP addresses, such
If the inbound Connect:Direct node as Connect:Direct/Plex z/OS. Use this parameter to
has more than one outgoing IP list all IP addresses or host names that are part of the

address, specify the IP addresses or multiple 1P address environment.

host names in a comma-delimited list For Connect:Direct/Plex, this list should include the

as shown in the Description. address of each Connect:Direct/Server with a different
IP address from the Connect:Direct/Plex Manager.

If a remote node has more than one outgoing IP
address (as in a load balancing environment), specify
all of the remote node’s possible outgoing addresses
in the Alternate Comm Info field so that those outgoing
IP addresses are contained in the local node’s netmap
entry for that remote node. This configuration allows
netmap checking to succeed when the remote node
connects to the local node using any of the possible
outgoing IP addresses specified.

Valid format: hostnamel/IP address, hostname2/IP
address, hostname3/IP address (maximum length is
2048 characters)

host name—Host name associated with the IP
address. For example:

host01 (where host01 is a machine on the local
domain)

hostO1.proddomain.com (fully-qualified host name)
nnn.nnn.nnn.nnn or

nnnn:nnnNN:NNNN:NNNN:NNNN:NNNN:NNNN:nnNn—IP
address of a machine running Connect:Direct

IPV6 is supported for Connect:Direct for UNIX 4.0 and
Connect:Direct for Windows 4.4 or later.

Secure+ Option Accept the default setting (Disabled)  Valid if Netmap Override=Yes at the Connect:Direct
until you start using Secure+. Server adapter. Indicate if you want to disable or
Files are not encrypted during copy ~ €nable encryption. Required.
operations. Valid values are:
¢ Disabled (default)
¢ Enabled

3. Click Next. The Confirm page appears.
4. Review your configuration settings and click Finish.

Connect:Direct Netmaps

Once you have defined at |east one Connect:Direct node you want to use, you can create a netmap.
When you configure a Connect:Direct Server adapter, you must specify the netmap you want to use
rather than the individual Connect:Direct nodes you want to communicate with. The individual
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Connect:Direct nodes are associated with netmaps with cross references. This arrangement is very
flexible and allows you to:

4+ Define each Connect:Direct node one time no matter how many Connect:Direct Server
adapters you have.

4+ Usethe same netmap for multiple Connect:Direct Server adapters.

4 Create speciaized netmaps for different Connect:Direct Server adapters.

Use the following procedure to create a new Connect:Direct netmap:

1. From the C:D Netmaps menu, select C:D Netmaps. The C:D Netmaps page appears.
2. Inthe Create New Netmap pane, click Go!. The Create Netmap page appears.

Field Value to Enter Description
Netmap Name Type the Connect:Direct netmap Netmap names consist of alphanumeric, dollar ($), dot
name. (), underscore (), and dash (-) characters. The

maximum length is 64 characters. Required.

Note: If you maintain multiple Connect:Direct
Server adapters, you can use the same
name for the netmap and Connect:Direct
Server adapter for easier administration.

Netmap Type the netmap description. Required.
Description

3. Click Next. The Confirm Page appears.
4. Review your configuration settings and click Finish.

Connect:Direct Netmap Cross-References

Y ou can reuse nodes for a netmap or several netmaps by setting up a cross reference so you don't
have to create a new node for each Connect:Direct Server adapter.

Use the following procedure to create a new netmap cross reference:
1. Fromthe C:D Netmaps menu, select C:D Netmap X-REF.
2. Inthe Create or Modify Netmap Cross Reference pane, click Go!. The Create Cross Reference

page appears.
Field Value to Enter Description
C:D Netmap Name Select the Connect:Direct netmap Select the Connect:Direct Netmap name. Required.

name that you created in
Connect:Direct Netmaps on page
14.
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Field

Value to Enter Description

Add Node

Click the plus sign to add a Node
Name to the cross-reference. A new
window appears, allowing you to
select the Connect:Direct Node
Name(s).

Select the node name that you
created Connect:Direct Netmaps on
page 14.

3.
4,

Click Next. The Confirm page appears.
Review your configuration settings and click Finish.

Configure a Sterling Integrator Connect:Direct Server Adapter

16

The Sterling Integrator Connect:Direct Server adapter can function as either the PNODE, SNODE,
or both, in the Connect:Direct network, initiating and responding to Connect:Direct transfer
requests. Configuring a Connect:Direct Server adapter is similar to configuring a Connect:Direct
server.

Use the following procedure to configure a Connect:Direct Server adapter in Sterling Integrator:

1

2
3.
4

From the Deployment menu, select Services > Configuration.
Click Go in the Create New Service pane.
In the Service Type box, type Connect:Direct Server Adapter and click Next.

Configure the following fields for this scenario. Accept default values for al other fields. For
more information about all Connect:Direct Server adapter fields, refer to the Sterling
Integrator documentation library.

Note: To enable session establishment retry processing, the value specified for either the number of
long-term or short-term retry attempts must be greater than 0. Both of these adapter-level
settings can be overridden by values specified for in the Connect:Direct Server Begin Session
service for a particular business process.

Note: To enable copy restart processing, session establishment retry processing must be enabled. You
must also configure the Checkpoint Interval in the Connect:Direct Server adapter CopyTo or
CopyFrom service in your business process. For additional information, see How Checkpoint
Restart and Retry Processing Works on page 158.

Caution: When you configure how you want retry processing to work, note that the short-term retry
interval isconfigured in secondsrather than in minutesused for thelong-termretry interval.
For additional information, see How Checkpoint Restart and Retry Processing Works on
page 158.
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Configure a Sterling Integrator Connect:Direct Server Adapter

Field Value to Enter Description
Name Type a unique name for the Required.
Connect:Direct Server adapter Note: Name is the adapter name, not the node
configuration. name. However, in Sterling Integrator
business processes, Name is the
CDLocalNodeName. To avoid confusion, use
the same value for both Name and
Connect:Direct Server Node Name in your
Connect:Direct Server adapter configuration.
Description Type a description for the Required

Connect:Direct Server adapter
configuration.

Connect:Direct
Server Node Name

Type the node name to use to
identify this Connect:Direct Server
adapter. Best practice is to use the
same value as the Name field.

Maximum 16 characters. This node name must match
the Connect:Direct netmap entry for the Connect:Direct
Server adapter. Required.

Connect:Direct
Server Port

Type the listening port number for
the Connect:Direct Server adapter.

Make sure you select a port number
that is not in use by another
application.

TCP/IP port number that Connect:Direct Server adapter
monitors for requests from remote nodes. Required.

Note: If your application is installed on a UNIX
operating system, do not select ports in the
range 1-1024. These are normally reserved
by the operating system.

Max locally initiated
(pnode) sessions
allowed

During testing, you may want to set
this value to a high number, such as
100, so that you do not run out of
sessions.

After testing, enter the estimated
number of sessions you require.
Otherwise, accept the default value
of 5.

If you need to specify session limits
for each node, set this value at the
highest anticipated number of total,
locally initiated sessions and then
specify node limits in the netmap.

Maximum number of sessions initiated locally by the
Connect:Direct Server adapter that may be active at any
point in time. Required.

May be overridden at the node level. If a node-level
value is configured, the effective session limit is the
smaller of two values: the limit for the adapter and the
session limit for the remote node.

Valid value: Any number through 9999. Minimum value
is 1. Default is 5.

For more information on session limits, see How
Sessions for Business Processes Are Established on
page 155.

Connect:Direct Server Adapter User Guide
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Field

Value to Enter

Description

Max remotely
initiated (snode)
sessions allowed

During testing, you may want to set
this value to a high number, such as
100, so that you do not run out of
sessions.

After testing, enter the estimated
number of sessions you required.
Otherwise, accept the default value
of 5.

If you need to specify session limits
for each node, set this value at the

highest anticipated number of total,
remotely initiated sessions and then
specify node limits in the netmap.

Maximum number of sessions initiated by all remote
nodes that may be active at any point in time.
Required.

May be overridden at the node level. If a node-level
value is configured, the effective session limit is the
smaller of two values: the limit for the adapter and the
session limit for the remote node.

Valid value: Any number through 9999. Minimum value
is 1. Default is 5.

NetMap Check

For testing purposes, you may find
it convenient to select the default
(No). After testing, select the value
that best serves your network
security requirements.

Whether the node netmap should be checked to
authorize sessions. Required values are:

¢ Check both node name and IP address—Searches
the Connect:Direct Server adapter network map for
an entry corresponding to the node name of the
remote client. If one exists, the IP address is
obtained and compared to the IP address of the
remote node making the request.

¢ Check node name only—Searches the
Connect:Direct Server adapter network map for an
entry corresponding to the node name of the remote
client.

¢ No (default)—Disables netmap validation.

Number of
short-term session
retry attempts

Valid value: Any number up through
9999. Default is 0. Required.

Retry activity is logged (if logging
enabled).

For more information on retry
processing, see Session
Establishment and Process
Recovery.

Specifies the maximum number of short-term attempts
for creating a session with a Connect:Direct node or for
re-establishing a session after a session failure during
COPY processing (both CopyTo and CopyFrom). This
setting can be overridden by the value specified for
ShortTermMaxRetries in the Connect:Direct Server
Begin Session service.

Note: The counter for the number of short-term
session retry attempts is reset to zero when a
session is successfully reestablished.

Interval between
short-term session
attempts (seconds)

Valid value: Any number through
99999999. Default is 5. Required.

Specifies the amount of time, in seconds, to wait
between short-term session establishment and
re-establishment attempts. This setting can be
overridden by the value specified for
ShortTermRetrylnterval in the Connect Direct Server
Begin Session service.

This parameter performs successive retries within a
shorter period of time than is available with the Interval
between session establishment attempts (minutes)
settings.

18
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Field Value to Enter Description
Number of Valid value: Any number up to Specifies the maximum number of long-term attempts
long-term session  9999. Default is 0. Required. for creating a session with a Connect:Direct node or for
retry attempts Retry activity is logged (if logging re-establishing a session after a session failure during
enabled). COPY processing (both CopyTo and CopyFrom). This
setting can be overridden by the value specified for
BeginSessionMaxRetries in the Connect:Direct Server
Begin Session service.
Note: The counter for the number of long-term
session retry attempts is reset to zero when a
session is successfully reestablished.
Interval between Any number through 99999999. Specifies the time, in minutes, to wait between
long-term session  Required. Default is 1. long-term session establishment and re-establishment
attempts (minutes) attempts. This setting can be overridden by the value

specified for BeginSessionRetryInterval in the Connect
Direct Server Begin Session service.

Encryption using Select the default setting (Disabled) Whether Secure+ is enabled. Required. Valid values are
Secure+ until you start using Secure+. Enabled and Disabled. Default is Disabled.

Your Connect:Direct node must be licensed for Secure+
Option and the Secure+ Option must be installed on
your system. In addition, you must have the required
certificates for implementing Secure+. For information,
see the Connect:Direct documentation for the platform
you are using.

C:D Netmap Name Select the netmap name you
created in Connect:Direct Netmaps
on page 14.

5. Onthe Confirm page, review your configuration settings, select Enable Service for Business
Processes and click Finish.

Thiswill complete the Connect:Direct Server adapter configuration and start the adapter.

Add Connect:Direct Server Adapter Node to Connect:Direct
Netmap

On your Connect:Direct server, add the Sterling Integrator Connect:Direct Server adapter node
information to your Connect:Direct netmap with the following settings. Other settings may be
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required, and will vary according to the type of Connect:Direct environment. For moreinformation
on the values valid for your Connect:Direct platform, refer to your Connect:Direct documentation.

Parameter Value

Node Name The node name of the Sterling Integrator Connect:Direct
Server adapter.

Operating System The operating system for your Sterling Integrator system.
Specify UNIX.

Host/IP Address Host or IP address of your Sterling Integrator system

Port/Service Port/Service of your Sterling Integrator Connect:Direct

Server adapter

Create a Sterling Integrator Mailbox

When you copy afile from Connect:Direct to Sterling Integrator, you can copy to a Sterling
Integrator mailbox. Mailboxes allow you to organize, store, and manage trading partner documents
and transactions, by providing business document repositories. In addition, setting up mailboxes
within Sterling I ntegrator can also facilitate how you stage and schedul e datatransmissions, making
the storage and retrieval of files more transparent to al parties—senders and recipients alike.

After you have set up your mailboxes, see Use Connect:Direct to Copy a Fileto a Serling
Integrator Mailbox on page 23, for more information on how to write a Connect:Direct process to
send information to a Sterling Integrator mailbox. To see examplesinvolving copying filesfrom a
variety of Connect:Direct platforms to a Sterling Integrator mailbox, refer to Serling
Integrator-Connect: Direct Server Adapter Examples on the Connect:Direct Process L anguage Web
Site. To see examplesfor retrieving and storing primary documentsin a Sterling Integrator mailbox
system, see Use Serling Integrator to Copy a Fileto a Connect: Direct for i5/0OS Node on page 118
and Use Serling Integrator to Copy a File from Connect: Direct on page 120.

Using Virtual Roots in a Mailbox Hierarchy

20

Asinmost operating systems, such asWindows or UNIX, Sterling Integrator mailboxes support the
concept of aroot directory acting as the first or top-most directory in your mailbox hierarchy. In
Sterling Integrator, mailboxes are visible to users as arelative path, while administrators see the
mailbox as an absolute or full path. Virtual roots can be useful for maintaining and reorganizing a
mailbox hierarchy without impacting users. By limiting visibility into the mailbox hierarchy, virtua
roots can enhance the general security of your system.

When avirtual root isdefined for auser account, Sterling Integrator automatically insertsthe virtual
root component into the target filename specification. For example, if the JohnSmith user account
used JohnSmith asits virtual root (for example, /JohnSmith), Sterling Integrator would
automatically insert /JohnSmith into the target filename. Then, if the document, sample.txt, was
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Create a Sterling Integrator Mailbox

being sent to JohnSmith, the Connect:Direct Server adapter would process /mailbox/sample.txt as
if it were specified /mailbox/JohnSmith/sampl e.txt.

Conversely, if you do not define avirtual root for auser account, documents sent to the user account
are stored in the one and only mailbox directory, provided the user has adequate permission. For
example, if the JohnSmith user account did not have avirtual root defined for it, the sample.txt
document would be stored in the “root” of the mailbox as /mailbox/sample.txt.

Setting Up a Mailbox

Note: You do not create avirtual root for your mailbox in this simple procedure. To set up a mailbox

hierarchy using virtual roots, refer to the Sterling Integrator online documentation.

Use the following procedure to create and configure the Sterling Integrator mailbox:

> WD

o N o o

0.

Loginto Sterling Integrator.

From the Deployment menu, select Mailboxes > Configuration.

On the Mailbox Configuration page, click Go! in the Create a new Mailbox pane.
On the Mailbox Name page, highlight the forward-slash in the Select pane.

Note: If you arerequired to specify avirtual root for your mailbox, highlight the mailbox or mailbox
path in the Select pane for your virtual root.

In the Name box, type the name of your mailbox.
In the Description box, type a short description for your mailbox and click Next.
On the Assign Groups page, click Next.

On the Assign Users page, select your Sterling Integrator User ID in the Available Users pane
and click the right-arrow to move your User ID to the Selected Users pane.

Click Next.

10. On the Confirm page, click Finish to create your mailbox.
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Use Connect:Direct to Copy a File to a
Sterling Integrator Mailbox

Use Connect:Direct to Copy a File to a Sterling Integrator
Mailbox

This chapter describes how to copy afile from a Connect:Direct server (PNODE) to a Sterling
Integrator Connect:Direct Server adapter (SNODE). The Connect:Direct Server adapter passesthis
fileto a Sterling Integrator Mailbox.

Optionally, you can set up amailbox rule so that a document copied to amailbox triggers a Sterling
Integrator business process. For more information about mailbox rules, refer to the Sterling
Integrator documentation library.

Connect:Direct
Server Adapter| destinatio

: Mailbox
file

. \e
Conr;ect: Direct ource f (SNODE)
erver

(PNODE)
Sterling Integrator

Use the following workflow to copy afile from a Connect:Direct server to a Sterling Integrator
mailbox:

4 Create Your Connect:Direct Process on page 24
4+ Submit and Monitor Your Connect: Direct Process on page 24
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Create Your Connect:Direct Process

Create a Process for your Connect:Direct platform similar to the following example.

Note: It isassumed that you have already set up the Sterling Integrator mailbox to which the destination
fileis being copied. For more information, see Create a Serling Integrator Mailbox on page 20.

COPY2MB PROCESS
SNODE=yourCDSANode
SNODEID= (yourUserID, yourPassword)

STEP1 COPY
FROM (
FILE=yourSourceFile
)
TO (
FILE=/mailbox/yourMailbox/targetdocName
DISP=RPL
)

PEND

This Connect:Direct process copies your SourcefFilefrom your Connect:Direct server to the Sterling
Integrator Connect:Direct Server adapter, your CDSANode, which passes the file in the Sterling
Integrator mailbox, your Mailbox. The SNODEID, yourUserID, isyour Sterling Integrator User ID.
There are three parts to the destination FILE name in this Copy step:

4+ /mailbox/ is areserved word and signals to Sterling Integrator that you are copying to a
Mailbox.

4+ yourMailbox includes the name of your Sterling Integrator Mailbox.

4+ targetdocName is the document that is passed to your mailbox by the Connect:Direct Server
adapter. This document is stored in the mailbox. This document can be retrieved by an FTP
client, business process or another Connect:Direct process.

Note: Refer to Serling Integrator-Connect: Direct Server Adapter Examples on the Connect:Direct
Process L anguage Web Site to see several examples involving transferring files from a variety of
Connect:Direct platforms to a Sterling Integrator mailbox.

Submit and Monitor Your Connect:Direct Process

Submit the Connect:Direct process.

Monitor with Connect:Direct

Y ou can use Connect:Direct Select Statistics to monitor your Connect:Direct to Sterling Integrator
Pprocesses.
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If the Connect:Direct process is successful, the Select Statistics detail will report the following:

Attribute Value

Message ID SCPAO0O0OI

Message Text Copy operation successful
Destination File /mailbox/yourMailbox/targetdocName

If the Connect:Direct processis not successful, refer to Troubleshooting on page 161.

View the Mailbox Document in Sterling Integrator

Y ou can view targetdocName in your mailbox with Sterling Integrator.

Use the following procedure to view your mailbox document with Sterling Integrator:

1
2.

From the Deployment menu, select Mailboxes > Messages.

On the Message Management page, select Filter by Name to display the Available Mailboxes
pane.

In the Available Mailboxes pane, scroll down and highlight /yourMailbox and click the
down-arrow to move /your Mailbox to the Selected Mailboxes pane.

Click Go! to display the search results.

Information about the targetdocName document is displayed, including Document ID,
Created date, Size, Mailbox, Extract Policy, Policy Vaue, and whether this document is
locked by a business process.

In this example, targetdocName has an Extraction Policy of Extractable. This meansthat users
can extract this document from /your Mailbox an unlimited number of times with no expiration
date and time. You can change the extraction policy for targetdocName by clicking on the Edit
link. If you need to change the extraction policy for documents you copy to mailboxes using
Connect:Direct, edit your Connect:Direct Server adapter configuration for Extractability.

Note:  You can also monitor your Connect:Direct process from the Business Process menu by navigating

to Monitor > Advanced Search > Documents or Monitor > Advanced Search > Communication
Sessions.
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Use Connect:Direct to Copy a File to a Sterling Integrator
Business Process

This chapter describes how to use Connect:Direct to copy afile to Sterling Integrator. In this
scenario, the Connect:Direct server isthe PNODE and the Sterling Integrator Connect:Direct
Server adapter isthe SNODE. The Connect:Direct Server adapter receives the file and passesit to

abusiness process.
Connect:Direct
‘e Business Process
Connect:Direct SOUrce ) (SNODE)
Server
(PNODE)
Sterling Integrator

Use the following workflow to copy afile from Connect:Direct to a Sterling Integrator business
process:

4+ Create a Serling Integrator Business Process on page 28

Check Your Business Process into Serling Integrator on page 29
Create Your Connect:Direct Process on page 30

Submit and Monitor Your Connect: Direct Process on page 31

+ 4+ 4
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Create a Sterling Integrator Business Process

When you copy afile from Connect:Direct to Sterling Integrator, you must copy to a Sterling
Integrator business process or mailbox. In this scenario, you are copying a document to a business
process. This business process contains a service that provides information about the sourcefile.

Use the Sterling Integrator Graphical Process Modeler to create and modify business processes.
Individual services and adapters are represented by iconsin the Modeler.

Use the following procedure to create the Sterling Integrator business process.

1
2.
3.

28

Log in to Sterling Integrator and launch the Graphical Process Modeler from the Home screen.
Enter your Sterling Integrator User ID and password in the Log In dialog box.

From the View menu, select Stencil > BPML. Thiswill add the BPML stencil to the GPM.
The BPML stencil contains BPML icons to use in your business processes.

From the View menu, select Stencil > Sync Mode. Thiswill add the Sync Mode stencil to the
GPM.

The Sync Mode stencil contains an icon you will need in your business processes.
From the File menu, select New to open a new business process.

Drag and drop the following icons from the BPML and Sync Maode stencils into the Business
Process window in the following order, from left to right:

¢ Sart

¢ Get Document Information Service
¢ End

To link theicons:

a. Click thearrow on theright side of the Start icon and drag it to the arrow on the left side of
the Get Document Information Service icon.

b. Click thearrow ontheright side of the Get Document Information Serviceicon and drag it
to the arrow on the left side of the End icon.

@- P> @

start Get Document End
Infarmation Service

All business processes begin with a Start icon and end with an End icon. In this business
process, the Get Documentation Information Service provides information about the primary
document.
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8. Configure the Get Document Information Service using the following procedure:
a. Double-click the Get Document Information Service icon. This opens the Service Editor
window.

b. Inthe Service Editor-Get Documentation Information Service window, select
GetDocumentlnfoService from the Config drop-down list.

Service Editor-Get Document Information Service

Mame |GetDacumentInfﬂrmatinn Serice |

Config. |GetDucumentInquewice

l/ Message To Service r Message From Service

QOutput Msg |0htain Process Data first, then Messages | - |
Message Name |GetDacumentlnfDSeNiceTypeInputMessage |
MName Walue Jge XPATH? Append? L
BodyMame ] ] a|
CORRELATION false 1 1
DOCUMENT_ID 1 1 =
DocumentCharEnc... ] ]
DocumentContents... ] ] j
M en Aenb Aebaont T [ | [ | -
Advanced
Editor

In this step you specify the pre-defined GetDocumentInfoService configuration for the Get

Document Information Service. You can override configuration valuesin the Service Editor.

9. From the File menu, select Save. In the Validate dialog box, click Yes to validate the business

process.

10. On the Save dialog box, type the business process file name in the File Name box and click
Save.

Remember where you save thisfile.

Note: To see asample business process, refer to Use Connect: Direct to Copy a Fileto Serling I ntegrator

on page 106.

Check Your Business Process into Sterling Integrator
Use the following procedure to check the business process into Sterling Integrator:

1. Loginto Sterling Integrator.
2. From the Business Process menu, select Manager.
3. Onthe Business Process Manager page, in the Create Process Definition pane, click Gol.
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Type the name of your business processin the Name box.

5. Under Select an input mode for defining the new process, select Check in Business Process
created by the graphical modeling tool and click Next.

6. On the Check-in page, click Browse and navigate to the business process file name that you
saved in step 10 of the previous procedure.

Type a short description for your business process in the Description box and click Next.
On the Process Levels page, select the Set onfault processing check box.
Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full and click Next.

11. On the Deadline Settings page, click Next.

12. Onthe Life Span page, click Next.

13. On the Confirm page, select the Enable Business Process box.

14. Select the Create Permission box.

This adds the business process to the list of Sterling Integrator security permissions. This
makesit possible to assign permission for this business process to the user account.

15. Click Finish.

Note: The Sterling Integrator administrator must assign your Sterling Integrator User ID permissionto run
this business process.

Create Your Connect:Direct Process

Create a Process for your Connect:Direct platform similar to the following example.

COPY2SI PROCESS
SNODE=yourCDSANode
SNODEID= (yourUserID, yourPassword)

STEP1 COPY
FROM (
FILE=yourSourceFile
)
TO (
FILE=/businessprocess/yourBusinessProcess/targetdocName
DISP=RPL
)

PEND

This Connect:Direct process copies your SourceFilefrom your Connect:Direct server to the Sterling
Integrator Connect:Direct Server adapter, your CDSANode, which invokes the business process,
yourBusinessProcess. The SNODEID, yourUserID, isyour Sterling Integrator User ID. There are
three parts to the destination FILE name in this Copy step:
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4+ /businessprocess/ isareserved word and signalsto Sterling Integrator that you are copyingto a
business process.

4+ yourBusinessProcessis the name of the Sterling Integrator business process that the
Connect:Direct Server adapter invokes.

4+ targetdocName is the name of the document that is passed to the business process by the
Connect:Direct Server adapter. This document becomes the Primary Document in the
your BusinessProcess business process. The primary document is the document that the
servicesin abusiness process act on or in relation to; thisis usually the document passed to a
business process by the initiating adapter.
Sterling Integrator uses a unique document 1D to reference and track documents as they flow
through the application. The document ID is assigned by Sterling Integrator. The business
process may reference a document by the document name or the document 1D, depending on
the design of the business process.

Submit and Monitor Your Connect:Direct Process

Submit the Connect:Direct process.

Monitor with Connect:Direct

Y ou can use the Connect:Direct Select Statistics to monitor your Connect:Direct to Sterling
Integrator processes.

If the Connect:Direct process is successful, the Select Statistics detail will report the following:

Attribute Value

Message ID SCPAO0O0OI

Message Text Copy operation successful

Destination File /businessprocess/yourBusinessProcess/targetdocName

If the Connect:Direct process is not successful, refer to Troubleshooting on page 161.

Monitor with Sterling Integrator

Y ou can also use Sterling Integrator to monitor your Connect:Direct to Sterling Integrator
processes.

Use the following procedure to monitor your Connect:Direct process with Sterling Integrator:

1. From the Business Process menu, select Monitor > Advanced Search > Business Processes.
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2. Inthe Search Using Business Process Name pane, select your BusinessProcess in the Business
Processes list and click Go!.

 Business Process 'Hmding Partners -b Deployment 'P Operaiions 'b Accounts

Monitor

Items 1-1 of 1

11:24:071 AW 11:24:01 AW

Last update on 02192009 11:40:09 AM

The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful execution
ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting on page 161.
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Click the ID number to see details about the business process execution.

w Business Process | b Trading Pariners | b Deployment | b Operations [» Accounts

Business Process Detail

Name: ReceiveFromCD Instance ID: 2577320 Status: Success State: Completed User miodd
Deadline: Mone Contract 1D: Mone

Action:lRBSlEI‘t 'I

Steps 1-2 of 2

Advanced Status Instance
Status  Status Started Report Document Data
0 IMITIATING_COMTEXT Success |Mane 02/18/2009 02M8/2009 Mone | @info @irro
11:24:01 Al 11:24:01 AM
1 GetDocumentinfo service Success |Mone 02/18/2009 02/18/2009 ©irfo [ @inro ©irro
11:24:01 AM 11:24:01 AM

*Inline Invocation
Last update on 021 9/2009 11:45:30 AM
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The Business Process Detail page displays the following information:

Label Description

Step The business process step number

Service The Sterling Integrator service name used in the step
Status The status of the step

Advanced Status Additional status information

Started The time and date the step started
Ended The time and date the step ended
Status Report A link to the status report for the step
Document A link to documents in use by the step
Instance Data A link to process data for the step

Click the Document info link for Step 1, GetDocumentlInfo service.
The PrimaryDocument page displays the contents of the Primary Document, targetdocName.
Close the PrimaryDocument page.

From the Business Process Detail page, click the Instance Datainfo link for Step 1,
GetDocumentInfo service.
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The Process Data page displays process data for the business process. The datais presented in
XML format as shown:

<?xml version="1.0" encoding="UTF-8"?>
<ProcessData>
<PrimaryDocument SCIObjectID="oxnard:nodel:llefefe9db6:26492407"/>
<CDServerNodeData>
<RemoteFileName>C: \source. txt</RemoteFileName>
<PnodeName>CDWIN</PnodeName>
<LocalFileName>/businessprocess/ReceiveFromCD/dest.txt</LocalFileName>
<SnodeName>SI51CD</SnodeName>
</CDServerNodeData>
<BodyName>dest . txt</BodyName>
<BodyLength>5</BodyLength>
<DocumentBodyLength>5</DocumentBodyLength>
<DocumentLength>5</DocumentLength>
<DocumentName>dest . txt</DocumentName>
<DocumentId>oxnard:nodel:1llefefe9db6:26492400</DocumentId>

</ProcessData>

In this example, the Get Document Information Service puts information about the Primary
Document, such as the BodyName and BodyL ength, into process data.

Note:  You can also monitor your business processes from the Business Process menu by navigating to
Monitor > Advanced Search > Documents or Monitor > Advanced Search > Communication
Sessions.
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Use Connect:Direct to Pull a File from Sterling Integrator

This chapter describes how to pull afile from a Sterling Integrator Connect:Direct Server adapter
(SNODE) using the Connect:Direct node (PNODE). The Connect:Direct node connects to the
Sterling Integrator Connect:Direct Server adapter which invokes a business process. This business
process passes a document back to the Connect:Direct Server adapter which sends the file back to
the Connect:Direct node.

Connect:Direct| 2. Invoke BP
—>

(;DSP‘ y Server Adapter 3. Send file |Business Process

Connect:Direct 4. CoN (SNODE)

Server o e
A.

Sterling Integrator

Use the following workflow to pull afile from Sterling Integrator to a Connect:Direct server:

<+

+ 4+

Configure a File System Adapter on page 36

Create a Serling Integrator Business Process on page 38

Check Your Business Process into Serling Integrator on page 40
Create Your Connect:Direct Process on page 41

Submit and Monitor Your Connect: Direct Process on page 41
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Configure a File System Adapter

Use the File System Adapter within a Sterling Integrator business process to collect afile from the
Sterling Integrator file system. Use the following procedure to create the directory and file for the
File System Adapter:

Create a collection directory on the Sterling Integrator file system.

2. Create asourcefilein the collection directory.
3. Add the some text to the file so that you can verify that Connect:Direct pulls the correct file.
4. Create an extraction directory on the Sterling Integrator file system.

An extraction directory is required to configure a File System Adapter configuration, but it is
not used to extract filesin this example.

Before you can use the File System Adapter in a business process, create a configuration of the
adapter in Sterling Integrator. Use the following procedure to configure a File System Adapter:

1. Loginto Sterling Integrator and navigate to Deployment > Services > Configuration.
2. Onthe Services Configuration page, click Go! in the Create New Service pane.
3. Inthe Service Type box, type File System Adapter and click Next.

Field Value to Enter Description
Name Type a unique name for the File Required.
System Adapter service
configuration.
Description Type a meaningful description for  Required.
the File System Adapter service
configuration.
Collection folder Specify the collection folder you The name of the folder or subfolder on the same
created above. computer where Application is installed and where it

collects (or picks up) files as part of a business process. If
the path of the folder is not included as part of the name,
the folder is assumed to be in the Application working
directory.
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Field

Value to Enter

Description

Filename filter

Specify the filter to match the file
you created in the collection folder
above.

Collect only files that match a specified filter within the
collection folder. Optional.

Examples include:

¢ = txt (collects only .txt files)

¢ = dat (collects only .dat files)

¢ EDL* (collects only files named EDI with any file
extension)

¢ EDL.txt (collects only files named EDI with a file
extension of .txt)
Note: If there are multiple files in the collection folder
and you leave this field blank, one of the
following occurs:

¢ If the adapter is configured to start a business
process, it processes all files in the collection folder.

¢ |f the adapter is within a business process, it collects
only the first file in the folder.

Collect files from
subfolders within
and including the
collection folder?

Select No for this scenario so that
the File System Adapter does not
collect files from subfolders of the
collection folder.

Whether to scan for files in subfolders of the collection
folder. Required.

Valid values:

Yes—Collects files in the specified folder and all
subfolders.

No—Collects files in the specified folder only.

User absolute file
path name for the
document name?

Select No for this scenario so that
the document name does not
include the path name.

Whether to keep the absolute path name of the files
collected when assigning the document name. Required.

Valid values:

Yes—The absolute file path name is kept with the
document in the business process. Choose this value if
your business process requires the path information to
precede the file name.

No—Only the file name is kept with the document in the
business process.

Start a business
process once files
are collected?

Select No for this scenario.

Since you use the File System
Adapter within a business
process, there is no need to start
another business process.

Whether to start a business process using the File
System adapter after files are collected. Required.

Valid values:

Yes—Starts the business process specified from the
business process drop-down list.

No—~No business process will be started.

Extraction folder

Select No for this scenario.

The File System Adapter collects
a file, but does not write (extract)
a file in this scenario.

The name of the folder or subfolder on the same
computer where Application is installed and where it
installs (or writes) data from the primary document as part
of a business process. If you do not include the file path
for the folder as part of the name, the folder is assumed to
be in the Application working directory. Required.

4. Click Finish to save the configuration.
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Create a Sterling Integrator Business Process

38

When you use Connect:Direct to pull afile from Sterling Integrator, you invoke a Sterling
Integrator business process. This business process contains a CD Server BP Response Service that
sends the primary document back to Connect:Direct.

In this example, the business process uses a File System adapter to collect afile from the Sterling
Integrator file System. This file becomes the primary document in the business process. The CD
Server BP Response Service then sends the primary document to the Connect:Direct node viathe
Connect:Direct Server adapter.

Use the following procedure to create the Sterling Integrator business process:

1
2.
3.

Log into Sterling Integrator and launch the Graphical Process Modeler from the Home screen.
Enter your Sterling Integrator User 1D and password in the Log In dialog box.

If the BPML stencil is not visible in the GPM, navigate to the View menu and select Stencil >
BPML.

Thiswill add the BPML stencil to the GPM.

If the Sync Mode stencil is not visible in the GPM, navigate to the View menu and select
Sencil > Sync Mode.

Thiswill add the Sync Mode stencil to the GPM.
From the View menu, select Stencil > Applications > Sterling Commerce > Connect:Direct.

Thiswill add the Connect:Direct stencil to the GPM. The Connect:Direct stencil contains an
icon you will need in your business processes.

From the File menu, select New to open a new business process.

Drag and drop the following icons from the BPML, Sync Mode, and Connect:Direct stencils
into the Business Process window in the following order, from left to right:

* Sart

+ File System Adapter

¢ CD Server BP Response Service
¢ End

To link theicons:

a. Click thearrow on theright side of the Start icon and drag it to the arrow on the | eft side of
the File System Adapter icon.

b. Click the arrow on the right side of the File System Adapter icon and drag it to the arrow
on the left side of the CD Server BP Response Service icon.
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c. Click thearrow on theright side of the CD Server BP Response Serviceicon and drag it to
the arrow on the left side of the End icon.

o
+
a P @ ®
@ -gﬁ
start File System Adapter CD Sewer BP End
Response Service

9. Configure the File System Adapter using the following procedure:
a. Double-click the File System Adapter icon.

b. Inthe Service Editor-File System Adapter window, select your File System Adapter
configuration from the Config drop-down list. The Message To Service tab is displayed.

In this step you specify the configuration that you created for the File System Adapter.
You can override configuration values in the Service Editor.

c. Onthe Message to Service tab, select Collection as the Value for Action.
This causes the File System Adapter to collect files from the collection folder.
d. Select No asthe Value for deleteAfterCollect.

If deleteAfterCollect is set to Yes, the File System Adapter deletes the filesin the
collection folder after it collects them. When you are testing this business process, keep
this value set to No so that you don’t have to replace the source file after each test run.

Service Editor-File System Adapter

Hame |Fi|e Systermn Adapter |
Config. |CollectForCD |=|

l’ Message To Senice r Message From Service

Output Msg |0htain Message first, then Process Data | bt |

Message Hame |FiIeSystemInputMessage |
Marme Walue Lse XPATH? Append? L

Action Collection ] ] -

appendonExtract ] ] E

assignedFilename ] ]

assignFilename Jge the original filename as t.. [1 [1

attachFile ] ] —

[SY Tl fad DR [ — — 1

Advanced
Editor
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10.

11

12.

Configure the CD Server BP Response Service using the following procedure:
a. Double-click the CD Server BP Response Service icon.
This opens the Service Editor window.

b. Inthe Service Editor-CD Server BP Response Service window, select
CDServerBPResponse from the Config drop-down list.

In this step you specify the pre-defined CDServerBPResponse configuration for the CD
Server BP Response Service. You can override configuration values in the Service Editor.

From the File menu, select Save. In the Validate dialog box, click Yes to validate the business
process.

On the Save dialog box, type the name of your business process in the File Name box and
click Save.

Remember where you save thisfile.

Note: To see asample business process, refer to Use Connect: Direct to Retrieve a File from Serling

Integrator on page 107.

Check Your Business Process into Sterling Integrator

40

Use the following procedure to check the business process into Sterling Integrator:

a b~ 0D

10.
11.
12.
13.
14.

15.

Log in to Sterling Integrator.

From the Business Process menu, select Manager.

On the Business Process Manager page, in the Create Process Definition pane, click Gol.
Type your business process name in the Name box.

Under Select an input mode for defining the new process, select Check in Business Process
created by the graphical modeling tool and click Next.

On the Check-in page, click Browse and navigate to the business processfile that you saved in
step 12 of the previous procedure.

Type a short description of the business process in the Description box and click Next.
On the Process Levels page, select the Set onfault processing check box.

Set the Persistence Level to Full.

Set the Event Reporting Level to Full and click Next.

On the Deadline Settings page, click Next.

On the Life Span page, click Next.

On the Confirm page, select the Enable Business Process box.

Select the Create Permission box.

This adds the business process to the list of Sterling Integrator security permissions. This
makes it possible to assign permission for this business process to the user account.

Click Finish.
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Create Your Connect:Direct Process

Create a Process for your Connect:Direct platform similar to the following example.

PULLFILE PROCESS
SNODE=yourCDSANode
SNODEID= (yourUserID, yourPassword)

STEP1 COPY
FROM (
FILE=/businessprocess/yourBusinessProcess/yourSourceFile
SNODE
)
TO (
FILE=targetdocName
PNODE
DISP=RPL
)

PEND

This Connect:Direct process retrieves your SourceFile from the Sterling Integrator Connect:Direct
Server adapter which receives the file from your business process. There are three parts to the
FROM FILE namein the Copy step:

4+ /businessprocess is areserved word and signals to Sterling Integrator that you are invoking a
business process.

4+ yourBusinessProcessis the name of the Sterling Integrator business process that the
Connect:Direct Server adapter invokes.

4+ targetdocName is the name of the document that is passed from the Sterling Integrator
Connect:Direct Server adapter to your Connect:Direct hode. This document is the Primary
Document in your business process.

Submit and Monitor Your Connect:Direct Process

Submit the Connect:Direct process.

Monitor with Connect:Direct

Y ou can use the Connect:Direct Select Statistics to monitor your Connect:Direct to Sterling
Integrator processes.

I the Connect:Direct process is successful, the Select Statistics detail will report the following:

Attribute Value

Message ID SCPAO0O0OI

Message Text Copy operation successful

Source File /businessprocess/yourBusinessProcess/yourSourceFile
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Attribute Value

Destination File <default download directory>\targetdocName

If the Connect:Direct processis not successful, refer to Troubleshooting on page 161.

Monitor with Sterling Integrator
Use the following procedure to monitor your Connect:Direct process with Sterling Integrator:
1. From the Business Process menu, select Monitor > Advanced Search > Business Processes.

2. Inthe Search Using Business Process Name pane, select your business processin the Business
Processes list and click Go!.

The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful execution
ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting on page 161.
3. Click the ID number to see details about the business process execution.
The Business Process Detail page displays the following information:

Label Description

Step The business process step number

Service The Sterling Integrator service name used in the step
Status The status of the step

Advanced Status Additional status information

Started The time and date the step started
Ended The time and date the step ended
Status Report A link to the status report for the step
Document A link to documents in use by the step
Instance Data A link to process data for the step
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4. Click the Document info link for the Connect:Direct Server Response Service.
The PrimaryDocument page displays the contents of the primary document.
5. Close the PrimaryDocument page.

Note: You can also monitor your business processes from the Business Process menu by navigating to
Monitor > Advanced Search > Documents or Monitor > Advanced Search > Communication
Sessions.
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Use Sterling Integrator to Copy a File to Connect:Direct

This chapter describes how to copy afile from Sterling Integrator to Connect:Direct. The Sterling
Integrator business process passes a document to the Connect:Direct Server adapter (PNODE)
which copies the file to the Connect:Direct node (SNODE). The business process functions much
like a Connect:Direct process.

Connect:Direct )
Server Adapter|  source file

Connect:Direct des{\f\a{\o“ (PNODE)
Server f\e

(SNODE)

Business Process,

Sterling Integrator

Use the following workflow to copy afile from Sterling Integrator to a Connect:Direct server:

4+ Create a Serling Integrator Business Process on page 45
4+ Check Your Business Processinto Serling Integrator on page 49
4+ Submit and Monitor Your Serling Integrator Business Process on page 50

Create a Sterling Integrator Business Process

When you use Sterling Integrator to copy afileto Connect:Direct, you execute a Sterling I ntegrator
business processthat contains Connect:Direct Server adapter servicesto send the primary document
to Connect:Direct.

Use the following procedure to create the Sterling Integrator business process.
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Loginto Sterling Integrator and launch the Graphical Process Modeler from the Home screen.
Enter your Sterling Integrator User 1D and password in the Log In dialog box.

If the BPML stencil is not visible in the GPM, navigate to the View menu and select Stencil >
BPML.

Thiswill add the BPML stencil to the GPM.

4. From the View menu, select Stencil > Applications > Sterling Commerce > Connect:Direct.
Thiswill add the Connect:Direct stencil to the GPM.
From the File menu, select New to open a new business process.

6. Drag and drop the following icons from the BPML and Connect:Direct stencils into the
Business Process window in the following order, from left to right:

* Sart
¢ CD Server Begin Session Service
¢ CD Server CopyTo Service
¢ CD Server End Session Service
¢ End
7. Tolink theicons:

a. Click thearrow on theright side of the Start icon and drag it to the arrow on the left side of
the CD Server Begin Session Service icon.

b. Click the arrow on the right side of the CD Server Begin Session Serviceicon and drag it
to the arrow on the left side of the CD Server CopyTo Service icon.

c. Click the arrow on theright side of the CD Server CopyTo Serviceicon and drag it to the
arrow on the |eft side of the CD Server End Session Service icon.

d. Click thearrow ontheright side of the CD Server End Session Service icon and drag it to
the arrow on the left side of the End icon.

O——G——@——& @

start CD Server Beqin CD Server CopyTo D Server End End
Session Service Senvice Session Service

8. Configure the CD Server Begin Session Service using the following procedure:
a. Double-click the CD Server Begin Session Service icon.

The CD Server Begin Session Service functions like the Connect:Direct Process
statement. It initiates a session on a specified remote Connect:Direct hode.
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b. Inthe Service Editor-CD Server Begin Session Service window, select
CDServerBeginSession from the Config drop-down list. The Message To Servicetabis

displayed.
In this step you specify the pre-defined CDServerBeginSession configuration for the CD

Server Begin Session Service. You can override configuration values in the Service
Editor.

c. Select your Connect:Direct Server adapter node name as the Value for
LocalCDNodeName.

d. Typethe remote Connect:Direct node name as the Value for RemoteCDNodeName.
e. Typethe Connect:Direct User ID as the Value for RemoteUserld.

Note: You must add the Connect:Direct User ID to your Connect:Direct User Authorities.

f. Type the password for the Connect:Direct User ID asthe Value for RemotePasswd.
g. Select No asthe Vaue for UsingObscuredPasswd.

Service Editor-CD Server Begin Session Service

Name |CD Sewer Begin Session Service |

Config. |CDServerBeginSession [~]

l/ Message To Service |’ Message From Service

OutputMsy  |Obtain Message first, then Process Data [~]

Message Name |CDServerEleginSessionServiceTypelnputMessage |

Mame Value Use XPATH? Append? L
LocalCDModeMame S150C0 1 1 -
WOTIFY_PARENT_OM_... |ALL ] ]

PlexClass || m =

ProcessMarne || ||

RemoteCDMNodeMame  |[COWIN ] ]

[=RaTReTel ToY = P e | i i hd
Advanced

Editor

9. Click the Message From Service tab.

10. Select Allow message write for Input Msg.

11. Click Add and add the following information to the new record:
¢ Inthe Name box, type BeginSessionResults.
¢ Inthe Valuefield, type*.
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*

Select the Use XPATH? check box.

Senvice Editor-CD Server Begin Session Service

Name |CD Server Begin Session Service |

Config. |CDSemerBeginSessiun | - |

f Message To Service r Message From Senice

Input Msg |n.lluw message write | - |
Mame Walug Use XPATH? Appeand?
BeginSessionResults  |* [¥] ] Add
Delete

12. Configure the CD Server CopyTo Service using the following procedure:

a

Double-click the CD Server CopyTo Service icon. This opens the Service Editor window.

The CD Server CopyTo Service functions like the Connect:Direct Copy statement. It
copies afile from the PNODE to the SNODE.

In the Service Editor-CD Server CopyTo Service window, select CDServerCopyTo from
the Config drop-down list.

In this step you specify the pre-defined CDServerCopyTo configuration to use for the CD
Server CopyTo Service. You can override configuration values in the Service Editor.

Note: To seeal parameters available in the CopyTo service, see Settings for Connect: Direct
Server CopyTo Service on page 137.

Type rpl asthe Value for RemoteDI SP.
Thisis equivalent to DISP=RPL in a Connect:Direct Copy statement.
Type the destination file name as the Value for RemoteFileName.

Type //BeginSessionResults/SessionToken/node() as the Value for SessionToken and
select the Use XPATH? box.

The Session Token is created by the CD Server Begin Session Service and identifies the
session that is established with the remote Connect:Direct node. The SessionToken value
in the CD Server CopyTo Service ensures that this service copiesthe file using the session
initiated by the CD Server Begin Session Service.

13. Configure the CD Server End Session Service using the following procedure:
a. Double-click the CD Server End Session Service icon.

48

The CD Server End Session Service functions like the Connect:Direct End statement. It
terminates the session with the remote Connect:Direct node. If the CD Server End Session
does not execute, the session remains open.
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b. Inthe Service Editor-CD Server End Session Service window, select
CDServerEndSession from the Config drop-down list.

In this step you specify the pre-defined CDServerEndSession configuration to use for the
CD Server End Session Service. You can override configuration values in the Service
Editor.

c. Type//BeginSessionResults/SessionToken/node() as the Value for SessionToken and
select the Use XPATH? box.

The SessionToken value in the CD Server End Session Service ensures that this service
closes the session initiated by the CD Server Begin Session Service.

14. From the File menu, select Save. In the Validate dialog box, click Yes to validate the business

process.

15. On the Save dialog box, type your business process file name in the File Name box and click

Save.
Remember where you save thisfile.

Note:  Sample Business Processes on page 105, contains the following examplesinvolving the basic

scenario of copying afile to aremote Connect:Direct server from Sterling Integrator:

Use Serling Integrator to Copy a File to a Connect: Direct for zOS Node on page 109
Use Serling Integrator to Copy a File to a Connect: Direct for Windows Node on page 111
Use Serling Integrator to Copy a File to a Connect: Direct for UNIX Node on page 113
Use Serling Integrator to Copy a File to a Connect: Direct HP NonSop Node on page 115
Use Serling Integrator to Copy a File to a Connect: Direct for i5/0S Node on page 118
Use Serling Integrator to Copy a File to Connect: Direct for ZOS (Advanced) on page 132

+ e

Check Your Business Process into Sterling Integrator

Use the following procedure to check your business process into Sterling Integrator:

a b~ 0w D

7.
8.
0.

Log in to Sterling Integrator.

From the Business Process menu, select Manager.

On the Business Process Manager page, in the Create Process Definition pane, click Gol.
Type your business process name in the Name box.

Under Select an input mode for defining the new process, select Check in Business Process
created by the graphical modeling tool and click Next.

On the Check-in page, click Browse and navigate to your business process file that you saved
in step 15 of the previous procedure.

Type a short description of your business process in the Description box and click Next.
On the Process L evels page, select the Set onfault processing check box.
Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full.
11. Set the Recovery Level to Auto Resume and click Next.
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12.
13.
14.
15.

If Sterling Integrator stops responding during a copy transaction and the recovery level is set
to Auto Resume, the business process resumes automatically at the next Sterling Integrator
start up.

On the Deadline Settings page, click Next.

On the Life Span page, click Next.

On the Confirm page, select the Enable Business Process box.
Click Finish.

Submit and Monitor Your Sterling Integrator Business Process

50

Use the following procedure to submit your Sterling Integrator business process:

o

7.

8.

Log into Sterling Integrator.

From the Business Process menu, select Manager.

In the Search pane, type your business process name in the Process Name box and click Go!.
On the Business Process Manager page, click Execution Manager.

On the Execution Manager page, click Execute to launch the Execute Business Process | nput
dialog box.

Click Browse and navigate to your source file on your local system and click Open.
Thisisthe file that the business process will copy to the Connect:Direct server.

; Administration - Microsoft Internet Explorer provided by Sterling Commerce = |EI|5|

Execute Business Process Input

Process Hame: CopyToCD Version 2

Specily Input Parameters
Local Desl:t-:upfilename:|c \collectisi txt Browse. . |

OR

Server filename: |

Encoding Type: | [Mot Applicable] =

Run 4s I_Iser:ladmin =

*Input data is not required, click Go to continue.

@ [ [ [ [ [0 meedses

B

Click Go! to submit the business process.
The Execute Business Process page is displayed.
Close the Execute Business Process page.
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Monitor with Sterling Integrator

Use the following procedure to monitor your business process with Sterling Integrator:

1. From the Business Process menu, select Monitor > Advanced Search > Business Processes.

2. Inthe Search Using Business Process Name pane, select your business process name in the
Business Processes list and click Go!.

The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful execution
ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indi

cates unsuccessful execution, refer to Troubleshooting on page 161.

3. Click the ID number to see details about the business process execution.

The Business Process Detail page displays the following information for each step:

Label Description

Step The business process step number

Service The Sterling Integrator service name used in the step
Status The status of the step

Advanced Status

Additional status information

Started

The time and date the step started

Ended

The time and date the step ended

Status Report

A link to the status report for the step

Document

A link to documents in use by the step

Instance Data

A link to process data for the step

4, Click the Status

Report link for the Connect:Direct Server Primitive CopyTo Service.

The Status Report displays a short summary of the CopyTo operation including the destination
file name and number of bytes copied.

5. Click the Document info link for the Connect:Direct Server Primitive CopyTo Service.

The PrimaryDocument page displays the contents of the Primary Document.

6. Closethe PrimaryDocument page.

Connect:Direct Server Adapter

User Guide

51



Chapter 6 Use Sterling Integrator to Copy a File to Connect:Direct

7. From the Business Process Detail page, click the Instance Datainfo link for the
Connect:Direct Server Primitive CopyTo Service.

The Process Data page displays process datafor the business process. The datais presented in
XML format and contains several fields and values, such as:

* Remote Node—node name of the remote Connect:Direct server
¢  Remote User—Connect:Direct User ID
¢ Remote File Name—your destination file

8. Thelast step in the Business process Detail page isthe CD Server End Session Service. The
Status indicates that it successfully terminates the Connect:Direct session.

Note:  You can also monitor your business processes from the Business Processes menu by navigating to
Monitor > Advanced Search > Documents or Monitor > Advanced Search > Communication
Sessions.

Monitor with Connect:Direct

Y ou can use the Connect:Direct Select Statistics to monitor your Sterling Integrator to
Connect:Direct business process.

I the Connect:Direct process is successful, the Select Statistics detail will report the following:

Attribute Value

Message ID SCPAO0O0OI

Message Text Copy operation successful

Destination File <default download directory>\<your destination file>

If the Connect:Direct process is not successful, refer to Troubleshooting on page 161.
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Use Sterling Integrator to Copy a File from Connect:Direct

This chapter describes how to use Sterling Integrator to copy afile from Connect:Direct. The
Sterling Integrator business process invokes the Connect:Direct Server adapter (PNODE) which
copies the file from the Connect:Direct node (SNODE) and passes it back to the business process.
The business process functions much like a Connect:Direct process.

invokes

Connect:Direct
. Business Process
Connect:Direct

Server

SNODE

Sterling Integrator

Use the following workflow to copy afile from Sterling Integrator to a Connect:Direct server:

4+ Create a Serling Integrator Business Process on page 53
4+ Check Your Business Processinto Serling Integrator on page 57
4+ Submit and Monitor Your Serling Integrator Business Process on page 58

Create a Sterling Integrator Business Process

When you use Sterling Integrator to copy afile from Connect:Direct, you execute a Sterling

Integrator business process that contains Connect:Direct Server adapter services to copy thefile
from Connect:Direct.

Use the following procedure to create the Sterling Integrator business process.
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Loginto Sterling Integrator and launch the Graphical Process Modeler from the Home screen.

Enter your Sterling Integrator User 1D and password in the Log In dialog box.

If the BPML stencil is not visible in the GPM, navigate to the View menu and select Stencil >
BPML.

Thiswill add the BPML stencil to the GPM.

4. From the View menu, select Stencil > Applications > Sterling Commerce > Connect:Direct.
Thiswill add the Connect:Direct stencil to the GPM.
From the File menu, select New to open a new business process.

6. Drag and drop the following icons from the BPML and Connect:Direct stencils into the
Business Process window in the following order, from left to right:

*

*

*

*

*

Start

CD Server Begin Session Service
CD Server CopyFrom Service
CD Server End Session Service
End

7. Tolink theicons:

a

Click the arrow on theright side of the Start icon and drag it to the arrow on the |eft side of
the CD Server Begin Session Service icon.

Click the arrow on the right side of the CD Server Begin Session Service icon and drag it
to the arrow on the left side of the CD Server CopyFrom Service icon.

Click the arrow on the right side of the CD Server CopyFrom Serviceicon and drag it to
the arrow on the left side of the CD Server End Session Serviceicon.

Click the arrow on the right side of the CD Server End Session Service icon and drag it to
the arrow on the left side of the End icon.

start

D Senier Bedin D Sener CopwFrom D Semver End End
Session Service Service Session Service

8. Configure the CD Server Begin Session Service using the following procedure:

a

54

Double-click the CD Server Begin Session Serviceicon.

The CD Server Begin Session Service functions like the Connect:Direct Process
statement. It initiates a session on a specified remote Connect:Direct node.
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b. Inthe Service Editor-CD Server Begin Session Service window, select
CDServerBeginSession from the Config drop-down list. The Message To Servicetabis

displayed.

In this step you specify the pre-defined CDServerBeginSession configuration for the CD
Server Begin Session Service. You can override configuration values in the Service
Editor.

Note: To see all parameters available in the CopyFrom service, see Settings for Connect: Direct Server CopyFrom
Service on page 144.

c. Select your Connect:Direct Server adapter node name as the Value for
LocalCDNodeName.

d. Type the remote Connect:Direct node name as the Value for RemoteCDNodeName.
e. Typethe Connect:Direct User ID as the Value for RemoteUserld.

Note:  You must add the Connect:Direct User 1D to your Connect:Direct User Authorities.

f. Type the password for the Connect:Direct User ID asthe Value for RemotePasswd.
g. Select No asthe Vaue for UsingObscuredPasswd.

Service Editor-CD Server Begin Session Service

Name |CD Sewer Begin Session Service |

Config. |CDSenrerBeginSessiun | - |

l/ Message To Service r Message From Service

OutputMsg  |Obtain Message first, then Process Data [~]

Message Name |CDServerBeginSessionSenficeTypelnputMessage |

Mame Yalug Use XPATH? Append?

LocalCDModeMame SI50CD | Il T|
NOTIFY_PARENT_OM_... |ALL 1 1
PlexClass || 1 =
ProcessMame ] ]
RemoteCDMNodeMame  |[COWIN ] ] -
o P = L | — ™

Advanced

l Editor

9. Click the Message From Service tab.

10. Select Allow message write for Input Msg.

11. Click Add and add the following information to the new record:
+ Inthe Name box, type BeginSessionResults.
¢ Inthe Valuefield, type*.
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¢  Sdect the Use XPATH? check box.

Senvice Editor-CD Server Begin Session Service

Name |CD Server Begin Session Service |

Config. |CDSemerBeginSessiun | - |

f Message To Service r Message From Senice

Input Msg |n.lluw message write | - |
Mame Walug Use XPATH? Appeand?
BeginSessionResults  |* [¥] ] Add
Delete

12. Configure the CD Server CopyFrom Service using the following procedure:

a. Double-click the CD Server CopyFrom Service icon. This opens the Service Editor
window.

The CD Server CopyFrom Service functions like the Connect:Direct Copy statement. It
copies afile from the SNODE to the PNODE.

b. Inthe Service Editor-CD Server CopyFrom Service window, select CDServerCopyFrom
from the Config drop-down list.

In this step you specify the pre-defined CD ServerCopyFrom configuration to use for the
CD Server CopyFrom Service. You can override configuration values in the Service
Editor.

c. Typethe source file name as the Value for RemoteFileName.
Thisfile must reside on the file system of the Connect:Direct node.

d. Type//BeginSessionResults/SessionToken/node() as the Value for SessionToken and
select the Use XPATH? box.

The Session Token is created by the CD Server Begin Session Service and identifies the
session that is established with the remote Connect:Direct node. The SessionToken value
in the CD Server CopyFrom Service ensures that this service copies the file using the
session initiated by the CD Server Begin Session Service.

13. Configure the CD Server End Session Service using the following procedure:
a. Double-click the CD Server End Session Serviceicon.

The CD Server End Session Service functions like the Connect:Direct Pend statement
used on the Windows and UNIX platforms. It terminates the session with the remote
Connect:Direct node. If the CD Server End Session does not execute, the session remains
open.
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b. Inthe Service Editor-CD Server End Session Service window, select
CDServerEndSession from the Config drop-down list.

In this step you specify the pre-defined CDServerEndSession configuration to use for the
CD Server End Session Service. You can override configuration values in the Service
Editor.

c. Type//BeginSessionResults/SessionToken/node() as the Value for SessionToken and
select the Use XPATH? box.

The SessionToken value in the CD Server End Session Service ensures that this service
closes the session initiated by the CD Server Begin Session Service.

From the File menu, select Save. In the Validate dialog box, click Yesto validate the business
process.

On the Save dialog box, type your business process file name in the File Name box and click
Save.

Remember where you save thisfile.

Note: To see a sample business process, refer to Use Serling Integrator to Copy a File from

Connect: Direct on page 120.

Check Your Business Process into Sterling Integrator

Use the following procedure to check your business process into Sterling Integrator:

a ~ D

10.
11

12.
13.

Log in to Sterling Integrator.

From the Business Process menu, select Manager.

On the Business Process Manager page, in the Create Process Definition pane, click Go!.
Type your business process name in the Name box.

Under Select an input mode for defining the new process, select Check in Business Process
created by the graphical modeling tool and click Next.

On the Check-in page, click Browse and navigate to your business process file that you saved
in step 15 of the previous procedure.

Type a short description of your business process in the Description box and click Next.
On the Process Levels page, select the Set onfault processing check box.

Set the Persistence Level to Full.

Set the Event Reporting Level to Full.

Set the Recovery Level to Auto Resume and click Next.

If Sterling Integrator stops responding during a copy transaction and the recovery level is set
to Auto Resume, the business process resumes automatically at the next Sterling Integrator
start up.

On the Deadline Settings page, click Next.
On the Life Span page, click Next.
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14. On the Confirm page, select the Enable Business Process box.
15. Click Finish.

Submit and Monitor Your Sterling Integrator Business Process
Use the following procedure to submit your Sterling Integrator business process:
1. Loginto Sterling Integrator.
From the Business Process menu, select Manager.
In the Search pane, type your business process hame in the Process Name box and click Go!.
On the Business Process Manager page, click Execution Manager.

a ~ D

On the Execution Manager page, click Execute to launch the Execute Business Process Input
dialog box.

6. Click Go! to submit the business process.
The Execute Business Process page is displayed.
7. Close the Execute Business Process page.

Monitor with Sterling Integrator
Use the following procedure to monitor your business process with Sterling Integrator:
1. From the Business Process menu, select Monitor > Advanced Search > Business Processes.

2. Inthe Search Using Business Process Name pane, select your business process name in the
Business Processes list and click Go!.

The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful execution
ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting on page 161.
3. Click the ID number to see details about the business process execution.
The Business Process Detail page displays the following information for each step:

Label Description

Step The business process step number
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Label Description
Service The Sterling Integrator service name used in the step
Status The status of the step

Advanced Status Additional status information

Started The time and date the step started
Ended The time and date the step ended
Status Report A link to the status report for the step
Document A link to documents in use by the step
Instance Data A link to process data for the step

4. Click the Status Report link for the Connect:Direct Server Primitive CopyFrom Service.

The Status Report displays a short summary of the CopyFrom operation including the source
file name and number of bytes copied.

5. Click the Document info link for the Connect:Direct Server Primitive CopyFrom Service.
The PrimaryDocument page displays the contents of the Primary Document.
Close the PrimaryDocument page.

From the Business Process Detail page, click the Instance Datainfo link for the
Connect:Direct Server Primitive CopyFrom Service.

The Process Data page displays process data for the business process. The datais presented in
XML format and contains several fields and values, such as:

+ Remote Node—node name of the remote Connect:Direct server
¢ Remote User—Connect:Direct User ID
+ Remote File Name—your sourcefile

8. Thelast step in the Business process Detail page isthe CD Server End Session Service. The
Status indicates that it successfully terminates the Connect:Direct session.

Note:  You can also monitor your business processes from the Business Processes menu by navigating to
Monitor > Advanced Search > Documents or Monitor > Advanced Search > Communication
Sessions.

Monitor with Connect:Direct

Y ou can use the Connect:Direct Select Statistics to monitor your Sterling Integrator to
Connect:Direct business process.
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If the Connect:Direct process is successful, the Select Statistics detail will report the following:

Attribute Value

Message ID SCPAO0O0OI

Message Text Copy operation successful

Source File <default upload directory>\<your source file>

If the Connect:Direct processis not successful, refer to Troubleshooting on page 161.
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Add Error Handling to a Sterling Integrator Business Process

This chapter describeshow to add error handling to an existing Sterling I ntegrator business process.
The business process passes a document to the Connect:Direct Server adapter (PNODE) which
copies the file to the Connect:Direct node (SNODE). The error handling ensures that the
Connect:Direct session closesif an error is encountered during the session.

Y ou can add OnFault Groups to your business processes to capture specific errors and take
appropriate actions in the business process based on those errors. OnFault Groups allow you to add
business process logic to handle specific and general error conditions. If you do not use OnFault
Groups, your business process will quit on the step where the error occurs with no error handling.

Business Process Version Management

Sterling Integrator uses version management for implementing business process. As you make
changes to an existing business process and create variations of that business process, you need to
be sure that the business process that runs is the appropriate version.

The first time you check in a business process, the data you enter creates a business process
definition—auniquely named copy of the processthat is stored in Sterling Integrator. The business
process stored in Sterling Integrator is independent of any .bp file of the process that you savein a
local directory.

At any time, you can open an existing business process, modify and save it, and then either check
in the new version to Sterling Integrator, or save the modified copy of the processin Sterling
Integrator as a new process atogether. All previously checked-in versions of business processes
continue to be stored in Sterling Integrator. This enables you to revert to using an older version
should the need arise.

Use the following workflow to update your business process with error handling:
1. Check Out the Business Process on page 62

2. Edit the Business Process on page 62

3. Check In Your Business Process on page 64
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4. Submit and Monitor Your Serling Integrator Business Process on page 65

Check Out the Business Process

When you check out an existing business process with the Source Manager, you lock the business
process and prevent other users from modifying it at the sametime.

Use the following procedure to check out your existing business process that copies afile from
Sterling Integrator to Connect:Direct:

1. Loginto Sterling Integrator.
2. From the Business Process menu, select Manager.

3. Onthe Business Process Manager page, in the Search pane, type the existing business process
name in the Process Name box and click Go.

Click Source Manager for your business process.

5. On the Source Manager page, click check out for the version of the business process you want
to check out.

Click OK inthe dialog box to lock the file for editing.

In the File Download dialog box, click Save to save a copy of the business process to your
local file system.

8. Inthe Save Asdialog box, navigate to the directory where you want to save the business
process, type the business process file name in the File name box, and click Save.

Edit the Business Process

62

In this scenario, you add an OnFault Group to handle errors in your business process.

Use the following procedure to edit the Sterling Integrator business process:

1. Loginto Sterling Integrator and launch the Graphical Process Modeler from the Home screen.
2. Enter your Sterling Integrator User 1D and password in the Log In dialog box.

3. If the BPML stencil isnot visiblein the GPM, navigate to the View menu and select Stencil >
BPML.

Thiswill add the BPML stencil to the GPM.

4. If the Connect:Direct stencil is not visible in the GPM, navigate to the View menu and select
Stencil > Applications > Sterling Commerce > Connect:Direct.

Thiswill add the Connect:Direct stencil to the GPM.

From the File menu, select Open, navigate to the existing business process file and click Open.
6. Drag and drop the following icons from the BPML stencil into the Business Process window:

¢ Sequence Start

¢ OnFault Group

¢ Sequence End
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7. Toarrange and link theicons:

a. Click thelink between the CD Server Begin Session Service icon and CD Server CopyTo
Service icon and press Delete to remove the link.

b. Place the Sequence Start icon between the CD Server Begin Session Service icon and the
CD Server CopyTo Serviceicon.

c. Click the arrow on the right side of the CD Server Begin Session Serviceicon and drag it
to the arrow on the left side of the Sequence Start icon.

d. Click thearrow on the right side of the Sequence Start icon and drag it to the arrow on the
left side of the CD Server CopyTo Serviceicon.

e. Click thelink between the CD Server End Session Service icon and End icon and press
Delete to remove the link.

f. Place the Sequence End icon between the CD Server End Session Service icon and the
End icon.

g. Click the arrow on the right side of the End Sequence icon and drag it to the arrow on the
left side of the End icon.

h. Place the OnFault Group icon below and to the right of the Begin Sequence icon.

i. Click the arrow on the right side of the Begin Sequence icon and drag it to the arrow on
the left side of the OnFault Group.

Fry o s sy o
@[‘: w\{: > SHE @t‘: 9\%& SHIE
start CD Server Beqgin Seguence Sta cD Server CopyTo CD Server End Sequence End End
Session Service Service Session Service
OnF ault Group

8. Configure the OnFault Group using the following procedure:

a. Double-click the OnFault Group icon. This opens the Property Editor window and Layers
window.

The OnFault element contains a fault handling activity. If an error occurs between the
Sequence Start and Sequence End, the fault handling activity isinvoked. In this example,
the fault handling activity contains a CD Server End Session Service to ensure that the
session ends if thereis an error. If the OnFault Group is not included in this business
process and an error occurs on the CD Server CopyTo Service, the business process would
stop before the CD Server End Service and the session would stay active.

b. Inthe Layers Window, click the Default icon to open the fault handling activity in the
business process window.

The business process window contains an OnFault Start icon and an OnFault End icon.

c. Drag and drop the CD Server End Session icon from the Connect:Direct stencil into the
Business Process window and place it between the OnFault Start icon and the OnFault
End icon.
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d. Click the arrow on the right side of the OnFault Start icon and drag it to the arrow on the
left side of the CD Server End Session Serviceicon.

e. Click thearrow on theright side of the CD Server End Session Serviceicon and drag it to
the arrow on the left side of the OnFault End icon.

=Y
@ > @
CnF ault Start D Server End CnFault End
Sesgsion Service

f. Double-click the CD Server End Session Service icon.

g. Inthe Service Editor-CD Server End Session Service window, select
CDServerEndSession from the Config drop-down list.

In this step you specify the pre-defined CDServerEndSession configuration to use for the
CD Server End Session Service. You can override configuration values in the Service
Editor.

h. Type //BeginSessionResults/SessionToken/node() as the Value for SessionToken and
select the Use XPATH? box.

The SessionToken value in the CD Server End Session Service ensures that this service
closes the session initiated by the CD Server Begin Session Service.

9. From the File menu, select Save. In the Validate dialog box, click Yesto validate the business
process.

10. On the Save dialog box, type your business process file name in the File Name box and click
Save. Remember where you save thisfile.

Note: To seeasample business process, refer to Add Error Handling to the Business Process on page 122.

Check In Your Business Process

64

Use the following procedure to check the revised business process into Sterling Integrator:
1. Loginto Sterling Integrator.
2. From the Business Process menu, select Manager.

3. Onthe Business Process Manager page, in the Search pane, type your business process name
in the Process Name box and click Gol.

4. Click Source Manager for your business process.

5. Onthe Source Manager page, select Go! to Check in an updated definition for this business
process.

6. On the Process Definition Check-in page, click Browse and navigate to the business process
file that you saved in step 10 of the previous procedure.
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7. Typeashort description of the business process changes in the Description box and click
Next.

On the Process Levels page, select the Set onfault processing check box.
Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full.

11. Set the Recovery Level to Auto Resume and click Next.

If Sterling Integrator stops responding during a copy transaction and the recovery level is set
to Auto Resume, the business process resumes automatically at the next Sterling Integrator
start up.

12. On the Deadline Settings page, click Next.

13. Onthe Life Span page, click Next.

14. On the Set Default Version page, select the updated version of the business process.
15. On the Confirm page, select the Enable Business Process box.

16. Click Finish.

Submit and Monitor Your Sterling Integrator Business Process

Submit and monitor your revised Sterling business processto verify that it still works. The OnFault
Group should not execute and the execution results should be the same as they were before you
modified the business process.

In order to test the OnFault logic, you must cause the CD Server CopyTo Serviceto fail.
Use the following procedure to test the revised business process OnFault logic:

1. Modify the Connect:Direct User ID in Connect:Direct. In the Functional Authorities, set the
Download directory for the account to a nonexistent directory.

2. Submit the revised business process.
¢ The CD Server CopyTo Service fails and the business process executes the OnFault logic.

¢ The CD Server End Session Service contained in the fault handling logic ends the
Connect:Direct session.

Use the following procedure to submit your Sterling Integrator business process:

Loginto Sterling Integrator.

From the Business Process menu, select Manager.

In the Search pane, type your business process hame in the Process Name box and click Go!.
On the Business Process Manager page, click Execution Manager.

a b~ 0D

On the Execution Manager page, click Execute for the revised business process to launch the
Execute Business Process I nput dialog box.
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6. Click Browse and navigate to your source file on your local system and click Open.

Execute Business Process Input

Process Hame: CopyToCD Version 2

Specily Input Parameters
Local Desl:t-:upfilename:|c \collectisi txt Browse. . |

Server filename: |

*Input data is not required, click Go to continue.

OR

Encoding Type: | [Mot Applicable] =

Run 4s I_Iser:ladmin =

-

€]

[T T [ [ [@ tustedsites >

7. Click Go! to submit your business process. The Execute Business Process page is displayed.

8. Close the Execute Business Process page.

Monitor with Sterling Integrator

Use the following procedure to monitor your business process with Sterling Integrator:

1. From the Business Process menu, select Monitor > Advanced Search > Business Processes.

2. Inthe Search Using Business Process Name pane, select your business process name in the
Business Processes list and click Go!.

The Monitor page displays the following information:

Description

Status of the business process—a green traffic light signals a successful execution

The business process ID number

The business process name

The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting on page 161.
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3. Click the ID number to see details about the business process execution.
The Business Process Detail page displays the following information for each step:

Label Description

Step The business process step number

Service The Sterling Integrator service name used in the step
Status The status of the step

Advanced Status Additional status information

Started The time and date the step started
Ended The time and date the step ended
Status Report A link to the status report for the step
Document A link to documents in use by the step
Instance Data A link to process data for the step

4. Check the Status and Advanced Status for the Connect:Direct Server CopyTo Service.

The CopyTo service generates an error and reports Check the file permissions or path on
Remote Connect: Direct.

Advanced Status Instance
Step Service Status  Status Started Ended Report Document Data
10 |ConnectDirect |Success |Inline Begin 0212412009 | 02/24/2009 |Mane |Mone Mane
Senver CopyTo CDInterop_CopyToWithLoop  |[4:07:22 PM |[4:07:22 PM
Sernvice
11* |Echo Senvice Success |Mone 0212412009 | 02/24/2009 |Mone omfg ﬂinf.;.
40722 PM 40722 PM
12* [Assign Senvice |Success |MNone 02/24/2009 | 02/24/2009 (Mone | info info
40722 PM |[4:07:22 PM
13* |Assign Service |Success [Mone 02/24/2009 | 02/24/2009 |Mone oinfg ﬂinf.;.

4:07:22 PM |[4:07:22 PM
14* |ConnectDirect |Error Check the file permissions or |02/24/2009 [02/24/2009 [Mone omfg ﬂinf.;.
Server Primitive path on Remote 40722 PM |[4:07:22 FM
CopyTo Service ConnectDirect

15 | ConnectDirect |Error Check the file permissions or (02/24/2009 | 02/24/2009 | @@info | Einfo Qino

Senver CopyTa path on Remaote 4.07:22 PM [4:07:22 PM
=envice ConnectDirect

16 |Decision Success |5 0212412009 | 02/24/2009 |Mone omfg ﬂinf.;.
Engine Service 40722 PM |[4:07:22 PM

17 | ConnectDirect |Success [Mone 022472009 | 02/24/2009 | irfo | hinfo Qino
=ener End 4:07:22 PM [4:.07:22 PM

Session Sernvice
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5. The next step in the Business Pracess Detail is the Decision Engine Service.

This step isinvoked by the error handling of the OnFault Group in the business process. The
Status for this step indicates that the Decision Engine Serviceis successfully ableto invokethe
OnFault error handling.

6. Thelast step in the Business Process Detail isthe CD Server End Session Service.
The Status for this step indicates that it successfully closes the Connect:Direct session.

Note:  You can also monitor your business processes from the Business Processes menu by navigating to
Monitor > Advanced Search > Documents or Monitor > Advanced Search > Communication
Sessions.

Monitor with Connect:Direct

68

Y ou can use the Connect:Direct Select Statistics to monitor your revised Sterling Integrator to
Connect:Direct business process.

If the Connect:Direct process is unsuccessful, the Select Statistics detail will report the error, such
as the one shown for a Windows system:

Attribute Value

Message ID LSFNOO1 (if Connect:Direct is installed on a Windows system)
Message Text Unable to open file <your destination file> - Fdbk=3
Destination File <revised download directory>\<your destination file>

If the Connect:Direct process is not successful, refer to Troubleshooting on page 161.
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Add Secure+ Option

The Connect:Direct Secure+ Option provides enhanced security for Connect:Direct and Sterling
Integrator Connect:Direct Server adapter. When you enable the Secure+ Option, the files are
encrypted using SSL or TLS during transfer. This chapter describes how to configure the Sterling
Integrator Connect: Direct Server adapter to work with the Connect:Direct Secure+ Option to enable
encrypted file transfers.

The Secure+ Option for Connect:Direct is an optional component. Before configuring the
Connect:Direct Server adapter to work with Secure+ Option, it isassumed the following conditions
are already in place:

4+ Your Connect:Direct nodeis licensed for Secure+ Option and it isinstalled on your system.
4+ You have the required certificates for implementing Secure+ Option.

Note: You can usethe Sterling Certificate Wizard to generate certificate signing requests, self-signed
certificates, key certificate files and certificate chains. The online help in the Sterling
Certificate Wizard product will step you through the process.

4 You have configured the local and remote nodes for Connect:Direct Secure+ Option following
the instructions specific to the platform you are using. After submitting the parametersfile and
preparing Connect:Direct for operation, you have validated and tested connections between
you and your business partners to establish secure communications and then tested to make
sure you can change your security defaults for a session.

Use the following workflow to implement Secure+ Option:

4+ Configure Securet+ Option in Serling Integrator on page 70

4+ Copy a File Using Connect: Direct Securet+ Option on page 73

4+ Copy a File Using Your Serling Integrator Business Process on page 74
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Configure Secure+ Option in Sterling Integrator

70

Use the following procedure to check in the Connect:Direct root CA certificate with Sterling
Integrator:

1. From the Trading Partner menu, select Digital Certificates> CA.
2. Inthe Check in New Certificate pane, click Go!.

3. Onthe Get Certificate page, click Browse and navigate to the Connect:Direct CA root
certificate.

4. Onthe Choose File dialog box, click Open. The dialog box closes and returns you to the Get
Certificate page.

5. Click Next to advance to the Naming page.
6. Make anote of the Certificate Name and click Next.
7. Onthe Confirm page, click Finish.

Use the following procedure to check in the Key Certificate file for your Connect:Direct Server
adapter:

Note: You can use a self-signed certificate that you create in Sterling Integrator or Certificate
Wizard as your system certificate for testing purposes. Self-signed certificates are not
recommended for production use.

From the Trading Partner menu, select Digital Certificates > System.
In the Check in pane, click Go! for Key Certificate.
On the Key Certificate Data page, type a descriptive name in the Certificate Name box.

A w D P

In the Private Key Password box, type the passphrase associated with the Sterling Integrator
Connect:Direct Server adapter private key.

You created this passphrase when you generated your CSR.
Click Browse and navigate to the private key file.

On the Choose File dialog box, click Open. The dialog box closes and you return to the Key
Certificate Data page.

Click Next to advance to the Vaidate When Used page.
Click Next to advance to the Confirm Page.
Click Finish.

Note: If you plan to configure different Secure+ settings for individual nodes, you might need to check in
additional CA certificates and Key Certificate files.
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Modify the Connect:Direct Server Adapter Configuration to Use Secure+

Use the following procedure to modify a Connect:Direct Server adapter in Sterling Integrator to
enableit to use Securet:

1. From the Deployment menu, select Services > Configuration.

2. Tosdlect an existing Connect:Direct Server adapter, use the Search or List paneto display and
select the adapter, and click Go!.

3. Select edit on the Services Configuration page and then click Next until you see Encryption

page.

4. Configure the following fields for this scenario.

Field

Value to Enter

Description

Encryption using Enabled. Whether Secure+ is enabled. Required. Valid values are
Secure+ Enabled and Disabled. Default is Disabled.
Enable Netmap Node Select Yes for this scenario.  If Yes, specifies that remote node netmap security settings
Override Configure Secure+ at the override the adapter security settings. Required. Valid values
adapter level and allow node are Yes and No. Default is No.
level settings to override the
adapter Secure+ settings.
CA Certificates Select the CA certificate you  Drop-down menu that contains a list of trusted Certificate

checked in above.
This is the CA root certificate

for the Connect:Direct server.

Authority public certificates. Only displayed if "Encryption
using Secure+" is enabled. Required if Encryption using
Secure+ is enabled. Valid values are all CA certificates in this
installation of your application.

System Certificate

Select the System certificate
you checked in above.

This is the certificate for the
Connect:Direct Server
adapter node.

List of private keys and public certificates signed by the
trading partner trusted certificate authority. This represents
the certificate for the local node (this adapter). Only displayed
if Encryption using Secure+ is enabled. Required if
Encryption using Secure+ is enabled. Valid values are all
system certificates in this installation of your application.

Certificate Common
Name

If you want to verify the
Common Name of the
Connect:Direct CA
certificate, specify it here.

This feature is only available
if you use signed certificates.

Coordinate this with the

remote Connect:Direct
administrator.

Value to be compared with the Common Name (CN) field
from the remote node's certificate during TLS/SSL
handshake in order to enhance certificate authentication.
Only displayed if Encryption using Secure+ is enabled. May
be overridden at the node level.

Note: To see the actual CNs being compared during the
handshake, set the Perimeter Services logging level to ALL.
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Field

Value to Enter

Description

Cipher Suites

Select which cipher suites
you wish to use.

Coordinate this list with the
remote Connect:Direct
administrator.

Best practice is to list cipher
suites in strongest to weakest
order.

Indicates cipher suites available to support varying
encryption levels. Multiple selections allowed. Selections can
be rank ordered. Only displayed if "Encryption using
Secure+" is enabled. Required if "Encryption using Secure+"
is enabled. Valid values are all available cipher suites in this
installation of your application.

SSLor TLS

Select SSL or TLS.

Coordinate this choice with
the remote Connect:Direct
administrator.

Indicates if Secure+ is enabled using SSL or TLS. Only
displayed if "Encryption using Secure+" is enabled. Required
if "Encryption using Secure+" is enabled. Valid values are
SSL and TLS. Default is SSL.

Require Client
Authentication

Select Yes or No for client
authentication.

Coordinate this choice with
the Connect:Direct
administrator.

Indicates whether authentication occurs at the client level.
Valid values are:

Yes
No

Modify the Netmap Node Configuration to Override Secure+ Configuration (Optional)

At this point, Secure+ is configured for the Connect:Direct Server adapter at the adapter level. All
remote nodes will use these Secure+ settings. If you want to override any or all of the adapter level
Secure+ settings for aremote node, modify the Secure+ node settings for that node using the

following procedure;

Note: You must select Enable Netmap Node Override for the Connect:Direct Server adapter to use this

option.

From the Deployment menu, select Adapter Utilities > C:D Netmaps > C:D Nodes.

To select an existing Connect:Direct Node, use the Search or List pane to display and select
the Node, and click Gol.

3. Select edit next to the node name on the C:D Nodes page.

Do one of the following:

+ Todisable Securet+ encryption for this node, select the Secure+ Option Disabled button.

+ To modify Secure+ encryption for this node, select the Secure+ Option Enabled button,
and click Next. Edit the fields you want to override using information in the following
table:
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Field

Value to Enter

Description

CA Certificates

Select the CA root certificate
you checked in above for the
Connect:Direct server.

Drop-down menu that contains a list of trusted Certificate
Authority public certificates. Only displayed if "Encryption
using Secure+" is enabled. Required if Encryption using
Secure+ is enabled. Valid values are all CA certificates in this
installation of your application.

System Certificate

Select the System certificate
you checked in above for the
Connect:Direct Server
adapter node.

List of private keys and public certificates signed by the
trading partner trusted certificate authority. This represents
the certificate for the local node (this adapter). Only displayed
if Encryption using Secure+ is enabled. Required if
Encryption using Secure+ is enabled. Valid values are all
system certificates in this installation of your application.

Certificate Common
Name

If you want to verify the
Common Name of the
Connect:Direct CA
certificate, specify it here.

This feature is only available
if you use signed certificates.

Coordinate this with the
remote Connect:Direct
administrator.

Value to be compared with the Common Name (CN) field
from the remote node's certificate during TLS/SSL
handshake in order to enhance certificate authentication.
Only displayed if Encryption using Secure+ is enabled. May
be overridden at the node level.

Note: To see the actual CNs being compared during the
handshake, set the Perimeter Services logging level to ALL.

Cipher Suites

Select which cipher suites
you wish to use.

Coordinate this list with the
remote Connect:Direct
administrator.

Best practice is to list cipher
suites in strongest to weakest
order.

Indicates cipher suites available to support varying
encryption levels. Multiple selections allowed. Selections can
be rank ordered. Only displayed if "Encryption using
Secure+" is enabled. Required if "Encryption using Secure+"
is enabled. Valid values are all available cipher suites in this
installation of your application.

SSLor TLS

Select SSL or TLS.

Coordinate this choice with
the remote Connect:Direct
administrator.

Indicates if Secure+ is enabled using SSL or TLS. Only
displayed if "Encryption using Secure+" is enabled. Required
if "Encryption using Secure+" is enabled. Valid values are
SSL and TLS. Default is SSL.

Require Client
Authentication

Select Yes or No for client
authentication.

Coordinate this choice with
the Connect:Direct
administrator.

Indicates whether authentication occurs at the client level.
Valid values are:

Yes
No

Copy a File Using Connect:Direct Secure+ Option

Secure+ is configured and enabled on Connect:Direct and Sterling Integrator. Y ou do not have to
modify your Connect:Direct processto encrypt the file with Secure+.

Submit your existing Connect:Direct processto copy afileto Sterling Integrator. Y ou can monitor
the process results from Connect:Direct or Sterling Integrator as before.

Connect:Direct Server Adapter User Guide

73



Chapter 9 Add Secure+ Option

Copy a File Using Your Sterling Integrator Business Process

74

Y ou do not have to modify your Sterling Integrator business process to encrypt the file with
Secure+.

Submit and monitor your revised Sterling business process that contains the OnFault Group to
verify that it still works. The OnFault Group should not execute and the execution results should be
the same as they were before you maodified the business process.
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Use Sterling Integrator to Submit a Connect:Direct Process

This chapter describes how to modify the Sterling Integrator business process to submit a process
on the Connect:Direct node after the file is copied. The Connect:Direct process copies the file
received from Sterling Integrator to a z/OS system.

Use the following workflow to submit a Connect:Direct process with Sterling Integrator:
4+ Create Connect:Direct Process on page 75

Check Out the Business Process on page 76

Edit the Business Process on page 76

Check In Your Business Process on page 78

¢4+

Submit and Monitor Your Serling Integrator Business Process on page 78

Create Connect:Direct Process

Create a Connect:Direct process that copiesthefile received from the Sterling Integrator nodeto a
remote Connect:Direct node similar to the following example.

This processisinvoked by the Sterling Integrator business process.
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COPY2Z0S PROCESS

SNODE=RemoteNode

STEP1 COPY

FROM (
FILE=sourceFile

)

TO (
FILE=destinationFile
DISP=RPL

)

PEND

Check Out the Business Process

When you check out an existing business process with the Source Manager, you lock the business
process and prevent other users from modifying it at the same time.

Use the following procedure to check out your business process that contains the OnFault Group
from Sterling Integrator:

1
2.
3.

Log in to Sterling Integrator.
From the Business Process menu, select Manager.

On the Business Process Manager page, in the Search pane, type your business process name
in the Process Name box and click Gol.

Click Source Manager for your business process.

On the Source Manager page, click check out for the version of the business process you want
to check out.

Click OK inthe dialog box to lock the file for editing.

In the File Download dialog box, click Save to save a copy of the business process to your
local file system.

In the Save As dialog box, navigate to the directory where you want to save the business
process, type the business process file name in the File name box, and click Save.

Edit the Business Process

76

In this scenario, you add aCD Server Submit Serviceto the business process. The business process
copies afileto the Connect:Direct server and then submits a process on that same server.

Use the following procedure to edit the Sterling Integrator business process:

1
2.
3.

Loginto Sterling Integrator and launch the Graphical Process Modeler from the Home screen.
Enter your Sterling Integrator User 1D and password in the Log In dialog box.

If the Connect:Direct stencil is not visible in the GPM, navigate to the View menu and select
Stencil > Applications > Sterling Commerce > Connect:Direct.

Thiswill add the Connect:Direct stencil to the GPM.
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From the File menu, select Open, navigate to the CopyToCD.bp file and click Open.

5. Drag and drop the CD Server Submit Service icon from the Connect:Direct stencil into the
Business Process window.

6. Toarrange and link theicons:

a. Click thelink between the CD Server CopyTo Serviceicon and CD Server End Session
Service icon and press Delete to remove the link.

b. Placethe CD Server Submit Service icon between the CD Server CopyTo Serviceicon
and the CD Server End Session Service icon.

c. Click the arrow on theright side of the CD Server CopyTo Serviceicon and drag it to the
arrow on the left side of the CD Server Submit Serviceicon.

d. Click the arrow on the right side of the CD Server Submit Serviceicon and drag it to the
arrow on the |eft side of the CD Server End Session Service icon.

@rr m\{:'\r: SHE N{F\f\\r‘ F—‘ h{mb SHE @

start CD Server Begin Sequence Sta CD Server CopyTo D Server Submit D Server End Sequence End End
Session Service Service Service Sessgion Service

OnFault Graup

7. Configure the CD Server Submit Service using the following procedure:
a. Double-click the CD Server Submit Serviceicon. This opens the Service Editor window.

The CD Server Submit Service acts like a Submit statement in a Connect:Direct process.
Use this service to submit a Connect:Direct process on a remote Connect:Direct server.

b. Inthe Service Editor-CD Server Submit Service window, select CDServerSubmit from
the Config drop-down list.

In this step you specify the pre-defined CDServerSubmit configuration to use for the CD
Server Submit Service. You can override configuration values in the Service Editor.

Type the Connect:Direct process file name as the Value for RemoteProcessFile.

Type //BeginSessionResults/ SessionToken/node() as the Value for SessionToken and
select the Use XPATH? box.

The SessionToken value in the CD Server Submit Service ensuresthat this service submits
the Connect:Direct process using the session initiated by the CD Server Begin Session
Service.

8. From the File menu, select Save. In the Validate dialog box, click Yesto validate the business
process.

9. Onthe Save dialog box, type the business process name in the File Name box and click Save.
Remember where you save thisfile.

Note: To see a sample business process, refer to Use Serling Integrator to Submit a Connect: Direct
Process on page 124.
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Check In Your Business Process

Use the following procedure to check the revised business process into Sterling Integrator:
1. Loginto Sterling Integrator.
2. From the Business Process menu, select Manager.

3. Onthe Business Process Manager page, in the Search pane, type the business process namein
the Process Name box and click Go!.

Click Source Manager for the business process.

On the Source Manager page, select Go! to Check in an updated definition for this business
process.

6. On the Process Definition Check-in page, click Browse and navigate to the business process
file that you saved in step 9 of the previous procedure.

Type a short description of the updated business process in the Description box and click Next.
On the Process Levels page, select the Set onfault processing check box.
. Set the Persistence Level to Full.
10. Set the Event Reporting Level to Full.
11. Set the Recovery Level to Auto Resume and click Next.

If Sterling Integrator stops responding during a copy transaction and the recovery level is set
to Auto Resume, the business process resumes automatically at the next Sterling Integrator
start up.

12. On the Deadline Settings page, click Next.

13. Onthe Life Span page, click Next.

14. On the Set Default Version page, select the updated version of the business process.
15. On the Confirm page, select the Enable Business Process box.

16. Click Finish.

Submit and Monitor Your Sterling Integrator Business Process

78

Before you submit your revised Sterling business process, madify the Connect:Direct User ID in
Connect:Direct. In the Functional Authorities, set the Download directory back to its origina
setting so that the CD Server CopyTo Service does not fail.

Use the following procedure to submit your Sterling Integrator business process:

1. Loginto Sterling Integrator.

From the Business Process menu, select Manager.

In the Search pane, type the business process name in the Process Name box and click Go!.
On the Business Process Manager page, click Execution Manager.

a ~ D

On the Execution Manager page, click Execute for the revised business process to launch the
Execute Business Process I nput dialog box.
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6. Click Browse and navigate to your source file on your local system and click Open.

] Administration - Microsoft Internet Explorer provided by Sterling Comme

Execute Business Process Input

Process Name: CopyToCD Version 2

Specily input Parameters
Local Desl:t-:lpfilename:lc wcollectisi txt Browse... |

OR

Server filename: |

Encading Type: | [Maot Applicable] =

Run As l_lser:ladmin 4

“Input data is not required, click Gao to continue.

] [ [T [ | @ Trstedsites

B

7. Click Go! to submit the business process.
The Execute Business Process page is displayed.
8. Close the Execute Business Process page.

Monitor with Sterling Integrator
Use the following procedure to monitor your business process with Sterling Integrator:
1. From the Business Process menu, select Monitor > Advanced Search > Business Processes.

2. Inthe Search Using Business Process Name pane, select your business processin the Business
Processes list and click Go!.

The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful execution
ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting on page 161.

Connect:Direct Server Adapter User Guide 79



Chapter 10 Use Sterling Integrator to Submit a Connect:Direct Process

3. Click the ID number to see details about the business process execution.

The Business Process Detail page displays the following information for each step:

Label Description

Step The business process step number

Service The Sterling Integrator service name used in the step
Status The status of the step

Advanced Status Additional status information

Started The time and date the step started
Ended The time and date the step ended
Status Report A link to the status report for the step
Document A link to documents in use by the step
Instance Data A link to process data for the step

4. The Status for the Connect:Direct Server Submit Service is Success. Thisindicates only that

the Connect:Direct process was successfully submitted. It does not provide acompletion status
for the process. You must use the Connect:Direct Statistics to verify completion status for the
process.

17

15

-
w

Server End 2:2217 PM [2:22.17 FM

ConnectDirect Success |Inline End 030212009 03/02/2009 node1 [] |Mone |Mone Mane

2:22:17 PM [2:22:17 PM

ConnectDirectl Success |Mone
F Subrmnit

©irro| @irfo Diro

ConnectDirectl Success |Mone 03/02/2009) 03/02/2009 node 1 [ | @info| @info irfo

Ses

5. Thelast step in the Business Process Detail isthe CD Server End Session Service. The Status

for this step indicates that it successfully closes the Connect:Direct session.

Note:  You can also monitor your business processes from the Business Processes menu by navigating to

Monitor > Advanced Search > Documents or Monitor > Advanced Search > Communication
Sessions.

Monitor with Connect:Direct

Y ou can use the Connect:Direct Select Statistics to monitor your revised Sterling Integrator to
Connect:Direct business process.

80
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If the Connect:Direct processis successfully submitted, the Select Statistics detail will indicatethis
and show information similar to the following:

Attribute Value

Message ID LSMG4071 (if Connect:Direct is installed on a Windows system)
Message Text SUBMIT within a process step completed successfully

Source File <default process directory>\<Connect:Direct process file>

If the Connect:Direct process completes successfully, the Select Statistics will indicate this and
show information similar to the following:

Attribute Value

Message ID LSMG252I (if Connect:Direct is installed on a Windows system)
Message Text A user process has completed successfully

Process Name Connect:Direct process name

If the Connect:Direct processis not successfully submitted or executed, refer to Troubleshooting on
page 161.
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Use Sterling Integrator to Start a Connect:Direct Run Job

This chapter describes how to modify the Sterling Integrator business processto start a program on
the Connect:Direct server using a Run Job after afileis copied. The Connect:Direct Server adapter
does not verify the validity of the submitted program and does not wait for the submitted job to
complete. The program runs as a separate process.

Use the following workflow to start a Connect:Direct Run Job from Sterling Integrator:

4 Check Out the Business Pracess on page 83

Edit the Business Process on page 84

Check In Your Business Process on page 85

Submit and Monitor Your Serling Integrator Business Process on page 86

¢+

Check Out the Business Process

When you check out an existing business process with the Source Manager, you lock the business
process and prevent other users from modifying it at the sametime.

Usethefollowing procedure to check out your business processthat containsthe CD Server Submit
Service from Sterling Integrator:

Loginto Sterling Integrator.
From the Business Process menu, select Manager.

On the Business Process Manager page, in the Search pane, type your business process name
in the Process Name box and click Gol.

Click Source Manager for your business process.

5. Onthe Source Manager page, click check out for the version of the business process you want
to check out.

6. Click OK inthe dialog box to lock the file for editing.

Connect:Direct Server Adapter User Guide 83



Chapter 11 Use Sterling Integrator to Start a Connect:Direct Run Job

In the File Download dialog box, click Save to save a copy of the business process to your
local file system.

In the Save As dialog box, navigate to the directory where you want to save the business
process, type the business process file name in the File name box, and click Save.

Edit the Business Process

In this scenario, you replace the CD Server Submit Service with the CD Server Run Job Servicein
your business process. The business process copies afile to the Connect:Direct server and then
starts a Connect:Direct Run Job on that server.

The Run Job in this scenario is for a Connect:Direct for Windows SNODE. If your SNODE is not
a Connect:Direct for Windows system, create a Run Job similar to the following example
appropriate for your SNODE platform.

Use the following procedure to edit the Sterling Integrator business process.

1
2.
3.

Log in to Sterling Integrator and launch the Graphical Process Modeler from the Home screen.
Enter your Sterling Integrator User ID and password in the Log In dialog box.

If the Connect:Direct stencil is not visible in the GPM, navigate to the View menu and select
Stencil > Applications > Sterling Commerce > Connect:Direct.

Thiswill add the Connect:Direct stencil to the GPM.
From the File menu, select Open, navigate to the business process file and click Open.

Drag and drop the CD Server Run Job Service icon from the Connect:Direct stencil into the
Business Process window.

To arrange and link the icons:
a. Click the CD Server Submit Service icon and press Delete to remove it.

b. Pacethe CD Server Run Job Service icon between the CD Server CopyTo Serviceicon
and the CD Server End Session Service icon.

c. Click the arrow on theright side of the CD Server CopyTo Serviceicon and drag it to the
arrow on the left side of the CD Server Run Job Serviceicon.

d. Click the arrow on theright side of the CD Server Run Job Service icon and drag it to the
arrow on the left side of the CD Server End Session Service icon.

start

84
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Configure the CD Server Run Job Service using the following procedure:
a. Double-click the CD Server Run Job Service icon. This opens the Service Editor window.

The CD Server Run Job Service acts like a Run Job statement in a Connect:Direct process.
Use this service to start a Connect:Direct Run Job on aremote Connect:Direct server.

b. Inthe Service Editor-CD Server Run Job Service window, select CDServerRunJob from
the Config drop-down list.

In this step you specify the pre-defined CDServerRunJob configuration to use for the CD
Server Run Job Service. You can override configuration values in the Service Editor.

c. Type pgm(path/filename) desktop(yes) as the Value for Sysopts, where path is the full
directory path and filename is the file name of the program or script you wish to runin the
Run Job.

d. Type//BeginSessionResults/SessionToken/node() as the Value for SessionToken and
select the Use XPATH? box.

The SessionToken value in the CD Server Run Job Service ensures that this service starts
the Connect:Direct Run Job using the session initiated by the CD Server Begin Session
Service.

From the File menu, select Save. In the Validate dialog box, click Yes to validate the business
process.

On the Save dialog box, type the business process name in the File Name box and click Save.
Remember where you save thisfile.

Note: To seeasamplebusiness process, refer to Use Serling Integrator to Sart a Connect: Direct Run Job

on page 126.

Check In Your Business Process

Use the following procedure to check the revised business process into Sterling Integrator:

1
2.
3.

7.
8.
9.

Log in to Sterling Integrator.
From the Business Process menu, select Manager.

On the Business Process Manager page, in the Search pane, type the business process namein
the Process Name box and click Go!.

Click Source Manager for your business process.

On the Source Manager page, select Go! to Check in an updated definition for this business
process.

On the Process Definition Check-in page, click Browse and navigate to the business process
file that you saved in step 9 of the previous procedure.

Type a short description of your business process in the Description box and click Next.
On the Process Levels page, select the Set onfault processing check box.
Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full.
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11. Set the Recovery Level to Auto Resume and click Next.

If Sterling Integrator stops responding during a copy transaction and the recovery level is set
to Auto Resume, the business process resumes automatically at the next Sterling Integrator
start up.

12. On the Deadline Settings page, click Next.

13. Onthe Life Span page, click Next.

14. On the Set Default Version page, select the updated version of the business process.
15. On the Confirm page, select the Enable Business Process box.

16. Click Finish.

Submit and Monitor Your Sterling Integrator Business Process

86

Use the following procedure to submit your Sterling Integrator business process:

Log into Sterling Integrator.

From the Business Process menu, select Manager.

In the Search pane, type your business process name in the Process Name box and click Go!.
On the Business Process Manager page, click Execution Manager.

o > w0 N

On the Execution Manager page, click Execute for the revised business process to launch the
Execute Business Process | nput dialog box.

6. Click Browse and navigate to the source file on your local system and click Open.

; Administration - Microsoft Internet Explorer provided by Sinig( DITHTIERCE = |EI|5|

Execute Business Process Input

Process Hame: CopyToCD Version 2
Specify Input Parameters
Local Desl?t-:upfilename:|c \collectisi txt Browse. . |

OR

Server filename: |

Encoding Type: | [Mot Applicable] =

Run 4s I_Iser:ladmin =

*Input data is not required, click Go to continue.

€] [ [ [ [ [ [ tustedsies

B

7. Click Go! to submit the business process.
The Execute Business Process page is displayed.
8. Close the Execute Business Process page.
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The program, application, or script runs on the Connect:Direct server.

Monitor with Sterling Integrator

Use the following procedure to monitor your business process with Sterling Integrator:

1. From the Business Process menu, select Monitor > Advanced Search > Business Processes.

2. Inthe Search Using Business Process Name pane, select your business process name in the
Business Processes list and click Go!.

The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful execution
ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indi

cates unsuccessful execution, refer to Troubleshooting on page 161.

3. Click the ID number to see details about the business process execution.

The Business Process Detail page displays the following information for each step:

Label Description

Step The business process step number

Service The Sterling Integrator service name used in the step
Status The status of the step

Advanced Status

Additional status information

Started

The time and date the step started

Ended

The time and date the step ended

Status Report

A link to the status report for the step

Document

A link to documents in use by the step

Instance Data

A link to process data for the step
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4. The Status for the Connect:Direct Server Run Job Service is Success. This indicates only that
the Connect:Direct Run Job successfully started. It does not provide a completion status for
the application invoked by the Run Job.

—

ury

CopyTo

ConnectDirect Success | Inline End
18 | ConnectDirect Success|Mone

ConnectDirect Success |Mone

[1 [Mone |Mone Mone

32009 node [ | @info| @ info Qirro
41 AN

/2009 03/03/2009 node 1 [ | @Pinfo €@ info Ui T
AM (9:57:41 AM

5. Thelast step in the Business Process Detail isthe CD Server End Session Service. The Status
for this step indicates that it successfully closes the Connect:Direct session.

Note: You can also monitor your business processes from the Business Processes menu by navigating to
Monitor > Advanced Search > Documents or Monitor > Advanced Search > Communication

Sessions.

Monitor with Connect:Direct

Y ou can use the Connect:Direct Select Statistics to monitor your revised Sterling Integrator to
Connect:Direct business process.

If the Connect:Direct Run Job starts successfully, the Select Statistics detail will indicate this and
show information similar to the following:

Attribute

Value

Message ID

LSMG400I (if Connect:Direct is installed on a Windows system)

Message Text

A user RUNJOB step completed successfully

Source File

pgm(path/filename) desktop(yes)

If the Connect:Direct processis not successful, refer to Troubleshooting on page 161.

88
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Use Sterling Integrator to Start a Connect:Direct Run Task

This chapter describes how to modify your Sterling Integrator business processto start and wait on
aprogram on the Connect:Direct server viaa Run Task after the sourcefileis copied. The program
may be a program or script. The Connect:Direct Server adapter does not verify the validity of the
submitted program, but it does wait for the submitted job to complete before moving to the next
service in the business process. The program or script runs as a separate process.

Use the following workflow to start a Connect:Direct Run Task from Sterling Integrator:

*

.+

Check Out the Business Process on page 89

Edit the Business Process on page 90

Check In Your Business Process on page 91

Submit and Monitor Your Serling Integrator Business Process on page 92

Check Out the Business Process

When you check out an existing business process with the Source Manager, you lock the business
process and prevent other users from modifying it at the sametime.

Use the following procedure to check out your business process that contains the CD Server Run
Job Service from Sterling Integrator:

1
2.
3.

Loginto Sterling Integrator.
From the Business Process menu, select Manager.

On the Business Process Manager page, in the Search pane, type your business process name
in the Process Name box and click Gol.

Click Source Manager for your business process.

On the Source Manager page, click check out for the version of the business process you want
to check out.
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Click OK inthe dialog box to lock the file for editing.

In the File Download dialog box, click Save to save a copy of the business process to your
local file system.

In the Save As dialog box, navigate to the directory where you want to save the business
process, type the business process file name in the File name box, and click Save.

Edit the Business Process

In this scenario, you replace the CD Server Run Job Service with the CD Server Run Task Service
in your business process. The business process copies afile to the Connect:Direct server and then
starts a Connect:Direct Run Task on that server. The business process waits for the Run Task to
compl ete before the CD Server End Session Service terminates the Connect:Direct session.

The Run Task in this scenario isfor a Connect:Direct for Windows SNODE. If your SNODE is hot
a Connect:Direct for Windows system, create a Run Task similar to the following example
appropriate for your SNODE platform.

90

@[‘»‘

start

Use the following procedure to edit the Sterling Integrator business process:

1
2.
3.

Log in to Sterling Integrator and launch the Graphical Process Modeler from the Home screen.
Enter your Sterling Integrator User 1D and password in the Log In dialog box.

If the Connect:Direct stencil is not visible in the GPM, navigate to the View menu and select
Stencil > Applications > Sterling Commerce > Connect:Direct.

Thiswill add the Connect:Direct stencil to the GPM.
From the File menu, select Open, navigate to the business process file and click Open.

Drag and drop the CD Server Run Task Service icon from the Connect:Direct stencil into the
Business Process window.

To arrange and link the icons:
a. Click the CD Server Run Job Serviceicon and press Delete to removeit.

b. Placethe CD Server Run Task Service icon between the CD Server CopyTo Serviceicon
and the CD Server End Session Serviceicon.

c. Click the arrow on theright side of the CD Server CopyTo Service icon and drag it to the
arrow on the left side of the CD Server Run Task Service icon.

d. Click thearrow on theright side of the CD Server Run Task Serviceicon and drag it to the
arrow on the left side of the CD Server End Session Service icon.

Gl @@

CD Server Begin Sequence Sta CD Server CopyTo  CD Server Run Task CD Server End Sequence End End
Session Service Service Service Session Service

OnF ault Graup
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Configure the CD Server Run Task Service using the following procedure:

a. Double-click the CD Server Run Task Serviceicon. This opens the Service Editor
window.

The CD Server Run Task Service acts like a Run Task statement in a Connect:Direct
process. Use this service to start a Connect:Direct Run Task on aremote Connect:Direct
server and wait for it to complete before executing the next service in a business process.

b. Inthe Service Editor-CD Server Run Task Service window, select CDServerRunTask
from the Config drop-down list.

In this step you specify the pre-defined CDServerRunTask configuration to use for the CD
Server Run Task Service. You can override configuration values in the Service Editor.

c. Type pgm(path/filename) desktop(yes) asthe Value for SystemOpts, where path is the full
directory path and filename is the file name of the program or script you wish to run in the
Run Task. (SystemOpits is the equivalent of Sysopts.)

Note: Do not enclose the value specified for SystemOpts in double quotes.

d. Type//BeginSessionResults/SessionToken/node() as the Value for SessionToken and
select the Use XPATH? box.

The SessionToken valuein the CD Server Run Task Service ensures that this service starts
the Connect:Direct Run Task using the session initiated by the CD Server Begin Session
Service.

From the File menu, select Save. In the Validate dialog box, click Yesto validate the business
process.

On the Save dialog box, type the business process file name in the File Name box and click
Save. Remember where you save thisfile.

Note: To see a sample business process, refer to Use Serling Integrator to Sart a Connect: Direct Run

Task on page 128. To see amore complex example involving Connect:Direct for zZ/OS, see Use
Serling Integrator to Copy a File to Connect: Direct for 2/OS (Advanced) on page 132.

Check In Your Business Process

Use the following procedure to check the revised business process into Sterling Integrator:

1
2.
3.

Loginto Sterling Integrator.
From the Business Process menu, select Manager.

On the Business Process Manager page, in the Search pane, type the business process namein
the Process Name box and click Go!.

Click Source Manager for your business process.

On the Source Manager page, select Go! to Check in an updated definition for this business
process.

On the Process Definition Check-in page, click Browse and navigate to the business process
file that you saved in step 9 of the previous procedure.
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10.
11

12.
13.
14.
15.
16.

Use Sterling Integrator to Start a Connect:Direct Run Task

Type a short description of your business process in the Description box and click Next.
On the Process Levels page, select the Set onfault processing check box.

Set the Persistence Level to Full.

Set the Event Reporting Level to Full.

Set the Recovery Level to Auto Resume and click Next.

If Sterling Integrator stops responding during a copy transaction and the recovery level is set
to Auto Resume, the business process resumes automatically at the next Sterling Integrator
start up.

On the Deadline Settings page, click Next.

On the Life Span page, click Next.

On the Set Default Version page, select the updated version of the business process.
On the Confirm page, select the Enable Business Process box.

Click Finish.

Submit and Monitor Your Sterling Integrator Business Process

92

Use the following procedure to submit your Sterling Integrator business process:

a > 0w D

Log in to Sterling Integrator.

From the Business Process menu, select Manager.

In the Search pane, type your business process name in the Process Name box and click Go!.
On the Business Process Manager page, click Execution Manager.

On the Execution Manager page, click Execute for the revised business process to launch the
Execute Business Process Input dialog box.
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6. Click Browse and navigate to the source file on your local system and click Open.

] Administration - Microsoft Internet Explorer provided by Sterling Comme

Execute Business Process Input

Process Name: CopyToCD Version 2

Specily input Parameters
Local Desl:t-:lpfilename:lc wcollectisi txt Browse... |

OR

Server filename: |

Encading Type: | [Maot Applicable] =

Run As l_lser:ladmin 4

“Input data is not required, click Gao to continue.

] [ [T [ | @ Trstedsites

B

7. Click Go! to submit the business process. The Execute Business Process page is displayed.
8. Close the Execute Business Process page.

Monitor with Sterling Integrator
Use the following procedure to monitor your business process with Sterling Integrator:
1. From the Business Process menu, select Monitor > Advanced Search > Business Processes.

2. Inthe Search Using Business Process Name pane, select your business processin the Business
Processes list and click Go!.

The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful execution
ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting on page 161.
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3. Click the ID number to see details about the business process execution.
The Business Process Detail page displays the following information for each step:

Label Description

Step The business process step number

Service The Sterling Integrator service name used in the step
Status The status of the step

Advanced Status

Additional status information

Started

The time and date the step started

Ended

The time and date the step ended

Status Report

A link to the status report for the step

Document

A link to documents in use by the step

Instance Data

A link to process data for the step

The Status for the Connect:Direct Server Run Task Serviceis not reported until the application
or script completes. The Business Process Detail screen shows that the Connect:Direct Server
Run Task ServiceisIn progress...

In progress...
Service

1 ConnectDirec] 10:43:48 33
Server Run
Task Service

* Inline Invocation

[ = Load Balar = Preferred Node, [m] = Mandatory Mode, [1] Execution Role

Lastupdate on 03 008 10:44:44 AM Page: <] 12 [

4. When you close the application or script, The CD Server Run Task Service completes and the
last step in the business process, the CD Server End Session Service, terminates the
Connect:Direct session.

Note:  You can also monitor your business processes from the Business Processes menu by navigating to
Monitor > Advanced Search > Documents or Monitor > Advanced Search > Communication
Sessions.

Monitor with Connect:Direct

Y ou can use the Connect:Direct Select Statistics to monitor your revised Sterling Integrator to
Connect:Direct business process.
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If the Connect:Direct Run Task completes successfully, the Select Statistics detail will indicatethis
and show information similar to the following:

Attribute Value

Message ID LSMG402 (if Connect:Direct is installed on a Windows system)
Message Text A user RUNTASK step completed. Exit code = 0

Source File pgm(path/filename) desktop(yes)

If the Connect:Direct process is not successful, refer to Troubleshooting on page 161.
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Hide the Connect:Direct Password in the Business Process

This chapter describes how to hide the value of the user password in your business process. Modify
your Sterling Integrator business process by adding an Obscure Data - Process Data VVaues Service
before the CD Server Begin Session Service.

Use the following workflow to hide the Connect:Direct password in the business process:

<+

¢4+

Configure the Obscure Data - Process Data Values Service on page 97
Check Out the Business Process on page 98

Edit the Business Process on page 98

Check In Your Business Process on page 99

Submit and Monitor Your Serling Integrator Business Process on page 100

Configure the Obscure Data - Process Data Values Service

Use the following procedure to configure the Obscure Data - Process Data Vaues Service:

A WD

Loginto Sterling Integrator.

From the Deployment menu, select Services > Configuration.

On the Services Configuration page, click Go! in the Create New Service pane.

In the Service Type box, type Obscure Data - Process Data Values and click Next.

Note: Alternately, you can navigate to Obscure Data - Process Data Values by clicking one of the
navigation buttons next to the Service Type box.

On the Name page, in the Name box, type CDClientObscureParameter.
In the Description box, type a short description of what you are obscuring and click Next.
On the Parameters page, in the first Parameter Name box, type the Connect:Direct User ID.
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In the first Parameter Value box, type the password for the Connect:Direct User ID and click
Next.

On the Confirm page, click Finish.

Check Out the Business Process

When you check out an existing business process with the Source Manager, you lock the business
process and prevent other users from modifying it at the sametime.

Use the following procedure to check out your business process that contains the CD Server Run
Task Service from Sterling Integrator:

1
2.
3.

Loginto Sterling Integrator.
From the Business Process menu, select Manager.

On the Business Process Manager page, in the Search pane, type your business process name
in the Process Name box and click Gol.

Click Source Manager for your business process.

On the Source Manager page, click check out for the version of the business process you want
to check out.

Click OK inthe dialog box to lock the file for editing.

In the File Download dialog box, click Save to save a copy of the business process to your
local file system.

In the Save As dialog box, navigate to the directory where you want to save the business
process, type the business process file name in the File name box, and click Save.

Edit the Business Process

98

Inthis scenario, add the Obscure Data- Process Data V a ues to your business process. The Obscure
Data - Process Data Values retrieves the remote password from the CDClientObscureParameter
configuration. The CD Server Begin Session Service gets the remote password from the Obscure
Data - Process Data VVaue. The remote password is not revealed in the business process.

Use the following procedure to edit the Sterling Integrator business process:

1
2.
3.

Log into Sterling Integrator and launch the Graphical Process Modeler from the Home screen.
Enter your Sterling Integrator User 1D and password in the Log In dialog box.

If the All Services stencil is not visible in the GPM, navigate to the View menu and select
Stencil > All Services.

Thiswill add the All Services stencil to the GPM.
From the File menu, select Open, navigate to your business process file and click Open.

Drag and drop the Obscure Data - Process Data Values icon from the Connect:Direct stencil
into the Business Process window.
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6. Toarrange and link theicons:

a. Click the arrow between the start icon and the CD Server Begin Session Service icon and
press Delete to removeit.

b. Placethe Obscure Data - Process Data Values icon between the start icon and the CD
Server Begin Session Service icon.

c. Click thearrow on theright side of the start icon and drag it to the arrow on the left side of
the Obscure Data - Process Data Values icon.

d. Click the arrow on theright side of the Obscure Data - Process Data Valuesicon and drag
it to the arrow on the |eft side of the CD Server Begin Session Service icon.

start Ohscure Data- CD Server Begin Sequence 5 CD Server CopyTo CD Server Run Task CD Server End Sequence End End

Process Data Values Session Service Service Service Session Service

@—2——@ H\ B l—®

OnFault Group

7. Configure the Obscure Data - Process Data Values using the following procedure:

a. Double-click the Obscure Data - Process Data Valuesicon. This opens the Service Editor
window.

b. Inthe Service Editor-Obscure Data - Process Data Values window, select
CDClientObscureParameter from the Config drop-down list.

In this step you specify the CDClientObscureParameter configuration to use for the
Obscure Data - Process Data Values. You can override configuration valuesin the Service
Editor.

8. Edit the CD Server Begin Session Service using the following procedure:
a. Double-click the CD Server Begin Session Service icon.
b. Select Yesasthe Value for UsingObscuredPasswd.

c. Type CDUser|D/text() asthe Vaue for the RemotePasswd and select the Use XPATH?
box. CDUserID isthe Connect:Direct User ID.

9. From the File menu, select Save. In the Validate dialog box, click Yesto validate the business
process.

10. On the Save dialog box, type your business process file name in the File Name box and click
Save.

Remember where you save thisfile.

Note: To see a sample business process, refer to Hide the Connect: Direct Password in the Business
Process on page 130.

Check In Your Business Process

Use the following procedure to check the revised business process into Sterling Integrator:
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10.
11.

12.
13.
14.
15.
16.

Hide the Connect:Direct Password in the Business Process

Loginto Sterling Integrator.
From the Business Process menu, select Manager.

On the Business Process Manager page, in the Search pane, type your business process name
in the Process Name box and click Go!.

Click Source Manager for your business process.

On the Source Manager page, select Go! to Check in an updated definition for this business
process.

On the Process Definition Check-in page, click Browse and navigate to your business process
file that you saved in step 10 of the previous procedure.

Type Added Obscure Data - Process Data Values to hide password in the Description box and
click Next.

On the Process Levels page, select the Set onfault processing check box.
Set the Persistence Level to Full.

Set the Event Reporting Level to Full.

Set the Recovery Level to Auto Resume and click Next.

If Sterling Integrator stops responding during a copy transaction and the recovery level is set
to Auto Resume, the business process resumes automatically at the next Sterling Integrator
start up.

On the Deadline Settings page, click Next.

On the Life Span page, click Next.

On the Set Default Version page, select the updated version of the business process.
On the Confirm page, select the Enable Business Process box.

Click Finish.

Submit and Monitor Your Sterling Integrator Business Process

Use the following procedure to submit your Sterling Integrator business process:

1
2.

3.
4.
5

100

Log into Sterling Integrator.

From the Business Process menu, select Manager.

In the Search pane, type your business process in the Process Name box and click Go!.
On the Business Process Manager page, click Execution Manager.

On the Execution Manager page, click Execute for the revised business process to launch the
Execute Business Process I nput dialog box.
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6. Click Browse and navigate to the source file on your local system and click Open.

3 Administration - Microsoft Internet Explorer provided by Sterling Commerce

Execute Business Process Input

Process Name: CopyToCD Version 2

Local Desl:t-:lpfilename:lc wcollectisi txt Browse... |

OR

Server filename: |

Encading Type: | [Maot Applicable] =

Run As l_lser:ladmin 4

“Input data is not required, click Gao to continue.

-0 x|

] [ [T [ | @ Trstedsites
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Click Go! to submit your business process.

The Execute Business Process page is displayed.

Close the Execute Business Process page.

The application or script runs on the Connect:Direct server.

Monitor with Sterling Integrator

If you modify your business process with the Obscure Data - Process Data Values correctly, the
business process execution results will be unchanged.

Use the following procedure to monitor your business process with Sterling Integrator:

1
2.

From the Business Process menu, select Monitor > Advanced Search > Business Processes.
In the Search Using Business Process Name pane, select your business processin the Business

Processes list and click Go!.
The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful execution
ID The business process ID number

Name The business process name

State The current state of the business process
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If the Status indicates unsuccessful execution, refer to Troubleshooting on page 161.
3. Click the ID number to see details about the business process execution.
The Business Process Detail page displays the following information for each step:

Label Description

Step The business process step number

Service The Sterling Integrator service name used in the step
Status The status of the step

Advanced Status Additional status information

Started The time and date the step started
Ended The time and date the step ended
Status Report A link to the status report for the step
Document A link to documents in use by the step
Instance Data A link to process data for the step

4. The Statusfor the Connect:Direct Server Run Task Serviceis not reported until the application
or script completes. The Business Process Detail screen shows that the Connect:Direct Server
Run Task Serviceis|In progress...

In progress...

1 ConnectDirect 10:43:48.33
Server Run
Task Service

*Inline Invocation
[-] = Load Balance
Lastupdate on 03

= Preferred MNode, [m] = Mandatory Maode, [1] Execution Role
009 10:44:44 AW Page: <] 12 [>

5. When you close the application or script, The CD Server Run Task Service completes and the
last step in the business process, the CD Server End Session Service, terminates the
Connect:Direct session.

Note:  You can also monitor your business processes from the Business Processes menu by navigating to
Monitor > Advanced Search > Documents or Monitor > Advanced Search > Communication
Sessions.

Monitor with Connect:Direct

Y ou can use the Connect:Direct Select Statistics to monitor your revised Sterling Integrator to
Connect:Direct business process.
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If the Connect:Direct Run Task completes successfully, the Select Statistics detail will indicatethis
and show information similar to the following:

Attribute Value

Message ID LSMG402I (if Connect:Direct is installed on a Windows system)
Message Text A user RUNTASK step completed. Exit code = 0

Source File pgm(path/filename) desktop(yes)

If the Connect:Direct process is not successful, refer to Troubleshooting on page 161.
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Sample Business Processes

Sample Business Processes

Here are the examples that focus on the Sterling Integrator side:

R A R R IR IR R R R R R R R

Use Connect:Direct to Copy a File to Serling Integrator on page 106

Use Connect: Direct to Retrieve a File from Serling Integrator on page 107

Use Serling Integrator to Copy a File to a Connect: Direct for zZOS Node on page 109
Use Serling Integrator to Copy a File to a Connect: Direct for Windows Node on page 111
Use Serling Integrator to Copy a Fileto a Connect: Direct for UNIX Node on page 113
Use Serling Integrator to Copy a File to a Connect: Direct HP NonSop Node on page 115
Use Serling Integrator to Copy a File to a Connect: Direct for i5/0S Node on page 118
Use Serling Integrator to Copy a File from Connect: Direct on page 120

Add Error Handling to the Business Process on page 122

Use Serling Integrator to Submit a Connect: Direct Process on page 124

Use Serling Integrator to Sart a Connect: Direct Run Job on page 126

Use Serling Integrator to Sart a Connect: Direct Run Task on page 128

Hide the Connect: Direct Password in the Business Process on page 130

Use Serling Integrator to Copy a File to Connect: Direct for ZOS (Advanced) on page 132

For more information about the Connect:Direct side, particularly on the Connect:Direct Process
language and how to tailor it to communicate with Sterling Integrator, refer to Sterling Integrator
Connect: Direct Server Adapter Syntax and Sterling Integrator-Connect: Direct Server Adapter
Examples on the Connect:Direct Process L anguage Web Site in the MFT Connect:Direct
documentation library.
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Use Connect:Direct to Copy a File to Sterling Integrator

Note:

106

In the Connect:Direct for Windows process, the Connect:Direct server (PNODE) copiesthe
orders.txt file to the Sterling Integrator Connect:Direct Server adapter (SNODE) which invokesthe
ReceiveFromCD business process and passes the file to the business process. The Connect:Direct
Server adapter node nameis SI50. The destination filename on Sterling Integrator is daily.txt.

CDSAMPLE PROCESS
SNODE=SI50
SNODEID= (myUserID, myPassword)

STEP1 COPY
FROM (
FILE=C:\orders.txt

FILE=/businessprocess/ReceiveFromCD/daily.txt
DISP=RPL

PEND

In the Sterling Integrator ReceiveFromCD business process, shown in BPML, the Get Document
Information Service obtainsfile information about the primary document and placesit into process
data. Y ou can add additional servicesto this business process to perform operations such as
trangdlating the file or copying the file to another server using FTP.

The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
the common user tasks described in the User Guide. To see BPML source code like the example shown below,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.

<process name = "ReceiveFromCD">
<operation name="Get Document Information Service">
<participant name="GetDocumentInfoService"/>
<output message="GetDocumentInfoServiceTypelnputMessage">

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

</process>
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Use Connect:Direct to Retrieve a File from Sterling Integrator

In the Connect:Direct for Windows process, the Connect:Direct server (PNODE) pulls afile from
a Sterling Integrator Connect:Direct Server adapter (SNODE). The Connect:Direct node connects
to the Sterling Integrator Connect:Direct Server adapter which invokesthe RespondToCD business
processwhich sends the sample.txt file back to Connect:Direct. The Connect:Direct Server Adapter
node name is SI50. The destination file name on the Connect:Direct server is orders.txt.

CDSAMPLE PROCESS
SNODE=SI50
SNODEID= (myUserID, myPassword)

STEP1 COPY
FROM (
FILE=/businessprocess/RespondToCD/sample. txt

FILE=C:\orders. txt
DISP=RPL

PEND

Inthe RespondToCD business process, shownin BPML, thebusinessprocessretrievesafile, passes
thisfile to the Connect:Direct Server adapter, and sends the file back to the Connect:Direct node.
The business process functions much like a Connect:Direct process.

In the first operation of the RespondToCD business process, the File System Adapter collects
(reads) the daily.txt file from the Sterling Integrator local file system. Thisfile becomesthe primary
document of the business process.

In the next operation of the business process, the CD Server BP Response Service passes the
primary document back to the Connect:Direct node (PNODE).

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of

the common user tasks described in the User Guide. To see BPML source code like the example shown below,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.
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<process name = "RespondToCD">
<sequence>

<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>

<operation name="CD Server BP Response Service">
<participant name="CDServerBPResponse" />
<output message="CDServerBPResponseServiceTypelInputMessage">

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

</sequence>
</process>

108 Connect:Direct Server Adapter User Guide



Use Sterling Integrator to Copy a File to a Connect:Direct for z/OS Node

Use Sterling Integrator to Copy a File to a Connect:Direct for
z/OS Node

In this sample, shown in BPML, the Sterling Integrator Copy ToCDMainframeNode business
process passes a document to the Connect:Direct Server adapter (PNODE) which copiesthefileto
the Connect:Direct for zZ/OS node (SNODE). The business process functions much like a
Connect:Direct process.

In the first operation of the CopyToCDMainframeNode business process, the File System Adapter
collects (reads) the daily.txt file from the Sterling Integrator local file system. Thisfile becomesthe
primary document of the business process.

The second operation uses the CD Server Begin Session Service to establish a connection to the
remote Connect:Direct node, CDZOS. The local node name of the Connect:Direct Server adapter
isDal1CDSA. The Begin Session Service uses the remote user ID of cduser to authenticate to the
Connect:Direct server. The Session Token created by the CD Server Begin Session Service
identifies the session that is established with the remote Connect:Direct node. The SessionToken
value in the CD Server CopyTo Service ensures that this service copies the file using the session
initiated by the CD Server Begin Session Service.

Thethird operation usesthe CD Server CopyTo Serviceto copy the primary document to a specific
unit (3380) and volume (serial number is SY S009) on the Connect:Direct for z/OS server. SPACE
information is also provided (4096, (200,40)...ROUND). The destination file nameis
SAMPLE.ZOSFILE.

The last operation uses the CD Server End Session Service to terminate the session with the
Connect:Direct server.

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
the common user tasks described in the User Guide. To see BPML source code like the example shown bel ow,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.

<process name="CopyToCDMainframeNode">
<sequence>

<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
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<operation name="CD Server Begin Session Service">

<participant name="CDServerBeginSession"/>

<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="." from="*"></assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="ProcessName">Copyto</assign>
<assign to="LocalCDNodeName">DallCDSA</assign>
<assign to="RemoteCDNodeName">CDZOS</assign>
<assign to="RemotePasswd">XXXXXXxXX/assign>
<assign to="UsingObscuredPasswd">NO</assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>
<assign to="BeginSessionResults" from="*"></assign>
</input>
</operation>

<operation name="CD Server CopyTo Service">

<participant name="CDServerCopyTo"/>

<output message="CDServerCopyToServiceTypelnputMessage">
<assign to="." from="*"></assign>
<assign to="RemoteUNIT">3380</assign>
<assign to="RemoteVOL">(SER=SYS009)</assign>
<assign to="RemoteDISP"> (NEW, CATLG)</assign>
<assign to="RemoteFileName">SAMPLE.ZOS.FILE</assign>
<assign to="RemoteSPACE"> (4096, (200,40),,,ROUND)</assign>
<assign to="SessionToken"

from="//BeginSessionResults/SessionToken/node () "></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelInputMessage">
<assign to="." from="*"></assign>
<assign to="SessionToken">//BeginSessionResults/SessionToken/node()</assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

</sequence>
</process>
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Use Sterling Integrator to Copy a File to a Connect:Direct for
Windows Node

In this sample, shown in BPML, the Sterling Integrator Copy ToCDWin business process passes a
document to the Connect:Direct Server adapter (PNODE) which copies thefileto the
Connect:Direct for Windows node (SNODE). The business process functions much like a
Connect:Direct process.

In the first operation of the CopyToCDWin business process, the File System Adapter collects
(reads) the daily.txt filefrom the Sterling Integrator local file system. Thisfile becomesthe primary
document of the business process.

The second operation uses the CD Server Begin Session Service to establish a connection to the
remote Connect:Direct for Windows node, CDWIN. The loca node name of the Connect:Direct
Server adapter is SI51CD. The Begin Session Service uses the remote user ID of cduser to
authenticate to the Connect:Direct server.

Thethird operation usesthe CD Server CopyTo Serviceto copy the primary document to the remote
Connect:Direct server. The Sysopts specifiesthat thefileisnot tranglated. The destination file name
iscd.txt. The Session Token created by the CD Server Begin Session Service identifies the session
that is established with the remote Connect:Direct node. The SessionToken value in the CD Server
CopyTo Service ensuresthat this service copiesthefile using the session initiated by the CD Server
Begin Session Service.

The fourth operation uses the CD Server End Session Service to terminate the session with the
Connect:Direct server.

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
the common user tasks described in the User Guide. To see BPML source code like the example shown bel ow,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.

<process name="CopyToCDWin">
<sequence>

<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
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<operation name="CD Server Begin Session Service">

<participant name="CDServerBeginSession"/>

<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd">XXXXXXXx</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypelInputMessage">
<assign to="RemoteFileName">C:\cd.txt</assign>
<assign to="Sysopts">xlate(no)</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelInputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
</sequence>
</process>
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Use Sterling Integrator to Copy a File to a Connect:Direct for
UNIX Node

In this sample, shown in BPML, the Sterling Integrator Copy ToCDUX business process passes a
document to the Connect:Direct Server adapter (PNODE) which copies thefileto the
Connect:Direct for UNIX node (SNODE). The business process functions much like a
Connect:Direct process.

In the first operation of the CopyToCDUX business process, the File System Adapter collects
(reads) the invoice.dly file from the Sterling Integrator local file system. This file becomes the
primary document of the business process.

The second operation uses the CD Server Begin Session Service to establish a connection to the
remote Connect:Direct for UNIX node, CDUX. The local node name of the Connect:Direct Server
adapter is SI51CD. The Begin Session Service uses the remote user ID of cduser to authenticate to
the Connect:Direct server.

Thethird operation usesthe CD Server CopyTo Serviceto copy the primary document to the remote
Connect:Direct server. The destination file nameis daily.inv. The Sysopts specifies that the file
datatype of thefileistext and thefileisnot translated. The Session Token created by the CD Server
Begin Session Service identifies the session that is established with the remote Connect:Direct
node. The SessionToken valuein the CD Server CopyTo Service ensures that this service copies
the file using the session initiated by the CD Server Begin Session Service.

The fourth operation uses the CD Server End Session Service to terminate the session with the
Connect:Direct server.

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
the common user tasks described in the User Guide. To see BPML source code like the example shown bel ow,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.

<process name="CopyToCDUX">
<sequence>

<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">invoice.dly</assign>
<assign to="collectionFolder">/daily/tran</assign>
<assign to="deleteAfterCollect">false</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>
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<operation name="CD Server Begin Session Service">

<participant name="CDServerBeginSession"/>

<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDUX</assign>
<assign to="RemotePasswd">XXXXXXXx</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypelInputMessage">
<assign to="RemoteFileName">/invoices/daily.inv</assign>
<assign to="Sysopts">:datatype=text:xlate=no:</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelInputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
</sequence>
</process>
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Use Sterling Integrator to Copy a File to a Connect:Direct HP
NonStop Node

In this sample, shown in BPML, the Sterling Integrator Copy ToCDHPNonStop business process
passes a document to the Connect:Direct Server adapter (PNODE) which copies thefileto the
Connect:Direct HP NonStop node (SNODE). The business process functions much like a
Connect:Direct process.

In the first operation of the CopyToCDHPNonStop business process, the File System Adapter
collects (reads) the daily.txt file from the Sterling Integrator local file system. Thisfile becomesthe
primary document of the business process.

The second operation uses the CD Server Begin Session Service to establish a connection to the
remote Connect:Direct HP NonStop nhode, CDHPNS. The local node name of the Connect:Direct
Server adapter is SI51CD. The Begin Session Service uses the remote user ID of cduser to
authenticate to the Connect:Direct server.

The third operation uses the CD Server Run Task Service to delete any previous copy of the HP
NonStop file. The PURGE $VOL.SUBVOL.CDSATEST! command is passed to the File Utility
Program (FUP) which deletes $V OL.SUBVOL.CDSATEST on the HP NonStop system.

The fourth operation uses the CD Server CopyTo Service to copy the primary document to the
remote Connect:Direct server. The destination file name is $VOL.SUBVOL.CDSATEST.
BinaryModeis set to NO to send the file astext and the Sysoptsare SET TY PE E,REC 80 to create
an 80 byte record of filetype E. CDDisposition is set to NEW because any previous version of the
fileis deleted. The Session Token created by the CD Server Begin Session Service identifies the
session that is established with the remote Connect:Direct node. The SessionToken valueinthe CD
Server CopyTo Service ensuresthat this service copiesthefile using the session initiated by the CD
Server Begin Session Service.

The last operation uses the CD Server End Session Service to terminate the session with the
Connect:Direct server.

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
the common user tasks described in the User Guide. To see BPML source code like the example shown bel ow,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.
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<process name="CopyToCDHPNonStop">
<sequence>

<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="deleteAfterCollect">false</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server Begin Session Service">

<participant name="CDServerBeginSession"/>

<output message="CDServerBeginSessionServiceTypelnputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDHPNS</assign>
<assign to="RemotePasswd">XXXXXXXX</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server Run Task Service">
<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypelnputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="Program">FUP</assign>
<assign to="SystemOpts">PURGE S$VOL.SUBVOL.CDSATEST!</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
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<operation name="CD Server CopyTo Service">

<participant name="CDServerCopyTo"/>

<output message="CDServerCopyToServiceTypelInputMessage">
<assign to="RemoteFileName">$VOL.SUBVOL.CDSATEST</assign>
<assign to="BinaryMode">NO</assign>
<assign to="Sysopts">SET TYPE E,REC 80</assign>
<assign to="CDDisposition">NEW</assign>
<assign to="SessionToken"

from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelInputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
</sequence>
</process>
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Use Sterling Integrator to Copy a File to a Connect:Direct for
I15/0S Node

In this sample, shown in BPML, the Sterling Integrator CopyToCDi50S business process passes a
document to the Connect:Direct Server adapter (PNODE) which copies thefileto the
Connect:Direct for i5/0S node (SNODE). The business process functions much like a
Connect:Direct process.

In the first operation of the Copy ToCDi50S business process, the Mailbox Extract Begin Service
retrieves the test1.zip message from the Sterling Integrator mailbox system. This file becomes the
primary document of the business process.

The second operation uses the CD Server Begin Session Service to establish a connection to the
remote Connect:Direct for i5/0OS node, CDi50S. Thelocal node name of the Connect:Direct Server
adapter is SI51CD. The Begin Session Service uses the remote user ID of cduser to authenticate to
the Connect:Direct server.

Thethird operation usesthe CD Server CopyTo Serviceto copy the primary document to the remote
Connect:Direct server. The destination file nameistest3.zip. BinaryModeis set to Y ESto send the
filein binary mode and the Sysopts set TEXTFILE to NO to create atext file. CDDisposition is set
to RPL and Checkpointinterval is set to 1000. The Session Token created by the CD Server Begin
Session Service identifies the session that is established with the remote Connect:Direct node. The
SessionToken valuein the CD Server CopyTo Service ensuresthat this service copiesthefile using
the session initiated by the CD Server Begin Session Service.

The fourth operation uses the CD Server End Session Service to terminate the session with the
Connect:Direct server.

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
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the common user tasks described in the User Guide. To see BPML source code like the example shown bel ow,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.

<process name="CopyToCDi50S">
<sequence>

<operation name="Mailbox ExtractBegin Service">
<participant name="MailboxExtractBegin"/>
<output message="ExtractBeginRequest">
<assign to="MessageName">testl.zip</assign>
<assign to="MessageId">36</assign>
<assign to="CommitNow">Yes</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
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<operation name="CD Server Begin Session Service">

<participant name="CDServerBeginSession"/>

<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDi50S</assign>
<assign to="RemotePasswd">XXXXXXXx</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server CopyTo Service">

<participant name="CDServerCopyTo"/>

<output message="CDServerCopyToServiceTypelInputMessage">
<assign to="RemoteFileName">/home/gadata/test3.zip</assign>
<assign to="BinaryMode">YES</assign>
<assign to="Sysopts">TEXTFILE (*NO)</assign>
<assign to="CheckpointInterval">1000</assign>
<assign to="CDDisposition">RPL</assign>
<assign to="SessionToken"

from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelInputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
</sequence>
</process>
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Use Sterling Integrator to Copy a File from Connect:Direct

In thissample, shownin BPML, the Sterling Integrator CopyFromCD business process invokesthe
Connect:Direct Server adapter (PNODE) which copies the file from the Connect:Direct node
(SNODE) back to the business process as the primary document. The business process functions
much like a Connect:Direct process.

Thefirst operation usesthe CD Server Begin Session Serviceto establish aconnection to theremote
Connect:Direct node, CDWIN. The local node name of the Connect:Direct Server adapter is
SI51CD. The Begin Session Service uses the remote user ID of cduser to authenticate to the
Connect:Direct server.

The second operation usesthe CD Server CopyFrom Serviceto copy the sourcefilefrom theremote
Connect:Direct server. The source file name is sample.txt. The Session Token created by the CD
Server Begin Session Service identifies the session that is established with the remote
Connect:Direct node. The SessionToken value in the CD Server CopyTo Service ensures that this
service copies the file using the session initiated by the CD Server Begin Session Service.

The third operation uses the CD Server End Session Service to terminate the session with the
Connect:Direct server.

Thelast operation usesthe MailboxAdd serviceto store the file sample.txt as amessage in mailbox
/box1.

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
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the common user tasks described in the User Guide. To see BPML source code like the example shown bel ow,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.

<process name="CopyFromCD">
<sequence>

<operation name="CD Server Begin Session Service">

<participant name="CDServerBeginSession"/>

<output message="CDServerBeginSessionServiceTypelnputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd">XXxXXxxxX</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
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<operation name="CD Server CopyFrom Service">
<participant name="CDServerCopyFrom"/>
<output message="CDServerCopyFromServiceTypelInputMessage">
<assign to="RemoteFileName">sample.txt</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelnputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
<!-- Add Msg to mailbox -->

<operation name="Mailbox Add Service">

<participant name="MailboxAdd"/>
<output message="AddRequest">
<assign to="." from="*"></assign>
<assign to="MailboxPath">/boxl</assign>
<assign to="MessageName">sample.txt</assign>
</output>
<input message="inmsg">
<assign to="AddResults" from="*"></assign>
</input>

</operation>

</sequence>
</process>
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Add Error Handling to the Business Process

In this sample, shown in BPML, add error handling to the Sterling Integrator business process you
created that passes adocument to the Connect:Direct Server adapter (PNODE) which copiesthefile
to the Connect:Direct node (SNODE). The error handling ensures that the Connect:Direct session
closesif an error is encountered during the session.

The onFault branch contains an instance of the CD Server End Session Service. If an error occurs
after the Begin Session Service, the onFault logicisinvoked and the End Session Serviceterminates
the session with the Connect:Direct server.

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
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the common user tasks described in the User Guide. To see BPML source code like the exampl e shown bel ow,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.

<process name="CopyToCD">
<sequence>
<operation name="File System Adapter">

<participant name="CollectForCD"/>

<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server Begin Session Service">

<participant name="CDServerBeginSession"/>

<output message="CDServerBeginSessionServiceTypelnputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd">XXXXXXxXx</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
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<sequence>
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypelnputMessage">
<assign to="RemoteFileName">cd.txt</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>

<operation name="CD Server End Session Service">

<participant name="CDServerEndSession"/>

<output message="CDServerEndSessionServiceTypelInputMessage">
<assign to="SessionToken"

from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>

</output>

<input message="inmsg">
<assign to="." from="*"></assign>

</input>

</operation>
<onFault>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

</onFault>
</sequence>
</sequence>
</process>
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Use Sterling Integrator to Submit a Connect:Direct Process

Inthissample, shownin BPML, modify the Sterling Integrator business processto submit aprocess
on the Connect:Direct node after the file is copied. The Connect:Direct process copies the file
received from Sterling Integrator to a z/OS system.

The CD Server Submit Serviceis placed after the CD Server CopyTo Service. The Submit Service
submits a Connect:Direct process called Copy2ZOS.cdp.

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
the common user tasks described in the User Guide. To see BPML source code like the example shown bel ow,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,

124

select View > Graph.

<sequence>

<assign
<assign
<assign
<assign
<assign
</output>

<assign
</input>

<assign
<assign
<assign
<assign
<assign
<assign
</output>

<assign
</input>

</operation>

</operation>

<process name="CopyToCD_Submit">

<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">

to="Action">FS_COLLECT</assign>
to="filter">daily.txt</assign>
to="collectionFolder">C:\Collection</assign>
to="deleteAfterCollect">false</assign>
to="." from="*"></assign>

<input message="inmsg">

to="." from="*"></assign>

<operation name="CD Server Begin Session Service">
<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypelnputMessage">

to="LocalCDNodeName">SI51CD</assign>
to="RemoteCDNodeName">CDWIN</assign>
to="RemotePasswd">xXXXxXxXxx</assign>
to="RemoteUserId">cduser</assign>
to="UsingObscuredPasswd">NO</assign>
to="." from="*"></assign>

<input message="inmsg">

to="." from="*"></assign>
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<sequence name="Sequence Start">
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypelnputMessage">
<assign to="RemoteFileName">cd.txt</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>

<operation name="CD Server Submit Service">
<participant name="CDServerSubmit"/>
<output message="CDServerSubmitServiceTypeInputMessage">
<assign to="RemoteProcessFile">Copy2Z0S.cdp</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node() "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
<onFault>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelnputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

</onFault>
</sequence>
</sequence>
</process>
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Use Sterling Integrator to Start a Connect:Direct Run Job

In this sample, shown in BPML, modify the Sterling Integrator business process to start a program
on the Connect:Direct server using a Run Job after afileis copied. The Connect:Direct Server
adapter does not verify the validity of the submitted program and does not wait for the submitted
job to complete. The program runs as a separate process.

The CD Server Run Job Serviceis placed after the CopyTo Service. The Run Job Service passes
pgm(C:\Windows\notepad.exe) desktop(yes) to the remote Connect:Direct server via Sysopts. This
causes the Windows Notepad application to run on the Connect:Direct server.

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
the common user tasks described in the User Guide. To see BPML source code like the exampl e shown bel ow,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
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select View > Graph.

<sequence>

<assign
<assign
<assign
<assign
<assign
</output>

<assign
</input>

<assign
<assign
<assign
<assign
<assign
<assign
</output>

<assign
</input>

</operation>

</operation>

<process name="CopyToCD_RunJob">

<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">

to="Action">FS_COLLECT</assign>
to="filter">daily.txt</assign>
to="collectionFolder">C:\Collection</assign>
to="deleteAfterCollect">false</assign>
to="." from="*"></assign>

<input message="inmsg">

to="." from="*"></assign>

<operation name="CD Server Begin Session Service">
<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypelnputMessage">

to="LocalCDNodeName">SI51CD</assign>
to="RemoteCDNodeName">CDWIN</assign>
to="RemotePasswd">xXXxXxXxXxx</assign>
to="RemoteUserId">cduser</assign>
to="UsingObscuredPasswd">NO</assign>
to="." from="*"></assign>

<input message="inmsg">

to="." from="*"></assign>
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<sequence name="Sequence Start">
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypelnputMessage">
<assign to="RemoteFileName">cd.txt</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>

<operation name="CD Server Run Job Service">
<participant name="CDServerRunJob"/>
<output message="CDServerRunJobServiceTypelnputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="Sysopts">pgm(C:\Windows\notepad.exe) desktop(yes)</assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
<onFault>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelnputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

</onFault>
</sequence>
</sequence>
</process>
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Use Sterling Integrator to Start a Connect:Direct Run Task

In this sample, shown in BPML, modify the Sterling Integrator business process to start and wait
on aprogram on the Connect:Direct server viaa Run Task after the source fileis copied. The
program may be aprogram or script. The Connect:Direct Server adapter does not verify the validity
of the submitted program, but it does wait for the submitted job to complete before moving to the
next service in the business process. The program or script runs as a separate process.

The CD Server Run Task Serviceis placed after the CopyTo Service. The Run Task Service passes
pgm(C:\Windows\notepad.exe) desktop(yes) to the remote Connect:Direct server viathe
SystemOpts parameter. (SystemOptsis the equivalent of Sysopts.) This causes the Windows
Notepad application to run on the Connect:Direct server.

Note: Do not enclose the value specified for SystemOpts in double quotes.
Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
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the common user tasks described in the User Guide. To see BPML source code like the example shown below,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.

<process name="CopyToCD_RunTask">
<sequence>

<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server Begin Session Service">

<participant name="CDServerBeginSession"/>

<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd">XXXXXXXxX</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>
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<sequence name="Sequence Start">
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypelnputMessage">
<assign to="RemoteFileName">cd.txt</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>

<operation name="CD Server Run Task Service">
<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypelnputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="SystemOpts">pgm(C:\Windows\notepad.exe)
desktop (yes)</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelInputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
<onFault>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelnputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

</onFault>
</sequence>
</sequence>
</process>
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Hide the Connect:Direct Password in the Business Process

In this sample, shown in BPML, modify the Sterling Integrator business process by adding an
Obscure Data - Process Data Vaues Service before the CD Server Begin Session Service to hide
the value of the user password.

Thefirst operation in the business process is Obscure Data - Process Data Values. This service
works with the CD Server Begin Session Service so that the password for the remote
Connect:Direct User ID, cduser, is not revealed in the business process. The password is retrieved
using the RemotePasswd parameter, which is set to cduser/text( )in the Begin Session Service.

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
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the common user tasks described in the User Guide. To see BPML source code like the exampl e shown bel ow,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.

<process name="CopyToCD_HidePassword">
<sequence>
<operation name="File System Adapter">

<participant name="CollectForCD"/>

<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="Obscure Data - Process Data Values">
<participant name="CDClientObscureParameter" />
<output message="ObscureParameterInputMessage">

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server Begin Session Service">
<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypelnputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd" from="cduser/text()"></assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">YES</assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="BeginSessionResults" from="*"></assign>
</input>
</operation>
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<sequence name="Sequence Start">
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypelnputMessage">
<assign to="RemoteFileName">cd.txt</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>

<operation name="CD Server Run Task Service">
<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypelnputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="SystemOpts">pgm(C:\Windows\notepad.exe)
desktop (yes)</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelInputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

<onFault>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelnputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>

</onFault>
</sequence>
</sequence>
</process>
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Use Sterling Integrator to Copy a File to Connect:Direct for
z/OS (Advanced)
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In this sample, shown in BPML, the Sterling Integrator Copy ToCDzOS business process passes a
document to the Connect:Direct Server adapter (PNODE) which copies thefileto the
Connect:Direct for z/OS node (SNODE). The business process functions much like a
Connect:Direct process. In this complex example containing nine operations, the operation
numbers are shown in the BPML code and correspond to the following narrative.

In Operation 1 of the CopyToCDzOS business process, the File System Adapter collects (reads) the
bplmbin.txt file from the Sterling Integrator local file system. This file becomes the primary
document of the business process.

Operation 2 uses the CD Server Begin Session Service to establish a connection to the remote
Connect:Direct node, CD.ZOS. The local node name of the Connect:Direct Server adapter is
SI51CD. The Begin Session Service uses the remote user ID of cduser to authenticate to the
Connect:Direct server.

Operation 3 executes a CD Server Run Task service to delete and uncatal og the output file,
CSDQAL1.O.TESTFILE.SMS2, if that file dready exists. In addition, this operation unall ocates the
CSDQAL.O.TESTFILE.SMS2file.

Note: SystemOptsisthe equivalent of Sysopts.

Also, do not enclose the value specified for SystemOptsin double quotes.

Operation 4 uses the CD Server CopyTo Service to copy the primary document to the remote
Connect:Direct for zZ/OS node. The CopyTo Service alocates an SMS managed file on zZ/OS with
the following Remote parms:

4+ RemoteSMS—SMS parms passed to z/OS for allocation. This parm specifies that the z/OS
system allocates this file with a DATACLAS of CSGWORK, STORCLAS of BENCH,
MGMTCLAS of STANDARD, and uses kilobytes (K) as the allocation unit (AV GREC)

4+ RemoteDISP— the disposition of the new file.
4+ RemoteFileName—the name of the destination z/OS dataset.
4+ RemoteSPA CE—defines the space requirements for the all ocation.

Operation 5 uses the CD Server Run Task Serviceto execute the DMRTDY N utility program to
perform the following functions:

4+ Allocate afile on the z/OS system with a DDname of OLDDD to be used as a basis for
comparison to the output file

4+ Allocate the output file from the previous step with a DDname of NEWDD for a comparison.

4+ Allocate an output DD called OUTDD that holds the output report file for the Compare step
instead of an actual file.
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Operation 6 uses the CD Server Run Task Service to execute the ISRSUPC program, a compare
utility. The ISRSUPC program compares the file allocated to OLDDD and the file allocated to
NEWDD using the parmsin the Sysopts. The results are written to the OUTDD.

Operation 7 uses the CD Server Run Task Serviceto execute DMRTDY N to deallocate OLDDD,
NEWDD and OUTDD.

Operation 8 uses the CD Server End Session Service to terminate the session with the
Connect:Direct server after the business process has executed successfully. To accommodate error
processing, Operation 9 contains an onFault branch with its own instance of the CD Server End
Session Service. If an error occurs after the Begin Session Service, the onFault logic isinvoked and
the End Session Service terminates the session with the Connect:Direct server.

Note: The Sterling Integrator Graphical Process Modeler (GPM) is used as the primary means to perform most of
the common user tasks described in the User Guide. To see BPML source code like the example shown below,
select View > Source while using the GPM. To see the business process as depicted in the GPM user interface,
select View > Graph.

<process name="CopyTOCDz0S">
<sequence name="Session Start">

<operation name="File System Adapter"> OPERATION 1
<participant name="CDExtractionService"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">bplmbin.txt</assign>
<assign to="collectionFolder">/collection</assign>
<assign to="collectZeroByteFiles">true</assign>
<assign to="deleteAfterCollect">false</assign>
<assign to="docStorageType">fs</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
<operation name="CD Server Begin Session Service"> OPERATION 2

<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="RemoteUserId">cduser</assign>
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CD.zZ0S</assign>
<assign to="RemotePasswd">xxxx</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
<assign to="BeginSessionResults" from="*"></assign>
</input>
</operation>
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<operation name="CD Server Run Task Service"> OPERATION 3
<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypeInputMessage">
<assign to="SystemOpts">C' ALLOC',C' DSN=CSDQAl.0.TESTFILE.SMS2',C'
DISP=(MOD,DELETE) ',F'-1',C"' UNALLOC',C' DSN=CSDQA1l.0.TESTFILE.SMS2'</assign>
<assign to="Program">DMRTDYN</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
<operation name="CD Server CopyTo Service"> OPERATION 4

<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteSMS">DATACLAS=CSGWORK AVGREC=K STORCLAS=BENCH
MGMTCLAS=STANDARD</assign>
<assign to="RemoteDISP"> (NEW,KEEP,DELETE)</assign>
<assign to="RemoteFileName">CSDQAl.O.TESTFILE.SMS2</assign>
<assign to="RemoteSPACE">(TRK, (18,2),RLSE)</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
<operation name="CD Server Run Task Service"> OPERATION 5

<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypelnputMessage">
<assign to="SystemOpts">C' ALLOC',C' DSN=CSDQAl.TESTFILE.BENCH.M1',6C'
DISP=SHR',C' DD=OLDDD',F'-1"',C' ALLOC',C' DSN=CSDQAl.O0.TESTFILE.SMS2',C' DISP=SHR',C'
DD=NEWDD',F'-1',C' ALLOC',C' DD=0OUTDD',C' DUMMY',C' SYSOUT=A'</assign>
<assign to="Program">DMRTDYN</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
<operation name="CD Server Run Task Service"> OPERATION 6

<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypelnputMessage">
<assign to="SystemOpts">C' DELTAL',C' LINECMP',C'',C''</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="Program">ISRSUPC</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
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<operation name="CD Server Run Task Service"> OPERATION 7
<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypeInputMessage">
<assign to="SystemOpts">C' UNALLOC',C' DD=OLDDD',F'-1',C' UNALLOC',C'
DD=NEWDD',F'-1',C' UNALLOC',C' DD=0OUTDD'</assign>
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>
<assign to="Program">DMRTDYN</assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
<operation name="CD Server End Session Service"> OPERATION 8

<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelnputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>
</input>
</operation>
<onFault>
<operation name="CD Server End Session Service"> OPERATION 9

<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypelInputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node () "></assign>

<assign to="." from="*"></assign>
</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>

</onFault>

</sequence>

</process>
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Copy Options

Copy Options

There are many copy options available when you use the Connect:Direct Server CopyTo Service.

When you using the Sterling Integrator Connect:Direct Server adapter to copy afileto aremote
Connect:Direct server, coordinate the copy options with the Connect:Direct administrator.

Settings for Connect:Direct Server CopyTo Service

Note:

Note:

When you configure the Connect:Direct Server CopyTo service, you must specify settings for the
following fieldsin the Graphical Process Modeler. These fields are listed in alphabetical order.

Sterling Integrator version 5.1 and later supports the most common set of parameters available in the
Connect:Direct for zZ/OS Process Copy statement To clause to provide more functionality, such as enhanced
file allocation and disposition options for the destination file on the remote Connect:Direct for zZ/OS node. To
ensure that business processes created in earlier versions of Sterling Integrator continue to execute properly,
parameters existing in versions 5.0 and earlier will still be supported. These old parameters, which cannot be
mixed with new parameters in the same CopyTo service, are not included in the following table. For more
information on both old and new Connect:Direct CopyTo Service parameters, refer to the Sterling Integrator
Services and Adapters documentation in the Sterling Integrator documentation library.

For usersfamiliar with the Connect:Direct Process language, the CD Server CopyTo Service parameters with
the Remote prefix are equivalent to the parameters specified in the COPY TO clause of aCOPY statement and
refer to the destination file being copied to the Connect:Direct hode. The parameters with the Local prefix
correspond to the parameters specified in the COPY FROM clause and refer to the source file on the Sterling
Integrator Connect:Direct Server adapter node.
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Field

Description

Supported Remote
Connect:Direct Platforms

BinaryMode

Specifies how the data from the source file on
the local Connect:Direct Server adapter node
will be transferred to the remote Connect:Direct
node. Optional.

Valid values are:

¢  Yes—dfile will be transferred in simple binary
mode

¢ No—file will not be transferred in binary
mode but rather in text mode (default)

¢ VB—copy will be performed as a variable
block binary transfer with Connect:Direct on
the z/OS platform

Yes—All platforms
No—All platforms
VB—z/OS platform

CDRecordType

Specifies the entry name of the type defaults
file. The type defaults file contains the default
file attributes used to allocate the destination
file. The type defaults file is specified only when
defaults are requested by the user.Optional.
For more information on the type defaults file,
see the Connect:Direct for z/OS user
documentation.

z/OS platform

Checkpointinterval

Specifies the byte interval for checkpoint
support, which allows restart of interrupted
transmissions at the last valid checkpoint point
and therefore reduces the time to retransmit the
file. Optional. For more information, see How
Checkpoint Restart and Retry Processing
Works on page 158.

Valid value is number of bytes, in one of the
following formats:

¢ nnnnnnnnnn
¢ nKornM

¢ nmornk

All platforms

Compression

Specifies that the data is to be compressed,
which reduces the amount of data transmitted
as the file is copied from one node to another.
The file will be automatically decompressed at
the destination. Optional. Valid values are 1-9.
Increasing the value indicates a greater attempt
at compression and will consume more CPU.
Values greater than 2 may not result in further
compression.

All platforms

Config

Name of the service configuration. Required.

All platforms

138
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Field Description Supported Remote
Connect:Direct Platforms

LocalDocumentld A valid document ID for an existing document  All platforms
in Application. When this field is left blank, the
primary document provided to the business
process is used. Optional.

LocalFileNameLabel Specifies a label for the name of the local file.  All platforms
This file name label is provided to the remote
Connect:Direct node for informational purposes
only. Optional.

LocalFromCodePage  Specifies a code page supported by Java VM.  All platforms
Used in conjunction with the value of the
LocalToCodePage parameter. The
Connect:Direct Server adapter will apply a
code page conversion to a document before
transferring it to a remote Connect:Direct
Server. This parameter is only valid with the
following conditions:

¢ Code page specified is supported by the
local Java VM

¢ Parameter LocalToCodePage is defined
« Text mode file transfer (BinaryMode =No)

Optional. Valid value is the name of a
codepage supported by the local Java VM.

For example:

<assign
to="LocalFromCodePage">Cpl1251</assign>
<assign
to="LocalToCodePage">Cp1047</assign>
This example will translate the local file from
windows latin-1 to ibm ebcdic. See
http://java.sun.com for a complete list of
supported encodings.

LocalStripBlanks Specifies whether the Connect:Direct Server All platforms
adapter will strip blanks from the end of records
in the local file before sending them to the
remote node. This option is only valid for Text
mode file transfers (BinaryMode = No).
Optional.

Valid value is Yes or No (default).
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Field Description Supported Remote
Connect:Direct Platforms

LocalToCodePage Specifies a code page supported by Java VM.  All platforms
Used in conjunction with the value of the
LocalFromCodePage parameter. The
Connect:Direct Server adapter will apply a
code page conversion to a document before
transferring it to a remote Connect:Direct
Server. This parameter is only valid with the
following conditions:

« Code page specified is supported by the
local Java VM

« Parameter LocalFromCodePage is defined
e Text mode file transfer (BinaryMode =No)

Optional. Valid value is the name of a
codepage supported by the local Java VM.

For example:

<assign
to="LocalFromCodePage">Cp1251</assign>

<assign
to="LocalToCodePage">Cp1047</assign>

This example will translate the local file from
windows latin-1 to ibm ebcdic. See
http://java.sun.com for a complete list of
supported encodings.

LocalXlate Specifies if the Connect:Direct Server adapter  All platforms
is to perform ASCII to EBCDIC translation
before copying a file to a remote
Connect:Direct Server. This option is only valid
for Text mode file transfers (BinaryMode = No).
Optional.

Valid value is Yes (default) or No.

RemoteBUFND Specifies the number of I/O buffers VSAM will ~ z/OS platform
use for transmitting data between virtual and
auxiliary storage. Optional.

Used only on the z/OS platform.

For more information on how to specify BUFND
information, see the Connect:Direct for z/OS
user documentation.

RemoteDATAEXIT Specifies a user-written program through which  z/OS platform
data is processed before being written to the
destination file. Optional.

Used only on the z/OS platform. Valid syntax is:
exit-name | (exit-name [,parameter,...])

For more information on dataexits, see the
Connect:Direct for z/OS user documentation.
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Field Description Supported Remote
Connect:Direct Platforms

RemoteDCB Specifies Data Control Block (DCB), a group of z/OS platform
attributes to be used in allocating destination
files on a z/OS system.

Used only on the z/OS platform. Optional. Valid
attributes are:

([model-file-name]

[, BLKSIZE=no.-bytes]
[[DEN=0|1]|2]3]4]
[[DSORG=[PS | PO | DA | VSAM]
[LKEYLEN=no.-bytes]
[,LIMCT=no.-blocks-or-tracks]
[,LLRECL=no.-bytes]

[LOPTCD=W | Q| Z]

[ RECFM=record-format]
[,RKP=first-byte-position-of-record-key]
)

For more information on DCB attributes , see
the Connect:Direct for z/OS user
documentation.

RemoteDISP Specifies how the destination file is to be All platforms
created on the remote Connect:Direct server.
Optional.

Valid syntax for Connect:Direct for z/OS is:
(INEW | OLD | MOD | RPL | SHR],
[KEEP | CATLG],

[KEEP | CATLG | DELETE]

)

I

(NEW | OLD | MOD | RPL | SHR)
|

NEW | OLD | MOD | RPL | SHR

For more information on the values and syntax
valid for the Connect:Direct platform you are
copying to, see your Connect:Direct
documentation.

RemoteFileName Name that should be given to the file that is All platforms
copied to the remote Connect:Direct server.
Required.

Note: You cannot use wildcards to copy
multiple files from Sterling Integrator
to Connect:Direct with a single
CopyTo service.
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Field Description Supported Remote
Connect:Direct Platforms

RemotelOEXIT Specifies a user-written program to be invoked z/OS platform
to perform 1/O requests on the source file
before copying the source file to a destination
file. Optional.
Used only on the z/OS platform. Valid syntax is:
exit-name | (exit-name [,parameter,...])

For more information on 1/O exits, see the
Connect:Direct for z/OS user documentation.

RemoteLABEL Specifies label information for the tape used for  z/OS platform
the destination file. Optional.

Used only on the z/OS platform. Valid syntax is:
([file-sequence-number]

JSL|AL|BLP | LTM | NL | AUL | NSL | SUL]
,[PASSWORD | NOPWREAD)]

JIN | OUT]

,[RETPD=nnnn | EXPDT=[yyddd | yyyy/ddd]]

)

For more information on how to specify label
information, see the Connect:Direct for z/OS
user documentation.

RemoteMSVGP Specifies the group of mass storage volumes z/OS platform
that reside on a mass storage system (MSS)
device. This must be a valid DD (data
definition) name, ranging from 1-8
alphanumeric characters with the first character
alphabetic. Optional.

Used only on the z/OS platform. Valid value is
MS-group-name.
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Field Description Supported Remote
Connect:Direct Platforms

RemoteSMS Specifies SMS attributes to use when creating  z/OS platform
the destination file. Optional.

Used only on the z/OS platform. Valid attributes
are:

¢ AVGREC=U |K|M
¢ DATACLAS=data-class-name

¢ DSNTYPE=PDS | LIBRARY | LARGE |
EXTREQ | EXTPREF | BASIC

¢ KEYLEN=length in bytes

¢ KEYOFF=offset-to-key

¢ LIKE=model-data-set-name

¢ LRECL=number of bytes

¢ MGMTCLAS=management-class-name
¢ RECORG=KS|ES|RR|LS

¢ SECMODEL=(profile-name [, GENERIC])
¢ STORCLAS=storage-class-name

For more information on SMS attributes, see
the Connect:Direct for z/OS user
documentation.

RemoteSPACE Specifies the amount of storage to be allocated z/OS platform
for new files on the destination node. If SPACE
is specified, the RemoteDISP of the destination
file must be NEW or RPL. Optional.

Used only on the z/OS platform. Valid syntax is:
(CYL | TRK | blk,

(prim , [sec] , [dir]), [RLSE] , [CONTIG],
[ROUND])) |

(av-rec-len , (primary-rcds , [secondary-rcds] ,
[dir])

)

For more information on how to specify SPACE
information, see the Connect:Direct for z/OS
user documentation.
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Field Description Supported Remote
Connect:Direct Platforms

RemoteUNIT Specifies the storage device or type along with  z/OS platform
the number of devices required. Optional.

Used only on the z/OS platform. Valid syntax is:
([unit-address | device-type | group-name]

, [unit-count | P ] [[DEFER]

)

For more information on how to specify UNIT
information, see the Connect:Direct for z/OS
user documentation.

RemoteVOL Specifies one or more volume serial numbers z/OS platform
containing the destination file and optional
processing associated with the file. Optional.

Used only on the z/OS platform. Valid syntax is:
([PRIVATE],[RETAIN]

,[volume-sequence-no] ,[volume-count]
[,.SER=(serial-no [,serial-no,...])
|SER=serial-no)

|([SER=(serial-no ,[serial-no,...]))

|(REF=dsn])

For more information on how to specify VOL
information, see the Connect:Direct for z/OS
user documentation.

SessionToken Identifies an established session between two  All platforms
Connect:Direct nodes. Required. Session
integrity cannot be guaranteed if the session
token is omitted. For examples of session token
usage, refer to Sample Business Processes on
page 105.

Sysopts Remote system operations to be implemented  All platforms
on the remote Connect:Direct node. Optional.  Eormat of Sysopts varies by

For example (for copying to Connect:Direct platform.
Windows only):

Datatype(text) xlate(yes)

For more information, see your Connect:Direct
documentation.

Settings for Connect:Direct Server CopyFrom Service
There are many copy options available when you use the Connect: Direct Server CopyFrom Service.

When you configure the Connect:Direct Server CopyFrom service, you must specify settings for
the following fields in the Graphical Process Modeler. Thesefields are listed in a phabetical order.
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Field Description Supported Remote
Connect:Direct Platforms
BinaryMode Specifies the mode for Connect:Direct File Yes—All platforms
transfer. Optional. Valid values are: No—All platforms
¢ Yes—simple binary mode VB—z/OS platform

¢ No—(default) - text mode

* VB—a variable block binary transfer with
Connect:Direct on z/0OS

Checkpointinterval Specifies the byte interval for checkpoint All platforms
support, which allows restart of interrupted
transmissions at the last valid checkpoint point
and therefore reduces the time to retransmit the
file. Optional. For more information, see How
Checkpoint Restart and Retry Processing
Works on page 158.

Valid value is number of bytes, in one of the
following formats:

¢ nnnnnnnnnn
¢ nKornM

¢ nmornk

Compression Specifies that the data is to be compressed, All platforms
which reduces the amount of data transmitted
as the file is copied from one node to another.
The file will be automatically decompressed at
the destination. Optional. Valid values are 1-9.
Increasing the value indicates a greater attempt
at compression and will consume more CPU.
Values greater than 2 may not result in further
compression.

Config Name of the service configuration. Required. All platforms

DCB Specifies Data Control Block (DCB), a group of z/OS platform
attributes specified as name-value pairs
separated by commas. Used only on the z/OS
platform. Optional. Valid attributes are:

¢ recordlength

*

blocksize
* recordformat

¢ datasetorganization

Note: More DCB attributes are available
but only these are supported in
Application. Any other attribute will
cause the copy to fail.

For more information, see the Connect:Direct
for z/OS user documentation.
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Field Description Supported Remote
Connect:Direct Platforms

LocalDocumentName  Name of the document in Application to which  All platforms
the remote file should be copied. Optional.

LocalFromCodePage  Specifies a code page supported by Java VM.  All platforms
Used in conjunction with the value of the
LocalToCodePage parameter. The
Connect:Direct Server adapter will apply a
code page conversion to a document before
transferring it to a remote Connect:Direct
Server. This parameter is only valid with the
following conditions:

« Code page specified is supported by the
local Java VM

e Parameter LocalToCodePage is defined
e Text mode file transfer (BinaryMode =No)

Optional. Valid value is the name of a
codepage supported by the local Java VM.

For example:

<assign
to="LocalFromCodePage">Cp1251</assign>

<assign
to="LocalToCodePage">Cp1047</assign>

This example will translate the local file from
windows latin-1 to ibm ebcdic. See
http://java.sun.com for a complete list of
supported encodings.

LocalStripBlanks Specifies whether the Connect:Direct Server All platforms
adapter will strip blanks from the end of records
in a received remote file before creating a new
document. This option is only valid for Text
mode file transfers (BinaryMode = No).
Optional.

Valid value is Yes or No (default).
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Field Description Supported Remote
Connect:Direct Platforms

LocalToCodePage Specifies a code page supported by Java VM.  All platforms
Used in conjunction with the value of the
LocalFromCodePage parameter. The
Connect:Direct Server adapter will apply a
code page conversion to a document before
transferring it to a remote Connect:Direct
Server. This parameter is only valid with the
following conditions:

« Code page specified is supported by the
local Java VM

« Parameter LocalFromCodePage is defined
e Text mode file transfer (BinaryMode =No)

Optional. Valid value is the name of a
codepage supported by the local Java VM.

For example:

<assign
to="LocalFromCodePage">Cp1251</assign>

<assign
to="LocalToCodePage">Cp1047</assign>

This example will translate the local file from
windows latin-1 to ibm ebcdic. See
http://java.sun.com for a complete list of
supported encodings.

LocalXlate Specifies if the Connect:Direct Server adapter  All platforms
is to perform ASCII to EBCDIC translation
before creating a new document from the
received remote file. This option is only valid for
Text mode file transfers (BinaryMode = No).
Optional.

Valid value is Yes (default) or No.

RemoteFileName Name of the file that should be copied from the All platforms
remote Connect:Direct server. Enter the legal
characters in the file name. Required.

SessionToken Identifies an established session between two  All platforms
Connect:Direct nodes. Required. Session
integrity cannot be guaranteed if the session
token is omitted. For examples of session token
usage, refer to Sample Business Processes on
page 105.
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Field Description Supported Remote
Connect:Direct Platforms

Sysopts Remote system operations to be implemented  All platforms
on the remote Connect:Direct node. Optional.  Eormat of Sysopts varies by

For example (for copying from Connect:Direct  platform.
Windows only):

Datatype(text) xlate(yes)

For more information, see your Connect:Direct
documentation.
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Clustering Considerations

Connect:Direct Server Adapter Configuration

When you configure a Connect:Direct Server adapter in a single node instance of Sterling

Integrator, the best practice is to use the same name for the Connect:Direct Server adapter Name
and the Connect:Direct Server Node Name.

When you configure a Connect:Direct Server adapter in a multiple node instance of Sterling
Integrator, the best practice is to set up one Group Name for the Connect:Direct Server adapters.
For example, in atwo node cluster, the Connect:Direct Server adapter Node Namesare NODE1.CD
and NODE2.CD. Bath of these nodes are put in one group called SI.CD. Provide SI.CD as the
Connect:Direct Server Adapter Node Name for your remote Connect:Direct nodes. Y ou will also
use SI.CD asthe Local CDNodeName in the CD Server Begin Session Service in your business
processes.

Note: For additional information about the Connect:Direct Server adapter and multiple node instances of
Sterling Integrator, refer to the Sterling Integrator documentation library.
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Monitoring Business Processes and
Documents

The Sterling Integrator Admin Console enables you to view information about business processes
that interact with remote Connect:Direct nodes. Correlation records are automatically maintained
so that you can search for specific information (such as, business process |Ds, document IDs,
workflow IDs, and mailbox I Ds). Each business process references a unique business process |D as
its primary processidentifier.

Tracking and Search Functions

The tracking and search functions available to track Sterling Integrator business processes,
Connect:Direct processes, and Connect:Direct adapter activity are described in the following table:

Tracking Option Description

Central Search Use to search for live (active) business process instances that do not appear in the
Current Processes. Search by Name, Status, or Date.

Current Processes  Lists the status of the ten most recent business process instances.

Current Activities Search for Connect:Direct Server adapter activity by adapter configuration name or
by when the activity registered within Sterling Integrator.

Advanced Search

Business Search for active, archived or stored business processes. Search by business
Processes process instance ID, business process Name, State, or Date.
Documents Search for active, archived or stored documents handled by a business process.

Search by Time, Document ID, Sender or Receiver ID, Type, Status or Correlations.
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Tracking Option Description

Communication Search for active, archived or stored communication sessions records. These records
Sessions include the associated authentication, authorization, file transfer, or non-file transfer

records, even if a document is not transferred and no data flow record is created.
Search by Time, Communication Session ID, Process ID, End Point, Protocol and so
forth.

Correlation Search for active, archived or stored business processes by name-value pairs. This is

a key tracking method in interoperability because you can search by values such as
PNODE, SNODE, Connect:Direct Process Name and so forth.

When you find the business process you are interested in on any of these Monitor pages, you can
obtain additional details by selecting the number in the ID column to open the Business Process
Details page.

Business Process Detail

The Business Process Detail page is accessed from any page that contains the business processID.
Thispage providesaprogress report about a specific business processinstance. In addition, you can
stop or restart the business process from this page.

Following is apartia list of the information you can obtain from this page:

<+

+ +

The business process definition (the BPML file)

The current state of each step in a business process

The date and time a business process started and ended

The contents of the process data and the primary document at each step of the business process

Current Process Monitor

152

Selecting Business Processes > Current Processes opens the Monitor page with alist of the
processes currently running in Sterling Integrator. A Green status indicates no errors or warnings
occurred during processing. A Red statusindicates errors or warnings encountered during
processing. Use this page to:

*

.+

Review detailed processing information by clicking on the ID of the process
View the business process definition by clicking on the Name of the process
View the current state of a business process

View the date and time a business process Started and Ended
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Current Activities Monitor

Selecting Business Processes > Current Activities opens the Service Activity search page. The
Service Activity page enables you to monitor activity of several adapters, including the
Connect:Direct Server adapter. When you select an adapter to monitor, activity detail occurring on
the adapter is displayed.

If the Connect:Direct Server adapter isused by abusiness processthat has stopped running, you can
use this feature to determine whether the adapter is preventing the business process from running.

The results of an activities search includes the following information:
4 Session identifier

4+ Node name

4+  When the activity started and when it last updated

Correlation Search

Correlation searches are a key to relating a Connect:Direct Process with a Sterling Integrator
business process. Whereas Connect:Direct identifies a process with a Process Number and a
Process Name, Sterling Integrator identifies its business processes with an Instance ID. The
Correlation Search enables you to search for Sterling Integrator processes using Connect:Direct
identifiers.

Note: Correlations are created to identify related Sterling Integrator and Connect:Direct processes.

The Connect:Direct Server adapter and related services automatically write Sterling Integrator
correlation records to enable searches for business processes and documents containing certain
correlation identifiers.

The Correlation Search page enables you to search for business process activity according to six
Connect:Direct specific name-value pairs, including:

CD_LocaFileName
CD_RemoteFileName
CD_ProcessName
CD_ProcessNum
CD_PnodeName
CD_SnodeName

R R R R

Note: Do not perform a correlation search by Process Number only. A Process Number is uniqueto a
single Connect:Direct server, therefore you may see the same Process Number used for different
processes—each associated with a different node.
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Session Establishment and Process
Recovery

Session Establishment and Process Recovery

Sterling Integrator provides severa parameters that allow you to customize features that govern
how many sessionsit establishes for a Connect:Direct Server adapter node and remote
Connect:Direct nodes and how it performsretry processing in the case of afailed or interrupted file
transfer. These parameters are discussed in Setup Procedures on page 11.

This appendix describes the processing that happens behind the scene when Sterling Integrator
establishes sessions initially and re-establishes sessions in case of failures or interruptions during
copy operations so you can fully understand how these featureswork and adjust your configuration
settings if necessary. Subtopics include:

4+ How Sessions for Business Processes Are Established on page 155
4+ How Checkpoint Restart and Retry Processing Works on page 158
4+ How File Allocation Retry Processing Works on page 159

How Sessions for Business Processes Are Established

Before you transfer files or initiate processes between Connect:Direct servers and the Sterling
Integrator Connect:Direct Server adapter, you configure those componentsin Sterling Integrator so
that it knowswho it will be communicating with. One of the required parametersyou definefor both
Connect:Direct nodes and the Connect:Direct Server adapter is the maximum number of locally
initiated sessions the Connect:Direct Server adapter may have active at any point in time. This
parameter, Max locally initiated (pnode) sessions allowed, determines the maximum number of
sessions available for establishing and re-establishing sessions, and plays akey role when business
processes are suspended and resumed. If thisvalue is aso specified at the remote node-level, the
effective session limit isthe smaller of two values: the limit for the adapter and the session limit for
the remote node.

When a Connect:Direct Server adapter initiates a data transfer between itself and aremote
Connect:Direct node, it does so as part of a Sterling Integrator business process. If the business
processinvokesaConnect:Direct Server adapter serviceto establish asession and thelocal PNODE
session limit has been met, the business process is suspended and placed in a queue of business
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processes waiting for an available session. When a session has become available, itisassigned to a
previously suspended business process, if any, on afirst-come first-served basis.

Thefirst (oldest) suspended business processis given the first chance to use the next free PNODE
session for the Connect:Direct Server adapter. If no suspended business process can use the session
or if no business processesarein the suspended business process queue, the freed sessionisreturned
to the available session count. If a PNODE session limit was also specified at the node level, the
number of currently active sessions with the particular remote node and the total number of active
PNODE sessions are both decremented when a freed session goes back to the available session
count. To see an example of how session counts go up and down when business processes are
suspended and resumed, see Sample Scenario of Workflow Suspension Processing and Session
Counts on page 156.

If Sterling Integrator or a Connect:Direct Server adapter isterminated while business processes are
suspending awaiting the next freed session, then an error is returned to the service invocation that
caused the business process to be suspended.

If you suspect an error has occurred or that the execution of a business process has been delayed,
you can check its status and the status of all related services. If a business process has been
suspended, the message, Session count exhausted, waiting for session availability, is displayed for
the Connect:Direct Server Begin Session Service, CopyTo, or CopyFrom service involved in
establishing or re-establishing a session. When a session count becomes available, the message,
Session now available: resuming, isdisplayed, and the Status Report screen will show how long the
business process was suspended, for example, Session now available, resuming after wait of 1
minutes 35 seconds.

Sample Scenario of Workflow Suspension Processing and Session Counts

In this sample scenario, there are three entities, all of which are configured as shown below in
Example 1.

4 The Connect:Direct Server adapter (CDSA), which isinvoked by business process X (BP-X)
to establish sessions with NODEA or NODEB.

4+ NODEA isaremote Connect:Direct node that Sterling Integrator wants to communicate with
4+ NODEB is aremote Connect:Direct node that Sterling Integrator wants to communicate with

Example 1

156

CDSA session limit =2
CDSA current sessions = 2

NODEA session limit =2
NODEA current sessions= 1

NODEB sessionlimit=1
NODEB current sessions= 1

SUSPENDED WORKFLOW QUEUE = <empty>
In this scenario, the following sequence of events occurs:
4+ BP-X attempts to establish a new PNODE session with NODEB.
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*

Since NODEB is aready at its session maximum, this triggers the workflow suspend
mechanism.

BP-X is placed on the suspended workflow queue to await a session count.

The current session with NODEA terminates and is freed.

CDSA looks for a suspended workflow that can use the newly freed session.

BP-X cannot use the freed NODEA session because NODEB is still at its session maximum.

The freed NODEA session is returned to the available session count, and BP-X continues to
wait.

R

S0, after this sequence of events, the situation is:
CDSA session limit=2

CDSA current sessions=1

NODEA session limit =2

NODEA current sessions=0

NODEB sessionlimit =1
NODEB current sessions= 1

SUSPENDED WORKFLOW QUEUE = BP-X

A new session can now be established with NODEA, but BP-X must still wait for the current
session with NODERB to be freed before it can proceed.

Example 2
In this example, the session limit for NODEB has been bumped up one:

CDSA session limit =2
CDSA current sessions = 2

NODEA session limit =2
NODEA current sessions= 1

NODEB session limit =2
NODEB current sessions= 1

SUSPENDED WORKFLOW QUEUE = <empty>
The following sequence of events occurs:

4+ BP-X attempts to establish a new PNODE session with NODEB.

4+ NODEB isnot at its session maximum, but the overall Connect:Direct Server adapter isat its
limit. As aresult, the workflow suspend mechanism is triggered.

BP-X is placed on the suspended workflow queue to await a session count.

The current session with NODEA terminates and is freed.

CDSA looks for a suspended workflow that can use the newly freed session.

BP-X can use this session because both NODEB and the adapter now have a session available.
BP-X isresumed and allowed to attempt session establishment with NODEB.

+ 44+
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After this sequence of events transpires, the situation stands as this:

CDSA session limit=2
CDSA current sessions = 2
NODEA session limit =2
NODEA current sessions=0

NODEB session limit =2
NODEB current sessions = 2

SUSPENDED WORKFLOW QUEUE = <empty>

How Checkpoint Restart and Retry Processing Works
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The checkpoint restart feature allows the restarting of copy operations that fail in certain ways, for
example, due to network errors. The copy operation is resumed from a previously checkpointed
location rather than having to start over from the beginning of the file transfer. Checkpoint restart
behavior is controlled by the PNODE—SNODE settings have no effect.

To enablethisfeature, on the PNODE you must specify avalue greater than O (O disables automatic
retries) using one of the following parameters:

4+ Number of long-term session retry attempts (the number of long-term retry attempts specified
for the Connect:Direct Server adapter)

4+ Number of short-term session retry attempts (for the Connect:Direct Server adapter)

4+ Number of Retry attempts for establishing a session (in the Connect:Direct Server Begin
Session Service used in a particular business process)

Y ou must also specify the Checkpointlnterval in the CopyTo and CopyFrom service of your
business process.

Note: Certain errorsfail without any retries, for example, when arequired parameter ismissing or invalid
or aremote node is not in the netmap.

Both the Interval between long-term session attempts (minutes) and Number of long-term session
retry attempts fields deal with long-term session establishment and re-establishment attempts. To
use a shorter timeframe to establish and re-establish sessions, specify the following fields when
configuring the Connect:Direct Server adapter:

4 Number of short-term session retry attempts
4+ Interval between short-term session attempts (seconds)

If both the short-term and long-term retry parameters are specified, the values for the short-term
parametersare used first, and if asession has still not been established (or re-established), the value
for the long-term parameter is used if it is specified. For more information, see Setup Procedures
on page 11.

Checkpoint restart is supported for both inbound and outbound file transfers. This feature is only
supported for documents stored in thefile system—it is not supported when document storageis set
to Database or data encryption is enabled in Sterling Integrator.

Checkpoint restart can be enabled whether or not Secure+, compression, or any other
communications session factor is enabled or disabled.
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In afiletransfer, the PNODE determines whether checkpointing will be performed and sets the
checkpoint interval. These two parameters can be set asaglobal default (usually inaninitialization
parameter or property file) or overridden in the Connect:Direct Process (Copy step) or Sterling
Integrator business process.

The checkpoint information is kept on the target node (the node receiving the file) until the file
transfer completes successfully (in which case, this temporary record is destroyed) or kept for a
specific period of timeif thefiletransfer fails. When afiletransfer fails, the checkpoint information
isretained for a specified default length of time on the target system (30 daysis common). In
Sterling Integrator, this setting is configured by setting the ckptRemoveDate property in the
noapp.properties property file located in the properties subdirectory of the installation.

If aremote Connect:Direct server or the network fails during a copy operation, the Connect:Direct
Server adapter goesinto retry mode using its own default long-term and short-term values and waits
the specified amount of time and then resumes the copy. These values can be overridden by the
following values, if specified, in the Connect:Direct Server Begin Session service:

4+ Number of long-term session retry attempts (BeginSessionM axRetries)
Interval between long-term session attempts (BeginSessionRetrylnterval)
Number of short-term session retry attempts (ShortTermM axRetries)
Interval between short-term session attempts (ShortTermRetryInterval)

¢+ 4

Purging Checkpoint Data

By default, Sterling Integrator stores checkpoint information for 30 days, after whichiit is
automatically purged. If your database has been corrupted, you must purge this checkpoint
information by performing a cold restart. To purge all checkpoint data, each Connect:Direct Server
adapter must be cold started.

To purge al the checkpoint records associated with a Connect:Direct Server adapter:

1. From the Business Processes menu, search for the adapter configuration.

Edit the configuration to set Server Start Option to Cold.

Save the changes and click Finish.

The Sterling Integrator adapter restarts. The checkpoint data is purged during startup.

a b~ 0D

Edit the configuration again to set Server Start Option to Warm to continue using Checkpoint
Restart without aloss of information between multiple sessions.

How File Allocation Retry Processing Works

File Allocation Retry (FAR) processing allows CDSA to retry a Copy operation when one of a set
of certain file allocation errors occurs in combination with a non-zero return code. Thisis most
useful when CDSA initiates afile transfer with aremote Connect:Direct for z/OS system. FAR
processing only affectslocally initiated (PNODE) sessions that use the Connect:Direct Server
CopyTo service or CopyFrom service.

When you enable FAR processing and CDSA receives one of aset of certain file allocation error
messages and a non-zero return code from the remote Connect:Direct server during a copy
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operation, CDSA retries the Copy operation subject to the existing short-term and long-term retry
settings. If the condition that caused the FAR processing persists, retries are performed up to a
maximum of the configured short-term and long-term retries only. The retry counters are not reset
after a successful connection when triggered by FAR processing.

If the retry counts are exhausted, the CopyTo or CopyFrom service fails and returns an error to the
Business Process that invoked it.

The set of FAR error messages, which include the commonly occurring Connect:Direct for Z/OS
retry-able file allocation errors, is pre-configured in the Sterling Integrator installation.

To enable FAR processing:

Loginto Sterling Integrator.

From the Deployment menu, select Services > Configuration.

From the Services Configuration page, search for the CDSA configuration.

On the InitParms screen, select the Retry Remote File Allocation Errors check box.
Save the changes and click Finish.

The Sterling Integrator adapter restarts. FAR processing is enabled.

© o b~ 0w D P

FAR processing is disabled by default when you create a new CDSA configuration or import a
CDSA configuration from an earlier version of Sterling Integrator or GIS.
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Troubleshooting

Sterling Integrator and Connect:Direct are designed to work together, in a seamless and tightly
integrated environment. However, asis the case with any application, occasions may occur when
you need to troubleshoot certain components or functions.

This section provides genera troubleshooting guidelines when configuring and using Sterling
Integrator with Connect:Direct.

To troubleshoot general Connect:Direct functions, see the Connect:Direct documentation set for
general troubleshooting information and instructions.

Y ou may need to work with your Trading Partners or system administrators to troubleshoot the
systems you are communicating with.

Verifying Connectivity
To verify connectivity between Connect:Direct and Sterling Integrator:

1. Check configurations on Connect:Direct and Sterling Integrator for compliance. In particular,
look at the network maps on both systems.

2. Verify that the Connect:Direct nodes in question are active when a begin session isinvoked.

3. Verify that perimeter services client connects to perimeter services server. If the client cannot
connect, it causes the perimeter services-enabled Connect:Direct Server adapter to fail.

Perimeter servers do not automatically reboot after afailure.
To determine the status of the perimeter services client in Sterling Integrator:
a. From the Sterling Integrator Operations menu, select Troubleshooter.

b. Look for the Perimeter Servers area. It isusually at the bottom of the Troubleshooting
page. This shows the state of the perimeter server clients which are defined in Sterling
Integrator and whether they are on.

Disconnected is displayed if no perimeter server isinstalled.
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Exchange Process IDs

If either Connect:Direct or Sterling Integrator cannot exchange process identifiers, the process
correlation in the various monitor user interfaces does not work for the particular instance of a
process. When this occurs, correct the identifiers and restart the process.

Business Process Permissions

If you receive permissions-related error messages, make sure that adequate permissions have been
assigned.

When a external request is received by Sterling Integrator to execute a business process, the
user/proxy user must have business process permissions for the specific business process that isto
be executed. That is, the business process itself must have permissions enabled when it is created.
In addition, the Sterling user account must have:

4+ General business process execution permission. Thisis acquired by assigning the Business
Processes group to the user account.

4+ Permission for the specific business process to be executed.

The business process will display in the drop down with the mailboxes in the user account
configuration windows.

Using the Graphical Process Modeler

The following restrictions apply to using the Graphical Process Modeler:

4+ Do not attempt simultaneous COPY operations for the same node.
4+ Issue aClose Session for each open session when session is finished.

Logging Files

162

Moreinformation, including audit messages and error messages, can be found in Sterling I ntegrator
log files. Log files are available through the Operations > System > L ogs menu.

The cdinterop.log filesrecord detailsfor all adapter activity and business processesthat involvethe
Connect:Direct Server and Requester adapters and the related Connect:Direct services.

A new cdinterop.log is create each time the Sterling Integrator server is started. At midnight, the
current log fileis closed and anew oneiscreated. In addition, when the size of the current log file
reaches the maximum size specified in the cdinterop log file configuration screen, it is closed and
anew log fileis opened. Thelog file name includes a date and time stamp to make each name
unique.

By default, the cdinterop.log file captures audit level messages, even when logging is not enabled.
When the log is enabled, all transactions are recorded, including:

4 Error messages

Adapter startup and shutdown
Adapter changes

Security checks

+ 4+ 4
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Customizing the Connect:Direct Server Adapter Log Settings

Y ou can enhance the logging for the Connect:Direct Server adapter using property filesto reduce
the footprint of the log files and processing overhead.

The log.properties file describes sets of properties required to define alogger used to log
information to afile, including the cdinterop.log. This log.properties file should not be edited. If
you need to override log.properties settings for the cdinterop.log, use the
customer_overrides.propertiesfile.

Caution: Overriding the log.properties settings for the cdinterop.log can have a dramatic impact on
performance and log volume.

The customer_overrides.propertiesfile is used to override property settingsin other property files.
Unlike the other property files and their associated .properties.in files, the
customer_overrides.properties file is not changed during installation of Application upgrades or
patches. To prevent having your customized settings overwritten, you should use the customer
override property file whenever possible rather than editing the Application property filesor .in
files.

The customer_overrides.propertiesfileisnot part of theinitial Application installation and must be
created. It must be named customer_overrides.properties.

To override log.properties file settings for the cdinterop.log:

1. Intheinstall_dir/properties directory, locate (or create, if necessary) the
customer_overrides.propertiesfile.

Open the customer_overrides.propertiesfile in atext editor.

Add the cdinteropcdinterop.log properties that you want to override to the log.propertiesfile,
using the following format:

logService. PROPERTY_NAME=PROPERTY_VALUE

logService—Name used to reference the log.properties file.

PROPERTY _NAME—Name of the property as used in the log.propertiesfile.
PROPERTY _VALUE—The value you want to assign to the property.

For example, assume that you want to change the maximum number of cdinterop.log filesto 5.
To do so, override the cdinteropl ogger.maxnumlogs property value in the log.properties file by
adding the following line to the customer_overrides.propertiesfile:

logService.cdinteroplogger.maxnumlogs=5
4. Save and close the customer_overrides.propertiesfile.
Stop and restart Application to use the new values.

Test your changes to ensure that the overrides give the desired results. If you have problems,
contact Sterling Commerce Customer Support for assistance.
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Configuration Settings

The following table describes properties used to configure the customer_overrides.propertiesfile

for the CDInterop logger:

Property

Description

logService.cdinteroplogger.logfilename

Specific name of the log file.
Example: ApplicationinstallDir/logs/cdinterop.log

logService.cdinteroplogger.rotatelogs

Flag indicating whether to rotate the log after it has reached its
maximum size.

Example: true

logService.cdinteroplogger.maxlogsize

Maximum size of logs of this type.
Example: 100000

logService.cdinteroplogger.maxnumlogs

Maximum number of logs of this type.
Example: 10

logService.cdinteroplogger.loglevel

A level value of the logger.

Valid entries:

NONE—Log nothing.
CRITICAL—Log critical errors only.
ERROR—Log errors only.
WARN—Log errors and warnings.
INFO—Log INFO and more severe.

R

TIMING—Log errors, warnings, timing messages.

logService.cdinteroplogger.displayname

Display name for the logger.
Example: Log.CDInterop

logService.cdinteroplogger.showsource

Flag indicating whether to show the java class that originated

an error message.

Note: This can have a dramatic impact on performance and
log volume, so it should only be used to diagnose
problems.

Example: false

Turning on Logging
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If theerror isnot in the existing logs, turn on the Sterling I ntegrator cdinterop.log to capture activity
of the Connect:Direct Server adapter and the services:

Browse to Operation > System > Logs.

A WD

Scroll to the Environment section of the page.
Click the edit icon to the left of Connect:Direct Server and Requester Adapter and Services.
In the Environment window, select On next to Logging Level and click Save.
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5. Attempt to recreate the problem.
6. View the cdinterop log for more informative entries.
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Use Secure Point of Entry

Secure Point of Entry (SPOE) isa security mechanism for maintaining the privacy of sensitive user
account information. Privacy is maintained by associating a pseudo-account with an authentic one.
Remote Connect:Direct trading partners establish sessions using pseudo-accounts rather than
authentic ones. In thisway, sensitive user account information remains private. The
cdinterop-spoe-policy.properties file describes settings for configuring the Secure Point-of-Entry
(SPOE) for use with the Connect:Direct Server adapter for inbound requests from remote
Connect:Direct PNODEs.

Sterling Integrator also supports Connect:Direct User Proxies as a PNODE whereby the business
process can:

4+ Specify a RemoteUserld without a RemotePasswd.

4+ Not specify a RemoteUserld or a RemotePasswd. The Connect:Direct Server adapter will use
the PNodeld (the user executing the business process).

4+ Specify aLocalUserld without a RemoteUserld or a RemotePasswd.

Usethefollowing procedure to configure SPOE with the Connect:Direct Server adapter for inbound
requests:

4+ Enable SPOE Authentication from Remote Connect: Direct PNODES on page 167
4+ Map Connect:Direct User IDsto Serling Integrator User Accounts on page 168

Enable SPOE Authentication from Remote Connect:Direct PNODEs

SPOE policy may be modified while Sterling Integrator is running. Changes take effect afew
seconds following the change committal step. To enable SPOE authentication:

1. Makeacopy of the SPOE Policy property file:

$ cd <install_dir>/properties
$ cp cdinterop-spoe-policy.properties cdinterop-spoe-policy.properties.copy

2. Useatext editor to make the desired changes to the cdinterop-spoe-policy.properties.copy file:
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$ vi cdinterop-spoe-policy.properties.copy

Uncomment the spoe .policy=yes property.

3. Modify other settings in the cdinterop-spoe-policy.properties.copy file necessary for your
situation.

For more information about the cdinterop-spoe-policy.propertiesfile, refer to the Sterling
Integrator documentation library.

4. Savethefile.
5. Commit the changes:

S cd <install_dir>/properties
$ cp cdinterop-spoe-policy.properties.copy cdinterop-spoe-policy.properties

Map Connect:Direct User IDs to Sterling Integrator User Accounts

After you enable SPOE authentication for the Connect:Direct Server adapter, configure the
cdinterop-spoe-auth.properties file to map external Connect:Direct user IDs to Sterling Integrator
user accounts.

Configuration Settings

The following table describes properties used to configure the cdinterop-spoe-auth.properties file
in Sterling Integrator:

Syntax Description

spoe-user-id Specifies a unique remote user identifier. The remote user may be specified by an
asterisk (*) to enable this definition to match any user.

Note: The asterisk does not perform similar to a wildcard character or regular
expression operator. It is a special keyword having the meaning "any user."

nodename Specifies the name of the remote Connect:Direct PNODE node. The node name may
be specified by an asterisk (*) to enable this definition to match any node.

Note: The asterisk does not perform similar to a wildcard character or regular
expression operator. It is a special keyword having the meaning "any
node."

gis-user-id Specifies an existing Sterling Integrator user account.

Each entry associates a SPOE username and remote Connect:Direct node name with a Sterling
Integrator user account. Each entry in the file consists of a single line of the form:

spoe-user-id@nodename=gis-user-id
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The @ joins the user identifier with the node name to form the SPOE remote user identifier. No
space is permitted either before or after it. The = associates the SPOE remote user identifier with
the Sterling Integrator user account. No space is permitted either before or after it.

Examples

A remote user id 'userl' is mapped to the gis 'user2' account:

userl@cd.logistics=user2

Any remote id from the cd.chicago node is mapped to the gis account ‘chicago”:

*@cd.chicago=chicago

The remote id ‘anonymous' from the *any* node is mapped to the Sterling Integrator ‘anonymous
account:

anonymous@*=anonymous

Any remote id from the *any* node is mapped to the Sterling Integrator 'guest' account:

*@*=guest

Add, Modify, or Delete SPOE User Accounts

SPOE user accounts may be added, modified, or deleted while Sterling Integrator is running.
Changes take effect afew seconds following the change committal step.

To change the cdinterop-spoe-auth.propertiesfile:

1. Makeacopy of the cdinterop-spoe-auth.properties file:

$ cd <install_dir>/properties
S cp cdinterop-spoe-auth.properties cdinterop-spoe-auth.properties.copy

2. Useatext editor to make the desired changes to the cdinterop-spoe-auth.copy file:

$ vi cdinterop-spoe-auth.properties.copy

3. Savethefile.
4, Commit the changes:

S cd <install_dir>/properties
$ cp cdinterop-spoe-auth.properties.copy cdinterop-spoe-auth.properties
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