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Introduction to the Graphical Process Modeler
To help you create business process models, Gentran Integration Suite includes the Graphical Process 
Modeler (GPM). The GPM is a Web-deployed graphical interface tool you use in conjunction with Gentran 
Integration Suite to create and modify business processes. The GPM converts your graphical business 
process models into source code, saving you the effort of writing code.

In the GPM interface you construct your business process models, coordinating the flow of activities in a 
graphical depiction of the ordered steps. The GPM provides icons representing the services, adapters and 
BPML instructions that make up your process models. In addition, you configure related parameters through 
the GPM and create rules and conditions within your process models.

You can validate the process models and check them in to Gentran Integration Suite from within the GPM. 
To make it easier to work with your business process models in the GPM without having to access Gentran 
Integration Suite interface, the GPM includes its own Source Manager tool, enabling you to lock, check in 
and check out business process models, and to monitor versions of business process models using a date and 
time stamp, all from within the GPM.

The GPM recognizes BPML code written in a text editor. Therefore, in the GPM, you can open a .bpml file 
created in a text editor and view its graphical representation. The GPM enables you to toggle the display 
between BPML and graphic view.

Example Business Process Model in the GPM
The following figure shows an example of a simple business process model as it appears in the GPM:

The callouts in the figure indicate the types of components depicted by the icons.

Overview of Using the GPM
To get started using the GPM, you must:

1. Install the GPM. See Installing the Graphical Process Modeler (GPM) on page 7.
2. Start the GPM. See Starting the GPM on page 8.

EDI Overdue Acknowledgment Check Service

BPML Activities and Instructions
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Introduction to the Graphical Process Modeler
3. (Optional) Set your preferences. You can specify settings for things such as language preference, when 
to validate BPML, and the location on your computer where you want the GPM to save your business 
process model files. See Setting Up Your GPM on page 14.

After these steps are completed, you can begin creating business process models. For the step-by-step 
procedure, see Creating Business Process Models. 

For an introduction to the GPM interface, see GPM Interface on page 11.

Everyday Activities and Flow
Your use of the GPM follows your business process modeling goals. Before you create a business process 
model, carefully plan it, so that you know which components you must include, as well as how you must 
configure the services and activities within it. For instructions, see Planning Your Business Process Models.

As you familiarize yourself with the GPM components, you will develop your own favorite methods of 
using it and navigating in the layers of your process models, as well as your own preferred order of 
completing the steps involved in creating and modifying business process models. 

The following table describes the activities generally involved in creating business process models in the 
GPM. You can complete the activities in different order, but the table is arranged in a logical order as a 
starting point for your reference.

Activity Description

Check out a business process model. To modify an existing business process model that is checked in to Gentran 
Integration Suite, you must check the process model out before you can 
work with it in the GPM. For instructions, see Modifying and Managing 
Business Process Models.

Determine which stencils you need to 
display.

Stencils are palettes of the services and activities you include in your 
process models. Because hundreds of services are represented, each 
stencil lists a given category of services. You will want to display only the 
ones you are likely to need for the process model you are working on. For 
information about available stencils and how to display them, see GPM 
Stencils on page 17.

Arrange icons in workspace. This activity involves:

Dragging and dropping the icons representing the services and BPML 
activities that comprise your process model into the workspace

Arranging the icons according to the desired flow

Linking the icons

Configure parameters for services, 
activities and links.

Some BPML activities, some links between your services and activities, 
and most services require some configuration in the GPM, depending on 
the task your business process model must accomplish. Use GPM element 
editors to view and modify parameters for the different components, or 
elements, of business process models. For information, see Element 
Editors in the GPM on page 16.
Sterling Commerce, an IBM Company 5



Introduction to the Graphical Process Modeler
Add decision points, rules and 
conditions.

Rules and conditions can be simple instructions or more complex directions 
defined using XPath expressions. The GPM enables you to assign rules 
using an element editor, as well as to define them using the Rule Manager 
and XPath Expression Builder tools. For information, see:

Defining and Assigning Rules and Conditions

GPM XPath Expression Builder on page 23

Make your process model descriptive 
for future reference.

Name the components of your process models in meaningful ways.

Use your company’s naming conventions to name your process model 
when you save it.

Add annotations to the graphical display of your process model. For 
information, see:
- Modifying Annotations
- GPM Annotation Tool on page 26

Save, validate, and check in the 
model.

After you create or modify a process model, you can simply save it or save 
and validate it, and check it in to Gentran Integration Suite. For information, 
see Checking in a Business Process Model.

Activity Description
Sterling Commerce, an IBM Company 6
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Installing the Graphical Process Modeler (GPM)
Although the GPM is an included feature of the Gentran Integration Suite, it does not automatically install 
with the Gentran Integration Suite, because it operates as a separate, Web-deployed application. The GPM 
must be installed on each computer from which a user will access the Gentran Integration Suite and work 
with the GPM.

If you use multiple copies of the Gentran Integration Suite, you must install a separate copy of the GPM for 
each. This enables the Gentran Integration Suite and the GPM to interact. For example, you can check in 
and out business process models from the GPM, and update a service configuration in the GPM after making 
changes to it in the Gentran Integration Suite.

GPM System Requirements
Gentran Integration Suite uses Java Webstart to start the GPM.

In previous versions of Gentran Integration Suite, WebStart was downloaded and installed on the client 
from Gentran Integration Suite’s interface. Now, however, it is bundled and installed with Java Runtime 
Environment (JRE) 5.0, which is required for this version of Gentran Integration Suite. See the System 
Requirements for more information about Java requirements.

GPM Updates
To use the GPM in Gentran Integration Suite 4.3, complete these steps on the client where you want to 
install the GPM:

1. Uninstall all old versions/instances of Java Webstart from the client system. 
Leaving these on the system will cause an error when attempting to load the GPM from the Gentran 
Integration Suite user interface.

2. Download and install Java Runtime Environment (JRE) 5.0 from the Sun ™ web site: 
http://java.sun.com/j2se/1.5.0/download.html

3. Install the JRE on the client system.
4. Log in to Gentran Integration Suite and download the GPM.



Starting the GPM
The first time you start the GPM on a given computer, you must do so from within the Gentran Integration 
Suite interface. Each time you start the GPM application, Java Web Start checks for a connection to the Web 
server to determine whether a new version of the GPM is available. When a new version is available, Java 
Web Start automatically updates the files on the client computer and opens the GPM. Any time after initial 
GPM startup, you can start it in either of the following ways:

✦ Inside Gentran Integration Suite interface
In this case, both the GPM and your network connection to Gentran Integration Suite are open. You 
must log into the GPM using your Gentran Integration Suite User ID and Password when using this 
method.

✦ Outside of Gentran Integration Suite
In this case, called working offline in the GPM, you do not log in to Gentran Integration Suite, and the 
GPM cannot interact with Gentran Integration Suite. There is no log in screen when you are working 
offline.

Note: The offline GPM mode is only possible if the Gentran Integration Suite instance is inaccessible over 
the network. If network connectivity exists, then the online mode is the only option.

The ability to work in the GPM without starting Gentran Integration Suite offers you the convenience of 
creating and modifying business process models without requiring a network connection. Because your 
business process models save directly to your hard drive, you can work on them at your convenience and at 
remote locations, and then check them in to Gentran Integration Suite later, after you log in.

Because the GPM and Gentran Integration Suite can interact (such as when you update the service stencils 
in the GPM), working in the GPM from outside Gentran Integration Suite involves the following 
restrictions:

✦ You cannot refresh (update from Gentran Integration Suite) the services listed in the GPM stencils
✦ You cannot check business process models into or out of Gentran Integration Suite
Plan ahead before you work offline in the GPM. For example, if you will need any new service 
configurations, you must create them in Gentran Integration Suite and refresh the services in the GPM 
(select View > Refresh Services) before you shut down Gentran Integration Suite and work offline in the 
GPM.

Similarly, if you plan to modify an existing process model, you must check it out while Gentran Integration 
Suite is running, before you shut it down and work offline in the GPM.

For instructions to start the GPM, see the appropriate procedure:

✦ Starting the GPM Inside Gentran Integration Suite (must use this option the first time you start the 
GPM)

✦ Starting the GPM Outside of Gentran Integration Suite

Starting the GPM Inside Gentran Integration Suite
You must use this method the first time you start the GPM. 
Sterling Commerce, an IBM Company 8



Starting the GPM
Note: Initial startup may require several minutes, depending on the speed of your connection.

To start the GPM from inside Gentran Integration Suite interface:

1. Complete one of the following tasks: 

From the Admin Console Home page, in the Tools section, next to Run Graphical Process 
Modeler, click Go! 

From the Business Process menu, select Manager, and in the Graphical Modeling section, next to 
Run Graphical Process Modeler, click Go!

2. The Log In dialog box displays. Type your Gentran Integration Suite User ID and Password, click 
OK.

3. If the Locale Settings dialog box displays, select your locale. Options are:

English – United States

Japanese – Japan 

By default, this option displays each time you start the GPM. For instructions on how to disable the 
display after your initial startup, see Setting up your GPM.

4. Click Continue to start the GPM.

You can now create and modify business process models. If this is the first time you have started the GPM, 
set your preferences. See Setting up your GPM. 

Because you are logged in to Gentran Integration Suite, you can check business process models in and out.

Starting the GPM Outside of Gentran Integration Suite
Certain restrictions apply when using the GPM offline. You can start the GPM offline only if you cannot 
access Gentran Integration Suite over a network.

To start the GPM offline for the first time, you must first install a shortcut to your Programs menu and 
Desktop:

1. From the Windows Start menu, select Run. 
2. Type javaws -viewer and click OK. The Java Cache Viewer appears.
3. From the Application column of the Applications menu, select the modeler for which you want to 

create a shortcut.
4. Click the Install shortcuts to the selected application button. The system installs a shortcut to your 

Programs menu and an icon on your Desktop.
5. To start the GPM, from the Start menu, select Programs > the GPM application (Modeler).
6. Click Start.

Note: You will not have to log in to the GPM when you start it outside of the Gentran Integration Suite.

7. Click Continue to start the GPM.
Note: After creating the shortcut, you can access the GPM using the shortcut on your Desktop.
Sterling Commerce, an IBM Company 9



Starting the GPM
You can now create and modify business process models that have been checked out of the Application. If 
you have not already done so, set your preferences. See Setting up your GPM.
Sterling Commerce, an IBM Company 10



GPM Interface
The GPM is designed to simplify your tasks in creating and modifying business process models through 
drag-and-drop technology and tools for navigation and configuration.

The following figure shows the GPM interface and its components. A business process model document is 
open (select File > New to activate the workspace). To create business process models, you drag and drop 
icons from the stencils into the workspace.

The following table provides information about the components identified in the figure:

Component Description

Stencil A stencil is a graphical palette of icons for dragging and dropping into your business 
process models in the workspace. The icons represent components you include in your 
process models—the services, adapters, and BPML instructions that perform tasks.
The GPM includes a variety of stencils, each containing icons of a specific category. You 
can select the stencils to display in the GPM interface at any time (from the View menu, 
select Stencil > <stencil name>. For stencil descriptions, see GPM Stencils.

Stencil

Title Bar Menu Bar Tool Bar Workspace

Navigation Pane
Element Editor 

and Output Pane

Status Bar
Sterling Commerce, an IBM Company 11



GPM Interface
Navigating Layers and Nodes in the GPM Interface
Working with graphical business process models often requires you to navigate sometimes complex or 
extensive arrangements of process components. For your convenience, the GPM contains a Navigation pane 
for quick navigating among components.

Title Bar Displays:

IP address and port of your associated installation of the Gentran Integration Suite

The word “(Offline)” or “(Online)” to indicate whether you are working online (this means 
with an Internet connection open) or offline (with no Internet connection open)

File name of the business process model document that is currently open in the GPM

Menu Bar Enables you to select options related to creating, modifying, and checking in and out your 
business process models.

Use the Edit menu to cut, copy, paste, delete, clear all, and select all components 
displayed on the workspace. Procedural documentation for working with business 
process models describes the other functions you can access from this menu.

The View menu enables you to customize the display. 

Tool Bar Displays buttons that provide quick access to commonly used commands. Inactive buttons 
become active when you select a service icon in the workspace. 

Workspace Area in the GPM interface to which you can drag and drop icons to create a business 
process model. Within the workspace, you click and drag to organize your process models, 
and select components to configure them. You can also view the BPML source code of a 
business process model in the workspace. 
To view BPML source code, from the View menu, select Source.

Status Bar Displays a description of a menu option, toolbar button, or service icon (in a stencil), when 
you point to it.

Navigation Pane Displays a tree diagram of the business process model, depicting any subflows (called 
layers in this pane) and the steps contained within each subflow (these are the nodes). The 
Navigation pane enables you to display a subflow in the workspace by selecting it from the 
Layers tab, and to open element editors for selected nodes by selecting a node from the 
Nodes tab.
The Navigation pane is especially helpful when you are working with complex processes 
that contain many subflows.

Element Editor and 
Output Pane

Displays either element editors for a selected component of the business process model, or 
the output for system messages.

Element editors enable you to view and configure parameters for components of your 
business process models. Double click a component in the workspace to display the 
element editor to configure it. For descriptions of the different element editors, see 
Element Editors in the GPM.

The Output tab displays error, validation, and system messages. This pane opens 
automatically when you validate a model or view source code. 

Component Description
Sterling Commerce, an IBM Company 12



GPM Interface
The Navigation pane makes it easy to select from among the different subflows and components of your 
business process model, using the Layers and Nodes tabs.

Layers
Layers are subflows contained within the business process model. The Layers tab depicts a graphical 
representation of the structure of the parent business process model displayed in the workspace, including 
subflows. To expand the structure to show the layers, double click the icon in the Navigation pane that 

represents the business process model ( ). When you expand the view, the structure shows any subflow 

layers contained within the business process model. The following figure illustrates a process model with 
two layers, when the view is expanded.

To work with the subflow, select the appropriate layer from the list. The subflow activities display in the 
workspace.

Nodes
Nodes are the steps in the business process model. Each BPML activity, service, adapter, and subflow is a 
node. 

For a selected layer, the Nodes tab displays an alphabetical list of the nodes in the layer. When you select a 
node from the list, the GPM displays in the workspace the section of the business process model containing 
the selected node, with the node selected in the workspace display. 

To use the Nodes tab, select a layer from the Layers tab and then click the Node tab to view:

✦ The list of nodes in the layer, displayed in the Navigation pane
✦ The subflow or parent business process model that comprises the layer, displayed in the workspace
If the element editor is open, when you select an icon on the Node tab, configurable parameters for the node 
display in the applicable element editor.

Using the Go To Command
When you are working with a business process model that includes multiple subflows, the Go To 
(Previous/Next) command enables you to return to the previous flow view or display the next flow view. To 
use the command, select View > Go To > Previous or Next. 
Sterling Commerce, an IBM Company 13



Setting Up Your GPM
You can choose from a variety of settings in the GPM to specify operations handling according to your own 
preferences. Setting up GPM preferences before using the GPM is not required, however setting preferences 
in advance enables you to be certain of the order in which steps such as validation will take place in your 
procedures, and where the GPM will store your process models when you save them. You can also modify 
the display according your needs.

Note: If multiple users log in to your computer using the same user ID and password, and use the GPM, 
they share the GPM application and therefore any preference settings. In this case, users can re-set 
their preferences whenever they use the GPM.

To set your preferences:

1. Select Options > Preferences.
2. On the General tab, indicate whether the GPM should automatically validate BPML each time you 

save a process model, or if you want the GPM to display the Validate on Save dialog box each time 
you save, so that you can determine then whether to validate the model you are working on.

3. Select the Source Manager tab. This enables you to opt to use the Expert display mode for checking 
business process models into Gentran Integration Suite when you use the GPM Source Manager. 
Expert Mode displays one dialog box containing all of the parameters related to checking in a business 
process model to Gentran Integration Suite. When you do not select Expert Mode, the parameters 
selections display in a series of dialog boxes, which breaks up the options into smaller groups for 
novice users. Select Use Expert Mode or leave the selection blank.

4. Select the File Location tab. If you like, specify a default directory to which the GPM will save all 
business process documents (.bp files) on your client computer.

5. Select the Locale tab and select a default locale (either English/United States or Japanese/Japan) for 
your installation. If you do not specify a default locale, the Locale Settings dialog box displays each 
time you start the GPM.

6. Select the Service Editor tab and indicate whether you want to be able to override parameters for 
service configurations as they are currently saved in Gentran Integration Suite. When you do not select 
this option, some predefined service configuration parameters are not editable in the GPM.

7. Click OK. 

The GPM also enables you to customize the display to facilitate your work habits. For information, see 
Customizing the GPM Interface.

Customizing the GPM Interface Display
The View menu enables you to customize the GPM display. In the View menu, you can click certain options 
you want to display or hide. When these options have a check mark next to them, they display. Options to 
display or hide are:

✦ Source/Graph – Enables you to switch between the graphical representation and the BPML source 
code of a business process model on the workspace. 

✦ Toolbar – Displays or hides the toolbar containing shortcut command buttons.
Sterling Commerce, an IBM Company 14



Setting Up Your GPM
✦ Status Bar – Displays or hides the status bar across the bottom of the page. 
✦ Output – Opens and closes the Output pane, which displays error, validation, and system messages. 

This pane opens automatically when the GPM encounters an error during validation, even when you 
have not selected the option.

✦ Navigation – Opens and closes the Navigation pane. 
✦ Stencil – Displays the menu that lists stencils. For information, see GPM Stencils on page 17.
✦ Auto Layout – Automatically aligns icons in the workspace.
✦ Zoom – Enables you to change the magnification of a business process model view. Zoom sets the 

magnification to 50, 75, 100, 150, or 200 percent.
✦ Grid – Enables you to select and displays dotted or line grid markers, or no grid markers. The grid 

points enable you to align icons on the workspace.
Sterling Commerce, an IBM Company 15
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Element Editors in the GPM
Element editors enable you to view and modify parameters for different components, or elements, of 
business process models. These elements are the icons representing services, adapters and BPML activities, 
and the edges, or links (represented by lines), that connect them and to which you can assign rules.

BPML activities and a small number of services are preconfigured when you install Gentran Integration 
Suite. However, some BPML activities and most services require you to perform additional configuration 
in the GPM, depending on the task your business process model must accomplish. 

The GPM has five element editors, each of which provides configuration parameters specific to a selected 
element. When you select an icon in the workspace, the appropriate element editor for that edge, service or 
BPML activity displays. 

The following table describes the GPM element editors:

If you need information about the parameters to enter for a service or adapter, review the parameter 
specifications in the reference documentation for the service.

Element Editor Description

Consume Editor Enables you to indicate the message a business process or subflow should expect, and the 
name of the participant sending that message.

Edge Editor Enables you to assign rules to the links that run from a Choice Start icon to the next icons at 
a decision point in a business process model. The Edge editor enables you to select from 
all previously created rules. 

Produce Editor Enables you to indicate the message and name of the receiving participant or activity for 
the business process or subflow. 

Property Editor Enables you to configure BPML activities that require additional information, such as 
Choice and Assign.
You can also use the Property editor to define values that indicate errors associated with 
the activity. If the business process encounters these values while running, Gentran 
Integration Suite generates a report that describes the error.

Service Editor Enables you to configure parameters for each service and adapter. The parameter fields 
correspond to the parameter information described in the reference documentation for the 
selected service. You can use the Service editor to:

Enter and modify values for parameters.

View protected parameter values that cannot be edited.

Use the preset values in the editor as a basis for defining conditions for configuration 
parameters.

Create your own name-value pairs, adding XPath expressions when needed, to define 
the path to name-value pairs that appear in business process data.



GPM Stencils
Stencils are palettes that you can display in the GPM and from which you select icons representing activities 
to include in your business process models. See GPM Interface for an illustration of the stencils pane.

Each stencil contains labeled icons for a specific category of installed services or BPML activities. You can 
choose from a menu to display the stencils containing icons you need as you build business process models. 
From the View menu, select Stencil and select the desired stencil. When you open more than one stencil, 
the stencils display in a tiered pane. With multiple stencils open, you can click the stencil name at the top 
or bottom of the pane to display the stencil you need as topmost in the list.

To close a stencil, right click on the stencil title and select Close Current Stencil or Close All Stencils.

Choosing the Stencils You Need
Stencil names describe the category or sub-category of services and adapters for the icons they contain, with 
the exception of the BPML stencil. The BPML stencil contains icons only for BPML activities and 
instructions that coordinate the flow of activities within a business process model.

To choose a stencil to open, look for the category of service and any sub-category that might apply.

For example, the ebXML stencil contains icons for services that implement business-to-business data 
exchange using the ebXML format, such as the ebXML Digital Signature service and the ebXML Profile 
service. In this example, the category is Internet B2B, and the sub-category is ebXML. Therefore, to choose 
the ebXML stencil, from the View menu, select Stencil > Internet B2B > ebXML.

You can also display all services (but not BPML activities) in one single stencil, by selecting View > Stencil 
> All Services.

Note: If you do not have a license for a service or adapter that you include in a business process model, the 
business process will fail when you attempt to run it in Gentran Integration Suite.

Adding New Services and Service Configurations to the GPM Stencils
Periodically, you may install additional services and adapters to your Gentran Integration Suite application 
or update service configurations created in Gentran Integration Suite interface. In order to update the GPM 
to include them, you must refresh the GPM. Select View > Refresh Services any time you need to update 
the GPM stencils to display the most current services and adapters installed with Gentran Integration Suite. 
You must be working with the GPM online (Gentran Integration Suite must be running) to use this 
command. 
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GPM Stencils
GPM Stencil Descriptions
The following table describes the GPM stencils. The table is arranged alphabetically by stencil category.

Category / Stencil Name Contains Icons for:

All / All Services All installed services (not including activities in the BPML stencil). Service icons 
display in alphabetical order. All other stencils are subsets of this stencil.

Applications / ERP Adapters installed to connect to external, Enterprise Resource Planning 
applications, such as:

PeopleSoft CRM® (Vantive) adapter

SAP® R/3® adapter

Applications / Sterling 
Commerce

Adapters installed to connect to external, Sterling Commerce applications, such as:

Connect:Direct® Requester adapter and related services

Connect:Enterprise® UNIX Server adapter and related services

Gentran:Server® Windows adapter 

Sterling Information Broker

B2B Protocols / FTP Client Services that complete B2B communication using File Transfer Protocol, such as:

FTP Client Password service

FTP Client Server service

B2B Protocols / HTTP Client Services that complete B2B communication using Hypertext Transfer Protocol, 
such as:

HTTP Client Post service

HTTP Client Method service

B2B Protocols / SFTP Client Services that complete B2B communication using Secure Shell File Transfer 
Protocol (SSH/SFTP), such as:

SFTP Client PUT service

SFTP Client GET service

BPML / BPML Commonly used BPML activities and instructions, such as:

Start

End

Assign

Join
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GPM Stencils
Communications / 
Communications

Services and adapters that enable Gentran Integration Suite to send and receive 
messages using the standard Internet communications protocols, such as. 

B2B HTTP Client adapter and related services

FTP Client adapter and related services

HTTP Client adapter and related services

MIME service

Custom / Custom Custom-created services, after your software developer has developed, installed, 
and configured them. 

EDI / ACH Services related to EDI transaction processing requirements using Automated 
Clearing House standards, such as:

ACH Enveloping service

ACH Deenvelope service

EDI / CII Services related to EDI transaction processing requirements using Japanese 
Center for Informatization of Industry standards, such as: 

CII Deenvelope service

Envelope service

EDI / EDIFACT Services related to EDI transaction processing requirements using EDIFACT 
standards, such as:

EDI, UNB, UNH, Deevenlope and Envelope services

Generate and Reconcile Control services

EDI / TRADACOMS Services related to EDI transaction processing requirements using TRADACOMS 
standards, such as:

EDI Envelope service

Generic Envelope service

EDI / X12 Services related to EDI transaction processing requirements using Accredited 
Standards Committee X12 standards, such as:

997 Generator and Reconcile services

EDI, GS, ISA, ST Deenvelope and Envelope services

TA1 Generator and Reconcile services

Internet B2B / E5 Services that implement business-to-business data exchange using the E5 (clients 
and servers) format, such as:

E5 Client Configuration service

E5 Obtain service

Internet B2B / ebXML Services that implement business-to-business data exchange using the ebXML 
format, such as:

ebXML Digital Signature service

ebXML Profile service

Category / Stencil Name Contains Icons for:
Sterling Commerce, an IBM Company 19



GPM Stencils
Internet B2B / EDIINT Services that implement business-to-business data exchange using the EDIINT 
protocol, such as:

EDIINT Acknowledge Check service

EDIINT Message service

EDIINT Pipeline service

Internet B2B / Mailbox Services that implement business-to-business data exchange using mailbox 
format, such as:

Mailbox Evaluation Routing Rule service

Mailbox Extract Begin service

Internet B2B / Rosettanet Services that implement business-to-business data exchange using RosettaNet™ 
RNIF standards, such as:

RNIF 20 MessageBuilder service

RN Profile service

RosettaNet Sender service

Internet B2B / SOAP Services that implement business-to-business data exchange using Simple Object 
Access Protocol, such as:

SOAP Inbound service

SOAP Outbound service

Internet B2B / Transora Services that implement business-to-business data exchange using Transora™ 
exchange methods, such as:

TDC Document XPath Replace service

Transora HTTP AS2 DocHandler service

Transora HTTP AS2 MDNHandler service

Internet B2B / UCCnet Services that implement business-to-business data exchange using UCCnet™ 
exchange methods, such as:

B2B Request Response service

B2B Send service

Internet B2B / UCCnet22 Services that implement business-to-business data exchange using UCCnet™ 
exchange methods for UCCnet version 2.2, such as:

UCCNet 2.2 Configuration service

UCCNet 2.2 DocHandler service

UCCNet 2.2 Query Deenveloper service

Messaging / Instant Messaging Services that enable Gentran Integration Suite to send and receive instant 
messages, such as:

IM Send Message service

IM Receive Message service

Category / Stencil Name Contains Icons for:
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GPM Stencils
Messaging / Queuing Adapters that enable Gentran Integration Suite to send messages to and from 
remote messaging queues, such as:

MSMQ adapter

Oracle AQ JMS Queue adapter

Oracle AQ JMS Topic adapter

TIBCO adapter

Vitria adapter

WebMethods Publisher adapter

WebMethods Subscriber adapter

WebSphereMQ adapter

WebSphereMQ Suite

Messaging / 
WebSphereMQSuite

Services that enable you to script a complete MQ session using a business 
process, such as:

WebSphere MQ Suite Open Session service

WebSphere MQ Suite Get Message service

WebSphere MQ Suite Commit service

Process Controls / Process 
Controls

Services that:

Enable custom control at an intricate level (for example, at each step) when 
running business processes

Can improve business process performance

For example, the Execution Control service enables you to change the priority 
queue previously defined with regard to system allocation of resources, when 
running business processes. 
Examples of Process Control services are:

Cache Refresh service

Execution Control service

Wait services

Retiring / Retiring Services and adapters that will soon no longer be supported in Gentran Integration 
Suite. 
In order to improve performance, enhance features, or ensure compatibility with 
recent product releases, Sterling Commerce periodically retires services and 
adapters and makes other services and adapters available to fill the need.
If you are currently using services or adapters listed in the Retiring stencil, you must 
replace these services and adapters in your business process models with other 
services and adapters.
Services and adapters listed in the Retiring stencil are supported for the current 
release of Gentran Integration Suite. However, to ensure that you employ the most 
current capability, avoid using them.

Category / Stencil Name Contains Icons for:
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GPM Stencils
System / System Services and adapters that enable business processes to interact with hardware 
and software resources such as application components, file systems, operating 
systems, and databases, both internal and external to Gentran Integration Suite, 
such as:

Command Line Adapter 2

File System adapter

Java™ Database Connectivity (JDBC™) adapter

Lightweight Java Database Connectivity (JDBC) adapter

Translation / Translation Services that translate or transform data using maps created with Gentran 
Integration Suite Map Editor, such as:

Translation service

Typing service

XML Encoder service

XSLT service

Transport / Transport Adapters that offer additional options that enable Gentran Integration Suite to 
communicate with local or remote servers and exchange data, such as:

Lightweight Directory Access Protocol (LDAP) adapter 

Remote Method Invocation (RMI) adapter 

Simple Network Management Protocol (SNMP) Trap adapter

Web Extensions / Web 
Extensions 

Services that support Web services technologies. Web services directly invoke 
application function calls over the Internet. 
Examples of Web Extensions services are:

Human Interaction Document Loader service

Human Interaction Event and Query services

Category / Stencil Name Contains Icons for:
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GPM XPath Expression Builder
Note: This topic assumes familiarity with XML Path language (XPath). If you need more information 

about XPath, see the World Wide Web Consortium at www.w3c.org and the BPML documentation. 

The XPath Expression Builder makes creating XPath expressions to use in your business process models 
more convenient. Clickable function and token menus enable you to select the functions and tokens to build 
an expression.

The following figure shows the XPath Expression Builder. For more information, see Defining and 
Assigning Rules and Conditions in Managing Business Processes.

The Expression Builder provides descriptive information to help you make your choices: 

✦ When you mouse over a function or token, pop-up help describes the selection. 
✦ Function selections are comprised of two parts. The first part, in italics, is descriptive of the function. 

The second part, in bold text, is the actual code for the XPath function you are selecting. For example, 
the number last ( ) function selection indicates that the last function returns a number.

Select function type 
from these tabs

Select related 
functions from this 

pane to populate the 
Expression field

Select appropriate 
token set from 

these tabs

Select tokens from 
this pane to populate 
the Expression field

Build your XPath 
expression in this field
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GPM XPath Expression Builder
The following figure shows a pop-up description and indicates the parts of a function selection:

The XPath Expression Builder supports several function types and token sets. To build XPath expressions, 
you must be familiar with the expression type you need and understand the functions and tokens used in the 
expression types. For descriptions of XPath function types and tokens, view the XPath Tutorial at 
www.w3c.org. 

Note: Remember that you cannot use functions and tokens in Gentran Integration Suite that are not 
supported in the XPath Expression Builder, with the following exceptions:

DocToDOM

DOMToDoc

For information about these exceptions, see the BPML documentation.

The following table describes the function types supported by the XPath Expression Builder:

Function type Description

Node-Set Used to obtain information from an XML document, such as counting purchase orders in a 
node set. Also:

Defines a set of sequential context-nodes

Specifies what information to process or return for the set of context-nodes

String Perform basic string operations, such as:

Finding the length of a string

Comparing a string

Changing letters from uppercase to lowercase

Modifying the text content of XML elements or attributes

Converting an argument of any type
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GPM XPath Expression Builder
The following table describes the three token sets supported by the XPath Expression Builder:

Boolean Specifies a Boolean argument (using either the true or false state) that can include 
predicates and return the result.

Number Manipulate numbers, such as:

Specifying a numeric function for adding groups of numbers

Finding the nearest integer to a number

Performing basic arithmetic operations

Token Set Use to:

Axis Define the direction of your search by using keywords, including:

Attributes

Child elements (default)

Descendants of the child elements

Parent elements

Ancestor elements

Node Test Indicate the name of the node for which to search. 
Note: Insert the name of the node test after the resolution operator (::) that follows the 

axis.

Predicate Insert a relational operator to test each node in the set of context-nodes of a location path. 
Note: Predicates can use Boolean operators.

Function type Description
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GPM Annotation Tool
The Annotation tool enables you to add customized comments such as descriptive names or explanations, 
for your reference, to the icons in the graphic display of your business process models.

The GPM automatically includes annotations with all icons. When you pause with your mouse arrow over 
an icon or the name of an icon in the workspace, the annotation for the icon pops up. Using the Annotation 
tool, you can modify the annotations so that they are more useful for you.

The following figure illustrates an annotation in a simple business process model:

The GPM does not store annotations in the BPML content of a business process model, therefore, they 
display only in the GPM representation of a business process model, not in the source BPML. For the same 
reason, if you edit and save a process model directly in the source BPML, the annotations will no longer be 
part of the business process model.

Annotation (system default)
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Uninstalling the GPM
If you have more than one copy of the GPM installed—for example, if you have installed a copy to use for 
testing and a copy to use for production—you can remove a copy of the GPM using the Java Application 
Cache Viewer. 

Removing One or More Copies of the GPM
This procedure is completed using the Java Application Cache Viewer. Complete this procedure to remove 
copies of the GPM. 

To remove a copy of the GPM: 

1. From the Windows Start menu, select Run. 
2. Type javaws -viewer and click OK. The Java Cache Viewer appears.
3. From the Application column, select the Modeler (or the copy of the GPM) that you want to remove.

4. Click the Remove selected items button (the red X).
The selected copy of the GPM is removed from the client computer.
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