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Introduction

To help you create business process models, Sterling Integrator includes the Graphical Process Modeler (GPM).
The GPM is a Web-deployed graphical interface tool you use in conjunction with Sterling Integrator to create
and modify business processes. The GPM converts your graphical business process models into source code,
saving you the effort of writing code.

In the GPM interface you construct your business process models, coordinating the flow of activities in a
graphical depiction of the ordered steps. The GPM provides icons representing the services, adapters and
Business Process Modeling Language (BPML) instructions that make up your process models. In addition,
you configure related parameters through the GPM and create rules and conditions within your process models.

You can validate the process models and check them in to Sterling Integrator from within the GPM. To make
it easier to work with your business process models in the GPM without having to access the Sterling Integrator
interface, the GPM includes its own Source Manager tool, enabling you to lock, check in and check out business
process models, and to monitor versions of business process models using a date and time stamp, all from
within the GPM.

The GPM recognizes BPML code written in a text editor. Therefore, in the GPM, you can open a .bpml file
created in a text editor and view its graphical representation. The GPM enables you to toggle the display
between BPML and graphic view.

Example Business Process Model in the GPM

The following figure shows an example of a simple business process model as it appears in the GPM:

The callouts in the figure indicate the types of components depicted by the icons.

3© Copyright IBM Corp. 2011



High-level Installation Process

Installing the GPM is a multi-step process which should be completed in the order described. To get started
using the GPM, you must:

1. Install the GPM. See Graphical Process Modeler Installion.
2. Start the GPM. See Start the GPM.
3. (Optional) Set your preferences. You can specify settings for things such as language preference, when to

validate BPML, and the location on your computer where you want the GPM to save your business process
model files. See Set User Preferences.

After these steps are completed, you can begin creating business process models. For the step-by-step procedure,
see Create Business Process Models.

For an introduction to the GPM interface, see User Interface.
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Everyday Activities and Flow

Your use of the Graphical Process Modeler (GPM) follows your business process modeling goals. Before you
create a business process model, carefully plan it, so that you know which components you must include, as
well as how you must configure the services and activities within it. For instructions, see Planning Your
Business Process Models.

As you familiarize yourself with the GPM components, you will develop your own favorite methods of using
it and navigating in the layers of your process models, as well as your own preferred order of completing the
steps involved in creating and modifying business process models.

The following table describes the activities generally involved in creating business process models in the GPM.
You can complete the activities in different order, but the table is arranged in a logical order as a starting point
for your reference.

DescriptionActivity

To modify an existing business process model that is
checked in to Sterling Integrator, you must check the process

Check out a business process model.

model out before you can work with it in the GPM. For
instructions, see Modifying and Managing Business Process
Models.

Stencils are palettes of the services and activities you include
in your process models. Because hundreds of services are

Determine which stencils you need to display.

represented, each stencil lists a given category of services.
You will want to display only the ones you are likely to need
for the process model you are working on. For information
about available stencils and how to display them, see GPM
Stencils.

This activity involves:Arrange icons in workspace.

• Dragging and dropping the icons representing the services
and BPML activities that comprise your process model into
the workspace

• Arranging the icons according to the desired flow
• Linking the icons

Some BPML activities, some links between your services
and activities, and most services require some configuration

Configure parameters for services, activities and links.

in the GPM, depending on the task your business process
model must accomplish. Use GPM element editors to view
and modify parameters for the different components, or
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DescriptionActivity

elements, of business process models. For information, see
Element Editors in the GPM.

Rules and conditions can be simple instructions or more
complex directions defined using XPath expressions. The

Add decision points, rules and conditions.

GPM enables you to assign rules using an element editor,
as well as to define them using the Rule Manager and XPath
Expression Builder tools. For information, see:

• Defining and Assigning Rules and Conditions
• GPM XPath Expression Builder

Make your process model descriptive for future reference. • Name the components of your process models in
meaningful ways.

• Use your company’s naming conventions to name your
process model when you save it.

• Add annotations to the graphical display of your process
model. For information, see:

- Modifying Annotations- GPM Annotation Tool

After you create or modify a process model, you can simply
save it or save and validate it, and check it in to Sterling

Save, validate, and check in the model.

Integrator. For information, see Checking in a Business
Process Model.
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System Requirements

Sterling Integrator uses Java Webstart to start the Graphical Process Modeler (GPM).

In previous versions of Sterling Integrator, WebStart was downloaded and installed on the client from the
Sterling Integrator interface. Now, however, WebStart is bundled and installed with Java Runtime Environment
(JRE) 5.0, which is now required.
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Install the Graphical Process Modeler
Although the Graphical Process Modeler (GPM) is an included feature of Sterling Integrator, it does not
automatically install with Sterling Integrator, because it operates as a separate, Web-deployed application. The
GPM must be installed on each computer from which a user will access Sterling Integrator and work with the
GPM. This enables Sterling Integrator and the GPM to interact. For example, you can check in and out business
process models from the GPM, and update a service configuration in the GPM after making changes to it in
Sterling Integrator.

To install the GPM, complete these steps on the client computer on which you want to use the GPM:

1. Uninstall all old versions/instances of Java Webstart from the client computer.

Leaving these on the system will cause an error when attempting to load the GPM from the Sterling Integrator
user interface.

2. Download and install Java Runtime Environment (JRE) 5.0 from the Sun ™ web site:
http://java.sun.com/javase/downloads/index_jdk5.jsp

3. Install the JRE on the client system.

4. Log in to Sterling Integrator and download the GPM:

a) Navigate to the Admin Console Home page.
b) Next to Run Graphical Process Modeler, click Go!

The Java Web Start window displays and begins loading GPM components.

c) Answer any prompts appropriately that appear.
d) When prompted, use your application User ID and Password to log in to the GPM . The GPM opens.

5. Set your preferences. See Set Up Your GPM.

You can now create and modify business process models.

Create a Desktop Graphical Process Modeler Shortcut
After you download and install the Graphical Process Modeler (GPM) on a client computer, you can add a
Modeler menu item to the Programs menu and create a shortcut icon on the Desktop to start the GPM locally.

To create a desktop shortcut for the GPM:

1. On a client PC on which you want to use the GPM, from the Windows Start menu, select Run.
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2. Type javaws -viewer and click OK.
The Java Cache Viewer appears.

3. From the Application column, select the modeler for which you want to create a shortcut.

4. From the Application menu, click the Install shortcuts to the selected application button.
The system installs a shortcut to your Programs menu and an icon on your Desktop.
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Graphical Process Modeler Startup

The first time you start the Graphical Process Modeler (GPM) on a given computer, you must do so from
within the Sterling Integrator user interface. This initiates the GPM installation on that client PC.

Note:  Each time you start the GPM application, Java Web Start checks for a connection to the Web server to
determine whether a new version of the GPM is available. When a new version is available, Java Web Start
automatically updates the files on the client computer and opens the GPM.

Any time after the initial GPM startup, you can start it in either of the following ways:

• Inside the Sterling Integrator User Interface

The GPM is started from a selection made from the Sterling Integrator user interface. Both the GPM and your
network connection to Sterling Integrator are open. You must log into the GPM using your Sterling Integrator
User ID and Password. You have complete functionality.

• Outside of Sterling Integrator

The GPM is started from a client PC locally. This is known as “working offline.” You do not log in to Sterling
Integrator, and the GPM cannot interact with Sterling Integrator. You still must log into the GPM using your
Sterling Integrator User ID and Password. You have restricted functionality.

Note: The offline GPM mode is only possible if the Sterling Integrator instance is inaccessible over the
network. If network connectivity exists, then the online mode is the only option.

The ability to work in the GPM without starting Sterling Integrator offers you the convenience of creating and
modifying business process models without requiring a network connection. Because your business process
models save directly to your hard drive, you can work on them at your convenience and at remote locations,
and then check them in to Sterling Integrator later, after you log in.

Because the GPM and Sterling Integrator can interact (such as when you update the service stencils in the
GPM), working in the GPM from outside Sterling Integrator involves the following restrictions:

• You cannot refresh (update from Sterling Integrator) the services listed in the GPM stencils
• You cannot check business process models into or out of Sterling Integrator

Plan ahead before you work offline in the GPM. For example, if you will need any new service configurations,
you must create them in Sterling Integrator and refresh the services in the GPM (select View > Refresh
Services) before you shut down Sterling Integrator and work offline in the GPM.
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Similarly, if you plan to modify an existing process model, you must check it out while Sterling Integrator is
running, before you shut it down and work offline in the GPM.

Start the Graphical Process Modeler Inside Sterling Integrator

This method must be used the first time you start the Graphical Process Modeler (GPM). To start the GPM
from inside the Sterling Integrator user interface:

1. Complete one of the following tasks:

• From the Admin Console Home page, in the Tools section, next to Run Graphical Process Modeler,
click Go!

• From the Administration menu, select Business Process > Manager, and in the Graphical Modeling
pane, next to Run Graphical Process Modeler, click Go!

2. The Log In dialog box displays. Type your Sterling Integrator User ID and Password, click OK.

You can now create and modify business process models. Because you are logged in to Sterling Integrator,
you can check business process models in and out.

The first time you start the GPM, set your preferences. See Set Up Your GPM.

Start the Graphical Process Modeler Outside of Sterling Integrator

This method can be used anytime after the initial installation of the Graphical Process Modeler (GPM), but
only if you cannot access Sterling Integrator over a network. To start the GPM offline, you must have installed
a shortcut to your Programs menu and desktop.

Note:  Certain restrictions apply when using the GPM offline. For information, see Start the GPM.

To start the GPM outside of Sterling Integrator:

1. Complete one of the following tasks:

• From the Start menu on a client computer, select Programs > Modeler (GPM application).
• From the Desktop on a client computer, double-click the Modeler shortcut.

2. The Log In dialog box displays. Type your Sterling Integrator User ID and Password, click OK.

You can now create and modify business process models locally on the client computer. Because you are not
logged in to Sterling Integrator, you cannot check business process models in and out.

The first time you start the GPM, set your preferences. See Set Up Your GPM.
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Graphical Process Modeler User Interface

The Graphical Process Modeler (GPM) is designed to simplify the tasks of creating and modifying business
process models through drag-and-drop technology and tools for navigation and configuration.

The following figure shows the GPM user interface and its components when a business process model
document is open (select File > New to activate the workspace). To create business process models, drag and
drop icons from the stencils into the workspace.

Graphical Process Modeler12



The following table provides information about the components identified in the figure:

DescriptionComponent

A stencil is a graphical palette of icons for dragging and
dropping into your business process models in the

Stencil

workspace.The icons represent components you include in
your process models—the services, adapters, and Business
Process Modeling Language (BPML) instructions that
perform tasks.The GPM includes a variety of stencils, each
containing icons of a specific category.You can select the
stencils to display in the GPM interface at any time (from
the View menu, select Stencil > <stencil name>. For stencil
descriptions, see GPM Stencils.

Displays:Title Bar

• IP address and port of your associated installation of the
application

• The word “(Offline)” or “(Online)” to indicate whether you
are working online (this means with an Internet connection
open) or offline (with no Internet connection open)
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DescriptionComponent

• File name of the business process model document that
is currently open in the GPM

Enables you to select options related to creating, modifying,
and checking in and out your business process models.

Menu Bar

• Use the Edit menu to cut, copy, paste, delete, clear all, and
select all components displayed on the workspace.
Procedural documentation for working with business
process models describes the other functions you can
access from this menu.

• The View menu enables you to customize the display. For
information, see Customizing the GPM Interface Display.

Displays buttons that provide quick access to commonly
used commands. Inactive buttons become active when you
select a service icon in the workspace.

Tool Bar

Area in the GPM interface to which you can drag and drop
icons to create a business process model. Within the

Workspace

workspace, click and drag to organize your process models,
and select components to configure them.You can also view
the BPML source code of a business process model in the
workspace. To view BPML source code, from the View
menu, select Source.

Displays a description of a menu option, toolbar button, or
service icon (in a stencil), when you point to it.

Status Bar

Displays a tree diagram of the business process model,
depicting any subflows (called layers in this pane) and the

Navigation Pane

steps contained within each subflow (these are the nodes).
The Navigation pane enables you to display a subflow in the
workspace by selecting it from the Layers tab, and to open
element editors for selected nodes by selecting a node from
the Nodes tab.The Navigation pane is especially helpful
when you are working with complex processes that contain
many subflows.For more information, see Navigating Layers
and Nodes in the GPM Interface.

Displays either element editors for a selected component of
the business process model, or the output for system
messages.

Element Editor and Output Pane

• Element editors enable you to view and configure
parameters for components of your business process
models. Double click a component in the workspace to
display the element editor to configure it. For descriptions
of the different element editors, see Element Editors in the
GPM.

• The Output tab displays error, validation, and system
messages. This pane opens automatically when you
validate a model or view source code.
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Navigating Layers and Nodes in the User Interface

Working with graphical business process models often requires you to navigate sometimes complex or extensive
arrangements of process components. For your convenience, the Graphical Process Modeler (GPM) contains
a Navigation pane for quick navigating among components.

The Navigation pane makes it easy to select from among the different subflows and components of your
business process model, using the Layers and Nodes tabs.

Layers

Layers are subflows contained within the business process model. The Layers tab depicts a graphical
representation of the structure of the parent business process model displayed in the workspace, including
subflows. To expand the structure to show the layers, double click the icon in the Navigation pane that represents
the business process model.

When you expand the view, the structure shows any subflow layers contained within the business process
model. The following figure illustrates a process model with two layers, when the view is expanded.

To work with the subflow, select the appropriate layer from the list. The subflow activities display in the
workspace.

Nodes

Nodes are the steps in the business process model. Each BPML activity, service, adapter, and subflow is a
node.

For a selected layer, the Nodes tab displays an alphabetical list of the nodes in the layer. When you select a
node from the list, the GPM displays in the workspace the section of the business process model containing
the selected node, with the node selected in the workspace display.

To use the Nodes tab, select a layer from the Layers tab and then click the Node tab to view:

• The list of nodes in the layer, displayed in the Navigation pane
• The subflow or parent business process model that comprises the layer, displayed in the workspace

If the element editor is open, when you select an icon on the Node tab, configurable parameters for the node
display in the applicable element editor.

Go To Command

When you are working with a business process model that includes multiple subflows, the Go To (Previous/Next)
command enables you to return to the previous flow view or display the next flow view.

To use the command, select View > Go To > Previous or Next.
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Customize the User Interface Display

The View menu enables you to customize the Graphical Process Modeler (GPM) display. In the View menu,
you can select certain options you want to display or hide. When these options have a check mark next to them,
they display.

Note: The option selections differ depending on if you have a file open or not.

Options to display or hide are:

• Source/Graph – Enables you to switch between the graphical representation and the BPML source code of
a business process model on the workspace.

• Toolbar – Displays or hides the toolbar containing shortcut command buttons.
• Status Bar – Displays or hides the status bar across the bottom of the page.
• Output – Opens and closes the Output pane, which displays error, validation, and system messages. This

pane opens automatically when the GPM encounters an error during validation, even when you have not
selected the option.

• Navigation – Opens and closes the Navigation pane.
• Stencil – Displays the menu that lists stencils. For information, see Stencils.
• Auto Layout – Automatically aligns icons in the workspace.
• Zoom – Enables you to change the magnification of a business process model view. Zoom sets the

magnification to 50, 75, 100, 150, or 200 percent.
• Grid – Enables you to select and displays dotted or line grid markers, or no grid markers. The grid points

enable you to align icons on the workspace.
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Set User Preferences
You can choose from a variety of settings in the Graphical Process Modeler (GPM) to specify operations
handling according to your own preferences. Setting up GPM preferences before using the GPM is not required,
however setting preferences in advance enables you to be certain of the order in which steps such as validation
will take place in your procedures, and where the GPM will store your process models when you save them.
You can also modify the display according your needs.

If multiple users log in to your computer using the same user ID and password, and use the GPM, they share
the GPM application and therefore any preference settings. In this case, users can re-set their preferences
whenever they use the GPM.To set your preferences:

1. Select Options > Preferences.

2. On the General tab, select the appropriate check box to indicate whether the GPM should automatically
validate the Business Process Modeling Language (BPML) each time you save a process model, or if you
want the GPM to display the Validate on Save dialog box each time you save, so that you can determine
then whether to validate the model you are working on.

3. Click the Source Manager tab.

4. Determine if you want to use the Expert Mode for checking business process models into Sterling Integrator
when you use the GPM Source Manager. Select the Use Expert Mode check box or leave the selection
blank.

Expert Mode displays one dialog box containing all of the parameters related to checking in a business
process model to Sterling Integrator. When you do not select Expert Mode, the parameters selections display
in a series of dialog boxes, which breaks up the options into smaller groups for novice users.

5. Click the File Location tab.

6. Enter or select a default directory to which the GPM will save all business process documents (.bp files)
on your client computer.

7. Click the Locale tab.

8. Select a default locale for your installation.

9. Click the Service Editor tab.

10. Determine whether you want to be able to override parameters for service configurations as they are currently
saved in Sterling Integrator.

If you do not select this option, some predefined service configuration parameters are not editable in the
GPM.

11. Click OK.
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Your new preference settings are applied to the current session and saved. They are automatically applied
each time the GPM is started.

The GPM also enables you to customize the display to facilitate your work habits. For information, see
Customize the User Interface Display.

Graphical Process Modeler18



Element Editors

Element editors enable you to view and modify parameters for different components, or elements, of business
process models. These elements are the icons representing services, adapters and Business Process Modeling
Language (BPML) activities, and the edges, or links (represented by lines), that connect them and to which
you can assign rules.

BPML activities and a small number of services are preconfigured when you install Sterling Integrator. However,
some BPML activities and most services require you to perform additional configuration in the Graphical
Process Modeler (GPM), depending on the task your business process model must accomplish.

The GPM has five element editors, each of which provides configuration parameters specific to a selected
element. When you select an icon in the workspace, the appropriate element editor for that edge, service or
BPML activity displays.

The following table describes the GPM element editors:

DescriptionElement Editor

Enables you to indicate the message a business process or
subflow should expect, and the name of the participant
sending that message.

Consume Editor

Enables you to assign rules to the links that run from a
Choice Start icon to the next icons at a decision point in a

Edge Editor

business process model. The Edge editor enables you to
select from all previously created rules.

View protected parameter values that cannot be edited. Use
the preset values in the editor as a basis for defining

Produce Editor

conditions for configuration parameters. Create your own
name-value pairs, adding XPath expressions when needed,
to define the path to name-value pairs that appear in
business process data.name-value pairs, creating in Service
editor;business process:creating name-value pairsEnables
you to configure parameters for each service and adapter.
The parameter fields correspond to the parameter
information described in the reference documentation for
the selected service.You can use the Service editor to:

Enables you to configure BPML activities that require
additional information, such as Choice and Assign.You can

Property Editor

also use the Property editor to define values that indicate
errors associated with the activity. If the business process
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DescriptionElement Editor

encounters these values while running, Sterling Integrator
generates a report that describes the error.

Enables you to configure parameters for each service and
adapter. The parameter fields correspond to the parameter

If you need information about the parameters to enter for a
service or adapter, review the parameter specifications in
the reference documentation for the service. information described in the reference documentation for

the selected service.You can use the Service editor to:

• Enter and modify values for parameters.
• View protected parameter values that cannot be edited.
• Use the preset values in the editor as a basis for defining

conditions for configuration parameters.
• Create your own name-value pairs, adding XPath

expressions when needed, to define the path to name-value
pairs that appear in business process data.

If you need information about the parameters to enter for a service or adapter, review the parameter specifications
in the reference documentation for the service.
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Stencils

Stencils are palettes that you can display in the Graphical Process Modeler (GPM) and from which you select
icons representing activities to include in your business process models. See GPM Interface for an illustration
of the stencils pane.

Each stencil contains labeled icons for a specific category of installed services or Business Process Modeling
Language (BPML) activities.

You can choose from a menu to display the stencils containing icons you need as you build business process
models. From the View menu, select Stencil and select the desired stencil. When you open more than one
stencil, the stencils display in a tiered pane. With multiple stencils open, you can click the stencil name at the
top or bottom of the pane to display the stencil you need as topmost in the list.

To close a stencil, right click on the stencil title and select Close Current Stencil or Close All Stencils.

Add New Services and Service Configurations to the Stencils
Periodically, you may install additional services and adapters to your application or update service configurations
created in the Sterling Integrator user interface. Perform this procedure any time you need to update the
Graphical Process Modeler (GPM) stencils to display the most current services and adapters installed with
Sterling Integrator.

You must be working with the GPM online (Sterling Integrator must be running) to use this command.

To refresh the listing of Services and Service configurations in the GPM:

1. Start the GPM.

2. From the View menu, select Refresh Services.

Perform this procedure any time you need to update the GPM stencils to display the most current services and
adapters installed with Sterling Integrator.

Select a Stencil
Stencil names describe the category or sub-category of services and adapters for the icons they contain, with
the exception of the Business Process Modeling Language (BPML) stencil. The BPML stencil contains icons
only for BPML activities and instructions that coordinate the flow of activities within a business process model.
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To select a stencil for use in the Graphical Process Modeler (GPM):

1. Start the GPM.

2. From the View menu, select Stencil > Stencil_Name.

Look for the category of service and any sub-category that you need. Depending on the stencil category
selected, there may be another level of stencils to select from.

3. If you want to display all services (but not BPML activities) in one single stencil, from the View menu
select View > Stencil > All Services.

For example, the ebXML stencil contains icons for services that implement
business-to-business data exchange using the ebXML format, such as the ebXML Digital
Signature service and the ebXML Profile service. In this example, the category is Internet
B2B, and the sub-category is ebXML. From the View menu, you would select Stencil >
Internet B2B > ebXML.

Note:  If you do not have a license for a service or adapter that you include in a business
process model, the business process will fail when you attempt to run it in Sterling Integrator.

For more information, see GPM Stencil Descriptions.

Stencil Descriptions

The following table describes the Graphical Process Modeler (GPM) stencils. The table is arranged alphabetically
by stencil category.

Contains Icons for:Category / Stencil Name

All installed services (not including activities in the Business
Process Modeling Language (BPML) stencil). Service icons

All / All Services

display in alphabetical order. All other stencils are subsets
of this stencil.

Adapters installed to connect to external, Enterprise
Resource Planning applications, such as:

Applications / ERP

• PeopleSoft CRM® (Vantive) adapter

• SAP® R/3® adapter

Adapters installed to connect to external, Sterling Commerce
applications, such as:

Applications / Sterling Commerce

• Connect:Direct® Requester adapter and related services

• Connect:Enterprise® UNIX Server adapter and related
services

• Gentran:Server® Windows adapter

• Sterling Information Broker

Services that complete B2B communication using File
Transfer Protocol, such as:

B2B Protocols / FTP Client

• FTP Client Password service
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Contains Icons for:Category / Stencil Name

• FTP Client Server service

Services that complete B2B communication using Hypertext
Transfer Protocol, such as:

B2B Protocols / HTTP Client

• HTTP Client Post service

• HTTP Client Method service

Services that complete B2B communication using Secure
Shell File Transfer Protocol (SSH/SFTP), such as:

B2B Protocols / SFTP Client

• SFTP Client PUT service

• SFTP Client GET service

Commonly used BPML activities and instructions, such as:BPML / BPML

• Start

• End

• Assign

• Join

Services and adapters that enable Sterling Integrator to send
and receive messages using the standard Internet
communications protocols, such as:

Communications / Communications

• B2B HTTP Client adapter and related services

• FTP Client adapter and related services

• HTTP Client adapter and related services

• MIME service

Custom-created services, after your software developer has
developed, installed, and configured them.

Custom / Custom

Services related to EDI transaction processing requirements
using Automated Clearing House standards, such as:

EDI / ACH

• ACH Enveloping service

• ACH Deenvelope service

Services related to EDI transaction processing requirements
using Japanese Center for Informatization of Industry
standards, such as:

EDI / CII

• CII Deenvelope service

• Envelope service

Services related to EDI transaction processing requirements
using EDIFACT standards, such as:

EDI / EDIFACT

• EDI, UNB, UNH, Deevenlope and Envelope services

• Generate and Reconcile Control services

Services related to EDI transaction processing requirements
using TRADACOMS standards, such as:

EDI / TRADACOMS

• EDI Envelope service
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Contains Icons for:Category / Stencil Name

• Generic Envelope service

Services related to EDI transaction processing requirements
using Accredited Standards Committee X12 standards, such
as:

EDI / X12

• 997 Generator and Reconcile services

• EDI, GS, ISA, ST Deenvelope and Envelope services

• TA1 Generator and Reconcile services

Services that implement business-to-business data exchange
using the E5 (clients and servers) format, such as:

Internet B2B / E5

• E5 Client Configuration service

• E5 Obtain service

Services that implement business-to-business data exchange
using the ebXML format, such as:

Internet B2B / ebXML

• ebXML Digital Signature service

• ebXML Profile service

Services that implement business-to-business data exchange
using the EDIINT protocol, such as:

Internet B2B / EDIINT

• EDIINT Acknowledge Check service

• EDIINT Message service

• EDIINT Pipeline service

Services that implement business-to-business data exchange
using mailbox format, such as:

Internet B2B / Mailbox

• Mailbox Evaluation Routing Rule service

• Mailbox Extract Begin service

Services that implement business-to-business data exchange
using RosettaNet™ RNIF standards, such as:

Internet B2B / Rosettanet

• RNIF 20 MessageBuilder service

• RN Profile service

• RosettaNet Sender service

Services that implement business-to-business data exchange
using Simple Object Access Protocol, such as:

Internet B2B / SOAP

• SOAP Inbound service

• SOAP Outbound service

Services that implement business-to-business data exchange
using Transora™ exchange methods, such as:

Internet B2B / Transora

• TDC Document XPath Replace service

• Transora HTTP AS2 DocHandler service

• Transora HTTP AS2 MDNHandler service
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Contains Icons for:Category / Stencil Name

Services that enable Sterling Integrator to send and receive
instant messages, such as:

Messaging / Instant Messaging

• IM Send Message service

• IM Receive Message service

Adapters that enable Sterling Integrator to send messages
to and from remote messaging queues, such as:

Messaging / Queuing

• MSMQ adapter

• Oracle AQ JMS Queue adapter

• Oracle AQ JMS Topic adapter

• TIBCO adapter

• Vitria adapter

• WebMethods Publisher adapter

• WebMethods Subscriber adapter

• WebSphereMQ adapter

• WebSphereMQ Suite

Services that enable you to script a complete MQ session
using a business process, such as:

Messaging / WebSphereMQSuite

• WebSphere MQ Suite Open Session service

• WebSphere MQ Suite Get Message service

• WebSphere MQ Suite Commit service

Services that:Process Controls / Process Controls

• Enable custom control at an intricate level (for example, at
each step) when running business processes

• Can improve business process performance

For example, the Execution Control service enables you to
change the priority queue previously defined with regard to
system allocation of resources, when running business
processes. Examples of Process Control services are:

• Cache Refresh service

• Execution Control service

• Wait services

Services and adapters that will soon no longer be supported
in Sterling Integrator. In order to improve performance,

Retiring / Retiring

enhance features, or ensure compatibility with recent product
releases, Sterling Commerce periodically retires services
and adapters and makes other services and adapters
available to fill the need.If you are currently using services
or adapters listed in the Retiring stencil, you must replace
these services and adapters in your business process
models with other services and adapters.Services and
adapters listed in the Retiring stencil are supported for the
current release of Sterling Integrator. However, to ensure
that you employ the most current capability, avoid using
them.
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Contains Icons for:Category / Stencil Name

Services that can run in Sync mode. Sync mode holds a
single processing thread until it has completed its work.

Sync Mode

Services that are not included are those in the following
categories:

• Performs Waiting or Waiting on IO

• Split

• Join

• Invoke sync

• Produce/Consume

• All Notify Complete services

Services and adapters that enable business processes to
interact with hardware and software resources such as

System / System

application components, file systems, operating systems,
and databases, both internal and external to Sterling
Integrator, such as:

• Command Line Adapter 2

• File System adapter

• Java™ Database Connectivity (JDBC™) adapter

• Lightweight Java Database Connectivity (JDBC) adapter

Services that translate or transform data using maps created
with the Map Editor, such as:

Translation / Translation

• Translation service

• Typing service

• XML Encoder service

• XSLT service

Adapters that offer additional options that enable Sterling
Integrator to communicate with local or remote servers and
exchange data, such as:

Transport / Transport

• Lightweight Directory Access Protocol (LDAP) adapter

• Remote Method Invocation (RMI) adapter

• Simple Network Management Protocol (SNMP) Trap
adapter

Services that support Web services technologies. Web
services directly invoke application function calls over the
Internet. Examples of Web Extensions services are:

Web Extensions / Web Extensions

• Human Interaction Document Loader service

• Human Interaction Event and Query services
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XPath Expression Builder

Note: This topic assumes familiarity with XML Path language (XPath). If you need more information about
XPath, see the World Wide Web Consortium at www.w3c.org and the Business Process Modeling Language
(BPML) documentation.

The XPath Expression Builder makes creating XPath expressions to use in your business process models more
convenient. Function and token menus enable you to select the functions and tokens to build an expression.

The following figure shows the XPath Expression Builder. For more information, see Defining and Assigning
Rules and Conditions under Managing Business Processes.
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The Expression Builder provides descriptive information to help you make your choices:

• When you mouse over a function or token, pop-up help describes the selection.
• Function selections are comprised of two parts. The first part, in italics, is descriptive of the function. The

second part, in bold text, is the actual code for the XPath function you are selecting. For example, the number
last ( ) function selection indicates that the last function returns a number.

The following figure shows a pop-up description and indicates the parts of a function selection:

The XPath Expression Builder supports several function types and token sets. To build XPath expressions,
you must be familiar with the expression type you need and understand the functions and tokens used in the
expression types. For descriptions of XPath function types and tokens, view the XPath Tutorial at
http://www.w3c.org.

Remember that you cannot use functions and tokens in Sterling Integrator that are not supported in the XPath
Expression Builder, with the following exceptions:

• DocToDOM
• DOMToDoc

For information about these exceptions, see the BPML documentation.

The following table describes the function types supported by the XPath Expression Builder:

DescriptionFunction type

Used to obtain information from an XML document, such as
counting purchase orders in a node set. Also:

Node-Set

• Defines a set of sequential context-nodes
• Specifies what information to process or return for the set

of context-nodes

Perform basic string operations, such as:String

• Finding the length of a string
• Comparing a string
• Changing letters from uppercase to lowercase
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DescriptionFunction type

• Modifying the text content of XML elements or attributes
• Converting an argument of any type

Specifies a Boolean argument (using either the true or false
state) that can include predicates and return the result.

Boolean

Manipulate numbers, such as:Number

• Specifying a numeric function for adding groups of numbers
• Finding the nearest integer to a number
• Performing basic arithmetic operations

The following table describes the three token sets supported by the XPath Expression Builder:

Use to:Token Set

Define the direction of your search by using keywords,
including:

Axis

• Attributes
• Child elements (default)
• Descendants of the child elements
• Parent elements
• Ancestor elements

Indicate the name of the node for which to search.

Note:  Insert the name of the node test after the resolution
operator (::) that follows the axis.

Node Test

Insert a relational operator to test each node in the set of
context-nodes of a location path.

Note:  Predicates can use Boolean operators.

Predicate
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Annotation Tool

The Annotation tool enables you to add customized comments such as descriptive names or explanations, for
your reference, to the icons in the graphic display of your business process models.

The Graphical Process Modeler (GPM) automatically includes annotations with all icons. When you pause
with your mouse arrow over an icon or the name of an icon in the workspace, the annotation for the icon pops
up. Using the Annotation tool, you can modify the annotations so that they are more useful for you.

The following figure illustrates an annotation in a simple business process model:

The GPM does not store annotations in the Business Process Modeling Language (BPML) content of a business
process model, therefore, they display only in the GPM representation of a business process model, not in the
source BPML. For the same reason, if you edit and save a process model directly in the source BPML, the
annotations will no longer be part of the business process model.
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Uninstall the Graphical Process Modeler
If you have more than one copy of the Graphical Process Modeler (GPM) installed—for example, if you have
installed a copy to use for testing and a copy to use for production—you can remove a copy of the GPM using
the Java Cache Viewer.

To remove a copy of the GPM:

1. From the Windows Start menu, select Run.

2. Type javaws -viewer and click OK.
The Java Cache Viewer appears.

3. From the Application column, select the Modeler (or the copy of the GPM) that you want to remove.

4. Click the Remove selected items button (the red X).
The selected copy of the GPM is removed from the client computer.
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Copyright

Licensed Materials - Property of Sterling Commerce

© Copyright Sterling Commerce, an IBM Company 2000, 2011 All Rights Reserved.

US Government Users Restricted Rights - Use, duplication or disclosure restricted by contract with Sterling
Commerce

Additional copyright information is located on the Sterling Integrator 5.1 Documentation Library:

http://www.sterlingcommerce.com/Documentation/SI51/CopyrightPage.htm
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