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Sterling Connect:Direct and Sterling B2B Integrator
Interoperability

You can set up Sterling B2B Integrator to interoperate with Sterling
Connect:Direct®.

What’s New with the Interface between Sterling B2B Integrator and
Sterling Connect:Direct

If your company uses both IBM® Sterling B2B Integrator and IBM Sterling
Connect:Direct to perform business activities, route data, and transfer files, you can
configure the IBM Sterling B2B Integrator - Connect:Direct Server Adapter to act as
the primary node, that is, the node on which the process is being submitted or the
secondary node that interacts with the primary node during process execution.

General Enhancements
In Sterling B2B Integrator version 5.2, several enhancements are focused on making
it easier to use the Sterling Connect:Direct Server Adapter and other related
Sterling Connect:Direct Server services, such as the CopyTo service used to transfer
files between a Sterling Connect:Direct Server Adapter node and other Sterling
Connect:Direct server nodes. Here’s a summary of the general enhancements:
v Sterling Connect:Direct Server Adapter upgrade now allows you to make

changes to an existing netmap, which take effect immediately without disabling
and re-enabling the adapter. Simply edit the configuration of the Sterling
Connect:Direct Server Adapter that uses the modified netmap, click Next until
you reach the Confirm page, and then click Finish for the system to immediately
recognize your netmap changes.

v Sterling B2B Integrator version 5.1 and later supports the most common set of
parameters available in the Sterling Connect:Direct for z/OS® Process Copy
statement To clause to provide more functionality, such as enhanced file
allocation and disposition options for the destination file on the remote Sterling
Connect:Direct for z/OS node. To ensure that business processes created in
earlier versions of Sterling B2B Integrator continue to execute properly,
parameters existing in versions 5.0 and earlier will still be supported. However,
these old parameters cannot be mixed with new parameters in the same CopyTo
service. It is recommended that you use the new parameters when you create a
new business process and that when you make changes to an existing CopyTo
service that you upgrade and use the new parameters, as well. For more
information, search for Sterling Connect:Direct Server CopyTo Service.

v To reduce the number of instances business processes that terminate with an
error because of PNODE session limits, Sterling B2B Integrator now places
business processes in a suspend queue to await session availability. When a
session count frees up, it is assigned to the oldest suspended business process
which can use the newly available session. The business process then resumes
and is allowed to try to establish a session. For more information on this
workflow suspension processing feature, see How Sessions for Business
Processes Are Established.

v Sterling Connect:Direct Server Adapter upgrade now allows you to take
advantage of the checkpoint restart feature. This feature allows the automatic
restarting of copy operations that fail in certain ways, for example, due to

© Copyright IBM Corp. 2000, 2014 1



network errors. The copy operation is resumed from a previously checkpointed
location rather than having to start over from the beginning of the file transfer.
To implement this feature, you must enable retry processing. For more
information, see How Checkpoint Restart and Retry Processing Works.
In earlier versions of Sterling B2B Integrator, you had to specify a retry in the
business process itself. In addition, in Sterling B2B Integrator version 5.1 and
later, when a session is established the current retry counts are reset to zero so
that if the session subsequently fails, the system starts counting retries from
zero, which represents a departure from the earlier behavior.
The copy checkpoint retry feature is now governed by the same short-term and
long-term retries parameters that control retries for initial session establishment.
Prior to Sterling B2B Integrator version 5.1, there were three sets of parameters
related to session establishment and retry processing:
– Session establishment parameters that were used only for initial session

establishment. These two fields, Number of Retry attempts for establishing a
session and Interval between session establishment attempts, were
configurable in both the Sterling Connect:Direct Server Adapter and Sterling
Connect:Direct Server Begin Session Service. These parameters did not affect
session re-establishment after a session failure during COPY processing.

– Short-term session retry parameters that were only used when the adapter
attempted to establish a session but there was no PNODE session available.
These two fields, Number of short-term session retry attempts and Interval
between short-term session retry attempts, were configurable in both the
Sterling Connect:Direct Server Adapter and Sterling Connect:Direct Server
Begin Session Service. The server in that scenario would perform a series of
delays and retries to try to acquire a free session count. These parameters
controlled the retrying of the acquisition of a session count but had nothing to
do with establishing sessions. This functionality has been made obsolete by
the workflow suspension processing feature described above. With that
feature, a business process is put in a suspend queue when there are no
available sessions to await for the next free session count.

– Checkpoint-based copy-restart parameters that were used only in CopyTo and
CopyFrom processing. These two fields, Number of Retry attempts for
checkpoint-based copy-restart and Interval between Retry attempts, were
configurable in only the Sterling Connect:Direct Server Adapter When a
COPY operation failed with a 'restartable' error such as a session failure, these
parameters controlled the number of retries performed and the interval
between retry attempts. This retry count was a hard limit on the number of
retries that could be done during a given communications session regardless
of whether sessions were re-established and then subsequently lost or
whether a session failed and then could not be re-established. This set of
parameters is now obsolete as a result of the enhanced copy checkpoint retry
feature.
Session establishment and retry processing has been both simplified and
enhanced in Sterling B2B Integrator version 5.1. There are now two sets of
parameters (short-term and long-term) instead of three and the two sets apply
throughout the session both to initial session establishment and also to
re-establishment after a failure. These two sets of parameters are configured
in the Sterling Connect:Direct Server Adapter and can be overridden in the
Sterling Connect:Direct Server Begin Session service:

– Session establishment parameters, which are now the long-term session retry
settings and apply both to initial session establishment as well as to COPY
steps when a session must be re-established. When the default settings
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defined in the adapter configuration are overridden in the Begin Session
service, the new values are retained for the duration of the session and also
apply to any subsequent COPY steps.

– Short-term session retry parameters, which now work in conjunction with the
long-term session retry parameters. The values for the short-term parameters
are used first if defined, and if a session has still not been established (or
re-established) when they are exhausted, the long-term retry values are used,
if configured. If the short-term values are overridden in the Begin Session
service, the new values are retained for the duration of the session and also
apply to any subsequent COPY steps.

v File Allocation Retry (FAR) processing allows the Sterling Connect:Direct Server
Adapter to retry a Copy operation when one of a set of certain file allocation
errors occurs in combination with a non-zero return code. This is most useful
when the Sterling Connect:Direct Server Adapter initiates a file transfer with a
remote Sterling Connect:Direct for z/OS system. This feature only affects locally
initiated (PNODE) sessions that use the Sterling Connect:Direct Server CopyTo
service or CopyFrom service. For more information, see How File Allocation
Retry Processing Works.

v For interoperability with other Sterling Connect:Direct nodes in high-availability
environmnents, the Alternate Comm Info parameter in the Sterling
Connect:Direct Server Adapter Netmap allows you to specify a list of alternate
hostnames and IP addresses that are used for Netmap checking of inbound
connection requests to the adapter. For more information, see Alternate Comm
Info.

Syntax Examples for Creating Sterling Connect:Direct
Processes to Communicate with Sterling B2B Integrator

Information about the syntax to use when creating Sterling Connect:Direct
Processes to communicate with Sterling B2B Integrator is available. For more
information, search for the following topics:
v Transmitting Files between Sterling Connect:Direct and Sterling B2B Integrator
v COPY Statement Keywords for Communicating with Sterling B2B Integrator
v Sending to a Sterling B2B Integrator Mailbox
v Sending to a Sterling B2B Integrator Business Process
v Retrieving from a Sterling B2B Integrator Business Process
v Retrieving from a Sterling B2B Integrator Mailbox
v Specifying File Formats using SYSOPTS
v Submitting a Sterling B2B Integrator Business Process from Sterling

Connect:Direct
v Sterling Connect:Direct Parameters for Communicating with Sterling B2B

Integrator

Sterling Connect:Direct Process Examples
Several Sterling Connect:Direct Process examples have been provided to illustrate
the syntax for the various platforms supported by Sterling Connect:Direct. For
more information, search for the following topics:
v Copying a File from Sterling Connect:Direct for z/OS to a Sterling B2B

Integrator Mailbox
v Copying a File from Sterling Connect:Direct for UNIX to a Sterling B2B

Integrator Mailbox
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v Copying a File from Sterling Connect:Direct for Microsoft Windows to a Sterling
B2B Integrator Mailbox

v Copying a File from Sterling Connect:Direct for HP NonStop to a Sterling B2B
Integrator Mailbox

v Copying a File from Sterling Connect:Direct for i5/OS™ to a Sterling B2B
Integrator Mailbox

v Copying a File from Sterling Connect:Direct for z/OS to a Sterling B2B
Integrator Business Process

v Copying a File from Sterling Connect:Direct for UNIX to a Sterling B2B
Integrator Business Process

v Copying a File from Sterling Connect:Direct for Microsoft Windows to a Sterling
B2B Integrator Business Process

v Copying a File from Sterling Connect:Direct for HP NonStop to a Sterling B2B
Integrator Business Process

v Copying a File from Sterling Connect:Direct for i5/OS to a Sterling B2B
Integrator Business Process

v Retrieving a File from a Sterling B2B Integrator Business Process to Sterling
Connect:Direct for z/OS

v Retrieving a File from a Sterling B2B Integrator Business Process to Sterling
Connect:Direct for Microsoft Windows

v Retrieving a File from a Sterling B2B Integrator Business Process to Sterling
Connect:Direct for UNIX

v Retrieving a File from a Sterling B2B Integrator Business Process to Sterling
Connect:Direct for HP NonStop

v Retrieving a File from a Sterling B2B Integrator Business Process to Sterling
Connect:Direct for i5/OS

v Retrieving a File from a Sterling B2B Integrator Mailbox to Sterling
Connect:Direct for z/OS

v Retrieving a File from a Sterling B2B Integrator Mailbox to Sterling
Connect:Direct for Microsoft Windows

v Retrieving a File from a Sterling B2B Integrator Mailbox to Sterling
Connect:Direct for UNIX

v Retrieving a File from a Sterling B2B Integrator Mailbox to Sterling
Connect:Direct for HP NonStop

v Retrieving a File from a Sterling B2B Integrator Mailbox to Sterling
Connect:Direct for i5/OS

v Submitting a Sterling B2B Integrator Business Process from Sterling
Connect:Direct for z/OS

v Submitting a Sterling B2B Integrator Business Process from Sterling
Connect:Direct for UNIX

v Submitting a Sterling B2B Integrator Business Process from Sterling
Connect:Direct for Microsoft Windows

v Submitting a Sterling B2B Integrator Business Process from Sterling
Connect:Direct for HP NonStop

v Submitting a Sterling B2B Integrator Business Process from Sterling
Connect:Direct for i5/OS
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Enhancements to Sterling Connect:Direct Server Adapter
Documentation

The IBM Sterling B2B Integrator - Connect:Direct Server Adapter Interoperability
Guide was introduced in June 2009. With the release of Sterling B2B Integrator
version 5.1, this basic documentation has been enhanced by adding the following
information:
v A procedure on setting up a Sterling B2B Integrator mailbox and the advantages

of using virtual roots. See Creating a Sterling B2B Integrator Mailbox.
v Detailed information on checkpoint restart and retry processing and how

sessions for business processes are established. After reading this information,
you may want to adjust your configuration settings to fit your environment. See
Session Establishment and Process Recovery.

v Five new Sterling B2B Integrator business process examples in Sample Business
Processes on the Sterling B2B Integrator Side.

v Existing sample business processes involving both Sterling Connect:Direct and
Sterling B2B Integrator processing, have been enhanced by adding the Sterling
Connect:Direct Process which precedes the activity on the Sterling B2B Integrator
side. Explanations for examples have been sharpened by adding
platform-specific information, and more details about operations, nodes, and
files being transferred. See Sample Business Processes on the Sterling B2B
Integrator Side.

In addition, the documentation for the following Sterling Connect:Direct Server
services has been updated:
v Sterling Connect:Direct Server Begin Session Service

Note: In Sterling Connect:Direct Server Begin Session Service, the Using Obscured
Password field was added and the related business process example was enhanced.
v Sterling Connect:Direct Server CopyFrom Service
v Sterling Connect:Direct Server CopyTo Service
v Sterling Connect:Direct Server End Session Service
v Sterling Connect:Direct Server Run Job Service
v Sterling Connect:Direct Server Run Task Service
v Sterling Connect:Direct Server Submit Service

As noted in General Enhancements, several enhancements in Sterling B2B
Integrator version 5.2 are focused on making it easier to use the Sterling
Connect:Direct Server Adapter and other related Sterling Connect:Direct Server
services. For more information about using these products most efficiently, search
for Working with Sterling Connect:Direct.

Sterling B2B Integrator Business Process Examples
Several Sterling B2B Integrator business process examples have been provided to
illustrate the syntax for the various platforms supported by Sterling B2B Integrator
and Sterling Connect:Direct. For more information, search for the following topics:
v Use Sterling Connect:Direct to Copy a File to Sterling B2B Integrator
v Use Sterling Connect:Direct to Retrieve a File from Sterling B2B Integrator
v Use Sterling B2B Integrator to Copy a File to a Sterling Connect:Direct for z/OS

Node
v Use Sterling B2B Integrator to Copy a File to a Sterling Connect:Direct for

Microsoft Windows Node
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v Use Sterling B2B Integrator to Copy a File to a Sterling Connect:Direct for UNIX
Node

v Use Sterling B2B Integrator to Copy a File to a Sterling Connect:Direct for HP
NonStop Node

v Use Sterling B2B Integrator to Copy a File to a Sterling Connect:Direct for i5/OS
Node

v Use Sterling B2B Integrator to Copy a File from Sterling Connect:Direct
v Add Error Handling to the Business Process
v Use Sterling B2B Integrator to Submit a Sterling Connect:Direct Process
v Use Sterling B2B Integrator to Start a Sterling Connect:Direct Run Job
v Use Sterling B2B Integrator to Start a Sterling Connect:Direct Run Task
v Hide the Sterling Connect:Direct Password in the Business Process
v Use Sterling B2B Integrator to Copy a File to Sterling Connect:Direct for z/OS

(Advanced)

About Sterling Connect:Direct and Sterling B2B Integrator
Interoperability

Sterling B2B Integrator enables a business to define business processes in a
software application and route data between enterprise systems using different
protocols and formats.

Sterling Connect:Direct is a peer-to-peer data transfer application that uses a
proprietary protocol to exchange data between Sterling Connect:Direct servers.

The Sterling Connect:Direct Server Adapter is a component of Sterling B2B
Integrator that allows Sterling B2B Integrator to act like a Sterling Connect:Direct
server, sending and receiving data using the Sterling Connect:Direct protocol. The
Sterling Connect:Direct Server Adapter enables you to use files from a Sterling
Connect:Direct server in a Sterling B2B Integrator business process and to create
business processes that exchange files with a Sterling Connect:Direct server.

Sterling Connect:Direct and Sterling B2B Integrator Processes
Sterling Connect:Direct and Sterling B2B Integrator each have their own version of
a process. Sterling Connect:Direct uses a Process statement to initiate a session
with another Sterling Connect:Direct node and then uses specific statements to
perform tasks and make requests on that node.

Sterling B2B Integrator uses business process services to initiate a session with
another Sterling Connect:Direct node to perform tasks and make requests on that
node. It is possible to use Sterling B2B Integrator business processes to handle
complex processes such as order fulfillment, invoicing, inventory, and other
processes that require data exchange and business integration.

These business processes enable you to transfer your files, or business documents,
to internal processing activities and to trading partners, exchanges, and customers.

Business Processes and Mailboxes
You can copy files from a Sterling Connect:Direct node directly to a Sterling B2B
Integrator business process or mailbox. Sterling B2B Integrator business processes
utilize services and adapters, such as the Sterling Connect:Direct Server Adapter
and related services, in a sequence of steps to achieve business goals. The Sterling
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B2B Integrator Mailbox is a business document repository that enables you to
organize, store, and manage trading partner documents and transactions.

Although staging and scheduling of data transmission is present to varying
degrees in numerous applications and infrastructure components, it is beneficial to
centralize the definition, operation, management, and control of this staging and
scheduling. In Sterling B2B Integrator, these capabilities are centralized in the
Mailbox.

You can set up mailboxes within Sterling B2B Integrator so that files copied over to
Sterling B2B Integrator are stored and retrieved later. When the files are stored in a
mailbox, they are referred to as messages. You can also use mailbox routing rules
to initiate business processes in Sterling B2B Integrator based on messages that are
stored in a mailbox. For more information on setting up mailboxes, see Creating a
Sterling B2B Integrator Mailbox.

After you have set up a Sterling B2B Integrator mailbox or business process to
which you want to send a file, you can create the Sterling Connect:Direct Process
to perform the file transfer. For more information about the Sterling Connect:Direct
Process language and how to tailor it to communicate with Sterling B2B Integrator,
search for Sterling B2B Integrator Connect:Direct Server Adapter Syntax and
Sterling B2B Integrator-Connect:Direct Server Adapter Examples.

Using Sterling Connect:Direct Server Adapter Services in a
Business Process

The Sterling Connect:Direct Server Adapter provides a suite of B2B services to
establish communication between Sterling B2B Integrator and Sterling
Connect:Direct.

Using these services, you can create business processes to perform the same tasks
performed with Sterling Connect:Direct Processes and with Sterling Connect:Direct
commands.

The Sterling Connect:Direct Server services correspond to the Sterling
Connect:Direct Process Language. These services work with the Sterling
Connect:Direct Server Adapter. All services (except for Sterling Connect:Direct
Server BP Response Service) are used when the Sterling Connect:Direct Server
Adapter is the PNODE. The Sterling Connect:Direct Server BP Response Service is
used when the Sterling Connect:Direct Server Adapter is the SNODE and Sterling
Connect:Direct is retrieving a file from Sterling B2B Integrator.

The services created specifically for use with Sterling Connect:Direct are described
in sample workflows in this user guide. These workflows demonstrate how each
service is used within a business process.

The Sterling Connect:Direct Server Adapter supports the following services:
v Sterling Connect:Direct Server Begin Session Service
v Sterling Connect:Direct Server BP Response Service
v Sterling Connect:Direct Server CopyFrom Service
v Sterling Connect:Direct Server CopyTo Service
v Sterling Connect:Direct Server End Session Service
v Sterling Connect:Direct Server Run Job Service
v Sterling Connect:Direct Server Run Task Service
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v Sterling Connect:Direct Server Submit Service

System Requirements for Interoperability
Interoperability between Sterling B2B Integrator and Sterling Connect:Direct has
the following system requirements:

Supported Sterling Connect:Direct Versions

The following versions of Sterling Connect:Direct support interoperability with
Sterling B2B Integrator:
v Sterling Connect:Direct for z/OS 4.6 or later
v Sterling Connect:Direct for Microsoft Windows 4.4 or later
v Sterling Connect:Direct for UNIX 3.8 or later
v Sterling Connect:Direct for HP NonStop 3.4 or later
v Sterling Connect:Direct for i5/OS 3.6 or later

Supported Sterling B2B Integrator Versions

Sterling B2B Integrator versions 4.2 or later support interoperability with Sterling
Connect:Direct.

Setup Procedures

Create Sterling Connect:Direct and Sterling B2B Integrator
User IDs

Your Sterling B2B Integrator administrator must create a Sterling B2B Integrator
User ID for you. The administrator must give this User ID permission to execute
Sterling B2B Integrator business processes that you copy files to or from. When
you create your Sterling Connect:Direct processes, use this Sterling B2B Integrator
User ID as the SNODEID of the Process statement.

Your Sterling Connect:Directadministrator must create a Sterling Connect:Direct
user account and give this account permission to copy files, submit processes,
perform Run Jobs, and perform Run Tasks on the Sterling Connect:Direct node.
When you create your Sterling B2B Integrator business processes, use this Sterling
Connect:Direct user account as the remote Sterling Connect:Direct User ID.

Configure a Sterling B2B Integrator Netmap Entry
A node is a Sterling Connect:Direct server. Two Sterling Connect:Direct servers
(local and remote) function together to perform data transfers. Either node can
initiate the work by submitting a Process.

When a session is established, the node that initiates the session is the PNODE
regardless of the direction of information flow. The other node is the SNODE. The
Process can specify work destined for either the PNODE or SNODE.

Note: The Sterling Connect:Direct Server Adapter can be a Sterling Connect:Direct
local or remote node and can function as a PNODE or an SNODE, depending on
whether or not it initiates the connection with a remote Sterling Connect:Direct
node.
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The Sterling Connect:Direct Server Adapter configuration identifies the remote
nodes that it can communicate with through the use of a network map, called a
netmap.

When you create a Sterling Connect:Direct Server Adapter, you must specify a
netmap.

In Sterling B2B Integrator version 4.3 and earlier, the netmap is integrated with the
Sterling Connect:Direct Server Adapter configuration. In Sterling B2B Integrator
version 5.0 and later, netmaps are configured as separate objects which allows one
netmap to be shared by more than one Sterling Connect:Direct Server Adapter.

In Sterling B2B Integrator version 5.0 and later, you can configure a netmap in
Sterling B2B Integrator from the Administration menu by selecting Deployment >
Adapter utilities > C:D Netmaps.

From this menu, you can configure:
v Sterling Connect:Direct Nodes
v Sterling Connect:Direct Netmaps
v Sterling Connect:Direct Netmap cross-references (X-REF)

Note: Updates to the netmap are not done dynamically. If you make changes to an
existing netmap, Sterling Connect:Direct node, or Sterling Connect:Direct netmap
cross-reference, you must refresh the configuration of each Sterling Connect:Direct
Server Adapter that uses the netmap by opening the adapter’s configuration and
re-saving it. In version 5.2, refreshing a Sterling Connect:Direct Server Adapter’s
configuration does not affect any active sessions. Click Save to go to the Confirm
page, and then click Finish to update the configuration. Your configuration
changes to netmap members take effect immediately.

Creating Sterling Connect:Direct Nodes
Create a Sterling Connect:Direct node definition for each remote Sterling
Connect:Direct node that communicates with the Sterling Connect:Direct Server
Adapter. This is only required for nodes you plan to connect to and for nodes that
connect to the Sterling Connect:Direct Server Adapter when you have netmap
checking enabled.

About this task

Use the following procedure to create a new Sterling Connect:Direct node:

Procedure
1. From the Administration menu, select Deployment > Adapter Utilities > C:D

Netmaps > C:D Nodes.
2. In the Create Nodes pane, click Go!. The Create Nodes page appears.

Field Value to Enter Description

Connect:Direct
Server Node Name

Type the node name for the
Sterling Connect:Direct server.

Name that will be used to identify the Sterling
Connect:Direct server. Required.
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Field Value to Enter Description

Connect:Direct
Server Host

Type the host name or IP address
for the Sterling Connect:Direct
server.

host name—Host name associated with the IP address. For
example:

host01 (where host01 is a machine on the local domain)

host01.proddomain.com (fully-qualified host name)

nnn.nnn.nnn.nnn or

nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn—IP

address of a machine running Sterling Connect:Direct.

IPV6 is supported for Sterling Connect:Direct for UNIX 4.0
and Sterling Connect:Direct for Microsoft Windows 4.4 or
later.

Required.

Connect:Direct Port Type the host port number for
the Sterling Connect:Direct server.

TCP/IP port number that Sterling Connect:Direct monitors
for requests from remote nodes. Required.
Note: If Sterling B2B Integrator is installed on a UNIX
operating system, do not select ports in the range 1-1024.
These are normally reserved by the operating system.

Max locally initiated
(pnode) sessions
allowed

During testing, set this value to
100 so that you do not run out of
sessions.

After testing, enter the estimated
number of sessions you require.
Otherwise, accept the default
value of 5.

Maximum number of sessions initiated locally by the
Sterling Connect:Direct Server Adapter that may be active
at any time. Optional. If omitted, the value defined by the
Sterling Connect:Direct Server Adapter is used.

This setting overrides the Max locally initiated (pnode)
sessions allowed setting in the Sterling Connect:Direct
Server Adapter configuration.

Valid value: Any number up to 9999. Minimum value is 1.
Default is 5.

For more information on session limits, see How Sessions
for Business Processes Are Established.

Max remotely
initiated (snode)
sessions allowed

During testing, set this value to
100 so that you do not run out of
sessions.

After testing, enter the estimated
number of sessions you require.
Otherwise, accept the default
value of 5.

Maximum number of sessions initiated by the remote
node that may be active at any point of time. If omitted,
the value defined by the Sterling Connect:Direct Server
Adapter is used.

This setting overrides the Max remotely initiated (snode)
sessions allowed setting in the Sterling Connect:Direct
Server Adapter configuration.

Valid value: Any number up to 9999. Minimum value is 1.
Default is 5.
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Field Value to Enter Description

Alternate Comm
Info

Leave this blank unless the
inbound Sterling Connect:Direct
node has more than one outgoing
IP address.

If the inbound Sterling
Connect:Direct node has more
than one outgoing IP address,
specify the IP addresses or host
names in a comma-delimited list
as shown in the Description.

Provides support for establishing netmap-checked sessions
with high-availability (especially load balancing) systems
with multiple IP addresses, such as Sterling
Connect:Direct/Plex for z/OS. Use this parameter to list
all IP addresses or host names that are part of the multiple
IP address environment.

For Sterling Connect:Direct/Plex, this list should include
the address of each Sterling Connect:Direct/Server with a
different IP address from the Sterling Connect:Direct/Plex
Manager.

If a remote node has more than one outgoing IP address
(as in a load balancing environment), specify all of the
remote node's possible outgoing addresses in the Alternate
Comm Info field so that those outgoing IP addresses are
contained in the local node's netmap entry for that remote
node. This configuration allows netmap checking to
succeed when the remote node connects to the local node
using any of the possible outgoing IP addresses specified.

Valid format: hostname1/IP address, hostname2/IP
address, hostname3/IP address (maximum length is 2048
characters)

host name—Host name associated with the IP address. For
example:

host01 (where host01 is a machine on the local domain)

host01.proddomain.com (fully-qualified host name)

nnn.nnn.nnn.nnn or

nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn—IP

address of a machine running Sterling Connect:Direct

IPV6 is supported for Sterling Connect:Direct for UNIX 4.0
and Sterling Connect:Direct for Microsoft Windows 4.4 or
later.

Secure+ Option Accept the default setting
(Disabled) until you start using
Sterling Connect:Direct Secure
Plus.

Files are not encrypted during
copy operations.

Valid if Netmap Override=Yes at the Connect:Direct Server
Adapter. Indicate if you want to disable or enable
encryption. Required.

Valid values are:

v Disabled (default)

v Enabled

3. Click Next. The Confirm page appears.
4. Review your configuration settings and click Finish.

Creating Sterling Connect:Direct Netmaps
Once you have defined at least one Sterling Connect:Direct node you want to use,
you can create a netmap. When you configure a Sterling Connect:Direct Server
Adapter, you must specify the netmap you want to use rather than the individual
Sterling Connect:Direct nodes you want to communicate with. The individual
Sterling Connect:Direct nodes are associated with netmaps with cross references.
This arrangement is very flexible and allows you to:
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About this task
v Define each Sterling Connect:Direct node one time no matter how many Sterling

Connect:Direct Server Adapter you have.
v Use the same netmap for multiple Sterling Connect:Direct Server Adapters.
v Create specialized netmaps for different Sterling Connect:Direct Server Adapters.

Use the following procedure to create a new Sterling Connect:Direct netmap:

Procedure
1. From the C:D Netmaps menu, select C:D Netmaps. The C:D Netmaps page

appears.
2. In the Create New Netmap pane, click Go!. The Create Netmap page appears.

Field Value to Enter Description

Netmap Name Type the Sterling
Connect:Direct netmap
name.

Netmap names consist of alphanumeric,
dollar ($), dot (.), underscore (_), and dash
(–) characters. The maximum length is 64
characters. Required.
Note: If you maintain multiple Sterling
Connect:Direct Server Adapters, you can
use the same name for the netmap and
Sterling Connect:Direct Server Adapter for
easier administration.

Netmap
Description

Type the netmap
description.

Required.

3. Click Next. The Confirm Page appears.
4. Review your configuration settings and click Finish.

Creating a Connect:Direct Netmap Cross-Reference
You can reuse nodes for a netmap or several netmaps by setting up a cross
reference so you don't have to create a new node for each Connect:Direct Server
Adapter.

About this task

To create a new netmap cross reference:

Procedure
1. From the C:D Netmaps menu, select C:D Netmap X-REF.
2. In the Create or Modify Netmap Cross Reference pane, click Go!. The Create

Cross Reference page appears.

Field Value to Enter Description

C:D Netmap
Name

Select the Connect:Direct netmap name
that you created in Creating Sterling
Connect:Direct Netmaps.

Select the Connect:Direct
Netmap name. Required.
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Field Value to Enter Description

Add Node Click the plus sign to add a Node
Name to the cross-reference. A new
window appears, allowing you to
select the Connect:Direct Node
Name(s).

Select the node name that you created
Creating Sterling Connect:Direct
Netmaps .

3. Click Next. The Confirm page appears.
4. Review your configuration settings and click Finish.

Configuring a Sterling Connect:Direct Server Adapter
The Sterling Connect:Direct Server Adapter can function as either the PNODE,
SNODE, or both, in the Sterling Connect:Direct network, initiating and responding
to Sterling Connect:Direct transfer requests. Configuring a Connect:Direct Server
Adapter is similar to configuring a Sterling Connect:Direct server.

Before you begin

Use the following procedure to configure a Connect:Direct Server Adapter in
Sterling B2B Integrator:

Procedure
1. From the Deployment menu, select Services > Configuration.
2. Click Go in the Create New Service pane.
3. In the Service Type box, type Connect:Direct Server Adapter and click Next.
4. Configure the following fields for this scenario. Accept default values for all

other fields.

Note: To enable session establishment retry processing, the value specified for
either the number of long-term or short-term retry attempts must be greater
than 0. Both of these adapter-level settings can be overridden by values
specified for in the Connect:Direct Server Begin Session service for a particular
business process.

To enable copy restart processing, session establishment retry processing must
be enabled. You must also configure the Checkpoint Interval in the
Connect:Direct Server Adapter CopyTo or CopyFrom service in your business
process. For additional information, see How Checkpoint Restart and Retry
Processing Works.

Note: When you configure how you want retry processing to work, note that
the short-term retry interval is configured in seconds rather than in minutes
used for the long-term retry interval. For additional information, see How
Checkpoint Restart and Retry Processing Works.
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Field Value to Enter Description

Name Type a unique name for the
Connect:Direct Server
Adapter configuration.

Required.
Note: Name is the adapter name, not the
node name. However, in Sterling B2B
Integrator business processes, Name is the
CDLocalNodeName. To avoid confusion,
use the same value for both Name and
Connect:Direct Server Node Name in your
Connect:Direct Server Adapter
configuration.

Description Type a description for the
Connect:Direct Server
Adapter configuration.

Required

Connect:Direct
Server Node
Name

Type the node name to use
to identify this
Connect:Direct Server
Adapter. Best practice is to
use the same value as the
Name field.

Maximum 16 characters. This node name
must match the Connect:Direct netmap
entry for the Connect:Direct Server
Adapter. Required.

Connect:Direct
Server Port

Type the listening port
number for the
Connect:Direct Server
Adapter.

Make sure you select a port
number that is not in use by
another application.

TCP/IP port number that Connect:Direct
Server Adapter monitors for requests from
remote nodes. Required.
Note: If your application is installed on a
UNIX operating system, do not select ports
in the range 1-1024. These are normally
reserved by the operating system.

Max locally
initiated
(pnode)
sessions
allowed

During testing, you may
want to set this value to a
high number, such as 100,
so that you do not run out
of sessions.

After testing, enter the
estimated number of
sessions you require.
Otherwise, accept the
default value of 5.

If you need to specify
session limits for each node,
set this value at the highest
anticipated number of total,
locally initiated sessions and
then specify node limits in
the netmap.

Maximum number of sessions initiated
locally by the Connect:Direct Server
Adapter that may be active at any point in
time. Required.

May be overridden at the node level. If a
node-level value is configured, the effective
session limit is the smaller of two values:
the limit for the adapter and the session
limit for the remote node.

Valid value: Any number through 9999.
Minimum value is 1. Default is 5.

For more information on session limits, see
How Sessions for Business Processes Are
Established.
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Field Value to Enter Description

Max remotely
initiated (snode)
sessions
allowed

During testing, you may
want to set this value to a
high number, such as 100,
so that you do not run out
of sessions.

After testing, enter the
estimated number of
sessions you required.
Otherwise, accept the
default value of 5.

If you need to specify
session limits for each node,
set this value at the highest
anticipated number of total,
remotely initiated sessions
and then specify node limits
in the netmap.

Maximum number of sessions initiated by
all remote nodes that may be active at any
point in time.

Required.

May be overridden at the node level. If a
node-level value is configured, the effective
session limit is the smaller of two values:
the limit for the adapter and the session
limit for the remote node.

Valid value: Any number through 9999.
Minimum value is 1. Default is 5.

NetMap Check For testing purposes, you
may find it convenient to
select the default (No). After
testing, select the value that
best serves your network
security requirements.

Whether the node netmap should be
checked to authorize sessions. Required
values are:

v Check both node name and IP
address—Searches the Connect:Direct
Server Adapter network map for an
entry corresponding to the node name of
the remote client. If one exists, the IP
address is obtained and compared to the
IP address of the remote node making
the request.

v Check node name only—Searches the
Connect:Direct Server Adapter network
map for an entry corresponding to the
node name of the remote client.

v No (default)—Disables netmap
validation.

Number of
short-term
session retry
attempts

Valid value: Any number up
through 9999. Default is 0.
Required.

Retry activity is logged (if
logging enabled).

For more information on
retry processing, see Session
Establishment and Process
Recovery.

Specifies the maximum number of
short-term attempts for creating a session
with a Sterling Connect:Direct node or for
re-establishing a session after a session
failure during COPY processing (both
CopyTo and CopyFrom). This setting can
be overridden by the value specified for
ShortTermMaxRetries in the Connect:Direct
Server Begin Session service.
Note: The counter for the number of
short-term session retry attempts is reset to
zero when a session is successfully
reestablished.
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Field Value to Enter Description

Interval
between
short-term
session attempts
(seconds)

Valid value: Any number
through 99999999. Default is
5. Required.

Specifies the amount of time, in seconds, to
wait between short-term session
establishment and re-establishment
attempts. This setting can be overridden by
the value specified for
ShortTermRetryInterval in the Connect
Direct Server Begin Session service.

This parameter performs successive retries
within a shorter period of time than is
available with the Interval between session
establishment attempts (minutes) settings.

Number of
long-term
session retry
attempts

Valid value: Any number up
to 9999. Default is 0.
Required.

Retry activity is logged (if
logging enabled).

Specifies the maximum number of
long-term attempts for creating a session
with a Sterling Connect:Direct node or for
re-establishing a session after a session
failure during COPY processing (both
CopyTo and CopyFrom). This setting can
be overridden by the value specified for
BeginSessionMaxRetries in the
Connect:Direct Server Begin Session
service.
Note: The counter for the number of
long-term session retry attempts is reset to
zero when a session is successfully
reestablished.

Interval
between
long-term
session attempts
(minutes)

Any number through
99999999. Required. Default
is 1.

Specifies the time, in minutes, to wait
between long-term session establishment
and re-establishment attempts. This setting
can be overridden by the value specified
for BeginSessionRetryInterval in the
Connect Direct Server Begin Session
service.

Encryption
using Secure+

Select the default setting
(Disabled) until you start
using Sterling
Connect:Direct Secure Plus.

Whether Sterling Connect:Direct Secure
Plus is enabled. Required. Valid values are
Enabled and Disabled. Default is Disabled.

Sterling Connect:Direct Secure Plus must
be installed on your system. In addition,
you must have the required certificates for
implementing Sterling Connect:Direct
Secure Plus. For information, see the
Sterling Connect:Direct documentation for
the platform you are using.

C:D Netmap
Name

Select the netmap name you
created in Creating Sterling
Connect:Direct Netmaps .

5. When you configure how you want retry processing to work, note that the
short-term retry interval is configured in seconds rather than in minutes used
for the long-term retry interval. For additional information, see How
Checkpoint Restart and Retry Processing Works. This will complete the
Connect:Direct Server Adapter configuration and start the adapter.
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Adding Connect:Direct Server Adapter Node to Sterling
Connect:Direct Netmap

On your Sterling Connect:Direct server, add the Sterling Connect:Direct Server
Adapter node information to your Sterling Connect:Direct netmap with the
following settings. Other settings may be required, and will vary according to the
type of Sterling Connect:Direct environment. For more information on the values
valid for your Sterling Connect:Direct platform, refer to your Sterling
Connect:Direct documentation.

Parameter Value

Node Name The node name of the Sterling Connect:Direct
Server Adapter.

Operating System The operating system for your Sterling B2B
Integrator system. Specify UNIX.

Host/IP Address Host or IP address of your Sterling B2B
Integrator system

Port/Service Port/Service of your Sterling Connect:Direct
Server Adapter

Creating a Sterling B2B Integrator Mailbox
When you copy a file from Sterling Connect:Direct to Sterling B2B Integrator, you
can copy to a Sterling B2B Integrator mailbox. Mailboxes allow you to organize,
store, and manage trading partner documents and transactions, by providing
business document repositories. In addition, setting up mailboxes within Sterling
B2B Integrator can also facilitate how you stage and schedule data transmissions,
making the storage and retrieval of files more transparent to all parties—senders
and recipients alike.

After you have set up your mailboxes, see Scenario 1 - Use Sterling Connect:Direct
to Copy a File to a Sterling B2B Integrator Mailbox, for more information on how
to write a Sterling Connect:Direct process to send information to a Sterling B2B
Integrator mailbox. To see examples involving copying files from a variety of
Sterling Connect:Direct platforms to a Sterling B2B Integrator mailbox, search for
Sterling B2B Integrator-Connect:Direct Server Adapter Examples. To see examples
for retrieving and storing primary documents in a Sterling B2B Integrator mailbox
system, see Use Sterling B2B Integrator to Copy a File to a Sterling Connect:Direct
for i5/OS Node and Use Sterling B2B Integrator to Copy a File from Sterling
Connect:Direct.

Use Virtual Roots in a Mailbox Hierarchy
As in most operating systems, such as Microsoft Windows or UNIX, Sterling B2B
Integrator mailboxes support the concept of a root directory acting as the first or
top-most directory in your mailbox hierarchy. In Sterling B2B Integrator, mailboxes
are visible to users as a relative path, while administrators see the mailbox as an
absolute or full path. Virtual roots can be useful for maintaining and reorganizing
a mailbox hierarchy without impacting users. By limiting visibility into the mailbox
hierarchy, virtual roots can enhance the general security of your system.

When a virtual root is defined for a user account, Sterling B2B Integrator
automatically inserts the virtual root component into the target filename
specification. For example, if the JohnSmith user account used JohnSmith as its
virtual root (for example, /JohnSmith), Sterling B2B Integrator would automatically
insert /JohnSmith into the target filename. Then, if the document, sample.txt, was
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being sent to JohnSmith, the Connect:Direct Server Adapter would process
/mailbox/sample.txt as if it were specified /mailbox/JohnSmith/sample.txt.

Conversely, if you do not define a virtual root for a user account, documents sent
to the user account are stored in the one and only mailbox directory, provided the
user has adequate permission. For example, if the JohnSmith user account did not
have a virtual root defined for it, the sample.txt document would be stored in the
“root” of the mailbox as /mailbox/sample.txt.

Setting Up a Mailbox
You are able to create and configure a mailbox in Sterling B2B Integrator.

About this task

Note: You do not create a virtual root for your mailbox in this simple procedure.
To set up a mailbox hierarchy using virtual roots, refer to the Sterling B2B
Integrator online documentation.

Use the following procedure to create and configure the Sterling B2B Integrator
mailbox:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Deployment menu, select Mailboxes > Configuration.
3. On the Mailbox Configuration page, click Go! in the Create a new Mailbox

pane.
4. On the Mailbox Name page, highlight the forward-slash in the Select pane.

Note: If you are required to specify a virtual root for your mailbox, highlight
the mailbox or mailbox path in the Select pane for your virtual root.

5. In the Name box, type the name of your mailbox.
6. In the Description box, type a short description for your mailbox and click

Next.
7. On the Assign Groups page, click Next.
8. On the Assign Users page, select your Sterling B2B Integrator User ID in the

Available Users pane and click the right-arrow to move your User ID to the
Selected Users pane.

9. Click Next.
10. On the Confirm page, click Finish to create your mailbox.

Scenario 1 - Use Sterling Connect:Direct to Copy a File to a Sterling
B2B Integrator Mailbox

This scenario describes how to copy a file from a Sterling Connect:Direct server
(PNODE) to a Sterling Connect:Direct Server Adapter (SNODE). The
Connect:Direct Server Adapter passes this file to a Sterling B2B Integrator Mailbox.

Optionally, you can set up a mailbox rule so that a document copied to a mailbox
triggers a Sterling B2B Integrator business process.
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Scenario 1 - Creating Your Sterling Connect:Direct Process
Create a Process for your Sterling Connect:Direct platform similar to the following
example:

Note: It is assumed that you have already set up the Sterling B2B Integrator
mailbox to which the destination file is being copied. For more information, see
Creating a Sterling B2B Integrator Mailbox.

COPY2MB PROCESS
SNODE=yourCDSANode
SNODEID=(yourUserID,yourPassword)
STEP1 COPY
FROM (
FILE=yourSourceFile
)
TO (
FILE=/mailbox/yourMailbox/targetdocName
DISP=RPL
)

PEND

This Sterling Connect:Direct process copies yourSourceFile from your Sterling
Connect:Direct server to the Sterling Connect:Direct Server Adapter,
yourCDSANode, which passes the file in the Sterling B2B Integrator mailbox,
yourMailbox. The SNODEID, yourUserID, is your Sterling B2B Integrator User ID.
There are three parts to the destination FILE name in this Copy step:
v /mailbox/ is a reserved word and signals to Sterling B2B Integrator that you are

copying to a Mailbox.
v yourMailbox includes the name of your Sterling B2B Integrator Mailbox.
v targetdocName is the document that is passed to your mailbox by the

Connect:Direct Server Adapter. This document is stored in the mailbox. This
document can be retrieved by an FTP client, business process or another Sterling
Connect:Direct process.

Note: To see several examples involving transferring files from a variety of
Sterling Connect:Direct platforms to a Sterling B2B Integrator mailbox, search for
Sterling B2B Integrator-Connect:Direct Server Adapter Examples.
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Scenario1 - Submitting and Monitoring Your Sterling
Connect:Direct Process

Submit the Sterling Connect:Direct process and then monitor it with either Sterling
Connect:Direct or Sterling B2B Integrator.

Scenario 1 - Monitoring with Sterling Connect:Direct
You can use Sterling Connect:Direct Select Statistics to monitor your Sterling
Connect:Direct to Sterling B2B Integrator processes.

If the Sterling Connect:Direct process is successful, the Select Statistics detail will
report the following:

Attribute Value

Message ID SCPA000I

Message Text Copy operation successful

Destination File /mailbox/yourMailbox/targetdocName

If the Sterling Connect:Direct process is not successful, refer to Troubleshooting.

Scenario 1 - Viewing the Mailbox Document in Sterling B2B
Integrator
You can view targetdocName in your mailbox with Sterling B2B Integrator.

About this task

Use the following procedure to view your mailbox document with Sterling B2B
Integrator:

Procedure
1. From the Deployment menu, select Mailboxes > Messages.
2. On the Message Management page, select Filter by Name to display the

Available Mailboxes pane.
3. In the Available Mailboxes pane, scroll down and highlight /yourMailbox and

click the down-arrow to move /yourMailbox to the Selected Mailboxes pane.
4. Click Go! to display the search results.

Information about the targetdocName document is displayed, including
Document ID, Created date, Size, Mailbox, Extract Policy, Policy Value, and
whether this document is locked by a business process.
In this example, targetdocName has an Extraction Policy of Extractable. This
means that users can extract this document from /yourMailbox an unlimited
number of times with no expiration date and time. You can change the
extraction policy for targetdocName by clicking on the Edit link. If you need to
change the extraction policy for documents you copy to mailboxes using
Sterling Connect:Direct, edit your Connect:Direct Server Adapter configuration
for Extractability.

Note: You can also monitor your Sterling Connect:Direct process from the
Business Process menu by navigating to Monitor > Advanced Search >
Documents or Monitor > Advanced Search > Communication Sessions.
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Scenario 2 - Use Sterling Connect:Direct to Copy a File to a Sterling
B2B Integrator Business Process

This scenario describes how to use Sterling Connect:Direct to copy a file to Sterling
B2B Integrator. In this scenario, the Sterling Connect:Direct server is the PNODE
and the Sterling Connect:Direct Server Adapter is the SNODE. The Connect:Direct
Server Adapter receives the file and passes it to a business process.

Scenario 2 - Creating a Sterling B2B Integrator Business
Process

When you copy a file from Sterling Connect:Direct to Sterling B2B Integrator, you
must copy to a Sterling B2B Integrator business process or mailbox. In this
scenario, you are copying a document to a business process. This business process
contains a service that provides information about the source file.

About this task

Use the Sterling B2B Integrator Graphical Process Modeler to create and modify
business processes. Individual services and adapters are represented by icons in
the Modeler.

Use the following procedure to create the Sterling B2B Integrator business process:

Procedure
1. Log in to Sterling B2B Integrator and launch the Graphical Process Modeler

from the Home screen.
2. Enter your Sterling B2B Integrator User ID and password in the Log In dialog

box.
3. From the View menu, select Stencil > BPML. This will add the BPML stencil to

the GPM.
The BPML stencil contains BPML icons to use in your business processes.

4. From the View menu, select Stencil > Sync Mode. This will add the Sync
Mode stencil to the GPM.
The Sync Mode stencil contains an icon you will need in your business
processes.

5. From the File menu, select New to open a new business process.
6. Drag and drop the following icons from the BPML and Sync Mode stencils

into the Business Process window in the following order, from left to right:
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v Start
v Get Document Information Service
v End

7. To link the icons:
Click the arrow on the right side of the Start icon and drag it to the arrow on
the left side of the Get Document Information Service icon.
Click the arrow on the right side of the Get Document Information Service
icon and drag it to the arrow on the left side of the End icon.

All business processes begin with a Start icon and end with an End icon. In
this business process, the Get Documentation Information Service provides
information about the primary document.

8. Configure the Get Document Information Service using the following
procedure:
Double-click the Get Document Information Service icon. This opens the
Service Editor window.
In the Service Editor-Get Documentation Information Service window, select
GetDocumentInfoService from the Config drop-down list.

In this step you specify the pre-defined GetDocumentInfoService configuration
for the Get Document Information Service. You can override configuration
values in the Service Editor.
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9. From the File menu, select Save. In the Validate dialog box, click Yes to
validate the business process.

10. On the Save dialog box, type the business process file name in the File Name
box and click Save.
Remember where you save this file.

Note: To see a sample business process, refer to Use Sterling Connect:Direct to
Copy a File to Sterling B2B Integrator.

Scenario 2 - Checking Your Business Process into Sterling
B2B Integrator

Use the following procedure to check the business process into Sterling B2B
Integrator:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Create Process Definition pane,

click Go!.
4. Type the name of your business process in the Name box.
5. Under Select an input mode for defining the new process, select Check in

Business Process created by the graphical modeling tool and click Next.
6. On the Check-in page, click Browse and navigate to the business process file

name that you saved in step 10 of the previous procedure.
7. Type a short description for your business process in the Description box and

click Next.
8. On the Process Levels page, select the Set onfault processing check box.
9. Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full and click Next.
11. On the Deadline Settings page, click Next.
12. On the Life Span page, click Next.
13. On the Confirm page, select the Enable Business Process box.
14. Select the Create Permission box.

This adds the business process to the list of Sterling B2B Integrator security
permissions. This makes it possible to assign permission for this business
process to the user account.

15. Click Finish.

Note: The Sterling B2B Integrator administrator must assign your Sterling B2B
Integrator User ID permission to run this business process.

Scenario 2 - Creating Your Sterling Connect:Direct Process
Create a Process for your Sterling Connect:Direct platform similar to the following
example:
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Before you begin

COPY2SI PROCESS
SNODE=yourCDSANode
SNODEID=(yourUserID,yourPassword)
STEP1 COPY
FROM (
FILE=yourSourceFile
)
TO (
FILE=/businessprocess/yourBusinessProcess/targetdocName
DISP=RPL
)
PEND

This Sterling Connect:Direct process copies yourSourceFile from your Sterling
Connect:Direct server to the Sterling Connect:Direct Server Adapter,
yourCDSANode, which invokes the business process, yourBusinessProcess. The
SNODEID, yourUserID, is your Sterling B2B Integrator User ID. There are three
parts to the destination FILE name in this Copy step:
v /businessprocess/ is a reserved word and signals to Sterling B2B Integrator that

you are copying to a business process.
v yourBusinessProcess is the name of the Sterling B2B Integrator business process

that the Connect:Direct Server Adapter invokes.
v targetdocName is the name of the document that is passed to the business

process by the Connect:Direct Server Adapter. This document becomes the
Primary Document in the yourBusinessProcess business process. The primary
document is the document that the services in a business process act on or in
relation to; this is usually the document passed to a business process by the
initiating adapter.
Sterling B2B Integrator uses a unique document ID to reference and track
documents as they flow through the application. The document ID is assigned
by Sterling B2B Integrator. The business process may reference a document by
the document name or the document ID, depending on the design of the
business process.

Scenario 2 - Submitting and Monitoring Your Sterling
Connect:Direct Process

Submit the Sterling Connect:Direct process and then monitor it with either Sterling
Connect:Direct or Sterling B2B Integrator.

Monitoring with Sterling Connect:Direct

You can use the Sterling Connect:Direct Select Statistics to monitor your Sterling
Connect:Direct to Sterling B2B Integrator processes.

If the Sterling Connect:Direct process is successful, the Select Statistics detail will
report the following:

Attribute Value

Message ID SCPA000I

Message Text Copy operation successful

Destination File /businessprocess/yourBusinessProcess/targetdocName

24 Sterling B2B Integrator: Interoperability with Sterling Connect:Direct



If the Sterling Connect:Direct process is not successful, refer to Troubleshooting.

Scenario 2 - Monitoring with Sterling B2B Integrator
You can use Sterling B2B Integrator to monitor your Sterling Connect:Direct to
Sterling B2B Integrator processes.

About this task

Use the following procedure to monitor your Sterling Connect:Direct process with
Sterling B2B Integrator:

Procedure
1. From the Business Process menu, select Monitor > Advanced Search > Business

Processes.
2. In the Search Using Business Process Name pane, select yourBusinessProcess in

the Business Processes list and click Go!.

The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful
execution

ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting.
3. Click the ID number to see details about the business process execution.
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The Business Process Detail page displays the following information:

Label Description

Step The business process step number

Service The Sterling B2B Integrator service name used in the step

Status The status of the step

Advanced Status Additional status information

Started The time and date the step started

Ended The time and date the step ended

Status Report A link to the status report for the step

Document A link to documents in use by the step

Instance Data A link to process data for the step

4. Click the Document info link for Step 1, GetDocumentInfo service.
The PrimaryDocument page displays the contents of the Primary Document,
targetdocName.

5. Close the PrimaryDocument page.
6. From the Business Process Detail page, click the Instance Data info link for Step

1, GetDocumentInfo service.
The Process Data page displays process data for the business process. The data
is presented in XML format as shown:
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<?xml version="1.0" encoding="UTF-8"?>
<ProcessData>

<PrimaryDocument SCIObjectID="oxnard:node1:11efefe9db6:26492407"/>
<CDServerNodeData>
<RemoteFileName>C:\source.txt</RemoteFileName>
<PnodeName>CDWIN</PnodeName>
<LocalFileName>/businessprocess/ReceiveFromCD/dest.txt</LocalFileName>
<SnodeName>SI51CD</SnodeName>

</CDServerNodeData>
<BodyName>dest.txt</BodyName>
<BodyLength>5</BodyLength>
<DocumentBodyLength>5</DocumentBodyLength>
<DocumentLength>5</DocumentLength>
<DocumentName>dest.txt</DocumentName>
<DocumentId>oxnard:node1:11efefe9db6:26492400</DocumentId>

...
</ProcessData>

In this example, the Get Document Information Service puts information about
the Primary Document, such as the BodyName and BodyLength, into process
data.

Note: You can also monitor your business processes from the Business Process
menu by navigating to Monitor > Advanced Search > Documents or Monitor >
Advanced Search > Communication Sessions.

Scenario 3 - Use Sterling Connect:Direct to Pull a File from Sterling
B2B Integrator

This scenario describes how to pull a file from a Sterling Connect:Direct Server
Adapter (SNODE) using the Sterling Connect:Direct node (PNODE). The Sterling
Connect:Direct node connects to the Sterling Connect:Direct Server Adapter which
invokes a business process. This business process passes a document back to the
Connect:Direct Server Adapter which sends the file back to the Sterling
Connect:Direct node.

Scenario 3 - Configuring a File System Adapter
Use the File System Adapter within a Sterling B2B Integrator business process to
collect a file from the Sterling B2B Integrator file system. Use the following
procedure to create the directory and file for the File System Adapter:
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Procedure
1. Create a collection directory on the Sterling B2B Integrator file system.
2. Create a source file in the collection directory.
3. Add the some text to the file so that you can verify that Sterling Connect:Direct

pulls the correct file.
4. Create an extraction directory on the Sterling B2B Integrator file system.

An extraction directory is required to configure a File System Adapter
configuration, but it is not used to extract files in this example.

Scenario 3 - Creating a Configuration of the File System
Adapter in Sterling B2B Integrator

Before you can use the File System Adapter in a business process, create a
configuration of the adapter in Sterling B2B Integrator. Use the following
procedure to configure a File System Adapter:

Procedure
1. Log in to Sterling B2B Integrator and navigate to Deployment > Services >

Configuration.
2. On the Services Configuration page, click Go! in the Create New Service pane.
3. In the Service Type box, type File System Adapter and click Next.

Field Value to Enter Description

Name Type a unique name for
the File System Adapter
service configuration.

Required.

Description Type a meaningful
description for the File
System Adapter service
configuration.

Required.

Collection
folder

Specify the collection
folder you created above.

The name of the folder or subfolder on the
same computer where Application is
installed and where it collects (or picks up)
files as part of a business process. If the path
of the folder is not included as part of the
name, the folder is assumed to be in the
Application working directory.

28 Sterling B2B Integrator: Interoperability with Sterling Connect:Direct



Field Value to Enter Description

Filename filter Specify the filter to match
the file you created in the
collection folder above.

Collect only files that match a specified filter
within the collection folder. Optional.

Examples include:

v *.txt (collects only .txt files)

v *.dat (collects only .dat files)

v EDI.* (collects only files named EDI with
any file extension)

v EDI.txt (collects only files named EDI
with a file extension of .txt)
Note: If there are multiple files in the
collection folder and you leave this field
blank, one of the following occurs:

v If the adapter is configured to start a
business process, it processes all files in
the collection folder.

v If the adapter is within a business process,
it collects only the first file in the folder.

Collect files
from subfolders
within and
including the
collection
folder?

Select No for this scenario
so that the File System
Adapter does not collect
files from subfolders of the
collection folder.

Whether to scan for files in subfolders of the
collection folder. Required.

Valid values:

Yes—Collects files in the specified folder and
all subfolders.

No—Collects files in the specified folder
only.

User absolute
file path name
for the
document
name?

Select No for this scenario
so that the document name
does not include the path
name.

Whether to keep the absolute path name of
the files collected when assigning the
document name. Required.

Valid values:

Yes—The absolute file path name is kept
with the document in the business process.
Choose this value if your business process
requires the path information to precede the
file name.

No—Only the file name is kept with the
document in the business process.

Start a business
process once
files are
collected?

Select No for this scenario.

Since you use the File
System Adapter within a
business process, there is
no need to start another
business process.

Whether to start a business process using
the File System adapter after files are
collected. Required.

Valid values:

Yes—Starts the business process specified
from the business process drop-down list.

No—No business process will be started.

Sterling Connect:Direct and Sterling B2B Integrator Interoperability 29



Field Value to Enter Description

Extraction
folder

Select No for this scenario.

The File System Adapter
collects a file, but does not
write (extract) a file in this
scenario.

The name of the folder or subfolder on the
same computer where Application is
installed and where it installs (or writes)
data from the primary document as part of a
business process. If you do not include the
file path for the folder as part of the name,
the folder is assumed to be in the
Application working directory. Required.

4. Click Finish to save the configuration.

Scenario 3 - Creating a Sterling B2B Integrator Business
Process

When you use Sterling Connect:Direct to pull a file from Sterling B2B Integrator,
you invoke a Sterling B2B Integrator business process. This business process
contains a Connect:Direct Server BP Response Service that sends the primary
document back to Sterling Connect:Direct.

About this task

In this example, the business process uses a File System adapter to collect a file
from the Sterling B2B Integrator file System. This file becomes the primary
document in the business process. The Connect:Direct Server BP Response Service
then sends the primary document to the Sterling Connect:Direct node via the
Connect:Direct Server Adapter.

Use the following procedure to create the Sterling B2B Integrator business process:

Procedure
1. Log in to Sterling B2B Integrator and launch the Graphical Process Modeler

from the Home screen.
2. Enter your Sterling B2B Integrator User ID and password in the Log In dialog

box.
3. If the BPML stencil is not visible in the GPM, navigate to the View menu and

select Stencil > BPML. This will add the BPML stencil to the GPM.
4. If the Sync Mode stencil is not visible in the GPM, navigate to the View menu

and select Stencil > Sync Mode.
This will add the Sync Mode stencil to the GPM.

5. From the View menu, select Stencil > Applications > Sterling Commerce >
Connect:Direct.
This will add the Connect:Direct stencil to the GPM. The Connect:Direct
stencil contains an icon you will need in your business processes.

6. From the File menu, select New to open a new business process.
7. Drag and drop the following icons from the BPML, Sync Mode, and

Connect:Direct stencils into the Business Process window in the following
order, from left to right:
v Start
v File System Adapter
v CD Server BP Response Service
v End
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8. To link the icons:
Click the arrow on the right side of the Start icon and drag it to the arrow on
the left side of the File System Adapter icon.
Click the arrow on the right side of the File System Adapter icon and drag it
to the arrow on the left side of the CD Server BP Response Service icon.
Click the arrow on the right side of the CD Server BP Response Service icon
and drag it to the arrow on the left side of the End icon.

9. Configure the File System Adapter using the following procedure:
Double-click the File System Adapter icon.
In the Service Editor-File System Adapter window, select your File System
Adapter configuration from the Config drop-down list. The Message To
Service tab is displayed.
In this step you specify the configuration that you created for the File System
Adapter. You can override configuration values in the Service Editor.
On the Message to Service tab, select Collection as the Value for Action.
This causes the File System Adapter to collect files from the collection folder.
Select No as the Value for deleteAfterCollect.
If deleteAfterCollect is set to Yes, the File System Adapter deletes the files in
the collection folder after it collects them. When you are testing this business
process, keep this value set to No so that you don't have to replace the source
file after each test run.
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10. Configure the CD Server BP Response Service using the following procedure:
Double-click the CD Server BP Response Service icon.
This opens the Service Editor window.
In the Service Editor-CD Server BP Response Service window, select
CDServerBPResponse from the Config drop-down list.
In this step you specify the pre-defined CDServerBPResponse configuration
for the CD Server BP Response Service. You can override configuration values
in the Service Editor.

11. From the File menu, select Save. In the Validate dialog box, click Yes to
validate the business process.

12. On the Save dialog box, type the name of your business process in the File
Name box and click Save.
Remember where you save this file.

Note: To see a sample business process, refer to Use Sterling Connect:Direct to
Retrieve a File from Sterling B2B Integrator.

Scenario 3 - Checking Your Business Process into Sterling
B2B Integrator

Use the following procedure to check the business process into Sterling B2B
Integrator:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Create Process Definition pane,

click Go!.
4. Type your business process name in the Name box.
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5. Under Select an input mode for defining the new process, select Check in
Business Process created by the graphical modeling tool and click Next.

6. On the Check-in page, click Browse and navigate to the business process file
that you saved in of the previous procedure.

7. Type a short description of the business process in the Description box and
click Next.

8. On the Process Levels page, select the Set onfault processing check box.
9. Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full and click Next.
11. On the Deadline Settings page, click Next.
12. On the Life Span page, click Next.
13. On the Confirm page, select the Enable Business Process box.
14. Select the Create Permission box.

This adds the business process to the list of Sterling B2B Integrator security
permissions. This makes it possible to assign permission for this business
process to the user account.

15. Click Finish.

Scenario 3 - Creating Your Sterling Connect:Direct Process
Create a Process for your Sterling Connect:Direct platform similar to the following
example.

About this task

PULLFILE PROCESS
SNODE=yourCDSANode
SNODEID=(yourUserID,yourPassword)
STEP1 COPY
FROM (
FILE=/businessprocess/yourBusinessProcess/yourSourceFile
SNODE
)
TO (
FILE=targetdocName
PNODE
DISP=RPL
)
PEND

This Sterling Connect:Direct process retrieves yourSourceFile from the Sterling
Connect:Direct Server Adapter which receives the file from your business process.
There are three parts to the FROM FILE name in the Copy step:

Results
v /businessprocess/ is a reserved word and signals to Sterling B2B Integrator that

you are invoking a business process.
v yourBusinessProcess is the name of the Sterling B2B Integrator business process

that the Connect:Direct Server Adapter invokes.
v targetdocName is the name of the document that is passed from the Sterling

Connect:Direct Server Adapter to your Sterling Connect:Direct node. This
document is the Primary Document in your business process.
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Scenario 3 - Submitting and Monitoring Your Sterling
Connect:Direct Process

Submit the Sterling Connect:Direct process and then monitor it with either Sterling
Connect:Direct or Sterling B2B Integrator.

Scenario 3 - Monitoring with Sterling Connect:Direct
You can use Sterling Connect:Direct Select Statistics to monitor your Sterling
Connect:Direct to Sterling B2B Integrator processes.

If the Sterling Connect:Direct process is successful, the Select Statistics detail will
report the following:

Attribute Value

Message ID SCPA000I

Message Text Copy operation successful

Source File /businessprocess/yourBusinessProcess/yourSourceFile

Destination File <default download directory>\targetdocName

If the Sterling Connect:Direct process is not successful, refer to Troubleshooting.

Scenario 3 - Monitoring with Sterling B2B Integrator
Use the following procedure to monitor your Sterling Connect:Direct process with
Sterling B2B Integrator:

About this task

Procedure
1. From the Business Process menu, select Monitor > Advanced Search > Business

Processes.
2. In the Search Using Business Process Name pane, select your business process

in the Business Processes list and click Go!.
The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful
execution

ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting.
3. Click the ID number to see details about the business process execution.

The Business Process Detail page displays the following information:

Label Description

Step The business process step number

Service The Sterling B2B Integrator service name used in the step

Status The status of the step

Advanced Status Additional status information
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Label Description

Started The time and date the step started

Ended The time and date the step ended

Status Report A link to the status report for the step

Document A link to documents in use by the step

Instance Data A link to process data for the step

4. Click the Document info link for the Connect:Direct Server Response Service.
The PrimaryDocument page displays the contents of the primary document.

5. Close the PrimaryDocument page.

Note: You can also monitor your business processes from the Business Process
menu by navigating to Monitor > Advanced Search > Documents or Monitor >
Advanced Search > Communication Sessions.

Scenario 4 - Use Sterling B2B Integrator to Copy a File to Sterling
Connect:Direct

This scenario describes how to copy a file from Sterling B2B Integrator to Sterling
Connect:Direct. The Sterling B2B Integrator business process passes a document to
the Connect:Direct Server Adapter (PNODE) which copies the file to the Sterling
Connect:Direct node (SNODE). The business process functions much like a Sterling
Connect:Direct process.

Scenario 4 - Creating a Sterling B2B Integrator Business
Process

When you use Sterling B2B Integrator to copy a file to Sterling Connect:Direct, you
execute a Sterling B2B Integrator business process that contains Connect:Direct
Server Adapter services to send the primary document to Sterling Connect:Direct.

About this task

Use the following procedure to create the Sterling B2B Integrator business process:

Procedure
1. Log in to Sterling B2B Integrator and launch the Graphical Process Modeler

from the Home screen.
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2. Enter your Sterling B2B Integrator User ID and password in the Log In dialog
box.

3. If the BPML stencil is not visible in the GPM, navigate to the View menu and
select Stencil > BPML.
This will add the BPML stencil to the GPM.

4. From the View menu, select Stencil > Applications > Sterling Commerce >
Connect:Direct.
This will add the Connect:Direct stencil to the GPM.

5. From the File menu, select New to open a new business process.
6. Drag and drop the following icons from the BPML and Connect:Direct stencils

into the Business Process window in the following order, from left to right:
v Start
v CD Server Begin Session Service
v CD Server CopyTo Service
v CD Server End Session Service
v End

7. To link the icons:
v Click the arrow on the right side of the Start icon and drag it to the arrow

on the left side of the CD Server Begin Session Service icon.
v Click the arrow on the right side of the CD Server Begin Session Service

icon and drag it to the arrow on the left side of the CD Server CopyTo
Service icon.

v Click the arrow on the right side of the CD Server CopyTo Service icon and
drag it to the arrow on the left side of the CD Server End Session Service
icon.

v Click the arrow on the right side of the CD Server End Session Service icon
and drag it to the arrow on the left side of the End icon.

8. Configure the CD Server Begin Session Service using the following procedure:
v Double-click the CD Server Begin Session Service icon.
v The Connect:Direct Server Begin Session Service functions like the Sterling

Connect:Direct Process statement. It initiates a session on a specified remote
Sterling Connect:Direct node.

v In the Service Editor-CD Server Begin Session Service window, select
CDServerBeginSession from the Config drop-down list. The Message To
Service tab is displayed.

v In this step you specify the pre-defined CDServerBeginSession configuration
for the CD Server Begin Session Service. You can override configuration
values in the Service Editor.

v Select your Connect:Direct Server Adapter node name as the Value for
LocalCDNodeName.
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v Type the remote Sterling Connect:Direct node name as the Value for
RemoteCDNodeName.

v Type the Sterling Connect:Direct User ID as the Value for RemoteUserId.

Note: You must add the Sterling Connect:Direct User ID to your Sterling
Connect:Direct User Authorities.
v Type the password for the Sterling Connect:Direct User ID as the Value for

RemotePasswd.
v Select No as the Value for UsingObscuredPasswd.

9. Click the Message From Service tab.
10. Select Allow message write for Input Msg.
11. Click Add and add the following information to the new record:

v In the Name box, type BeginSessionResults.
v In the Value field, type *.
v Select the Use XPATH? check box.
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12. Configure the CD Server CopyTo Service using the following procedure:
v Double-click the CD Server CopyTo Service icon. This opens the Service

Editor window.
v The Connect:Direct Server CopyTo Service functions like the Sterling

Connect:Direct Copy statement. It copies a file from the PNODE to the
SNODE.

v In the Service Editor-CD Server CopyTo Service window, select
CDServerCopyTo from the Config drop-down list.

v In this step you specify the pre-defined CDServerCopyTo configuration to
use for the CD Server CopyTo Service. You can override configuration
values in the Service Editor.

Note: To see all parameters available in the CopyTo service, see Settings for
Connect:Direct Server CopyTo Service .
v Type rpl as the Value for RemoteDISP.
v This is equivalent to DISP=RPL in a Sterling Connect:Direct Copy

statement.
v Type the destination file name as the Value for RemoteFileName.
v Type //BeginSessionResults/SessionToken/node() as the Value for

SessionToken and select the Use XPATH? box.
v The Session Token is created by the CD Server Begin Session Service and

identifies the session that is established with the remote Sterling
Connect:Direct node. The SessionToken value in the CD Server CopyTo
Service ensures that this service copies the file using the session initiated by
the CD Server Begin Session Service.

13. Configure the CD Server End Session Service using the following procedure:
v Double-click the CD Server End Session Service icon.

The Connect:Direct Server End Session Service functions like the Sterling
Connect:Direct End statement. It terminates the session with the remote
Sterling Connect:Direct node. If the Connect:Direct Server End Session does
not execute, the session remains open.
v In the Service Editor-CD Server End Session Service window, select

CDServerEndSession from the Config drop-down list.
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In this step you specify the pre-defined CDServerEndSession configuration to
use for the CD Server End Session Service. You can override configuration
values in the Service Editor.
Type //BeginSessionResults/SessionToken/node() as the Value for
SessionToken and select the Use XPATH? box.
The SessionToken value in the CD Server End Session Service ensures that this
service closes the session initiated by the Connect:Direct Server Begin Session
Service.

14. From the File menu, select Save. In the Validate dialog box, click Yes to
validate the business process.

15. On the Save dialog box, type your business process file name in the File
Name box and click Save.
Remember where you save this file.

Note: Sample Business Processes on the Sterling B2B Integrator Side, contains
examples involving the basic scenario of copying a file to a remote Sterling
Connect:Direct server from Sterling B2B Integrator.

Scenario 4 - Checking Your Business Process into Sterling
B2B Integrator

Use the following procedure to check your business process into Sterling B2B
Integrator:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Create Process Definition pane,

click Go!.
4. Type your business process name in the Name box.
5. Under Select an input mode for defining the new process, select Check in

Business Process created by the graphical modeling tool and click Next.
6. On the Check-in page, click Browse and navigate to your business process file

that you saved in step 15 of the previous procedure.
7. Type a short description of your business process in the Description box and

click Next.
8. On the Process Levels page, select the Set onfault processing check box.
9. Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full.
11. Set the Recovery Level to Auto Resume and click Next.

If Sterling B2B Integrator stops responding during a copy transaction and the
recovery level is set to Auto Resume, the business process resumes
automatically at the next Sterling B2B Integrator start up.

12. On the Deadline Settings page, click Next.
13. On the Life Span page, click Next.
14. On the Confirm page, select the Enable Business Process box.
15. Click Finish.
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Scenario 4 - Submitting Your Sterling B2B Integrator Business
Process

Use the following procedure to submit your Sterling B2B Integrator business
process:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. In the Search pane, type your business process name in the Process Name box

and click Go!.
4. On the Business Process Manager page, click Execution Manager.
5. On the Execution Manager page, click Execute to launch the Execute Business

Process Input dialog box.
6. Click Browse and navigate to your source file on your local system and click

Open.
This is the file that the business process will copy to the Sterling Connect:Direct
server.

7. Click Go! to submit the business process.
The Execute Business Process page is displayed.

8. Close the Execute Business Process page.

Scenario 4 - Monitoring with Sterling B2B Integrator
Use the following procedure to monitor your business process with Sterling B2B
Integrator:
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Procedure
1. From the Business Process menu, select Monitor > Advanced Search > Business

Processes.
2. In the Search Using Business Process Name pane, select your business process

name in the Business Processes list and click Go!.
The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful
execution

ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting.
3. Click the ID number to see details about the business process execution.

The Business Process Detail page displays the following information for each
step:

Label Description

Step The business process step number

Service The Sterling B2B Integrator service name used in the step

Status The status of the step

Advanced Status Additional status information

Started The time and date the step started

Ended The time and date the step ended

Status Report A link to the status report for the step

Document A link to documents in use by the step

Instance Data A link to process data for the step

4. Click the Status Report link for the Connect:Direct Server Primitive CopyTo
Service.
The Status Report displays a short summary of the CopyTo operation including
the destination file name and number of bytes copied.

5. Click the Document info link for the Connect:Direct Server Primitive CopyTo
Service.
The PrimaryDocument page displays the contents of the Primary Document.

6. Close the PrimaryDocument page.
7. From the Business Process Detail page, click the Instance Data info link for the

Connect:Direct Server Primitive CopyTo Service.
The Process Data page displays process data for the business process. The data
is presented in XML format and contains several fields and values, such as:
v Remote Node—node name of the remote Sterling Connect:Direct server
v Remote User—Sterling Connect:Direct User ID
v Remote File Name—your destination file
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8. The last step in the Business process Detail page is the CD Server End Session
Service. The Status indicates that it successfully terminates the Sterling
Connect:Direct session.

Note: You can also monitor your business processes from the Business
Processes menu by navigating to Monitor > Advanced Search > Documents or
Monitor > Advanced Search > Communication Sessions.

Scenario 4 - Monitoring with Sterling Connect:Direct
You can use the Sterling Connect:Direct Select Statistics to monitor your Sterling
B2B Integrator to Sterling Connect:Direct business process.

Before you begin

If the Sterling Connect:Direct process is successful, the Select Statistics detail will
report the following:

Attribute Value

Message ID SCPA000I

Message Text Copy operation successful

Destination File <default download directory>\<your destination file>

If the Sterling Connect:Direct process is not successful, refer to Troubleshooting.

Scenario 5 - Use Sterling B2B Integrator to Copy a File from Sterling
Connect:Direct

This scenario describes how to use Sterling B2B Integrator to copy a file from
Sterling Connect:Direct. The Sterling B2B Integrator business process invokes the
Connect:Direct Server Adapter (PNODE) which copies the file from the Sterling
Connect:Direct node (SNODE) and passes it back to the business process. The
business process functions much like a Sterling Connect:Direct process.

Scenario 5 - Creating a Sterling B2B Integrator Business
Process

When you use Sterling B2B Integrator to copy a file from Sterling Connect:Direct,
you execute a Sterling B2B Integrator business process that contains Connect:Direct
Server Adapter services to copy the file from Sterling Connect:Direct.

42 Sterling B2B Integrator: Interoperability with Sterling Connect:Direct



About this task

Use the following procedure to create the Sterling B2B Integrator business process:

Procedure
1. Log in to Sterling B2B Integrator and launch the Graphical Process Modeler

from the Home screen.
2. Enter your Sterling B2B Integrator User ID and password in the Log In dialog

box.
3. If the BPML stencil is not visible in the GPM, navigate to the View menu and

select Stencil > BPML.
This will add the BPML stencil to the GPM.

4. From the View menu, select Stencil > Applications > Sterling Commerce >
Connect:Direct.
This will add the Connect:Direct stencil to the GPM.

5. From the File menu, select New to open a new business process.
6. Drag and drop the following icons from the BPML and Connect:Direct stencils

into the Business Process window in the following order, from left to right:
v Start
v CD Server Begin Session Service
v CD Server CopyFrom Service
v CD Server End Session Service
v End

7. To link the icons:
Click the arrow on the right side of the Start icon and drag it to the arrow on
the left side of the CD Server Begin Session Service icon.
Click the arrow on the right side of the CD Server Begin Session Service icon
and drag it to the arrow on the left side of the CD Server CopyFrom Service
icon.
Click the arrow on the right side of the CD Server CopyFrom Service icon and
drag it to the arrow on the left side of the CD Server End Session Service icon.
Click the arrow on the right side of the CD Server End Session Service icon
and drag it to the arrow on the left side of the End icon.

8. Configure the Connect:Direct Server Begin Session Service using the following
procedure:
v Double-click the CD Server Begin Session Service icon. The Connect:Direct

Server Begin Session Service functions like the Sterling Connect:Direct
Process statement. It initiates a session on a specified remote Sterling
Connect:Direct node.

v In the Service Editor-CD Server Begin Session Service window, select
CDServerBeginSession from the Config drop-down list. The Message To
Service tab is displayed. In this step specify the pre-defined
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CDServerBeginSession configuration for the CD Server Begin Session
Service. You can override configuration values in the Service Editor.

Note: To see all parameters available in the CopyFrom service, see Settings
for Connect:Direct Server CopyFrom Service .

v Select your Connect:Direct Server Adapter node name as the Value for
LocalCDNodeName.

v Type the remote Sterling Connect:Direct node name as the Value for
RemoteCDNodeName.

v Type the Sterling Connect:Direct User ID as the Value for RemoteUserId.
v To add the Sterling Connect:Direct User ID to your Sterling Connect:Direct

User Authorities, type the password for the Sterling Connect:Direct User ID
as the Value for RemotePasswd. Select No as the Value for
UsingObscuredPasswd.

9. Click the Message From Service tab.
10. Select Allow message write for Input Msg.
11. Click Add and add the following information to the new record:

v In the Name box, type BeginSessionResults.
v In the Value field, type *.
v Select the Use XPATH? check box.
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12. Configure the CD Server CopyFrom Service using the following procedure:
Double-click the CD Server CopyFrom Service icon. This opens the Service
Editor window.
The Connect:Direct Server CopyFrom Service functions like the Sterling
Connect:Direct Copy statement. It copies a file from the SNODE to the
PNODE.
In the Service Editor-CD Server CopyFrom Service window, select
CDServerCopyFrom from the Config drop-down list.
In this step you specify the pre-defined CDServerCopyFrom configuration to
use for the CD Server CopyFrom Service. You can override configuration
values in the Service Editor.
Type the source file name as the Value for RemoteFileName.
This file must reside on the file system of the Sterling Connect:Direct node.
Type //BeginSessionResults/SessionToken/node() as the Value for
SessionToken and select the Use XPATH? box.
The Session Token is created by the CD Server Begin Session Service and
identifies the session that is established with the remote Sterling
Connect:Direct node. The SessionToken value in the CD Server CopyFrom
Service ensures that this service copies the file using the session initiated by
the CD Server Begin Session Service.

13. Configure the CD Server End Session Service using the following procedure:
Double-click the CD Server End Session Service icon.
The CD Server End Session Service functions like the Sterling Connect:Direct
Pend statement used on the Microsoft Windows and UNIX platforms. It
terminates the session with the remote Sterling Connect:Direct node. If the CD
Server End Session does not execute, the session remains open.
In the Service Editor-CD Server End Session Service window, select
CDServerEndSession from the Config drop-down list.
In this step you specify the pre-defined CDServerEndSession configuration to
use for the CD Server End Session Service. You can override configuration
values in the Service Editor.
Type //BeginSessionResults/SessionToken/node() as the Value for
SessionToken and select the Use XPATH? box.
The SessionToken value in the CD Server End Session Service ensures that this
service closes the session initiated by the CD Server Begin Session Service.
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14. From the File menu, select Save. In the Validate dialog box, click Yes to
validate the business process.

15. On the Save dialog box, type your business process file name in the File
Name box and click Save.
Remember where you save this file.

Note: To see a sample business process, refer to Use Sterling B2B Integrator to
Copy a File from Sterling Connect:Direct .

Scenario 5 - CheckingYour Business Process into Sterling
B2B Integrator

Use the following procedure to check your business process into Sterling B2B
Integrator:

About this task

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Create Process Definition pane,

click Go!.
4. Type your business process name in the Name box.
5. Under Select an input mode for defining the new process, select Check in

Business Process created by the graphical modeling tool and click Next.
6. On the Check-in page, click Browse and navigate to your business process file

that you saved in step 15 of the previous procedure.
7. Type a short description of your business process in the Description box and

click Next.
8. On the Process Levels page, select the Set onfault processing check box.
9. Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full.
11. Set the Recovery Level to Auto Resume and click Next.

If Sterling B2B Integrator stops responding during a copy transaction and the
recovery level is set to Auto Resume, the business process resumes
automatically at the next Sterling B2B Integrator start up.

12. On the Deadline Settings page, click Next.
13. On the Life Span page, click Next.
14. On the Confirm page, select the Enable Business Process box.
15. Click Finish.

Scenario 5 - Submitting Your Sterling B2B Integrator Business
Process

Use the following procedure to submit your Sterling B2B Integrator business
process:
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About this task

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. In the Search pane, type your business process name in the Process Name box

and click Go!.
4. On the Business Process Manager page, click Execution Manager.
5. On the Execution Manager page, click Execute to launch the Execute Business

Process Input dialog box.
6. Click Go! to submit the business process.

The Execute Business Process page is displayed.
7. Close the Execute Business Process page.

Scenario 5 - Monitoring with Sterling B2B Integrator
Use the following procedure to monitor your business process with Sterling B2B
Integrator:

Procedure
1. From the Business Process menu, select Monitor > Advanced Search > Business

Processes.
2. In the Search Using Business Process Name pane, select your business process

name in the Business Processes list and click Go!.
The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful
execution

ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting.
3. Click the ID number to see details about the business process execution.

The Business Process Detail page displays the following information for each
step:

Label Description

Step The business process step number

Service The Sterling B2B Integrator service name used in the step

Status The status of the step

Advanced Status Additional status information

Started The time and date the step started

Ended The time and date the step ended

Status Report A link to the status report for the step

Document A link to documents in use by the step

Instance Data A link to process data for the step
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4. Click the Status Report link for the Connect:Direct Server Primitive CopyFrom
Service.
The Status Report displays a short summary of the CopyFrom operation
including the source file name and number of bytes copied.

5. Click the Document info link for the Connect:Direct Server Primitive CopyFrom
Service.
The PrimaryDocument page displays the contents of the Primary Document.

6. Close the PrimaryDocument page.
7. From the Business Process Detail page, click the Instance Data info link for the

Connect:Direct Server Primitive CopyFrom Service.
The Process Data page displays process data for the business process. The data
is presented in XML format and contains several fields and values, such as:
v Remote Node—node name of the remote Sterling Connect:Direct server
v Remote User—Sterling Connect:Direct User ID
v Remote File Name—your source file

8. The last step in the Business process Detail page is the CD Server End Session
Service. The Status indicates that it successfully terminates the Sterling
Connect:Direct session.

Note: You can also monitor your business processes from the Business
Processes menu by navigating to Monitor > Advanced Search > Documents or
Monitor > Advanced Search > Communication Sessions.

Scenario 5 - Monitoring with Sterling Connect:Direct
You can use the Sterling Connect:Direct Select Statistics to monitor your Sterling
B2B Integrator to Sterling Connect:Direct business process.

If the Sterling Connect:Direct process is successful, the Select Statistics detail will
report the following:

Attribute Value

Message ID SCPA000I

Message Text Copy operation successful

Source File <default upload directory>\<your source file>

If the Sterling Connect:Direct process is not successful, refer to Troubleshooting.

Scenario 6 - Add Error Handling to a Sterling B2B Integrator Business
Process

This scenario describes how to add error handling to an existing Sterling B2B
Integrator business process. The business process passes a document to the
Connect:Direct Server Adapter (PNODE) which copies the file to the Sterling
Connect:Direct node (SNODE). The error handling ensures that the Sterling
Connect:Direct session closes if an error is encountered during the session.

You can add OnFault Groups to your business processes to capture specific errors
and take appropriate actions in the business process based on those errors. OnFault
Groups allow you to add business process logic to handle specific and general
error conditions. If you do not use OnFault Groups, your business process will quit
on the step where the error occurs with no error handling.

48 Sterling B2B Integrator: Interoperability with Sterling Connect:Direct



Scenario 6 - Business Process Version Management
Sterling B2B Integrator uses version management for implementing business
process. As you make changes to an existing business process and create variations
of that business process, you need to be sure that the business process that runs is
the appropriate version.

The first time you check in a business process, the data you enter creates a
business process definition—a uniquely named copy of the process that is stored in
Sterling B2B Integrator. The business process stored in Sterling B2B Integrator is
independent of any .bp file of the process that you save in a local directory.

At any time, you can open an existing business process, modify and save it, and
then either check in the new version to Sterling B2B Integrator, or save the
modified copy of the process in Sterling B2B Integrator as a new process
altogether. All previously checked-in versions of business processes continue to be
stored in Sterling B2B Integrator. This enables you to revert to using an older
version should the need arise.

Scenario 6 - Checking Out the Business Process
When you check out an existing business process with the Source Manager, you
lock the business process and prevent other users from modifying it at the same
time.

About this task

Use the following procedure to check out your existing business process that
copies a file from Sterling B2B Integrator to Sterling Connect:Direct:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Search pane, type the existing

business process name in the Process Name box and click Go.
4. Click Source Manager for your business process.
5. On the Source Manager page, click check out for the version of the business

process you want to check out.
6. Click OK in the dialog box to lock the file for editing.
7. In the File Download dialog box, click Save to save a copy of the business

process to your local file system.
8. In the Save As dialog box, navigate to the directory where you want to save the

business process, type the business process file name in the File name box, and
click Save.

Scenario 6 - Editing the Business Process
In this scenario, you add an OnFault Group to handle errors in your business
process.

About this task

Use the following procedure to edit the Sterling B2B Integrator business process:
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Procedure
1. Log in to Sterling B2B Integrator and launch the Graphical Process Modeler

from the Home screen.
2. Enter your Sterling B2B Integrator User ID and password in the Log In dialog

box.
3. If the BPML stencil is not visible in the GPM, navigate to the View menu and

select Stencil > BPML.
This will add the BPML stencil to the GPM.

4. If the Connect:Direct stencil is not visible in the GPM, navigate to the View
menu and select Stencil > Applications > Sterling Commerce > Connect:Direct.
This will add the Connect:Direct stencil to the GPM.

5. From the File menu, select Open, navigate to the existing business process file
and click Open.

6. Drag and drop the following icons from the BPML stencil into the Business
Process window:
v Sequence Start
v OnFault Group
v Sequence End

7. To arrange and link the icons:
Click the link between the CD Server Begin Session Service icon and CD
Server CopyTo Service icon and press Delete to remove the link.
Place the Sequence Start icon between the CD Server Begin Session Service
icon and the CD Server CopyTo Service icon.
Click the arrow on the right side of the CD Server Begin Session Service icon
and drag it to the arrow on the left side of the Sequence Start icon.
Click the arrow on the right side of the Sequence Start icon and drag it to the
arrow on the left side of the CD Server CopyTo Service icon.
Click the link between the CD Server End Session Service icon and End icon
and press Delete to remove the link.
Place the Sequence End icon between the CD Server End Session Service icon
and the End icon.
Click the arrow on the right side of the End Sequence icon and drag it to the
arrow on the left side of the End icon.
Place the OnFault Group icon below and to the right of the Begin Sequence
icon.
Click the arrow on the right side of the Begin Sequence icon and drag it to the
arrow on the left side of the OnFault Group.

8. Configure the OnFault Group using the following procedure:
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v Double-click the OnFault Group icon. This opens the Property Editor
window and Layers window.
The OnFault element contains a fault handling activity. If an error occurs
between the Sequence Start and Sequence End, the fault handling activity is
invoked. In this example, the fault handling activity contains a CD Server
End Session Service to ensure that the session ends if there is an error. If the
OnFault Group is not included in this business process and an error occurs
on the CD Server CopyTo Service, the business process would stop before
the CD Server End Service and the session would stay active.

v In the Layers Window, click the Default icon to open the fault handling
activity in the business process window.
The business process window contains an OnFault Start icon and an
OnFault End icon.

v Drag and drop the CD Server End Session icon from the Connect:Direct
stencil into the Business Process window and place it between the OnFault
Start icon and the OnFault End icon.

v Click the arrow on the right side of the OnFault Start icon and drag it to
the arrow on the left side of the CD Server End Session Service icon.

v Click the arrow on the right side of the CD Server End Session Service icon
and drag it to the arrow on the left side of the OnFault End icon.

Double-click the CD Server End Session Service icon.
In the Service Editor-CD Server End Session Service window, select
CDServerEndSession from the Config drop-down list.
In this step you specify the pre-defined CDServerEndSession configuration to
use for the CD Server End Session Service. You can override configuration
values in the Service Editor.
Type //BeginSessionResults/SessionToken/node() as the Value for
SessionToken and select the Use XPATH? box.
The SessionToken value in the CD Server End Session Service ensures that this
service closes the session initiated by the CD Server Begin Session Service.

9. From the File menu, select Save. In the Validate dialog box, click Yes to
validate the business process.

10. On the Save dialog box, type your business process file name in the File
Name box and click Save. Remember where you save this file.

Note: To see a sample business process, refer to Add Error Handling to the
Business Process.

Scenario 6 - Checking In Your Business Process
Use the following procedure to check the revised business process into Sterling
B2B Integrator:
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Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Search pane, type your business

process name in the Process Name box and click Go!.
4. Click Source Manager for your business process.
5. On the Source Manager page, select Go! to Check in an updated definition for

this business process.
6. On the Process Definition Check-in page, click Browse and navigate to the

business process file that you saved in step 10 of the previous procedure.
7. Type a short description of the business process changes in the Description

box and click Next.
8. On the Process Levels page, select the Set onfault processing check box.
9. Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full.
11. Set the Recovery Level to Auto Resume and click Next.

If Sterling B2B Integrator stops responding during a copy transaction and the
recovery level is set to Auto Resume, the business process resumes
automatically at the next Sterling B2B Integrator start up.

12. On the Deadline Settings page, click Next.
13. On the Life Span page, click Next.
14. On the Set Default Version page, select the updated version of the business

process.
15. On the Confirm page, select the Enable Business Process box.
16. Click Finish.

Scenario 6 - Submitting the Business Process
Submit and monitor your revised Sterling business process to verify that it still
works. The OnFault Group should not execute and the execution results should be
the same as they were before you modified the business process.

About this task

In order to test the OnFault logic, you must cause the CD Server CopyTo Service to
fail.

Use the following procedure to test the revised business process OnFault logic:

Procedure
1. Modify the Sterling Connect:Direct User ID in Sterling Connect:Direct. In the

Functional Authorities, set the Download directory for the account to a
nonexistent directory.

2. Submit the revised business process.
v The CD Server CopyTo Service fails and the business process executes the

OnFault logic.
v The CD Server End Session Service contained in the fault handling logic ends

the Sterling Connect:Direct session.
Log in to Sterling B2B Integrator.
From the Business Process menu, select Manager.

52 Sterling B2B Integrator: Interoperability with Sterling Connect:Direct



In the Search pane, type your business process name in the Process Name
box and click Go!.
On the Business Process Manager page, click Execution Manager.
On the Execution Manager page, click Execute for the revised business
process to launch the Execute Business Process Input dialog box.
Click Browse and navigate to your source file on your local system and click
Open.

Click Go! to submit your business process. The Execute Business Process
page is displayed.
Close the Execute Business Process page.

Scenario 6 - Monitoring with Sterling B2B Integrator
Use the following procedure to monitor your business process with Sterling B2B
Integrator:

About this task

Procedure
1. From the Business Process menu, select Monitor > Advanced Search > Business

Processes.
2. In the Search Using Business Process Name pane, select your business process

name in the Business Processes list and click Go!.
The Monitor page displays the following information:
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Label Description

Status Status of the business process—a green traffic light signals a successful
execution

ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting.
3. Click the ID number to see details about the business process execution.

The Business Process Detail page displays the following information for each
step:

Label Description

Step The business process step number

Service The Sterling B2B Integrator service name used in the step

Status The status of the step

Advanced Status Additional status information

Started The time and date the step started

Ended The time and date the step ended

Status Report A link to the status report for the step

Document A link to documents in use by the step

Instance Data A link to process data for the step

4. Check the Status and Advanced Status for the Connect:Direct Server CopyTo
Service.
The Connect:Direct Server CopyTo service generates an error and reports Check
the file permissions or path on Remote Connect:Direct.
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5. The next step in the Business Process Detail is the Decision Engine Service.
This step is invoked by the error handling of the OnFault Group in the
business process. The Status for this step indicates that the Decision Engine
Service is successfully able to invoke the OnFault error handling.

6. The last step in the Business Process Detail is the Connect:Direct Server End
Session Service.
The Status for this step indicates that it successfully closes the Sterling
Connect:Direct session.

Note: You can also monitor your business processes from the Business
Processes menu by navigating to Monitor > Advanced Search > Documents or
Monitor > Advanced Search > Communication Sessions.

Scenario 6 - Monitoring with Sterling Connect:Direct
You can use the Sterling Connect:Direct Select Statistics to monitor your revised
Sterling B2B Integrator to Sterling Connect:Direct business process.

If the Sterling Connect:Direct process is unsuccessful, the Select Statistics detail will
report the error, such as the one shown for a Microsoft Windows system:

Attribute Value

Message ID LSFN001 (if Sterling Connect:Direct is installed on a Microsoft Windows
system)

Message Text Unable to open file <your destination file> - Fdbk=3

Destination File <revised download directory>\<your destination file>
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If the Sterling Connect:Direct process is not successful, refer to Troubleshooting.

Scenario 7 - Add Sterling Connect:Direct Secure Plus
IBM Sterling Connect:Direct Secure Plus provides enhanced security for Sterling
Connect:Direct and Sterling Connect:Direct Server Adapter. When you enable
Sterling Connect:Direct Secure Plus, the files are encrypted during transfer. This
scenario describes how to configure the Sterling Connect:Direct Server Adapter to
work with Sterling Connect:Direct Secure Plus to enable encrypted file transfers.

Sterling Connect:Direct Secure Plus is an optional component. Before configuring
the Connect:Direct Server Adapter to work with Sterling Connect:Direct Secure
Plus, it is assumed the following conditions are already in place:
v You have the required certificates for implementing Sterling Connect:Direct

Secure Plus.

Note: You can use the IBM® Sterling Certificate Wizard to generate certificate
signing requests, self-signed certificates, key certificate files and certificate chains.
The online help in the Sterling Certificate Wizard product will step you through
the process.
v You have configured the local and remote nodes for Sterling Connect:Direct

Secure Plus following the instructions specific to the platform you are using.
After submitting the parameters file and preparing Sterling Connect:Direct for
operation, you have validated and tested connections between you and your
business partners to establish secure communications and then tested to make
sure you can change your security defaults for a session.

Scenario 7 - Checking In the Sterling Connect:Direct Root CA
Certificate

Use the following procedure to check in the Sterling Connect:Direct root CA
certificate with Sterling B2B Integrator:

About this task

Procedure
1. From the Trading Partner menu, select Digital Certificates > CA.
2. In the Check in New Certificate pane, click Go!.
3. On the Get Certificate page, click Browse and navigate to the Sterling

Connect:Direct CA root certificate.
4. On the Choose File dialog box, click Open. The dialog box closes and returns

you to the Get Certificate page.
5. Click Next to advance to the Naming page.
6. Make a note of the Certificate Name and click Next.
7. On the Confirm page, click Finish.

Scenario 7 - Checking In the Key File Certificate
Use the following procedure to check in the Key Certificate file for your
Connect:Direct Server Adapter:
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About this task

Note: You can use a self-signed certificate that you create in Sterling B2B
Integrator or Sterling Certificate Wizard as your system certificate for testing
purposes. Self-signed certificates are not recommended for production use.

Procedure
1. From the Trading Partner menu, select Digital Certificates > System.
2. In the Check in pane, click Go! for Key Certificate.
3. On the Key Certificate Data page, type a descriptive name in the Certificate

Name box.
4. In the Private Key Password box, type the passphrase associated with the

Sterling Connect:Direct Server Adapter private key.
You created this passphrase when you generated your CSR.

5. Click Browse and navigate to the private key file.
6. On the Choose File dialog box, click Open. The dialog box closes and you

return to the Key Certificate Data page.
7. Click Next to advance to the Validate When Used page.
8. Click Next to advance to the Confirm Page.
9. Click Finish.

Note: If you plan to configure different Sterling Connect:Direct Secure Plus
settings for individual nodes, you might need to check in additional CA
certificates and Key Certificate files.

Scenario 7 - Modifying the Connect:Direct Server Adapter
Configuration to Use Sterling Connect:Direct Secure Plus
(V5.2 - 5.2.5)

Use the following procedure to modify a Connect:Direct Server Adapter in Sterling
B2B Integrator to enable it to use Sterling Connect:Direct Secure Plus:

About this task

Procedure
1. From the Deployment menu, select Services > Configuration.
2. To select an existing Connect:Direct Server Adapter, use the Search or List pane

to display and select the adapter, and click Go!.
3. Select edit on the Services Configuration page and then click Next until you see

Encryption page.
4. Configure the following fields for this scenario.

Results

Field Value to Enter Description

Encryption using
Secure+

Enabled. Whether Sterling Connect:Direct Secure Plus is
enabled. Required. Valid values are Enabled
and Disabled. Default is Disabled.
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Field Value to Enter Description

Enable Netmap
Node Override

Select Yes for this
scenario. Configure
Sterling Connect:Direct
Secure Plus at the
adapter level and allow
node level settings to
override the adapter
Sterling Connect:Direct
Secure Plus settings.

If Yes, specifies that remote node netmap
security settings override the adapter security
settings. Required. Valid values are Yes and
No. Default is No.

CA Certificates Select the CA certificate
you checked in above.

This is the CA root
certificate for the
Sterling Connect:Direct
server.

Drop-down menu that contains a list of trusted
Certificate Authority public certificates. Only
displayed if "Encryption using Secure+" is
enabled. Required if Encryption using Secure+
is enabled. Valid values are all CA certificates
in this installation of your application.

System
Certificate

Select the System
certificate you checked
in above.

This is the certificate
for the Connect:Direct
Server Adapter node.

List of private keys and public certificates
signed by the trading partner trusted
certificate authority. This represents the
certificate for the local node (this adapter).
Only displayed if Encryption using Secure+ is
enabled. Required if Encryption using Secure+
is enabled. Valid values are all system
certificates in this installation of your
application.

Certificate
Common Name

If you want to verify
the Common Name of
the Sterling
Connect:Direct CA
certificate, specify it
here.

This feature is only
available if you use
signed certificates.

Coordinate this with
the remote Sterling
Connect:Direct
administrator.

Value to be compared with the Common
Name (CN) field from the remote node's
certificate during TLS/SSL handshake in order
to enhance certificate authentication. Only
displayed if Encryption using Secure+ is
enabled. May be overridden at the node level.

Note: To see the actual CNs being compared
during the handshake, set the Perimeter
Services logging level to ALL.

Cipher Suites Select which cipher
suites you wish to use.

Coordinate this list
with the remote
Sterling Connect:Direct
administrator.

Best practice is to list
cipher suites in
strongest to weakest
order.

Indicates cipher suites available to support
varying encryption levels. Multiple selections
allowed. Selections can be rank ordered. Only
displayed if "Encryption using Secure+" is
enabled. Required if "Encryption using
Secure+" is enabled. Valid values are all
available cipher suites in this installation of
your application.
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Field Value to Enter Description

SSL or TLS Select SSL or TLS.

Coordinate this choice
with the remote
Sterling Connect:Direct
administrator.

Indicates if Sterling Connect:Direct Secure Plus
is enabled using SSL or TLS. Only displayed if
"Encryption using Secure+" is enabled.
Required if "Encryption using Secure+" is
enabled. Valid values are SSL and TLS. Default
is TLS.

Require Client
Authentication

Select Yes or No for
client authentication.

Coordinate this choice
with the Sterling
Connect:Direct
administrator.

Indicates whether authentication occurs at the
client level. Valid values are:

Yes

No

Scenario 7 - Modifying the Netmap Node Configuration to
Override Sterling Connect:Direct Secure Plus Configuration
(Optional) (V5.2 - 5.2.5)

At this point, Sterling Connect:Direct Secure Plus is configured for the
Connect:Direct Server Adapter at the adapter level. All remote nodes will use these
Sterling Connect:Direct Secure Plus settings. If you want to override any or all of
the adapter level Sterling Connect:Direct Secure Plus settings for a remote node,
modify the Sterling Connect:Direct Secure Plus node settings for that node using
the following procedure:

About this task

Note: You must select Enable Netmap Node Override for the Connect:Direct
Server Adapter to use this option.

Procedure
1. From the Deployment menu, select Adapter Utilities > C:D Netmaps > C:D

Nodes.
2. To select an existing Connect:Direct Node, use the Search or List pane to

display and select the Node, and click Go!.
3. Select edit next to the node name on the C:D Nodes page.
4. Do one of the following:
v To disable Sterling Connect:Direct Secure Plus encryption for this node, select

the Secure+ Option Disabled button.
v To modify Sterling Connect:Direct Secure Plus encryption for this node, select

the Secure+ Option Enabled button, and click Next. Edit the fields you want
to override using information in the following table:

Field Value to Enter Description

CA Certificates Select the CA root
certificate you checked
in above for the
Sterling Connect:Direct
server.

Drop-down menu that contains a list of trusted
Certificate Authority public certificates. Only
displayed if "Encryption using Secure+" is
enabled. Required if Encryption using Secure+
is enabled. Valid values are all CA certificates
in this installation of your application.
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Field Value to Enter Description

System
Certificate

Select the System
certificate you checked
in above for the
Connect:Direct Server
Adapter node.

List of private keys and public certificates
signed by the trading partner trusted
certificate authority. This represents the
certificate for the local node (this adapter).
Only displayed if Encryption using Secure+ is
enabled. Required if Encryption using Secure+
is enabled. Valid values are all system
certificates in this installation of your
application.

Certificate
Common Name

If you want to verify
the Common Name of
the Sterling
Connect:Direct CA
certificate, specify it
here.

This feature is only
available if you use
signed certificates.

Coordinate this with
the remote Sterling
Connect:Direct
administrator.

Value to be compared with the Common
Name (CN) field from the remote node's
certificate during TLS/SSL handshake in order
to enhance certificate authentication. Only
displayed if Encryption using Secure+ is
enabled. May be overridden at the node level.

Note: To see the actual CNs being compared
during the handshake, set the Perimeter
Services logging level to ALL.

Cipher Suites Select which cipher
suites you wish to use.

Coordinate this list
with the remote
Sterling Connect:Direct
administrator.

Best practice is to list
cipher suites in
strongest to weakest
order.

Indicates cipher suites available to support
varying encryption levels. Multiple selections
allowed. Selections can be rank ordered. Only
displayed if "Encryption using Secure+" is
enabled. Required if "Encryption using
Secure+" is enabled. Valid values are all
available cipher suites in this installation of
your application.

SSL or TLS Select SSL or TLS.

Coordinate this choice
with the remote
Sterling Connect:Direct
administrator.

Indicates if Sterling Connect:Direct Secure Plus
is enabled using SSL or TLS. Only displayed if
"Encryption using Secure+" is enabled.
Required if "Encryption using Secure+" is
enabled. Valid values are SSL and TLS. Default
is TLS.

Require Client
Authentication

Select Yes or No for
client authentication.

Coordinate this choice
with the Sterling
Connect:Direct
administrator.

Indicates whether authentication occurs at the
client level. Valid values are:

Yes

No

Scenario 7 - Copying a File Using Sterling Connect:Direct
Secure Plus

Sterling Connect:Direct Secure Plus is configured and enabled on Sterling
Connect:Direct and Sterling B2B Integrator. You do not have to modify your
Sterling Connect:Direct process to encrypt the file with Sterling Connect:Direct
Secure Plus.
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Submit your existing Sterling Connect:Direct process to copy a file to Sterling B2B
Integrator. You can monitor the process results from Sterling Connect:Direct or
Sterling B2B Integrator as before.

Scenario 7 - Copying a File Using Your Sterling B2B Integrator
Business Process

You do not have to modify your Sterling B2B Integrator business process to
encrypt the file with Sterling Connect:Direct Secure Plus.

Submit and monitor your revised Sterling business process that contains the
OnFault Group to verify that it still works. The OnFault Group should not execute
and the execution results should be the same as they were before you modified the
business process.

Scenario 8 - Use Sterling B2B Integrator to Submit a Sterling
Connect:Direct Process

This scenario describes how to modify the Sterling B2B Integrator business process
to submit a process on the Sterling Connect:Direct node after the file is copied. The
Sterling Connect:Direct process copies the file received from Sterling B2B Integrator
to a z/OS system.

Scenario 8 - Creating Your Sterling Connect:Direct Process
Create a Sterling Connect:Direct process that copies the file received from the
Sterling B2B Integrator node to a remote Sterling Connect:Direct node similar to
the following example.

Before you begin

This process is invoked by the Sterling B2B Integrator business process.

COPY2ZOS PROCESS
SNODE=RemoteNode

STEP1 COPY
FROM (
FILE=sourceFile
)
TO (
FILE=destinationFile
DISP=RPL
)
PEND

Scenario 8 - Checking Out the Business Process
When you check out an existing business process with the Source Manager, you
lock the business process and prevent other users from modifying it at the same
time.

About this task

Use the following procedure to check out your business process that contains the
OnFault Group from Sterling B2B Integrator:
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Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Search pane, type your business

process name in the Process Name box and click Go!.
4. Click Source Manager for your business process.
5. On the Source Manager page, click check out for the version of the business

process you want to check out.
6. Click OK in the dialog box to lock the file for editing.
7. In the File Download dialog box, click Save to save a copy of the business

process to your local file system.
8. In the Save As dialog box, navigate to the directory where you want to save the

business process, type the business process file name in the File name box, and
click Save.

Scenario 8 - Editing the Business Process
In this scenario, you add a CD Server Submit Service to the business process. The
business process copies a file to the Sterling Connect:Direct server and then
submits a process on that same server.

About this task

Use the following procedure to edit the Sterling B2B Integrator business process:

Procedure
1. Log in to Sterling B2B Integrator and launch the Graphical Process Modeler

from the Home screen.
2. Enter your Sterling B2B Integrator User ID and password in the Log In dialog

box.
3. If the Connect:Direct stencil is not visible in the GPM, navigate to the View

menu and select Stencil > Applications > Sterling Commerce > Connect:Direct.
This will add the Connect:Direct stencil to the GPM.

4. From the File menu, select Open, navigate to the CopyToCD.bp file and click
Open.

5. Drag and drop the CD Server Submit Service icon from the Connect:Direct
stencil into the Business Process window.

6. To arrange and link the icons:
v Click the link between the CD Server CopyTo Service icon and CD Server

End Session Service icon and press Delete to remove the link.
v Place the CD Server Submit Service icon between the CD Server CopyTo

Service icon and the CD Server End Session Service icon.
v Click the arrow on the right side of the CD Server CopyTo Service icon and

drag it to the arrow on the left side of the CD Server Submit Service icon.
v Click the arrow on the right side of the CD Server Submit Service icon and

drag it to the arrow on the left side of the CD Server End Session Service
icon.
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7. Configure the CD Server Submit Service using the following procedure:
Double-click the CD Server Submit Service icon. This opens the Service Editor
window.
The Connect:Direct Server Submit Service acts like a Submit statement in a
Sterling Connect:Direct process. Use this service to submit a Sterling
Connect:Direct process on a remote Sterling Connect:Direct server.
In the Service Editor-CD Server Submit Service window, select CDServerSubmit
from the Config drop-down list.
In this step you specify the pre-defined CDServerSubmit configuration to use
for the CD Server Submit Service. You can override configuration values in the
Service Editor.
Type the Sterling Connect:Direct process file name as the Value for
RemoteProcessFile.
Type //BeginSessionResults/SessionToken/node() as the Value for
SessionToken and select the Use XPATH? box.
The SessionToken value in the CD Server Submit Service ensures that this
service submits the Sterling Connect:Direct process using the session initiated
by the CD Server Begin Session Service.

8. From the File menu, select Save. In the Validate dialog box, click Yes to validate
the business process.

9. On the Save dialog box, type the business process name in the File Name box
and click Save. Remember where you save this file.

Note: To see a sample business process, refer to Use Sterling B2B Integrator to
Submit a Sterling Connect:Direct Process .

Scenario 8 - Checking In Your Business Process
Use the following procedure to check the revised business process into Sterling
B2B Integrator:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Search pane, type the business

process name in the Process Name box and click Go!.
4. Click Source Manager for the business process.
5. On the Source Manager page, select Go! to Check in an updated definition for

this business process.
6. On the Process Definition Check-in page, click Browse and navigate to the

business process file that you saved in step 9 of the previous procedure.
7. Type a short description of the updated business process in the Description

box and click Next.
8. On the Process Levels page, select the Set onfault processing check box.
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9. Set the Persistence Level to Full.
10. Set the Event Reporting Level to Full.
11. Set the Recovery Level to Auto Resume and click Next.

If Sterling B2B Integrator stops responding during a copy transaction and the
recovery level is set to Auto Resume, the business process resumes
automatically at the next Sterling B2B Integrator start up.

12. On the Deadline Settings page, click Next.
13. On the Life Span page, click Next.
14. On the Set Default Version page, select the updated version of the business

process.
15. On the Confirm page, select the Enable Business Process box.
16. Click Finish.

Scenario 8 - Submitting Your Sterling B2B Integrator Business
Process

Before you submit your revised Sterling business process, modify the Sterling
Connect:Direct User ID in Sterling Connect:Direct. In the Functional Authorities,
set the Download directory back to its original setting so that the CD Server
CopyTo Service does not fail.

About this task

Use the following procedure to submit your Sterling B2B Integrator business
process:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. In the Search pane, type the business process name in the Process Name box

and click Go!.
4. On the Business Process Manager page, click Execution Manager.
5. On the Execution Manager page, click Execute for the revised business process

to launch the Execute Business Process Input dialog box.
6. Click Browse and navigate to your source file on your local system and click

Open.
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7. Click Go! to submit the business process.
The Execute Business Process page is displayed.

8. Close the Execute Business Process page.

Scenario 8 - Monitoring with Sterling B2B Integrator
Use the following procedure to monitor your business process with Sterling B2B
Integrator:

About this task

Procedure
1. From the Business Process menu, select Monitor > Advanced Search > Business

Processes.
2. In the Search Using Business Process Name pane, select your business process

in the Business Processes list and click Go!.
The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful
execution

ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting.
3. Click the ID number to see details about the business process execution.
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The Business Process Detail page displays the following information for each
step:

Label Description

Step The business process step number

Service The Sterling B2B Integrator service name used in the step

Status The status of the step

Advanced Status Additional status information

Started The time and date the step started

Ended The time and date the step ended

Status Report A link to the status report for the step

Document A link to documents in use by the step

Instance Data A link to process data for the step

4. The Status for the Connect:Direct Server Submit Service is Success. This
indicates only that the Sterling Connect:Direct process was successfully
submitted. It does not provide a completion status for the process. You must
use the Sterling Connect:Direct Statistics to verify completion status for the
process.

5. The last step in the Business Process Detail is the Connect:Direct Server End
Session Service. The Status for this step indicates that it successfully closes the
Sterling Connect:Direct session.

Note: You can also monitor your business processes from the Business
Processes menu by navigating to Monitor > Advanced Search > Documents or
Monitor > Advanced Search > Communication Sessions.

Scenario 8 - Monitoring with Sterling Connect:Direct
You can use the Sterling Connect:Direct Select Statistics to monitor your revised
Sterling B2B Integrator to Sterling Connect:Direct business process.

If the Sterling Connect:Direct process is successfully submitted, the Select Statistics
detail will indicate this and show information similar to the following:

Attribute Value

Message ID LSMG407I (if Sterling Connect:Direct is installed on a Microsoft
Windows system)

Message Text SUBMIT within a process step completed successfully
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Attribute Value

Source File <default process directory>\<Sterling Connect:Direct process file>

If the Sterling Connect:Direct process completes successfully, the Select Statistics
will indicate this and show information similar to the following:

Attribute Value

Message ID LSMG252I (if Sterling Connect:Direct is installed on a Microsoft
Windows system)

Message Text A user process has completed successfully

Process Name Sterling Connect:Direct process name

If the Sterling Connect:Direct process is not successfully submitted or executed,
refer to Troubleshooting.

Scenario 9 - Use Sterling B2B Integrator to Start a Sterling
Connect:Direct Run Job

This scenario describes how to modify the Sterling B2B Integrator business process
to start a program on the Sterling Connect:Direct server using a Run Job after a file
is copied. The Connect:Direct Server Adapter does not verify the validity of the
submitted program and does not wait for the submitted job to complete. The
program runs as a separate process.

Scenario 9 - Checking Out the Business Process
When you check out an existing business process with the Source Manager, you
lock the business process and prevent other users from modifying it at the same
time.

About this task

Use the following procedure to check out your business process that contains the
CD Server Submit Service from Sterling B2B Integrator:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Search pane, type your business

process name in the Process Name box and click Go!.
4. Click Source Manager for your business process.
5. On the Source Manager page, click check out for the version of the business

process you want to check out.
6. Click OK in the dialog box to lock the file for editing.
7. In the File Download dialog box, click Save to save a copy of the business

process to your local file system.
8. In the Save As dialog box, navigate to the directory where you want to save the

business process, type the business process file name in the File name box, and
click Save.
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Scenario 9 - Editing the Business Process
In this scenario, you replace the CD Server Submit Service with the CD Server Run
Job Service in your business process. The business process copies a file to the
Sterling Connect:Direct server and then starts a Sterling Connect:Direct Run Job on
that server.

About this task

The Run Job in this scenario is for a Sterling Connect:Direct for Microsoft Windows
SNODE. If your SNODE is not a Sterling Connect:Direct for Microsoft Windows
system, create a Run Job similar to the following example appropriate for your
SNODE platform.

Use the following procedure to edit the Sterling B2B Integrator business process:

Procedure
1. Log in to Sterling B2B Integrator and launch the Graphical Process Modeler

from the Home screen.
2. Enter your Sterling B2B Integrator User ID and password in the Log In dialog

box.
3. If the Connect:Direct stencil is not visible in the GPM, navigate to the View

menu and select Stencil > Applications > Sterling Commerce > Connect:Direct.
This will add the Connect:Direct stencil to the GPM.

4. From the File menu, select Open, navigate to the business process file and click
Open.

5. Drag and drop the CD Server Run Job Service icon from the Connect:Direct
stencil into the Business Process window.

6. To arrange and link the icons:
Click the CD Server Submit Service icon and press Delete to remove it.
Place the CD Server Run Job Service icon between the CD Server CopyTo
Service icon and the CD Server End Session Service icon.
Click the arrow on the right side of the CD Server CopyTo Service icon and
drag it to the arrow on the left side of the CD Server Run Job Service icon.
Click the arrow on the right side of the CD Server Run Job Service icon and
drag it to the arrow on the left side of the CD Server End Session Service icon.

7. Configure the CD Server Run Job Service using the following procedure:
Double-click the CD Server Run Job Service icon. This opens the Service Editor
window.
The Connect:Direct Server Run Job Service acts like a Run Job statement in a
Sterling Connect:Direct process. Use this service to start a Sterling
Connect:Direct Run Job on a remote Sterling Connect:Direct server.
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In the Service Editor-CD Server Run Job Service window, select
CDServerRunJob from the Config drop-down list.
In this step you specify the pre-defined CDServerRunJob configuration to use
for the CD Server Run Job Service. You can override configuration values in the
Service Editor.
Type pgm(path/filename) desktop(yes) as the Value for Sysopts, where path is
the full directory path and filename is the file name of the program or script
you wish to run in the Run Job.
Type //BeginSessionResults/SessionToken/node() as the Value for
SessionToken and select the Use XPATH? box.
The SessionToken value in the CD Server Run Job Service ensures that this
service starts the Sterling Connect:Direct Run Job using the session initiated by
the CD Server Begin Session Service.

8. From the File menu, select Save. In the Validate dialog box, click Yes to validate
the business process.

9. On the Save dialog box, type the business process name in the File Name box
and click Save. Remember where you save this file.

Note: To see a sample business process, refer to Use Sterling B2B Integrator to
Start a Sterling Connect:Direct Run Job .

Scenario 9 - Checking In Your Business Process
Use the following procedure to check the revised business process into Sterling
B2B Integrator:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Search pane, type the business

process name in the Process Name box and click Go!.
4. Click Source Manager for your business process.
5. On the Source Manager page, select Go! to Check in an updated definition for

this business process.
6. On the Process Definition Check-in page, click Browse and navigate to the

business process file that you saved in step 9 of the previous procedure.
7. Type a short description of your business process in the Description box and

click Next.
8. On the Process Levels page, select the Set onfault processing check box.
9. Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full.
11. Set the Recovery Level to Auto Resume and click Next.

If Sterling B2B Integrator stops responding during a copy transaction and the
recovery level is set to Auto Resume, the business process resumes
automatically at the next Sterling B2B Integrator start up.

12. On the Deadline Settings page, click Next.
13. On the Life Span page, click Next.
14. On the Set Default Version page, select the updated version of the business

process.
15. On the Confirm page, select the Enable Business Process box.
16. Click Finish.
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Scenario 9 - Submit Your Sterling B2B Integrator Business
Process

Use the following procedure to submit your Sterling B2B Integrator business
process:

About this task

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. In the Search pane, type your business process name in the Process Name box

and click Go!.
4. On the Business Process Manager page, click Execution Manager.
5. On the Execution Manager page, click Execute for the revised business process

to launch the Execute Business Process Input dialog box.
6. Click Browse and navigate to the source file on your local system and click

Open.

7. Click Go! to submit the business process.
The Execute Business Process page is displayed.

8. Close the Execute Business Process page.
The program, application, or script runs on the Sterling Connect:Direct server.
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Scenario 9 - Monitoring with Sterling B2B Integrator
Use the following procedure to monitor your business process with Sterling B2B
Integrator:

Procedure
1. From the Business Process menu, select Monitor > Advanced Search > Business

Processes.
2. In the Search Using Business Process Name pane, select your business process

name in the Business Processes list and click Go!.
The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful
execution

ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting.
3. Click the ID number to see details about the business process execution.

The Business Process Detail page displays the following information for each
step:

Label Description

Step The business process step number

Service The Sterling B2B Integrator service name used in the step

Status The status of the step

Advanced Status Additional status information

Started The time and date the step started

Ended The time and date the step ended

Status Report A link to the status report for the step

Document A link to documents in use by the step

Instance Data A link to process data for the step

4. The Status for the Connect:Direct Server Run Job Service is Success. This
indicates only that the Sterling Connect:Direct Run Job successfully started. It
does not provide a completion status for the application invoked by the Run
Job.
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5. The last step in the Business Process Detail is the Connect:Direct Server End
Session Service. The Status for this step indicates that it successfully closes the
Sterling Connect:Direct session.

Note: You can also monitor your business processes from the Business
Processes menu by navigating to Monitor > Advanced Search > Documents or
Monitor > Advanced Search > Communication Sessions.

Scenario 9 - Monitoring with Sterling Connect:Direct
You can use the Sterling Connect:Direct Select Statistics to monitor your revised
Sterling B2B Integrator to Sterling Connect:Direct business process.

If the Sterling Connect:Direct Run Job starts successfully, the Select Statistics detail
will indicate this and show information similar to the following:

Attribute Value

Message ID LSMG400I (if Sterling Connect:Direct is installed on a Microsoft
Windows system)

Message Text A user RUNJOB step completed successfully

Source File pgm(path/filename) desktop(yes)

If the Sterling Connect:Direct process is not successful, refer to Troubleshooting.

Scenario 10 - Use Sterling B2B Integrator to Start a Sterling
Connect:Direct Run Task

This scenario describes how to modify your Sterling B2B Integrator business
process to start and wait on a program on the Sterling Connect:Direct server via a
Run Task after the source file is copied. The program may be a program or script.
The Connect:Direct Server Adapter does not verify the validity of the submitted
program, but it does wait for the submitted job to complete before moving to the
next service in the business process. The program or script runs as a separate
process.

Scenario 10 - Checking Out the Business Process
When you check out an existing business process with the Source Manager, you
lock the business process and prevent other users from modifying it at the same
time.
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About this task

Use the following procedure to check out your business process that contains the
CD Server Run Job Service from Sterling B2B Integrator:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Search pane, type your business

process name in the Process Name box and click Go!.
4. Click Source Manager for your business process.
5. On the Source Manager page, click check out for the version of the business

process you want to check out.
6. Click OK in the dialog box to lock the file for editing.
7. In the File Download dialog box, click Save to save a copy of the business

process to your local file system.
8. In the Save As dialog box, navigate to the directory where you want to save the

business process, type the business process file name in the File name box, and
click Save.

Scenario 10 - Editing the Business Process
In this scenario, you replace the CD Server Run Job Service with the CD Server
Run Task Service in your business process. The business process copies a file to the
Sterling Connect:Direct server and then starts a Sterling Connect:Direct Run Task
on that server. The business process waits for the Run Task to complete before the
CD Server End Session Service terminates the Sterling Connect:Direct session.

About this task

The Run Task in this scenario is for a Sterling Connect:Direct for Microsoft
Windows SNODE. If your SNODE is not a Sterling Connect:Direct for Microsoft
Windows system, create a Run Task similar to the following example appropriate
for your SNODE platform.

Use the following procedure to edit the Sterling B2B Integrator business process:

Procedure
1. Log in to Sterling B2B Integrator and launch the Graphical Process Modeler

from the Home screen.
2. Enter your Sterling B2B Integrator User ID and password in the Log In dialog

box.
3. If the Connect:Direct stencil is not visible in the GPM, navigate to the View

menu and select Stencil > Applications > Sterling Commerce > Connect:Direct.
This will add the Connect:Direct stencil to the GPM.

4. From the File menu, select Open, navigate to the business process file and click
Open.

5. Drag and drop the CD Server Run Task Service icon from the Connect:Direct
stencil into the Business Process window.

6. To arrange and link the icons:
Click the CD Server Run Job Service icon and press Delete to remove it.
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Place the CD Server Run Task Service icon between the CD Server CopyTo
Service icon and the CD Server End Session Service icon.
Click the arrow on the right side of the CD Server CopyTo Service icon and
drag it to the arrow on the left side of the CD Server Run Task Service icon.
Click the arrow on the right side of the CD Server Run Task Service icon and
drag it to the arrow on the left side of the CD Server End Session Service icon.

7. Configure the CD Server Run Task Service using the following procedure:
Double-click the CD Server Run Task Service icon. This opens the Service
Editor window.
The Connect:Direct Server Run Task Service acts like a Run Task statement in a
Sterling Connect:Direct process. Use this service to start a Sterling
Connect:Direct Run Task on a remote Sterling Connect:Direct server and wait
for it to complete before executing the next service in a business process.
In the Service Editor-CD Server Run Task Service window, select
CDServerRunTask from the Config drop-down list.
In this step you specify the pre-defined CDServerRunTask configuration to use
for the CD Server Run Task Service. You can override configuration values in
the Service Editor.
Type pgm(path/filename) desktop(yes) as the Value for SystemOpts, where
path is the full directory path and filename is the file name of the program or
script you wish to run in the Run Task. (SystemOpts is the equivalent of
Sysopts.)

Note: Do not enclose the value specified for SystemOpts in double quotes.

Type //BeginSessionResults/SessionToken/node() as the Value for
SessionToken and select the Use XPATH? box.

The SessionToken value in the CD Server Run Task Service ensures that this
service starts the Sterling Connect:Direct Run Task using the session initiated
by the CD Server Begin Session Service.

8. From the File menu, select Save. In the Validate dialog box, click Yes to validate
the business process.

9. On the Save dialog box, type the business process file name in the File Name
box and click Save. Remember where you save this file.

Note: To see a sample business process, refer to Use Sterling B2B Integrator to
Start a Sterling Connect:Direct Run Task. To see a more complex example
involving Sterling Connect:Direct for z/OS, see Use Sterling B2B Integrator to
Copy a File to Sterling Connect:Direct for z/OS (Advanced) .
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Scenario 10 - Checking In Your Business Process
Use the following procedure to check the revised business process into Sterling
B2B Integrator:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Search pane, type the business

process name in the Process Name box and click Go!.
4. Click Source Manager for your business process.
5. On the Source Manager page, select Go! to Check in an updated definition for

this business process.
6. On the Process Definition Check-in page, click Browse and navigate to the

business process file that you saved in step 9 of the previous procedure.
7. Type a short description of your business process in the Description box and

click Next.
8. On the Process Levels page, select the Set onfault processing check box.
9. Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full.
11. Set the Recovery Level to Auto Resume and click Next.

If Sterling B2B Integrator stops responding during a copy transaction and the
recovery level is set to Auto Resume, the business process resumes
automatically at the next Sterling B2B Integrator start up.

12. On the Deadline Settings page, click Next.
13. On the Life Span page, click Next.
14. On the Set Default Version page, select the updated version of the business

process.
15. On the Confirm page, select the Enable Business Process box.
16. Click Finish.

Scenario 10 - Submitting Your Sterling B2B Integrator
Business Process

Use the following procedure to submit your Sterling B2B Integrator business
process:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. In the Search pane, type your business process name in the Process Name box

and click Go!.
4. On the Business Process Manager page, click Execution Manager.
5. On the Execution Manager page, click Execute for the revised business process

to launch the Execute Business Process Input dialog box.
6. Click Browse and navigate to the source file on your local system and click

Open.
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7. Click Go! to submit the business process. The Execute Business Process page is
displayed.

8. Close the Execute Business Process page.

Scenario 10 - Monitoring with Sterling B2B Integrator
Use the following procedure to monitor your business process with Sterling B2B
Integrator:

About this task

Procedure
1. From the Business Process menu, select Monitor > Advanced Search > Business

Processes.
2. In the Search Using Business Process Name pane, select your business process

in the Business Processes list and click Go!.
The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful
execution

ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting.
3. Click the ID number to see details about the business process execution.

76 Sterling B2B Integrator: Interoperability with Sterling Connect:Direct



The Business Process Detail page displays the following information for each
step:

Label Description

Step The business process step number

Service The Sterling B2B Integrator service name used in the step

Status The status of the step

Advanced Status Additional status information

Started The time and date the step started

Ended The time and date the step ended

Status Report A link to the status report for the step

Document A link to documents in use by the step

Instance Data A link to process data for the step

The Status for the Connect:Direct Server Run Task Service is not reported until
the application or script completes. The Business Process Detail screen shows
that the Connect:Direct Server Run Task Service is In progress... .

4. When you close the application or script, The Connect:Direct Server Run Task
Service completes and the last step in the business process, the Connect:Direct
Server End Session Service, terminates the Sterling Connect:Direct session.

Note: You can also monitor your business processes from the Business
Processes menu by navigating to Monitor > Advanced Search > Documents or
Monitor > Advanced Search > Communication Sessions.

Scenario 10 - Monitoring with Sterling Connect:Direct
You can use the Sterling Connect:Direct Select Statistics to monitor your revised
Sterling B2B Integrator to Sterling Connect:Direct business process.

If the Sterling Connect:Direct Run Task completes successfully, the Select Statistics
detail will indicate this and show information similar to the following:

Attribute Value

Message ID LSMG402 (if Sterling Connect:Direct is installed on a Microsoft
Windows system)

Message Text A user RUNTASK step completed. Exit code = 0

Source File pgm(path/filename) desktop(yes)

If the Sterling Connect:Direct process is not successful, refer to Troubleshooting.
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Scenario 11 - Hide the Sterling Connect:Direct Password in the
Business Process

This scenario describes how to hide the value of the user password in your
business process. Modify your Sterling B2B Integrator business process by adding
an Obscure Data - Process Data Values Service before the CD Server Begin Session
Service.

Scenario 11 - Configuring the Obscure Data - Process Data
Values Service

Use the following procedure to configure the Obscure Data - Process Data Values
Service:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Deployment menu, select Services > Configuration.
3. On the Services Configuration page, click Go! in the Create New Service pane.
4. In the Service Type box, type Obscure Data - Process Data Values and click

Next.

Note: Alternately, you can navigate to Obscure Data - Process Data Values by
clicking one of the navigation buttons next to the Service Type box.

5. On the Name page, in the Name box, type CDClientObscureParameter.
6. In the Description box, type a short description of what you are obscuring and

click Next.
7. On the Parameters page, in the first Parameter Name box, type the Sterling

Connect:Direct User ID.
8. In the first Parameter Value box, type the password for the Sterling

Connect:Direct User ID and click Next.
9. On the Confirm page, click Finish.

Scenario 11 - Checking Out the Business Process
When you check out an existing business process with the Source Manager, you
lock the business process and prevent other users from modifying it at the same
time.

About this task

Use the following procedure to check out your business process that contains the
CD Server Run Task Service from Sterling B2B Integrator:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Search pane, type your business

process name in the Process Name box and click Go!.
4. Click Source Manager for your business process.
5. On the Source Manager page, click check out for the version of the business

process you want to check out.
6. Click OK in the dialog box to lock the file for editing.
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7. In the File Download dialog box, click Save to save a copy of the business
process to your local file system.

8. In the Save As dialog box, navigate to the directory where you want to save the
business process, type the business process file name in the File name box, and
click Save.

Scenario 11 - Editing the Business Process
In this scenario, add the Obscure Data - Process Data Values to your business
process. The Obscure Data - Process Data Values retrieves the remote password
from the CDClientObscureParameter configuration. The CD Server Begin Session
Service gets the remote password from the Obscure Data - Process Data Value. The
remote password is not revealed in the business process.

About this task

Use the following procedure to edit the Sterling B2B Integrator business process:

Procedure
1. Log in to Sterling B2B Integrator and launch the Graphical Process Modeler

from the Home screen.
2. Enter your Sterling B2B Integrator User ID and password in the Log In dialog

box.
3. If the All Services stencil is not visible in the GPM, navigate to the View menu

and select Stencil > All Services.
This will add the All Services stencil to the GPM.

4. From the File menu, select Open, navigate to your business process file and
click Open.

5. Drag and drop the Obscure Data - Process Data Values icon from the
Connect:Direct stencil into the Business Process window.

6. To arrange and link the icons:
Click the arrow between the start icon and the CD Server Begin Session
Service icon and press Delete to remove it.
Place the Obscure Data - Process Data Values icon between the start icon and
the CD Server Begin Session Service icon.
Click the arrow on the right side of the start icon and drag it to the arrow on
the left side of the Obscure Data - Process Data Values icon.
Click the arrow on the right side of the Obscure Data - Process Data Values
icon and drag it to the arrow on the left side of the CD Server Begin Session
Service icon.

7. Configure the Obscure Data - Process Data Values using the following
procedure:
Double-click the Obscure Data - Process Data Values icon. This opens the
Service Editor window.
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In the Service Editor-Obscure Data - Process Data Values window, select
CDClientObscureParameter from the Config drop-down list.
In this step you specify the CDClientObscureParameter configuration to use
for the Obscure Data - Process Data Values. You can override configuration
values in the Service Editor.

8. Edit the CD Server Begin Session Service using the following procedure:
Double-click the CD Server Begin Session Service icon.
Select Yes as the Value for UsingObscuredPasswd.
Type CDUserID/text( ) as the Value for the RemotePasswd and select the Use
XPATH? box. CDUserID is the Sterling Connect:Direct User ID.

9. From the File menu, select Save. In the Validate dialog box, click Yes to
validate the business process.

10. On the Save dialog box, type your business process file name in the File
Name box and click Save.
Remember where you save this file.

Note: To see a sample business process, refer to Hide the Sterling
Connect:Direct Password in the Business Process.

Scenario 11 - Checking In Your Business Process
Use the following procedure to check the revised business process into Sterling
B2B Integrator:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. On the Business Process Manager page, in the Search pane, type your business

process name in the Process Name box and click Go!.
4. Click Source Manager for your business process.
5. On the Source Manager page, select Go! to Check in an updated definition for

this business process.
6. On the Process Definition Check-in page, click Browse and navigate to your

business process file that you saved in the previous procedure.
7. Type Added Obscure Data - Process Data Values to hide password in the

Description box and click Next.
8. On the Process Levels page, select the Set onfault processing check box.
9. Set the Persistence Level to Full.

10. Set the Event Reporting Level to Full.
11. Set the Recovery Level to Auto Resume and click Next.

If Sterling B2B Integrator stops responding during a copy transaction and the
recovery level is set to Auto Resume, the business process resumes
automatically at the next Sterling B2B Integrator start up.

12. On the Deadline Settings page, click Next.
13. On the Life Span page, click Next.
14. On the Set Default Version page, select the updated version of the business

process.
15. On the Confirm page, select the Enable Business Process box.
16. Click Finish.
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Scenario 11 - Submitting Your Sterling B2B Integrator
Business Process

Use the following procedure to submit your Sterling B2B Integrator business
process:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Business Process menu, select Manager.
3. In the Search pane, type your business process in the Process Name box and

click Go!.
4. On the Business Process Manager page, click Execution Manager.
5. On the Execution Manager page, click Execute for the revised business process

to launch the Execute Business Process Input dialog box.
6. Click Browse and navigate to the source file on your local system and click

Open.

7. Click Go! to submit your business process.
The Execute Business Process page is displayed.

8. Close the Execute Business Process page.
The application or script runs on the Sterling Connect:Direct server.

Scenario 11 - Monitoring with Sterling B2B Integrator
If you modify your business process with the Obscure Data - Process Data Values
correctly, the business process execution results will be unchanged.
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About this task

Use the following procedure to monitor your business process with Sterling B2B
Integrator:

Procedure
1. From the Business Process menu, select Monitor > Advanced Search > Business

Processes.
2. In the Search Using Business Process Name pane, select your business process

in the Business Processes list and click Go!.
The Monitor page displays the following information:

Label Description

Status Status of the business process—a green traffic light signals a successful
execution

ID The business process ID number

Name The business process name

State The current state of the business process

If the Status indicates unsuccessful execution, refer to Troubleshooting.
3. Click the ID number to see details about the business process execution.

The Business Process Detail page displays the following information for each
step:

Label Description

Step The business process step number

Service The Sterling B2B Integrator service name used in the step

Status The status of the step

Advanced Status Additional status information

Started The time and date the step started

Ended The time and date the step ended

Status Report A link to the status report for the step

Document A link to documents in use by the step

Instance Data A link to process data for the step

4. The Status for the Connect:Direct Server Run Task Service is not reported until
the application or script completes. The Business Process Detail screen shows
that the Connect:Direct Server Run Task Service is In progress.
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5. When you close the application or script, The Connect:Direct Server Run Task
Service completes and the last step in the business process, the Connect:Direct
Server End Session Service, terminates the Sterling Connect:Direct session.

Note: You can also monitor your business processes from the Business
Processes menu by navigating to Monitor > Advanced Search > Documents or
Monitor > Advanced Search > Communication Sessions.

Scenario 11 - Monitoring with Sterling Connect:Direct
You can use the Sterling Connect:Direct Select Statistics to monitor your revised
Sterling B2B Integrator to Sterling Connect:Direct business process.

If the Sterling Connect:Direct Run Task completes successfully, the Select Statistics
detail will indicate this and show information similar to the following:

Attribute Value

Message ID LSMG402I (if Sterling Connect:Direct is installed on a Microsoft
Windows system)

Message Text A user RUNTASK step completed. Exit code = 0

Source File pgm(path/filename) desktop(yes)

If the Sterling Connect:Direct process is not successful, refer to Troubleshooting.

Use Custom Translation Tables
cdinterop-xlate.properties is introduced in Sterling B2B Integrator and used to
introduce custom translation tables. Each entry in this file associates a table name
with a path to a file defining a translation table.

Configure Custom Translation Table

Create a translation table.

A translation table consists of a set of 256 values specified by a series of two
character hexadecimal numbers separated by whitespace, such as spaces, tabs,
carriage returns and linefeeds. The values are ordered according to the translation
direction. If data is arriving in EBCDIC format, the table values should specify
ASCII values in EBCDIC order. If data is sent in ASCII format, this table’s values
should specify EBCDIC values in ASCII order. A translation table may also include
comments. Comments are formed by enclosing comment text in c-style comment
start characters ‘/*’ and comment end characters ‘*/’. Syntax errors are reported in
the CDSA log file (cdinterop.log). For example:
/* Sample ASCII-to-EBCDIC translation table */

/*00*/ 00 01 02 03 37 2d 2e 2f 16 05 25 0b 0c 0d 0e 0f
/*10*/ 10 11 12 13 3c 3d 32 26 18 19 3f 27 1c 1d 1e 1f
/*20*/...

Assign a name for the translation table in the cdinterop-xlate.properties file.

Every entry in this file consists of a property name and a property value. The
property name specifies the name of a custom translation table used during a copy
operation. The property name is referenced either by the new LocalXlateTable
CopyTo/CopyFrom Service parameter, or by the new xlate.table SYSOPTS
parameter.
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The property’s value specifies the complete path leading to a file that defines the
custom translation table values. Any acceptable filename (and/or extension) may
be used.

For example, the following entry assigns the name ascii-to-ebcdic-table to the file
sample-ascii-to-ebcdic.xlate. This file is located in the /path/to/xlate/table/files
directory and contains the translation characters to be used during the copy
operation.

ascii-to-ebcdic-table=/path/to/xlate/table/files/sample-ascii-to-ebcdic.xlate
ebcdic-to-ascii-table=/path/to/xlate/table/files/sample-ascii-to-ebcdic.xlate

Table names are case insensitive; ascii-to-ebcdic-table, Ascii-To-Ebcdic-Table and
ASCII-TO-EBCDIC-TABLE all refer to the sample-ascii-to-ebcdic.xlate translation
table.

Specify Custom Translation in Sterling Integrator CopyTo/CopyFrom Services

Specify the new LocalXlateTable Connect:Direct CopyTo/CopyFrom Service
parameter to indicate which translation table the service should use during
transmission. It may be specified using the Graphical Process Modeler or by
editing the XML source of the business process. For example:
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteFileName">c:\tmp\ebcdic.txt</assign>
<assign to="BinaryMode">No</assign>
<assign to="LocalXlate">Yes</assign>
<assign to="LocalXlateTable">ascii-to-ebcdic-table</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="CopyToResults" from="*"></assign>
</input>
</operation>

Note: BinaryMode=No and LocalXlate=Yes must be specified in order for
translation to occur.

How to Configure Custom Translation in Remote Connect:Direct Z/OS Process
COPY Statements

Remote Connect:Direct nodes may now send the new xlate.table( table-name)
parameter in the SYSOPTS string to the CDSA from within the COPY statement.

B00001 PROCESS SNODE=cdsa -

SNODEID=(userid,password)

STEP01 COPY FROM (DSN=EBCDIC.FILE -

DISP=SHR -

PNODE) -

TO (DSN='/mailbox/ascii.txt' -
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DISP=RPL -

SYSOPTS=":DATATYPE=TEXT:XLATE=YES:XLATE.TABLE=EBCDIC-TO-ASCII-
TABLE:" - SNODE)

datatype(text) and xlate(yes) must be specified in order for translation to occur.

Sample Business Processes

Sample Business Processes on the Sterling B2B Integrator
Side

For more information about the Sterling Connect:Direct side, particularly on the
Sterling Connect:Direct Process language and how to tailor it to communicate with
Sterling B2B Integrator, search for Sterling Connect:Direct Server Adapter Syntax
and Sterling B2B Integrator-Connect:Direct Server Adapter Examples.

Use Sterling Connect:Direct to Copy a File to Sterling B2B
Integrator

In the Sterling Connect:Direct for Microsoft Windows process, the Sterling
Connect:Direct server (PNODE) copies the orders.txt file to the Sterling
Connect:Direct Server Adapter (SNODE) which invokes the ReceiveFromCD
business process and passes the file to the business process. The Connect:Direct
Server Adapter node name is SI50. The destination filename on Sterling B2B
Integrator is daily.txt.
CDSAMPLE PROCESS

SNODE=SI50
SNODEID=(myUserID,myPassword)

STEP1 COPY
FROM (

FILE=C:\orders.txt
)
TO (

FILE=/businessprocess/ReceiveFromCD/daily.txt
DISP=RPL

)
PEND

In the Sterling B2B Integrator ReceiveFromCD business process, shown in BPML,
the Get Document Information Service obtains file information about the primary
document and places it into process data. You can add additional services to this
business process to perform operations such as translating the file or copying the
file to another server using FTP.

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.
<process name = "ReceiveFromCD">

<operation name="Get Document Information Service">
<participant name="GetDocumentInfoService"/>
<output message="GetDocumentInfoServiceTypeInputMessage">

<assign to="." from="*"></assign>
</output>
<input message="inmsg">
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<assign to="." from="*"></assign>
</input>

</operation>
</process>

Use Sterling Connect:Direct to Retrieve a File from Sterling
B2B Integrator

In the Sterling Connect:Direct for Microsoft Windows process, the Sterling
Connect:Direct server (PNODE) pulls a file from a Sterling Connect:Direct Server
Adapter (SNODE). The Sterling Connect:Direct node connects to the Sterling
Connect:Direct Server Adapter which invokes the RespondToCD business process
which sends the sample.txt file back to Sterling Connect:Direct. The Connect:Direct
Server Adapter node name is SI50. The destination file name on the Sterling
Connect:Direct server is orders.txt.
CDSAMPLE PROCESS

SNODE=SI50
SNODEID=(myUserID,myPassword)

STEP1 COPY
FROM (

FILE=/businessprocess/RespondToCD/sample.txt
)
TO (

FILE=C:\orders.txt
DISP=RPL

)
PEND

In the RespondToCD business process, shown in BPML, the business process
retrieves a file, passes this file to the Connect:Direct Server Adapter, and sends the
file back to the Sterling Connect:Direct node. The business process functions much
like a Sterling Connect:Direct process.

In the first operation of the RespondToCD business process, the File System
Adapter collects (reads) the daily.txt file from the Sterling B2B Integrator local file
system. This file becomes the primary document of the business process.

In the next operation of the business process, the CD Server BP Response Service
passes the primary document back to the Sterling Connect:Direct node (PNODE).

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.
<process name = "RespondToCD">

<sequence>
<operation name="File System Adapter">

<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>

<operation name="CD Server BP Response Service">
<participant name="CDServerBPResponse"/>
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<output message="CDServerBPResponseServiceTypeInputMessage">
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>

</sequence>
</process>

Use Sterling B2B Integrator to Copy a File to a Sterling
Connect:Direct for z/OS Node

In this sample, shown in BPML, the Sterling B2B Integrator
CopyToCDMainframeNode business process passes a document to the
Connect:Direct Server Adapter (PNODE) which copies the file to the Sterling
Connect:Direct for z/OS node (SNODE). The business process functions much like
a Sterling Connect:Direct process.

In the first operation of the CopyToCDMainframeNode business process, the File
System Adapter collects (reads) the daily.txt file from the Sterling B2B Integrator
local file system. This file becomes the primary document of the business process.

The second operation uses the CD Server Begin Session Service to establish a
connection to the remote Sterling Connect:Direct node, CDZOS. The local node
name of the Connect:Direct Server Adapter is Dal1CDSA. The Begin Session
Service uses the remote user ID of cduser to authenticate to the Sterling
Connect:Direct server. The Session Token created by the CD Server Begin Session
Service identifies the session that is established with the remote Sterling
Connect:Direct node. The SessionToken value in the CD Server CopyTo Service
ensures that this service copies the file using the session initiated by the CD Server
Begin Session Service.

The third operation uses the CD Server CopyTo Service to copy the primary
document to a specific unit (3380) and volume (serial number is SYS009) on the
Sterling Connect:Direct for z/OS server. SPACE information is also provided (4096,
(200,40)...ROUND). The destination file name is SAMPLE.ZOS.FILE.

The last operation uses the CD Server End Session Service to terminate the session
with the Sterling Connect:Direct server.

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.
<process name="CopyToCDMainframeNode">
<sequence>
<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Begin Session Service">
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<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="." from="*"></assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="ProcessName">Copyto</assign>
<assign to="LocalCDNodeName">Dal1CDSA</assign>
<assign to="RemoteCDNodeName">CDZOS</assign>
<assign to="RemotePasswd">xxxxxxxx/assign>
<assign to="UsingObscuredPasswd">NO</assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>
<assign to="BeginSessionResults" from="*"></assign>

</input>
</operation>
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="." from="*"></assign>
<assign to="RemoteUNIT">3380</assign>
<assign to="RemoteVOL">(SER=SYS009)</assign>
<assign to="RemoteDISP">(NEW,CATLG)</assign>
<assign to="RemoteFileName">SAMPLE.ZOS.FILE</assign>
<assign to="RemoteSPACE">(4096,(200,40),,,ROUND)</assign>
<assign to="SessionToken"

from="//BeginSessionResults/SessionToken/node()"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="." from="*"></assign>
<assign to="SessionToken">//BeginSessionResults/SessionToken/node()
</assign></output>

<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>

</sequence>
</process>

Use Sterling B2B Integrator to Copy a File to a Sterling
Connect:Direct for Microsoft Windows Node

In this sample, shown in BPML, the Sterling B2B Integrator CopyToCDWin
business process passes a document to the Connect:Direct Server Adapter
(PNODE) which copies the file to the Sterling Connect:Direct for Microsoft
Windows node (SNODE). The business process functions much like a Sterling
Connect:Direct process.

In the first operation of the CopyToCDWin business process, the File System
Adapter collects (reads) the daily.txt file from the Sterling B2B Integrator local file
system. This file becomes the primary document of the business process.

The second operation uses the CD Server Begin Session Service to establish a
connection to the remote Sterling Connect:Direct for Microsoft Windows node,
CDWIN. The local node name of the Connect:Direct Server Adapter is SI51CD. The
Begin Session Service uses the remote user ID of cduser to authenticate to the
Sterling Connect:Direct server.

The third operation uses the CD Server CopyTo Service to copy the primary
document to the remote Sterling Connect:Direct server. The Sysopts specifies that
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the file is not translated. The destination file name is cd.txt. The Session Token
created by the CD Server Begin Session Service identifies the session that is
established with the remote Sterling Connect:Direct node. The SessionToken value
in the CD Server CopyTo Service ensures that this service copies the file using the
session initiated by the CD Server Begin Session Service.

The fourth operation uses the CD Server End Session Service to terminate the
session with the Sterling Connect:Direct server.

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.
<process name="CopyToCDWin">

<sequence>
<operation name="File System Adapter">

<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>

<operation name="CD Server Begin Session Service">
<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd">xxxxxxxx</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server CopyTo Service">

<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteFileName">C:\cd.txt</assign>
<assign to="Sysopts">xlate(no)</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">

</assign><assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server End Session Service">

<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken"

from="//BeginSessionResults/SessionToken/node()"></assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>
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</input>
</operation>
</sequence>

</process>

Use Sterling B2B Integrator to Copy a File to a Sterling
Connect:Direct for UNIX Node

In this sample, shown in BPML, the Sterling B2B Integrator CopyToCDUX business
process passes a document to the Connect:Direct Server Adapter (PNODE) which
copies the file to the Sterling Connect:Direct for UNIX node (SNODE). The
business process functions much like a Sterling Connect:Direct process.

In the first operation of the CopyToCDUX business process, the File System
Adapter collects (reads) the invoice.dly file from the Sterling B2B Integrator local
file system. This file becomes the primary document of the business process.

The second operation uses the CD Server Begin Session Service to establish a
connection to the remote Sterling Connect:Direct for UNIX node, CDUX. The local
node name of the Connect:Direct Server Adapter is SI51CD. The Begin Session
Service uses the remote user ID of cduser to authenticate to the Sterling
Connect:Direct server.

The third operation uses the CD Server CopyTo Service to copy the primary
document to the remote Sterling Connect:Direct server. The destination file name is
daily.inv. The Sysopts specifies that the file datatype of the file is text and the file is
not translated. The Session Token created by the CD Server Begin Session Service
identifies the session that is established with the remote Sterling Connect:Direct
node. The SessionToken value in the CD Server CopyTo Service ensures that this
service copies the file using the session initiated by the CD Server Begin Session
Service.

The fourth operation uses the CD Server End Session Service to terminate the
session with the Sterling Connect:Direct server.

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.

<process name="CopyToCDUX">
<sequence>

<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">invoice.dly</assign>
<assign to="collectionFolder">/daily/tran</assign>
<assign to="deleteAfterCollect">false</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation><operation name="CD Server Begin Session Service">

<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDUX</assign>
<assign to="RemotePasswd">xxxxxxxx</assign>
<assign to="RemoteUserId">cduser</assign>
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<assign to="UsingObscuredPasswd">NO</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server CopyTo Service">

<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteFileName">/invoices/daily.inv</assign>
<assign to="Sysopts">:datatype=text:xlate=no:</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server End Session Service">

<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken"
from="//BeginSessionResults/SessionToken/node()"></assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
</sequence>

</process>

Use Sterling B2B Integrator to Copy a File to a Sterling
Connect:Direct for HP NonStop Node

In this sample, shown in BPML, the Sterling B2B Integrator CopyToCDHPNonStop
business process passes a document to the Connect:Direct Server Adapter
(PNODE) which copies the file to the Sterling Connect:Direct for HP NonStop node
(SNODE). The business process functions much like a Sterling Connect:Direct
process.

In the first operation of the CopyToCDHPNonStop business process, the File
System Adapter collects (reads) the daily.txt file from the Sterling B2B Integrator
local file system. This file becomes the primary document of the business process.

The second operation uses the CD Server Begin Session Service to establish a
connection to the remote Sterling Connect:Direct for HP NonStop node, CDHPNS.
The local node name of the Connect:Direct Server Adapter is SI51CD. The Begin
Session Service uses the remote user ID of cduser to authenticate to the Sterling
Connect:Direct server.

The third operation uses the CD Server Run Task Service to delete any previous
copy of the HP NonStop file. The PURGE $VOL.SUBVOL.CDSATEST! command is
passed to the File Utility Program (FUP) which deletes $VOL.SUBVOL.CDSATEST
on the HP NonStop system.

The fourth operation uses the CD Server CopyTo Service to copy the primary
document to the remote Sterling Connect:Direct server. The destination file name is
$VOL.SUBVOL.CDSATEST. BinaryMode is set to NO to send the file as text and
the Sysopts are SET TYPE E,REC 80 to create an 80 byte record of file type E.

Sterling Connect:Direct and Sterling B2B Integrator Interoperability 91



CDDisposition is set to NEW because any previous version of the file is deleted.
The Session Token created by the CD Server Begin Session Service identifies the
session that is established with the remote Sterling Connect:Direct node. The
SessionToken value in the CD Server CopyTo Service ensures that this service
copies the file using the session initiated by the CD Server Begin Session Service.

The last operation uses the CD Server End Session Service to terminate the session
with the Sterling Connect:Direct server.

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.
<process name="CopyToCDHPNonStop">
<sequence>
<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="deleteAfterCollect">false</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Begin Session Service">
<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDHPNS</assign>
<assign to="RemotePasswd">xxxxxxxx</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>

<operation name="CD Server Run Task Service">
<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="Program">FUP</assign>
<assign to="SystemOpts">PURGE $VOL.SUBVOL.CDSATEST!</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>

<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteFileName">$VOL.SUBVOL.CDSATEST</assign>
<assign to="BinaryMode">NO</assign>
<assign to="Sysopts">SET TYPE E,REC 80</assign>
<assign to="CDDisposition">NEW</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>
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</input>
</operation>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken"

from="//BeginSessionResults/SessionToken/node()"></assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
</sequence>

</process>

Use Sterling B2B Integrator to Copy a File to a Sterling
Connect:Direct for i5/OS Node

In this sample, shown in BPML, the Sterling B2B Integrator CopyToCDi5OS
business process passes a document to the Connect:Direct Server Adapter
(PNODE) which copies the file to the Sterling Connect:Direct for i5/OS node
(SNODE). The business process functions much like a Sterling Connect:Direct
process.

In the first operation of the CopyToCDi5OS business process, the Mailbox Extract
Begin Service retrieves the test1.zip message from the Sterling B2B Integrator
mailbox system. This file becomes the primary document of the business process.

The second operation uses the CD Server Begin Session Service to establish a
connection to the remote Sterling Connect:Direct for i5/OS node, CDi5OS. The
local node name of the Connect:Direct Server Adapter is SI51CD. The Begin
Session Service uses the remote user ID of cduser to authenticate to the Sterling
Connect:Direct server.

The third operation uses the CD Server CopyTo Service to copy the primary
document to the remote Sterling Connect:Direct server. The destination file name is
test3.zip. BinaryMode is set to YES to send the file in binary mode and the Sysopts
set TEXTFILE to NO to create a text file. CDDisposition is set to RPL and
CheckpointInterval is set to 1000. The Session Token created by the CD Server
Begin Session Service identifies the session that is established with the remote
Sterling Connect:Direct node. The SessionToken value in the CD Server CopyTo
Service ensures that this service copies the file using the session initiated by the
CD Server Begin Session Service.

The fourth operation uses the CD Server End Session Service to terminate the
session with the Sterling Connect:Direct server.

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.
<process name="CopyToCDi5OS">

<sequence>
<operation name="Mailbox ExtractBegin Service">

<participant name="MailboxExtractBegin"/>
<output message="ExtractBeginRequest">
<assign to="MessageName">test1.zip</assign>
<assign to="MessageId">36</assign>
<assign to="CommitNow">Yes</assign>
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<assign to="." from="*"></assign>
</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Begin Session Service">

<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDi5OS</assign>
<assign to="RemotePasswd">xxxxxxxx</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server CopyTo Service">

<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteFileName">/home/qadata/test3.zip</assign>
<assign to="BinaryMode">YES</assign>
<assign to="Sysopts">TEXTFILE(*NO)</assign>
<assign to="CheckpointInterval">1000</assign>
<assign to="CDDisposition">RPL</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server End Session Service">

<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken"

from="//BeginSessionResults/SessionToken/node()"></assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
</sequence>

</process>

Use Sterling B2B Integrator to Copy a File from Sterling
Connect:Direct

In this sample, shown in BPML, the Sterling B2B Integrator CopyFromCD business
process invokes the Connect:Direct Server Adapter (PNODE) which copies the file
from the Sterling Connect:Direct node (SNODE) back to the business process as the
primary document. The business process functions much like a Sterling
Connect:Direct process.

The first operation uses the CD Server Begin Session Service to establish a
connection to the remote Sterling Connect:Direct node, CDWIN. The local node
name of the Connect:Direct Server Adapter is SI51CD. The Begin Session Service
uses the remote user ID of cduser to authenticate to the Sterling Connect:Direct
server.
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The second operation uses the CD Server CopyFrom Service to copy the source file
from the remote Sterling Connect:Direct server. The source file name is sample.txt.
The Session Token created by the CD Server Begin Session Service identifies the
session that is established with the remote Sterling Connect:Direct node. The
SessionToken value in the CD Server CopyTo Service ensures that this service
copies the file using the session initiated by the CD Server Begin Session Service.

The third operation uses the CD Server End Session Service to terminate the
session with the Sterling Connect:Direct server.

The last operation uses the MailboxAdd service to store the file sample.txt as a
message in mailbox /box1.

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.
<process name="CopyFromCD">

<sequence>
<operation name="CD Server Begin Session Service">

<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd">xxxxxxxx</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server CopyFrom Service">

<participant name="CDServerCopyFrom"/>
<output message="CDServerCopyFromServiceTypeInputMessage">
<assign to="RemoteFileName">sample.txt</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server End Session Service">

<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>

<!-- Add Msg to mailbox -->
<operation name="Mailbox Add Service">

<participant name="MailboxAdd"/>
<output message="AddRequest">
<assign to="." from="*"></assign>
<assign to="MailboxPath">/box1</assign>
<assign to="MessageName">sample.txt</assign>
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</output>
<input message="inmsg">
<assign to="AddResults" from="*"></assign>
</input>

</operation>
</sequence>
</process>

Add Error Handling to the Business Process
In this sample, shown in BPML, add error handling to the Sterling B2B Integrator
business process you created that passes a document to the Connect:Direct Server
Adapter (PNODE) which copies the file to the Sterling Connect:Direct node
(SNODE). The error handling ensures that the Sterling Connect:Direct session
closes if an error is encountered during the session.

The onFault branch contains an instance of the CD Server End Session Service. If
an error occurs after the Begin Session Service, the onFault logic is invoked and the
End Session Service terminates the session with the Sterling Connect:Direct server.

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.
<process name="CopyToCD">
<sequence>
<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Begin Session Service">
<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd">xxxxxxxx</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<sequence>
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteFileName">cd.txt</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
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<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<onFault>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">

<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>
</onFault>

</sequence>
</sequence>

</process>

Use Sterling B2B Integrator to Submit a Sterling
Connect:Direct Process

In this sample, shown in BPML, modify the Sterling B2B Integrator business
process to submit a process on the Sterling Connect:Direct node after the file is
copied. The Sterling Connect:Direct process copies the file received from Sterling
B2B Integrator to a z/OS system.

The CD Server Submit Service is placed after the CD Server CopyTo Service. The
Submit Service submits a Sterling Connect:Direct process called Copy2ZOS.cdp.

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.
<process name="CopyToCD_Submit">
<sequence>
<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Begin Session Service">
<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd">xxxxxxxx</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>
<assign to="." from="*"></assign>
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</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<sequence name="Sequence Start">
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteFileName">cd.txt</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Submit Service">
<participant name="CDServerSubmit"/>
<output message="CDServerSubmitServiceTypeInputMessage">
<assign to="RemoteProcessFile">Copy2ZOS.cdp</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<onFault>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">

<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>
</onFault>

</sequence>
</sequence>

</process>

Use Sterling B2B Integrator to Start a Sterling Connect:Direct
Run Job

In this sample, shown in BPML, modify the Sterling B2B Integrator business
process to start a program on the Sterling Connect:Direct server using a Run Job
after a file is copied. The Connect:Direct Server Adapter does not verify the
validity of the submitted program and does not wait for the submitted job to
complete. The program runs as a separate process.
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The CD Server Run Job Service is placed after the CopyTo Service. The Run Job
Service passes pgm(C:\Windows\notepad.exe) desktop(yes) to the remote Sterling
Connect:Direct server via Sysopts. This causes the Microsoft Windows Notepad
application to run on the Sterling Connect:Direct server.

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.
<process name="CopyToCD_RunJob">
<sequence>
<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Begin Session Service">
<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd">xxxxxxxx</assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation> <sequence name="Sequence Start">
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteFileName">cd.txt</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>

<operation name="CD Server Run Job Service">
<participant name="CDServerRunJob"/>
<output message="CDServerRunJobServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="Sysopts">pgm(C:\Windows\notepad.exe) desktop(yes)</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>
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</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<onFault>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">

<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>
</onFault>

</sequence>
</sequence>

</process>

Use Sterling B2B Integrator to Start a Sterling Connect:Direct
Run Task

In this sample, shown in BPML, modify the Sterling B2B Integrator business
process to start and wait on a program on the Sterling Connect:Direct server via a
Run Task after the source file is copied. The program may be a program or script.
The Connect:Direct Server Adapter does not verify the validity of the submitted
program, but it does wait for the submitted job to complete before moving to the
next service in the business process. The program or script runs as a separate
process.

The CD Server Run Task Service is placed after the CopyTo Service. The Run Task
Service passes pgm(C:\Windows\notepad.exe) desktop(yes) to the remote Sterling
Connect:Direct server via the SystemOpts parameter. (SystemOpts is the equivalent
of Sysopts.) This causes the Microsoft Windows Notepad application to run on the
Sterling Connect:Direct server.

Note: Do not enclose the value specified for SystemOpts in double quotes.

To see BPML source code like the example shown below, select View > Source
while using the Sterling B2B Integrator Graphical Process Modeler (GPM). To see
the business process as depicted in the GPM user interface, select View > Graph.
<process name="CopyToCD_RunTask">
<sequence>
<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Begin Session Service">
<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd">xxxxxxxx</assign>
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<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">NO</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation> <sequence name="Sequence Start">
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteFileName">cd.txt</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Run Task Service">
<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="SystemOpts">pgm(C:\Windows\notepad.exe) desktop(yes)</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<onFault>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">

<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>
</onFault>

</sequence>
</sequence>

</process>

Hide the Sterling Connect:Direct Password in the Business
Process

In this sample, shown in BPML, modify the Sterling B2B Integrator business
process by adding an Obscure Data - Process Data Values Service before the CD
Server Begin Session Service to hide the value of the user password.

The first operation in the business process is Obscure Data - Process Data Values.
This service works with the CD Server Begin Session Service so that the password
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for the remote Sterling Connect:Direct User ID, cduser, is not revealed in the
business process. The password is retrieved using the RemotePasswd parameter,
which is set to cduser/text( )in the Begin Session Service.

Note: Do not enclose the value specified for SystemOpts in double quotes.
<process name="CopyToCD_HidePassword">
<sequence>
<operation name="File System Adapter">
<participant name="CollectForCD"/>
<output message="FileSystemInputMessage">
<assign to="Action">FS_COLLECT</assign>
<assign to="filter">daily.txt</assign>
<assign to="collectionFolder">C:\Collection</assign>
<assign to="deleteAfterCollect">false</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="Obscure Data - Process Data Values">
<participant name="CDClientObscureParameter"/>
<output message="ObscureParameterInputMessage">
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Begin Session Service">
<participant name="CDServerBeginSession"/>
<output message="CDServerBeginSessionServiceTypeInputMessage">
<assign to="LocalCDNodeName">SI51CD</assign>
<assign to="RemoteCDNodeName">CDWIN</assign>
<assign to="RemotePasswd" from="cduser/text()"></assign>
<assign to="RemoteUserId">cduser</assign>
<assign to="UsingObscuredPasswd">YES</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="BeginSessionResults" from="*"></assign>

</input>
</operation><sequence name="Sequence Start">
<operation name="CD Server CopyTo Service">
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteFileName">cd.txt</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Run Task Service">
<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="SystemOpts">pgm(C:\Windows\notepad.exe) desktop(yes)</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>

<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
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<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<onFault>
<operation name="CD Server End Session Service">
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">

<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">

<assign to="." from="*"></assign>
</input>

</operation>
</onFault>

</sequence>
</sequence>

</process>

Use Sterling B2B Integrator to Copy a File to Sterling
Connect:Direct for z/OS (Advanced)

In this sample, shown in BPML, the Sterling B2B Integrator CopyToCDzOS
business process passes a document to the Connect:Direct Server Adapter
(PNODE) which copies the file to the Sterling Connect:Direct for z/OS node
(SNODE). The business process functions much like a Sterling Connect:Direct
process. In this complex example containing nine operations, the operation
numbers are shown in the BPML code and correspond to the following narrative.

In Operation 1 of the CopyToCDzOS business process, the File System Adapter
collects (reads) the bp1mbin.txt file from the Sterling B2B Integrator local file
system. This file becomes the primary document of the business process.

Operation 2 uses the CD Server Begin Session Service to establish a connection to
the remote Sterling Connect:Direct node, CD.ZOS. The local node name of the
Connect:Direct Server Adapter is SI51CD. The Begin Session Service uses the
remote user ID of cduser to authenticate to the Sterling Connect:Direct server.

Operation 3 executes a CD Server Run Task service to delete and uncatalog the
output file, CSDQA1.O.TESTFILE.SMS2, if that file already exists. In addition, this
operation unallocates the CSDQA1.O.TESTFILE.SMS2 file.

Note: SystemOpts is the equivalent of Sysopts.

Also, do not enclose the value specified for SystemOpts in double quotes.

Operation 4 uses the CD Server CopyTo Service to copy the primary document to
the remote Sterling Connect:Direct for z/OS node. The CopyTo Service allocates an
SMS managed file on z/OS with the following Remote parms:
v RemoteSMS—SMS parms passed to z/OS for allocation. This parm specifies that

the z/OS system allocates this file with a DATACLAS of CSGWORK,
STORCLAS of BENCH, MGMTCLAS of STANDARD, and uses kilobytes (K) as
the allocation unit (AVGREC)

v RemoteDISP— the disposition of the new file.
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v RemoteFileName—the name of the destination z/OS dataset.
v RemoteSPACE—defines the space requirements for the allocation.

Operation 5 uses the CD Server Run Task Service to execute the DMRTDYN utility
program to perform the following functions:
v Allocate a file on the z/OS system with a DDname of OLDDD to be used as a

basis for comparison to the output file
v Allocate the output file from the previous step with a DDname of NEWDD for a

comparison.
v Allocate an output DD called OUTDD that holds the output report file for the

Compare step instead of an actual file.

Operation 6 uses the CD Server Run Task Service to execute the ISRSUPC
program, a compare utility. The ISRSUPC program compares the file allocated to
OLDDD and the file allocated to NEWDD using the parms in the Sysopts. The
results are written to the OUTDD.

Operation 7 uses the CD Server Run Task Service to execute DMRTDYN to
deallocate OLDDD, NEWDD and OUTDD.

Operation 8 uses the CD Server End Session Service to terminate the session with
the Sterling Connect:Direct server after the business process has executed
successfully. To accommodate error processing, Operation 9 contains an onFault
branch with its own instance of the CD Server End Session Service. If an error
occurs after the Begin Session Service, the onFault logic is invoked and the End
Session Service terminates the session with the Sterling Connect:Direct server.

Note: To see BPML source code like the example shown below, select View >
Source while using the Sterling B2B Integrator Graphical Process Modeler (GPM).
To see the business process as depicted in the GPM user interface, select View >
Graph.
<operation name="CD Server Run Task Service"> OPERATION 3

<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypeInputMessage">
<assign to="SystemOpts">C’ ALLOC’,C’ DSN=CSDQA1.O.TESTFILE.SMS2’,

C’ DISP=(MOD,DELETE)’,F’-1’,C’ UNALLOC’,
C’ DSN=CSDQA1.O.TESTFILE.SMS2’</assign>

<assign to="Program">DMRTDYN</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server CopyTo Service"> OPERATION 4
<participant name="CDServerCopyTo"/>
<output message="CDServerCopyToServiceTypeInputMessage">
<assign to="RemoteSMS">DATACLAS=CSGWORK AVGREC=K STORCLAS=BENCH MGMTCLAS=STANDARD
</assign>
<assign to="RemoteDISP">(NEW,KEEP,DELETE)</assign>
<assign to="RemoteFileName">CSDQA1.O.TESTFILE.SMS2</assign>
<assign to="RemoteSPACE">(TRK,(18,2),RLSE)</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Run Task Service"> OPERATION 5
<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypeInputMessage">
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<assign to="SystemOpts">C’ ALLOC’,C’ DSN=CSDQA1.TESTFILE.BENCH.M1’,
C’ DISP=SHR’,C’ DD=OLDDD’,F’-1’,C’ ALLOC’,
C’ DSN=CSDQA1.O.TESTFILE.SMS2’,C’ DISP=SHR’,
C’ DD=NEWDD’,F’-1’,C’ ALLOC’,C’ DD=OUTDD’,
C’ DUMMY’,C’ SYSOUT=A’

</assign>
<assign to="Program">DMRTDYN</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server Run Task Service"> OPERATION 6
<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypeInputMessage">
<assign to="SystemOpts">C’ DELTAL’,C’ LINECMP’,C’’,C’’</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="Program">ISRSUPC</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>

<operation name="CD Server Run Task Service"> OPERATION 7
<participant name="CDServerRunTask"/>
<output message="CDServerRunTaskServiceTypeInputMessage">
<assign to="SystemOpts">C’ UNALLOC’,C’ DD=OLDDD’,F’-1’,

C’ UNALLOC’,C’ DD=NEWDD’,F’-1’,C’ UNALLOC’,
C’ DD=OUTDD’

</assign>
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()"></assign>
<assign to="Program">DMRTDYN</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<operation name="CD Server End Session Service"> OPERATION 8
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>
<onFault>
<operation name="CD Server End Session Service"> OPERATION 9
<participant name="CDServerEndSession"/>
<output message="CDServerEndSessionServiceTypeInputMessage">
<assign to="SessionToken" from="//BeginSessionResults/SessionToken/node()">
</assign>
<assign to="." from="*"></assign>

</output>
<input message="inmsg">
<assign to="." from="*"></assign>

</input>
</operation>

</onFault>
</sequence>

</process>

Copy Options
There are many copy options available when you use the Connect:Direct Server
CopyTo Service.
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When you using the Sterling Connect:Direct Server Adapter to copy a file to a
remote Sterling Connect:Direct server, coordinate the copy options with the Sterling
Connect:Direct administrator.

Settings for Connect:Direct Server CopyTo Service
When you configure the Connect:Direct Server CopyTo service, you must specify
settings for the following fields in the Graphical Process Modeler. These fields are
listed in alphabetical order.

Note: Sterling B2B Integrator version 5.1 and later supports the most common set
of parameters available in the Sterling Connect:Direct for z/OS Process Copy
statement To clause to provide more functionality, such as enhanced file allocation
and disposition options for the destination file on the remote Sterling
Connect:Direct for z/OS node. To ensure that business processes created in earlier
versions of Sterling B2B Integrator continue to execute properly, parameters
existing in versions 5.0 and earlier will still be supported. These old parameters,
which cannot be mixed with new parameters in the same CopyTo service, are not
included in the following table.

For users familiar with the Sterling Connect:Direct Process language, the CD Server
CopyTo Service parameters with the Remote prefix are equivalent to the
parameters specified in the COPY TO clause of a COPY statement and refer to the
destination file being copied to the Sterling Connect:Direct node. The parameters
with the Local prefix correspond to the parameters specified in the COPY FROM
clause and refer to the source file on the Sterling Connect:Direct Server Adapter
node.

Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

BinaryMode Specifies how the data from the source
file on the local Connect:Direct Server
Adapter node will be transferred to the
remote Sterling Connect:Direct node.
Optional.

Valid values are:

v Yes—file will be transferred in simple
binary mode

v No—file will not be transferred in
binary mode but rather in text mode
(default)

v VB—copy will be performed as a
variable block binary transfer with
Sterling Connect:Direct on the z/OS
platform

Yes—All
platforms

No—All
platforms

VB—z/OS
platform

CDRecordType Specifies the entry name of the type
defaults file. The type defaults file
contains the default file attributes used
to allocate the destination file. The type
defaults file is specified only when
defaults are requested by the user.
Optional.

z/OS platform
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Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

CheckpointInterval Specifies the byte interval for
checkpoint support, which allows
restart of interrupted transmissions at
the last valid checkpoint point and
therefore reduces the time to retransmit
the file. Optional. For more information,
see How Checkpoint Restart and Retry
Processing Works.

Valid value is number of bytes, in one
of the following formats:

v nnnnnnnnnn

v nK or nM

v nm or nk

All platforms

Compression Specifies that the data is to be
compressed, which reduces the amount
of data transmitted as the file is copied
from one node to another. The file will
be automatically decompressed at the
destination. Optional. Valid values are
1-9. Increasing the value indicates a
greater attempt at compression and will
consume more CPU. Values greater
than 2 may not result in further
compression.

All platforms

Config Name of the service configuration.
Required.

All platforms

LocalDocumentId A valid document ID for an existing
document in Application. When this
field is left blank, the primary
document provided to the business
process is used. Optional.

All platforms

LocalFileNameLabel Specifies a label for the name of the
local file. This file name label is
provided to the remote Sterling
Connect:Direct node for informational
purposes only. Optional.

All platforms
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Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

LocalFromCodePage Specifies a code page supported by Java
VM. Used in conjunction with the value
of the LocalToCodePage parameter. The
Connect:Direct Server Adapter will
apply a code page conversion to a
document before transferring it to a
remote Sterling Connect:Direct Server.
This parameter is only valid with the
following conditions:

v Code page specified is supported by
the local Java VM

v Parameter LocalToCodePage is
defined

v Text mode file transfer (BinaryMode
=No)

Optional. Valid value is the name of a
codepage supported by the local Java
VM.

For example:

<assign
to="LocalFromCodePage">Cp1251</
assign>

<assign
to="LocalToCodePage">Cp1047</
assign>

This example will translate the local file
from windows latin-1 to ibm ebcdic. See
http://java.sun.com for a complete list
of supported encodings.

All platforms

LocalStripBlanks Specifies whether the Connect:Direct
Server Adapter will strip blanks from
the end of records in the local file
before sending them to the remote
node. This option is only valid for Text
mode file transfers (BinaryMode = No).
Optional.

Valid value is Yes or No (default).

All platforms
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Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

LocalToCodePage Specifies a code page supported by Java
VM. Used in conjunction with the value
of the LocalFromCodePage parameter.
The Connect:Direct Server Adapter will
apply a code page conversion to a
document before transferring it to a
remote Sterling Connect:Direct Server.
This parameter is only valid with the
following conditions:

v Code page specified is supported by
the local Java VM

v Parameter LocalFromCodePage is
defined

v Text mode file transfer (BinaryMode
=No)

Optional. Valid value is the name of a
codepage supported by the local Java
VM.

For example:

<assign
to="LocalFromCodePage">Cp1251</
assign>

<assign
to="LocalToCodePage">Cp1047</
assign>

This example will translate the local file
from windows latin-1 to ibm ebcdic. See
http://java.sun.com for a complete list
of supported encodings.

All platforms

LocalXlate Specify the new LocalXlateTable
Connect:Direct CopyTo/CopyFrom
Service parameter to indicate which
translation table the service should use
during transmission. It may be specified
using the Graphical Process Modeler or
by editing the XML source of the
business process.

For example:

<assign to="LocalXlate">Yes</assign>

<assign to="LocalXlateTable">ascii-to-
ebcdic-table</assign>

All platforms

RemoteBUFND Specifies the number of I/O buffers
VSAM will use for transmitting data
between virtual and auxiliary storage.
Optional.

Used only on the z/OS platform.

z/OS platform
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Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

RemoteDATAEXIT Specifies a user-written program
through which data is processed before
being written to the destination file.
Optional.

Used only on the z/OS platform. Valid
syntax is:

exit-name | (exit-name [,parameter,...])

z/OS platform

RemoteDCB Specifies Data Control Block (DCB), a
group of attributes to be used in
allocating destination files on a z/OS
system.

Used only on the z/OS platform.
Optional. Valid attributes are:

([model-file-name]

[,BLKSIZE=no.-bytes]

[,DEN=0 | 1 | 2 |3 | 4]

[,DSORG=[PS | PO | DA | VSAM]

[,KEYLEN=no.-bytes]

[,LIMCT=no.-blocks-or-tracks]

[,LRECL=no.-bytes]

[,OPTCD=W | Q | Z]

[,RECFM=record-format]

[,RKP=first-byte-position-of-record-key]

)

z/OS platform
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Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

RemoteDISP Specifies how the destination file is to
be created on the remote Sterling
Connect:Direct server. Optional.

Valid syntax for Sterling Connect:Direct
for z/OS is:

([NEW | OLD | MOD | RPL | SHR],

[KEEP | CATLG] ,

[KEEP | CATLG | DELETE]

)

|

(NEW | OLD | MOD | RPL | SHR)

|

NEW | OLD | MOD | RPL | SHR

All platforms

RemoteFileName Name that should be given to the file
that is copied to the remote Sterling
Connect:Direct server. Required.
Note: You cannot use wildcards to
copy multiple files from Sterling B2B
Integrator to Sterling Connect:Direct
with a single CopyTo service.

All platforms

RemoteIOEXIT Specifies a user-written program to be
invoked to perform I/O requests on the
source file before copying the source
file to a destination file. Optional.

Used only on the z/OS platform. Valid
syntax is:

exit-name | (exit-name [,parameter,...])

z/OS platform

RemoteLABEL Specifies label information for the tape
used for the destination file. Optional.

Used only on the z/OS platform. Valid
syntax is:

([file-sequence-number]

,[SL | AL | BLP | LTM | NL | AUL |
NSL | SUL]

,[PASSWORD | NOPWREAD]

,[IN | OUT]

,[RETPD=nnnn | EXPDT=[yyddd |
yyyy/ddd]]

)

z/OS platform
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Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

RemoteMSVGP Specifies the group of mass storage
volumes that reside on a mass storage
system (MSS) device. This must be a
valid DD (data definition) name,
ranging from 1-8 alphanumeric
characters with the first character
alphabetic. Optional.

Used only on the z/OS platform. Valid
value is MS-group-name.

z/OS platform

RemoteSMS Specifies SMS attributes to use when
creating the destination file. Optional.

Used only on the z/OS platform. Valid
attributes are:

v AVGREC=U | K | M

v DATACLAS=data-class-name

v DSNTYPE=PDS | LIBRARY |
LARGE | EXTREQ | EXTPREF |
BASIC

v KEYLEN=length in bytes

v KEYOFF=offset-to-key

v LIKE=model-data-set-name

v LRECL=number of bytes

v MGMTCLAS=management-class-
name

v RECORG=KS | ES | RR | LS

v SECMODEL=(profile-name
[,GENERIC])

v STORCLAS=storage-class-name

z/OS platform

RemoteSPACE Specifies the amount of storage to be
allocated for new files on the
destination node. If SPACE is specified,
the RemoteDISP of the destination file
must be NEW or RPL. Optional.

Used only on the z/OS platform. Valid
syntax is:

(CYL | TRK | blk,

(prim, [sec] , [dir]), [RLSE] , [CONTIG] ,
[ROUND]) |

(av-rec-len, (primary-rcds ,
[secondary-rcds] , [dir])

)

z/OS platform
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Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

RemoteUNIT Specifies the storage device or type
along with the number of devices
required. Optional.

Used only on the z/OS platform. Valid
syntax is:

([unit-address | device-type |
group-name]

, [unit-count | P ] [,DEFER]

)

z/OS platform

RemoteVOL Specifies one or more volume serial
numbers containing the destination file
and optional processing associated with
the file. Optional.

Used only on the z/OS platform. Valid
syntax is:

([PRIVATE],[RETAIN]

,[volume-sequence-no],[volume-count]

[,SER=(serial-no [,serial-no,...])

|SER=serial-no)

|([SER=(serial-no,[serial-no,...]))

|(REF=dsn])

z/OS platform

SessionToken Identifies an established session
between two Sterling Connect:Direct
nodes. Required. Session integrity
cannot be guaranteed if the session
token is omitted. For examples of
session token usage, refer to Sample
Business Processes on the Sterling B2B
Integrator Side .

All platforms

Sysopts Remote system operations to be
implemented on the remote Sterling
Connect:Direct node. Optional.

For example (for copying to Sterling
Connect:Direct for Microsoft Windows
only):

Datatype(text) xlate(yes)

All platforms

Format of
Sysopts varies
by platform.

Settings for Connect:Direct Server CopyFrom Service
There are many copy options available when you use the Connect:Direct Server
CopyFrom Service.
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When you configure the Connect:Direct Server CopyFrom service, you must
specify settings for the following fields in the Graphical Process Modeler. These
fields are listed in alphabetical order.

Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

BinaryMode Specifies the mode for Sterling
Connect:Direct File transfer. Optional.
Valid values are:

v Yes—simple binary mode

v No—(default) - text mode

v VB—a variable block binary transfer
with Sterling Connect:Direct on z/OS

Yes—All
platforms

No—All
platforms

VB—z/OS
platform

CheckpointInterval Specifies the byte interval for
checkpoint support, which allows
restart of interrupted transmissions at
the last valid checkpoint point and
therefore reduces the time to retransmit
the file. Optional. For more information,
see How Checkpoint Restart and Retry
Processing Works .

Valid value is number of bytes, in one
of the following formats:

v nnnnnnnnnn

v nK or nM

v nm or nk

All platforms

Compression Specifies that the data is to be
compressed, which reduces the amount
of data transmitted as the file is copied
from one node to another. The file will
be automatically decompressed at the
destination. Optional. Valid values are
1-9. Increasing the value indicates a
greater attempt at compression and will
consume more CPU. Values greater
than 2 may not result in further
compression.

All platforms

Config Name of the service configuration.
Required.

All platforms

DCB Specifies Data Control Block (DCB), a
group of attributes specified as
name-value pairs separated by commas.
Used only on the z/OS platform.
Optional. Valid attributes are:

v recordlength

v blocksize

v recordformat

v datasetorganization
Note: More DCB attributes are
available but only these are
supported in Application. Any other
attribute will cause the copy to fail.

z/OS platform
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Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

LocalDocumentName Name of the document in Application
to which the remote file should be
copied. Optional.

All platforms

LocalFromCodePage Specifies a code page supported by Java
VM. Used in conjunction with the value
of the LocalToCodePage parameter. The
Connect:Direct Server Adapter will
apply a code page conversion to a
document before transferring it to a
remote Sterling Connect:Direct Server.
This parameter is only valid with the
following conditions:

v Code page specified is supported by
the local Java VM

v Parameter LocalToCodePage is
defined

v Text mode file transfer (BinaryMode
=No)

Optional. Valid value is the name of a
codepage supported by the local Java
VM.

For example:

<assign
to="LocalFromCodePage">Cp1251</
assign>

<assign
to="LocalToCodePage">Cp1047</
assign>

This example will translate the local file
from windows latin-1 to ibm ebcdic. See
http://java.sun.com for a complete list
of supported encodings.

All platforms

LocalStripBlanks Specifies whether the Connect:Direct
Server Adapter will strip blanks from
the end of records in a received remote
file before creating a new document.
This option is only valid for Text mode
file transfers (BinaryMode = No).
Optional.

Valid value is Yes or No (default).

All platforms
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Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

LocalToCodePage Specifies a code page supported by Java
VM. Used in conjunction with the value
of the LocalFromCodePage parameter.
The Connect:Direct Server Adapter will
apply a code page conversion to a
document before transferring it to a
remote Sterling Connect:Direct Server.
This parameter is only valid with the
following conditions:

v Code page specified is supported by
the local Java VM

v Parameter LocalFromCodePage is
defined

v Text mode file transfer (BinaryMode
=No)

Optional. Valid value is the name of a
codepage supported by the local Java
VM.

For example:

<assign
to="LocalFromCodePage">Cp1251</
assign>

<assign
to="LocalToCodePage">Cp1047</
assign>

This example will translate the local file
from windows latin-1 to ibm ebcdic. See
http://java.sun.com for a complete list
of supported encodings.

All platforms

LocalXlate Used to indicate which translation table
the service should use during
transmission. It may be specified using
the Graphical Process Modeler or by
editing the XML source of the business
process.. Optional.

Valid value is Yes (default) or No.

For example:

<assign to="LocalXlate">Yes

<assign to="LocalXlateTable">ascii-to-
ebcdic-table</assign>

All platforms

RemoteFileName Name of the file that should be copied
from the remote Sterling Connect:Direct
server. Enter the legal characters in the
file name. Required.

All platforms
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Field Description

Supported
Remote
Sterling
Connect:Direct
Platforms

SessionToken Identifies an established session
between two Sterling Connect:Direct
nodes. Required. Session integrity
cannot be guaranteed if the session
token is omitted. For examples of
session token usage, refer to Sample
Business Processes on the Sterling B2B
Integrator Side .

All platforms

Sysopts Remote system operations to be
implemented on the remote Sterling
Connect:Direct node. Optional.

For example (for copying from Sterling
Connect:Direct for Microsoft Windows
only):

Datatype(text) xlate(yes)

All platforms

Format of
Sysopts varies
by platform.

Clustering Considerations for Connect:Direct Server Adapter
When you configure a Connect:Direct Server Adapter in a single node instance of
Sterling B2B Integrator, the best practice is to use the same name for the
Connect:Direct Server Adapter Name and the Connect:Direct Server Node Name.

When you configure a Connect:Direct Server Adapter in a multiple node instance
of Sterling B2B Integrator, the best practice is to set up one Group Name for the
Connect:Direct Server Adapters. For example, in a two node cluster, the
Connect:Direct Server Adapter Node Names are NODE1.CD and NODE2.CD. Both
of these nodes are put in one group called SI.CD. Provide SI.CD as the
Connect:Direct Server Adapter Node Name for your remote Sterling Connect:Direct
nodes. You will also use SI.CD as the LocalCDNodeName in the CD Server Begin
Session Service in your business processes.

Monitoring Business Processes and Documents
The Sterling B2B Integrator Admin Console enables you to view information about
business processes that interact with remote Sterling Connect:Direct nodes.
Correlation records are automatically maintained so that you can search for specific
information (such as, business process IDs, document IDs, workflow IDs, and
mailbox IDs). Each business process references a unique business process ID as its
primary process identifier.

Tracking and Search Functions
The tracking and search functions available to track Sterling B2B Integrator
business processes, Sterling Connect:Direct processes, and Connect:Direct adapter
activity are described in the following table:

Tracking Option Description

Central Search Use to search for live (active) business process instances that do not
appear in the Current Processes. Search by Name, Status, or Date.
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Tracking Option Description

Current Processes Lists the status of the ten most recent business process instances.

Current Activities Search for Connect:Direct Server Adapter activity by adapter
configuration name or by when the activity registered within Sterling
B2B Integrator.

Advanced Search

Business
Processes

Search for active, archived or stored business processes. Search by
business process instance ID, business process Name, State, or Date.

Documents Search for active, archived or stored documents handled by a business
process. Search by Time, Document ID, Sender or Receiver ID, Type,
Status or Correlations.

Communication
Sessions

Search for active, archived or stored communication sessions records.
These records include the associated authentication, authorization, file
transfer, or non-file transfer records, even if a document is not
transferred and no data flow record is created. Search by Time,
Communication Session ID, Process ID, End Point, Protocol and so
forth.

Correlation Search for active, archived or stored business processes by name-value
pairs. This is a key tracking method in interoperability because you can
search by values such as PNODE, SNODE, Sterling Connect:Direct
Process Name and so forth.

When you find the business process you are interested in on any of these Monitor
pages, you can obtain additional details by selecting the number in the ID column
to open the Business Process Details page.

Business Process Detail
The Business Process Detail page is accessed from any page that contains the
business process ID. This page provides a progress report about a specific business
process instance. In addition, you can stop or restart the business process from this
page.

Following is a partial list of the information you can obtain from this page:
v The business process definition (the BPML file)
v The current state of each step in a business process
v The date and time a business process started and ended
v The contents of the process data and the primary document at each step of the

business process

Current Process Monitor
Selecting Business Processes > Current Processes opens the Monitor page with a
list of the processes currently running in Sterling B2B Integrator. A Green status
indicates no errors or warnings occurred during processing. A Red status indicates
errors or warnings encountered during processing. Use this page to do the
following:
v Review detailed processing information by clicking on the ID of the process
v View the business process definition by clicking on the Name of the process
v View the current state of a business process
v View the date and time a business process Started and Ended
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Current Activities Monitor
Selecting Business Processes > Current Activities opens the Service Activity search
page. The Service Activity page enables you to monitor activity of several adapters,
including the Connect:Direct Server Adapter. When you select an adapter to
monitor, activity detail occurring on the adapter is displayed.

If the Connect:Direct Server Adapter is used by a business process that has
stopped running, you can use this feature to determine whether the adapter is
preventing the business process from running.

The results of an activities search includes the following information:
v Session identifier
v Node name
v When the activity started and when it last updated

Correlation Search
Correlation searches are a key to relating a Sterling Connect:Direct Process with a
Sterling B2B Integrator business process. Whereas Sterling Connect:Direct identifies
a process with a Process Number and a Process Name, Sterling B2B Integrator
identifies its business processes with an Instance ID. The Correlation Search
enables you to search for Sterling B2B Integrator processes using Sterling
Connect:Direct identifiers.

Note: Correlations are created to identify related Sterling B2B Integrator and
Sterling Connect:Direct processes.

The Connect:Direct Server Adapter and related services automatically write
Sterling B2B Integrator correlation records to enable searches for business processes
and documents containing certain correlation identifiers.

The Correlation Search page enables you to search for business process activity
according to six Sterling Connect:Direct specific name-value pairs, including:
v CD_LocalFileName
v CD_RemoteFileName
v CD_ProcessName
v CD_ProcessNum
v CD_PnodeName
v CD_SnodeName

Note: Do not perform a correlation search by Process Number only. A Process
Number is unique to a single Sterling Connect:Direct server, therefore you may see
the same Process Number used for different processes—each associated with a
different node.

Session Establishment and Process Recovery
Sterling B2B Integrator provides several parameters that allow you to customize
features that govern how many sessions it establishes for a Connect:Direct Server
Adapter node and remote Sterling Connect:Direct nodes and how it performs retry
processing in the case of a failed or interrupted file transfer.
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How Sessions for Business Processes Are Established
Before you transfer files or initiate processes between Sterling Connect:Direct
servers and the Sterling Connect:Direct Server Adapter, you configure those
components in Sterling B2B Integrator so that it knows who it will be
communicating with. One of the required parameters you define for both Sterling
Connect:Direct nodes and the Connect:Direct Server Adapter is the maximum
number of locally initiated sessions the Connect:Direct Server Adapter may have
active at any point in time. This parameter, Max locally initiated (pnode) sessions
allowed, determines the maximum number of sessions available for establishing
and re-establishing sessions, and plays a key role when business processes are
suspended and resumed. If this value is also specified at the remote node-level, the
effective session limit is the smaller of two values: the limit for the adapter and the
session limit for the remote node.

When a Connect:Direct Server Adapter initiates a data transfer between itself and a
remote Sterling Connect:Direct node, it does so as part of a Sterling B2B Integrator
business process. If the business process invokes a Connect:Direct Server Adapter
service to establish a session and the local PNODE session limit has been met, the
business process is suspended and placed in a queue of business processes waiting
for an available session. When a session has become available, it is assigned to a
previously suspended business process, if any, on a first-come first-served basis.

The first (oldest) suspended business process is given the first chance to use the
next free PNODE session for the Connect:Direct Server Adapter. If no suspended
business process can use the session or if no business processes are in the
suspended business process queue, the freed session is returned to the available
session count. If a PNODE session limit was also specified at the node level, the
number of currently active sessions with the particular remote node and the total
number of active PNODE sessions are both decremented when a freed session goes
back to the available session count.

If Sterling B2B Integrator or a Connect:Direct Server Adapter is terminated while
business processes are suspending awaiting the next freed session, then an error is
returned to the service invocation that caused the business process to be
suspended.

If you suspect an error has occurred or that the execution of a business process has
been delayed, you can check its status and the status of all related services. If a
business process has been suspended, the message, Session count exhausted,
waiting for session availability, is displayed for the Connect:Direct Server Begin
Session Service, CopyTo, or CopyFrom service involved in establishing or
re-establishing a session. When a session count becomes available, the message,
Session now available: resuming, is displayed, and the Status Report screen will
show how long the business process was suspended, for example, Session now
available, resuming after wait of 1 minutes 35 seconds.

Sample Scenario of Workflow Suspension Processing and
Session Counts

In this sample scenario, there are three entities, all of which are configured as
shown below in Example 1:
v The Connect:Direct Server Adapter, which is invoked by business process X

(BP-X) to establish sessions with NODEA or NODEB.
v NODEA is a remote Sterling Connect:Direct node that Sterling B2B Integrator

wants to communicate with
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v NODEB is a remote Sterling Connect:Direct node that Sterling B2B Integrator
wants to communicate with

Example 1

Connect:Direct Server Adapter session limit = 2

Connect:Direct Server Adapter current sessions = 2

NODEA session limit = 2

NODEA current sessions = 1

NODEB session limit = 1

NODEB current sessions = 1

SUSPENDED WORKFLOW QUEUE = <empty>

In this scenario, the following sequence of events occurs:
1. BP-X attempts to establish a new PNODE session with NODEB.
2. Since NODEB is already at its session maximum, this triggers the workflow

suspend mechanism.
3. BP-X is placed on the suspended workflow queue to await a session count.
4. The current session with NODEA terminates and is freed.
5. Connect:Direct Server Adapter looks for a suspended workflow that can use the

newly freed session.
6. BP-X cannot use the freed NODEA session because NODEB is still at its session

maximum.
7. The freed NODEA session is returned to the available session count, and BP-X

continues to wait.

So, after this sequence of events, the situation is:

Connect:Direct Server Adapter session limit = 2

Connect:Direct Server Adapter current sessions = 1

NODEA session limit = 2

NODEA current sessions = 0

NODEB session limit = 1

NODEB current sessions = 1

SUSPENDED WORKFLOW QUEUE = BP-X

A new session can now be established with NODEA, but BP-X must still wait for
the current session with NODEB to be freed before it can proceed.
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Example 2

In this example, the session limit for NODEB has been bumped up one:

Connect:Direct Server Adapter session limit = 2

Connect:Direct Server Adapter current sessions = 2

NODEA session limit = 2

NODEA current sessions = 1

NODEB session limit = 2

NODEB current sessions = 1

SUSPENDED WORKFLOW QUEUE = <empty>

The following sequence of events occurs:
1. BP-X attempts to establish a new PNODE session with NODEB.
2. NODEB is not at its session maximum, but the overall Connect:Direct Server

Adapter is at its limit. As a result, the workflow suspend mechanism is
triggered.

3. BP-X is placed on the suspended workflow queue to await a session count.
4. The current session with NODEA terminates and is freed.
5. Connect:Direct Server Adapter looks for a suspended workflow that can use the

newly freed session.
6. BP-X can use this session because both NODEB and the adapter now have a

session available.
7. BP-X is resumed and allowed to attempt session establishment with NODEB.

After this sequence of events transpires, the situation stands as this:

Connect:Direct Server Adapter session limit = 2

Connect:Direct Server Adapter current sessions = 2

NODEA session limit = 2

NODEA current sessions = 0

NODEB session limit = 2

NODEB current sessions = 2

SUSPENDED WORKFLOW QUEUE = <empty>

How Checkpoint Restart and Retry Processing Works
The checkpoint restart feature allows the restarting of copy operations that fail in
certain ways, for example, due to network errors. The copy operation is resumed
from a previously checkpointed location rather than having to start over from the
beginning of the file transfer. Checkpoint restart behavior is controlled by the
PNODE. SNODE settings have no effect.
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To enable this feature, on the PNODE you must specify a value greater than 0 (0
disables automatic retries) using one of the following parameters:
v Number of long-term session retry attempts (the number of long-term retry

attempts specified for the Connect:Direct Server Adapter)
v Number of short-term session retry attempts (for the Connect:Direct Server

Adapter)
v Number of Retry attempts for establishing a session (in the Connect:Direct

Server Begin Session Service used in a particular business process)

You must also specify the CheckpointInterval in the CopyTo and CopyFrom service
of your business process.

Note: Certain errors fail without any retries, for example, when a required
parameter is missing or invalid or a remote node is not in the netmap.

Both the Interval between long-term session attempts (minutes) and Number of
long-term session retry attempts fields deal with long-term session establishment
and re-establishment attempts. To use a shorter timeframe to establish and
re-establish sessions, specify the following fields when configuring the
Connect:Direct Server Adapter:
v Number of short-term session retry attempts
v Interval between short-term session attempts (seconds)

If both the short-term and long-term retry parameters are specified, the values for
the short-term parameters are used first, and if a session has still not been
established (or re-established), the value for the long-term parameter is used if it is
specified.

Checkpoint restart is supported for both inbound and outbound file transfers. This
feature is only supported for documents stored in the file system—it is not
supported when document storage is set to Database or data encryption is enabled
in Sterling B2B Integrator.

Checkpoint restart can be enabled whether or not Sterling Connect:Direct Secure
Plus, compression, or any other communications session factor is enabled or
disabled.

In a file transfer, the PNODE determines whether checkpointing will be performed
and sets the checkpoint interval. These two parameters can be set as a global
default (usually in an initialization parameter or property file) or overridden in the
Sterling Connect:Direct Process (Copy step) or Sterling B2B Integrator business
process.

The checkpoint information is kept on the target node (the node receiving the file)
until the file transfer completes successfully (in which case, this temporary record
is destroyed) or kept for a specific period of time if the file transfer fails. When a
file transfer fails, the checkpoint information is retained for a specified default
length of time on the target system (30 days is common). In Sterling B2B
Integrator, this setting is configured by setting the ckptRemoveDate property in the
noapp.properties property file located in the properties subdirectory of the
installation.

If a remote Sterling Connect:Direct server or the network fails during a copy
operation, the Connect:Direct Server Adapter goes into retry mode using its own
default long-term and short-term values and waits the specified amount of time
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and then resumes the copy. These values can be overridden by the following
values, if specified, in the Connect:Direct Server Begin Session service:
v Number of long-term session retry attempts (BeginSessionMaxRetries)
v Interval between long-term session attempts (BeginSessionRetryInterval)
v Number of short-term session retry attempts (ShortTermMaxRetries)
v Interval between short-term session attempts (ShortTermRetryInterval)

Purging Checkpoint Data
By default, Sterling B2B Integrator stores checkpoint information for 30 days, after
which it is automatically purged. If your database has been corrupted, you must
purge this checkpoint information by performing a cold restart. To purge all
checkpoint data, each Connect:Direct Server Adapter must be cold started.

About this task

To purge all the checkpoint records associated with a Connect:Direct Server
Adapter:

Procedure
1. From the Business Processes menu, search for the adapter configuration.
2. Edit the configuration to set Server Start Option to Cold.
3. Save the changes and click Finish.
4. The Sterling B2B Integrator adapter restarts. The checkpoint data is purged

during startup.
5. Edit the configuration again to set Server Start Option to Warm to continue

using Checkpoint Restart without a loss of information between multiple
sessions.

How File Allocation Retry Processing Works
File Allocation Retry (FAR) processing allows Connect:Direct Server Adapter to
retry a Copy operation when one of a set of certain file allocation errors occurs in
combination with a non-zero return code. This is most useful when Connect:Direct
Server Adapter initiates a file transfer with a remote Sterling Connect:Direct for
z/OS system. FAR processing only affects locally initiated (PNODE) sessions that
use the Connect:Direct Server CopyTo service or CopyFrom service.

When you enable FAR processing and Connect:Direct Server Adapter receives one
of a set of certain file allocation error messages and a non-zero return code from
the remote Sterling Connect:Direct server during a copy operation, Connect:Direct
Server Adapter retries the Copy operation subject to the existing short-term and
long-term retry settings. If the condition that caused the FAR processing persists,
retries are performed up to a maximum of the configured short-term and
long-term retries only. The retry counters are not reset after a successful connection
when triggered by FAR processing.

If the retry counts are exhausted, the CopyTo or CopyFrom service fails and
returns an error to the Business Process that invoked it.

The set of FAR error messages, which include the commonly occurring Sterling
Connect:Direct for z/OS retry-able file allocation errors, is pre-configured in the
Sterling B2B Integrator installation.
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Enabling File Allocation Retry Processing
To enable FAR processing:

Procedure
1. Log in to Sterling B2B Integrator.
2. From the Deployment menu, select Services > Configuration.
3. From the Services Configuration page, search for the Connect:Direct Server

Adapter configuration.
4. On the InitParms screen, select the Retry Remote File Allocation Errors check

box.
5. Save the changes and click Finish.
6. The Sterling B2B Integrator adapter restarts. FAR processing is enabled.

Results

FAR processing is disabled by default when you create a new Connect:Direct
Server Adapter configuration or import a Connect:Direct Server Adapter
configuration from an earlier version of Sterling B2B Integrator.

Shared Session Limits (V5.2.5 and higher)
The Shared Session Limits (SHSL) feature manages all session activity within a
group of Sterling Connect:Direct Server Adapters.

Before SHSL, session activity was maintained privately within each Connect:Direct
Server Adapter. Without a single, central bookkeeping authority, session accounting
accuracy was almost impossible to achieve for a group.

With SHSL, session bookkeeping is centrally managed and shared between
Connect:Direct Server Adapters participating within the same group. This feature
enables accurate session accounting because all group participants use a single set
of session counters.

Guidelines

Follow these guidelines to take full advantage of SHSL:
v SHSL is enabled by default in Sterling B2B Integrator. You do not have configure

SHSL.
v Since each Connect:Direct Server Adapter is configured independently, care must

be taken to ensure that every Connect:Direct Server Adapter participating in the
group is configured with identical session limits. For example, each
Connect:Direct Server Adapter must define the same pnode session limit and the
same snode session limit.
If the configuration is inconsistent, the group’s limits are defined by the
configuration of the final member of the group to start. For example, if two
Connect:Direct Server Adapters belong to a group and one Connect:Direct Server
Adapter defines the pnode session limit to be 10 and the other Connect:Direct
Server Adapter defines it to be 5, if the second adapter is the final adapter in the
group to start, the group’s pnode session limit is 5.
It is also good practice to configure each Connect:Direct Server Adapter
participating in a group with the same Netmap. This practice ensures that each
Connect:Direct Server Adapter in the group uses the same session limits that are
defined in the remote node's configuration.
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Attention: As with all configuration changes to a Connect:Direct Server
Adapter Netmap (for example, remote node definitions or additions and
deletions from a Netmap), all Connect:Direct Server Adapters that reference the
Netmap must have their configuration refreshed. For example, you can refresh a
configuration by one of the following actions:
– Open the configuration for editing and then save the configuration.
– Disable the configuration and then re-enable the configuration.

Recovery from system failure

If a system failure occurs, you can manually reset the session system activity
records with the following procedure:
1. If Sterling B2B Integrator is not running, restart all of its nodes.
2. Disable all of the Connect:Direct Server Adapters.
3. After all of the Connect:Direct Server Adapters are disabled, re-enable them.

Troubleshooting
Sterling B2B Integrator and Sterling Connect:Direct are designed to work together,
in a seamless and tightly integrated environment. However, as is the case with any
application, occasions may occur when you need to troubleshoot certain
components or functions.

This section provides general troubleshooting guidelines when configuring and
using Sterling B2B Integrator with Sterling Connect:Direct.

To troubleshoot general Sterling Connect:Direct functions, see the Sterling
Connect:Direct documentation set for general troubleshooting information and
instructions.

You may need to work with your Trading Partners or system administrators to
troubleshoot the systems you are communicating with.

Verifying Connectivity
To verify connectivity between Sterling Connect:Direct and Sterling B2B Integrator:

About this task

Procedure
1. Check configurations on Sterling Connect:Direct and Sterling B2B Integrator for

compliance. In particular, look at the network maps on both systems.
2. Verify that the Sterling Connect:Direct nodes in question are active when a

begin session is invoked.
3. Verify that perimeter services client connects to perimeter services server. If the

client cannot connect, it causes the perimeter services-enabled Connect:Direct
Server Adapter to fail.
Perimeter servers do not automatically reboot after a failure.
To determine the status of the perimeter services client in Sterling B2B
Integrator:
From the Sterling B2B Integrator Operations menu, select Troubleshooter.
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Look for the Perimeter Servers area. It is usually at the bottom of the
Troubleshooting page. This shows the state of the perimeter server clients
which are defined in Sterling B2B Integrator and whether they are on.
Disconnected is displayed if no perimeter server is installed.

Exchange Process IDs
If either Sterling Connect:Direct or Sterling B2B Integrator cannot exchange process
identifiers, the process correlation in the various monitor user interfaces does not
work for the particular instance of a process. When this occurs, correct the
identifiers and restart the process.

Business Process Permissions
If you receive permissions-related error messages, make sure that adequate
permissions have been assigned.

When a external request is received by Sterling B2B Integrator to execute a
business process, the user/proxy user must have business process permissions for
the specific business process that is to be executed. That is, the business process
itself must have permissions enabled when it is created. In addition, the Sterling
user account must have:
v General business process execution permission. This is acquired by assigning the

Business Processes group to the user account.
v Permission for the specific business process to be executed.

The business process will display in the drop down with the mailboxes in the
user account configuration windows.

Logging Files With the Graphical Process Modeler
More information, including audit messages and error messages, can be found in
Sterling B2B Integrator log files. Log files are available through the Operations >
System > Logs menu.

The cdinterop.log files record details for all adapter activity and business processes
that involve the Connect:Direct Server and Requester adapters and the related
Connect:Direct services.

A new cdinterop.log is create each time the Sterling B2B Integrator server is
started. At midnight, the current log file is closed and a new one is created. In
addition, when the size of the current log file reaches the maximum size specified
in the cdinterop log file configuration screen, it is closed and a new log file is
opened. The log file name includes a date and time stamp to make each name
unique.

By default, the cdinterop.log file captures audit level messages, even when logging
is not enabled. When the log is enabled, all transactions are recorded, including:
v Error messages
v Adapter startup and shutdown
v Adapter changes
v Security checks

Customizing the Connect:Direct Server Adapter Log Settings
You can enhance the logging for the Connect:Direct Server Adapter using property
files to reduce the footprint of the log files and processing overhead.
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About this task

The log.properties file describes sets of properties required to define a logger used
to log information to a file, including the cdinterop.log. This log.properties file
should not be edited. If you need to override log.properties settings for the
cdinterop.log, use the customer_overrides.properties file.

CAUTION:
Overriding the log.properties settings for the cdinterop.log can have a dramatic
impact on performance and log volume.

The customer_overrides.properties file is used to override property settings in
other property files. Unlike the other property files and their associated
.properties.in files, the customer_overrides.properties file is not changed during
installation of Application upgrades or patches. To prevent having your
customized settings overwritten, you should use the customer override property
file whenever possible rather than editing the Application property files or .in files.

The customer_overrides.properties file is not part of the initial Application
installation and must be created. It must be named customer_overrides.properties.

To override log.properties file settings for the cdinterop.log:

Procedure
1. In the install_dir/properties directory, locate (or create, if necessary) the

customer_overrides.properties file.
2. Open the customer_overrides.properties file in a text editor.
3. Add the cdinteropcdinterop.log properties that you want to override to the

log.properties file, using the following format:
logService.PROPERTY_NAME=PROPERTY_VALUE
logService—Name used to reference the log.properties file.
PROPERTY_NAME—Name of the property as used in the log.properties file.
PROPERTY_VALUE—The value you want to assign to the property.
For example, assume that you want to change the maximum number of
cdinterop.log files to 5. To do so, override the cdinteroplogger.maxnumlogs
property value in the log.properties file by adding the following line to the
customer_overrides.properties file:
logService.cdinteroplogger.maxnumlogs=5

4. Save and close the customer_overrides.properties file.
5. Stop and restart Application to use the new values.
6. Test your changes to ensure that the overrides give the desired results. If you

have problems, contact IBM Customer Support for assistance.

Configuration Settings for the customer_overrides.properties
file

The following table describes properties used to configure the
customer_overrides.properties file for the CDInterop logger:
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Property Description

logService.cdinteroplogger.logfilename Specific name of the log file.

Example: ApplicationinstallDir/logs/
cdinterop.log

logService.cdinteroplogger.rotatelogs Flag indicating whether to rotate the log
after it has reached its maximum size.

Example: true

logService.cdinteroplogger.maxlogsize Maximum size of logs of this type.

Example: 100000

logService.cdinteroplogger.maxnumlogs Maximum number of logs of this type.

Example: 10

logService.cdinteroplogger.loglevel A level value of the logger.

Valid entries:

v NONE—Log nothing.

v CRITICAL—Log critical errors only.

v ERROR—Log errors only.

v WARN—Log errors and warnings.

v INFO—Log INFO and more severe.

v TIMING—Log errors, warnings, timing
messages.

logService.cdinteroplogger.displayname Display name for the logger.

Example: Log.CDInterop

logService.cdinteroplogger.showsource Flag indicating whether to show the java
class that originated an error message.
Note: This can have a dramatic impact on
performance and log volume, so it should
only be used to diagnose problems.

Example: false

Turning on Logging
If the error is not in the existing logs, turn on the Sterling B2B Integrator
cdinterop.log to capture activity of the Connect:Direct Server Adapter and the
services:

About this task

Procedure
1. Browse to Operation > System > Logs.
2. Scroll to the Environment section of the page.
3. Click the edit icon to the left of Connect:Direct Server and Requester Adapter

and Services.
4. In the Environment window, select On next to Logging Level and click Save.
5. Attempt to recreate the problem.
6. View the cdinterop log for more informative entries.

Sterling Connect:Direct and Sterling B2B Integrator Interoperability 129



Identifying Error Messages
Identify Sterling Connect:Direct error messages and their descriptions for UNIX
and Windows operating systems.

Sterling Connect:Direct Error Messages for UNIX
Identify error messages and their descriptions for UNIX operating systems.

Accessing Sterling Connect:Direct Messages:

The Sterling Connect:Direct message file contains records with text for all
messages, including errors and messages from Sterling Connect:Direct servers
other than the host server. You can add and delete message records with a text
editor. The message file resides in d_dir/ndm/cfg/cd_node/msgfile.cfg. You can
display message text with the ndmmsg command.

Message File Content: The message file is structured much the same way as other
Sterling Connect:Direct configuration files. Each record is a logical line in a text file
that consists of one or more physical lines. Each record has a unique name, a
message ID, and fields that make up the message text.

The message record definitions provide for symbolic substitution, which permits
including actual file names or other variable information within the text to more
specifically identify a problem. Symbolic variables begin with the ampersand
character (&).

The format of Sterling Connect:Direct message IDs is listed in the following table:
XxxxnnnI

Where:

X Indicates Sterling Connect:Direct
xxx is a 3-character Sterling Connect:Direct component identifier
nnn is a 3-digit decimal number
I is the standard, though not required, suffix

Message File Record Format: The following example shows the format of the
message file record. Each record can be up to 4K bytes long. Optional parameters
and values are in brackets.
message id [long.text detailed message explanation] [mod.name issuing module name] short.text
message summary

Following are the parameters for the message file record:

Parameter Description Values

long.text A string that explains the message in detail. A text string

mod.name The name of the source module issuing the
message ID.

Source module name

short.text A summary of the message. This field is
required.

Summary message, up to
72 characters

The following example illustrates a sample message record for XCPS008I:
XCPS008I:\ :mod.name=NUSMCP00.C:\
:short.text=File is not VB datatype.:\
:long.text=File is not variable block. Change sysopts datatype to\
either binary or text to transfer this file.\
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\nSYSTEM ACTION-> the copy step failed and CD processing\
continued with the next process step.\
\nRESPONSE-> change the sysopts datatype to either\
binary or text.:\

Displaying Message Text: Use the ndmmsg command to display text in the message
file. You can display both short and long text.

The following command illustrates the format for ndmmsg:

ndmmsg -f msgfname [-l | -s] msgid1 [msgid2 [msgid3 [...]]]

Following are the parameters for the ndmmsg command. If you do not specify an l
or s parameter, both short and long text are displayed.

Parameter Description

-f Specifies the name of the message file.

-l Displays the long text of a message.

-s Displays the short text of a message.

Following is a sample ndmmsg command:
ndmmsg -f /usr/ndmunix/msgfile.cfg XCMG000I

Output from the command is displayed in the following example:
rc=&rc
fdbk=&fdbk
mod.name=NUCMRG00.C
func.name=ndmapi_sendcmd
short.text=CMGR RPC call returns NULL
long.text=The ndmapi_sendcmd RPC call made by the API to the CMGR returns a
NULL pointer.There is probably an RPC error.ndm.action=None
user.action=First, check if the ndmcmgr is still running; it could have
been killed accidently.If so, then abort the current CLI and restart the
CLI. If the same problem occurs again, try to increase the value of wait
time (if set) in the API configuration file (ndmapi.cfg).

Sterling Connect:Direct Error Messages for Windows
Identify error messages and their descriptions for Windows operating systems.

Viewing Messages:

About this task

Use the Sterling Connect:Direct Message Lookup Utility to view the short and long
text explanations for error messages.

Procedure

1. Select Start > All Programs > IBM Sterling Connect:Direct > v4.6.0 > CD
Message Lookup.

2. Enter the message ID in the Message ID field.
3. Click Lookup to display the short and long message text.
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Use Secure Point of Entry
Secure Point of Entry (SPOE) is a security mechanism for maintaining the privacy
of sensitive user account information. Privacy is maintained by associating a
pseudo-account with an authentic one. Remote Sterling Connect:Direct trading
partners establish sessions using pseudo-accounts rather than authentic ones. In
this way, sensitive user account information remains private. The
cdinterop-spoe-policy.properties file describes settings for configuring the Secure
Point-of-Entry (SPOE) for use with the Connect:Direct Server Adapter for inbound
requests from remote Sterling Connect:Direct PNODEs.

Sterling B2B Integrator also supports Sterling Connect:Direct User Proxies as a
PNODE whereby the business process can:
v Specify a RemoteUserId without a RemotePasswd.
v Not specify a RemoteUserId or a RemotePasswd. The Connect:Direct Server

Adapter will use the PNodeId (the user executing the business process).
v Specify a LocalUserId without a RemoteUserId or a RemotePasswd.

Enabling SPOE Authentication from Remote Sterling
Connect:Direct PNODEs

You can modify SPOE policy without stopping Sterling B2B Integrator.

Before you begin

You should be aware that because changes to the cdinterop-spoe-policy.properties
file take effect immediately, you cannot use customer_overrides.properties to
preserve them. Instead, you should save the file with a different name to create a
backup.

Procedure
1. Make a copy of the SPOE Policy property file:

$ cd <install_dir>/properties
$ cp cdinterop-spoe-policy.properties cdinterop-spoe-policy.properties.copy

2. Use a text editor to make the desired changes to the cdinterop-spoe-
policy.properties.copy file:

$ vi cdinterop-spoe-policy.properties.copy

3. Uncomment the spoe.policy=yes property.
4. Modify other settings in the cdinterop-spoe-policy.properties.copy file necessary

for your situation.
For more information, search for cdinterop-spoe-policy.properties file.

5. Save the file.
6. Commit the changes:

$ cd <install_dir>/properties
$ cp cdinterop-spoe-policy.properties.copy cdinterop-spoe-policy.properties
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Map Sterling Connect:Direct User IDs to Sterling B2B
Integrator User Accounts

After you enable SPOE authentication for the Connect:Direct Server Adapter,
configure the cdinterop-spoe-auth.properties file to map external Sterling
Connect:Direct user IDs to Sterling B2B Integrator user accounts.

Configuration Settings to Map User Accounts
The following table describes properties used to map user accounts in the
cdinterop-spoe-auth.properties file in Sterling B2B Integrator:

Note: You should be aware that because changes to the cdinterop-spoe-
auth.properties file take effect immediately, you cannot use
customer_overrides.properties to preserve them. Instead, you should save the file
with a different name to create a backup.

Syntax Description

spoe-user-id Specifies a unique remote user identifier. The remote user may be
specified by an asterisk (*) to enable this definition to match any user.
Note: The asterisk does not perform similar to a wildcard character or
regular expression operator. It is a special keyword having the meaning
"any user."

nodename Specifies the name of the remote Sterling Connect:Direct PNODE node.
The node name may be specified by an asterisk (*) to enable this
definition to match any node.
Note: The asterisk does not perform similar to a wildcard character or
regular expression operator. It is a special keyword having the meaning
"any node."

gis-user-id Specifies an existing Sterling B2B Integrator user account.

Each entry associates a SPOE username and remote Sterling Connect:Direct node
name with a Sterling B2B Integrator user account. Each entry in the file consists of
a single line as shown in the following:

spoe-user-id@nodename=gis-user-id

The @ joins the user identifier with the node name to form the SPOE remote user
identifier. No space is permitted either before or after it. The = associates the SPOE
remote user identifier with the Sterling B2B Integrator user account. No space is
permitted either before or after it.

Examples for Mapping Local User Accounts
A remote user id 'user1' is mapped to the gis 'user2' account:

user1@cd.logistics=user2

Any remote id from the cd.chicago node is mapped to the gis account 'chicago':

*@cd.chicago=chicago

The remote id 'anonymous' from the *any* node is mapped to the Sterling B2B
Integrator 'anonymous' account:
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anonymous@*=anonymous

Any remote id from the *any* node is mapped to the Sterling B2B Integrator 'guest'
account:

*@*=guest

Adding, Modifying, or Deleting SPOE User Accounts
You can add, change, or delete SPOE user accounts without stopping Sterling B2B
Integrator.

Before you begin

You should be aware that because changes to the cdinterop-spoe-auth.properties
file take effect immediately, you cannot use customer_overrides.properties to
preserve them. Instead, you should save the file with a different name to create a
backup.

Procedure
1. Make a copy of the cdinterop-spoe-auth.properties file:

$ cd <install_dir>/properties
$ cp cdinterop-spoe-auth.properties cdinterop-spoe-auth.properties.copy

2. Use a text editor to make the desired changes to the cdinterop-spoe-auth.copy
file:

$ vi cdinterop-spoe-auth.properties.copy

3. Save the file.
4. Commit the changes:

$ cd <install_dir>/properties
$ cp cdinterop-spoe-auth.properties.copy cdinterop-spoe-auth.properties

Upload and Download Parameters for Local Users
Upload and download parameters can be used to designate where to store
incoming files and retrieve outgoing files when sent by or requested by a remote
node. These can be configured for local user accounts or (if SPOE authentication is
implemented) for proxy accounts in the cdinterop-user-records.properties and
cdinterop-proxy-records.properties files, respectively.

The cdinterop-user-records.properties file is a User Record Repository that allows
the Connect:Direct Server Adapter to identify a file and how to handle it based on
a limited amount of information. This allows the Connect:Direct Server Adapter to
process files despite restrictions such as limited file name length.

Each entry in the cdinterop-user-records.properties file assigns a Sterling B2B
Integrator document path prefix to a file based on the Connect:Direct Server
Adapter that receives the request, and the combination of remote Sterling
Connect:Direct PNODE and user ID where the request originated. A document
path prefix is then assigned and combined with the target or inbound filename to
form a fully-qualified path name.
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Precedence rules specify processing order in the case of directory parameter
conflicts.

If no entries are defined in the cdinterop-user-records.properties file, the Sterling
Connect:Direct attempts to store or retrieve the file using the path provided in the
message protocol.

Configuration Settings for Upload and Download Parameters for
Local Users
You must configure upload and download parameters for local users in the
Sterling B2B Integrator cdinterop-user-records.properties file.

Note: You cannot use customer_overrides.properties to make changes to this file.
Instead, save the file with a different name to create a backup.

The following table describes the properties used to configure the upload and
download parameters for local users in the cdinterop-user-records.properties file:

Property Description

directory.precedence Specifies the processing order in cases where two or
more directory parameters conflict. Example:

jsmith/download = /mailbox/inbox
[cdsa-1]download = /mailbox/downloads

Valid values:

user—Choose the definition that supplies the Sterling
B2B Integrator user account ID. In the example above,
the first rule is chosen. Default.

adapter—Choose the definition that supplies the
Connect:Direct server adapter name. In the example
above, the second rule will be chosen.

userid An existing local Sterling B2B Integrator user. If
omitted, may be any Sterling B2B Integrator user.
Optional.

cdsa-name Name of a Sterling Connect:Direct Server Adapter.
Syntax:

[cdsa-name]

If omitted, all presently defined Connect:Direct Server
Adapters. Optional.
Note: If omitted, separate the User ID from the
upload/download keyword by a slash (/) character.

parameter-name Specifies either the "download" or "upload" keyword.
Keywords are not case-sensitive. Required.

v download—Designates that the parameter's value
identifies the location where the incoming file is to be
stored. Default (when no other definitions match the
session's adapter or user account):

/businessprocess/PO-Request

v upload - Designates that the parameter's value
identifies the location from which the outgoing file is
to be obtained.
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Property Description

gis-path-prefix Path used to store the incoming document or retrieve
the outgoing one. Valid values:

v /businessprocess/<bp-name>

where

<bp-name> is the name of a business process. Required.

v /mailbox/<path>

where

<path> specifies a target mailbox accessible from the
virtual root of the Sterling B2B Integrator account.
Optional. If omitted, the virtual root is assumed.

Adding or Modifying Entries for Local Users
The cdinterop-user-records.properties file may be modified while Sterling B2B
Integrator is running. Changes take effect immediately. To add or modify entries in
this file for local users:

Before you begin

You should be aware that because changes to the cdinterop-user-records.properties
file take effect immediately, you cannot use customer_overrides.properties to
preserve them. Instead, you should save the file with a different name to create a
backup.

Procedure
1. Make a copy of the cdinterop-user-records.properties file:

$ cd <install_dir>/properties
$ cp cdinterop-user-records.properties cdinterop-user-records.properties.copy

2. Use a text editor to make the desired changes to the cdinterop-user-
records.properties.copy file:

$ vi cdinterop-user-records.properties.copy

3. To add or modify entries in this file, use this syntax:

gis-userid / upload | download = gis-path-prefix
userid ([cdsa-name] | / ) upload | download = gis-path-prefix

If cdsa-name is not specified, separate the User ID from the upload/download
parameter name with a slash (/).

4. Save the file.
5. Commit the changes:

$ cd <install_dir>/properties
$ cp cdinterop-user-records.properties.copy cdinterop-user-records.properties

Upload and Download Parameter Examples for Local Users
The following examples show upload and download parameter values:
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v /mailbox/receipts as a download parameter value—When a remote node
connects to Connect:Direct Server Adapter CDSA.DALLAS using the Sterling
B2B Integrator user account purchasing, this download parameter value is used
to compute the destination directory where the transmitted file will be stored:

purchasing[CDSA.DALLAS]download=/mailbox/receipts

v /mailbox/outbox as an upload parameter value—When a remote node connects
to any Connect:Direct Server Adapter using the Sterling B2B Integrator user
account purchasing, this parameter value is used to compute the source
directory location of the file to be transmitted to the remote node:

purchasing/upload=/mailbox/outbox

v /businessprocess/DelinquentAccounts as an upload parameter value. When a
remote node connects to Connect:Direct Server adapter CDSA-CHICAGO using
any Sterling B2B Integrator user account, this parameter value determines which
business process to execute to produce the document's content to be sent to the
remote node:

[CDSA-CHICAGO]upload=/businessprocess/DelinquentAccounts

v /businessprocess/PO-Request as the default download parameter value. It is
used when no other definitions match for the session's adapter or user account:

download=/businessprocess/PO-Request

Upload and Download Parameters for Proxy Users
The cdinterop-proxy-records.properties file serves as Proxy Record Repository for
the Connect:Direct Server Adapter. If a proxied remote user ID (SPOE account) is
enabled in the cdinterop-spoe-policy.properties file, an upload/download directory
path for that proxied user can be configured in cdinterop-proxy-records.properties.

Configuration Settings for Upload and Download Parameters for
Proxy Users
The following table describes properties used to configure the upload and
download parameters for proxy users in the Sterling B2B Integrator
cdinterop-proxy-records.properties file:

Note: You cannot use customer_overrides.properties to make changes to this file.
Instead, save the file with a different name to create a backup.
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Property Description

external-id An external, remote proxied user ID. It may be specified in any of the
following ways:

v address-form: proxyid @nodename

where proxyid and nodename are specified. A match occurs only if
the user name and node name from the request exactly match proxyid
and nodename. Example:

john@company/upload=/mailbox/company/john/out

The upload path is prepended to the outbound target filename if
spoe-policy=yes and the remote userid is "john" and the remote pnode
name is "company."

v domain-form: *@nodename

where only nodename is specified. A match occurs only if the node
name from the request exactly matches nodename. Example:

*@company/upload=/mailbox/company/out

The upload path is prepended to the outbound target filename if
spoe-policy=yes and no rule is found for this remote userid, but one
is found for the remote pnode name "company."

v account-form: userid @*

where only proxyid is specified. A match occurs only if the user name
from the request exactly matches userid. Example:

john@*/upload=/mailbox/john/out

The upload path is prepended to the outbound target filename if
spoe-policy=yes and a rule is found for remote userid "john," but no
rule is found for the name of the remote pnode.

v default-form: *@*

This rule always matches any user name from any node name.
Example:

*@*/upload=/mailbox/default/out

parameter-name Specifies either the "download" or "upload" keyword. Keywords are
not case-sensitive. Required.

v download—Designates that the parameter's value identifies the
location where the incoming file is to be stored. Default (when no
other definitions match the session's adapter or user account):

/businessprocess/PO-Request

v upload—Designates that the parameter's value identifies the
location from which the outgoing file is to be obtained.
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Property Description

gis-path-prefix Path used to store the incoming document or retrieve the outgoing
one. Valid values:

v /businessprocess/<bp-name>

where

<bp-name> is the name of a business process. Required.

v /mailbox/<path>

where

<path> specifies a target mailbox accessible from the virtual root of
the Sterling B2B Integrator account. Optional. If omitted, the virtual
root is assumed.

Adding or Modifying Upload and Download Parameters for Proxy
Users
The cdinterop-proxy-records.properties file may be modified while Sterling B2B
Integrator is running. Changes take effect immediately. To add or modify entries in
this file for proxy users:

Before you begin

You should be aware that because changes to the cdinterop-proxy-
records.properties file take effect immediately, you cannot use
customer_overrides.properties to preserve them. Instead, you should save the file
with a different name to create a backup.

Procedure
1. Make a copy of the cdinterop-proxy-records.properties file:

$ cd <install_dir>/properties
$ cp cdinterop-proxy-records.properties cdinterop-proxy-records.properties.copy

2. Use a text editor to make the desired changes to the cdinterop-proxy-
records.properties.copy file:

$ vi cdinterop-proxy-records.properties.copy

3. To add or modify entries in this file, use this syntax:

external-id / upload | download = gis-path-prefix

4. Save the file.
5. Commit the changes:

$ cd <install_dir>/properties
$ cp cdinterop-proxy-records.properties.copy cdinterop-proxy-records.properties
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Upload and Download Example - Sterling Connect:Direct as
PNODE Initiates a Transfer TO Sterling B2B Integrator

In this example, the PNODE is a Sterling Connect:Direct Server named
CD.CHICAGO. The SNODE is a Sterling Connect:Direct Server Adapter named
CDSA.DALLAS.

The Sterling Connect:Direct process contains the following:

TOGIS PROCESS
SNODE=CDSA.DALLAS
SNODEID=(cduser1,cduser1)

STEP1 COPY
FROM (

FILE=”payload.txt”
)
TO (

FILE=”po-12558-a202”
DISP=RPL

)
PEND

The cdinterop-user-properties file contains the following entries:

cduser1 [CDSA.DALLAS] upload=/mailbox/out
cduser1 [CDSA.DALLAS] download=/mailbox/in
admin [CDSA.DALLAS] upload=/mailbox/upload
admin [CDSA.DALLAS] download=/mailbox/download

The Connect:Direct Server Adapter computes the destination filename by
appending the local filename po-12558-a202 to the cduser1 [CDSA.DALLAS]
download parameter value:

Result: /mailbox/in/po-122558-a202

The Sterling Connect:Direct User Authorities for cduser1 contains the following
Directory Restrictions:

Directory Restriction

Upload C:\Connect Direct\data\upload

Download C:\Connect Direct\data\download

Sterling Connect:Direct computes the source filename by appending the local
filename payload.txt to user cduser1's upload parameter value:

Result: C:\Connect Direct\data\upload\payload.txt

Upload and Download Example - Sterling Connect:Direct as
PNODE Initiates a Transfer FROM Sterling B2B Integrator

In this example, the PNODE is a Sterling Connect:Direct Server named
CD.CHICAGO. The SNODE is a Sterling Connect:Direct Server Adapter named
CDSA.DALLAS.

The Sterling Connect:Direct process contains the following:
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FROM GIS PROCESS
SNODE=CDSA.DALLAS
SNODEID=(cduser1,cduser1)

STEP1 COPY
FROM (

FILE=”po-12558-a202”
SNODE

)
TO (

FILE=”payload.txt”
PNODE
DISP=RPL

)
PEND

The cdinterop-user-properties file contains the following entries:

cduser1 [CDSA.DALLAS] upload=/mailbox/out
cduser1 [CDSA.DALLAS] download=/mailbox/in
admin [CDSA.DALLAS] upload=/mailbox/upload
admin [CDSA.DALLAS] download=/mailbox/download

The Connect:Direct Server Adapter computes the source filename by appending the
local filename po-12558-a202 to the cduser1 [CDSA.DALLAS] upload parameter
value:

Result: /mailbox/out/po-122558-a202

The Sterling Connect:Direct User Authorities for cduser1 contains the following
Directory Restrictions:

Directory Restriction

Upload C:\Connect Direct\data\upload

Download C:\Connect Direct\data\download

Sterling Connect:Direct computes the destination filename by appending the local
filename payload.txt to user cduser1's download parameter value:

Result: C:\Connect Direct\data\download\payload.txt
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Notices

This information was developed for products and services offered in the US. This
material might be available from IBM in other languages. However, you may be
required to own a copy of the product or product version in that language in order
to access it.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive, MD-NC119
Armonk, NY 10504-1785
US

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of
express or implied warranties in certain transactions, therefore, this statement may
not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM websites are provided for
convenience only and do not in any manner serve as an endorsement of those
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websites. The materials at those websites are not part of the materials for this IBM
product and use of those websites is at your own risk.

IBM may use or distribute any of the information you provide in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Director of Licensing
IBM Corporation
North Castle Drive, MD-NC119
Armonk, NY 10504-1785
US

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

The performance data and client examples cited are presented for illustrative
purposes only. Actual performance results may vary depending on specific
configurations and operating conditions.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBMproducts.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

Statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.

This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to actual people or business enterprises is entirely
coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
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IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work must
include a copyright notice as shown in the next column.

© 2015.
Portions of this code are derived from IBM Corp. Sample Programs.
© Copyright IBM Corp. 2015.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the web at "Copyright and
trademark information" at www.ibm.com/legal/copytrade.shtml.

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States,
and/or other countries.

IT Infrastructure Library is a registered trademark of the Central Computer and
Telecommunications Agency which is now part of the Office of Government
Commerce.

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,
Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

ITIL is a registered trademark, and a registered community trademark of the Office
of Government Commerce, and is registered in the U.S. Patent and Trademark
Office.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java™ and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the
United States, other countries, or both and is used under license therefrom.
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Linear Tape-Open, LTO, the LTO Logo, Ultrium and the Ultrium Logo are
trademarks of HP, IBM Corp. and Quantum in the U.S. and other countries.

Connect Control Center®, Connect:Direct®, Connect:Enterprise®, Gentran®,
Gentran®:Basic®, Gentran:Control®, Gentran:Director®, Gentran:Plus®,
Gentran:Realtime®, Gentran:Server®, Gentran:Viewpoint®, Sterling Commerce™,
Sterling Information Broker®, and Sterling Integrator® are trademarks or registered
trademarks of Sterling Commerce®, Inc., an IBM Company.

Other company, product, and service names may be trademarks or service marks
of others.

Terms and conditions for product documentation
Permissions for the use of these publications are granted subject to the following
terms and conditions.

Applicability

These terms and conditions are in addition to any terms of use for the IBM
website.

Personal use

You may reproduce these publications for your personal, noncommercial use
provided that all proprietary notices are preserved. You may not distribute, display
or make derivative work of these publications, or any portion thereof, without the
express consent of IBM.

Commercial use

You may reproduce, distribute and display these publications solely within your
enterprise provided that all proprietary notices are preserved. You may not make
derivative works of these publications, or reproduce, distribute or display these
publications or any portion thereof outside your enterprise, without the express
consent of IBM.

Rights

Except as expressly granted in this permission, no other permissions, licenses or
rights are granted, either express or implied, to the publications or any
information, data, software or other intellectual property contained therein.

IBM reserves the right to withdraw the permissions granted herein whenever, in its
discretion, the use of the publications is detrimental to its interest or, as
determined by IBM, the above instructions are not being properly followed.

You may not download, export or re-export this information except in full
compliance with all applicable laws and regulations, including all United States
export laws and regulations.

IBM MAKES NO GUARANTEE ABOUT THE CONTENT OF THESE
PUBLICATIONS. THE PUBLICATIONS ARE PROVIDED "AS-IS" AND WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING
BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY,
NON-INFRINGEMENT, AND FITNESS FOR A PARTICULAR PURPOSE.
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