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Graphical Process Modeler

To help you create business process models, Sterling B2B Integrator includes the
Graphical Process Modeler (GPM).

The GPM is a Web-deployed graphical interface tool you use in conjunction with
Sterling B2B Integrator to create and modify business processes. The GPM converts
your graphical business process models into source code, saving you the effort of
writing code.

In the GPM interface you construct your business process models, coordinating the
flow of activities in a graphical depiction of the ordered steps. The GPM provides
icons representing the services, adapters and Business Process Modeling Language
(BPML) instructions that make up your process models. In addition, you configure
related parameters through the GPM and create rules and conditions within your
process models.

You can validate the process models and check them in to Sterling B2B Integrator
from within the GPM. To make it easier to work with your business process
models in the GPM without having to access the Sterling B2B Integrator interface,
the GPM includes its own Source Manager tool, enabling you to lock, check in and
check out business process models, and to monitor versions of business process
models using a date and time stamp, all from within the GPM.

The GPM recognizes BPML code written in a text editor. Therefore, in the GPM,
you can open a .bpml file created in a text editor and view its graphical
representation. The GPM enables you to toggle the display between BPML and
graphic view.

Example Business Process Model in the GPM

The following figure shows an example of a simple business process model as it
appears in the GPM:

The callouts in the figure indicate the types of components depicted by the icons.

High-level Installation Process

Installing the GPM is a multi-step process which should be completed in the order
described. To get started using the GPM, you must:
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1. Install the GPM. See Graphical Process Modeler Installion.
2. Start the GPM. See Start the GPM.
3. (Optional) Set your preferences. You can specify settings for things such as

language preference, when to validate BPML, and the location on your
computer where you want the GPM to save your business process model files.
See Set User Preferences.

After these steps are completed, you can begin creating business process models.
For the step-by-step procedure, see Create Business Process Models.

For an introduction to the GPM interface, see User Interface.

Everyday Activities and Flow
Your use of the Graphical Process Modeler (GPM) follows your business process
modeling goals. Before you create a business process model, carefully plan it, so
that you know which components you must include, as well as how you must
configure the services and activities within it. For instructions, see Planning Your
Business Process Models.

As you familiarize yourself with the GPM components, you will develop your own
favorite methods of using it and navigating in the layers of your process models,
as well as your own preferred order of completing the steps involved in creating
and modifying business process models.

The following table describes the activities generally involved in creating business
process models in the GPM. You can complete the activities in different order, but
the table is arranged in a logical order as a starting point for your reference.

Activity Description

Check out a business process model. To modify an existing business process
model that is checked in to Sterling B2B
Integrator, you must check the process
model out before you can work with it in
the GPM. For instructions, see Modifying and
Managing Business Process Models.

Determine which stencils you need to
display.

Stencils are palettes of the services and
activities you include in your process
models. Because hundreds of services are
represented, each stencil lists a given
category of services. You will want to
display only the ones you are likely to need
for the process model you are working on.
For information about available stencils and
how to display them, see GPM Stencils.

Arrange icons in workspace. This activity involves:

v Dragging and dropping the icons
representing the services and BPML
activities that comprise your process
model into the workspace

v Arranging the icons according to the
desired flow

v Linking the icons
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Activity Description

Configure parameters for services, activities
and links.

Some BPML activities, some links between
your services and activities, and most
services require some configuration in the
GPM, depending on the task your business
process model must accomplish. Use GPM
element editors to view and modify
parameters for the different components, or
elements, of business process models. For
information, see Element Editors in the GPM.

Add decision points, rules and conditions. Rules and conditions can be simple
instructions or more complex directions
defined using XPath expressions. The GPM
enables you to assign rules using an element
editor, as well as to define them using the
Rule Manager and XPath Expression Builder
tools. For information, see:

v Defining and Assigning Rules and Conditions

v GPM XPath Expression Builder

Make your process model descriptive for
future reference.

v Name the components of your process
models in meaningful ways.

v Use your company's naming conventions
to name your process model when you
save it.

v Add annotations to the graphical display
of your process model. For information,
see:

- Modifying Annotations- GPM Annotation Tool

Save, validate, and check in the model. After you create or modify a process model,
you can simply save it or save and validate
it, and check it in to Sterling B2B Integrator.
For information, see Checking in a Business
Process Model.

Install the Graphical Process Modeler
Although the Graphical Process Modeler (GPM) is an included feature of Sterling
B2B Integrator, it does not automatically install with Sterling B2B Integrator,
because it operates as a separate, Web-deployed application. The GPM must be
installed on each computer from which a user will access Sterling B2B Integrator
and work with the GPM. This enables Sterling B2B Integrator and the GPM to
interact. For example, you can check in and out business process models from the
GPM, and update a service configuration in the GPM after making changes to it in
Sterling B2B Integrator.

About this task

To install the GPM, complete these steps on the client computer on which you
want to use the GPM:

Procedure
1. Uninstall all old versions/instances of Java™ Web Start from the client

computer. Leaving these on the system will cause an error when attempting to
load the GPM from the Sterling B2B Integrator user interface.
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2. Download the correct JRE according to the System Requirements.
3. Install the JRE on the client system.
4. Log in to Sterling B2B Integrator and download the GPM:

a. Navigate to the Admin Console Home page.
b. Next to Run Graphical Process Modeler, click Go! The Java Web Start

window displays and begins loading GPM components.
c. Answer any prompts appropriately that appear.
d. When prompted, use your Sterling B2B Integrator User ID and Password to

log in to the GPM . The GPM opens.
5. Set your preferences. See Set Up Your GPM.

Results

You can now create and modify business process models.

Create a Desktop Graphical Process Modeler Shortcut
About this task

After you download and install the Graphical Process Modeler (GPM) on a client
computer, you can add a Modeler menu item to the Programs menu and create a
shortcut icon on the Desktop to start the GPM locally.

To create a Desktop Shortcut for the GPM:

Procedure
1. On a client pc on which you want to use the GPM, from the Windows Start

menu, select Run.
2. Type javaws -viewer and click OK. The Java Cache Viewer appears.
3. From the Application column, select Modeler.
4. From the Application menu, select Install shortcuts to the selected

application. The system installs a shortcut to your Programs menu and an icon
on your Desktop.

Graphical Process Modeler Startup
The first time you start the Graphical Process Modeler (GPM) on a given computer,
you must do so from within the Sterling B2B Integrator user interface. This
initiates the GPM installation on that client PC.

Note: Each time you start the GPM, Java Web Start checks for a connection to the
Web server to determine whether a new version of the GPM is available. When a
new version is available, Java Web Start automatically updates the files on the
client computer and opens the GPM.

Any time after the initial GPM startup, you can start it in either of the following
ways:
v Inside the Sterling B2B Integrator User Interface

The GPM is started from a selection made from the Sterling B2B Integrator user
interface. Both the GPM and your network connection to Sterling B2B Integrator
are open. You must log into the GPM using your Sterling B2B Integrator User ID
and Password. You have complete functionality.

v Outside of Sterling B2B Integrator
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The GPM is started from a client PC locally. This is known as “working offline.”
You do not log in to Sterling B2B Integrator, and the GPM cannot interact with
Sterling B2B Integrator. You still must log into the GPM using your Sterling B2B
Integrator User ID and Password. You have restricted functionality.

Note: The offline GPM mode is only possible if the Sterling B2B Integrator
instance is inaccessible over the network. If network connectivity exists, then the
online mode is the only option.

The ability to work in the GPM without starting Sterling B2B Integrator offers you
the convenience of creating and modifying business process models without
requiring a network connection. Because your business process models save
directly to your hard drive, you can work on them at your convenience and at
remote locations, and then check them in to Sterling B2B Integrator later, after you
log in.

Because the GPM and Sterling B2B Integrator can interact (such as when you
update the service stencils in the GPM), working in the GPM from outside Sterling
B2B Integrator involves the following restrictions:
v You cannot refresh (update from Sterling B2B Integrator) the services listed in

the GPM stencils
v You cannot check business process models into or out of Sterling B2B Integrator)

Plan ahead before you work offline in the GPM. For example, if you will need any
new service configurations, you must create them in Sterling B2B Integrator and
refresh the services in the GPM (select View > Refresh Services) before you shut
down Sterling B2B Integrator and work offline in the GPM.

Similarly, if you plan to modify an existing process model, you must check it out
while Sterling B2B Integrator is running, before you shut it down and work offline
in the GPM.

Start the Graphical Process Modeler Inside Sterling B2B
Integrator

About this task

This method must be used the first time you start the Graphical Process Modeler
(GPM). To start the GPM from inside the Sterling B2B Integrator user interface:

Procedure
1. Complete one of the following tasks:
v From the Admin Console Home page, in the Tools section, next to Run

Graphical Process Modeler, click Go!

v From the Administration menu, select Business Process > Manager, and in
the Graphical Modeling pane, next to Run Graphical Process Modeler, click
Go!

2. The Log In dialog box displays. Type your Sterling B2B Integrator User ID and
Password, click OK.

Results

You can now create and modify business process models. Because you are logged
in to Sterling B2B Integrator, you can check business process models in and out.
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What to do next

The first time you start the GPM, set your preferences. See Set Up Your GPM.

Start the Graphical Process Modeler Outside of Sterling B2B
Integrator

Before you begin

This method can be used anytime after the initial installation of the Graphical
Process Modeler (GPM), but only if you cannot access Sterling B2B Integrator over
a network. To start the GPM offline, you must have installed a shortcut to your
Programs menu and Desktop.

Note: Certain restrictions apply when using the GPM offline. For information, see
“Graphical Process Modeler Startup” on page 4.

About this task

To start the GPM outside of Sterling B2B Integrator:

Procedure
1. Complete one of the following tasks:
v From the Start menu on a client computer, select Programs > Modeler (GPM

application).
v From the Desktop on a client computer, double-click the Modeler shortcut.

2. The Log In dialog box displays. Type your Sterling B2B Integrator User ID and
Password, click OK.

Results

You can now create and modify business process models locally on the client
computer. Because you are not logged in to Sterling B2B Integrator, you cannot
check business process models in and out.

What to do next

The first time you start the GPM, set your preferences. See Set Up Your GPM.

Graphical Process Modeler User Interface
The Graphical Process Modeler (GPM) is designed to simplify the tasks of creating
and modifying business process models through drag-and-drop technology and
tools for navigation and configuration.

The following figure shows the GPM user interface and its components when a
business process model document is open (select File > New to activate the
workspace). To create business process models, drag and drop icons from the
stencils into the workspace.
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The following table provides information about the components identified in the
figure:

Component Description

Stencil A stencil is a graphical palette of icons for
dragging and dropping into your business
process models in the workspace. The icons
represent components you include in your
process models—the services, adapters, and
Business Process Modeling Language
(BPML) instructions that perform tasks.The
GPM includes a variety of stencils, each
containing icons of a specific category. You
can select the stencils to display in the GPM
interface at any time (from the View menu,
select Stencil > <stencil name>. For stencil
descriptions, see GPM Stencils.

Graphical Process Modeler 7



Component Description

Title Bar Displays:

v IP address and port of your associated
installation of Sterling B2B Integrator

v The word “(Offline)” or “(Online)” to
indicate whether you are working online
(this means with an Internet connection
open) or offline (with no Internet
connection open)

v File name of the business process model
document that is currently open in the
GPM

Menu Bar Enables you to select options related to
creating, modifying, and checking in and out
your business process models.

v Use the Edit menu to cut, copy, paste,
delete, clear all, and select all components
displayed on the workspace. Procedural
documentation for working with business
process models describes the other
functions you can access from this menu.

v The View menu enables you to customize
the display. For information, see
Customizing the GPM Interface Display.

Tool Bar Displays buttons that provide quick access
to commonly used commands. Inactive
buttons become active when you select a
service icon in the workspace.

Workspace Area in the GPM interface to which you can
drag and drop icons to create a business
process model. Within the workspace, click
and drag to organize your process models,
and select components to configure them.
You can also view the BPML source code of
a business process model in the workspace.
To view BPML source code, from the View
menu, select Source.

Status Bar Displays a description of a menu option,
toolbar button, or service icon (in a stencil),
when you point to it.

Navigation Pane Displays a tree diagram of the business
process model, depicting any subflows
(called layers in this pane) and the steps
contained within each subflow (these are the
nodes). The Navigation pane enables you to
display a subflow in the workspace by
selecting it from the Layers tab, and to open
element editors for selected nodes by
selecting a node from the Nodes tab.The
Navigation pane is especially helpful when
you are working with complex processes
that contain many subflows.For more
information, see Navigating Layers and Nodes
in the GPM Interface.

8 Sterling B2B Integrator: Graphical Process Modeler



Component Description

Element Editor and Output Pane Displays either element editors for a selected
component of the business process model, or
the output for system messages.

v Element editors enable you to view and
configure parameters for components of
your business process models. Double
click a component in the workspace to
display the element editor to configure it.
For descriptions of the different element
editors, see Element Editors in the GPM.

v The Output tab displays error, validation,
and system messages. This pane opens
automatically when you validate a model
or view source code.

Navigating Layers and Nodes in the User Interface
Working with graphical business process models often requires you to navigate
sometimes complex or extensive arrangements of process components. For your
convenience, the Graphical Process Modeler (GPM) contains a Navigation pane for
quick navigating among components.

The Navigation pane makes it easy to select from among the different subflows
and components of your business process model, using the Layers and Nodes tabs.

Layers

Layers are subflows contained within the business process model. The Layers tab
depicts a graphical representation of the structure of the parent business process
model displayed in the workspace, including subflows. To expand the structure to
show the layers, double click the icon in the Navigation pane that represents the
business process model.

When you expand the view, the structure shows any subflow layers contained
within the business process model. The following figure illustrates a process model
with two layers, when the view is expanded.

To work with the subflow, select the appropriate layer from the list. The subflow
activities display in the workspace.

Nodes

Nodes are the steps in the business process model. Each BPML activity, service,
adapter, and subflow is a node.
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For a selected layer, the Nodes tab displays an alphabetical list of the nodes in the
layer. When you select a node from the list, the GPM displays in the workspace
the section of the business process model containing the selected node, with the
node selected in the workspace display.

To use the Nodes tab, select a layer from the Layers tab and then click the Node
tab to view:
v The list of nodes in the layer, displayed in the Navigation pane
v The subflow or parent business process model that comprises the layer,

displayed in the workspace

If the element editor is open, when you select an icon on the Node tab,
configurable parameters for the node display in the applicable element editor.

Go To Command

When you are working with a business process model that includes multiple
subflows, the Go To (Previous/Next) command enables you to return to the
previous flow view or display the next flow view.

To use the command, select View > Go To > Previous or Next.

Customize the User Interface Display
The View menu enables you to customize the Graphical Process Modeler (GPM)
display. In the View menu, you can select certain options you want to display or
hide. When these options have a check mark next to them, they display.

Note: The option selections differ depending on if you have a file open or not.

Options to display or hide are:
v Source/Graph – Enables you to switch between the graphical representation and

the BPML source code of a business process model on the workspace.
v Toolbar – Displays or hides the toolbar containing shortcut command buttons.
v Status Bar – Displays or hides the status bar across the bottom of the page.
v Output – Opens and closes the Output pane, which displays error, validation,

and system messages. This pane opens automatically when the GPM encounters
an error during validation, even when you have not selected the option.

v Navigation – Opens and closes the Navigation pane.
v Stencil – Displays the menu that lists stencils. For information, see Stencils.
v Auto Layout – Automatically aligns icons in the workspace.
v Zoom – Enables you to change the magnification of a business process model

view. Zoom sets the magnification to 50, 75, 100, 150, or 200 percent.
v Grid – Enables you to select and displays dotted or line grid markers, or no grid

markers. The grid points enable you to align icons on the workspace.

Set User Preferences
You can choose from a variety of settings in the Graphical Process Modeler (GPM)
to specify operations handling according to your own preferences. Setting up GPM
preferences before using the GPM is not required, however setting preferences in
advance enables you to be certain of the order in which steps such as validation
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will take place in your procedures, and where the GPM will store your process
models when you save them. You can also modify the display according your
needs.

About this task

If multiple users log in to your computer using the same user ID and password,
and use the GPM, they share the GPM and therefore any preference settings. In
this case, users can re-set their preferences whenever they use the GPM.To set your
preferences:

Procedure
1. Select Options > Preferences.
2. On the General tab, select the appropriate check box to indicate whether the

GPM should automatically validate the Business Process Modeling Language
(BPML) each time you save a process model, or if you want the GPM to
display the Validate on Save dialog box each time you save, so that you can
determine then whether to validate the model you are working on.

3. Click the Source Manager tab.
4. Determine if you want to use the Expert Mode for checking business process

models into Sterling B2B Integrator when you use the GPM Source Manager.
Select the Use Expert Mode check box or leave the selection blank. Expert
Mode displays one dialog box containing all of the parameters related to
checking in a business process model to Sterling B2B Integrator. When you do
not select Expert Mode, the parameters selections display in a series of dialog
boxes, which breaks up the options into smaller groups for novice users.

5. Click the File Location tab.
6. Enter or select a default directory to which the GPM will save all business

process documents (.bp files) on your client computer.
7. Click the Locale tab.
8. Select a default locale for your installation.
9. Click the Service Editor tab.

10. Determine whether you want to be able to override parameters for service
configurations as they are currently saved in Sterling B2B Integrator. If you do
not select this option, some predefined service configuration parameters are
not editable in the GPM.

11. Click OK. Your new preference settings are applied to the current session and
saved. They are automatically applied each time the GPM is started.

Results

The GPM also enables you to customize the display to facilitate your work habits.
For information, see Customize the User Interface Display.

Element Editors
Element editors enable you to view and modify parameters for different
components, or elements, of business process models. These elements are the icons
representing services, adapters and Business Process Modeling Language (BPML)
activities, and the edges, or links (represented by lines), that connect them and to
which you can assign rules.
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BPML activities and a small number of services are preconfigured when you install
Sterling B2B Integrator. However, some BPML activities and most services require
you to perform additional configuration in the Graphical Process Modeler (GPM),
depending on the task your business process model must accomplish.

The GPM has five element editors, each of which provides configuration
parameters specific to a selected element. When you select an icon in the
workspace, the appropriate element editor for that edge, service or BPML activity
displays.

The following table describes the GPM element editors:

Element Editor Description

Consume Editor Enables you to indicate the message a
business process or subflow should expect,
and the name of the participant sending that
message.

Edge Editor Enables you to assign rules to the links that
run from a Choice Start icon to the next
icons at a decision point in a business
process model. The Edge editor enables you
to select from all previously created rules.

Produce Editor Create your own name-value pairs, adding
XPath expressions when needed, to define
the path to name-value pairs that appear in
business process data. Enables you to
configure parameters for each service and
adapter. The parameter fields correspond to
the parameter information described in the
reference documentation for the selected
service.

Property Editor Enables you to configure BPML activities
that require additional information, such as
Choice and Assign.You can also use the
Property editor to define values that indicate
errors associated with the activity. If the
business process encounters these values
while running, Sterling B2B Integrator
generates a report that describes the error.

If you need information about the
parameters to enter for a service or adapter,
review the parameter specifications in the
reference documentation for the service.

Enables you to configure parameters for
each service and adapter. The parameter
fields correspond to the parameter
information described in the reference
documentation for the selected service. You
can use the Service editor to:

v Enter and modify values for parameters.

v View protected parameter values that
cannot be edited.

v Use the preset values in the editor as a
basis for defining conditions for
configuration parameters.

v Create your own name-value pairs,
adding XPath expressions when needed,
to define the path to name-value pairs
that appear in business process data.
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If you need information about the parameters to enter for a service or adapter,
review the parameter specifications in the reference documentation for the service.

Stencils
Stencils are palettes that you can display in the Graphical Process Modeler (GPM)
and from which you select icons representing activities to include in your business
process models. See GPM Interface for an illustration of the stencils pane.

Each stencil contains labeled icons for a specific category of installed services or
Business Process Modeling Language (BPML) activities.

You can choose from a menu to display the stencils containing icons you need as
you build business process models. From the View menu, select Stencil and select
the desired stencil. When you open more than one stencil, the stencils display in a
tiered pane. With multiple stencils open, you can click the stencil name at the top
or bottom of the pane to display the stencil you need as topmost in the list.

To close a stencil, right click on the stencil title and select Close Current Stencil or
Close All Stencils.

Add New Services and Service Configurations to the Stencils
About this task

Periodically, you may install additional services and adapters to Sterling B2B
Integrator or update service configurations created in the Sterling B2B Integrator
user interface. Perform this procedure any time you need to update the Graphical
Process Modeler (GPM) stencils to display the most current services and adapters
installed with Sterling B2B Integrator .

You must be working with the GPM online (Sterling B2B Integrator must be
running) to use this command.

To refresh the listing of Services and Service configurations in the GPM:

Procedure
1. Start the GPM.
2. From the View menu, select Refresh Services.

Results

Perform this procedure any time you need to update the GPM stencils to display
the most current services and adapters installed with Sterling B2B Integrator.

Select a Stencil
About this task

Stencil names describe the category or sub-category of services and adapters for
the icons they contain, with the exception of the Business Process Modeling
Language (BPML) stencil. The BPML stencil contains icons only for BPML activities
and instructions that coordinate the flow of activities within a business process
model.

To select a stencil for use in the Graphical Process Modeler (GPM):
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Procedure
1. Start the GPM.
2. From the View menu, select Stencil > Stencil_Name. Look for the category of

service and any sub-category that you need. Depending on the stencil category
selected, there may be another level of stencils to select from.

3. If you want to display all services (but not BPML activities) in one single
stencil, from the View menu select View > Stencil > All Services.

Example

For example, the ebXML stencil contains icons for services that implement
business-to-business data exchange using the ebXML format, such as the ebXML
Digital Signature service and the ebXML Profile service. In this example, the
category is Internet B2B, and the sub-category is ebXML. From the View menu,
you would select Stencil > Internet B2B > ebXML.

Note: If you do not have a license for a service or adapter that you include in a
business process model, the business process will fail when you attempt to run it
in Sterling B2B Integrator.

What to do next

For more information, see GPM Stencil Descriptions.

Stencil Descriptions
The following table describes the Graphical Process Modeler (GPM) stencils. The
table is arranged alphabetically by stencil category.

Category / Stencil Name Contains Icons for:

All / All Services All installed services (not including activities
in the Business Process Modeling Language
(BPML) stencil). Service icons display in
alphabetical order. All other stencils are
subsets of this stencil.

Applications / ERP Adapters installed to connect to external,
Enterprise Resource Planning applications,
such as:

v PeopleSoft CRM
®

(Vantive) adapter

v SAP® R/3
®

adapter

Applications / IBM® Adapters installed to connect to external,
IBM applications, such as:

v IBM Sterling Connect:Direct® Requester
adapter and related services

v IBM Sterling Connect:Enterprise® UNIX
Server adapter and related services

v IBM Sterling Gentran:Server® Windows
adapter

v IBM Sterling Information Broker®

B2B Protocols / FTP Client Services that complete B2B communication
using File Transfer Protocol, such as:

v FTP Client Password service

v FTP Client Server service
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Category / Stencil Name Contains Icons for:

B2B Protocols / HTTP Client Services that complete B2B communication
using Hypertext Transfer Protocol, such as:

v HTTP Client Post service

v HTTP Client Method service

B2B Protocols / SFTP Client Services that complete B2B communication
using Secure Shell File Transfer Protocol
(SSH/SFTP), such as:

v SFTP Client PUT service

v SFTP Client GET service

BPML / BPML Commonly used BPML activities and
instructions, such as:

v Start

v End

v Assign

v Join

Communications / Communications Services and adapters that enable Sterling
B2B Integrator to send and receive messages
using the standard Internet communications
protocols, such as:

v B2B HTTP Client adapter and related
services

v FTP Client adapter and related services

v HTTP Client adapter and related services

v MIME service

Custom / Custom Custom-created services, after your software
developer has developed, installed, and
configured them.

EDI / ACH Services related to EDI transaction
processing requirements using Automated
Clearing House standards, such as:

v ACH Enveloping service

v ACH Deenvelope service

EDI / CII Services related to EDI transaction
processing requirements using Japanese
Center for Informatization of Industry
standards, such as:

v CII Deenvelope service

v Envelope service

EDI / EDIFACT Services related to EDI transaction
processing requirements using EDIFACT
standards, such as:

v EDI, UNB, UNH, Deevenlope and
Envelope services

v Generate and Reconcile Control services

EDI / TRADACOMS Services related to EDI transaction
processing requirements using
TRADACOMS standards, such as:

v EDI Envelope service

v Generic Envelope service

Graphical Process Modeler 15



Category / Stencil Name Contains Icons for:

EDI / X12 Services related to EDI transaction
processing requirements using Accredited
Standards Committee X12 standards, such
as:

v 997 Generator and Reconcile services

v EDI, GS, ISA, ST Deenvelope and
Envelope services

v TA1 Generator and Reconcile services

Internet B2B / E5 Services that implement business-to-business
data exchange using the E5 (clients and
servers) format, such as:

v E5 Client Configuration service

v E5 Obtain service

Internet B2B / ebXML Services that implement business-to-business
data exchange using the ebXML format,
such as:

v ebXML Digital Signature service

v ebXML Profile service

Internet B2B / EDIINT Services that implement business-to-business
data exchange using the EDIINT protocol,
such as:

v EDIINT Acknowledge Check service

v EDIINT Message service

v EDIINT Pipeline service

Internet B2B / Mailbox Services that implement business-to-business
data exchange using mailbox format, such
as:

v Mailbox Evaluation Routing Rule service

v Mailbox Extract Begin service

Internet B2B / Rosettanet Services that implement business-to-business
data exchange using RosettaNet

™
RNIF

standards, such as:

v RNIF 20 MessageBuilder service

v RN Profile service

v RosettaNet Sender service

Internet B2B / SOAP Services that implement business-to-business
data exchange using Simple Object Access
Protocol, such as:

v SOAP Inbound service

v SOAP Outbound service

Internet B2B / Transora Services that implement business-to-business
data exchange using Transora

™
exchange

methods, such as:

v TDC Document XPath Replace service

v Transora HTTP AS2 DocHandler service

v Transora HTTP AS2 MDNHandler service
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Category / Stencil Name Contains Icons for:

Messaging / Instant Messaging Services that enable Sterling B2B Integrator
to send and receive instant messages, such
as:

v IM Send Message service

v IM Receive Message service

Messaging / Queuing Adapters that enable Sterling B2B Integrator
to send messages to and from remote
messaging queues, such as:

v MSMQ adapter

v Oracle AQ JMS Queue adapter

v Oracle AQ JMS Topic adapter

v TIBCO adapter

v Vitria adapter

v WebMethods Publisher adapter

v WebMethods Subscriber adapter

v WebSphereMQ adapter

v WebSphereMQ Suite

Messaging / WebSphereMQSuite Services that enable you to script a complete
MQ session using a business process, such
as:

v WebSphere® MQ Suite Open Session
service

v WebSphere MQ Suite Get Message service

v WebSphere MQ Suite Commit service

Process Controls / Process Controls Services that:

v Enable custom control at an intricate level
(for example, at each step) when running
business processes

v Can improve business process
performance

For example, the Execution Control service
enables you to change the priority queue
previously defined with regard to system
allocation of resources, when running
business processes. Examples of Process
Control services are:

v Cache Refresh service

v Execution Control service

v Wait services
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Category / Stencil Name Contains Icons for:

Retiring / Retiring Services and adapters that will soon no
longer be supported in Sterling B2B
Integrator. In order to improve performance,
enhance features, or ensure compatibility
with recent product releases, IBM
periodically retires services and adapters
and makes other services and adapters
available to fill the need. If you are currently
using services or adapters listed in the
Retiring stencil, you must replace these
services and adapters in your business
process models with other services and
adapters.Services and adapters listed in the
Retiring stencil are supported for the current
release of Sterling B2B Integrator. However,
to ensure that you employ the most current
capability, avoid using them.

Sync Mode Services that can run in Sync mode. Sync
mode holds a single processing thread until
it has completed its work. Services that are
not included are those in the following
categories:

v Performs Waiting or Waiting on IO

v Split

v Join

v Invoke sync

v Produce/Consume

v All Notify Complete services

System / System Services and adapters that enable business
processes to interact with hardware and
software resources such as application
components, file systems, operating systems,
and databases, both internal and external to
Sterling B2B Integrator, such as:

v Command Line Adapter 2

v File System adapter

v Java
™

Database Connectivity (JDBC
™
)

adapter

v Lightweight Java Database Connectivity
(JDBC) adapter

Translation / Translation Services that translate or transform data
using maps created with the Map Editor,
such as:

v Translation service

v Typing service

v XML Encoder service

v XSLT service
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Category / Stencil Name Contains Icons for:

Transport / Transport Adapters that offer additional options that
enable Sterling B2B Integrator to
communicate with local or remote servers
and exchange data, such as:

v Lightweight Directory Access Protocol
(LDAP) adapter

v Remote Method Invocation (RMI) adapter

v Simple Network Management Protocol
(SNMP) Trap adapter

Web Extensions / Web Extensions Services that support Web services
technologies. Web services directly invoke
application function calls over the Internet.
Examples of Web Extensions services are:

v Human Interaction Document Loader
service

v Human Interaction Event and Query
services

XPath Expression Builder

Note: This topic assumes familiarity with XML Path language (XPath). If you need
more information about XPath, see the World Wide Web Consortium at
www.w3c.org and the Business Process Modeling Language (BPML)
documentation.

The XPath Expression Builder makes creating XPath expressions to use in your
business process models more convenient. Function and token menus enable you
to select the functions and tokens to build an expression.

The following figure shows the XPath Expression Builder. For more information,
see Defining and Assigning Rules and Conditions under Managing Business Processes.
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The Expression Builder provides descriptive information to help you make your
choices:
v When you mouse over a function or token, pop-up help describes the selection.
v Function selections are comprised of two parts. The first part, in italics, is

descriptive of the function. The second part, in bold text, is the actual code for
the XPath function you are selecting. For example, the number last ( ) function
selection indicates that the last function returns a number.

The following figure shows a pop-up description and indicates the parts of a
function selection:
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The XPath Expression Builder supports several function types and token sets. To
build XPath expressions, you must be familiar with the expression type you need
and understand the functions and tokens used in the expression types. For
descriptions of XPath function types and tokens, view the XPath Tutorial at
http://www.w3c.org.

Remember that you cannot use functions and tokens in Sterling B2B Integratorthat
are not supported in the XPath Expression Builder, with the following exceptions:
v DocToDOM
v DOMToDoc

For information about these exceptions, see the BPML documentation.

The following table describes the function types supported by the XPath
Expression Builder:

Function type Description

Node-Set Used to obtain information from an XML
document, such as counting purchase orders
in a node set. Also:

v Defines a set of sequential context-nodes

v Specifies what information to process or
return for the set of context-nodes

String Perform basic string operations, such as:

v Finding the length of a string

v Comparing a string

v Changing letters from uppercase to
lowercase

v Modifying the text content of XML
elements or attributes

v Converting an argument of any type

Boolean Specifies a Boolean argument (using either
the true or false state) that can include
predicates and return the result.

Number Manipulate numbers, such as:

v Specifying a numeric function for adding
groups of numbers

v Finding the nearest integer to a number

v Performing basic arithmetic operations

The following table describes the three token sets supported by the XPath
Expression Builder:

Token Set Use to:

Axis Define the direction of your search by using
keywords, including:

v Attributes

v Child elements (default)

v Descendants of the child elements

v Parent elements

v Ancestor elements
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Token Set Use to:

Node Test Indicate the name of the node for which to
search.
Note: Insert the name of the node test after
the resolution operator (::) that follows the
axis.

Predicate Insert a relational operator to test each node
in the set of context-nodes of a location path.
Note: Predicates can use Boolean operators.

Annotation Tool
The Annotation tool enables you to add customized comments such as descriptive
names or explanations, for your reference, to the icons in the graphic display of
your business process models.

The Graphical Process Modeler (GPM) automatically includes annotations with all
icons. When you pause with your mouse arrow over an icon or the name of an
icon in the workspace, the annotation for the icon pops up. Using the Annotation
tool, you can modify the annotations so that they are more useful for you.

The following figure illustrates an annotation in a simple business process model:

The GPM does not store annotations in the Business Process Modeling Language
(BPML) content of a business process model, therefore, they display only in the
GPM representation of a business process model, not in the source BPML. For the
same reason, if you edit and save a process model directly in the source BPML, the
annotations will no longer be part of the business process model.

Uninstall the Graphical Process Modeler
If you have more than one copy of the Graphical Process Modeler (GPM)
installed—for example, if you have installed a copy to use for testing and a copy to
use for production—you can remove a copy of the GPM using the Java Application
Cache Viewer.

About this task

To remove a copy of the GPM:
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Procedure
1. From the Windows Start menu, select Run.
2. Type javaws -viewer and click OK. The Java Cache Viewer appears.
3. From the Application column, select the Modeler (or the copy of the GPM)

that you want to remove.
4. Click Remove selected items. The selected copy of the GPM is removed from

the client computer.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive

Armonk, NY 10504-1785

U.S.A.

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing

Legal and Intellectual Property Law

IBM Japan Ltd.

19-21, Nihonbashi-Hakozakicho, Chuo-ku

Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
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incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation

J46A/G4

555 Bailey Avenue

San Jose, CA 95141-1003

U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.
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This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© IBM 2015. Portions of this code are derived from IBM Corp. Sample Programs. ©
Copyright IBM Corp. 2015.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks

IBM, the IBM logo, and ibm.com® are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “Copyright and
trademark information” at http://www.ibm.com/legal/copytrade.shtml.

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States,
and/or other countries.

IT Infrastructure Library is a registered trademark of the Central Computer and
Telecommunications Agency which is now part of the Office of Government
Commerce.

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,
Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.
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Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

ITIL is a registered trademark, and a registered community trademark of the Office
of Government Commerce, and is registered in the U.S. Patent and Trademark
Office.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the
United States, other countries, or both and is used under license therefrom.

Linear Tape-Open, LTO, the LTO Logo, Ultrium and the Ultrium Logo are
trademarks of HP, IBM Corp. and Quantum in the U.S. and other countries.

Connect Control Center®, Connect:Direct®, Connect:Enterprise, Gentran®,
Gentran®:Basic®, Gentran:Control®, Gentran:Director®, Gentran:Plus®,
Gentran:Realtime®, Gentran:Server®, Gentran:Viewpoint®, Sterling Commerce™,
Sterling Information Broker®, and Sterling Integrator® are trademarks or registered
trademarks of Sterling Commerce®, Inc., an IBM Company.

Other company, product, and service names may be trademarks or service marks
of others.
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