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Chapter 1. Localization of IBM Sterling Business Intelligence:
An Overview

The IBM® Sterling Business Intelligence solution can be used by users from
different locales to generate dashboards and reports. Localization of Sterling
Business Intelligence is the process of adapting Sterling Business Intelligence for a
particular country or region. Localization enables Sterling Business Intelligence to
support the character set of a user's locale, and display numbers, literals, and
report data that is appropriate to the locale.

Localization of Sterling Business Intelligence includes the following tasks:
v “Localize the IBM Sterling Business Intelligence Dashboard Literals” on page 5
v Chapter 4, “Localize IBM Sterling Business Intelligence Report Literals,” on page

7
v Chapter 5, “Localize IBM Sterling Business Intelligence Reports and Dashboard

Data,” on page 9
v Chapter 6, “Localizing the Factory Setup Data,” on page 11

Intended Audience
This manual is intended to provide a general localization procedure for users who
are responsible for localizing the Sterling Business Intelligence solution.
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Chapter 2. Localizing Resource Bundles

The user interface components in Sterling Business Intelligence use resource
bundles that contain all the static literals displayed throughout the application.
After you perform the translation into multiple languages ensure that you create a
folder corresponding to each of the locales and the corresponding bundle files. The
folder name must be in the format <language>_<locale>. For example, if a locale
has been created for Japan in Japanese language, a folder named ja_JP must be
created. In addition, literals used in the customized screens have their own
resource bundles and must also be considered during the localization process.

A resource bundle is a file that consists of the resource bundle keys and the
corresponding values. Each field in the user interface has a resource bundle key
associated with it. The values pertaining to these resource bundle keys are
translated as part of localization. To display the translated literal pertaining to a
field in the user interface, the localized value of the key associated with the field is
fetched from the bundle file.

Sterling Business Intelligence supports the following resource bundles:
v Menu: The menu resource bundle file enables the localization of menu entries

by fetching the values from the sbibundle.properties file located in the
Files\resources folder.

v Screen Literals and Messages: The bundle-index.properties file is used to
localize the following:
– Error and warning messages displayed on the user interface.
– Descriptions pertaining to labels, panels, and headings in the user interface.
– Dynamic data within a literal. For example, the user interface may have to

display a literal that informs a user that an input value cannot exceed a
certain number of characters, and that the number of characters is dynamic.
In this case, if the maximum character length for a description is set at 428
characters, 428 is the value of the parameter. The corresponding bundle entry
is defined as "b_MaxCharLengthExceeded":"The value cannot exceed {0}
characters”.

For more information about understanding the localizable components and data,
refer to the Sterling Selling and Fulfillment Foundation: Localization Guide.

Localize Client-Side Literals
About this task

To localize the client-side literals, you must run the JavaScript bundle collector
utility by performing the following steps:

Procedure
1. If you are localizing Sterling Business Intelligence, you must generate the

bundle-index.properties file. Therefore, run the following script from the
<INSTALL_DIR>/bin folder to extract the client-side literals in the
bundle-index.properties file:
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ant -f jsUtil.xml bundle.index -Dsourcedir=<INSTALL_DIR>/repository/
eardata/sbi/war -Dindexdir=<INSTALL_DIR>/repository/eardata/sbi/
localization_index

where -Dindexdir is the output directory.
A new folder, localization_index, containing the following files is created:
v opts
v context-index
v bundle-index.properties

2. Send the bundle-index.properties file for translation.
3. After localization, save the localized bundle-index.properties file as

bundle-index_<language_code>_<locale>.properties based on the locale in the
<INSTALL_DIR>/repository/eardata/sbi/localization_index folder.
For example, if you want to localize the application for France in French
language, save the localized bundle-index.properties as bundle-
index_fr_FR.properties.

Note: If you have not localized the Web UI Framework client-side literals
already, you must localize the Web UI Framework client-side literals by
running the JavaScript bundle collector utility. For more information about
running the bundle collector utility to localize platform files, refer to Sterling
Selling and Fulfillment Foundation: Localizing the Web UI Framework .

4. Perform the postlocalization tasks on the client side. For more information
about the postlocalization tasks, refer to the topic Chapter 7, “Postlocalization
Tasks,” on page 13.

Localize Server-Side Literals
About this task

To localize the server-side literals, perform the following steps:

Procedure
1. Send the sbibundle.properties file located in the <INSTALL_DIR>/resources

folder for translation.
2. Save the localized sbibundle.properties file as

sbibundle_<language>_<locale>.properties based on the locale in the
<INSTALL_DIR>/resources folder. For example, if you localize the application for
France in French language, save the localized sbibundle.properties file as
sbibundle_fr_FR.properties.

3. Perform the postlocalization tasks on the server side. For more information
about the postlocalization tasks, refer to the topic Chapter 7, “Postlocalization
Tasks,” on page 13.

Note: It is recommended that when you localize the literals, you keep the
length of the literals short in order to avoid them getting truncated.
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Chapter 3. Localizing IBM Sterling Business Intelligence
Dashboard Literals

The dashboards in Sterling Business Intelligence use a common resource bundle
that contains the literals displayed on the screens. You can localize the dashboard
headers, column titles, field names, chart titles, and chart legends.

The resource bundles of Sterling Business Intelligence are located in the
<BI_COGNOS8_HOME>/resources/sbianalyticsbundle.properties file. Cognos 8
Business Intelligence Content is installed in the <BI_COGNOS8_HOME> folder.

Note: IBM always releases all the resource bundles in the
sbianalyticsbundle.properties file with the localized versions of Sterling Business
Intelligence. Incremental updates for the sbianalyticsbundle.properties file are
not provided. When localizing the Sterling Business Intelligence dashboards, it is
your responsibility or that of your localizing company to compare and validate the
differences between the resource bundles.

Localize the IBM Sterling Business Intelligence Dashboard Literals
About this task

To localize the resource bundles, perform the following tasks:

Procedure
1. Open the <BI_COGNOS8_HOME>/resources/sbianalyticsbundle.properties file

from the <BI_COGNOS8_HOME>/resources folder and save it as
<BI_COGNOS8_HOME>/resources/
sbianalyticsbundle_<language>_<locale>.properties.

2. Each resource bundle contains a <key>=<value> pair, where key is the resource
key, and value is the literal displayed for the corresponding locale. Replace
<value> with the translated value.

3. Save the modified file. If the file is in UTF-8 format, convert it to ASCII by
running the native2ascii command as follows:
native2ascii -encoding UTF-8 <source file> <target file>

The file should be returned in the following format:
<filename>_<2 letter code for language as given by ISO 639>_<2 letter
code for territory as given by ISO 3166>.<file extension>

For example, sbianalyticsbundle.properties should be returned as
sbianalyticsbundle_fr_FR.properties.

Note: Files localized in Latin1 languages do not require this conversion.

What to do next

To localize the dashboard literals, perform the following tasks:
1. Ensure that the environment variables BI_RT and BI_COGNOS8_HOME are set, For

example in UNIX,
export BI_RT = <BI_COGNOS8_HOME>

export BI_COGNOS8_HOME = <BI_COGNOS8_HOME>
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Note: The <BI_COGNOS8_HOME> directory is the root directory where the Cognos
8 Business Intelligence Content is installed.

2. Copy the following jar files to <BI_COGNOS8_HOME>/lib folder from
<COGNOS_HOME>/ap/webapps/p2pd/WEB-INF/lib folder.
v axis.jar
v axisCrnpClient.jar
v CAM_AAA.jar
v CAM_AAA_CustomIF.jar
v commons-discovery.jar
v commons-logging-1.0.4.jar
v dom4j.jar
v jaxrpc.jar
v saaj.jar
v soap.jar
v xalan.jar
v xercesImpl.jar
v xml-apis.jar

3. Ensure that you have disabled the Cognos 8 Business Intelligence
authentication.

4. To localize the dashboard literals in the <BI_COGNOS8_HOME> folder, execute the
following command from the <BI_COGNOS8_HOME>/bin folder:
ant -f sbilocalizer.xml import

Note:

v If you have installed Sterling Business Intelligence Content for Cognos® 8
Business Intelligence and Sterling Business Intelligence on two different
machines, you must modify the following line of the XML by replacing
localhost with the IP address of the machine on which Sterling Business
Intelligence Content for Cognos 8 Business Intelligence has been installed
before you execute the command:
<property name="cognosurl" value="http://localhost:<port>/p2pd/
servlet/dispatch"/>

v The sbilocalizer.xml file can be executed in the following modes:
ant -f sbilocalizer.xml validate, to validate the dashboard literals in the
sbianalyticsbundle_<language>_<locale>.properties file.
ant -f sbilocalizer.xml extract, to export the dashboard literals.

Note: The sbilocalizer.xml command reads all the bundles in the
<BI_COGNOS8_HOME>/resources folder. It then adds the literal translations for
each locale into the dashboard definitions present in the <BI_COGNOS8_HOME>/
reports folder. The modified dashboard definitions are copied into the
<BI_COGNOS8_HOME>/localizedreports folder, and added into the content
repository. When the dashboards are generated again, the literals are displayed
according to the user's locale.

5. Ensure that you enable the Cognos 8 Business Intelligence authentication.
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Chapter 4. Localize IBM Sterling Business Intelligence Report
Literals

You can localize the Sterling Business Intelligence report labels and report titles by
exporting and importing language translation files using the IBM Cognos Adaptive
Warehouse and IBM Cognos Adaptive Analytics applications.

Localize Report Literals using IBM Cognos Adaptive Warehouse
About this task

To localize the report literals, perform the following tasks:

Procedure
1. Launch the IBM Cognos Adaptive Warehouse application and click on the

Target tab to open the Target view.
2. From Project menu, navigate to Languages > Define Languages. The Define

Languages window is displayed.
3. From the Available Languages list, select each language that you want to add

and click the arrow button to move it to the Project languages box and click
OK.

4. From the Project menu, navigate to Languages > Export Translation File. The
Export Translation File window is displayed.

5. Select each language that you want to export, and click the arrow button to
move them into the Languages to be exported box.

6. Enter the location of the folder from where the <AC_INSTALL_DIR>\resources\
sbiawbundle_<languagecode>_<localecode>.txt translation file must be
exported.

7. Open the sbiawbundle_<languagecode>_<localecode>.txt file and modify the
contents of the file to match your locale and save the file using the File >
Save option.

8. From the Project menu, navigate to Languages > Import Translation File. The
Import Translation File window is displayed.

9. From the Project Languages list, select the required project language.
10. Select the <AC_INSTALL_DIR>\resources\

sbiawbundle_<languagecode>_<localecode>.txt file that must be imported.
Sterling Business Intelligence Analytics Content is installed in
the<AC_INSTALL_DIR> folder.

11. Click OK.
12. Click Save.
13. In the Target tab, in the Project Viewer pane, click on Packages > Sterling Data

Source.
14. In Properties window click on Language, Languages window is displayed.
15. In the Languages window, select the language that you want to add from the

Available Languages list and click the arrow button to move it to the Project
languages box. Click OK.

16. Click Save.
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17. Publish the Sterling Data Source Package. For more information about
publishing Sterling Data Source Package, refer to the Sterling Business
Intelligence: Installation Guide.

Localize Report Literals using IBM Cognos Adaptive Analytics
About this task

To localize the report literals, perform the following tasks:

Procedure
1. Launch the IBM Cognos Adaptive Analytics application and open the project

that you want to localize.
2. From Project menu, navigate to Languages > Define Languages. The Define

Languages window is displayed.
3. From the Available Languages list, select each language that you want to add

and click the arrow button to move it to the Project languages box and click
OK.

4. From the Project menu, navigate to Languages > Export Translation File. The
Export Translation File window is displayed.

5. Select each language that you want to export, and click the arrow button to
move them into the Languages to be exported box.

6. Enter the location of the folder from where the <AC_INSTALL_DIR>\resources\
sbiaabundle_<languagecode>_<localecode>.txt translation file must be
exported.

7. Open the sbiaabundle_<languagecode>_<localecode>.txt file and modify the
contents of the file to match your locale and save the file using the File >
Save option.

8. From the Project menu, navigate to Languages > Import Translation File. The
Import Translation File window is displayed.

9. From the Project Languages list, select the required project language.
10. Select the <AC_INSTALL_DIR>\resources\

sbiaabundle_<languagecode>_<localecode>.txt file that must be imported.
Sterling Business Intelligence Analytics Content is installed in the
<AC_INSTALL_DIR> folder.

11. Click OK.
12. Click Save.
13. From the Actions menu, select Generate Deployment Archive. The Save As

window is displayed
14. In the File name box, enter a name for the archive.
15. Click Save. The Validate Object dialog box is displayed.
16. Click Close. The deployment archive is created. You can now publish your

reports in IBM Cognos Connection. For more information about publishing
your reports in IBM Cognos Connection, refer to the IBM Cognos 8 Analytic
Applications Adaptive Analytics User Guide.

8 Sterling Business Intelligence: Localization Guide



Chapter 5. Localize IBM Sterling Business Intelligence
Reports and Dashboard Data

You can localize the data in the Sterling Business Intelligence reports and
dashboards using the IBM Cognos Adaptive Warehouse application. All the data
present in a dashboard that describing an entity, for example, Category
Description, Region Description, Buyer Description and so on, are localized in the
data warehouse database. The data warehouse database contains localized data
from the YFS_LOCALIZED_STRINGS table, which is transformed and added as
additional columns.

Before you begin

Note: Before you start the data localization process, the database factory default
values must be localized. For more information about localization for multilingual
installation, refer to the Sterling Selling and Fulfillment Foundation: Localization Guide.

About this task

To localize the data in the Sterling Business Intelligence reports and dashboards,
perform the following tasks:

Procedure
1. Launch the IBM Cognos Adaptive Warehouse application. By default, the

application opens in the Warehouse view.
2. From the Actions menu, select Edit Data languages.

The Specify Project Languages pop-up window is displayed.
3. Click Add.
4. Enter the New Languages and Language code.
5. Click OK.
6. Click Synchronize Target Metadata.
7. Click Save and perform the load management.

For more information about performing load management, refer to the Cognos 8
Analytic Applications Adaptive Warehouse User Guide.
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Chapter 6. Localizing the Factory Setup Data

Besides storing your transactional data, the database also stores configuration data,
such as error codes. This means that the database may need to store values in a
language-specific format. If these database literals are not localized, screen literals
are displayed inconsistently, with some being displayed in the localized language
and others being displayed in English.

The sbifcliterals2translate.properties file contains all the Sterling Business
Intelligence factory setup literals that need to be localized.

To localize the factory setup data, perform the following tasks:
1. Open the sbifcliterals2translate.properties file located in

Files/installed_data/smcfs/components/complete_installation/
factorysetup/XMLS in the localization kit, and enter the corresponding literals
for the required locale after the corresponding delimiter.

2. Rename the sbifcliterals2translate.properties file as en_US_
sbifcliterals2translate.properties_<language>_<locale>.properties

For example, in the case of French customers,
sbifcliterals2translate.properties should be renamed as
en_US_sbifcliterals2translate.properties_fr_FR.properties, where fr
indicates the language, that is French, and FR indicates the country or region,
France.

3. Copy the
en_US_sbifcliterals2translate.properties_<language>_<locale>.properties
file to the <INSTALL_DIR>/installed_data/smcfs/components/
complete_installation/factorysetup/XMLS folder. <INSTALL_DIR> is the
directory where the Sterling Selling and Fulfillment Foundation is installed.

4. Run the following command from the <INSTALL_DIR>/bin folder:
v For Windows:

sci_ant.cmd -f localizedstringreconciler.xml import
-Dsrc=<INSTALL_DIR>\installed_data\smcfs\components\
complete_installation\factorysetup\XMLS
-Dbasefilename=sbifcliterals2translate

v For UNIX or Linux:
sci_ant.sh -f localizedstringreconciler.xml import
-Dsrc=<INSTALL_DIR>/installed_data/smcfs/components/
complete_installation/factorysetup/XMLS
-Dbasefilename=sbifcliterals2translate
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Chapter 7. Postlocalization Tasks

The localized resource bundles are not automatically used by Sterling Business
Intelligence. To ensure that the localized bundles are used by Sterling Business
Intelligence, you must re-create the Sterling Selling and Fulfillment Foundation
Enterprise ARchive (EAR) package.

The following sections describe the postlocalization activities on the server side
and the client side.

Postlocalization Tasks for Server Side Literals
About this task

After you have localized the server-side bundles, perform the following steps:

Procedure
1. Create the resource JAR using the following command from the

<INSTALL_DIR>/bin folder:
For Windows:
deployer.cmd -t resourcejar

For Linux/UNIX:
deployer.sh -t resourcejar

2. Re-create the smcfs.ear file. This file is the Sterling Selling and Fulfillment
Foundation EAR package.
For more information about creating the EAR file, refer to the Sterling Selling
and Fulfillment Foundation: Installation Guide.

Postlocalization Tasks for Client Side Literals
About this task

After you have localized the client-side bundles, perform the following steps:

Procedure
1. Navigate to the <INSTALL_DIR>/bin folder:
2. To generate localized JavaScript source files from the localized

bundle-index.properties file, run the following command:

Note: Ensure that the directory <INSTALL_DIR> is set as an environment
variable.

ant -f jsUtil.xml bundle.map -Dsourcedir=<INSTALL_DIR>/repository/
eardata/sbi/war -Dindexdir=<INSTALL_DIR>/repository/eardata/sbi/
localization_index -Dindexfile=<INSTALL_DIR>/repository/eardata/sbi/
localization_index/bundle-index_<language>_<locale>.properties
-Dwebcontentdepth=0

where -Dindexdir is the output directory.
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For example, if you have localized for the French locale, and the localization
directory is <INSTALL_DIR>/repository/eardata/sbi/localization_index, and
the localized bundle-index file is bundle-index_fr_FR.properties, run the
following command:

ant -f jsUtil.xml bundle.map -Dsourcedir=<INSTALL_DIR>/repository/
eardata/sbi/war -Dindexdir=<INSTALL_DIR>/repository/eardata/sbi/
localization_index -Dindexfile=<INSTALL_DIR>/repository/eardata/sbi/
localization_index/bundle-index_fr_FR.properties -Dwebcontentdepth=0

where -Dindexdir is the output directory.
3. To generate minified JavaScript source files from the localized

bundle-index.properties file, run the following command:
ant -f jsUtil.xml minify-js -DsrcDir=<INSTALL_DIR>/repository/eardata/
sbi/war -DdestDir=<INSTALL_DIR>/repository/eardata/sbi/war -Dminify=true
-DcreateIndividualFile=false -DjsbDir=<INSTALL_DIR>/repository/eardata/
sbi/war/builder/sbi

4. Re-create the smcfs.ear file. This file is the IBM Sterling Selling and Fulfillment
Foundation EAR package.
For more information about creating the EAR file, refer to the Sterling Selling
and Fulfillment Foundation: Installation Guide.

Note: After localizing the application, you may want to verify that the
application has been localized. However, because resource bundles are cached
in a Web browser, it is recommended that you clear the Web cache before
verifying the localization.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive

Armonk, NY 10504-1785

U.S.A.

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing

Legal and Intellectual Property Law

IBM Japan Ltd.

1623-14, Shimotsuruma, Yamato-shi

Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
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incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation

J46A/G4

555 Bailey Avenue

San Jose, CA 95141-1003

U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.
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This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© IBM 2011. Portions of this code are derived from IBM Corp. Sample Programs. ©
Copyright IBM Corp. 2011.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “Copyright and
trademark information” at http://www.ibm.com/legal/copytrade.shtml.

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States,
and/or other countries.

IT Infrastructure Library is a registered trademark of the Central Computer and
Telecommunications Agency which is now part of the Office of Government
Commerce.

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,
Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.
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Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

ITIL is a registered trademark, and a registered community trademark of the Office
of Government Commerce, and is registered in the U.S. Patent and Trademark
Office.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the
United States, other countries, or both and is used under license therefrom.

Linear Tape-Open, LTO, the LTO Logo, Ultrium and the Ultrium Logo are
trademarks of HP, IBM Corp. and Quantum in the U.S. and other countries.

Connect Control Center®, Connect:Direct®, Connect:Enterprise, Gentran®,
Gentran:Basic®, Gentran:Control®, Gentran:Director®, Gentran:Plus®,
Gentran:Realtime®, Gentran:Server®, Gentran:Viewpoint®, Sterling Commerce™,
Sterling Information Broker®, and Sterling Integrator® are trademarks or registered
trademarks of Sterling Commerce, Inc., an IBM Company.

Other company, product, and service names may be trademarks or service marks
of others.
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