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Welcome to Axiant 4GL

Overview
Axiant 4GL is a Windows-based programming tool you use to create and migrate PowerHouse 
applications. You can build simple standalone systems—such as an employee information system 
for a small business. You can also build complex client/server systems—such as a sales/orders 
system for a large firm. You can define data from within Axiant 4GL, or you can import data 
definitions (SQL, ODBC, or PDL). You can create new Screen, Report, or QTP programs, and you 
can import existing QUICK, QUIZ, and QTP programs from your PowerHouse applications.

Axiant 4GL creates applications with Relational Databases and File Collections.

Axiant 4GL is particularly suited to team development. This is because Axiant 4GL provides a 
central Repository for the objects that comprise your application.

Installing Axiant 4GL
Install Axiant 4GL and PowerHouse Licensing. If you want to try a deployed Axiant application, 
install Axiant 4GL Client. You will also have to obtain permanent or temporary license keys for 
Axiant 4GL.

For instructions on how to install and license Axiant 4GL, see the Axiant 4GL Getting Started 
book.

For late-breaking information about installing Axiant 4GL, see the Axiant 4GL Release and 
Install Notes.

The Tours
The  procedures in the tours are performed using the Sybase SQL Anywhere 9 database. For 
information about setting up Sybase SQL Anywhere before you start the tours, see "Using Sybase 
SQL Anywhere 9" (p. 59) 

You can use other databases instead of Sybase SQL Anywhere 9 to complete the tours. For 
information about these databases and the database setup required, see the appendix, "Database 
Requirements" (p. 59).

The procedures documented in the tours can vary if you are not using Sybase SQL Anywhere 9 as 
your database.  Where the procedures differ, you are advised. 

What's in This Book?
This book contains hands-on tutorials and basic conceptual information. Here's what each 
chapter offers:

Chapter Contents

Welcome Information about the resources available to help you learn to 
use Axiant 4GL.

Chapter 1. 
The Fast Tour

A hands-on tutorial that introduces the Axiant 4GL migration 
process. In under 30 minutes, you can migrate a modest 
PowerHouse application to Axiant 4GL.
A Guided Tour of Axiant 4GL  5
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How Can I Learn How to Use Axiant 4GL?

This Guided Tour will help you learn to use Axiant 4GL. You can also import and use the 
example database (example_4gl.db) or example SQL (example_4gl.sql) included with the product. 

For information about setting up the example database, see (p. 60). For additional topics that use 
the example database, refer to the Axiant 4GL online Help.

Axiant 4GL Courses
Cognos offers Axiant 4GL courses. For more information, contact your Cognos representative or 
CognosDirect, or see the Cognos Web site at www.cognos.com.

How Can I Access Online Help?
The online Help is the most comprehensive source of information available about Axiant 4GL. It 
contains thousands of topics. Because it is context-sensitive, you can usually get the information 
you need when and where you need it.

Help Topics Window

You can access help from the Help menu. Click the Help Topics command to view the Help Topics 
window, where you can look up terms in the Index tab, explore the Contents tab, or perform 
full-text searches in the Find tab.

Context-Sensitive Help

How you access context-sensitive Help varies with the subject of the Help request. The following 
table indicates what techniques can be used in different parts of the product.

Chapter 2.
What Happened in the 
Fast Tour

A description of what took place behind the scenes when you 
performed the Fast Tour.

Chapter 3.
Customizing Screen 
Programs

A hands-on tutorial that introduces screen customization in 
Axiant 4GL. In under 30 minutes, you can customize an 
Axiant 4GL Screen Program.

Chapter Contents

Press F1

Click and 
apply the 
What’s this 
tool

Right-click and 
select "What’s 
This?"

Click and 
apply the 
Question 
mark button

Click the 
Help 
button

Object ✔ ✔ ✔

Properties ✔ ✔ ✔

Menu 
Commands

✔ ✔

Tools ✔

Keyword in 
syntax*

✔

Dialog boxes ✔
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What Customer Support Services Are Offered?

Cognos is committed to providing quality software and support to all our customers. To do that, 
we provide online Help in our products, high quality documentation, and a wide range of support 
and services, from software support to training and consulting. For information about customer 
support services, see Cognos Customer Support (p. 7), or the customer support information 
included in the Axiant 4GL box.

Cognos offers you several ways to get product help with Axiant 4GL. As a Cognos customer, you 
also have access to a range of additional services, such as
• Customer Support Packages
• TeleSupport
• Emergency Support

Cognos Customer Support
For more information about using this product or for technical assistance, visit the Cognos Global 
Customer Services Web site (http://support.cognos.com). This site provides product information, 
services, user forums, and a knowledge base of documentation and multimedia materials. To 
create a case, contact a support person, or provide feedback, click the Contact Us link at the 
bottom of the Web page. To create a Web account, click the Web Login & Contacts link. For 
information about education and training, click the Training link.

Dialog box 
controls

✔ ✔ ✔

* Place your cursor on a keyword then press F1 to get help for that keyword. If the 
keyword is part of a multiple-word statement or option, highlight the entire phrase to get 
help.

Press F1

Click and 
apply the 
What’s this 
tool

Right-click and 
select "What’s 
This?"

Click and 
apply the 
Question 
mark button

Click the 
Help 
button
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Chapter 1: The Fast Tour

Overview
This is a fast tour of the Axiant 4GL migration process. There are few explanations of what 
Axiant 4GL is doing in the background, and the tour does not go into great detail about what 
Axiant 4GL creates. The objective is simply to migrate an application that you can study later.

You can examine the Fast Tour and the application you create in Chapter 2, "What Happened in 
the Fast Tour?". You can customize one of the application’s screens in Chapter 3, "Customizing 
Screen Programs".

Setting the Scene
You are a developer with the Great Outdoors Company, a manufacturer and wholesaler of 
camping and hiking equipment. The company's sales force regularly visits camping supply stores 
and generates orders from the field through a mobile order entry system.

Currently, the sales force needs to file monthly timesheet reports using a PowerHouse application 
on a server. The application uses indexed files and a terminal interface available only at the head 
office.

The company wants to move the timesheet application from the server to a system the sales force 
can access remotely through their PCs. The new application needs to support a relational database 
and have a graphical user interface.

What Needs to be Done?
The current PowerHouse timesheet application includes a series of related QUICK screens, QUIZ 
reports, and QTP runs. The entire application must be moved to Axiant 4GL.

To successfully migrate the PowerHouse application, you need to:
• Review your existing PDL and normalize it (we've already done this for you).
• Create a Workspace and a Repository.
• Create a Migration Profile
• Migrate your data definitions and your application.
• Get your data ready to migrate, then use QTP to move the data into a relational database (if 

your using Sybase SQL Anywhere 9, we’ve done this for you).

It sounds like a lot. It's not. Axiant 4GL does most of the work through its Migration Profile.

Customizing Toolbars
Throughout the tutorial, you'll see optional shortcut buttons displayed in the left margin, like the 
one shown here for starting Axiant 4GL. Some are available only if you've customized your 
Axiant 4GL toolbars. To do this, click Toolbars from the View menu, then click Customize. If you 
need help, see Toolbars on the Index tab of the Axiant 4GL online Help.

Create a Workspace and Repository
Any time you work in Axiant 4GL, you need a place to do your work and a place to store your 
work. In Axiant 4GL, these places are the Workspace and the Repository.
A Guided Tour of Axiant 4GL  9
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You create a Workspace and a Repository as follows:
1. Start Axiant 4GL.
2. In the Welcome dialog box, click the New button. 

The New Workspace dialog box appears.

3. Click New Repository.
The New Repository dialog box appears.

We recommend saving your repository in the "My Documents" folder.
4. In the Location box, specify where you want the repository saved. (We recommend saving it 

in the My Documents folder.)
5. Type TSRepository in the Repository Name box and click OK. 
6. Click Connect on the New Workspace dialog box.

The Object Explorer window appears. It contains objects created by Axiant 4GL.

What Are Those Objects in My Workspace?
Your Workspace was populated with objects from the standard 
Axiant 4GL Repository. These include an Application object, several Library objects, a Relational 
Database object, and a File Collection object.

Do I Need all of the Objects?

You won't need the Relational Database and File Collection objects for this tour, so you can delete 
them. 
1. Click the Relational Database object to put it in focus.
2. Press the Delete key, and click Yes when you are prompted to confirm the deletion.
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3. Repeat Steps 1 and 2 to delete the File Collection object.

Create a Migration Profile
You can now begin the migration process. The first thing you need to do is to create a Migration 
Profile.

A Migration Profile guides the migration of a PowerHouse application to Axiant 4GL.
1. From the Insert Menu, click Migration Profile. 

The Data Definitions page of the Migration Profile Wizard appears.

You use the Migration Profile Wizard to specify the source components of your application.
2. Position your cursor inside the PDL Definitions box, then click the Browse button to the top 

right of it.
3. Find and double-click the following file: \Program Files\Cognos\Axiant 4GL 

<version>\Examples\GuidedTour\<database version>\Data\Timesheet.pdl.

4. Click Next.
The Program Source page appears.
A Guided Tour of Axiant 4GL  11
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5. Click in the PowerHouse Program Directories box, then click the Browse button to the top 

right of it. 
6. Find and double-click the QUICK source directory:

\Program Files\Cognos\Axiant 4GL<version>\Examples
\GuidedTour\<database version>\Source\Quick.
You'll see a list of source files.

7. Click Open.
The wizard now displays a directory pathname in the PowerHouse Program Directories box.

8. Do the same with the QUIZ and QTP source directories.
9. Once the three pathnames are displayed in the PowerHouse Program Directories box, click 

Next, and keep clicking it until the Finish option appears.

10. Click Finish.
Notice the Migration Profile you have just created is now shown in the left pane of the Object 
Explorer window of the Workspace.
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11. From the File menu, click Commit to store your work in the Repository.

Migrate Data Definitions
The Migration Profile you just created contains the details of the PowerHouse application you 
plan to migrate. Your next task is to import the application's data definitions into Axiant 4GL.
1. Maximize the Object Explorer window.
2. Double-click the Migration Profile object.

The Migration Profile window appears.
3. Click the Data Manager tab.

4. To move all file definitions at once, drag <all tables> from the left pane onto the Profile 
Databases object in the right pane.
Timesheet appears below the Profile Databases object.

5. Click the Timesheet database object to put it in focus.
6. We will be migrating from indexed files to Relational. In the Convert Selected Database to 

box, click Sybase SQL Anywhere. Note: If you are not using Sybase SQL Anywhere, click the 
database you are using instead, for example, DB2.
A Guided Tour of Axiant 4GL  13
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Edit the Definitions

Some naming conventions and structures common to indexed files are not supported by the SQL 
files used by a relational database. The source files need to be edited before you continue the 
migration. Axiant 4GL automates much of the process.
1. Click Advice. 

The Migration Advisor dialog box appears.

Several errors and warnings are identified; for example, the dashes or hyphens commonly 
used in indexed filenames are illegal characters in SQL filenames. 
Any errors need to be fixed. The warnings can be ignored for this tour.

2. Double-click the first error listed in the Issue box. The Migration Advisor Details dialog box 
appears.
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This dialog box lists the element names that include dashes. The Migration Advice box on the 
left describes the problem and recommends how to fix it. In this case, the recommendation is 
to change the dashes to underscores.

3. Click Change.
In the New Name column, Axiant 4GL shows you how the names will be changed. The 
changes will be applied to all the source programs that you migrate.

4. Click OK.
The Migration Adviser dialog box reappears.

5. Double-click the second error listed in the Issues box and repeat Steps 3 and 4.
6. Click OK.

The Data Manager tab reappears.
7. Click Migrate.

The Migration Issues Detected dialog box appears.

8. Click Continue.
The Migration Status dialog box appears.
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It gives a summary of any migration issues detected during the import. There may be a few 
warnings but there should be no errors. 

9. Click Close.
10. From the File menu, click Commit.

Migrate Your Application
Now that you've migrated your data definitions, it's time to migrate your application. For the 
purposes of this tour, we're going to migrate a series of QUICK screens.

You also migrate a QTP run file if you are using an Oracle, DB2, Sybase ASE or Microsoft SQL 
Server. The QTP run file is used to load data from portable subfiles into your database. You do 
not need to complete this task for Sybase SQL Anywhere 9 because this task has been completed 
for you.

Migrate a System of QUICK Screens
1. In the Migration Profile window, click the Application Manager tab.

2. Drag the file, TRSINITK.QKS, from the left pane onto the Application object in the right 
pane.
If TRSINITK.QKS doesn’t appear in your PowerHouse Environment window, change the 
filter to "QUICK Files", or scroll to find the file.
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ProgramSet_TRSINITK_QKS is created. This Program Set contains all the programs that are 
called from TRSINITK.QKS.

3. Click ProgramSet_TRSINITK_QKS.
4. Click Migrate.

Your screens are imported. When the import is complete, the Migration Status dialog box 
appears again. There should be no errors.

5. Click Close.
The Application Manager tab reappears.

Migrate a QTP Source File (Oracle, DB2, Sybase ASE, Microsoft SQL Server 
only)

If you are using Oracle, DB2, Sybase ASE, or Microsoft SQL Server, you must migrate a QTP run 
file in addition to the QUICK screens. Later in the tour, you use the QTP run to load data from the 
portable subfiles into the Timesheet database. This is not required if you are using Sybase SQL 
Anywhere 9 because the data has been loaded for you.
1. In the Application Manager tab, drag the file, LOAD.qts from the left pane onto the 

Application object in the right pane.
2. Click Migrate.
3. Click Close.
4. Close the Migration Profile window.

Specifying the Database Open Name for ODBC Connections
Now that the source code is moved, let’s check the database open name before attempting to build 
and execute the application. The database open name must be specified correctly. If you are using 
ODBC for your database connection, the open name must match the ODBC data source name.
A Guided Tour of Axiant 4GL  17
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1. In the left pane of the Object Explorer, click the Timesheet relational database object to put it 
in focus.

2. Double-click Timesheet and click the Definition tab.
3. In the Open Name property, specify the correct open name.

If you are not using ODBC for your database connection and require more information to 
specify the open name, click F1 in the Open Name property. 

4. Close the Timesheet relational database object and return to the Object Explorer window.

Build and Execute a Menu Screen
Now let's build and execute the timesheet application’s menu screen.
1. Click the Application object in the left pane of the Object Explorer window.

2. Click TRSINITK in the right pane to put it in focus.
3. From the Tools Menu, click Build. 
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4. In the message box asking if you want to create a default Build Profile, click OK.
5. In the message box asking if you want to create a Build location, click OK.
6. On the Build Complete dialog box, click No.
7. Click TRSINITK to make sure that it is in focus, then from the Tools menu, click Execute.
8. If you see a dialog box asking if you want to create a default Run profile, click OK.

The main menu of the timesheet application appears. You might have to scroll down to see 
the Initials and Password boxes.

As you can see, the PASSWORD label intrudes into its entry field. Don’t worry about this for 
now; you’ll fix it when you customize this screen in Chapter 3, "Customizing Screen 
Programs."

9. From the File menu, click Return to Previous Screen.
The main menu closes, and the Object Explorer window reappears.

Am I Done Yet? 
Normally, you would have to complete a number of tasks to move your data from indexed files 
into a relational database. You have to use Axiant 4GL to generate the SQL required to build the 
database, then open the database client and use the generated SQL to create the database. Once 
that was done, you would move the data in your indexed files into portable subfiles, and then 
create a QTP run to load the data from the portable subfiles into your database.

To facilitate doing the tours, some of these tasks have been completed already. If you are using 
Sybase SQL Anywhere 9, we created a database called Timesheet.db. So, all you need to do before 
building a data screen is review and modify your data definitions. If you are using Oracle, DB2, 
Sybase ASE, or Microsoft SQL Server, you must create the tables using the Timesheet.sql file, 
which is provided (p. 59), and load the data (p. 22) from the portable subfiles, which are also 
provided (p. 60).
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Review Your Data Definitions
When you move data, it’s a good idea to review the data definitions that have been imported, and 
change them if necessary to ensure they apply to the new environment. We’ve already moved the 
data for you, so all you have to do is change the data definitions.

Change Data Definitions
You could change your data definitions by opening each object and making the changes one at a 
time. However, Axiant 4GL's Find and Change capabilities allow you to make mass changes.

Find Elements

To find all the elements that meet certain conditions:
1. From the Edit menu, click Find Object.

The Find tab appears.

2. Under Find Objects of Type, select Element: Date.
3. Under Find Element: Date Objects Where, click the Insert Grid Object button.

4. Under Object, click Date Element.

5. Under Property, select PH Data Type.
6. Under Operator, select <>.
7. Under Value, select Date.

The Find Element: Date Objects Where box should now look like this:

8. Click Find.
The Elements that match the compound condition you have defined are displayed in the 
Results Set box.
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Change Date Element Values

You can now change the datatype from Phdate to Date in the date elements you have found.
1. On the Find tab, click Change.

The Change dialog box appears.

2. In the Property box, click PH Data Type.
3. In the Value field, click Date.
4. Click Apply.

The new values are displayed in the Results box. Note that the list of values in the Old Value 
column may differ slightly depending on the database you are using.

Change Date Element Size

To specify that dates are to occupy eight characters:
1. In the Property field, click Size.
2. In the Value field, type 8.
3. Click Apply.

The new values are displayed in the Results box.

Change Date Element Format

To change the display format for dates:
1. In the Property field, click Display Format. 
2. In the Value field, click YYYYMMDD.
3. Click Apply.
4. Click Close.

The Find Object dialog box reappears.
5. Click Close to return to the Object Explorer Window.
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Load the Data (Oracle, DB2, Sybase ASE, Microsoft SQL 
Server only)

If you are using an Oracle, DB2, Sybase ASE or Microsoft SQL Server database, you must load 
data from the portable subfiles (p. 60) into your database using a QTP run file. After you have 
completed loading the data, you can create and execute a data screen.

Note: The procedures in this section apply only to Oracle, DB2, Sybase and Microsoft SQL Server. 
If you are using Sybase SQL Anywhere, you can go directly to "Create and Execute a Data 
Screen" (p. 22)
1. In the right pane of the Object Explorer Window, click the QTP Run named LOAD to put it 

in focus.
2. From the Tools menu, click Build.

Note:  If you did not install Axiant 4GL in the default location, you will encounter Build 
errors. Here’s what you must do. In the right-hand pane of the Object Explorer window, 
double-click LOAD and select the Syntax tab. Modify the path to your install location, then 
close the LOAD object, and resume from Step 1.

3. Click OK.
4. From the Tools menu, click Execute.

The Run window appears showing that the data has been loaded.

Create and Execute a Data Screen
Now that you've changed the data definitions, let's build a screen to access the data.
1. Click the Application to put it in focus.
2. From the Insert Menu, click Screen Program, then click Data Screen.
3. Under the Tables box, double-click PROJECTS.
4. Click Next.
5. From the Contents box, double-click PROJECT, BEGIN_DATE, and FINAL_DATE.

The selected fields are listed in the Screen Contents box.
6. Click Finish.

The screen object Screen1 appears in the right pane of the window.
7. Click Screen1 to put it in focus.
8. From the Tools menu, click Build.

The Build Complete dialog box appears. There should be no errors or warnings.
9. Click OK.
10. From the Tools menu, click Execute.

The Screen1 data screen appears.

11. From the File menu, click Find.
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The cursor appears in the Project Code field.
12. Press the Enter key.

Data appears in Screen1.

13. From the File menu, click Return to Previous Screen.
14. From the File menu, click Commit.

What Do I Do Now?
This is the end of the Fast Tour. You've successfully migrated a PowerHouse application to 
Axiant 4GL.

Next, you can read Chapter 2, "What Happened in the Fast Tour?". It examines your sample 
application and describes what Axiant 4GL did during the migration.

Or, you can skip Chapter 2 and go to Chapter 3, "Customizing Screen Programs," where you'll 
continue the tutorial by customizing one of the Screens you imported in the Fast Tour.
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Chapter 2: What Happened in the Fast Tour?

Overview
In Chapter 1, you migrated an application from PowerHouse to Axiant 4GL. You accomplished 
this using the Migration Profile and various Axiant 4GL objects and tools. But what took place 
behind the scenes? Let’s examine the Fast Tour.

Creating a Workspace and Repository
After you started Axiant 4GL, your first step was to create a Workspace and a Repository.

Take a Look
To look at the dialog boxes you used to create a Workspace and Repository:
1. From the File menu, click New. 

Note: If you’re prompted to save changes and then commit, click Yes for both, making sure 
that you save the Repository and Workspace in an appropriate location (for example, 
C:\MyDocuments\TSRepository).

In the Fast Tour, you created a Repository named TSRepository. Notice that Axiant 4GL 
automatically created a folder for the Repository (TSRepository\TSRepository).
In the New Repository dialog box:
• For information about a button, click the What’s This tool then position the cursor over 

the button and click again.
• Click the New Repository button to create a new Repository.
• If you want every new Workspace to automatically connect to the selected Repository, 

click the Always connect new Workspace to this Repository check box.
2. Click New Repository.
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In the New Repository dialog box, you can:
• Type a name for your new Repository in the Repository Name box.
• Enter the Repository location in the Location box.
• For information about a button, click the What’s This tool then position the cursor over 

the button and click again.
• Click the None option to create an empty Repository.
• Click the Custom option to create a Repository containing copies of objects from a 

Repository that you select.
• Click the Default option to create a Repository containing a default set of objects.

3. Since you’re just looking right now, click Cancel.
The New Workspace dialog box reappears.

4. Make sure that TSRepository is in focus, then click Connect.
The Object Explorer window appears.

What Do I Do Now?
For more information about Workspaces, Repositories, and objects, read the following Questions 
and Answers section.

Don’t need this information? Jump to the section called "Creating a Migration Profile".

Questions and Answers: Workspaces and Repositories

What Are Workspaces and Repositories?

A Workspace is a local work file that typically resides on your PC because it's personal. Your 
work remains separate and private until you decide to commit it to a Repository.

A Repository is a hierarchy of directories and files, which typically resides on a LAN. The 
Repository allows you to share your work with other developers. It also allows you to access and 
copy other developers' work.

What Objects are in a New Workspace?

The objects that were in your Workspace when you first opened it came from the Standard 
Repository that is supplied with Axiant 4GL. By default, every new Repository that you create is 
pre-populated with these objects.
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Tell Me About the Objects from the Standard Repository

Each of the objects from the Standard Repository has a role in migrating an application. The 
objects are:

You deleted Relational Database and File Collection because you were planning to migrate the 
Timesheet PDL.

What's in These Objects?

All of the objects created in a pre-populated Repository can contain other objects. When the 
Repository was created, however, only two of the Libraries contained other objects.

The Usage Library contains Elements that correspond to Usages in PDL. To see these Elements, 
click Usage Library in the left pane of the Object Explorer window. The objects it contains are 
displayed in the right pane.

Object Description

TSRepository This is the Repository you created.

Application An Application object is a container for 
Programs—a place to put your 
Programs when you migrate or create 
them.

Default Section 
Library

A Library object is a container for other 
objects. This Library contains objects 
used by Axiant 4GL Forms (the former 
QUICK screens).

Element Library This Library is meant to contain 
Elements. Elements are low-level data 
objects (for example, Customer 
Number). By default, any Elements that 
you import or migrate will be placed in 
this Library.

 
Structure Library This Library is meant to contain 

Structures. A Structure is typically a 
group of Elements (for example, an 
address).

Usage Library This Library contains Elements that 
correspond to Usages in PDL.

Relational 
Database

A Relational Database contains related 
Tables.

File Collection A File Collection contains a list of 
indexed Files.
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The Default Section Library contains components, such as default menus and toolbars, that are 
used to convert terminal screens into GUI screens when they are migrated or imported.

Need More Information
See these topics from the Index tab of the online Help:
• Repository
• Workspace
• objects

Creating a Migration Profile
In the Fast Tour, you used the Migration Profile Wizard to create a Migration Profile.

A Migration Profile guides the migration of a PowerHouse application to Axiant 4GL. It describes 
what data definitions and program source code will be migrated from PowerHouse and how they 
must be modified to work in Axiant 4GL.

Take a Look
To look more closely at the pages of the Migration Profile Wizard:
1. From the Insert Menu, click Migration Profile.
2. The Data Definitions page of the Migration Profile Wizard appears.
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In the Fast Tour, you specified the PDL file (Timesheet.pdl) that contained the data definitions 
you planned to migrate. On this page, you may also specify one or more SQL files related to 
your PowerHouse application.

3. Click Next.
The Program Source page appears.

On this page you specified the QUICK, QUIZ, and QTP directories that contain your 
PowerHouse source programs.
Alternatively, you can specify a root directory and click the Include Subfolders check box to 
include any subdirectories that contain your programs.

4. Click Next.
The Conditional Compile page appears.
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You didn’t need to use this page in the Fast Tour. Use this page only when your imported 
source code contains conditional compile statements that you want processed.
You can select the machine type and the user-defined conditional compile flags you want 
activated when importing QUICK screens into Axiant 4GL. Axiant 4GL must know what 
code to use to create a consistent look for your screens. Conditional compile code is migrated 
as is from QUIZ reports, QTP runs, and QUICK screen procedures.
If you select a CC parameter that is related to Form design, the code associated with that 
parameter is processed during import. Any unselected CC code related to Form design is 
discarded. If you select more than one alternative CC parameter, this will be flagged as a 
migration issue before you actually import the Program. If you select none of the alternative 
CC parameters, any Else code will be processed on import.

5. Click Next.
The MPE/iX page appears.

In the Fast Tour, you chose not to use MPE/iX Syntax Rules by accepting the default of No. If 
your imported source is primarily MPE/iX, this is where you respond Yes to indicate that you 
want Axiant 4GL to make modifications, such as trimming spaces and line numbers, to 
improve your MPE/iX import.

6. Click Next.
The Finish page appears.
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When you complete the wizard, Axiant 4GL creates a new object in your Workspace—the 
Migration Profile.

7. Because you don't need another Migration Profile object, click Cancel.
You return to the Object Explorer window.

Need More Information
See these topics from the Index tab of the online Help:
• Migration Profile Wizard
• Migration Profile, creating

Migrating Your Data Definitions and Application Files
In the Fast Tour, you used some of the features of the Migration Profile Wizard to create a 
Migration Profile. You then opened the Migration Profile to make changes to your data 
definitions and application files. Let's look at the Migration Profile in more detail.

Take a Look
1. Double-click the Migration Profile object to open it.

The Migration Profile window opens.

2. Click the Directory Manager tab.
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In the Directory Manager tab, use the Browse button:
• Beside the SQL Definitions box to add SQL definitions.
• Beside the PDL Definitions box to change the source of your PDL definitions.
• Beside the PowerHouse program directories box to add or delete directories of source 

files.
• Beside the Root Application Directory to specify a root directory for your source files. To 

include any subdirectories in the root directory, select the Include Subfolders check box. 
The subdirectories appear in the PowerHouse Application Directory box.

This tab shows the directories that contain your data definitions and program source files. In 
the Fast Tour, you identified these directories when you used the Migration Profile Wizard. If 
you wanted, you could identify more directories on this tab.

3. Click the Data Manager tab.

In the Data Manager tab, you can:
• Convert your database using the Convert Selected Databases to drop-down box.
• Click the Advice button to identify and correct any data definition problems.
In the Fast Tour, you used this tab to migrate your PowerHouse tables into Axiant 4GL. You 
also converted your File Collection to a relational database. Then, you used the Migration 
Advisor to identify data definition errors or issues. You edited your data definitions (changed 
dashes and hyphens to underscores).

4. Click the Application Manager tab.
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On this tab, you select the source files to migrate.
In the Fast Tour, you dragged the TRSINITK file onto the Application object to create 
ProgramSet_TRSINITK_QKS under the Application object. When you dragged the 
TRSINITK file, it and the entire hierarchy of files that were called by it were automatically 
moved over.
If you were using Oracle, DB2, Sybase SQL or Microsoft SQL server to do the Fast Tour, you 
did the additional step of migrating the LOAD.qts, a QTP run file, by dragging it from the 
PowerHouse Environment box to the Application object in the Axiant 4GL Environment.
The Axiant 4GL Environment box acts like the Windows Explorer—you can open or close 
container objects to view their contents.

5. Click on some of the objects in the Axiant 4GL Environment box to expand the display. For 
example:

6. Click the Change Manager tab.
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Here you can edit the names and locations of your data definitions. On the Change Manager 
tab, Axiant 4GL does not give advice as to what changes might be appropriate. If you want 
Axiant 4GL to identify changes that should be made, use the Migration Advisor dialog box, 
which you can access by clicking Advice on the Data Manager tab or the Application 
Manager tab.
In the Fast Tour, you used the Migration Advisor on the Data Manager tab. You then changed 
the dashes and hyphens in your filenames to underscores.

7. Close the Migration Profile window.

Tell Me More About the Data Manager Tab

On the Data Manager tab of the Migration Profile, you:
• Converted your file collection to a relational database.
• Identified the data definitions to be migrated.
• Used the Migration Advisor to edit your data definitions.
• Migrated your data definitions.

The Data Manager tab has two distinct panes, PowerHouse Environment and Axiant 4GL 
Environment.
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PowerHouse Environment

In the PowerHouse Environment, the Data Source box lists the data source files that you specified 
initially in the Migration Profile Wizard or later in the Directory Manager tab. The Tables box 
lists the tables contained in the data source file selected in the Data Source box.

If Unused Tables is selected, the tables appearing in the Tables box are filtered so that only tables 
not yet selected for migration appear. This is the default. If All Tables is selected then all tables will 
appear in the Tables box.

Axiant 4GL Environment

The following is a list of the controls you find in the Axiant 4GL Environment with a description 
of the functions they perform:
• The Convert Selected Databases to box allows you to select the type of database into which 

you want to import the tables grouped beneath the currently selected database in the 
Databases box.

• The Generate: primary keys option is available only for Relational Databases. It generates a 
Primary Key for any PDL or SQL table being imported with a unique or inferred primary 
index. 

• The Generate: foreign keys option is available only for Relational Databases. ALTER TABLE 
and FOREIGN KEY statements added to interim SQL for any PDL or SQL table index being 
imported that has all its segments matching all segments in a primary index for another table, 
results in the tables being linked.

• The Databases box shows how you’ve grouped tables into databases for import into 
Axiant 4GL.

• The Contents box lists the tables in the database currently selected in the Databases box.
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• Click the Advice button to open the Migration Advisor dialog box where you can learn about 
the issues related to your migration.

• Click the Migrate button to begin migrating your definitions.
• Click the Options button to open the Migration Profile Options dialog box. You can specify 

the Libraries where you want to import your data definitions and the application that you 
want associated with a particular database.

Tell Me More About the Application Manager Tab

On the Application Manager tab of the Migration Profile, you migrated your Timesheet 
application by putting the Application in focus and then double-clicking files in the PowerHouse 
Environment box. Each time you double-clicked a file, a new Program Set was created in the 
Axiant 4GL Environment box.

Like the Data Manager tab, the Application Manager tab has two distinct panes, PowerHouse 
Environment and Axiant 4GL Environment.

PowerHouse Environment

In the PowerHouse Environment, the Refresh button updates the files displayed in the Files list 
box.

All files appearing in the Pattern list box match the pattern (*.*). You can specify a pattern to 
display only certain files. The files in the specified source directories are displayed below the 
Pattern box.
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If Unused Files is selected, only those files in the specified source directories not yet selected for 
import are displayed.

Axiant 4GL Environment

The Axiant 4GL Environment box shows how you’ve grouped programs into program sets and 
program sets into applications for import into Axiant 4GL. You can use the:
• Programs or Tables option to display the Programs or Tables referenced by the object 

currently selected in the Applications box. The numbers in parentheses indicate the total 
number of programs and tables.

• Advice button to open the Migration Advisor dialog box where you can learn about the issues 
related to your migration.

• Migrate button to begin migrating whatever you’ve selected in the Applications box.
• Options button to open the Migration Profile Options dialog box. You can specify the 

Libraries where you want to import your data definitions and the application that you want 
associated with a particular database.

How Can I Tell What's In My Program Set?

One way is to open up all the container objects in the Axiant 4GL Environment box. 
Alternatively, you can right-click an object in a Program Set, then click Save Report. The 
following information dialog box appears.

To get a full report, click Yes. To get a partial report, click No. You can view the report with a 
spreadsheet or word processor. Click Cancel for now.

How Can I Find Out More About My Source Files?

Once you click the Migrate button, the Migration Status dialog box appears. You can view the 
syntax of any source file listed by double-clicking the filename.
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When you do, a Browse window appears, like this Screen Program example.

You can view the syntax here, which can be handy if the Migration Status dialog lists error or 
warning messages. You can't make changes here, but if you double-click an error message in the 
lower pane of the screen, the line of syntax that caused the error will be in focus in the upper pane.

Questions and Answers About the Migration

What Was Migrated?

You migrated data definitions and data from the existing Great Outdoors Company PowerHouse 
application. The normalized data structures and data files are supplied with Axiant 4GL. They are 
located in
\\Axiant 4GL <version>\Examples\GuidedTour\<database>\Data

You also migrated QUICK programs. They too are supplied with Axiant 4GL and are located in
\\Axiant 4GL <version>\Examples\GuidedTour\<database>\Source

After Migration is Complete, What Objects Do I Have?

During migration, your Workspace was populated with Axiant 4GL objects. These include an 
empty Application object, Libraries of data definitions, and the newly created Relational 
Database, Timesheet.
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After you migrated your PowerHouse application, including the source files, your Workspace 
contained these objects:

* You got these objects when you migrated your data definitions and application files.

** You got these objects when you created your Repository and you pre-populated from the 
Standard Axiant 4GL Repository. Every Repository you create is, by default, pre-populated with 
the objects from the Standard Repository.

*** You created the Migration Profile and the definitions it contains.

The migration copied and modified source files, and created data-related objects based on an 
existing PowerHouse application. The objects were placed in your Workspace. These objects were 
created: 

Object Object Contents Object Origin

Application Report programs,

Screen programs,

     and
QTP runs

migration*

Default 
Section 
Library

Screen Sections Standard 
Repository**

Element 
Library

Elements migration*

Screen Section 
Library1

Screen Sections, 
Use files (screen 
procedures, QUIZ 
or QTP programs)

migration*

Structure 
Library

Structures migration*

Usage Library Elements Standard 
Repository**

Timesheet Tables migration*

Migration 
Profile1

Migration 
definitions

user-defined***

Elements Lowest-level data objects. These were 
placed inside your Element Library.
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Where Can I See the Elements?

On the Object Explorer window, click the Element Library object. The right pane shows all the 
Elements created during migration. You can also double-click the Element Library object and then 
click the Objects tab. This way you can also view other tabs used to set default formatting settings 
and pattern-matching symbols.

Some Elements may still contain a dash instead of an underscore. This means the Element was in 
the original PDL file but was not referenced by any of the indexed files you migrated.

Where Can I See the Element Definitions?

Double-click an Element name in the right pane of the Object Explorer window or on the Objects 
tab of the Element Library object. 

The various tabs associated with each Element object let you view and set layout options, default 
values, and data storage settings.

Where Can I See the Structures?

On the Object Explorer window, click the Structure Library object. The right pane shows all the 
Structures created during migration. You can also double-click the Structure Library object and 
then click the Objects tab. This way you can also view other tabs used to set default formatting 
settings and pattern-matching symbols.

Where Can I See the Structure Definitions?

Double-click a Structure name in the right pane of the Object Explorer window or on the Objects 
tab of the Structure Library object. Click the Items tab to see what Items are included in the 
Structure.

Where Can I See the Tables?

On the Object Explorer window, click the Timesheet Relational Database object. The right pane 
shows all the Tables created during migration. You can also double-click the Timesheet Relational 
Database object and then click the Objects tab. 

Click the Diagram tab. It gives you a graphic description of how the Tables are linked. Links can 
be removed, added, or modified.

Where Can I See the Table Definitions?

Double-click a Table name in the right pane of the Object Explorer window or the Objects tab of 
the Relational Database object. The Table object has tabs that list Columns in the Table, Keys, 
Indexes, Relationships, and Constraints.

I Need More Information
For information about objects, see this topic from the Index tab of the online Help:
• objects

For information about Migration, see these topics from the Index tab of the online Help:
• Migration Profile tasks
• Migration Profile Wizard
• Migration Profile, creating

Structures Groups of related data objects. These 
were placed inside your Structure 
Library.

Tables Tables. These were placed inside the 
Timesheet relational database.
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Chapter 3: Customizing Screen Programs

Overview
When you migrated the Great Outdoors Company timesheet application from PowerHouse to 
Axiant 4GL during the Fast Tour, a default graphical interface was generated automatically. Now 
you’ll customize a migrated screen to take full advantage of its new graphical environment.

Setting the Scene
The Axiant 4GL Screen Programs that are created when you migrate a PowerHouse application 
save you considerable time and effort.

When you migrate Screens, settings on the Options tab of the Repository object determine some 
aspects of the Screens' appearance in Axiant 4GL. Before migration, you can specify whether 
Screen objects will be positioned on 80 columns or 132, override certain style attributes, and set 
the frame border size and other basic characteristics.

Even so, once you've migrated Screens, you'll want to customize them to take advantage of 
Axiant 4GL's graphical user interface.

What's Involved in Screen Customization?
Before customizing Axiant 4GL Screens, you'll want to design a consistent look for them. As 
much as possible, it's a good idea to follow Windows standards, so your Axiant 4GL programs 
will be consistent with other Windows applications.

When you're ready to start customizing Screens, you can do it in two ways: by using Axiant 4GL’s 
inheritance feature, and by modifying individual Screen Programs directly.

Customizing Through Inheritance

Axiant 4GL’s Object Explorer window contains a Default Section Library that comes with the 
Standard Repository. It also contains any additional Screen Section Libraries that are created 
during migration or inserted manually.

Screen Section Libraries contain different types of Sections (such as Data Access Sections, Style 
Sections, and Form Sections) from which properties can be inherited by one or more Screen 
Programs.

Inheritance makes it easy to assign common properties to all of the Screen Programs in an 
Application. And it means you can redesign entire Applications by modifying only the Library 
Sections they inherit from.

In this chapter, you’ll modify properties in the Default Screen Sections that your migrated Screens 
inherit from.
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Customizing Individual Screen Programs

You can also customize individual Screen Programs directly by changing their properties and 
syntax and by adding objects to them. You do this using the tabs that are displayed when you 
open a Screen Program.

The modifications you can make range from something as simple as changing a program's name 
to something as sophisticated as defining designer procedures for a Screen.

In this chapter, you'll use some of the Screen Program's tabs to modify the Screen you're 
customizing.

Before You Customize
Before you can start customizing a Screen, Axiant 4GL must be running, and you must be 
connected to TSRepository.

If You Completed the Fast Tour
If you created a TSRepository in the Fast Tour, then you might still be connected to it. If not, 
connect to it now.
1. If you’ve exited Axiant 4GL, start Axiant 4GL.
2. In the Wecome dialog box, click the New button to create a new workspace.

The New Workspace dialog box appears.

3. Find and double-click the file TSRepository that you created during the Fast Tour.
Note: If you saved it in the location we suggested, then it's in \My Documents\TSRepository.
Your Object Explorer window should look like this:
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What Needs to be Done?
You will customize TRSINITK, the first screen that is displayed when you start the timesheet 
application that you migrated in the Fast Tour.

The Screen Before
Here's how the menu looked in Axiant 4GL after you migrated it:

The screen has a graphical interface, but you can make many enhancements to improve its 
appearance and functionality.

The Screen After
You will customize the Screen by changing properties in the Default Section Library that the 
Screen inherits from, and by making changes directly to the Screen Program.

When you've finished, the Screen will look like this:
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Customizing Screens Using Inheritance
All the Screens in the Time Reporting System inherit Menus, Toolbars, Events, Commands, and 
Styles from the Default Section Library. You can see this on the Default Section tab of the 
Application object.

You want some Style changes to apply to all of the Application's screens, not just the screen that 
you're customizing now. So, you'll begin by changing these inherited properties in the Default 
Style Section:
• the background color
• the text font
• the properties of objects you'll insert in Screen Programs

Change the Background Color
1. In the left pane of the Object Explorer window, click the Default Section Library to put it in 

focus.
The Library’s default sections are displayed in the right pane.

2. In the right pane, double-click Default Style Section.
The Style - Default Style Section window appears.
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3. In the left pane, click Default Form Style.

Form Style properties appear in the right pane.

Notice that the Background Color property is gray.
4. Click the Background Color property, then click the ellipsis button (...) at the right of the 

property field.
The Color dialog box appears.

5. Click the pale yellow color second from the left in the first row, then click OK.
The color sample at the right of the property field shows the new color.
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As you'll see later, when you customize the menu Screen directly, this color has been assigned 
as the background of all the Time Reporting System Screen Programs.

Change the Font Size
1. In the left pane, click Default Label Style.

Label style properties appear in the right pane.

2. Click the Font property, then click the ellipsis button (...) at the right of the property field.
The Font dialog box appears.

3. Change the Font Size settings to 10, then click OK.

Add a 3D Effect to the Rectangle Object
When you add a rectangle to your Screen later, you want it to have a three-dimensional look. 
You'll define that look by changing the Default Shape Style in the Default Section Library.
1. In the left pane, click Default Shape Style.
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Shape properties appear in the right pane.

2. Change the 3D Look property to True.
3. Close the Style - Default Style Section window.
4. From the File menu, click Commit to store your work in the Repository.

Check the Results
Let's check the results of the inheritance changes.
1. In the left pane of the Object Explorer window, click the Application object.
2. In the right pane, double-click TRSINITK.

The Screen Program object opens.
3. Click the Form tab.

The Screen's form appears in the left pane. Its properties are displayed on General, Styles, and 
Events tabs in the right pane.

Notice that the form’s background color is now yellow, its text is 10-point Arial, and the 
rectangle around the heading is three-dimensional. You defined these properties with settings 
in the Default Style Section. You could also have achieved these results by:
• Defining another Style Section in a Section Library and having the Screen inherit from it.
• Modifying the properties directly on the Screen's Style tab.
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Customizing an Individual Screen
You've made changes that have been inherited by your Screen Programs, including the screen you 
are customizing. Now you'll modify the Screen Program directly, in order to:
• Delete the company name and the rectangle surrounding it.
• Resize the Screen Form.
• Insert an image of The Great Outdoors company name.
• Insert a rectangle around the Initials and Password fields.
• Set the Action property to Entry.
• Align the Screen's objects and perform other finishing touches.

Delete the Company Name
You'll replace the text string, THE GREAT OUTDOORS COMPANY, and the rectangle around 
it, with an imported image. As a first step, you'll delete the text and the rectangle.

A vertical splitter separates the two panes of the Form tab. You can drag it left or right to increase 
the size of the pane you want to view.
1. Drag the vertical splitter between the two panes of the Screen Program's Form tab to the right 

until you can see all of the Screen Form's objects.

2. Click anywhere within the rectangle surrounding the company name and Screen title.
An outline with eight black squares appears around the rectangle, indicating it is selected.

3. Press the Delete key.
The rectangle is deleted.

4. Click the text string THE GREAT OUTDOORS COMPANY to select it, then press the Delete 
key.
The text string is deleted, and your Screen should now look similar to this:
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Resize the Screen Form

PowerHouse screens are designed for a 24-line by 80-character terminal environment, where 
including a lot of information in a single screen reduces the need for users to move from screen to 
screen. In a graphical environment like Axiant 4GL, users typically open several overlapping 
windows at a time, and Screens tend to be more compact and numerous.

To reduce the Screen's size, you will move the entry fields and their labels closer to the Screen title, 
then change the form's height and width.

Move the Fields and Labels Closer to the Heading

You'll begin by moving the Form's fields closer together.
1. Place the cursor above and to the left of the word INITIALS.
2. Press and hold the left mouse button, then drag to a point below and to the right of the 

PASSWORD field, creating a selection box that surrounds the fields and their labels.

3. Release the mouse button.
The entry fields and labels are selected.

Note: You can also select several objects by Shift-Clicking them one at a time.
4. Place the cursor over any of the selected objects.
5. Press and hold the left mouse button, then drag the objects closer to the text string ID 

SCREEN.
6. Release the mouse button.

The Screen's objects are now closer together.
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Change the Form's Width and Height

Now you can make the Form smaller.
1. Click the Screen background to deselect any selected objects.
2. On the General tab in the right pane of the Screen Program's Form tab, change the Initial 

Width and Width properties to 400.
3. Change the Initial Height and Height properties to 250, then press the Enter key.

Your Screen Program should look something like this:

 
When you change the form’s Height and Width settings, the Form’s bottom and right borders 
become visible. You can also drag the borders to change their locations.

Insert an Image 
You'll replace the deleted company name with a bitmap image.
1. Click the Screen background to deselect any selected objects.
2. From the Insert menu, click Imported Image.

The Bitmap File Browse dialog box appears.

3. Find and double-click the file Program Files\Cognos\Axiant 4GL 
<version>\Examples\Bitmaps\greatout.bmp.
The Great Outdoors image appears in the Screen.

4. Drag the graphic to the upper left of the Screen Program form.
The Screen Program should now look something like this:
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Insert a Rectangle

You'll insert a rectangle around the two entry fields and their titles.
1. Click the Screen background to deselect any selected objects.
2. From the Insert menu, click Shape, then Rectangle.
3. Place the cursor above and to the left of the word INITIALS, press and hold the left mouse 

button, drag to create a rectangle around the two fields and their labels, then release the 
mouse button.
Your Screen Program should now look something like this:

You’ll work with the fields within the rectangle later, so you need to move the rectangle to the 
back and out of the way.

4. Ensure that the rectangle is selected.
5. From the Format menu, click Move to Back.
6. Close the Screen - TRSINITK window.
7. From the File menu, click Commit.

Try Out the Screen
Let’s build, execute, and use the screen.

Build and Execute the Screen
1. In the right pane of the Object Explorer window, click TRSINITK to put it in focus.
2. From the Tools menu, click Build.
3. In response to any messages asking if you want to use an existing build profile or build 

location, click OK.
4. On the Build Complete dialog box, click No.
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5. From the Tools menu, click Execute.
6. If you see a dialog box asking if you want to create a default Run profile, click OK.

The screen that we’ve customized appears.

Use the Screen

To use this screen, employees will enter their initials and password to access the next screen in the 
Time Reporting System. Let’s see how the screen works from a user’s perspective.
1. Click the Initials field.

The cursor does not appear in the field, because we haven’t yet activated Entry mode.
2. From the File menu, select Entry.

The cursor appears in the Initials field.
3. In the Initials field type BF, then press the TAB key to move to the Password field.
4. In the Password field, type BF again, then press the Enter key.

We haven’t built the other screens in the Time Reporting System, so error messages appear.
5. In response to each error message, click OK.
6. From the File menu, select Return to Previous Screen.

We’ve seen that the Screen Program works—or will once you’ve built the other screens in the Time 
Reporting System. You can still make the screen more appealing and easier to use, though. To do 
that, you will:
• Add an Event so that Entry mode is activated automatically when users start the screen.
• Make additional enhancements to the screen’s appearance.

Add an Event to the Initials Field
When you used the ID Screen, you began by setting the Action property to Entry. To eliminate the 
need for this when a user starts the screen, you will add an Event to the Initials field. An Event is a 
command or series of commands performed in a Screen when a user accesses the screen, clicks a 
mouse button, or presses a key such as Enter or Tab.

To add an Event:
1. In the right pane of the Object Explorer, double click TRSINITK.

The Screen - TRSINITK window appears.
2. Click the Initials field to put it in focus.

3. Click the Events tab.
Event properties are displayed.
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4. In the Events tab, under Left Click, click the Action Context property, then click the ellipsis 

button (...) at the right of the property field .
The Action Context dialog box appears.

5. In the Command box, click Entry, then click OK.
6. Close the Screen - TRSINITK window.

Entry mode will now be activated automatically when users start the screen.

I Need More Information
See this topic from the Index tab of the online Help:
• Events Overview

Test the Event
Let’s test the Event we’ve defined.
1. In the right pane of the Object Explorer, click TRSINITK to put it in focus.
2. From the Tools menu, select Build.
3. In the Build Results dialog box, click No.
4. From the Tools menu, select Execute.

The Screen appears.
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Now that you’ve added an Event to the screen, you can click directly in the Initials field 
without having to activate Entry mode first.

5. Click the Initials field.
This time the cursor appears in the field. We didn’t need to select Entry from the File menu 
because the Event we defined activated Entry mode automatically.

6. Type BF, then press the TAB key to move to the Password field.
7. In the Password field, type BF, then press the Enter key.

Again, since we haven’t built the other screens in the Time Reporting System, error messages 
appear.

8. In response to each error message, click OK.
9. From the File menu, select Return to Previous Screen.

Perform Finishing Touches
To complete your screen customization, you need to reorganize objects on the Screen—to move, 
align, and resize them so they're placed more appropriately—and to perform other finishing 
touches.

Note: If you make a mistake, select Undo from the Edit menu and try again.

Move Objects

First, move all the other objects under the imported image.
1. Double-click TRSINITK.

The Screen Program window appears.
2. Click the Form tab.
3. Move the splitter so you can see all of the Screen Program’s form.
4. Select all of the objects except the image that you inserted.
5. Drag the selected objects under the image, centering them roughly by hand.

Your Screen should now look something like this:
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Align the Image and Headings

You need to align the image and headings.
1. Click the Screen background to deselect any selected objects.
2. Select the text string ID SCREEN and drag it closer to the text string, TIME REPORTING 

SYSTEM.
3. Select the image and the two heading text strings.
4. From the Format menu, click Align, then Center.

The three objects are centered.

Resize the Rectangle

You’ll also adjust the size and alignment of the rectangle.
1. Click the Screen background to deselect any selected objects.
2. Click the rectangle to select it.

Black boxes appear around the rectangle.

3. Drag whatever black boxes are necessary to make the rectangle roughly the same size as the 
imported image.

4. From the Format menu, with the rectangle still selected, click Move to Back.

Change Font Styles

You’ll override the default font settings for the two heading labels.
1. Click the text string, TIME REPORTING SYSTEM, to select it.
2. In the right pane of the Form tab, click the Styles tab.

Style properties appear for the text string.
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3. In the Styles tab, click the Font property, then click the ellipsis button (...) at the right of the 

property field.
The Font dialog box appears.

4. Change the Font style to Bold Italic, then click OK.
The text style changes on the Screen Form.

5. Repeat steps 1 through 4 to change the Font style of the text string ID SCREEN.

Change Labels

The two field labels – INITIALS and PASSWORD – contain all capital letters and are followed by 
a colon. You’ll change them to initial capitals without a colon.
1. Click the INITIALS label on the Screen Form to select it.
2. In the right pane of the Form tab, click the General tab.
3. In the General tab, click the Text property.

The word is highlighted.

4. Type Initials, with an initial capital only and no colon at the end, then press the Enter key.
The text string changes in both the property field and on the Screen Form.

5. Repeat steps 1 through 3 with the PASSWORD label.
6. From the File menu, click Commit.
56  Axiant (R)  4GL   Version 3.4E



Chapter 3: Customizing Screen Programs
 

Anything Else?

Use what you've already learned to perform whatever other finishing touches are needed to make 
the Screen Form look very similar to this:

You’ll want to resize the form by dragging its borders, and maybe touch up the alignment of the 
Screen Form’s objects. Experiment as much as you want until you're satisfied with the result. 
When you've made your changes, be sure to commit them by selecting Commit from the File 
menu.

Suggestions for Further Exploration
That's all the customization you'll perform on the Time Reporting System’s menu. If you're 
interested in continuing to explore Screen customization on your own, here are some suggestions.

Suggestion Detail

Explore the Insert 
Menu

On the Form tab of the Screen Program, you 
used Axiant 4GL's Insert menu to add an 
imported image and a rectangle to a Screen 
Program. The menu has other objects you can 
add, including Push Buttons, Labels, Combo 
Boxes, and more. Click to select any item in the 
Insert menu, then click where you want to place 
the item and drag to size. When you've finished 
experimenting, you can delete the objects.

Customize another 
Screen

You might want to practice customizing other 
Screens before creating your own Axiant 4GL 
application. Open one of the other Screen 
Programs migrated during the Fast Tour and 
experiment with it.

Explore the Screen 
Program tabs

To customize the Time Reporting System’s 
Menu Screen, you used some of the Screen 
Program's tabs. You might want to explore the 
other tabs to find out how they work. To learn 
about a tab, right-click a Screen Program, click 
What's This?, then click the tab in the Contains 
section.
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Tips for Customizing Screens

You can customize Axiant 4GL Screen Programs in an almost limitless number of ways. There are 
some changes, however, that users typically want to make to Screens after migrating them. This 
table lists the most common ones.

What Now?
That’s it for the Guided Tour. You've learned how to migrate a PowerHouse application to 
Axiant 4GL and how to customize a Screen Program.

To explore further or to get more information, check the online Help—the most comprehensive 
source of information about Axiant 4GL. In Axiant 4GL, click the Help menu and then click Help 
Topics. You can explore at random, or search for specific topics in the Index tab. To learn how to 
find information in the online Help, see the section, "How Can I Access Online Help?", in the 
front of this book.

Explore the Default 
Section Library

When you customized the Time Reporting 
System’s Menu Screen, you changed Style 
settings in the Default Section Library so your 
screens would inherit a different Background 
Color and other properties. You didn't use the 
other Default Sections, including Data Access, 
Command, Menu, and Form Sections. You 
might want to check those out now.

Suggestion Detail

Do this ... In order to ...

Resize Forms Adapt to a graphical environment. QUICK 
Screens are designed for a terminal 
environment, where it's an advantage to have 
lots of information in a Screen. Smaller screens 
with less information are more effective in 
Axiant 4GL.

Convert Entry fields 
to Drop-Down List 
Boxes or similar 
objects

Simplify the use of Axiant 4GL Screens and 
make better use of available space.

Set up Menus Provide users with access to a variety of 
commands, including those that are standard 
for Windows applications.

Add Delete 
commands in 
Multi-Record Screens

Delete individual entries. Place a delete button 
beside every detail entry in a multi-record 
Screen.

Set up Panels Move processing from the typical free-form 
Windows mode to block mode, where data is 
not updated until an entire panel of entries is 
processed.
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The tours in this book use the Timesheet.db with the Sybase SQL Anywhere 9 database. If you 
want, you can complete the tours using a different database. You are provided with files (p. 60), 
to help you complete the tour using these alternate databases. Here is a list of the databases that 
you can use:
• DB2
• Oracle
• Microsoft SQL Server
• Sybase ASE
• Sybase SQL Anywhere

If you are using the Sybase SQL Anywhere 9 database, you must attach to the database using 
ODBC. For more information, see the section, "Database Setup for Timesheet.db" (p. 59).

If you are not using Sybase SQL Anywhere 9 as your database, you must create database tables 
before you start the tours. For more information, see the section, "Database Setup for 
Timesheet.db" (p. 59).

Example_4gl.db and Example_4gl.sql
Besides the tours in this book, you can also import and use the example_4gl.db and 
example_4gl.sql included with the product to learn about Axaint 4GL. If you choose to use the 
example database, you must complete the database setup before you begin. For more information, 
see the section, "Database Setup for Example_4gl.db" (p. 60).

Database Setup for Timesheet.db

Using Sybase SQL Anywhere 9
The Axiant 4GL 3.4E install provides the physical database, Timesheet.db, to use with the Sybase 
SQL Anywhere 9 database. As a result, you only need to attach to this database located in 
\Program Files\Cognos\Axiant 4GL 3.4E\Examples\Guided Tour\SqlAny\Data\ using the ODBC 
Administrator tool provided with your SQL Anywhere 9 database client. The user name for the 
database is dba and the password is sql.

Note: A backup copy of the Timesheet.db is located in \Program Files\Cognos\Axiant 4GL 
3.4E\Examples\Guided Tour\SqlAny\Originaldb\

Using Oracle, DB2, Microsoft SQL Server and Sybase ASE
If you are not using Sybase SQL Anywhere 9 as your database, you must create the Timesheet 
database tables with the SQL source provided with the Axiant 4GL install. After you create the 
database tables, you can begin the tour.

Steps to Create the Timesheet Database Tables
1. Connect to the database, for example, Oracle.
2. Browse to the file, Timesheet.sql. 

Assuming you have installed Axiant 4GL in the default location, you’ll find it in \Program 
Files\Cognos\Axiant 4GL 3.4E\Examples\GuidedTour\<database>\Sql\

3. Execute Timesheet.sql. 
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Now you are ready to start the Guided Tour.

Timesheet.PDL
To facilitate the completion of the Guided Tour, you are provided with a database-specific version 
of Timesheet.pdl. Timesheet.pdl provides the data definitions.

In Windows Explorer, you can find Timesheet.pdl in the following locations:

Data Files for the Timesheet
The Guided Tour provides subfiles containing data for the application you migrate. If you are 
using Oracle, DB2, Sybase ASE, and Microsoft SQL server, you must load the data from the 
subfiles, using the QTP run file LOAD.qts., into your application.This step is not required if you 
are Sybase SQL Anywhere 9 because the data has already been loaded for you.

If you installed Axiant 4GL in the default location, you’ll find the data files in \Program 
Files\Axiant 4GL <version>\Examples\GuidedTour\<database>\Data\.

Database Setup for Example_4gl.db
The Axiant 4GL 3.4E install provides the physical database, example_4gl.db, to help you learn 
how to use Axiant 4GL. To use example_4gl.db, you must complete certain setup procedures. 
These procedures vary depending on the database client software you are using. 

For information about the database setup for Sybase SQL Anywhere 9, see the section, "Using 
Sybase SQL Anywhere 9" (p. 60).

For information about database setup for Oracle, DB2, Microsoft SQL Server and Sybase ASE, 
see "Using Oracle, DB2, Microsoft SQL Server and Sybase ASE" (p. 60).

Using Sybase SQL Anywhere 9
If you are using Sybase SQL Anywhere 9, you must attach to the example_4gl database located in 
\Examples\Example_4gl\SQLAny\Data\ using the ODBC Administrator tool provided with your 
SQL Anywhere 9 database client. The user name for the database is dba and the password is sql.

Note: A backup copy of Example_4gl.db is located in \Program Files\Cognos\Axiant 4GL 
3.4E\Examples\Example_4gl\SQLAny\Originaldb

Using Oracle, DB2, Microsoft SQL Server and Sybase ASE
If you are using Oracle, DB2, Microsoft SQL Server or Sybase ASE, you must create the 
example_4gl database tables with the SQL source provided with the Axiant 4GL install. After you 
create the database tables, you can use the database with the product.

Database Location

Sybase SQL Anywhere \Program Files\Cognos\Axiant 4GL <version>\Examples 
\GuidedTour\SqlAny\Data\

Oracle \Program Files\Cognos\Axiant 4GL <version>\Examples 
\GuidedTour\Oracle\Data\

Microsoft SQL Server \Program Files\Cognos\Axiant 4GL <version>\Examples 
\GuidedTour\Mssql\Data\

DB2 \Program Files\Cognos\Axiant 4GL <version>\Examples 
\GuidedTour\Db2\Data\

Sybase ASE \Program Files\Cognos\Axiant 4GL <version>\Examples 
\GuidedTour\Sybase\Data\
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Steps to Create the Example_4gl Database Tables
1. Connect to the database, for example, Oracle.
2. Browse to the file, example_4gl.sql.

Assuming you have installed Axiant 4GL in the default location, you’ll find it in \Program 
Files\Cognos\Axiant 4GL 3.4E\Examples\Example_4GL\<database>\Sql\

3. Execute example_4gl.sql. 
Now you are ready to use the example database with the product.

Example_4gl.sql
You are also provided a database-specific version of example_4gl.sql containing your data 
definitions that you will need to migrate using the Migration Profile, Data Manager tab in Axiant 
4GL. 

In Windows Explorer, you can find example_4gl.sql in the following locations:

For information about importing example_4gl.sql, see the Axiant 4GL online help.

Data Files for Example_4gl
You are provided subfiles containing data for the application you migrate. If you are using Oracle, 
DB2, Sybase ASE, and Microsoft SQL server, you must load the data from the subfiles, using the 
QTP run file LOAD.qts., into your application. This step is not required if you are Sybase SQL 
Anywhere 9 because the data has already been loaded for you.

If you installed Axiant 4GL in the default location, you’ll find 
• the data files in \Program Files\Cognos\Axiant 4GL 

<version>\Examples\Example_4gl\<database>\Data\
• the Qtp source for LOAD.qts in \Program Files\Cognos\Axiant 4GL 

<version>\Examples\Example_4gl\<database>\Source\

For information about migrating the QTP Run program, LOAD.qts, see the Axiant 4GL online 
Help.

Database Location

Sybase SQL Anywhere \Program Files\Cognos\Axiant 4GL <version>\Examples\ 
Example_4gl\SqlAny\Sql\

Oracle \Program Files\Cognos\Axiant 4GL 
<version>\Examples\Example_4gl\Oracle\Sql\

Microsoft SQL Server \Program Files\Cognos\Axiant 4GL <version>\Examples 
\Example_4gl\Mssql\Sql\

DB2 \Program Files\Cognos\Axiant 4GL 
<version>\Examples\Example_4gl\Db2\Sql\

Sybase ASE \Program Files\Cognos\Axiant 4GL 
<version>\Examples\Example_4gl\Sybase\Sql\
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example_4gl, 60
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Default Section Library object, 27, 39, 41, 43
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window, 46

delete commands
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Directory Manager tab, 31

E
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viewing, 40
Element Library object, 27, 39
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dates, 20
finding, 20
making mass changes, 21
viewing, 40

Event, 44, 47, 52-53
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data files, 61
database setup, 60
loading data, 61

example_4gl.pdl, 61
example_4gl.sql, 59

F
File Collection object, 11, 27
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Find Object dialog box, 20
finding elements, 20
Font dialog box, 46
Font property

changing, 46
Font settings, 55
Form height, 50
Form tab, 47
Form width, 50

G
Getting ready to move data, 20

H
Help. See online Help

I
images

inserting in a Screen Program, 50
importing data definitions, 5
Inheritance

and Screen Programs, 41
Insert menu, 57
installing

Axiant 4GL, 5

K
Keys, 40

L
Labels

changing, 56
LOAD.qts, 17, 60, 61
loading data

example_4gl.db, 61
Timesheet, 60

M
Menu Screen

building, 18
Microsoft SQL Server, 19
Migrating

a PowerHouse application, 9
data definitions, 13
QTP run file, 17
QUICK screens, 16

Migration Advisor Details dialog box, 14
Migration Advisor dialog box, 14, 32
Migration Issues Detected dialog box, 15
Migration Profile

creating, 11-13, 28-31
defined, 11
object, 39
object window, 13

Migration Profile wizard, 11, 28
Conditional Compiles page, 30
Data Definitions page, 11
Finish page, 30

MPE/iX page, 30
Program Source page, 11, 29

Migration questions and answers, 38
Migration Status dialog box, 15
Move to back, 51, 55
moving objects, 49, 54

N
naming conventions, 14
New Repository dialog box, 10, 26
New Workspace dialog box, 9, 26

O
objects

Application, 27, 39
Default Section Library, 27, 39
Element Library, 27, 39
File Collection, 27
in a new workspace, 26
Migration Profile, 28, 31, 39
Relational Database, 27
Repository, 27
Screen Section Library, 39
Structure Library, 27, 39
Usage Library, 27, 39

ODBC connection
database open name, 17

online Help, 6, 40
open name

specifying, 17
Oracle, 19

P
Panel mode, 58
PDL Definitions box, 11
portable subfiles, 19
PowerHouse Environment

in Application Manager tab, 36
in Data Manager tab, 35

PowerHouse screens, 49
pre-populated Repository, 27
Profile Databases object, 13
Program Set, 37
program source files, 32

Q
QTP run, 19
QTP source file

migrating, 17
QUICK screens

migrating, 16

R
Rectangle object, 46
Relational Database object, 10, 27
Repository

connecting to, 26
creating, 9, 25
defined, 26
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pre-populated, 27
Standard, 10, 26, 39, 41

resizing a Screen Form, 49
resizing forms, 58
resizing objects, 55

S
Screen customization. See Customizing Screen Programs
Screen Program properties

background color, 44
Screen Section Library, 41
Screen Section Library object, 39
Sections, 41
sharing work with other developers, 26
shortcut buttons, 9
source files, 32, 37
Standard Repository, 10, 26, 39, 41
structure definitions

viewing, 40
Structure Library object, 27, 39
subfiles, 19
Sybase ASE, 19
Sybase SQL Anywhere, 19

T
three-dimensional effect, 46
Timesheet

data files, 60
Timesheet application

main menu, 19
Timesheet.db, 19

database setup, 59
Timesheet.pdl, 60
Timesheet.sql, 19
toolbars, 9
tours

databases to use, 59

U
Usage Library object, 27, 39

V
version of document, 2

W
workspace

creating, 9, 25
defined, 26
objects, 10
A Guided Tour of Axiant 4GL  65



Index  
 

66  Axiant (R)  4GL   Version 3.4E


	A Guided Tour of Axiant 4GL 
	Table of Contents 
	Welcome to Axiant 4GL 
	Installing Axiant 4GL 
	The Tours 
	What's in This Book? 
	How Can I Learn How to Use Axiant 4GL? 
	Axiant 4GL Courses 
	How Can I Access Online Help? 

	What Customer Support Services Are Offered? 
	Cognos Customer Support 

	Chapter 1: The Fast Tour 
	Setting the Scene 
	What Needs to be Done? 
	Customizing Toolbars 

	Create a Workspace and Repository 
	What Are Those Objects in My Workspace? 

	Create a Migration Profile 
	Migrate Data Definitions 
	Edit the Definitions 

	Migrate Your Application 
	Migrate a System of QUICK Screens 
	Migrate a QTP Source File (Oracle, DB2, Sybase ASE, Microsoft SQL Server only) 

	Specifying the Database Open Name for ODBC Connections 
	Build and Execute a Menu Screen 
	Am I Done Yet? 
	Review Your Data Definitions 
	Change Data Definitions 

	Load the Data (Oracle, DB2, Sybase ASE, Microsoft SQL Server only) 
	Create and Execute a Data Screen 
	What Do I Do Now? 

	Chapter 2: What Happened in the Fast Tour? 
	Creating a Workspace and Repository 
	Take a Look 
	What Do I Do Now? 
	Questions and Answers: Workspaces and Repositories 
	Need More Information 

	Creating a Migration Profile 
	Take a Look 
	Need More Information 

	Migrating Your Data Definitions and Application Files 
	Take a Look 
	Questions and Answers About the Migration 
	I Need More Information 


	Chapter 3: Customizing Screen Programs 
	Setting the Scene 
	What's Involved in Screen Customization? 

	Before You Customize 
	If You Completed the Fast Tour 

	What Needs to be Done? 
	The Screen Before 
	The Screen After 

	Customizing Screens Using Inheritance 
	Change the Background Color 
	Change the Font Size 
	Add a 3D Effect to the Rectangle Object 
	Check the Results 

	Customizing an Individual Screen 
	Delete the Company Name 
	Resize the Screen Form 
	Insert an Image 
	Insert a Rectangle 
	Try Out the Screen 
	Add an Event to the Initials Field 
	I Need More Information 
	Test the Event 
	Perform Finishing Touches 

	Suggestions for Further Exploration 
	Tips for Customizing Screens 
	What Now? 

	Appendix A: Database Requirements 
	Example_4gl.db and Example_4gl.sql 
	Database Setup for Timesheet.db 
	Using Sybase SQL Anywhere 9 
	Using Oracle, DB2, Microsoft SQL Server and Sybase ASE 
	Timesheet.PDL 
	Data Files for the Timesheet 

	Database Setup for Example_4gl.db 
	Using Sybase SQL Anywhere 9 
	Using Oracle, DB2, Microsoft SQL Server and Sybase ASE 
	Example_4gl.sql 
	Data Files for Example_4gl 


	Index 


