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Installation

This presentation explains how to install the IBM WebSphere Everyplace Client 

Toolkit Version 6.
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Goals

�Understand the how to install the IBM WebSphere 

Everyplace Client Toolkit Version 6

The goal of this presentation is to understand how to support the IBM WebSphere 

Everyplace Client Toolkit Version 6.
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Agenda

� Installation

The agenda of this presentation is to explain how to install the toolkit.
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Section

Installation
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WebSphere Everyplace Client Toolkit Install

� Eclipse Update site

�Available on CD in WEC_Toolkit directory

� Single master feature

�Sub-features cannot be installed/managed separately

� Toolkit install includes

�Tools

�Docs

� Application Developer’s Guide

� Administrators Guide

�Samples

� Installed into the samples gallery

�WebSphere Everyplace Deployment test environment

The contents of the WebSphere Everyplace Client Toolkit includes the following:

•Eclipse Update site
•Available on CD in WEC_Toolkit directory

•Single master feature
•Sub-features cannot be installed/managed separately

•Toolkit install includes

•Tools
•Docs

•Application Developer’s Guide

•Administrators Guide
•Samples

•Installed into the samples gallery

•WebSphere Everyplace Deployment test environment required to test and 

debug your applications
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WEC_Toolkit Update Site
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Install process

� Standard Eclipse update 

site process

�Not part of the Rational 

Product Updater

� Documented in the Getting 

Started Guide (index.html)

� Takes approximately 10 
minutes to complete

� After restart the toolkit will 
make a few configuration 

changes

�User is prompted

Please review the WebSphere Everyplace Client Toolkit Getting started guide 
for additional information.  To manually open the Getting started guide, open the 
index.html file in the root directory of the install CD.
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Configuration process

� The toolkit will ask the user to set the preferences for 

development

� If the user answers no and does not check the “Don’t ask 
me again” checkbox, the system will ask each time until 

the user clicks OK.

� This is a per workspace 

configuration, so each 
new workspace will require 

a separate answer

� Clicking OK will:
�Change the target platform

�Change the workspace JRE
�Start the Bundle Registration Job

For the WebSphere Everyplace Client Toolkit to work correctly it must be 
configured.  To help the user configure the toolkit, a message box comes up 
that allows users to configure multiple settings in just one click.  
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Bundle Registration Job

� All target platform and workspace bundles are registered in 

the toolkit for advanced pre-requisite checking

� Registration starts after target platform is changed or 
reloaded

�Starts as a result of selecting OK on change preference dialog 

� Takes approximately 90 seconds

� After bundle registration job completes, restart the IDE

The Bundle Registration Job is necessary to do extensive pre-requisite checking 
on bundles.  The job can be run in the background to allow you to still use the 
IDE during the process.  The Launcher and Platform Builder will not be available 

while the job is running.
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From the Getting Started Guide (index.html)

To install the IBM WebSphere Everyplace Client Toolkit Version 6, follow these steps:
1. Review release notes for system requirements and product information, such as software limitations at the time of this 

release. 

2. Log on to your system with an administrator ID that has write permission to the installation location and start the Rational 
SDP. 

3. From the main menu, click Help > Software Updates > Find and Install. The Install/Update wizard is displayed. 

4. Select Search for new features to install and click Next. 

5. In the "Update sites to visit" window, select the New Local Site button. 

6. Browse to select the drive and directory where the IBM WebSphere Everyplace Client Toolkit feature is located and click 
OK. For example, if installing from the product CD, select the WEC_Toolkit directory and click OK. 

7. Select the check box next to the site name and click Next. Note: Selection of the Ignore features not applicable to 
this environment check box does not affect toolkit installation.

8. In the Search Results window, select the IBM WebSphere Everyplace Client Toolkit Version 6.0.0 feature and click 
Next. 
Note: Selection of the Filter features included in other features on the list check box does not affect toolkit 
installation. 

9. In the Feature License window, read the licensing information, select to accept the license and click Next. 

10. In the Install Location window, the directory location where this feature will be installed is displayed. Click Finish to 
begin the installation. 

11. In the Feature verification window, verify that the feature information is correct and click Install. 
Note: When warned about installing an unsigned feature, click Install to continue. This does not cause problems during 
installation. 

12.When installation completes, you are prompted to restart your Rational program for changes to take effect. Click Yes to 
continue. Note: Clicking Apply Changes does not properly configure the environment.
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Verifying the installation

� Method 1

�Select Help > Software Updates > Manage Configuration…

�Expand <RSDP_Install>\spdisv\eclipse

�Should be the last in the list

�Check for IBM WebSphere Everyplace Client Toolkit

� Method 2

�Verify the system is installed by selecting File > New > Other

�The Client Services category will be available

You can use one of the methods shown on this slide to verify that the toolkit was 
installed correctly.
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Method 1

Method 2
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Uninstall

To uninstall the toolkit, perform the following procedure: 

� Select Window > Preferences > Java™ > Installed JREs. The Installed Java 
Runtime Environments panel displays, showing all installed JREs. Unselect 
WebSphere Everyplace Deployment (to remove it as the default JRE), and check 
the JRE originally provided with the Rational® Software Development Platform. 

� Select Window > Preferences > Plug-in Development > Target Platform and 
change the Location field to the Rational Software Development Platform, by 
selecting it from the drop down list. 

� Select Help > Software Updates > Manage Configuration. The Product 
Configuration menu displays. From the Navigator window, open the sdpisv Extension 
Location, and select IBM® WebSphere Everyplace Client Toolkit. The information for 
the feature displays in the window to the right. Select Disable.1

� Restart the platform when prompted.1 

� Select Help > Software Updates > Manage Configuration. The Product 
Configuration menu displays. From the Navigator window, open the sdpisv Extension 
Location and select IBM WebSphere Everyplace Client Toolkit. The information for 
the feature displays in the window to the right. Select Uninstall. 

� Select OK in the next dialog. Restart the platform when prompted.

Note: Steps 3 and 4 are only required on Windows®. Linux® users can step directly from step 3 to step 5. 
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Trademarks, Copyrights, and Disclaimers
The following terms are trademarks or registered trademarks of International Business Machines Corporation in the United States, other countries, or both:

IBM CICS IMS MQSeries Tivoli
IBM(logo) Cloudscape Informix OS/390 WebSphere
e(logo)business DB2 iSeries OS/400 xSeries
AIX DB2 Universal Database Lotus pSeries zSeries

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both. 

Microsoft, Windows, Windows NT, and the Windows logo are registered trademarks of Microsoft Corporation in the United States, other countries, or both. 

Intel, ActionMedia, LANDesk, MMX, Pentium and ProShare are trademarks of Intel Corporation in the United States, other countries, or both.  

UNIX is a registered trademark of The Open Group in the United States and other countries. 

Linux is a registered trademark of Linus Torvalds.  

Other company, product and service names may be trademarks or service marks of others.

Product data has been reviewed for accuracy as of the date of initial publication.  Product data is subject to change without notice.  This document could include technical inaccuracies or 
typographical errors.  IBM may make improvements and/or changes in the product(s) and/or program(s) described herein at any time without notice.   Any statements regarding IBM's 
future direction and intent are subject to change or withdrawal without notice, and represent goals and objectives only.  References in this document to IBM products, programs, or 
services does not imply that IBM intends to make such products, programs or services available in all countries in which IBM operates or does business.  Any reference to an IBM Program 
Product in this document is not intended to state or imply that only that program product may be used.  Any functionally equivalent program, that does not infringe IBM's intellectual 
property rights, may be used instead.

Information is provided "AS IS" without warranty of any kind.  THE INFORMATION PROVIDED IN THIS DOCUMENT IS DISTRIBUTED "AS IS" WITHOUT ANY WARRANTY, EITHER 
EXPRESS OR IMPLIED.  IBM EXPRESSLY DISCLAIMS ANY WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT. IBM shall 
have no responsibility to update this information.   IBM products are warranted, if at all, according to the terms and conditions of the agreements (e.g., IBM Customer Agreement, 
Statement of Limited Warranty, International Program License Agreement, etc.) under which they are provided. Information concerning non-IBM products was obtained from the suppliers 
of those products, their published announcements or other publicly available sources.  IBM has not tested those products in connection with this publication and cannot confirm the 
accuracy of performance, compatibility or any other claims related to non-IBM products.  IBM makes no representations or warranties, express or implied, regarding non-IBM products and 
services.

The provision of the information contained herein is not intended to, and does not, grant any right or license under any IBM patents or copyrights.  Inquiries regarding patent or copyright 
licenses should be made, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY  10504-1785
U.S.A.

Performance is based on measurements and projections using standard IBM benchmarks in a controlled environment.  All customer examples described are presented as illustrations of 
how those customers have used IBM products and the results they may have achieved.  The actual throughput or performance that any user will experience will vary depending upon 
considerations such as the amount of multiprogramming in the user's job stream, the I/O configuration, the storage configuration, and the workload processed.  Therefore, no assurance 
can be given that an individual user will achieve throughput or performance improvements equivalent to the ratios stated here.

© Copyright International Business Machines Corporation 2005.  All rights reserved.

Note to U.S. Government Users - Documentation related to restricted rights-Use, duplication or disclosure is subject to restrictions set forth in GSA ADP Schedule Contract and IBM Corp.
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