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Introducing WebSphere Everyplace Deployment 6.0

IBM® WebSphere® Everyplace® Deployment for Windows® and Linux® 6.0 is a
software program that provides a runtime environment and integrated middleware
components for extending many enterprise applications to server-managed laptop
and desktop systems. It includes the Workbench—a client-side, services-oriented
framework that can enable application to run locally while the system is
disconnected from the network. The Workbench synchronizes data, transactions,
and applications after the system is reconnected. You can also use the Workbench
to deploy, maintain, update, and even remove software from end-user systems,
with minimal end-user intervention.

Note: The WebSphere Everyplace Deployment runtime platform provides an
application environment on which ISV’s can develop applications using
Rational® Software Application Development tools from IBM, and Eclipse
tools (http:/ /eclipse.org/]). For more information, see the IBM WebSphere
Everyplace Deployment Application Developer’s Guide installed with the IBM
WebSphere Everyplace Client Toolkit 6.0 product.
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Accessibility

© Copyright IBM Corp. 2005

The WebSphere Everyplace Deployment Workbench is designed to accommodate
people who have physical challenges, such as restricted mobility, limited vision, or
those with special needs to use software products successfully. It uses Microsoft
Active Accessibility (MSAA) APIs to render user interface elements accessible to
assistive technology.

The Workbench permits the following accessibility features:

* Support for keyboard shortcuts and commands. For more information, see
[“Using keyboard commands” on page 6.|

* Support for screen-reader software, such as Freedom Scientific’s JAWS ", and a
digital speech synthesizer to hear what is displayed on the screen.

* Support for voice recognition software, such as IBM ViaVoice ", to enter data
and to navigate the user interface.

* Support for display settings, such as color scheme, font size, and high-contrast
display. You can enable High Contrast mode through your operating system and
change the size of your display fonts. Note that changing your Windows display
fonts affects all programs on your computer. Refer to Windows Help for more
information.

In addition to keyboard commands, the Workbench supports shortcut and
command keys:

* A shortcut key is usually displayed as an underlined letter. For example, the
letter F is the shortcut key for the File menu. To use a shortcut key, hold down
the Alt key and then press the shortcut key to trigger an action. For example, to
display the File menu, press Alt+F. On some Linux systems, you can also use
the F10 key to set focus on the menu item and then press the shortcut key to
initiate the action.

* A command key is a combination of the Ctrl key and a letter. To use a command
key, hold down the Ctrl key and press the letter. For example, to print, press
Ctrl+P.

The Workbench also contains a View menu, which enables people with a physical
disability to modify the look and feel of the platform. Users can show or hide the
Application Switcher, switch between large and small icons in the Application
Switcher, and show or hide the labels of icons in the Application Switcher. In
addition, users can also show or hide the platform banner.
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Navigating the Workbench

When you start WebSphere Everyplace Deployment, a desktop application
environment called the Workbench is displayed. This interface provides the window
management capabilities needed to host several applications. It displays a banner,
a toolbar menu bar, an application switcher pane, and content space for
applications. What you see in each pane varies with the capabilities that are
available, in ready-to-use configurations or customized for your organization, and
with the context of your current work session.

User interface components

When navigating the Workbench, you can use various interface components, such
as the Application Switcher, which defines the initial set and layout of views in the
Workbench window.

User interface components of the Workbench include the following;:

Application Launcher
Use to start or open an application.

Application Switcher
Applications that are opened are added to the Application Switcher pane,
allowing you to quickly move between applications.

Applications
Each Workbench window contains one or more applications, each with its
own display area.

Banner
The banner is the top section that displays the WebSphere Everyplace
Deployment name and the toolbar. It also displays the application name
when it has focus.

Icons Icons display throughout the Workbench. To view a description of an icon,
move the mouse pointer over the icon.

Menu bar
The main menu is the menu bar provided at the top of the Workbench
window. It provides File, Application, View, and Help menu options.
Installed applications can add options to the menu bar when the
application is active.

Status bar
The status bar displays action buttons and messages about current status
and activity.

Toolbar
The main Workbench toolbar is displayed directly below the menu bar. The
content of this toolbar changes based on the active application.

View A perspective consists of one or more tabbed views, each displaying a page
with application data or resources. A view can have its own menu and

toolbars. It can also appear by itself, or stacked with other views in a
tabbed notebook.
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Switching between applications

Use the Application Switcher pane to open applications and switch between them
with the touch of a mouse.

When you open an application, an associated icon appears on the side of the
window in the Application Switcher. This makes it easy for you to switch between
open applications in the Workbench. Simply click an icon to bring focus to the
application and display it. If an application was previously opened, it is replaced
by the most recently opened application. However, if you want to bring the
application to the foreground again, its content is restored to the state where you
last left it.

By default, the Workbench displays the Application Switcher pane with the Open
icon. You can do the following;:

* Select View > Show Application Switcher to hide or display the Application
Switcher.

* Click and drag the edge of the Application Switcher frame to resize it.
* Select View > Show Icon Labels to show or hide labels for the icons displayed.

Using keyboard commands

6

Use keyboard commands instead of a mouse. Refer to the main menus to view
shortcut and command keys for each menu item.

The Tab key iterates through the controls in a particular scope (for example, a
dialog or a view and its related icons). To navigate to the main controls for the
Workbench window or to tab out of views that use the Tab key, use Ctrl+Tab. Key
combinations are as follows:

+ |“Application Management”]

* [“Application Switcher” on page 7|

+ |["Help system” on page 7|

* ["Menus” on page 7|

* [“Workbench” on page §

Application Management

Key combination Action

* (up arrow) Moves up.

¥ (down arrow) Moves down.

PgDn Moves down, scrolling to the following page (if applicable).
PgUp Moves up, scrolling to the previous page (if applicable).
Ctrl+Home Moves to the top of the page.

Ctrl+End Moves to the bottom of the page.

Enter Displays tasks for the selected component.

F10 Accesses the File menu on the main menu bar.
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Application Switcher

Key combination

Action

CTRL+F8

Cycles through each component in the Application Switcher.

SHIFT+CTRL_F8

Cycles counter clockwise through each component in the
Application Switcher.

Help system

Key combination

Action

Tab inside a frame (page)

Moves up to the next link, button, or topic node.

+ or ¢ (right or left arrows)

Expands or collapses a tree node. Also moves between tabs.

Tab or t (up arrow)

Switches and moves to a view.

Tab or ¥ (down arrow)

Moves to the next topic node.

Shift+Tab or * (up arrow)

Moves to the previous topic node.

Enter Displays the selected topic.
Home Moves to the top of the topic list.
End Moves to the bottom of the topic list.

Alt+ ¢ (left arrow)

Moves back.

Alt+ » (right arrow)

Moves forward.

Ctrl+Tab (Ctrl+F6 if using
Mozilla, or a Mozilla-based
browser)

Moves to the next frame or toolbar.

Shift+Ctrl+Tab
(Shift-Ctrl+F6 if using
Mozilla or a Mozilla-based
browser)

Moves to the previous frame or toolbar.

Alt+K when using the
embedded help browser or
Internet Explorer on
Windows systems

Moves to the frame displaying topic content.

Ctrl+P

Prints the current page.

Ctrl+F when using the
embedded help browser or
Internet Explorer on
Windows systems

Finds a string in the current page or active frame.

Alt+S

Moves to the search entry field.

Menus

Key combination

Action

F10 Accesses the menus on the main menu bar.
SHIFT+F10 Displays the context menu for the current view.

Note: This shortcut depends on your window manager.
Ctrl+F10 Accesses the pull down menu for the current view (if one

exists).
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Key combination

Action

Alt+mnemonic

Activates the Workbench menu for a particular entry; for
example, Alt+A accesses the Application menu. On Windows
systems, pressing Alt returns focus to the menu bar.

F10 accesses the menus on the main menu bar. Shift+F10 displays the context
menu for the current view. Parent topic: Navigating (using the keyboard)

Workbench

Key combination

Action

Tab Moves to the next control in the Workbench. Also moves
between drop-down menus within the toolbar.
Shift+Tab Moves to the toolbar and selects the previously selected icon

in the toolbar.

Enter or Spacebar

Activates the selected action.

Ctrl+Tab

Moves from the body of the Workbench to the toolbar (from
left to right).

» or ¢ (right or left arrows)

Moves between icons within the toolbar.

t or ¥ (up and down
arrows)

Moves through menu items.

Exiting the Workbench

Use the File > Exit menu choice or click the Close icon EI in the upper right
corner of the window to close the Workbench.

If the Workbench preference Confirm exit when closing last window is selected,
you are prompted for confirmation before the Workbench window closes.
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Customizing the Workbench

Use the Preferences page to customize preferences for installed applications and
services. Use the View menu to change the appearance of the Workbench platform
to suit your needs.

To customize the Workbench, follow these steps:

1.

Select File > Preferences from the main menu. The default installation contains
preferences for the Workbench, [Enterprise Management Agent| and
Install/Update] If other applications provide preferences pages, you can access

them here.

Select Workbench from the tree view in the left pane.
Accept default values or update one or more of the following options:

* Select whether to open an application in the existing Workbench window or
to open an application in a new window. This option applies to all
applications. The default value is to open applications in the same window.

* To be prompted with a confirmation dialog when you close the last
Workbench window, select the Confirm exit when closing last window
check box. If this is not selected, the Workbench closes immediately.

Do one of the following:
* Click OK to save the preference values and close the Preferences dialog.

* Click Apply to save the preference values, but keep the Preferences dialog
open.

To change the appearance of the Workbench, use the View menu as follows:

© Copyright IBM Corp. 2005

To display the Application Switcher, select View > Show Application Switcher.

To display large or small icons in the Application Switcher, select View > Show
Small Icons or View > Show Large Icons.

To display icon labels in the Application Switcher, select View > Show Icon
Labels.

To display the platform banner, select View > Show Banner.
To display the toolbar, select View > Show Toolbar.
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Administering the Workbench remotely

Use the Enterprise Management Agent to enable remote management and
distribution of applications in an enterprise environment. Attention: Do not enable
this agent unless instructed to do so by your system administrator.

By default, the Enterprise Management Agent is not activated. If you select the
Enable Enterprise Management Agent check box, you are enabling the platform to
be managed remotely by an enterprise management system. The agent initiates
requests to the server on demand or at specified polling intervals. You will not be
able to install, update, or uninstall features after this agent is enabled. You will also
not be able to deactivate this agent without assistance from your system
administrator.

To enable the Enterprise Management Agent, do the following:
1. Select File > Preferences from the main menu.
2. Select Enterprise Management Agent from the tree view in the left pane.

3. Select the Enable Enterprise Management Agent check box and supply the
following information:

* Type the user name and associated password required to connect to the
management server. Type the password again for verification.

¢ (Optional): Type the password required to access the server. Type the
password again for verification.

* In the Server IP Address field, type the host name or IP address necessary to
connect to the management server.

* When the IP address is filled in, your system administrator can set a polling
interval to define the frequency with which the agent contacts the server. The
agent contacts the server between the specified polling start and end times
for the specified interval duration.

Attention: Only your system administrator can change the polling interval,
start/end time, and whether to enable polling at startup.

* Select the Test Connection button to verify that the information is correct
and that you can connect to the server successfully.

4. Do one of the following:
* Click OK to save the preference values and close the Preferences dialog.

¢ Click Apply to save the preference values, but keep the Preferences dialog
open.

© Copyright IBM Corp. 2005 11
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Managing applications

Use the Application Manager to manage the current configuration of the
WebSphere Everyplace Deployment platform. To access the Application Manager,
click Application > Application Management.

The initial dialog displays installed features, including a set of actions that enable
you to:

* Search for updates for all the installed features

* View all activities since the installation of the product

* View the activities that caused the creation of this configuration
* Restore features that were installed but not linked to this version

* Revert to one of the previous configurations if you are having problems with the
current one

Note: If the Enterprise Management Agent is enabled, you cannot manage features
using this selection.

Opening and closing an application

To open an application, select Application > Open from the main menu or click

the g Open icon in the Application Switcher. Select from the list of
applications that you want to launch.

Note: To restore closed views associated with the most recently opened
application, select Application > Reset from the main menu, or right-click
an icon in the Application Switcher and click Reset.

To close an application, use the main menu as follows:
* Select Application > Close to close the application in focus (most recently used).
* Select Application > Close All to close all open applications.

You can also right-click on an icon in the Application Switcher to close its
associated application or all open applications.

Setting installation options

Install/Update preferences allow you to select how the WebSphere Everyplace
Deployment platform manages downloads and updates. Your system administrator
should provide you with the correct values to complete these fields.

To set Install/Update preferences, do the following;:

1. Select File > Preferences from the main menu.

2. Select Install/Update from the tree view in the left pane.

3. Accept default values or update one or more of the following options:
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¢ Type a value for the maximum number of "History” configurations. This is

the number of history configurations that is maintained and displayed within
the Application Management dialog. The default value is 100.

Select whether or not to check digital signatures of downloaded archives. If
selected, warnings are displayed if the features are not digitally signed, and
if digital signatures exist, they must match the certificates. If this check box is
clear, digital signatures are not verified and warnings are not displayed.

Select how updates are applied to existing applications. It is recommended
that you check with your administrator on the proper settings.

— Select equivalent (default) to limit updates to service changes only, such
as defect fixes. Application/Feature versions are specified using
major.minor.service. For example when installing the Order Entry
sample, the version listed might be 6.0.1.2005mmdd, where the major
version is 6, the minor version is 0, and the service version is 1. If the
version of the Order Entry Sample installed is 6.0.1, then future attempts
at upgrades filter out any major version not equal to 6 and any minor
version not equal to 0.

— Select compatible to allow the installation of any upgrade that is not a
major version. Compatible upgrades might include changes in the
behavior of the application, which coexist and work with the existing
application and features.

To update policy on your system, you can specify a URL provided by your
administrator. This enables your administrator to control updates on your
system. This reduces network bandwidth and limits application versions to
only those that are approved and tested.

If a firewall prevents access to a remote update site, you might require a
proxy server configuration to access the remote update site. To do so, select
the Enable HTTP proxy connection check box and type an HTTP proxy host
address and port. By default, proxy connections are not enabled.

4. Do one of the following:

* Click OK to save the preference values and close the Preferences dialog.
¢ Click Apply to save the preference values, but keep the Preferences dialog

open.

Installing an application

14

To locate and install a new application, follow these steps:

Note: During installation, an application is called a feature. This is simply a way of

1.
2.

grouping and describing different functions that make up a product.
Click Application > Install to open the installation wizard.
Add the location of the features and plug-ins to the Location List using one of
the following methods:

* Add Remote Location to add a remote location (URL), which contains the
application. In the Add Remote Location dialog box, specify a Web site
name, such as CompanyA, and enter the URL, such as
http://companyA.example.com/wed updates.

¢ Add Folder Location to add the location of the folder that contains the
application on a local drive or CD.

* Add Zip/Jar Location to add the location of the .zip or .jar file (when the
application is packaged as a jar or zip file).
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3. After adding the site, select the site and expand it to view the categories of
feature versions available at that update site. Note: This action may contact a
Web site to discover what features are available.

4. Select the categories you want to search and click Next.

5. Wait for the search to finish and select the features to be added. To view more
detail for any feature, select the feature and click Properties.

6. After selecting the features to install, click Next.

7. Carefully review the license agreements for the features. If the terms of all
these licenses are acceptable, select "I accept the terms in the license
agreements”. Do not proceed to download the features if the license terms are
not acceptable.

8. If a feature selected for install includes optional features, you are prompted as
to whether you want them installed or not. Optional features typically carry
functionality that is not essential for proper functioning of the main feature.

9. At the Install Location page, select the directory where you want the new
feature’s files to be installed on your computer and click Next. Note: If the
product is installed in a directory to which you do not have write access, you
should contact your system administrator and get them to install this feature
so that it will be generally available. The other option is to click Add and
point to a directory to which you do have write access.

10. Feature versions can be digitally signed by the company that provides them.
This allows you to verify more easily that the features and plug-ins that are
about to be downloaded and installed are coming from a trusted supplier. To
be prompted with a warning message when features are not digitally signed,
[set installation options]

Click Install to allow the download and installation to proceed.

Updating a feature

The basic underlying mechanism of the update manager is simple: the files for a
feature or plug-in are always stored in a subdirectory whose name includes a
version identifier (for example, "2.0.0"). Different versions of a feature or plug-in
are given unique identifiers to ensure that multiple versions of the same feature or
plug-in can coexist on a disk. This means that installing or updating features and
plug-ins requires adding more files, but never requires deleting or overwriting
existing files. After the files are installed on the local computer, the new feature
and plug-in versions are available to be configured. The same installed base of files
is therefore capable of supporting many different configurations simultaneously;
installing and upgrading an existing product is reduced to formulating a
configuration that is incrementally newer than the current one. Important
configurations can be saved and restored to active service in the event of an
unsuccessful upgrade.

To determine whether there are updates for an application’s existing features, do
the following:

1. Click Application > Application Management from the main menu.

2. Select WebSphere Everyplace Deployment or expand it to locate and select the
application feature that you want to update.

3. Select Scan for Updates from the Available Tasks list.

4. In the Updates window, select the feature versions that you want to upgrade
and then click Next.
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5. Carefully review the license agreements for the upgraded features. If the terms

of these licenses are acceptable, select I accept these terms in the license
agreements. Do not proceed to download the features if the license terms are
not acceptable.

Feature versions can be digitally signed by the company that provides them.
This allows you to verify more easily that the features and plug-ins that are
about to be downloaded and installed are coming from a trusted supplier. To
be prompted with a warning message when features are not digitally signed,
[set installation options}

Click Install to allow the download and installation to proceed.

Enabling or disabling an application

To open the configuration manager, click Application > Application Management.
To disable an application (or feature), select the feature and click Disable in the
right pane. The action is available only when the feature is currently enabled, and
the feature is either an optional feature or a root feature (not included by other
features).

To enable an application, select the disabled application from the list and click
Enable in the right pane. If the disabled feature is not displayed in the list, click

the Show Disabled Features icon f .

Uninstalling a feature

To uninstall a feature, click Application > Application Management from the main
menu. Select the feature and click the Uninstall task in the right pane of the dialog
or in the context menu.

Scanning for updates

16

To determine whether there are updates for an application’s existing features,
follow these steps:

1.
2.

Click Application > Application Management from the main menu.

Select WebSphere Everyplace Deployment or expand it to locate and select the
application feature that you want to update.

Select Scan for Updates from the list of Available Tasks.

In the Updates window;, select the feature versions that you want to upgrade
and click Next.

Carefully review the license agreements for the features. If the terms of all these
licenses are acceptable, select "I accept the terms in the license agreements”.
Do not proceed to download the features if the license terms are not acceptable.

Feature versions can be digitally signed by the company that provides them.
This allows you to verify more easily that the features and plug-ins that are
about to be downloaded and installed are coming from a trusted supplier. To
be prompted with a warning message when features are not digitally signed,
[set installation options|

Click Install to allow the download and installation to proceed.
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Viewing the current configuration

The About dialog (Help > About WebSphere Everyplace Deployment) shows
most of the important information about the features and plug-in configured in the
product.

To find more detailed information about the current configuration, follow these
steps:

1. Click Application > Application Management from the main menu.

2. Select a feature version and click Show Properties to display detailed
information about the selected feature.

3. Click the Show Disabled Features button in the toolbar of the Application
Management dialog. Any feature versions that are disabled are now shown, if
applicable. Disabled feature versions are ones that are installed on the local
computer, but excluded from the current configuration. At most, one version of
any given feature is present in a given configuration; usually the ones with the
lower version numbers appear disabled.

4. In the Properties dialog of a feature, click Status to find out whether the
selected feature is configured exactly as packaged. The status shows when a
feature’s plug-ins are present at different versions, or disabled due to missing
prerequisite plug-ins that are expected to be supplied by some other feature.

5. In this dialog you can revert to a previous install configuration, view the
installation history, or even add another eclipse product extension. A product
extension is a local folder that has a similar file layout as the eclipse
installation, but with an .eclipse extension marker (instead of .eclipseproduct).
If you add a product extension, make sure there are no duplicate features in the
extension you add.

When the installation wizard is used to install features in a user selected location,
that location automatically becomes an eclipse product extension.

Revert to a previous configuration

A previously saved configuration (or any configuration recorded in the history) can
be restored, thereby backing out of an unsuccessful upgrade. Restoring a saved
configuration does not delete the files for feature and plug-in versions from the
local computer; it merely ignores them and acts as it did when they were not
present. To restore a saved configuration to be the current configuration:

1. Click Application > Application Management from the main menu.

2. In the Application Management dialog, select WebSphere Everyplace
Deployment and then select Revert to a Previous Configuration from the
Available Tasks list.

3. Select one of the previous configurations (which are listed by date and time).
4. Click Finish to apply the selected configuration.

5. Click Yes when prompted to exit and restart the Workbench for the changes to
take effect.

Managing applications 17



18 1BM WebSphere Everyplace Deployment: User’s Guide



Using the Order Entry sample application

The Order Entry sample application is installed with WebSphere Everyplace
Deployment. This "client side” sample provides both a rich client application and a
Web application version. Use these samples to become more familiar with how to
install and launch applications using the Workbench. Note that application
developers interested in obtaining both the client and server portion of this sample
application must install the IBM WebSphere Everyplace Client Toolkit 6.0.

The Order Entry application shows two different user interface styles to access the
application:

¢ Using views
* Using the embedded browser supplied with the Workbench
The sample demonstrates a simple application that enables a delivery employee to

capture orders from convenience stores for cans and bottles of a beverage. Orders
submitted are retained until the client connects to a server application.

Installing the Order Entry application

You must install and configure the Order Entry sample application before you use
it.

Follow these steps to install the Order Entry sample application:
1. Start WebSphere Everyplace Deployment.
2. Select Application > Install from the main menu.

3. If you have been provided a CD, or network attached drive, select Add Folder
Location.

a. Browse to the /updates/platform directory.
b. Click OK.

4. If you do not have the media or a network attached drive, you will need to
obtain the Update Site address from your IT personnel.

a. Select Add Remote Location.

b. Add a name to identify the site, and enter the URL that you were
provided.

c. Click OK.

In the list, select only the site that you just added, then Next.
From the list presented, select the Order Entry feature, then Next.
Read the license terms provided, and if acceptable, click Next

© N o o>

Select the appropriate installation site. (This defaults to WebSphere Everyplace
Deployment installation directory.)

Click Finish.

10. When prompted to install features that are unsigned, click Install. Result: The
application is installed and available.

©

11. When prompted to Restart, select Yes.
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Configuring the Order Entry application

If the Order Entry sample is connected to the server, you must configure the
sample before using it. If you are running the sample while disconnected from the
server, configuration is not required.

To configure settings for this sample application, do the following:

1.
2.
3.

Select File > Preferences from the main menu.
Select Order Entry from the tree view in the left pane.

Type the port number on which the server application counterpart is listening.
The default value is 8082.

Type the host name or IP address on which the server application is listening.
The default value is localhost.

Select whether or not to Clear database at service start. If selected (default),
this option resets the database content to a list of customers with no orders. If
this option is not selected, database contents retain the orders from the
previous use.

Provide an MQ Everyplace Client ID for the client device when accessing the
server application. The default value is DefaultClientID.

Specify a directory for Queue Manager and Database Files. This is the directory
where files containing MQ Everyplace queue information and the database
content are stored. The default directory is /temp. If this directory does not
exist, it is created. Make sure that you have access to the directory specified, or
change the specified directory to one that you do have access to.

Do one of the following:
* Click OK to save the preference values and close the Preferences dialog.

* Click Apply to save the preference values, but keep the Preferences dialog
open.

Starting the Order Entry Web application

20

Use the Web version of the Order Entry application to become familiar with
running a Web application using the Workbench.

The Order Entry sample application is installed with WebSphere Everyplace
Deployment. To start this Web application version, follow these steps:

1.

3.
4.

Select Application > Open > Order Entry Web Application to open the
application. This new perspective contains two views: Submit Order, and Order
Status.

To use the Order Entry Web Application, follow these steps:
Click Start.

Select a customer from the list.

Select New Order.

Select a quantity for cans and bottles and click Submit.

a0 op

e. Click Refresh to synchronize orders and update status.
Repeat this procedure to submit orders for any additional customers.
To close the application, select Application > Close from the main menu.
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Starting the Order Entry Rich Client application

Use the Rich Client version of the Order Entry application to become familiar with
running a Rich Client Platform application using the Workbench.

The Order Entry sample application is installed with WebSphere Everyplace
Deployment. To start the Rich Client application version, follow these steps:

1. Select Application > Open > Order Entry Rich Client Application. This new
perspective contains two views: Submit Order, and Order Status.

2. To use the application, follow these steps:
a. In the Submit Order view, select a customer from the list.

b. Select a quantity for cans and bottles and click Submit. The Order Status
view displays any existing orders for this customer. If orders are displayed,
the order status for those orders is also displayed.

c. Click Refresh to synchronize orders and update status.

3. To close the application, select Application > Close from the main menu.

Uninstalling the Order Entry application

After you have finished with this sample application, you can remove it from your
Workbench.

Follow these steps to remove the applications:

1. Select Manage > Application Management. This opens the Application
Management perspective.

2. Expand WebSphere Everyplace Deployment and select Order Entry Sample
6.0.0.

3. In the right hand panel, select the Uninstall task.

4. When prompted to restart your Workbench, ensure all other work in the
Workbench is saved, then select Yes.

Using the Order Entry sample application 21



22 IBM WebSphere Everyplace Deployment: User’s Guide



Uninstalling WebSphere Everyplace Deployment

To uninstall WebSphere Everyplace Deployment, do one of the following:

© Copyright IBM Corp. 2005

On a Linux system, select Start > Office > IBM WebSphere Everyplace
Deployment> WebSphere Everyplace Deployment 6.0.0 Uninstall.

On a Windows system:
1. Select Start > Settings > Control Panel > Add/Remove Programs.

2. Select IBM WebSphere Everyplace Deployment 6.0.0 and click
Change/Remove.

3. Follow the prompts to remove the application.

Alternatively, select Start > Programs > IBM WebSphere Everyplace
Deployment> WebSphere Everyplace Deployment 6.0.0 Uninstall.
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Getting help

The Help menu provides access to online help for the Workbench, as well as help
topics contributed by installed applications. To get help, select Help from the main
menu.

The first time that you search online help contents, the help system initiates an
index-generation process. This process builds the indexes for the search engine to
use. It may take several minutes, depending on the amount of documentation.
Results of the search are available when the indexing process is complete. Each
time you add or modify the documentation set (for example, when you install a
new feature or update an existing one), the index is updated to reflect the new
information set.

Using the help system

Use the help system to browse, search, and print online documentation for the
product.

To access help contents, select Help from the main menu.

Browsing

Browse topics in the Contents pane ( l.ﬂl ) on the left. Click a topic to display it.
Use the Back (':::' ) and Forward ( = ) buttons to navigate within the history of
viewed topics.

Searching

To search the entire online help, type a keyword or phrase in the Search field and

click Go (or press Enter). Use the Search tab (‘a-?.?'”) to display the Search view. Each
time that you add or modify the documentation set (for example, when you install
a new application), the search index is updated to reflect the new information.

By default, when you run an online search, the help system searches all
documentation installed with this product. To narrow the scope of your search,
click the Search scope link and then click the New button to refine the number
topics that you want to search.

After you run a search and find the topic you were looking for, click either the
Refresh / Show Current Topic button (':ﬂ-::i‘ ) or Show in Table of Contents button

(T:g,%') to match the navigation tree with the current topic. You might also find it
useful to synchronize after following in-topic links.

For further information, see [“Search expression rules” on page 26
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Printing

To print a topic from the online help, select the topic in the Contents pane and

then click the Print button (E=]).

Search expression rules

When using the help system’s search function, the following rules apply:

¢ Unless otherwise stated, there is an implied AND between all search terms. In
other words, topics that contain all the search terms will be returned. For
example: Disconnected Offline returns topics that contain the word
Disconnected and the word 0ffline, but does not return topics that contain only
one of these words.

* Use OR before optional terms. For example: Disconnected OR 0ffline returns
topics that contain the word Disconnected or the word 0ffline (or both).

* Use NOT before terms you want to exclude from search results. For example:
Disconnected NOT 0ffline returns topics that contain the word Disconnected
and do not contain the word 0ffline.

Note: NOT only works as a binary operator (that is, "NOT servlet” is not a valid
expression).

* Use a question mark (?) for a single-character wildcard and an asterisk (*) for a
multi-character wildcard. For example: par? returns topics that contain part or
park, but not participate. On the other hand: par=* returns topics that contain
part, park, participate, pardon, and so on.

Note: The search engine does not accept terms with a wild card at first character
position.
¢ Use double quotation marks around terms you want treated as a phrase. For
example: "Manage applications" returns topics that contain the entire phrase
manage applications, and not manage or application on its own.

* Punctuation acts as a term delimiter. For example: org.eclipse returns hits on
topics that contain org.eclipse, org, and eclipse, which is likely broader than
you want. If you want to find just those topics containing org.eclipse, use
double quotes, as in: "org.eclipse"

* The search engine ignores character case. For example: Workbench returns topics
that contain workbench, Workbench, WorkBench, and WORKBENCH.

Using the IBM Support Assistant

26

Use the IBM Support Assistant to submit service requests and gain access to a
wide-variety of useful IBM resources, including IBM Support Web links, product
Technotes, and newsgroups.

To use the IBM Support Assistant, follow these basic steps:
1. Click Help > IBM Support Assistant.
2. Select from the following tabs:

¢ Search—Search support and development resources for WebSphere
Everyplace Deployment and associated products. For example, you can
search for Technotes, forum postings, product downloads, IBM
developerworks articles, and more. To initiate a search, use the search
options box in the right pane and specify your search criteria. For example,
to search product defects, known as Authorized Program Analysis Reports
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(APARs), select IBM Software Support Documents > specific document
type > IBM APARs from the Search tab. To limit the scope of your search,
select specific product check boxes in the right-hand pane.

* Support Links—Access useful IBM Support links, including product pages,
support pages, and newsgroups. To review product support documentation,
select from a variety of product-related Web links.

* Service—Collect system data, submit an IBM service request, and then send
the data to IBM—all in a few easy steps. To get started, follow online
instructions to guide you through the process of submitting a service request
to IBM in the form of a Problem Management Record (PMR). This option has
the added benefit of allowing you to send important system data to IBM
along with your service request to expedite the resolution process. Internet
access is required.

¢ User Guide—Get detailed information about IBM Support Assistant desktop
software to help you find answers or address challenges as you use your
IBM software products.

Viewing product information

Use the About WebSphere Everyplace Deployment dialog to view information
about the installed platform and applications.

In addition to the conventional logo and version information, buttons to display
feature details, plug-in details, and configuration information are available.

To view WebSphere Everyplace Deployment product information, follow these
steps:

1. Click Help > About WebSphere Everyplace Deployment.
2. Select from the following buttons:

* Feature Details—Provides details about features currently installed. Installed
features include the base platform feature, as well as features provided by
application vendors that include a branding plug-in. Note that features
without branding plug-ins do not appear in this list.

* Plug-in Details —Provides details about the plug-ins that are currently
installed. For each plug-in listed, a More Info is enabled if additional
information is available, such as licensing or contact information.

* Configuration Details—Provides configuration information, including
system properties, installed features and plug-ins, and user preferences.

3. Click OK to close the About WebSphere Everyplace Deployment dialog.
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Appendix. Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

Some states do not allow disclaimer of express or implied warranties in certain
transactions, therefore, this statement may not apply to you. This information
could include technical inaccuracies or typographical errors. Changes are
periodically made to the information herein; these changes will be incorporated in
new editions of the publication. IBM may make improvements and/or changes in
the product(s) and/or the program(s) described in this publication at any time
without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.
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IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
Department LZKS
1400 Burnet Road
Austin, TX 78758
US.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee. The licensed program described in this
information and all licensed material available for it are provided by IBM under
terms of the IBM Customer Agreement, IBM International Program License
Agreement, or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM for the purposes of developing, using, marketing, or distributing application
programs conforming to IBM’s application programming interfaces.
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Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp.
Sample Programs. © Copyright IBM Corp. _enter the year or years_. All rights
reserved.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks

The following terms are trademarks or registered trademarks of International
Business Machines Corporation in the United States, or other countries, or both:

IBM
Everyplace
WebSphere

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

Linux is a trademark of Linus Torvalds in the United States, other countries, or
both.

Microsoft Windows and the Windows logo are trademarks of Microsoft
Corporation in the United States, other countries, or both.

Other company, product or service names may be trademarks or service marks of
others.
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