
© Copyright IBM Corporation 2007 All rights reserved 

IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE 

2007 March, 07  Page 1 of 30 

IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE 

 FTP Adapter Outbound Lab 

FTP Adapter Outbound Lab 

What this exercise is about ................................................................................................................................... 1 

Lab Requirements................................................................................................................................................. 1 

What you should be able to do ............................................................................................................................. 1 

Introduction ........................................................................................................................................................... 3 

Exercise Instructions ............................................................................................................................................. 4 

Part 1: Initialize  workspace and Import RAR file into WebSphere Integration Developer ................................... 5 

Part 2: Use ESD Wizard to Generate Business Objects and other Artifacts ........................................................ 8 

Part 3: Test the Adapter Application using WebSphere Process Server Test Environment .............................. 18 

Part 4: Restore Server Configuration.................................................................................................................. 28 

What you did in this exercise .............................................................................................................................. 30 

 

What this exercise is about 

The objective of this lab is to provide you with an understanding of the WebSphere® Adapter for FTP and 
outbound processing. In this lab you will deploy the WebSphere Adapter for FTP using WebSphere 
Integration Developer, and integrate it into an SCA application that processes outbound requests to the 
remote file system. 

Lab Requirements 

List of system and software required for the student to complete the lab 

• WebSphere Integration Developer V6.0.2 installed 

• WebSphere Process Server V6.0 Test Environment installed 

• WebSphere Adapter for FTP V6.0.2 installed 

• Unzip LabFiles602.zip to your C:\ (your root) drive 

• FTP server installed and configured 

What you should be able to do 

At the end of this lab you should be able to: 

• Import FTP adapter RAR file into WebSphere Integration Developer 

• Use Enterprise Service Discovery wizard to configure the FTP Managed Connection Factory 
Properties and Resource Adapter Properties to generate Business Objects and other artifacts 
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• Deploy the adapter application onto the WebSphere Process Server test environment 

• Test the above deployed application using WebSphere Process Server test environment  

• Restore the server configuration 
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Introduction 

 

The J2EE Client makes a SCA call by giving the outbound operation name and the input data object and 
then the custom data binding is called and it invokes other content-specific data binding based on the 
ContentType set in the child data object.  
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The protocol specific properties like directory Name, file name which are required during outbound 
operation are populated in the wrapper data object present in BG. These values are set on to the 
FTPFileUnstructuredRecord in the custom data binding and sent to the adapter. 

 

Exercise Instructions 

Some instructions in this lab may be Windows® operating-system specific.  If you plan on running the lab 
on an operating-system other than Windows, you will need to run the appropriate commands, and use 
appropriate files ( .sh vs. .bat) for your operating system.  The directory locations are specified in the lab 
instructions using symbolic references, as follows: 

Reference Variable Windows Location AIX®/UNIX® Location 

<WID_HOME> C:\Program Files\IBM\WebSphere\6.0  

<WPS_HOME> <WID_HOME>\runtimes\bi_v6  

<FFADAPTER_HOME> C:\Program 
Files\IBM\ResourceAdapters\FTP\adapter\FTP 

 

<LAB_FILES> C:\Labfiles602 /tmp/Labfiles60 

<WORKSPACE> C:\LabFiles602\FTPOutbound\workspace  

<TEMP> C:\temp /tmp 

Windows users note : When directory locations are passed as parameters to a Java™ program such as 
EJBdeploy or wsadmin, it is necessary to replace the backslashes with forward slashes to follow the Java 
convention. For example, C:\LabFiles602\ would be replaced by C:/LabFiles602/ 
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Part 1: Initialize  workspace and Import RAR file i nto WebSphere 
Integration Developer 

This part of the lab will guide you through the steps for starting WebSphere Integration Developer with a 
new workspace, and then import the connector file CWYFT_FTPFile.rar  into your new workspace. 

____ 1. Start WebSphere Integration Developer V6.0.2 with a new workspace 

o Select Start > Programs > IBM WebSphere > Integration Deve loper V6.0.2 
> WebSphere Integration Developer V6.0.2  

o From the Workspace Launcher window, enter <WORKSPACE>  for the 
Workspace field 

 

o Click on the  button on the right hand corner to close the Welcome page 
and proceed with the workbench 
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____ 2. Import FTP Adapter RAR file 

o From main menu, select File > Import…  

 

o Select RAR file  from the Import window and then click Next  
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o Click on the Browse…  button next to the Connector file  field to select the 
CWYFT_FTPFile.rar  

o Uncheck the check box next to Add module to and EAR  project  and click 
Finish  

 

o Click on No from Confirm Perspective Switch window to continue with the 
Business Integration perspective 

 

____ 3. Create directory structure on your FTP Server 

o Log onto your FTP Server using your ftpuser and password 

o Create an Output directory named Outputdir  under the user’s home directory 

� mkdir Outputdir 
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Part 2: Use ESD Wizard to Generate Business Objects  and other Artifacts 

____ 1. Launch the Enterprise Service Discovery wizard 

__ a. Select File > New > Enterprise Service Discovery  

 

____ 2. Select IBM WebSphere Adapter for FTP (version 6.0.1) from the ‘CWYFT_FTPFile’ Connector 
Project  and click Next  

 

____ 3. Configure settings for the Discovery agent 

You will specify the properties to initialize the Resource Adapter and Enterprise Service Discovery agent 
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__ a. Click Browse…  button next to the Folder Name  field and select the folder 
<FTPADAPTER_HOME>\samples  that contains the XSD file for Customer  Business Object 

Note : For your convenience, the Customer.xsd  is also placed under <LAB_FILES>\FTPFiles.  

__ b. Select Big5  from the drop down list for the Character Set  field 

__ c. Select text/xml  for the Content Type  field. Once the content type is selected, the DataBinding 
Type  will be automatically set to XMLBOSerializerDataBinding  

__ d. Click the Show Advanced >>  button to see the Log file location and Logging level options for 
discovery log and click Next  leaving the default log file location 
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____ 4. Find and discover the enterprise services. In this step you will select the business objects and 
services to be used with the adapter 

__ a. From the Enterprise Service Discovery window, click on Execute Query  button. You will see a 
Custome r business object under Objects discovered by query  

__ b. Select Customer  business object and click Add to import list  button. The Customer business 
object will now be displayed under the Objects to be imported  

 

__ c. Click Next  

____ 5. Configure the objects that will be imported by the discovery agent 

__ a. From the Configure objects window, select Outbound  from the dropdown menu for the Service 
Type . Note the operations available for the selected Service Type 



© Copyright IBM Corporation 2007. All rights reserved 

IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE 

2007 March, 07 IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE Page 11 of 30 

 FTP Adapter Outbound Lab 

__ b. Enter the BO Location  as FTPOutBO  and click Next  

 

____ 6. Specify the properties for the artifacts that will be generated in your workspace 

__ a. Create a new module 

1) Click on the New… button next to the Module  field 
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2) From the New Integration Project window, ensure that the radio button next to Create a 
module project  is selected and click Next  

 

3) Enter FTPOutboundModule  for the Module Name field and click Finish  
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__ b. The module which is created above will appear under the Module  field of the Generate Artifacts 
window 

 

__ c. From the Generate Artifacts window, select the radio button next to Use discovered connection 
properties . This will make the FTP Adapter Managed Connection Factory and Resource 
Adapter Properties visible 

__ d. Enter the following fields under the FTP Adapter Managed Connection Factory Properties: 

1) FtpUrl: ftp://<FTP Server IP Address>  

2) UserName: <user>  (username using which you connect to your FTP machine) 

3) Password: <password>  (password for the above user to connect to your FTP machine) 

4) EisEncoding: Big5  (from the drop down menu) 
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__ e. Enter the following fields under Resource Adapter Properties: 

1) LogFilename: C:\FTPRA\outlog.txt  

2) TraceFilename: C:\FTPRA\outtrace.txt  
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__ f. Click Finish  

____ 7. You can also configure/change the adapter properties using Assembly Editor 

__ a. Change to the Business Integration perspective if not open 

1) Select Window > Open Perspective > Other… . 

 

2) From the Select Perspective window, select Business Integration (default)  and click OK 

 

__ b. Expand FTPOutboundModule  and double-click FTPOutboundModule to open it in Assembly 
Editor 

 

__ c. Click on FTPFileOutboundInterface  from the Assembly Editor and select Properties  tab from 
the bottom 

__ d. Select Binding  under Properties and select Endpoint Configuration  under Binding itself and 
then select the Connection  tab 
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1) Ensure the radio button next to Specify properties for pre-configured new J2EE 
Connector Architecture recourse  is selected and then c lick on Managed Connection 
Factory Properties  to expand it. You can change the properties that you entered using the 
ESD wizard in the previous steps and save those changes before you deploy the 
application onto the server 
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2) Click on Resource Adapter  tab to view/change the Resource Adapter Properties 
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Part 3: Test the Adapter Application using WebSpher e Process Server 
Test Environment 

In this part of the lab, you will use the WebSphere Process Server Test Environment to test the SCA 
application outbound processing. 

FTP adapter supports the following outbound operations: 

Create  –file with the specified name is created in the specified directory of the FTP Server. The content of the 
file can be given as either a part of the request from the client of it can be picked from the local file system 
where the adapter is running according to the configuration. If the file to be created already exists, an 
FTPFileCreateException is thrown. Existing file is not overwritten. 

Append  – the file with specified name in the specified directory of the FTP Server is appended with the 
content sent across in the request. If the file to be appended doesn’t exist, an FTPFileAppendException is 
thrown to the calling component. 

Delete  – deletes the file from the specified directory in the FTP Server. If the file to be deleted doesn’t exist, an 
FTPFileDeleteException is thrown to the calling component. 

Retrieve  – response returns the content of the file(s) which is/are specified in the request. The file names are 
input as comma separated in a Filename attribute. If the file doesn’t exist, an FTPFileRetrieveException is 
thrown to the calling component. 

Overwrite  – overwrites the file in the directory with the content specified in the request. If the file to be updated 
doesn’t exist, an FTPFileOverwriteException is thrown to the calling component. 

Exists  - checks the existence of a file. Returns true if the file name in the request exists in the specified 
directory and returns false if either directory or file name doesn’t exist. 

List  - returns all the file names in the all directories specified in the request. If the directory specified doesn’t 
exist, an FTPFileListException is thrown to the calling component. 

ServerToServerFileTransfer –transfers the specified file from a directory of one FTP server to a directory of 
another FTP server. If all the details of the two servers are not specified, an 
FTPFileServerToServerFileTransferException is thrown. 

ExecuteFTPScript  –executes the commands present in a FTP script file, which exists on the local machine 
where adapter is installed. The location of the script file is given in DirectoryPath and Filename attributes of the 
FTPFileUnstructuredRecord.  This operation executes only the commands supported by FTP Server. 
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____ 1. Add the project to the server for the WebSphere Process Server Test Environment 

__ a. Right-click on WebSphere Process Server v6.0  under the server view and select Add and 
remove projects…  from the context menu 

 

__ b. From the Add and Remove Projects window, select FTPOutboundModuleApp  under Available 
projects panel and click Add >  
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__ c. You will now see the FTPOutboundModuleApp  added to the Configured projects . Click 
Finish  

 

Wait for the project to be added to the server and the application to start. The server will be started in 
Debug mode if it is not already started before. 
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____ 2. Test Scenario : outbound for createCustomer  operation (Non_PassThrough) 

__ a. Right-click the FTPOutboundModule  and select Test > Test Module  from the context menu 
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__ b. The FTPOutboundModule_Test editor will be opened in Assembly Editor 

 

__ c. Under Detailed Properties , for the Operation  field, select createCustomer  from the drop down 
list 
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__ d. Fill out the fields for Initial request parameters : 

1) DirectoryPath: <Outputdir>  

Note : Outputdir is the output directory that you created in Step 3 of Part 1. 

2) Filename: Customer.xml  

3) Give any values for the fields (CustomerName, Address, City, and State) under Content 

 

o Click Continue  
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o From Deployment Location window, select WebSphere Process Servers > 
WebSphere Process Server v6.0 and click Finish  
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__ e. Click on the Invoke (FTPFileOutboundInterface:createCustomer)  and you will see a window 
similar to the following, that contains the data you just entered in the previous steps: 

 

__ f. To verify the results, check the Outputdir  folder on the machine where you have FTP server. You 
should have a Customer.xml  file created under that directory with the following contents: 

 

____ 3. Test Scenario : outbound for createFTPFile  operation (PassThrough) 

__ a. Click on Invoke button  at the top from the FTPOutboundModule_Test window 

__ b. FTPOutbpoundModule_Test  window will be opened in Assembly Editor 

__ c. Under Detailed Properties , for the Operation  field, select createFTPFile  from the drop down 
menu 

__ d. Fill out the fields for Initial request parameters : 

1) DirectoryPath: <Outputdir>  

Note : Outputdir is the output directory that you created in Step 3 of Part 1. 
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2) Filename: ftptest.txt  

� On the row that contains Content , under Type and select browse 
button and then select UnstructuredContent  from the Data Type 
Selection window 

3) Enter some string data for AsText  field 

 

__ e. Click Continue  
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o Click on the Invoke (FTPFileOutboundInterface:createFTPFile)  and you will 
see a window similar to the following, that contains the data you just entered 
in the previous steps: 

 

__ f. To verify the results, check the Outputdir  folder on the machine where you have FTP server. You 
should have the ftptest.txt  file created under that directory with the following contents: 
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Part 4: Restore Server Configuration 

____ 1. Close the FTPOutboundModule_Test  window and click No for the Save Resources window 

 

____ 2. Right-click on WebSphere Process Server v6.0  under the Servers view and select Add and 
remove projects…  from the context menu 

 

____ 3. Select FTPOutboundModuleApp  under Configured projects and click < Remove  
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____ 4. Click Finish  after you see the application moved to Available projects. Wait until the application is 
unpublished 

____ 5. Right-click on WebSphere Process Server v6.0  from the Servers view and select Stop  from the 
context menu 

 

 



© Copyright IBM Corporation 2007. All rights reserved 

IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE 

2007 March, 07 IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE Page 30 of 30 

 FTP Adapter Outbound Lab 

What you did in this exercise 

In this lab, you imported the FTP Adapter RAR file into your WebSphere Integration Developer workspace 
and integrated it into an SCA application that creates a file to the file system. 

You made use of Enterprise Service Wizard available in WebSphere Integration Developer to specify 
Managed Connection Factory Properties and Resource Adapter Properties which, after deploying onto the 
server will generate Business Objects and other artifacts.  

In the end you deployed and then tested the adapter application for the operations available.  

 


