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What this exercise is about 

The objective of this lab is to provide you with an understanding of how to configure Adapters for Custom 
Data Bindings. In this lab you will use three custom data bindings – Delimited, NameValue, and 
FixedWidth. 

Lab requirements 

List of system and software required for the student to complete the lab. 

• WebSphere Integration Developer V6.0.2 installed 

• WebSphere Process Server V6.0.2 Test Environment installed 

• WebSphere Adapter for Flat File V6.0.2 installed 

• Unzip LabFiles602.zip to your C:\ (your root) drive 

What you should be able to do 

At the end of this lab you should be able to: 

• Configure and test FlatFile Adapter Inbound operation for Delimited custom bindings 

o Use ESD to configure FlatFile Adapter for inbound operation to process Delimited files 

o Create Java Component with an Interface 

o Create required Data maps and Interface map 

o Use WebSphere Integration Developer test environment to test the Delimited inbound 
scenario 

• Configure and test FlatFile Adapter Outbound operation for NameValue custom bindings 

o Use ESD to configure FlatFile Adapter for outbound operation to process NameValue files 

o Create required Data maps and Interface map 

o Use WebSphere Integration Developer test environment to test the NameValue outbound 
scenario 

• Configure and test FlatFile Adapter Outbound operation for FixedWidth custom bindings 

o Use ESD to configure FlatFile Adapter for outbound operation to process FixedWidth files 

o Create required Data maps and Interface map 

o Use WebSphere Integration Developer test environment to test the FixedWidth outbound 
scenario 

• Test FlatFile Adapter for both Inbound and Outbound with one Module 

 



© Copyright IBM Corporation 2007. All rights reserved 

IBM WebSphere Adapter 6.0.2 – Lab Exercise 

2007 January, 19 IBM WebSphere Adapter 6.0.2 – Lab Exercise Page 3 of 82 

 Flat File Adapter Custom Data Bindings Lab 

Introduction 

This lab provides the steps to test the FlatFile adapter for three different Custom Data Bindings – 
Delimited, NameValue and FixedWidth. This lab guides you to configure FlatFile Adapter to process 
Delimited files in its inbound operation and NameValue and FixedWidth files in its outbound operation. 

 

Exercise instructions 

Some instructions in this lab may be Windows operating-system specific.  If you plan on running the lab on 
an operating-system other than Windows, you will need to run the appropriate commands, and use 
appropriate files (.sh vs. .bat) for your operating system.  The directory locations are specified in the lab 
instructions using symbolic references, as follows: 

Reference Variable Windows Location AIX/UNIX Location 

<WID_HOME> C:\Program Files\IBM\ID\6.0  

<WPS_HOME> <WID_HOME>\runtimes\bi_V6  

<FFADAPTER_HOME> C:\Program 
Files\IBM\ResourceAdapters\FlatFiles\adapter\FlatFile 

 

<LAB_FILES> C:\Labfiles602  

<WORKSPACE> <LAB_FILES>\DTF\workspace  

<EVENT_DIR> <LAB_FILES>\DTF\EventDir  

<ARCHIVE_DIR> <LAB_FILES>\DTF\ArchiveDir  

<DATA_DIR> <LAB_FILES>\DTF\DataDir  

<STAGING_DIR> <LAB_FILES>\DTF\StagingDir  

<TEMP> C:\temp /tmp 

Windows users note : When directory locations are passed as parameters to a Java program such as 
EJBdeploy or wsadmin, it is necessary to replace the backslashes with forward slashes to follow the Java 
convention. For example, C:\LabFiles602\ would be replaced by C:/LabFiles602/ 
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Part 1: Preparation for the lab 

In this part, you will create the required Database in cloudscape, data source using Administrative console 
and the directory structure. You will also import the FlatFile RAR file, source code, and the Business 
Objects into the project that will be created in this part. 
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1.1. Create database and subdirectory structure  

This part of the lab, describes the steps for creating the DTFDATABASE  database in Cloudscape which 
will contain the Event Persistence Table, DTFTABLE .  The DTFTABLE  will be created automatically for 
you during the install and deployment of the application containing the Flat File adapter to the WebSphere 
Process Server. 

____ 1. Start the Cloudscape Cview Graphical User Interface (GUI) by executing the cview.bat file 

__ a. Open a command prompt window, change to the following subdirectory 
<WPS_HOME>\cloudscape\bin\embedded 

 

__ b. Type cview.bat  

 

__ c. The Cview window will be opened. From that window, select File > New > Database… . 
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__ d. Enter DTFDATABASE  in the Name field and click OK 

 

You will see the DTFDATABASE  created in the left pane of the Cview window: 

 

__ e. Select File > Exit  to close the Cview GUI 

____ 2. Unzip the provided LabFiles602.zip to your C:\ (root) drive, if you have not already done so.  This 
will create the necessary subdirectory structure to complete the lab, and also provides you with 
sample text files. 
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1.2. Create module and import flat file RAR 

____ 1. Create CustomBindingProcessing module 

__ a. Start the WebSphere Integration Developer V6.0.2 with a new workspace if not already started. 

1) Select Start > Programs > IBM WebSphere > Integration Deve loper V6.0.2 > 
WebSphere Integration Developer V6.0.2  

2) From the Workspace Launcher window, enter <WORKSPACE>  for the Workspace field 

3) Click on the  button on the right hand corner to close the Welcome page and proceed 
with the workbench 

 

__ b. From the main menu, select File > New > Project  

__ c. From New Project window, select Module  and click Next  

 

__ d. Create New Module for the scenario 

1) From the New Module window, enter CustomBindingProcessing  for the Module Name , 
uncheck Open module assembly diagram  
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2) Click Finish  

You should see the CustomBindingProcessing module listed in the Business Integration perspective 

____ 2. Import FlatFile RAR into CustomBindingProcessing Module 

__ a. From the main menu, select File > Import  

__ b. From the Select screen, select RAR File  and click Next  

__ c. Enter the following for the Connector Import screen 

1) Connector file:  Click on Browse…  button and select CWYFF_FlatFile.rar  from 
<FFADAPTER_HOME>  

2) EAR project:  Click on the drop down arrow and select CustomBindingProcessingApp  
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3) Click Finish  

__ d. Select Yes from Confirm Perspective Switch window to continue with the J2EE Perspective 

Note : You can also change to the J2EE perspective from the main menu: select Window > Open 
Perspective > Other and then select J2EE from the Select Perspective window. 

__ e. Modify FlatFileASI.xsd with the binding metadata information 

1) From the Project Explorer, expand Connector Projects > CWYFF_FlatFile > connector 
Module   

 

2) Right-click on FlatFileASI.xsd  and select Open With > Text Editor  to open it in text editor 

3) Add following highlighted piece of binding metadata information to FlatFileASI.xsd. This 
code can be added between XMLBOSerializerDataBindingMetadata  and 
DataTransformationMetadata as shown. 
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Note : For your convenience, the metadata information to be added is provided in the file 
BindingMetadata.txt  under <LAB_FILES>\DTF   

 

__ f. Save (Ctrl + S ) your changes to FlatFileASI.xsd and close it by clicking on the X 

__ g. Change to Business Integration Perspective 

1) Select Window > Open Perspective > Other…  

2) Select Business Integration and click OK 
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1.3. Use WebSphere Process Server Administrative Co nsole to 
configure data sources 

In this part of the lab, you will make use of WebSphere Process Server Administrative Console to create 
the required JDBC Provider and the Data source that will be used by the Adapter to configure itself to the 
end point. 

____ 1. Start the WebSphere Process Server 

__ a. Select the Servers view 

__ b. Right-click on the row that contains WebSphere Process Server V6.0  and select Start  from the 
context menu 

 

__ c. Wait until the server status shows as Started  

____ 2. Right-click on the row that contains WebSphere Process Server V6.0 and select Run 
administrative console  from the context menu 

 

____ 3. From the Administrative Console, enter any User ID  and click on Log In  
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____ 4. Expand Resources  on the left pane and select JDBC Providers  

 

____ 5. Accept the default scope and click on New 

____ 6. In the following screen, for General Properties, select the following from the dropdown list: 

__ a. Step 1: Cloudscape  

__ b. Step 2: Cloudscape JDBC Provider  

__ c. Step 3: XA data source  

____ 7. Click Next  
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____ 8. Enter Cloudscape JDBC Provider (XA) for DTF  in the Name field and then click OK 

 

____ 9. Click Save on the top of the window, and then click on Save from the following screen 

____ 10. Click Cloudscape JDBC Provider (XA) for DTF  from the following screen to create a new data 
source 

____ 11. Select Data sources  under Additional Properties  on the right hand side 

 

____ 12. Create the required JNDI Data source 

__ a. Click New 

__ b. Enter these values: 

a) Name: Cloudscape JDBC Driver XA DataSource for DTF  

b) JNDI Name: jdbc/DTF  

c) Database name: DTFDATABASE  
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__ c. Click OK 
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____ 13. Click on Save and then Save from the following screens 

____ 14. Test the Data Source connection 

__ a. Check the box next to Cloudscape JDBC Driver XA DataSource  for DTF  and click on Test 
connection  from the top of the screen 

 

__ b. You should see the following success message on the top of the screen: 

 

____ 15. Log out of the Administrative Console and close it 
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1.4. Import custom bindings source code 

____ 1. From main menu, select File > Import  

____ 2. select File System  from the list in the Select screen and click Next  

____ 3. Enter the following for the File system screen 

__ a. From Directory : Click on Browse and select <LAB_FILES>\DTF\src.  

__ b. Click OK 

__ c. Expand src  and add a checkmark next to com as shown.  

__ d. Into Folder : Click on Browse and an Import Into Folder window will be opened 

__ e. Select CustomBindingProcessing and click OK 

__ f. Click Finish  from the Import window 

 

Note : Ignore the errors that you will see after this step. There errors will be resolved in the following steps 
as you continue with the lab. 
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1.5. Import and review business objects 

In this part you will import the required business objects – Address, Customer, FFDelimitedAddress, 
FFDelimitedCustomer, FFNameValueAddress, FFNameValueCustomer, FFFixedWidthAddress, and 
FFFixedWidthCustomer and then review the attributes of each of those Business Objects.  

____ 1. From main menu, select File > Import  

____ 2. select File System  from the list in the Select screen and click Next  

____ 3. Enter the following for the File system screen 

__ a. From Directory : Click on Browse and select <LAB_FILES>\DTF\XSDs. Click OK. 

__ b. Click on Select All to select all the .xsd files on the right side window 

__ c. Into folder : Click on Browse and an Import Into Folder window will be opened 

__ d. Select CustomBindingProcessing and click OK 

____ 4. Click Finish  from the Import window 

 

____ 5. Review the imported Business objects 

__ a. From the Business Integration view, expand CustomBindingProcessing > Data Types and 
observe the imported Data Types 
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__ b. Review Customer and Address BOs 

1) Double-click on Customer  to open it in the Business object editor on the right side. Expand 
Address  from the Customer BO editor window on the right side. 

 

2) Click on X next to Customer to close it 

__ c. Review FFDelimitedCustomer and FFDelimitedAddress BOs 

1) Double-click on FFDelimitedCustomer  to open it in the Business object editor on the right 
side. Expand FFDelimitedAddress  from the FFDelimitedCustomer BO editor window on 
the right side. 

2) Click on X next to FFDelimitedCustomer to close it 
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__ d. Review FFFixedWidthCustomer and FFFixedWidthAddress BOs 

1) Double-click on FFFixedWidthCustomer  to open it in the Business object editor on the 
right side. Expand FFFixedWidthAddress  from the FFFixedWidthCustomer BO editor 
window on the right side. 

 

2) Click on X next to FFFixedWidthCustomer to close it 

__ e. Review FFNameValueCustomer and FFNameValueAddress BOs 

1) Double-click on FFNameValueCustomer  to open it in the Business object editor on the 
right side. Expand FFNameValueAddress  from the FFNameValueCustomer BO editor 
window on the right side. 



© Copyright IBM Corporation 2007. All rights reserved 

IBM WebSphere Adapter 6.0.2 – Lab Exercise 

2007 January, 19 IBM WebSphere Adapter 6.0.2 – Lab Exercise Page 20 of 82 

 Flat File Adapter Custom Data Bindings Lab 

 

2) Click on X next to FFNameValueCustomer to close it 
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Part 2: Inbound configuration - Delimited 

In this part, you will perform these main tasks: 

• You will use Enterprise Service Discovery (ESD) wizard to generate the 
FlatFileDelimitedInboundInterface, and also the artifacts – FFDelimitedCustomerWrapper, 
FFDelimitedCustomerWrapperBG and so forth. 

• You will create an Interface, CustomerInterface, which you will add to the Java component, 
ProcessComponent. 

• You will create these maps: 

o Data maps – FFDelimitedAddressToAddress, FFDelimitedCustomerToCustomer, and 
FFDelimitedCustomerWrapperBGToCustomer 

o Interface Map – DelimitedCustomerToCustomer 

• You will test the adapter for the Delimited Inbound scenario 
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2.1. Run ESD to create inbound interface and other artifacts 

____ 1. Launch the Enterprise Service Discovery wizard 

__ a. From the top Menu bar, select File > New > Enterprise Service Discovery  

____ 2. Select IBM WebSphere Adapter for Flat Files (version 6.0.2 ) from the ‘CWYFF_FlatFile’ 
Connector Project and click Next  

 

____ 3. Enter the following for the Configure Settings for Discovery Agent screen 

__ a. Folder Name : Click on Browse and select <WORKSPACE>\CustomBindingProcessing and 
then click OK. 

__ b. For Character set,  select UTF-8 from the drop down menu. 

__ c. Content Type : Select text/delimited1  from the drop down menu and the DataBinding Type  will 
automatically be selected as the Delimited1DataBinding  

__ d. Enter the following for the DataBindingProperties 

1) TargetNameSpace: http://www.ibm.com/crm  

2) Delimiter: , 

__ e. Click on Show Advanced  to see the logging properties. Note the Log file output location . 
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__ f. Click Next  

____ 4. Find and discover the enterprise services. In this step you will select the business objects and 
services to be used with the adapter 

__ a. From Find and Discover Enterprise Services window, click on Execute Query  button. You will 
see all the business objects the you imported  under Objects discovered by query  
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__ b. Select FFDelimitedCustomer  business object and click >>Add to import list  button. The 
Customer business object will now be displayed under the Objects to be imported  

 

__ c. Click Next  

____ 5. Configure the objects that will be imported by the discovery agent 

__ a. From the Configure objects window, for the Service Type, select Inbound  from the dropdown 
menu. 

 

__ b. Click Next  

____ 6. Enter the following on the Generate Artifacts window 
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__ a. Enter the following for Properties for Interface  

1) For Module,  ensure that CustomBindingProcessing  is selected. 

2) Name: Enter  FlatFileDelimitedInboundInterface  

 

__ b. Ensure that Use discovered connection properties  radio button is selected 

 

__ c. Enter the following for FlatFile Properties  

1) Event Directory: <EVENT_DIR> 

2) Archive Directory: <ARCHIVE_DIR> 

3) DataSource JNDI Name: jdbc/DTF  

4) Event Table Name: CustomDataBinding  

5) Event Content Type: text/delimited1  

6) Default Object Name: FFDelimitedCustomerWrapperBG  
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__ d. Enter the following for ResourceAdapterProperties  

1) Log file name: C:\FFRA\DTF\Inlog.txt  

2) Trace file name: C:\FFRA\DTF\Intrace.txt  
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__ e. Click Finish  

__ f. From Business Integration window, expand CustomBindingProcessing > Data Types  

__ g. Right-click on FFDelimitedCustomer  and select Open With > Text Editor  to open it 

__ h. Delete the following line highlighted in blue with include statement: 

 

__ i. Save (Ctrl+S ) your changes and close FFDelimitedCustomer BO 

Note : You should not see any errors at this point. Ignore any exceptions. 
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2.2. Create Java component with an interface 

____ 1. Create Interface 

__ a. From Business Integration window, expand CustomBindingProcessing > Interfaces  

__ b. Right-click on Interfaces  and select New > Interface  

 

__ c. From New Interface Wizard, for Name enter CustomerInterface  and click Finish  

 

__ d. Add processCustomer  one way operation 

1) Click on Add one way operation ( ) icon 

2) Replace operation1 with processCustomer  

3) Replace input1 with customer for Name 

4) Click on string  under Type and select Customer  from the context menu 
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__ e. Repeat step d to add appendCustomer  one way operation 

__ f. Add Request Response Operation, existsCustomer  

1) Click on Add Request Response Operation  ( )icon 

2) Replace operation1 with existsCustomer  

3) Replace input1 with customer  for Name 

4) Click on string  under Type and select Customer  from the context menu 

5) Replace output1 with response for Name 

6) Leave the Type as string  

You should see the following screen after you are done with creating all the three operations 

 

__ g. Save (Ctrl+S ) your changes and close CustomerInterface 

____ 2. Create Java Component 

__ a. Open Assembly diagram for CustomBindingProcessing 

1) From Business Integration window, Expand CustomBindingProcessing > Assembly 
Diagram  and double-click on CustomBindingProcessing  to open the in Assembly 
diagram editor 
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__ b. From the diagram window, click on the icon for Component (with no implementation type). 
select Java  component from the context menu icon then click in the Assembly Diagram’s empty 
space to drop it there 

__ c. Rename Component1 to ProcessComponent  

__ d. Right-click on ProcessComponent  and select Add > Interface from the context menu 

 

__ e. Select the radio button show WSDL  

__ f. Select CustomerInterface  from the Matching interfaces section 

 

__ g. Click OK 

__ h. Save (Ctrl+S ) your changes and close the Assembly Diagram: CustomBindingProcessing 
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2.3. Create data and interface maps 

____ 1. Create FFDelimitedAddressToAddress map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  

__ b. Right-click on Data Maps  and select New > Business Object Map  

 

__ c. From the Business Object Map screen, for the Name field, enter 
FFDelimitedAddressToAddress   

 

__ d. Click Next  

__ e. Select the following from the Business Object Map screen 

1) Under Inputs  section, select the check box for FFDelimitedAddress   

2) Under Outputs  section select the check box for Address   
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3) Click Finish  

The FFDelimitedAddressToAddress map will be opened for transformation. Ignore the error that you will 
see at this point. It will be resolved in the following step. 

__ f. Add a connection from the id field of FFDelimitedAddress business object to the id field  of 
Address business object 

To perform this step, hover your mouse over the id  field of FFDelimitedAddress business object and click 
on Add connection  then click on the id  field of Address business object. Using the same method, add the 
following connections: 

 

__ g. Save (Ctrl +S ) your changes and close the FFDelimitedAddressToAddress map 
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Note : You should not see any errors at this point. Ignore any exceptions. 

____ 2. Create FFDelimitedCustomerToCustomer map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  

__ b. Right-click on Data Maps  and select New > Business Object Map  

__ c. For the Name field, enter FFDelimitedCustomerToCustomer  and click Next  

__ d. From the Business Object Map screen, select the following 

1) Under Inputs , select the check box for FFDelimitedCustomer   

2) Under Outputs , select the check box for Customer  

3) Click Finish  

The FFDelimitedCustomerToCustomer map will be opened for transformation. Ignore any errors that you 
will see at this point. They will be resolved in the following step. 

__ e. Add the following connections 

 

__ f. Click on 4 Submap   

__ g. From the bottom window, click the Properties  tab. 

__ h. Click on Details   

__ i. For Business object map field, select FFDelimitedAddressToAddress  from the drop down menu 

 

__ j. Save (Ctrl+S ) your changes and close the FFDelimitedCustomerToCustomer map 

Note : You should not see any errors at this point. Ignore any exceptions. 

____ 3. Create FFDelimitedCustomerWrapperBGToCustomer map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  
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__ b. Right-click on Data Maps  and select New > Business Object Map  

__ c. For the Name field, enter FFDelimitedCustomerWrapperBGToCustomer   and click Next  

__ d. From the Business Object Map screen, select the following 

1) Under Inputs , select the check box for FFDelimitedCustomerWrapperBG   

2) Under Outputs , select the check box for Customer  

3) Click Finish  

The FFDelimitedCustomerWrapperBGToCustomer map will be opened for transformation. Ignore any 
errors that you will see at this point. They will be resolved in the following step. 

__ e. Add the following connection 

 

__ f. Click on 1 Submap   

__ g. From the bottom window, click the Properties  tab. 

__ h. Click on Details  

__ i. For Business object map field, select FFDelimitedCustomerToCustomer  from the drop down 
menu 

__ j. Save (Ctrl+S ) your changes and close the FFDelimitedCustomerWrapperBGToCustomer map 

Note : You should not see any errors at this point. Ignore any exceptions. 

____ 4. Create DelimitedCustomerToCustomer Interface Map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  

__ b. Right-click on Interface Maps  and select New > Interface Map  
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__ c. For the Name field, enter DelimitedCustomerToCustomer   

 

__ d. Click Next  

__ e. Select FlatFileDelimitedInboundInterface  for Source interface  and CustomerInterface  for 
Target interface  and click Finish  
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DelimitedCustomerToCustomer Interface map will be opened for mapping. Ignore any errors at this point.  
They will be resolved in the following step. 

__ f. Create mapping from emitFFDelimitedCustomerWrapper  field of 
FlatFileDelimitedInboundInterface to processCustomer  field of CustomerInterface 

 

__ g. Click on the mapping line under Operation mappings to see the Parameter mappings  

__ h. Create mapping from emitFFDelimitedCustomerWrapperInput  to customer  

 

__ i. Click on move    

__ j. From Properties view, select Description  then select map  from the drop down menu for the 
Parameter Mapping Type  field 

__ k. From Properties  view, select Details  tab and then 
FFDelimitedCustomerWrapperBGToCustomer  from the drop down menu for the Business 
Object Map  field 
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__ l. Save (Ctrl+S ) your changes and close the DelimitedCustomerToCustomer interface map window 

Note : You should not see any errors at this point. Ignore any exceptions 

____ 5. Wire the components 

__ a. Open the Assembly diagram for CustomBindingProcessing  

__ b. Select CustomBindingProcessing > Mapping > Interface Maps > 
DelimitedCustomerToCustomer and drop it in the Assembly diagram 

__ c. Add a wire from FlatFileDelimitedInboundInterface to DelimitedCustomerToCustomer 

1) Click on FlatFileDelimitedInboundInterface , select Add wire  and then click on 
DelimitedCustomerToCustomer  

2) Click OK for the following pop up window: 
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__ d. Add a wire from DelimitedCustomerToCustomer to ProcessComponent 

1) Click on DelimitedCustomerToCustomer , select Add wire  and then click on 
ProcessComponent  

You will see the following in the Assembly diagram 

 

__ e. Save (Ctrl+S ) your changes and close the Assembly Diagram: CustomBindingProcessing 
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2.4. Run intermediate test 

Note : Refer to the Appendix: Troubleshooting Tips  at the end of this lab for any exceptions/errors that 
you might see while running the intermediate test. 

____ 1. Generate Implementation for ProcessComponent 

__ a. From the CustomBindingProcessing  assembly diagram, right-click on ProcessComponent  
and select Generate Implementation  

__ b. Select default package  from the Generate Implementation window and click OK 

 The ProcessComponentImpl.java window will be opened. 

__ c. Add the following to the processCustomer method: 

 

__ d. Save (Ctrl+S ) your changes and close ProcessComponentImpl.java 

__ e. Save (Ctrl+S ) your changes in the Assembly Diagram 

____ 2. Start the WebSphere Process Server (if it is not already started) 

__ a. Select the Servers view 

__ b. Right-click on the row that contains WebSphere Process Server V6.0  and select Start  from the 
context menu 

__ c. Wait until the server status shows as Started  

____ 3. Add the project to the WebSphere Test Environment server 

__ a. Right-click on WebSphere Process Server V6.0  under the Servers view and select Add and 
remove projects…  from the context menu 

__ b. From the Add and Remove Projects window, select CustomBindingProcessingApp  under 
Available projects panel and click Add >  

__ c. You will now see the CustomBindingProcessingApp  added to the Configured projects  

__ d. Click Finish  and wait until the project is being published onto the server. The server will be 
started in Debug mode if it is not already started before 

____ 4. Test the adapter application 

__ a. Copy a test file to the <EVENT_DIR>. As the file is copied to the event directory, the same will 
be picked up and processed by the adapter and will be moved to the <ARCHIVE_DIR>  

Note : For your convenience, a test file named Delimited.txt  file can be found in <LAB_FILES>\DTF . 

____ 5. Verify your test results 
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__ a. Check your test environment console (or SystemOut.log file) for the following successful 
message: 

 

__ b. Now, check the <ARCHIVE_DIR> subdirectory which should contain an archive of the event file, 
with the same file name appended with year, month, date, system time, and success 

 

____ 6. Restore the Sever Configuration 

__ a. Right-click on WebSphere Process Server V6.0  under the Servers view and select Add and 
remove projects…  from the context menu. 

__ b. Select CustomBindingProcessingApp  under Configured projects and click < Remove  

__ c. Click Finish  after you see the application moved to Available projects. Wait until the application 
is being unpublished. 
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Part 3: Outbound configuration - NameValue 

In this part, you will perform the following main tasks: 

• You will use Enterprise Service Discovery (ESD) wizard to generate the 
FlatFileNameValueOutboundInterface, and also the artifacts –, ExistsResponse, ExistsResponseBG, 
FFNameValueCustomerWrapper, FFNameValueCustomerWrapperBG and so forth. 

• You will create the following maps 

o Data maps – AddressToFFNameValueAddress, CustomerToFFNameValueCustomer, and 
CustomerToFFNameValueCustomerWrapperBG 

o Interface Map –CustomerToNameValueCustomer 

• You will test the adapter for the NameValue Outbound scenario 
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3.1. Run ESD to create outbound interface and other  artifacts 

____ 1. Launch the Enterprise Service Discovery wizard 

__ a. From the top Menu, select File > New > Enterprise Service Discovery  

____ 2. Select IBM WebSphere Adapter for Flat Files (version 6.0.2 ) from the ‘CWYFF_FlatFile’ 
Connector Project if not selected by default and click Next  

____ 3. Enter the following for the Configure Settings for Discovery Agent screen 

__ a. Click on Browser… next to Folder Name and select 
<WORKSAPCE>\CustomBindingProcessing  

__ b. Select UTF-8 from the drop down menu for the Character Set  

__ c. Select text/namevalue  from the drop down menu for the Content Type  and the 
NameValueDataBinding  will automatically be selected as the DataBinding Type  

__ d. Enter the following for the DataBindingProperties 

1) TargetNameSpace: http://www.ibm.com/crm   

__ e. Click on Show Advanced  to see the logging properties. Note the Log file output location  
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__ f. Click Next  

____ 4. Find and discover the enterprise services. In this step you will select the business objects and 
services to be used with the adapter 

__ a. From the Enterprise Service Discovery window, click on Execute Query  button. You will see all 
the business objects the you imported  under Objects discovered by query  

__ b. Select FFNameValueCustomer  business object and click >>Add to import list  button. The 
Customer business object will now be displayed under the Objects to be imported  
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__ c. Click Next  

____ 5. Configure the objects that will be imported by the discovery agent 

__ a. From the Configure objects window, select Outbound  if not already selected from the dropdown 
menu for the Service Type.  

__ b. Click Next  

 

____ 6. Enter the following from the Generate Artifacts window 

__ a. Enter the following for Properties for Interface  

1) For Module  field, ensure that CustomBindingProcessing  is selected  

2) For Name field, enter FlatFileNameValueOutboundInterface   
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__ b. Ensure that Use discovered connection properties  radio button is selected 

 

__ c. Enter the following for FlatFile MCF Properties  

1) Output Directory: <DATA_DIR>  

2) Staging Directory: <STAGING_DIR> 

__ d. Enter the following for ResourceAdapterProperties  

1) LogFilename: C:\FFRA\DTF\NameValueOutlog.txt  

2) TraceFilename: C:\FFRA\DTF\NameValueOuttrace.txt  

 

__ e. Click Finish  
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____ 7. From Business Integration window, expand CustomBindingProcessing > Data Types  

__ a. Right-click on FFNameValueCustomer  and select Open With > Text Editor  to open it 

__ b. Scroll down to the place where it shows the error and delete the following 

 

__ c. Save (Ctrl+S ) your changes and close FFNameValueCustomer business object 

Note : You should not see any errors at this point. Ignore any exceptions. 

____ 8. Edit CustomerInterface with the ExistsResponseBG output 

__ a. Expand CustomBindingProcessing > Interfaces and double-click on CustomerInterface to open it 

__ b. Under the existsCustomer operation, for Output Type, click on string and select 
ExistsResponseBG from the context menu 

 

__ c. Save (Ctrl+S ) your changes and close CustomerInterface 

____ 9. Regenerate Implementation for ProcessComponent 

__ a. Expand CustomBindingProcessing  and double click on Assembly Diagram  to open it in 
Assembly editor 

__ b. Right-click on ProcessComponent  and select Regenerate Implementation  

A pop-up window will come up. Click OK to replace. 

The implementation will automatically be regenerated and the ProcessComponentImpl.java will be 
opened.  

__ c. Close the ProcessComponentImpl.java  and save (Ctrl+S ) the changes to the Assembly 
diagram 
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3.2. Create data and interface maps 

____ 1. Create AddressToFFNameValueAddress map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  

__ b. Right-click on Data Maps  and select New > Business Object Map  

__ c. From the Business Object Map screen, enter AddressToFFNameValueAddress  for Name and 
click Next   

__ d. Select the following from the Business Object Map screen 

1) Under Inputs section, select the check box for Address   

2) Under Outputs section select the check box for  FFNameValueAddress   

3) Click Finish  

The AddressToFFNameValueAddress map will be opened for transformation. Ignore the error that you will 
see at this point. It will be resolved in the following step. 

__ e. Add the following connections 

 

__ f. Save (Ctrl +S ) your changes and close the AddressToFFNameValueAddress map 

Note : You should not see any errors at this point. Ignore any exceptions. 

____ 2. Create CustomerToFFNameValueCustomer map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  

__ b. Right-click on Data Maps  and select New > Business Object Map  

__ c. Enter CustomerToFFNameValueCustomer  for the Name field and click Next  

__ d. From the Business Object Map screen, select the following 

1) Under Inputs section, select the check box for Customer   

2) Under Outputs section select the check box for FFNameValueCustomer  

3) Click Finish.  

The CustomerToFFNameValueCustomer map will be opened for transformation. Ignore any errors that 
you will see at this point. They will be resolved in the following step. 
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__ e. Add the following connections 

 

__ f. Click on 4 Submap   

__ g. From the bottom window, click the Properties  tab. 

__ h. Click on Details  

__ i. For Business object map field, select AddressToFFNameValueAddress  from the drop down 
menu 

 

 

__ j. Save (Ctrl+S ) your changes and close the CustomerToFFNameValueCustomer map 

Note : You should not see any errors at this point. Ignore any exceptions. 

____ 3. Create CustomerToFFNameValueCustomerWrapperBG map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  

__ b. Right-click on Data Maps  and select New > Business Object Map  

__ c. Enter CustomerToFFNameValueCustomerWrapperBG  for the Name field and click Next  

__ d. From the Business Object Map screen, select the following 

1) Under Inputs  section select the check box for Customer   

2) Under Outputs  select the check box for FFNameValueCustomerWrapperBG   

3) Click Finish  

The CustomerToFFNameValueCustomerWrapperBG map will be opened for transformation. Ignore any 
errors that you will see at this point. They will be resolved in the following step. 

__ e. Add the following connection 
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__ f. Click on 1 Submap   

__ g. From the bottom window, click the Properties  tab. 

__ h. Click on Details  

__ i. For Business object map field, select CustomerToFFNameValueCustomer  from the drop down 
menu 

 

__ j. On the transformations, right-click on fileName  and select Create Transform >  Assign  from the 
context menu 

 

__ k. Ensure that Assign  is selected and then click on Details  under the Properties  view from the 
bottom window 

__ l. Enter NameValue.txt for Value  
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__ m. Save (Ctrl+S ) your changes and close the CustomerToFFNameValueCustomerWrapperBG 
map 

Note : You should not see any errors at this point. Ignore any exceptions. 

____ 4. Create CustomerToNameValueCustomer Interface Map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  

__ b. Right-click on Interface Maps  and select New > Interface Map  

__ c. Enter CustomerToNameValueCustomer  for the Name and click Next  

__ d. For Source interface  field, select CustomerInterface  

__ e. For Target interface  field, select FlatFileNameValueOutboundInterface   

__ f. Click Finish  

 

CustomerToNameValueCustomer Interface map will be opened for mapping. Ignore any errors at this 
point. They will be resolved in the following step. 

__ g. Create a map from processCustomer to createFFNameValueCustomer 

1) Click on processCustomer , select Create operation mapping  and then click on 
createFFNameValueCustomer  
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2) Click on the above mapping line and you will see Parameter mappings  for it 

3) Create a mapping from Customer  to createFFNameValueCustomerInput under 
Parameter mappings 

4) Click on move  and from Properties view, select Description  and then select map  from the 
drop down menu for the Parameter Mapping Type field 

 

5) From Properties  view, select Details  tab and then select 
CustomerToFFNameValueCustomerWrapperBG  from the drop down menu for the 
Business Object Map  field 

 

__ h. Create an operation mapping from appendCustomer to appendFFNameValueCustomer 

1) Click on appendCustomer , select Create operation mapping  and then click on 
appendFFNameValueCustomer  

2) Click on the above mapping line and you will see Parameter mappings  for it 
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3) On Parameter mappings section, create a mapping from Customer  to 
appendFFNameValueCustomerInput  

4) Click on move  and from Properties view, select Description  and then select map  from the 
drop down menu for the Parameter Mapping Type  field 

 

5) From Properties  view, select Details  tab and then select 
CustomerToFFNameValueCustomerWrapperBG  from the drop down menu for the 
Business Object Map  field 

__ i. Create a map from existsCustomer to existsFFNameValueCustomer 

1) Click on existsCustomer , select Create mapping  and then click on 
existsFFNameValueCustomer  
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2) Click on the above mapping line and you will see Parameter mappings  for it 

3) Create mapping the following mappings under Parameter mappings  

a) from Customer  to existsFFNameValueCustomerInput  

b) from existsFFNameValueCustomerOutput  to ExistsResponseBG  

4) Click on move , connecting from Customer to existsFFNameValueCustomerInput, and from 
Properties view, select Description  and then select map  from the drop down menu for the 
Parameter Mapping Type  field 

 

5) From Properties  view, select Details  tab and then select 
CustomerToFFNameValueCustomerWrapperBG  from the drop down menu for the 
Business Object Map  field 

 

__ j. Save (Ctrl+S ) your changes and close the CustomerToNameValueCustomer interface map 
window 

Note : You should not see any errors at this point. Ignore any exceptions. 
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____ 5. Wire the components 

__ a. From the Business Integration window, expand CustomBindingProcessing  and double-click on  
CustomBindingProcessing  to open it in Assembly Editor 

__ b. Select CustomBindingProcessing > Mapping > Interface Maps > 
CustomerToNameValueCustomer and drop it in the Assembly diagram 

__ c. Add a wire from ProcessComponent  to CustomerToNameValueCustomer . Click OK for the 
following pop up window: 

__ d. Click Yes for the following window 

 

__ e. Add a wire from CustomerToNameValueCustomer  to FlatFileNameValueOutboundInterface  

You will see the following in the Assembly diagram 

 

____ 6. Save (Ctrl+S ) your changes on Assembly diagram 

____ 7. Regenerate Implementation for ProcessComponent 

__ a. Right-click on ProcessComponent and select Regenerate Implementation  from the context 
menu. This will automatically regenerate implementation. Click OK to the pop-up box 
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The ProcessComponentImpl.java  will be opened for you for any required code changes. For this part, 
you do not have to add any code. You can see the added CustomerInterface method which is generated 
automatically. 

__ b. Close the ProcessComponentImpl.java window 

____ 8. Save (Ctrl+S ) your changes and close the Assembly diagram 
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3.3. Run intermediate test 

Note : Refer to the Appendix: Troubleshooting Tips  at the end of this lab for any exceptions/errors that 
you might see while running the intermediate test. 

____ 1. Start WebSphere Process Server test environment and add the CustomBindingProcessingApp  
as shown in Part 2.4 Run Intermediate Test  

Wait for the project to be added to the server and the application to start. The server will be started in 
Debug mode if it is not already started before. 

____ 2. Test the adapter application 

__ a. From the Business Integration perspective, expand CustomBindingProcessing  and double-
click on CustomBindingProcessing to open it in assembly editor 

__ b. right-click on the FlatFileNameValueOutboundInterface  and select Test Component  

The FlatFileNameValueOutboundInterface_Test will be opened 

__ c. Under Detailed Properties , for the Operation  field, select createFFNameValueCustomer  from 
the drop down menu 

__ d. Fill out the fields for Initial request parameters: 

1) For content and address fields enter some data of your choice such as shown on the image 
below 

2) fileName: NameValue.txt  
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__ e. Click Continue  

__ f. From Deployment Location window, select WebSphere Process Servers > WebSphere 
Process Server V6.0  if not already selected, then click Finish  

____ 3. Verify the created file contents 

__ a. Check the subdirectory <DATA_DIR>  for the file NameValue.txt  

 

__ b. Double-click on NameValue.txt  to open it and you should see the contents that you filled in the 
above steps: 
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____ 4. Restore the Sever Configuration 

__ a. Close FlatFileNameValueOutboundInterface_Test  window and select No from the Save 
Resource pop up window 

__ b. Right-click on WebSphere Process Server V6.0  under the Servers view and select Add and 
remove projects…  from the context menu 

__ c. Select CustomBindingProcessingApp  under Configured projects and click < Remove  

__ d. Click Finish  after you see the application moved to Available projects. Wait until the application 
is being unpublished 

__ e. Delete the NameValue.txt  file from <DATA_DIR>  
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Part 4: Outbound configuration - FixedWidth 

In this part, you will perform the following main tasks: 

• You will use Enterprise Service Discovery (ESD) wizard to generate the 
FlatFileFixedWidthOutboundInterface, and also the artifacts – FFFixedWidthCustomerWrapper, 
FFFixedWidthCustomerWrapperBG, and so forth. 

• You will create the following maps 

o Data maps – AddressToFFFixedWidthAddress, CustomerToFFFixedWidthCustomer, and 
CustomerToFFFixedWidthCustomerWrapperBG 

o Interface Map –CustomerToFixedWidthCustomer 

• You will test the adapter for the FixedWidth Outbound scenario 
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4.1. Run ESD to create outbound interface and other  artifacts 

____ 1. Launch the Enterprise Service Discovery wizard 

__ a. From the top Menu bar, select File > New > Enterprise Service Discovery  

____ 2. Select IBM WebSphere Adapter for Flat Files (version 6.0.2 ) from the ‘CWYFF_FlatFile’ 
Connector Project and click Next  

____ 3. Enter the following for the Configure Settings for Discovery Agent  screen 

__ a. Click on Browser… next to Folder Name and select 
<WORKSAPCE>\CustomBindingProcessing  

__ b. Select UTF-8 from the drop down menu for the Character Set  

__ c. For content type  select text/fixedwidth  from the drop down menu. FixedWidth1DataBinding  
will automatically be selected for DataBinding Type.   

__ d. Enter the following for the DataBindingProperties 

1) TargetNameSpace: http://www.ibm.com/crm  

2) PadCharacter: ~ 

3) Field width: 15 

__ e. Scroll down and click on Show Advanced  to see the logging properties. Note the Log file 
output location  
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__ f. Click Next  

____ 4. Find and discover the enterprise services. In this step you will select the business objects and 
services to be used with the adapter 

__ a. From the Enterprise Service Discovery window, click on Execute Query  button. You will see all 
the business objects that you imported  under Objects discovered by query  

__ b. Select FFFixedWidthCustomer  business object and click >>Add to import list  button. The 
Customer business object will now be displayed under the Objects to be imported  
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__ c. Click Next  

____ 5. Configure the objects that will be imported by the discovery agent 

__ a. From the Configure objects window, select Outbound  (this is the default selection) from the 
dropdown menu for the Service Type  

__ b. Click Next  

____ 6. Enter the following from the Generate Artifacts window 

__ a. Enter the following for Properties for Interface  

1) For Module  field, ensure that CustomBindingProcessing  is selected  

2) For Name field enter FlatFileFixedWidthOutboundInterface   

__ b. Ensure that Use discovered connection properties  radio button is selected 

__ c. Enter the following for FlatFile MCF Properties  

1) Output Directory: <DATA_DIR>  

2) Staging Directory: <STAGING_DIR> 
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3) Output File Name: FixedWidth.txt  

__ d. Enter the following for ResourceAdapterProperties  

1) LogFilename: C:\FFRA\DTF\FWOutlog.txt  

2) TraceFilename: C:\FFRA\DTF\FWOuttrace.txt  

/ 

__ e. Click Finish  
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____ 7. From Business Integration window, expand CustomBindingProcessing > Data Types  

__ a. Right-click on FFFixedWidthAddress  and select Open With > Text Editor  to open it 

__ b. Scroll down to the place where it shows the error and delete the following: 

 

__ c. Save (Ctrl+S ) your changes and close FFFixedWidthAddress BO 

Note : You should not see any errors at this point. Ignore any exceptions. 
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4.2. Create data and interface maps 

____ 1. Create AddressToFFFixedWidthAddress map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  

__ b. Right-click on Data Maps  and select New > Business Object Map  

__ c. From the Business Object Map screen, enter AddressToFFFixedWidthAddress  for Name and 
click Next   

__ d. Select the following from the Business Object Map screen 

1) Under Inputs , select the check box for the Address   

2) Under Outputs  select the check box for the  FFFixedWidthAddress  section 

3) Click Finish  

The AddressToFFFixedWidthAddress map will be opened for transformation. Ignore the error that you will 
see at this point as these would be resolved in the following step. 

__ e. Add the following connections 

 

__ f. Save (Ctrl +S ) your changes and close the AddressToFFFixedWidthAddress map 

Note : You should not see any errors at this point. Ignore any exceptions. 

____ 2. Create CustomerToFFFixedWidthCustomer map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  

__ b. Right-click on Data Maps  and select New > Business Object Map  

__ c. Enter CustomerToFFFixedWidthCustomer  for the Name field and click Next  

__ d. From the Business Object Map screen, select the following 

1) Under Inputs , select the check box for the Customer   

2) Under Outputs , select the check box for  FFFixedWidthCustomer  

3) Click Finish  
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The CustomerToFFFixedWidthCustomer map will be opened for transformation. Ignore any errors that you 
will see at this point. They will be resolved in the following step. 

__ e. Add the following connections 

 

__ f. Click on 4 Submap  and then click on Details  under the Properties  view from the bottom window 

__ g. Select AddressToFFFixedWidthAddress  for the Business object map  from the drop down 
menu 

 

__ h. Save (Ctrl+S ) your changes and close the CustomerToFFFixedWidthCustomer map 

Note : You should not see any errors at this point. Ignore any exceptions. 

____ 3. Create CustomerToFFFixedWidthCustomerWrapperBG map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  

__ b. Right-click on Data Maps  and select New > Business Object Map  

__ c. Enter CustomerToFFFixedWidthCustomerWrapperBG  for the Name field and click Next  

__ d. From the Business Object Map screen, select the following 

1) Under Inputs, select the check box for the Customer   

2) Under Outputs, select the check box for the  FFFixedWidthCustomerWrapperBG   

3) Click Finish  

The CustomerToFFFixedWidthCustomerWrapperBG map will be opened for transformation. Ignore any 
errors that you will see at this point. They will be resolved in the following step. 

__ e. Add the following connection 
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__ f. Click on 1 Submap   

__ g. On the bottom window, under Properties view, click on Details   

__ h. Select CustomerToFFFixedWidthCustomer  for the Business object map  from the drop down 
menu 

 

__ i. On the transformations (top window) right-click on fileName  and select Create Transform >  
Assign  from the context menu 

__ j. Ensure that Assign  is selected and then click on Details  under the Properties  view from the 
bottom window 

__ k. Enter FixedWidth.txt for Value 

 

__ l. Save (Ctrl+S ) your changes and close the CustomerToFFFixedWidthCustomerWrapperBG map 

Note : You should not see any errors at this point. Ignore any exceptions. 

____ 4. Create CustomerToFixedWidthCustomer Interface Map 

__ a. From the Business Integration window, expand CustomBindingProcessing > Mapping  



© Copyright IBM Corporation 2007. All rights reserved 

IBM WebSphere Adapter 6.0.2 – Lab Exercise 

2007 January, 19 IBM WebSphere Adapter 6.0.2 – Lab Exercise Page 68 of 82 

 Flat File Adapter Custom Data Bindings Lab 

__ b. Right-click on Interface Maps  and select New > Interface Map  

__ c. Enter CustomerToFixedWidthCustomer  for the Name and click Next  

__ d. For Source interface  field, select CustomerInterface  

__ e. For Target interface  select FlatFileFixedWidthOutboundInterface   

__ f. Click Finish  

 

CustomerToFixedWidthCustomer Interface map will be opened for mapping. Ignore any errors at this 
point. They will be resolved in the following step. 

__ g. Create a map from processCustomer to createFFFixedWidthCustomer 

1) Click on processCustomer , select Create operation mapping  and then click on 
createFFFixedWidthCustomer  

2) Click on the above mapping line and you will see Parameter mappings  for it 

3)  Under Parameter mappings , create a map from Customer  to 
createFFFixedWidthCustomerInput  

4) Click on move  and from Properties view, select Description  and then select map  from the 
drop down menu for the Parameter Mapping Type  field 
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5) From Properties  view, select Details  tab then select 
CustomerToFFFixedWidthCustomerWrapperBG  from the drop down menu for the 
Business Object Map  field 

 

__ h. On the operation mappings, create a map from appendCustomer to 
appendFFFixedWidthCustomer 

1) Click on appendCustomer , select Create mapping  and then click on 
appendFFFixedWidthCustomer  

2) Click on the above mapping line and you will see Parameter mappings  for it 

3) Under Parameter mappings, create a map from Customer  to 
appendFFFixedWidthCustomerInput  
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4) Click on move  and from Properties view, select Description  and then select map  from the 
drop down menu for the Parameter Mapping Type  field 

 

5) From Properties  view, select Details  tab and then select 
CustomerToFFFixedWidthCustomerWrapperBG  from the drop down menu for the 
Business Object Map  field 

 

__ i. On the operation mappings create a map from existsCustomer to existsFFFixedWidthCustomer 

1) Click on existsCustomer , select Create operation mapping  and then click on 
existsFFFixedWidthCustomer  

2) Click on the above mapping line to see Parameter mappings  for it 

3) Create the following mappings under Parameter mappings  
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a) from Customer  to existsFFFixedWidthCustomerInput  

b) from existsFFFixedWidthCustomerOutput  to ExistsResponseBG  

 

4) Click on move , connecting from Customer to existsFFFixedWidthCustomerInput, and from 
Properties view, select Description  and then select map  from the drop down menu for the 
Parameter Mapping Type  field 

 

5) From Properties  view, select Details  tab and then select 
CustomerToFFFixedWidthCustomerWrapperBG  from the drop down menu for the 
Business Object Map  field 
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__ j. Save (Ctrl+S ) your changes and close the CustomerToFixedWidthCustomer interface map 
window 

Note : You should not see any errors at this point. Ignore any exceptions 

____ 5. Wire the components 

__ a. From the Business Integration window, expand CustomBindingProcessing  and double-click on  
CustomBindingProcessing  to open it in Assembly Editor 

__ b. Select CustomBindingProcessing > Mapping > Interface Maps > 
CustomerToFixedWidthCustomer and drop it in the Assembly diagram 

__ c. Add a wire from ProcessComponent  to CustomerToFixedWidthCustomer . Click OK and Yes 
for the two pop-up windows. 

__ d. Add a wire from CustomerToFixedWidthCustomer  to FlatFileFixedWidthOutboundInterface  

You will see the following in the Assembly diagram 

 

____ 6. Save (Ctrl+S ) your changes on Assembly diagram 

____ 7. Regenerate Implementation for ProcessComponent 

__ a. Right-click on ProcessComponent and select Regenerate Implementation  from the context 
menu 

__ b. The ProcessComponentImpl.java  will be opened for you. You can see the added 
CustomerInterface method. 

__ c. Close the ProcessComponentImpl.java  window 

____ 8. Save (Ctrl+S ) your changes and close the Assembly diagram 
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4.3. Run intermediate test  

Note : Refer to the Appendix: Troubleshooting Tips  at the end of this lab for any exceptions/errors that 
you might see while running the intermediate test. 

____ 1. Start WebSphere Process Server test environment and add the CustomBindingProcessingApp  
as shown in Part 2.4 Run Intermediate Test  

Wait for the project to be added to the server and the application to start. The server will be started in 
Debug mode if it is not already started before. 

____ 2. Test the adapter application 

__ a. From the Business Integration perspective, expand CustomBindingProcessing  and double-
click on Assembly Diagram  to open it in assembly editor 

__ b. right-click on the FlatFileFixedWidthOutboundInterface  and select Test Component  

The FlatFileFixedWidthOutboundInterface_Test will be opened 

__ c. Under Detailed Properties , for the Operation  field, select createFFFixedWidthCustomer  from 
the drop down menu 

__ d. Fill out the fields for Initial request parameters: 

1) For content and address fields enter some data of your choice similar to what is shown on 
the image 

2) fileName: FixedWidth.txt  
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__ e. Click Continue  

__ f. From Deployment Location window, select WebSphere Process Servers > WebSphere 
Process Server V6.0 and click Finish  

____ 3. Verify the created file contents 

__ a. Check the subdirectory <DATA_DIR>  for the file FixedWidth.txt  

 

__ b. Double-click on FixedWidth.txt  to open it and you should see the contents that you filled in the 
above steps: 
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____ 4. Restore the Sever Configuration 

__ a. Close FlatFileFixedWidthOutboundInterface_Test  window and select No from the Save 
Resource pop up window 

__ b. Right-click on WebSphere Process Server V6.0  under the Servers view and select Add and 
remove projects…  from the context menu 

__ c. Select CustomBindingProcessingApp  under Configured projects and click < Remove  

__ d. Click Finish  after you see the application moved to Available projects. Wait until the application 
is being unpublished 

__ e. Delete the FixedWidth.txt  file from <DATA_DIR>  
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Part 5: Test the scenario 

In this part of the lab, you will use the WebSphere Process Server Test Environment to test complete scenario 
of this lab. 

____ 1. Generate Implementation for the ProcessComponent 

__ a. Open the assembly diagram for CustomBindingProcessing 

__ b. Right-click on ProcessComponent and select Regenerate Implementation 

__ c. The ProcessComponentImpl.java window will be opened. From this window, scroll down to the 
processCustomer  method and enter the following code: 

 

Note : For you convenience, the code is available at <LAB_FILES>\DTF\ProcessComponentImpl.txt  file 

__ d. Save (Ctrl+S ) your changes and close the ProcessComponentImpl.java window 

__ e. Save (Ctrl+S ) your changes to the Assembly diagram 

____ 2. Start the WebSphere Process Server (if it is not already started) 

__ a. Select the Servers view 

__ b. Right-click on the row that contains WebSphere Process Server V6.0  and select Start  from the 
context menu 

__ c. Wait until the server status shows as Started  

____ 3. Add the project to the WebSphere Test Environment server 

__ a. Right-click on WebSphere Process Server V6.0  under the Servers view and select Add and 
remove projects…  from the context menu 

__ b. From the Add and Remove Projects window, select CustomBindingProcessingApp  under 
Available projects panel and click Add >  

__ c. You will now see the CustomBindingProcessingApp  added to the Configured projects  
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__ d. Click Finish  and wait until the project is being published onto the server. The server will be 
started in Debug mode if it is not already started before 

____ 4. Test the adapter application 

__ a. Copy a test file to the <EVENT_DIR>. As the file is copied to the event directory, the same will 
be picked up and processed by the adapter and will be moved to the <ARCHIVE_DIR>  and also 
the NameValue.txt  and FixedWidth.txt  files will be created under <DATA_DIR>  

Note : For your convenience, a test file named Delimited.txt  file can be found in <LAB_FILES>\DTF . 

____ 5. Verify your test results 

__ a. Inbound operation verification:  

1) Check your test environment console (or SystemOut.log file) for the following successful 
message: 

 

2) Now, check the <ARCHIVE_DIR> subdirectory which should contain an archive of the 
event file, with the same file name appended with year, month, date, system time, and 
success. 

__ b. Outbound operation verification: 

1) Check for the NameValue.txt  and FixedWidth.txt  files created under <DATA_DIR>  

 

2) You can open the above created files and see the content in it 

a) Open FixedWidth.txt  

 

b) Open NameValue.txt  
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____ 6. Restore the Sever Configuration 

__ a. Right-click on WebSphere Process Server V6.0  under the Servers view and select Add and 
remove projects…  from the context menu 

__ b. Select CustomBindingProcessingApp  under Configured projects and click < Remove  

__ c. Click Finish  after you see the application moved to Available projects. Wait until the application 
is being unpublished 

__ d. Stop the server 
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Appendix: Troubleshooting tips 

This part will help you with some tips when you see some exceptions/errors while doing this lab. 

____ 1. Delete the spaces and new line (if added) from the xsds 

__ a. If the new line is added to the target namespace in FlatFile.xsd and 
FFDelimitedCustomerWrapper.xsd or any other xsds, delete the spaces and new lines from them 
and save those changes 

__ b. For example, if your TargetNameSpace and DataBindingClass is as shown: 

<TargetNamespace> 
  http://www.ibm.com/crm 
</TargetNamespace> 
<DataBindingClass> 
  com.ibm.websphere.samples.databinding.DelimitedEISDataBinding 
</DataBindingClass> 

__ c. Change it to the following (delete the space and new line): 

  <TargetNamespace>http://www.ibm.com/crm</TargetNamespace> 
<DataBindingClass>com.ibm.websphere.samples.databinding.DelimitedEISDataBinding</Dat
aBindingClass> 

____ 2. Clean and Build the Project – If you see any errors regarding the synchronizing problem of 
WebSphere Integration Developer. For example, after running ESD wizard, you might see a WSDL 
Port Type error which you can get rid off by doing this step. 

__ a. From the main menu, select Project > Clean  

__ b. Select radio button next to Clean all projects and click OK 

____ 3. Restart the server 

__ a. Click on the Servers  tab 

__ b.  Ensure that WebSphere Process Server V6.0 is selected 

__ c. Click on Restart the server ( ) icon and wait for the server to start 

____ 4. Restart workspace – because of the WebSphere Integration Developer V6.0.2 synchronization 
issues 

__ a. From main menu, select  File > Switch Workspace  and then select <WORKSPACE>  from the 
Workspace Launcher window 

____ 5. See the server logs 

__ a. From the windows explorer, select <WID_HOME>\pf\wps\logs\server1 

__ b. Check the contents in SystemOut.log and SystemErr.log mainly 

____ 6. Republish the application – check server log files and if there is anything that you missed in ESD 
wizard, or entered incorrect information, then make those corrections and then do republish of the 
application 

__ a. Remove application 
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1) Right-click on WebSphere Process Server V6.0  under the Servers view and select Add 
and remove projects…  from the context menu 

2) From the Add and Remove Projects window, select CustomBindingProcessingApp  under 
Configured projects panel and click Remove >  

3) You will now see the CustomBindingProcessingApp  added to the Available projects  

4) Click Finish  

__ b. Add the application 

1) Right-click on WebSphere Process Server V6.0  under the Servers view and select Add 
and remove projects…  from the context menu 

2) From the Add and Remove Projects window, select CustomBindingProcessingApp  under 
Available projects panel and click Add >  

3) You will now see the CustomBindingProcessingApp  added to the Configured projects 
and click Finish  
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What you did in this exercise 

In this lab, you used ESD to configure the Flat File Adapter for Inbound operation to process Delimited files 
and tested it independently with a Delimited test file. Then, you continued using ESD to configure Flat File 
Adapter for two outbound operations to process NameValue and FixedWidth files and tested these two 
output configurations independently. 

At the end, you tested the entire scenario, where the Delimited file is polled from the event directory and 
then the two – NameValue and FixedWidth files were sent to the output directory as configured using only 
one Module. 
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