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What this exercise is about 

The objective of this lab is to provide you with an understanding of WebSphere® Adapter for Flat Files and 
inbound event processing. In this lab you will deploy the WebSphere Adapter for Flat Files, using 
WebSphere Integration Developer, and integrate it with an SCA application that polls for inbound events 
and processes those inbound requests from the file system. 

Lab requirements 

List of system and software required for the student to complete the lab. 

• WebSphere Integration Developer V6.0.2 installed 

• WebSphere Process Server V6.0.2 Test Environment installed 

• WebSphere Adapter for Flat File V6.0.2 installed 

• Unzip LabFiles602.zip to your C:\ (your root) drive 
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What you should be able to do 

At the end of this lab you should be able to:   

• Create databases required in Cloudscape 

• Import Flat File adapter RAR file into WebSphere Integration Developer 

• Use WebSphere Process Server Administrative Console to create required JDBC provider and a Data 
source under it 

• Use Enterprise Service Discovery (ESD) wizard to configure  Activation Spec Properties and Resource 
Adapter Properties to generate Business Objects and other artifacts 

• Deploy the adapter application onto WebSphere Process Server 

• Test the deployed application using WebSphere Process Server test environment for both pass-
through and non pass-through using four different scenarios 

• Restore the server configuration 
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Introduction 

 

The backend EIS is the source of events. When events are generated at the EIS, files would be created by 
the EIS in the file system at a specific directory location, which needs to be configured as the Event 
Directory for the adapter. 
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The adapter polls event files from the multiple Event Directories periodically based on user-configured 
Event File Mask, Poll Quantity and Poll Period. Each file would form a fundamental unit of transfer to the 
adapter which can internally represent more than one backend events. The adapter sends the entire file 
content across to the endpoint in the form of a WebSphere Business Integration Business Object for 
further processing. 

The event management framework takes care of delivering the event only once to the endpoint. FF RA 
(Flat File Resource Adapter) internally uses an event table, Flat Files event table, to log the status of the 
events that have been polled but not yet posted to the endpoint. Once an event is polled, the FF RA 
generates the Event ID and stores the event reference in the Flat Files event table with a NEW status.  
The base class functions call the adapter methods to process the events. The FF RA changes the status 
for the event in the Flat Files event table to an IN_PROGRESS status. It wraps the file content in a Record 
and posts the same across to the configured endpoint.  

The base classes call the deleteEvent() method once the event BO is posted and the event entry is then 
deleted from the Flat Files event table. After the Business Objects are sent out of the adapter, the events 
are archived optionally, in a user-configured Archive Directory on the file system. 

 

Exercise instructions 

Some instructions in this lab may be Windows® operating-system specific.  If you plan on running the lab 
on an operating-system other than Windows, you will need to run the appropriate commands, and use 
appropriate files ( .sh vs. .bat) for your operating system.  The directory locations are specified in the lab 
instructions using symbolic references, as follows: 

Reference Variable Windows Location AIX®®/UNXI® 
Location 

<WID_HOME> C:\Program Files\IBM\ID\6.0  

<WPS_HOME> <WID_HOME>\runtimes/bi_v6  

<FFADAPTER_HOME> C:\Program 
Files\IBM\ResourceAdapters\FlatFiles\adapter\FlatFile 

 

<LAB_FILES> C:\Labfiles602 /tmp/Labfiles602 

<WORKSPACE> <LAB_FILES>\FlatFileInbound\workspace  

<EVENT_DIR> <LAB_FILES>\FlatFileInbound\eventdir  

<ARCHIVE_DIR> <LAB_FILES>\FlatFileInbound\archivedir  

<TEMP> C:\temp /tmp 

Windows users note : When directory locations are passed as parameters to a Java™ program such as 
EJBdeploy or wsadmin, it is necessary to replace the backslashes with forward slashes to follow the Java 
convention. For example, C:\LabFiles602\ would be replaced by C:/LabFiles602/ 
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Part 1: Prepare database and subdirectory structure   

This part of the lab, describes the steps for creating the FFDATABASE  database in Cloudscape which will 
contain the Event Persistence Table, FFTABLE .  The FFTABLE  will be created automatically for you 
during the install and deployment of the application containing the Flat File adapter to the WebSphere 
Process Server. 

____ 1. Start the Cloudscape Cview Graphical User Interface (GUI) by executing the cview.bat file 

__ a. Open a command prompt window, change to the following subdirectory 
<WPS_HOME>\cloudscape\bin\embedded 

 

__ b. Type cview.bat  

 

__ c. The Cview window will be opened. From that window, select File > New > Database… . 
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__ d. Enter FFDATABASE  in the Name field and click OK 

 

You will see the FFDATABASE  created in the left pane of the Cview window: 

 

__ e. Select File > Exit  to close the Cview GUI 

____ 2. Unzip the provided LabFiles602.zip to your C:\ (root) drive, if you have not already done so.  This 
will create the necessary subdirectory structure to complete the lab, as well as provide you with 
sample text files. 
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Part 2: Initialize workspace and import RAR into We bSphere Integration 
Developer 

This part of the lab will guide you through the steps for starting WebSphere Integration Developer with a new 
workspace, and then import the connector file CWYFF_FlatFile.rar  into your new workspace. 

____ 1. Start the WebSphere Integration Developer V6.0.2 with a new workspace 

__ a. Select Start > Programs > IBM WebSphere > Integration Deve loper V6.0.2 > WebSphere 
Integration Developer V6.0.2  

__ b. From the Workspace Launcher window, enter <WORKSPACE>  for the Workspace field 

 

__ c. Click on the  button on the right hand corner to close the Welcome page and proceed with 
the workbench 
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____ 2. Import Flat File Adapter RAR file 

__ a. From main menu, select File > Import…  

 

__ b. Select RAR file  from the Import window and then click Next  
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__ c. Click on the Browse…  button next to the Connector file  field to select CWYFF_FlatFile.rar  

__ d. Uncheck the check box next to Add module to and EAR  project  and click Finish  

 

__ e. Click on No from Confirm Perspective Switch window to continue with the Business Integration 
perspective 
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Part 3: Use WebSphere Process Server Administrative  Console to 
configure data sources 

In this part of the lab, you will make use of WebSphere Process Server Administrative Console to create 
the required JDBC Provider and the Data source that will be used by the Adapter to configure itself to the 
end point. 

____ 1. Start the WebSphere Process Server 

__ a. Select the Servers view 

__ b. Right-click on the row that contains WebSphere Process Server v6.0  and select Start  from the 
context menu 

 

__ c. Wait until the server status shows as Started  

____ 2. Right-click on the row that contains WebSphere Process Server v6.0 and select Run 
administrative console  from the context menu 

 

____ 3. From the Administrative Console, enter any User ID  and click on Log In  
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____ 4. Expand Resources  on the left pane and select JDBC Providers  

 

____ 5. Accept the default scope and click on New 

____ 6. In the following screen, for General Properties, select the following from the dropdown list: 

__ a. Step 1: Cloudscape  

__ b. Step 2: Cloudscape JDBC Provider  

__ c. Step 3: XA data source  

____ 7. Click Next  
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____ 8. Enter Cloudscape JDBC Provider (XA) for FF  in the Name field and then click OK 

 

____ 9. Click Save on the top of the window, and then click on Save from the following screen 

____ 10. Click Cloudscape JDBC Provider (XA) for FF  from the following screen to create a new 
DataSource 

____ 11. Select Data Sources  under Additional Properties  on the right hand side 

 

____ 12. Create the required JNDI Data source 

__ a. Click New 

__ b. Enter these values: 

a) Name: Cloudscape JDBC Driver XA DataSource for FF  

b) JNDI Name: jdbc/Cloudscape JDBC Driver XA DataSource for FF  

c) Database name: FFDATABASE  
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__ c. Click OK 
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____ 13. Click on Save and then Save from the following screens 

____ 14. Test the Data Source connection 

__ a. Check the box next to Cloudscape JDBC Driver XA DataSource  for FF  and click on Test 
connection  from the top of the screen 

 

__ b. You should see the following success message on the top of the screen: 

 

____ 15. Log out of the Administrative Console and close it. 
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Part 4: Use Enterprise Service Discovery Wizard to generate business 
objects and other artifacts 

Enterprise Service Discovery (ESD) or Enterprise Metadata Discovery (EMD) is a component within 
adapter that enables the generation of business object definition and other artifacts required by SCA. 

The instances of Activation Spec and the Resource Adapter from EMD translate to the section on SCA 
export files. During runtime, the adapter component that exposes the adapter as SCA uses these export 
files to create instances of Activation Spec and Resource Adapter and fills in values from the SCA files that 
were created with EMD. 

____ 1. Launch the Enterprise Service Discovery wizard 

__ a. From the top Menu bar, select File > New > Enterprise Service Discovery  

 

____ 2. Select IBM WebSphere Adapter for Flat Files (version 6.0.2 ) from the ‘CWYFF_FlatFile’ 
Connector Project  and click Next  
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____ 3. Configure settings for the Discovery agent 

You will specify the properties to initialize the Resource Adapter and Enterprise Service Discovery agent. 

__ a. Click on the Browse…  button next to the Folder Name  field and select the folder 
<FFADAPTER_HOME>\samples  that contains the XSD file for Customer  Business Object 

Note : For your convenience, the Customer.xsd  is also placed under <LAB_FILES>\FFFiles . 

__ b. Select text/xml  for the Content Type  field. Once the content type is selected, the DataBinding  
Type  will be automatically set to XMLBOSerializerDataBinding  

__ c. Click the Show Advanced >>  button to see the Log file location and Logging level options for the 
discovery log and click Next  leaving the default log file location 
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____ 4. Find and discover the enterprise services. In this step you will select the business objects and 
services to be used with the adapter 

__ a. From the Enterprise Service Discovery window, click on Execute Query  button. You will see a 
Custome r business object under Objects discovered by query  

__ b. Select Customer  business object and click Add to import list  button. The Customer business 
object will now be displayed under the Objects to be imported  
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__ c. Click Next  

____ 5. Configure the objects that will be imported by the discovery agent 

__ a. From the Configure objects window, select Inbound  from the dropdown menu for the Service 
Type . 
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__ b. Enter FFInBO  for the BO Location  field and click Next  

 

____ 6. Specify the properties for the artifacts that will be generated in your workspace 

__ a. Create a new module 

1) Click on the New… button next to Module  field 
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2) From the New Integration Project window, ensure that the radio button next to Create a 
module project  is selected and click Next  

 

3) Enter FFInboundModule  for the Module Name field and click Finish. The assembly 
diagram for FFInboundModule will be opened for you. 

 

__ b. The module which is created above will appear under the Module  field of the Generate Artifacts 
window  

__ c. From Generate Artifacts window, select the radio button next to Use discovered connection 
properties .  
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This will make the Properties for Activation Spec and Resource Adapter Properties visible 

 

__ d. Enter the following for FlatFile Properties  of Activation Spec Properties: 

1) EventDirectory: <EVENT_DIR> 

2) ArchiveDirectory: <ARCHIVE_DIR> 

3) EPDataSourceJNDIName: jdbc/Cloudscape JDBC Driver XA DataSource for FF  

4) EPEventTableName: FFTABLE  

__ e. Enter the following for the Logging and Tracing  of Resource Adapter Properties: 
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1) LogFilename: C:\FFRA\Inlog.txt  

2) TraceFilename: C:\FFRA\Intrace.txt  
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__ f. Click Finish  

____ 7. Create a Java Component and wire it to the FlatFileInboundInterface . 

__ a. Open the assembly diagram for FFInboundModule (if it is not opened already) 

1) From the Business Integration perspective, expand the FFInboundModule  folder 

2) Double-click the FFInboundModule  module to open it in Assembly editor 

 

__ b. From the palette, click the Component (with no implementation type) icon, and select Java  
component from the context menu icon and then click in the Assembly Diagram’s empty space to 
drop it there 

 

__ c. Wire the FlatFileInboundInterface  to the Component1  

1) Select the wire  icon from the palette 
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2) Click on FlatFileInboundInterface  and then click on Component1  to wire them together 

 

3) Select OK for the Add Wire popup window 

 

4) Click on the Selection Tool  to get back to the normal cursor mode 

 

__ d. Right-click on Component1  and select Generate Implementation from the context menu 

__ e. On the Generate Implementation panel, select the FFInBO  package, and click OK 

__ f. Component1Impl.java will be opened in Assembly editor. Scroll down to the method 
emitFlatFile(DataObject emitFlatFileInput)   and emitFlatFile(DataObject 
emitCustomerWrapperInput) that needs to be implemented and add the code as shown below 
for each of those methods: 
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__ g. Save (Ctrl + S ) and close Component1Impl.java 

__ h. Save (Ctrl + S ) and close Assembly diagram: FFInboundModule 

____ 8. You can also configure/change the adapter properties using Assembly Editor 

__ a. Change to Business Integration perspective if you are in a different perspective 

1) Select Window > Open Perspective > Other… . 

 

2) From the Select Perspective window, select Business Integration (default)  and click OK 

 

__ b. Expand FFInboundModule  and double-click FFInboundModule to open it in Assembly Editor 
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__ c. Click on FlatFileInboundInterface  from the Assembly Editor and select Properties  tab from the 
bottom 

__ d. Select Binding  under Properties and select Endpoint Configuration  under Binding itself and 
then select the Connection  tab 
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__ e. Ensure the radio button next to Specify properties for pre-configured new J2EE Conn ector 
Architecture recourse  is selected and then click on Activation Spec Properties  to expand 
them. You can change the properties, which you entered using the ESD wizard in the previous 
steps, and make sure that you save those changes before you deploy the application onto the 
server 
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__ f. You can also select Resource Adapter tab and review/change those properties 
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Part 5: Test scenario: Simple pass-through 

In this part of the lab, you will use the WebSphere Process Server Test Environment to test the SCA 
application Inbound processing for the PassThrough Scenario. 

____ 1. Add the project to the WebSphere Test Environment server 

__ a. Right-click on WebSphere Process Server v6.0  under the Servers view and select Add and 
remove projects…  from the context menu 

 

__ b. From the Add and Remove Projects window, select FFInboundModuleApp  under Available 
projects panel and click Add >  
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__ c. You will now see the FFInboundModuleApp  added to the Configured projects  

 

__ d. Click Finish  and wait until the project is being published onto the server. The server will be 
started in Debug mode if it is not already started before 

____ 2. Test the adapter application 

__ a. Copy a test file to the <EVENT_DIR>. As the file is copied to the event directory, the same will 
be picked up and processed by the adapter and will be moved to the <ARCHIVE_DIR> 

Note : For your convenience, a test file named SplitBySize.txt  file can be found in <LAB_FILES> . 

____ 3. Verify your test results 

__ a. Check your test environment console (or Systemout.log file) for the following successful 
message: 

 

__ b. Now, check the <ARCHIVE_DIR> subdirectory which should contain an archive of the event file, 
with the same file name appended with year, month, date, system time, and success 
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____ 4. Restore the Sever Configuration 

__ a. Right-click on WebSphere Process Server v6.0  under the Servers view and select Add and 
remove projects…  from the context menu 

 

__ b. Select FFInboundModuleApp  under Configured projects and click < Remove  

 

__ c. Click Finish  after you see the application moved to Available projects. Wait until the application 
is being unpublished 
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__ d. If you are continuing to the next part, you may leave the server running.  If not, right-click on 
WebSphere Process Server v6.0  from the Servers view and select Stop  from the context 
menu.   
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Part 6: Test scenario: Simple data transformation ( non pass-through) 

In this part of the lab, you will edit the Activation Spec Properties to see how a simple Data Transformation 
works for an Inbound operation. 

____ 1. Open the Activation Spec Properties from the Attributes View 

__ a. Click on FlatFileInboundInterface  from the Assembly Editor and select Properties  tab from the 
bottom 

__ b. Select Binding  under Properties and select Endpoint Configuration  under Binding itself and 
then select the Connection  tab 

__ c. Ensure the radio button next to Specify properties for pre-configured new J2EE Conn ector 
Architecture recourse  is selected and then click on Activation Spec Properties  to expand 
them and enter the following fields: 

1) EventContentType: text/xml  
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2) FileContentEncoding: UTF-8 (or any other valid encoding) 

 

__ d. Save (Ctrl +S ) your changes 

____ 2. Follow step 1 of Part 5 to add the modified FFInboundModuleApp  to the server 

____ 3. Test the adapter 

Note : For your convenience, a test file SimpleDTF.xml  is placed in <LAB_FILES>\FFFiles . The file 
contains one Business Object.  
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__ a. Copy the SimpleDTF.xml  file from <LAB_FILES>\FFFiles to <EVENT_DIR>. The adapter will 
poll the copied xml file from the event directory and will transform it to the archive directory 

____ 4. Verify your results 

__ a. Check your test environment console (or Systemout.log file) for the following successful 
message: 

 

__ b. Check your <ARCHIVE_DIR> which should contain an archive of the event file, with the same 
file name appended with year, month, date, system time, and success 

 

____ 5. Repeat Step 4 of Part 5 to restore server Configuration 



© Copyright IBM Corporation 2007. All rights reserved 

IBM WebSphere Adapter 6.0.2 – Lab Exercise 

2007 January, 19 IBM WebSphere Adapter 6.0.2 – Lab Exercise Page 37 of 44 

 Flat File Adapter Inbound Lab 

Part 7: Test scenario: SplitByDelimiter for data tr ansformation 

In this part of the lab, you will edit the Activation Spec Properties to see how SplitByDelimiter works with Data 
Transformation for an Inbound operation. 

____ 1. Open the Activation Spec Properties from the Attributes View 

__ a. Click on FlatFileInboundInterface  from the Assembly Editor and select Properties  tab from the 
bottom 

__ b. Select Binding  under Properties and select Endpoint Configuration  under Binding itself and 
then select the Connection  tab 

__ c. Ensure the radio button next to Specify properties for pre-configured new J2EE Conn ector 
Architecture recourse  is selected and then click on Activation Spec Properties  to expand 
them and enter the following fields: 

1) SplitCriteria: #####;\n  



© Copyright IBM Corporation 2007. All rights reserved 

IBM WebSphere Adapter 6.0.2 – Lab Exercise 

2007 January, 19 IBM WebSphere Adapter 6.0.2 – Lab Exercise  Page 38 of 44 

 Flat File Adapter Inbound Lab 

2) SplittingFunctionClassName: com.ibm.j2ca.utils.filesplit.SplitByDelimiter  

3) EventContentType: text/xml  

 

__ d. Save (Ctrl +S ) your changes 

____ 2. Follow step 1 of Part 5 to add the modified FFInboundModuleApp  to the server 

____ 3. Test the adapter 
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Note : For your convenience, a test file SplitByDelimiter.xml  is placed in <LAB_FILES>\FFFiles . The file 
contains two Business Objects separated by the delimiter ##### followed by a new line .  

__ a. Copy the SplitByDelimiter.xml file from <LAB_FILES>\FFFiles to <EVENT_DIR>. The adapter 
will poll the copied xml file from the event directory and will transform it to the archive directory 

____ 4. Verify your results 

__ a. Check your test environment console (or Systemout.log file) for the following successful 
message: 

Note : You will see the successful event delivery message twice as there were two Business Objects 
present in the event file separated by the delimiter ##### followed by a new line. 

 

__ b. Check your <ARCHIVE_DIR> which should contain an archive of the event file, with the same 
file name appended with year, month, date, system time, and success 

 

____ 5. Repeat Step 4 of Part 5 to restore server configuration 
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Part 8: Test scenario: SplitBySize for pass through  

In this part of the lab, you will edit the Activation Spec Properties to see how SplitBySize works for an Inbound 
operation. 

____ 1. Open the Activation Spec Properties from the Attributes View 

__ a. Click on FlatFileInboundInterface  from the Assembly Editor and select Properties  tab from the 
bottom 

__ b. Select Binding  under Properties and select Endpoint Configuration  under Binding itself and 
then select the Connection  tab 
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__ c. Ensure the radio button next to Specify properties for pre-configured new J2EE Conn ector 
Architecture recourse  is selected and then click on Activation Spec Properties  to expand 
them and enter the following fields: 

1) SplitCriteria: 10000 

2) SplittingFunctionClassName: com.ibm.j2ca.utils.filesplit.SplitBySize  

3) Make sure that you delete any values you have for FileContentEncoding and 
EventContentType  fields 

 

__ d. Save (Ctrl +S ) your changes 
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____ 2. Follow step 1 of Part 5 to add the modified FFInboundModuleApp to the server 

____ 3. Test the adapter 

Note : For your convenience, a test file SplitBySize.txt  is placed in <LAB_FILES> . Note the size of the 
file. 

__ a. Copy the SplitBySize.txt  file from <LAB_FILES>  to <EVENT_DIR>. Adapter will poll the copied 
txt file from the event directory and will transform it to the archive directory 

____ 4. Verify your results 

__ a. Check your WebSphere Process Server console (or Systemout.log file) for the following 
successful message: 

Note : You will see the successful event delivery message for four times as the file size is 37KB and the 
split criteria has 10KB, which means it splits the file into four part and delivers to the endpoint. 

 

Note : The same SplitBySize.txt file was delivered as one event file to the end point when you did not 
specify the SplitCriteria in part 5 while configuring ESD. Here, in this part, you will see the successful event 
delivery message for four times for the same file (with the file size being 37KB) because of the split criteria 
that has been given as 10KB, which means it splits the file into four part and delivers to the endpoint. 

__ b. Check your <ARCHIVE_DIR> which should contain an archive of the event file, with the same 
file name appended with year, month, date, system time, and success 

 

____ 5. Repeat Step 4 of Part 5 to restore the server configuration 
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What you did in this exercise 

In this lab, you created the database in Cloudscape required for this lab. You continued with importing the 
Flat File Adapter RAR file into your WebSphere Integration Developer workspace. Then, used your 
WebSphere Process Server administrative console and configured it to create the Data source required to 
complete this lab. 

You made use of the Enterprise Service Wizard available in WebSphere Integration Developer to specify 
Activation Spec Properties and Resource Adapter Properties which, after deploying onto the server, will 
generate Business Objects and other artifacts.  

In the end you deployed and then tested the adapter application for two pass-through test scenarios – 
simple pass through and split by size and two data transformation test scenarios – simple data 
transformation and split by delimiter. 
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