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What this exercise is about 

The objective of this lab is to provide you with an understanding of the IBM WebSphere Adapter for Flat 
Files and outbound processing. In this lab you will deploy the WebSphere Adapter for Flat Files, using 
WebSphere Integration Developer, and integrate it with an SCA application that processes outbound 
requests to the file system. 

Lab requirements 

List of system and software required for the student to complete the lab 

• WebSphere Integration Developer V6.0.2 installed 

• WebSphere Process Server V6.0.2 test environment installed 

• WebSphere Adapter for Flat Files V6.0.2 installed 

• Unzip LabFiles602.zip to your C:\ (your root) drive 

What you should be able to do 

• Import Flat Files adapter RAR file into WebSphere Integration Developer 

• Use Enterprise Service Discovery wizard to configure the Managed Connection Factory Properties  
and Resource Adapter Properties to generate Business Objects and other artifacts 

• Deploy the adapter application onto the WebSphere Process Server test environment 

• Test the above deployed application using WebSphere Process Server test environment  

• Restore the server configuration 
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Introduction 

 

The request to the FF RA (Flat File Resource Adapter) from an SCA client will be sent with the information 
required for creating the output file - the directory to create the output file, the name of the output file and 
the operation. The file name will be treated as the key for the Flat Files request/response BO entity.   



© Copyright IBM Corporation 2007. All rights reserved 

IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE 

2007 January, 19 IBM WebSphere Adapter 6.0.2 – Lab Exercise Page 3 of 28 

 Flat Files Adapter Outbound 

FF RA uses the application server’s connection pool to establish connections with an EIS. The adapter 
creates a new file connection for every outbound operation and closes it after the operation is completed 
based on the EIS connectivity requirement. The requests initiated from any SCA client would result in a 
response being sent back to the client after the request is processed. 

 

Exercise instructions 

Some instructions in this lab might be specific for Windows platforms.  If you run the lab on a platform 
other than Windows, you will need to run the appropriate commands, and use appropriate files ( for 
example .sh in place of .bat) for your operating system.  The directory locations are specified in the lab 
instructions using symbolic references as follows: 

 

Reference Variable Windows Location Linux Location 

<WID_HOME> C:\Program Files\IBM\WebSphere\ID\6.0  

<WPS_HOME> <WID_HOME>\runtimes\bi_v6  

<FFADAPTER_HOME> C:\Program 
Files\IBM\ResourceAdapters\FlatFiles\adapter\flatfile 

 

<LAB_FILES> C:\LabFiles602 /tmp/LabFiles602 

<WORKSPACE> <LAB_FILES>\FlatFileOutbound\workspace  

<OUT_DIR> <LAB_FILES>\ FlatFileOutbound\OutputDir  

<TEMP> C:\temp /tmp 

 

Windows users : When directory locations are passed as parameters to a Java program such as 
EJBdeploy or wsadmin, you must replace the backslashes with forward slashes to follow the Java 
convention. For example, C:\Labfiles602\ would be replaced by C:/Labfiles602/. 



© Copyright IBM Corporation 2007. All rights reserved 

IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE 

2007 January, 19 IBM WebSphere Adapter 6.0.2 – Lab Exercise  Page 4 of 28 

 Flat Files Adapter Outbound 

Part 1:  Initialize workspace and import RAR into W ebSphere Integration 
Developer  

____ 1. Start the WebSphere Integration Developer V6.0.2 with a new workspace 

 Select Start > Programs > IBM WebSphere > Integration Deve loper V6.0.2 > WebSphere 
Integration Developer V6.0.2  

 From the Workspace Launcher window, enter <WORKSPACE>  for the Workspace field 

 

 Click on the  button on the right hand corner to close the Welcome page and proceed with 
the workbench 
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____ 2. Import Flat File Adapter RAR file 

 From main menu, select File > Import…  

 

 Select RAR file  from the Import window and then click Next  
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 Click on the Browse…  button next to the Connector file  field to select CWYFF_FlatFile.rar  

 Uncheck the check box next to Add module to and EAR  project  and click Finish  

 

 Click on No from Confirm Perspective Switch window to continue in Business Integration 
perspective 
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Part 2: Use ESD wizard to generate business objects  and other artifacts  

Enterprise Service Discovery (ESD) or Enterprise Metadata Discovery (EMD) is a component within the 
adapter that enables the generation of business object definitions and other artifacts required by SCA. 

The instances of the Managed Connection Factory and Resource Adapter from EMD translate to the 
section on SCA import files. During runtime, the adapter component that exposes an adapter as SCA uses 
these import files to create instances of Managed Connection Factory and Resource Adapter and fills in 
values from the SCA files that were created with EMD. 

____ 1. Start the Enterprise Service Discovery process and import the Flat Files Adapter Resource Archive 
(RAR) file.  

__ a. From the top Menu bar, select File > New > Enterprise Service Discovery  
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____ 2. Select IBM WebSphere Adapter for Flat Files (version 6.0.2 ) from the ‘CWYFF_FlatFile’ 
Connector Project  and click Next  

 

____ 3. Configure settings for the Discovery agent 

You will specify the properties to initialize the Resource Adapter and Enterprise Service Discovery agent. 

__ a. Click the Browse…  button next to the Folder Name  field and select the folder 
<FFADAPTER_HOME>\samples  that contains the XSD file for Customer  Business Object 

Note : For your convenience, the Customer.xsd  is also placed under <LAB_FILES>\FFFiles . 

__ b. Select text/xml  for the Content Type  field. When you select the content type, the DataBinding 
Type  will be automatically set to XMLBOSerializerDataBinding  



© Copyright IBM Corporation 2007. All rights reserved 

IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE 

2007 January, 19 IBM WebSphere Adapter 6.0.2 – Lab Exercise Page 9 of 28 

 Flat Files Adapter Outbound 

__ c. Click the Show Advanced >>  button to see the Log file location and Logging level options for 
discovery log and click Next  leaving the default log file location 

 

____ 4. Find and discover the enterprise services. In this step you will select the business objects and 
services to be used with the adapter 

__ a. From the Enterprise Service Discovery window, click on Execute Query  button. You will see a 
Custome r business object under Objects discovered by query  
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__ b. Select Customer  business object and click Add to import list  button. The Customer business 
object will now be displayed under the Objects to be imported  

 

__ c. Click Next  

____ 5. Configure the objects that will be imported by the discovery agent 

__ a. From the Configure objects window, select Outbound  from the dropdown menu for the Service 
Type . Note the operations available for the selected Service Type 
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__ b. Enter the BO Location  as FFOutBO  and click Next  

 

____ 6. Specify the properties for the artifacts that will be generated in your workspace 

__ a. Create a new module 

1) Click on the New… button next to the Module  field 

2) From the New Integration Project window, ensure that the radio button next to Create a 
module project  is selected and click Next  
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3) Enter FFOutboundModule  for the Module Name field and click Finish  

 

__ b. The module which is created above will appear under the Module  field of the Generate Artifacts 
window 

__ c. From Generate Artifacts window, select the radio button next to Use discovered connection 
properties . This will make the Flat File MCF (Managed Connection Factory) and Resource 
Adapter Properties visible 

__ d. Enter the following fields: 

1) OutputDirectory: <OUT_DIR> 

2) LogFilename: C:\FFRA\outlog.txt  

3) TraceFilename: C:\FFRA\outtrace.txt  

__ e. Click Finish  
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____ 7. You can also configure/change the adapter properties using the Assembly Editor 
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__ a. Change to the Business Integration perspective if not open 

1) Select Window > Open Perspective > Other… . 

 

2) From the Select Perspective window, select Business Integration (default)  and click OK 

 

__ b. Expand FFOutboundModule  and double-click FFOutboundModule to open it in the Assembly 
Editor 

 

__ c. Click on FlatFileOutboundInterface  from the Assembly Editor and select Properties  tab from 
the bottom 

__ d. Select Binding  under Properties and select Endpoint Configuration  under Binding itself and 
then select the Connection  tab 
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1) Ensure the radio button next to Specify properties for pre-configured new J2EE 
Connector Architecture recourse  is selected and then c lick on Managed Connection 
Factory Properties  to expand them. You can change the properties that you entered using 
the ESD wizard in the previous steps and save those changes before you deploy the 
application onto the server 

 

2) Click on Resource Adapter  tab to view/change the Resource Adapter Properties 

 



© Copyright IBM Corporation 2007. All rights reserved 

IBM WEBSPHERE ADAPTER 6.0.2 – LAB EXERCISE 

2007 January, 19 IBM WebSphere Adapter 6.0.2 – Lab Exercise  Page 16 of 28 

 Flat Files Adapter Outbound 

Part 3: Test the adapter application using the WebS phere Process Server 
test environment  

In this part of the lab, you will use the WebSphere Process Server Test Environment to test the SCA 
application outbound processing. 

Flat File Adapter supports the following outbound operations: 

Create  –creates the specified file name in the specified directory with the content sent across in the 
request. If the file to be created already exists, a FlatFileCreateException is thrown and no file will be 
created. In other words, create operation doesn’t support the overwriting of the existing file. 

Append  –appends the content, specified in the request, at the end of the file. The file to be appended 
should exist, if not a FlstFileAppendException is thrown. 

Delete  –deletes the file from the directory specified in the request. If the file to be deleted doesn’t exist, a 
FlatFileDeleteException is thrown to the calling component. 

Retrieve  – retrieves the file contents of the file name specified in the request and sends as response. If 
the file doesn’t exist, a FlatFileRetrieveException is thrown to the calling component. 

Overwrite  – overwrites the file in the directory with the content specified in the request. It the file doesn’t 
exist, a FlatFileOverwriteException is thrown to the calling component. 

Exists  – checks the existence of a file. Returns true if the file name in the request exists in the specified 
directory and returns false if either directory or file name does not exist. 

List  – returns all the file names in the directory specified in the request. If the directory specified doesn’t 
exist, a FlatFileListException is thrown to the calling component. 

____ 1. Add the project to the WebSphere Process Server Test Environment 

__ a. Right-click on WebSphere Process Server v6.0  under the Servers view and select Add and 
remove projects…  from the context menu 
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__ b. In the Add and Remove Projects dialog, select the FFOutboundModuleApp  project from the 
Available projects panel  

 

__ c. Click Add >  to add it to the Configured projects panel.  Click Finish  

 

Wait for the project to be added to the server and the application to start. The server will be started in 
Debug mode if it is not already started before. 

____ 2. Publish the module to the WebSphere Process Server test environment 
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 From the Business Integration perspective, right-click on the FFOutboundModule  and select 
Test > Test Module  

 

 The FFOutBoundModule_Test editor will be opened 
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____ 3. Test Scenario : outbound for createCustomer  operation (Non-PassThrough) 

 Under Detailed Properties , for the Operation  field, select createCustomer  from the drop down 
menu 

 Fill out the fields for Initial request parameters: 

 For the fields – CustomerName, Address, City, State you can enter any string 

 fileName: createtest.xml  (a file with this name will be created under the directoryPath you 
will specify in the following step) 

 directoryPath: <OUT_DIR>  (Refer to the table at the beginning of this document for this 
value.  The specified subdirectory must already exist; otherwise you will receive a failure 
when trying to create the file.  This subdirectory is created for you, if you unzipped the 
LabFiles602.zip or you can manually create the subdirectory now. ) 

 For the remaining three fields – fileContentEndcoding, includeEndBODelimiter, 
stagingDirectory, you can set them to <null>  from the drop down menu.  You must set 
fileContentEncoding to <null> or <unset> for the newly created file to contain the content. 

 

 Click Continue  
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 From Deployment Location window, select WebSphere Process Servers > WebSphere 
Process Server v6.0 and click Finish  

 

 Click on the Invoke (FlatFileOutboundInterface:createCustomer)  and you will see a window 
similar to the following, that contains the data you just entered in the previous steps: 
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 Verify the created file contents 

__ a. Check the subdirectory <OUT_DIR> for the file createtest.xml  

__ b. Open the createtest.xml  file and it will contain the following contents: 

 

____ 4. Test Scenario : outbound for createFlatFile  operation (Pass-Through) 

 Click on Invoke button  at the top from the FFOutboundModule_Test window 

 Under Detailed Properties , for the Operation  field, select createFlatFile  from the drop down 
menu 

 Fill out the fields for Initial request parameters: 

 On the row that contains content , under Type and select browse button and then select 
UnstructuredContent  from the Data Type Selection window 

 Enter some string data for AsText  field 

 fileName: createtest.txt  (a file with this name will be created under the directoryPath you 
will specify in the following step) 

 directoryPath: <OUT_DIR>  (Refer to the table at the beginning of this document for this 
value.  The specified subdirectory must already exist, otherwise you will receive a failure 
when trying to create the file.  This subdirectory is created for you, if you unzipped the 
LabFiles602.zip or you can manually create the subdirectory now. ) 

 For the remaining three fields – fileContentEndcoding, includeEndBODelimiter, stagingDirectory, 
you can set them to <null>  from the drop down menu.  You must set fileContentEncoding to 
<null> or <unset> for the newly created file to contain the content 
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 Click on the Invoke (FlatFileOutboundInterface:createFlatFile)  and you will see a window 
similar to the following, that contains the data you just entered in the previous steps: 

 

 Verify the created file contents 

__ a. Check the subdirectory <OUT_DIR> for the file createtest.txt  

__ b. Open the createtest.txt  file and it will contain the following contents: 
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Part 4: Restore server configuration 

____ 1. Close the FFOutBoundModule_Test  window and click No for the Save Resources window 

 

____ 2. Right-click on WebSphere Process Server v6.0  under the Servers view and select Add and 
remove projects…  from the context menu 

 

____ 3. Select FFOutboundModuleApp  under Configured projects and click < Remove  
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____ 4. Click Finish  after you see the application moved to Available projects. Wait until the application is 
unpublished 

____ 5. Right-click on WebSphere Process Server v6.0  from the Servers view and select Stop  from the 
context menu 
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What you did in this exercise 

In this lab, you imported the Flat File Adapter RAR file into your WebSphere Integration Developer 
workspace and integrated it into an SCA application that creates a file to the file system. 

You made use of Enterprise Service Wizard available in WebSphere Integration Developer to specify 
Managed Connection Factory Properties and Resource Adapter Properties which, after deploying onto the 
server will generate Business Objects and other artifacts.  

In the end you deployed and then tested the adapter application for the operations available. 
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