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What this exercise is about   

This exercise shows you how to develop Interface maps (mediations) and Data maps. These are used to 
map between the PeopleSoft ASBOs and the GBOs and from the GBOs to the Siebel ASBOs.  

Lab Requirements 

List of system, software and other tasks required for the student to complete the lab. 

• WebSphere Integration Developer V6.0.1 installed 

• WebSphere Process Server V6.0 test environment installed 

• Sample code in the directory C:\Labfiles60 (Windows) or /tmp/LabFiles60 (Linux) 

• IBM WebSphere Business Integration Toolset installed 

• Visual Test Connector 

 

What you should be able to do 

At the end of this lab you should be able to 
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• Create and Interface map and define the handling of the parameters for the interfaces 

• Create a data map with a variety of transforms 

• Test the maps using Component Test 

 

Introduction 

The following diagram highlights the parts of the overall scenario that will be addressed in this lab. You will 
add mapping of business objects to the PeopleSoft and Siebel modules. This will build upon what you 
have already developed for these modules in the WBI Adapters – Import/Export lab.   
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Description of the Module 

Data mapping operations are used to convert between ASBOs and GBOs. In WebSphere Integration 
Developer, Data Maps are always contained within Interface Maps. What you will do is add an Interface 
Map to each module, and then build the Data Maps that are required to do the PeopleSoft ASBO to GBO 
mappings and the GBO to Siebel ASBO mappings. Then the test component will be used to test the 
Interface Map and its contained Data Maps.   
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Exercise Instructions 

Some instructions in this lab might be specific for Windows platforms.  If you run the lab on a platform 
other than Windows, you will need to run the appropriate commands, and use appropriate files ( for 
example .sh in place of .bat) for your operating system.  The directory locations are specified in the lab 
instructions using symbolic references as follows:  

 

Reference Variable Windows Location Linux Location 

<WID_HOME> C:\Program Files\IBM\WebSphere\ID\6.0 /opt/IBM/WebSphere/ID/6.0 

<WPS_HOME> <WID_HOME>\runtimes\bi_v6 <WID_HOME>/runtimes/bi_v6 

<LAB_FILES> C:\Labfiles60 /tmp/Labfiles60 

<WORKSPACE>  C:\Labfiles60\eXchange\WBIAdapters\w
orkspaceMaps 

/tmp/Labfiles60/eXchange/WBI
Adapters\workspace 

<TEMP> C:\temp /tmp 

<SOLUTION> C:\Labfiles60\WBIAdapters\Solution /tmp/WBIAdapaters/Solution 

 

Windows users’ note: When directory locations are passed as parameters to a Java program such as 
wsadmin, you must replace the backslashes with forward slashes to follow the Java convention. For 
example, C:\LabFiles60\ would be replaced by C:/LabFiles60/. 

Note that the previous table is relative to where you are running WebSphere Integration Developer.  The 
following table is related to where you are running remote test environment: 
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Reference Variable Example: Remote 
Windows test server 

location 

Example: Remote 
z/OS test server 

location 

Input your values for the 
remote location of the test 

server 

<SERVER_NAME> server1 cl1sr01  

<WAS_HOME> C:\Program 
Files\IBM\WebSphere\AppServer 

/etc/cl1cell/AppServerNode1  

<HOSTNAME> localhost mvsxxx.rtp.raleigh.ibm.com  

<BOOTSTRAP_PORT> 2809 2809  

<TELNET_PORT> N/A 1023  

<PROFILE_NAME> AppSrv01 default  

<USERID> N/A cl1admin  

<PASSWORD> N/A fr1day  

 

Instructions for using a remote testing environment, such as z/OS, AIX or Solaris, can be found at the end 
of this document, in the section “Task: Adding Remote Server to WebSphere Integration Developer 
Test Environment”.  
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Part 1: Initialize the Workspace for this Lab Exercise 

This lab exercise is dependent upon the completion of the WBIAdatpers – Import/Export lab exercise. 
There are two approaches you can take to performing this lab. 

1. Import pre-built projects – Using this approach, you will import a project which will establish 
your workspace with the required constructs from the previous lab exercise.  

2. Use your existing workspace – Using this approach, you will continue to use the workspace 
you were using in the previous lab exercise.  

It is recommended that you use approach 1 where you import pre-built projects. This is because it avoids 
any possible problems that may have been introduced when you completed the previous lab. In addition, 
the testing of the previous lab leaves some testing specific constructs that are not needed in this lab.  

Perform only one of the following steps depending upon your choice of workspace.  

If you want to import pre-built projects, follow the directions to initialize the Workspace for the lab using the 
following values:  

 <WORKSPACE> 

C:\Labfiles60\eXchange\WBIAdapters\workspaceMaps 

 <PROJECT_INTERCHANGE> 

C:\Labfiles60\eXchange\WBIAdapters\Solution\ImportExport_PI.zip 

 <MODULE> 

n/a 

 <DEPENDENT_LIBRARIES> 

  n/a 

If you want to use your existing workspace, follow the directions to initialize the Workspace for the lab using 
the following values:  

 <WORKSPACE> 

C:\Labfiles60\eXchange\WBIAdapters\workspace 

 <PROJECT_INTERCHANGE> 

n/a 

 <MODULE> 

n/a 

 <DEPENDENT_LIBRARIES> 

  n/a 
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____ 1. Start WebSphere Integration Developer V6 with a new workspace located at 
<WORKSPACE>.  

__ a. From Windows Explorer, navigate to the <WID_HOME> directory and double click on wid.exe. 

__ b. When prompted for workspace name, enter the value provided by the <WORKSPACE> variable for 
this lab and click OK. 

 

__ c. When WebSphere Integration Developer V6.0 opens, close the Welcome page by clicking on the Go 
to the workbench icon (bent over arrow at top-right).              

    

 

__ d. Ensure you are in the Business Integration perspective. 

There is more than one way to switch from one perspective to another. The different ways are described 
below.  

____ 1. After WebSphere Integration Developer V6.0 opens, you can determine which perspective you are 
currently in. 
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__ a. Look for the perspective name in the title bar. 

 

__ b. In the top right of WebSphere Integration Developer, you can see the name of the current perspective 
displayed as you hover the mouse over the perspective icon. 

 

____ 2. Select a new perspective you want to switch to. 

__ c. From the top right of WebSphere Integration Developer workspace, click ( ) and select Other. 

__ d. The Select Perspective dialog will appear.  Highlight the perspective that you want to open or you can 
select Show All to view all available perspective within the workspace. 

 

__ e. Click OK. 
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NOTE: You can also open perspectives through Window -> Open Perspective -> Other and then choose 
your perspective. 

____ 3. Select an existing perspective that you have not used before. 

__ f. From the top right of WebSphere Integration Developer workspace, click ( ) which is next to the name 
of the current perspective. 

__ g. Once you click on ( ), you will get the list of existing perspectives that you have opened before from 
the same workspace. 

 

____ 4. Close Perspective. 

__ h. Right click on the perspective and select Close to close the currently open perspective or Close All to 
close all perspectives. 

 

 

____ 5. If this lab requires you to import a project interchange file, setup the required libraries and 
modules for this lab by importing the project interchange file <PROJECT_INTERCHANGE>.  

__ i. From the menu bar, select File -> Import… 
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__ j. In the Import dialog, scroll down and select Project Interchange. 

 

__ k. Click Next. 

__ l. In the Import Projects dialog, initialize the From zip file: field to <PROJECT_INTERCHANGE>. 
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__ m. Click the Select All button. 

 

__ n. Click Finish. 

____ 6. If this lab requires that you create a Business Integration module called <MODULE>, 
complete these steps: 

__ o. Right click on the background of the Business Integration view to access the pop-up menu. 

__ p. Select New > Module. 
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__ q. In the New Module dialog, enter <MODULE>  for the Module Name. 

 

__ r. Click Finish. 

____ 7. If this lab requires that <MODULE> needs any <DEPENDENT_LIBRARIES>, complete 
these steps. 

__ s. In the Business Integration view, right click on the <MODULE> you just created to access the pop-up 
menu. 

__ t. Select Open Dependency Editor. 

 

__ u. In the Dependency Editor, click the Add… button. 

__ v. In the Library Selection dialog, select from the list the <DEPENDENT_LIBRARIES>. 

__ w. Click OK. 

__ x. Press Ctrl+S to save the dependencies for this module. 
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Part 2: Define Interface Maps and Data Maps for PeopleSoft 

In this part you will create the Interface Map needed to map the InboundDelivery interface of the Export for 
the PeopleSoft adapter to the CleansePublish interface which will be called on the CleansePublish 
module. Within the Interface Map you will define the Data Maps required to map the PeopleSoft ASBOs to 
the GBOs.   

____ 1. Establish your WebSphere Integration Developer and WebSphere Process Server environments for 
completing this lab.  

__ a. Start WebSphere Integration Developer specifying a workspace that has been initialized according to 
the instructions in the LAB: WBI Adapters – Import/Export. 

__ b. Ensure you are in the Business Integration perspective (see task Switching Perspectives within the 
Workspace). 

____ 8. Open the PeopleSoftAdapter in the Assembly Editor. 

__ c. In the Business Integration view, use the + in front of PeopleSoftAdapter to expand its sub-tree. 

__ d. Right click on the PeopleSoftAdapter module assembly and select Open With > Assembly Editor. 

 

____ 9. Add the Import that will be used to call the CleansePublish module. 

__ e. Click on the ( ) by the second icon down to expand the submenu, and then click on the Import icon 
(icon with the arrow going out). 

 

__ f. Move the mouse over the assembly editor pallet and click the mouse to drop the Import, and the result 
should look like this: 
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__ g. Click on Import1 and the add Interface icon should appear.  

 

__ h. Click on the Add Interface icon and the Add Interface dialog will appear. 

 

__ i. Select CleansePublish and click OK. 

__ j. In the lower panel, click on the Properties tab to see the properties panel for Import1.  

 

__ k. Change the Display name and Name both to be CleansePublish (hint � update the Name field first 
and the Display name will be automatically updated).  

__ l. Set the folder by using the Move… button. 

__ m. In the Select Folder for Import CleansePublish dialog, click the New Folder… button. 



© Copyright IBM Corporation 2006. All rights reserved 

2006 August, 02 IBM WebSphere Process Integration 6.0 – Lab Exercise Page 14 of 60 

 WPSWIDv6_eXcLab_WBIAMappinglab.doc 

__ n. In the New Folder dialog, enter the folder name com/clipsandtacks/scm. 

 

__ o. Click OK. 

__ p. On the Select Folder for Import CleansePublish dialog, click OK. 

__ q. Verify that the properties have been correctly initialized to the following values. 

 

__ r. Right click on the CleansePublish Import and select Generate Binding… > SCA Binding. 

 

__ s. Press Ctrl+S to save the Assembly Diagram. 

____ 10. Add the Interface Map that will map the InboundDelivery interface to the CleansePublish 
interface. 

__ t. In the Business Integration view, expand to Mapping under the PeopleSoftAdapter sub-tree. 

 



© Copyright IBM Corporation 2006. All rights reserved 

2006 August, 02 IBM WebSphere Process Integration 6.0 – Lab Exercise Page 15 of 60 

 WPSWIDv6_eXcLab_WBIAMappinglab.doc 

__ u. Right click on Interface Maps and select New > Interface Map. 

 

__ v. In the New Interface Map dialog, set the following values:  

Module: PeopleSoftAdapter 

Namespace: (accept the default) 

Folder: com/clipsandtacks/scm (you can use the Browse… dialog to select this) 

Name: InboundDeliveryToCleansePublish 

 

__ w. Click Next. 

__ x. On the next panel, use the drop down boxes to select InboundDelivery as the Source interface and 
CleansePublish as the Target interface.  
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__ y. Click Finish and you should see the Interface Mapping editor displayed with the Operation Mappings 
pane visible.  

 

____ 11. Define the InboundDeliveryToCleansePublish Interface Map. 

__ z. Draw a line from the receivedPsft_ClipTypeDelivery operation to the cleanseAndPublishClip operation. 
This is done by doing a click and hold on receivedPsft_ClipTypeDelivery and dragging and dropping 
onto cleanseAndPublishClip.  

 

 

__ aa. Click on the line between the two operations, and the Parameter mappings pane will become visible. 

 

__ bb. Draw a line from the Psft_ClipTypeRequest parameter to the inClipBG parameter.  

 

__ cc. Notice that the default parameter mapping operation is a move. Since these parameters are of 
different types, you will need to change this to a map in the next step.  
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____ 12. Create the Data Map to map the Psft_ClipTypeRequest parameter (which is a 
Psft_ClipTypeBG) to the inClipBG parameter (which is a ClipBG). 

__ dd. Click on the line with the move to select it. 

__ ee. Click on the Properties tab in the lower pane and then on the Description tab. 

__ ff. Use the drop down box to change the Parameter Mapping Type from move to map. 

 

__ gg. Click on the Details tab in the Properties view. 

 

__ hh. Click the New… button to open the New Business Object Mapping wizard dialog.  

__ ii. In the top portion of the dialog, set the following values. 

Module: PeopleSoftAdapter 

Namespace: (accept the default) 

Folder: com/clipsandtacks/scm (you can use the Browse… dialog to select this) 

Name: PsftClipTypeBGToClipBG 
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__ jj. Click Next. 

__ kk. For both the Input Type and Output Type, click on the Business Graph radio button so that the lists 
are filtered to only show Business Graphs – this makes looking through the list easier.  

 

__ ll. Select Psft_ClipTypeBG for the Inputs. 

__ mm. Select ClipBG for the Outputs.  

__ nn. Click Finish. 

__ oo. Press Ctrl-S to save the Interface Map. 

____ 13. Open the PsftClipTypeBGToClipBG map that you just created in the Map Editor. 

__ pp. Expand PeopleSoftAdapter > Mapping > Data Maps in the Business Integration view. 

__ qq. Double click on PsftClipTypeBGToClipBG to open it in the Map Editor. 

 

____ 14. Map the verb (when mapping a BG, you generally always want to move the verb). 
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__ rr. Click and hold on the verb in Psft_ClipTypeBG and drag to the verb in ClipBG. 

 

__ a. Notice that the default transformation is move, which is what you want in this case.  

____ 15. Map the contained Business Objects. 

__ b. Click and hold on Psft_ClipType and drag to Clip. 

 

__ c. Notice that in this case, since you are mapping from BO to BO, the default transformation is Submap. 

____ 16. Create the Submap. 

__ d. Click on the Submap so that you can access information about the submap in the Properties view. 

 

__ e. Click on the Details tab in the Properties view.  

__ f. Click the New… button to open the New Business Object Map wizard dialog.  

__ g. In the top portion of the dialog, set the following values. 

Module: PeopleSoftAdapter 

Namespace: (accept the default) 

Folder: com/clipsandtacks/scm 

Name: PsftClipTypeToClip 

__ h. Click Next. 

__ i. For both the Input Type and Output Type, click on the Business Object radio button so that the lists 
are filtered to only show Business Objects – this just makes looking through the list easier.  

__ j. For the Inputs, make sure that Psft_ClipType is checked. 

__ k. For the Outputs, make sure that Clip is checked. 

__ l. Click Finish. This will put you into the map editor for the map you just created. 
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____ 17. Map the fields from Psft_ClipType to Clip. 

__ m. By using the click, hold and drag technique, define move transformations for the following:  

ClipID > clipID 

Clip > clip 

Size > size 

Color > color 

 

__ n. The GLN field is used to hold the Global Location Number, a 13 digit number which uniquely identifies 
Clips and Tacks Clip Division. This will be set by the map using an Assign. 
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1) Right click on GLN and select Create Transform > Assign. 

 

2) Click on the left of the Assign. 

 

3) Click on the Details tab in the Properties view. 

4) Ensure that the User defined value radio button is selected.  

5) Fill in a value of 1234567890123. 

 

__ o. The brand field is also set by the map to Clips and Tacks. 

1) Right click on brand and select Create Transform  > Assign. 

2) Click on the left of the Assign. 

 

3) Click on the Details tab in the Properties view. 

4) Ensure that the User defined value radio button is selected.  
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5) Fill in a value of Clips and Tacks. 

 

__ p. Map RetailUnits to retailItems. This will require a submap.  

1) Drag a line between RetailUnits Psft_RetailItem [ ] and retailItems ClipItem[ ] to define a submap 
transform. 

 

2) Click on the left of the Submap. 

3) In the Properties view, click on the Details tab. 

4) Click the New… button by the Business Object Mapping field. 

5) In the top portion of the dialog, set the following values. 

Module: PeopleSoftAdapter 

Namespace:  (accept the default) 

Folder: com/clipsandtacks/scm 

Name: PsftRetailItemToClipItem 

6) Click Next. 

7) For both the Input Type and Output Type, click on the Business Object radio button so that the 
lists are filtered to only show Business Objects. 

8) For the Inputs, ensure that Psft_RetailItem is selected. 

9) For the Outputs, ensure that ClipItem is selected. 

10) Click Finish. This will put you into the map editor for the map you just created: 
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____ 18. Map the fields from Psft_RetailItem to ClipItem. 

__ a. By using the click, hold and drag technique, define move transformations for the following:  

ItemCode > itemID 

Package > package 

Quantity > quantity 

Price > price 

AvailableDate > startDate 

WithdrawDate > endDate 

 

__ b. GTIN is a Global Trade Item Number is a 14 digit number which uniquely identifies this saleable 
item. It is composed of a portion that is unique to ClipsAndTacks.com and a portion that is a 
unique identifier within ClipsAndTacks.com. This will be accomplished using a custom transform 
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containing a Java snippet that concatenates a constant for the ClipsAndTacks.com portion and 
the item code for this retail item.  

1) Draw a line from ItemCode to GTIN which will create a move transform.  

2) Click on the left side of the Move. 

 

3) In the Properties view, on the Description tab, use the Transform type dropdown box to 
select Custom. 

 

4) Click on the Details tab. 

5) Select the Java radio button. 

6) Click on Yes for the Question dialog that pops up. 

7) The snippet code that is displayed is not needed.  Select it (Ctrl+A) and click Delete to 
remove it. 

 

8) With the cursor placed in the text entry box, click Ctrl-Spacebar to get the context assist 
dropdown. 
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9) Select the target field ClipItem_GTIN and click Enter.  

10) Enter a space,  =, a space, “123456789”, a space, +, a space and then click Ctrl-
Spacebar again for context assist. 

 

11) Select the field Psft_Retailitem_ItemCode and click Enter. 

12) Enter ; (semi colon)  and result should look like this: 

 

__ c. Handle the fullDescription field by combining the Package and Quantity fields using a Join 
transform.  

1) Drag a line from Package to fullDescription and you will see a Move transform generated.  

2) Drag a line from Quantity to fullDescription and you will see the transform changed to a 
Join. 

   

3) Click on the left of the Join to bring up this transform in the Properties view.  

4) Click on the Details tab in the Properties view. You will see the fields that are part of the 
Join. You will also notice that there is the ability to reorder the fields and to specify a 
delimiter to be inserted between the fields. In this case you will use a blank for the delimiter 
and the order is correct, so there is nothing else to do.  
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__ d. Handle the OwningContact field, which is in the format of lastname,firstname. This field must be 
split between the contactFirstName and contactLastName fields which can be done using the 
Extract transform.  

1) Draw a line from OwningContact to contactFirstName and the default Move transform will 
be created.  

2) Click in front of the Move to bring up the transform in the Properties view.  

3) Click on the Description tab. 

4) In the Transform Type field, use the dropdown box and select Extract. 

5) Click on the Details tab. 

6) Enter a , (comma) for the delimiter. 

7) Enter a 1 for the Substring index (this is a zero based number, so 1 is the second item). 
You will notice at the bottom there is an example which shows the delimiter and the 
substring index (position) you have defined.  

 

8) Draw a line from OwningContact to contactLastName and the default Move transform will 
be created.  

9) Click in front of the Move to bring up the transform in the Properties view.  

10) Click on the Description tab. 

11) In the Transform Type field, use the dropdown box and select Extract. 

12) Click on the Details tab. 

13) Enter a , (comma) for the delimiter. 

14) Enter a 0 for the position. 

 



© Copyright IBM Corporation 2006. All rights reserved 

2006 August, 02 IBM WebSphere Process Integration 6.0 – Lab Exercise Page 27 of 60 

 WPSWIDv6_eXcLab_WBIAMappinglab.doc 

__ e. Your map should look like this:  

 

__ f. Press Ctrl-S to save the map.  

____ 19. The Interface Map and all three Data Maps are now complete. Prior to proceeding, ensure 
that all the maps you have been working with are saved.  

__ q. Examine the tabs at the top of the editors pane. 

 

__ r. For each one with an asterisk (*), click on the tab to bring that editor to the foreground and then click 
Ctrl-S to save.  

____ 20. You are now ready to add the Interface Map to the wiring diagram.  

__ a. Click on the Assembly Diagram: PeopleSoftAdapter tab on the top of the editors pane.  

__ b. In the Business Integration view, navigate to PeopleSoftAdapter > Mapping > Interface Maps. 
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__ c. Click on InboundDeliveryToCleansePublish and drag it onto the Assembly Editor. 

 

__ d. Draw a wire from the PsftConnectorDeliveryHub Export to the 
InboundDeliveryToCleansePublish Interface Map.  

__ e. Draw a wire from the InboundDeliveryToCleansePublish Interface Map to the CleansePublish 
Import.  

 

__ f. Press Ctrl-S to save the Assembly Diagram. 
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Part 3:  Define Interface maps and Data maps for Siebel 

In this part you will create the Interface Map needed to map the Publish interface of the Export which is 
called by the CleansePublish module to the OutboundRequest interface supported but the Import used to 
talk to the Siebel Adapter. Within the Interface Map you will define the Data Maps required to map the 
GBOs to the Siebel ASBOs.  

____ 1. Open the SiebelAdapter in the Assembly Editor. 

__ a. In the Business Integration view, Expand SiebelAdapter. 

__ b. Right click on the SiebelAdapter module assembly and select Open With > Assembly Editor. 

____ 21. Add the Export that will be used to call this module from the CleansePublish module. 

__ a. Click on the > by the second icon from the top to expand the submenu, then click on the Export 
icon (the arrow coming into the icon). 

 

__ b. Move the mouse over the assembly editor pallet and click the mouse to drop the Export. 

__ c. Click on Export1 and the add Interface icon should appear. 

__ d. Click on the Add Interface icon and the Add Interface dialog will appear. 

__ e. Select Publish and click OK. 

__ f. Click on the Properties tab in the lower panel to see the properties panel for Export1. 

__ g. Change the Display name and Name both to Publish. 

__ h. Set the location by using the Move… button. 

__ i. Click the New Folder… button in the Select Folder for Export Publish dialog. 

__ j. Enter the folder name com/clipsandtacks/scm in the New Folder dialog. 

__ k. Click OK. 

__ l. Click OK on the Select Folder for Export Publish dialog. 
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__ m. Verify that the properties have been correctly initialized to the following values. 

 

__ n. Press Ctrl-S to save the Assembly Diagram. 

____ 22. Add the Interface Map that will map the Publish interface to the OutboundRequest interface. 

__ a. In the Business Integration view, Expand Mapping under the SiebelAdapter sub tree. 

__ b. Right click on Interface Maps and select New > Interface Map. 

__ c. In the New Interface Map dialog, set the following values:  

Module: SiebelAdapter 

Namespace: (accept the default) 

Folder: com/clipsandtacks/scm (you can use the Browse… dialog to select this.) 

Name: PublishToOutboundRequest 

__ d. Click Next. 

__ e. On the next panel, use the drop down boxes to select Publish as the Source interface and 
OutboundRequest as the Target interface. 

__ f. Click Finish and you should see the Interface Mapping editor displayed with the Operation 
Mappings pane visible. 

 

____ 23. Define the PublishToOutboundRequest Interface Map. 

__ a. Draw a line from the publishClip operation to the sendSiebel_ProductTypeRequest operation. 
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__ b. Click on the line between the two operations, and the Parameter mappings pane will become 
visible.  

 

NOTE: You will notice that the publishClip operation only has an input while the 
sendSiebel_ProductTypeRequest not only has an input but also has an output and a fault. In this lab you 
will just map the inputs and ignore the output and the fault. In the subsequent lab on relationships changes 
will be made to handle the output.  

__ c. Draw a line from the inClipBG parameter to the Siebel_ProductTypeRequest parameter. 

__ d. Notice that the default parameter mapping operation is a move. Since these parameters are of 
different types, you will need to change this to a map in the next step.  

____ 24. Create the Data Map to map the inClipBG parameter (which is a ClipBG) to the 
Siebel_ProductTypeRequest parameter (which is a Siebel_ProductTypeBG). 

__ a. Click on the Move. 

__ b. Click on the Properties tab in the lower pane and then on the Description tab. 

__ c. Use the drop down box to change the Parameter Mapping Type from move to map. 

__ d. Click on the Details tab in the Properties view. 

__ e. Click the New… button to open the New Business Object Map wizard dialog.  

__ f. Set the following values in the top portion of the dialog:  

Module: SiebelAdapter 

Namespace: (accept the default) 

Folder: com/clipsandtacks/scm (you can use the Browse… dialog to select this) 

Name: ClipBGToSiebelProductTypeBG 

__ g. Click Next. 
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__ h. For both the Input Type and Output Type, click on the Business Graph radio button so that the lists 
are filtered to only show Business Graphs – this just makes looking through the list easier.  

__ i. For the Inputs, select ClipBG. 

__ j. For the Outputs, select Siebel_ProductTypeBG. 

__ k. Click Finish. 

__ l. Press Ctrl-S to save the Interface Map. 

____ 25. Open the ClipBGToSiebelProductTypeBG map that you just created in the Map Editor. 

__ a. Expand SiebelAdapter > Mapping > Data Maps in the Business Integration view. 

__ b. Double click on ClipBGToSiebelProductTypeBG to open it in the Map Editor. 

____ 26. Map the verb. 

__ a. Click and hold on the verb in ClipBG and drag to the verb in Siebel_ProductTypeBG which will 
create a Move transform. 

____ 27. Map the contained Business Objects. 

__ a. Click and hold on Clip and drag to Siebel_ProductType which will create a Submap transform. 

____ 28. Create the Submap. 

__ a. Click on the Submap so that you can access information about the Submap in the Properties 
view. 

 

__ b. Click on the Details tab in the Properties view. 

__ c. Click the New… button to open the New Business Object Map wizard dialog.  

__ d. Set the following values in the top portion of the dialog:  

Module: SiebelAdapter 

Namespace: (accept the default) 

Folder: com/clipsandtacks/scm 

Name: ClipToSiebelProductType 

__ e. Click Next. 

__ f. For both the Input Type and Output Type, click on the Business Object radio button so that the 
lists are filtered to only show Business Objects. 

__ g. For the Inputs, select Clip. 

__ h. For the Outputs, select Siebel_ProductType. 

__ i. Click Finish. This will put you into the map editor for the map you’ve just created. 
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____ 29. Map the fields from Clip to Siebel_ProductType. 

__ j. The first transform will be to use a Join to initialize the Description field with the size, clip and 
color fields.  

1) Draw a line from size to Description. This will result in the default Move transformation.  

2) Draw a line from clip to Description. This will change the transformation to a Join.  

3) Draw a line from color to Description. Your map should now look like this.  

 

__ k. Map retailItems to ProductPackages. This requires a submap.  

1) Drag a line between ClipItem [ ] and Siebel_ProductPackage [ ] to define a submap 
transform. 

 

2) Click on Submap. 
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3) Click on the Details tab in the Properties view. 

4) Click the New… button by the Business Object Map field. 

5) Set the following values in the top portion of the dialog:  

Module: SiebelAdapter 

Namespace: (accept the default) 

Folder: com/clipsandtacks/scm 

Name: ClipItemToSiebelProductPackage 

6) Click Next. 

7) For both the Input Type and Output Type, click on the Business Object radio button so 
that the lists are filtered to only show Business Objects. 

8) For the Inputs, select ClipItem. 

9) For the Outputs, select Siebel_ProductPackage. 

10) Click Finish. This will put you into the map editor for the map you just created.  

 

____ 30. Map the fields from ClipItem to Siebel_ProductPackage. 

__ a. By using the click, hold and drag technique, define Move transformations for the following:  

GTIN > GlobalIdentifier 

fullDescription > PackageDescription 

price > Price 

startDate > AvailabilityStart 
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endDate > AvailabilityEnd 

__ b. The Contact field will contain the name in the firstname lastname format. Create a Join 
transformation to do this.  

1) Draw a line from contactFirstName to Contact.  

2) Draw a line from contactLastName to Contact.  

__ c. Your map should look like this:  

 

__ d. Press Ctrl-S to save the map.  

____ 31. The Interface Map and all three Data Maps are now complete. Prior to proceeding, ensure 
that all the maps you have been working with are saved.  

__ m. Examine the tabs at the top of the editors pane. 

 

__ n. For each one with an asterisk (*), click on the tab to bring that editor to the foreground and then press 
Ctrl-S to save.  

____ 32. You are now ready to add the Interface Map to the wiring diagram. 

__ a. Click on the Assembly Diagram: SiebelAdapter tab on the top of the editors pane. 

__ b. Navigate to SiebelAdapter > Mapping > Interface Maps in the Business Integration view. 
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__ c. Click on PublishToOutboundRequest and drag it onto the Assembly Editor. 

__ d. Rearrange the assembly diagram by dragging the elements so that they look like this: 

 

__ e. Draw a wire from the Publish Export to the PublishToOutboundRequest Interface Map. 

 

__ f. Draw a wire from the PublishToOutboundRequest Interface Map to the 
SiebelConnectorAgent Import.  

 

__ g. Press Ctrl-S to save the Assembly Diagram. 
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Part 4: Test the PeopleSoft Maps 

There are two ways that the maps created for PeopleSoft can be tested. The first approach would be to 
use the Test Component to drive the Interface Map on the input side and to see the result on the output 
side. This would be a unit test of just the maps. The other approach would be to use the Visual Test 
Connector to drive input through the Export which is wired to the Interface Map and then to use the Test 
Component to see the result on the output side of the Interface map. This not only tests the maps but also 
the wiring to ensure your module works as a whole. This is the approach you will take in this section.  

____ 1. Add the PeopleSoftAdapter module to the UTE server so that it can be tested. 

__ a. From the Server view, right click on the server and select Add and Remove Projects… from the 
popup menu.  

 

__ b. In the Add and Remove Projects dialog, select the PeopleSoftAdapterApp project from the 
Available projects panel. 



© Copyright IBM Corporation 2006. All rights reserved 

2006 August, 02 IBM WebSphere Process Integration 6.0 – Lab Exercise Page 38 of 60 

 WPSWIDv6_eXcLab_WBIAMappinglab.doc 

__ c. Click Add > to add it to the Configured projects panel. 

 

 

__ d. Click Finish. 

__ e. If using a remote testing environment, follow the directions provided in Task: Adding Remote 
Server to WebSphere Integration Developer Test Environment (at the end of this document) 
to restart a server.   
 
If using a local testing environment, the server will automatically begin to start so that the module 
can be added to the server.  

__ f. You will at first see the following in the Servers view in the lower right panel.  
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__ g. You will then see the Console view appear with something similar to the following:  

 

__ h. Wait for the server startup to complete. This may take several minutes. Look for the “Server 
server1 open for e-business” message in the console.  

 

____ 2. The server must be restarted at this point for the messaging engine to be fully in initialized and 
ready to receive input from the Visual Test Connector.  

__ a. If using a remote testing environment, follow the directions provided in Task: Adding Remote 
Server to WebSphere Integration Developer Test Environment (at the end of this document) 
to restart a server.   
 
If using a local testing environment, click the Restart the server icon. 

  

__ b. Wait for the server restart to complete.  

____ 3. Connect the Visual Test Connector to the UTE Server. 

__ a. Using the connector configuration you created previously and saved at 
<LAB_FILES>\eXchange\PeopleSoft\ASBOs\PsftConnectorWPS.cfg follow the instructions 
below.  

____ 4. Ensure the WebSphere Process Server is active (the server is the JMS Broker).   The VTC requires 
an active JMS Broker to start its connection.  

____ 5. Start the Visual Test Connector. 

__ a. From the menu, select Programs > IBM WebSphere Business Integration Adapters > IBM 
WebSphere Business Integration Toolset > Visual Test Connector (VTC).  This opens a 
command window in the background where the process runs and the Visual Test Connector 
Interface in the foreground.  Do not close the command window as this will cause the VTC to 
exit. 

____ 6. Create/Select a Profile. 
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__ b. From the VTC interface, select File > Create/Select Profile. 

 

__ c. If a profile does not already exist, create one by selecting File > New Profile …  If a profile does 
already exist skip to step d. 

 

__ d. Browse to and select the connector configuration file, type in a Connector Name for the Profile, 
and select WAS for the Broker Type.   Click OK. 
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__ e. Select and highlight the profile and click OK 

 

__ f. Select File > Connect. 

 

__ g. View messages in the lower window.   

 

____ 7. Attach the test component to the PeopleSoftAdapter module. 

__ a. In the Business Integration view, right click on the PeopleSoftAdapter and select Test > Attach. 
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__ b. Click on the Configurations tab at the bottom of the PeopleSoftAdapter_Test view. You should 
see something like the following:  

 

__ c. Notice PsftConnectorDeliveryHub.<export> -> InboundDeliveryToCleansePublish and 
InboundDeliveryToCleansePublish -> CleansePublish are listed under monitors. These are 
the wires, and the monitors will allow you to look at the data that passed through the wire when 
the test is run.  
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__ d. Click on the Events tab at the bottom of the PeopleSoftAdapter_Test view. You should see 
something like the following screen capture. This is where the results will be shown when the 
application is invoked.  

 

__ e. Click on Continue.  

__ f. Expand WBI 6.0 Server in the Deployment Location window and select the appropriate 
WebSphere Process Server on which you want to deploy the application. This is especially true 
for z/OS, AIX, Solaris remote test environment, where the WebSphere Integration Developer will 
be remote to the test environment. Click Finish 
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__ g. Click Finish. The Test Component is now ready to monitor the execution flow.  

____ 8. Load a predefined business object into the Visual Test Connector. 

__ a. In the VTC window, select Edit > Load Business Object. 

__ b. In the Open dialog, navigate to c:\Labfiles60\eXchange\PeopleSoft\ASBOInstances and 
select PsftASBO1.bo. 

__ c. Click Open. 

__ d. In the New Instance dialog, enter a name to be assigned to this instance, such as Psft1. 

__ e. Click OK. 
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__ f. This is the same ASBO that was used in the previous lab. You can examine its contents to be 
familiar with the data it will be sending into the server. 

 

____ 9. Send the business object to the server. 

__ a. Select Request > Send in the Visual Test Connector. 

____ 10. Examine the resulting business object in the server test component. 

__ a. In the Events panel, use the + to expand Attach and then Session. You should see the Request 
Monitor for the wire between the InboundDeliveryToCleansePublish Interface Map and the 
CleansePublish Import.  

 

__ b. Click on Request Monitor (InboundDeliveryToCleansePublish -> CleansePublish). The 
object that went over this wire will be visible on the right side in the Request parameters box.  

 

__ c. Scroll down to view the rest of the data. 
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__ d. Compare the data from the Visual Test Connector with the data in the Test Component to verify 
that the mapping operations you defined worked properly.  

____ 11. Stop and close the test component. 

__ h. Click the Stop icon at the upper right corner Events pane. 

 

__ a. Click the X on the PeopleSoftAdapter_Test tab.  

__ b. Click No in the Save Resource dialog. 

____ 12. Close the Visual Test Connector. 

__ a. Select File > Exit in the VTC window. 

__ b. Select Yes In the Shutdown dialog. 

__ c. Click the enter key in the Visual Test Connector command window to close it. 
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Part 5: Test the Siebel Maps 

As with PeopleSoft, there are two ways that the maps created for Siebel can be tested. In both cases the 
Interface Map is driven with the Test Component. The first approach would be to also use the Test 
Component to monitor the output of the Interface Map and the other would be to let it flow all the way to 
the Visual Test Connector. The later is the approach you will take in this section.  

This section assumes that the server is still running from the previous testing of the PeopleSoftAdapter 
module. However, these instructions should work whether the server is running or not when you begin.  

____ 1. Configure the UTE server so that the SiebelAdapter module can be tested.  

__ a. From the Server view, right click on the server and select Add and Remove Projects… from the 
popup menu.  

__ b. In the Add and Remove Projects dialog, use the Add > and < Remove buttons to configure the 
server so that the SiebelAdapter module is in the Configured projects list and that the 
PeopleSoftAdapter is in the Available projects list.   

__ c. Click on Finish. 

__ d. Wait for the server to complete the reconfiguration. Look in the lower right corner any you will 
see indicators such as this. 

 

__ e. Wait for the publishing to finish. If your server was not started when you began this, there will be 
a wait while the server starts before publishing takes place.  

____ 33. Connect the Visual Test Connector to the UTE Server. 

__ a. Using the connector configuration you created previously and saved at 
<LAB_FILES>\eXchange\Siebel\ASBOs\SiebelConnectorWPS.cfg follow the instructions 
below. 

____ 34. Ensure the WebSphere Process Server is active (the server is the JMS Broker).   The VTC 
requires an active JMS Broker to start it’s connection.  

____ 35. Start the Visual Test Connector. 

__ i. From the start menu, select Programs > IBM WebSphere Business Integration Adapters > 
IBM WebSphere Business Integration Toolset > Visual Test Connector (VTC).  This opens a 
command window in the background where the process runs and the Visual Test Connector 
Interface in the foreground.  Do not close the command window as this will cause the VTC to 
exit.  

____ 36. Create/Select a Profile. 

__ j. From the VTC interface, select File > Create/Select Profile. 
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__ k. If a profile does not already exist, create one by selecting File > New Profile… if a profile does 
already exist skip to step d. 

 

__ l. Browse to and select the connector configuration file, type in a Connector Name for the Profile, 
and select WAS for the Broker Type.   Click OK. 
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__ m. Select and highlight the profile and click OK. 

 

__ n. Select File > Connect. 

 

__ o. View messages in the lower window.   

 

____ 37. Open the SiebelAdapter in the Assembly Editor. 

__ a. In the Business Integration view, Expand SiebelAdapter. 

__ b. Right click on the SiebelAdapter module assembly and select Open With > Assembly Editor. 

____ 38. Setup the Test Component to drive the test. 

__ a. In the Assembly Editor, right click on the PublishToOutboundRequest Interface Map and select 
Test Component from the popup menu.  
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__ b. Click on the Configurations tab at the bottom of the PublishToOubboundRequest_Test panel. 
You should see something like the following:  

 

__ c. Notice that there is an Emulator defined for the SiebelConnectorAgent. This means the Test 
Component is set up to emulate the Import going to the Visual Test Connector rather than letting 
it process. Since you want to let this process, you need to remove this emulator. 

1) Select the emulator wbia/asbo/SiebelConnectorAgent. 

2) Click the Remove button. 

__ d. Click on the Events tab at the bottom of the PublishToOubboundRequest_Test panel.  

__ e. Fill in the data values for the ClipBG. 

  For verb, use the drop down box in the value column to set the value create. 

__ f. Fill in the data values for the Clip. 

clipID: CID12345 

GLN: 1234567890123 

clip: clasp 

size: small 

color: black 

brand: Clips and Tacks 

__ g. Create a ClipItem instance. 

1) Select and right click on retailItems. 

2) Select Add Element. 

__ h. Scroll down so that you can fill in the data values for the ClipItem. 

Set itemID: 98765. 

Set GTIN: 12345678912345. 

Set package: box. 
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Set quantity: 40. 

Set fullDescription: box 40. 

Set price: 2.59. 

Set startDate: 2005-03-01. 

Set endDate: 2010-06-30. 

Set contactFirstName: Sam. 

Set contactLastName: Jones. 

__ i. Save the object values so that you will not have to reenter them another time if you repeat the 
testing scenario.  

1) Scroll back to the top of the Initial request parameters panel. 

2) Select and right click on ClipBG. 

3) Select Add value to Pool… 

4) Give it a name, such as inClipBG. 

5) Click OK. 

____ 39. Run the test. 

__ p. Click Continue. 

__ q. Expand WBI 6.0 Server in the Deployment Location window and select the appropriate 
WebSphere Process Server on which you want to deploy the application. This is especially true 
for z/OS, AIX, Solaris remote test environment, where the WebSphere Integration Developer will 
be remote to the test environment. Click FinishClick Finish. 

____ 40. You can now examine the following items:  

__ r. Expand Invoke > Started in the Events panel and you should see the following. It shows the 
invocation on the PublishToOuboundRequest interface map and also the request which is what 
went over the wire to the SiebelConnectorAgent import.  
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__ s. Double click on the Request so that you can see the output of the Interface map. 

 

__ t. Switch to the Visual Test Connector window. You should see an entry in the Business Object 
Request List as shown below.  

 

__ u. Double click on the Siebel_ProductType.Create and you will get a Response Business Object 
window showing you what was sent to the Visual Test Connector.  
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__ v. Enlarge the window and expand the ProductPackages[n] and [0] elements.  You should see 
something like the following:  

 

__ w. Compare the values reported above with those entered in the Test Component to see if the 
mapping definitions you defined appear to have worked correctly. Also, these should be the 
same as what was passed on the wire.  

____ 41. Now you can send back a response to the server.  

__ x. In the Response Business Object window you will enter a value for the Key = A1234. 

__ y. Click OK. 

__ z. Send the response back to the server by selecting Request > Reply > Success. 
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__ aa. You will see in the Test Component a Response to the Invocation. Double click on the 
Response so that the Response parameters show on the right panel. Examine the returned 
ebel_ProductType business object to see the Key has been set to A1234.  

 

____ 42. Stop and close the test component. 

__ bb. Click the Stop icon at the upper right corner Events pane. 

  

__ cc. Click the X on the PublishToOutboundRequest_Test tab.  

d  

__ dd. Click No in the Save Resource dialog. 

____ 43. Close the Visual Test Connector. 

__ a. Select File > Exit in the VTC window. 

__ b. Select Yes in the Shutdown dialog. 

____ 44. Remove the SiebelAdapter from the server. 

__ a. Right click on the server from the Servers view and select Add and Remove Projects… from 
the popup menu. 

__ b. Select SiebelAdapter and click the < Remove button in the Add and Remove Projects dialog.   
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__ c. Click on Finish. 

__ d. Wait for the server to complete the reconfiguration. 

____ 45. Stop the Server 

__ a. Right click on WebSphere Process Server v6.0 server from the Servers view and select Stop from the 
context menu. 
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What you did in this exercise 

You defined Interface Maps and Data Maps which were used to map between ASBOs and GBOs. You tested 
these maps using the Component Test capabilities in WebSphere Integration Developer.  
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Solution Instructions 

____ 2. Follow the directions in the task Initialize the Workspace for a Lab Exercise, using the following 
values:  

 <WORKSPACE> 

C:\Labfiles60\eXchange\WBIAdapters\workspaceMaps 

 <PROJECT_INTERCHANGE> 

C:\Labfiles60\eXchange\WBIAdapters\Solution\Mapping_PI.zip 

 <MODULE> 

n/a 

 <DEPENDENT_LIBRARIES> 

  n/a 

____ 46. Continue with Part 4: Test the PeopleSoft Maps. 



© Copyright IBM Corporation 2006. All rights reserved 

2006 August, 02 IBM WebSphere Process Integration 6.0 – Lab Exercise Page 58 of 60 

 WPSWIDv6_eXcLab_WBIAMappinglab.doc 

Task: Adding Remote Server to WebSphere Integration Developer Test 
Environment 

This task describes how to add a remote server to the WebSphere Integration Developer Test 
environment.  The sample will use a z/OS machine. 

Create a new remote server. 

__ a. Right click on the background of the Servers view to access the pop-up menu. 

__ b. Select New > Server. 

 

  

__ c. Specify hostname to the remote server, <HOSTNAME>. 

__ d. Ensure that ‘WebSphere Process v6.0 Server’ is highlighted in the server type list.   

 

__ e. Click Next. 

__ f. On the WebSphere Server Settings page, select the radio button for RMI and change the 
ORB bootstrap port to the correct setting (<BOOTSTRAP_PORT>). 
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__ g. Click Finish. 

__ h. The new server should be seen in the Server view. 
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Start the remote server if it is not already started.  WebSphere Integration Developer does not support 
starting remote servers from the Server View. 

__ a. From a command prompt, telnet to the remote system if needed:   

‘telnet <HOSTNAME> <TELNET_PORT>’ 

 userid :  <USERID> 

 pw :  <PASSWORD> 

__ b. Navigate to the bin directory for the profile being used:           

 cd <WAS_HOME>/profiles/<PROFILE_NAME>/bin 

__ c. Run the command file to start the server:  ./startServer.sh <SERVER_NAME> 

__ d. Wait for status message indicating server has started: 

 

 

 

 

 

ADMU3200I: Server launched. Waiting for initialization status. 

ADMU3000I: Server cl1sr01 open for e-business; process id is 0000012000000002 


