
© Copyright International Business Machines Corporation 2011, 2013. All rights reserved. 
US Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.

25 September 2013

IBM Worklight V6.0.0
Getting Started

Setting up your Android development environment



© Copyright International Business Machines Corporation 2011, 2013. All rights reserved.

Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of 
International Business Machines Corporation, registered in many jurisdictions 
worldwide. Worklight is a trademark or registered trademark of Worklight, an IBM 
Company. Other product and service names might be trademarks of IBM or other 
companies. A current list of IBM trademarks is available on the Web at “Copyright and 
trademark information” at www.ibm.com/legal/copytrade.shtml.
Linux is a registered trademark of Linus Torvalds in the United States, other countries, 
or both.
Java and all Java-based trademarks and logos are trademarks or registered 
trademarks of Oracle and/or its affiliates.
Other company products or service names may be trademarks or service marks of 
others.
This document may not be reproduced in whole or in part without the prior written
permission of IBM. 

See http://www.ibm.com/ibm/us/en/

About IBM®
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Agenda

Set up your Android development environment

– Install the Android SDK

– Install the Android Development Tools plug-in for Eclipse

Deploy to an Android device

– Setting up a device for development

Publishing your applications

– Setting up an account in Google Play

– Publish your application in Google Play
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Install the Android SDK

The Android SDK provides the tools and APIs that are required to
develop applications on the Android platform by using the Java™
programming language. 

– Download the Android SDK package from 
http://developer.android.com/sdk/

– Install it on your system

– Android SDK might have issues when you run it on 64-bit Linux 
systems.

– For more information, see
http://developer.android.com/sdk/installing.html
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Install the ADT Plug-in for Eclipse

The Android Development Tools
(ADT) plug-in for Eclipse is an 
integrated environment in which 
you can build rich Android apps.

To install ADT in Eclipse, click 
Help > Install New Software
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Install the ADT Plug-in for Eclipse

Click Add and enter the name and location of the ADT plug-in.

Plug-in location is https://dl-ssl.google.com/android/eclipse/

If you cannot install the plug-in, use “http” instead of “https”.
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Install the ADT Plug-in for Eclipse

Check Developer Tools
and click Next to 
proceed.

Proceed with the ADT 
installation sequence.
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Add SDK Platform and Virtual Devices to SDK

After the ADT plug-in installation is 
complete and Eclipse restarted, click 
Window > Android SDK Manager

If the Android SDK Manager / AVD 
Manager is not visible in the Window 
menu, click Window > Customize 
Perspective > Command Groups 
Availability, and select the Android SDK 
and AVD Manager checkboxes.
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Add SDK Platform and Virtual Devices to SDK

In Available Packages, 
select the required SDK 
Platforms and their 
documentation, and 
then click Install.

IBM Worklight supports 
API Levels 8 and above.
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Add SDK Platform and Virtual Devices to SDK

To create a virtual device (emulator), go to 
Window > AVD Manager, click New, and
create an Android Virtual Device (AVD) 
according to your needs.
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Develop

As you later learn in Module 3.2, building a Worklight® application 
generates a separate Android application that is automatically 
displayed in Eclipse.

You are then able to run the Android application on the Android 
simulator by right-clicking the Android project and selecting 
Run As > Android Application.



© Copyright International Business Machines Corporation 2011, 2013. All rights reserved.13

Agenda

Set up your Android development environment

– Install the Android SDK

– Install the Android Development Tools plug-in for Eclipse

Deploy to an Android device

– Setting up a device for development

Publishing your applications

– Setting up an account in Google Play

– Publish your application in Google Play



© Copyright International Business Machines Corporation 2011, 2013. All rights reserved.14

Setting Up a Device For Development

The following resource describes how to set up your development 
environment and Android-powered device for on-device testing and 
debugging.

– For information about installation and usage on different platforms, 
see http://developer.android.com/guide/developing/device.html.
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Setting Up an Account in Google Play

Google Play is a hosted service that simplifies the download and 
installation process of applications to Android-powered devices, and 
makes it easy for developers to publish their applications for Android 
users.

To create an account, go to https://play.google.com/.
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Publish Your Application in Google Play 

For more information, see 
http://developer.android.com/guide/publishing/publishing.html.



© Copyright International Business Machines Corporation 2011, 2013. All rights reserved.

Notices

Permission for the use of these publications is granted subject to these terms and conditions.

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. 
Consult your local IBM representative for information on the products and services currently available in 
your area. Any reference to an IBM product, program, or service is not intended to state or imply that only 
that IBM product, program, or service may be used. Any functionally equivalent product, program, or 
service that does not infringe any IBM intellectual property right may be used instead. However, it is the 
user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. 
The furnishing of this document does not grant you any license to these patents. You can send license 
inquiries, in writing, to: 

– IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A. 

For license inquiries regarding double-byte character set (DBCS) information, contact the IBM Intellectual 
Property Department in your country or send inquiries, in writing, to:

– Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other country where such 
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION 
PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR 
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer 
of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically 
made to the information herein; these changes will be incorporated in new editions of the publication. IBM 
may make improvements and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in 
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of 
the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without 
incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the 
exchange of information between independently created programs and other programs (including this one) 
and (ii) the mutual use of the information which has been exchanged, should contact:

– IBM Corporation
Dept F6, Bldg 1
294 Route 100
Somers NY 10589-3216
USA

Such information may be available, subject to appropriate terms and conditions, including in some cases, 
payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by 
IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any 
equivalent agreement between us.

Information concerning non-IBM products was obtained from the suppliers of those products, their 
published announcements or other publicly available sources. IBM has not tested those products and 
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming 
techniques on various operating platforms. You may copy, modify, and distribute these sample programs 
in any form without payment to IBM, for the purposes of developing, using, marketing or distributing 
application programs conforming to the application programming interface for the operating platform for 
which the sample programs are written. These examples have not been thoroughly tested under all 
conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these 
programs.

Each copy or any portion of these sample programs or any derivative work, must include a copyright notice 
as follows:

– © (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. 
© Copyright IBM Corp. _enter the year or years_. All rights reserved.

Privacy Policy Considerations

IBM Software products, including software as a service solutions, (“Software Offerings”) may use cookies 
or other technologies to collect product usage information, to help improve the end user experience, to 
tailor interactions with the end user or for other purposes. In many cases no personally identifiable 
information is collected by the Software Offerings. Some of our Software Offerings can help enable you to 
collect personally identifiable information. If this Software Offering uses cookies to collect personally 
identifiable information, specific information about this offering’s use of cookies is set forth below.

Depending upon the configurations deployed, this Software Offering may use session cookies that collect 
session information (generated by the application server). These cookies contain no personally identifiable 
information and are required for session management. Additionally, persistent cookies may be randomly 
generated to recognize and manage anonymous users. These cookies also contain no personally 
identifiable information and are required.

If the configurations deployed for this Software Offering provide you as customer the ability to collect 
personally identifiable information from end users via cookies and other technologies, you should seek 
your own legal advice about any laws applicable to such data collection, including any requirements for 
notice and consent. For more information about the use of various technologies, including cookies, for 
these purposes, see IBM’s Privacy Policy at http://www.ibm.com/privacy and IBM’s Online Privacy 
Statement at http://www.ibm.com/privacy/details the sections entitled “Cookies, Web Beacons and Other 
Technologies” and the “IBM Software Products and Software-as-a-Service Privacy Statement” at 
http://www.ibm.com/software/info/product-privacy.
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Support and comments

For the entire IBM Worklight documentation set, training material and online forums where you can post questions, see the IBM website at:
– http://www.ibm.com/mobile-docs
Support
– Software Subscription and Support (also referred to as Software Maintenance) is included with licenses purchased through Passport 

Advantage and Passport Advantage Express. For additional information about the International Passport Advantage Agreement and the 
IBM International Passport Advantage Express Agreement, visit the Passport Advantage website at:
• http://www.ibm.com/software/passportadvantage

– If you have a Software Subscription and Support in effect, IBM provides you assistance for your routine, short duration installation and 
usage (how-to) questions, and code-related questions. For additional details, consult your IBM Software Support Handbook at:
• http://www.ibm.com/support/handbook

Comments
– We appreciate your comments about this publication. Please comment on specific errors or omissions, accuracy, organization, subject 

matter, or completeness of this document. The comments you send should pertain to only the information in this manual or product and 
the way in which the information is presented.

– For technical questions and information about products and prices, please contact your IBM branch office, your IBM business partner, 
or your authorized remarketer.

– When you send comments to IBM, you grant IBM a nonexclusive right to use or distribute your comments in any way it believes 
appropriate without incurring any obligation to you. IBM or any other organizations will only use the personal information that you supply 
to contact you about the issues that you state.

– Thank you for your support.
– Submit your comments in the IBM Worklight Developer Edition support community at:

• https://www.ibm.com/developerworks/mobile/worklight/connect.html
– If you would like a response from IBM, please provide the following information:

• Name 
• Address
• Company or Organization
• Phone No.
• Email address
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