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Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corporation, registered in many jurisdictions
worldwide. Worklight is a trademark or registered trademark of Worklight, an IBM
Company. Other product and service names might be trademarks of IBM or other
companies. A current Ilst of IBM trademarks is available on the Web at “

" at :

Linux is a registered trademark of Linus Torvalds in the United States, other countries,
or both.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Other company products or service names may be trademarks or service marks of
others.

This document may not be reproduced in whole or in part without the prior written
permission of IBM.

About IBM®

See
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Agenda

Set up your Android development environment

Install the Android SDK

Install the Android Development Tools plug-in for Eclipse
Deploy to an Android device

Setting up a device for development

Publishing your applications
Setting up an account in Google Play

Publish your application in Google Play
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Install the Android SDK

The Android SDK provides the tools and APIs that are required to
develop applications on the Android platform by using the Java™
programming language.

Download the Android SDK package from

Install it on your system

Android SDK might have issues when you run it on 64-bit Linux
systems.

For more information, see

Note: Use Oracle Java
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Agenda

= Set up your Android development environment

— Install the Android SDK

— Install the Android Development Tools plug-in for Eclipse
= Deploy to an Android device

— Setting up a device for development

= Publish your applications
— Set up an account in Google Play

— Publish your application in Google Play
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Install the ADT Plug-in for Eclipse

The Android Development Tools
(ADT) plug-in for Eclipse is an

integrated environment in which
you can build rich Android apps.

To install ADT in Eclipse, click
Help > Install New Software
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| () Help Contents
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Search

Dynamic Help

Key Assist... Ctrl+ Shift+L
Tips and Tricks...
Report Bug or Enhancement...

Cheat Sheets...

Check for Updates
Install Mew Software...
Eclipse Marketplace...

About Eclipse
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Install the ADT Plug-in for Eclipse

= Click Add and enter the name and location of the ADT plug-in.

+ |  Add.

Find more software by working with the "Available Software Sites” preferences.

-

E Add Repository

Y MName: ADT Plugin

[ &2

| Local...

Location: https://dl-ssl.google.com/android/eclipse/

| Archive... |

@

Ok

|

Cancel

b

= Plug-in location is

= If you cannot install the plug-in, use “http” instead of “https”.
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Install the ADT Plug-in for Eclipse
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= Check Developer Tools BvaaeSotware »
. Check the items that you wish to install. :)i
and click Next to
proceed.

Work with:  ADT - https://dl-ssl.google.com/android/eclipse/ - Add...
Find more software by working with the "Available Software Sites” preferences.
type filter text

Name Version
> [#] 000 Developer Tools
> [] 000 MDK Plugins

= Proceed with the ADT
installation sequence.

selectAll | | Deselect Al 5 items selected
Details
(7] Show only the latest versions of available software ] Hide items that are already installed
[¥] Group items by category What is already installed?

[]Show only software applicable to target environment
[¥] Contact all update sites during install to find required software

~
@) < Back MNext > Finish
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Add SDK Platform and Virtual Devices to SDK

= After the ADT plug-in installation is
complete and Eclipse restarted, click
Window > Android SDK Manager

= |f the Android SDK Manager / AVD
Manager is not visible in the Window
menu, click Window > Customize
Perspective > Command Groups
Availability, and select the Android SDK
and AVD Manager checkboxes.

q

1a

E.] Customize Perspective - Java

|
Tool Bar Visibility | Menu Visibily| Command Groups Availabilty | Shbricuts |

Select the command groups th erspective (Java), The details field identifies which menu items
and/or toolbar items are added to the perspective by the selected command group.

Available command groups: Menubar details: Toolbar details:

[¥] Android Lint
B Ao deoid Dofobor

T

[¥] Android SDK and AVD Manager
¥ Android Wizards i |

Mew Window
Mew Editor

auth_test/common/jgm_auth_test.html - Eclipse

ct ﬂindow| Help

cm_z
Open Perspective o
Show View hab
Customize Perspective... It
fa lue
Save Perspective As... ~nr
Reset Perspective... </d3
Close Perspective
Close All Perspectives
Auth
Mavigation i
&
Android 5DK Manager
rt or Y
D AVD Manager /p>
| pla
Web Browser bord”
Preferences ™
<fdivzs
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Add SDK Platform and Virtual Devices to SDK

= In Available Packages, select the required SDK Platforms and their
documentation, and then click Install.

Android SDK Manager | .EEZ__.l
Packages Tools
W kI . ht t SDK Path:  C:handroid-sdk
|
Or Ig Suppor S Packages
APl LeveIS 9 7 MName API Rev.  Status -
. D& Samples for SDK 14 1 Sbinstalled
(Andr0|d 23) and [7] % ARM EABIW7a System Image 14 1 Elnstalled
[¥] '€ Google APIs by Google Inc. 14 w Not installed
above [T] i£] Android 3.2 (AP113) ‘
[zl Android 3.1 (AP112) |2
- [[]1£] Android 3.0 (API11)
4 []|Z] Android 2.3.3 (AP110)
[T] v SDK Plotform 10 -« Not installed
[l & Samples for SDK 10 « Not installed
[] . Dual Screen APls by KYOCERA Corporation 10 -« Not installed
[ l'fq. EDK 1.1 by Sony Ericsson Mobile Communications 10 -« Not installed
[] i Google APis by Google Inc. 1o + Not installed
a []lZ] Android 2.2 (APIB)
[] 7 SDK Platform 8 3 9lnstalled |
[ | S n - ®e: . u
Show: [¥]Updates/New [¥]Installed  [] Obsolete Select New/Updates Install 11 packages... |
Sort by: © AP level () Repository Deselect All Delete packages...
. o
Done loading packages.
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Add SDK Platform and Virtual Devices to SDK

) . @] Create new Android Virtual Device (AVD) =]
= To create a virtual device (emulator), go to R—
Window > AVD Manager, click New, and Taget [ Qadzatiied n
create an Android Virtual Device (AVD) CPU/ABE [ ARM (armeb)
according to your needs. 50 Cordk
g y @ Size:
() File: Browse...
Snapshot:
[]Enabled
Skin:
@) Built-in: Default (WVGABDD) -
) Resolution: %
Hardware:

Property Value

Abstracted LCD density 240

— Delete
Max VM application hea.. 24
Override the existing AVD with the same name
Create AVD ] ’ Cancel
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Develop

As you will later learn in the Getting Started module Previewing your
application on Android, building a Worklight® application generates a

separate Android project (application) that is automatically displayed
in Eclipse.

You are then able to run the Android application on the Android

simulator by right-clicking the Android project and selecting
Run As > Android Application.

", Copy path(s) to clipboard gress El Console 2 . LogCat
Run As » | [&] 1 Android Application |
Debug As b | Ji 2 Android JUnit Test
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Agenda

Set up your Android development environment

Install the Android SDK

Install the Android Development Tools plug-in for Eclipse
Deploy to an Android device

Setting up a device for development

Publishing your applications
Setting up an account in Google Play

Publish your application in Google Play
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Setting Up a Device For Development

The following resource describes how to set up your development
environment and Android-powered device for on-device testing and
debugging.

For information about installation and usage on different platforms,
see
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Setting Up an Account in Google Play

Google Play is a hosted service that simplifies the download and
Installation process of applications to Android-powered devices, and
makes it easy for developers to publish their applications for Android
users.

To create an account, go to
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Publish Your Application in Google Play

For more information, see
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Notices
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Permission for the use of these publications is granted subject to these terms and conditions.
This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries.
Consult your local IBM representative for information on the products and services currently available in
your area. Any reference to an IBM product, program, or service is not intended to state or imply that only
that IBM product, program, or service may be used. Any functionally equivalent product, program, or
service that does not infringe any IBM intellectual property right may be used instead. However, it is the
user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document.
The furnishing of this document does not grant you any license to these patents. You can send license
inquiries, in writing, to:

- IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
US.A.

For license inquiries regarding double-byte character set (DBCS) information, contact the IBM Intellectual
Property Department in your country or send inquiries, in writing, to:

- Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other country where such
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION
PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT,
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer
of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically
made to the information herein; these changes will be incorporated in new editions of the publication. IBM
may make improvements and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of
the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without
incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the
exchange of information between independently created programs and other programs (including this one)
and (i) the mutual use of the information which has been exchanged, should contact:

- IBM Corporation
Dept F6, Bldg 1
294 Route 100
Somers NY 10589-3216
USA

I

Such information may be available, subject to appropriate terms and conditions, including in some cases,
payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by
IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any
equivalent agreement between us.

Information concerning non-IBM products was obtained from the suppliers of those products, their
published announcements or other publicly available sources. IBM has not tested those products and
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming
techniques on various operating platforms. You may copy, modify, and distribute these sample programs
in any form without payment to IBM, for the purposes of developing, using, marketing or distributing
application programs conforming to the application programming interface for the operating platform for
which the sample programs are written. These examples have not been thoroughly tested under all
conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these
programs.

Each copy or any portion of these sample programs or any derivative work, must include a copyright notice
as follows:

- © (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs.
© Copyright IBM Corp. _enter the year or years_. All rights reserved.

Privacy Policy Considerations

IBM Software products, including software as a service solutions, (“Software Offerings”) may use cookies
or other technologies to collect product usage information, to help improve the end user experience, to
tailor interactions with the end user or for other purposes. In many cases no personally identifiable
information is collected by the Software Offerings. Some of our Software Offerings can help enable you to
collect personally identifiable information. If this Software Offering uses cookies to collect personally
identifiable information, specific information about this offering’s use of cookies is set forth below.

Depending upon the configurations deployed, this Software Offering may use session cookies that collect
session information (generated by the application server). These cookies contain no personally identifiable
information and are required for session management. Additionally, persistent cookies may be randomly
generated to recognize and manage anonymous users. These cookies also contain no personally
identifiable information and are required.

If the configurations deployed for this Software Offering provide you as customer the ability to collect
personally identifiable information from end users via cookies and other technologies, you should seek
your own legal advice about any laws applicable to such data collection, including any requirements for
notice and consent. For more information about the use of various technologies, including cookies, for
these purposes, see IBM’s Privacy Policy at and IBM's Online Privacy
Statement at the sections entitled “Cookies, Web Beacons and Other
Technologies” and the “IBM Software Products and Software-as-a-Service Privacy Statement” at
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Support and comments
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For the entire IBM Worklight documentation set, training material and online forums where you can post questions, see the IBM website at:

Support

Software Subscription and Support (also referred to as Software Maintenance) is included with licenses purchased through Passport
Advantage and Passport Advantage Express. For additional information about the International Passport Advantage Agreement and the
IBM International Passport Advantage Express Agreement, visit the Passport Advantage website at:

If you have a Software Subscription and Support in effect, IBM provides you assistance for your routine, short duration installation and
usage (how-to) questions, and code-related questions. For additional details, consult your IBM Software Support Handbook at:

Comments

We appreciate your comments about this publication. Please comment on specific errors or omissions, accuracy, organization, subject
matter, or completeness of this document. The comments you send should pertain to only the information in this manual or product and
the way in which the information is presented.

For technical questions and information about products and prices, please contact your IBM branch office, your IBM business partner,
or your authorized remarketer.

When you send comments to IBM, you grant IBM a nonexclusive right to use or distribute your comments in any way it believes
appropriate without incurring any obligation to you. IBM or any other organizations will only use the personal information that you supply
to contact you about the issues that you state.

Thank you for your support.
Submit your comments in the IBM Worklight Developer Edition support community at:

If you would like a response from IBM, please provide the following information;
Name
Address
Company or Organization
Phone No.
Email address
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