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About This Book

This book describes how to install, configure, and start Personal Communications.
After you get Personal Communications up and running and begin to perform
various tasks, use the online help whenever you need additional information. See
d i ion” iii for information about online help,
the Personal Communications library, and related publications. See the glossary on
page [15d for definitions of technical terms used throughout this book.

This book is for users of:

« IBM® Personal Communications Version 5.0 for Windows® 95, Windows 98,
Windows NT®, and Windows 2000

¢ IBM Personal Communications AS/400 Version 5.0 for Windows 95, Windows
98, Windows NT, and Windows 2000

See 'What's in the Packages” an page viii for information regarding what is in

each package.

The screens in this book are representative of ones that you might see while
working with Personal Communications. Minor variations could occur between
what you see on your display and what is in the book.

In this book, Windows refers to Windows 95, Windows 98, Windows NT, and
Windows 2000. When information is specific to only Windows 95, Windows 98,
Windows NT, or Windows 2000, this will be indicated in the text.

Conventions Used in This Book
This book uses the following text conventions:

UPPERCASE
Uppercase indicates commands, program keywords, and default values.
You can enter these values in uppercase or lowercase.

Bold Bold type indicates the names of window controls, such as lists, check
boxes, entry fields, menu choices, and push buttons

Italics Ttalics indicate:
* Special emphasis in text or a reference citation
* Variables that you supply a value for

Example type

Example type indicates information that the user is instructed to type at a
command prompt or in a window.

This book also uses icons (pictures) in the text to help you find different types of
information.

This icon represents a note, important information that can affect the
operation of Personal Communications, or the completion of a task.

© Copyright IBM Corp. 1989, 2000 vii



This icon represents a tip or additional information that can help you
complete a task.

What'’s in the Packages

Personal Communications Version 5.0 provides two basic CD-ROM package
options. The packages are:

1. A CD-ROM (Version 5.0) containing IBM Personal Communications for Windows
95, Windows 98, Windows NT, and Windows 2000 which provides 5250, 3270, and
VT emulation and connections to AS/400, S/390®, ASCII, and System/36 or
System/38 (S/3X) host systems.

2. A CD-ROM (Version 5.0) containing IBM Personal Communications AS/400 for
Windows 95, Windows 98, Windows NT, and Windows 2000 which provides 5250
and VT emulation and SNA connections to remote systems.

The information in this book applies to both packages.

In addition to the products previously mentioned, both CD-ROMs contain the
following:

¢ Adobe Acrobat reader to enable you to read softcopy books (PDF) available on
the CD-ROM

* Book files in .PDF format, which allow you to view the books shipped with the
products
Notes:
1. For each of the two basic packaging options, there are also separate CD-ROMs,
depending on:

National Languages
There is a multiple-language version that supports up to nineteen
languages at the same time. There are single language versions for

* Traditional Chinese
* Simplified Chinese
¢ Korean

Security Levels

There are separate packages for encryption levels of 56-bit, 128-bit, and
168-bit.

2. There is a separate CD-ROM containing the DB2 Connect product.

Where to Find More Information

viii

The following sections discuss getting help when you are installing, configuring, or
using Personal Communications.

Online Help

The help facility describes how to install, configure, and use Personal
Communications. Online help is very extensive and includes information about
every aspect of configuring and using Personal Communications.

Use help to obtain information about:

Personal Communications Quick Beginnings



Finding More Information

* Menu choices

* Operation procedures

¢ Operations in windows

* Meanings of the terms displayed in windows

* Causes of errors and the corresponding actions to take

* Mouse-based operations

* Operation without a mouse

¢ Detailed explanations of specific terms

¢ Further technical information about Personal Communications

* Detailed explanations of operator information area (OIA) messages

To display online help, select choices from the Help menu.

You can use Personal Communications online help just as you use the online help
for Windows 95, Windows 98, Windows NT, or Windows 2000.

Personal Communications Library

The Personal Communications library includes the following publications:

* IBM Personal Communications Version 5.0 Quick Beginnings, GC31-8679-01

e IBM Personal Communications Version 5.0 Access Feature, SC31-8684-01

* IBM Personal Communications Version 5.0 Reference Volume 1, SC31-8680-01

* IBM Personal Communications Version 5.0 Reference Volume 1I, SC31-8682-01

* IBM Personal CommunicationsVersion 5.0 Emulator Programming, SC31-8478-03

e IBM Personal Communications Version 5.0 Client/Server Communications
Programming, SC31-8479-04

* IBM Personal Communications Version 5.0 System Management Programming,
SC31-8480-04

e IBM Personal Communications Version 5.0 CM Mouse Support User’s Guide and
Reference

* IBM Personal Communications Version 5.0 Host Access Class Library, SC31-8685-01

* IBM Personal Communications Version 5.0 Configuration File Reference, SC31-8655-03

In addition to the printed books, there are HTML documents provided with
Personal Communications:

Host Access Class Library for Java
This HTML document describes how to write an ActiveX/OLE
2.0-compliant application to use Personal Communications as an
embedded object.

Host Access Beans for Java
This HTML document describes Personal Communications emulator
functions delivered as a set of Java' " Beans.

Open Host Interface Objects for Java
This HTML document describes how to write an OHIO-compliant
application to use Personal Communications as an embedded object.

Related Publications

For information about local area networks (LANSs), refer to the following
publications:

* IBM Local Area Network Technical Reference

e AS/400 Communications: Local Area Network (LAN) Guide Version 2

For more information about NetWare, refer to the publications for the following
products:

About This Book  1X



Finding More Information

* For the client NetWare Client for Windows
» For NetWare for SAA NetWare for SAA

Contacting IBM

This section lists a number of ways you can reach IBM for various reasons.
Depending on the nature of your problem or concern, we will ask you to be
prepared to provide the following information to allow us to serve you better. For
information about the tools available to help with problem analysis, refer to the
Personal Communications Version 5.0 Reference Volume 1.

* The environment in which the problem occurs:
— Personal Communications configuration
- Personal Communications version and CSD level
- The name of the workstation profile
- The name of the SNA Node Configuration file
— Workstation configuration
- The machine type and model, the system memory, the video adapter

- The communication adapter you are using

Other adapters (especially communication adapters) installed

The printer type and model

Other devices installed, such as sound cards, modems, or fax machines
— Software configuration

- Windows version and level

- Communication and device-driver version and level

- Other communication programs (such as NetWare, Microsoft SNA Server,
or Microsoft Data Link Control) that are running and using resources

- Printer driver version and level
— Host configuration
- The upstream host connection and configuration
¢ Problem analysis information
— Symptoms
— Type of problem
— OIA messages or error messages (if any)
— Key factors related to the problem
If you have a technical problem, take the time to review and carry out the actions
suggested here. Use your local support personnel before contacting IBM. You can
also check the Hints and Tips on the WWW for more information. Only persons

with in-depth knowledge of the problem should contact IBM; therefore, support
personnel should act as the interface with IBM.

Support Options
If you determine that you need to contact IBM, you can do any of the following:

e Access the Personal Communications for Windows 95, Windows 98, and
Windows NT Web page:

http://www.ibm.com/software/network/pcomm

* To find the phone number for IBM Software Support, U.S. customers can call
1-800-IBM-4YOU. International customers that have access to the U.S. "800" toll
free numbers can reach the International Support Center by calling

X  Personal Communications Quick Beginnings



Finding More Information

1-800-IBM-4YOU and asking to speak with the International Support Center
(ISC) in Atlanta. International customers without access to the U.S. toll free

numbers can call the ISC directly at 770-863-1234. The ISC’s FAX number is
770-863-3030 and is available 24 hours a day.

About This Book  Xi
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Chapter 1. Welcome to Personal Communications

Personal Communications brings the power of personal networking to your
workstation by exploiting the networking capabilities to provide a variety of
connectivity options supporting local area network (LAN) and wide area network
(WAN) environments. Whether it’s for host terminal emulation, client/server
applications, or connectivity, Personal Communications offers a robust set of
communication, networking, and administrative features.

Personal Communications is a full-function emulator. In addition to host terminal

emulation, it provides these useful features:

* File transfer

* Dynamic configuration

* An easy-to-use graphical interface

* APIs for SNA-based client applications

* An API allowing TCP/IP-based applications to communicate over an SNA-based
network

A variety of SNA-based client application programming interfaces (APIs) are
supported by Personal Communications. You can create applications that use the
peer-to-peer client APIs, which are based on LU 6.2 and provided by Personal
Communications. These APIs let you simultaneously access and process
information on peer workstations.

Personal Communications supports Advanced-Peer-to-Peer Networking® (APPN®)
as an end node, and uses the advanced network features: high-performance
routing (HPR) and dependent LU requester (DLUR).

AnyNet SNA over TCP/IP is a feature of Personal Communications which allows
emulator and client/server SNA applications to communicate over a TCP/IP
network.

The AnyNet Sockets over SNA access node function enables TCP/IP application
programs using the WinSock 1.1 or WinSock 2.0 socket interface to communicate
over an SNA network.

Personal Communications Version 5.0 provides many enhancements. See
New in Personal Communications Version 5.0 for Windows 95, Windows 98

Windows NT, and Windows 2000” on page 16 for a complete list of the new

enhancements for Personal Communications Version 5.0.

Personal Communications Program lcons

When you have installed Personal Communications, the main functions that you
can use are displayed as icons. Icons are grouped in subfolders of the IBM
Personal Communications program folder.

A brief explanation of each function follows:

© Copyright IBM Corp. 1989, 2000 3



Introduction

Start or Configure Session
Use this icon to start or configure new emulator sessions. During
configuration, you can specify the session type, screen size, LU number,
graphics support, the type of communication link and its parameters, as
well as other information. You can save all this information in a
workstation profile. After saving, you can start the session by just clicking
the session icon.

#a

SNA Node Configuration
Use this icon to configure an SNA node and associated resources or to
change advanced configuration parameters. Although most emulator
sessions can be configured without the use of this utility, you will need to
create an SNA node configuration to enable client/server and peer
communication. This can also be run from an active session by selecting
Launch > SNA Node Configuration from the Actions menu.

A

IBM Software Registration
Use this icon if you want to be notified of any program updates provided
by IBM.

Administrative and Problem Determination (PD) Aids

CN

Display SNA Sense Data
Use this icon to display SNA sense data and associated explanations. Sense
data is SNA error information located in internal SNA flows, error logs,
error messages, and traces. Some Personal Communications error messages
include sense data.

Information Bundler
Use this icon to gather system files and specific trace and log files, as well
as registry information, such as the software installed or running on a
machine. This can also be run from an active session by selecting Launch >
Information Bundler from the Actions menu

]

Internet Service
Use this icon to send system and diagnostic data collected by the
Information Bundler to an FTP server. This can also be run from an active
session by selecting Launch > Internet Service from the Actions menu.

Log Viewer
Use this icon to view, merge, and sort the Personal Communications
message and trace logs. Personal Communications logs errors and

4  Personal Communications Quick Beginnings
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informational messages during initialization and operation. This can also
be run from an active session by selecting Launch > Log Viewer from the
Actions menu.

(]

Migration Utility
Use this icon to migrate your configuration files to Personal
Communications Version 5.0.

SNA Node Configuration Verification
Use this icon to verify that the ASCII editing changes that you have
manually made to the SNA node configuration data are valid.

SNA Node Operations
Use this icon to perform SNA node operations, such as starting or stopping
resources or displaying resource information. This can also be run from an

active session by selecting Launch > SNA Node Operations from the
Actions menu.

Trace Facility
Use this icon to turn trace functions on and off and to capture
communication-protocol information that passes between your workstation
and other host systems. You can use traces to resolve communication
problems. This can also be run from an active session by selecting Launch
> Trace Facility from the Actions menu.

Product Information

Readme-Please!
The Readme file includes important information that became available too
late to be included in this book or that might be of special interest.

&
Manuals

You can install the following books so they can be available online to you
by choosing Custom Install. The books can be viewed from the CD-ROM,
or by installing Adobe Acrobat Reader.

Quick Beginnings
This book, which you are now reading, describes how to install, configure,
and start Personal Communications.

Reference
This set of books contains reference information that you might need when
installing or using Personal Communications.

Chapter 1. Welcome to Personal Communications 5
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Emulator Programming
This book provides necessary programming information for you to use the
IBM Personal Communications Emulator High-Level Language Application
Program Interface (EHLLAPI), Dynamic Data Exchange (DDE), Personal
Communications API (PCSAPI), and Server-Requester Programming
Interface (SRPI).

Client/Server Communications Programming
This book describes support for the APPC and LUA application
programming interfaces (APIs).

System Management Programming
This book describes how to use the Node Operations Facility (NOF)
application programming interface (API).

CM Mouse User’s Guide and Reference
This book describes how to use the CM Mouse interface.

Configuration File Reference
This book describes how to edit and verify configuration data using an
ASCII editor.

Host Access Class Library
This book provides a core set of classes that allow the development of
platform-independent applications that can access host information at the
data stream level.

In addition to the printed books, the following online publications are included:

Host Access Class Library for Java
This HTML document describes how to write an ActiveX/OLE
2.0-compliant application to use Personal Communications as an
embedded object.

Host Access Beans for Java
This HTML document describes Personal Communications emulator
functions delivered as a set of Java' Beans.

Open Host Interface Objects for Java
This HTML document describes how to write an OHIO-compliant
application to use Personal Communications as an embedded object.

Utilities

The APING and AFTP utilities are available in U.S. English only.

THESE PROGRAMS ARE PROVIDED ON AN AS-IS BASIS WITHOUT ANY
WARRANTY OF ANY KIND, INCLUDING THE WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE WHICH ARE EXPRESSLY DISCLAIMED.

6  Personal Communications Quick Beginnings
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Certificate Management
Use this icon to enable Secure Sockets Layer (SSL) communication between
your communication server and client. Refer to Personal Communications
Referenc Volume II for details on how to use this utility.

Certificate Wizard
Use this icon to launch the Certificate Wizard which allows you to enable
Secure Sockets Layer (SSL) communication between your communications
server and client. Refer to Personal Communications Referenc Volume II for
details on how to use this utility.

09

Check Connection APING
Use this sample CPI-C program to verify network connections. You can use
APING to establish network connections, diagnose problems, and take
simple performance measurements. APING exchanges data packets with a
partner computer and measures how long the data transfer takes.

CM Mouse
Use this icon to define mouse buttons to perform any sequence of host
keystrokes, including PF keys and special emulator control keys. You can

also build pop-up menus to control host applications without making any
changes to those host programs.

— Note

CM Mouse is a sample application that has been provided for
use as a utility. It is English only and only runs on SBCS
systems.

e

CM Mouse Configuration
Use this icon to configure the CM Mouse Scripting utility.

Convert Macro to VBScript
Use this icon to convert an existing Personal Communications macro to a
VBScript file.

Chapter 1. Welcome to Personal Communications 7



Introduction
Data Transfer (AS/400 only)
Use this iconto transfer data between a workstation and an AS/400
database.

ey

Database Access
Use this icon to start the Database Access utility that lets you retrieve data
from a database, such as an SQL server, Microsoft® Excel, Lotus® 1-2-3, or
dBASE database (that complies with Microsoft ODBC standards, Level 1).
You can then directly pass the retrieved data to Excel, Lotus 1-2-3, and
other applications.

&

DOS EHLLAPI
Use this icon to enable or disable DOS-Based EHLLAPI programs that

communicate with the 32-bit Personal Communications emulator.

Menu-Bar Customization
Use this icon to customize the menu bar in the session window.

Multiple Sessions
Use this icon to create batch files (.BCH), which specify multiple emulator

sessions (workstation profiles) or other Windows 95, Windows 98,
Windows NT, or Windows 2000 programs that you want to start
concurrently. You can create an icon for each batch file and start the
programs just by clicking the icon.

AS/400 Connection Configuration
Use this icon if you want to define connections to each AS/400 host that

will use the network drives or the data transfer function.

Note: This function is not available for Windows 2000.

&

Transfer File AFTP
Use this program to provide a fast and efficient transfer of text and binary
files.

T
User Preferences
Use this icon if you want to set up or change the user preferences, for

instance to change the user interface language, or the Personal
Communications private subdirectory.
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ZipPrint (3270 only)
Use this icon to start the ZipPrint program, which allows you to print host
system files or screens, PROFS® or OfficeVision® notes, calendars, and
documents, CMS files, and XEDIT workspaces. When started, ZipPrint
adds an item to the menu bar of the session window.

Personal Communications Sessions

The sessions that Personal Communications provides are logical connections
enabling communication between your workstation and a host system. The
following session types are available:
Display session

Use your workstation as a display terminal connected to the host system.
Printer session

Use your workstation printer as a host system printer.
Client/server session

Establish connections that allow peer communications using CPI-C and
APPC (LU 6.2).

Personal Communications Connections

Personal Communications supports a variety of connections to the following host

systems. Following are the icons you will encounter when you begin to configure
an emulator session:

[

S/390

il

S/3X
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System/390 Emulator Connections

Interface Attachment
LAN via IEEE 802.2
@ 3270 via NWSAA or Communications Server for Windows NT
LAN Telnet3270

3270 via AS/400 (passthru)

APPC 3270 via LAN

Microsoft SNA client over FMI

Microsoft SNA client (using the LUA interface)
Microsoft SNA client (using the APPC interface)
Dependent LU Requester (DLUR)

3174 Peer Communications

VT-over-Telnet (TCP/IP)

SNA Distributed Function Terminal
Non-SNA Distributed Function Terminal

B

COAX

SNA-over-Async
IBM Global Network (not in Japan)
COM Home3270
port IBM Global Network - SNA-over-Async
Dependent LU Requester (DLUR) via
SNA-over-Async
Hayes AutoSync
Hayes AutoSync
APPC 3270 via:
SNA-over-Async
Hayes AutoSync
VT over Async
Telnet 3270
VT over Telnet (TCP/IP)
X.25 Hayes AutoSync
X.25 DLUR via Hayes AutoSync
X.25 APPC 3270 via Hayes AutoSync

3270 via AS/400
@ Dependent LU Requester (DLUR)

Synchronous Data Link Control
@ 3270 via AS/400 (passthru)
SDLC APPC 3270 via SDLC

Dependent LU Requester (DLUR)

LUOo, 1,23
APPC 3270
LU 0,1,2,3 via DLUR

Synchronous Data Link Control
@ 3270 via AS/400 (passthru)
IBM ISA/ APPC 3270 via SDLC
MCA WAC Dependent LU Requester (DLUR)

X.25 Qualified Logical Link Control
X.25 3270 via AS/400
APPC 3270 via X.25
X.25 DLUR
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Interface Attachment
NetWare for SAA client
@ Communications Server client
API Communications Server
Client
— LU (0, 1, 2, 3) via DLUR
|:||:||:| | APPC 3270
IBM
EEDLC
LU(©1,2,3)
@ 3270 via AS/400 (passthru)
OEM APPC 3270

Dependent LU Requester (DLUR)

AS/400 Emulator Connections

Interface Attachment
LAN via IEEE 802.2
@ Telnet5250 over TCP/IP
LAN Telnet5250 over IPX/SPX
VT over Telnet
Twinaxial Data Link Control (APPC)
@ Twinaxial Data Link Control (Console)
5250
SNA-over-Async
{Ej: Hayes AutoSync
%(grl\tll SNA-over-Async (Console)

VT over Async

VT over Telnet
Telnet 5250

X.25 Hayes AutoSync

Synchronous Data Link Control

|| 5250
SNA/IP
Synchronous Data Link Control (WAC)
X.25 Qualified Logical Link Control
IBM ISA/
MCA WAC
:n | 5250
IBM
EEDLC
APPC 5250
OEM
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ASCIl Emulator Connections (SBCS only)

Interface Attachment

VT over Telnet (TCP/IP)

=

LAN

VT over Async

VT over Telnet (TCP/IP)
COM
port

S/3X Emulator Connections

Interface Attachment

Twinaxial Data Link Control (Console)

=

5250

Client/Server (Peer) Connections

Personal Communications provides APPN end node support for workstations,
allowing them to communicate more flexibly with other systems in the network.

When your workstation is defined as an APPN end node, an APPN network node
server provides the following directory and routing services for your workstation:
* Intermediate session routing

* Directory services

* Topology and route selection services

Using Personal Communications, you can establish client/server connections to a
variety of computers and to workstations running OS/2, Windows 3.x, Windows
95, Windows 98, Windows NT, or Windows 2000. Another option is to connect the
computers to a workstation running Communications Server. Available SNA
client/server connection types are:

» LAN via IEEE 802.2

* Synchronous Data Link Control

* SNA-over-Async

* AnyNet SNA over TCP/IP

* Hayes AutoSync

» IBM Global Network — SNA over Async

* Twinaxial Data Link Control (APPC)

* X.25

* OEM Deep adapter

+ WAC

* Enterprise Extender

APPN Networking

Advanced Peer-to-Peer Networking (APPN) is the underlying networking protocol
that routes APPC traffic through intermediate nodes in the network. For instance,
when Program A uses APPC to talk to Program B, APPN finds the node where
Program B is located and directs the APPC traffic through the network.
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APPN includes several features that help reduce the amount of configuration
required to set up and maintain a network. These features automate many tasks
that are time consuming, complicated, and error prone. For example, if you're
installing a new workstation that uses APPN, you don’t have to set up
configuration information for every workstation you want to communicate with.
You simply provide the name of the computer and the address of the intermediate
node that handles your traffic. APPN takes care of the rest of the information
needed to route APPC traffic to and from your workstation.

If you connect to an APPN network, you simplify your own configuration and
make it easier for other computers in the network to find you.

Refer to “SNA Client/Server Concepts” in the Personal Communications Reference
Volume II for more information.

APPC

Advanced program-to-program communication (APPC), also known as LU 6.2, is
software that enables high-speed communications between programs on different
computers, from portables and workstations to midrange and host computers.
APPC software is available for many different operating systems, either as part of
the operating system or as a separate software package.

APPC is a communications protocol that enables programs on different computers
to “talk to” each other. APPC provides the interface between the programs and the
networking hardware and software and defines the rules that programs use to
exchange information.

APPC serves as an interface between application programs and the network. When
the communications application on your workstation passes information to the
APPC software, APPC takes the information and sends it on to a network
interface, such as a Token-Ring adapter card. The information travels across the
network to another computer, where the APPC software receives the information
from the network interface. APPC puts the information back into its original
format and passes it to the corresponding communications application.

Refer to Personal Communications Version 5.0 Reference Volume II for more
information.

APPN Network

By participating in an APPN network, Personal Communications workstations can
also take advantage of two additional functions:

* High-performance routing

* Dependent LU requester

High-Performance Routing (HPR): Personal Communications supports
high-performance routing (HPR) over token-ring and Ethernet connections, which
increases data routing performance and reliability. HPR supports the rapid
transport protocol to provide nondisruptive rerouting around network outages,
efficient selective retransmission, and end-to-end data integrity and congestion
control.

Dependent LU Requester (DLUR): DLUR allows dependent LUs (LU 0, 1, 2, 3,
and dependent LU 6.2) to benefit from an APPN network. It supports dynamic and
multiple paths through the network and eliminates the need for dependent LUs (or
their gateway) to be adjacent to the VTAM® host.
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A DLUR is an APPN end node or network node that owns dependent LUs, but
requests that a dependent LU server (DLUS) provide the system services control
point (SSCP) for those dependent LUs. A DLUS controls conversion from a subarea
environment to an APPN environment, allowing you to maintain central
management of remote dependent LUs while benefiting from an APPN network.

Personal Communications uses the support in VTAM V4R2 for dependent LUs
through APPN networks and combined subarea and APPN networks. The
dependent LU server function (in VTAM) provides dependent secondarylogical
unit (SLU) support by establishing an LU 6.2 session between a dependent LU
requester node (DLUR), and a dependent LU server node (DLUS).

See “SNA Client/Server Concepts” in the Personal Communications Reference Volume
II for more information.

AnyNet

AnyNet® allows any application to communicate over any networking protocol
and to extend the reach of applications over multiple networks. Using AnyNet
function, you can reduce the number of installed network protocols and reduce
operational complexity without modifying your existing applications or hardware.
Personal Communications includes AnyNet SNA over TCP/IP support, which
allows SNA emulator and client/server applications to communicate over a
TCP/IP network.

Refer to “Introducing AnyNet SNA Over TCP/IP” in the Personal Communications
Reference Volume II for more basic information about AnyNet.

Personal Communications also includes AnyNet Sockets over SNA support, which
enables TCP/IP application programs using the WinSock 1.1 or WinSock 2.0 socket
interface to communicate over an SNA network. For more information, refer to
“AnyNet Sockets over SNA” in the Personal Communications Reference.

Note: This function is not available for Windows 2000.

Refer to “/Appendix D AnyNet Configuration Examples” on page 121 for examples

of how to set up AnyNet connections.

Enterprise Extender (HPR over IP)

Enterprise Extender allows you to extend the reach of SNA applications and data
to include IP networks and IP-attached clients with similar levels of reliability,
scalability, and control as SNA users. Enterprise Extender integration uses standard
IP technology and does not require new hardware or software in the IP backbone.

Enterprise Extender is a simple set of extensions to the existing HPR technology,
and provides the following;:

* Non-disruptive backup from desktop to host
* SNA transport over native IP network

* End-to-end failure protection

* End-to-end data prioritization

* Scalable and cost-effective connectivity
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ActiveX/OLE 2.0 Support

Personal Communications Version 5.0 sessions can now be included as part of a
compound document. A compound document is a document that appears to be a
single unit, but which is in fact made up of information from more than one
program. For example, a compound document could include data that allows
Personal Communications to execute within the context of the spreadsheet
program.

When included as part of another program, Personal Communications is known as
an embedded or linked object and the program is known as a container. Personal
Communications supports ActiveX/OLE 2.0-compliant containers such as Lotus
Notes®, Lotus WordPro®, and Microsoft Word. For most containers you can embed
an object by using a menu sequence (for example, in Microsoft Word, use Insert,
then Object), or by dragging and dropping a workstation profile into the
document.

As an embedded object, Personal Communications can change its appearance to be
part of the container program, providing the container program allows this change
to occur. Or, Personal Communications can be started so that it runs in its own
separate window utilizing its own profile and screen displays.

There is a variety of ways that Personal Communications can be activated as an
embedded object. For example, Personal Communications can be shown as an icon
within another program, and be activated by double-clicking. Another way
Personal Communications can be activated is through a script; Visual Basic or
LotusScript are examples of scripting languages supported by Personal
Communications, but any ActiveX/OLE automation scripting language can be
used.

The use of scripts allows Personal Communications to be activated as a part of an
automation request. For example, a script can be written to automatically start
Personal Communications every time the container object is started, or a script can
be used to automatically put data on host entry screens.

The Personal Communications session ends when the container is closed or when
you close the Personal Communications window. If Personal Communications was
actuated as a linked object, it must be closed separately.

Object-Oriented API

Personal Communications provides a new language-independent object-oriented
APL There are seven objects that can be used in conjunction with Visual Basic,
Lotus Script, or any ActiveX/OLE automation scripting language to produce
compound documents where Personal Communications is an embedded object
within another program.

If you are interested in writing an application that includes Personal
Communications as an object within your ActiveX/OLE 2.0 compliant program,
refer to the IBM Personal Communications Host Access Class Library (HACL)
programming manual. This manual describes the objects that Personal
Communications provides and describes what you need to do to access the
Personal Communications data. Information is provided for programmers using
Visual Basic scripts, Lotus scripts, and the C++ programming language. Samples of
Visual Basic and Lotus scripts are provided on the Personal Communications
CD-ROM.
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What's New in Personal Communications Version 5.0 for Windows 95,
Windows 98, Windows NT, and Windows 2000

Personal Communications Version 5.0 is based on the popular Personal
Communications Version 4.3. If you are familiar with Personal Communications
Version 4.3, you might want to review some of the new functions and
enhancements.

The following sections briefly describe the major new Personal Communications
functions.

Programming Enhancements

New Menu Structure
Emulator session menus have been improved to be compatible with other
Windows 95, Windows 98, Windows NT, and Windows 2000 applications.

Additonal EHLLAPI Functions
Additonal functionality for EHLLAPI allows better monitoring and control
of host sessions.

Open Host Interface Objects for Java
Provides a Java Interface to the Personal Communications Open Host
Interface Objects for Java (OHIO).

Windows 2000 Support
Windows 2000 is a supported environment, including plug-and-play device
support.

Multiple Language Support
Personal Communications supports installation of multiple languages and
switching from one to another.

Connectivity Enhancements

Improved Twinax Configuration Support
Setup for Twinax devices has been simplified, including plug-and-play
device support.

Client Certificate Authentication Support
Personal Communications Version 5.0 provides additional support for
Secure Sockets Layer (SSL), including support for authentication of client
workstations.

Installation/Configuration Enhancements

System Policy Support
Personal Communications Version 5.0 provides support for utilizing
Windows System Policies to control access to selected functions. For
detailed information about creating this file, refer to Personal
Communications Version 5.0 Reference Volume I.

Tivoli Support
Personal Communications Version 5.0 is Tivoli®-Ready certified. It is
integrated with Tivoli Enterprise as a Desktop application, and provides a
Plus module for its application management. The Plus module, called
IBMPCOMM Plus, includes event management, software distribution, and
administrative tasks; it provides additional support for Tivoli remote
management functions, including the following:
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* Starting emulator sessions
* Stopping emulator sessionsInstallation

* Monitoring emulator sessions

AS/400 Connectivity Configuration for Network Drives
Personal Communications Version 5.0 provides a utility to define the
characteristics of connections needed to take advantage of remote access to
disk drives over IP network connections.

Other Enhancements

VT Enhancements
Personal Communications Version 5.0 provides the following VT
Enhancements:

* Additonal Screen Sizes Beyond 24 Lines
 History Display in Scrollable Window

Euro Sign
Additional code page tables have been changed to support the new euro
sign.

Printer support for this currency sign depends on the printer and printer
driver supporting it.

New code pages

Provides new or updated support for these code pages:

* 1153 (Latin 2)

* 1154 (Cyrillic)

* 1155 (Latin 5 —Turkey)

* 1156 (Latvia, Lithuania)

* 1157 (Estonia)

* 1158 (Ukraine)

* 1160 (Thailand)

* 1164 (Vietnam)

* 1364 (Korea)

* Personal Communications now uses the IBM CDRA Tables (for SBCS
versions only).

Chapter 1. Welcome to Personal Communications 17



What's New

18  Personal Communications Quick Beginnings



Chapter 2. Planning to Install Personal Communications

Personal Communications supports a wide range of workstations that use different
bus architectures and peripheral components. There are hardware and software
requirements, as well as memory and storage requirements,to consider when
planning the installation of Personal Communications.

The following sections describe and list support for monitors, adapters, and
keyboards.

For detailed instructions on installing Personal Communications, refer to the
Personal Communications Version 5.0 CD-ROM Guide to Installation.

Workstation Hardware

[Cable 1 shows the workstation hardware support for Personal Communications.
Personal Communications supports workstations with the following hardware:

Table 1. Workstation Hardware Support

System units The recommended system unit has an Intel® 80486 or faster
microprocessor and access to a CD-ROM drive.

Display monitors All display monitors supported by Windows 95, Windows 98,
Windows NT, or Windows 2000.

Video adapters All video adapters supported by Windows 95, Windows 98,
Windows NT, or Windows 2000.

Keyboards * Enhanced keyboard (101-key, 102-key, 104-key) (Only the 101-key

for Japanese)
* Space-saving keyboard
* Microsoft Natural Keyboard
* 5576-001/002/003/A01/B01/B05 (Japanese)

Printers All printers supported by Windows 95, Windows 98, Windows NT,
and Windows 2000 when a PDT file is not used. For more details
about printers supported in PDT mode, refer to the Personal
Communications Reference manual.

Communication LAN, SDLC, coaxial, twinaxial, WAC, COM Port, OEM, and
adapters Multiprotocol communication adapters.
Modems All asynchronous modems that use the Hayes AT command set and

are supported by Windows 95, Windows 98, or Windows NT.

Synchronous (SDLC) modems attached to a multiprotocol adapter
(MPA), SDLC or WAC adapter.

Workstation Hard Disk Requirements

This section tells the amount of disk space you will need to install the full IBM
Personal Communications for Windows 95, Windows 98, Windows NT, and Windows
2000 on your workstation.

If you are running Windows 95 or Windows 98, Personal Communications files

will need 700 KB of disk space on the disk drive where Windows 95 or Windows
98 is installed.
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If you are running Windows NT or Windows 2000, Personal Communications files
will need 9 MB of disk space on the disk drive where Windows NT or Windows
2000 is installed.

In addition, for each item in the following table that is not already installed, you
will need the amount of space shown. The space must be on the same disk drive
where Windows is installed:

Software Package Space Required
VBScript Runtime Libraries 1.8 MB
Microsoft Shared Libraries 2.4 MB

Refer to the Personal Communications Readme for the most current information on
space requirements.

If you use the Install on a workstation to run from a server installation option,
Personal Communications requires less than 12 MB of disk space on your
workstation.

In addition to the amount of space Personal Communications takes, you need 3
MB of disk space for temporary files or work space during installation.

Workstation Memory Requirements

For Personal Communications the amount of memory you need depends on
several factors, including the operating system you are running on, the attachment
type, number of sessions, and the use of programming interfaces such as Emulator
High-Level Language Application Programming Interface (EHLLAPI) and Dynamic
Data Exchange (DDE). Personal Communications for Windows 95 and Windows 98
will run on 16-MB workstations; a minimum of 32 MB of memory is recommended
for Windows NT.

If you want to run Personal Communications and other applications
simultaneously, you might need to add more memory to your workstation.

Workstation Software

For SNA client attachment to a NetWare for SAA 2.0 (or later) gateway, or to a
Communications Server for Windows gateway, you need the API Client for
NetWare for SAA and IBM Communications Server for Windows NT (provided
with Personal Communications).

For attachment to the Microsoft SNA Server for Windows, you need the Microsoft
SNA Server Windows NT Client; for attachment to the Microsoft SNA Server for
Windows 95 and Windows 98, you need the Microsoft SNA Server Windows 95 or
Windows 98 Client.

Host Requirements

Refer to the Personal Communications Version 5.0 Reference Volume I for
information about software and hardware requirements for host systems.
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Chapter 3. Configuring Sessions

Personal Communications saves emulator configuration information to a
workstation profile (WS) and SNA information to a configuration file (ACG).
Depending on your Personal Communications configuration, you might have a
workstation profile only or both a workstation profile and a configuration file. The
workstation profile can be used later by other Personal Communications sessions,
or to restart this session. The SNA configuration file (ACG) is used to initialize the
SNA node of Personal Communications.

You can have an icon created for each workstation profile.Then you can select the
session icon to establish communication with the host system using the saved
workstation profile.

— Note

If you configure more than one workstation profile, we strongly
recommend that you use the same SNA configuration file for all of
them. If you do not use a common SNA configuration file, make sure
that there are no conflicts of link names or PU names (for 3270
sessions) between the two configuration files. In addition, the local
system information should be the same on the Configure Local
System windows. Failure to do this might result in unpredictable or
inconsistent behavior.

— Configuring for AS/400

To connect to an AS/400 system, specific configuration information in
the workstation profile must correspond to the information specified
at the AS/400 system. See !Appendix C_AS/400 Canfiguration
Examples” an page 101 for more information about creating display,
line, and controller descriptions on the AS/400 system.

”

If you want to configure multiple links, see ‘’Appendix E_Configuring Multipld

Creating a Configuration

To configure a session:
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1. From the Start menu, select:

Programs
IBM Personal Communications

Start or Configure Session

If there is no configuration currently defined, and your workstation is
coax-connected, a window is displayed, asking you to start or configure a
connection.

n

Click Configure to continue. The Customize Communication window appears.

w

Select the type of host from the Type of Host drop-down list box. The choices
are:

* S/390 for connections to an S/390 system

* AS/400 for connections to an AS/400 system

¢ ASCII for connections to an ASCII system

* S/3x for connection to System 36 and System 38 computers

P

Select the Interface you will use from the Interface drop-down list box.

o

Select the attachment type you want to use from the Attachment drop-down
list box.

6. Click Session Parameters.
The Customize Communication — 3270, 5250, ASCII, or S/3X — Host window
appears (depending on the host you selected in step B). Click OK.

7. Click Link Parameters.
Depending on the attachment type selected, a wizard or a window will be
displayed.
If you selected an SNA attachment, a wizard will provide prompts for
configuring an SNA attachment. Enter the appropriate information for each
page and click Next to continue. Click Finish when you are done.
Save the SNA configuration, as described on page 3.

If you selected an attachment type other than SNA, make your selections for
the parameters in the window displayed. Click Help or press F1 to display
parameter details. Click OK when you are finished. You will not need to save
an SNA configuration.

Note: If your host is configured to support secure sockets layer (SSL), then
click the tab for the Advanced Security Setup property page. Refer to
Personal Communications Reference Volume 1I for details on configuring for
this capability.
8. Click OK on the Customize Communication window. The session is displayed
automatically.

Save the workstation profile as described on page kd.
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If you have a user profile that was created by a previous version of
Personal Communications, Auto-Logon (when connecting to an
AS/400 host) may not work. In this case, you must recreate. Select
Configure User Profile in the Customize Communication — 5250
Host window.

Saving Configuration Information

This section describes how to save configuration information. SNA configuration
information is stored in an *.ACG file, and emulator configuration information is
stored in a workstation profile (*.WS).

Saving an SNA Configuration

The Save As window appears automatically after you create or change a
configuration with an SNA attachment. To save this information in a configuration
file:

1. Type the file name and then click Save. The default file type is .ACG and the
default directory is the Personal Communications private subdirectory.

When you save an SNA configuration file, you are also makingit the default
configuration for the SNA node.

You are returned to the Customize Communication window.

2. Click OK until you return to the session window, and then save your
workstation profile, as described in the next section, i i

Saving a Workstation Profile

If you save your emulator configuration information, the session will have the
same characteristics the next time you start it. If you have an icon added to the
Personal Communications folder, you can restart the session with the saved
configuration information by clicking this icon from the Start menu. You are
automatically given the opportunity to save your session information when you
close a session. However, if you want to save the information at any time, do as
follows:

1. Select Save from the File menu in the session window.
The Save WorkStation Profile as window appears.

2. Type a file name ((WS) and then click OK. The name you enter will become the
icon title unless you enter a description.
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If you want a longer or more descriptive title, enter the text you
want in the Description field.

Note that you can choose the directory where this file is saved, but the default
location is the Personal Communications private subdirectory.

A message appears that lets you choose to have an icon created.

If you select Yes, an icon is created in the folder or program group you specify.
You can start the workstation profile by selecting this icon.

If you select No, you can start the session using the Start option of the Start or
Configure Session icon in your IBM Personal Communications folder on your
Windows Start menu.Optionally, you can start the session by clicking Run from
the Start menu, and entering:

C:\PROGRAM FILES\PERSONI\PCSWS.EXE x:\<pcomm-private>\xxx.WS

where x: \<pcomm-private>is the location of your Personal Communications
private subdirectory, and xxx.WS is the workstation profile name.

Note: You must specify all paths and directories. You can type the name of the
directory as either PERSON 1 or PERSONAL COMMUNICATIONS.

Changing Configuration Information

You can change all of the configuration parameters in the workstation profile and
the SNA configuration.

Changing an SNA Configuration

You can change the basic configuration parameters of an SNA configuration for
your session in the following three ways:

* Using the Emulator Configuration
* Using the SNA Node Configuration
 Editing the configuration file with an ASCII editor
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To change advanced configuration options or to specify a different
default configuration, you need to use the SNA Node Configuration
program. In fact, we recommend that you use the SNA Node
Configuration program whenever possible. If you manually edit the
configuration files, we strongly suggest that you use the SNA Node
Configuration Verification utility prior to making use of the file for
the first time.

Using the Emulator Configuration

To change an SNA configuration:

1. Select Configure from the Communication menu, then click Session
Parameters.

2. Change the parameters on this window, as necessary and click OK.
3. Click Link Parameters.

Your default configuration file should be opened automatically. If you want to
change a different configuration, click Existing and choose the configuration
file you want to change.

A wizard is displayed to prompt you through the configuration.
4. Make your changes and then click Next.

Now you can proceed through the Wizard and make additional changes, if
necessary.

5. Click Finish when you are done.

6. If you want to replace the existing configuration, click Yes to overwrite it. If
you want to create a new configuration that is based on the existing one, type a
new file name; however, you must use SNA Node Configuration to make a
new configuration the default configuration.

7. Click OK until you return to the session window.

Using the SNA Node Configuration Program

For Personal Communications Version 5.0, all SNA data is stored in the SNA node
configuration files (extension .ACG). The SNA Node Configuration program is a
graphical user interface (GUI) for managing the content of these .ACG files. This
program allows you to define individual SNA resources or change the definition of
these resources.

Using an ASCII Editor to Change Your Configuration Files

You can create and modify a configuration file without going through the SNA
Node configuration interface. You can use the ASCII editor of your choice. A
verification tool is available to ensure that you have not made errors when editing
your file.

Refer to the Personal Communications Configuration File Reference manual for

information on how to edit your configuration data using an ASCII editor and how
to verify your editing changes.
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Changing a Workstation Profile

To change a workstation profile:

1. If your session window is not active, select the icon corresponding to the

workstation profile to be changed.

The session window appears.

Select Configure from the Communication menu.

The subsequent steps are the same as for creating a new configuration,
beginning with step

After you have made your changes, the following message appears:

Because you have changed the configuration,
communication will be terminated if you
proceed. Are you sure?

If you click OK, communication ends, but then you are reconnected using the
new configuration information.

To save the changes in your workstation profile, click Save from the File menu
in the session window and then click Yes to replace the existing file. Otherwise,
click No to save this information in a new configuration file.

Unless you have unchecked Save on Exit in the Exit Options dialog
by selecting Preferences > Exit from the Edit menu, changes are
saved in the workstation profile automatically whenever you exit a
session.
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This chapter describes how to start and stop single and multiple emulator sessions.

If Vour emulator conﬁguratlon information was saved, as described in @

v , it is stored in a workstation profile (*.WS).
If you have a session icon, you can select it to start a session, using the saved
configuration information.

— Note

If you are a first-time user of Personal Communications, or there are
no session icons in your Personal Communications folder or program

group, refer to !Chapter 3 Configuring Sessions” on page 23 to create

a configuration.

Starting Sessions

You can use the methods described below to start sessions:

* Select Programs > IBM Personal Communications > Start or Configure Session
from the Windows Start menu.

* Select an already-configured session icon from the Windows Explorer or from
the Programs > IBM Personal Communications folder from the Windows Start
menu.

* Start from an existing session window.

* Specify a workstation profile name in the Run window.

* Enter the PCOMSTRT command in the Run window or MS-DOS Prompt.
e Start multiple sessions with a batch file.

When you start multiple sessions, the titles of session windows are Session A,
Session B, and so on, unless you have customized them using a batch file.

Note: Connection status messages will be displayed on a status bar at the bottom
of your session window during connection to the host.

Starting from the Start or Configure Session Icon

Select Programs > IBM Personal Communications > Start or Configure Session
from the Start menu. The logo panel appears; click Start to continue. The file open
dialog window appears; select the profile for the session you desire.

Starting by Selecting an Already-Configured Session Icon

To start a session, click the relevant Session icon from the Personal
Communications folder on the Start menu.
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Starting from an Existing Session Window

Use the following methods to start from an existing session window:
Starting Another Session Using the Same Profile

Select Run the Same from the File menu. Another session starts, using the same
profile.

Starting Another Session Using a Different Profile
1. Select Run Other from the File menu.
The Open Other Workstation Profile window appears.
2. Double-click the desired workstation profile in the File Name list.
3. Select OK.

Another session starts, using the profile specified in step B

Starting a Different Type of Session from a Session Window
1. Select Open from the File menu.

2. Specify the desired workstation profile and then select OK.

The current session ends and then another session starts, using the selected
profile.

Starting Using a Command
To start a session:
1. Select Programs > Run or Programs > MS-DOS Prompt from the Start menu.
2. Enter the command:
PCOMSTRT /P=x:\<pcomm-private>\my .WS

where my. WS is the workstation profile stored in the Personal Communications
private subdirectory. This is the only required parameter; for a complete
description, refer to the Personal Communications Reference Volume 1.

Another method for invoking Personal Communications using a command is with
the command for the PCSWS.EXE module; see step m

Starting a Workstation Profile from the Run Command Line
To start the session:
1. Select Start and then Run.

2. Type the following command in the Command Line field and then select OK.
PCOMSTRT /P=x:\<pcomm-private>\my.WS

where my. IS is the workstation profile stored in the Personal Communications
private subdirectory.

Starting Multiple Sessions

If you installed the Multiple Sessions utility, you can use the batch program, which
runs batch files (*.BCH), to start two or more workstation profiles at the same
time.Personal Communications batch files can also start other programs when you
include their startup commands. This is especially useful if you always want to
start an application when you start a session. For example, you might want to start
an application, such as ZipPrint, that uses a Personal Communications APL
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If you created an icon for your batch file, you can start workstation profiles and
other programs in the batch file just by selecting the icon.

Creating a Batch File

To configure a session:

1. From the Windows Start menu, select the Multiple Sessions icon in the
Utilities subfolder of the IBM Personal Communications folder.
The Create/Modify Batch File window appears.

2. There are four methods for including profiles or programs in a batch file. Use
the method you prefer:
* Double-click the file names in the File Name list box.
* Drag and drop the file names (using the right mouse button) from the File

Name box to Batch-File Entries.

* Select a file name from the File Name list box and then select Add.

* Type the complete path and command file name in the batch files entries
area.

Personal Communications places the full path and command that is needed to
run the workstation profile or other program above the cursor line in the edit
area. If there is no cursor, the command will be added to the last line. To see
the contents of the profile you added to the batch file, click it in the File Name
list box and then click View File or the magnifying glass.

— Note

Some brief instructions appear at the top of Batch-File Entries;
you need not remove them, because they do not affect the
running of the batch file.

There is one exception—if you are using the Japanese version of
Windows NT, you must delete these instructions. One way to do
this is to select New from the File menu of the Create/Modify
Batch File dialog before adding any files.

3. Repeat step B for each subsequent file to be added.
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— PCSWS.EXE Options
* To suppress the IBM logo when you start one or more sessions, add the
parameter /Q to the first commandin the batch file:
C:\dir\PCSWS.EXE C:\dir\<PCOMM-PRIVATE>\TCPIP1.WS /Q

where dir is the directory where you have Personal Communications
installed, and <PCOMM-PRIVATE> is the Personal Communications
private subdirectory.

+ To start a session as an icon, not as a window, add the parameter /I to
the commandin the batch file:

C:\dir\PCSWS.EXE C:\dir\<PCOMM-PRIVATE>\TWINAX.WS /I

where dir is the directory where you have Personal Communications
installed, and <PCOMM-PRIVATE> is the Personal Communications
private subdirectory.

* To start a hidden session, not as an icon or a window, add the parameter
/h to the commandin the batch file:

C:\dir\PCSWS.EXE C:\dir\<PCOMM-PRIVATE>\TWINAX.WS /H

where dir is the directory where you have Personal Communications
installed, and <PCOMM-PRIVATE> is the Personal Communications
private subdirectory.

 To start a session with a specific short session ID,insert the parameter
/S=m after PCSWS.EXE in the batch file:

C:\dir\PCSWS.EXE /S=m C:\dir\<PCOMM-PRIVATE>\LANI.WS

where m is the short session ID and dir is the directory where you have
Personal Communications installed, and <PCOMM-PRIVATE> is the
Personal Communications private subdirectory.

Notes:

a. Several parameters may be specified for controlling the particular
characteristics for starting sessions; the switch values are designated
by a single character.

b. If you use the /S option to assign A as the short session 1D, you
should use this option for all of the sessions in the batch
file.Otherwise, if another session starts first, it becomes the A
Session and the session with the /S=a option will not start because
of the conflicting short session IDs. Another way to prevent conflicts
is to assign a character later in the alphabet for the short session ID.

4. When you complete the edit, save the created batch file by selecting Save from
the File menu.

The Save Batch File As window appears.
5. Enter a name for the batch file (*.BCH).

The name you enter is used as the icon title, unless you enter a description as
well.

6. Select OK to continue.
7. Select Yes if you want to create an icon for the batch file.
The Personal Communications window appears.
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8. Specify the program folder to which the batch file icon is to be added and then
select OK.

A message appears, asking you to save the batch file.
9. Select OK.

The batch file icon appears in the specified program group.

The following example is a batch file that runs six workstation profiles, saved in
the C:\PROGRAM FILES\PERSONI\PRIVATE directory, and then runs MYAPP.EXE.

— Sample Batch File

C:\dir\PCSWS.EXE C:\dir\PRIVATE\COAX1.WS /Q
C:\dir\PCSWS.EXE C:\dir\PRIVATE\COAX2.WS /I
C:\dir\PCSWS.EXE C:\dir\PRIVATE\SLAN1.WS
C:\dir\PCSWS.EXE C:\dir\PRIVATE\SLAN2.WS
C:\dir\PCSWS.EXE C:\dir\PRIVATE\AS4Y1.WS
C:\dir\PCSWS.EXE C:\dir\PRIVATE\VT220.WS
C:\APPL\MYAPP.EXE

where dir is the directory where you have Personal Communications
installed.

Using a Batch File
You can use one of the following methods to run a batch file:
* Select the batch file icon from the Explorer or from the Start menu.
¢ Run the batch file from the Run command line:
[drive]:\[path]\PCSBAT.EXE [drive]:\[path]\xxxx.BCH /R

Note: To run a batch file, specify the /R option.
* Start the Multiple Sessions icon.
1. Select Open from the File menu in the Create/Modify Batch File window.
2. Select the desired batch file and then select OK.
The contents of the batch file appears in the edit area.
3. Select Run from the Run menu.

Editing an Existing Batch File
To edit an existing batch file:
1. Select the Multiple Sessions icon from the Start menu.
The Create/Modify Batch File window appears.
2. Select Open from the File menu.
The Open Batch File window appears.
3. Select the batch file you want to edit and then select OK.

The contents of the batch file you selected appear in the edit area of the
Create/Modify Batch File window.

4. Edit the batch file. Refer to step m‘ for more details.

Refer to the online help for details about the menu bar Edit functions. Select
Index from the Help menu and then click Menu-Bar Commands on the
Batch-Program Window.

Chapter 4. Starting and Stopping Emulator Sessions 33



Starting Emulator Sessions

5. When you complete the edit, save your changes by selecting Save or Save As
from the File menu.
* Select Save to save your changes in the existing file.
* Select Save As to save your changes in a new file and then continue with
step

6. Exit the Create/Modify window.

Starting Multiple Sessions without a Batch File
To start multiple sessions without a batch file:
1. Select the icon for the session you want to start first from the Start menu.

2. After it connects to the host, select one of the following choices from the File
menu:

* Run the Same... to start another session with the same configuration.
* Run Other... to start a session with a different configuration.

When the Open Other Workstation window appears, select the profile you
want to start and then click OK.

Automatically Starting Sessions

To start one or more sessions automatically, do as follows:
1. From the Start menu, select:

Settings
Taskbar

2. Click the Start Menu Programs tab and then click Add.

Click Browse and then open the Personal Communications private
subdirectory.

w

Change the file type to A11 Files.

Double-click the session icon or the batch icon.
Click Next and then double-click the Startup folder.
Accept the icon name or type a new one.

© N o gk

Click Finish and then OK when you are done.

Stopping Sessions
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To stop a session, click the X in the upper-right corner or double-click the
upper-left corner of the session window, or select Exit from the File menu.

To stop multiple sessions at the same time, select Exit All from the File menu. All
emulator sessions end, and the associated session windows are closed.

Sessions can also be stopped using a command:
1. Select Programs > Run or Programs > MS-DOS Prompt from the Start menu.
2. Enter the command:

PCOMSTOP /S=x

or
PCOMSTOP /ALL
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where x is the session letter of the particular session to be stopped; use ALL to
stop all active sessions. There are other parameters; for a complete description,
refer to the Personal Communications Reference Volume I1.
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Chapter 5. Using Emulator Sessions

This chapter describes how to use the printing, editing, and data-transfer functions
in an emulator session. It also describes the choices on the Appearance, Assist, and
Window menus in the emulator session windows.

Printing

You can use Personal Communications to print from display or printer sessions:

From display sessions, you can print all (Print Screen)or part (Trim Print) ofthe
screen of your session window on a workstation printer.

To print only part of the session window, drag the mouse to create a trimming
rectangle around the part of the window you want to print and then select Print
Screen from the File menu.

With printer sessions, you can print files directly from a host system to a
workstation printer. Refer to the online help for more information.

Configure a printer session to designate a workstation printer as a system
printer that will use either the printer definition tables (PDTs) provided with
Personal Communications or the Windows printer drivers. Refer to the online
help for more information.

To print, the following methods apply:

You can use Windows printer drivers that you configure through printer setup
in the file menu of the session window.

You can use printer definition tables (PDTs), which give greater control over the
print data stream.

For 5250 only: You can use Host Print Transform, where the host formats and
builds the printer commands.

For more information about printing, refer to the Personal Communications Version
5.0 Reference Volume 1.

Using the Windows Printer Driver

To set up your printer to use a Windows printer driver:

1.

Select Printer Setup from the File menu of the session window.

The Printer Setup window lists the supported printers.

Select the printer driver to be used from the Printer list box. DEFAULT will
cause the use of the Windows default printer.

Notes:

a. The DEFAULT selection is shown when the .WS file specifies
printer=DEFAULT in the [printers] stanza.

b. When this selection is made, no message will appear before the job is
printed.

c. When a printer has been selected for a session, the name of that printer is
displayed in the status bar of the session window.

If desired, click on the check box to Show this dialog before every print.
Confirm that the Use PDT file check box is not selected and then select OK.
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Personal Communications will now use the printer driver you selected, and the

Printer Setup window is closed.

Using Printer Definition Table (PDT) Files

Printer Definition Table files define the transfer of characters and control codes to a

printer, and the printer output format. If a PDT file is used, the Windows printer

driver is not used, and Personal Communications generates print output based on

printer control information defined in the PDT file.

Refer to the Personal Communications Version 5.0 Reference Volume I for more
information about PDT files.

To use PDT files:

1.

5.

Select Printer Setup from the File menu of the session window.

The Printer Setup window appears.

Select the port to be used from the Printer list box.

Selected PDT files are available for the port selected here.

Select Setup and then specify the paper size of the selected printer driver.
Select the Use PDT file check box and then select Select PDT.

The Select PDT file window appears.

To use an existing PDT file, select a PDT file to be used and then select OK.

Using Host Print Transform (5250 only)
To use Host Print Transform (HPT):

1. When configuring a 5250 session, the HPT mode may be selected.
2. From the Configure panel, click Advanced.
3. Select HPT Yes.
The following window items become available.
4. Enter the Printer Module.
5. Enter Drawer 1, Drawer 2, and Envelope form names.
6. Enter Code Page 899, Y or N.
7. Select Customizing Object and Library (optional)
Page Setup

Personal Communications allows you to set Page Setup parameters, such as the

maximum number of lines per page, the maximum number of columns, and fonts.

For detailed information and instructions on Page Setup, refer to the Personal
Communications Version 5.0 Reference Volume I

Scalable (Truetype) APL-Font Support on Printers

Because special APL characters are not provided for printers, when APL characters

are printed, the APL fonts provided for displays are used. In some cases, APL
characters are printed rather small. To print larger APL characters, you should
install a scalable (Truetype) APL font as follows.

1.

2.
3.

Open the Control Panel Folder.

* Click Start on the task bar.

* Move the pointer to Settings and click Control Panel.
Open the Fonts folder. (Double-click the Fonts icon.)
On the File menu, click Install New Font.
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4. Click the drive and folder where Personal Communications is installed.
5. Double-click AICAPL.

ZipPrint (3270 Only)

Use ZipPrint to print PROFS or OfficeVision notes, calendars,OV documents, CMS
files, XEDIT workspaces, and 3270 session screens.

Preparing to Use ZipPrint

Before you can use ZipPrint, DDE/EHLLAPI must be enabled for the sessions. To
do this, select API Settings from the File menu and refer to the online help for
detailed instructions. DDE/EHLLAPI is enabled by default.

— Note

By default, PROFS-oriented functions of ZipPrint are U.S. English
PROFS. You can customize ZipPrint for other languages. Start
ZipPrint before you start any display sessions.

Starting ZipPrint

Start ZipPrint before you start any display sessions. The ZipPrint menu is added to
the menu bar of the specified session window; then you can use it from the menu
bar the same as with the other functions.

Start ZipPrint by selecting the ZipPrint icon in the Personal Communications
program folder. This starts ZipPrint for Session A only.

You can also start ZipPrint by placing it as the first command in a Personal
Communications batch file.

For more information about ZipPrint, including information about using ZipPrint
for additional emulator sessions, search for ZipPrint in Help.

Using ZipPrint

Keep the following consideration in mind when using ZipPrint:

ZipPrint uses the Personal Communications File-Transfer function to print
VM/CMS notes and files. On slower communication lines such as SDLC, Async
(IIN), or Home3270 attachment, or when using a large packet or block size, you
might experience a file-transfer timeout. If this happens, you should increase the
timeout delay as follows:

1. Select Preferences > Transfer from the Edit menu of the session window.

2. Increase the timeout value to 150 seconds or longer.

When using ODPS (Japanese PROFS or other DBCS PROFS), ZipPrint uses the
Hankaku (SBCS) font. So when using a ZENKAKU font, such as KAN]JI or
HIRAGANA, the font setting should be changed as follows:

1. Click Configure ZipPrint from the ZipPrint menu in your session window.
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2. Click Setup font.
3. Select a ZENKAKU font such as MINCHO and GOTHIC and then click OK.

IBM 5586-H02 Printer (Japanese Only)
Use IBM5585.PDT for PDT mode printing with the IBM 5586-H02 printer.

Editing
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You can edit the contents of your session window using the Windows clipboard
and the Edit menu.

Note: When using copy/cut functions, Personal Communications takes the entire
contents from the session window and places it on the clipboard. To copy or
cut only marked sections from the session window, you need to update the
Cut/Copy options. To update the Cut/Copy options, do the following:

1. Select Preferences > Edit from the Edit menu from the Edit menu.
2. From the Edit Options window;, select the Cut/Copy tab.

3. From the Cut/Copy page, select the Only if a trim-rectangle is marked
check box.

4. Close the Edit Options window.

Undo Cancels the most recent Edit operation, except for Copy Link, and restores
the contents of the session window and the clipboard accordingly.

Cut  Copies the marked area into the clipboard and removes it from the display
session window.

Copy Copies (or duplicates) the marked area into the clipboard without
removing it from the display session window.

Copy Append
Copies the marked area into the clipboard without removing it from the
display session window. If there is already data in the clipboard, Copy
Append adds the new data to it.

Paste Overlays the current contents of the clipboard into the session window,
starting at the current cursor position.

Clear Removes the marked area of the session window. The clipboard contents
are not altered.

Copy Link
Supports the DDE Copy Link function. To start a link between Personal
Communications and another application program, mark an area of the
session window, select Copy Link, and then select Paste Link in the other
application program.

— Note

The command you should use for PasteLink or PasteSpecial
depends on the application program you are using.
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Unmark
Removes the clipping (or marking) rectangle. The session window and the
clipboard contents are not altered.

Select All
Marks the entire session window.
Options
Allows you to control the behavior of pasting to a VM screen

Editing by Linking to Windows Application Programs

Linking to Windows application programs supporting PasteLink lets you paste
session-window data to the windows of those application programs. You can run
CopyLink when DDE/EHLLAPI is usable.

Confirming the DDE/EHLLAPI Settings
To check whether DDE/EHLLAPI is currently set to usable status:

1. Select API Settings from the File menu.
2. Make sure the DDE/EHLLAPI check box is selected.
If the box is checked, DDE/EHLLAPI is set to usable status. Continue to step 7}
3. If the box is not checked:
a. Click the DDE/EHLLAPI check box and then click OK.
b. Stop and then start your session to enable the new settings.
4. If DDE/EHLLAPI was already set to usable status, select OK.

Using CopyLink and PasteLink
1. Mark the session window area for which CopyLink should be issued.
2. Select CopyLink from the Edit menu.

If the session window is already linked with an application program,
CopyLink appears in gray and cannot be selected. In this case, force the
application program to end the linkage, or stop the application program. Then
you can select CopyLink.

3. Start the Windows application program for the window to which an area
should be copied.

4. Specify the location for which PasteLink should be run.

5. Issue PasteLink or PasteSpecial by using the menu for the application
program.

The contents of the marked area are pasted into the specified location in the
window of the application program.

CopyLink is now completed.

When the contents of the marked area in the session window are updated during
linking, the contents of the area pasted to the window of the linked application
program are also updated.

See the online help for more information about the CopyLink and PasteLink
functions.

Copying Table Data to a Spreadsheet

You can use the Cut, Copy, CopyLink, or CopyAppendchoices in the Edit menu to
copy data in the session window to the window of a Windows spreadsheet
application program.
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To use Copy, select the Paste or PasteLink choice in the application program
window into which data is to be copied.

Data in the marked area can be copied in the following three data formats,
depending on the format supported by the spreadsheet for the window to which
data is to be copied:

Sylk format
Data format for general-purpose spreadsheets, such as Multiplan**

Biff3 format
Data format for Microsoft Excel**

WKk3 format
Data format for Lotus** 1-2-3**

Whether application programs, such as Excel or Lotus 1-2-3, also
support these data formats in subsequent versions depends on
individual application program specifications.

Individual items of data in tables of the session window are divided automatically
such that they are suitable for spreadsheets, and they are copied into individual
cells of tables in the application program.

Copying Marked Data without Dividing It into Cells

To paste data in the marked area per line, without dividing it into individual cells,
add the following lines to the workstation profile:

[Edit]

SyTk=N (If Sylk format data is not divided into cells)
Biff3=N (If Biff3 format data is not divided into cells)
Wk3=N (If Wk3 format data is not divided into cells)

Copying Lines Containing Only Operational Signs

If data in the marked area contains signs, such as +, —, =, or |, the signs are
regarded as being ruled lines of the table. Once they are removed, only numeric
data is copied.

+ + b b — +

| | 1 12131 4l 1 2] 3] a4
+ +

| 1900 | 60 |-63]71] 58| — | 1990 |60 |-63] 71| 58
+ + Copy

| 1991 |+69 |69 |90 | 80 | 1991 | 69 | 69| 90 | 80
-+ -+

| 1902 | 71 lso|so]|-30]| 1992 | 71 [ 80| 80| 30
+ + F—— b —-

Table Data in the Marked Area Spreadsheet

To copy these signs without replacing them with null characters, add the following
lines to the workstation profile:
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[Edit]
MaskGridCharacter=N

Copying Data in Cells As Text Data

Data in the marked area is treated as numeric data by default. Therefore, currency
signs, such as $, and punctuation marks, such as commas, are removed before
copying. To copy data containing such signs and marks as text data rather than
numeric data, add the following lines to the workstation profile:

[Edit]

ConvertToNumeric=N

Data in the marked area containing signs and marks is then copied as text data. In
addition, all numeric data that does not contain signs and marks is also copied as
text data.

Getting Help

For information about all the tasks you can perform with the Edit menu choices, as
well as how to mark and then edit an area within the window, refer to the online
help:

1. Select Index from the Help menu.

2. When the help window displays, select Menu Bar Commands of the
Workstation Window.

3. Select Edit from the list of Menu Bar Commands.

Restrictions with Home3270 Attachment
When you use the Home3270 attachment, the following edit functions are
restricted:

Undo function
You cannot perform the Undo function after using the Cut, Paste,
PasteNext, or Clear functions because these functions modify display areas
in the protocol converter.

Cut and Clear functions
When an area to be cut or cleared contains a field attribute character or
protected field, or each line in that area ends at the end of an unprotected
field, the following things might occur:

* Characters in an unprotected field outside the area to be cut or cleared
might also be cleared.

¢ An alarm might sound.

* The cursor might not appear at the initial position.

When you perform the Cut or Clear function, specify only the minimum
area required (for example, some words or one field in one line), and then
confirm that the frame exists in an unprotected field.

Paste and PasteNext functions
When the area to be pasted contains a field attribute character or protected
field, or the end of the paste area on each line is at the end of an
unprotected field, the following things might occur:

¢ The character to be pasted might not be written to the expected position.
* An alarm might sound.

* The cursor might not appear at the initial position.
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When you use the paste function, paste the shortest character string
possible (for example, a character string, but excluding CR/LF). Confirm
that the area to be pasted is in an unprotected field.

Input Method Editor (Japanese Only)

If you are using the Input Method Editor (IME, an editor for double-byte character
sets) on the Japanese version of Personal Communications and you encounter
problems, install a patch file as follows:

1. Copy PCSWLIB.DLL to PCSWLIB.SAV.
2. Copy PCSWLIB.NT to PCSWLIB.DLL.

This file is provided on an “as-is” basis without service. If you wish to restore the
original PCSWLIB.DLL file, copy PCSWLIB.SAV to PCSWLIB.DLL.

To create files with the Multiple Sessions utility on the Japanese version of
Personal Communications, please delete the comments from the .bch file by
selecting New from the File menu of the "Create/Modify Batch File” dialog before
adding any files.

DBCS IME Auto-Start Switch (DBCS only)

The session default is IME auto-start, which means when the cursor moves to
DBCS field, the system selected IME is invoked automatically. In PCSWIN.INI, one
switch flag is added into [DBCS] section to disable this function.

[DBCS] IME_AUTO_START=N

The default is Yes. When "N" is specified in INI file, the IME would not be
invoked automatically. User needs to invoke IME by pressing system keys.

DOS GAIJI Files (Japanese Only)

The GAlJl-editor J can only process GAIJI files that were created with the Windows
3.1 GAIJJI editor. It cannot process DOS GAIJI files. The GAIJI-HENKAN-HOJO
tool (GAIJICNV.EXE) can be used to convert DOS GAIJI files as follows:

1. C:\PROGRAM FILES\PERSONAL COMMUNICATIONS\GAIJICNV.EXE
A dialog box to specify source file and target file appears.

2. Specify the source path/file C:\$SYS1Z24.FNT and the target path/file
C:\USERFONT. FON.

3. Start a conversion by clicking the Conversion button.

4. Run the Windows NT, Windows 95, or Windows 98 Gaiji-editor and capture the
file that is created by step 3, which is C:\USERFONT.FON.

For each file, you only need to convert either the 24x24 font or the 16x16 font with
GAIJICNV.EXE, not both.

Using the User Font Defined on AS/400 (Japanese Only)

You can capture the user-defined font (GAIJI) defined on AS/400 into Windows 95,
Windows 98, Windows NT, or Windows 2000 by using IBM Personal
Communications Tools/400 (PCT/400), IBM Personal Communications, and the
Gaiji editor of Windows 95, Windows 98, Windows NT, or Windows 2000.

The capturing is done as follows:
1. PCT/400
* Copying user font (CPYUSRFNT) command
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This command is executed on AS/400. It copies the user-defined font image
from DBCS font table to a file. Please refer to the PCT /400 documentation
for details of the command.

2. Personal Communications
* File transfer facility

This facility transfers the file member that is copied by the copying user font
(CPYUSRENT) command.

- GAII-HENKAN-HOJO tool (GAIJICNV.EXE)

This program is executed on Windows 95, Windows 98, Windows NT, or
Windows 2000. It converts the file copied by the copying user font
(CPYUSRENT) command to a Windows 3.1 format GAIJI file so that it can
be captured by the Gaiji editor of Windows 95, Windows 98, Windows NT,
or Windows 2000.

3. Windows 95, Windows 98, Windows NT, and Windows 2000
* GAIJI editor

By using the facility to capture the Windows 3.1 format GAIJI file, the file
converted by the GAIJI-HENKAN-HO]JO tool (GAIJICNV.EXE) program is
captured.

Example

1. Copy the user-defined font images from the DBCS font table to a file by using
the copying user font (CPYUSRENT) command.

a. ADDLIBLE QPCT (Add QPCT Tlibrary to the Tibrary Tlist)
b. CPYUSRFNT (Copying fonts, using default parameter)

The physical file USRFNT is created in library QTEMP and user-defined fonts
are copied to member USRFNT from the DBCS font table.

2. Download QTEMP/USRFNT(USRENT) to the PC as file USRENT.FNT by using
the file transfer facility of Personal Communications.

3. Convert USRENT.ENT by using the GAIJI-HENKAN-HO]JO tool
(GATJJICNV.EXE).

e C:\PROGRAM FILES\PERSONAL COMMUNICATIONS\GAIJICNV.EXE
(This command runs GAIJICNV.EXE.):

* As the source file, specify the USRENT.FNT file that you downloaded in step
2. Enter it as c:\usrfnt.fnt

* As the target path/file, specify c:\userfont.fon)
e Start the conversion by clicking the Conversion button.

4. Run the Windows 95, Windows 98, Windows NT, or Windows 2000 NT GAIJI
editor to capture the file that is created.

What Is Different from Windows 3.1

1. The GAIJI-HENKAN-HOJO tool (GAIJICNV.EXE) program is used to convert
the USRENT.ENT. Font Setup Utility (SETUFNTV.EXE), which is provided by
PCT /400, is not used. Therefore, Font Setup Utility (SETFNTV.EXE) does not
need to be downloaded from AS/400.

2. To capture the font into Windows 95, Windows 98, Windows NT, or Windows
2000, the GAIJI editor of Windows 95, Windows 98, Windows NT, or Windows
2000 is used.
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Transferring Files

Personal Communications enables the transfer of one or more files between a host
system and workstation. You can define file transfer options in advance to help
you transfer a variety of files quickly and easily.

With Personal Communications, you can perform the following file transfer
functions:

Send files to the host system
Send files using the Send File to Host from the Actions menu; or by
clicking the Send button on the tool bar; or, when using 3270 sessions, the
SEND command from the DOS prompt.

You can also send files by using an EHLLAPI or DDE application or a
macro that invokes file transfer.

Receive files from the host system
Receive files using the Receive File from Host from the Actions menu; or
by clicking the Receive button on the tool bar; or, when using 3270
sessions, the RECEIVE command from the DOS prompt.

You can also receive files by using an EHLLAPI or DDE application or a
macro that invokes file transfer.

Data Transfer
For 5250 sessions, click Preferences > Transfer from the Edit menu; then
select Data Transfer on the property page with the General tab. This
causes the invoking of data transfer functionality when one of the above
actions is taken. If Data Transfer is not selected, normal file transfer is
invoked.

Create, test, replace, and delete templates
Create a template to have Personal Communications automatically generate
a workstation or host file name and transfer type when you select a file to
be sent or received.

Note: It is not possible to define a file transfer template with the long file
name naming convention.

Define transfer types
Define up to 16 transfer types for each host system. Text, binary, and
append (except for CICS) are initially set as transfer types.

Select, create, and customize translation tables
Select translation tables to define which translation table is used during file
transfer.

Select, create, and customize DBCS translation tables
Select DBCS translation tables to define which DBCS translation table is
used during file transfer. (Japanese and Korean only.)

Import or export files (PC/3270 only)
Import/Export is an office system communication program and an
application program run on the IBM Customer Information Control
System® (CICS®). The import/export function makes it possible to import
or export Final Form Text (FFT), Revisable Form Text (RFT), and PC
documents.
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When you export a file from the host, your workstation receives the file
you exported and an interchange document profile (IDP) file. Before you
can import a file to your workstation, you need to create an IDP file with
transmission information.

Create interactive document profile (IDP) files (PC/3270 only)
An IDP file contains document header information, has the same name as
the file to be transferred, and has the extension .IDP.

To create an IDP file, select Preferences > Transfer from the Edit menu.

— Note

When you transfer a file on a Telnet5250 session, you cannot transfer
a file that includes FFEF. The current version of the AS/400 Telnet
program misinterprets FFEF in the file as an end-of-record marker.

ASCI| Host Data Transfer

When you are transferring files between two computers, specific protocols must be
followed. Files can be transferred only when your PC uses the same protocol as the
host. Personal Communications supports the XMODEM and YMODEM public
domain protocols.

For XMODEM, Personal Communications uses the XMODEM and XMODEM1K
protocols. XMODEM is a block-oriented, error checking protocol that is a single
file, half duplex protocol. XMODEMIK is the same as XMODEM, except that it

uses larger 1024 byte (1K) packets.

The YMODEM protocol is similar to the XMODEMIK protocol in that it transfers
data in 1K packets, but it also allows multiple files to be sent in one transfer.

The YMODEMG protocol transfers multiple files like YMODEM, but performs no
error detection or error correction. It can be much faster than YMODEM, but
requires an error-free data connection.

With Personal Communications, you can perform the following data transfer
functions to or from ASCII hosts:

Send any type of files to the host system
Send files using the Transfer menu using XMODEM, YMODEM,
XMODEMI1K, or YMODEMG.

Receive files from the host system
Receive files using the Transfer menu and XMODEM, YMODEM,
XMODEMI1K, or YMODEMG.

Create, test, replace, and delete templates
Create a template to have Personal Communications automatically generate
a workstation or host file name and transfer type when you select a file to
be sent or received.
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Getting Help

For more information about transferring files, refer to the online help:
1. Select Procedures from the Help menu.

2. When the help window displays, scroll down to Transferring Data.
3. Select choices from that list for detailed information.

Setting Up a Session Window’s Appearance

48

You can use the following functions to define the appearance of your session
window:

Preferences > Appearance > Display Setup from the Edit menu
Customize a variety of characteristics, such as the cursor, pointer, rule line,
and trimming styles, graphics, sound, DBCS, and color palette, in the
display session.

Preferences > Appearance > Color Mapping from the Edit menu
Set the colors used in session windows.

Preferences > Appearance > Font from the Edit menu
Choose the font to use for display session windows, the style, and whether
it will be an automatic sizing font or a fixed size font. If you use a fixed
size font, you can also choose its size. The set of fonts from which you can
choose depends on the type of display you are using.

Note: You cannot change the font size when the session window is
maximized.

Preferences > Appearance > Window Setup
Change the appearance and title of the session window and change the
session icon.

Tool Bar Setup

The tool bar displays under the menu bar in your session window to allow quick
access to the Personal Communications functions, commands, and defined macros.

Use the tool bar pop-up menu to quickly and easily create, edit, and delete tool bar
items, as well as to save and load customized tool bars. When you customize the
tool bar, you can change the order of items, add and delete items, change the
function, title, or graphic associated with any item, change the fonts, colors, and
other tool bar visual style elements. The settings are stored in a .BAR file.

To customize your tool bar, select Preferences > Tool Bar > Tool Bar Style from
the Edit menu, or display the Tool Bar pop-up menu by clicking on the right
mouse button while pointing at any part of the tool bar.

For information about customizing the tool bar, refer to the online help.

If you want to hide the tool bar, refer to 'Showing or Hiding the Menu Bar, Statud
Bar and Tool Bar’l

7)

Showing or Hiding the Menu Bar, Status Bar and Tool Bar

You can show or hide the menu bar, status bar or tool bar. To do this:
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If the menu bar is displayed, select Show Status Bar from the View menu or
Show Tool Bar from the View menu; otherwise:
1. Click the upper left corner of the session window to display the system menu.

* Hide Menu Bar appears when the menu bar is shown.

¢ Show Menu Bar appears when the menu bar is not shown.

* Hide Status Bar appears when the status bar is shown.

e Show Status Bar appears when the status bar is not shown.

* Hide Tool Bar appears when the tool bar is shown.

* Show Tool Bar appears when the tool bar is not shown.

2. To hide either the menu bar, status bar or tool bar, select Hide Menu Bar, Hide
Status Bar, or Hide Tool Bar.

3. To show either the menu bar, status bar or tool bar, select Show Menu Bar,
Show Status Bar, or Show Tool Bar.

If you hide the menu bar, the Pop-up Menu Bar choice is added to the system
menu. The Pop-up Menu Bar shows a cascading menu that contains all
commands in the hidden menu bar.

Windows Setup

— Note

If you set the Maximized Style (in the Windows Setup dialog) to
Without Title Bar, then the Minimize All Windows option on the
Windows taskbar will not have any effect. To minimize the window,
press Alt-Space and select Minimize.

Getting Help

If you're not sure how to set the session window’s appearance options, view the
detailed instructions in the help.

1. Select Procedures from the Help menu.

2. When the help window appears, search for appearance or scroll down to
Changing the Screen Appearance.

Select choices from that list for detailed information.

Setting Up and Using the Assist Functions

Personal Communications provides auxiliary functions that let you operate the
system more efficiently. You can use the following functions:

* Keyboard/Macro/Script Function from the Actions menu

* Preferences > Hotspots from the Edit menu

* Preferences > Keyboard from the Edit menu

* Preferences > Macro/Script from the Edit menu

¢ Preferences > Mouse from the Edit menu

* Preferences > Popup Keypad from the Edit menu

* Preferences > Tab from the Edit menu (for VI Emulation sessions only)

* Preferences > Web Browser from the Edit menu
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This section describes these auxiliary functions, and explains how to set up and
use them.

Keyboard, Macro and Script Functions

A Keyboard /Macro/Script Function command lets you run scripts, macros or
Personal Communications-supplied key functions without using the keyboard. Run
the scripts, macros or key functions from the current cursor position in the session
window.

Scripting Functions

You can write, execute, record and terminate VBScripts in the emulator
environment. These scripts have access to the HACL automation API. The
programming environment includes methods, class descriptions and properties.
VBScript is a subset of the Visual Basic programming language.

Macro Functions

A macro is a sequence of key or mouse actions and host commands that you can
perform with a single action, such as a keystroke. Before you can use a macro
function, you need to define it. For more information, see L i

”

Key Functions

Personal Communications provides many key functions that can be assigned to the
keys on the keyboard, the mouse buttons, or the buttons of the pop-up keypad.
You can also use them to generate macros.

CM Mouse (Sample Application)

CM Mouse is a sample application included with Personal Communications that
provides intelligent and programmable mouse support for 3270 and 5250
emulation sessions. It allows users of host applications to point-and-click to
perform host functions. With its unique screen-recognition technology, CM Mouse
“hotspots” change instantly to give context-sensitive functions to each host
application window.

CM Mouse pop-up menus give you instant access to lists of options and functions
simply by pointing and clicking. Pop-up menus can simplify the selection of
commands and options, and can automate repetitive tasks.

For more information about CM Mouse, refer to the CM Mouse Support User’s Guide
and Reference.

Hotspots Setup

A hotspot is an area of the session window on which you can double-click the left
mouse button to perform a command or function. You do not need to use the
keyboard. For example, you can double-click a function key number to perform the
function.
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— 3D Hotspots

Select Show hotspots to get three dimensional (3D) hotspots; these
only require a single click, and they stand out on your screen.

You can define the following actions for a hotspot:
* Click on a URL to connect to a World Wide Web site.
* Simulate function keys.

* Play a macro that has the same name as the character string you select on the
session window.

 Enter the selected string at the cursor position.
* Simulate the Enter key at the cursor position.
* For VT, simulate two sets of function keys, PF1 through PF4 and F6 through F20.

Using Hotspots

— Note

You must have a mouse to use hotspots.

To use a hotspot:
1. Move the mouse pointer to the hotspot displayed in the session window.

2. Double-click the left button of the mouse, except for 3D hotspots, which only
require a single click.

Personal Communications determines whether you have specified a hotspot
function that matches what appears at the position of the mouse pointer. If so,
it processes the hotspot. When two or more hotspots are specified for a single
character string, the first retrieved hotspot is processed.
Hotspots are retrieved in the following order:

(1) Point-and-select (connect to Web site using URL)

(2) PFnn, FPnn, Fnn, nn

(3) Point-and-select (run the macro)

(4) Point-and-select (enter the selected string)

(5) Point-and-select (enter at the cursor position)

Keyboard Setup

You can use Keyboard Setup to modify the function defined for each key on the
keyboard, except some reserved keys.

You can define the following functions for the keys.
* Performing a key function
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* Playing a macro
* Entering characters

— Note

By default, the Enter function is assigned to the Ctrl key. To change
this assignment or, if you are using a non-IBM compatible keyboard
and the Enter key does not work properly, you need to customize
your keyboard.

Keyboard File

When you specify a key, you can save the new keyboard layout in a file (.KMP). If
you create two or more keyboard files, you can alternate between them as
required.

To assign a function to a key on the keyboard:

1. Select Preferences > Keyboard from the Edit menu or click the map icon on
the tool bar.

When the Keyboard Setup window appears, select Customize.
Assign the key functions, referring to the online help for detailed instructions.
Save your changes and exit the Customize Keyboard window.

o~ w N

Select OK after completing the setup.

You can reset either the entire keyboard or specific keys to defaults:

* To reset the entire keyboard, set the current keyboard to IBM Default in the
Keyboard Setup window.

* To reset specific keys, select a key in the Customize Keyboard window and then
select Default from the Current Actions for Selected Key box.

There are seven keys that you cannot redefine and they are gray or
dimmed in Keyboard Setup; these keys are: Alt, AltGr, Print Screen,
Scroll Lock, CapsLock, NumLock, and Shift.

Customizing the VT Emulator Keyboard
If you are using a VT emulator session, you can represent ASCII control characters
in the character strings that you define for your customized keyboard.

Use the # character to represent the CTRL key, following it by any character from
the following list (only upper-case alphabetics are allowed):

@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\] ™ _
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Use ## to represent an actual #. For example, 123##45 represents 123#45.

If you follow # with any other character than those shown, you will get an error
message:

PCSKBD160 - Unrecognized key-action: "character string

For example, the error for the string "#a is
PCSKBD160 - Unrecognized key-action: "#a

Here is the set of control characters:

Character pair Control Notes
#@ Control-@ NULL
#A Control-A
through
#Z. Control-Z
#[ Control-[ ESC
#\ Control-\
#] Control-]
# Control-"
# Control-_

Because the * KMP file can be edited, there is a run time check to ensure that the
character string is correct. If "### is processed, then # will be displayed, followed
by a beep to signify that the entire character string was not played. If "123#a456 is
processed, then 123 will be displayed, followed by a beep.

Macro/Script Setup and Use

A macro is a sequence of key or mouse actions and host commands that you can
perform with a single action, such as a keystroke. You can edit an existing macro
or create a new macro by selecting Preferences > Macro/Script from the Edit
menu.

A script is a VBScript program that is a subset of the Visual Basic programming
language. For information on VBScript, see the on-line help pages.

Using a Macro/Script

You can use a macro or script in various ways. [[able 4 lists examples of how you
can set up and then use macros and scripts.

Table 2. Macro Use Examples and Settings

If you want to... Do this...

Automatically play a macro or script when your Set an Auto-Start Macro/Script.
session starts.

Play a macro or script while attached to a host Start Playing Macro/Script.
application.

Play a macro or script with the keyboard or macro Use the Keyboard/Macro/Script
function. Function.

Click on a hotspot to play a macro or script. Set a Hotspot.

Assign a macro or script to a pop-up keypad button.  Customize the Pop-Up Keypad file.

Press the mouse button to play a macro. Customize a Mouse file.
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Table 2. Macro Use Examples and Settings (continued)

If you want to... Do this...

Press a key on the keyboard to play a macro or script. Customize a Keyboard file.

Creating a Macro
You can create a macro manually or by recording some of your interactions with
the host system, such as your logon procedure.

To create a macro manually:

1. Preferences > Macro/Script from the Edit menu.

2. When the Macro/Script Setup window appears, select Customize.

3. When the Customize Macro/Script window appears, select File, then New,
then Macro, and edit the macro. You can type statements directly or select
functions, characters, or even other macros, from the list of Key Actions in the
Select a Key-Action subpanel.

Refer to the online help for detailed information.

4. C(lick File, then Save to save the macro file.

Macro Statements
You can use the following statements when you create a macro:

Key function
Use Personal Communications-supplied key functions

Macro Define a macro within another macro but you cannot create a macro in a
permanent loop where the first macro is repeatedly called at the end of the
macros.

Character
Use any characters in the Character list in the Customized Macro window.

Character string
Use character strings you can type from the keyboard. You must use a
double quotation mark (“) at the beginning of the character string.

Wait condition
Specify wait conditions to stop the process until the specified time has
elapsed or the status satisfying the specified condition occurs.

Tokens
You can use tokens, such as goto and run, to add logic.

Macro Loop Considerations

If you use a GOTO and a label in a macro to create a loop, you may experience
unpredictable behavior if that loop executes a large number (more than 1000) of
iterations.

Creating a Script

You can create a script manually or by recording some of your interactions with
the host system, such as your logon procedure. Scripts, however, allow a higher
level of programming control unavailable with macros.

To create a script:
1. Preferences > Macro/Script from the Edit menu.
2. When the Macro/Script Setup window appears, select Customize.
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3. When the Customize Macro/Script window appears, select File, then New,
then Script, and edit the script. The Select a Key-Action subpanel, in gray, is
not available for creating scripts.

Refer to the online help for detailed information.
4. Click File, then Save to save the script file.

Setting Up a Macro or Script to Autostart

To set up a macro or script to autostart:
1. Preferences > Macro/Script from the Edit menu.
The Macro/Script Setup window appears.
2. Set a macro or script to auto-start when your workstation starts.

3. Refer to the online help for detailed instructions and then select OK after
completing your setup.

Recording Macros or Scripts
To start macro or script recording, Start Recording Macro from the Actions menu,

type the macro or VBScript name, select the type of file required, and then select
OK.

Note: When recording a macro, the processing of a nondisplayable field is
controlled by the setting of the parameter HideNonDisplayDataOnRecord=Y
in the [Keyboard] stanza of the .WS file. The hidden fields are ignored
during the recording session.

To end macro or script recording, select Cancel Recording Macro from the Actions
menu. The recording operation is canceled, and the macro or script is not saved.

To pause macro or script recording, select Pause Recording Macro from the
Actions menu. The recording operation stops. To restart recording, select Resume
Recording Macro.

To end macro or script recording, select Stop Recording Macro from the Actions
menu. Recording ends and the macro is saved in a specified file.

Playing Macros and Scripts

To start macro or script playing, select Start Playing Macro/Script from the
Actions menu, select the macro or script, and then select OK. The selected macro
starts to play.

To stop macro or script playing, select Quit Playing Macro/Script from the Actions
menu. The macro or script stops playing.

Note: When playing a macro, the processing of a nondisplayable field is controlled
by the setting of the parameter HideNonDisplayDataOnRecord=Y in the
[Keyboard] stanza of the .WS file; setting this causes a pop-up window to
display, requiring your input. When this appears, type in the requested
information and press Enter to continue.

Mouse Setup

The Mouse Setup command lets you allocate functions to the right and left
buttons of the mouse; this enables you to perform the following actions without
having to use the keyboard:

* Running the Personal Communications-supplied key functions
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* Running the user-defined macros
* Placing a character at the current cursor location

Mouse File

You can save the functions defined for the mouse buttons in a mouse file (*. MMP).
You can create two or more mouse files and switch between them as required.

To set up the mouseand assign functions to the mouse buttons:

1. Select Preferences > Mouse from the Edit menu.
The current settings appear in the Mouse Setup window.

2. Set up the required items, referring to the online help for detailed instructions.
If you want to create or edit a mouse file:
a. Select Customize.

b. When the Customize Mouse window appears, allocate functions to the right
and left buttons of the mouse. These appear in Current Action for Mouse
Button.

C. Select the required functions from List of Key Actions.
d. Save your changes and then select OK.
3. Select OK.

The mouse setup is complete.

Pop-Up Keypad Setup

The pop-up keypad is a small window in which some buttons are arranged. To
display the pop-up keypad, put the pointer anywhere in the session window and
press the right mouse button.

You can allocate the following functions to these buttons:

* A standard key function provided by Personal Communications
* A user-specified macro

* A character entry

To perform these functions, you only need to click a button on the pop-up keypad
with the left mouse button.

To view the description of a short-name key function or macro, click the right
mouse button while pointing at one of the function or macro names.

Pop-Up Keypad File

You can specify the number of buttons displayed in the pop-up keypad, the
functions allocated to those buttons, and colors of the buttons. You can save the
specified pop-up keypad contents in a pop-up keypad file (also referred to as a
poppad file).

A pop-up keypad file (*.PMP) contains the information for the number of buttons
displayed in the pop-up keypad, the functions allocated to those buttons,and color
information. You can define which pop-up keypad file is allocated to the pop-up
keypad.

Using the Pop-Up Keypad

To use a pop-up keypad:
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1. With the mouse pointer anywhere in the session window, click the right mouse
button.
2. Select Pad 1, Pad 2, Pad 3, or Pad 4.
3. Click the required button in the pop-up keypad.

To set up the pop-up keypad:
1. Select Preferences > Popup Keypad from the Edit menu.

2. When the Popup Keypad Setup window appears, set the required items,
referring to the online help for detailed instructions.

If you want to edit the pop-up keypad file, select Customize and then make
your changes.

3. Select OK. The pop-up keypad you selected is ready for use.

Tab Setup

For VT, Tab Setup allows you to define tab stops for your VT session.

Web Browser Setup

Web Browser Setup allows you to define a preferred web browser and to use it
rather than the one that comes with your operating system.

Managing Emulator Sessions

Personal Communications provides the following functions, in addition to those
provided by Windows, for those who work with several open session windows
simultaneously. These functions allow you to manage your session windows easily
and quickly. The Window menu has the following selections:

Jump Use Jump to switch between the currently opened session windows.

You cannot use Jump to switch to a session window that is currently
hidden. Instead, select Show Session from the Window menu to display
the session window on the screen. Then, select Jump.

Hide Session
Use Hide Session to stop displaying a visible session window.

You cannot hide all sessions. At least one session is always shown.

Show Session
Use Show Session to display a session window that was previously
hidden with Hide Session.

Use the View menu to display a previously-saved arrangement of windows, or to
save an arrangement of windows.

Personal Communications can save and restore the following information relating
to the session window view:

» Position and size of each window

* Window status (standard, minimized, or maximized)

* Window font

You can save view information for up to eight windows.
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Getting Help
For more information about managing session windows, refer to the online help:
1. Select Procedures from the Help menu.

2. When the help window appears, scroll down to Managing Workstation
Windows.

Select choices from that list for detailed information.
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Personal Communications provides various utilities; this chapter describes the
following:

32-bit ODBC Administrator
Allows you to add, configure, or delete an ODBC data source.

Database Access
Allows read-only access to data in the selected database after you have
configured a data source.

CM Mouse
Provides intelligent and programmable mouse support for 3270 and 5250
emulation sessions.

DOS EHLLAPI
Allows DOS-based EHLLAPI programs to communicate with the 32-bit
Personal Communications emulator.

Menu-Bar Customization
Provides a means of changing the content of the menu-bar of the Personal
Communications session window.

Multiple Sessions
Provides the capability to run multiple host sessions using a single icon.

ZipPrint
Allows you to print PROFS or OfficeVision notes, calendars, OV
documents, CMS files, XEDIT workspaces, and 3270 session screens.

Convert Macro to a VBScript
Allows an existing Personal Communications Macro file to be converted to
a VBScript file.

PC Organizer
Runs Windows applications from a 5250 display session.

Data Transfer
Transfers data from the AS/400 system to your workstation,or from your
workstation to the AS/400 system. (Record-level data transfer).

Text Assist (SBCS only)
Allows you to create or edit a document or short messages.

AS/400 Connection Configuration
Provides access to AS/400 folders as if they were disk drives on your
workstation.

User Preference Manager
Allows setting up of certain advanced configuration parameters.

32-Bit ODBC Administrator

ODBC is a programming interface that enables applications to access data in
database management systems that use Structured Query Language (SQL) as a
data access standard.

Use the following steps to set up the Personal Communications ODBC data source:
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1. Select the 32-bit ODBC Administrator icon from the Windows Control Panel.
The Data Sources window appears.

2. Select IBM DB2® ODBC Driver data source in the Data Sources (Drivers) list.
Then click Finish.

Click Add Database. The Personal Communications Add Database SmartGuide
appears to prompt you through the set up.

w

Select the Manually Configure a Connection to a DB2 Database radio button.
Specify the information to set up the data source, by clicking Next.
When you are finished specifying the information, click Done.

N o gk

You will be prompted to test the connection. To test the connection, click OK.

— Note

Personal Communications uses ODBC 32-bit drivers. Applications,
such as Lotus 1-2-3 included in the Lotus SmartSuite 96 package,
require a 16-bit driver and will not work with Personal
Communications. You should see your product vendor for a version
that utilizes 32-bit ODBC drivers (Lotus 1-2-3 included in Lotus
SmartSuite 97 for example).

To successfully test the DB2 connection, you must start the Personal
Communications SNA subsystem with the appropriate configuration
data. This configuration data must include the following:

* Node definition

* Device definition

* Connection definition

* Partner LU definition

* Mode definition (IBMRDB must be created)
* CPI-C Side Information

You might also need to include a Local LU 6.2 definition.

For more information on SNA Node operations, refer to the Personal
Communications Reference Volume 1.

Following is a sample .ACG file:
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NODE= (

)

ANYNET_SUPPORT=ANYNET_SUPPORTED
CP_ALIAS=YOURALIAS
DEFAULT_PREFERENCE=NATIVE
DISCOVERY_SUPPORT=DISCOVERY_CLIENT
FQ_CP_NAME=YOUR.CPNAME
NODE_ID=05D00000
NODE_TYPE=END_NODE
REGISTER_WITH_CDS=1
REGISTER_WITH_NN=1

% <---- Modify w/ CP Name

PORT= (

PORT_NAME=LANO_04
DLC_DATA=00000000000004
DLC_NAME=LAN
IMPLICIT CP_CP_SESS_SUPPORT=1
IMPLICIT_DEACT_TIMER=0
IMPLICIT_DSPU_SERVICES=NONE
IMPLICIT_HPR_SUPPORT=1
IMPLICIT_LIMITED RESOURCE=NO
LINK_STATION_ROLE=NEGOTIABLE
MAX_TFRM_RCVD=8
MAX_RCV_BTU_SIZE=32767
PORT_TYPE=SATF
PORT_LAN_SPECIFIC_DATA=(
ACK_DELAY=100
ACK_TIMEOUT=3000
ADAPTER_NUMBER=0
BUSY_STATE_TIMEOUT=60
IDLE_STATE_TIMEOUT=30
LOCAL_SAP=04
MAX_RETRY=10
OUTSTANDING_TRANSMITS=16
POLL_TIMEOUT=3000
POOL_SIZE=16
REJECT_RESPONSE_TIMEOUT=30
TEST_RETRY_INTERVAL=8
TEST _RETRY_LIMIT=5
XID_RETRY INTERVAL=8
XID_RETRY_LIMIT=5
)

)
LINK_STATION=(

)

LS_NAME=LINKMVS
ACTIVATE_AT_STARTUP=1
ADJACENT _NODE_TYPE=APPN_NODE
AUTO_ACTIVATE_SUPPORT=0
CP_CP_SESS_SUPPORT=1
DEFAULT_NN_SERVER=0
DEST_ADDRESS=40000000000000 * <---- Modify w/ Dest
DISABLE_REMOTE_ACT=0
DSPU_SERVICES=NONE
ETHERNET_FORMAT=0
HPR_SUPPORT=0
LIMITED_RESOURCE=NO
LINK_DEACT_TIMER=0
LINK_STATION_ROLE=USE_ADAPTER DEFAULTS
MAX_TFRM_RCVD=0
MAX_SEND_BTU_SIZE=32767
NODE_1D=05D00000
PORT_NAME=LANO_04
SOLICIT_SSCP_SESSION=0
TARGET PACING_COUNT=1
TG_NUMBER=0
USE_DEFAULT_TG_CHARS=1

DLUR_DEFAULTS=(
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DEFAULT_PU_NAME=YOURALIAS * <---- Modify w/ your name
DLUS_RETRY_LIMIT=3
DLUS_RETRY_TIMEOUT=5

)

LOCAL_LU=(
LU_NAME=LUNAME % <--== Modify w/ LU Name
LU_ALIAS=LUALIAS % <---- Modify w/ LU Alias

LU_SESSION_LIMIT=0
NAU_ADDRESS=0
ROUTE_TO_CLIENT=0
DEFAULT_POOL=0

)

PARTNER_LU=(
FQ_PLU_NAME=PARTNER.LUNAME * <---- Modify w/ Partner Info
CONV_SECURITY_VERIFICATION=1
MAX_MC_LL_SEND_SIZE=32767
PARALLEL_SESSION_SUPPORT=1
PARTNER_LU_ALIAS=RBNAME * <---- Modify w/ Location/RDBNAME
PREFERENCE=USE_DEFAULT_PREFERENCE

)

CPIC_SIDE_INFO=(
SYM_DEST_NAME=DB2CPIC * Semmee- Needed for ODBC configuration
CONVERSATION_SECURITY_TYPE=NONE
MODE_NAME=IBMRDB
PARTNER_LU_NAME=USIBMNM.NM57DB21 * <---- Modify w/ Partner Info
TP_NAME=DB2DRDA * <---- Modify w/TP Name (per DB2 help)
TP_NAME_TYPE=APPLICATION_TP

)

SHARED_FOLDERS=(
CACHE_SIZE=256

)

VERIFY=(
CFG_MODIFICATION LEVEL=13
CFG_VERSION_LEVEL=1

Database Access

62

Database Access lets you access host or PC databases and retrieve data, using
ODBC drivers. If you specify the conditions for accessing data in each window, the
desired query can be created automatically.

From Database Access, you can:

See and modify the SQL statements that are created automatically.
See available database-table lists.
Copy spreadsheet data to the clipboard.

Show data in the grid in the main window spreadsheet, send data to other
applications (for example, Lotus 1-2-3 or Microsoft Excel), or send data to a
printer.

Before using Database Access, you should read Help information on:

Database size limits
Installed programs
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CM Mouse

CM Mouse allows users of host applications to point and click to perform host
functions. Clicking a CM Mouse on hot spots gives true context-sensitive function
to each host application screen. Hot spots are not fixed function or fixed
placement, but change dynamically as you move through a host application.

CM Mouse pop-up menus give you instant access to lists of options and functions
with a simple point and click. Pop-up menus can simplify command selection,
choose options, and automate repetitive tasks. The CM Mouse pop-up menu editor
allows you to quickly and easily customize the menus for your own purposes or to
create new menus.

The CM Mouse scripting language is powerful enough to automate complex host
interactions, yet simple enough for novice users.

Refer to the IBM CM Mouse Support User’s Guide and Reference for more
information.

Menu Bar Customization

This utility enables you to remove items from the menu bar of the Personal
Communications session window. The changes affect only the session that you
customize, so you can make different changes to each session. You can remove
three types of items:

1. A menu bar command, such as File, Edit, or Communication

2. A pulldown menu command, such as, New, Open..., Color Mapping,
Configure

3. A separator-line that resides between two commands in a pulldown menu

The modifications to the menu bar are saved in the workstation profile that you
choose and become active the next time you start the session.

Note: If you created a customized menu in a previous version of Personal
Communications, you may need to reconfigue the settings to account for the
new menu structure in Version 5.0.

Multiple Sessions

The Personal Communications Multiple Sessions Batch Program allows you to start
several host sessions by clicking a single icon; the necessary commands are
specified in a batch file (BCH). You can include in a batch file other programs,
which may communicate with a host session via the DDE or EHLLAPI interface.

It is also possible to start multiple sessions without a batch file.

ZipPrint

ZipPrint is a 3270 utility that enables you to print PROFS or OfficeVision (OV)
notes, calendars, OV documents, CMS files, XEDIT workspaces, and 3270 session
screens. By default, it uses the Windows printer currently set up for the host
session, but you can change it if you wish.
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You do not have to install ZipPrint—you just start it. It adds itself to the menu-bar
of the sessions for which you define it, so you can use it in the same way as any
other menu-bar function. You must start ZipPrint before you start a session in
which you want to use it.

ZipPrint needs the DDE/EHLLAPI, so you must make sure that this is enabled for
the sessions for which you want to use ZipPrint. (It is enabled by default, but you
should check that it has not been turned off.)

For more information about ZipPrint, see IZipPrint (3270 Qnly)” on page 39,

Convert Macro to a VBScript

The Convert Macro to a VBScript utility allows you to convert an existing
Personal Communications Macro file to a VBScript file. To use the conversion
utility, click the Convert Macro to VBScript icon in the Utilities folder.

To convert an existing macro to a VBScript, do the following:
1. Select the name of an existing macro to be converted.

Note: The macro must exist in the Personal Communications private
subdirectory.

2. Enter a name for the new VBScript or accept the generated name. The
extension will be added automatically.
3. Click the OK Button.

4. Repeat these procedures to convert another macro, or click Close to end the
application.

PC Organizer

You can use the PC Organizer to run DOS commands and applications or
Windows applications from a 5250 display session.

— AS/400 Requirements

Before you can use the PC Organizer, one of the following programs must
have been installed on the AS/400 system:

* Client Access/400 (or OS/400 V3 or later)

* PC Support/400 (5738-PC1)

Starting the PC Organizer

To start the PC Organizer:

1. Start a 5250 display session.

2. Sign on to the AS/400 system.

3. Enter the following command on the AS/400 command line:
STRPCO PCTA(*NO)
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Personal Communications does not support the PC Text Assist
(PCTA) function, so you should specify this parameter with *NO.
Even if you specify *YES, you cannot use the PC Text Assist
function provided by the PC Support/400 Workstation Feature.

You can now use the PC Organizer functions in a 5250 display session by using
one of the following methods:
* Display and then select choices from the menu.
To display the PC Support/400 or Client Access/400 Organizer menu, enter:
GO PCOMNU
* Enter PC Organizer commands.
To start the PC Organizer functions, enter:
STRPCCMD

PCO.EXE Message
When you run a workstation command or program, you might receive a
message that the PCO.EXE program is not active. You can ignore this
message, because it is not necessary for PC400 to activate PCO.EXE.

Getting Help
Refer to the online help for more information about using the PC Organizer.
1. Select Procedures from the Help menu.

2. When the help window appears, search for organizer or scroll down to PC
Organizer (5250 Session).

Select topics in the list to view information about starting and using the PC
Organizer, using the PC Organizer menu, and the differences between the PC
Organizer provided with PC400 and PC Support/400.

Data Transfer

Personal Communications Data Transfer enables you to transfer data between an
AS/400 system and your workstation.To use the Data Transfer function, select the
Data Transfer icon.

Transferring data is quite different from transferring files, which is described in

: ”
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Data Transfer

— Requirements

Before you can transfer data with Personal Communications:
* You must have an SNA connection to an AS/400 system.

* IBM PC Support/400 (5738-PC1) must be installed on your AS/400
system, unless IBM OS/400 Version 3 or later is installed.

 Data transfer cannot be used over TN5250 connection types.

There are two types of data transfer, depending onthe direction of the transfer.

Data sending
Data is transferred from your workstation to the AS/400 system.You can
transfer data to any of the following destinations:
 Existing members in an existing AS/400 physical file
* New members in an existing AS/400 physical file
* New members in a new AS/400 physical file

— Note

You cannot transfer data from a workstation file to an AS/400
logical file.

Data receiving
Data is transferred from the AS/400 system to your workstation.

While receiving data from the host, you can specify the data to be received
and where the data is to be output.

Receivable data includes:

* An entire AS/400 file

e Part of an AS/400 file

* Data combined from several AS/400 files
* Summary of record groups

Specify the following output destinations:
 Display

* Disk

* Printer

Also, you can specify the numeric value format.

For more information about data transfer, refer to Personal Communications Reference
Vol 1.
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Text Assist (SBCS Only)

With Personal Communications, you can use the improved text editing capability
of Text Assist provided by the OfficeVision/400 word processing function to create
a document or short messages, or to edit an existing document.

To start the text assist function, enter WRKDUC on the 5250 command line.

For more information about using Text Assist, refer to the documents for the
OfficeVision/400 program.

The Text Assist function in Personal Communications is a “Controller Text Assist,”
not the “PC Text Assist” supported by PC Support/400 Workstation Feature.

Controller Text Assist in Personal Communications provides the following
functions that are not included in PC Text Assist:

e Line commands

* 132 columns

Controller Text Assist in Personal Communications does not, however, provide the
multicolumn edit function that is included in PC Text Assist.

— Note

In the Text Assist environment, Alt key functions are assigned to the
Ctrl key state to avoid conflicts with existing emulator functions. For
example, the Word Underscore (WrdUnd) key is Ctrl+W rather than
Alt+W. Many of these functions can be remapped to the Alt key state
without conflicting with emulator functions.

When you draw a line using the cursor draw option of the OfficeVision/400
program, the insert mode is not available.

— AS/400 Software Requirements

The AS/400 system must have one of the following programs installed to
support the Text Assist features:

* OS5/400 V2R2.0 with cumulative PTF C3285220 with PTF SF14687

* OS5/400 V2R3.0 with PTF SF14495

+ 0S/400 V3R0.5

* 0OS/400 V3R1.0, or later

Text Assist Key Functions
Following is a list of OfficeVision/400 Text Assist key functions:

Function Description

Begin of Line Moves the cursor to the beginning of the line
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Function

Description

Begin Bold

Begins bold highlighting

Bottom of Page

Moves the cursor to the bottom of the page

Carrier Return

Ends a line of text or a paragraph by inserting a carrier return

Center Text

Centers a line of text

End of Line

Moves the cursor to the end of the line

End of Page

Inserts an “end of page” character at the cursor position

End Bold/Underscore

Ends bold highlighting and underlining

Half Index Down

Begin subscript or end superscript

Half Index Up

Begin superscript or end subscript

Insert Symbol

Displays a menu for special symbols

Display Text Codes

Shows hidden text controls

Next Column

Inserts a “next column” instruction at the cursor position

Next Stop Code

Moves the cursor to the next stop code symbol

Required Backspace

Moves the cursor one space to the left

Required Space

Inserts a required space to keep words together on a line

Required Tab

Indents a block of text

Stop Code

Inserts a stop code at the cursor position

Top of Page

Moves the cursor to the top of the page

Begin Underscore

Begins underlining text

Word Underscore

Underlines the word that starts at the cursor position

AS/400 Connection Configuration Utility

The AS/400 Connection Configuration Utility is used to define connections to each
AS/400 host that will use the network drives or the data transfer function. The
connection definitions are saved in an .NDC file in ASCII format.

You can use this utility for either SNA or TCP/IP connections.

Refer to Personal Communications Reference Volume II for more details on configuring

Network Drives.

Network drives requires AS/400 Version 2 Release 3 or higher.

This function is not available for Windows 2000.

For more information on Data Transfer see [’Data Transfer” on page 63.
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To use the utility, click Programs > IBM Personal Communications > Utilities >
AS/400 Connection Configuration from the Windows Start menu; the resulting
AS/400 Configuration screen has the following options:

Show IP Host Connections
Click this button to display and configure IP connections to the AS/400
host.

Show SNA Hosts
Click this button to display and configure SNA connections to the AS/400
host.

Add  Click the type of connection (IP or SNA), and then click Add. Enter the
Host name and Alias in the resulting dialog box.

Modify
Select a host name from the connection list, and then click Modify to edit
the Host name and the Alias in the .NDC file.

Remove
Select a host name from the connection list, and click Remove to delete
this connection definition from the .NDC file.

Note: Disabling a Connection: If you want to preserve the connection
definition but disable the connection, uncheck the checkbox next to
the name in the connection list.

Select ACG File
Click this button to select an associated SNA Node configuration file
((ACG).

Global Parameters
Click this button to edit the Extension list and Cache size.

Extension List

The Extension list parameter specifies the extension of a file on an AS/400. You can
specify more than one extension parameter in the extension list. The code pages of
files with the specified extensions are translated from the EBCDIC code page to the
ASCII code page when the file is transferred between the AS/400 and the client.Up
to three characters are allowed. There are two special cases:

* A dot alone (.) indicates that data for files having no extension should be
converted.

* The character pair .* indicates that data for all files should be converted.

Cache Size

The Cache size parameter specifies the number of kilobytes of AS/400 data that is
buffered in the read-ahead cache of the client. The default is 256KB; the maximum
is 4MB. A value of zero requests that no cache be used. AS/400 data can be
retrieved in amounts that are first cached locally on the client. The client retrieves
the data from the cache to populate the local device. This read-ahead caching
reduces the number of times the client has to access the AS/400 to retrieve the
data.
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User Preference Manager

The user preference manager (UPM) provides a method for changing configuration
and setup items.

Notes:

1. Preferences set using the user preference manager pertain to you whenever you
log on to the same user ID on the affected workstation; they apply to all of
your sessions while you are logged on.

2. Preferences set using the session Edit menu apply to all sessions controlled by
the workstation profile created or changed while using a session; when that
session profile is used again, the preferences are applicable, regardless of the
user ID at the time.

3. One of the capabilities of UPM is to allow specification of a Personal
Communications private subdirectory to be used for storing your profiles; this
allows full control of your environment.

To access UPM, click Programs > IBM Personal Communications > Utilities >
User Preferences from the Windows Start menu. The initial UPM screen displays
basic information about your Personal Communications installation on the
property page with the General tab. To change selected configuration items, select
the appropriate property page using the appropriate tab:

Basic to select the Personal Communications private subdirectory, and the
language which is to be used for the user interface in subsequent Personal
Communications sessions.

The Basic property page shows a textbox with the currently assigned location for
the Personal Communications private subdirectory, where profile files are stored.
To change it, type a new name, or click the Browse button to locate the directory
location of your choice.

If your system was installed with multiple language support, the Basic property
page shows a section labeled Select a default user interface langauage. If you
click on the radio button for PCOMM User Interface Language Preference, it also
shows a drop-down listbox, with the language selected that is currently being
used; you can select any other language from the list, and that language will be
used for the user interface when you subsequently restart Personal
Communications. Or you can select the radio button User Default from Regional
Settings if you want the language to be that specified in the Windows settings.
You may also select the radio button Post a Language Selection Dialog for each
process; this results in a pop-up dialog each time you start a new application from
the Personal Communications group of programs.

Note: You may receive a warning message, if the selected language is incompatible
with your system’s current code page. You may ignore this, if you are
planning to reboot yor computer to select a new system locale with a
compatible code page.
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Chapter 7. Enabling Client/Server Applications

Personal Communications support for APPN end nodeslets you take advantage of
APPN network nodes. An APPN network allows automatic locating of partner
applications and dynamic, optimized route selection. These features allow
workstations to communicate more flexibly with other systems in the network.

Personal Communications also provides support for 32-bit APPC and CPI-C
application programming interfaces (APIs), which provide convenient ways for
32-bit client application programs on your workstation to communicate with those
on other workstations.

Configuring a Node

Before you can take advantage of the client APIs and communicate with other
application programs, you first need to configure Personal Communications as an
SNA end node.

To configure the SNA node:
1. From the Start menu, select:

Programs
IBM Personal Communications
SNA Node Configuration

The Personal Communications SNA Node Configuration window appears.
2. Select the necessary Configuration Options in the order listed on the window.
To select an option, click it and then click New....

For each option, enter the appropriate information on the property pages. Most
required information is listed on the Basic page. Click OK to complete the
option. Click Help for more information about the individual parameters.

3. Click Save or Save As from the File menu.

4. Type the file name and then click Save. Note that you can choose the file type
and where to save this file. The default file type is .ACG and the default
directory is the Personal Communications private subdirectory.

5. Click Exit from the File menu.

If you have more than one configuration file, you can apply
additional configuration files to an active node. Refer to the help in
the SNA Node Operations section of the product for details.
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Starting the SNA Node
1. To start the SNA node, from the Start menu, select:

Programs
IBM Personal Communications
Administrative and PD Aids
SNA Node Operations

The Personal Communications SNA Node Operations window appears.
2. Click Start Node... from the Operations menu.
The Select configuration file to use... window appears.

3. Double-click the configuration file (ACG) that defines the node you want to
start.

— Note

Another way to start the SNA node is to use the command line. The
command to use is CSSTART. For the proper syntax see Personal
Communications Reference Volume 1.

Stopping the SNA Node

1. To stop the SNA node, from the Start menu, select:

Programs
IBM Personal Communications
Administrative and PD Aids
SNA Node Operations

The Personal Communications SNA Node Operations window appears.
2. Click a resource in the Alias column.
3. Click Stop Node... from the Operations menu.

— Note

Another way to stop the SNA node is to use the command line. The
command to use is CSSTOP. For the proper syntax see Personal
Communications Reference Volume 1.
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Enabling Client/Server Applications

APING Requirements

If you wish to run the Check Connection (APING) utility provided with this
package to an AS/400 running OS/400 V3R1, you must install PTF MF10808 on
the AS/400 first. If this PTF is not installed, then errors with sense codes of 080F
6051 and 1008 201D will occur.
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Chapter 8. Messages

Online messages are displayed during Personal Communications sessions, but a
message does not always mean an error occurred. For example, a message might
tell you that an operation is in progress or has been completed. A message can also
prompt you to wait for the completion of an operation.

Press F1 to display help for the messages that appear.

Security-Related Messages

Personal Communications optionally utilizes Secure Sockets Layer (SSL) to
establish sessions with servers; this may require input from you (for example, a
password). Refer to IBM Personal Communications Reference Volume II for details.

Functions Restricted by System Policies

If your workstation is centrally administered, you may be shown a warning or
pop-up error message whenever you attempt to use certain restricted functions.
For example, if your ability to remap the keyboard is restricted, a message would
be displayed when you select Preferences > Keyboard from the Edit menu.

Contact your system administrator for further guidance. For further information
about the systems policies provided with Personal Communications, refer to IBM
Personal Communications Version 5.0 Reference Volume II.

System Error Messages

If a page fault or similar system error message appears in a pop-up window, you
can copy its contents into the Windows 95, Windows 98, Windows NT, or
Windows 2000 clipboard. To do this:

1. Click Details Command on the pop-up window.
2. Mark the text that you want to copy.

3. Right click the marked text and then click Copy.
4. Start an editor, such as Notepad, and click Paste from the Edit menu.
5. Save the file in case an IBM service representative needs this information to

diagnose your problem.

OIA Messages

Personal Communications displays messages in the operator information area(OIA)
or in a pop-up window. Messages from Personal Communications are displayed in
the message window; messages from the host system are displayed in the OIA of
the session window.

The bottom line of the session window is the OIA. The OIA indicator indicates the
status of Personal Communications and information about the workstation, host

system, and attachment method.

All of the OIA indicators, reminders, and messages are described in the online
help. To view this information:
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1. Select Help Contents from the Help menu.
2. Select The operator information area messages.

When the index window appears, select the Index button, and
then select Find. Type in the number of the message. Click Search.
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Appendix A. Directories Created by the Installation Program

The program creates numerous subdirectories in the root of the main Personal
Communications directory; some of them are:

* CMMOUSE
* DRIVERS
* INCLUDE
* JRE

* LIB

* PDFPDT
* PRIVATE
* SAMPLES
* XLNCOAX

With the exception of the PRIVATE subdirectory, the subdirectories might contain
files only when you have elected to install them.

Note: In addition, subdirectories are created for languages chosen when installing
multiple language support. Refer to Personal Communications CD-ROM Guide
to Installation for details.

Personal Communications Private Subdirectory

This is the location for storing your configuration profiles, and related information.

Notes:

1. By default, it is the PRIVATE subdirectory in the directory where you install
Personal Communications; the location of the base directory can be selected
during installation.

2. The user preference manager can be used to choose another directory for each
user, after installation; any configuration information previously contained in
the PRIVATE subdirectory may need to be copied or recreated in the user’s
specific Personal Communications private subdirectory.

This is almost empty when you first install Personal Communications (unless you
have migrated from a previous version), but if you create and save configurations,
the following types of files are stored here:

Personal files in the Personal Communications private subdirectory:
» Workstation (session) profiles (.WS)

* SNA configuration files (.ACG)

* Batch files (to start multiple sessions) (.BCH)
» Keyboard files (.KMP)

* Pop-up keypad files (.PMP)

* Mouse files (.MMP)

* Macro files (.MAC)

* Automatic-dial facility files (.ADU)

* File-transfer translation files (.XLT)

» User profile (.UPR) (AS/400 only)

* Tool bar files (.BAR)

* Trace log files (.TLG)
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SAMPLES Subdirectory

This has several subdirectories, each containing the executable and source files for
a sample program. Header and LIB files are stored in the Personal
Communications\samples directory.

These programs are designed to illustrate the use of a programming interface:

DDXFER
Shows how the EHLLAPI interface can be used to create a drag-and-drop
application.

HLLSMP
Shows how the EHLLAPI interface can be used by an application on your
workstation to request keystrokes and to log on to a VM system.

LISTFILE
[lustrates how the dynamic data exchange (DDE) interface can make use
of the LOAD button to transfer files from a VM host system (3270 only).

PCSMAIN
Illustrates the use of the PCSAPI interface.

SPL2FILE
A DDE sample program that converts the AS/400 spooled file to the
workstation file.

SRPSMP
Shows how the SRPI SEND_REQUEST interface verb can be used by a
requester application on your workstation to invoke a server on the host.

VBDDE
Illustrates the use of the DDE interface with Microsoft Visual Basic**.

VBHLLAPI
Illustrates the use of the EHLLAPI interface with Microsoft Visual Basic.

VBPCSAPI
Illustrates the use of the PCSAPI interface with Microsoft Visual Basic.

WINAPING
Mlustrates the use of CPI-C API programming.

PDFPDT Subdirectory

This directory contains PDF/PDT files used by Personal Communications print
function in PDT mode. Refer to [ Jsing Printer Definition Table (PDT) Files” on

for more information about using PDF/PDT files.

ECL Subdirectory

The ECL subdirectory contains samples for using the Host Access Class Library for
Visual Basic (VB), Lotus Script, and C++.
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Appendix B. Attachment Considerations

This appendix describes factors you should consider when configuring Personal
Communications for the attachment types described in this appendix; for details,
see:

4 7

G 77

o 13270 Attachment via the AS/400 qYQh:-m" on page ad

” g . . 17

4 : ”

G ”

’ : 7

Note: Support for Windows 2000 Plug-and-Play may differ somewhat from that
for Windows 95 and Windows 98.

COAX Attachment

This section describes factors you should consider when configuring Personal
Communications with a coaxial attachment.

— Note

The APPC and CPI-C APIs, provided with Personal Communications,
do not support coaxial connections.

Avoiding Machine Check 207

Patch the microcode of the 3174 control unit. The following table shows the
relationship between 3174 control unit microcode levels and patch IDs:

Microcode Level
Patch ID
S0503 PCA53D1
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S0504 PCA53D2
A0503 PCA53D3
A0504 PCA53D4
B0200 PCA53D5
B0401 PCA53D6
B0402 PCA53DS8
C0101 PCA53D7

In addition, if you have a 3174 with Configuration Support B or higher, you can
set the following parameters:

* 3174 customization Q126 digit 2=1 to change the COAX timeout from 50 to 100
microseconds.

* 3174 customization Q125 digit 4=1 to set command chaining off.

Polling Feature

Your workstation may have been configured so that an IBM coax adapter cannot
acquire an interrupt request line (IRQ) that it needs in order to function. This
situation occurs because other devices have been configured to use these IRQs, so
that the IRQs are no longer available. This situation can occur in Windows 95,
Windows 98, Windows NT, or Windows 2000.

In such a situation, the IBM coax adapter may or may not be able to use another
available IRQ. The IBM 3278/79 Emulation Adapter (ISA bus) can use only IRQ 9.
Other IBM coax adapters, such as the IBM 3270 Credit Card adapter, can use other
IRQs than IRQ 9, but all these other usable IRQs may also have been reserved for
other devices in the system.

If this happens, you can use the polling feature to enable the IBM coax adapter to
function without using an IRQ. To activate the polling feature, add the Po11=Y
parameter to the [CSDFT] or h[CNDFT] section of your workstation profile (*.WS) as
follows:

¢ SNA/DFT attachment

[CSDFT]
Poll=Y <-- add
¢ Non SNA/DFT attachment
[CNDFT]
Poll=Y <-- add

For an IBM 3270 Credit Card adapter, the polling feature is automatically activated,
without "Poll=Y" being added to the .WS file.

Configuring a Non-Plug-and-Play Coax Adapter (ISA)

7 ”

See for more information on

configuring all the IBM 5250 adapters.

Functions Not Available with DFT Attachment

When your workstation is configured to use a DFT attachment, the following
functions and capabilities of the IBM 3174 or 3274 Control Units are not supported:
* Programmed symbols on attached workstations

* Attachment to port 0 on attached workstations

* Database operations

* 3270 Diagnostic Reset Dump

* Patch facility
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PCMCIA and PCI Configuration for a DFT Attachment
Using a Plug-and-Play Coax Adapter (PCMCIA or PCI)

If your workstation has an IBM 3270 Emulation Plug-and-Play Adapter (3270 PnP)
installed, Personal Communications usesit in the same way as the IBM 3278/79
Emulation or 3270 Connection Adapter.

You cannot use multiple 3270 PnP adapters; nor can you use a 3270 PnP at the
same time as a 3278/79 Emulation or 3270 Connection Adapter. Before you can use
a PCMCIA or PCI adapter under Windows 95, Windows 98, or Windows 2000, you

must first install drivers for it. Refer to l‘Adapter Setup Hints and Tips” on page 94

for more information.

Coax Adapters and ROM Shadowing
Personal Communications maps the shared RAM of the 3270 connection adapter
on the PC. The default values for the adapters as follows.

* Adapter #0 CE0O0Oh - CFFFFh
* Adapter #1 DO00Oh - D1FFFh
* Adapter #2 D2000h - D3FFFh
* Adapter #3 D4000h - D5FFFh

PCs that support ROM shadowing in BIOS may use these areas for ROM
shadowing by default (IBM PC350 P100, for example). Check the ROM shadowing
settings before installing an adapter and disable the range for the adapter you are
going to install.

LAN via IEEE 802.2 Attachment

Following is a description of preinstallation considerations for installing Personal
Communications for use on a LAN. For more detailed information, refer to the
IBM Local Area Network Technical Reference.

PIU Size

This value is negotiated between your workstation and the host system, unless
XID=No is defined on the PU, or the Adjacent CP type has been changed to
Host - XIDO in SNA Node Configuration. If this value is not negotiated, the
Maximum PIU Size must match the MAXDATA value defined on the host system.

Receive Window Count

This value is negotiated between your workstation and the host system, unless
XID=No is defined on the PU, or the Adjacent CP type has been changed to

Host - XIDO in SNA Node Configuration. If this value is not negotiated, the
Receive Window Count must match the MAXOUT value defined on the host system.

Using a PCMCIA Token-Ring or Ethernet Card

PC/3270 supports the IBM Token-Ring and Ethernet credit card adapters in the
same way as it does the full-size adapters.

TCP/IP Connection

This section provides information, considerations, and restrictions for Personal
Communications TCP/IP connections.
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TCP/IP Protocol Driver

You must set up your Windows environment for the TCP/IP network. To verify
that the TCP/IP protocol is installed on your workstation, double-click Network in
your Control Panel and see if TCP/IP appears in the list of network components.
Double-click TCP/IP to specify your IP address and other TCP/IP properties.

Screen Size

The following four screen sizes are supported for TN3270:
24 x 80
32 x 80
43 x 80
27 x 132

The following two screen sizes are supported for TN5250:
24 x 80
27 x 132

Screen size 48X80, 62X160, and 24X132 are supported if your server/host supports
the TN3270E protocol.

Terminal Type to Be Negotiated With TN3270

The terminal type to be negotiated is set to IBM-3278-2-E, IBM-3278-3-E,
IBM-3278-4-E, or IBM3278-5-E according to the screen size that is specified on the
Customize Communication - 3270 Host panel. If you need to specify IBM-3279-2-E
or IBM-3279-3-E (for graphics), add the following line to the [Telnet3270] section in
the workstation profile (WS):

TerminalType=3279

Telnet3270, TN3287, and TN3270E Connection

TN3287 (defined in RFC 1646) and TN3270E (defined in RFC 1647) were tested
with following Telnet servers:

* Communications Server for Windows NT

* Communications Server for OS/2

* TNB3287 Brixton PU2.1 V3.0

— SNA Client Access for AIX Versionl Release 2

— IBM Communications Server for OS/2 Warp
* TN3270E Brixton PU2.1 V3.0

— SNA Client Access for AIX Versionl Release 2

— IBM Communications Server for OS/2 Warp

e Microsoft SNA Server

Other TCP/IP Functions

The following sections describe enhancements made to TCP/IP connections for
Personal Communications Version 4.3 and Version 5.0.

Backup Server/Host with LU Name and Port Number

Personal Communications enables you to specify up to two backup host or server
names to connect to. This provides easier connections when the primary host or
server cannot be reached. A specific LU name or port number unique to that server
or host can also be specified.
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Service Location Protocol

Personal Communications enables connection to SLP servers that are RFC 2165
compliant. This function eliminates the need for users to know the name of a
network host supporting a specific service. SLP implementation for a Personal
Communications client allows load balancing and dynamic location of a specific
LU or LU pool across a group of servers. IntraNetware for SAA (IWSAA) 3.0 and
IBM Communications Server (CS/NT) 6.0 currently support SLP. This support can
be used in conjunction with SSL support.

Security - SSL

Personal Communications enables you to connect to a server that supports SSL
V3.0 or higher for TN3270(E), TN5250 or VT emulation. This allows you to encrypt
the data flowing on the network, and can be configured on a per session basis.
This support can be used in conjunction with SLP support.

Additional function is provided in Version 5.0 for Client Certificate Authentication.

Connect Timeout

Personal Communications uses a non-blocking sockets when connecting to a
remote system. Personal Communications will wait three seconds, by default, to
establish the socket connection. The default can be changed by adding the
following line to the Telnet3270 or Telnet5250 section of the workstation profile:

InactiveTimeout=xx
where: xx is the time in seconds

TN5250 Enhancements

Personal Communications enables you to emulate a TN5250 printer session if the
Host carries OS/400 V4.2 or higher. A Workstation ID for display and printer
emulation sessions can also be specified.

SDLC MPA Attachment

This section describes factors you should consider when configuring Personal
Communications with an SDLC attachment.

Line Speed

For the SDLC attachment, a line speed up to 28.8 Kbps is supported. However,
actual line speed will vary depending on the carrier speed the modem supports.

V.25bis Autodial

Personal Communications only supports the bit-oriented protocol for V.25bis call
control messages. Modems must support an ASCII-coded character set consisting
of 7-bit coded ASCII characters with odd parity.

Personal Communications supports the following adapters:
* Multiprotocol (MPA) interface compatible adapters, for example:
— IBM Multiprotocol Communications Adapter (73G7099)
— IBM Multiprotocol Adapter/A (645114 or later)
— IBM SDLC/Asynch Communications Adapter (ASCA) (42H4332)
* IBM SDLC PCMCIA adapter (Japanese only)
* IBM SDLC PCMCIA modem (Japanese only)
 IBM PCI Multiprotocol Adapter (12]2981)
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Performance Considerations

If you use multiple sessions in a high-speed and high-load configuration with an
SDLC attachment, the connection to the host might fail. In this case, set the host’s
timeout value to be greater than that of Personal Communications.

* To change the host timeout value, modify the following NCP parameters:

REPLYTO
The maximum duration in seconds that the host waits for a reply from
the terminal. The default is 1 second.

RETRIES=(m,t,n)
The number of recovery attempts for errors occurring during
transmission over the link. Repetitive retries are called a retry sequence.
The maximum number of retries is specified as m, which can be from 0
to 128. NCP pause (the time between the retry sequences) is specified as

t and can be from 1 to 255 seconds. The maximum number of retry
sequences is specified by n and can be from 1 to 127. For example:
REPLYTO=1, RETRIES=(3,4,5)
(( 1(seconds) x 3(times) + 4(seconds)) x 5(times)
= 35 (seconds)

— Note

In this example, the host will wait 35 seconds for the
terminal to reply.

For more details, ask your system personnel.

* To change the Personal Communications timeout value, type a new value in the
Inactivity timer field on the Performance page of the Connections property sheet

in SNA Node Configuration.
The value is in seconds and can be from 40 to 160. The default is 80.

PIU Size

This value is negotiated between your workstation and the host system, unless
XID=No is defined on the PU, or the Adjacent CP type has been changed to
Host - XIDO in SNA Node Configuration. If this value is not negotiated, the
Maximum PIU Size must match the MAXDATA value defined on the host system.

Receive Window Count

This value is negotiated between your workstation and the host system, unless
XID=No is defined on the PU, or the Adjacent CP type has been changed to

Host - XIDO in SNA Node Configuration. If this value is not negotiated, the
Receive Window Count must match the MAXOUT value defined on the host system.

Preventing Conflicts with Non-PCIl MPA Adapters

The multiprotocol adapters use system resources that, in some cases, cannot be
shared.Therefore, you must make sure there are no conflicts with the following
resources:

* DMA level

* I/0O addresses (MPAQ uses X'380'-X'38F' and MPA1 uses X'3A0-X"3AF')
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* IRQ level (ISA bus only)

The IBM Multiprotocol interface adapters use the following system resources:

* The AT-bus SDLC adapters require the use of IRQ3 and DMA channel 1 and
only the MPAO communication port is supported.

* The MPA for ISA can be supported using mode 4 (IRQ3 and DMAI1 channel 1)
or mode A (IRQ4 and DMA channel 1). IRQ level send/receive of 3 or 4 is
supported. The ASCA can be supported using mode 4 (IDQ3 or IRQ5 or IRQ4 or
IRQ7 and DMA channel 1) or mode A (IRQ4 or IRQ7 and DMA channel 1). IRQ
level send/receive or 3, 4, 5, or 7 is supported. The interrupt level setting on the
configuration panel in Personal Communications must match the value on the
adapter card.

— Note

When the MPA is configured for mode 4, the device will not be
allowed to use the other IRQ even though only one interrupt is
claimed.

Personal Communications supports the MPAO or MPA1 communication ports.
Some sound cards use an I/O address within the range X'380'-X'38F'. MPA1
should be used to avoid a conflict.

e The MPA/A for a microchannel-bus workstation uses IRQ3, and the DMA level
is configurable. Both the MPAO and MPA1 communication ports can be active at
the same time and the interrupt is claimed as sharable.

IBM Global Network - SNA over Async Attachment

IBM Global Network - SNA over Async is supported using 8-bit no parity; SNA
session-level compression and decompression is not supported.

Line Speed

Line speeds up t0115.2 Kbps are supported. However, the maximum usable line
speed depends on the speed of the processor or communication port. If
communication stops or becomes exceedingly slow, reduce the line speed.

Updating Phone List
To update the phone number list for IBM Global Network SNA over Async, do the

following:
1. Click the Used Phone Book button on the Define a Com Port Connection
panel.

2. Click the Download Phone Numbers button.

Personal Communications FIPs to the IGN server and downloads the phone
number file and converts it to the correct format.
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— Note

Sockets over SNA or Proxy must be configured in order for this
procedure to work.

IBM Global Network Connection Attachment

— Note

This attachment type is not available in Japan.

IBM Global Network Connection supports only a single communication port.

Line Speed

IBM Global Network Connection supports up to 115.2 kbps as the line speed.
However, the maximum usable line speed depends on the speed of the processor
or communication port. If communication stops or becomes exceedingly slow,
reduce the line speed.

Updating Phone List

To update the phone number list for IBM Global Network SNA over Async, click
the Download Phone Numbers button from the Configuration panel. When this
button is selected, Personal Communications FTPs to the IGN server and
downloads the phone number file and converts it to the correct format.

— Note

Sockets over SNA or Proxy must be configured in order for this
procedure to work.

Functions Not Available with the IBM Global Network
Connection

You cannot use the following functions:
* Import/Export

* Host graphics

* Host print
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* Server-Requester Programming Interface (SRPI)
¢ Concurrent multiple file transfers

Home3270 Attachment

Because Home3270 supports only a single COM port, only one session is available
for use at a time.

Setting the Screen Colors in a Home3270 Session

Because protocol converters translate the 3270 (EBCDIC) data stream into an ASCII
data stream, the original information about the 3270 fields is lost, and all the field
attributes of the 3270 screen are treated as extended attributes. Because of this, you
must select the Extended Color category in order to change the colors of characters
on the screen. Changing base colors will have no effect.

For example, if you want to change the color of characters that appear in green on
a black background, select Extended Color - Green, then click or drag-and-drop
the color you want for the characters (and for the background if you wish). Do not
change the appropriate Base Color because the change will have no effect.

Line Speed

Line speeds up t0115,200 bps are supported. However, characters might be lost on
high-speed lines, depending on the processor speed. If communication stops or
becomes exceedingly slow, reduce the line speed.

Unsupported Character Sequences

The following character sequence is valid for the Home3270 attachment. However,
it performs no function.

* ESC P 1 (Block cursor command)

* ESC P 0 (Underline cursor command)

* DLE DC2 (Printer start command)

* DLE DC4 (Printer end command)

Conditions for Communication Check 50x

Home3270 requires both Data Set Ready (DSR) and Carrier Detect (CD) to
determine the state of the attachment with the host system.If DSR is not
recognized, communication check 501 appears in the operator information area.
When DSR is recognized, if CD is not recognized, communication check 504
appears in the operator information area.

When you select ROLMphone** with DCM in the Home3270 configuration,
communication check 504 does not appear.

Home3270 and OIA message COMM 504

If you run Home3270 sessions at a speed of 28.8 kbps or higher and the session
disconnects with a COMMb504 in the OIA, try lowering the port speed to equal the
line speed of the Protocol Converter you are connecting to.

— Note

DBCS is not available with this attachment.
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Restrictions

The following functions are not available with this attachment:
* Host graphics

* Host print

* Server Requester Programming Interface

3270 Attachment via the AS/400 System

This section provides information, considerations, and restrictions for PC/3270
connections through an AS/400 system.

AS/400 System Setup

PC/3270 can connect to a host computer via one or more AS/400 systems by using
the passthrough function (usable with OS/400 Version 2.2.0 or later).

To use this function, set the following communication configuration descriptions in
the AS/400 system to on (Vary On):

* Line description

* Controller description

* Printer description

Error Messages from the AS/400 System

When this system is connected to an 5/390 host system via the AS/400 system, the
following message might appear on the screen.

AS/400 CPI5xxx

The message might appear for the following reasons:
* Line error between the AS/400 system and the host system.
¢ Communication configuration description error in the AS/400 system.

e The communication configuration description in the AS/400 system is set off
(Vary Off).

When this message appears, detailed error information is saved in the AS/400
system operator message queue. Refer to the error message that corresponds to the
number displayed on the screen and then correct the cause of the error.

IBM PC720 Modem Initialization (Japan Only)

In the Japanese version of Personal Communications, if you use an IBM PC720 and
connect it via a dial connection, the error message “COMDIA15 Unable to initialize
modem” may appear at startup. To correct this condition, increase the value of
Retries in Initialization to more than 1 by using the Modem Information panel.

Twinax Attachments

Twinax Adapter Types
Personal Communications classifies twinax adapters under five adapter types:
» IBM 5250 Plug-and-Play Adapters
— IBM 5250 Emulation PCMCIA Adapter
— IBM 5250 PCMCIA Adapter (DBCS-unique adapter)
— IBM 5250 Emulation PCI Adapter
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— IBM 5250 Express ISA Adapter, when the adapter’s Plug-and-Play BIOS is
enabled.
— IBM 5250 Express PC Card
— IBM 5250 Express PCI Adapter
IBM 5250 MicroChannel Adapters
— IBM System36/38 Workstation Emulation Adapter /A (DBCS-unique adapter)
— IBM 5250 Emulation Adapter /A
IBM 5250 ISA Adapters
— IBM Enhanced 5250 Display Station Emulation Adapter

— IBM 5250 Express ISA Adapter, when the adapter’s Plug-and-Play BIOS is
disabled.

IBM 5250 ISA Adapter (Asia-Pacific)

— IBM AT-Bus Communication Adapter (DBCS-unique adapter)
* Other Twinax Adapter

— OEM 5250 adapters

See ['LIsing Twinax (5250) Adapters” an page 98 for details on these adapters.

Using IBM 5250 Plug-and-Play Adapters

Before you can use one of the IBM 5250 Plug-and-Play adapters under Windows
95, Windows 98, or Windows 2000, you must first install a driver for the adapter.
See L i ing” for more information on
configuring all the IBM 5250 adapters.

— Note

Note to developers of software drivers for OEM twinax adapter
cards: If you are a software developer seeking to implement support
for Personal Communications on an OEM twinax adapter, you should
obtain a copy of the document Twinax OEM Interface Specfication for
Windows NT and Windows 95, as well as associated program materials,
which should be useful in your development; you can download
these from the internet at

www.ibm.com/software/network/pcomm /about/api/twinax.html

The documented interface is completely functional for Windows 98
and Windows 2000 Professional as well as for Windows 95 and
Windows NT. However, it does not support the Microsoft Windows
Driver Model (WDM) for Windows 98 and Windows 2000.

IBM SDLC PCMCIA Adapter and Modem (Japan Only)

For Windows 95 and Windows 98: The support uses the Configuration Manager
for Plug-and-Play support, which will automatically configure IRQ number, I/O
ports and memory addresses as required. IBMSDLC.INF (installed in the Personal
Communications installation directory) describes the SDLC PCMCIA cards to the
operating system. When you insert the PCMCIA card, Windows 95 and Windows
98 prompt you for the adapter drivers. You must specify the
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Personal Communications installation directory and select OK. To verify that the
adapter is functioning properly, select the appropriate PCMCIA adapter under
Other Devices on the Device Manager property page of the System Windows
control panel applet.

For Windows NT: Plug-and-Play is not supported. During installation the registry
is updated, using default parameters. When the configuration is started and an
incoming or outbound connection is enabled, the device attempts to load, using the
stored parameters from the registry. If a card is found and a conflict is detected,
the registry is updated with values that do not conflict and you are notified to
restart the system.

— Note

The system must be restarted for these values to take affect.

No more than one SDLC PCMCIA card can be used concurrently. Because a
common driver supports both SDLC PCMCIA and MPA interface cards, an MPA
cannot be used concurrently with SDLC PCMCIA.

IBM SDLC PCMCIA Adapter

This card supports:

* Leased and switched connections

* Speeds up to 19.2 Kbps

* Switched and Constant Request To Send (RTS)
* NRZ and NRZI encoding schemes

The IRQ number on the device page’s adapter property sheet is ignored.

IBM SDLC PCMCIA Modem

This card supports:

* Switched V.26bis connections only
* Speeds up to 2400 baud

* Switched RTS only

The configured value on the constant RTS and IRQ level send/receive device
page’s adapter property sheet are ignored.

IBM PCI Multiprotocol Adapter

92

Refer to the Quick Installation Guide in the PCI Multiprotocol Adapter User’s Guide for
instructions on installing this adapter under Windows 95, Windows 98, and
Windows NT.

Two IBM PCI Multiprotocol Adapters can operate concurrently. The configuration
specifies one adapter with Communication Port MPAO and the second adapter
with Communication Port MPA1. When the link is activated, MPADO is the first PCI
Multiprotocol Adapter that the operating system finds and MPA1 is the second
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adapter found. If more than one PCI Multiprotocol adapter is installed on a
machine and you are unsure which adapter the operating system will find first,
you may want to perform an isolated test to determine which adapter is connected
to which Communication Port. One suggestion is to disconnect the modems
connected to the adapter from the telephone line and then try to start each link
individually. By watching the modems, you should be able to determine which
modem is connected to which Communication Port. Then the modems can be
attached to the proper network. If a single PCI Multiprotocol Adapter is used, the
configuration file must specify MPAOQ as the Communication Port.

— Note

If a Personal Communications configuration is using this adapter, and
a PCI MPA adapter is added or removed from the system, Personal
Communications may have to be reconfigured.

An ISA-bus MPA and IBM PCI Multiprotocol Adapter can be used concurrently, as
long as the ISA-bus MPA adapter is configured as MPAL.

This adapter supports:

* Leased and switched connections

* Speeds up to 56 kbps

* Switched and Constant Request To Send (RTS)
* NRZ and NRZI encoding schemes

The IRQ number on the device page adapter property sheet is ignored.

WAC Attachments

This section describes factors you should consider when configuring Personal
Communications to communicate via a Wide Area Connector (WAC) adapter.

EIB Support
All available Electrical Interface Boards (EIBs) are supported for the WAC adapter.

Supported Adapters
The IBM WAC adapters for bus types ISA and MCA are supported.

Note: At this time, the new IBM PCI bus WAC adapter is NOT supported by
Personal Communications.

Potential Configuration Issues

When configuring both ports (upper and lower) on a single WAC adapter, you
must create two logical devices, using the configuration utility. Be careful to
configure the same Shared Ram Address for both devices, using the same adapter
number. If you do not do this, the Shared Ram Address for the first device
activated will be used for the second device.
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For ISA systems, the adapter number is obtained from the interpretation of the
on-board DIP switch settings. Switches 1-3 determine the Interrupt level, and
switches 4-7 (read in reverse order) determine the adapter number. Please consult
the adapter installation publication for additional information. Adapter numbers 0
and 1 are logically the same. This is also true for adapter numbers 8 and 9.

On some IBM ValuePoint systems, intermittent problems can occur. If you are
using one of these systems and are having problems, ensure that the adapter’s DIP
switch settings are such that Interrupt Level 9 is being used.

If you intend to use the WAC adapter in a system and you also plan on using
Hayes AutoSync function, then you might experience problems with your async
connection. To find appropriate Shared Memory values, you should use the
adapter diagnostic disk provided with the adapter.

For MCA systems, the adapter number is the slot number in which the adapter
physically resides. You can easily obtain this number via the MCA Configuration
utility that was provided with your system.For IBM systems, you can determine
this number by looking at the back of the system unit and providing the number
displayed for the selected slot.

System Resources

The Wide Area Connector adapter utilizes the following system resources per each

adapter installed:

* 32 bytes of IO addresses (differs depending upon the adapter number used on
ISA; see help on the configuration panel for additional information, or via MCA
adapter configuration.)

* Interrupt level (1 level can be used on MCA if all adapters share the same, ISA
adapters must have unique interrupt numbers.)

* 16 KB of shared memory

For ISA adapters, you should consult your WAC installation publication for
information concerning the IRQ used and the adapter number configured, both of
which are configured via the adapter’s DIP switches.

3174 Peer Communications Support (LAN over Coax)

94

The LAN over Coax function provides peer-to-peer communication for
workstations connected to an IBM 3174 Control Unit via an IBM 3270
communication adapter. It provides support for any NDIS protocol stack capable of
utilizing the IEEE 802.5 (token-ring) frame format, such as IEEE 802.2 (SNA),
NETBIOS, TCP/IP, or LLC2.

Installation

Under Windows 95 or Windows 98, to install the 3174 Peer Communications
Adapter Support, from the Network Control Panel, choose to install a new adapter,
and, when prompted, select the Have Disk option, and direct the installation
program to the XLNCOAX subdirectory in the Personal Communications installation
directory.

Under Windows 2000, install the 3174 Peer Communications Adapter support
using the Windows 2000 Add/Remove Hardware wizard. From the wizard, choose
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to install a new network adapter, and when prompted, select the Have Disk
option; direct the wizard to the XLNCOAX subdirectory in the Personal
Communications installation directory.

For Windows 95, Windows 98, and Windows 2000, the .INF file will install the new
adapter support and bind the adapter to all valid protocol stacks. To utilize the
new adapter, after installing and rebooting, configure Personal Communications to
utilize a LAN adapter, and enter the adapter number that corresponds to the 3174
Peer Communications adapter number found under the LLC Protocol for this
adapter. The 3174 Peer Communications RPQ is also required on the 3174.

Configuration

For Windows 95 and Windows 98, configure by using the Network Control Panel
Properties button for the selected adapter. For Windows 2000, configure by
opening the Windows 2000 Device Manager, and expanding the Network Adapters
entry; right-click the subentry for IBM 3174 Peer Communications (Lan over
Coax) Adapter and select Properties.

Options

Network Address
Overrides the burned in adapter address.

Queued Transmits
Number of queued transmit elements to support.

Slot Number
Required for MCA bus systems, not applicable to others; indicates the
adapter to use in a specific MCA slot.

On Micro Channel workstations, you can use up to 4 type-B 3270 Connection
Adapters (but only 1 type A). When you configure Personal Communications, you
must specify the physical slot in which each adapter is installed.

System Resources
On ISA Bus systems, the following system resources are used:

* Interrupt Level 2

* 1O address 0x2d0 through 0x2df

* Shared memory address Oxce000

These resources are not changeable. On MCA systems, these resources are

configured via the MCA adapter configuration, with the exception for the Interrupt
number, which is Interrupt 2.

Multiple Adapter Coexistence

If you use type-B adapters, you can use one or more for DFT connections
concurrently with 3174 Peer Communications. If you want to do this, the Peer
Communications adapter(s) must be in higher-numbered slots than the DFT
adapter(s) because DFT connections will, by design, use the first adapter(s) they
find, searching from slot 1.
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Twinaxial Console

You can configure Personal Communications to act as the console for an AS/400. If
you want to use full-function 5250 emulation, you must not use the console
attachment; you must use Twinaxial Data Link Control (APPC).

Restrictions:

* The Setup API functions of the File menu cannot be used.
* Copy is the only editing function available.

* The file transfer function cannot be used.

* The session type cannot be set to Printer. (AS/400)

* Multiple console sessions cannot be used.

* The Enhanced Non-programmable Terminal User Interface (ENPTUI) cannot be
transferred from the host system.

e The PC Organizer cannot be used.
* The screen size is always 24 x 80, even if 27 x 132 is specified.

* The cursor position cannot be moved by the mouse.

Asynchronous Console

For the asynchronous console attachment, you must have a 2609 or 2612 adapter
for the Multiple Function I/O Processor (MFIOP) on the AS/400 system. This
connection also requires a special cable. The part numbers for the cables are
46G0450 (6m) and 46G0479 (2.5m).

— Note

The AS/400 Advanced Portable Model P02 does not support the
asynchronous console attachment.

An asynchronous console has the following restrictions:
* Multiple console sessions cannot be used.

* APIs are not supported

* The session type cannot be set to the Printer.

* The file transfer functions is not supported.

* The PC Organizer cannot be used.

Adapter Setup Hints and Tips

The following sections describe how to configure adapters, including PCMCIA and
PCI cards.

Using Coax (3270) Adapters

Personal Communications supports IBM AT-bus, Micro Channel (MCA), and Plug
and Play coax adapters; the configuration of each is described in the following
sections.
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3278/79 Emulation Adapter (ISA-Bus)

This adapter has a fixed I/O-port address and interrupt level (IRQ), but you have
to set the memory address, which you can do only through the Personal
Communications configuration.

The buffer address must be set. The default is CE000. If you happen to know that
this address is already being used by another device, you should change it, but,
when you first try to connect, Personal Communications will check the registry to
find an available address anyway.

Under Windows 2000, if Personal Communications cannot acquire a system
resource (that is, an IRQ, a memory address, or an I/O address) needed by this
adapter, Personal Communications displays an error panel identifying the
unavailable resource. For an IRQ conflict (this adapter uses IRQ 9 only), Personal
Communications automatically tries to activate the polling feature instead of using
IRQ 9; if this succeeds then no error panel is displayed. For a memory address
conflict, you should use the Personal Communications coax adapter configuration
panel to select another memory address. For an I/O address conflict, you should
reconfigure the device that is using the I/O address to use some other I/O
address.

IBM 3270 Connection Adapter (Micro Channel)

Micro Channel adapters need the same types of resource as AT-bus but
configuration is much easier because the resources are all set by the workstation’s
hardware configuration and Personal Communications is able to read them.

Configure Personal Communications in the normal way. The default buffer address
will be the one set in the system configuration. You should not change it.

Plug-and-Play Adapters

Configure Personal Communications in the normal way; you will notice that the
Plug-and-Play radio button is active and that you do not have to configure the
buffer address.

The first time that you insert the 3270 Emulation Credit Card Adapter into a
PCMCIA slot or start your PC with the PCI card installed, Windows 95 or
Windows 98 or Windows 2000 will prompt you for the location of the .INF file for
the card. The .INF file is located in the directory where Personal Communications
is installed. Under Windows 2000, the file is named IBM3270X.INF. Under Windows
95 and Windows 98, the file is named IBM3270.INF.

Removing the card while you have an active connection will have
unpredictable results.

3270 ISA-Bus and MCA Adapters and ROM Shadowing

These adapters use 8KB of workstation memory; the default values for the memory
addresses are as follows:

¢ Adapter #0 CEO00h - CFFFFh

e Adapter #1 DO0O0Oh - D1FFFh

* Adapter #2 D2000h - D3FFFh
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* Adapter #3 D4000h - D5FFFh

Some types of workstation may use these areas, by default, for ROM shadowing in
BIOS (the IBM PC350 for example). You should check the ROM-shadowing settings
before installing an adapter, and disable the range that will be used by the adapter
that you are going to install.

OEM Adapters

Personal Communications has an open API that enables vendors and other
equipment manufacturers (OEMs) to provide adapter cards that allow for
additional connectivity options, for example, additional X.25, ISDN, SDLC. or
twinax support. After installing the OEM adapter, you can begin to configure it in
the usual manner described in L i i ion” . However, at
some point in the configuration process you may need to provide information
required by the manufacturer of the OEM adapter card.

Using Twinax (5250) Adapters
Personal Communications classifies twinax adapters under five adapter types:
+ IBM 5250 Plug-and-Play Adapters
— IBM 5250 Emulation PCMCIA Adapter
— IBM 5250 PCMCIA Adapter (DBCS-unique adapter)
— IBM 5250 Emulation PCI Adapter

— IBM 5250 Express ISA Adapter, when the adapter’s Plug-and-Play BIOS is
enabled.

— IBM 5250 Express PC Card
— IBM 5250 Express PCI Adapter
e IBM 5250 MicroChannel Adapters
— IBM System36/38 Workstation Emulation Adapter /A (DBCS-unique adapter)
— IBM 5250 Emulation Adapter /A
* IBM 5250 ISA Adapters
— IBM Enhanced 5250 Display Station Emulation Adapter

— IBM 5250 Express ISA Adapter, when the adapter’s Plug-and-Play BIOS is
disabled.

* IBM 5250 ISA Adapter (Asia-Pacific)
— IBM AT-Bus Communication Adapter (DBCS-unique adapter)
* Other Twinax Adapter
— OEM 5250 adapters
The configuration of each IBM adapter type is described in the following sections.

All the IBM adapters are supported; OEM adapters are supported if their
manufacturer has created a device driver that is compatible with the IBM driver.

IBM 5250 Plug-and-Play Adapter
In Personal Communications, set the Adapter Type to IBM 5250 Plug-and-Play

Adapter. You do not have to set the Interrupt Level, I/O Address, or Memory
Address fields; these fields are grayed out. Personal Communications
automatically reads the interrupt level, I/O address, and memory address from the
adapter card.

The first time that you insert the 5250 PCMCIA or PC Card adapter into a
PCMCIA slot, or start your PC with the 5250 PCI card or 5250 ISA Express card
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(with Plug-and-Play BIOS enabled) installed, Windows 95 or Windows 98 or
Windows 2000 prompts you for the location of the .INF file for the card. The .INF
file is located in the directory where Personal Communications is installed. Under
Windows 2000, the file is named IBM5250X.INF. Under Windows 95 and Windows
98, the file is named IBM5250. INF.

If you experience problems getting a host connection with the 5250 Emulation PCI
Adapter and you have an IBM personal computer, upgrading the BIOS might solve
the problem. You can find the date of your system BIOS by using your system
setup when you boot your personal computer. Then you can look on the Internet
to see if there is a later version for your personal computer. The IBM File Library
Web site that has the latest BIOS upgrade files is located at:
www.pc.ibm.com/listfiles.html

From there you can search for your specific IBM personal computer. If there is a
flash BIOS upgrade date later than that on your personal computer, download the
file to your personal computer and follow the instructions that come with the file.
For non-IBM personal computers, contact the manufacturer of your personal
computer for BIOS upgrade information.

IBM 5250 MicroChannel Adapter

In Personal Communications, set the adapter type to IBM 5250 MicroChannel
Adapter. You do not have to set the Interrupt Level, I/O Address, or Memory
Address fields; these fields are grayed out. Personal Communications
automatically reads the interrupt level, I/O address, and memory address from the
adapter card.

IBM 5250 ISA Adapter

In Personal Communications, set the adapter type to IBM 5250 ISA Adapter. You
must then set the interrupt level, I/O address, and Memory address to match the
values set on the adapter card. For a new configuration, Personal Communications
shows the default settings.

To view or change the settings on the adapter card, use the adapter configuration
utility provided with the adapter. For the IBM Enhanced 5250 Display Station
Emulation Adapter only, change the I/O address using switches on the adapter
itself.

Under Windows 2000, if Personal Communications cannot acquire a system
resource (that is, an I/O address, a memory address, or an IRQ) needed by this
adapter, Personal Communications displays an error panel identifying the
unavailable resource. To resolve this resource conflict, use the Personal
Communications configuration panel to select another I/O address, memory
address, or IRQ. If a conflict still exists, reconfigure the device that is currently
using the resource to use some other resource.

— Note

Removing a 5250 PCMCIA card or 5250 PC Card, or stopping a
PCMCIA adapter slot containing a 5250 PCMCIA card or 5250 PC
Card, will have unpredictable results.
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IBM 5250 ISA Adapter (Asia-Pacific)
In Personal Communications, set the adapter type to IBM 5250 ISA Adapter

(Asia-Pacific). You must then set the interrupt level and memory address to match
the values set on the adapter card. For a new configuration, Personal
Communications shows the default settings. The I/O Address field is grayed out;
you do not need to set this field. Personal Communications automatically reads the
I/O address from the adapter card.

To change the I/O address on the adapter card, use the switches on the adapter
itself. To view the I/O address, or to view or change the interrupt level or memory
address on the adapter card, use the adapter configuration utility provided with
the adapter.

Twinax Connections Through a 5494 Controller to an AS/400

To set up a twinaxial connection to an AS/400 through a 5494 controller:

1. Click Programs>IBM Personal Communications>SNA Node Configuration
from the Windows Start menu.

2. Click Configure Connections from the list of Configuration options and then
click Twinaxial from the list of DLCs.

3. Click an entry from the list of configured twinaxial connections and click
View>Change>Add

4. Check Link to preferred NN server.
5. Click the Security tab.

6. In the Adjacent CP name field, enter the network ID and CP name of the
5494 controller.

7. Click OK to save the connection information.
8. Click Configure Partner LU 6.2 from the list of Configuration options.

9. Click an entry from the list of Partner LU 6.2 definitions and click
View>Change>Add

10. In the Partner LU name field, enter the CP name of the AS/400 system. The
CP name is also known as the system location name.

11. In the Fully qualified CP name field, enter the network ID and CP name of
the 5494 controller.

12. Click OK to save the Partner LU 6.2 information.
13. Click Save As... from the File menu.

14. Enter a file name with an .ACG file extension, such as CFG5494.ACG. Click Yes
to make this configuration the default.

Note: To enable this configuration, configure the 5494 controller as a network node
(NN).
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To connect to an AS/400 system, you need to specify configuration information in
the workstation profile that accurately corresponds to the information specified in
the AS/400 system (referred to as the device description).

For example, the LAN attachment via IEEE 802.2 in the following figure shows
how the configuration information specified in the AS/400 workstation profile

corresponds to the configuration information in the AS/400 system.

AS/400

PC400

Network Attribute

Local Network ID <
Local Location Name «

Local Adapter Address <«
Source Service Access Point (SSAP) <

Line Description

Configure Link
(LAN via IEEE 802.2)

Destination Address
Remote SAP

Controller Description
Controller Category (*APPC)
Remote Network ID <
Remote Control Point <
LAN Remote Adapter Address
(PC LAN Adapter Address)

LAN DSAP «
LAN SSAP <

T
(Select Advanced)

L Local SAP
]

Device Description
Device Category (*APPC)
Remote Location <
Remote Network ID Code <
APPN available (*YES)

Device Description «
Device Category (*DSP, *PRT)

Configure Communication

— Session Type
Host Code Page
System Location Name
Field 1

Field 2
PC Location Name

Field 1

Field 2
Workstation ID

<

<

Device Type (3197/3477, 3812)

Device Class (*VRT)
Device Format (C1/FC,1)

Keyboard Language Type (USB)

Character Identifier (697 037)

© Copyright IBM Corp. 1989, 2000
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AS/400 Device Description

To configure 5250 display or printer sessions, the following values must be set in
the AS/400 device description:

AS/400 Device Display Session
Description 24 x 80 27 x 132 Printer Session

Device category *DSpP *DSP *PRT
Device class *VRT *VRT *VRT
Device type 3197 3477 3812
Device model C1 FC 1
Keyboard language uUsB* UsB* -
type
Character identify 697 037° 697 037° -
code
: 7 For SBCS, depends on the host code page selection.

The following table applies to DBCS only.

Display Session
Host Code Page | Host Code Page
AS/400 Device Description 931 939 Printer Session

Device category *DSP *PRT
Device class *VRT *VRT
Device type 5555 5555

Cco1 Co1

JUB JPB -
Character identify code 101 037 -
DBCS device feature 2424]0 2424]0 2424]0

5250 Sessions through One Link

If you want all your 5250 sessions to connect through one link to an AS/400

system, use the same PC Location Name and the same Link Parameters for all the
sessions.

For example, you can configure two display sessions and one printer session
connected to an AS/400 system using APPN.PC5250 as the Location Name.
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Session A
(Display)

Session B
(Display)

Session C
(Printer)

Session Type

System Location Name
PC Location Name
Workstation ID

Session Type

System Location Name
PC Location Name
Workstation ID

Session Type

System Location Name
PC Location Name
Workstation ID

AS/400 Device Description

Display
APPN.S7801234
APPN.PC5250
(not specified)

Display
APPN.S7801234
APPN.PC5250
(not specified)

Printer
APPN.S7801234
APPN.PC5250
PCLOCALP1

In this example, the AS/400 network attributes are:

Local network ID : APPN

Local Tocation

: §7801234

Enter DSPNETA from a 5250 session to display AS/400 network
attributes.

AS/400 System Mode Description
PC400 initially uses mode description QPCSUPP on the AS/400 system. If the PC

Support/400 program or Client Access/400 is installed on the AS/400 system,

QPCSUPP need not be created. If mode description QPCSUPP does not exist on
the AS/400 system, create the mode description:

1. Enter the following command on the command line of the main menu of the
AS/400 system:

CRTMODD

The Creating Mode Description panel appears.
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4 N
Creating Mode Description (CRTMODD)
Type the selected items, and push the Enter key.
Mode Description.........ccuuunn.. Name
Maximum Session......ceevuvennnn. 8 1-512
Maximum number of interaction.... 8 1-512
Number of Local Control Sessions. 4 0-512
Number of Pre-joined Sessions.... 0 0-512
Inbound Pacing Value............. 7 0-63
Outbound Pacing Value............ 7 0-63
Maximum Length of Request Unit... *CALC 241-16384, *CALC
Text Description ....covevveenenns *BLANK
End
F3=Exit F4=Prompt F5=Reshow F10=Add parameter F12= Cancel
F13=How to use this panel F24=More key
& %

2. Type the necessary values in each field, according to the following table.

Field Name Input Value
Mode description QPCSUPP
Maximum session 64
Maximum number of interactions 64

Number of local control sessions 0

Number of pre-joined sessions 0

Inbound pacing value 7

Outbound pacing value 7
Maximum length of request unit *CALC

Text description

3. After you type all the values, press the Enter key.

This field is optional

This completes the creation of the mode description QPCSUPP.

AS/400 Device Description for Twinaxial Attachments (APPC) Example

104

If you want to use a twinaxial (TDLC) attachment, the AS/400 system requires that
you specify a device description. When the automatic device configuration
indicator (QAUTOCEFG) is set to ON in the AS/400 system, the device description
is created automatically. When the indicator is set to OFF, create the device

description, as follows:

1. Enter the following command on the command line of the AS/400 system main

menu:
CRTDEVDSP

The Creating Device Description (Display) panel appears.
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4 Creating Device Description(Display)  (CRTDEVDSP) h
Type the selected item, and push Enter key.
Device Description...
Device ClasS.......... *LCL, *RMT, *VRT, *SNPT
Device Type........... 3101, 3151, 3161, 3162...
Device Format........ 0, 1, 2, 4, 11, 12, 23...
End
F3=Exit F4=Prompt F5=Reshow F10=Add parameter F12= Cancel
F13=How to use this panel F24=More key
N J
2. Type the values in each field, according to the following table.
Field Name Input Value
Device description This is an optional field
Device class *LCL
Device type 5150
Device format 2
3. After you type all values, press the Enter key.
The following screen appears:
4 Creating Device Description(Display)  (CRTDEVDSP) h
Type the selected item, and push Enter key.
Device Description.......... >TWXPOAL Name
Device ClasS.ueeeeeeeennnnnn. >%| CL *LCL, *RMT, *VRT, *SNPT
Device Type.ceeseeesenesaans 5150 3101, 3151, 3161, 3162...
Device Format............... g 0, 1, 2, 4, 11, 12, 23...
Port Number.............. _ 0-17
Switch Setting........... _ 0,1, 2, 4,5, 6
Online when IPL............. >xYES *YES, *NO
Controller to be attached... Name
Keyboard Word Type.......... >%xSYSVAL *SYSVAL,AGB,AGI,BLI...
Text Description............ >*BLANK
F3=Exit F4=Prompt F5=Reshow F10=Add parameter  F12= Cancel
F13=How to use this panel F24=More key
N J

4. Type the values for each field, according to the following table.

Field Name

Input Value

Port number

Number of the port to be attached

Switch setting

Device address

Controller to be attached

Descriptive name of the controller to be attached
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Field Name

Input Value

Keyboard word type

USB!

: ! Depends on the host code page selection.

5. After you enter all the values, press the Enter key.

This completes the creation of the device description for the twinaxial

attachment.

AS/400 Device Description for Asynchronous Attachment Example

If you want to use an asynchronous dial attachment, the AS/400 system requires
that you specify configuration parameters for the controller/line/devices to be

used.

The following sample is a typical configuration on the AS/400 system for an
asynchronous dialed connection through an ASCII Workstation Controller.

1. Enter the following command on the command line of the AS/400 system main

menu:

WRKCFGSTS =CTL CTLO3

where CTLO3 is the name of your controller.

The Work with Configuration Status panel appears.

4 Work with Configuration Status )
Position to . . . . . Starting characters
Type options, press Enter
1=Vary on 2=Vary off 5=Work with job 8=Work with description
9-Display mode status ...
Opt Description Status = mmmemmemeeee- Job--=-mmmmmmemm
8 CTLO3 ACTIVE
_ ADLCTST VARY ON PENDING
o ASYNC VARY ON PENDING
- ASYNCD VARY ON PENDING
_ EZASYNC VARY ON PENDING
. ASYNCPO VARY ON PENDING
_ ASYNRTR ACTIVE
BOTTOM
Parameters or command
===
F3=Exit F4=Prompt F12=Cancel F23=More options F24=More keys
o %

2. Enter 8 in the Opt field to work with the controller description for CTLO03.
The Work with Controller Descriptions panel appears.
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4 Work with Controller Descriptions )
Position to . . . . . Starting characters
Type options, press Enter
2=Change 3=Copy 4=Delete 5=Display 6=Print 7=Rename
8=Work with status 9=Retrieve source 12=Print device addresses
Opt Controller Type Text
2_ CTLO3 6141 CREATED BY AUTO-CONFIGURATION
Parameters or command
===5]
F3=Exit F4=Prompt F5=Refresh F6=Create F9=Retrieve F12=Cancel
Fl4=Work with status
N J
3. Enter 2 in the Opt field to change the controller description for CTLO03.
The Change Controller Description panel appears.
4 N
Change Ct1 Desc (local WS) (CHGCTLLWS)
Controller Description . . . . . . : CTLO3
Option . . . . . . . . . . . . . . : *BASIC
Category of controller . . . . . . : *LWS
Controller type . . . . . . . . . : 6141
Controller model . . . . . . . . . :1
Resource name . . . . . . . . . . : CTLO3
TDLC 1ine . . . . . . . . . . . . : QTDL429000
Online at IPL . . . . . . . . . . ¢ *YES
Auto-configuration controller . . : *YES
Text . . . . . .. .. ... . . . : CREATED BY AUTO-CONFIGURATION
Device wait timer . . . . . . . . : 10
Press Enter to continue.
===2)
F3=Exit F4=Prompt F5=Refresh F12=Cancel F13=How to use this display
F24=More keys
%
4. Type the values in each field, according to the following table.
Field Name Input Value
Controller description CTLO03
Resource name CTLO03
Online at IPL *YES
Device wait timer 10
Auto-configuration controller *YES
Text description This field is optional
The Work with Controller Descriptions panel appears.
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-

Work with Controller Descriptions

Position to . . . . . Starting characters

Type options, press Enter
2=Change 3=Copy 4=Delete 5=Display 6=Print 7=Rename
8=Work with status 9=Retrieve source 12=Print device addresses

Opt  Controller Type Text
8  CTLe3 6141 Created by auto-configuration

BOTTOM
Parameters or command
===>
F3=Exit F4=Prompt F5=Refresh F6=Create F9=Retrieve F12=Cancel
Fl4=Work with status

-

5. Enter 8 in the Opt field to work with the configuration status.
The Work with Configuration Status panel appears.

-

Work with Configuration Status

Position to . . . . . Starting characters

Type options, press Enter
1=Vary on 2=Vary off 5=Work with job 8=Work with description
9-Display mode status ...

Opt  Description Status  mmmmmmemmeee- Job-------ommmm-
CTLO3 ACTIVE
ADLCTST VARY ON PENDING
ASYNCPERTH VARY ON PENDING
ASYNCD VARY ON PENDING
EZASYNC VARY ON PENDING
_ ASYNCPO VARY ON PENDING
8 ASYNRTR ACTIVE

BOTTOM
Parameters or command

===>

F3=Exit F4=Prompt F12=Cancel F23=More options F24=More keys

-

6. Enter 8 in the Opt field next to ASYNRTR to work with the display device
description.

The Work with Device Descriptions panel appears.

108  Personal Communications Quick Beginnings



Asynchronous Attachments

4 Work with Device Descriptions )
Position to . . . . . Starting characters
Type options, press Enter
2=Change 3=Copy 4=Delete 5=Display 6=Print 7=Rename
8=Work with status 9=Retrieve source
Opt Controller Type Text
2_ ASYNRTR 5150 FOR PC400
BOTTOM
Parameters or command
===
F3=Exit F4=Prompt F5=Refresh F6=Create F9=Retrieve F12=Cancel
Fl4=Work with status
& %
7. Enter 2 in the Opt field to change the device description.
The Change Device Description panel appears.
/ . . N
Change Device Desc (Display) (CHGDEVDSP)
Type choices, press Enter.
Device description . . . . . . .. > ASYNRTR Name
Port number . . . . . . . .. .. 4 0-17, *SAME
Switch setting . . . . . . . . .. 0 0-6, *SAME
Online at IPL . . . . . . . . .. *YES *SAME, *YES, *NO
Keyboard language type . . . . . . USI *SAME, *SYSVAL, *NONE, AGB...
Character identifier:
Graphic character set . . . . . *KBDTYPE 1-32767, *KBDTYPE, *SYSVAL...
Code page . . . .. .. .. .. 1-32767
AlTow bTinking cursor . . . . . . *YES *SAME, *YES, *NO
Print device . . . . . . . . . .. *SYSVAL Name, *SAME, *SYSVAL
Qutput queue . . . . . . . . . .. *DEV Name, *SAME, =*DEV
Library . . . . . . . . . ... Name, *LIBL, *CURLIB
Printer file . . . . . . . . . .. QSYSPRT Name, *SAME
Library . . . . . o o o ... *LIBL Name, *LIBL, *CURLIB
More...
Press Enter to continue.
===
F3=Exit F4=Prompt F5=Refresh F1l0=Additional parameters F12=Cancel
F13=How to use this display F24=More keys
N J

This completes the creation of the controller and display device descriptions for

an asynchronous dial attachment.

AS/400 VT Asynchronous Attachment Example

The following sample is a typical configuration on the AS/400 system for a VT

asynchronous dialed connection through an ASCII Workstation Controller. For
more details on AS/400 for VT asynchronous attachments, refer to the AS/400
ASCII Workstation Reference (SA41-3130-00).

1. Enter the following command on the command line of the AS/400 system main

menu.:
CRTDEVDSP
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The Create Device Description panel appears, in a first and second screen, as
shown for the configuration of a VT100 device below. When filling in the panel,
make sure that the name of the attached controller (arbitrarily shown as CTLO05
here) matches the name of the twinaxial controller configured on your AS/400.

4 Create Device Desc (Display) (CRTDEVDSP) )

Type choices, press Enter.

Device description . . . . . . . > VT100 Name
Device class . . . . . . . . . . > x| CL *LCL, *RMT, =VRT, *SNPT
Device type . . . . . . . . .. > V100 3101, 3151, 3161, 3162...
Device model . . . . . . . . .. > *ASCII 0, 1, 2, 4, 5, 12, 23 ...
Emulated twinaxial device . . . > *TYPE 3196A2, 3197D2, *TYPE
Port number . . . . . . . . .. > 1 0-17
Emulating ASCII device . . . . . > *NO *NO, *YES
Physical attachment . . . . . . > *MODEM *DIRECT, *PTT, *MODEM...
Online at IPL . . . . . . . .. > *YES *YES, *NO
Attached controller . . . . . . > CTLO5 Name
Keyboard language type . . . . . > USB *SYSVAL, AGB, AGI, ALI...
Inactivity timer . . . . . . . . > *NOMAX 1-30, *ATTACH, *NOMAX...
Line speed . . . . . . . . . .. > 19200 *TYPE, *CALC, 150, 300...
Word length . . . . . . . . .. > 8 *TYPE, *CALC, 7, 8
Type of parity . . . . . . . .. > *NONE *TYPE, *CALC, *EVEN, =0DD...
Stop bits . . . . . ..o oL > 2 *TYPE, 1, 2
More...
F3=Exit  F4=Prompt F5=Refresh  F10=Additional parameters F12=Cancel
F13=How to use this display F24=More keys
o %
4 N

Create Device Desc (Display) (CRTDEVDSP)
Type choices, press Enter.

Text 'description' . . . . . .. > 'dec vt100 device description test'

Additional Parameters
Character identifier:

F13=How to use this display

Graphic character set . > *=KBDTYPE 1-32767, *SYSVAL, *KBDTYPE
Code page . . . . . . . . .. 1-32767
Print device . . . . . . . . .. > xSYSVAL Name, *SYSVAL
Qutput queue . . . . . . . . .. > *DEV Name, *DEV
Library . . . . . . . . ... Name, *LIBL, *CURLIB
Printer file . . . . . . . . .. > QSYSPRT Name
Library . . . . . . . . ... > *LIBL Name, *LIBL, *CURLIB
Bottom
F3=Exit  F4=Prompt F5=Refresh  F10=Additional parameters F12=Cancel

F24=More keys

-

2. Here is a similar configuration for a VI220.

Use the same command, CRTDEVDSP, on the command line of the AS/400
system main menu. Again, the same kind of panels appear. You must make

sure that the name of the attached controller matches the name of the twinaxial

controller configured on your AS/400.
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4 Create Device Desc (Display) (CRTDEVDSP) h
Type choices, press Enter.
Device description . . . . . . . V1220 Name
Device class . . . . . . . . .. > x| CL *LCL, *RMT, *VRT, *SNPT
Device type . . . . . . . . .. > V220 3101, 3151, 3161, 3162...
Device model . . . . . . . . .. > *ASCII 0, 1, 2, 4, 5, 12, 23
Emulated twinaxial device > *TYPE 3196A2, 3197D2, *TYPE
Port number . . . . . . . ... > 2 0-17
Emulating ASCII device . . . . . > *NO *NO, *YES
Physical attachment . . . . . . > *MODEM *DIRECT, *PTT, *MODEM...
Online at IPL . . . . . . . .. > *YES *YES, *NO
Attached controller . . . . . . > CTLOS Name
Keyboard Tanguage type . . . . . > USB *SYSVAL, AGB, AGI, ALI...
Inactivity timer . . . . . . . . > *NOMAX 1-30, *ATTACH, *NOMAX...
Line speed . . . . . . . . . .. > 19200 *TYPE, *CALC, 150, 300...
Word length . . . . . . . . .. > 8 *TYPE, *CALC, 7, 8
Type of parity . . . . . . . .. > *NONE *TYPE, *CALC, *EVEN, O0DD...
Stop bits . . . . . .. .. L. > 1 *TYPE, 1, 2
More...
F3=Exit  F4=Prompt F5=Refresh  F10=Additional parameters F1l2=Cancel
F13=How to use this display F24=More keys
& %
4 Create Device Desc (Display) (CRTDEVDSP) h
Type choices, press Enter.
Text 'description' . . . . . .. > 'dec vt220 device description test'
Additional Parameters
Character identifier:
Graphic character set > +xKBDTYPE 1-32767, *SYSVAL, *KBDTYPE
Code page . . . . . . . . .. 1-32767
Print device . . . . . . . . .. > *SYSVAL Name, *SYSVAL
Qutput queue . . . . . . . . . . > *DEV Name, *DEV
Library . . . . . . . o ... Name, *LIBL, *CURLIB
Printer file . . . . . . . . .. > QSYSPRT Name
Library . . . . . . . . . .. >  *LIBL Name, *LIBL, *CURLIB
Bottom
F3=Exit  F4=Prompt F5=Refresh  F10=Additional parameters F12=Cancel
F13=How to use this display F24=More keys
- J
AS/400 Configuration for SDLC Example
The following examples refer to SDLC and Hayes AutoSync:
Network Attributes
To display the network attributes for the AS/400 to which you are connecting,
enter the command dspneta on the AS/400 Main Menu.
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/MAIN AS/400 Main Menu
System:
Select one of the following:

User tasks

O0ffice tasks

General system tasks

Files, libraries, and folders
Programming

Communications

Define or change the system
Problem handling

Display a menu

Information Assistant options
Client Access tasks

H O WONO O WN -
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90. Sign off

Selection or command
===> dspneta

F23=Set initial menu

RALYAS4B

F3=Exit  F4=Prompt F9=Retrieve F12=Cancel F13=Information Assistant

Press Enter.

The Display Network Attributes screen is displayed.

e
Display Network Attributes

Press Enter to continue.

F3=Exit  Fl2=Cancel

System:

Current systemname . . . . . . . . . . . . . . RALYAS4B
Pending systemname . . . . . . . . . . . . .

Local network ID . . . . . . . . . ... .. .. : USIBMRA
Local control point name . . . . . . . . . . . . : RALYAS4B
Default Tocal location . . . . . . . . . . . . . : RALYAS4B
Default mode . . . . . . . . . . . ... ... .: BLAN
APPN node type . . . . . . . . . .. ... ... *NETNODE
Data compression . . . . . . . . . . . . ... . *NONE
Intermediate data compression . . . . . . . . . : *NONE
Maximum number of intermediate sessions . . . . : 200
Route addition resistance . . . . . . . . .. . : 128
Server network ID/control point name . . . . . . :  *LCLNETID

RALYAS4B

*ANY

More...

The network attributes include the AS/400 Network ID and CP name.

SDLC Leased Configuration

Several descriptions must be created on the AS/400; examples are given below.

Creating an SDLC Line Description

To create an SDLC leased line description, enter the command crtlinsdlc on the

AS/400 Main Menu.
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/'MAIN AS/400 Main Menu )
System: RALYAS4B
Select one of the following:
1. User tasks
2. Office tasks
3. General system tasks
4. Files, libraries, and folders
5. Programming
6. Communications
7. Define or change the system
8. Problem handling
9. Display a menu
10. Information Assistant options
11. Client Access tasks
90. Sign off
Selection or command
===> crtlinsdlc
F3=Exit F4=Prompt F9=Retrieve F12=Cancel F13=Information Assistant
F23=Set initial menu
J
Press F4 (Prompt).
The Create LIne Description panel is displayed. Enter the values for each
parameter on the panel.
4 Create Line Desc (SDLC) (CRTLINSDLC) )
Type choices, press Enter.
Line description . . . . . . . . > PCOMMSDLCL Name
Resource names . . . . . . . . . > LINO21 Name
+ for more values
Online at IPL . . . . . . . .. *YES *YES, *NO
Data link role . . . . . . . .. *NEG *NEG, *PRI, *SEC
Physical interface . . . . . . . *RS232V24 *RS232V24, *V35, *X21, ...
Connection type . . . . . . .. *NONSWTPP *NONSWTPP, *SWTPP, *MP, *SHM
Switched network backup *NO *NO, *YES
Exchange identifier . . . . . . *SYSGEN 05600000-056FFFFF, *SYSGEN
NRZI data encoding . . . . . . . *YES *YES, *NO
Line speed . . . . . . . . . .. 9600 600, 1200, 2400, 4800...
Modem type supported . . . . . . *NORMAL *NORMAL, =*V54, *IBMWRAP...
Maximum frame size . . . . . . . 521 265, 521, 1033, 2057
Duplex . . . . . . o o o o o .. *HALF *HALF, =FULL
Inactivity timer . . . . . . . . 300 *NOMAX, 150-4200 (0.1 sec)
Poll response delay . . . . .. ] 0-2048 (0.0001 seconds)
More...
F3=Exit  F4=Prompt F5=Refresh  F12=Cancel F13=How to use this display
F24=More keys
& %
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4 Create Line Desc (SDLC) (CRTLINSDLC)

Type choices, press Enter.

Additional Parameters

F24=More keys

Nonproductive receive timer . . 320 160-4200 (0.1 seconds)
Idle timer . . . . . . . . . .. 30 5-300 (0.1 seconds)
Connect poll timer . . . . . . . 30 2-300 (0.1 seconds)
Poll cycle pause . . . . . . . . 0 0-2048 (0.0001 seconds)
Frame retry . . . . . . . . .. 7 0-64

Text 'description' . . . . . . . PCOMM SDLC Teased line

Attached nonswitched ctls . . . Name
+ for more values
Modem data rate select . . . . . *FULL *FULL, *HALF
Error threshold level . . . . . *OFF *0FF, *MIN, *MED, *MAX
Modulus . . . . . . . . . . .. 8 8, 128
Maximum outstanding frames . . . 7 1-28

More...

F3=Exit  F4=Prompt F5=Refresh  Fl12=Cancel F13=How to use this display

Press Enter to save the line description pcommsdic1.

SDLC Controller Description

To create the SDLC controller description for the line PCOMMSDLCL, enter

crtctlappc on the AS/400 Main Menu.

/MAIN AS/400 Main Menu

Select one of the following:

User tasks

0ffice tasks

General system tasks

Files, libraries, and folders
Programming

Communications

Define or change the system
Problem handling

Display a menu

Information Assistant options
Client Access tasks

—HOWOONOO O WN -

—_

90. Sign off

Selection or command
===> crtctlappc

F23=Set initial menu

System: RALYAS4B

F3=Exit  F4=Prompt F9=Retrieve F12=Cancel F13=Information Assistant

Press F4 (Prompt). The Create Controller Description panel is displayed. Enter

values for each parameter on the following two panels.
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4 Create Ct1 Desc (APPC) (CRTCTLAPPC) h
Type choices, press Enter.
Controller description . . . . . > PCOMMSDLCL Name
Link type . . . . . . . . ... > *SDLC *ANYNW, *FAX, *FR, *IDLC...
Online at IPL . . . . . . . . . *YES *YES, *NO
Switched connection . . . . . . *NO *NO, *YES
Switched network backup *NO *NO, *YES
APPN-capable . . . . . . . . .. *YES *YES, *NO
Attached nonswitched Tline > PCOMMSDLCL Name
Maximum frame size . . . . . . . *LINKTYPE 265-16393, 256, 265, 512...
Remote network identifier > USIBMRA Name, *NETATR, *NONE, =*ANY
Remote control point . . . . . . > PCOMMCP Name, *ANY
Exchange identifier . . . . . . 00000000-FFFFFFFF
Data link role . . . . . . . .. *NEG *NEG, *PRI, *SEC
Station address . . . . . . . . C1 00-FE
APPN CP session support *NO *YES, *NO
APPN node type . . . . . . . .. *LENNODE *ENDNODE, *LENNODE. ..
APPN transmission group number 1 1-20, *CALC
More...
F3=Exit  F4=Prompt F5=Refresh  Fl12=Cancel F13=How to use this display
F24=More keys
J
4 Create Ct1 Desc (APPC) (CRTCTLAPPC) h
Type choices, press Enter.
Autocreate device . . . . . . . *ALL *ALL, *NONE
Autodelete device . . . . . .. 1440 1-10000, *NO
User-defined 1 . . . . . . . .. *IND 0-255, *LIND
User-defined 2 . . . . . . . .. *LIND 0-255, *LIND
User-defined 3 . . . . . . . .. *LIND 0-255, *LIND
Text 'description' . . . . . . . PCOMM SDLC Leased
Additional Parameters
Attached devices . . . . . . .. Name
+ for more values
Character code . . . . . . . .. *EBCDIC *EBCDIC, *ASCII
SSCP identifier . . . . . . .. 000000000001-FFFFFFFFFFFF
IDLC window size . . . . . . . . *LIND 1-31, *LIND
IDLC frame retry . . . . . . . . *LIND 0-100, *LIND
More...
F3=Exit  F4=Prompt F5=Refresh  Fl12=Cancel F13=How to use this display
F24=More keys
J
Press Enter.
The APPC Device Description will create itself automatically.
SDLC Switched Configuration
The following examples contain information about the SDLC switched
configuration on the AS/400.
SDLC Line Description
To create an SDLC switched line definition on the AS/400, enter the command
crtlinsdlc on the AS/400 Main Menu.
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/'MAIN AS/400 Main Menu )
System:  RALYAS4B

Select one of the following:

. User tasks

. Office tasks

. General system tasks

. Files, libraries, and folders
. Programming

. Communications

. Define or change the system

. ProbTem handling

. Display a menu

. Information Assistant options
. Client Access tasks

HF O WOWONOO B WN —
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90. Sign off

Selection or command
===> crtlinsdlic

F3=Exit  F4=Prompt F9=Retrieve F12=Cancel Fl3=Information Assistant
F23=Set initial menu

Press F4 (Prompt).

The Create Ctl Description panel is displayed. Enter values for each parameter on

the panel.
4 Create Line Desc (SDLC) (CRTLINSDLC) )
Type choices, press Enter.
Line description . . . . . . .. > PCOMSDLCSW Name
Resource names . . . . . . . . . > LINO51 Name
+ for more values
Online at IPL . . . . . . . . . *YES *YES, *NO
Data link role . . . . . . . .. > *PRI *NEG, *PRI, *SEC
Physical interface . . . . . . . *RS232V24 *RS232V24, *V35, *X21, ...
Connection type . . . . . . .. > *SWTPP *NONSWTPP, *SWTPP, *MP, *SHM
Vary on wait . . . . . . . . .. *NOWAIT *NOWAIT, 15-180 (1 second)
Autocall wnit . . . . . . . .. *NO *NO, *YES
Exchange identifier . . . . . . *SYSGEN 05600000-056FFFFF, *SYSGEN
NRZI data encoding . . . . . . . *YES *YES, *NO
Line speed . . . . . . . . . .. 9600 600, 1200, 2400, 4800...
Modem type supported . . . . . . *NORMAL *NORMAL, =*V54, *IBMWRAP...
Switched connection type . . . .  *BOTH *BOTH, *ANS, *DIAL
Autoanswer . . . . . . . . . .. *YES *YES, *NO
Autodial . . . . . . . . . . .. *NO *NO, *YES
More...
F3=Exit  F4=Prompt F5=Refresh  F12=Cancel F13=How to use this display
F24=More keys
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4 Create Line Desc (SDLC) (CRTLINSDLC) h

Type choices, press Enter.

Calling number . . . . . . . .. *NONE

Connect poll retry . . . . . . . 7 0-64

Maximum frame size . . . . . . . 521 265, 521, 1033, 2057
Duplex . . . . . . . . . o . .. *HALF *HALF, =FULL
Nonproductive receive timer . . 320 160-4200 (0.1 seconds)
Idle timer . . . . . . . . . .. 30 5-300 (0.1 seconds)
Connect poll timer . . . . . . . 30 2-300 (0.1 seconds)
Poll cycle pause . . . . . . . . 0 0-2048 (0.0001 seconds)
Frame retry . . . . . . . . .. 7 0-64

Data Set Ready drop timer . . . 6 3-60 (seconds)
Autoanswer type . . . . . . . . *DTR *DTR, *CDSTL

Remote answer timer . . . . . . 60 30, 35, 40, 45 (seconds)...
Text 'description’ . . . . . . . PCOMM SDLC switched line

More...
F3=Exit  F4=Prompt F5=Refresh  Fl12=Cancel F13=How to use this display
F24=More keys

Press Enter to save the description pcomsdlcsw.

SDLC Controller Description
To create the controller description for the switched SDLC line, enter crtctlappc on
the AS/400 Main Menu.

/MAIN AS/400 Main Menu h
System: RALYAS4B

Select one of the following:

User tasks

0ffice tasks

General system tasks

Files, libraries, and folders
Programming

Communications

Define or change the system
Problem handling

Display a menu

Information Assistant options
Client Access tasks

= O WOONOYOT WN -

—_ =

90. Sign off

Selection or command
===> crtctlappc

F3=Exit F4=Prompt F9=Retrieve F12=Cancel F13=Information Assistant
F23=Set initial menu

Press F4 (Prompt).

The Create Controller Description panel is displayed. Enter values for each
parameter on the panel.
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4 Create Ct1 Desc (APPC) (CRTCTLAPPC) h

Type choices, press Enter.

Controller description . . . . . > PCOMSDLCSW Name
Link type . . . . . . . . ... > xSPLC *ANYNW, =FAX, *FR, *IDLC...
Online at IPL . . . . . . . . . *YES *YES, *NO
Switched connection . . . . . . > *YES *NO, *YES
Short hold mode . . . . . . .. *NO *NO, *YES
APPN-capable . . . . . . . . .. *YES *YES, *NO
Switched Tine list . . . . . . . > PCOMSDLCSW Name
+ for more values
Maximum frame size . . . . . . . *LINKTYPE 265-16393, 256, 265, 512...
Remote network identifier . . . *NETATR Name, *NETATR, *NONE, *ANY
Remote control point . . . . . . > J0 Name, *ANY
Exchange identifier . . . . . . > 00000000 00000000-FFFFFFFF
Initial connection . . . . . . . > *ANS *DIAL, *ANS
Connection number . . . . . . . > 123
Data link role . . . . . . . .. > *SEC *NEG, *PRI, *SEC
Station address . . . . . . .. 01 00-FE

More...
F3=Exit  F4=Prompt F5=Refresh  Fl12=Cancel F13=How to use this display
F24=More keys

o J
4 Create Ct1 Desc (APPC) (CRTCTLAPPC) h

Type choices, press Enter.

APPN CP session support . . . . *NO *YES, *NO

APPN node type . . . . . . . .. +*ENNODE *ENDNODE, *LENNODE. ..

APPN transmission group number 1 1-20, *CALC

APPN minimum switched status . . *VRYONPND *VRYONPND, *VRYON

Autocreate device . . . . . .. *ALL *ALL, *NONE

Autodelete device . . . . . .. 1440 1-10000, *NO

User-defined 1 . . . . . . . . . *LIND 0-255, *LIND

User-defined 2 . . . . . . . .. *LIND 0-255, *LIND

User-defined 3 . . . . . . . .. *LIND 0-255, *LIND

Text 'description' . . . . . . . PCOM SDLC switched line

Additional Parameters
Attached devices . . . . . . .. Name
+ for more values
More...
F3=Exit F4=Prompt F5=Refresh  F12=Cancel F13=How to use this display
F24=More keys
%

Press Enter to save the controller description pcomsdlcsw.

The APPC Device Description will create itself automatically once Personal
Communications attaches to the AS/400 using the line and controller descriptions
that were just created.

LAN Configuration Example

This example assumes that a line description (token-ring or Ethernet) is already in
place. This is a shared configuration object—all connections on that adapter will
use the same line description. In the configuration example shown, the line
description name is TRN2619.

LAN Controller Description

The normal method would be to let the APPC controller create itself automatically.
However, if preferred, the following command can be used to manually create the
APPC controller.
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To create a LAN controller description, enter crtctlappc on the AS/400 Main Menu.

/MAIN AS/400 Main Menu )
System: RALYAS4B
Select one of the following:
1. User tasks
2. Office tasks
3. General system tasks
4. Files, libraries, and folders
5. Programming
6. Communications
7. Define or change the system
8. Problem handling
9. Display a menu
10. Information Assistant options
11. Client Access tasks
90. Sign off
Selection or command
===> crtctlappc
F3=Exit  F4=Prompt F9=Retrieve F12=Cancel F13=Information Assistant
F23=Set initial menu
J
Press F4 (Prompt). The Create Controller Description panel will be displayed.
Enter values for each parameter on the panel.
4 Create Ct1 Desc (APPC) (CRTCTLAPPC) h
Controller description . . . . . PCOMMLAN Name
LIRR B2 o0 0 0 0 6 06 06 0 6 0 o *LAN *ANYNW, =FAX, *FR, =IDLC...
Online at IPL . . . . . . . .. *YES *YES, *NO
APPN-capable . . . . . . . . .. *YES *YES, *NO
Switched Tine list . . . . . . . TRN2619 Name
+ for more values
Maximum frame size . . . . . . . *LINKTYPE 265-16393, 256, 265, 512...
Remote network identifier *NETATR Name, *NETATR, *NONE, *ANY
Remote control point . . . . . . PEPE Name, *ANY
Exchange identifier . . . . . . 00000000-FFFFFFFF
Initial connection . . . . . . . *DIAL *DIAL, *ANS
Dial initiation . . . . . . .. *LINKTYPE *LINKTYPE, *IMMED, *DELAY
LAN remote adapter address . . . 400052005109 000000000001-FFFFFFFFFFFF
APPN CP session support . *NO *YES, *NO
APPN node type . . . . . . . .. *LENNODE *ENDNODE, *LENNODE...
APPN/HPR capable . . . . . . . . *YES *YES, *NO
More...
F3=Exit  F4=Prompt F5=Refresh  F12=Cancel F13=How to use this display
F24=More keys
- J
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4 Create Ct1 Desc (APPC) (CRTCTLAPPC)

Type choices, press Enter.

APPN transmission group number 1 1-20, *CALC

APPN minimum switched status . . *VRYONPND *VRYONPND, *VRYON
Autocreate device . . . . . . . *ALL *ALL, *NONE

Autodelete device . . . . . . . 1440 1-10000, *NO
User-defined 1 . . . . . . . . . *LIND 0-255, *LIND
User-defined 2 . . . . . . . .. *LIND 0-255, *LIND
User-defined 3 . . . . . . . .. *LIND 0-255, *LIND

Model controller description . . *NO *NO, *YES

Text 'description' . . . . . . . PCOMM token-ring

Bottom

F3=Exit  F4=Prompt Fb5=Refresh  F10=Additional parameters Fl2=Cancel
\Fl3=How to use this display F24=More keys

Press Enter to save the controller description pcommlan.
The APPC Device Description will create itself automatically. Personal

Communications attaches to the AS/400 using the controller description that was
just created.
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This section includes examples of AnyNet running SNA over IP connections.The
following configuration instructions are complete only for the Windows NT and
Windows 95 operating systems. In all examples, the SNA domain name suffix is
SNA.IBM.COM.

Notes:

1. In the following examples, Windows 95 is shown; Windows 98 can be treated
the same.

2. Windows NT is shown; Windows 2000 can be treated the same.

For more information about AnyNet as part of Personal Communications, refer to
the Personal Communications Reference Volume II. For more information about
configuring AnyNet for any other platforms mentioned in this section (such as
VTAM or AS/400), refer to the appropriate product documentation.

Example 1. 5250 Emulation Over a TCP/IP Network

Node A: Windows 95 Node B: AS/400 Host
CP name: NETA.CPNAME2 CP name: NETA.CPNAME1
IP address: 10.2.1.1 IP address: 10.1.1.1

Personal 0S/400
Communications

* AnyNet SNA
* AnyNet SNA over TCP/IP
over TCP/IP * TCP/IP

Follow these steps to establish communication between the Windows 95
workstation (Node A) and the AS/400 host (Node B).

For Windows 95 Node A, do as follows:
1. Add the following entries to the local HOSTS file:
10.1.1.1 CPNAME1.NETA.SNA.IBM.COM

2. Create a workstation profile using the Personal Communications configuration
tool:

a. Click the Start/Configure Session icon; or click Configure from the
Communication menu. The Customize Communication window is
displayed.

b. Select the following options:
¢ Host: AS/400

* Interface: AnyNet
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¢ Attachment: TCP/IP 5250

c. Click Configure.

d. Click Configure Link.

e. On the Configure Local System window, enter:
e PC Location Name: NETA.CPNAME2

On the Configure Logical Connection Windows, enter:
e System Location Name: NETA.CPNAME1
f. Save your workstation profile.

For AS/400 Node B, add the following entry to the local HOSTS file:
10.2.1.1 CPNAME2.NETA.SNA.IBM.COM

Example 2. Running APPC or CPI-C Applications over a TCP/IP
Network

Node A: Windows 95 Node B: Windows NT
LU name: NETA.CP1 LU name: NETA.CP2
IP address: 172.25.11.1 IP address: 172.25.11.2
Application A Application B
Personal Personal
Communications Communications
* AnyNet SNA * AnyNet SNA
over TCP/IP over TCP/IP

Follow these steps to establish communication between a Windows NT node and a
Windows 95 node. Note that in this example, the CP names are used as LU names.

For Windows 95 Node A, do as follows:
1. Add the following entry to the local HOSTS file:
172.25.11.2 CP2.NETA.SNA.IBM.COM
2. Create a configuration using the Personal Communications configuration tool:

a. Click the SNA Node Configuration icon; or click Launch > SNA Node
Configuration from the Actions menu. The Personal Communications SNA
Node Configuration window is displayed.

b. In the Configuration Options list, choose Configure Node and click New.

c. On the Define the Node window on the Basic tab, enter:
* Fully qualified CP name: NETA.CP1

Click OK to complete node configuration.

d. Choose Configure Devices. In the DLCs list, choose AnyNet SNA/IP and
click New.
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e. On the Define an AnyNet SNA over TCP/IP Device window on the Basic
tab, enter:
* SNA domain name suffix: SNA.IBM.COM

f. Click the Routing Preferences tab:
* Default Routing Preference: Non-native only

Click OK to complete configuration of the AnyNet device.

g. From the Personal Communications SNA Node Configuration window, click
File. Click Save as... and enter the desired file name to save.

For Windows NT Node B, do as follows:

1.

Add the following entry to the local HOSTS file:
172.25.11.1 CP1.NETA.SNA.IBM.COM
Create a configuration using the Personal Communications configuration tool:

a. Click the SNA Node Configuration icon; or click Launch > SNA Node
Configuration from the Actions menu. The Personal Communications SNA
Node Configuration window is displayed.

b. In the Configuration Options list, choose Configure Node and click New.

c. On the Define the Node window on the Basic tab, enter:
* Fully qualified CP name: NETA.CP2

Click OK to complete node configuration.

d. Choose Configure Devices. In the DLCs list, choose AnyNet SNA/IP and
click New.

e. On the Define an AnyNet SNA over TCP/IP Device window on the Basic
tab, enter:
¢ SNA domain name suffix: SNA.IBM.COM

f. Click the Routing Preferences tab:
* Default Routing Preference: Non-native only
Click OK to complete configuration of the AnyNet device.

g. From the Personal Communications SNA Node Configuration window, click
File. Click Save as... and enter the desired file name to save.

Start Personal Communications on each machine.
Start your applications (for example APING).
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Example 3. APPC3270 Emulation over a TCP/IP Network

Node A: VTAM

LU name: NETA.LUNAME1
IP address: 10.2.1.1

VTAM

* AnyNet SNA
over TCP/IP

Node B: Windows 95

LU name: NETA.LUNAME?2
IP address: 10.2.1.2

Personal
Communications

* AnyNet SNA
over TCP/IP

Follow these steps to establish communication between the VTAM host (Node A)
and the Windows 95 (Node B).

For VTAM Node A, add the following entry to the local HOSTS file:
10.2.1.2 LUNAME2.NETA.SNA.IBM.COM

For Windows 95 Node B, do as follows:
1. Add the following entry to the local HOSTS file:
10.1.1.1 LUNAME1.NETA.SNA.IBM.COM

2. Create a workstation profile using the Personal Communications configuration
tool:

a. Click the Start/Configure Session icon; or click Configure from the
Communication menu. The Customize Communication window is
displayed.

b. Select the following options:

* Host: S/390
* Interface: AnyNet
* Attachment: APPC3270

c. Click Configure.

d. Click Configure Link.

e. On the Configure Local System window, enter:

e PC Location Name: NETA. LUNAME2

f. On the Configure Logical Connection window, enter:
* System location name: NETA. LUNAME1
* Routing Preference: Non-native only

g. On the Configure AnyNet Connection window, enter:
* SNA domain name suffix: SNA.IBM.COM

h. Save your workstation profile.
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Example 4. 3270 Emulation via DLUR over a TCP/IP Network

Node A: VTAM Node B: Windows 95
CP name: NETA.CP1 CP name: NETA.CP2
IP address: 192.168.7.8 IP address: 192.168.7.10

Dependent LU name: NETA.DEPLU1

VTAM Personal
Communications
* AnyNet SNA
over TCP/IP *DLUR
*DLUS * AnyNet SNA

over TCP/IP

Follow these steps to establish communication between the VTAM Host (Node A)
and the Windows 95 workstation (Node B).

For VTAM Node A, add the following entry to the HOSTS file:

192.168.7.10 CP2.NETA.SNA.IBM.COM
192.168.7.10 DEPLU1.NETA.SNA.IBM.COM

For Windows 95 Node B, do as follows:
1. Add the following entry to the local HOSTS file:
192.168.7.8  CP1.NETA.SNA.IBM.COM

2. Create a workstation profile using the Personal Communications configuration
tool:

a. Click on the Start/Configure Session icon; or click Configure from the
Communication menu. The Customize Communication window is
displayed.

b. Select the following options:
¢ Host: S/390
* Interface: AnyNet
* Attachment: TCP/IP LU 0,1,2,3 via DLUR

c. Click Configure.

d. Click Configure Link.

e. On the Configure Local System window, enter:

* PC Location Name: NETA.CP2
On the Configure DLUR window, enter:
* DLUS name: NETA.CP1

* Routing Preference: Non-native only

—h

g. On the Configure AnyNet Connection window, enter:
* SNA domain name suffix: SNA.IBM.COM

Save your workstation profile.

=
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Example 5. 3270 Emulation over a TCP/IP Network via an SNA Gateway
to a VTAM Host on an SNA Network

Node A: OS/2 or Windows NT Node B: Windows 95
PLU CP name: NETA.CP2 CP name: NETA.CP1
IP address: 172.16.3.4 IP address: 172.16.5.6
Communications Persona
Server Communications
VTAM * SNA Gateway * AnyNet SNA
* AnyNet SNA over TCP/IP
over TCP/IP

For OS/2 (or Windows NT) Node A, add the following entry to the HOSTS file:
172.16.5.6 CP1.NETA.SNA.IBM.COM

Follow these steps to establish communication between the Windows 95
workstation (Node B) and the VTAM host.

For Windows 95 Node B, do as follows:
1. Add the following entry to the local HOSTS file:
172.16.3.4 CP2.NETA.SNA.IBM.COM

2. Create a workstation profile using the Personal Communications configuration
tool:

a. Click on the Start/Configure Session icon; or click Configure from the
Communication menu. The Customize Communication window is
displayed.

b. Select the following options:

* Host: S/390
* Interface: AnyNet
e Attachment: TCP/IP LU 0,1,2,3

c. Click Configure.

d. Click Configure Link.

e. On the Configure Local System window, enter:
e PC Location Name: NETA.CP1

f. On the Configure AnyNet Connection window, enter:

* SNA domain name suffix: SNA.IBM.COM
* Fully qualified CP name: NETA.CP2
g. Save your workstation profile.
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Example 6. 3270 Emulation via an SNA Gateway over a TCP/IP Network

Node A: VTAM

Node B: OS/2 or Windows NT Node C: Windows 95

CP name: NETA.CP3
IP address: 10.1.1.1

VTAM

* AnyNet SNA
over TCP/IP
*DLUS

CP name: NETA.CP2
IP address: 10.1.1.2

CP name: NETA.CP1
IP address: 10.1.1.3
Dependent LU name: NETA.DEPLU1

Communications Personal
Server Communications
* SNA Gateway * AnyNet SNA
*DLUR over TCP/IP
* AnyNet SNA
over TCP/IP

IP

\( Network r

Follow these steps to establish communication between the Windows 95
Workstation (Node C) and the VTAM host (Node A).

For VTAM Node A, add the following entry to the HOSTS file:

10.1.1.2  CP2.NETA.SNA.IBM.COM
10.1.1.2  DEPLU1.NETA.SNA.IBM.COM

For OS/2 Node B, add the following entry to the HOSTS file:

10.1.1.3 CP1.NETA.SNA.IBM.COM
10.1.1.1 CP3.NETA.SNA.IBM.COM

For Windows 95 Node C, do as follows:
1. Add the following entry to the local HOSTS file:
10.1.1.2 CP2.NETA.SNA.IBM.COM

2. Create a workstation profile using the Personal Communications configuration
tool:

a. Click the Start/Configure Session icon; or click Configure from the
Communication menu. The Customize Communication window is
displayed.

b. Select the following options:
¢ Host: S/390
* Interface: AnyNet
* Attachment: TCP/IP LU 0,1,2,3

c. Click Configure.

d. Click Configure Link.

e. On the Configure Local System window, enter:

¢ PC Location Name: NETA.CP1

On the Configure AnyNet Connection window, enter:

* SNA domain name suffix: SNA.IBM.COM

* Fully qualified CP name: NETA.CP2

0. Save your workstation profile.

—h
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Example 7. 3270 Emulation over a TCP/IP Network via an AnyNet
SNA/IP Gateway to a VTAM Host on an APPN Network

Node A: VTAM Node B: OS/2 or Windows NT Node C: Windows 95

CP name: NETA.CP1 IP address: 192.168.1.1 CP name: NETA.CP2
IP address: 192.168.1.2
Dependent LU name:
NETA.DEPLU1

VTAM Communications Personal
Server Communications
«DLUS PLU
* AnyNet SNA * AnyNet SNA
over TCP/IP over TCP/IP
Gateway *DLUR
SNA
(APPN)

Follow these steps to establish communication between the OS/2 (or Windows NT)
workstation (Node B) and the Windows 95 workstation (Node C).

For OS/2 (or Windows NT) Node B, add the following entries to the HOSTS file:

192.168.1.2 CP2.NETA.SNA.IBM.COM
127.0.0.2  DEPLU1.NETA.SNA.IBM.COM
192.168.1.2 DEPLU1.NETA.SNA.IBM.COM

For Windows 95 Node C, do as follows:
1. Add the following entry to the local HOSTS file:
192.168.1.1 CP1.NETA.SNA.IBM.COM

2. Create a workstation profile using the Personal Communications configuration
tool:

a. Click the Start/Configure Session icon; or click Configure from the
Communication menu. The Customize Communication window is
displayed.

b. Select the following options:
¢ Host: S/390
* Interface: AnyNet
* Attachment: TCP/IP LU 0,1,2,3 via DLUR

c. Click Configure.

d. Click Configure Link.

e. On the Configure Local System window, enter:
e PC Location Name: NETA.CP2

f. On the Configure DLUR window, enter:
* DLUS name: NETA.CP1
* Routing Preference: Non-native only

g. On the Configure AnyNet Connection window, enter:
* SNA domain name suffix: SNA.IBM.COM
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h. Save your workstation profile.
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Example 8. 3270 Emulation from a Windows NT Workstation and a

Windows 95 Workstation on Different IP Networks

Node A: Windows NT

Node B: OS/2 or Windows NT

Node C: OS/2 or Windows NT

Node D: Windows 95

CP name: NETA.CP1

IP address: 10.2.4.6

Dependent LU name:
NETA.DEPLU1

CP name: NETB.CP2
IP address: 10.2.4.8

CP name: NETB.CP3
IP address: 172.20.1.1

CP name: NETC.CP4

IP address: 172.20.1.2

Dependent LU name:
NETC.DEPLU2

Personal
Communications

+DLUR
« AnyNet SNA/IP

1P
Network
#1

CN name: IPNET1.GWCNET
CP name: IPNET1.CP1

Communications
Server

* AnyNet SNA/IP
Gateway

Communications
Server

* AnyNet SNA/IP
Gateway

Personal
Communications

*DLUR
* AnyNet SNA/IP

SNA

VTAM
*DLUS

Node E: VTAM

CP name: NETB.CP5

1P
Network
#2

CN name: IPNET2.GWCNET
CP name: IPNET2.CP2

PLU

Follow these steps to establish communication from the Windows NT workstation
(Node A), and from Windows 95 (Node D), to the VTAM Host (Node E).

For Windows NT Node A, do as follows:
1. Add the following entries to the local HOSTS file:

10.2.4.8
127.0.0.4
127.0.0.3

CP5.NETB.SNA.IBM.COM
IPNET1.GWCNET
IPNET1.CP1

2. Create a workstation profile using the Personal Communications configuration

tool:
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a. Click on the Start/Configure Session icon; or click Configure from the
Communication menu. The Customize Communication window is
displayed.

b. Select the following options:

* Host: S/390
* Interface: AnyNet
e Attachment: TCP/IP LU 0,1,2,3 via DLUR

c. Click on Configure.

d. Click on Configure Link.

e. On the Configure Local System window, enter:
e PC Location Name: NETA.CP1

f. On the Configure DLUR window, enter:
* DLUS name: NETB.CP5
* Routing Preference: Non-native only

g. On the Configure AnyNet Connection window, enter:
* SNA domain name suffix: SNA.IBM.COM

h. Save your workstation profile.

For OS/2 (or Windows NT) Node B, add the following entries to the HOSTS file:

10.2.4.6 CP1.NETA.SNA.IBM.COM
127.0.0.2  DEPLU1.NETA.SNA.IBM.COM
10.2.4.6 DEPLU1.NETA.SNA.IBM.COM
127.0.0.4  IPNET1.GWCNET

127.0.0.3  IPNET1.CP1

For OS/2 (or Windows NT) Node C, add the following entries to the HOSTS file:

172.20.1.2 CP4.NETC.SNA.IBM.COM
127.0.0.2  DEPLU2.NETC.SNA.IBM.COM
172.20.1.2 DEPLU2.NETC.SNA.IBM.COM
127.0.0.4  IPNET2.GWCNET

127.0.0.3  IPNET2.CP2

For Windows NT Node D, do as follows:
1. Add the following entry to the local HOSTS file:

172.20.1.1 CP5.NETB.SNA.IBM.COM
127.0.0.4  IPNET2.GWCNET
127.0.0.3  IPNET2.CP2

2. Create a workstation profile using the Personal Communications configuration
tool:

a. Click the Start/Configure Session icon; or click Configure from the
Communication menu. The Customize Communication window is
displayed.

b. Select the following options:
¢ Host: S/390
* Interface: AnyNet
* Attachment: TCP/IP LU 0,1,2,3 via DLUR

c. Click Configure.

d. Click Configure Link.

e. On the Configure Local System window, enter:

e PC Location Name: NETC.CP4
f. On the Configure DLUR window, enter:
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* DLUS name: NETB.CP5
* Routing Preference: Non-native only

g. On the Configure AnyNet Connection window, enter:
* SNA domain name suffix: SNA.IBM.COM

h. Save your workstation profile.
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Appendix E. Configuring Multiple Links

Many customers must attach to multiple AS/400 and S/390 mainframe systems.
Personal Communications allows this type of configuration. The following sections
explain how to do this.

Note: You do not need to read this section if you want to create multiple sessions
on the same host.

Configuring a Second 3270 Emulation Link

Recommendation

If you want a second SNA connection (link) to run concurrently, we strongly
recommend that you configure it in the same .PCG file as the first one; this
will avoid any possible conflict of settings.

Here are the steps you should follow. You can make the configuration even if the
first link is active.

1. Double-click the Start or Configure Session icon to start a new session; or
click Configure from the Communication menu.

2. Choose the host, interface, and attachment type, as usual.

3. Configure the session parameters, then click Configure Link.

4. In the Configure Local System panel, check that the default .PCG file is the
one in which you saved the configuration for the first link. If not, click
Existing and choose the correct file from the list.

5. Check that the settings for the PC Location Name are correct. Click Next.

6. The LAN Device Connection panel appears. Under Device Selection, be sure
that the device used for the first link is displayed. Under Connection

Selection, select New Connection. Notice that the connection name has
changed to show a new link name. Click Next.

7. The Configure LAN Connection panel is displayed. The Destination Address
tield will show 400000000000. Enter the Destination Address for the second
link, and change the additional parameters if needed.

8. Click Advanced.
9. The Advanced dialog panel shows the default values for block ID and PU ID.
Change them as necessary to the values for the second link. Click OK.

10. Click Next, then Finish, and save the .ACG file (replace the existing file).
Then click OK until you return to the session window. If you have done
everything correctly, and if the gateway or controller is running, you should
get a connection.

You can add further 3270 links in the same way.

Configuring a Second 5250 Emulation Link

The steps you should follow are almost the same as for 3270. You can make the
configuration even if the first link is active:
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1.

Double-click the Start or Configure Session icon to start a new session; or click
Configure from the Communication menu.

Choose the host, interface, and attachment type, as usual.
Configure the session parameters, then click Configure Link.

In the Configure Local System panel, check that the default .PCG file is the one
in which you saved the configuration for the first link. If not, click Existing and
choose the correct file from the list.

Check that the settings for the first link are correct. Click Next.

The Configure Logical Connection panel appears, showing the settings for the
first link. If you are going to connect to a different AS/400, change the System
Location Name. Click Next.

The Configure LAN Connection panel appears. If the Link Station Name has
not changed, change it.

Change the Destination Address (and the other parameters if necessary). If you
want to change the Local SAP number or the Receive Buffer Count, (which is
unlikely), click Advanced. If not, click Next, then Finish, and save the .ACG
file (replace the existing file), then click OK until you return to the session
window.

You can add further 5250 links in the same way.

Configuring a Second Link of a Different Kind

The rules about this are similar to those for the configurations just described and
they apply equally whether you are going to configure two (or more) links that use
the same connection type, or links that use different connection types. In this
example, we shall assume that you have already configured a 3270 connection and
now want to add a 5250 connection. As before, you can make the configuration
even if the first link is active.

1.

Double-click the Start or Configure Session icon to start a new session; or click
Configure from the Communication menu.

Choose AS/400, the LAN interface and the IEEE 802.2 attachment type.
Configure the session parameters, then click Configure Link.

In the Configure Local System panel, check that the default .ACG file is the one
in which you saved the configuration for the 3270 link. If not, click Existing
and choose the correct file from the list. Notice that the PC Location Name is
already there. Click Next.

The Configure Logical Connection panel appears. Enter the System Location
Name and click Next.

Notice that the Link Station Name has changed. Enter the Destination Address
of the AS/400. Click Next, then Finish, and save the .ACG file (replace the
existing file); then click OK until you return to the session window.

Configuring to Perform 3270 and 5250 Emulation to Multiple Hosts

134

To configure Personal Communications to perform 3270 and 5250 emulation to
multiple hosts:

1.

Click Launch > SNA Node Configuration from the Actions menu of your
active session; or click SNA Node Configuration from the Program>IBM
Personal Communications folder on the Windows Start menu.

Configure the node information:
a. Click Configure Node from the list of Configuration options.
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b. Click New.

C. In the Fully qualified CP name field, enter the Network ID and CP name
that is defined for you on the AS/400 (APPN.TEST, for example).

Note: If the AS/400 is performing automatic configuration, the value you
enter here is ignored. However, it is still necessary to enter a value in the
field to close the panel.

d. Click OK.
3. Configure the device information:
a. Click Configure Devices from the list of Configuration options.
b. Click LAN from the list of available DLCs.

Note: These instructions are based on the LAN DLC; the field names and
tabs might be slightly different if you are configuring another type of DLC.

c. Click New.

d. Specify the adapter number for the connection.

e. Click OK.
4. Configure the connection information:

a. Click Configure Connections from the list of Configuration options.
Click LAN from the list of available DLCs.
Click New.

Enter the Link station name (default is LINKO0000) and click the device (for
example, LANX_04) that you defined in step 3 from the Device Name list.
This link will be defined for the 5250 session to the AS/400.

e. Enter the LAN destination address of the AS/400.
f. Click the Advanced tab.

0. Verify that Activate at startup is checked.

h. Verify that APPN support is checked.

i. If you plan to use 3270 pass-through on this connection, click Solicit SSCP
sessions.

2 oo

j- Click OK to save the information.
5. Configure the second link for the 3270 session:
a. Click New.

b. Enter the Link station name (default is LINK0001) and select the same
device you used to define the 5250 session (for example, LANX_04). This
link will be defined for the 3270 session to the host.

c. Enter the LAN destination address of the host.
d. Click the Advanced tab.

e. Verify that Activate at startup is checked.

f. Verify that APPN support is checked.

g. Click Solicit SSCP sessions.

h

. In the Local Node ID field, enter the Block ID and Physical Unit ID that
identifies the device.

i. Click the Adjacent Node tab.
j. Click HOST-XID3 from the list of Adjacent CP types.
k. Click OK.
6. Configure the Partner LU 6.2 information:
a. Click New.
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b.

C.

Enter the Partner LU name, such as APPN.S5101010. This is the name of the
AS/400; this information can be obtained by running a DSPNETA on the
AS/400.

Click OK.

7. Save the configuration information:
a.

C.

On the SNA Node Configuration window, click Save As from the File
menu.

Enter a file name with an .ACG file extension (4.2 users) or a .PCG file
extension (4.1 users), such as TEST.ACG. Click Yes to make this
configuration the default.

Click Exit on the File menu.

8. Start the 5250 emulator session:
a.

j-

Se@ ~o 200

k.

Click Start or Configure Session from the Program>IBM Personal
Communications folder of the Windows Start menu.

Click the AS/400 host, the LAN interface, and the IEEE 802.2 attachment.
Click Configure.

Click Configure Link.

Click Existing.

Click the configuration you saved in step 7 from the list and click Open.
Click Next.

. Verify that the System location name matches the name you specified in

step 6. Click Next.

In the Device name field, select the device name you defined in step 3. Click
Next.

In the Link station name field, select the name you defined in step 4, such
as LINK0000. Click Next.

Click Finish.
Click Save and then click Yes to overwrite the existing file.

m. Click OK to close the Customize Communication - 5250 Host window and

then click OK to close the Customize Communication window and start
the 5250 session.

9. Save the workstation profile for the 5250 session:

10.

a.
b.
c.

d.

Click Save As from the File menu on the emulator window.
Enter a file name with a .WS extension and click OK.

If you want the ability to start this session separately, click Yes to create an
icon; otherwise, click No.

Click OK.

Start the 3270 emulator session:

a.

b
c
d
e.
f
g
h

Click Start or Configure Session from the Program>IBM Personal
Communications folder of the Windows Start menu.

. Click the S/390 host, the LAN interface, and the IEEE 802.2 attachment.

. Click Configure.

. Click Configure Link.
Click Existing.

. Select the configuration you saved in step 7 from the list and click Open.

. Click Next.

. In the Device name field, select the device name you defined in step 3.
Click Next.
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11.

12.

13.

Configuring Multiple Links
i. In the Link station name field, select the name you defined in step 5, such
as LINKO0001.
j. Click Advanced.
k. Deselect APPN support and click OK.
I. Click Next.
m. Click Finish.
n. Click Save and then click Yes to overwrite the existing file.

0. Click OK to close the Customize Communication - 3270 Host window and
then click OK to close the Customize Communication window and start
the 3270 session.

Save the workstation profile for the 3270 session:
a. Click Save As from the File menu on the emulator window.
b. Enter a file name with a .WS extension and click OK.

c. If you want to start this session separately, click Yes to create an icon;
otherwise, click No.

d. Click OK.

Create a batch file to start both the 5250 session and the 3270 session at the
same time:

a. Close both running emulator sessions.

b. Click Programs > IBM Personal Communications > Utilities > Multiple
Sessions from the Windows Start menu.

c. From the list of workstation profile files, select the .WS file for the 5250
session (step 9). Click Add.

d. From the list of workstation profile files, select the .WS file for the 3270
session (step 11). Click Add.

e. Click Save As from the File menu and enter a file name with a .BCH
extension to save the batch file. Click OK.

f. Click Yes. Verify that the folder is the DESKTOP and select both check boxes.
Click OK.

g. Click Exit from the File menu.

To start the 5250 and 3270 emulator sessions together, double-click the Batch
File icon on your Desktop.
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Appendix F. Default Key Function Assignments

This appendix lists the functions assigned, by default, to each key on your

keyboard.

For more information about each function, refer to the Keyboard choice on the

Help menu.

You can change the default key assignments to the following default function
tables, by selecting Keyboard Setup from the Assist menu.

When the Keyboard Setup window appears, select one of the following choices:

* 3270 for a 3270 keyboard layout
* 5250 for a 5250 keyboard layout

* 3270+5250 for a combined keyboard layout
* VT for a DEC VT220 keyboard layout

Default Key Functions for a 3270 Layout

[Cable d shows the default key functions for PC/3270. The key used is the same for

all the supported keyboard types.

Table 3. Default Key Functions for a 3270 Layout

Function of Key Key
APL Ctrl+F8
Attention Esc
Alternate Cursor Alt+F11

Backspace <+ (Backspace)
Back Tab Shift+—» |
Back Tab Word Alt+¢

Break Break
Change Format Toggle Alt+F3
Change Screen Ctrl+PageUp
Clear Pause

Color Blue Ctrl+Shift+F5
Color Field Inherit Ctrl+Shift+F8
Color Green Ctrl+Shift+F3
Color Pink Ctrl+Shift+F2
Color Red Ctrl+Shift+F1
Color Turquoise Ctrl+Shift+F6
Color White Ctrl+Shift+F7
Color Yellow Ctrl+Shift+F4
Cursor Blink Ctrl+F10
Cursor Down V or 2(pad)
Cursor Left <« or 4(pad)
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Table 3. Default Key Functions for a 3270 Layout (continued)

Function of Key Key
Cursor Right > or 6(pad)
Cursor Select Ctrl+F9
Cursor Up 1 or 8(pad)
Delete Character Delete or
.(pad)
Delete Word Ctrl+Delete or
Ctrl+.(pad)
Document Mode Toggle Alt+F1
Dup Shift+Insert?
Edit Copy Ctrl+Insert
Edit Cut Shift+Delete
Edit Paste Shift+PageDown or
Ctrl+Shift+Insert
Edit Undo Alt+< (Backspace)
End Field Pad End
Enter Right Ctrl
Enter/Control Right Ctrl
Erase EOF End?
Erase Field Shift+End?
Erase Input Alt+End?
Fast Cursor Down Alt+{ or
Alt+2(pad)
Fast Cursor Up Alt+1 or
Alt+8(pad)
Field Mark Shift+Home?
Graphic Cursor Alt+F12
Highlighting Field Inherit Alt+3(pad)
Highlighting Reverse Alt+*(pad)
Highlighting Underscore Alt+6(pad)

Home Home or 7(pad)

Insert Insert or O(pad)

Jump Next Alt+PageUp

New Line < (Enter)

Mark Down Shift+{

Mark Left Shift+¢

Mark Right Shift+»

Mark Up Shift+1*

Move Mark Down Ctrl+{ or
Ctrl+2(pad)

Move Mark Left Ctrl+¢ or
Ctrl+4(pad)
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Table 3. Default Key Functions for a 3270 Layout (continued)

Function of Key Key

Move Mark Right Ctrl+> or
Ctrl+6(pad)

Move Mark Up Ctrl+? or
Ctrl+8(pad)

PA1 Alt+Insert?

PA2 Alt+Home?

PA3 Shift+PageUp?2

Pause Ctrl+F7

PF1 to PF12 F1 to F12

PF13 to PF24 Shift+F1 to F12

Play Ctrl+F6

PS Field Inherit Ctrl+Shift+(pad)0

Print (Local Copy) Not assigned

Quit (Device Cancel) Alt+Left Ctrl

Record Ctrl+F5

Reset/Control Left Ctrl

Response Time Monitor Ctrl+F11

Rule Ctrl+Home

Sys Request Shift+Esc

Tab Field —>| or Shift+— | (pad)

Tab Word Alt+»

Test Ctrl+PageDown

Transparency Field Inherit Ctrl+Shift+8(pad)

Transparency Opaque Ctrl+Shift+/(pad)

Word Wrap Toggle Alt+F2

Note:

2 Indicates the key on the main keyboard.

(pad)  Indicates a key on the numeric keypad.

Note: The Enhanced keyboard has some duplicated keys. The functions
of the duplicated keys are the same except when you specify a single
key. For example, Del means any Delete key, whereas Pad Del specifies
only the Delete key on the numeric keypad.

Default Key Functions for a 5250 Layout

shows the default key functions for AS/400. The key used is
the same for all the supported keyboard types.

Note: If you use AS/400 from the combined package, see 'Default Key Functiond
h lI ‘ M I I : I 77 I 4 j‘
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The default key functions for a 5250 layout are not available by
default. To make these functions available perform the procedures in

Table 4. Default Key Functions for a 5250 Layout

Function of Key Key
Alternate Cursor Ctrl+F11
Attention Esc
Backspace < (Backspace)
Backtab Shift+—» |
Backtab Word Alt+«

Begin Bold* Ctrl+B

Begin of line* Ctrl+4(pad)
Begin Underscore* Ctrl+U
Bottom of Page* Ctrl+2(pad)
Carrier Return Ctrl+Enter or

Ctrl+— (pad) or
Ctrl++ (pad)

Center Text* Ctrl+C

Clear Pause

Cursor Blink Ctrl+F10

Cursor Down V or 2(pad)

Cursor Left <« or 4(pad)

Cursor Right » or 6(pad)

Cursor Up * or 8(pad)

Delete Character Delete or .(pad)

Delete Word Ctrl+Delete or
Ctrl+.(pad)

Display Text Code Alt+Insert

Dup Shift+Insert

Edit Copy Ctrl+Insert

Edit Cut Shift+Delete

Edit Paste Shift+PageDown or
Ctrl+Shift+Insert

Edit Undo Alt+< (Backspace)

End Bold/Underscore* Ctrl+]

End of line* Ctrl+6(pad)

End of page* Ctrl+P
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Table 4. Default Key Functions for a 5250 Layout (continued)

Function of Key Key

Enter/Control Right Ctrl

Erase EOF End or 1(pad)

Erase Input Alt+End

Fast Cursor Down Alt+{ or
Alt+2(pad)

Fast Cursor Up Alt+1 or
Alt+8(pad)

Field Exit Enter(pad) or
< (Enter)

Field Mark Shift+Home

Field Minus (-) —(pad)

Field Plus (+) + (pad)

Half Index Down* Ctrl+H

Half Index Up* Ctrl+Y

Help Alt+F1

Home Home or 7(pad)

Host Print Ctrl+Pause

Insert Insert or
0 (pad)

Insert Symbol* Ctrl+A

Jump Next Alt+PageUp

Mark Down Shift+{

Mark Left Shift+¢

Mark Right Shift+-

Mark Up Shift+1

Move Mark Down Ctrl+{

Move Mark Left Ctrl+«

Move Mark Right Ctrl+»

Move Mark Up Ctrl+?

New Line Shift+< (Enter)

Next Column* Ctrl+D

Next Stop* Ctrl+N

Pause Ctrl+F7

PF1 to PF12 F1 to F12

PF13 to PF24 Shift+F1 to F12

Play Ctrl+F6

Quit Alt+Left Ctrl

Record Ctrl+F5

Required Backspace

Ctrl+< (Backspace)

Required Space*

Ctrl+Space

Required Tab*

Ctrl+—»|
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Table 4. Default Key Functions for a 5250 Layout (continued)

Function of Key Key
Reset/Control Left Ctrl

Roll Down 9(pad) or PageUp
Roll Up 3(pad) or PageDown
Rule Ctrl+Home

Stop Code* Ctrl+S

System Request Shift+Esc

Tab Field -

Tab Word Alt+»

Test Request Alt+Pause

Top of Page* Ctrl+8(pad)
Word Underscore* Ctrl+W

Note:

(pad)  indicates a key on the numeric keypad.
* indicates a Text Assist Key (SBCS only).

Setting the 5250 Keyboard Layout Default

To make the 5250 keyboard layout defaults available, do the following:

1. Select Preferences > Keyboard from the Edit menu. The Keyboard dialog box

is displayed.

2. Select the IBM Default radio button next to Current Keyboard.

3. Click OK.

Default Key Functions for the Combined Package

[Cable 5 shows the default key functions for the combined package. The key used is
the same for all the supported keyboard types.

When you use the 3270+5250 keyboard layout, the key definitions for the 3270 and
5250 layouts are combined with those listed here.

Table 5. Default Key Functions for the Combined Package

Function of Key

Key

Change Screen

Not assigned

Character Advance

Shift+BackSpace

Help Not assigned
Host Print Not assigned
PA3 Not assigned
Roll Down PageUp

Roll Up PageDown

144  Personal Communications Quick Beginnings



Key Functions and Assignments

Default Key Functions for the VT Emulator Layout

[able d shows the default key functions for VT220, VT100 and VT52. The key used
is the same for all the supported keyboard types. The VT emulator keyboard gets
selected as the default only when the "VT Component” is selected in the

installation path.

Table 6. Default Key Functions for a VT Emulator Layout

Function of Key

Key

Backspace < (Backspace)

Break Ctrl+Pause

CAN Ctrl+< (Backspace)

Cursor Down I or 2(pad)

Cursor Left <« or 4(pad)

Cursor Right > or 6(pad)

Cursor Up * or 8(pad)

Edit Copy Ctrl+Insert

Edit Cut Shift+Delete

Edit Paste Shift+PageDown or
Ctrl+Shift+Insert

Edit Undo Alt+< (Backspace)

ESC ESC

Jump Next Alt+PageUp

New Line < (Enter)

Mark Down Shift+{

Mark Left Shift+«

Mark Right Shift+-

Mark Up Shift+1

Move Mark Down Ctrl+{ or
Ctrl+2(pad)

Move Mark Left Ctrl+¢ or
Ctrl+4(pad)

Move Mark Right Ctrl+> or
Ctrl+6(pad)

Move Mark Up Ctrl+? or
Ctrl+8(pad)

PF6 to PF12 F6 to F12

PF13 to PF20 Shift+F1 to F8

Rule Ctrl+Home

Tab Field —>| or Shift+— |

VT Enter Shift+Enter(pad)

VT Find End? or
1(pad)

VT Hold Pause

VT Insert Insert or O(pad)
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Table 6. Default Key Functions for a VT Emulator Layout (continued)

Function of Key

Key

VT Next Page Down? or
3(pad)

VT Numpad 0 to VT Numpad 9 Shift+0(pad) to
Shift+9(pad)

VT Numpad Comma Shift++(pad)

VT Numpad Minus

-(pad) or Shift+-(pad)

VT Numpad Period

Shift+.(pad)

VT PF1 to VT PF4 F1 to F4

VT Prev Page Up2? or
9(pad)

VT Remove Delete or .(pad)

VT Select Home? or
7(pad)

VT User F6 to VT User F12

Ctrl+F6 to F12

VT User F13 to VT User F20

Ctrl+Shift+F1 to F8

Note:

2 Indicates the key on the main keyboard.
(pad)  Indicates a key on the numeric keypad.

Note: The Enhanced keyboard has some duplicated keys. The functions
of the duplicated keys are the same except when you specify a single
key. For example, Del means any Delete key, whereas Pad Del specifies
only the Delete key on the numeric keypad.
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Appendix G. Configuring Your Workstation for Thai, Arabic, or
Hebrew

Configuring for Thai

To configure for the Thai language:

1. Select Configure from the Communication menu.

2. Click on Session Parameters.

3. For each configuration, select Host Code-Page to be one of the following:
* 838 Thai
* 037 Thai/US

To enable Thai keyboard input:

1. Select Preferences > Keyboard from the Edit menu.

2. Select Keyboard Layout: Thai.

Note: Thai features are enabled when running on Windows 95 and Windows 98
Thai only and these Thai settings are defaults.

Configuring for Arabic or Hebrew

To set up an Arabic or Hebrew workstation, verify that you have fulfilled the

following definitions:

1. Select Configure from the Communication pulldown menu and then select
Configure once again to display the Customize Communication panel. Select
420 Arabic Speaking for Arabic or 424 Hebrew (Bulletin Code) or 803 Hebrew
(Old Code) as the host code page for Hebrew.

2. Select Preferences > Keyboard from the Edit menu. Select Arabic Speaking as
the keyboard layout for Arabic. Select 424 Hebrew (Bulletin Code) or 803
Hebrew (Old Code) as the keyboard layout for Hebrew.

3. Select Preferences > Appearance > Font from the Edit menu. For Arabic,
choose ARB3270 at the Automatic Sizing list box or at the Fixed size font
selection. For Hebrew, select HEB3270 in these same places.

4. Select Preferences > API from the Edit menu, and then select 864 as the
DDE/EHLLAPI PC Code-Page for Arabic. For Hebrew, select 862 in the same
place.

For Arabic, to set up for Numeric Swapping or Symmetric Swapping:
1. Select Preferences > Appearance > Display Setup from the Edit menu.

2. Select Swapping from the list box at the left; the settings for numerics and
symmetric characters are displayed. Changes are immediately reflected on the
active session.

Note: Numeric Swapping is a 3270-only feature. This function will not be
selectable if the session is an AS/400 session.

File Transfer

For Arabic, when transferring files between the PC and the host, the available PC
code pages are code page 864 (the IBM PC Arabic code page) and code page 1256,
the Microsoft Arabic windows code page.
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For Hebrew, when transferring files between the PC and the host, the available PC
code pages are code page 862 (the IBM PC Hebrew code page) and code page 916
for the Hebrew ISO-conforming code page.

For Code Page 1256 Only
You must set the parameter for the orientation of the HOST File. Set the parameter
as follows:

Select Preferences > Transfer from the Edit menu; on the page with the General
tab:

1. For right-to-left host file orientation, mark the HostFile Orientation box.
2. For left-to-right host file orientation, unmark the HostFile Orientation box.

Data Transfer for Arabic

When transferring SQL Data between the PC and the AS/400, the available PC
code page is code page 864 (the IBM Arabic Code page) and code page 1256 for
the Microsoft Arabic windows code page. To transfer data, do as follows:

1. Select Preferences > Transfer from the Edit menu.
Select the tab for the Translation Tables property page.
Select User Defined.

Select Host Codepage : 420 Arabic Speaking.

Select PC Codepage : 864 or 1256.

o~ DN

If code page 1256 is selected, the user must then set the parameter for the
orientation of the host file, as explained above.

Refer to the Personal Communications Reference Volume II, where the chapter
“Country Codes, Code Pages and Character Sets” shows the actual code pages,
and where the Appendix “Bidirectional Language Support” provides additional
information.
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Appendix H. Installation and Limitations of Personal
Communications on ChineseStar and RichWin

This appendix describes how to install Personal Communications on ChineseStar
(CStar) and RichWin, and the limitations of running Personal Communications on
CStar and RichWin.

Installing Personal Communications on ChineseStar and RichWin

Before installing Personal Communications, you must make sure that CStar or
RichWin is installed and running on the English version of Windows 95, Windows
98, or Windows NT. Once CStar or RichWin is installed and running, install
Personal Communications by following the steps described in the Personal
Communications CD-ROM Guide to Installation.

Limitations of Personal Communications on ChineseStar and RichWin

Running Personal Communications on CStar and RichWin has the following
limitations:

* Personal Communications supports only the GBK code page.
* RichWin does not support 3270 APL functions.
¢ CStar and RichWin support single Input Method Editor (IME) only.

For example, if you open IME in multiple windows, IME behavior is
synchronized in those windows. This is a platform limitation and it applies to
Personal Communications as well.

* Although CStar and RichWin provide many true type fonts, Personal
Communications supports only fixed pitch fonts.
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Appendix I. API Client Attachments

Communications Server for Windows NT and NetWare for SAA

Support for Communications Server

If you are connecting to a Communications Server for Windows by using the
Communications Server client or installing on the Communications Server
machine, configure Personal Communications to use the SNA API client interface.

Three different connectivities apply:

Host 390
APPC3270 or LUA3270

AS/400
5250

Support for NetWare for SAA

If you are connecting to NetWare SAA Version 2.0 or later, or IBM
Communications Server for Windows NT 5.0 or later, first install the client, then
install Personal Communications. When you select to install the API Client for
NetWare for SAA, you will be prompted to specify the type of server that you use.
In the configuration step, choose API Client for the interface and then choose the
connectivity that applies.

Refer to the API Client documentation for further information.

Load Balancing

Personal Communictions now supports load balancing for all client types. Load
balancing enables you to distribute LU 0 to 3 and LU 6.2 sessions across Personal
Communications and NetWare for SAA servers. The server advertises services
including load factors, which the clients or servers can gather and organize to
select a server.

3270 via NWSAA or IBM Personal Communications (IPX/SPX-I1P)

Load Balancing over IPX/SPX Protocols: Load balancing over IPX/SPX is a key
feature for NWSAA 2.0 and later versions. This feature dynamically balances
dependent LU2 (host-to-workstation) sessions. For LU2 sessions over IPX/SPX
connections, the load is distributed across host links on servers to a named LU2
pool.

Note: For true load balancing use a wild card ("*') Server Name and Service Name,
and use the pooled LU category with a LU-Pool Name.

Load Balancing over TCP/IP Protocols: Load Balancing over TCP/IP protocols is
a key feature for IWSAA 3.0 and CS/NT 5.1. This feature dynamically balances
dependent LU2 (host-to-workstation) sessions. For LU2 sessions over TCP/IP
connections, the load is distributed across servers within a named LU2 pool and a
named scope. That is the server with the least overall load within the named scope
supporting the named LU2 pool will satisfy a given LU2 connection request.
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Note: IBMSLP.DLL should be available on the client workstation system directory.
Refer to your Server documentation for information about where to obtain
this dynamic load library file.

Note: For true load balancing use a wild card ("*') Server Name and Service Name,
and use the pooled LU category with a LU-Pool Name.

Hot Standby over IPX/SPX and TCP/IP

The NWSAA Hot Standby feature enables to ensure that configured connections to
a host can continue to function when a critical server goes down by triggering
activation of alternative connections on a backup server. Load Balancing can be
used in conjunction with Hot Standby.

If the active session to the server goes down because of server or link failure,
Personal Communications will try to reconnect the session with the provided

backup server name, service name, or pool name.

IBMSLP.DLL should be available on the client workstation system directory.

NetWare Coexisting with LAN

If you want to use LAN via NetWare for SAA, or if you want to use NetWare
Client and the LAN connection of Personal Communications simultaneously, you
should use the NDIS driver.

The API client attachments let you use an interface provided by another
application to make a Personal Communications connection.

Three interfaces are supported:
¢ Communications Server for Windows

You can run Personal Communications on a Communications Server; it uses the
Communications Server protocol stack to connect to the host.

¢ (Client for Communications Server for Windows

For client workstations, Communications Server has a client that communicates
with the server and provides an interface that Personal Communications can
use. The client must be installed on your workstation before you install Personal
Communications.

¢ Client for NetWare for SAA

NetWare for SAA provides 'hot backup” and ’load balancing’. The requirements

are:

— The Novell NetWare client for Windows must be installed.

— The NetWare for SAA client must be installed.

— Both clients must be installed before you install Personal Communications.

— If you are using NetWare for SAA 2.0, you must create an INI file for the
NetWare for SAA client, as described in the client Readme file.

Notes:

1. You cannot install the Personal Communications SNA protocol drivers if you
intend to use the API Client interface. You can, however, use the non-SNA
attachment types, which include HPO, Home3270, TN3270, and IPX/SPX.

2. The Netware for SAA connections discussed here are separate from the
IPX/SPX connection which you can configure through the LAN interface.

The API client interface lets you make the following attachments:

— 3270 emulation
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LUA-LUO, 1, 2 or 3 via the WinRUI interface. This lets you have normal
display or printer sessions.

APPC3270

This provides 3270 display sessions (not printer) over an LU 6.2 connection to
the host.

5250 emulation
This provides 5250 display and printer sessions through APPC.
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Appendix J. Notices

This information was developed for products and services offered in the United
States. IBM may not offer the products, services, or features discussed in this
information in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or imply
that only that IBM product, program, or service may be used. Any functionally
equivalent product, program or service that does not infringe any IBM intellectual
property right may be used instead. However, it is the user’s responsibility to
evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this information. The furnishing of this information does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

500 Columbus Avenue

Thornwood, NY 10594

US.A

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:
IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS INFORMATION AS IS
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the information. IBM may make improvements
and/or changes in the product(s) and/or program(s) described in this information
at any time without notice.

Any references in this information to non-IBM documentation or non-IBM Web
sites are provided for convenience only and do not in any manner serve as an
endorsement of those documents or Web sites. The materials for those documents
or Web sites are not part of the materials for this IBM product and use of those
documents or Web sites is at your own risk.

Licensees of this program who wish to have information about it for the purpose
of enabling:(i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:
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IBM Corporation

Department TO01

Building 062

P.O. Box 12195

Research Triangle Park, NC 27709-2195

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Programming License Agreement, or any equivalent agreement
between us.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.
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Trademarks

Trademarks

The following terms are trademarks of the IBM Corporation in the United States or
other countries, or both:

400 NetView
ACF/VTAM 0Ss/2

AFP 0S5/400

AIX OfficeVision
AIXwindows OfficeVision/400
APL2 OfficeVision/MVS
APPN Open Blueprint
AS/400 PROFS

AT PS/2

Advanced Peer-to-Peer Networking PSF

AnyNet Personal System/2
Application System/400 Presentation Manager
BookManager Proprinter

CICS PRS/6000
CICS/MVS Quickwriter
CICS/VSE Quietwriter
COBOL/2 S/390

CUA SAA

Common User Access SP

Client Access Series/1

Client Access/400 System /36

Current System /370

DB2 System /38
DB2/400 System /390

DRDA Systems Application Architecture
DisplayWrite TalkLink
Distributed Relational Database Architecture ThinkPad

ExecJet VM/ESA

GDDM VM/XA

Global Network VTAM

IBM ValuePoint
IBMLink Virtual Machine/Enterprise Systems Architecture
1IN WIN-OS/2

IMS WebExplorer
InfoWindow XGA

MVS/ESA XT

MVS/XA

Microsoft, Windows, Windows NT©, and the Windows logo are trademarks of
Microsoft Corporation in the United States and/or other countries.

Tivoli is a trademark of Tivoli Systems Inc. in the United States and/or other
countries.

Java and all Java-based trademarks and logos are trademarks of Sun Microsystems,
Inc. in the United States and/or other countries.

PC Direct is a registered trademark of Ziff Communications Company and is used
by IBM Corporation under license.

UNIX is a registered trademark in the United States and other countries licensed
exclusively through X/Open Company Limited.
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C-bus is a trademark of Corollary, Inc.

ActionMedia, LANDesk, MMX, Pentium, and ProShare are trademarks or
registered trademarks of Intel Corporation in the U.S. and other countries.

Other company, product, and service names may be trademarks or service marks
of others.
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Glossary

The complete IBM Dictionary of Computing is
available on the World Wide Web at
www.networking.ibm.com/nsg/nsgmain.htm.

A

access control. In computer security, ensuring that the
resources of a computer system can be accessed only
by authorized users in authorized ways.

access control profile. A list of the access privileges
assigned to users and groups for a particular network
resource in a domain.

access priority. In the IBM Token-Ring Network, the
maximum priority a token can be given by the adapter
for transmission.

ACF/NCP. Advanced Communication Function for the
Network Control Program.

ACF/TCAM. Advanced Communication Function for
the Telecommunications Access Method.

ActiveX. A diverse set of technologies using COM.

adapter. A part that electrically or physically connects
a device to a computer or to another device.

Advanced Communications Function (ACF). A group
of IBM licensed programs, principally VTAM, TCAM,
NCP, and SSP, that use the concepts of Systems
Network Architecture (SNA), including distribution of
function and resource sharing.

Advanced Communication Function for the
Telecommunications Access Method (ACF/TCAM). A
network host communication program.

Advanced Communication Function for the Network
Control Program (ACF/NCP). A network host
communication program.

Advanced Communication Function for the Virtual
Telecommunications Access Method (ACF/'VTAM). A
network host communication program.

Advanced Peer-to-Peer Networking (APPN). An
extension to SNA featuring (a) greater distributed
network control that avoids critical hierarchical
dependencies, thereby isolating the effects of single
points of failure; (b) dynamic exchange of network
topology information to foster ease of connection,
reconfiguration, and adaptive route selection; (c)
dynamic definition of network resources; and (d)
automated resource registration and directory lookup.
APPN extends the LU 6.2 peer orientation for end-user
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services to network control and supports multiple LU
types, including LU 2, LU 3, and LU 6.2.

Advanced Peer-to-Peer Networking (APPN) end
node. A node that provides a broad range of end-user
services and supports sessions between its local control
point (CP) and the CP in an adjacent network node. It
uses these sessions to dynamically register its resources
with the adjacent CP (its network node server), to send
and receive directory search requests, and to obtain
management services. An APPN end node can also
attach to other end nodes.

Advanced Peer-to-Peer Networking (APPN) network.
A collection of interconnected network nodes and their
client end nodes.

Advanced Peer-to-Peer Networking (APPN) network
node. A node that offers a broad range of end-user
services and that can provide the following;:

* Distributed directory services, including registration
of its domain resources to a central directory server

* Topology database exchanges with other APPN
network nodes, enabling network nodes throughout
the network to select optimal routes for LU-LU
sessions based on requested classes of service

¢ Session services for its local LUs and client end
nodes

* Intermediate routing services within an APPN
network

Advanced Peer-to-Peer Networking (APPN) node. An
APPN network node or an APPN end node.

advanced program-to-program communication
(APPC). (1) The general facility characterizing the LU
6.2 architecture and its various implementations in
products. (2) Sometimes used to refer to the LU 6.2
architecture and its product implementations as a
whole, or to an LU 6.2 product feature in particular,
such as an APPC application programming interface.

AID key. A control key that generates a host attention
interrupt.

alert. (1) A message sent to a management services
focal point in a network to identify a problem or an
impending problem. (2) In SNA management services
(SNA/MS), a high priority event that warrants
immediate attention.

alias name. A name that is defined in one network to
represent a logical unit name in another interconnected
network. The alias name does not have to be the same
as the real name; if these names are not the same,
translation is required.
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American National Standard Code for Information
Interchange (ASCII). A character set standard
established by the American National Standards
Institute, using a set of 7-bit binary-coded characters (8
bits including parity check). ASCII is used for
information interchange among data processing
systems, data communication systems, and associated
equipment. An extended, 8-bit version of this code is
used in the personal computer. It consists of control
characters and graphic characters in addition to the
7-bit ASCII characters. See also extended binary-coded
decimal interchange code.

American National Standards Institute (ANSI). An
organization consisting of producers, consumers, and
general interest groups, that establishes the procedures
by which accredited organizations create and maintain
voluntary industry standards in the United

States. (A)

ANSI. American National Standards Institute.

AnyNet product family. A group of IBM products that
implement the multiprotocol transport networking
(MPTN) architecture, thus enabling application
programs to communicate independently of the
underlying network transport protocol.

API. Application programming interface.

APL. A programming language requiring the use of a
special keyboard to represent various operator symbols.

APPC. Advanced program-to-program
communications.

application. A collection of software components used
to perform specific types of user-oriented work on a
computer.

application program. (1) A program written for or by
a user that applies to the user’s work, such as a
program that does inventory control or payroll. (2) A
program used to connect and communicate with
stations in a network, enabling users to perform
application-oriented activities.

application programming interface (API). (1) The set
of programming language constructs or statements that
can be coded in an application program to obtain the
specific functions and services provided by an
underlying operating system or service program. (2) In
VTAM, the language structure used in control blocks so
that application programs can reference them and be
identified to VTAM.

application transaction program. A program written
for or by a user to process the user’s application; in an
SNA network, a user of a type 6.2 logical unit. Contrast
with service transaction program.

APPN. Advanced Peer-to-Peer Networking.
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APPN end node. See Advanced Peer-to-Peer Networking
(APPN) end node.

APPN network node. See Advanced Peer-to-Peer
Networking (APPN) network node.

ASCII (American National Standard Code for
Information Interchange). The standard code, using a
coded character set consisting of 7-bit coded characters
(8 bits including parity check), that is used for
information interchange among data processing
systems, data communication systems, and associated
equipment. The ASCII set consists of control characters
and graphic characters. (A)

ASYNC. Asynchronous.

asynchronous (ASYNC). (1) Pertaining to two or more
processes that do not depend upon the occurrence of
specific events such as common timing signals. (T) (2)
Without regular time relationship; unexpected or
unpredictable with respect to the execution of program
instructions.

Asynchronous Data Link Control (ASYNCH). A
discipline for managing asynchronous, serial-by-bit
information transfer over a line connection.

asynchronous transmission. A data communication
method wherein character strings of variable length are
transmitted serially at a variable transmission rate.
Each character or defined block of characters has a
constant transmission duration.

atom. Represents a character string that has been
reduced to a unique integer value.

attention identifier. See AID key.

attachment. A communication link used by Personal
Communications to connect a personal computer to a
host system, consisting of an adapter and controlling
software.

audit trail. A history of network activity on a server.

AUTOEXEC.BAT file. In the DOS operating system, a
batch file that resides in the root directory of the boot
drive. AUTOEXEC.BAT contains commands that DOS
executes every time the PC is booted.

automatic access utility. A utility that allows you to
create and edit the files that control the automatic-dial,
automatic-logon, and modem control programs.

autoskip. A field defined as protected and numeric.
Causes the cursor to skip to the next unprotected field.

B

backup diskette. A diskette that contains information
copied from a Personal Communications diskette.



base-color mode. The mode in which a terminal
operates if the host system does not supply color
information.

Basic Input/Output System (BIOS). Code that
controls basic hardware operations, such as interactions
with diskette drives, hard disk drives, and the
keyboard.

binary. Pertaining to the base two system of numbers.
The binary digits are 0 and 1. Executable files are
generally in binary format rather than the character
string format that text files are composed of.

BIOS. (1) Basic Input/Output System. (2) See also
NetBIOS.

bis. A suffix used to designate the second version of a
standard, as in ITU-T Recommendation V.25 bis.

bit map. A representation of an image by an array of
bits.

C

Caps Lock. The personal computer keyboard mode
entered after the Caps Lock key is pressed. This mode
is indicated by a capital A in the operator information
area (OIA). When the Shift key is pressed while in this
mode, Caps Lock is temporarily discontinued and the
OIA indicator changes. Pressing the Shift key again
returns the Caps Lock mode.

character cell. The maximum physical boundary of a
character on a display screen.

character set. A finite group of characters defined for
a keyboard or output device.

CICS/VS. Customer Information Control System for
Virtual Storage.

code page. (1) An assignment of graphic characters
and control function meanings to all code points; for
example, assignment of characters and meanings to 256
code points for an 8-bit code, assignment of characters
and meanings to 128 code points for a 7-bit code. (2) A
particular assignment of hexadecimal identifiers to
graphic characters.

COM. Component Object Model.

Component Object Model. An architecture developed
by Microsoft defining a common paradigm for
interaction among software components independent of
source language.

Common Programming Interface for Communications
(CPI-C). An evolving application programming
interface (API), embracing functions to meet the
growing demands from different application
environments and to achieve openness as an industry
standard for communications programming. CPI-C

provides access to interprogram services such as (a)
sending and receiving data, (b) synchronizing
processing between programs, and (c) notifying a
partner of errors in the communication.

configuration. (1) The manner in which the hardware
and software of an information processing system are
organized (2) In Personal Communications, the
arrangement of personal computers connected to one or
more host systems by one or more attachment types.

configuration file. A file that specifies the
characteristics of a system device or network.

continuous carrier. A characteristic of the modem
used in an SDLC type of attachment; frequency capable
of being modulated or impressed with a second
(informative carrier) signal.

control unit. A device that manages the flow of data
between personal computers used with Personal
Communications and a host system.

conversation. A logical connection between two
transaction programs using an LU 6.2 session.
Conversations are delimited by brackets to gain
exclusive use of a session.

CP. Control point.

CPI-C. Common Programming Interface for
Communications.

CP name. A network-qualified name of a control point
(CP), consisting of a network ID qualifier identifying
the network (or name space) to which the CP’s node
belongs, and a unique name within the scope of that
network ID identifying the CP. Each APPN or LEN
node has one CP name, assigned to it at
system-definition time.

CSD. Corrective service diskette.

Customer Information Control System for Virtual
Storage (CICS/VS). An IBM licensed program that can
be used in a communications network.

customization. The process of configuring one or
more personal computers connected to a host system
by the SDLC, LAN, ASYNCH, X.25, DFT, or other
attachment. Customization precedes Personal
Communications installation and includes the
definition of the sessions to be carried out by Personal
Communications.

D

DBCS. Double-byte character set

default. A value, attribute, or option that is assumed
when no differing selection is made.
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definition file. A file loaded by default that contains
keyboard and screen color characteristics that can be
adapted for a particular session. The lines of a
definition file must be coded according to a strict
layout.

delimiter. In the IBM Token-Ring Network, a bit
pattern that defines the limits of a frame or token.

dependent LU. See SSCP-dependent LU.

dependent LU requester (DLUR). An APPN end node
or an APPN network node that owns dependent LUs,
but requests that a dependent LU server provide the
SSCP services for those dependent LUs.

dependent LU server (DLUS). An APPN network
node that provides SSCP services for a dependent LU
in its own or another APPN network. Contrast with
dependent LU requester.

DFT. See distributed function terminal.

diacritic key. A key that allows a character to be
entered without the cursor position being changed.
When you enter an accent mark or a tilde, for example,
the cursor does not advance to the next position until
you enter the corresponding alphabetic character.

dial-up line. See switched line.

direct memory access (DMA). The system facility that
allows a device on the Micro Channel bus to get direct
access to the system or bus memory without the
intervention of the system processor.

distributed function terminal (DFT). A terminal that
supports multiple concurrent logical terminal sessions.

distributed function terminal attachment. The
connection of a personal computer with an IBM 3174 or
3274 Control Unit using a coaxial cable and software
that provides DFT capabilities.

directory. A named hierarchical grouping of files in a
file system.

DLUR. Dependent LU requester.
DLUS. Dependent LU server.
DMA. See direct memory access.

domain. A set of servers that allocate shared network
resources within a single logical system.

DOS session. A session in which a personal computer
operates as a stand-alone computer, running under
Disk Operating System (DOS). See host session.

download. The transfer of a file from a host system to
a personal computer.
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double-byte character set (DBCS). A set of characters
in which each character is represented by 2 bytes.
Languages such as Japanese, Chinese, and Korean,
which contain more symbols than can be reqpresented
by 256 code points, require double-byte character sets.
Because each character requires 2 bytes, the typing,
display, and printing of DBCS characters requires
hardware and programs that support DBCS. Contrast
with single-byte character (SBCS).

DRDA. Distributed Relational Database Architecture.

dynamic data exchange (DDE). A protocol that allows
applications to exchange data.

E

EBCDIC. See extended binary-coded decimal interchange
code.

ECE. See Enhanced Connectivity Facilities.
EGA. See enhanced graphics adapter.

EHLLAPI. See Emulator High-Level Language
Application Programming Interface.

EIA 232. A standard established by the Electronic
Industries Association for direct linkage for serial
binary data transfer between a computer and
peripheral equipment, such as a modem or printer. See
V.24.

EMM. See Expanded Memory Manager.
EMS. See Expanded Memory Specification.

emulator. A program that allows a device to operate
as if it were a different type of device. Personal
Communications, for example, allows supported
personal computers and printers to operate as if they
were 3270-series or 5250-series workstations.

Emulator High-Level Language Application
Programming Interface (EHLLAPI). A programming
interface that permits workstation-based programs to
access host computer presentation space.

end node (EN). See Advanced Peer-to-Peer Networking
(APPN) end node and low-entry networking (LEN) end
node.

Enhanced Connectivity Facilities (ECF). An IBM
communication utility that provides the ability to share
resources between workstations and host systems.

enhanced graphics adapter (EGA). An adapter, such
as the IBM Enhanced Graphics Adapter, that provides
high-resolution graphics, allowing the use of a color
display for text processing as well as graphics
applications.

EOF. End of Field



EOT. End of Text

error log. A file that stores error information for later
access.

Ethernet. A 10-Mbps baseband local area network that
allows multiple stations to access the transmission
medium at will without prior coordination, avoids
contention by using carrier sense and deference, and
resolves contention by using collision detection and
delayed retransmission. Ethernet uses carrier sense
multiple access with collision detection (CSMA /CD).

exit function. A function that allows the user to
switch from a host session to a DOS session. The key
sequence for exit is Ctrl+End.

Expanded Memory Manager (EMM). A standard
device driver that manages expanded memory in 16-KB
logical pages. The EMM maps a set of logical pages
into a page frame using the physical address space that
is available in memory above 640 KB, storing the map
into conventional memory. The application then
accesses the expanded memory thus created as though
it were conventional memory.

Expanded Memory Specification (EMS). A
specification for accessing memory above the
conventional DOS memory address space, 0-640 KB.
See Expanded Memory Manager, LIM EMS 3.2, and LIM
EMS 4.0.

extended binary-coded decimal interchange code
(EBCDIC). The standard code, using a character set
consisting of 8-bit coded characters, used by Personal
Communications for information interchange between
personal computers and a host system. See also
American National Standard Code for Information
Interchange.

extended-color mode. The mode in which a terminal
operates if the host system supplies color information.

extended error code. An 8-byte data string returned
by Query System generated by an internal system error
that is used by service personnel for diagnosis.

extended memory. Memory above 1 MB that can be
accessed and used by 80286 and 80386** (or greater)
CPUs to run applications in protected mode. PC DOS
does not normally access memory above 640 KB. This
memory is useful only for applications that are written
specifically to use extended memory. Successful use of
extended memory by an application usually requires
the use of an 80386 or greater CPU, which provides
machine instructions to handle the use of extended
memory.

external resource. A file, directory, or device supplied
by a server outside the current domain.

F

field. (1) An area in a record or panel used to contain
data. (2) In the IBM 3270 data stream, a group of
consecutive positions on a presentation space having
similar characteristics that are defined by a field
attribute byte at the beginning of the field.

field delimiters. Symbols (often brackets) that indicate
the limits of a data entry field.

file mode. In VM/CMS, the third field of the file
identifier, which indicates the assigned virtual disk
wherein the file resides.

file type. In VM/CMS, the second field of the file
identifier. The file type can be arbitrary, or of
significance to the system (for example, SCRIPT,
LIST3270, and NOTEBOOXK file types).

fixed disk. See hard disk.

flag. A character or bit sequence that marks an
occurrence or boundary, such as the end of a word or
the beginning or end of a data transmission block.

frame. A data structure (data frame) composed of
fields meeting the field specifications of a type of
communication protocol. Frames are used to control
data transfer across a data link.

In SDLC, a frame is a sequence of bits delimited by an
opening and closing flag. In X.25 packet switching data
networks, frames are composed of 8-bit byte sequences
delimited by beginning and ending flags; the frames in
X.25 control various functions, data transfer, and
transmission checking.

G

gateway. A station in a local area network through
which a connection to a host system or a separate
network is established.

gateway status utility. A utility that allows a user to
check the status of sessions in a gateway network.

GDDM. See Graphical Data Display Manager.

GDDM-PCLK. A personal computer application
program that supports host GDDM graphics
applications. This application requires an LLAPI
interface for PC/3270.

Graphical Data Display Manager (GDDM). An IBM
host function that processes text and graphics for
output to a display, printer, or graphic output device.
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H

hard disk. A rigid-magnetic disk such as the internal
disks used in the system units of personal computers

and in external hard disk drives (also known as fixed
disks).

High-Level Language Application Programming
Interface (HLLAPI). A software product that supports
interaction between a host program and an application
program running on a personal computer in terminal
emulation (usually 3270 terminal emulation).

High-Performance Routing (HPR). An addition to
APPN that enhances data-routing performance and
session reliability.

HLLAPI. See High-Level Language Application
Programming Interface.

host address. A LAN address used by the host
controller.

host code page. The character code page used by the
host system to which a gateway connects.

host print. A printer session on a local personal
computer directed by the host system.

host profile. A configuration profile that identifies a
gateway by name, and establishes LU addresses and
types for connected logical units.

host session. A logical connection that enables a

personal computer to communicate with a host system.
A session can be identified by LU address, LT number,
or session ID. See DOS session. See also logical terminal.

host short name. See short name.

host system. In Personal Communications, the
computer linked to one or more personal computers by
the SDLC, LAN, ASYNCH, X.25, or DFT attachment.

hot key. A keystroke or keystroke combination that
initiates the hotkey function. See hotkey function.

hotkey function. A function that allows you to switch
to the next logical terminal or DOS, on whichever
screen it last appeared, without exiting the current
application.

HPR. High-Performance Routing.

IBM PC Network. A local area network providing
peer-to-peer communication among IBM personal
computers, allowing them to share resources. It utilizes
carrier sense multiple access/collision detect

(CSMA /CD) protocol and supports a data transmission
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rate of 2 million bits per second. Broadband and
baseband versions are available.

IBM Token-Ring Network. A general-purpose
baseband token-ring local area network for
interconnecting information processing equipment at a
local site. It uses a token-ring access protocol and
supports a data rate of either 4 or 16 million bits per
second. It conforms to the IEEE 802.5 (token-ring) and
IEEE 802.2 (logical link control) standards.

IBM NCP Packet Switching Interface Program
(NPSI). A network host communication product that
runs in an IBM 3745 communications controller and
enables it to connect to an ITU-TS X.25
recommendation packet-switching data network.

idles. In a token-ring network, the signals sent when
neither frames nor tokens are being transmitted.

IEEE. See Institute of Electrical and Electronics Engineers.

IEEE 802.2. An IEEE standard for logical link control
in local area networks.

initial program load (IPL). The initialization
procedure that starts an operating system, or the
process of loading programs and preparing a system to
run jobs.

installation. In Personal Communications, the process
of loading microcode from the Personal
Communicationsdiskettes.

Institute of Electrical and Electronics Engineers
(IEEE). An organization that establishes and promotes
standards in related industries.

integrated services digital network. A digital
end-to-end telecommunication network that supports
multiple services including, but not limited to, voice
and data.

interleave. In Personal Communications, to arrange
parts of a transmission sequence so that they are
interspersed with parts of one or more other
transmission sequences of the same nature, with each
sequence retaining distinct meaning and identity. See
also packet-switching data network and X.25
Recommendation.

International Telecommunication Union (ITU). The
specialized telecommunication agency of the United
Nations, established to provide standardized
communication procedures and practices, including
frequency allocation and radio regulations worldwide.

interrupt level. A number assigned to an interrupt to
indicate priority. The interrupt with the lowest number
has the highest priority.

IPL. See initial program load.

ISDN. Integrated services digital network.



ITU-TS. See ITU-T.

ITU-T. International Telecommunication Union -
Telecommunication Standardization Sector. The part of
the International Telecommunication Union (ITU) that
is reponsible for developing recommendations for
telecommunications. (Formerly known as the CCITT.)

J

jump. To start the jump function.

jump function. A switch to the logical terminal
session specified.

K

key assignment. The character, numeral, symbol, or
function generated when a keyboard key is pressed. All
keys have default assignments that can be customized.

keyboard definition. Definitions of keyboard keys as
stored on one of the Personal Communications
diskettes.

keyboard template. An overlay placed on a keyboard
to explain the function of each key.

L

LAN. See local area network.
leased line. See nonswitched line.
LEN. Low-entry networking.

LEN node. A node that supports independent LU
protocols but does not support CP-CP sessions. It may
be a peripheral node attached to a boundary node in a
subarea network, an end node attached to an APPN
network node in an APPN network, or a
peer-connected node directly attached to another LEN
node or APPN end node. See also low-entry networking
(LEN) end node.

LIM EMS 3.2. An expanded memory specification
agreed to in 1984 by the computer software
manufacturers Lotus**, Intel**, and Microsoft** to access
memory above the DOS conventional memory area,
0-640 KB, using an EMM device driver. LIM EMS 3.2
allows an application to store up to 8 MB of data in
expanded memory, in 512 logical pages of 16 KB. The
EMS 3.2 expanded memory manager maps up to 64 KB
of expanded memory in the PC BIOS memory area. See
also LIM EMS 4.0 and Expanded Memory Manager.

LIM EMS 4.0. An extended expanded memory
specification (EEMS) pioneered by AST** Research
Corporation as an extension to LIM EMS 3.2 to permit
expanded memory to be used for directly executing
programs through multitasking, and to expand the

areas accessible for mapping expanded memory
beyond the conventional memory barrier, up to 1024
KB. The EEMS was further improved and defined by
agreement of Lotus, Intel, and Microsoft corporations to
better support windowing and multitasking operating
environments. With appropriate hardware support, LIM
EMS 4.0 supports up to 32 MB of expanded memory.
Its EMM can create page frames up to 896 KB, and up
to 2048 logical pages of 16-KB memory.

line speed. The speed at which data is transferred
over an analog (telephone) line. Line speeds depend on
the quality of the line.

local area network (LAN). (1) A computer network
located on a user’s premises within a limited
geographical area. Communication within a local area
network is not subject to external regulations; however,
communication across the LAN boundary may be
subject to some form of regulation. (T) (2) A network
in which a set of devices are connected to one another
for communication and that can be connected to a
larger network. (3) See also Ethernet and foken ring.

local copy. A printer session initiated by a personal
computer user or host that reproduces a presentation
space with all supported graphics.

local LU. A logical unit not distributed over the LAN,
but controlled by a gateway personal computer. This is
normally a physical device such as a workstation,
printer, or terminal.

logical terminal (LT). (1) A terminal with a name
related to one or more physical terminals. (2) The
definition of a specific 3270 terminal emulation session.
See also host session.

logical terminal ID. See logical terminal identifier.

logical terminal identifier (LT ID). An identifier for
the LU type specified in the gateway host profile. In
Personal Communications, up to 8 (unchangeable) IDs
can be displayed. See session ID.

logical terminal number. A number used to identify
DEFT host sessions. A 3270 control unit controls some
number of sessions with the host. The control unit then
assigns from 1 to 5 of these sessions to a particular
coaxial connection and assigns each session an LT
number from 1 to 5.

logical unit (LU). A type of network accessible unit
that enables users to gain access to network resources
and communicate with each other.

logon. The process of accessing a domain and
assuming a user ID.

LT. See logical terminal.

LU. Logical unit.
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LU 2. A type of LU for an application program that
communicates with a single display workstation in an
interactive environment, using the SNA 3270 data
stream.

LU 3. A type of LU for an application program that
communicates with a single printer, using the SNA
3270 data stream.

LU 6.2. A type of LU that supports sessions between
two applications in a distributed data processing
environment using the SNA general data stream, which
is a structured-field data stream, or a user-defined data
stream.

LU address. In Personal Communications, a number
from 02 to 254 assigned by the host to represent the
remote partner in an SNA session.

M

MAN. Metropolitan area network.
mantissa. The decimal part of a common logarithm.

mark. A symbol or sequence of symbols that indicate
the beginning or end of a field, word, data item, or
data set.

menu. A list of available operations. You select which
operation you want from the list.

messaging name. A name under which messages can
be received.

metropolitan area network (MAN). A network
formed by the interconnection of two or more networks
which may operate at higher speed than those
networks, may cross administrative boundaries, and
may use multiple access methods. (T) Contrast with
local area network (LAN) and wide area network (WAN).

modem. A serial data translator that converts digital
signals into analog signals at transmission, and on
reception, converts analog signals back into digital
signals. Modems are used primarily for telephonic
computer communication. Synonymous with
modulator/demodulator.

multiplexer (mux). A device capable of interleaving
events of two or more activities, or of spreading the
events of an interleaved sequence of the multiple
activities.

mux. See multiplexer.

MVS. See Operating System/Virtual Storage Version 2.
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N

NA. Not applicable. When this appears in a calling
parameter position, it means that PC400 EHLLAPI does
not require this parameter to perform the specific
function.

NCB. See network control block.
netID. See network identifier.

NetBIOS. Network Basic Input/Output System. In
Personal Communications, an interface for application
programs (API) between a LAN adapter and a
token-ring network.

netname. The name used to identify a shared resource
on the network.

network. (1) An arrangement of nodes and connecting
branches. (T) (2) A configuration of data processing
devices and software connected for information
interchange. (3) A group of nodes and the links
interconnecting them.

network accessible unit (NAU). A logical unit (LU),
physical unit (PU), control point (CP), or system
services control point (SSCP). It is the origin or the
destination of information transmitted by the path
control network. Synonymous with network addressable
unit.

network address. (1) According to ISO 7498-3, a name,
unambiguous within the OSI environment, that
identifies a set of network service access points. (2) In a
subarea network, an address, consisting of subarea and
element fields, that identifies a link, link station,
physical unit, logical unit, or system services control
point. Subarea nodes use network addresses; peripheral
nodes use local addresses or local-form session
identifiers (LFSIDs). The boundary function in the
subarea node to which a peripheral node is attached
transforms local addresses or LFSIDs to network
addresses and vice versa. Contrast with network name.

network addressable unit (NAU). Synonym for
network accessible unit.

network administrator. A person who manages the
use and maintenance of a network.

network application program. In the IBM Token-Ring
Network, a program used to connect and communicate
with adapters on a network, enabling users to perform
application-oriented activities and to run other
application programs.

network control block (NCB). A part of the network
control program that controls the resources used by the
communication network in a LAN attachment.

network name. The symbolic identifier by which users
refer to a network accessible unit, a link, or a link



station within a given subnetwork. In APPN networks,
network names are also used for routing purposes.
Contrast with network address.

network node (NN). See Advanced Peer-to-Peer
Networking (APPN) network node.

network node server. An APPN network node that
provides network services for its local LUs and client
end nodes.

node. (1) In a network, a point at which one or more
functional units connect channels or data circuits. (I)
(2) Any device, attached to a network, that transmits
and receives data. (3) An endpoint of a link or a
junction common to two or more links in a network.
Nodes can be processors, communication controllers,
cluster controllers, or terminals. Nodes can vary in
routing and other functional capabilities.

non-return-to-zero inverted encoding (NRZI). A data
encoding method that ensures correct synchronization
of information in an analog data stream transmission.

nonswitched line. A communication line (such as is
used in the SDLC attachment) that is permanently
connected and does not require dialing to establish
communication. Contrast with switched line.

NPSI. See IBM NCP Packet Switching Interface Program.
NRZI. See non-return-to-zero inverted encoding.

NUL. A transmission control character used as a filler
or for sequence control in network communication.

Num Lock. The keyboard mode entered after the
Num Lock key is pressed. When the Shift key is
pressed while in this mode, Num Lock is temporarily
discontinued.

O

ODBC. Open Data Base Connectivity. An interface
that allows applications to access data from many
sources using Structured Query Language (SQL) as a
standard for accessing data.

OIA. See operator information area.

OIA indicator. Characters or symbols in the operator
information area providing information about network,
workstation, gateway, or interface status. See also
operator information area.

operator information area (OIA). The bottom line of a
session window that shows information on status and
Personal Communications connections.

OLE. Object Linking and Embedding; OLE is a
COM-based technology that allows for the creation of
compound documents.

Operating System/Virtual Storage Version 2
(OS/VS2). A set of commands, subcommands, and
operands recognized by the host computer.
Synonymous with MVS.

P

packet. A discrete unit of information including
addressing and sequence information that can be sent
interleaved with other packets of the same and other
transmission sequences. Packets sent over X.25 virtual
circuits always follow the same route and arrive in the
order they were sent.

packet assembler/disassembler (PAD). A functional
unit that enables data terminal equipment (DTEs) not
equipped with an X.25 interface to use a
packet-switching data network. On the most common
PAD, data from ASCII start/stop DTEs is tranformed to
and from X.25 packets. See also packet, packet-switching
data network.

packet-switching data network (PSDN). A data
transmission system consisting of one or more host
systems and one or more network stations that
communicates using packets of information. The data is
sent in interleaved packets to distribute the flow of
information and maximize the data transmission
capabilities of the network. X.25 is a packet-switching
data network communication protocol. See X.25
network.

PAD. See packet assembler/disassembler.

parity bit. A binary digit appended to a group of
binary digits as needed to make the sum of all the
digits either odd (odd parity) or even (even parity).

PC Network. See IBM PC network.

PCSDIAL. A program that automatically dials a host
number, permitting a fast connection.

permanent virtual circuit (PVC). An X.25 virtual
circuit that is permanently established (by subscription)
and, therefore, needs no call-establishment protocol.
Contrast with switched virtual circuit.

physical unit (PU). The component that manages and
monitors the resources (such as attached links and
adjacent link stations) associated with a node, as
requested by an SSCP via an SSCP-PU session. An
SSCP activates a session with the physical unit in order
to indirectly manage, through the PU, resources of the
node such as attached links. This term applies to type
2.0, type 4, and type 5 nodes only.

physical unit identifier (PUID). In the gateway status
utility, five hexadecimal digits used to identify the
network station to the gateway.

PIU. Path information unit.
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pooled LUs. Logical units that share host sessions in a
common pool to save system resources.

POR. See power-on reset function.

port number. In DFT attachment, the logical ports
assigned to a terminal by a control unit.

power-on reset (POR) function. A function that
allows the user to reset all logical terminals. The key
sequence for POR is Ctrl+Pause using the Enhanced or
Space Saving keyboards. Otherwise, the sequence is
Ctrl+F2.

preallocated LUs. Logical units only available to a
specified network station.

presentation space. The host display space for the
window.

presentation space position parameter. One of the
four parameters that you must specify for some
EHLLAPI functions. A position in the presentation
space from 1 to 3564.

printer utility. A utility that allows users to check the
status of the printers in their network.

private application. An application maintained for use
only on one computer or user, that is not available on
the network for other users.

program operator. The EHLLAPI program that
performs and monitors activities in a workstation
presentation space.

programmed symbol set (PS). A set of fonts that can
be system-defined or defined by the user and to which
a code can be assigned.

protected field. A field that holds data for viewing;
the data cannot be changed (at the current screen) by
the user.

protocol. A specification for the format and timing of

data exchanged between communicating systems. Also,
the set of rules governing the operation of units of the

communication system to facilitate communication.

PSDN. See packet-switching data network.

PSID. Presentation Space Identifier; a short
one-character or one-letter name of the presentation
space.

PU. Physical unit. See also physical unit identifier.

public application. An application shared among
users on a network.

PUID. See physical unit identifier.

PVC. See permanent virtual circuit.
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Q

queue. A list of pending tasks for a computer or
server to execute in order.

R

redefinition file. See definition file.

request. A message unit that signals initiation of a
particular action or protocol. For example, Initiate-Self
is a request for activation of an LU-LU session.

requester. A computer that accesses shared network
resources through a server.

resource. A directory (files resource) or device used by
computers on a network.

response time monitor. A function that measures and
displays the host response time

RS-232C. See EIA 232 and V.24.

RSAP. Remote service access point. See service access
point.

run book. A supplemental guide, controlled by a
system administrator, that describes the implementation
and usage of a specific system configuration.

S

SAP. See service access point.

SAS. See session active screen.

SBCS. See single-byte character set.

SDLC. See Synchronous Data Link Control.

SDLC command. The control information in the
C-field of the link header, sent from a primary station
to a secondary station.

Server-Requester Programming Interface (SRPI). An
IBM application programming interface (API) used by
requester and server programs to communicate with
the personal computer or host routers.

service access point (SAP). The gateway address of
the controller. An SAP provides a point to link the
controller to the host system.

service coordinator. The person in your organization
responsible for answering hardware and software
computing questions.

service transaction program. Any IBM-supplied
transaction program running in a network accessible
unit. Contrast with application transaction program.



session. (1) A logical connection between a server and
a requester that was initiated by a successful request
for a shared resource. See also host session and DOS
session. (2) A logical connection between two network
addressable units that can be activated, tailored to
provide various protocols, and deactivated, as
requested.

session active screen (SAS). The display that is active
for the current communication session. See also
next-session-active-screen function.

session ID. An alphabetic ID (a through h) assigned
by Personal Communications to each session or screen.
This applies to all types of host sessions and is used in
file transfers. See also short name.

shared resource. A directory or device made available
to users on a network. A shared resource is attached to
a server, but it is not attached to the requesters that use
them.

Shift Lock. The personal computer keyboard mode
entered after the Shift Lock key is pressed. In this
mode, the keyboard performs the function printed on
the upper half of the keytop. Press the Shift key to
cancel the Shift Lock mode.

short name. In Personal Communications, a character
displayed in column 7 of the operator information area
that shows the session ID. See also session ID and
operator information area.

single-byte character set. A character set in which
each character is represented by a one-byte code.

SMS Install. The Microsoft Systems Management
Server (SMS) product provides for the remote
installation and uninstallation of Personal
Communications.

SNA. See Systems Network Architecture.

SNA network. The part of a user-application network
that conforms to the formats and protocols of Systems
Network Architecture. It enables reliable transfer of
data among users and provides protocols for
controlling the resources of various network
configurations. The SNA network consists of network
accessible units (NAUs), boundary function, gateway
function, and intermediate session routing function
components; and the transport network.

Sockets over SNA. The AnyNet Sockets over SNA
access node function of Personal Communications
enables TCP/IP application programs using the
WinSock interface to communicate over an SNA
network.

source diskette. In a diskette copying procedure, the
diskette from which information is read.

SRPI. Server-Requester Programming Interface.

SSCP. System services control point.

SSCP-dependent LU. An LU that requires assistance
from a system services control point (SSCP) in order to
initiate an LU-LU session. It requires an SSCP-LU
session.

SVC. See switched virtual circuit.

switched line. A telecommunication line in which the
connection is established by dialing. See also switched
virtual circuit. Contrast with nonswitched line.

switched virtual circuit (SVC). An X.25 virtual circuit
that is dynamically established when needed. The X.25
equivalent of a switched line. Also known as a virtual
call. Contrast with permanent virtual circuit (PVC).

switch-screen function. A function that switches
keyboard control to the other screen, if two screens are
used. The key sequence for switch-screen is Alt+Tab.

Synchronous Data Link Control (SDLC). A discipline
for managing synchronous, code-transparent,
serial-by-bit information transfer over a line connection.
Transmission exchanges can be duplex (in both
directions at the same time) or half-duplex (in either
direction, one direction at a time) over switched lines
or direct lines.

system services control point (SSCP). A component
within a subarea network for managing the
configuration, coordinating network operator and
problem determination requests, and providing
directory services and other session services for users
of the network. Multiple SSCPs, cooperating as peers
with one another, can divide the network into domains
of control, with each SSCP having a hierarchical control
relationship to the physical units and logical units
within its own domain.

Systems Network Architecture (SNA). The
description of the logical structure, formats, protocols,
and operational sequences for transmitting information
units through, and controlling the configuration and
operation of, networks. The layered structure of SNA
allows the ultimate origins and destinations of
information, that is, the users, to be independent of and
unaffected by the specific SNA network services and
facilities used for information exchange.

T

target diskette. In a diskette or storage copying
procedure, the diskette onto which information is
written.

template. See keyboard template.
terminal emulator. See emulator.

terminal operator. The human user of a EHLLAPI
application program. Contrast with program operator.
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Time Sharing Option (TSO). A set of commands,
subcommands, and operands recognized by the host
computer.

token ring. (1) According to IEEE 802.5, network
technology that controls media access by passing a
token (special packet or frame) between media-attached
stations. (2) A FDDI or IEEE 802.5 network with a ring
topology that passes tokens from one attaching ring
station (node) to another. (3) See also local area network
(LAN).

token-ring network. (1) A ring network that allows
unidirectional data transmission between data stations,
by a token passing procedure, such that the transmitted
data return to the transmitting station. (T) (2) A
network that uses a ring topology, in which tokens are
passed in a circuit from node to node. A node that is
ready to send can capture the token and insert data for
transmission.

trace size. See trace table.

trace table. A storage area that contains the records of
all Personal Communications operations. The trace
information can either be directed to the standard
output destination, or it can be redirected to a file.

transaction program (TP). A program that processes
transactions in an SNA network. There are two kinds of
transaction programs: application transaction programs
and service transaction programs. See also conversation.

transferring files. Sending files from a personal
computer to a host system or vice versa. See download
and upload.

TSO. See Time Sharing Option.

U

UID. See user identifier.

unprotected field. A field that is available for the user
to enter or modify data.

upload. The transfer of a file from a personal
computer to a host system.

user ID. See user identifier.

user identifier (UID). A name that uniquely identifies
a user on a network or system.

user profile. A file containing values for setting up the
user environment, and that can be automatically
accessed when a user logs on.

utility programs. Programs that support operations of
Personal Communications, such as file transfer and
keyboard redefinitions.
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V

V.24. An ITU-T recommendation that defines
interchange circuits between data terminal equipment
(DTE) and data circuit-terminating equipment (DCE).
When combined with the specification of electrical
characteristics given in ITU-T recommendation V.28, it
specifies a modem interface for data rates below 20
kilobits per second (which is equivalent to EIA 232).

V.35. An ITU-T recommendation that defines
interchange circuits and electrical characteristics
between data terminal equipment (DTE) and data
circuit-terminating equipment (DCE) at various data
rates. Originally defined for wideband modems, but
now commonly used for various data network services.

valid key. A key that is recognized by the host
session.

VB Scripting. An interface used with Personal
Communications to define and execute Visual Basic
scripts.

VGA. See video graphics adapter.

video graphics adapter (VGA). A computer adapter
that provides high-resolution graphics and a total of
256 colors. See also enhanced graphics adapter (EGA).

virtual machine (VM). A time sharing control
program.

VM. See virtual machine.

VM/CMS. See Virtual Machine/Conversational
Monitoring System.

Virtual Machine/Conversational Monitoring System
(VM/CMS). A time sharing system control program
that manages the resources of an IBM System /370 such
that multiple remote terminal users have a functioning
simulation of a computing system at their disposal. The
Conversational Monitoring System provides general
time sharing, development, and problem-solving
facilities.

Virtual Telecommunications Access Method (VTAM).
A host program for communication using switched
lines. See also switched line.

virtual route (VR). In SNA, either (a) a logical
connection between two subarea nodes that is
physically realized as a particular explicit route or (b) a
logical connection that is contained wholly within a
subarea node for intranode sessions. See also Systerns
Network Architecture.

VR. See virtual route.

VS. Virtual storage.



VT terminal. A series of general purpose ASCII
terminals that were introduced by Digital Equipment
Company.

VTAM. See Virtual Telecommunications Access Method.

W

WAN. See wide area network.

wide area network (WAN). (1) A network that
provides communication services to a geographic area
larger than that served by a local area network or a
metropolitan area network, and that may use or
provide public communication facilities. (T) (2) A
data communication network designed to serve an area
of hundreds or thousands of miles; for example, public
and private packet-switching networks, and national
telephone networks. (3) Contrast with local area network
(LAN) and metropolitan area network (MAN).

X

X.21. An ITU-T recommendation for a general-purpose
interface between data terminal equipment and data
circuit-terminating equipment for synchronous
operation on a public data network.

X.25 network. A packet-switching data network linked
in accordance with ITU-T recommendation X.25.

X.25 Recommendation. An ITU-T recommendation for
the interface between data terminal equipment and
packet-switched data networks.

X.400. The message-handling services standard of
ITU-T and ISO.

XID. SNA exchange identification command. See also
Systems Network Architecture.

Numbers

3270 numeric field. A display field that accepts only
numerics (0-9), a minus sign, a period, a comma, and
DUP keyboard entries.
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FTP 8
functions not available with DFT
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G

Global Network 88
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the menu bar 48
the tool bar 48
windows 57
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Home3270 89
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considerations 88
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installation planning 19
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K
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assignments 139, 145
default 139, 141, 145
description 50
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setup 51

L

LAN adapter considerations 83
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licensing agreement 156
line speed
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IBM Global Network - SNA over
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SDLC attachment 85
Log Viewer 4
LUO, 1, 2, 3 via WinRUI
Attachment 151
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M

machine check 207 81
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usage 53
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for Windows 95 20
for Windows 98 20
for Windows NT 20
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OIA 75
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O
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pop-up keypad 56 (continued)
setup 56

poppad color 56

print screen 37

printer definition

file 38
table 38
printing

description 37

function 39

PROFS/OV note, calendar,

document 39

ZipPrint 9, 39
private subdirectory 79
processing environment 19
PROFS/OV note, calendar, document

printing 39

Q

q option 32
quit macro recording select 55
quit script recording select 55

R

receiving data from the host 66
related publications ix
requirements

hardware 19

software 20

storage 19
workstation 19
running

copylink 41
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S
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sample 102
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keyboard layout 52
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window 29
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setting up (continued)
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the pop-up keypad 57
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SNA
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configuration 4, 71
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stopping 72
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SNA Node Operations 5
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starting
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multiple sessions 30
sessions 29
SNA nodes 72
with a batch program 30
workstation profiles from the Start
menu 30
stopping
macro playing 55
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SNA nodes 72
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PDFPDT 80
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samples 80

T

TCP/IP
connection considerations 83
protocol driver 84

Text Assist 67

Thai Language 147

Tivoli Support
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twinax
adapters, using 98
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description 104

types of
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sessions 9

U

unsupported character sequences 89

Vv

VBScript 7
VT Enhancements 17

W

window

appearance 48
setup 48
view 57

Windows printer driver 37
Winsock 14

WinSock 3

workstation profile 25, 30

workstations supported by Personal
Communications 19

X

XEDIT work-space printing 39

Z

ZipPrint 9, 39
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