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About This Book

Beginning with Version 5.5, IBM® Personal Communications for Windows®

reference books were separated into four volumes: a 3270 Emulator User’s
Reference, a 5250 Emulator User’s Reference, a VT Emulator User’s Reference and
an Administrator’s Guide and Reference. These volumes provide information for
using IBM Personal Communications AS/400® for Windows operating systems.
(hereafter called PC400) and IBM Personal Communications for Windows
operating systems. In this book, Windows refers to Windows 95, Windows 98,
Windows NT, Windows Me, and Windows 2000. When information is applies only
to a specific operating systems, this is indicated in the text. Throughout this book,
workstation refers to all supported personal computers. When only one model or
architecture of the personal computer is referred to, only that type is specified.

Who Should Read This Book
This book is intended for the person who installs and uses Personal
Communications on a workstation to connect to ASCII hosts.

How to Use This Book
This book contains reference information that you might need to refer to when
installing or operating Personal Communications.

Personal Communications is designed to use various communication adapters and
to work with other workstation and host system software. Refer to the appropriate
documentation for the products you use.

Command Syntax Symbols
Parentheses, brackets, ellipses, and slashes have the following meanings or uses:

( ) Parentheses enclose operands that govern the action of certain command
options.

[ ] Brackets indicate an optional command argument. If you do not use the
optional item, the program selects a default.

... Ellipsis after an argument indicates that you can repeat the preceding item
any number of times.

\ A backslash is included as part of any directory name. An initial backslash
indicates the first-level directory, and an additional backslash is inserted in
the directory name to indicate another level.

All directives, operands, and other syntax can be typed in either uppercase or
lowercase, unless otherwise indicated.

Where to Find More Information
This section discusses getting help when you are installing, configuring, or using
Personal Communications.
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Online Help
The help facility describes how to install, configure, and use Personal
Communications. Online help is very extensive and includes information about
every aspect of configuring and using Personal Communications.

Use help to obtain the following information:
v Menu choices
v Operation procedures
v Operations in windows
v Meanings of the terms displayed in windows
v Causes of errors and the corresponding actions to take
v Mouse-based operations
v Operation without a mouse
v Detailed explanations of specific terms
v Further technical information about Personal Communications
v Detailed explanations of operator information area (OIA) messages

To display online help, select choices from the Help menu or press F1.

You can use Personal Communications online help just as you use the online help
for Windows.

Messages and Alerts
Online messages are displayed by Personal Communications, but a message does
not always mean an error occurred. For example, a message might tell you that an
operation is in progress or has been completed. A message can also prompt you to
wait for the completion of an operation.

Messages That Appear in Pop-Up Windows
While using Personal Communications, you may see messages appear in pop-up
windows, but not necessarily as a direct result of your actions. These messages can
appear for a number of reasons, outlined in the following sections.

System-Fault Messages: For Windows NT, if a message does appear in a pop-up
window, you can paste its contents into the Windows NT clipboard. To do this:
1. Click Details on the pop-up window.
2. Mark the text that you want to copy.
3. Click the marked text with the right mouse button and then click Copy.
4. Start an editor, such as Notepad, and click Paste from the Edit menu.
5. Save the file in case an IBM Service Representative needs this information to

diagnose your problem.

Security-Related Messages: Personal Communications optionally utilizes Secure
Sockets Layer (SSL) to establish sessions with servers; this may require input from
you (for example, a password). Refer to IBM Personal Communications Version 5.5
Administrator’s Guide and Reference for details.

System-Policy-Related Messages: Your Personal Communications workstation
configuration can be controlled centrally using facilities for managing system
policies. Refer to IBM Personal Communications Version 5.5 Administrator’s Guide and
Reference for details.
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OIA Messages

Personal Communications displays messages in the operator information area
(OIA) or in a pop-up window. Messages from Personal Communications are
displayed in the message window; messages from the host system regarding the
condition of the session are displayed in the OIA of the session window.

The OIA is the bottom line of the session window. An OIA message indicates the
status of Personal Communications as well as information about the workstation,
host system, and attachment method.

All of the OIA indicators, reminders, and messages are described in the online
help. To view this information:
1. Select Index from the Help menu.
2. Select The operator information area messages.

To look up a specific OIA message, select Search. When the Search window
appears, type the letters that appear in the OIA. For example, MACH or PROG. If a
lightning bolt appears, type COMM.

3. Double-click the index entry that matches your search.
4. Scroll through the window until you find the number that appears in your

OIA.

Alerts
Alerts may be generated which correspond to specific Personal Communications
messages. See the Administrator’s Guide and Reference for more information.

Personal Communications Library
The Personal Communications library includes the following publications:
v IBM Personal Communications for Windows, Version 5.5 CD-ROM Guide to

Installation, GC31-8079-06
v IBM Personal Communications AS/400 for Windows, Version 5.5 CD-ROM Guide to

Installation, GC31-8080-06
v IBM Personal Communications for Windows, Version 5.5 Quick Beginnings,

GC31-8679-02
v IBM Personal Communications for Windows, Version 5.5 Access Feature, SC31-8684-02
v IBM Personal Communications for Windows, Version 5.5 5250 Emulator User’s

Reference, SC31-8837-00
v IBM Personal Communications for Windows, Version 5.5 3270 Emulator User’s

Reference, SC31-8838-00
v IBM Personal Communications for Windows, Version 5.5 VT Emulator User’s

Reference, SC31-8839-00
v IBM Personal Communications for Windows, Version 5.5 Administrator’s Guide and

Reference, SC31-8840-00
v IBM Personal Communications for Windows, Version 5.5 Emulator Programming,

SC31-8478-05
v IBM Personal Communications for Windows, Version 5.5 Client/Server

Communications Programming, SC31-8479-05
v IBM Personal Communications for Windows, Version 5.5 System Management

Programming, SC31-8480-05
v IBM Personal Communications for Windows, Version 5.5 CM Mouse Support User’s

Guide and Reference
v IBM Personal Communications for Windows, Version 5.5 Host Access Class Library,

SC31-8685-02

About This Book ix



v IBM Personal Communications for Windows, Version 5.5 Configuration File Reference,
SC31-8655-04

These books are also available (except in DBCS versions) in PDF format and are
optionally installed or viewed from the CD-ROM.

In addition to the printed books, there are HTML documents provided with
Personal Communications:

Host Access Class Library for Java
This HTML document describes how to write an ActiveX/OLE
2.0–compliant application to use Personal Communications as an
embedded object.

Host Access Beans for Java
This HTML document describes Personal Communications emulator
functions delivered as a set of Java Beans.
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Part 1. General Information
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Chapter 1. Personal Communications Highlights

Personal Communications brings the power of personal networking to your
workstation by providing a variety of connectivity options supporting local area
network (LAN) and wide area network (WAN) environments. Whether you need
host terminal emulation, client/server applications, or connectivity, Personal
Communications offers a robust set of communications, networking, and
administrative features.

Personal Communications is a full-function emulator package with an easy-to-use
graphical interface, which includes many useful features such as file transfer and
dynamic configuration, and emulator APIs including the IBM Host Access Class
Library.

With Personal Communications, you can participate in Advanced-Peer-to-Peer
Networks (APPN) as an end node, and use the advanced network features,
high-performance routing (HPR), and dependent LU requester (DLUR).

Personal Communications provides the following functions:
v System/390® Connections

LAN LAN via IEEE 802.2
3270 NWSAA or Communications Server for Windows NT®

Telnet3270
3270 via AS/400
APPC 3270 via LAN
Microsoft® SNA client over FMI
Dependent Logical Unit Requester (DLUR)
VT-over-Telnet (TCP/IP)
3174 Peer Communication

COAX SNA Distributed Function Terminal
Non-SNA Distributed Function Terminal

COM port
Telnet 3270
SNA-over-Async
IBM Global Network® (not in Japan)
Home3270
IBM Global Network - SNA-over-Async
Dependent Logical Unit Requester (DLUR) via

SNA-over-Async

Hayes AutoSync
APPC 3270 via SNA-over-Async
APPC 3270 via Hayes AutoSync
VT-over-Async
VT-over-Telnet (TCP/IP)
X.25 Hayes AutoSync
X.25 DLUR via Hayes AutoSync
X.25 APPC 3270 via Hayes AutoSync

5250 3270 via AS/400
Dependent Logical Unit Requester (DLUR)

SDLC Synchronous Data Link Control
3270 via AS/400 (passthru)
APPC 3270 via SDLC
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Dependent Logical Unit Requester (DLUR)
SNA/IP

LU 0, 1, 2, 3
APPC 3270
LU 0, 1, 2, 3 via DLUR

IBM ISA/MCA WAC
Synchronous Data Link Control
3270 via AS/400 (passthru)
APPC 3270 via SDLC
Dependent Logical Unit Requester (DLUR)
X.25 Qualified Logical Link Control
X.25 3270 via AS/400
APPC 3270 via X.25
X.25 DLUR

API Client
NetWare for SAA® Client
Communications Server Client
Communications Server

IBM-EEDLC
LU (0, 1, 2, 3) via DLUR
APPC 3270

OEM LU (0, 1, 2, 3)
3270 via AS/400 (passthru)
APPC 3270
Dependent LU Requester (DLUR)

v AS/400 Connections
LAN LAN via IEEE 802.2

Telnet5250 over TCP/IP
VT over Telnet
Telnet5250 over IPX/SPX

5250 Twinaxial Data Link Control (APPC)
Twinaxial Data Link Control (Console)

COM port
SNA-over-Async
Hayes AutoSync
SNA-over-Async (Console)
VT over Async
VT over Telnet
Telnet 5250
X.25 Hayes AutoSync

SDLC Synchronous Data Link Control
SNA/IP

5250
IBM ISA/MCA WAC

Synchronous Data Link Control (WAC)
X.25 Qualified Logical Link Control

IBM-EEDLC
5250

OEM APPC 5250
v ASCII Emulator Connections

LAN VT over Telnet
COM port

VT-over-Async
VT over Telnet

v S/3X Emulator Connections
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5250 Twinaxial Data Link Control (Console)
v Client/Server Connections

LAN LAN via IEEE 802.2
Twinaxial

Twinaxial Data Link Control (APPC)
COM port

SNA-over-Async
Hayes AutoSync
X.25

SDLC Synchronous Data Link Control
IBM WAC

Synchronous Data Link Control
X.25

AnyNet® SNA over TCP/IP
APPC

Enterprise Extender
HPR over IP

v Configuration of SNA Node (APPN) Sessions
– Emulator
– Client/server applications

v SNA Node Operations
– Starting and stopping resources
– Deleting resources
– Displaying resource information
– Changing session limits
– Initiation of path switches

v Log Viewer
– View Message Log, Trace Log, and Merged Log files
– Summary and Detail views
– Set default Message Log size and location
– Filter and search Log files
– Message Log entries Help

v Trace Capability
– 3270/5250 emulator data
– APPN® and APPC API data
– Connectivity data, such as LAN or SDLC
– User services data, such as node initialization

v APPC Applets
– Display SNA sense data (GETSENSE)
– Transfer files (AFTP and AFTPD)
– Check connection (APING)

v Sample Programs

– Located in \Personal Communications\samples subdirectory
v Installation and Configuration

– Partial installation option
– Program sharing on a network server
– Automatic detection of installed communication adapters
– Dynamic change of communication configurations
– Automatic Dial Facility (Async (IGN), SDLC, Home3270, SNA-A)
– Silent Installation
– ASCII SNA-node configuration
– Verification of ASCII configuration

v OEM Adaptor Cards
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An open API enables vendors and other equipment manufacturers (OEMs) to
provide adapter cards that allow for additional connectivity options, for
example, additional X.25, ISDN, SDLC or twinax support.

v Host Session Function
– Up to 26 sessions
– Variable screen size and automatic font scaling
– Function settings (of the host code page, for example) for each session

v Host Graphics Support
– Built-in vector graphics support for GDDM® and other graphics applications

v File Transfer Function
– Easy operation through graphical user interface (GUI) windows
– Batch transfer of multiple files
– Concurrent file transfer through multiple sessions
– Background file transfer
– File transfer invocation by macro
– OfficeVision/MVS™ Import/Export functions
– VT File Transfer (XModem and YModem)

v Edit (Cut and Paste) Function

You can use the clipboard to cut, copy, and paste a selected area. In addition,
you can paste data in other applications, such as spreadsheet programs, that
support the PasteLink function.
– Support of spreadsheet data format (Sylk, Biff3, Wk3 formats)
– Copy Append
– Paste Next
– Paste to Trim Rectangle
– Paste Stop at Protected Line

v Graphical User Interface (GUI)
– Customizable 3D iconic tool bar
– 3D-button hotspots
– Pop-up keypad
– Macro function, including record and play
– VBScripts, including record and play
– Keyboard-function setup and remapping
– Mouse-button-function setup and remapping
– Display setup (cursor type, graphics, sound, colors, for example)
– Automatic font size adjustment or fixed font size
– Window-appearance setup
– Menu-bar customization
– 3270 Light Pen emulation by using a mouse
– Status bar with history
– Page setup (Text and Graphics)
– Revised Configuration Dialog
– Online help

v Print Function
– Printer session (for PC/3270: SCS, LU 3, or non-SNA)
– Graphics local print
– Printing with the Windows NT printer drivers
– Print function by printer definition table (PDT)
– Multiple host-print functions in multiple sessions
– Print-job control by SNA′ bracket timeout
– PDF-to-PDT conversion tool
– PC400 print function by OS/400® Host Print Transform (HPT)
– PC400 printing supported by the AS/400 Advanced Print Support Utility
– ZipPrint
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v Programming Interfaces
– 16/32-bit Emulator High-Level Language Application Programming Interface

(EHLLAPI)
– 16/32-bit Dynamic Data Exchange (DDE)
– 32-bit Node Operations Facility (NOF)
– 16/32-bit Personal Communications API (PCSAPI)
– 32-bit Advanced Program-to-Program Communication (APPC)
– 32-bit Common Programming Interface for Communications (CPI-C)
– 32-bit Automation Object API
– 32-bit ActiveX/OLE 2.0
– Host Access Beans for Java™

– ActiveX Controls
v PC400 Client Function

– Data transfer
– PC Organizer
– Text Assist
– Enhanced Programmable Terminal User Interface (ENPTUI)
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Chapter 2. Problem Analysis

This chapter describes the information that will help you analyze problems with
Personal Communications, and ways to report a problem to IBM. For detailed
information about contacting IBM, refer to Quick Beginnings.

For information about Personal Communications and support, refer to the
following Web sites:
v The Personal Communications home page provides access to general product

information, and download services. To view this page, use an Internet browser
and go to the following Internet address or Universal Resource Locater (URL):
http://www.ibm.com/software/network/pcomm

v The Personal Communications support page provides links to code fixes, tips,
newsgroups, support options, and services. To view this page or to submit a
software defect report, use an Internet browser and go to the following Internet
address:
http://www.ibm.com/software/network/pcomm/support

Personal Communications provides several utilities to help you with problem
analysis. They can be invoked by selecting their icons from the Programs > IBM
Personal Communications → Administrative and PD Aids subfolder on the
Windows Start menu.

The following sections describe these utilities and how to use them.

Log Viewer
The Personal Communications log viewer utility enables you to view, merge, sort,
search, and filter information contained in message and trace logs. Use the log
viewer during problem analysis to work with message and trace log entries. The
default name of the message log output file is PCSMSG.MLG; its file extension
must be .MLG. The file extension for trace logs must be .TLG.

To view message or trace logs:
1. From the Administrative and PD Aids subfolder, click Log Viewer; or, from an

active session, click Actions > Launch → Log Viewer.
2. From the list of logged messages, double-click a message to display the

message text.

For more information about log viewer functions, see “Chapter 7. Log Viewer
Functions” on page 53.

Trace Facility
The Personal Communications trace facility enables you to log trace information
for certain Personal Communications functions.

To start a trace, perform the following steps:
1. From the Administrative and PD Aids folder, click Trace Facility; or, from an

active session, click Actions → Launch → Trace Facility. The trace status on the
title bar displays the current state:
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Active Trace data is being collected by the trace facility.

Inactive
No trace data is being collected.

2. From the main dialog box, click Set Up to set the desired trace system
parameters.

3. Click OK to return to the main trace dialog box.
4. From the main trace dialog box, select the type of data you want to trace from

the Function Name, Component Name, and Trace Option list boxes.

Function Name
A specific set of Personal Communications features, such as User
Services.

Component Name
The name of a specific part of a function, such as Node Initialization
(for the User Services function).

Trace Options
The options associated with a particular component, such as EHLLAPI
(for the API component) or API trace (for the Node Initialization
component).

5. Start tracing data by clicking Start, or apply changes to the trace options by
clicking Apply.

6. Run the operation that you want to trace.
7. Optionally, stop the trace by clicking Stop.
8. Save the trace data to your hard disk by clicking Save.
9. Click Format to specify a formatted trace file name and to format the trace

data. The Information Bundler utility should be used immediately after the
trace is complete to ensure that the correct information is gathered.

Note: If you have changed the path for the formatted trace file, the
Information Bundler will not find the trace information. Copy the trace
files to the Personal Communications private subdirectory.

10. Click OK.
11. Click Clear to clear the trace buffer where you saved a trace.
12. Use the log viewer to view the formatted trace log.

Information Bundler
The Personal Communications Information Bundler utility gathers system files,
trace and log files, and registry information and creates a self-extracting .EXE file.
This .EXE file is sent to support personnel via FTP for problem resolution. This
utility should be executed immediately after the trace is complete to ensure that
the correct information is gathered. To use the information bundler utility:
1. From the PD Aids folder in the Personal Communications program group,

double-click the Information Bundler icon; or, from an active session, click
Actions → Launch > Information Bundler.

2. A .EXE file containing system and Personal Communications information is
created in the Personal Communications directory. By default this file is called
12345.EXE.
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Internet Service
The Internet Service utility enables you to send the .EXE file containing diagnostic
data collected by the Information Bundler to an FTP server. This utility will not
work unless TCP/IP is configured and you have a direct connection to the internet.
To use Internet Service:
1. Double-click the Internet Service icon located in the Personal Communications

program group; or, from an active session, click Actions → Launch → Internet
Service.
The Internet Service window contains four data fields that must have valid
values before you can submit your problem report.

2. Verify that the FTP Address field contains the default address
testcase.software.ibm.com. This is the service anonymous FTP server.

3. Type your e–mail address in the field provided.
4. In the Problem Determination Filename field, type the file name and path of

the .EXE file created with the Information Bundler. This file is located in the
Personal Communications installation directory.

5. In the PMR Number field, type the PMR number that you received as a result
of contacting IBM support personnel.

6. When all fields in the window have been filled with valid values, click
Transmit to submit your problem determination information.
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Part 2. Using Personal Communications
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Chapter 3. Considerations for Using VT Sessions

This chapter contains hints and tips for using VT sessions.

Supplementary information other than the items described in this book may be
included in README.TXT in the Personal Communications directory.

Power Management
Personal Communications complies with Windows 2000 Power Management
requirements for handling sleep events. This support minimizes session
interruptions due to network disconnections caused by sleep on Windows 2000
and subsequent versions.

Note: In this context, the term ″sleep″ means that the system is on standby or is in
hibernation. To applications such as Personal Communications, standby and
hibernation are the same.

The benefits of this power management system include the following:
v Power consumption is reduced via the Advanced Configuration and Power

Interface (ACPI); the system is able to enter a lower power state (or sleep mode)
that appears to be ″off″ but is still powered enough to enable the system to
power up (or wake) to handle timed events or device related needs such as
receiving a fax.

v The PC is instantly available to the user because it can rapidly return from a low
power state to a fully-functional state.

v Customers can rely on their PCs to power down and up in a way that is easily
understood and predictable.

The following Personal Communications components are affected by this Power
Management arrangement:
v Emulator sessions
v Transfers that utilize an emulator session

Sleep Permission
Before entering a sleep state (stand by or hibernate), Windows 2000 normally
requests permission from the applications that are running. When one or more
emulator sessions are connected and Windows signals that the user is available for
interaction, Personal Communications asks the user to grant or deny sleep
permission. If the user grants permission, Personal Communications logs the event
and then notifies Windows. When user interaction is not possible, sleep permission
is denied.

When Personal Communications is not in the connected state, Windows 2000 may
automatically sleep, without prompting the user for permission.

Critical Sleep
When Windows 2000 resumes after an emergency suspension, Personal
Communications may display and log a warning message.

© Copyright IBM Corp. 1989, 2001 15



Usage Notes for Sessions in OLE Documents

Changing Fonts
If you are using an In-Place embedded session, then changing the font face name,
switching between automatic sizing and fixed size, or changing the size for a fixed
size font can result in an incorrect display on the screen. To correct the display,
adjust the size of the session object window slightly.

Initial Selection of Font
The initial font selection for a embedded or linked session is determined by its
Session ID (a letter A through Z) just like a regular session. Therefore, the initial
font may change if other sessions are already active. Further, to prevent In-Place
embedded sessions from having adverse effects on subsequent sessions, font
changes made during use of In-Place embedded sessions are not saved.

WordPad
Personal Communications session objects created in Microsoft WordPad documents
by the drag-and-drop method cannot be used after the document has been saved
and closed. This limitation may be fixed by some future version of WordPad. For
the present, you should only create Personal Communications objects in WordPad
by using the Insert-Object menu item.

Some versions of Microsoft Word and Microsoft WordPad incorrectly save the state
of embedded objects that are displayed as icons. If you open a document that
contains a Personal Communications session object that was created to display as
an icon, and the object is activated, then it may activate In-Place instead of as a
separate window. This problem may be fixed in future versions of these containers.

WordPro
If you attempt to open a link to a Personal Communications session in a Lotus®

WordPro document, current versions WordPro are likely to trap. This limitation
may be fixed by some future version of WordPro. For the present, you should only
use embedded Personal Communications objects in WordPro documents. You may
use the Display as Icon option if a separate window is desired.

Updating Linked Files
Files that are linked into Word 97 or Excel 97 do not update automatically. You
must manually save the linked file before your edits are reflected in the container
window.

Inactivity Timeout for Communication Links
The Inactivity Timeout automatically disconnects a link after it has been idle for a
specified length of time. Its purpose is to avoid excessive charges on dial-up links,
such as switched-line connections with SNA/A, Asynchronous IIN, Hayes
AutoSync, or SDLC. Inactivity Timeout is not recommended for other types of
connections.

To enable Inactivity Timeout, add the following statement to the PU section of
your workstation profile (.WS file):

[PU]
InactiveTimeout=xx
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The value xx, in the range 1 to 999, is the number of minutes a link remains
connected when there is no activity over it. The default value, InactiveTimeout=0
disables Inactivity Timeout.

Note: The Inactivity Timeout function monitors only attention keys (that is, the
Enter, Clear, and PFx keys). It is recommend that you set a comparably
longer value for xx if, for example, you expect to key in large amounts of
data on the screen before pressing the Enter key.

Other Considerations
The following are environmental considerations for Personal Communications.

Virtual Memory
If you receive a message stating that the system is low on virtual memory, increase
the virtual memory paging file. If you get this message as you are trying to open
new host sessions or starting a Personal Communications function such as File
Transfer, it is apparent that virtual memory settings should be increased. You can
increase the size of the virtual memory paging file on Windows NT as follows:

For Windows NT and Windows 2000
1. Click Start → Settings → Control Panel.
2. On the Control Panel, double-click on the System icon.
3. Select the Performance tab on the System Properties panel and then click

Change .
4. Select the appropriate drive and increase the maximum size value.
5. Click Set to establish the new size.
6. Click OK on the Virtual Memory panel.
7. Click Close on the System Properties panel.
8. You will be prompted to restart your computer. You should close any open

applications and restart your computer.

Emulator Session Icons
Emulator session icons that were not migrated during installation of Personal
Communications Version 5.5 will not function correctly if they were not created in
the application data directory specified during installation of Version 5.5. The icons
can be updated by using the File → Import option from the Session Manager. This
option will not copy the prior icons to the application data directory specified
during installation; the icons must be moved manually

Migrating from Windows 95 or Windows 98 to Windows NT or
Windows 2000

On Windows NT or Windows 2000, Personal Communications installs itself as an
entry in the Common area of the Start/Programs menu (that is, below the split line
on the Programs menu). Personal Communications for Windows 95 or Windows 98
places itself in the Private area of the Programs menu—above the split line on the
Programs menu. When you install Personal Communications on a machine where
Personal Communications Version 4.1 for Windows 95 or Windows 98 was
previously installed, the Personal Communications for Windows 95 or Windows 98
icons will not automatically be removed from the Private area of the Programs
menu. You can manually remove these icons by clicking the Taskbar with the right
mouse button and clicking Properties → Start Menu Programs → Remove.
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Disabling CDRA Tables
This release uses the standard IBM CDRA translation tables when converting
between ASCII and EBCDIC. From some code page pairs, the standard tables differ
from those that Personal Communications has used in the past. For code pages
that were supported in prior releases, you can configure Personal Communications
to use the old tables. A switch is available in PCSWIN.INI to disable the use of
CDRA tables. This switch is located in the Translate section and is named
UseOnlyPCOMM. This switch takes a binary value and is defaulted to FALSE
(except for Japan, Korea, Taiwan, and PRC where it defaults to TRUE). For the
code pages that are new to Version 5.5 you must use the standard tables. Setting
the switch will apply to all sessions, as well as data transfer and command line file
transfer.
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Chapter 4. VT Emulation

For connection to ASCII hosts, Personal Communications provides the VT
Emulator for VT340, VT100, and VT52 terminals. ASCII hosts commonly use these
terminal control sequences as standards for session presentation, and many
ASCII-host application programs assume a VT-compatible terminal. VT emulation
allows your personal computer or workstation to operate as if it were a VT
terminal. Software that is designed to operate a VT340, VT100, or VT52 terminal
should work correctly with the Personal Communications VT emulator.

Although the keyboard layout on VT terminals is similar to that of the personal
computer, there are some exceptions. The default mapping of keys for VT
emulation appears in the IBM Personal Communications Version 5.5 Administrator’s
Guide and Reference.

For file transfer to and from ASCII hosts, using the XMODEM and YMODEM
protocols, see “Using XMODEM and YMODEM” on page 37.

VT connections to non-ASCII hosts, such as the IBM System/390 (S/390) are also
possible if you have the appropriate communication devices.

Configuring a VT Session
Use the Customize Communication - ASCII Host panel to select values for the
parameters that define your ASCII host session. There are two types of parameters:
Session and Link.

Customizing the VT over Async Attachment
1. Click Communication from the WorkStation-window menu bar.
2. Click Configure... from the Communication menu. The Customize

Communication window appears.
3. Select VT over Async attachment.
4. Click Session Parameters.

The Session Parameters Host window appears.
5. Set the session parameters (see “Session Parameters” on page 20).
6. Click Link Parameters.

The VT Async Attachment window appears.
7. Set the Communication and Automatic-Dial Facility parameters, and click the

Advanced... button to set advanced parameters.
8. Click OK until the Customize Communication window disappears.

Customization is complete.

Customizing the VT over Telnet Attachment
1. Click Communication from the WorkStation-window menu bar.
2. Click Configure... from the Communication menu.

The Customize Communication window appears.
3. Select the ASCII host and then select the LAN or COM Port interface.

The available attachments appear.
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4. Select VT over Telnet attachment.
5. Click Session Parameters.

The Session Parameters — ASCII Host window appears.
6. Set the Session Parameters (see “Session Parameters”).
7. Click Link Parameters.

The TelnetASCII window appears.
8. Enter the host name or IP address.
9. Optionally enter the port number, change the terminal ID, or select the

Auto-reconnect check box.
10. Click OK until the Customize Communication window disappears.

Customization is complete.

Session Parameters
These parameters correspond to setup choices on a VT340 terminal.

Online/Local

In the Online state, the emulator receives data from the host computer,
and can send data to it. In the Local state, data you enter on the keyboard
appears on the screen, but is not sent to the host; data from the host is
held, and not presented on the screen until you change the state to Online.

Operating Mode

Select Char if the host does not echo the characters you type on your
keyboard. The VT emulator displays them as it sends them to the host.

Select Echo if the host echos your keyboard characters for display. The VT
emulator displays them only as they return from the host.

If you see doubled characters, you should select Echo instead of Char.
Echo is the default.

Machine Mode

There are four machine modes. These are:

VT340 mode, with 7-bit controls

This is the default. This mode is recommended for most
applications.

VT340 mode, with 8-bit controls

The emulator is set for an 8-bit environment with 8-bit controls.

VT100 mode

This mode is intended for situations requiring strict compatibility
with the VT100 terminal. In general, the VT340 7-bit mode is
appropriate for applications that expect a VT100.

VT52 mode

This mode is only for applications designed for the VT52 terminal.

Screen Size

You can choose the number of rows and columns that the session screen
displays. The choices are
v Rows: 24, 36, 48, 72, and 144
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v Columns: 80 and 132

The defaults are 24 rows and 80 columns.

Type of Host Code-Page

The choices are for the host code page are National, PC, and Multinational.
Multinational which selects the 8–bit DEC Supplemental Graphic Character
Set is the default. If you select National, then you must select a country
from the Host Code Page pull-down list. The PC option selects the PC
Code Page 437.

Host Code-Page

Select a National host code page. The choices are as follows:
v Belgian
v Canadian French
v Danish
v Finnish
v French
v German
v Italian
v Norwegian
v Spanish
v Swedish
v Swiss French
v Swiss German
v United Kingdom
v United States

Optional Parameters
These parameters correspond to setup choices on a VT340 terminal.

Reverse Screen Image

Check this box to reverse the foreground and background colors.

User Feature Lock

Check this box to lock the following functions so that the host cannot
change them.
v Auto Repeat
v Keyboard Lock
v Reversed Screen Image
v Tab Stops

Auto Wrap

Check this box if you want the VT emulator to start a new line whenever
the current row of characters reaches the end of line.

Auto-Answer Back Message

Check this box if you want the VT emulator to send a message
automatically to the host, once a connection has been established.

Answer Back Message

Enter the message, which is a maximum of 31 characters, to send to the
host when communication is established.

Conceal
If you check this box, your answerback message is not displayed in the
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configuration window. After you conceal your message, the Conceal box
has no effect, and the message remains concealed until it is changed.

User Defined Key Lock

Check this box to lock user-defined keys. For example, you can select User
Defined Key Lock and define the values of the F6 to F20 keys. These keys
are then locked with those values and cannot be redefined by the host.

Transparent Mode

Check this box to cause the VT emulator to display control characters
rather than interpreting them.

VT ID The attributes of the selected model are sent to the host computer. Choose
one of the following: VT100 ID, VT101 ID, VT102 ID, VT220 ID, VT240
ID, VT320 ID, or VT340 ID.

History Window Buffer Size
You can choose the size of the buffer used to store the history lines for the
session; these lines can then be viewed in a scrollable window. The choices
are 16KB, 32KB, 64KB, 128KB, and 512KB. The default is 64KB.

Advanced ASCII Host
The Advanced button takes you to the Advanced ASCII Host dialog. The
Advanced Options dialog contains all of the configuration options needed for the
Local editing feature of VT340 Emulation. The following list defines these
configuration options. Default settings are indicated in italic.

Graphics Cursor
Determines whether the graphics input cursor is shown when in graphics
mode.

Sixel Scrolling
When this option is selected, a sixel graphics image scrolls to the next row
when the last column is reached.

MacroGraph Reports
Controls the ability of the host to retrieve stored macro graph procedures.
Possible values are Enabled or Disabled.

Edit Mode
Selects whether local editing is available and the current mode of
operation. Possible values are Unavailable, Interactive, or Edit.

Erasure Mode
Determines which characters can be erased in edit mode. Possible values
are Unprotected or All.

Edit Key
Determines how the VT340 emulation switches between interactive and
edit mode. Possible values are Immediate or Deferred.

Transmit
Determines how the VT340 emulation sends a block of data to the host
system in edit mode. Possible values are Immediate or Deferred.

Application Keys
Determines how the unshifted function keys F6 through F20 work in edit
mode. Possible values are Disabled, Immediate, Prefix, or Suffix.
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Guarded Area
Determines whether protected characters can be sent to the host system.
Possible values are All or Selected.

Selected Area
Determines whether the VT340 emulation can send all characters or only
selected characters to the host system. Possible values are All or Selected.

Multiple Area
Determines whether VT340 emulation can send all selected areas on the
page, or only the area selected with the cursor. Possible values are Multiple
or Single.

VT131 Transfer
When Line Transmit Mode is disabled, this feature selects an ANSI-style
or VT131-style data transmission. The size of the block depends on
Transfer Termination Mode. Possible values are ANSI or VT131.

EOL Characters
Allows you to select characters used to indicate the end of a line (EOL) in
a data block. By default the VT340 emulation sends a carriage return (CR).
Up to six hexadecimal characters can be specified.

EOB Characters
Allows you to select characters used to indicate the end of a data block
(EOB). This feature has no default. Up to six hexadecimal characters can be
specified.

Page Coupling
Determines whether to automatically display a new page when the cursor
moves to a new page in page memory. Possible values are Enabled or
Disabled.

Line Transmit Mode
Allows you to send characters one line at a time to the host system.
Possible values are Disabled or Enabled.

Transfer Termination Mode
When Line Transmit Mode is disabled, this feature determines whether
the VT340 emulation sends a partial page or the scrolling region. Possible
values are Enabled or Disabled.

Space Compression Mode
Determines how the VT340 emulation sends unused character fields and
spaces in a data block. Possible values are Disabled or Enabled.

Link Parameters
The Configure Links button take you to a panel for configuring the details of the
connection to the ASCII host computer. The panel you see depends upon the
attachment type that you chose for your ASCII host. There are two types:
v VT over Async
v VT over Telnet

Configuring Links for VT over Async
The VT over Async attachment connects to an ASCII host through a protocol
converter, using normal telephone lines or a direct connection.

For VT over Async attachment, you must define the following items.
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Attachment Parameters

v Communication Port
v Line Speed in bps
v Data Bits
v Parity
v Stop Bits

Advanced Configuration Parameters

v Flow Control
v XOFF Point
v Modem Signal Detection
v Break Signal Length

Additional Configuration Information

v Automatic-Dial
v Modem Name
v Primary/Backup Phone
v Title
v Configure Phone/Modem
v Automatic-Dial Facility
v Automatic-Dial Utility
v Dial / Stop Dialing
v Hang up
v Manual Dial
v Auto-exit after connection
v Modem-signal indicator

Attachment Parameters
Communication Port

Select the number of the communications port though which your async
connection will be established. The choices are COM1, COM2, COM3, and
COM4. The default is COM1.

Line Speed (bps)

Line speed is the data transmission speed in bits per second.

If you have a 14,400 or 28,800 baud modem, its use of V.42bis compression
technology allows you to take advantage of the highest speeds that your
system supports. For a 14,400 baud modem, select a line speed of 57,600 or
lower; for a 28,800 baud modem, select 115,200 or lower.

If you are not successful with these high speeds, you may need to select a
lower line speed. For example, if your COM port does not have a FIFO
buffer, you might need to select a lower speed. When a connection attempt
fails or is not reliable at a higher speed, try a lower speed.

The default speed is 9600 bps.

The maximum usable speed depends on the capability of the processor or
the communication port. If your connection fails, try a slow speed.

If you use the 8250 UART, your line speed should not be higher than
19,200 bps.
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Data Bits
Select the number of bits that constitute a character, either 7 or 8. Your
choice should match the value your ASCII host uses. The default is 8.

Parity

Parity is a method for detecting transmission errors. An extra bit is
appended to some unit of data, usually a byte. That bit is set to 0 or 1,
making the total number of 1 bits an even number (for even parity) or an
odd number (for odd parity). The valid parity type is None, Odd, Even,
Space, or Mark. None means that no parity bit is sent or expected. Mark
and Space mean that the parity position is always set to 1 or 0,
respectively, and that received parity is not checked.

Select the same parity used on your remote system.

The default is None.

Stop Bits

One or two stop bits signify the end of each asynchronously-transmitted
character. Select the same value, 1 or 2, as used by your remote system.
The number of stop bits in use may depend upon the line speed. The
default is 1.

Advanced Configuration Parameters
The following advanced configuration parameters are available:

Flow Control

Select the method for controlling the flow of data between the emulator
and the modem or the ASCII host. The choices are:

XON/XOFF
The software flow control method places the characters DC3 and
DC1 into the data stream to stop and start the flow of data. This
method, no longer common, allows the session user to pause
incoming data for reading, by using the Control-S and Control-Q
keys. DC3 is X'13', or XOFF; it is initially mapped to Control-S.
DC1 is X'11', or XON; it is initially mapped to Control-Q. The
keyboard positions are remappable.

Hardware
The hardware flow control method uses the electrical signals RTS
(Request to Send) and CTS (Clear to Send). If your modem is using
high-speed data compression, or if you are performing XMODEM
or YMODEM file transfers, this method is mandatory.

Both This method uses both hardware and XON/XOFF flow control; it
is the default.

None If you select None there is no flow control.

XOFF Point

For software flow control, the XOFF point is the level (in bytes) at which
the XOFF signal is sent to the modem or ASCII host. The options (64, 256,
512, and 1024) specify the space remaining in the buffer. For example, if
you select 64, the XOFF signal is sent when 64 bytes of space remain in the
buffer.

Modem Signal Detection
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Select the method that the VT emulator will use to determine whether data
can be sent on the asynchronous line. The options are:

None The VT emulator will assume that the line is ready, ignoring CD,
CTS and DSR.

Ignore CD
The VT emulator will ignore Carrier Detect, which some modems
artificially force high. Use this option if your host is connected
through a null modem cable; most null modems do not support
CD.

All The VT emulator will monitor CD, CTS (Clear to Send) and DSR
(Data Set Ready).

Break Signal Length

The break signal is an intentional framing error on the asynchronous line,
used as an attention signal to the host. Some hosts expect the break to be a
particular length. The default value is 250 milliseconds. The other options
are 500, 1000, and 2000 milliseconds. Select the value required by your
host.

Additional Configuration Information
Automatic-Dial

Click Yes for Automatic-Dial; then use the Configure Phone/Modem if you
need to provide more detailed information than is shown. Click No if you
are using a leased-line connection; you will not use the Automatic-Dial
Facility.

Modem Name
When running Windows 95, Windows 98, Windows NT, Windows Me, or
Windows 2000, the modem information is handled through the operating
system control panel modem applet. This drop-down list contains all the
modems defined to Windows; select the one you wish to use.

Primary Phone
This entry is the primary phone number that should be dialed, in order to
gain access to the network. It can include a delay for the dial tone and
access codes for an outside line or for long-distance services.

Backup Phone
This entry specifies a backup phone number. If you specify a backup
number, it is dialed automatically after an attempt to contact the gateway
or host through the primary number fails. If you leave this option blank,
backup dialing does not happen.

Title This optional entry is text to describe the connection that you are
configuring. The text will be displayed when the number is dialed, but it
has no effect on the connection.

Configure Phone/Modem
When Personal Communications is running on Windows 95, Windows 98,
Windows NT, Windows Me, or Windows 2000, phone and modem
configuration is handled through the operating system’s modem utility.

Clicking this button allows you to adjust the details of the modem
configurations.

Automatic-Dial Facility
The automatic-dial facility establishes a connection to the host when you
start a session.
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To use the automatic-dial facility, you must store the dial information,
telephone numbers, communication-line information and modem-control
information in a file. For details, see the online help. The following
functions are provided to enable you to create and change a
dial-configuration file:
v Configure Phone/Modem
v Automatic-Dial Utility

Automatic-Dial Utility
The automatic-dial utility enables you to configure and use the
automatic-dial function.

The automatic-dial utility window appears when Show AutoDial Utility
in the Communication menu (on the session-window menu bar) is selected
and the Automatic-Dial Facility starts.

Dial / Stop Dialing
This push-button either starts or stops dialing, depending on the current
dialing status.

Dial Click Dial to dial the specified telephone number and establish a
connection.

Stop Dialing
Click Stop Dialing to stop the dial process immediately.

Hang up
Clicking Hang up sends the modem-hang-up string and disconnects your
PC from the remote computer.

Manual Dial
Manual Dial enables you to use a nonpublic telephone line or operator
assist to dial the number.

Auto-exit after connection
Choose Auto-exit after connection if you want the automatic-dial utility
window to close after a connection is established. The window will
otherwise remain open.

Modem-signal indicator
On Windows 95, Windows 98, Windows NT, Windows Me, and Windows
2000 systems, use the operating system’s modem utility to monitor modem
signals.

Configuring Links for VT over Telnet
The VT over Telnet attachment is an application that uses TCP/IP (Transmission
Control Protocol/Internet Protocol) and that enables remote logon to an ASCII
host. TCP/IP provides connectivity functions for both local area networks (LAN)
and wide area networks (WAN) and includes the ability to route information
between LANs and WANs. The major TCP/IP networks—the Internet—use a
standardized addressing procedure to ensure that IP addresses are unique and that
communication between enterprises is possible.

The VT over Telnet attachment for Personal Communications requires a TCP/IP
stack that supports the Windows Sockets Version 1.1 interface. WSOCK32.DLL
must be in the Windows system directory or the current path to provide the
interface for the stack program and to support the Windows Sockets V1.1 interface.
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For the VT over Telnet attachment, you must define the following attachment
parameters.
v Host Name or IP Address (mandatory)
v Port Number (optional)
v Terminal ID (optional)
v Auto-reconnect (optional)

Host Name or IP Address

Specify either the alphabetic name of the target host or its numeric IP
address.

Host Name

The name of the target host is a string—for example:
host.test.ibm.com

Host IP Address

The 32-bit Internet address of the target host is in dotted-decimal
notation—for example: 0.0.0.0

Port Number

Specify the decimal number of the target host’s Telnet port. The default, 23,
is the standard Telnet port.

Terminal ID

The VT emulator and the Telnet server use the terminal ID for negotiating
an appropriate connection. Ask your Telnet administrator for your host’s
correct terminal ID. When the default box is selected, the default values are
selected from the Machine Mode, as shown in the following table:

Machine Mode Default Terminal ID

VT340 DEC-VT220

VT100 DEC-VT100

VT52 DEC-VT52

ANSI ansi

Auto-reconnect

If the session is disconnected from the host, and if this box is selected, you
will be re-connected automatically.

The default is not selected.

Using A VT Session
Your Personal Communications VT session works as if you were using a VT340,
VT100, or VT52 terminal. For AS/400 or mainframe VT connections, the protocol
converters have defined VT keyboard sequences, such as F1 or PA1.

The following tables are provided:
v Characters generated by VT Compose Key
v Characters displayed in transparent mode
v OIA line display messages
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Refer to the Administrator’s Guide and Reference for default mapping of the VT340
keyboard to the PC keyboard, as used by the Personal Communications VT
emulator.

Compose Key
The VT emulator supports the VT340 compose key for generating special
characters on the display. Before using the compose key, define a key combination
that represents it.

Using the compose key involves three separate actions:
1. Press and release the compose key.
2. Press and release the first character (see Table 1).
3. Press and release the second character.

The first and second characters may be typed in either order, except when the table
specifies that they must be entered as shown,

Table 1 shows the appearance and name of each special character, the character
pair that generates the character, and an indication whether the order of entering
the characters is significant.

Table 1. Character Generation (Special Characters)

Generated Character Compose Key, Plus This Pair

Appearance Description First Second Order

Á A acute A ' either

á a acute a ' either

Â A circumflex A | either

â a circumflex a | either

À A grave A either

à a grave a either

Å A ring A * either

A ° either

å a ring a * either

a ° either

Ã A tilde A either

ã a tilde a either

Ä A umlaut A " either

ä a umlaut a " either

Æ AE ligature A E as shown

æ ae ligature a e as shown

u apostrophe ' space either

@ at sign a a either

A A either

\ backslash / / either

\ backslash / < either

Ç C cedilla C , either

ç c cedilla c , either
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Table 1. Character Generation (Special Characters) (continued)

Generated Character Compose Key, Plus This Pair

Appearance Description First Second Order

¢ cent sign c / either

C / either

c | either

C | either

| circumflex accent | space either

} close brace ) - either

] close bracket ) ) either

» close French quote > > either

@ commercial at a a either

A A either

© copyright mark c o either

C O either

c 0 either

C 0 either

° degree sign 0 | either

° space either

# space either

É E acute E ' either

é e acute e ' either

Ê E circumflex E | either

ê e circumflex e | either

È E grave E either

è e grave e either

Ë E umlaut E " either

ë e umlaut e " either

a feminine ordinal indicator a _ either

A _ either

½ fraction one-half 1 2 as shown

¼ fraction one-quarter 1 4 as shown

ß German ess-tset s s either

µ Greek mu / u as shown

/ U as shown

» guillemets, closing > > either

« guillemets, opening < < either

Í I acute I ' either

í i acute i ' either

Î I circumflex I | either

î i circumflex i | either

Ì I grave I either
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Table 1. Character Generation (Special Characters) (continued)

Generated Character Compose Key, Plus This Pair

Appearance Description First Second Order

ì i grave i either

Ï I umlaut I " either

ï i umlaut i " either

¡ inverted exclamation ! ! either

¿ inverted question mark ? ? either

o masculine ordinal indicator o _ either

O _ either

µ micro sign / u as shown

/ U as shown

· middle dot . | either

Ñ N tilde N either

ñ n tilde n either

# number sign + + either

Ó O acute O ' either

ó o acute o ' either

Ô O circumflex O | either

ô o circumflex o | either

Ò O grave O either

ò o grave o either

Ø O slash O / either

ø o slash o / either

Õ O tilde O either

õ o tilde o either

Ö O umlaut O " either

ö o umlaut o " either

Œ OE ligature O E as shown

œ oe ligature o e as shown

{ open brace ( - either

[ open bracket ( ( either

« open French quote < < either

¶ paragraph sign p ! either

± plus-or-minus sign + - either

£ pound sterling sign l - either

L - either

l = either

L = either

" quotation mark " space either
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Table 1. Character Generation (Special Characters) (continued)

Generated Character Compose Key, Plus This Pair

Appearance Description First Second Order

§ section sign s o either

S O either

s ! either

S ! either

s 0 either

S 0 either

' single quote ' space either

ß ss German s s either

¹ superscript 1 1 | either

² superscript 2 2 | either

³ superscript 3 3 | either

tilde space either

Ú U acute U ' either

ú u acute u ' either

Û U circumflex U | either

û u circumflex u | either

Ù U grave U either

ù u grave u either

Ü U umlaut U " either

ü u umlaut u " either

| vertical line / | either

Ÿ Y umlaut Y " either

ÿ y umlaut y " either

¥ yen sign y - either

Y - either

y = either

Y = either

Transparent Mode
Table 2 shows the symbol displayed for each character and control code when the
VT emulator is in transparent mode. The characters at AA and BA are the feminine
and masculine ordinals, respectively. The characters at 1E, 1F, 80, and 9E are
underlined, although they may not appear underlined on the output.

Table 2. Character Generation (Transparent Mode)

0x 1x 2x 3x 4x 5x 6x 7x 8x 9x Ax Bx Cx Dx Ex Fx

x0 @ P 0 @ P p p Ÿ ° À Ð à ð

x1 A Q ! 1 A Q a q a q ¡ ± Á Ñ á ñ

x2 B R " 2 B R b r b r ¢ ² Â Ò â ò

x3 C S # 3 C S c s c s £ ³ Ã Ó ã ó
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Table 2. Character Generation (Transparent Mode) (continued)

0x 1x 2x 3x 4x 5x 6x 7x 8x 9x Ax Bx Cx Dx Ex Fx

x4 D T $ 4 D T d t d t ¤ u Ä Ô ä ô

x5 E U % 5 E U e u e u ¥ µ Å Õ å õ

x6 F V & 6 F V f v f v ¦ ¶ Æ Ö æ ö

x7 G W ' 7 G W g w g w § · Ç × ç ÷

x8 H X ( 8 H X h x h x } q È Ø è ø

x9 I Y ) 9 I Y i y i y © ¹ É Ù é ù

xA J Z * : J Z j z j z a o Ê Ú ê ú

xB K [ + ; K [ k { k { « » Ë Û ë û

xC L \ , < L \ l | l | ¬ ¼ Ì Ü ì ü

xD M ] - = M ] n } m } − ½ Í Ý í ý

xE N | . > N | m n ¾ Î Þ î þ

xF O _ / ? O _ n Œ o œ ‾ ¿ Ï ß ï ÿ

OIA Line Display Messages
During VT emulation, messages unique to VT can appear in certain columns of the
OIA line. These columns display only VT messages, and do not display any of the
messages that would appear there in 3270 or 5250 mode. Table 3 shows the
meaning of each VT-specific message. Columns that are not mentioned in the table
show messages common to all Personal Communications modes.

Table 3. OIA Line Display Messages (VT only)

Columns Message Meaning

1 through 7 VT340 7 Machine mode is VT340, seven-bit control.

VT340 8 Machine mode is VT340, eight-bit control.

VT100 Machine mode is VT100.

VT52 Machine mode is VT52.

VTANSI Machine mode is VTANSI.

9 through 12 LOCK Keyboard is locked.

30 through 39 OVERSTRIKE New characters replace the character at the
cursor position in Local Edit mode.

INSERT New characters move characters in page
memory to the right in Local Edit mode.

61 through 64 HOLD Screen is in hold mode.

66 through 69 EDIT Local Edit mode is enabled.

71 through 72 Pn (n=1 through 6) Current page number.

Scrollable History Display
Depending on the size of the history buffer set (see “Configuring a VT Session” on
page 19) for your session, you can use the Windows scroll bar control to view
history data from the current session.
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Default Key Function Assignments
This section lists the functions assigned, by default, to each key on your keyboard.

For more information about each function, refer to the Keyboard choice on the
Help menu.

You can change the default key assignments to the following default function
tables by selecting Keyboard Setup from the Assist menu.

When the Keyboard Setup window appears, select one of the following choices:
v 3270 for a 3270 keyboard layout
v 5250 for a 5250 keyboard layout
v 3270+5250 for a combined keyboard layout
v VT for a DEC VT220 keyboard layout

Setting the VT Keyboard Layout Default
To make the VT keyboard layout defaults available, do the following:
1. Click Preferences → Keyboard from the Edit menu. The Keyboard dialog box is

displayed.
2. Select the IBM Default radio button next to Current Keyboard.
3. Click OK.

Default Key Functions for the VT Emulator Layout
Table 4 shows the default key functions for VT220, VT100 and VT52. The key used
is the same for all the supported keyboard types. The VT emulator keyboard gets
selected as the default only when the VT Component is selected in the installation
path.

Table 4. Default Key Functions for a VT Emulator Layout

Function of Key Key

Backspace "─ (Backspace)

Break Ctrl+Pause

CAN Ctrl+"─ (Backspace)

Cursor Down ↓ or 2(pad)

Cursor Left ← or 4(pad)

Cursor Right → or 6(pad)

Cursor Up ↑ or 8(pad)

Edit Copy Ctrl+Insert

Edit Cut Shift+Delete

Edit Paste Shift+PageDown or
Ctrl+Shift+Insert

Edit Undo Alt+"─ (Backspace)

ESC ESC

Jump Next Alt+PageUp

New Line "┘ (Enter)

Mark Down Shift+↓

Mark Left Shift+←
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Table 4. Default Key Functions for a VT Emulator Layout (continued)

Function of Key Key

Mark Right Shift+→

Mark Up Shift+↑

Move Mark Down Ctrl+↓ or
Ctrl+2(pad)

Move Mark Left Ctrl+← or
Ctrl+4(pad)

Move Mark Right Ctrl+→ or
Ctrl+6(pad)

Move Mark Up Ctrl+↑ or
Ctrl+8(pad)

PF6 to PF12 F6 to F12

PF13 to PF20 Shift+F1 to F8

Rule Ctrl+Home

Tab Field ─)| or Shift+─)|

VT Enter Shift+Enter(pad)

VT Find End² or
1(pad)

VT Hold Pause

VT Insert Insert or 0(pad)

VT Next Page Down² or
3(pad)

VT Numpad 0 to VT Numpad 9 Shift+0(pad) to
Shift+9(pad)

VT Numpad Comma Shift++(pad)

VT Numpad Minus -(pad) or Shift+-(pad)

VT Numpad Period Shift+.(pad)

VT PF1 to VT PF4 F1 to F4

VT Prev Page Up² or
9(pad)

VT Remove Delete or .(pad)

VT Select Home² or
7(pad)

VT User F6 to VT User F12 Ctrl+F6 to F12

VT User F13 to VT User F20 Ctrl+Shift+F1 to F8

² Indicates the key on the main keyboard.
(pad) Indicates a key on the numeric keypad.

Note: The Enhanced keyboard has some duplicated keys. The functions
of the duplicated keys are the same except when you specify a single
key. For example, Del means any Delete key, whereas Pad Del specifies
only the Delete key on the numeric keypad.
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Chapter 5. ASCII Host File Transfer

Setting Preferences
You can set up your Workstation to perform file transfers; some preferences need
to be set first, as described in this section. Other facilities to simplify handling of
transfers are also described.

Using XMODEM and YMODEM
Personal Communications allows you to transfer files to and from ASCII hosts that
support the XMODEM and YMODEM protocols. In order to use XMODEM or
YMODEM, you must have established a connection to an ASCII host.

For file transfer over asynchronous lines, you must select eight data bits and
hardware flow control. See “Configuring Links for VT over Async” on page 23 for
details.

Choosing a Protocol
You have four choices for protocols. The one you select will depend upon the
protocols supported by your ASCII host and by your particular requirements. The
following table shows the capabilities of the protocols:

Downloading Uploading

Single File Multiple Files Single File Multiple Files

XMODEM Yes No Yes No

XMODEM1K Yes No Yes No

YMODEM Yes Yes Yes Yes

YMODEMG Yes Yes Yes Yes

XMODEM

The XMODEM protocol is a single-file half-duplex protocol that performs
error checking. Data is transmitted in 128-byte packets. Error checking,
either by CRC or by checksum, occurs automatically. The Personal
Communications implementation of XMODEM first tries CRC. If the
sender fails to acknowledge the first three requests for CRC, XMODEM
shifts to the checksum mode.

XMODEM1K

The XMODEM1K protocol is the same as XMODEM, except that it always
uses CRC and has a larger packet size of 1024 bytes. Because some hosts
are not able to handle the 1024-byte packets, there is a need for both
XMODEM and XMODEM1K

YMODEM

The YMODEM protocol is similar to XMODEM, but it allows you to send
multiple files in a single transfer. You may use a set of unique file names,
or you may specify groups of files.

YMODEMG
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The YMODEMG protocol is the same as YMODEM, supporting multiple
files, but it does not supply error checking. It assumes that the data always
transfers correctly, and is only for use with error-correcting modems. For
large amounts of data it can achieve much greater throughput than
YMODEM because it does not wait for packet acknowledgment.

XMODEM and XMODEM1K
To use XMODEM, click Edit → Preference → Transfer in your Personal
Communications session. The Transfer Preferences window appears. Select the
XMODEM or XMODEM1K protocol, and optionally click on the tab for the
selected modem protocol to define the Transfer Type or to change advanced
settings.

When receiving a file, in the Receive File from Host dialog box, enter the file name
in the PC File field or select a personal computer file name from the drop-down
listbox. The transfer type is automatically generated according to the templates.

YMODEM and YMODEMG
To use YMODEM, click Edit → Preference → Transfer in your Personal
Communications session. The Transfer Preferences window appears. Select the
YMODEM or YMODEMG protocol, and optionally click on the tab for the
selected modem protocol to define the Transfer Type or to change advanced
settings.

When receiving a file, you cannot select the personal computer file name, but you
can change the default transfer type, the drive, and the directory, if necessary.

File-Transfer Timeout
You can define the time the workstation waits for a response from the host system
(in seconds). If the host system does not respond, the transfer is canceled, and an
error message appears. A number in the range 20–65535 (or 0) can be specified.
The default is 60 seconds for ASCII sessions. Specify an appropriate value such
that the error message does not appear too early. If you specify 0, a timeout is not
set.

If a packet or block size is relatively large for low-speed lines, such as COM port
lines, it is recommended that 150 seconds or greater be specified.

Extension for List-Files
You can change the default extension (.SRL) of file-transfer list files.

Show Status Window
You can choose the method of displaying the file-transfer-progress status.

In Session
When file transfer starts, the status window appears. The name of the file
being transferred and the transfer progress appear.

In Icon
When file transfer starts, the status icon appears on the screen. If the icon
is restored, the status window appears.

Defining Transfer Types
Transfer types define the option information used for controlling file transfer. Up
to 32 transfer types can be defined for each host system. The original default types
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are: delete (deletes a file on abort), over (overwrites existing files) and none (does
not delete on abort, and does not overwrite).

To add or change transfer types:
1. Click Edit → Preference → Transfer.
2. Click the tab for the modem protocol you have selected. The items that appear

depend on the selected host system.
3. Enter transfer-type names in the Transfer-Type text box, or select them from

the drop-down list.
4. To add or replace a transfer type, click Save. To delete a transfer type, click

Delete.
5. Depending on the transfer type, select one of the following file receive options:

Delete File on Abort
With this option, if a file transfer is aborted then the incompletely
received file is automatically deleted.

Overwrite Existing File

With this option, any existing file with the same name as the incoming
file is overwritten.

If you do not select this option, then a new name is given to the
incoming file, according to the following scheme:

Existing file: EXAMPLE.TXT
First contender becomes: EXAMPLE.TX1
Second contender: EXAMPLE.TX2
Tenth contender: EXAMPLE.T10
Hundredth contender: EXAMPLE.100
999th contender: EXAMPLE.999

6. Click OK.

These options are independent of each other.

File Transfer Templates
For sending ASCII files, Personal Communications automatically generates Host
file names and transfer types. For receiving ASCII files via XMODEM and
XMODEM1K, Personal Communications generates a transfer type. In both
situations, templates define the rules for file name and transfer type generation.

Defining Templates
The templates are common for all sessions and are used for both sending and
receiving files. For ASCII host file transfer, you can define up to three templates for
each protocol.

To display the templates panels, click the Templates button in the Send File to
Host or Receive File from Host panel.

You can add, delete, or replace templates; you can also test templates to see how
Personal Communications generates the target file name and transfer type.

When defining templates, you can use * (asterisk) for the global searching of file
names; for example, *.EXE for all files that have a file name extension of EXE.
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Automatic Generation of File Names
The templates are numbered from 1 to 32; when Personal Communications
generates file names, the templates are searched, starting from 1, and the first
template that matches is used.

Example of ASCII Protocol Template
The following example shows the use of templates for ASCII host file transfer.
When sending files, Personal Communications automatically generates a host file
name from a personal computer file name, and vice versa. It also generates a
transfer type. When receiving files, Personal Communications automatically
generates only transfer types, and only for the XMODEM and XMODEM1K
protocols.

For more information about templates, refer to the Administrator’s Guide and
Reference.

Following are the definitions of the three default templates. The template is
selected from the available choices by matching the name of the file being
transmitted or received against each template’s file specifications.

Template Number

Wildcard
specification for PC
File

Wildcard
specification for host
File Type

1 *.exe *.* delete

2 *.txt *.* over

3 *.* *.* none

Send Example: If you enter program.exe, Personal Communications selects
template 1, and displays program.exe delete in the list box.

Receive Example: (XMODEM AND XMODEM1K only) If you enter program.exe,
Personal Communications selects template 1, and displays program.exe delete in
the list box.

Working with Lists of Files
For transferring a group of files it is convenient to use a list. A list makes it easier
to transfer the same groups of files frequently, with a single command. Even if you
are transferring a group of files only once, a list can help prevent errors. A list of
files is itself a file.

You can transfer multiple files at once by using the send/receive list; it is
accessible from the Send Files to Host or Receive Files from Host windows. For
either window, the files selected are displayed in a Transfer List. This list can be
saved, and later retrieved and modified. For instructions on selecting a file, see
“Receiving Files From an ASCII Host” on page 41 and “Sending Files to an ASCII
Host” on page 42.

File Name Extension for List Files
By default, send/receive list files have a file name extension of .SRL. You can
change this default on the property page with the General tab, by clicking
Preferences → Transfer from the Edit menu.

Note: Personal Communications does not recognize a file as a send/receive list file
unless its name has the specified extension.
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Remove From List
By clicking the Remove button, you can delete the selected file from a
send/receive list.

Open List File
If you click the Open List button, the Open File-Transfer List File dialog box
appears, allowing you to manipulate the file names in the list.

Save List File
If you click the Save button, the Save File-Transfer List File As dialog-box appears
and you can save the list of files.

Changing a List of Files
You can make changes to a list of files to be transferred:

Change the Personal Computer or Host File Name: When you select a file to
send or receive, Personal Communications automatically generates a host or
personal computer file name by using templates. To change the generated file
name, just type over it.

Note: When receiving a file from an ASCII host, you specify the host file name on
the host system.

For receiving files, you can select a personal computer file from the dialog
obtained by clicking the Browse button.

Note: The browse function is not available when receiving files from an ASCII host;
it is available when sending files, but only when using the YMODEM or
YMODEMG protocols.

Delete File Names From List: To delete a file from the list, select it from the list
and click the Remove button.

Add More File Names To List: To add more files to the list, select a file in the PC
File list box with Ctrl + left mouse-button, or type a file name in the PC File entry
field and press Enter.

Receiving Files From an ASCII Host
Receive File From Host allows you to receive files from a host system to your
personal computer; with one command, you can receive a single file or several. If
you often receive the same list of files, you can save the list of file names and
receive all the files with one command.

For ASCII host file transfer, the host system must support one of two protocols,
XMODEM or YMODEM.

Selecting a Workstation Directory
To receive files to a workstation directory, you can key in the directory information
or click the Browse button to open the Browse dialog and select the directory; this
can be done as part of setting preferences (setting the Default PC Directory field)
or at the time of the file transfer.
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Selecting Files to Receive
For ASCII host file transfer, select the file to receive on the host system.

Follow these steps to receive one or more files from an ASCII host:
1. For the COM port interface (VT over Async attachment only), set the Flow

Control to Hardware. To display the window for setting flow control, follow
these steps:
a. Click Configure from the Communication menu in an active session; or

click Programs → IBM Personal Communications → Start or Configure
Sessions from the Windows Start menu. Start the desired profile from the
Session Manager, then click the Configure button. The Customize
Communication window appears.

b. Click the Link Parameters button. The VT Async Attachment window
appears.

c. Click the Advanced button to display a second attachment window with
the Flow Control field; select Hardware.

d. Click OK in each window successively to return to your Personal
Communications session window.

2. Prepare the host system. The exact method of preparation, including selection
of file names, depends on the kind of host system to which you are connected.
Contact your host-system administrator for details.

Note: The host system must support one of two protocols: XMODEM or
YMODEM.

3. Click Edit → Preference → Transfer to display the Transfer Preferences window.
Select the type of protocol you want to use from the drop-down list box on
the property page with the General tab.

4. In the Default PC Directory field, type the workstation directory where the
file or files should be sent; or, click the Browse button to open a dialog and
select the directory.

5. To change the transfer parameter defaults for the protocol you selected, click
the tab to display the property page for the selected modem protocol.

6. When all preferences have been set, click OK.
7. Click Receive File from Host from the Actions menu. The Receive File from

Host window appears.
8. For XMODEM and XMODEM1K, click the Browse button to open a dialog

and select a personal computer file name or names, or enter the names in the
PC File entry field. The transfer type is automatically generated and appears
in the Transfer Type entry-field.

9. For YMODEM and YMODEMG, select the transfer type and click the Browse
button to open a dialog and change the directory, if you desire.

10. Click the Receive button to display the Receive Files Status window and start
the transfer.

Sending Files to an ASCII Host
Send file to host allows you to send files from your personal computer to the host
system; with one command, you can send a single file or several files. If you often
send the same list of files, you can save the list of file names, and subsequently
send all the files with one command.

Note: This is supported using the YMODEM and YMODEMG protocols only.

42 Personal Communications VT Emulator User’s Reference



Selecting Files to Send
There are several ways to select files to send:

Basic Methods
Type a file name in the PC File field and press Tab; a host file name and a transfer
type are generated automatically according to the templates.

Select files from the dialog obtained by clicking the Browse button.

Select From a Send/Receive List
If you have saved a list of file names in a send/receive list, click the Open List
button and select the list you want to use; the file names saved in the list appear.

Note: For ASCII host file transfer, you can use the send/receive list only with the
YMODEM and YMODEMG protocols (not with XMODEM or XMODEM1K).

Advanced Method
The Browse window, obtained by clicking the Browse button, displays all the files
in the current directory; you can display only certain types of files if you want to.

For example, if the directory has many files and you want to display only files that
have the extension .DOC, you can type *.doc in the PC File field and click the
Browse button; the resulting dialog shows only files that have the extension .DOC.

Changing the Host File Name or the Transfer Type
When you select a file to send, Personal Communications automatically generates a
host file name and selects a transfer type from the default templates. You can
change the file name by typing over the text in the Host File field; you can change
the transfer type by selecting a different one from the Transfer Type drop-down
list.

Saving a List of Files to Send
If you frequently send the same set of files, it is a good idea to save the names in a
list, called a send/receive list.

Note: For ASCII host file transfer, you can use the send/receive list only with the
YMODEM or YMODEMG protocols (not with XMODEM or XMODEM1K).

Sending a List of Files
Select the list, then click the Send button.

PC Code Page
When a file is transferred, EBCDIC codes are converted to 1-byte workstation
codes, and vice versa. A valid value is automatically selected from among the
following values for SBCS sessions: 437, 737, 806, 813, 819, 833, 850, 852, 854, 857,
858, 860, 861, 862, 863, 864, 865, 866, 869, 874, 912, 915, 916, 920, 921, 922, 1008,
1089, 1124, 1125, 1127, 1129, 1131, 1133, 1153, 1155, 1156, 1157, 1158, 1160, 1164, 1250,
1251, 1252, 1253, 1254, 1255, 1256, 1257, and 1258; and from the following values
for DBCS sessions: 897 and 1041 (Japanese); 1088 and 1126 (Hangeul); 1114
(Simplified Chinese and Traditional Chinese)—according to the host code page
specified when the workstation is configured. For an explanation of how to select
host code pages, see the online help for the host code page.
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Chapter 6. Printing

You can use Personal Communications to print from display sessions.

From display sessions, you can print all (Print Screen) or part (Trim Print) of the
screen of your session window on a workstation printer. For more information,
refer to Quick Beginnings or the online help.

Note: When you use a host application which prints to your workstation’s LPT1,
you must first select the printer in the Printer Setup dialog of the File
menu.

Setting Up the Printer
Following is a description of how to set up your printer with either a Windows
printer driver or a PDT file.

Using PDT Files
To use a PDT file:
1. Click File → Printer Setup from the menu bar of the session window.

The Printer Setup window appears.
2. Click the printer to be used from the list box.
3. Click Setup; specify the paper size.
4. Click OK.
5. Click the Use PDT check box, then Select PDT.

The Select PDT file window appears.
6. Do one of the following:

v To use an existing PDT, select the PDT file to be used; then click OK.
v To use a PDF that you have modified, you must first convert it to a PDT. To

do so:
a. Click Convert PDF.
b. Select the PDF file to be converted from the list, then click Convert.

The window displays the result of the conversion. If there are any errors
during the conversion, they are listed in the window.

c. When you select Save List, the window list is saved in *.LST file in the
PDFPDT subdirectory.
To close without saving the list, click Close.
After the file is converted, control returns to the Select PDT file window
and the converted PDT file appears in the list.

d. Select the PDT file; then click OK.
7. Click OK in the Printer Setup window.
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Page Setup Parameters
You can set Page Setup parameters, such as the maximum number of lines per
page, the maximum number of columns, and fonts. These parameters are initially
set to the defaults. Use this function to change specific control items.

Note: When a PDT file is used, this function cannot be used.

You can set the following parameters.

Table 5. Page Setup Parameters — Text

Parameter Description

CPI Specifies the number of characters to be printed per inch. If CPI
was not set previously, a CPI value suitable for the font selected
from the Font list box is assumed as the default.

LPI Specifies the number of lines to be printed per inch. If LPI was not
set previously, an LPI value suitable for the font selected from the
Font list box is assumed as the default.

Maximum Number of
Lines per Page

Specifies the maximum number of lines per page. A number in the
range 1–255 can be specified. The default is 66. See Note 1.

Maximum Number of
Characters per Line

Specifies the maximum number of characters per line. A number in
the range 1–255 can be specified. The default is 132. See Note 2.

Font Lists, in the list box, the fonts that can be used with the currently
selected printer.

The fonts in brackets [ ] are device fonts specific to the printer
driver. The other fonts are graphics display interface (GDI) fonts
printed in bit map formats.

Notes:

1. When you set this to a value other than the default, Personal Communications uses it
to scale the LPI and font to the best fit for the page.

2. When you set this to a value other than the default, Personal Communications uses it
to scale the CPI and font to the best fit for the page.

From a Personal Communications display session, you can set additional
parameters by selecting the Text Options tab, as follows:
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Table 6. Page Setup Parameters — Text Options

Group Options Setting

Print Options The following
options can be selected as print
options. These options are not
available for the printer session.

Suppress null lines Determines whether to delete
lines containing only null or
non-printable characters (null
or non-printable field
characters, and field attributes)
or to print them as null lines.

Selected
Null lines are not
printed.

Not selected
Null lines are printed.

This option can be used when:

v The Print Screen command
is used

v LU type 3 printing, or
non-SNA printing is done

v The combination of bits 2
and 3 of the WCC is not 00.

Print nulls as spaces Determines whether to print
NULL control codes as null
characters.

Selected
The codes are printed
as blanks.

Not selected
The codes are treated
as null characters.

This option can be used when:

v The Print Screen command
is used

v LU type 1 or 3 printing, or
non-SNA printing is done.
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Table 6. Page Setup Parameters — Text Options (continued)

Group Options Setting

Ignore FF when at
first print position

Determines whether to ignore
the FF code at the beginning
of the buffer address.

Selected
The FF code is
ignored and not
executed.

Not selected
The FF code is
executed.

This option can be used when:

v The Print Screen command
is used

v LU type 1, LU type 2, LU
type 3, or non-SNA printing
is done.

This option cannot be used in
5250 sessions.

FF takes a print
position if followed
by data

Determines whether to print
null characters if data follows
the FF code.
Selected

FF is executed, and a
blank character is
printed at the
beginning of the next
page. Therefore, the
next data is printed
in the second column
of the line.

Not selected
FF is executed, and
the next data is
printed at the
beginning of the first
line on the next page.

This option can be used when:

v The Print Screen command
is used

v Host initiated local copy
and LU type 3 printing, or
non-SNA printing is done

v In both PDT and standard
modes

This option cannot be used in
5250 sessions.
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Table 6. Page Setup Parameters — Text Options (continued)

Group Options Setting

Suppress auto new line when: CR at maximum print
position +1 Determines whether to

perform automatic new line
when CR is the maximum
number of columns to be
printed away from the first
column.
Selected

Automatic new line is
not done. The
characters after the
CR code are printed
on the same line.

Not selected
Automatic new line is
done.
Determines whether
to perform automatic
new line/carriage
return before new
line/carriage return
(NL) is done when
NL is the maximum
number of columns to
be printed away from
the first column.

This option cannot be used for
5250 sessions.

NL at maximum print
position +1 Selected

Automatic new line is
not done.

Not selected
After automatic new
line is done, new line
is done again.

This option can be used when
LU type 3 printing or
non-SNA printing is done and
the combination of bits 2 and
3 of the WCC is 00.

This option cannot be used in
5250 sessions.

Form Feed Position
Note: This cannot be used for
5250 sessions.

Any position Determines that printing can
start at any position on the
page.

Column 1 only Determines that printing starts
at column 1 of the page.

To set or change setup items:
1. Click File → Page Setup from the menu bar of the session window.

The Page Setup window appears.
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2. Select the tab that contains the parameters you want to change.

Note: To switch from the current settings back to the defaults, select Default.
3. When all the items have been set, click OK or Apply.

Printing to Disk
If you are using a PDT, you can save a host print-job or the contents of the session
window (Print Screen) to a workstation file instead of printing it.

Two types of Print-to-Disk function are provided by Personal Communications:

Print-to-Disk Append
Appends multiple host print jobs or print screen jobs to a single
workstation file.

Print-to-Disk Separate
Saves each host-print job or screen to a separate workstation file. You can
specify the file name, but the extension is automatically assigned as a
decimal number from 000 to 999. If you delete a file, its number will be
re-used. When all 999 numbers have been used, the extension is
automatically assigned a decimal number from 1000 to 9999.

Notes:

1. Print-to-Disk is not available for the Print-Graphics function.
2. Print-to-Disk can be used only when you use a printer definition table (PDT)

file.

To set up Print-to-Disk:
1. Click File → Printer Setup from the menu bar in the session window.

The Printer Setup window lists the supported printers.
2. Select Print to Disk Append or Print to Disk Separate from the list box.
3. Click Select PDT.

The Select PDT file window appears.
4. Select a PDT file from the list; then click OK.

The Printer Setup window reappears.
5. Click Setup.

The File Selecting window appears.
6. Specify a file name, drive, and path; then click OK.

Note: If you specify the name of an existing file, subsequent print jobs are
appended to the data in the original file in the case of Print to Disk
Append.

Printing Japan Postal Bar Code
In support of the new postal bar code implemented in Japan, Personal
Communications provides print capabilities for postal bar codes.
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Workstation Profile Parameter for Code Page
Occasionally a font does not support the desired code page. The wrong characters
may be printed within the specific character set (Latin 2, for example). Personal
Communications has a workstation profile parameter that allows the program to
use a different code page that is supported by the desired font.

You can use the PrinterFontCodePage parameter if the following conditions are
met:
v If you can specify the printer font code page with which the desired font is

encoded.
v If Personal Communications provides the translation table for the host code page

and the printer font code page.

However, since some Personal Communications releases may require manual
adjustment of the workstation profile, try using different fonts before altering the
.ws file. Fonts are listed in the Personal Communications Page Setup panel for all
display sessions and 3270 host print sessions. For 5250 print sessions, the
PCSPD.DAT file can be manually changed to control the fonts used. The Courier
New font should support most languages and corresponding code pages.

To edit the .ws file, you must change the PrinterFontCodePage parameter to the
value of the supported code page you wish to use. This option must be put in the
[printers] section, and is case-sensitive. See the following example for the proper
parameter syntax. The parameter does not need to be placed immediately after the
[printers] section label.
[printers]
PrinterFontCodePage=852

In this case, the desired font is encoded with code page 852. Personal
Communications uses a different, existing translation table to translate data from
EBCDIC to 852, versus using the standard Windows code page.
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Chapter 7. Log Viewer Functions

The Personal Communications log viewer utility enables you to view, merge, sort,
search, and filter information contained in message and trace logs. You can use the
viewer during problem determination to work with message and trace log entries.
The default name of the message log output file is PCSMSG.MLG; its file extension
must be .MLG. The file extension for trace logs must be .TLG. Note that the Help
per Message Log Item functionality is available only for message logs.

Viewing Message and Trace Logs
To view message or trace logs:
1. From the Administrative and PD Aids folder, click Log Viewer; or, from an

active session window, click Actions → Launch → Log Viewer.
2. From the list of logged messages, click on one of the details on the log entry in

the bottom pane.

Note: If the logger device driver determines that the product kernel
driver-generated log is full and cannot log a message, it will create an entry
in the Windows log. The information logged may include which log failed,
as well as the location and reason for the failure.

Changing Message Log Size and Location
The Personal Communications log viewer utility allows you to modify the size and
location of message log files, and change the name of the default message log file.
The size of a log file is counted in kilobytes and can range from a minimum of
4Kb to a maximum limited only by available hard disk space.

To modify the location and size of the log:
1. From the Log Viewer main menu, click Options and then click Configure

Message Log Settings... A Windows common dialog box is displayed.
2. From the dialog box, browse the directory structure and choose the destination

directory and file name for the message log.
3. Using the spin control counter field, use the up and down arrows to increase or

decrease the log file size (in kilobytes).
4. Select OK to save settings and exit the window.

Merging Message and Trace Logs
The Personal Communications log viewer utility allows you to open and merge
message and trace log entries in the same log viewer window. You can merge any
combination of message and trace log files.
v .MLG into .TLG
v .TLG into .TLG
v .TLG into .MLG
v .MLG into .MLG

To merge message and trace log files:
1. From the Log Viewer window, select the message or trace log file window

where the files will be merged.
2. Click the File menu, then click Merge and choose a file to be merged.
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Sorting Message and Trace Logs
The Personal Communications log viewer utility allows you to sort message and
log files in ascending and descending order. To sort files in ascending order, click
the column header one time, or right mouse click the data. Click the column
header, or right mouse click the data a second time to sort in descending order.

Message and logs can also be sorted by selecting the data to be sorted, and right
mouse clicking to display the pop-up menu. Click Sort.

Searching Personal Communications Logs
To search the log files, click Edit → Find on the Main menu.

Type your search string in the provided box. You can refine your search by
checking the Match case check box if your search is to be case-specific. If you want
to limit your search to only complete words, select the Match whole word only
check box.

Clicking Find Next takes you to the next instance where your search string
appears highlighted in the log.

Clicking Cancel will stop the search.

Filtering Personal Communications Logs
Messages can be filtered by component only. Traces can be filtered by component,
by process ID, and by thread ID.

To filter the message or trace record list, do the following:
1. Decide what parameter by which you want to filter. For example, in the

message log, you may want to filter your view so that it contains only
messages issued by a particular component. (Filtering by component is the
default.)

2. Click the left mouse button to highlight the item that has the value by which
you want to filter.

3. Right click in the appropriate column list area.
4. Click Filter In, Filter Out or Sort.

Filter In allows only those items selected to be in the resulting view. Filter Out
removes the selected items from the resulting view. Sort allows you to sort
entries in ascending or descending order based upon the entry selected. This
function works much like sorting by column header. Filters are cumulative, so
you can filter the results of your first filter.

To restore your original view, click View and then Refresh, or you can press F5.

Log Viewer Functions
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Appendix. Notices

This information was developed for products and services offered in the U.S.A.
IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
500 Columbus Avenue
Thornwood, NY 10594
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM documentation or non-IBM Web
sites are provided for convenience only and do not in any manner serve as an
endorsement of those documents or Web sites. The materials for those documents
or Web sites are not part of the materials for this IBM product and use of those
documents or Web sites is at your own risk.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
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programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
Department T01
Building 062
P.O. Box 12195
RTP, NC 27709-2195
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement
or any equivalent agreement between us.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

Trademarks
The following terms are trademarks of the IBM Corporation in the United States or
other countries, or both:

APPN
AS/400
AnyNet
GDDM
IBM Global Network
IBM
IBMLink
OS/400
OfficeVision/MVS
SAA
System/390

C-bus is a registered trademark of Corollary, Inc in the United States, other
countries, or both.

Java and all Java-based trademarks and logos are trademarks of Sun Microsystems,
Inc. in the United States, other countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are registered
trademarks of Microsoft Corporation in the United States, other countries, or both.

PC Direct is a registered trademark of Ziff Communications Company in the
United States, other countries, or both.

Notices
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UNIX is a registered trademark in the United States and other countries licensed
exclusively through X/Open Company Limited in the United States, other
countries, or both.

Other company, product, and service names may be trademarks or service marks
of others.

Notices
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Readers’ Comments — We’d Like to Hear from You

Personal Communications for Windows, Version 5.5
VT Emulator User’s Reference

Publication No. SC31-8839-00

Overall, how satisfied are you with the information in this book?
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