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About This Book

This book describes how to install, configure, and start IBM® Personal
Communications. After you get Personal Communications up and running and
begin to perform various tasks, use the online help whenever you need additional
information. See “Where to Find More Information” on page viii for information
about online help, the Personal Communications library, and related publications.
Refer to the IBM Glossary of Computing Terms at the following URL for
definitions of technical terms used throughout this book:

http://www.networking.ibm.com/nsg/nsgmain.htm

This book is for users of:
v IBM Personal Communications for Windows, Version 5.7

v IBM Personal Communications iSeries for Windows, Version 5.7

See “What’s in the Package” for information regarding what is in the product
package.

In this book, Windows® refers to Microsoft® Windows 95, Windows 98, Windows
NT®, Windows Me, Windows 2000, and Windows XP. When information is
applicable only to a specific operating system, this will be indicated in the text.

What’s in the Package
The Personal Communications Version 5.7 package contains IBM Personal
Communications for Windows, Version 5.7, which provides 5250, 3270, and VT
emulation and connections to z/OS™, z/VM™, iSeries™, zSeries™, ASCII, and
System/36™ or System/38™ (S/3X) host systems.

In addition to the products previously mentioned, the Personal Communications
CD-ROM contains the following:
v Adobe Acrobat Reader, to enable you to read softcopy books available on the

CD-ROM
v Book files in PDF format

Notes:

1. For each of the two basic packaging options, there are also separate CD-ROMs,
depending on:

National Languages
There is a multiple-language version that supports up to nineteen
languages at the same time. There are also single language versions for
v Traditional Chinese
v Simplified Chinese
v Korean

Security Levels
Personal Communications is shipped at the 168-bit encryption level.

2. The DB2 Connect™ product is packaged on a separate CD-ROM.

© Copyright IBM Corp. 1989, 2003 vii



Where to Find More Information
The following sections discuss getting help when you are installing, configuring, or
using Personal Communications.

Online Help
The help facility describes how to install, configure, and use Personal
Communications. Online help is very extensive and includes information about
every aspect of configuring and using Personal Communications. You can use
Personal Communications online help just as you use the online help for Windows.

Use help to obtain information about:
v Menu choices
v Operation procedures
v Operations in windows
v Meanings of the terms displayed in windows
v Causes of errors and the corresponding actions to take
v Mouse-based operations
v Operation without a mouse
v Detailed explanations of specific terms
v Further technical information about Personal Communications
v Detailed explanations of operator information area (OIA) messages

The Quick Beginnings book is also available online, in HTML form. You can access
the book from the Help menu in the Session Manager.

Personal Communications Library
The Personal Communications library includes the following publications:
v CD-ROM Guide to Installation
v CD-ROM Guide to Installation
v Quick Beginnings (this document)
v 5250 Emulator User’s Reference
v 3270 Emulator User’s Reference
v VT Emulator User’s Reference
v Administrator’s Guide and Reference
v Emulator Programming
v Client/Server Communications Programming
v System Management Programming
v CM Mouse Support User’s Guide and Reference
v Host Access Class Library
v Configuration File Reference

In addition to the PDF documents, there are HTML documents provided with
Personal Communications:

Quick Beginnings
The HTML form of Quick Beginnings contains the same information as the
PDF version. The HTML files are installed automatically and can be
accessed from the Help menus in the Session Manager and .WS session
panels.

Host Access Class Library for Java
This HTML document describes how to write an ActiveX/OLE
2.0–compliant application to use Personal Communications as an
embedded object.
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Host Access Beans for Java
This HTML document describes Personal Communications emulator
functions delivered as a set of JavaBeans™.

Related Publications
For information about local area networks (LANs), refer to the following
publications:
v IBM Local Area Network Technical Reference
v AS/400 Communications: Local Area Network (LAN) Guide Version 2

Contacting IBM
This section lists ways you can reach IBM in case you encounter a problem or
concern with Personal Communications. Depending on the nature of your problem
or concern, we ask that you be prepared to provide the following information to
allow us to serve you better.
v The environment in which the problem occurs:

– Personal Communications configuration
- Personal Communications version and CSD level
- The name of the workstation profile
- The name of the SNA Node Configuration file

– Workstation configuration
- The machine type and model, the system memory, the video adapter
- The communication adapter you are using
- Other adapters (especially communication adapters) installed
- The printer type and model
- Other devices installed, such as sound cards, modems, or fax machines

– Software configuration
- Windows version and level
- Communication and device-driver version and level
- Other communication programs (such as Microsoft SNA Server or

Microsoft Data Link Control) that are running and using resources
- Printer driver version and level

– Host configuration
- The upstream host connection and configuration

v Problem analysis information
– Symptoms
– Type of problem
– OIA messages or error messages (if any)
– Key factors related to the problem

If you have a technical problem, take the time to review and carry out the actions
suggested here. Use your local support personnel before contacting IBM. You can
also check the Hints and Tips at the Personal Communications support Web page
for more information. Only persons with in-depth knowledge of the problem
should contact IBM; therefore, support personnel should act as the interface with
IBM.

For information about the tools available to help with problem analysis, refer to
the individual VT, 3270, and 5250 emulators user’s references for IBM Personal
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Communications Version 5.7. These references also provide detailed, specific
emulator information about printing, file and data transfer, node operations, and
other topics.

Support Options
If you determine that you need to contact IBM, you can do any of the following:
v Access the Personal Communications Web page at the following URL:

http://www.ibm.com/software/network/pcomm
v To find the phone number for IBM Software Support, U.S. customers can call

1-800-IBM-4YOU. International customers that have access to the U.S. ″800″ toll
free numbers can reach the International Support Center by calling
1-800-IBM-4YOU and asking to speak with the International Support Center
(ISC) in Atlanta. International customers without access to the U.S. toll free
numbers can call the ISC directly at 770-863-1234. The ISC’s FAX number is
770-863-3030 and is available 24 hours a day.
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Chapter 1. Welcome to Personal Communications

Personal Communications brings the power of personal networking to your
workstation by exploiting networking capabilities to provide a variety of
connectivity options supporting local area network (LAN) and wide area network
(WAN) environments. Whether it is for host terminal emulation, client/server
applications, or connectivity, Personal Communications offers a robust set of
communication, networking, and administrative features.

Personal Communications is a full-function emulator. In addition to host terminal
emulation, it provides these useful features:
v File transfer
v Dynamic configuration
v An easy-to-use graphical interface
v APIs for SNA-based client applications
v An API allowing TCP/IP-based applications to communicate over an SNA-based

network

A variety of SNA-based client application programming interfaces (APIs) are
supported by Personal Communications. You can create applications that use the
peer-to-peer client APIs, which are based on LU 6.2 and provided by Personal
Communications. These APIs let you simultaneously access and process
information on peer workstations.

Personal Communications supports Advanced Peer-to-Peer Networking® (APPN®)
as an end node, and uses the advanced network features: high-performance
routing (HPR) and dependent LU requester (DLUR).

AnyNet® SNA over TCP/IP is a feature of Personal Communications which allows
emulator and client/server SNA applications to communicate over a TCP/IP
network.

Enterprise Extender allows you to extend the reach of SNA applications and data
to include IP networks and IP-attached clients with similar levels of reliability,
scalability, and control as SNA users. Personal Communications supports the
Enterprise Extender (EE) DLC.

What’s New in Personal Communications Version 5.7
Personal Communications Version 5.7 is based on the popular Personal
Communications Version 5.6. If you are familiar with Personal Communications
Version 5.6, you might want to review the following new functions and
enhancements.

Emulator session enhancements

Connection timeout
For emulator Telnet sessions, the Connection Timeout and Try
connecting to last configured host infinitely options allow you to
modify connection waiting and reconnection behavior. See
“Creating a Configuration” on page 25.
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IPv6 support
For emulator Telnet sessions, Personal Communications Version 5.7
supports IPv6 addresses. This support is available on Windows XP
(SP1 or later) and Windows 2003.

Accessibility enhancements
Personal Communications Version 5.7 has been enhanced to further
facilitate the use of accessibility devices such as screen readers.

Expanded OIA
You can display an accessible version of the Operator
Information Area by clicking View → Expanded OIA in an
emulator session. You can also map a key combination to
toggle focus to and from the Expanded OIA display.

Popup Keypad
The Customize Poppad dialog allows you to customize the
dimensions of individual keypads. You can also map key
combinations to display a specific popup keypad and
toggle focus to and from the keypads.

New emulator features

Collect and print multiple print screens
The Collect Screen feature allows you to gather individual print
screens, to be printed at the same time. You can print the collected
screens with the Print Collection function. These functions can be
used concurrently with the regular Print Screen function. See
“Collect Screen and Print Collection” on page 48.

Autostart Java Applet
To run a Java™ applet automatically, you can add the function Run
Applet to a macro. You can add this function to an autostart
macro, so that an applet can be run at session startup. See
“Configuring a Java Applet to Autostart” on page 67.

Power management

Standby/Hibernate user preference setting
The User Preference Manager adds a setting to suppress prompts
for permission to standby or hibernate. See “Standby/Hibernate”
on page 84.

Bidirectional enhancements

Symmetric and numeric swapping for Arabic RTL printing
When modifying the printer setup for 3270 Arabic printer sessions,
symmetric and numeric swapping are enabled for RTL host file
orientation. See “RTL Print Orientation” on page 30.

ZipPrint support
For Hebrew and Arabic 3270 sessions, Personal Communications
supports the following ZipPrint functions.
v Print Screen
v Print CMS File
v Print XEDIT Workspace

See “Bidirectional Considerations” on page 51.

Hebrew Symmetric Swapping support for transfers
As with Arabic sessions, Personal Communications supports
Symmetric Swapping for Hebrew file and data transfers.
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Terminal services support
For Windows Terminal Services and other simultaneous user environments,
Personal Communications enables you to automatically stop an SNA node,
and provides enhanced options for automatically starting a node. You can
also control how, and on whose desktop, a transaction program runs. Refer
to Administrator’s Guide and Reference for more information.

SNA Node Configuration

Session-level encryption (SLE)
SNA session-level encryption enables secure data transfer between
nodes running SNA applications. This feature is available on
Windows NT, 2000, and XP, for dependent LU (LU 0 to 3) or LU
6.2 sessions.

Refer to Administrator’s Guide and Reference for more information
about SNA node operations.

Node configuration preferences
Using the SNA Node Configuration utility Edit → Preferences
dialog, you can specify SNA node automatic start and stop
behavior, transaction program context behavior, and the default
node configuration (.acg) file. Refer to Administrator’s Guide and
Reference for more information.

Security

Certificate Management enhancement
Personal Communications provides IKEYMAN command-line
interface ability to manage certificates on Smart Cards.

Transport Layer Security
Personal Communications allows you to negotiate Transport Layer
Security (TLS) 1.0 security.

Refer to Administrator’s Guide and Reference for more information about
security setup and Certificate Management options.

Tivoli Support
Personal Communications supports Tivoli® Software Distribution Version
4.2. Refer to CD-ROM Guide to Installation for information about installing
Personal Communications using Tivoli Software Distribution.

Personal Communications Program Icons
When you have installed Personal Communications, the main functions that you
can use are displayed as icons. Icons are grouped in subfolders of the IBM
Personal Communications program folder.

A brief explanation of each function follows:

Start or Configure Sessions
Use this icon to bring up the Session Manager. This dialog allows you to
start or configure sessions. During configuration, you can specify the
session type, screen size, LU number, graphics support, the type of
communication link and its parameters, as well as other information. You
can save all this information in a workstation profile. After saving, you can
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start the session by just clicking the session icon. Authorized users can also
create new batch files from this dialog.

SNA Node Configuration
Use this icon to configure an SNA node and associated resources or to
change advanced configuration parameters. Although most emulator
sessions can be configured without the use of this utility, you will need to
create an SNA node configuration to enable client/server and peer
communication. This can also be run from an active session by selecting
Actions → Launch → SNA Node Configuration.

IBM Software Registration
Use this icon if you want to be notified of any program updates provided
by IBM.

Administrative and Problem Determination (PD) Aids

Display SNA Sense Data
Use this icon to display SNA sense data and associated explanations. Sense
data is SNA error information located in internal SNA flows, error logs,
error messages, and traces. Some Personal Communications error messages
include sense data.

Information Bundler
Use this icon to gather system files and specific trace and log files, as well
as registry information, such as the software installed or running on a
machine. This can also be run from an active session by selecting Actions →
Launch → Information Bundler.

Internet Service
Use this icon to send system and diagnostic data collected by the
Information Bundler to an FTP server. This can also be run from an active
session by selecting Actions → Launch → Internet Service.

Log Viewer
Use this icon to view, merge, and sort the Personal Communications
message and trace logs. Personal Communications logs errors and
informational messages during initialization and operation. This can also
be run from an active session by selecting Actions → Launch → Log Viewer.
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Migration Utility
Use this icon to migrate your user-class and system-class files and desktop
icons to Personal Communications Version 5.7.

Product Update Tool
Use this icon to access WebUpdate and check for Authorized Program
Analysis Reports (APARs) and Corrective Service Distributions (CSDs).

SNA Node Configuration Verification
Use this icon to verify that the ASCII editing changes that you have
manually made to the SNA node configuration data are valid.

SNA Node Operations
Use this icon to perform SNA node operations, such as starting or stopping
resources or displaying resource information. This can also be run from an
active session by selecting Actions → Launch → SNA Node Operations.

Trace Facility
Use this icon to turn trace functions on and off and to capture
communication-protocol information that passes between your workstation
and other host systems. You can use traces to resolve communication
problems. This can also be run from an active session by selecting Actions
→ Launch → Trace Facility.

Utilities
The APING and AFTP utilities are available in U.S. English only.

Note
THESE PROGRAMS ARE PROVIDED ON AN AS-IS BASIS WITHOUT ANY WARRANTY OF ANY KIND,
INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE

WHICH ARE EXPRESSLY DISCLAIMED.

iSeries Connection Configuration
Use this icon if you want to define connections to each iSerieshost that will
use the data transfer function.

Certificate Management
Use this icon to enable Secure Sockets Layer (SSL) communication between
your communication server and client. Refer to the Administrator’s Guide
and Reference for details on how to use this utility.
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Check Connection APING
Use this sample CPI-C program to verify network connections. You can use
APING to establish network connections, diagnose problems, and take
simple performance measurements. APING exchanges data packets with a
partner computer and measures how long the data transfer takes.

CM Mouse
Use this icon to define mouse buttons to perform any sequence of host
keystrokes, including PF keys and special emulator control keys. You can
also build popup menus to control host applications without making any
changes to those host programs.

Note: CM Mouse is a sample application that has been provided for use as
a utility. It is only available in English and only runs on SBCS
systems.

This utility can only be installed using the Custom Installation
option. Refer to the CD-ROM Guide to Installation for more
information.

CM Mouse Configuration
Use this icon to configure the CM Mouse Scripting utility.

Convert Macro
Use this icon to convert an existing Personal Communications macro to an
XML or VBScript file.

Data Transfer (iSeries only)
Use this icon to transfer data between a workstation and an iSeries
database.

Database Access
Use this icon to start the Database Access utility that lets you retrieve data
from a database, such as an SQL server, Microsoft Excel, Lotus® 1-2-3®, or
dBASE database (that complies with Microsoft ODBC standards, Level 1).
You can then pass the retrieved data directly to Excel, Lotus 1-2-3, and
other applications.
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DOS EHLLAPI
Use this icon to enable or disable DOS-based EHLLAPI programs that
communicate with the 32-bit Personal Communications emulator.

Menu-Bar Customization
Use this icon to customize the menu bar in the session window.

Multiple Sessions
Use this icon to create batch files (.BCH), which can specify multiple
emulator sessions (workstation profiles) or other supported Windows
programs that you want to start concurrently. You can create an icon for
each batch file and start the programs just by clicking the icon.

Transfer File AFTP
Use this program to provide a fast and efficient transfer of text and binary
files.

User Preferences
Use this icon if you want to set up or change the user preferences, such as
changing the user interface language.

ZipPrint (3270 only)
Use this icon to start the ZipPrint program, which allows you to print host
system files or screens, PROFS® or OfficeVision® notes, calendars, and
documents, CMS files, and XEDIT workspaces. When started, ZipPrint
adds an item to the menu bar of the session window.

Personal Communications Sessions
The sessions that Personal Communications provides are logical connections
enabling communication between your workstation and a host system. The
following session types are available:
Display session

Use your workstation as a display terminal connected to the host system.
Printer session

Use your workstation printer as a host system printer.
Client/server session

Establish connections that allow peer communications using CPI-C and
APPC (LU 6.2).

Chapter 1. Welcome to Personal Communications 9



Personal Communications Connections
Personal Communications supports a variety of connections to the following host
systems. Following are the icons you will encounter when you begin to configure
an emulator session:

zSeries

iSeries

ASCII

S/3X

zSeries Emulator Connections
Table 1. zSeries Emulator Connection Icons

Interface Attachment

LAN LAN via IEEE 802.2
3270 via Communications Server for Windows
Telnet3270
3270 via iSeries (passthru)
APPC 3270 via LAN
Microsoft SNA client over FMI
Microsoft SNA client (using the LUA interface)
Microsoft SNA client (using the APPC interface)
Dependent LU Requester (DLUR)
3174 Peer Communications
VT-over-Telnet (TCP/IP)

COAX SNA Distributed Function Terminal
Non-SNA Distributed Function Terminal

COM port SNA-over-Async
IBM Global Network® (not in Japan)
Home3270
IBM Global Network - SNA-over-Async
Dependent LU Requester (DLUR) via

SNA-over-Async
Hayes AutoSync

Hayes AutoSync
APPC 3270 via:

SNA-over-Async
Hayes AutoSync

VT over Async
Telnet 3270
VT over Telnet (TCP/IP)
X.25 Hayes AutoSync
X.25 DLUR via Hayes AutoSync
X.25 APPC 3270 via Hayes AutoSync
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Table 1. zSeries Emulator Connection Icons (continued)

Interface Attachment

5250 3270 via iSeries
Dependent LU Requester (DLUR)

SDLC Synchronous Data Link Control
3270 via iSeries (passthru)
APPC 3270 via SDLC
Dependent LU Requester (DLUR)

SNA/IP LU 0, 1, 2, 3
APPC 3270
LU 0,1,2,3 via DLUR

IBM ISA/MCA WAC Synchronous Data Link Control
3270 via iSeries (passthru)
APPC 3270 via SDLC
Dependent LU Requester (DLUR)
X.25 Qualified Logical Link Control
X.25 3270 via iSeries
APPC 3270 via X.25
X.25 DLUR

API Client Communications Server client
Communications Server

IBM-EEDLC LU (0, 1, 2, 3) via DLUR
APPC 3270

OEM LU (0, 1, 2, 3)
3270 via iSeries (passthru)
APPC 3270
Dependent LU Requester (DLUR)

iSeries Emulator Connections
Table 2. iSeries Emulator Connection Icons

Interface Attachment

LAN LAN via IEEE 802.2
Telnet5250 over TCP/IP
Telnet5250 over IPX/SPX
VT over Telnet

5250 Twinaxial Data Link Control (APPC)
Twinaxial Data Link Control (Console)
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Table 2. iSeries Emulator Connection Icons (continued)

Interface Attachment

COM port SNA-over-Async
Hayes AutoSync
SNA-over-Async (Console)
VT over Async
VT over Telnet
Telnet 5250
X.25 Hayes AutoSync

SDLC Synchronous Data Link Control

SNA/IP 5250

IBM ISA/MCA WAC Synchronous Data Link Control (WAC)
X.25 Qualified Logical Link Control

IBM-EEDLC 5250

OEM APPC 5250

ASCII Emulator Connections (SBCS only)
Table 3. ASCII Emulator Connection Icons

Interface Attachment

LAN VT over Telnet (TCP/IP)

COM port VT over Async
VT over Telnet (TCP/IP)

S/3X Emulator Connections
Table 4. S/3X Emulator Connection Icons

Interface Attachment

5250 Twinaxial Data Link Control (Console)
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Client/Server (Peer) Connections
Personal Communications provides APPN end node support for workstations,
allowing them to communicate more flexibly with other systems in the network.

When your workstation is defined as an APPN end node, an APPN network node
server provides the following directory and routing services for your workstation:
v Intermediate session routing
v Directory services
v Topology and route selection services

Using Personal Communications, you can establish client/server connections to a
variety of computers and to workstations running Windows 95, Windows 98,
Windows NT, Windows Me, Windows 2000, or Windows XP. Another option is to
connect the computers to a workstation running Communications Server. Available
SNA client/server connection types are:
v LAN via IEEE 802.2
v Synchronous Data Link Control
v SNA-over-Async
v AnyNet SNA over TCP/IP
v Hayes AutoSync
v IBM Global Network – SNA over Async
v Twinaxial Data Link Control (APPC)
v X.25
v OEM Deep adapter
v WAC
v Enterprise Extender

APPN Networking
Advanced Peer-to-Peer Networking (APPN) is the underlying networking protocol
that routes APPC traffic through intermediate nodes in the network. For instance,
when Program A uses APPC to talk to Program B, APPN finds the node where
Program B is located and directs the APPC traffic through the network.

APPN includes several features that help reduce the amount of configuration
required to set up and maintain a network. These features automate many tasks
that are time consuming, complicated, and error prone. For example, if you’re
installing a new workstation that uses APPN, you don’t have to set up
configuration information for every workstation you want to communicate with.
You simply provide the name of the computer and the address of the intermediate
node that handles your traffic. APPN takes care of the rest of the information
needed to route APPC traffic to and from your workstation.

If you connect to an APPN network, you simplify your own configuration and
make it easier for other computers in the network to find you.

For more information about SNA Client/Server concepts, refer to Administrator’s
Guide and Reference.

APPC
Advanced program-to-program communication (APPC), also known as LU 6.2, is
software that enables high-speed communications between programs on different
computers, from portables and workstations to midrange and host computers.
APPC software is available for many different operating systems, either as part of
the operating system or as a separate software package.
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APPC is a communications protocol that enables programs on different computers
to “talk to” each other. APPC provides the interface between the programs and the
networking hardware and software and defines the rules that programs use to
exchange information.

APPC serves as an interface between application programs and the network. When
the communications application on your workstation passes information to the
APPC software, APPC takes the information and sends it on to a network
interface, such as a Token-Ring adapter card. The information travels across the
network to another computer, where the APPC software receives the information
from the network interface. APPC puts the information back into its original
format and passes it to the corresponding communications application.

Refer to the 3270 Emulator User’s Reference or 5250 Emulator User’s Reference for
more information.

APPN Network
By participating in an APPN network, Personal Communications workstations can
also take advantage of two additional functions:
v High-performance routing
v Dependent LU requester

High-Performance Routing (HPR): Personal Communications supports
high-performance routing (HPR) over token-ring and Ethernet connections, which
increases data routing performance and reliability. HPR supports the rapid
transport protocol to provide nondisruptive rerouting around network outages,
efficient selective retransmission, and end-to-end data integrity and congestion
control.

Dependent LU Requester (DLUR): DLUR allows dependent LUs (LU 0, 1, 2, 3,
and dependent LU 6.2) to benefit from an APPN network. It supports dynamic and
multiple paths through the network and eliminates the need for dependent LUs (or
their gateway) to be adjacent to the VTAM® host.

A DLUR is an APPN end node or network node that owns dependent LUs, but
requests that a dependent LU server (DLUS) provide the system services control
point (SSCP) for those dependent LUs. A DLUS controls conversion from a subarea
environment to an APPN environment, allowing you to maintain central
management of remote dependent LUs while benefiting from an APPN network.

Personal Communications uses the support in VTAM V4R2 for dependent LUs
through APPN networks and combined subarea and APPN networks. The
dependent LU server function (in VTAM) provides dependent secondarylogical
unit (SLU) support by establishing an LU 6.2 session between a dependent LU
requester node (DLUR), and a dependent LU server node (DLUS).

Refer to the information about SNA Client/Server concepts in the 3270 Emulator
User’s Reference or 5250 Emulator User’s Reference for more information.

AnyNet
AnyNet allows any application to communicate over any networking protocol and
to extend the reach of applications over multiple networks. Using AnyNet
function, you can reduce the number of installed network protocols and reduce
operational complexity without modifying your existing applications or hardware.
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Personal Communications includes AnyNet SNA over TCP/IP support, which
allows SNA emulator and client/server applications to communicate over a
TCP/IP network.

Refer to the information about AnyNet SNA over TCP/IP in the 3270 Emulator
User’s Reference or 5250 Emulator User’s Reference for more basic information about
AnyNet.

Refer to the Administrator’s Guide and Reference for examples of how to set up
AnyNet connections.

Enterprise Extender (HPR over IP)
Enterprise Extender allows you to extend the reach of SNA applications and data
to include IP networks and IP-attached clients with similar levels of reliability,
scalability, and control as SNA users. Enterprise Extender integration uses standard
IP technology and does not require new hardware or software in the IP backbone.

Enterprise Extender is a simple set of extensions to the existing HPR technology,
and provides the following:
v Non-disruptive backup from desktop to host
v SNA transport over native IP network
v End-to-end failure protection
v End-to-end data prioritization
v Scalable and cost-effective connectivity

ActiveX/OLE 2.0 Support
Personal Communications Version 5.7 sessions can now be included as part of a
compound document. A compound document is a document that appears to be a
single unit, but which is in fact made up of information from more than one
program. For example, a compound document could include data that allows
Personal Communications to execute within the context of the spreadsheet
program.

When included as part of another program, Personal Communications is known as
an embedded or linked object and the program is known as a container. Personal
Communications supports ActiveX/OLE 2.0–compliant containers such as Lotus
Notes®, Lotus WordPro, and Microsoft Word. For most containers you can embed
an object by using a menu sequence (for example, in Microsoft Word, use Insert,
then Object), or by dragging and dropping a workstation profile into the
document.

As an embedded object, Personal Communications can change its appearance to be
part of the container program, providing the container program allows this change
to occur. Or, Personal Communications can be started so that it runs in its own
separate window utilizing its own profile and screen displays.

There is a variety of ways that Personal Communications can be activated as an
embedded object. For example, Personal Communications can be shown as an icon
within another program, and be activated by double-clicking. Another way
Personal Communications can be activated is through a script; Visual Basic or
LotusScript are examples of scripting languages supported by Personal
Communications, but any ActiveX/OLE automation scripting language can be
used.
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The use of scripts allows Personal Communications to be activated as a part of an
automation request. For example, a script can be written to automatically start
Personal Communications every time the container object is started, or a script can
be used to automatically put data on host entry screens.

The Personal Communications session ends when the container is closed or when
you close the Personal Communications window. If Personal Communications was
actuated as a linked object, it must be closed separately.

Object-Oriented API
Personal Communications provides a new language-independent object-oriented
API. There are seven objects that can be used in conjunction with Visual Basic,
Lotus Script, or any ActiveX/OLE automation scripting language to produce
compound documents where Personal Communications is an embedded object
within another program.

If you are interested in writing an application that includes Personal
Communications as an object within your ActiveX/OLE 2.0 compliant program,
refer to the Host Access Class Library (HACL) programming manual. This manual
describes the objects that Personal Communications provides and describes what
you need to do to access the Personal Communications data. Information is
provided for programmers using Visual Basic scripts, Lotus scripts, and the C++
programming language. Samples of Visual Basic and Lotus scripts are provided on
the Personal Communications CD-ROM.
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Chapter 2. Planning to Install Personal Communications

Personal Communications supports a wide range of workstations. There are
hardware and software requirements, as well as memory and storage requirements,
to consider when planning the installation of Personal Communications.

The following sections describe and list support for monitors, adapters, and
keyboards.

For detailed instructions on installing Personal Communications, refer to the
CD-ROM Guide to Installation.

Workstation Hardware
Personal Communications supports workstations with the following hardware:

Table 5. Workstation Hardware Support

System units The recommended system unit has an Intel 80486 or faster
microprocessor and access to a CD-ROM drive.

Display monitors All VGA resolution or above display monitors supported by
Windows.

Video adapters All VGA resolution or above video adapters supported by
Windows.

Keyboards v Enhanced keyboard (101-key, 102-key, 104-key) (Only the 101-key
for Japanese)

v Space-saving keyboard
v Microsoft Natural keyboard
v 5576-001/002/003/A01/B01/B05 (Japanese)

Printers All printers supported by Windows when a PDT file is not used.
For more details about printers supported in PDT mode, refer to
the user’s reference for the specific host system.

Communication
adapters

LAN, SDLC, coaxial, twinaxial, WAC, COM Port, OEM, and
Multiprotocol communication adapters.

Modems All asynchronous modems that use the Hayes AT® command set
and are supported by Windows.

Synchronous (SDLC) modems attached to a multiprotocol adapter
(MPA), SDLC or WAC adapter.

Workstation Memory Requirements
For Personal Communications the amount of memory you need depends on
several factors, including the operating system you are running on, the attachment
type, number of sessions, and the use of programming interfaces such as Emulator
High-Level Language Application Programming Interface (EHLLAPI) and Dynamic
Data Exchange (DDE). Personal Communications for Windows 95 and Windows 98
will run on 16-MB workstations; a minimum of 32 MB of memory is recommended
for Windows NT, Windows Me, Windows 2000, and Windows XP.

If you want to run Personal Communications and other applications
simultaneously, you might need to add more memory to your workstation.
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Workstation Software
Personal Communications is supported for the following desktop operating
systems:
v Windows 95 and 98
v Windows NT 4.0 SP6 or higher
v Windows 2000 (Professional, Server and Advanced Server)
v Windows Millennium
v Windows XP (Professional and Home Edition)

Personal Communications is supported for the following server platforms:
v Windows Terminal Server Version 4 and Windows Terminal Services for 2000

and XP
v Citrix MetaFrame 1.8 for Windows Terminal Server 4.0 and Windows 2000

Server. Citrix is a third-party application for specific Windows platforms.
v Citrix MetaFrame XP (versions s, a, e) for Windows
v Windows 2003

Personal Communications is supported for the following API Clients.
v IBM Communications Server for Windows V6.1
v Microsoft SNA Server Version 4 SP4
v Microsoft Host Integration 2000 Server V5

For SNA client attachment to a Communications Server for Windows gateway, you
need the API Client for IBM Communications Server for Windows (provided with
CS).

For attachment to the Microsoft SNA Server for Windows, you need the Microsoft
SNA Server Windows NT Client; for attachment to the Microsoft SNA Server for
Windows 95 and Windows 98, you need the Microsoft SNA Server Windows 95 or
Windows 98 Client.

Host Requirements
Refer to the VT Emulator User’s Reference, 3270 Emulator User’s Reference, 5250
Emulator User’s Reference, and Administrator’s Guide and Reference for
information about software and hardware requirements for host systems.

For Windows 95, Java Runtime Environment 1.3.0 is installed by default. For
all other supported Windows operating systems, Java Runtime Environment
1.4.1 is installed.

Application Data
Application Data is generally defined to be files that contain user preferences or
configuration information; an application may need some or all of these files to run
properly. Personal Communications uses multiple configuration files: User Class
files can be stored individually by user profile, while System Class files are stored
in a common location.

Table 6 on page 19 lists the classifications of some of the most common Personal
Communications file extensions.
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Table 6. Application Data File Types

User Class System Class

Extension File Type Extension File Type

.ws Workstation Profile .acg SNA Configuration

.bch Multiple Sessions .mlg Default Message Log

.ini Session Size and Location .trc Unformatted Trace

.pmp Popup-Keypad
Configuration

.tlg Formatted Trace

.kmp Keyboard Configuration

.srl File Transfer List

.ndc iSeries Connection
Configuration

.upr iSeries User Profile

.tto iSeries Data Transfer
Request (Receive)

.tfr iSeries Data Transfer
Request (Send)

.bar Toolbar Setup

.mac Macro

.mmp Mouse Setup

.xlt Translation Table

.xld DBCS Translation Table

.cert Certificate

.sth Password Stash

.adu Automatic Dial Utility

.kdb Certificate Management
Database

.der Binary DER

Application Data Locations
The location for Application Data is specified during installation of Personal
Communications. The following tables list the default Application Data locations,
based on operating system.

If the [UserProfile]\Application Data location was selected at installation, the
following profile paths are used:

Operating
System

User Class Directory (Current User) System Class Directory

Windows
95/98/Me

C:\Windows\Application Data\
IBM\Personal Communications

C:\Windows\All Users\
Application Data\IBM\Personal
Communications

Windows
95/98/Me
(user profiles
enabled)

C:\Windows\Profiles\
%USERNAME%\Application
Data\IBM\Personal
Communications

C:\Windows\All Users\
Application Data\IBM\Personal
Communications
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Operating
System

User Class Directory (Current User) System Class Directory

Windows NT
4.0

C:\Winnt\Profiles\
%USERNAME%\Application
Data\IBM\Personal
Communications

C:\Winnt\Profiles\All Users\
Application Data\IBM\Personal
Communications

Windows
2000/XP

C:\Documents and Settings\
%USERNAME%\Application
Data\IBM\Personal
Communications

C:\Documents and Settings\All
Users\Application Data\IBM\
Personal Communications

If the All Users\Application Data location was selected at installation, the
following profile paths are used:

Operating
System

User Class Directory (Current User) System Class Directory

Windows
95/98/Me

C:\Windows\All Users\Application
Data\IBM\Personal
Communications

C:\Windows\All Users\
Application Data\IBM\Personal
Communications

Windows
95/98/Me
(user profiles
enabled)

C:\Windows\All Users\Application
Data\IBM\Personal
Communications

C:\Windows\All Users\
Application Data\IBM\Personal
Communications

Windows NT
4.0

C:\Winnt\Profiles\All Users\
Application Data\IBM\Personal
Communications

C:\Winnt\Profiles\All Users\
Application Data\IBM\Personal
Communications

Windows
2000/XP

C:\Documents and Settings\All
Users\Application Data\IBM\
Personal Communications

C:\Documents and Settings\All
Users\Application Data\IBM\
Personal Communications

Note: In Windows 95, 98, and Me, you have the option of enabling user profiles. A
user profile is an account, maintained by the operating system, that keeps
track of a particular user’s files and system configuration. When a user logs
on to the system, Windows is loaded with the logged-on user’s files and
system configuration settings in place.

In Windows NT, 2000, and XP, user profiles are always enabled.
If the classic Private directory location was selected at installation, the following
profile paths are used:

Operating
System

User Class Directory (Current
User)1,2

System Class Directory

Windows
95/98/Me

C:\Program Files\IBM\Personal
Communications\Private

C:\Program Files\IBM\Personal
Communications\Private

Windows
95/98/Me
(user profiles
enabled)

C:\Program Files\IBM\Personal
Communications\Private

C:\Program Files\IBM\Personal
Communications\Private

Windows NT
4.0

C:\Program Files\IBM\Personal
Communications\Private

C:\Program Files\IBM\Personal
Communications\Private

Windows
2000/XP

C:\Program Files\IBM\Personal
Communications\Private

C:\Program Files\IBM\Personal
Communications\Private
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Operating
System

User Class Directory (Current
User)1,2

System Class Directory

1If the User Preference Manager (UPM) was set to a directory other than the default
directory, Personal Communications will utilize that directory to store the user–class files.
System–class files are always stored in the Private directory.

2For the classic Private directory locations, C:\Program Files\IBM\Personal
Communications is the drive where Personal Communications is installed.

Installation and Limitations of Personal Communications on
ChineseStar and RichWin

This section describes how to install Personal Communications on ChineseStar
(CStar) and RichWin, and the limitations of running Personal Communications on
CStar and RichWin.

Installing Personal Communications on ChineseStar and
RichWin

Before installing Personal Communications, you must make sure that CStar or
RichWin is installed and running on the English version of Windows 95, Windows
98, or Windows NT. Once CStar or RichWin is installed and running, install
Personal Communications by following the steps described in the Personal
Communications Version 5.7 CD-ROM Guide to Installation.

Limitations of Personal Communications on ChineseStar and
RichWin

Running Personal Communications on CStar and RichWin has the following
limitations:
v Personal Communications supports only the GBK code page.
v RichWin does not support 3270 APL functions.
v CStar and RichWin support single Input Method Editor (IME) only.

For example, if you open IME in multiple windows, IME behavior is
synchronized in those windows. This is a platform limitation and it applies to
Personal Communications as well.

v Although CStar and RichWin provide many true type fonts, Personal
Communications supports only fixed pitch fonts.
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Part 2. Using Personal Communications
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Chapter 3. Configuring Sessions

Personal Communications saves emulator configuration information to a
workstation profile (.WS) and SNA information to a configuration file (.ACG).
Depending on your Personal Communications configuration, you might have a
workstation profile only or both a workstation profile and a configuration file. The
workstation profile can be used later by other Personal Communications sessions,
or to restart this session. The SNA configuration file (.ACG) is used to initialize the
SNA node of Personal Communications.

You can have an icon created for each workstation profile.Then you can select the
session icon to establish communication with the host system using the saved
workstation profile.

Note: If you configure more than one workstation profile for connection to an
SNA host, we strongly recommend that you use the same SNA configuration
file for all of them. If you do not use a common SNA configuration file,
make sure that there are no conflicts of link names or PU names (for 3270
sessions) between the two configuration files. In addition, the local system
information should be the same on the Configure Local System windows.
Failure to do this might result in unpredictable or inconsistent behavior.

Configuring for iSeries
To connect to an iSeries system, specific configuration information in the
workstation profile must correspond to the information specified at the
iSeries system. Refer to the iSeries configuration examples in the 5250
Emulator User’s Reference for more information about creating display, line,
and controller descriptions on the iSeries system.

If you want to configure multiple links, refer to Administrator’s Guide and Reference.

Creating a Configuration
To create a new session:
1. From the Start menu, click Programs → IBM Personal Communications → Start

or Configure Sessions.
2. From the Session Manager dialog, click New Session.
3. The Customize Communication window appears.
4. Select the type of host from the Type of Host drop-down list box.
5. Select the Interface you will use from the Interface drop-down list box.
6. Select the attachment type you want to use from the Attachment drop-down

list box.
7. Click Session Parameters (optional).

The Session Parameters – 3270, 5250, ASCII, or S/3X – Host window appears
(depending on the host you selected in step 4). Click OK.

8. Click Link Parameters.
If you selected an SNA attachment, a wizard will provide prompts for
configuring an SNA attachment. Enter the appropriate information for each
page and click Next to continue. Click Finish when you are done.
Save the SNA configuration, as described on page 26.
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If you selected an attachment type other than SNA, make your selections for
the parameters in the window displayed. Click Help or press F1 to display
parameter details. Click OK when you are finished. You will not need to save
an SNA configuration.

Note: If your host is configured to support Secure Sockets Layer (SSL) or
Transport Security Layer (TLS), then click the tab for the Advanced
Security Setup property page. Refer to the Administrator’s Guide and
Reference for details on configuring for this capability.

9. Click the Host Definition tab to configure the Connection Options.
v Select Auto-reconnect to reestablish an interrupted connection.
v The Connection Timeout value tells Personal Communications how long it

should wait for connection to the host.
v The Try connecting to last configured host infinitely option is enabled by

default. Clear this box if you do not want Personal Communications to
automatically and indefinitely wait for acknowledgement for a connect
request from the last correctly configured server/host.

10. For 3270 sessions, if you want a Telnet 3270 server to associate a printer with
the specific terminal, do the following:
a. Click the Host Definition tab.
b. Using the Associated Printer Session drop-down box, select or enter the

.WS file for the printer that is to be associated with the specific terminal.
c. Select the Start Associated Printer Minimized check box, if preferred. This

option is unavailable until an associated printer is selected.
d. Select the Automatically close Associated Printer Session with this

session check box, if preferred. This option is unavailable until an
associated printer is selected.

11. Click OK on the Customize Communication window. The session is displayed
automatically.
Save the workstation profile as described in “Saving a Workstation Profile” on
page 27.

Note: If you have a user profile that was created by a previous version of Personal
Communications, Auto-Logon, when connecting to an iSeries host over an
SNA connection, may not work. In this case, you must recreate. Select
Configure User Profile in the Session Parameters – 5250 Host window.

Saving Configuration Information
This section describes how to save configuration information. SNA configuration
information is stored in an *.ACG file, and emulator configuration information is
stored in a workstation profile (*.WS).

Saving an SNA Configuration
The Save As window appears automatically after you create or change a
configuration with an SNA attachment. To save this information in a configuration
file:
1. Type the file name and then click Save. The default file type is .ACG and the

default directory is the application data directory specified during installation.
When you save an SNA configuration file, you are also makingit the default
configuration for the SNA node.
You are returned to the Customize Communication window.
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2. Click OK until you return to the session window, and then save your
workstation profile, as described in the next section, Saving a Workstation
Profile.

Note: You must Power User or Administrator privileges in order to modify or
create an SNA .ACG configuration.

Saving a Workstation Profile
If you save your emulator configuration information, the session will have the
same characteristics the next time you start it. If you have an icon added to the
Personal Communications folder, you can restart the session with the saved
configuration information by clicking this icon from the Start menu. You are
automatically given the opportunity to save your session information when you
close a session. However, if you want to save the information at any time, do as
follows:
1. Select Save from the File menu in the session window.

The Save WorkStation Profile As window appears.
2. Type a file name (.WS) and then click OK. The name you enter will become the

icon title unless you enter a description. Note that you can choose the directory
where this file is saved, but the default directory is the application data
directory specified during installation.

3. An icon associated with the profile will appear in the Session Manager.

Changing Configuration Information
You can change all of the configuration parameters in the workstation profile and
the SNA configuration.

Changing an SNA Configuration
You can change the basic configuration parameters of an SNA configuration for
your session in the following three ways:
v Using the emulator SNA configuration wizard
v Using the SNA Node Configuration utility
v Editing the configuration file with an ASCII editor

Note: To change advanced configuration options or to specify a different default
configuration, you should use the SNA Node Configuration program, which
provides more configuration options than the emulator wizard. If you
manually edit the configuration files, it is highly recommended that you use
the SNA Node Configuration Verification utility, before using the file for the
first time.

Using the Emulator Configuration
To change an SNA configuration:
1. Select Configure from the Communication menu, then click Session

Parameters.
2. Change the parameters on this window as necessary and click OK.
3. Click Link Parameters.

Your default configuration file should be opened automatically. If you want to
change a different configuration, click Existing and choose the configuration
file you want to change.
A wizard is displayed to prompt you through the configuration.
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4. Make your changes and then click Next.
Now you can proceed through the wizard and make additional changes, if
necessary.

5. Click Finish when you are done.
6. If you want to replace the existing configuration, click Yes to overwrite it. If

you want to create a new configuration that is based on the existing one, type a
new file name; however, you must use SNA Node Configuration to make a
new configuration the default configuration.

7. Click OK until you return to the session window.

Using the SNA Node Configuration Program
The SNA Node Configuration program is a graphical user interface (GUI) for
managing the content of the .ACG files. This program allows you to define
individual SNA resources or change the definition of these resources.

Using an ASCII Editor to Change Your Configuration Files
You can create and modify a configuration file without going through the SNA
Node configuration interface. You can use the ASCII editor of your choice. A
verification tool is available to ensure that you have not made errors when editing
your file.

Refer to the Configuration File Reference manual for information on how to edit your
configuration data using an ASCII editor and how to verify your editing changes.

Changing a Workstation Profile
To change a workstation profile:
1. If your session window is not active, select the icon corresponding to the

workstation profile to be changed.
The session window appears.

2. Select Configure from the Communication menu.
The subsequent steps are the same as for creating a new configuration,
beginning with step 4 on page 25.

3. After you have made your changes, the following message appears:
Because you have changed the configuration,
communication will be terminated if you
proceed. Are you sure?

If you click OK, communication ends, but then you are reconnected using the
new configuration information.

To save the changes in your workstation profile, click Save from the File menu
in the session window and then click Yes to replace the existing file. Otherwise,
click No to save this information in a new configuration file.

Tip
Unless you have unchecked Save on Exit in the Exit Options dialog by
selecting Preferences → Exit from the Edit menu, changes are saved in the
workstation profile automatically whenever you exit a session.
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Configuring Your Workstation for Thai, Hindi, Arabic, or Hebrew
Refer to the bidirectional language support section of the Administrator’s Guide and
Reference for additional information on printing and other configuration options.

Configuring for Thai
To configure for the Thai language:
1. Select Configure from the Communication menu.
2. Click on Session Parameters.
3. For each configuration, select Host Code-Page to be one of the following:

v 838 Thai
v 037 Thai/US

To enable Thai keyboard input:
1. Select Preferences → Keyboard from the Edit menu.
2. Select Keyboard Layout: Thai.

Note: Thai features are enabled when running on Windows 95 and Windows 98
Thai only. The Thai settings specified here are the default settings.

Configuring for Hindi

Note: Hindi configuration is only supported on Windows NT and 2000 systems.

To configure for the Hindi language:
1. Select Configure from the Communication menu.
2. Click Session Parameters.
3. For each configuration, select Host Code-Page to be one of the following:

v 1137 Hindi
v /US

To enable Hindi keyboard input:
1. Select Preferences → Keyboard from the Edit menu.
2. Select Keyboard Layout: India—Hindi.

Refer to the Administrator’s Guide and Reference for more information about Hindi
support.

Configuring for Arabic or Hebrew
To set up an Arabic workstation, do the following:
1. Select Configure from the Communication pull-down menu.
2. ClickSession Parameters to display the Customize Communication panel.
3. Select 420 Arabic Speaking as the host code page.

Note: For 5250 print sessions, selecting the 420 host code page prompts
Personal Communications to load the PCSPDA.DAT file. This file
ensures that the host-specified fonts will map properly to the Typing
Arabic print font. Refer to the bidirectional language support section of
the Administrator’s Guide and Reference for more information about DAT
file options for Arabic sessions.

4. Click OK in the Session Parameters panel.
5. Click OK in the Customize Communication panel.
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6. Select Keyboard from the Edit → Preferences pull-down menu. Select Arabic
Speaking as the keyboard layout.

7. Select Font from the Edit → Preferences → Appearance pull-down menu.
Choose ARB3270 at the Automatic Sizing list box or at the Fixed size font
selection. This ensures that the active font for display is the Arabic font.

8. Select API from the Edit → Preferences pull-down menu.
9. Select DDE/EHLLAPI and select 1256 as the PC code page.

10. Select Page Setup from the File pull-down menu. Choose Typing Arabic as
the font in order to be able to print Arabic files.

Note: For Personal Communications for Windows 95 you can also select
ARB3270 for printers with drivers that allow bit-map fonts. For
example, printing through PDT requires the IBM Arabic 864 font to be
available on the printer.

For Arabic, to set up for Numeric Swapping or Symmetric Swapping, do the
following:
1. Select Preferences → Appearance → Display Setup from the Edit menu.
2. Select Swapping from the list box at the left; the settings for numerics and

symmetric characters are displayed. Changes are immediately reflected on the
active session.

Note: Numeric Swapping is only available for 3270 sessions. This function will
not be selectable for iSeries sessions.

To set up a Hebrew workstation, do the following:
1. Select Configure from the Communication pull-down menu; then click

Session Parameters to display the Customize Communication panel.
2. Select 424 Hebrew (Bulletin Code) or 803 Hebrew (Old Code) as the host

code page.
3. Click OK in the Session Parameters panel.
4. Click OK in the Customize Communication panel.
5. Select Keyboard from the Edit → Preferences pull-down menu. Select Hebrew

(Bulletin Code) or Hebrew (Old Code) as the Keyboard layout.
6. Select Transfer from the Edit → Preferences pull-down menu.
7. From the General tab, select 862, 916, or 1255 from the PC Code-Page list.
8. Select API from the Edit → Preferences pull-down menu.
9. Check the DDE/EHLLAPI box, then select 862, 916, or 1255 as the PC

Code-Page.
10. Select Font from the Edit → Preferences → Appearance pull-down menu.
11. Choose HEB3270 in the Automatic Sizing list box or choose the appropriate

size of face name at the Fixed size font selection.
12. Select Page Setup from the File pull-down menu.
13. In the Text tab, choose (Courier Heb) printer font.

RTL Print Orientation
For 3270 Arabic printer sessions (code page 420), you can print a file in RTL
orientation. Select the Host File RTL Orientation option in the Printer Setup
dialog. You can then select the symmetric and numeric swapping options.
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Page Setup for Arabic Printing

Using the Windows Printer Driver: For 5250 printer sessions, click the Advanced
Options tab in the Page Setup dialog. Set the Printer Font Code Page to 1008.

For 3270 sessions, click the Text tab in the Page Setup dialog. Set the Font to
Typing Arabic.

Using Printer Definition Table (PDT) Files: For 5250 printer sessions, click the
Advanced Options tab in the Page Setup dialog. Set the Printer Font Code Page to
864.

Using Host Print Transform (5250 only): For 5250 printer sessions, click the
Advanced Options tab in the Page Setup dialog. Set the Printer Font Code Page to
864.

Lam-Alef Expansion
The bidirectional layout engine converts between visual and implicit representation
of Arabic characters. The Lam-Alef ligature in visual representation is expanded to
<Lam> and <Alef> characters in implicit representation. If there are insufficient
blank spaces at the end of Arabic text (i.e., the beginning of the English field) into
which the Lam-Alef can be expanded, characters at the end of the Arabic field are
lost and replaced by the <SUB> control character.

To ensure a sufficient number of spaces at the beginning of the field, Personal
Communications protects one space for each <Lam-Alef> character. An error
message is returned if you try to enter a character in the protected space.

In the following example, entering one <Lam-Alef> character at the beginning of
the Arabic field results in the protection of one space at the beginning of the
English field.

Position 1 2 3 4 6

Character None allowed
(protected)

open open open <Lam-Alef>

In this example, two <Lam-Alef> characters have been entered, so Personal
Communications protects two spaces at the end of the Arabic field.

Position 1 2 3 4 5

Character None allowed
(protected)

None allowed
(protected)

open <Lam-Alef> <Lam-Alef>

Notes:

1. If there are no more unprotected spaces available in a field and you try to enter
any additional characters, you will receive an error message and the keyboard
will be locked. Click Reset to unlock the keyboard.

2. For the Paste and Delete functions, if the leftmost space in the field (position 1
in the above examples) is not blank when the <Lam-Alef> character is entered,
you will not be able to enter the <Lam-Alef> character and Personal
Communications will return an invalid key error message.

3. This expansion feature is not supported for Windows Terminal Server.
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You may enable this expansion protection feature from the Edit → Preferences →
Appearance → Display Setup menu.

File Transfer
For Arabic, when transferring files between the PC and the host, the available PC
code pages are 864 (IBM PC Arabic) and 1256 (Microsoft Windows Arabic).

For Hebrew, when transferring files between the PC and the host, the available PC
code pages are 862 (IBM PC Hebrew), 916 (Hebrew ISO-conforming), and 1255
(Microsoft Windows Hebrew).

You can set the file transfer parameters using the following procedure:
1. Click Edit → Preferences → Transfer in the session window.
2. Click the General tab.
3. Click Bidi Options.

You can modify the following options.
v For right-to-left host file orientation, select Host File Orientation. For

left-to-right host file orientation, clear this box.
v When uploading (sending) an Arabic file to the host, select Lam-Alef

Compression. When downloading (receiving) an Arabic file from the host,
select Lam-Alef Expansion.

v Use Symmetric Swapping to reset swappable characters. For example, in a
right-to-left string, the ″(″ and ″)″ will be reversed.

v Use the Round Trip option to disable the reversal of numerals if they are
preceded by Arabic characters.

v For Numerals Shape, select the appropriate shape: Nominal, National, or
Contextual.

Note: When performing a Send File or Receive File in an RTL screen, Numeric and
Symmetric Swapping should be disabled. To do this, click Edit → Preferences
→ Display Setup. In the Swapping selection, set Symmetric Swapping and
Numeric Swapping to No.

Data Transfer for Arabic
When transferring SQL Data between the PC and iSeries, the available PC code
pages are 864 (IBM Arabic) and 1256 (Microsoft Windows Arabic). To transfer data,
do as follows:
1. Select Preferences → Transfer from the Edit menu.
2. Select the tab for the Translation Tables tab.
3. Select User Defined.
4. Select Host Codepage: 420 Arabic Speaking.
5. Select PC Codepage: 864 or 1256.

If code page 1256 is selected, then you must then set the parameter for the
orientation of the host file, as described for file transfer.

OIA Indicators for Arabic
In the host session, the bottom line of the screen is called the Operator Information
Area (OIA). This line is always displayed from left-to-right. In the Arabic
environment, the following symbols are used:
v Language Indicator
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– Isolated EIN

Current language, Arabic
– E : Current language, English

v Screen Direction
– S> : Left-to-right screen direction
– <S : Right-to-left screen direction

v Typing Direction
– => : Left-to-right direction
– <= : Right-to-left direction

– : Left-to-right Push direction (3270 Only)

– : Right-to-Left Push direction (3270 Only)
v Auto Field Reverse function active (3270 Only)

– <->
v Auto Field Reverse for numbers (3270 Only)

– N
v Auto Push active indicator (3270 Only)

– P
v Arabic Character Shape Mode

– The character Alef-Madda

indicates CSD mode
– Isolated GHEIN

indicates Base/Isolated Shaping Mode
– Initial GHEIN

indicates Initial Shaping Mode (3270 Only)
– Middle GHEIN

indicates Middle Shaping Mode (3270 Only)
– Final GHEIN

indicates Final Shaping Mode (3270 Only)

OIA Indicators for Hebrew
When you are working in host mode, the bottom line of the screen becomes an
Operator Information Area (OIA). This line is always displayed from left to right.
For work in the Hebrew environment, the following symbols are used:
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v Language Indicator
– H : Current language is Hebrew
– E : Current language is English

v Screen Direction
– S> : Left-to-right screen direction
– <S : Right-to-left screen direction

v Typing Direction
– => : Left-to-right direction
– <= : Right-to-left direction
– #>: Left-to-right Push direction (3270 Only)
– <#: Right-to-Left Push direction (3270 Only)

v Auto Field Reverse function active - bidirectional arrow
– <-->

v Auto Field Reverse for numbers
– N

v Autopush active indicator
– P

Configuring VT Emulation for Arabic or Hebrew
To set up an Arabic or Hebrew workstation for VT emulation, do the following:
1. Select Configure from the Communication pull-down menu.
2. Select ASCII for the host type.
3. Click the Session Parameters button.
4. Select the National Host Code-Page type.
5. Select the Host Code-Page.

v If configuring for Arabic, choose Arabic ASMO 708 for 8–bit code page or
Arabic ASMO 449 for 7–bit code page.

v If configuring for Hebrew, choose Hebrew ISO or Hebrew NRCS.
6. Click the Advanced button.
7. Click the BiDi Options button.
8. Set bidirectional options from the Advanced BiDi ASCII Host dialog.

v If configuring for Arabic, do the following:
– Select the Numeral Shape.
– Select the BiDi Mode to be either on or off.

v If configuring for Hebrew, do the following:
– Select the Display Text Type.
– Select the Cursor Direction (for Visual Hebrew sessions only).

9. Close the open dialogs by clicking OK in each panel.
10. Select the font by going to the Edit pull-down menu and selecting Preferences

→ Appearance → Font.
11. Select Face Name.

v If configuring for Hebrew, select HEB3270.
v If configuring for Arabic, select AVT3270.
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File Transfer
Automatic code page conversion occurs during file transfer. However, this is only
valid for 8–bit code pages.

For Arabic workstations, the conversion is from Arabic ASMO 708 to 1256 when
sending. The code page conversion is reversed when receiving.

For Hebrew workstations, the conversion is from Hebrew ISO to 1255 when
sending. The code page conversion is reversed when receiving.

Copy/Paste
Automatic code page conversion occurs during copy and paste operations. For
Arabic, the conversion is from the current host code page to 1256, and vice-versa.
For Hebrew, the conversion is from the current host code page to 1255, and
vice-versa.

Print Screen
To print a screen in an Arabic or Hebrew session, do the following:
1. Click Page Setup from the File menu.
2. For an Arabic session, select the Typing Arabic VT font. For a Hebrew session,

select the Courier Heb font.

Arabic OIA Indicators for VT
In the Arabic environment, the following OIA symbols are used:
v Language Indicator

– AIN (Arabic character): Current language is Arabic
– E : Current language is English

v Screen Direction
– S> : Left-to-right screen direction
– <S : Right-to-left screen direction

v Column Heading
– CH : Column heading is on

Hebrew OIA Indicators for VT
In the Hebrew environment, the following OIA symbols are used:
v Language Indicator

– H : Current language is Hebrew
– E : Current language is English

v Screen Direction
– S> : Left-to-right screen direction
– <S : Right-to-left screen direction

v Text type mode
– I : Logical/Implicit text mode
– V : Visual text mode

v Cursor Direction
– => : Left-to-right direction
– <= : Right-to-left direction

Changing Advanced BiDi Display Options
To set advanced ASCII bidirectional options for Hebrew sessions, do the following:
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1. Select the appropriate Hebrew National host code page. Click the Advanced
button in the Session Parameters-ASCII Host panel.

2. Click the BiDi Options... button in the Customize Communications-Advanced
ASCII Host panel.

3. Select the Display Text Type, either Logical or Visual.
v For Logical Hebrew sessions, choose the Smart Ordering option, either

Enable or Disable. For Smart Ordering enabled, choose the Show Text
Attributes option, either Yes or No.

v For Visual Hebrew sessions, select the Cursor Direction, either LTR or RTL.

To set advanced ASCII bidirectional options for Arabic sessions, do the following:
1. Select the appropriate Arabic National host code page. Click the Advanced

button in the Session Parameters-ASCII Host panel.
2. Click the BiDi Options... button in the Customize Communications-Advanced

ASCII Host panel.
3. Select the Numeral Shape, either Contextual, Nominal, or National.
4. Select the BiDi Mode, either On or Off.
5. Choose the Smart Ordering option, either Enable or Disable. For Smart

Ordering enabled, choose the Show Text Attributes option, either Yes or No.
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Chapter 4. Starting and Stopping Emulator Sessions

This chapter describes how to start and stop single and multiple emulator sessions.

If you saved your emulator configuration information, as described in “Saving
Configuration Information” on page 26, it is stored in a workstation profile (*.WS),
which should be displayed in the Session Manager.

Note: If you are a first-time user of Personal Communications, or there are no
session icons in the Session Manager, see Chapter 3, “Configuring Sessions”,
on page 25 to create a configuration.

Session Manager
Personal Communications Version 5.7 uses the Session Manager dialog to provide
easy access to workstation profiles and batch files. You can use the Session
Manager to start a single or multiple sessions, and create a new session or batch
file.

Note: The Session Manager dialog only displays workstation profiles and batch
files that are located in the Application Data location that was specified
during Personal Communications Version 5.7 installation. See “Application
Data” on page 18 for more information about Application Data.

You can drag an icon from the Session Manager to the Windows Start menu or to
the desktop. Select the session(s) and drag with the right mouse button. A
contextual menu appears when the icons are dropped, which gives you the options
for moving, copying, or creating a shortcut. If you drag an icon with the left
mouse button held down, the icon is moved to that location. If you drag an icon
while pressing the Ctrl key and with the left mouse button held down, the icon is
copied to that location. If you drag an icon while pressing the Alt key and with
the left mouse button held down, a shortcut is created for the icon.

You should use the shortcut option whenever possible. Moving and copying will
affect the location (and therefore the function) of the profile. Specifically, when you
copy a profile to the desktop instead of creating a shortcut, you have actually
created another profile. Any changes you make to the desktop profile will not be
reflected in the original profile (and vice versa). Also, the desktop profile is located
in the desktop folder (not in the application data folder) and will not appear in the
Session Manager—the original version of the profile remains in the Session
Manager.

Session Manager Options
Various Session Manager options are available from the pull-down menus and the
right-click menu. For example, you can customize the look of the displayed Session
Manager information and import sessions or batch files into the Personal
Communications Application Data directory.

Session Manager Menus
The following options are available from the Session Manager menus.

File
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Change Directory
You can run files that are stored in a directory other than the
Personal Communications Application Data directory.

Import
This option allows you to copy sessions or batch files to the
Personal Communications Application Data directory. Afterwards,
the imported files can be displayed in the Session Manager dialog.

View

Sessions
This option shows all valid workstation profiles that have the
standard .WS extension and are located in the Application Data
directory.

Multiple Sessions
This option shows all valid batch files that are have the standard
.BCH extension and are located in the Application Data directory.

All File Extensions
This option shows all valid multiple sessions and workstation
profiles that are located in the Application Data directory,
regardless of extension.

Hidden
This option shows files that have been previously hidden using the
right-click menu option. If this option is selected, hidden sessions
are shown with black-and-white icons; otherwise, they will not be
displayed.

Large Icons
This option shows large session icons in the Session Manager.

Small Icons
This option shows small session icons in the Session Manager.

Details
The following session detail information is displayed in the panel
columns. The columns can be resized as needed.
v File Name
v File extension
v Type (session or batch file)
v Description (shows the information specified in the

″Description=″ field in the .WS file)
v The following session information is not shown for batch files.

– Host Name (if SNA, this column shows the .ACG file name).
– Host Type (shows the host type specified in the Customize

Communication dialog during session configuration)
– Interface (shows the interface specified in the Customize

Communication dialog during session configuration)
– Attachment (shows the attachment specified in the Customize

Communication dialog during session configuration)
– Session Type (printer or display)

v Modified (indicates the last modification date/time of the file)
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Refresh
If you manually copy a session or batch file into the Application
Data directory, you must refresh the Session Manager view in
order to see the new files.

Right-Click Menu (Contextual)
The following options are available by right-clicking on one or more session.

Start Starts the selected sessions

Delete Deletes the selected sessions. You must have permission in the System
Policy to delete any sessions from the Session Manager.

Hide/Unhide
You can hide or unhide sessions using this option. To view hidden
sessions, you must select View → Hidden. Hidden sessions have
black-and-white icons when displayed.

Modify
This option is only available when selecting one or more batch files—the
batch files are brought up in edit mode. You must have permission in the
System Policy to modify batch files from the Session Manager.

Starting Sessions
You can use the following methods to start sessions:
v Select an already-configured session icon from the Session Manager.
v Start from an existing session window.
v Specify a workstation profile name in the Run window.
v Enter the PCOMSTRT command in the Run window or MS-DOS prompt.
v Select an icon that has been previously dragged from the Session Manager.
v Start multiple sessions with a batch file.

Note: Connection status messages are displayed on a status bar at the bottom of
your session window during connection to the host.

Starting from the Start or Configure Sessions Icon
Select Programs → IBM Personal Communications → Start or Configure
Sessions from the Start menu. Select the desired session from the Session
Manager dialog and click the Start button.

Starting from an Existing Session Window
Use the following methods to start from an existing session window:

Starting Another Session Using the Same Profile
Select Run the Same from the File menu. Another session starts,
using the same profile.

Starting Another Session Using a Different Profile

1. Select Run Other from the File menu.
The Open Other Workstation Profile window appears.

2. Double-click the desired workstation profile in the File Name
list.

3. Select OK.
Another session starts, using the profile specified in step 2.

Starting a Different Type of Session from a Session Window

1. Select Open from the File menu.
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2. Specify the desired workstation profile and then select OK.
The current session ends and then another session starts, using
the selected profile.

Starting Using a Command
To start a session:
1. Select Run or Programs → MS-DOS Prompt from the Start menu.
2. Enter the command:

PCOMSTRT /P=x:\AppData\my.WS

where my.WS is the workstation profile stored in the Application Data
directory specified during installation. This is the only required
parameter.

Note: If multiple /p parameters are given, PCOMSTRT only uses the
last one to start a profile (.WS file).

For a complete description of parameters, refer to the Administrator’s
Guide and Reference.

Another method for invoking Personal Communications using a command
is with the command for the PCSWS.EXE module (see “PCSWS.EXE
Options”).

Starting Multiple Sessions
If you installed the Multiple Sessions utility, you can use the batch program
PCSWS.EXE, which runs batch files (*.BCH), to start two or more workstation
profiles at the same time. Personal Communications batch files can also start other
programs when you include their startup commands. This is especially useful if
you always want to start an application when you start a session. For example,
you might want to start an application, such as ZipPrint, that uses a Personal
Communications API.

Note: You must have permission in the System Policy in order to create a new
batch file.

If you created an icon for your batch file, double-click the icon in the Session
Manager or select the icon and click the Start button.

PCSWS.EXE Options
You can use the following options when creating or modifying a batch file.
v To specify which view should be used during a session, add the command

/V=myview, where myview is the name of the previously saved view:
C:\Pcomm\PCSWS.EXE C:\AppData\LAN1.WS /V=myview

If the specified view does not exist, the command is ignored. See “Managing
Emulator Sessions” on page 70 for information on how to save a view.

v To suppress the IBM logo when you start one or more sessions, add the
parameter /Q to the first command in the batch file:
C:\Pcomm\PCSWS.EXE C:\AppData\TCPIP1.WS /Q

where C:\Pcomm\ is the directory where you have Personal Communications
installed, and C:\AppData\ is the Application Data directory.
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v To start a session as an icon, not as a window, add the parameter /I to the
command in the batch file:

C:\Pcomm\PCSWS.EXE C:\AppData\TWINAX.WS /I

where C:\Pcomm\ is the directory where you have Personal Communications
installed, and C:\AppData\ is the Application Data directory.

v To start a hidden session, not as an icon or a window, add the parameter /H to
the commandin the batch file:

C:\Pcomm\PCSWS.EXE C:\AppData\TWINAX.WS /H

where C:\Pcomm\ is the directory where you have Personal Communications
installed, and C:\AppData\ is the Application Data directory.

v To start a session with a specific short session ID (session letter),insert the
parameter /S=m after PCSWS.EXE in the batch file:

C:\Pcomm\PCSWS.EXE /S=m C:\AppData\LAN1.WS

where C:\Pcomm\ is the directory where you have Personal Communications
installed, m is the short session ID, and C:\AppData\ is the Application Data
directory.

Notes:

1. If you use the /S option to assign A as the short session ID, you should use
this option for all of the sessions in the batch file. Otherwise, if another session
starts first, it becomes the A Session and the session with the /S=a option will
not start because of the conflicting short session IDs. Another way to prevent
conflicts is to assign a character later in the alphabet for the short session ID.

2. Several parameters can be specified for controlling the particular characteristics
for starting sessions; the switch values are designated by a single character.

Creating a Batch File
To create a batch file:
1. From the Session Manager dialog, click New Multiple Sessions. You can also

start a new batch file from the Windows Start menu, using the Multiple
Sessions icon in the Utilities subfolder of the IBM Personal Communications
folder.
The Create/Modify Batch File panel appears.

2. There are several methods for including profiles or programs in a batch file:
v Double-click the file names in the File Name list box.
v Drag and drop the file names (using the right mouse button) from the File

Name box to Batch-File Entries.
v Select a file name from the File Name list box and then select Add.
v Type the complete path and command file name in the batch files entries

area.
v You can also use the Capture View button to capture multiple session

windows into a view.

Personal Communications places the full path and command that is needed to
run the workstation profile or other program above the cursor line in the edit
area. If there is no cursor, the command is added to the last line.

To see the contents of the profile you added to the batch file, click it in the File
Name list box and then click View File or the magnifying glass.
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Note: Some brief instructions appear at the top of Batch-File Entries; you need
not remove them, because they do not affect the running of the batch
file.

There is one exception—if you are using the Japanese version of Personal
Communications, you must delete these instructions. One way to do this
is to select File → New from the Create/Modify Batch File dialog before
adding any files.

3. Repeat step 2 for each subsequent file to be added.
4. When you complete the edit, save the created batch file by selecting Save from

the File menu.
The Save Batch File As window appears.

5. Enter a name for the batch file (*.BCH).
The name you enter is used as the icon title, unless you enter a description as
well.

The following example is a batch file that runs six workstation profiles located in
the Application Data directory, and then runs MYAPP.EXE.
C:\dir\PCSWS.EXE C:\dir\COAX1.WS /Q
C:\dir\PCSWS.EXE C:\AppData\COAX2.WS /I
C:\dir\PCSWS.EXE C:\AppData\SLAN1.WS
C:\dir\PCSWS.EXE C:\AppData\SLAN2.WS
C:\dir\PCSWS.EXE C:\AppData\AS4Y1.WS
C:\dir\PCSWS.EXE C:\AppData\VT220.WS
C:\APPL\MYAPP.EXE

where C:\AppData is the Application Data directory specified during installation
and dir is the installation directory.

Saving Multiple Session Views
You can use the Create/Modify Batch File panel to capture up to multiple session
views. Simply size and position up to 26 session windows and click the Capture
View button. Name the view and click Save View in the View Setup panel. You
can save up to eight views. You may also delete previously saved views from the
drop-down list in the View Setup panel.

If a view is already being used when you click Capture View, that view is
automatically used and you are not prompted to save a new view.

Starting a Batch File
You can use one of the following methods to run a batch file:
v If you created an icon for your batch file, double-click the icon in the Session

Manager or select the icon and click the Start button.
v Run the batch file from the Run command line:

[drive]:\[path]\PCSBAT.EXE [drive]:\[path]\xxxx.BCH /R

Note: To run a batch file, specify the /R option.
v Start the Multiple Sessions Utility.

1. Select Open from the File menu in the Create/Modify Batch File window.
2. Select the desired batch file and then select OK.

The contents of the batch file appears in the edit area.
3. Select Run from the Run menu.
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Editing an Existing Batch File
To edit an existing batch file, do one of the following:
1. Right-click on the icon in the Session Manager and choose Modify.

You can also use the following procedure:
a. Start the Multiple Sessions Utility from the Start menu. The Create/Modify

Batch File window appears.
b. Select Open from the File menu. The Open Batch File window appears.
c. Select the batch file you want to edit and then select OK. The contents of

the batch file you selected appear in the edit area of the Create/Modify
Batch File window.

2. Edit the batch file. See step 2 on page 41 for more details.
Refer to the online help for details about the menu bar Edit functions. Select
Index from the Help menu and then click Menu-Bar Commands on the
Batch-Program Window.

3. When you complete the edit, save your changes by selecting Save or Save As
from the File menu.
v Select Save to save your changes in the existing file.
v Select Save As to save your changes in a new file and then continue with

step 5 on page 42.
4. Exit the Create/Modify window.

Starting Multiple Sessions without a Batch File
To start multiple sessions without a batch file:
1. Start the Session Manager.
2. Select the icons for the sessions, then click the Start button. You can select icons

using a drag selection box or holding down the Ctrl key while selecting icons
with the mouse.

3. After it connects to the host, select one of the following choices from the File
menu:
v Run the Same... to start another session with the same configuration.
v Run Other... to start a session with a different configuration.

When the Open Other Workstation window appears, select the profile you
want to start and then click OK.

Automatically Starting Sessions
To start one or more sessions automatically, do as follows:
1. From the Start menu, select Settings → Taskbar.
2. Click the Start Menu Programs tab and then click Add.
3. Click Browse and then open the Application Data directory specified during

installation.
4. Change the file type to All Files.
5. Double-click the session icon or the batch icon.
6. Click Next and then double-click the Startup folder.
7. Accept the icon name or type a new one.
8. Click Finish and then OK when you are done.

You can also drag an icon from the Session Manager to the Startup folder as a
shortcut.
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Stopping Sessions
To stop a session, click the X in the upper-right corner or double-click the
upper-left corner of the session window, or select Exit from the File menu.

To stop multiple sessions at the same time, select Exit All from the File menu. All
emulator sessions end, and the associated session windows are closed.

Sessions can also be stopped using a command:
1. Select Run or Programs → MS-DOS Prompt from the Start menu.
2. Enter one of the following commands:

PCOMSTOP /S=x
PCOMSTOP /ALL

where x is the session letter of the particular session to be stopped; use ALL to
stop all active sessions. There are other parameters; for a complete description,
refer to the Personal Communications user’s reference manual for the specific
host system.

Note: Stopping a TN3270E session will automatically close an associated printer
session, if that option was selected when configuring the session. See “Telnet
3270E Printer Association” on page 46 for information on how to
automatically close an associated printer session.
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Chapter 5. Using Emulator Sessions

This chapter describes how to use the printing, editing, and data transfer functions
in an emulator session. It also describes the choices on the Appearance, Actions,
and Window menus in the emulator session windows.

Accessibility
Personal Communications Version 5.7 provides functionality with assistive
technology such as screen readers. Following are some of the accessibility-related
enhancements.

Sounds
Personal Communications supports the ShowSounds and SoundsSentry options
available in the Windows Control Panel → Accessibility Options → Sound dialog.
The ShowSounds option displays a string representing the event that generated a
sound in the status bar.

To mute all of the sounds generated by Personal Communications, select the Mute
option in the Edit → Preferences → Appearance → Display Setup → Sound panel.

Screen Reader Assist
Users can configure a toggle key to enable Personal Communications to replace
blank and null characters in the input field with another character. This option
enables screen readers to report the length of the field to visually impaired users.
Data sent to and from the host is not changed—only the screen display and the
screen reader’s voicing of the display are affected. By default, this function is not
enabled.

For 3270 and VT emulators, the default padding character is a blank. For 5250, the
default replacement character is an underscore. You can choose another character if
you prefer.

During the emulation session, you can turn the screen reader assist on or off, as
needed. To map the screen reader toggle to a key, click Edit → Preferences →
Keyboard. Click Customize to access the keyboard setup dialog. Refer to the
online help for a complete list of available keyboard functions.

Expanded OIA
For an accessible version of the Operator Information Area (bottom line of the
session), you can display the expanded OIA window. Click View → Expanded OIA
from the session menu bar. You can also select Show Expanded OIA from the
session’s system menu. You can change the number of lines displayed in the
expanded OIA in the Edit → Preferences → Appearance → Window Setup dialog.

To set focus to the expanded OIA so that a screen reader can read the values, you
need to map a key to the function OIA: Toggle focus to/from Expanded OIA. This
key enables you to toggle focus back and forth between the session window and
the expanded OIA window. When you set focus to the expanded OIA window
with a key, the focus in the expanded OIA is always set to the first line. When you
return to the session window, the cursor should be where it was before you went
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into the expanded OIA window. Refer to the online help in the Edit → Preferences
→ Keyboard → Keyboard Setup → Customize dialog, for more information about
custom key mapping.

Popup Keypad
Even though most users use the popup keypad with a mouse, it is possible to
customize and use the poppads with the keyboard alone. To display (execute) a
poppad without a mouse, you must map a few keys in the Edit → Preferences →
Keyboard → Keyboard Setup → Customize dialog.

The Display Poppad function shows the last poppad and puts keyboard focus on
it. The functions Display Poppad Pad 1, Display Poppad Pad 2, Display Poppad
Pad 3, and Display Poppad Pad 4 display a specific poppad and put keyboard
focus on that pad. You can execute the button with current focus by pressing the
space bar or the Enter key.

If you are using a sticky poppad, the poppad window remains open until you
close it. A regular poppad exits when you push one of the buttons. To get focus to
a sticky pad without a mouse, you must map the Set Focus to Poppad function to
a key—this sets focus to the sticky poppad from the session window. Because you
must use the Ctrl-Tab key combination to get focus from the sticky poppad back to
the session, mapping the Set Focus to Poppad function to the Ctrl-Tab key
combination is not advisable.

Telnet 3270E Printer Association
The Telnet 3270E standard lets you specify an association between a display and a
printer session. This is unique to telnet. and is not available in the SNA
environment. When you configure a display session, Personal Communications lets
you specify an associated printer session. This function requires that the host be
configured, and is only implemented on Communications Server and zSeries
TN3270E servers.

The association starts at the telnet server. In the server’s configuration, there is a
one-to-one correspondence when defining associated printers. When LU names
and relations are already defined by the server, the server will assign the printer
LU for the client. Each printer LU is configured as associated with a particular
display LU.

Advantages of this association are as follows:
v If sessions are associated, the person who configures the client workstation does

not have to know any detail about the printer session because the associated
pairs are defined at the telnet server.

v When you start the display session, the associated printer session is started
automatically. If the printer session is configured to direct output to a printer
that is near you, and if you ensure that your host applications print to that
session, it is obviously convenient.

When configuring a session, if you want a TN3270E-capable server to associate a
printer with the specific terminal:
1. Click the Host Definition tab.
2. Using the Associated Printer Session drop-down box, select or enter the .WS

file for the printer that is to be associated with the specific terminal.
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3. Select the Start Associated Printer Minimized check box, if preferred. This
option is unavailable until an associated printer is selected.

4. Select the Automatically close Associated Printer Session with this session
check box, if preferred. This option is unavailable until an associated printer is
selected.

Stopping a TN3270E session will automatically close an associated printer session,
if that option was selected when configuring the session.

Power Management
Personal Communications complies with Windows 2000 Power Management
requirements for handling sleep events (stand by and hibernate). This support
minimizes session interruptions due to network disconnections caused by sleep on
Windows 2000 and subsequent versions.

Connected State
When Personal Communications is in the connected state and Windows
2000 indicates that the user is available for interaction, Personal
Communications prompts the user to grant permission to sleep.

You can specify a setting in the User Preference Manager that allows the
system to standby or hibernate without prompting. In default mode
(unchecked), if there is at least one connected session, you will be
prompted to allow the system to standby or hibernate. If there are no
connected sessions, Personal Communications allows the system to
standby or hibernate without prompting. See “Standby/Hibernate” on
page 84.

Non-Connected State
When Personal Communications is not in the connected state, Windows
2000 might automatically sleep, without prompting the user for
permission.

Critical Sleep
When Windows 2000 resumes after an emergency suspension, Personal
Communications might display and log a warning message.

Refer to the Administrator’s Guide and Reference for more information about Power
Management.

Printing
You can use Personal Communications to print from display or printer sessions:
v From display sessions, you can print all (Print Screen) or part (Trim Print) of

the screen of your session window on a workstation printer.
To print only part of the session window, drag the mouse to create a trimming
rectangle around the part of the window you want to print and then select Print
Screen from the File menu.

v With printer sessions, you can print files directly from a host system to a
workstation printer. Refer to the online help for more information.
Configure a printer session to designate a workstation printer as a system
printer that will use either the printer definition tables (PDTs) provided with
Personal Communications or the Windows printer drivers. Refer to the online
help for more information.

To print, the following methods apply:
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v You can use Windows printer drivers that you configure through Printer Setup
in the File menu of the session window.

v You can use printer definition tables (PDTs), which give greater control over the
print data stream.

v For 5250 only: You can use Host Print Transform, where the host formats and
builds the printer commands.

For more information about printing, refer to VT Emulator User’s Reference, 3270
Emulator User’s Reference, and 5250 Emulator User’s Reference.

Collect Screen and Print Collection
Using the Collect Screen feature, you can add a capture of all or part of the screen
to a collection of captures. You can then print all the collected captures at the same
time, using the Print Collection feature.

To add the current screen (or part of the screen) to the collection, click File → Print
Screen Collection → Collect Screen. To print all the collected screens, click File →
Print Screen Collection → Print Collection.

All the collected screens can be deleted without printing by clicking File → Print
Screen Collection → Purge Collection. An individual screen or part of the
collection cannot be deleted.

The File → Print Screen Collection → Print Collection on Exit option ensures that
the collected screens are printed before you close or disconnect the session. This
option is enabled by default. To end the session without printing the collected
screen, clear the Print Collection on Exit option. All the collected screens are then
deleted when you close or disconnect the session.

Note: The Collect Screen feature works independently of the normal Print Screen
function. You can still use Print Screen to print individual screens, while
collecting multiple screens.

You can add the Collect Screen and Print Collection functions to the toolbar, a
popup keypad, or a custom keyboard map, using the Edit → Preferences menu in
the session window. The settings in the Page Setup dialog are used (shared with
the normal Print Screen function).

In PDT mode, there is an option available for printing more than one screen in a
page. Refer to the Administrator’s Guide and Reference for more information.

Using the Windows Printer Driver
To set up your printer to use a Windows printer driver:
1. Select Printer Setup from the File menu of the session window.

The Printer Setup window lists the supported printers.
2. Select the printer driver to be used from the Printer list box. DEFAULT will

cause the use of the Windows default printer.

Notes:

a. The DEFAULT selection is shown when the .WS file specifies
printer=DEFAULT in the [printers] stanza.

b. When this selection is made, no message appears before the job is printed.
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c. When a printer has been selected for a session, the name of that printer is
displayed in the status bar of the session window.

3. If desired, click on the check box to Show this dialog before every print.
4. Confirm that the Use PDT file check box is not selected and then select OK.

Personal Communications will now use the printer driver you selected, and the
Printer Setup window is closed.

Using Printer Definition Table (PDT) Files
Printer Definition Table files define the transfer of characters and control codes to a
printer, and the printer output format. If a PDT file is used, the Windows printer
driver is not used, and Personal Communications generates print output based on
printer control information defined in the PDT file.

Refer to the Administrator’s Guide and Reference for more information about PDT
files.

To use PDT files:
1. Select Printer Setup from the File menu of the session window.

The Printer Setup window appears.
2. Select the port to be used from the Printer list box.

Selected PDT files are available for the port selected here.
3. Select Setup and then specify the paper size of the selected printer driver.
4. Select the Use PDT file check box and then select Select PDT.

The Select PDT file window appears.
5. To use an existing PDT file, select a PDT file to be used and then select OK.

Using Host Print Transform (5250 only)
When configuring a 5250 printer session, the HPT mode may be selected. To use
Host Print Transform (HPT):
1. From the Session Parameters panel, click Advanced.
2. Select HPT Yes. You can then enter the following parameters:

v Printer Module
v Drawer 1, Drawer 2, and Envelope form names
v Code Page 899, Yes or No

v Customizing Object and Library (optional)

Image Print Transform
Personal Communications Version 5.7 allows use of Image Print Transform in 5250
print sessions, when using Host Print Transform. Refer to the most recent IBM
iSeries printing reference for more information on this feature.

Page Setup
Personal Communications allows you to set Page Setup parameters, such as the
maximum number of lines per page, the maximum number of columns, and fonts.
For detailed information and instructions on Page Setup, refer to the VT Emulator
User’s Reference, 3270 Emulator User’s Reference, 5250 Emulator User’s Reference, and
Administrator’s Guide and Reference.
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Scalable (Truetype) APL Font Support on Printers
Because special APL characters are not provided for printers, the APL fonts
provided for displays are used when APL characters are printed. In some cases,
APL characters are printed rather small. To print larger APL characters, you should
install a scalable (Truetype) APL font as follows.
1. Open the Control Panel Folder.

v Click Start on the task bar.
v Move the pointer to Settings and click Control Panel.

2. Open the Fonts folder. (Double-click the Fonts icon.)
3. On the File menu, click Install New Font.
4. Click the drive and folder where Personal Communications is installed.
5. Double-click AICAPL.

ZipPrint (3270 Only)

Use ZipPrint to print PROFS or OfficeVision notes, calendars, OfficeVision
documents, CMS files, XEDIT workspaces, and 3270 session screens.

Preparing to Use ZipPrint
Before you can use ZipPrint, DDE/EHLLAPI must be enabled for the sessions. To
do this, select API Settings from the File menu and refer to the online help for
detailed instructions. DDE/EHLLAPI is enabled by default.

Note: By default, PROFS-oriented functions of ZipPrint are U.S. English PROFS.
You can customize ZipPrint for other languages. Start ZipPrint before you
start any display sessions.

Starting ZipPrint
Start ZipPrint before you start any display sessions. The ZipPrint menu is added to
the menu bar of the specified session window; then you can use it from the menu
bar the same as with the other functions.

Start ZipPrint by selecting the ZipPrint icon in the Personal Communications
program folder. This starts ZipPrint for Session A only.

You can also start ZipPrint by placing it as the first command in a Personal
Communications batch file.

For more information about ZipPrint, including information about using ZipPrint
for additional emulator sessions, search for ZipPrint in Help.

Using ZipPrint
Keep the following consideration in mind when using ZipPrint.

ZipPrint uses the Personal Communications File Transfer function to print
VM/CMS notes and files. On slower communication lines such as SDLC, Async
(IIN), or Home3270 attachment, or when using a large packet or block size, you
might experience a file transfer timeout. If this happens, you should increase the
timeout delay as follows:
1. Select Preferences → Transfer from the Edit menu of the session window.
2. Increase the timeout value to 150 seconds or longer.
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When using ODPS (Japanese PROFS or other DBCS PROFS), ZipPrint uses the
Hankaku (SBCS) font. So when using a ZENKAKU font, such as KANJI or
HIRAGANA, the font setting should be changed as follows:
1. Click Configure ZipPrint from the ZipPrint menu in your session window.
2. Click Setup font.
3. Select a ZENKAKU font such as MINCHO and GOTHIC and then click OK.

Bidirectional Considerations
For Hebrew and Arabic sessions, Personal Communications supports the following
ZipPrint functions.
v Print Screen
v Print CMS File
v Print XEDIT Workspace

For bidirectional sessions, the bidirectional-specific parameters for File Transfer also
define the functionality of ZipPrint.

To disable the reversal of numerals if preceded by bidirectional characters, use the
Typing Arabic font for Arabic ZipPrint sessions and Cumberland Hebrew font for
Hebrew sessions.

Note: In order to use the Typing Arabic font for ZipPrint, you must specify code
page 1008 in the File Transfer settings.

IBM 5586-H02 Printer (Japan only)
Use IBM5585.PDT for PDT mode printing with the IBM 5586-H02 printer.

Editing
You can edit the contents of your session window using the Windows clipboard
and the Edit menu.

Note: When using copy/cut functions, Personal Communications takes the entire
contents from the session window and places it on the clipboard. To copy or
cut only marked sections from the session window, you need to update the
Cut/Copy options. To update the Cut/Copy options, do the following:
1. Select Edit → Preferences → Edit.
2. From the Edit Options window, select the Cut/Copy tab.
3. From the Cut/Copy page, select the Only if a trim-rectangle is marked

check box.
4. Close the Edit Options window.

Undo Cancels the most recent Edit operation, except for Copy Link, and restores
the contents of the session window and the clipboard accordingly.

Cut Copies the marked area into the clipboard and removes it from the display
session window.

Copy Copies (or duplicates) the marked area into the clipboard without
removing it from the display session window.
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Copy Append
Copies the marked area into the clipboard without removing it from the
display session window. If there is already data in the clipboard, Copy
Append adds the new data to it.

Paste Overlays the current contents of the clipboard into the session window,
starting at the current cursor position.

Paste Next
If not all data was pasted, Paste Next is enabled and the remaining
clipboard data can be pasted.

Clear Removes the marked area of the session window. The clipboard contents
are not altered.

Copy Link
Supports the DDE Copy Link function. To start a link between Personal
Communications and another application program, mark an area of the
session window, select Copy Link, and then select Paste Link in the other
application program.

Note: The command you should use for PasteLink or PasteSpecial depends
on the application program you are using.

Unmark
Removes the clipping (or marking) rectangle. The session window and the
clipboard contents are not altered.

Select All
Marks the entire session window.

Edit Options

Paste Options
You can control how text is pasted before and after protected fields, and how
tabulated text appears after it is pasted. The following Paste functions are
available.

Field Wrap
Check this box if you want pasted data that falls onto a protected field to
move to the next unprotected field. If you do not check this box, any data
that falls onto an unprotected field is lost.

Line Wrap
Check this box to allow pasting of copied text across lines.

Don’t Split Words
Check this box to avoid words being split across fields and lines. The text
being pasted into fields is split on word boundaries, which breaks the text
and starts the new word in the next field. If one word is being pasted into
a field, but the field is not long enough to hold the word, then as much of
the word as possible is put into the field, and the rest of the word is
carried on to the next field.

Note: If the Field Wrap or Line Wrap option is not enabled, the word
break option is not available.

Paste to marked area
Check this box to restrict pasting to a marked area, if it exists. If the
marked area doesn’t exist, pasting will take place at the current location.
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Stop pasting when protected line encountered
Check this box to have the pasted text stop when it comes to a protected
line on the emulator screen. If you do not check this box, the paste
continues.

Tab Character Processing

Advance to next tab stop
You can choose to align tabulated text at specified tab stops. For
example, if you choose Advance to next tab stop 4 column(s), your
tabulated text is advanced to the column position that is the next
multiple of 4.

Replace with n space(s)
You can choose to replace tab stops with a certain number of
spaces. For example, if you choose replace with 3 spaces, each tab
stop in your original text becomes 3 spaces.

The default setting is to replace each tab character with one space.

Paste data to fields
You can choose to have tabulated text placed in subsequent
unprotected fields. With this option, when a tab character is
encountered, the following text data will be pasted into the next
unprotected field of the emulator session.

Note: This option is available only for 5250 sessions.

Cut/Copy Options
You can control the size of the copy area and how +/- signs behave with signed
numeric fields (5250 only).

Only if a trim rectangle is marked
Select this box if you want to copy only the trim rectangle that has been
marked on the session screen. The default is to copy the entire screen if no
rectangle is marked.

Force Leading +/-
On a signed numeric field, the Force Leading +/- option will force the +/-
sign to be at the beginning of the field rather than at the end.

Note: This option is available only for 5250 sessions.

Trim Options
You can control the behavior of the trim rectangle.

Trim Rectangle sizing handles
Check this box to add handles to the trim rectangle, allowing you to
modify the size.

Trim Rectangle remains after edit function
This option keeps the trim rectangle active after completing the trim.

Editing by Linking to Windows Application Programs
Linking to Windows application programs supporting PasteLink lets you paste
session-window data to the windows of those application programs. You can run
CopyLink when DDE/EHLLAPI is usable.
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Confirming the DDE/EHLLAPI Settings
To check whether DDE/EHLLAPI is currently set to usable status:
1. Select API Settings from the File menu.
2. Make sure the DDE/EHLLAPI check box is selected.

If the box is checked, DDE/EHLLAPI is set to usable status. Continue to step 4.
3. If the box is not checked:

a. Click the DDE/EHLLAPI check box and then click OK.
b. Stop and then start your session to enable the new settings.

4. If DDE/EHLLAPI was already set to usable status, select OK.

Using CopyLink and PasteLink
1. Mark the session window area for which CopyLink should be issued.
2. Select CopyLink from the Edit menu.

If the session window is already linked with an application program,
CopyLink appears in gray and cannot be selected. In this case, force the
application program to end the linkage, or stop the application program. Then
you can select CopyLink.

3. Start the Windows application program for the window to which an area
should be copied.

4. Specify the location for which PasteLink should be run.
5. Issue PasteLink or PasteSpecial by using the menu for the application

program.
The contents of the marked area are pasted into the specified location in the
window of the application program.
CopyLink is now completed.

When the contents of the marked area in the session window are updated during
linking, the contents of the area pasted to the window of the linked application
program are also updated.

See the online help for more information about the CopyLink and PasteLink
functions.

Copying Table Data to a Spreadsheet
You can use the Cut, Copy, CopyLink, or CopyAppend choices in the Edit menu
to copy data in the session window to the window of a Windows spreadsheet
application program.

To use Copy, select the Paste or PasteLink choice in the application program
window into which data is to be copied.

Data in the marked area can be copied in the following three data formats,
depending on the format supported by the spreadsheet for the window to which
data is to be copied:

Sylk format
Data format for general-purpose spreadsheets, such as Multiplan

Biff3 format
Data format for Microsoft Excel
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Wk3 format
Data format for Lotus 1-2-3

Note: Whether application programs, such as Excel or Lotus 1-2-3, also support
these data formats in subsequent versions depends on individual application
program specifications.

Individual items of data in tables of the session window are divided automatically
such that they are suitable for spreadsheets, and they are copied into individual
cells of tables in the application program.

Copying Marked Data without Dividing It into Cells
To paste data in the marked area per line, without dividing it into individual cells,
add the following lines to the workstation profile:
[Edit]
Sylk=N (If Sylk format data is not divided into cells)
Biff3=N (If Biff3 format data is not divided into cells)
Wk3=N (If Wk3 format data is not divided into cells)

Copying Lines Containing Only Operational Signs
If data in the marked area contains signs, such as +, −, =, or |, the signs are
regarded as being ruled lines of the table. Once they are removed, only numeric
data is copied.

Table 7. Table Data in Marked Area

1 2 3 4

1990 60 —63 71 +58

1991 +69 69 90 80

1992 71 +80 80 —30

Table 8. Data Copied to Spreadsheet

1 2 3 4

1990 60 —63 71 58

1991 69 69 90 80

1992 71 80 80 —30

To copy these signs without replacing them with null characters, add the following
lines to the workstation profile:
[Edit]
MaskGridCharacter=N

Copying Data in Cells As Text Data
Data in the marked area is treated as numeric data by default. Therefore, currency
symbols, such as $, and punctuation marks, such as commas, are removed before
copying. To copy data containing such signs and marks as text data rather than
numeric data, add the following lines to the workstation profile:
[Edit]
ConvertToNumeric=N

Data in the marked area containing signs and marks is then copied as text data. In
addition, all numeric data that does not contain signs and marks is also copied as
text data.
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Getting Help
For information about all the tasks you can perform with the Edit menu choices, as
well as how to mark and then edit an area within the window, refer to the online
help:
1. Select Index from the Help menu.
2. When the help window displays, select Menu Bar Commands of the

Workstation Window.
3. Select Edit from the list of Menu Bar Commands.

Restrictions with Home3270 Attachment
When you use the Home3270 attachment, the following edit functions are
restricted:

Undo function
You cannot perform the Undo function after using the Cut, Paste,
PasteNext, or Clear functions because these functions modify display areas
in the protocol converter.

Cut and Clear functions
When an area to be cut or cleared contains a field attribute character or
protected field, or each line in that area ends at the end of an unprotected
field, the following things might occur:
v Characters in an unprotected field outside the area to be cut or cleared

might also be cleared.
v An alarm might sound.
v The cursor might not appear at the initial position.

When you perform the Cut or Clear function, specify only the minimum
area required (for example, some words or one field in one line), and then
confirm that the frame exists in an unprotected field.

Paste and PasteNext functions
When the area to be pasted contains a field attribute character or protected
field, or the end of the paste area on each line is at the end of an
unprotected field, the following things might occur:
v The character to be pasted might not be written to the expected position.
v An alarm might sound.
v The cursor might not appear at the initial position.

When you use the paste function, paste the shortest character string
possible (for example, a character string, but excluding CR/LF). Confirm
that the area to be pasted is in an unprotected field.

DBCS IME Auto-Start Switch (DBCS only)
The session default is IME auto-start, which means when the cursor moves to
DBCS field, the system selected IME is invoked automatically. In PCSWIN.INI, one
switch flag is added into [DBCS] section to disable this function.
[DBCS] IME_AUTO_START=N

The default is Yes. When N is specified in INI file, the IME would not be invoked
automatically. User needs to invoke IME by pressing system keys.
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DOS GAIJI Files (Japan only)
The GAIJI-editor J can only process GAIJI files that were created with the Windows
3.1 GAIJI editor. It cannot process DOS GAIJI files. The GAIJI-HENKAN-HOJO
tool (GAIJICNV.EXE) can be used to convert DOS GAIJI files as follows:
1. Start GAIJICNV.EXE, which is located in the Personal Communications

installation directory.
A dialog box to specify source file and target file appears.

2. Specify the source path/file C:\$SYS1Z24.FNT and the target path/file
C:\USERFONT.FON.

3. Start a conversion by clicking the Conversion button.
4. Run the Windows NT, Windows 95, or Windows 98 Gaiji-editor and capture the

file that is created by step 3, which is C:\USERFONT.FON.

For each file, you only need to convert either the 24x24 font or the 16x16 font with
GAIJICNV.EXE, not both.

Using the User Font Defined on iSeries (Japan only)
You can capture the user-defined font (GAIJI) defined on iSeries into Windows by
using IBM Personal Communications Tools/400 (PCT/400), IBM Personal
Communications, and the Gaiji editor of Windows.

The capturing is done as follows:
1. PCT/400

v Copying user font (CPYUSRFNT) command
This command is executed on iSeries. It copies the user-defined font image
from DBCS font table to a file. Please refer to the PCT/400 documentation
for details of the command.

2. Personal Communications
v File transfer facility

This facility transfers the file member that is copied by the copying user font
(CPYUSRFNT) command.
– GAIJI-HENKAN-HOJO tool (GAIJICNV.EXE)

This program is executed on Windows. It converts the file copied by the
copying user font (CPYUSRFNT) command to a Windows 3.1 format
GAIJI file so that it can be captured by the Gaiji editor of Windows.

3. Windows 95, Windows 98, Windows NT, Windows Me, Windows 2000, and
Windows XP
v GAIJI editor

By using the facility to capture the Windows 3.1 format GAIJI file, the file
converted by the GAIJI-HENKAN-HOJO tool (GAIJICNV.EXE) program is
captured.

Example
1. Copy the user-defined font images from the DBCS font table to a file by using

the copying user font (CPYUSRFNT) command.
a. ADDLIBLE QPCT (Add QPCT library to the library list)
b. CPYUSRFNT (Copying fonts, using default parameter)

The physical file USRFNT is created in library QTEMP and user-defined fonts
are copied to member USRFNT from the DBCS font table.
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2. Download QTEMP/USRFNT(USRFNT) to the PC as file USRFNT.FNT by using
the file transfer facility of Personal Communications.

3. Convert USRFNT.FNT by using the GAIJI-HENKAN-HOJO tool
(GAIJICNV.EXE).
v C:\PROGRAM FILES\PERSONAL COMMUNICATIONS\GAIJICNV.EXE

(This command runs GAIJICNV.EXE.):
v As the source file, specify the USRFNT.FNT file that you downloaded in step

2. Enter it as c:\usrfnt.fnt

v As the target path/file, specify c:\userfont.fon)

v Start the conversion by clicking the Conversion button.
4. Run the Windows GAIJI editor to capture the file that is created.

What Is Different from Windows 3.1
1. The GAIJI-HENKAN-HOJO tool (GAIJICNV.EXE) program is used to convert

the USRFNT.FNT. Font Setup Utility (SETUFNTV.EXE), which is provided by
PCT/400, is not used. Therefore, Font Setup Utility (SETFNTV.EXE) does not
need to be downloaded from iSeries.

2. To capture the font into Windows, the GAIJI editor of Windows is used.

Transferring Files
Personal Communications enables the transfer of one or more files between a host
system and workstation. You can define file transfer options in advance to help
you transfer a variety of files quickly and easily.

Note:
PCT400 was withdrawn from marketing 3/98.

With Personal Communications, you can perform the following file transfer
functions:

Send files to the host system
Send files using the Send File to Host from the Actions menu; or by
clicking the Send button on the tool bar; or, when using 3270 sessions, the
SEND command from the DOS prompt.

You can also send files by using an EHLLAPI or DDE application or a
macro that invokes file transfer.

Receive files from the host system
Receive files using the Receive File from Host from the Actions menu; or
by clicking the Receive button on the tool bar; or, when using 3270
sessions, the RECEIVE command from the DOS prompt.

You can also receive files by using an EHLLAPI or DDE application or a
macro that invokes file transfer.

Data Transfer
For 5250 sessions, click Preferences → Transfer from the Edit menu; then
select Data Transfer on the property page with the General tab. This
causes the invoking of data transfer functionality when one of the above
actions is taken. If Data Transfer is not selected, normal file transfer is
invoked.
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Create, test, replace, and delete templates
Create a template to have Personal Communications automatically generate
a workstation or host file name and transfer type when you select a file to
be sent or received.

Note: It is not possible to define a file transfer template with the long file
name naming convention.

Define transfer types
Define up to 16 transfer types for each host system. Text, binary, and
append (except for CICS®) are initially set as transfer types.

Select, create, and customize translation tables
Select translation tables to define which translation table is used during file
transfer.

Select, create, and customize DBCS translation tables
Select DBCS translation tables to define which DBCS translation table is
used during file transfer. (Japanese and Korean only.)

Import or export files (PC/3270 only)
Import/Export is an office system communication program and an
application program run on the IBM Customer Information Control System
(CICS). The import/export function makes it possible to import or export
Final Form Text (FFT), Revisable Form Text (RFT), and PC documents.

When you export a file from the host, your workstation receives the file
you exported and an interchange document profile (IDP) file. Before you
can import a file to your workstation, you need to create an IDP file with
transmission information.

Create interactive document profile (IDP) files (PC/3270 only)
An IDP file contains document header information, has the same name as
the file to be transferred, and has the extension .IDP.

To create an IDP file, select Preferences → Transfer from the Edit menu.

Note: When you transfer a file on a Telnet5250 session, you cannot transfer a file
that includes FFEF. The current version of the iSeriesTelnet program
misinterprets FFEF in the file as an end-of-record marker.

ASCII Host Data Transfer
When you are transferring files between two computers, specific protocols must be
followed. Files can be transferred only when your PC uses the same protocol as the
host. Personal Communications supports the XMODEM and YMODEM public
domain protocols.

For XMODEM, Personal Communications uses the XMODEM and XMODEM1K
protocols. XMODEM is a block-oriented, error checking protocol that is a single
file, half duplex protocol. XMODEM1K is the same as XMODEM, except that it
uses larger 1024 byte (1K) packets.

The YMODEM protocol is similar to the XMODEM1K protocol in that it transfers
data in 1K packets, but it also allows multiple files to be sent in one transfer.

The YMODEMG protocol transfers multiple files like YMODEM, but performs no
error detection or error correction. It can be much faster than YMODEM, but
requires an error-free data connection.
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With Personal Communications, you can perform the following data transfer
functions to or from ASCII hosts:

Send any type of files to the host system
Send files using the Transfer menu using XMODEM, YMODEM,
XMODEM1K, or YMODEMG.

Receive files from the host system
Receive files using the Transfer menu and XMODEM, YMODEM,
XMODEM1K, or YMODEMG.

Create, test, replace, and delete templates
Create a template to have Personal Communications automatically generate
a workstation or host file name and transfer type when you select a file to
be sent or received.

Setting Up the Appearance of a Session Window
You can use the following functions to define the appearance of your session
window:

Preferences → Appearance → Display Setup from the Edit menu
Customize a variety of characteristics, such as the cursor, pointer, rule line,
and trimming styles, graphics, sound, DBCS, and color palette, in the
display session.

Preferences → Appearance → Color Mapping from the Edit menu
Set the colors used in session windows.

Preferences → Appearance → Font from the Edit menu
Choose the font to use for display session windows, the style, and whether
it will be an automatic sizing font or a fixed size font. If you use a fixed
size font, you can also choose its size. The set of fonts from which you can
choose depends on the type of display you are using.

Note: You cannot change the font size when the session window is
maximized.

Preferences → Appearance → Window Setup
Change the appearance and title of the session window and change the
session icon.

Sounds
Personal Communications enables customization of program sounds through the
Windows Control Panel. You can configure specific program sounds using sound
files included with the Personal Communications product.

A Mute function can be used to silence all program sounds. This option is
available from the Edit → Preferences → Appearance → Display Setup → Sound
dialog.

Tool Bar Setup
The tool bar displays under the menu bar in your session window to allow quick
access to the Personal Communications functions, commands, and defined macros.

Use the tool bar pop-up menu to quickly and easily create, edit, and delete tool bar
items, as well as to save and load customized tool bars. When you customize the
tool bar, you can change the order of items, add and delete items, change the
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function, title, or graphic associated with any item, change the fonts, colors, and
other tool bar visual style elements. The settings are stored in a .BAR file.

To customize your tool bar, select Preferences → Tool Bar → Tool Bar Style from the
Edit menu, or display the Tool Bar pop-up menu by clicking on the right mouse
button while pointing at any part of the tool bar.

For information about customizing the tool bar, refer to the online help.

If you want to hide the tool bar, see “Showing or Hiding the Menu Bar, Status Bar,
or Tool Bar”.

Showing or Hiding the Menu Bar, Status Bar, or Tool Bar
You can show or hide the menu bar, status bar or tool bar.

If the menu bar is displayed, select Show Status Bar from the View menu or
Show Tool Bar from the View menu; otherwise:
1. Click the upper left corner of the session window to display the system menu.

v Hide Menu Bar appears when the menu bar is shown.
v Show Menu Bar appears when the menu bar is not shown.
v Hide Status Bar appears when the status bar is shown.
v Show Status Bar appears when the status bar is not shown.
v Hide Tool Bar appears when the tool bar is shown.
v Show Tool Bar appears when the tool bar is not shown.

2. To hide either the menu bar, status bar or tool bar, select Hide Menu Bar, Hide
Status Bar, or Hide Tool Bar.

3. To show either the menu bar, status bar or tool bar, select Show Menu Bar,
Show Status Bar, or Show Tool Bar.
If you hide the menu bar, the Pop-up Menu Bar choice is added to the system
menu. The Pop-up Menu Bar shows a cascading menu that contains all
commands in the hidden menu bar.

Window Setup
For some Windows operating systems, if you clear the Maximized Style → With
Title Bar option in the session Edit → Preferences → Window Setup dialog, then the
Minimize All Windows option on the Microsoft Windows taskbar may not have
any effect. To minimize the window, press Alt-Space and click Minimize.

Getting Help
If you are not sure how to set the session window’s appearance options, view the
detailed instructions in the help.
1. Select Procedures from the Help menu.
2. When the help window appears, search for appearance or scroll down to

Changing the Screen Appearance.
Select choices from that list for detailed information.
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Setting Up and Using the Assist Functions
Personal Communications provides auxiliary functions that let you operate the
system more efficiently. You can use the following functions:
v Keyboard/Macro/Script Function from the Actions menu
v Preferences → Hotspots from the Edit menu
v Preferences → Keyboard from the Edit menu
v Preferences → Macro/Script from the Edit menu
v Preferences → Mouse from the Edit menu
v Preferences → Popup Keypad from the Edit menu
v Preferences → Tab from the Edit menu (for VT Emulation sessions only)
v Preferences → Web Browser from the Edit menu

This section describes these auxiliary functions, and explains how to set up and
use them.

Keyboard, Macro, and Script Functions
A Keyboard/Macro/Script Function command lets you run scripts, macros or
Personal Communications-supplied key functions without using the keyboard. Run
the scripts, macros or key functions from the current cursor position in the session
window.

Scripting Functions
You can write, execute, record and terminate VBScripts in the emulator
environment. These scripts have access to the HACL automation API. The
programming environment includes methods, class descriptions and properties.
VBScript is a subset of the Visual Basic programming language.

Macro Functions
A macro is a sequence of key or mouse actions and host commands that you can
perform with a single action, such as a keystroke. Before you can use a macro
function, you need to define it. For more information, see “Macro/Script Setup and
Use” on page 65.

Key Functions
Personal Communications provides many key functions that can be assigned to the
keys on the keyboard, the mouse buttons, or the buttons of the pop-up keypad.
You can also use them to generate macros.

CM Mouse (Sample Application)
CM Mouse is a sample application included with Personal Communications that
provides intelligent and programmable mouse support for 3270 and 5250
emulation sessions. It allows users of host applications to point-and-click to
perform host functions. With its unique screen-recognition technology, CM Mouse
hotspots change instantly to give context-sensitive functions to each host
application window.

CM Mouse pop-up menus give you instant access to lists of options and functions
simply by pointing and clicking. Pop-up menus can simplify the selection of
commands and options, and can automate repetitive tasks.

For more information about CM Mouse, refer to the CM Mouse Support User’s Guide
and Reference.
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Hotspot Setup
A hotspot is an area of the session window on which you can double-click the left
mouse button to perform a command or function. You do not need to use the
keyboard. For example, you can double-click a function key number to perform the
function.

Tip: Select Show hotspots to get three-dimensional (3D) hotspots; these only
require a single click, and they stand out on your screen.

You can define the following actions for a hotspot:
v Click on a URL to connect to a World Wide Web site.
v Simulate function keys.
v Play a macro that has the same name as the character string you select on the

session window.
v Enter the selected string at the cursor position.
v Simulate the Enter key at the cursor position.
v For VT, simulate two sets of function keys, PF1 through PF4 and F6 through F20.

Using Hotspots

Note: You must have a mouse to use hotspots

To use a hotspot:
1. Move the mouse pointer to the hotspot displayed in the session window.
2. Double-click the left button of the mouse, except for 3D hotspots, which only

require a single click.
Personal Communications determines whether you have specified a hotspot
function that matches what appears at the position of the mouse pointer. If so,
it processes the hotspot. When two or more hotspots are specified for a single
character string, the first retrieved hotspot is processed.
Hotspots are retrieved in the following order:

(1) Point-and-select (connect to Web site using URL)
(2) PFnn, FPnn, Fnn, nn
(3) Point-and-select (run the macro)
(4) Point-and-select (enter the selected string)
(5) Point-and-select (enter at the cursor position)

Keyboard Setup

You can use Keyboard Setup to modify the function defined for each key on the
keyboard, except some reserved keys.

You can define the following functions for the keys.
v Performing a key function
v Playing a macro
v Entering characters

Note: By default, the Enter function is assigned to the Ctrl key. To change this
assignment or, if you are using a non-IBM compatible keyboard and the
Enter key does not work properly, you need to customize your keyboard.
For 3270 and 5250 sessions, you may use the keyboard map files provided
with Personal Communications. Refer to the individual emulator references
for more information about keyboard mapping and functions.
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Keyboard File
When you specify a key, you can save the new keyboard layout in a file (.KMP). If
you create two or more keyboard files, you can alternate between them as
required.

To assign a function to a key on the keyboard:
1. Select Preferences → Keyboard from the Edit menu or click the map icon on the

tool bar.
2. When the Keyboard Setup window appears, select Customize.
3. Assign the key functions, referring to the online help for detailed instructions.
4. Save your changes and exit the Customize Keyboard window.
5. Select OK after completing the setup.

You can reset either the entire keyboard or specific keys to defaults:
v To reset the entire keyboard, set the current keyboard to IBM Default in the

Keyboard Setup window.
v To reset specific keys, select a key in the Customize Keyboard window and then

select Default from the Current Actions for Selected Key box.

Note: There are seven keys that you cannot redefine and they are gray or dimmed
in Keyboard Setup; these keys are: Alt, AltGr, Print Screen, Scroll Lock,
CapsLock, NumLock, and Shift.

Customizing the VT Emulator Keyboard
If you are using a VT emulator session, you can represent ASCII control characters
in the character strings that you define for your customized keyboard.

Use the # character to represent the CTRL key, following it by any character from
the following list (only upper-case alphabetics are allowed):
@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_

Use ## to represent an actual #. For example, 123##45 represents 123#45.

If you follow # with any other character than those shown, you will get an error
message:
PCSKBD160 - Unrecognized key-action: "character string

For example, the error for the string "#a is
PCSKBD160 - Unrecognized key-action: "#a

The set of control characters is as follows:

Character pair Control Notes

#@ Control-@ NULL
#A Control-A

through
#Z Control-Z
#[ Control-[ ESC
#\ Control-\
#] Control-]
#^ Control-^
#_ Control-_
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Because the *.KMP file can be edited, there is a run time check to ensure that the
character string is correct. If "### is processed, then # will be displayed, followed
by a beep to signify that the entire character string was not played. If "123#a456 is
processed, then 123 will be displayed, followed by a beep.

Macro/Script Setup and Use
A macro is a sequence of key or mouse actions and host commands that you can
perform with a single action, such as a keystroke. You can edit an existing macro
or create a new macro by selecting Preferences → Macro/Script from the Edit
menu.

A script is a VBScript program that is a subset of the Visual Basic programming
language. For information on VBScript, see the on-line help pages.

Using a Macro or Script
You can use a macro or script in various ways. Table 9 lists examples of how you
can set up and then use macros and scripts.

Table 9. Macro Use Examples and Settings

If you want to... Do this...

Automatically play a macro or script when your
session starts.

Set an Auto-Start Macro/Script.

Play a macro or script while attached to a host
application.

Start Playing Macro/Script.

Play a macro or script with the keyboard or macro
function.

Use the Keyboard/Macro/Script
Function.

Click on a hotspot to play a macro or script. Set a Hotspot.

Assign a macro or script to a pop-up keypad button. Customize the Pop-Up Keypad file.

Press the mouse button to play a macro. Customize a Mouse file.

Press a key on the keyboard to play a macro or
script.

Customize a Keyboard file.

Creating a Macro
You can create a macro manually or by recording some of your interactions with
the host system, such as your logon procedure.

To create a macro manually:
1. Preferences → Macro/Script from the Edit menu.
2. When the Macro/Script Setup window appears, select Customize.
3. When the Customize Macro/Script window appears, select File, then New,

then Macro, and edit the macro. You can type statements directly or select
functions, characters, or even other macros, from the list of Key Actions in the
Select a Key-Action subpanel.
Refer to the online help for detailed information.

4. Click File, then Save to save the macro file.

Notes:

1. Macros that are converted to XML are intended for use in Host On-Demand
and will not function in Personal Communications emulation sessions. Use the
HOD Macro Manager to import a converted Personal Communications macro
into HOD. These converted macros will not appear in the list of available
Personal Communications macros.
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2. Arabic code page conversion is performed when an XML/VBScript macro is
created, so that the Arabic characters in the macro are displayed properly.
When recording the macro, the code page conversion is as follows:
v 3270/5250 sessions: 1008 (Arabic font code page) to 1256
v VT sessions: 1089 to 1256

When playing the macro, the code page conversion is as follows:
v 3270/5250 sessions: 1256 to 1008
v VT sessions: 1256 to 1089

Macro Statements
You can use the following statements when you create a macro:

Key function
Use Personal Communications-supplied key functions

Macro Define a macro within another macro but you cannot create a macro in a
permanent loop where the first macro is repeatedly called at the end of the
macros.

Character
Use any characters in the Character list in the Customized Macro window.

Character string
Use character strings you can type from the keyboard. You must use a
double quotation mark (“) at the beginning of the character string.

Wait condition
Specify wait conditions to stop the process until the specified time has
elapsed or the status satisfying the specified condition occurs.

Tokens
You can use tokens, such as goto and run, to add logic.

Macro Loop Considerations
If you use a GOTO and a label in a macro to create a loop, you may experience
unpredictable behavior if that loop executes a large number (more than 1000) of
iterations.

Creating a Script
You can create a script manually or by recording some of your interactions with
the host system, such as your logon procedure. Scripts, however, allow a higher
level of programming control unavailable with macros.

To create a script:
1. Preferences → Macro/Script from the Edit menu.
2. When the Macro/Script Setup window appears, select Customize.
3. When the Customize Macro/Script window appears, select File, then New,

then Script, and edit the script. The Select a Key-Action subpanel, in gray, is
not available for creating scripts.
Refer to the online help for detailed information.

4. Click File, then Save to save the script file.

Configuring a Macro or Script to Autostart
To configure a macro or script to autostart, do the following:
1. Click Edit → Preferences → Macro/Script.

The Macro/Script Setup window appears.
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2. Set a macro or script to autostart when your workstation starts.
3. Refer to the online help for detailed instructions and then select OK after

completing your setup.

Configuring a Java Applet to Autostart
To run a Java applet automatically, you can add the function Run Applet to a
macro. You can add this function to an autostart macro, so that an applet can be
run at session startup.
1. Click Edit → Preferences → Macro/Script.

The Macro/Script Setup window appears.
2. Select Run Applet from the Function drop-down list and type the name of the

class.

Refer to the online help for syntax and detailed instructions.

Note: The applet class specified must exist in the same directory path as the .WS
file in which the macro is included.

Recording Macros or Scripts
To start macro or script recording, Start Recording Macro from the Actions menu,
type the macro or VBScript name, select the type of file required, and then select
OK. If you are recording a Macro format file for Express Logon, select the Enable
check box and enter the Express Logon Feature (ELF) Application ID.

Note: When recording a macro, the processing of a nondisplayable field is
controlled by the setting of the parameter HideNonDisplayDataOnRecord=Y
in the [Keyboard] stanza of the .WS file. The hidden fields are ignored
during the recording session.

To end macro or script recording, select Cancel Recording Macro from the Actions
menu. The recording operation is canceled, and the macro or script is not saved.

To pause macro or script recording, select Pause Recording Macro from the
Actions menu. The recording operation stops. To restart recording, select Resume
Recording Macro.

To end macro or script recording, select Stop Recording Macro from the Actions
menu. Recording ends and the macro is saved in a specified file.

Playing Macros and Scripts
To start macro or script playing, select Start Playing Macro/Script from the
Actions menu, select the macro or script, and then select OK. The selected macro
starts to play.

To stop macro or script playing, select Quit Playing Macro/Script from the Actions
menu. The macro or script stops playing.

Note: When playing a macro, the processing of a nondisplayable field is controlled
by the setting of the parameter HideNonDisplayDataOnRecord=Y in the
[Keyboard] stanza of the .WS file; setting this causes a pop-up window to
display, requiring your input. When this appears, type in the requested
information and press Enter to continue.
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Express Logon Feature
The Express Logon Feature (ELF) allows a Personal Communications TN3270E
user to logon to a host application without sending the user ID and password. This
function is designed to be implemented only in certain circumstances by
administrators of Personal Communications; please refer to the Administrator’s
Guide and Reference for detailed information on implementation.

Recording an Express Logon Macro
To record an ELF macro, do the following:
1. Select the Macro file format of recording.
2. Check the Express Logon for Macro Enable box.
3. Enter the Application ID for Express Logon.
4. Follow this sequence when the host prompts you to type the user ID:

a. Type the user ID.
b. Type the password into the non-display password field.
c. Only after typing the password should you type any additional data needed

for logon.

As the keystrokes that were recorded during the logon are saved in the ELF
macro file, Personal Communications will attempt to identify and replace the
user ID and password that you enter with special placeholder strings, )USR.ID(
and )PSS.WD(. This automatic recognition requires that the password be typed
into the first non-display input field. The user ID is assumed to have been
entered just prior to the password.

If you make an error when typing any logon data, you must record the macro
again.

During later playback of the macro, the ELF Application ID (stored in the macro)
and the secured connection will be used to repeat the logon without the need for
user ID and password.

You can also manually configure a macro for ELF. Refer to the Administrator’s Guide
and Reference for more information.

Verifying an ELF Macro
You can visually inspect the macro recording of a host application logon to verify
that the UserID and Password have been replaced by Express Logon Feature (ELF)
tags. The procedure is as follows:
1. From the Action Bar, open the macro file containing the recorded keystrokes by

selecting Edit → Preferences → Macro/Script.
2. Select the macro file you just recorded and then select Customize.
3. Verify that the UserID has been replaced with two tags: the ELF Application ID

and the ELF UserID placeholder. The Application ID tag consists of three
words, each separated by a blank character: elf, applid, and the identifier of
the host application that will be logged onto. The UserID placeholder is
)USR.ID(

For example, "myUserID should have been replaced with ")USR.ID(.
4. Verify that the Password has been replaced with the ELF Password placeholder

tag )PSS.WD(.
For example, "myPassword should have been replaced with ")PSS.WD(.
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Mouse Setup
The Mouse Setup command lets you allocate functions to the right and left
buttons of the mouse; this enables you to perform the following actions without
having to use the keyboard:
v Running the Personal Communications-supplied key functions
v Running the user-defined macros
v Placing a character at the current cursor location

Mouse File
You can save the functions defined for the mouse buttons in a mouse file (*.MMP).
You can create two or more mouse files and switch between them as required.

To set up the mouseand assign functions to the mouse buttons:
1. Select Preferences → Mouse from the Edit menu.

The current settings appear in the Mouse Setup window.
2. Set up the required items, referring to the online help for detailed instructions.

If you want to create or edit a mouse file:
a. Select Customize.
b. When the Customize Mouse window appears, allocate functions to the right

and left buttons of the mouse. These appear in Current Action for Mouse
Button.

c. Select the required functions from List of Key Actions.
d. Save your changes and then select OK.

3. Select OK.
The mouse setup is complete.

Pop-Up Keypad Setup

The pop-up keypad is a small window in which some buttons are arranged. To
display the pop-up keypad, put the pointer anywhere in the session window and
press the right mouse button.

You can allocate the following functions to these buttons:
v A standard key function provided by Personal Communications
v A user-specified macro
v A character entry

To perform these functions, you only need to click a button on the pop-up keypad
with the left mouse button.

To view the description of a short-name key function or macro, click the right
mouse button while pointing at one of the function or macro names.

Pop-Up Keypad File
You can specify the number of buttons displayed in the pop-up keypad, the
functions allocated to those buttons, and colors of the buttons. You can save the
specified pop-up keypad contents in a pop-up keypad file (also referred to as a
poppad file).

A pop-up keypad file (*.PMP) contains the information for the number of buttons
displayed in the pop-up keypad, the functions allocated to those buttons,and color
information. You can define which pop-up keypad file is allocated to the pop-up
keypad.
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Using the Pop-Up Keypad
To use a pop-up keypad:
1. With the mouse pointer anywhere in the session window, click the right mouse

button.
2. Select Pad 1, Pad 2, Pad 3, or Pad 4.
3. Click the required button in the pop-up keypad.

To set up the pop-up keypad:
1. Select Preferences → Popup Keypad from the Edit menu.
2. When the Popup Keypad Setup window appears, set the required items,

referring to the online help for detailed instructions.
If you want to edit the pop-up keypad file, select Customize and then make
your changes.

3. Select OK. The pop-up keypad you selected is ready for use.

Tab Setup
For VT, Tab Setup allows you to define tab stops for your VT session.

Web Browser Setup
Web Browser Setup allows you to define a preferred web browser and to use it
rather than the one that comes with your operating system.

Managing Emulator Sessions
Personal Communications provides the following functions, in addition to those
provided by Windows, for those who work with several open session windows
simultaneously. These functions allow you to manage your session windows easily
and quickly. The Window menu has the following selections:

Jump Use Jump to switch between the currently opened session windows.

You cannot use Jump to switch to a session window that is currently
hidden. Instead, select Show Session from the Window menu to display
the session window on the screen. Then, select Jump.

Hide Session
Use Hide Session to stop displaying a visible session window.

You cannot hide all sessions. At least one session is always shown.

Show Session
Use Show Session to display a session window that was previously
hidden with Hide Session.

Use the View menu to display a previously-saved arrangement of windows, or to
save an arrangement of windows.

Personal Communications can save and restore the following information relating
to the session window view:
v Position and size of each window
v Window status (standard, minimized, or maximized)
v Window font

You can save view information for up to eight windows.
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Getting Help
For more information about managing session windows, refer to the online help:
1. Select Procedures from the Help menu.
2. When the help window appears, scroll down to Managing Workstation

Windows.
Select choices from that list for detailed information.

1390/1399 Code Page Support
Personal Communications supports 1390 and 1399 code pages; this allows Japanese
character processing capability. For more information, refer to the information
about Unicode support in the Administrator’s Guide and Reference.

Detect and Repair
You can use the Help → Detect and Repair function to check the Personal
Communications product integrity. The Detect and Repair operation performs a
check on the installed Personal Communications files to determine whether the
installation has been damaged. A subsequent repair is performed, if necessary.

Note: You should stop all active sessions or SNA nodes before starting the Detect
and Repair function.

Check Restore my shortcuts if you want your original shortcuts restored. If you
have modified your shortcuts since the original Personal Communications
installation, you might want to keep your shortcuts intact—in that case, do not
choose this option.

In order to use the Detect and Repair function, you must be authorized in the
System Policy. You might be prompted to provide the original Personal
Communications installation source.

Personal Communications Detect and Repair can be invoked from the Session
Manager or from an emulator session window. Windows Installer repair of the
Personal Communications product is invoked from the Windows Add/Remove
Programs function. Note the following differences in the operations.

Personal Communications Detect and Repair performs the following operations:
v Reinstalls a file if it is missing or corrupt, or if it is an older version.
v Rewrites all registry settings for the application in the LOCAL_MACHINE

section of the registry.
v Rewrites all registry settings for the application in the CURRENT_USER section

of the registry.
v Reinstalls all shortcuts (optional).

Alternatively, Windows Installer performs the following operations:
v Reinstalls a file if it is missing, or if it is an older version. Windows Installer

does not check files for corruption.
v Rewrites all registry settings for the application in the LOCAL_MACHINE

section of the registry.
v Rewrites all registry settings for the application in the CURRENT_USER section

of the registry.
v Reinstalls all shortcuts. This function is not optional in Windows Installer.
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Chapter 6. Utilities

Personal Communications provides various utilities, including the following:

32-bit ODBC Administrator
Allows you to add, configure, or delete an ODBC data source.

Database Access
Allows read-only access to data in the selected database after you have
configured a data source.

CM Mouse
Provides intelligent and programmable mouse support for 3270 and 5250
emulation sessions.

Menu-Bar Customization
Provides a means of changing the content of the menu bar of the Personal
Communications session window.

Multiple Sessions
Provides the capability to run multiple host sessions using a single icon.

ZipPrint
Allows you to print PROFS or OfficeVision notes, calendars, OV
documents, CMS files, XEDIT workspaces, and 3270 session screens.

Convert Macro
Allows an existing Personal Communications Macro file to be converted to
an XML or VBScript file.

PC Organizer
Runs Windows applications from a 5250 display session.

Data Transfer
Transfers data from the iSeries system to your workstation, or from your
workstation to the iSeries system. (Record-level data transfer).

Text Assist (SBCS only)
Allows you to create or edit a document or short messages.

iSeries Connection Configuration
Define connections to each iSeries host that will use the data transfer
function.

User Preferences
Allows set-up of certain advanced configuration parameters.

Product Update Tool
Allows testing and application of Corrective Service Distributions and
Authorized Program Analysis Reports

32-Bit ODBC Administrator
ODBC is a programming interface that enables applications to access data in
database management systems that use Structured Query Language (SQL) as a
data access standard.

Use the following steps to set up the Personal Communications ODBC data source:
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1. Select the 32-bit ODBC Administrator icon from the Windows Control Panel.
The Data Sources window appears.

2. Select IBM DB2® ODBC Driver data source in the Data Sources (Drivers) list.
Then click Finish.

3. Click Add Database. The Personal Communications Add Database SmartGuide
appears to prompt you through the set up.

4. Select the Manually Configure a Connection to a DB2 Database radio button.
5. Specify the information to set up the data source, by clicking Next.
6. When you are finished specifying the information, click Done.
7. You will be prompted to test the connection. To test the connection, click OK.

Notes:

1. Personal Communications uses ODBC 32-bit drivers. Applications, such as
Lotus 1-2-3 included in the Lotus SmartSuite® 96 package, require a 16-bit
driver and will not work with Personal Communications. You should see your
product vendor for a version that utilizes 32-bit ODBC drivers (Lotus 1-2-3
included in Lotus SmartSuite 97 for example).

2. To successfully test the DB2 connection, you must start the Personal
Communications SNA subsystem with the appropriate configuration data. This
configuration data must include the following:
v Node definition
v Device definition
v Connection definition
v Partner LU definition
v Mode definition (IBMRDB must be created)
v CPI-C Side Information

You might also need to include a Local LU 6.2 definition.

For more information on SNA Node operations, refer to the Administrator’s
Guide and Reference.

Following is a sample .ACG file:
NODE=(

ANYNET_SUPPORT=ANYNET_SUPPORTED
CP_ALIAS=YOURALIAS

DEFAULT_PREFERENCE=NATIVE
DISCOVERY_SUPPORT=DISCOVERY_CLIENT
FQ_CP_NAME=YOUR.CPNAME * <---- Modify w/ CP Name
NODE_ID=05D00000
NODE_TYPE=END_NODE
REGISTER_WITH_CDS=1
REGISTER_WITH_NN=1

)
PORT=(

PORT_NAME=LAN0_04
DLC_DATA=00000000000004
DLC_NAME=LAN
IMPLICIT_CP_CP_SESS_SUPPORT=1
IMPLICIT_DEACT_TIMER=0
IMPLICIT_DSPU_SERVICES=NONE
IMPLICIT_HPR_SUPPORT=1
IMPLICIT_LIMITED_RESOURCE=NO
LINK_STATION_ROLE=NEGOTIABLE
MAX_IFRM_RCVD=8
MAX_RCV_BTU_SIZE=32767
PORT_TYPE=SATF
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PORT_LAN_SPECIFIC_DATA=(
ACK_DELAY=100
ACK_TIMEOUT=3000
ADAPTER_NUMBER=0
BUSY_STATE_TIMEOUT=60
IDLE_STATE_TIMEOUT=30
LOCAL_SAP=04
MAX_RETRY=10
OUTSTANDING_TRANSMITS=16
POLL_TIMEOUT=3000
POOL_SIZE=16
REJECT_RESPONSE_TIMEOUT=30
TEST_RETRY_INTERVAL=8
TEST_RETRY_LIMIT=5
XID_RETRY_INTERVAL=8
XID_RETRY_LIMIT=5

)
)
LINK_STATION=(

LS_NAME=LINKMVS
ACTIVATE_AT_STARTUP=1
ADJACENT_NODE_TYPE=APPN_NODE
AUTO_ACTIVATE_SUPPORT=0
CP_CP_SESS_SUPPORT=1
DEFAULT_NN_SERVER=0
DEST_ADDRESS=40000000000000 * <---- Modify w/ Dest
DISABLE_REMOTE_ACT=0
DSPU_SERVICES=NONE
ETHERNET_FORMAT=0
HPR_SUPPORT=0
LIMITED_RESOURCE=NO
LINK_DEACT_TIMER=0
LINK_STATION_ROLE=USE_ADAPTER_DEFAULTS
MAX_IFRM_RCVD=0
MAX_SEND_BTU_SIZE=32767
NODE_ID=05D00000
PORT_NAME=LAN0_04
SOLICIT_SSCP_SESSION=0
TARGET_PACING_COUNT=1
TG_NUMBER=0
USE_DEFAULT_TG_CHARS=1

)
DLUR_DEFAULTS=(

DEFAULT_PU_NAME=YOURALIAS * <---- Modify w/ your name
DLUS_RETRY_LIMIT=3
DLUS_RETRY_TIMEOUT=5

)
LOCAL_LU=(

LU_NAME=LUNAME * <---- Modify w/ LU Name
LU_ALIAS=LUALIAS * <---- Modify w/ LU Alias
LU_SESSION_LIMIT=0
NAU_ADDRESS=0
ROUTE_TO_CLIENT=0
DEFAULT_POOL=0

)
.
.
.
PARTNER_LU=(

FQ_PLU_NAME=PARTNER.LUNAME * <---- Modify w/ Partner Info
CONV_SECURITY_VERIFICATION=1
MAX_MC_LL_SEND_SIZE=32767
PARALLEL_SESSION_SUPPORT=1
PARTNER_LU_ALIAS=RBNAME * <---- Modify w/ Location/RDBNAME
PREFERENCE=USE_DEFAULT_PREFERENCE

)
CPIC_SIDE_INFO=(
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SYM_DEST_NAME=DB2CPIC * <----- Needed for ODBC configuration
CONVERSATION_SECURITY_TYPE=NONE
MODE_NAME=IBMRDB
PARTNER_LU_NAME=USIBMNM.NM57DB21 * <---- Modify w/ Partner Info
TP_NAME=DB2DRDA * <---- Modify w/TP Name (per DB2 help)
TP_NAME_TYPE=APPLICATION_TP

)
VERIFY=(

CFG_MODIFICATION_LEVEL=13
CFG_VERSION_LEVEL=1

)

Database Access
Database Access lets you access host or PC databases and retrieve data, using
ODBC drivers. If you specify the conditions for accessing data in each window, the
desired query can be created automatically.

From Database Access, you can:
v See and modify the SQL statements that are created automatically.
v See available database-table lists.
v Copy spreadsheet data to the clipboard.
v Show data in the grid in the main window spreadsheet, send data to other

applications (for example, Lotus 1-2-3 or Microsoft Excel), or send data to a
printer.

Before using Database Access, you should read Help information on:
v Database size limits
v Installed programs

CM Mouse
CM Mouse allows users of host applications to point and click to perform host
functions. Clicking a CM Mouse on hot spots gives true context-sensitive function
to each host application screen. Hot spots are not fixed function or fixed
placement, but change dynamically as you move through a host application.

CM Mouse pop-up menus give you instant access to lists of options and functions
with a simple point and click. Pop-up menus can simplify command selection,
choose options, and automate repetitive tasks. The CM Mouse pop-up menu editor
allows you to quickly and easily customize the menus for your own purposes or to
create new menus.

The CM Mouse scripting language is powerful enough to automate complex host
interactions, yet simple enough for novice users.

Refer to the CM Mouse Support User’s Guide and Reference for more information.

Menu-Bar Customization
This utility enables you to remove items from the menu bar of the Personal
Communications session window. The changes affect only the session that you
customize, so you can make different changes to each session. You can remove
three types of items:
v A menu bar command, such as File, Edit, or Communication
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v A pulldown menu command, such as, New, Open..., Color Mapping, Configure

v A separator-line that resides between two commands in a pulldown menu

The modifications to the menu bar are saved in the workstation profile that you
choose and become active the next time you start the session.

Note: If you created a customized menu in a previous version of Personal
Communications, you may need to reconfigue the settings to account for the
new menu structure in Version 5.7.

Multiple Sessions
The Personal Communications Multiple Sessions Batch Program enables you to
start several host sessions by clicking a single icon; the necessary commands are
specified in a batch file (.BCH). You can include in a batch file other programs,
which may communicate with a host session using the DDE or EHLLAPI interface.

ZipPrint
ZipPrint is a 3270 utility that enables you to print PROFS or OfficeVision (OV)
notes, calendars, OV documents, CMS files, XEDIT workspaces, and 3270 session
screens. By default, it uses the Windows printer currently set up for the host
session, but you can change it if you wish.

You do not have to install ZipPrint—you just start it. It adds itself to the menu-bar
of the sessions for which you define it, so you can use it in the same way as any
other menu-bar function. You must start ZipPrint before you start a session in
which you want to use it.

ZipPrint needs the DDE/EHLLAPI, so you must make sure that this is enabled for
the sessions for which you want to use ZipPrint. (It is enabled by default, but you
should check that it has not been turned off.)

For more information about ZipPrint, see “ZipPrint (3270 Only)” on page 50.

File Transfer Considerations
ZipPrint uses the Personal Communications file transfer function to print
VM/CMS notes and files. In order for this function to work correctly, you should
use the VM/CMS host type for 3270 file transfer.

In the emulator session window, click Edit → Preferences → Transfer. On the File
Transfer Settings → General tab, select VM/CMS from the Host Type dropdown
list.

On slow communications lines, such as some IBM Global Network or Home3270
connections, or if you are using a large packet or block size, you may experience a
file transfer timeout. If you do, you should increase the timeout delay. To change
the timeout delay, do the following:
1. From the session menu, click Edit → Preferences → Transfer .
2. On the General tab, change the File Transfer Timeout to 150 seconds.
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Convert Macro
The Convert Macro utility enables you to convert an existing Personal
Communications Macro file to XML or a VBScript file.

Note: Macros that are converted to XML are intended for use in Host On-Demand
and will not function in Personal Communications emulation sessions. Use
the HOD Macro Manager to import a converted Personal Communications
macro into HOD. These converted macros will not appear in the list of
available Personal Communications macros.

To use the conversion utility, click IBM Personal Communications → Utilities →
Convert Macro.

To convert an existing macro to XML or a VBScript, do the following:
1. Select the name of an existing macro to be converted.

Note: The macro must exist in the application data directory specified during
installation.

2. Select VBScript or XML as the type of macro to which to convert.
3. Click Convert.
4. Enter a name for the new XML file or VBScript or accept the generated name.

The extension will be added automatically.

Note: When saving a converted XML macro you can choose where you would
like to save it. You should not change the location of the converted
VBScript macros.

5. Click Save.
6. Repeat the procedure to convert another macro, or click Close to end the

application.

PC Organizer
You can use the PC Organizer to run DOS commands and applications or
Windows applications from a 5250 display session.

iSeries Requirements
Before you can use the PC Organizer, one of the following programs must
have been installed on the iSeries system:
v iSeries Access for Windows (or OS/400® V3 or later)
v PC Support/400 (5738-PC1)

Starting the PC Organizer
To start the PC Organizer:
1. Start a 5250 display session.
2. Sign on to the iSeries system.
3. Enter the following command on the iSeries command line:

STRPCO PCTA(*NO)

Note: Personal Communications does not support the PC Text Assist (PCTA)
function, so you should specify this parameter with *NO. Even if you

78 Personal Communications Quick Beginnings



specify *YES, you cannot use the PC Text Assist function provided by
the PC Support/400 Workstation Feature.

You can now use the PC Organizer functions in a 5250 display session by using
one of the following methods:
v Display and then select choices from the menu.

To display the PC Support/400 or iSeries Access for Windows Organizer menu,
enter:

GO PCOMNU
v Enter PC Organizer commands.

To start the PC Organizer functions, enter:
STRPCCMD

PCO.EXE Message
When you run a workstation command or program, you might receive a
message that the PCO.EXE program is not active. You can ignore this
message, because it is not necessary for PC400 to activate PCO.EXE.

STRPCCMD_PAUSE Keyword
You can use the .WS profile keyword STRPCCMD_PAUSE to control the pause
behavior after a command is issued using STRPCCMD. The keyword can take
values Y (Yes) or N (No).

If the STRPCCMD_PAUSE feature is not enabled (value is N), PC5250 processes
the STRPCCMD command in the following manner. This is the default behavior.
v If the given command is a DOS command, PC5250 spawns the DOS command.

PC5250 does not issue a DOS PAUSE. It just waits for the DOS command to
finish, immediately closes the DOS box, and then tells the iSeries host that it has
finished.

v If the given command is a Windows application, PC5250 ignores the PAUSE
option because there is no way to do a DOS PAUSE after a Windows application
has finished running. Once the Windows application finishes, PC5250 tells the
iSeries host that it has finished. PC5250 assumes that the application is finished
when focus returns to the PC5250 session window. If the user does nothing, the
Windows application will start, which gives it focus. Then, when the application
finishes, the last window to have focus will get the focus back, which should be
the PC5250 session window.

Note: This implementation has another effect: you can force PC5250 to tell the
iSeries host that the STRPCCMD command is finished (even if it is not
finished) just by clicking on the PC5250 session window.

If the STRPCCMD_PAUSE feature is enabled, PC5250 spawns the given
STRPCCMD command (DOS command or Windows application). PC5250 waits for
the command/application to complete before telling the iSeries host that it has
finished.

Notes:

1. For DOS commands, there is no way to have Press any key to continue...
appear in the DOS box or have PC5250 wait for the user to press a key before
it tells the iSeries host that it is finished.
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2. While waiting for the command/application to complete, the presentation
space (display) is cleared to a blank state.

Getting Help
Refer to the online help for more information about using the PC Organizer.
1. Select Procedures from the Help menu.
2. When the help window appears, search for organizer or scroll down to PC

Organizer (5250 Session).
Select topics in the list to view information about starting and using the PC
Organizer, using the PC Organizer menu, and the differences between the PC
Organizer provided with PC400 and PC Support/400.

Data Transfer
Personal Communications Data Transfer enables you to transfer data between an
iSeries system and your workstation. To use the Data Transfer function, select the
Data Transfer icon.

Transferring data is quite different from transferring files, which is described in
“Transferring Files” on page 58.

Requirements
Before you can transfer data with Personal Communications:
v If you are using SNA connectivities, you must have an active iSeries

session.
v IBM PC Support/400 (5738-PC1) must be installed on your iSeries system,

unless IBM OS/400 Version 3 or later is installed.

There are two types of data transfer, depending onthe direction of the transfer.

Data sending
Data is transferred from your workstation to the iSeries system.You can
transfer data to any of the following destinations:
v Existing members in an existing iSeries physical file
v New members in an existing iSeries physical file
v New members in a new iSeries physical file

Note: You cannot transfer data from a workstation file to an iSerieslogical
file.

Data receiving
Data is transferred from the iSeries system to your workstation.

While receiving data from the host, you can specify the data to be received
and where the data is to be output.

Receivable data includes:
v An entire iSeries file
v Part of an iSeries file
v Data combined from several iSeries files
v Summary of record groups

Specify the following output destinations:
v Display
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v Disk
v Printer

Also, you can specify the numeric value format.

For more information about data transfer, refer to the 5250 Emulator User’s
Reference.

Text Assist (SBCS only)
With Personal Communications, you can use the improved text editing capability
of Text Assist provided by the OfficeVision/400™ word processing function to
create a document or short messages, or to edit an existing document.

To start the text assist function, enter WRKDUC on the 5250 command line.

For more information about using Text Assist, refer to the documentation for the
OfficeVision/400 program.

The Text Assist function in Personal Communications is a Controller Text Assist,
not the PC Text Assist supported by PC Support/400 Workstation Feature.

Controller Text Assist in Personal Communications provides the following
functions that are not included in PC Text Assist:
v Line commands
v 132 columns

Controller Text Assist in Personal Communications does not, however, provide the
multicolumn edit function that is included in PC Text Assist.

Note: In the Text Assist environment, Alt key functions are assigned to the Ctrl
key state to avoid conflicts with existing emulator functions. For example,
the Word Underscore (WrdUnd) key is Ctrl+W rather than Alt+W. Many of
these functions can be remapped to the Alt key state without conflicting
with emulator functions.

When you draw a line using the cursor draw option of the OfficeVision/400
program, the insert mode is not available.

iSeries Software Requirements
The iSeries system must have one of the following programs installed to
support the Text Assist features:
v OS/400 V2R2.0 with cumulative PTF C3285220 with PTF SF14687
v OS/400 V2R3.0 with PTF SF14495
v OS/400 V3R0.5
v OS/400 V3R1.0, or later

Text Assist Key Functions
Following is a list of OfficeVision/400 Text Assist key functions:

Function Description

Begin of Line Moves the cursor to the beginning of the line

Begin Bold Begins bold highlighting
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Function Description

Bottom of Page Moves the cursor to the bottom of the page

Carrier Return Ends a line of text or a paragraph by inserting a carrier return

Center Text Centers a line of text

End of Line Moves the cursor to the end of the line

End of Page Inserts an end-of-page character at the cursor position

End Bold/Underscore Ends bold highlighting and underlining

Half Index Down Begin subscript or end superscript

Half Index Up Begin superscript or end subscript

Insert Symbol Displays a menu for special symbols

Display Text Codes Shows hidden text controls

Next Column Inserts a next column instruction at the cursor position

Next Stop Code Moves the cursor to the next stop code symbol

Required Backspace Moves the cursor one space to the left

Required Space Inserts a required space to keep words together on a line

Required Tab Indents a block of text

Stop Code Inserts a stop code at the cursor position

Top of Page Moves the cursor to the top of the page

Begin Underscore Begins underlining text

Word Underscore Underlines the word that starts at the cursor position

iSeries Connection Configuration Utility
The iSeries Connection Configuration Utility is used to define connections to each
iSeries host that will use the data transfer function. The connection definitions are
saved in an .NDC file in ASCII format.

You can use this utility for either SNA or TCP/IP connections.

For more information on Data Transfer see “Data Transfer” on page 80.

To use the utility, click Start → Programs → IBM Personal Communications →
Utilities → iSeries Connection Configuration; the resulting iSeries configuration
screen has the following options:

Show IP Host Connections
Click this button to display and configure IP connections to the iSeries
host.

Show SNA Hosts
Click this button to display and configure SNA connections to the iSeries
host.

Add Click the type of connection (IP or SNA), and then click Add. Enter the
Host name and Alias in the resulting dialog box.

Modify
Select a host name from the connection list, and then click Modify to edit
the Host name and the Alias in the .NDC file.
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Remove
Select a host name from the connection list, and click Remove to delete
this connection definition from the .NDC file.

Note: When disabling a connection, if you want to preserve the connection
definition but disable the connection, uncheck the checkbox next to
the name in the connection list.

Select ACG File
Click this button to select an associated SNA Node configuration file
(.ACG).

Global Parameters
Click this button to edit the Extension list and Cache size.

Extension List
The extension list parameter specifies the extension of a file on an iSeries. You can
specify more than one extension parameter in the extension list. The code pages of
files with the specified extensions are translated from the EBCDIC code page to the
ASCII code page when the file is transferred between the iSeries and the client. Up
to three characters are allowed. There are two special cases:
v A dot alone (. ) indicates that data for files having no extension should be

converted.
v The character pair .* indicates that data for all files should be converted.

Cache Size
The cache size parameter specifies the number of kilobytes of iSeries data that is
buffered in the read-ahead cache of the client. The default is 256 KB; the maximum
is 4 MB. A value of zero requests that no cache be used. iSeries data can be
retrieved in amounts that are first cached locally on the client. The client retrieves
the data from the cache to populate the local device. This read-ahead caching
reduces the number of times the client has to access the iSeries to retrieve the data.

User Preference Manager
The User Preference Manager (UPM) provides a method for changing
configuration and setup items.

Notes:

1. Preferences set with UPM pertain to you whenever you log on to the same user
ID on the affected workstation; they apply to all of your sessions while you are
logged on.

2. Preferences set using the session Edit menu apply to all sessions controlled by
the workstation profile created or changed while using a session—when that
session profile is used again, the preferences are applicable, regardless of the
user ID at the time.

3. One of the capabilities of UPM is to allow specification of a directory to be
used for storing your profiles; this allows full control of your environment.

To access UPM, click Programs → IBM Personal Communications → Utilities →
User Preferences from the Windows Start menu. The initial UPM screen displays
basic information about your Personal Communications installation on the
property page with the General tab.
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To change specific configuration items, select the appropriate property page using
the Basic tab. Select the language to use for the user interface in subsequent
Personal Communications sessions.

If the UPM application data directory location was selected during installation of
Personal Communications, you can specify the default location of workstation
profiles.

The Basic property page shows a textbox with the currently assigned location
where profile files are stored. To change it, type a new name, or click the Browse
button to locate the directory location of your choice.

User Interface Language
If your system was installed with multiple-language support, the Basic property
page shows a section labeled Select a default user interface language. If you click
on the radio button for Personal Communications User Interface Language
Preference, it also shows a drop-down listbox, with the language selected that is
currently being used; you can select any other language from the list, and that
language will be used for the user interface when you subsequently restart
Personal Communications. Or you can click the radio button User Default from
Regional Settings if you want the language to be that specified in the Windows
settings. You can also click the radio button Post a Language Selection Dialog for
each process; this results in a pop-up dialog each time you start a new application
from the Personal Communications group of programs.

Note: You might receive a warning message, if the selected language is
incompatible with your system’s current code page. You can ignore this, if
you are planning to reboot your computer to select a new system locale with
a compatible code page.

Standby/Hibernate
Choose whether to prompt for acceptance when the system attempts to go to
standby or hibernate (power saving) mode. If you select Standby/Hibernate
without prompting, Personal Communications allows the system to standby or
hibernate without prompting you, even if sessions are connected. By default, this
option is clear.

See “Power Management” on page 47 for more information.

Product Update Tool
IBM provides two forms of updates to the Personal Communications product:
Corrective Service Distributions (CSDs) and Authorized Program Analysis Reports
(APARs). CSDs are full product updates and APARs are single module product
fixes. You should not implement CSDs or APARs without administrative approval.

You can use the Product Update Tool to check for CSDs and APARs for Personal
Communications, using the Internet. You must be authorized in the System
Policy—if you are not authorized, then a System Policy restriction panel will open.

Note: If you have difficulty using the Product Update Tool on Windows 95
systems, you might have to test an APAR or check for CSDs using another
platform. Refer to the Personal Communications Readme file for the latest
information.

84 Personal Communications Quick Beginnings



To check for CSDs and APARs:
1. From the Windows Start menu, click IBM Personal Communications→

Administrative and PD Aids.
2. Select Product Update Tool.
3. The configuration panel appears automatically if WebUpdate has not been run

after the initial Personal Communications installation. Click Connection
Configuration to select the following options:
v Connection Method

Specify your Internet connection method. If connecting through a modem,
select the dialup connection name from the drop-down list.

v Proxy Connection Settings
During installation, Personal Communications automatically checks the
Internet browser proxy settings and configures WebUpdate to use those
settings. If no proxy settings are available, Personal Communications defaults
the settings to blank (no settings). Select Uses Proxy Connection to add or
change the proxy settings for WebUpdate. If you use an HTTP proxy server,
you can enter the username and password.
If you are connecting through a SOCKS server, type socks= in front of the
server address.

4. Click OK to close the configuration panel.
5. Click Check for CSDs to access WebUpdate and check for available CSDs. If

CSDs are available, you will be prompted to go to the registration Web pages
for the CSDs. If you do not go to the registration Web page, then the date used
for automatic checking is not updated in the registry. A pop-up panel will
notify you if there are no CSDs available for the current version.

6. The APAR portion of the utility is intended primarily for Personal
Communications administrators. Do not test, commit, or remove an APAR
without administrative approval. You must be connected to the Internet in
order to test or commit APARs.

Refer to the Administrator’s Guide and Reference for more information about APARs
and CSDs and using the Product Update Tool.
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Chapter 7. Enabling Client/Server Applications

Personal Communications support for APPN end nodes lets you take advantage of
APPN networks. An APPN network allows automatic locating of partner
applications and dynamic, optimized route selection. These features allow
workstations to communicate more flexibly with other systems in the network.

Personal Communications also provides support for 32-bit APPC and CPI-C
application programming interfaces (APIs), which provide convenient ways for
32-bit client application programs on your workstation to communicate with those
on other workstations.

Configuring a Node
Before you can take advantage of the client APIs and communicate with other
application programs, you first need to configure Personal Communications as an
SNA end node.

To configure the SNA node:
1. From the Start menu, click Programs → IBM Personal Communications → SNA

Node Configuration.
The Personal Communications SNA Node Configuration window appears.

2. Select the necessary Configuration Options in the order listed on the window.
To select an option, click it and then click New.
For each option, enter the appropriate information on the configuration panels.
Most required information is listed on the Basic page. Click OK to complete the
option. Click Help if you need more information about the individual
parameters.

3. Click Save or Save As from the File menu.
4. Type the file name and then click Save. Note that you can choose the file type

and where to save this file. The default file type is .ACG and the default
location is the system-class application data directory.

5. Click Exit from the File menu.

Tip
If you have more than one configuration file, you can apply additional
configuration files to an active node. Refer to the help in the SNA Node
Operations section of the product for details.

Starting the SNA Node
1. To start the SNA node, from the Start menu, click Programs → IBM Personal

Communications → SNA Node Configuration.
The Personal Communications SNA Node Operations window appears.

2. Click Start Node... from the Operations menu.
The Select configuration file to use... window appears.

3. Double-click the configuration file (.ACG) that defines the node you want to
start.
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Note: Another way to start the SNA node is to use the command line. The
command to use is CSSTART. For the proper syntax, refer to Administrator’s
Guide and Reference.

Stopping the SNA Node
1. To stop the SNA node, click Programs → IBM Personal Communications →

Administrative and PD Aids → SNA Node Operations.
The Personal Communications SNA Node Operations window appears.

2. Select a resource in the Alias column.
3. Click Stop Node... from the Operations menu.

Note: Another way to stop the SNA node is to use the command line. The
command to use is CSSTOP. For the proper syntax, refer to Administrator’s
Guide and Reference.

APING Requirements
If you wish to run the Check Connection (APING) utility provided with this
package to an iSeries running OS/400 V3R1, you must install PTF MF10808 on the
iSeries first. If this PTF is not installed, then errors with sense codes of 080F 6051
and 1008 201D will occur.
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Chapter 8. API Client Attachments

IBM Communications Server for Windows

Support for Communications Server
If you are connecting to a Communications Server for Windows by using the
Communications Server client or installing on the Communications Server
machine, configure Personal Communications to use the SNA API client interface.

The API client interface lets you make the following attachments:
v 3270 emulation

LUA - LU 0, 1, 2 or 3 via the WinRUI interface. This lets you have normal
display or printer sessions.

v APPC3270

This provides 3270 display sessions (not printer) over an LU 6.2 connection to
the host.

v 5250 emulation

This provides 5250 display and printer sessions through APPC.

Note: You must first install the Communications Server for Windows 5.0 or later
client.

You can install Personal Communications on top of Communications Server for
Windows Server or over the API Client.

Two interfaces are supported:
v Communications Server for Windows

You can run Personal Communications on a Communications Server; it uses the
Communications Server protocol stack to connect to the host.

v Client for Communications Server for Windows

For client workstations, Communications Server has a client that communicates
with the server and provides an interface that Personal Communications can
use. The client must be installed on your workstation before you install Personal
Communications.

Note: You cannot install the Personal Communications SNA protocol drivers if you
intend to use the API Client interface. You can, however, use the non-SNA
attachment types, which include HPO, Home3270, TN3270, and IPX/SPX.

Load Balancing
Personal Communications supports load balancing for all client types. Load
balancing enables you to distribute LU 0 to 3 and LU 6.2 sessions across Personal
Communications servers. The server advertises services including load factors,
which the clients or servers can gather and organize to select a server.

Load Balancing over TCP/IP Protocols
Load Balancing over TCP/IP protocols is a key feature for IBM Communications
Server for Windows 5.1. This feature dynamically balances dependent LU2
(host-to-workstation) sessions. For LU2 sessions over TCP/IP connections, the load
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is distributed across servers within a named LU2 pool and a named scope. That is
the server with the least overall load within the named scope supporting the
named LU2 pool will satisfy a given LU2 connection request.

Notes:

1. IBMSLP.DLL should be available on the client workstation system directory.
Refer to your Server documentation for information about where to obtain this
dynamic load library file.

2. For true load balancing use a wild card (’*’) Server Name and Service Name,
and use the pooled LU category with a LU-Pool Name.

Hot Standby
The Hot Standby feature enables to ensure that configured connections to a host
can continue to function when a critical server goes down by triggering activation
of alternative connections on a backup server. Load Balancing can be used in
conjunction with Hot Standby.

If the active session to the server goes down because of server or link failure,
Personal Communications will try to reconnect the session with the provided
backup server name, service name, or pool name.

IBMSLP.DLL should be available on the client workstation system directory.
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Chapter 9. Messages

Online messages are displayed during Personal Communications sessions, but a
message does not always mean an error occurred. For example, a message might
tell you that an operation is in progress or has been completed. A message can also
prompt you to wait for the completion of an operation.

Press F1 to display help for the messages that appear.

Security-Related Messages
Personal Communications optionally utilizes Transport Layer Security (TLS) or
Secure Sockets Layer (SSL) to establish sessions with servers; this might require
input from you (for example, a password). Refer to Administrator’s Guide and
Reference for details.

Functions Restricted by System Policies
If your workstation is centrally administered, you may be shown a warning or
pop-up error message whenever you attempt to use certain restricted functions.
For example, if your ability to remap the keyboard is restricted, a message would
be displayed when you select Preferences → Keyboard from the Edit menu.

Contact your system administrator for further guidance. For further information
about the systems policies provided with Personal Communications, refer to
Administrator’s Guide and Reference.

System Error Messages
If a page fault or similar system error message appears in a pop-up window, you
can copy its contents into the Windows clipboard. To do this:
1. Click Details Command on the pop-up window.
2. Mark the text that you want to copy.
3. Right click the marked text and then click Copy.
4. Start an editor, such as Notepad, and click Paste from the Edit menu.
5. Save the file in case an IBM service representative needs this information to

diagnose your problem.

OIA Messages
Personal Communications displays messages in the operator information area(OIA)
or in a pop-up window. Messages from Personal Communications are displayed in
the message window; messages from the host system are displayed in the OIA of
the session window.

The bottom line of the session window is the OIA. The OIA indicator indicates the
status of Personal Communications and information about the workstation, host
system, and attachment method.

All of the OIA indicators, reminders, and messages are described in the online
help. To view this information:

© Copyright IBM Corp. 1989, 2003 91



1. Select Help Contents from the Help menu.
2. Select The operator information area messages.

Tip
When the index window appears, select the Index button, and then select
Find. Type in the number of the message. Click Search.
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Part 3. Appendixes
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Appendix. Notices

This information was developed for products and services offered in the United
States. IBM may not offer the products, services, or features discussed in this
information in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or imply
that only that IBM product, program, or service may be used. Any functionally
equivalent product, program or service that does not infringe any IBM intellectual
property right may be used instead. However, it is the user’s responsibility to
evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this information. The furnishing of this information does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
500 Columbus Avenue
Thornwood, NY 10594
U.S.A

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS INFORMATION AS IS
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the information. IBM may make improvements
and/or changes in the product(s) and/or program(s) described in this information
at any time without notice.

Any references in this information to non-IBM documentation or non-IBM Web
sites are provided for convenience only and do not in any manner serve as an
endorsement of those documents or Web sites. The materials for those documents
or Web sites are not part of the materials for this IBM product and use of those
documents or Web sites is at your own risk.

Licensees of this program who wish to have information about it for the purpose
of enabling:(i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:
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IBM Corporation
Department T01
Building 062
P.O. Box 12195
Research Triangle Park, NC 27709-2195

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Programming License Agreement, or any equivalent agreement
between us.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

Trademarks
The following terms are trademarks of the IBM Corporation in the United States or
other countries, or both:

1-2-3
Advanced Peer-to-Peer Networking
AnyNet
APPN
AT
CICS
DB2
DB2 Connect
IBM
IBM Global Network
iSeries
Lotus

Lotus Notes
OfficeVision
OfficeVision/400
OS/400
PROFS
SmartSuite
System/36
System/38
VTAM
z/OS
z/VM
zSeries

Microsoft, Windows, Windows NT©, and the Windows logo are trademarks of
Microsoft Corporation in the United States and/or other countries.

Tivoli is a trademark of Tivoli Systems Inc. in the United States and/or other
countries.

Java, JavaBeans, and all Java-based trademarks and logos are trademarks of Sun
Microsystems, Inc. in the United States and/or other countries.

PC Direct™ is a registered trademark of Ziff Communications Company and is
used by IBM Corporation under license.

UNIX® is a registered trademark in the United States and other countries licensed
exclusively through X/Open Company Limited.

C-bus™ is a trademark of Corollary, Inc.

ActionMedia, LANDesk®, MMX™, Pentium®, and ProShare® are trademarks or
registered trademarks of Intel Corporation in the U.S. and other countries.
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Other company, product, and service names may be trademarks or service marks
of others.
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Index

Numerics
1390/1399 code page 71
32-Bit ODBC Administrator 73

A
ActiveX 15
adapters

attachments 25
AFTP (file transfer) 9
AnyNet

functions 14
APARs

WebUpdate 84
API Client Attachments 89
APING (check connection) 8
APPC communications protocol 13
applet 67
Application Data

file types 18
locations 18

APPN
end node 87

APPN network protocol 13
ASCII emulator 12
Assist Functions

CM Mouse 62
hotspots 63
keyboard 62
Keyboard Setup 63
macro 62
macro/script 65
script 62
setup 62

automatically starting sessions 43
autostart

applet 67
macro 66

B
batch file

editing 43
h option 41
i option 41
q option 40
s option 41
using 40
v option 40

bidirectional language support
Arabic

OIA 32
Hebrew

OIA 33
RTL printing 30

C
certificate management, icon 7

changing
configuration files 27
workstation profiles 27

Client/server applications
enabling 87

CM Mouse 8, 62, 76
Collect Screen

Print Collection on Exit 48
Purge Collection 48

color mapping 60
communications protocols

APPC 13
LU 6.2 13

Communications Server for Windows 89
configuration

changing
SNA 27
workstation profiles 28

creating 25
default 26
saving

SNA 26
workstation profiles 27

configuring
CM Mouse 8

Configuring
SNA node 87

connection
checking 8

Connections
ASCII emulator 12
client/server 13
icons 10
iSeries emulator 11
S/3X emulator 12
zSeries emulator 10

Convert Macro 78
copying

data in cells as text data 55
lines containing only operational signs 55
marked data 55

Copying
table data to spreadsheet 54

Copylink 54
CSDs

WebUpdate 84
customizing the menu bar 9
Cut/Copy

Copy signed numeric fields 53
Force Leading +/- 53
Only if a trim rectangle is marked 53

D
Data Transfer

icon 8
power management 47
types of 80

Data Transfer utility 80
Database Access 76
database access tool 8
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DDE/EHLLAPI 54
dependent LU requester (DLUR) 14
dependent LU server 14
desktop 39
DLUR (dependent LU requester) 14
DOS EHLLAPI 9

E
Editing

copylink 54
functions 51
Home3270 attachment restrictions 56
linking to Windows application programs 53
options

Cut/Copy 52
Paste 52

pastelink 54
EHLLAPI 9
emulator sessions

configuring 25
exiting 44
starting 37
stopping 44

Emulator sessions
managing 70
using 45

enabling
DDE/EHLLAPI 54

Enterprise Extender 15
existing batch file 43
Express Logon Feature

macro 68

F
file transfer 9
File Transfer

power management 47
Files

transfer 58
ASCII host data transfer 59

fonts 60
FTP 9

H
high-performance routing (HPR) 14
Hindi 29
Home3270 attachment 56
Hotspots 63
how to

configure Personal Communications 25
HPR (high-performance routing) 14

I
i option 41
IBM software registration, icon 6
icons

IBM software registration 6
information bundler 6
Internet service 6
log viewer 6
migration utility 7

icons (continued)
product update tool 7
SNA node configuration 6
SNA node configuration verification 7
SNA node operations 7
SNA sense data 6
start or configure sessions 5
trace facility 7

information bundler, icon 6
Installation

ChineseStar 21
hardware requirements 17, 18
RichWin 21

Internet service, icon 6
iSeries emulator 11

J
Japanese language

DOS GAIJI 57
iSeries user-defined font 57

Java applet 67

K
Keyboard

functions 62
Keyboard Setup 63

keyboard file 64
modifying layout 64

L
Lam-Alef expansion 31
licensing agreement 96
log viewer, icon 6
LU 6.2 communications protocol 13

M
macro

convert 8
Express Logon Feature 68

Macro
creating 65
Express Logon Feature 67
functions 62
playing 67
recording 67
setup 65

autostart 66
statements 66
using 65

menu bar
customizing 9

Menu bar
setup 61

Menu Bar Customization 76
Messages 91

OIA 91
security 91
system error 91

migration utility, icon 7
mouse

file 69
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mouse (continued)
setup 69

mouse buttons 8
Multiple Sessions

batch program 77

N
network protocols

APPN 13

O
object-oriented API 16
OLE 2.0 15
online help viii

P
Page Setup 49
Paste

options
Paste 52
Tab character processing 52
Wrap 52

Pastelink 54
PC Organizer 78
PCSWS.EXE

options 40
PDT files

using 49
Personal Communications

ChineseStar 21
connections 10
icons 5
library viii
program folder 5
RichWin 21
sessions

Client/server 9
Display 9
Printer 9

ping 8
pop-up keypad 70

(poppad) file 69
setup 69

poppad color 69
Power Management

data transfer 47
file transfer 47
resume 47
sleep 47
wake 47

Print Collection 48
Print screen 47
Print Screen Collection

Print Collection on Exit 48
Purge Collection 48

printer association
TN3270E 46

Printer definition
file 49
table 49

printing
3270 session screen 50
APL Font Support 50

printing (continued)
Host Print Transform 49

Image Print Transform 49
OfficeVision 50
Page Setup 49
PDT files 49
Printer session 49
Scalable Font 50
TN3270E printer association 46
Truetype Font 50
Windows printer driver 48
ZipPrint 9, 50

CMS file 50
Printing

Collect Screen
Print Collection on Exit 48
Purge Collection 48

description 47
multiple print screen 48
Print Collection 48
Print Screen Collection

Print Collection on Exit 48
Purge Collection 48

Product Update Tool 84
product update tool, icon 7

Q
q option 40

R
receiving data from the host 80
related publications ix

S
s option 41
S/3X emulator 12
saving

configuration information 26
Script

creating 66
functions 62
playing 67
recording 67
setup 65
using 65

sending data to the host 80
session

start or configure sessions, icon 5
Session

tool bar 60
menu bar 61
status bar 61

window appearance 60
Session Manager 5, 25, 37

options 37
sessions

automatically starting 43
exiting 44
icons 37
icons for 25
IDs for 41
multiple 40
starting 39
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sessions (continued)
starting specific session ID 41
stopping 44
window 37

Sessions
managing 70
using 45

setting up
the mouse 69
the pop-up keypad 70

SNA
node configuration 25

SNA node
configuration 87
starting 87
stopping 88

SNA node configuration verification, icon 7
SNA node configuration, icon 6
SNA node operations, icon 7
SNA sense data, icon 6
starting

configuration setup 25
with a batch program 40

Starting
SNA node 87

Status bar
setup 61

stopping
macro playing 67
SNA nodes 88

T
Text Assist 81
Thai 29
Tool bar

setup 60, 61
trace facility, icon 7
trademarks 96
Transfer

files 58
ASCII host data transfer 59

Trim
options

Trim Rectangle remains after edit function 53
Trim Rectangle sizing handles 53

Trim print 47
types of

hotspots 63
sessions 9

U
Unicode support 71
User Preference Manager 83
Utilities

32-Bit ODBC Administrator 73
CM Mouse 76
Convert Macro 78
Data Transfer 80
Database Access 76
Menu Bar Customization 76
Multiple Sessions

batch program 77
overview 73
PC Organizer 78

Utilities (continued)
Text Assist 81
User Preference Manager 83
ZipPrint 77

V
v option 40
View menu

Hide Session 70
Jump 70
Show Session 70

W
WebUpdate

APARs 84
CSDs 84

window
setup 60

Windows printer driver 48
workstation profile 26, 40

Z
ZipPrint 9, 77

3270 session screen 50
CMS file 50
OfficeVision 50
PROFS/OV note, calendar, document printing 50
XEDIT workspace 50

zSeries emulator 10
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Readers’ Comments — We’d Like to Hear from You

Personal Communications for Windows, Version 5.7
Quick Beginnings

Publication No. GC31-8679-04

Overall, how satisfied are you with the information in this book?

Very Satisfied Satisfied Neutral Dissatisfied Very
Dissatisfied

Overall satisfaction h h h h h

How satisfied are you that the information in this book is:

Very Satisfied Satisfied Neutral Dissatisfied Very
Dissatisfied

Accurate h h h h h

Complete h h h h h

Easy to find h h h h h

Easy to understand h h h h h

Well organized h h h h h

Applicable to your tasks h h h h h

Please tell us how we can improve this book:

Thank you for your responses. May we contact you? h Yes h No

When you send comments to IBM, you grant IBM a nonexclusive right to use or distribute your comments in any
way it believes appropriate without incurring any obligation to you.

Name Address

Company or Organization

Phone No.
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