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Getting Started

Shows you how to build a map and then save it as a map file for future use.

In this section

Running the Map Builder
Provides information about running the Map Builder.

An example map
Guides you through creating an example map and saving it.
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Running the Map Builder

You can run the Map Builder from any Operating System supporting Java™ including
Microsoft® Windows® or UNIX® systems.

For example, to run the Map Builder on a Microsoft® Windows® system:

Choose, for example: Start>All Programs>IBM ILOG JViews Maps for Defense 8.
6>Map Builder

where IBM ILOG is the default program group suggested by the installer

or

Double-click run.bat in the directory:

<installdir> /jviews-maps86/samples/mapbuilder

This directory is also accessible from the JViews Maps for Defense Product Guide and
is displayed when you follow the path Samples and code
examples>Design Tools>Map Builder and click the directory link.

Note:

To run the Map Builder on a UNIX system, run the shell script run.sh in the directory:

<installdir> /jviews-maps86/samples/mapbuilder/index.html
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An example map

Guides you through creating an example map and saving it.

In this section

Overview
Describes data sources used in this example.

Creating a map
Explains how to create a new map and add different types of map data.

Setting map properties
Explains how to set map properties to display map outlines or relief.

Adding data to a particular state
Explains how to enlarge a map area and add data to it.

Saving the current map
Explains how to save the current map.

Adding data to a particular city
Explains how to zoom in to an area and add data to it.

Saving the final map
Explains how to save the final map.
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Overview

This section uses data for demonstration purposes, see Data used in this
documentation. For a list of suggested free sources for downloading map data see
Map data.

Note:

This section shows you how to create a map and save it as a file. This example map could
be used in homeland security, for example, to deploy national guards in Los Angeles to
counter an urban terrorist threat. The map goes down to street and building level.

The finished map consists of the following data sources:

♦ Shape\World_Countries.shp

Provides the world as a backdrop, although the actual sample is centered on California.

♦ GeoTIFF\World2_24M.tif

Adds an esthetically pleasing map, mainly for use in the Overview pane.

♦ CADRG\A.TOC

Provides important military information such as bases, topographic terrain information
and corridors in the USA.

♦ vmaplv0\noamer

A pure vector type defense map covering North America.

♦ GTOPO30-DEM\W140N40.DEM

Provides altitude information for terrain analysis that can be performed later in the final
application.

♦ GeoTIFF\LA_Houses.tif

Adds details of the houses in relation to the street level views.

♦ Shape\LA_Streets.shp

Provides a street level view of Los Angeles.
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Creating a map

This section assumes that you have downloaded appropriate data to your workstation.
For a list of suggested free sources for downloading map data, see Map data

Note:

To create the map containing the data sources described in An example map:

1. Start the Map Builder as described in Running the Map Builder .

2. Choose File>New Map to clear the Map View of any map data.

3. Choose File>Add Map Data to open the file browser, select the GeoTIFF format, and
then select the drive where you have downloaded your data. For example, select the
data source World2_24M.tif, and then choose Open.

You can copy all the files to your workstation for faster
access.

Note:

4. Click the button to fit the whole world into the view.

The following figure shows the resulting Map View pane.

The data source World2_24M

5. Choose File>Add Map Data to open the file browser, select the ESRI/Shape format,
and then select the drive where you have downloaded and saved your data. For
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example, select the data source ESRI/Shape World_countries.shp, and then choose
Open.

The following figure shows the resulting Map View pane.

The data source World_countries.shp
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Setting map properties

To set map properties:

1. Expand the ESRI/Shape branch and select the World_Countries.shp layer in theMap
Layers pane to display the corresponding map style property sheet below it.

2. Scroll down the properties in the map style property sheet and select the Visible in
Overview property and check that the value is False so that this data source is not
displayed in the Overview pane.

3. Click in the right column of the Line Color property in the map style property sheet,

click the button, set the Line Color value to white using the Color Editor
displayed and click Apply.

The following figure shows the resulting Map View pane.

Setting the map outline color

4. Select the Filled property in the map style property sheet and set the value to False.

The following figure shows the resulting map relief.
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Setting the map relief
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Adding data to a particular state

Zooming in on California

♦ Click the button on the toolbar and draw a rectangle around the California area
to zoom in on it. If necessary, zoom in again to enlarge the map more.

Adding military data
1. Choose File>Add Map Data to open the file browser, select the CADRG format, and

then select the drive where you downloaded and saved your data. For example, select
the data source A.TOC and then choose Open.

2. Click the button on the toolbar and draw a rectangle around the Los Angeles
area to zoom in on it. If necessary, zoom in again until the Los Angeles area fills the
Map View.

The following figure shows the resulting Map View pane.

The data source CADRG A.TOC

Adding vectorial VMAP data
1. Choose File>Add Map Data to open the file browser, select the VMAP format, and

then select the drive where you downloaded and saved your data.

2. For example, select the data source noamer

3. Select Transportation (Roads) in the Features Choice pane, click the button, and
draw a rectangle around the part of the map where you want to add vectorial VMAP
Data (Los Angeles). While you do this the Select Data Sources window remains open.

4. Choose Open.
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The following figure shows the resulting Map View pane.

The data source VMAP noamer

5. In theMap Layers pane, open the VMAP hierarchy and select Road (secondary Route)
to display the corresponding map style property sheet.

6. Select the Line Width property in the map style property sheet and set the Line
Width value to 3.0.

7. Click in the right column of the Line Color property in the map style property sheet,

click the button, and set the Line Color value to black using the Color Editor
displayed.

The following figure shows the resulting Map View pane.

The data source VMAP noamer Road (secondary route)
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Adding altitude information
1. Choose File>Add Map Data to open the file browser, select the GTOPO30-DEM

format, and then select the drive where you downloaded and saved your data. For
example, select the data source W140N40.DEM, and then choose Open.

The following figure shows the resulting Map View pane

The data source GTOPO30-DEM W140N40-DEM

2. Select the GTOPO30-DEM layer in the Map Layers pane and drag and drop it just
below the ESRI/Shape layer.

3. Select the Preferences tab and set the Distances property to International Statute
Mile, the Altitudes property to International Foot, and the Coordinates property to
UTM.

4. Select theMap Layers tab to redisplay the pane and then click the button to
display the whole map in the Map View pane.

The following figure shows the resulting Map View pane.
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The data source GTOPO30-DEM W140N40-DEM

5. Select the VMAP layer in the Map Layers pane, click the button to zoom to the
content of this layer, and then zoom in on Los Angeles.

6. Select the Visible in Overview property in the map style property sheet and set the
value to false to prevent this layer being displayed in the Overview pane.

7. Click the button again to display the whole map in the Map View pane.
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Saving the current map

1. Save the current map “look and feel”. The theme can be saved without the data and
applied to other imported data sources, or together with the map data. For more
information about themes, refer to Map themes and zoom levels.

2. Choose File>Save Map as in the main menu and select or deselect the Save Theme
Only option as required.

The Save Theme Only option saves only a description of the map, without
the data. As a result, saving will be quicker and take less disk space, but

Note:

the theme may be unusable on another machine that does not have the
original data source available.
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Adding data to a particular city

Zooming in on LA

♦ Click the button, and zoom in twice on Los Angeles.

Adding LA house information
1. Choose File>Add Map Data to open the file browser, select the GeoTIFF format, and

then select the drive where you downloaded and saved your data. For example, select
the data source LA_Houses.tif, and then choose Open.

2. Click the button, and zoom in on Los Angeles.

The following figure shows the resulting Map View pane.

Los Angeles and its secondary routes

3. Drag and drop the GeoTIFF layer to the bottom of the Map Layers pane, open the
hierarchy, and click the LA_Houses.tif data source to select it.

4. Click the button to zoom the whole LA_Houses.tif layer into theMap View pane.

5. Click the button, and rotate the mouse wheel backwards to zoom into the part
of LA_Houses.tif that is of interest. Now zoom in or out using the zoom in\out slider
in the Overview pane, until the houses are displayed at the scale you want.

The following figure shows the resulting Map View pane.

I B M ®  I L O G ®  J V I E W S  M A P S  F O R  D E F E N S E  8 . 622



The data source LA_Houses

Adding LA street information
1. Drag and drop the VMAP layer to the bottom of the Map Layers pane.

2. Choose File>Add Map Data to open the file browser, select the ESRI/Shape format,
and then select the drive where you downloaded and saved your data. For example,
select the data source LA_Streets.shp and then choose Open.

3. Drag and drop the ESRI/Shape layer to the bottom of the Map Layers pane and select
LA_Streets.shp to display the corresponding Map Data Style Sheet.

4. Select the Line Color property and set the Line Color value to white using the Color
Editor displayed.

The following figure shows the resulting Map View pane.
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The data source LA_Streets

5. Choose Option>Show Tooltips on the Map to enable the display of tooltips when
you move the mouse pointer over the map.

6. Click the button, and zoom in on the part of the LA_Houses.tif and LA_Streets.
shp data sources that are of interest to you.

The following figure shows the resulting Map View pane.

LA_Streets and LA_Houses
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Saving the final map

♦ Choose File>Save Map As and save the map under the directory and name of your
choice.

You have now completed the map and saved it. You can reopen the map at any time
and make any changes to it that you want.

You can now, for example, begin to add your APP-6a symbols and deploy your forces
for the defense of Los Angeles.

To save your current zoom setting, you can also create areas of interest (seeManaging
areas of interest) which enable you to quickly locate and move between these saved
areas.
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Getting to know the Map Builder

Introduces you to features of the Map Builder that help you develop maps through this
Graphical User Interface (GUI).

In this section

Maps
Provides general definitions of map properties like layers, themes and related concepts.

Coordinate systems supported
Provides a list of coordinate systems supported by Map Builder.

Map data supported
Provides a list of map data supported by Map Builder.

Exporting map data
Describes the map data formats that Map Builder can export to and the Export Map window.

Map Builder features
Provides descriptions of the main features of the Map Builder.

Terrain Analysis
Describes the terrain analysis features provided by JViews Maps for Defense
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Maps

Provides general definitions of map properties like layers, themes and related concepts.

In this section

Overview
Describes how maps are characterized.

Map layers
Defines map layers.

Map themes and zoom levels
Defines map themes and zoom levels.

Saving a map theme with or without map data
Describes how map themes and map source data can be saved separately or together.

Map layer hierarchy
Defines a map layer hierarchy and describes how this can be customized.

Viewing hidden map layers
Describes how to view hidden map layers by configuring and using the See Through
Interactor.

Map Dynamic Styles
Describes the Dynamic Style Setting pane.

Split or filtered map layers
Describes the result of splitting or filtering map background layers with examples.
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Overview

Whether it contains vectorial or raster data, every map exists as a set of data. In addition
to this data set, a map is characterized by a set of properties and a theme. Every map has
a theme, and in JViewsMaps for Defense a theme specifies the layers, zoom levels, and other
information that control how the map is viewed at different zoom levels. A theme is the sum
of the characteristics of a map. See Map themes and zoom levels for more information.
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Map layers

Amap displays one or more data sources, which describe the map components. A data source
provides the map components, such as polygons and lines, and their properties. If you import
more than one data source, each is placed into a separate layer that forms part of the map
background.

Layers are also used to contain other information, such as grids, labels, terrain analysis and
measurements. You can control how much information is displayed at any one time by
selecting which layers to make visible. SeeMap themes and zoom levels for more information.

Most layers allow users to define styling parameters, such as color, border thickness, or
labels for the graphical components. You can adjust the order of layers and the transparency
of its content so that one layer does not obscure the information in another (see Managing
map layers).

A component is the lowest level of object and can be considered as a polyline with properties
such as name and position (used for streets for example), or as an area with properties
such as name and color (used for countries for example). Component properties can be used
for labeling or filtering and are displayed in the tool tips (if activated on the map), and in
the Property pane of the selected layer.

The purpose of layers is to provide a hierarchical organization/decomposition of the map
represented using a given style. There is no limit to the number of layers you can define.
The contribution that each layer makes to the overall theme is known as a layer style.

For example, a map background layer could consist of ground transportation with roads,
motorways, streets, and tunnels defined as sublayers. Or the map background layer could
be based on legal boundaries with countries, states, counties, cities, and blocks defined as
sublayers.

The following figure shows an example of a map showing road, highway, and motorway
layers.
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A map displaying layers

Layers are displayed in a pane in the Map Builder under theMap Layers tab.

For more information, see Managing map layers.
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Map themes and zoom levels

Amap theme is a collection of all layer styles, zoom levels, symbols, and how zooming affects
each map configuration. For example, you can specify a set of visual properties in the Map
Style Property Sheet, such as whether elements are visible or not, the transparency level,
and the color, line thickness, or label for each layer. You can then associate these properties
with a selected zoom level and when a zoom operation crosses the zoom threshold, the next
style set is applied dynamically. In other words, you can display a style set per scale range,
(see Setting dynamic styles). There is no limit to the number of zoom levels that you can
define that trigger a change in the appearance of a map.

For example, in a map of an entire country, the cities could display at a zoom level that
shows the whole country. When zooming in, you can see only street and building map layers,
and when zooming out only the motorways and cities.

Symbols can also be added to a map and contribute to the overall theme, but this must be
done outside of the Map Builder. Symbols are placed in their own layers and can be set to
visible or invisible.

For more information about how to add symbols to a map, see Managing Symbols.
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Saving a map theme with or without map data

You can save the map with data, or save it as a theme only containing references to the raw
map data.

Map Theme Only
A theme has basically to do with the look and feel of the map and provides you with full
control over howmap data is displayed. A map theme allows you to decide what is displayed,
when, and how.

If a map is saved as theme only, the application must have access to the map data sources.
The following prepared map data is saved:

♦ Uniform Resource Locators (URLs) or file names, pointers to map data sets (server, local
directories, databases, …), and any specific parameter relevant to each data source (for
example, the features selected or the area of selection within the data source).

♦ The number, name and hierarchy of layers.

♦ The look and feel of each layer (color, transparency, thickness for vector, …).

♦ The resolution collection to which a given map theme will apply (for example, see roads
in white, thickness 3 at “street level”, but after a zoom out operation see the same roads
in black, thickness 1 at “city level”, then zoom out again to make them disappear).

♦ The zoom level setting, if this has been defined by an Area of Interest, (see Managing
areas of interest).

A use case for this implementation could be as an application used to monitor an attack on
a city. The map data is stored in large servers and a command center. The application
developed in the command center using JViewsMaps reads the map data from these servers.

For more information about saving a map theme, see Saving a map.

Map Theme and Map Data
When you save the map theme and the map data, the contents of the map file are the same
as when you save a map theme only, but instead of storing map data as a set of URLs or
pointers, the data is copied locally. This provides a faster loading time, especially for raster
data, and allows a map to be displayed even if the original "source data" is not accessible
anymore.

However, some operations on the map such as a change in coordinate system might need
this source data to ensure proper reprojection without loss of precision. If source data is
not available, embedded map elements are reprojected without reading them back from the
original data source.

A use case for this implementation could be if the application developed using JViews Maps
for Defense is used onboard a battle tank with poor or no connectivity to servers and the
command center. The mission planner who prepares the map for the defense of the city
saves the map data and burns a DVD, which he or she then hands over to the tank
commander.

For more information about saving a map theme and map data, see Saving a map.
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Map layer hierarchy

As you import different data source types a layer hierarchy is built up consisting of layers
and sublayers. Data sources of the same type are grouped as sublayers of a parent layer.

In the following figure, the ESRI/Shape (see Shapefile format) and GeoTIFF (see GeoTIFF
format) files are grouped as sublayers under their parent layers. The last layer in the
hierarchy becomes the front layer in the Map View pane. For example, the Labels layer is
displayed in front of the GeoTIFF layer in the Map View pane.

Standard layer hierarchy

You can rename layers and sublayers to make the name more meaningful, (see Renaming
a map layer). For example, San Francisco Streets would be more meaningful than
SF_Streets.shp.

You can also set up your own layer hierarchy by creating new layers and sublayers, (see
Creating a map layer hierarchy). You can then fill them with one or more of the data sources
you have already imported.

The following figure shows an example of a new parent layer called Top Layer into which
the SF_Streets.shp file has been placed.

Customized layer hierarchy

Map layers can also be hidden from the layer tree, (see Hiding and showing a map layer in
the tree). For example, in a case where end users can add more map layers to an application
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that has a fixed background map, the application developer may want to ensure that the
end user cannot alter or remove this background map. The solution to this problem is to
hide those layers from the tree so that they cannot be modified.

You also have the possibility to move layers to different positions in the hierarchy and to
split layers or create filters on layers that contain metadata (see Splitting or filtering a map
layer). You can send layers to the front (top) or back (bottom) of the hierarchy, or change
the position of a layer within the hierarchy.

The filtering mechanism allows you to create a layer that displays only the objects that match
a filter. You can also split a layer by grouping together the objects that match the same
value for selected metadata. In both cases, the split/filtered layers are added to the map
layer hierarchy.

The following figure shows an example of an ESRI/Shape file displayed according to a
CONTINENT filter.

Split and filtered map layers

A shortcut menu is available in the Map Layers pane that allows you to carry out most of
the operations available in the Map Layers pane. For more information, seeManaging map
layers and Split or filtered map layers.
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Viewing hidden map layers

As shown inMap layer hierarchy, a map is made up using layers of map data. The visibility
of layer data is controlled by the map layer order. It is also possible to hide the contents of
a layer entirely (seeHiding and showing a map layer in the tree). The See Through Interactor
is used to view the contents of a layer that is not visible in a map.

The following figure shows a map with hidden layers.

A map with hidden layers

To view hidden layer information, you first have to configure the See Through Interactor.

To configure the See Through Interactor:

1. Click the + sign in the bottom right of the See Through Interactor button . The
See Through Tool Configuration window opens.
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The See Through Tool Configuration window

The layers selected in the See Through Tool Configuration window follow
the map layer hierarchy, that is, higher layers are visible before lower ones.

Note:

2. Select the layers to be displayed by the See Through Interactor.

3. Set the visible area using the See Through Size Area slider.

4. Click OK. The See Through Tool Configuration window closes and the See Through
Interactor is activated automatically.

5. Click the area in the map where you wish to view a sublayer. The sublayer is revealed,
as shown in the following figure.
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Sublayers in a Map Displayed Using the See Through Interactor

6. Once the see through tool has been configured, click the See Through Interactor
button to active the See Through Interactor. You do not need to reconfigure the See
Through Interactor each time you use it.
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Map Dynamic Styles

The Dynamic Style Setting pane enables you to define a set of dynamic styles for selected
zoom levels, for each layer that contributes to the overall theme. The default style displayed
in the Dynamic Style Setting pane when you first start the Map Builder has only the basic
style set applied and will not change as you zoom in or out.

The following figure shows the Dynamic Style Setting pane. For more information, see
Setting dynamic styles.

The Dynamic Style Setting pane

If you have a multiresolution map, for example, a CADRG, the different resolutions are
displayed in theMap Layers pane as sublayers. When a sublayer is selected, a bar is displayed
in the Dynamic Style Setting pane, and the name of the style is displayed for each section
of the bar. You can also use this bar to set the map scale with a single click. This enables
you to preview the map appearance at the selected scale.

Setting the map scale with the Dynamic Style Setting bar
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Split or filtered map layers

You can split or filter a map background layer according to the component properties
contained within it. Splitting results in two or more filtered layers, whereas filtering produces
only a single filtered layer. For example, you could split a layer to create two filtered layers
that group together countries with a population above and below a given size, or create a
single filtered layer that groups together all countries by name or by continent.

The list of properties displayed depends entirely on the meta data contained in the map
layer you have selected and may be different for different layers. You can also split or filter
a map layer more than once or you can split or filter an already filtered map layer again. In
the case of splitting, an additional option allows you to create a second filtered layer for
objects that do not match the filter.

Each time you split a layer into one or more filtered layers, they are automatically added to
the Map Layers pane and marked (Filtered).

An example of map layer splitting
When you open the Map Builder, the map layer ESRI/Shape (data/World_Countries.shp)
is displayed by default. You can split this map layer, for example, to show the countries in
the world that have a population equal to or more than, or less than 10,000,000 people. To
do this, you must select the option that creates another filtered layer that groups together
the world countries that do not have a population equal to the value you set (see Splitting
or filtering a map layer). By making the split layers active or inactive, you can display your
map in a way that highlights the specific objects you want to filter.

The following figure, centered on Africa, shows countries with a population equal to or more
than 10,000,000.

Countries with a population greater than 10,000,000

The next figure shows the result of switching the active and inactive states of the split layers
to show the countries that have a population of less than 10,000,000.
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Countries with a population less than 10,000,000

An example of map layer filtering
In the following example, centered on Africa, the Map Layer has been filtered to group
together the countries of the world.

An example of map layer filtering

For more information, see Splitting or filtering a map layer.
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Coordinate systems supported

The Map Builder supports the following coordinate systems:

♦ Geographical

♦ Albers Equal Area

♦ Azimuthal Equidistant

♦ Cassini

♦ Cylindrical Equal Area

♦ Eckert IV and Eckert VI

♦ Equidistant Cylindrical Projection

♦ French Lambert

♦ Gnomonic

♦ Lambert Azimuthal Equal Area, Lambert Conformal Conic, and Lambert Equal Area Conic

♦ Mercator, Oblique Mercator, and Transverse Mercator

♦ Miller Cylindrical

♦ Mollweide

♦ Orthographic

♦ Polyconic

♦ Robinson

♦ Sinusoidal

♦ Stereographic

♦ Universal Polar Stereographic and Universal Transverse Mercator

♦ Wagner IV

For information about projections, see Coordinate systems and Setting coordinate systems.
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Map data supported

The Map Builder supports the following types of map data:

♦ ARC Standard Raster Product (ASRP) (.gen )

♦ UTM/USP Standard Raster Product (USRP) (.gen)

♦ Compressed ARC Digitized Raster Graphic (CADRG) (.TOC)

♦ TIFF file-based interchange format for georeferenced raster imagery (GeoTIFF) (.tif)

♦ Non-georeferenced raster images (.gif, .tif, .jpg, .png)

♦ Environmental Systems Research Institute (ESRI) Shape files (.shp)

♦ MapInfo Interchange Format (.mif)

♦ Topologically Integrated Geographic Encoding and Referencing system (TIGER/Line® )
files (.rt*)

♦ Drawing Interchange Format ( see DXF format) files (.dxf)

♦ Google™ Earth Keyhole Markup Language (KML) and KML Zipped (KMZ) formats ( see
KML/ KMZ) (.kml, .kmz)

♦ Digital Aeronautical Flight Information File format (see DAFIF file)

♦ National Imagery and Mapping Agency (NIMA) VPF/VMAP 0, 1 and 2

♦ Digital Terrain Elevation Data (DTED® ) 0, 1 and 2

♦ Global Topographic Data (GTOPO30) DEM

♦ International Hydrographic Organization (IHO) S57 formatted file sets (see S57 standard)

♦ Web Map Server (see WMS standard) images

♦ Oracle® Spatial

♦ Scalable Vector Graphics (SVG) files

Note that you can code your own map reader using the API provided. For more information,
see Using readers and Readers and writers.

For information about data sources, see Data sources and Importing a simple data source.
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Exporting map data

Exporting map data can be useful if you want to export a map or part of a map using standard
formats that can be used by other software. For example, some software may not be able
to read CADRG (see CADRG format) or VMAP (see VMAP format) formats, but may be able
to use the basic and widely used Shapefile (see Shapefile format and GeoTIFF formats).
Also, you may want to use Google Earth™ to visualize or share the map on top of the wide
array of maps provided by this tool.

Three vector exporters (Shape, Oracle® , and KML) and two raster exporters (GeoTIFF and
KML) are provided, although you can develop other exporters to extend this and export in
your own specific format.

Exporting to an Oracle database not only enables other software to use the map data, but
also allows you to use the Oracle layer import option in your JViews Maps application. You
can then use the Oracle database features to share data between different users, instead of
having to install the same files on different machines.

Exporting files is carried out using the Export map window as shown in the following figure.
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Export Map window

The Limits pane enables you to export a selected part of a map. You can select the area
you want to export in the Map View using the button provided. All graphical components
that intersect with this area will be entirely exported.

The Vector Exporter allows you to export Shape, Oracle, and KML files and the Raster
Exporter allows you to export GeoTIFF and KML files. The four exporters export files as
follows:

♦ The Export to Shape exporter exports one Shape file for each vector layer selected in the
Map Layers pane.

♦ The Export to GeoTIFF exporter exports one GeoTIFF image for each image contained
in a raster layer selected in the Map Layers pane.

♦ The Export to Oracle exporter exports one Oracle layer to the database for each layer
selected in the Map Layers pane.
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♦ The Export to KML exporter exports either a set of files including the (XML-based) KML
description and any raster images (transformed into PNG format) or a KMZ file that
compresses the set into a single file.

You can select more than one layer in the hierarchy tree. The Settings button enables you
to set the target folder to which the map data will be exported.

For more information about exporting map data, see Exporting data sources.
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Map Builder features

Provides descriptions of the main features of the Map Builder.

In this section

Overview pane
Describes the Map Overview pane of the Map Builder.

Symbols
Describes different ways symbols can be added to maps.

Using JViews Diagrammer Designer to design symbols
Explains how to use JViews Diagrammer to design symbols to represent nodes and links.

APP-6a defense symbols
Describes the purpose, use and features of symbols.

Uncluttered symbols
Describes the uncluttering symbols feature.

Properties
Describes layer properties that can be customized using the Map Style Property Sheet.

Sublayer properties
Describes inheritance between layers and sublayers of properties defined in the Map Style
Property Sheet.

Areas of Interest
Describes the purpose of the Areas of Interest pane.
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Map scale pane
Describes the scale bar and scale control panes in Map Builder.

Preferences
Describes the preferences tab of the Map Builder.

Coordinate systems
Describes the ways coordinate systems can be set in Map Builder.

Labels
Describes the use of of labels on map layers and sublayers.

Annotations
Describes the purpose and use of annotations on maps.

Grid Settings
Describes the purpose and use of displaying grids on maps.

Map magnification
Describes the purpose and use of map magnification.

Map rotation
Describes the map rotation feature.

Compass
Describes the compass feature of Map Builder.

Advanced Settings
Describes features that can be set in the Advanced Settings pane.

Legend
Describes information that is found in the legend pane.

Additional views
Describes additional tabs that can be displayed or hidden in the views pane.

Data sources
Describes the the information displayed in the Data Sources pane and what you can change
in it.

Printing Features
Describes the features offered in the Printing tab.

Multithread monitor
Describes the information displayed in the Multithread monitor pane.

Orthodromy Measures
Describes the Measures layer you obtain when using the orthodromy measure feature.
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Tiled Images for a Thin Client
Describes the option of generating tiled images of a map for a thin client.

Zoom Configuration
Describes the features available in the Zoom Configuration pane.
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Overview pane

The Overview pane displays a representation of the current map that enables you to navigate
to a part of it that is of particular interest, and display it in the Map Builder main window.
This is done by clicking on and dragging the rectangle to the position of interest in the
Overview pane, and then releasing the mouse button.

You can choose which map layer you want to display in the Overview pane by setting the
Visible in Overview property for each layer, see Using the map style property sheet. This
prevents cluttering of the pane.

A zoom in/zoom out slider is provided to the right of the Overview pane. Moving the slider
pointer will zoom in or out constantly until the user releases it. Zooming speed increases
with the distance of the slider from the center point.

The following figure shows an example of the Overview pane.

Map Overview pane
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Symbols

Symbols in the Map Builder
The Map Builder allows you to select, configure symbols, and add them to a map. When you
add symbols to a map, they are displayed in the Map View and also in any 3D Views that
may exist. Such symbols will be saved along with the map. You should not use JViews
Diagrammer Designer with this type of map. See also Symbol groups and Symbols in a 3D
View.

Symbols with JViews Diagrammer Designer
You can use the Map Builder to create a map and then load the map into the Designer for
JViews Diagrammer and add nodes or links to the model.

For more information see Using JViews Diagrammer Designer to design symbols.

Symbols from palettes in JViews Maps for Defense
You can select from symbols palettes in JViewsMaps for Defense and drag-and-drop symbols
onto your map. Symbols can also be edited.

For more information see Adding a new symbol from a palette in Using more Map Builder
features

APP-6a defense symbols in JViews Maps for Defense
You can select APP-6a symbols from the NATO Symbol manager in JViews Maps for Defense.
APP-6a symbols can also be edited.

For more information see APP-6a defense symbols in Getting to know the Map Builder and
Adding a new APP-6a symbol in Using more Map Builder features.

Symbol groups
You can also collect symbols together as a group and define whether the group is visible or
not. The symbol groups are displayed in a pane in the Map Builder under the Symbols tab.

The following figure shows an example of symbol groups displayed in the Symbols pane.
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Symbols pane

The Symbols pane has its own toolbar, which allows you to manage symbols or symbol groups
by:

♦ Creating and deleting them

♦ Duplicating a symbol

♦ Editing them

♦ Making them visible or invisible

These commands are also available from a shortcut menu when you right-click a symbol or
group. You can define a group in any way you want.

A group could be based on, for example, tanks or missiles or other military hardware, or
could be based on the formation of a battalion, with an individual soldier represented by
GI1 in group1 in section 2 of battalion 4. Note that groups are recursive; you can define an
infinite number of hierarchical levels.

The following figure shows an example of hostile sea surface and friendly airborne military
hardware.
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Groups of hostile forces, tanks, and missiles in a Map

Symbols in a 3D View
Although symbols are 2-dimensional objects, they can be used in 3D Views. When used in
this way, symbols have a particular representation on the 3D View to make them clearer
and more visible, otherwise they could be hidden behind a terrain elevation, see 3D View
and Creating a 3D View for more information on 3D Views. This 3D View representation of
a symbol consists of:

♦ An icon that identifies the object, and which is situated directly above and connected to
a point.

♦ A point that represents the real position of the object in the 3D View.

♦ A ground position indicated by a dotted line from the point to the actual position on the
ground (for symbols representing objects at altitude). Note that if the object is in the air,
but no altitude is specified, the point is on the ground and there is no dotted line to show
the symbol’s ground position.

The following figure shows an example of symbols at altitude in a 3D View.
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Symbols at altitude in a 3D View

If you use symbols in a 3D View, the altitude of the symbol is determined by the Altitude
Above Sea Level property. For more information about 3D Views and their properties, see
Creating a 3D View.

For more information about symbols, see Managing Symbols.
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Using JViews Diagrammer Designer to design symbols

To create symbols in JViews Diagrammer for use in Map Builder:

1. Edit the map with the Map Builder and then save it.

2. Open Designer, use the map as the backdrop and add nodes or links to the model.

3. Use the Symbol Editor to choose or design the symbols that you want to represent the
nodes or links and then save the whole as a diagrammer project.

4. Load the diagrammer project in your application.
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APP-6a defense symbols

You can choose APP-6a defense symbols from a palette and add them to a map either
programmatically or using mouse clicks. When you add symbols to a map, they are displayed
in the Map View and also in any 3D Views, if they exist. Note however, that symbols are not
saved when you save a map.

This Map Builder feature is mainly for demonstration purposes and for testing symbols by
setting their properties, for example, their ID, position on the map, combat effectiveness,
altitude and depth. This functionality is also available using the API, and symbol source code
created in the Map Builder provides programmers with help in understanding how to use
the available beans to create, remove, rename symbols and so on.

In a 2D view, Symbols are usually icons surrounded by various satellite text or indicators.
In a 3D view, they are seen as two dimensional objects that are always facing the camera.

Symbols are created as a layer in the Map Layers pane and once added to the map, they
can be selected and dragged to a new position on the map, deleted, edited and so on. In
addition, you can define the symbol coordinates and decide whether the symbol must be
visible or not.

For more information about creating symbols, placing them on maps, and saving them, see
Using the Symbol Editor and Using the Designer.
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Uncluttered symbols

This feature enables you to separate overlapping symbols that are positioned very close
together and which give a cluttered appearance to the view. Separating symbols in this way
is done by dragging a rectangle over the set of symbols of interest. This displaces all the
symbols related to the current SDM model displayed (and contained within the rectangle)
and removes the clutter from the view.

When you displace the symbols, their true position can be seen more clearly; the anchor
point for each symbol is shown in red with a line connecting it to the symbol. Note that if a
symbol does not need to be moved, only the point is displayed.

The following figure shows an example of cluttered and uncluttered symbols.

Cluttered and uncluttered symbols

For more information, see Removing symbol clutter.
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Properties

Each map layer has a set of properties associated with it. The properties define the
characteristics of the selected layer. Using the Map Style Property Sheet you can customize
the kind of map data selected (vector, raster, or elevation), define whether the map outline
is shown or not, what colors are used to fill the terrestrial and marine areas, define the
transparency level, and so on. The Map Style Property Sheet gives access to a number of
editors that enable you to carry out these operations.

For example, for the Labeling property, a choice of label types is displayed that depends
on the content of the data source. This enables you to display labels, for example, as the
name of the country, or at a more detailed level such as the name of a street. You can change
any property value at any time. The properties defined for each map layer constitute a layer
style and each layer style contributes to the overall map theme.

Note that some properties are not displayed in the Map Style Property Sheet by default. To
display all the properties you must select Options>Show Advanced Properties.

The following figure shows an example of a Map Style Property Sheet.

Map Style Property Sheet example
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Sublayer properties

When a sublayer is selected in the Map Layers pane, the Map Style Property Sheet displays
the properties for that layer prefixed with either an Up Arrow or a Right Arrow. The Up
Arrow indicates that the sublayer property value is inherited from the parent layer and must
be changed in the parent layer style sheet. The Right Arrow indicates that the property
has its own, independent value that can be set at any time.

Inheritance is applied as follows:

♦ Sublayers can inherit almost all properties that are present in the parent layer. There
are some exceptions such as the Color Model property.

♦ All sublayer properties are added to the parent layer Map Style Property Sheet, if not
already present.

The following figure shows an example of a sublayer Map Style Property Sheet.

Sublayer properties

For more information, see Using the map style property sheet.
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Areas of Interest

You can select areas of a map that are of particular interest to you and save them for future
reference. Areas of Interest are similar to using the bookmark function of a browser. This
enables you to quickly switch between any parts of a map that you have saved in this way.
It could be based on traffic monitoring such that you can easily navigate between known
congested areas to study their status (for example, red=congested, green=uncongested).
It could be based on areas where particular military hardware is stored, ammunition dumps,
battalions of soldiers, and so on.

The areas of interest are managed in a pane in the Map Builder under the Areas of Interest
tab as shown in the following figure.

Areas of Interest pane

For more information, see Managing areas of interest.
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Map scale pane

Scale bar
This pane at the bottom of the Map Builder main window displays a scale bar that enables
you to estimate distances in the displayed map. You can change the units in which the
distances are displayed using the Preferences pane.

The following figure shows an example of the scale bar.

Scale bar pane

For more information, see Setting preferences.

Scale control
This pane at the bottom of the Map Builder main window displays the scale of the map
currently displayed. The scale changes automatically when you zoom in or out. This pane
also enables you to set the scale of the map interactively.

The following figure shows an example of the scale control pane.

Scale control pane

For more information, see Setting the map scale.
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Preferences

Preferences enable you to set distances, altitudes, and coordinates in the units of your choice.
The preferences are displayed in a pane in the Map Builder under the Preferences tab. You
can change preference settings at anytime and the changes take place immediately. The
preference settings can affect, for example, the units of the altitude charts used in terrain
analysis, the orthodromy measures drawn on the map, the scale bar, and mouse locator
units.

You can select the units from a list in the preferences tab, as shown in the following figure.

Preferences pane

TheDate Line Wrapping option can be used to cut polygons that circumnavigate the world.
Note that this option is only applied when the next reprojection occurs, for example, when
you change the center of the projection.

For more information, see Setting preferences.
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Coordinate systems

You can set your map coordinate system using one of two ways:

♦ using the Coordinate system tab tab

♦ using the Predefined Coordinate System pane pane

Coordinate system tab
The coordinate system enables you to set the type of projection that you want to apply to
your map and the projection properties. The current projection is displayed in a pane in the
Map Builder under the Coordinate System tab. You can change the projection at anytime.

For example, you may want to display your maps using the UTM Zone6 coordinate system,
which is a transverse mercator projection centered at 147˚W, with a false easting, and which
uses the GRS80 ellipsoid and North American 1983 (CONUS) datum. These parameters are
available by selecting the Advanced settings in the Coordinate System pane.

A coordinate system is presented as a projection and parameters, plus its datum and ellipsoid
as shown in the following figure.
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Coordinate System pane

Predefined Coordinate System pane
The Predefined Coordinate Systems pane (choose Options>Predefined Coordinate Systems
to display this pane) lists all the known systems and settings that are normally used. The
list is built on an historical and country basis. The Predefined Coordinate Systems pane also
provides a preview of the selected coordinate system. Note that when you set the coordinate
system from this pane, it is automatically updated in the Coordinate System pane.

The following figure shows an example of a Predefined Coordinate System pane.
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Predefined Coordinate System pane

For more information, see Setting coordinate systems.
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Labels

Labels on Layers
You can choose to display labels on your map to help with identification of the various parts.
Typically the labels could be the name of the country or continent, the abbreviation usually
used for a given country, the name of a road or installation, and so on. A list of label types
is proposed (if available) when you select the Labeling property of a layer in the Map Style
Property Sheet.

The label types for a given layer are contained in the map data and are reflected in the list.
When you add labels to a layer for the first time, a Labels layer is created in the Map Layers
pane.

The following figure shows an example of a map with NAME labels for countries.

Labels

For more information, see Displaying labels.

Labels on Sublayers
Labels sublayers give you the possibility to label each vector layer differently. For example,
the labels can be:
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♦ Centered for areas and countries

♦ Along polylines for roads

In addition, it is important to distinguish the visible differences between road, motorway,
and state or county labels to make the map more readable. You can do this by setting the
font size, fill color, whether the outline is drawn, and if so what the outline color will be.
SeeUsing the map style property sheet and Setting sublayer properties for more information
on how to use the Property Sheet.

Each time you set the Labeling property for a displayed data source containing label
information, a Labels for: sublayer is created in the Map Layers pane under the Labels layer.
You can then specify the style of labeling for each Labels sublayer using the corresponding
Property Sheet.

The order of the Labels sublayers in the hierarchy defines the priority of the labeling. When
the labeling is performed, the labeler places as many labels as possible on the first layer in
the hierarchy, and then considers the placement of labels on the next Labels sublayer, and
so on.

You can then specify the priority of the labeling by reordering the Labels sublayers. This
enables you to distinguish between the labeling layers more easily and prevent the view
becoming too complex. Note that the layer with the highest priority is situated at the bottom
of the stack.

The following figure shows an example of customized Labels sublayers.
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Customized Labels sublayers

For more information, see Displaying labels.
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Annotations

An annotation is a drawing made on the top of a map to describe or provide additional
information about a specific zone of a map. Annotations are labeled and are projected with
respect to the coordinate system of the map. Labels can be created to provide text information
and are displayed using the JViewsMaps labeling mechanism, (see Editing annotation labels).
You can also add a description to an annotation that can be multiline, formatted using HTML
tags, and displayed as a tool tip when the mouse is held over the annotation.

You can use map annotations to add, for example, specific points, borders, sections, divisions,
limits, or areas of interest to your map, (see Creating annotations). There are several types
of annotation that you can add:

♦ Points

♦ Polylines

♦ Polygons

♦ Links

Each time you create a point, polyline, polygon or link, it is added to the annotations layer
in the Map Layers pane.

You can customize the annotations in a number of ways and can also carry out management
operations on them. For example, you can change the line width, change the fill color, modify
the label, and make the annotation visible or invisible. In the case of polylines and polygons,
you can add or remove a point to or from the annotation and drag a point to another position
to change the shape.

The following figure shows an example of annotations
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Adding Annotations to a Map

For more information about annotations, how to manage them, and how to set their
properties, see Managing annotations.
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Grid Settings

Grid settings enable you to choose between having no grid displayed on the map or having
a Military Grid Reference System (MGRS) or a latitude/longitude grid displayed. The grid
settings are displayed in a pane in the Map Builder under the Grid Settings tab. You can
select the grid type from a list.

The following figure shows a Grid Settings pane.

Grid Settings pane

When the Use Delayed Drawing option is selected, there is no full drawing of the grid
when themap changes or moves, for example, when you use the zoom control in the Overview
pane or pan the map. Full drawing of the grid only occurs when there is no movement or
change to the map. This avoids unnecessary grid drawing, which results in improved
performance and response time.

When you add a grid to a layer a Grid layer is also created, which enables you to set the
corresponding properties (colors, fonts, and so on). See Using the map style property sheet
for more information.

The following figure shows an example of a Latitude\Longitude grid.
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Grid display

For more information, see Displaying a grid.
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Map magnification

Map magnification enables you to magnify a selected part of the map of particular interest
to you. A circular area around the position of the mouse is magnified. This area moves with
the mouse as you move it around the map and is displayed until you release the mouse
button.

The following figure shows an example of map magnification.

Map magnification

For more information, see Magnifying part of a map.
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Map rotation

Map rotation enables you to rotate a map to any angle in any direction. A compass is displayed
to help you set the angle through which you want to rotate the map.

The following figure shows an example of map rotation.

Map rotation

For more information, see Rotating a map.
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Compass

A Compass tab in the left of the Map Builder enables you to show a compass. This is useful
when your map is displayed using a coordinate system that makes it difficult to recognize
the direction.

If you change the projection of your map to, for example, Albers Equal Area and then zoom
in a number of times, you may lose your sense of direction. However, if you click on the
Compass tab you will see that it always indicates north as seen from the center of the view.

The following figure shows the Compass tab with the compass indicating north.

Compass tab

For more information, see Using the Compass.
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Advanced Settings

The Advanced Settings pane (if this tab is not visible see Additional views) provides the
following options:

♦ Limit Overview Repaints

Limits the Overview pane to not more than two refreshes per second to reduce CPU
usage. When you are zooming or manipulating the main view, it is not always necessary
for the Overview pane to be refreshed as often of the main view. This option is set by
default.

♦ Default Tile Release

Determines the way image tiles are kept in memory or dumped on the hard disk cache
area (tiles are parts of each image). This determines what happens when you pan or zoom
the map. To improve performance, already-computed images are stored in the cache
ready for when you pan or zoom back. This value represents the number of tiles kept in
memory, not the size in KB or MB.

The following figure shows how the caching mechanism works.

Caching Mechanism

♦ Show Tile Debugging View

Displays a view of the existing tiles for debugging purposes.
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♦ Activate Garbage Collection

Activates a timer that periodically cleans as much unused memory as possible.

♦ Memory Usage and Refresh

Displays the memory used by the application and the refresh rate (in seconds) for the
redisplay of images.

The following figure shows an example of the Advanced Settings pane.

Advanced Settings pane

For more information, see Using Advanced Settings.
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Legend

The Legend pane (if this tab is not visible see Additional views) provides a map with
explanatory notes that describe what objects in the map represent, for example, highways,
primary and secondary roads, and so on. This is the typical sort of legend that can be found
on most paper maps. Entries in the Legend pane are added automatically when you add a
new layer. If the data source is complex, the entries in the Legend pane are displayed
according to your choice of features when you import the file. For example, if you import a
data source and choose Transportation (Roads) as a feature, the Legend pane will show an
entry for secondary routes, causeways, and trails. You can organize your map legend
differently using the advanced properties of the layers, such as Legend Category and Legend
Group.

The following figure shows an example of the Legend pane.

.

Legend pane
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Additional views

There are several views available to you that are not displayed by default. You can access
these views by choosing Options>Show Additional Views in the Map Builder main window.
This opens the Unused Views pane, which displays the following additional view tabs:

♦ Data Sources

♦ Printing

♦ Advanced Settings

♦ Zoom Configuration

You can drag and drop any combination of these views into the pane on the left of the Map
View. The configuration you choose is saved and redisplayed the next time you start the
Map Builder. This feature enables you to set up the views pane in a way that makes the tabs
you use the most readily available. You can hide those you do not use much by dragging and
dropping them back into the Unused Views pane.

The following figure shows an example of the complete set of tabs in the views pane.

Additional views
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Data sources

Data sources can be of several types. Some data sources provide only a simple map backdrop,
while others can provide details down to street level, describe water facilities, transport
facilities, and so on. Normally, one data source is equivalent to one map data file or one
database query. However, when reading multiresolution maps such as CADRG, there is one
data source per resolution.

Note that CADRG data is available on the maps data DVD supplied with the installers for
JViews Maps

The Data Sources pane (if this tab is not visible see Additional views) provides a list of all
the data sources currently imported into theMap Builder and their corresponding properties.
Typically the properties define the coordinate system applied to the data source and the
name of the file in which the data is held. The complete set of properties in the list depends
on the type of data source selected.

You can select a data source in the list, change its properties at any time, or remove it from
the list.

The following figure shows an example of the Data Sources pane.

Data Sources pane

For information about how to use the Data Sources pane, see Using the Data Sources pane
and for information about how to import a data source, see Importing a simple data source.
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Printing Features

The Printing tab (if this tab is not visible see Additional views) provides you with standard
print facilities for printing a copy of the map displayed. You can also select and print a part
of the map that is of particular interest to you.

The following figure shows an example of the Printing pane.

Printing pane

For more information, see Printing a map.
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Multithread monitor

This small pane at the bottom right of the Map Builder main window displays the status of
already initiated actions. For example, you can start to import several data sources
simultaneously. The Multithread monitor pane shows the number of tasks initiated and the
progress of each task in turn. When one or more tasks are in progress, a red square is
displayed in the top left corner of the Map view.

You can use the Multithread monitor to display details of which threads are running and
what their purpose is. When finished, the Multithread Monitor pane should show 100%
(0 tasks).

The following figure shows an example of a Multithread Monitor pane.

Multithread monitor pane

For more information, see Using the Multithread Monitor.
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Orthodromy Measures

An orthodromy measure is represented by a line on a map. This is useful for defining the
shortest distance between any two points selected on the map. The total distance between
the two points is computed and displayed next to the line. Depending on the length of the
line and the zoom scale, the line may not be straight due to the curvature of the Earth. A
Measures layer is added to the Map Layers pane.

The following figure shows an example of a Measures layer with a curved orthodromy
measure displayed.

Orthodromy measure

For more information about Orthodromy measures and how to set their properties, see
Creating an orthodromy measure.
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Tiled Images for a Thin Client

If you are operating using a thin client, you can generate tiled images of a map at different
scales (zoom levels) and then save them in the cache of a thin-client server application.
These tiled images can be used by the servlet as pre-rendered tile requests to speed up the
response time of the server.

However, this is not mandatory since the server also has a cache. Using this function you
can fill the cache with data at startup. The cache is initially empty, but is gradually filled
with the most requested Map Views, regardless of whether it was pre-filled or not.

Two values need to be provided: Tile Size (the tile size in pixels) and Scales (a list of scales
for which you want to generate the tiled images). You can do this in the Thin Client Settings
pane.

The following figure shows an example of a Thin Client Settings pane.
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Set Thin Client Parameters pane

A graphical tool to interactively generate tiles is provided as a code sample in: <installdir>
/jviews-maps86/samples/tilegeneration/src/TileGenerator.java
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Zoom Configuration

The Zoom Configuration tab (if this tab is not visible see Additional views) provides facilities
to customize the delay and zoom factor for the continuous zoom mechanism. Continuous
zoom permits a user to zoom into or out from amap by pressing and holding a mouse button.

The delay factor is the time interval between zoom operations, the zoom factor is the amount
that is zoomed for each zoom operation.

The following figure shows the Zoom Configuration default settings.

Default Zoom Configuration settings.

To set the continuous zoom tool to zoom as rapidly as possible, set the Continuous Zoom
Factor to Max and the Delay to Min.

The following figure shows the Continuous Zoom Factor set to Max and the Delay set to Min
used to obtain the fastest zoom.

Fastest Zoom Configuration settings
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Terrain Analysis

Describes the terrain analysis features provided by JViews Maps for Defense

In this section

Overview
Provides overview of terrain analysis.

Lines of Sight
Describes the purpose and use of the Line of Sight feature.

Terrain cuts
Describes the purpose and use of the terrain cut feature.

3D View
Describes the purpose and use of the 3D View feature.

Fly Through
Describes the purpose and use of the Fly Through feature.

Gradient computations
Describes the purpose and use of the gradient computation feature.

Valley computations
Describes the purpose and use of the valley computation feature.

Areas of Sight
Describes the purpose and use of the Area of Sight feature.
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Overview

Terrain analysis provides a number of features that enable you to get a better understanding
of the terrain on which you want to devise your system of attack or defense. You can use
these functions to display color-coded elevation data of what is visible and what is not visible
from a given point, to display areas of sight covering 360 degrees about a selected point,
and to compute gradient and valley information for selected areas.

In addition, you can create cuts through a terrain that display color-coded elevation data
along a polyline, create 3D views and change their display angle and tilt, and simulate the
trajectory of ground based or airborne objects.
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Lines of Sight

The Line of Sight feature enables you to draw a particular Line of Sight in a map. The line
drawn is color-coded according to the elevation of the terrain. The color coding indicates
whether a particular point on the line is visible from the point of origin or not. When you
draw the line, the corresponding terrain elevation data is automatically displayed in its own
pane at the bottom of the Map Builder main window. You can create more than one line of
site on the same map.

You can use this information to study different ways of approaching a given target or to set
up a particular defense strategy. The coordinates of the line of view are displayed in the
pane, which presents distance along the x axis and height along the y axis.

The following figure shows an example of a map with a Line of Sight drawn and the
corresponding terrain elevation data displayed. .

This is an example only and the computation is performed using “classic” 3D algorithms.
However, if you want to use radar coverage and include weather and fog in
computations, you can do so using the API.

Note:

Elevation data along a Line of Sight

For more information about Lines of Sight and how to set their properties, see Creating a
Line of Sight.
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Terrain cuts

This terrain cut feature of JViews Maps for Defense enables you to draw a polyline in a map.
When you draw the polyline, the corresponding terrain elevation data is automatically
displayed in its own pane at the bottom of the Map Builder main window. You can create
more than one terrain cut on the same map.

You can use this information to study more complex ways of approaching a given target or
to set up a particular defense strategy. This could represent, for example, an attempt at
encirclement or a two-pronged attack on a given target. The coordinates of the line of view
are displayed in the pane, which presents distance along the x axis and height along the y
axis.

The following figure shows an example of a terrain cut with the corresponding elevation
data and x,y coordinates displayed.

Elevation data along a terrain cut

You can select the polyline as a unit and move it on the map, or select one of the nodes and
change the shape of the polyline; the terrain elevation data is updated accordingly. You can
also add or remove points to or from the polyline using the the CTRL key and a mouse click.
The nodes in the elevation data correspond to the nodes in the polyline.

For more information about Terrain Cuts and how to set their properties, see Creating a
Terrain Cut.
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3D View

This feature of JViewsMaps for Defense enables you to visualize a map area in 3D to facilitate
your understanding of the landscape. When you select a specific area of the map in the Map
View, this area is automatically displayed in 3D in its own pane at the bottom of the Map
Builder main window. You can create more than one 3D View on the same map. With simple
mouse movements or using the interactors on the right, you can easily navigate in the 3D
View, zooming in or out or moving left to right.

3D Views can be draped with maps displayed in 2D views and symbols can also be added
and displayed.

You can use this information to study the terrain of interest from all angles and tilts and so
better determine points of attack or defense by identifying potential hazards in the terrain.
You can enlarge the 3D View, make it smaller, move its position in the view, rotate it through
360 degrees, and change the tilt from top to side view in the same operation. You can also
use an exaggeration factor to increase or decrease the elevation data display. Visually this
is very useful when the distance represented by the 3D View is great and the elevation of
the terrain is quite low.

You can also display the 3D View in Wireframe mode, which helps in understanding the
geometry, given that areas of light and shadow are not displayed. In addition, a refresh of
the display can be set such that it is only carried out when a change takes place in the 3D
View, thus reducing the CPU usage.

Symbols (2-dimensional) can be added to a 3D View and managed. For more information,
see Symbols in a 3D View and Managing Symbols.

The following figure shows an example of a 3D View.
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3D View

For more information about 3D Views and how to set their properties, see Creating a 3D
View.
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Fly Through

This Fly Through feature enables you to define a path to be followed during the assault on
a given target and study, in 3D, the effects that the terrain could have on such an attack.
You could, for example, simulate an approach for ground vehicles, foot soldiers, or for fighter
planes that fly close to the ground. Or you could create your own scenario using the API.
You have full control over the camera placement and the direction in which it is looking.

The API has been designed to specify an altitude for each of the trajectory points and a view
point, and can also use a customer-written interpolation method between the points. In
addition, you can specify the speed and altitude above ground by changing the style of the
map layer containing the Fly Through.

The Fly Through function makes it a simple task to simulate movements in a 3D View.

The operations that you can carry out on the trajectory (polyline) and 3D View are the same
as those described in 3D View.

The following figure shows an example of the 2D Fly Through pane.

The 2D Fly Through pane

The following figure shows an example of the 3D Fly Through pane.

The 3D Fly Through pane

For more information about Fly Through paths and how to set their properties, see Creating
a Fly Through.
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Gradient computations

The gradient computation feature enables you to compute a color-coded gradient chart that
highlights where all the gradients occur in a selected area of terrain. Gradient computations
simplify the task of identifying the flat and steep areas. You can change the color model
using the Gradient Style Settings window or the Property Sheet. A new Gradient layer is
created and displayed in the Map Layers pane each time you carry out a gradient
computation.

The following figure shows an example of a computed gradient chart.

Gradient Computation

For more information about gradient computations and how to set the gradient properties
in the Gradient Style Settings pane, see Creating a gradient computation.
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Valley computations

The valley computation feature enables you to compute a color-coded valleys and summits
chart that highlights all the peaks and troughs in a selected area of terrain. The valleys and
summits, that is the highest and lowest points, are highlighted by the different colors. You
can change the color model using the Valley Style Settings window or the Property Sheet.
A new Valley layer is created and displayed in the Map Layers pane each time you carry out
a valley computation.

The following figure shows an example of a valley computation.

Valley computation

For more information about valley computations and how to set the valley properties in the
Valley Style Settings pane, see Creating a valley computation.
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Areas of Sight

An Area of Sight can be shown as a circular area around the mouse position on the map.
The Area of Sight reveals an approximation of the elevation data within the circle and changes
as the mouse is moved around the map.

The following figure shows an example of an Area of Sight.

Area of Sight approximation

When you click the mouse button the Area of Sight at this point is saved and the Area of
Sight Style Setting window appears for you to set the properties you want. When you have
set the properties, a detailed computation of the visible and invisible areas is carried out
and displayed in the Map View as a raster image.

The following figure shows an example of an Area of Sight with detailed computations.
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Detailed Area of Sight computation

The point around which the computation is done is displayed in the center of the Area of
Sight (you may have to zoom in to see it). A new Area of Sight layer is created and displayed
in the Map Layers pane each time you carry out an Area of Sight computation.

You can change the colors used to display the visible and invisible parts of the terrain,
increase or decrease the precision of the terrain display, and change the point of view height
to view the terrain either at ground level or at a given altitude.

For more information about Area of Sight computations and how to set their properties, see
Creating an area of sight.
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Using more Map Builder features

Shows you how to use more of the Map Builder features.

In this section

Map Builder main window
Describes the Map Builder main window and the map display process.

Opening a Map
Explains how to open a map.

Importing data sources
Describes options available and how to importing certain types of data files.

Exporting data sources
Explains how to export map layers to enable you to use data sources with other software.

Map Layers
Explains how to manage and display map layers

Managing annotations
Describes the options available for annotating maps.

Managing Terrain Analysis
Describes options available for Terrain Analysis.

Managing Symbols
Describes the operations you can carry out in the Symbols pane.
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Managing areas of interest
Explains how areas of interest can be managed.

Setting the map scale
Explains how to set the scale of the map.

Setting preferences
Explains how to set preferences.

Setting coordinate systems
Explains how coordinate systems can be set.

Displaying labels
Explains how to display labels.

Displaying a grid
Explains how to display a grid.

Creating an orthodromy measure
Explains how to create an orthodromy measure.

Deleting an orthodromy measure
Explains how orthodromy measures can be deleted.

Magnifying part of a map
Explains how to magnify part of a map.

Rotating a map
Explains how to rotate a map.

Using the Compass
Explains how to display a compass.

Using the Data Sources pane
Explains how to set the properties for a selected data source or remove a data source from
the list.

Using Advanced Settings
Explains how to set the tile release mode and lists other advanced setting options.

Using the Multithread Monitor
Explains how to display and stop tasks with the Multithread Monitor pane.

Setting thin client parameters
Explains how to set thin client parameters.

Printing a map
Explains how to print a map.
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Saving a map
Explains how to save a map.
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Map Builder main window

Describes the Map Builder main window and the map display process.

In this section

Overview
Describes map display process.

Map Builder toolbar
Provides descriptions of buttons in the Map Builder toolbar.

Menus
Describes the File, Options and Help menus in main window.

The Shortcut Menu
Describes the shortcut menu
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Overview

The Map Builder is a map preparation tool that enables you to combine map data, provide
a given look and feel, define specific map behavior, and then save it for reuse later. A map
is displayed in the Map Builder main window.

When you open a map, the map display process is as follows:

1. Map data is read

2. Map features are created

3. Graphical objects are created from the map features

4. Graphical objects are styled using the current layer properties

This provides great flexibility on how to represent map data. For example you could change
the map renderers to have a street map feature displayed as something other than polylines.

The following figure shows an example of the Map Builder main window displaying a map.

Map Builder main window
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Map Builder toolbar

The toolbar is displayed at the top of the main Map Builder window.

Map Builder toolbar buttons
DescriptionButton

Pan: Moves and repositions the entire map when you click and drag in the main window.

Select: Puts the Map Builder main window into selection mode.

Zoom in Rectangle: Zooms in on a section of the map contained within a zoom box drawn
by you. Note that this enlarges the whole map. This button can also be used to zoom in (left
click) and zoom out (CTRL + left click).

Zoom In: Increases the size of the map displayed in the main window.

Continuous Zoom: Zoom in by pressing the left mouse button. Zoom out by pressing the
right mouse button. Use the mouse wheel to zoom into and out from the map. To pan, press
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DescriptionButton

and drag the mouse. The zoom operation pauses as the map pans to the area you want to
see.

Zoom Out: Decreases the size of the map displayed in the main window.

Fit to View: Fits the visible map to the size of the main window so that you can view the whole
map without having to scroll.

Zoom to Selected Layer: Zooms in to the layer selected in the Map Layers pane.

Rotate: Rotates the whole map in the direction that you drag it. A compass indicates the angle
of rotation. Rotation can be reset with a right click.

Magnify: Shows a circular, magnified area around the mouse pointer position on the map.
Select this button and then drag the mouse on the main window to magnify different parts of
the map.

See Through: Reveals a hidden part of the map.

Measure: Creates a new orthodromy measure, that is, a line on the map. The line represents
the shortest distance between the origin and end point of the line.The line may not be straight
due to the curvature of the Earth.

Remove Clutter: Displaces a set of overlapping symbols so that their true position can be
seen more clearly

Line of Sight: Creates a line of sight and an elevation chart in a map containing elevation
data.

Gradient: Creates a color-coded slope computation of a selected area. The gradient is
highlighted by different colors.

Valleys & Elevated Areas: Creates a color-coded computation of the valleys and summits
of a selected area. The valleys and elevated areas are highlighted by different colors.

Area of Sight: Shows an approximation of the elevation data within a circle around the mouse
pointer position on the map. Clicking the mouse on a selected point in the map creates a
detailed computation of the visible and invisible areas.

Terrain Cut: Creates an elevation chart in a map based on the elevation data of an irregular
cut through the terrain (a polyline).

3D: Creates a 3 dimensional view of a selected section of a map and allows you to rotate it
and change the tilt for a better analysis of the terrain.

Fly Through: Defines a trajectory to be followed during the simulation of an assault on a given
target and enables the study, in 3D, of the effects that the terrain could have on such an attack.

Polyline Annotation: Creates a polyline on a map and adds an annotation to it.
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DescriptionButton

Polygon Annotation: Creates a polygon on a map and adds an annotation to it

Point Annotation: Creates a point on a map and adds an annotation to it.

Link Annotation: Creates a link between two annotations on the map and adds an annotation
to the link.
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Menus

There are three menus in the main window: File, Options, and Help.

File
The following table shows menu entries provided in the File menu.

The File menu
DescriptionMenu Entry

Clears the currently displayed map from the view pane.New Map

Imports map data selected from the file Browser.Add Map Data

Opens a previously saved map file selected from the file Browser.Open Prepared Map

Saves the currently open map file under the directory name you supply and the
name you give it.

Save Map

Saves the currently open map file under the directory name you supply and the
name you give it.

Save Map As

Enables you to export map layers in Shapefile or GeoTIFF format, or to an Oracle®
database.

Export

Reopens a recently closed map file selected from the displayed list.Recent Files

Exits the application.You are asked if you want to save the map file before exiting.Exit

Options
The following table shows menu entries provided in the Options menu.
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The Options menu
DescriptionMenu Entry

Displays a brief explanation of the selected function when the mouse pointer
is held over it in the main window.

Show Tool Tips on the
Window

Displays a brief explanation about the part of the map in the Map View that
has the mouse pointer positioned over it.

Show Tool Tips on the Map

Shows a set of advanced properties that you can set. The properties
displayed correspond to the selected layer.

Show Advanced Properties

“Smooths out” the features to produce a “nicer” display of maps, but at the
cost of a reduction in performance.You must choose between “standard
and fast” or “more aesthetic but slower”.

Antialiasing

This provides faster displays and is particularly useful when numerous
objects are moved around on top of a static map. Note however, that this
uses more memory and slows down panning.

Triple Buffer

Displays the parameters used for tiled image generation. These images
can be used by the servlet as pre-rendered tile requests to speed-up the
server's response time.

Thin Client Settings

Displays a list of predefined coordinate systems in a dedicated pane. A
predefined coordinate system set from this pane is reflected in the
Coordinate System pane on the left of the Map Builder.

Predefined Coordinate
Systems

Displays the Unused Views pane.You can drag and drop these additional
views into the left of the Map Builder main window and display them along

Show Additional Views

with the other tabs.You can also drag and drop any of the tabs back into
the Unused Views pane.

Help
The following table shows menu entries provided in the Help menu.

The Help menu
DescriptionMenu Entry

Displays information about your Map Builder installation.About the Map Builder

Displays the help contents in your browser.Help Contents
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The Shortcut Menu

Right-click to display the Shortcut menu in the Map View.

The following table shows menu entries provided in the Shortcut menu.

The Shortcut menu
DescriptionMenu Entry

Selects the topmost element at the Shortcut menu location.This is useful when
the Select interactor is not active. This menu entry is not active when there is

Select

no element (or a non selectable element) at the Shortcut menu location or the
object is already selected

Shows a data sheet used to allow the user to change the data values. As soon
as this option is activated, the original data source will no longer be used: all

Edit Data

computations will be based on the existing graphic object coordinates and data
values.

Remove the selected objects from the map. This menu is unavailable if no
object is selected. As soon as this option is activated, the original data source

Delete selected
object(s)

will no longer be used: all computations will be based on the remaining graphic
object coordinates.

Zooms to the selected layer. This menu entry is not active if there is no layer
selected in the Map Layer pane.

Zoom to Layer

Centers the Map View on the center of the current selection bounding box
(represented by four points).This menu entry is not active if there is no element
selected in the Map View.

Center View on
Selection

Zooms the view to the area that contains the current selection. This button is
not active if there is no element selected in the Map View.

Zoom to Selection

Closes the Shortcut menu.Cancel
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Opening a Map

To open a previously saved map:

1. Choose File>Open Prepared Map to display the Open Map Definition File window.

If you have changed the current map, the Map has been modified window opens. Click
Yes to save the current map.

2. In the Open Map Definition File window, Browse to the map file (.ivl) you want to
open, select it, and click Open.
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Importing data sources

Describes options available and how to importing certain types of data files.

In this section

Importing a simple data source
Explains how to import a data source.

The Select Data Sources pane
Explains the purpose of the Select Data Sources pane.

Importing an ESRI/Shape file
Explains how to import an ESRI/Shape file and describes the available options.

Importing non-georeferenced image files
Explains how to import a non-georeferenced image file and describes the available options.

Importing a TIGER/Line file
Explains how to import a TIGER/Line® file and describes the available options.

Importing a DXF file
Explains how to import a DXF file and describes the available options.

Importing a DAFIF file
Explains how to import a DAFIF file and describes the available options.

Importing a CADRG file
Explains how to import a CADRG table of contents file and describes the available options.
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Importing a VMAP database file
Explains how to import a VMAP database file and describes the available options.

Importing an IHO S57 file or catalog database
Explains how to import an S57 file and describes the available options.

Importing a Web Map Server Image
Explains how to import a Web Map Server image and describes the available options.

Importing layers from an Oracle spatial database
Explains how to import layers from an Oracle® spatial database and describes the available
options.

Importing an SVG file
Explains how to import an SVG file and describes the available options.

Importing any file type using menus
Explains how to import files of any type using the menus.

Using drag-and-drop
Shows you how to use the drag-and-drop mechanism to import a generic file.
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Importing a simple data source

The Select Data Sources pane displayed depends on the type of data source you want to
import. In most cases this is a simple pane.

To import a simple data source.

1. Choose File>Add Map Data to display the Select Data Sources pane.

2. Browse to the data source you want to open, select it, and click Open.
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The Select Data Sources pane

In some cases the Select Data Sources pane is more complex and displays specific options
depending on the type data source you choose.
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Importing an ESRI/Shape file

If the data source is an ESRI/Shape (.shp) file, there are additional options that you can
use.

The following figure shows both the Advanced and Select Projection options selected.

Select data sources pane for ESRI/Shape file

1. Choose File>Add Map Data to display the Select Data Sources pane.

2. Select Use Tiling, if you want to have an additional index file (.idx) managing the
shape file using a load on demand algorithm. If the index file does not exist, the Create
index file pane asks you if you want to create a new one.
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3. To create a new index file, click Yes to display the Tiling parameters pane and enter
the parameters you want.

The following figure shows the Tiling parameters pane.

Tiling parameters pane

4. If you want to set projection parameters, see Setting coordinate systems.

5. If your shape file has an associated dbf (database) file and thus contains metadata,
you can use this to filter so that you load only a subset of the file content. To do this,
select the Filter tab, select the Activate Filter check box and define your filter
by selecting items from the drop-down lists.

The following figure shows the definition of a filter which will only load San Francisco
streets which have ZIP codes greater than “92000”.
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Filter definition to load only a subset of the shape file content

6. Click Open.
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Importing non-georeferenced image files

Explains how to import a non-georeferenced image file and describes the available options.

In this section

Importing a non-georeferenced image file
Explains how to import a non-georeferenced image file options.

Options when importing a non-georeferenced image file
Describes calibration and image bound options.
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Importing a non-georeferenced image file

If the data source is a Non-Georeferenced Image file (.gif, .tif, .jpg, .jpeg), there are
specific options that you can set.

The following figure shows the options available when importing a Non-Georeferenced Image
file.

Select Data Sources pane for a Non-Georeferenced Image file

1. Choose File>Add Map Data to display the Select Data Sources pane.

2. In the top part of the pane click the gray rectangle to preview the image and use the
toolbar to pan, zoom in/out, and fit the image to the view.

3. By default the Image Calibration pane is displayed in bounds mode. In bounds mode
you can set the latitude and longitude of the image manually. Click the row and enter

the coordinates. You can also click on the button to interactively select the
boundaries.

4. To switch to control point mode, click the button. This adds two columns: Pixel
Column and Pixel Line. In this mode you can set the position of the image manually
using the pixel properties or the latitude\longitude properties. In addition, you
can drag the red crosses to the point you want; this automatically sets the property
values in the Image Calibration pane. The red cross associated with a selected row is
contained in a rectangle.

5. Click the button to add another row and another red cross in the Image pane.
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6. Click the button again to return to bounds mode.

7. To remove a row from the Image Calibration pane, select the row and click the
button.

8. Since this is a non-georeferenced data source, you must state the coordinate system
in which the data source is defined in the Projection pane. The coordinate system in
which you finally project the data source can be a different system and should be
defined in the Coordinate System pane, see Setting coordinate systems.

9. Click Open.
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Options when importing a non-georeferenced image file

Setting the number of calibration points
Calibration in the Image Calibration pane uses an IlvFittedTransform class. This class
requires a certain number of points to be entered for more complex transformations (that
is, a higher degree of interpolation).

You must enter:

♦ For a degree 1 polynomial (linear transformation): 3 calibration points.

♦ For a degree 2 polynomial transformation: 6 calibration points.

♦ For a degree 3 polynomial transformation: 10 calibration points.

♦ For a degree 4 polynomial transformation: 15 calibration points.

Polynomial interpolations are more precise in the area inside the calibration points. If you
use this feature, try providing calibration points that cover as large an area as possible.

The first part of the following figure shows an initial map of Alaska. Calibration points have
been placed around the right side of this image. The second part of the following figure
shows the interpolated image, however, the left side is quite skewed.
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Setting calibration points

Predefining the Image Bounds Using World Files
World files provide information for image calibration. A World file has the same filename
as the main image file. For example, a file called USA.jgw could accompany an image named
USA.jpg, and contain the coordinates of the image in seconds of arc.

An example of a World file content is as follows:
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1.50000000000000 (X pixel size)
0.00000000000000 (translation)
0.00000000000000 (rotation)
-1.50000000000000 (Y pixel size)
1934001.50000000000000 (X coordinate of the upper left pixel)
1187698.50000000000000 (Y coordinate of the upper left pixel)

The Map Builder ignores the translation and rotation parameters.

When loading images in GIF, JPG, PNG, or TIF format, the Map Builder scans the directory
to see if a World file exists, and if so, predefines the image bounds accordingly in the
importation dialog box.

For GIF, JPG, PNG, and TIF formats, the world file extensions checked are in the form .tifw
or .tfw, .gifw or .gfw, .jpgw or .jgw, and .pngw or .pgw respectively.
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Importing a TIGER/Line file

If the data source is a TIGER/Line® (*.rt1) file, there are specific parameters that you can
set.

The following figure shows the options available when importing a TIGER/Line file.

Select Data Sources pane for a TIGER/Line file

1. Choose File>Add Map Data to display the Select Data Sources pane.

2. In the Feature Choice pane, click each of the features you want to display in the
TIGER/Line data source. Note that you can expand a feature and select one or more
of its subfeatures.
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3. Click Select All to select all the features in the pane or Deselect All to deselect all
of them.

4. Select Use Tiling, if you want to use this option, and set the number of rows and
columns.

5. Click Open.
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Importing a DXF file

If the data source is a DXF file, there are additional options that you can set.

The following figure shows the options available when importing a DXF file.

Select Data Sources pane for a DXF file

1. Choose File>Add Map Data to display the Select Data Sources pane.

2. In the top part of the pane click the gray rectangle to preview the image and use the
toolbar to pan, zoom in/out, and fit the image to the view.

3. By default the DXF Calibration pane is displayed in "bounds mode". In bounds mode
you can set the latitude and longitude of the image manually. Click the row and enter

the coordinates. You can also click on the button to interactively select the
boundaries.

4. To switch to "control point" mode, click the button. This adds two columns: Pixel
Column and Pixel Line. In this mode you can set the position of the image manually
using the pixel properties or the latitude\longitude properties. In addition, you
can drag the red crosses to the point you want; this automatically sets the property
values in the DXF Calibration pane. The red cross associated with a selected row is
contained in a rectangle.
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5. Click the button to add another row and another red cross in the Image pane.

6. Click the button again to return to bounds mode.

7. To remove a row from the Image Calibration pane, select the row and click the
button.

8. Select Use Tiling, if you want to use this option, and set the number of rows and
columns.

9. Since this is a non-georeferenced data source, you must state the coordinate system
in which the data source is defined in the Projection pane. The coordinate system in
which you finally project the data source can be a different system and should be
defined in the Coordinate System pane, see Setting coordinate systems.

10. Click Open.
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Importing a DAFIF file

If the data source is a DAFIF file, there are a number of other parameters that you can set.

The following figure shows the options available when importing a DAFIF file.

Select Data Sources pane for a DAFIF file

1. Choose File>Add Map Data to display the Select Data Sources pane.

2. Select the DAFIF file you want to open.

3. In the Feature Choice pane, click each of the features you want to display in the DAFIF
data source. Note that you can expand a feature and select one or more of its
subfeatures.
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4. In the Limits pane, set the limits manually for the Lat/Lon properties or click the
button and then draw a rectangle in the Map View to set the limits.

5. Select Use Tiling, if you want to use this option, and set the number of rows and
columns.

6. Click Open.
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Importing a CADRG file

If the data source is a CADRG table of contents file (.toc) you can choose a set of CADRG
map resolutions to import from a list displayed in the Scale Selection pane.

Note that CADRG data is available on the maps data DVD supplied with the installers for
JViews Maps.

The following figure shows the Scale Selection pane available when importing a CADRG
file.

Select Data Sources pane for a CADRG file

1. ChooseFile>Add Map Data to display the Select Data Sources pane.

2. Select the CADRG (.toc) file you want to open.

3. Select the resolutions you want to import from the CADRG Scale Selection pane.

4. If you do not select any resolutions, you cannot open the CADRG file and a warning
pane is displayed;

The following figure shows the warning pane that is displayed if you do not select any
resolutions.
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No scales selected warning pane

5. Click Open.
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Importing a VMAP database file

If the data source is a VMAP database file, there are a number of other parameters that you
can set.

The following figure shows the options available when importing a VMAP database file.
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Select Data Sources pane for a VMAP file

1. Choose File>Add Map Data to display the Select Data Sources pane.

2. In the Feature Choice pane, click each of the features you want to display in the VMAP
data source. Note that you can expand a feature and select one or more of its
subfeatures.
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3. In the Limits pane, set the limits manually for the Lat/Lon properties or click the
button and then draw a rectangle in the Map View to set the limits.

4. Select Use Tiling, if you want to use this option, and set the number of rows and
columns.

5. Click the Get Library Bounds button, if you have set limits, but want to return to the
full set of data in the VMAP data source.

6. Click Open.
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Importing an IHO S57 file or catalog database

If the data source file is an S57 file or catalog database file, there are a number of other
parameters that you can set.

The following figure shows the options available when importing an S57 file.

Select Data Sources pane for an S57 file or catalog database file

1. Choose File>Add Map Data to display the Select Data Sources pane.

2. In the Feature Choice pane, click each of the features you want to display in the S57
data source. Note that you can expand a feature and select one or more of its
subfeatures.
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3. Select Use Tiling, if you want to use this option, and set the number of rows and
columns.

4. Either select Simple Rendering to have pre-IBM® ILOG® JViews Maps for Defense
8.1 rendering, or deselect it, and input the rendering options you want to use.

Rendering Options

5. Click Open.
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Importing a Web Map Server Image

If the data source file is a Web Map Server (WMS) image, there are a number of other
parameters that you can set.

The following figure shows the options available when importing a WMS image.

Select Data Sources pane for a WMS image

In the previous figure the red cross on certain servers indicates that these servers were not
available at the time the Map Builder was started.

1. Choose File>Add Map Data and selectWeb Map Server as the file type, to display
the Select Data Sources pane for WMS images.
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2. If you need to specify a server that does not appear on the list, click the Add Server
button. Enter a name for this server, and the get capabilities URL associated with this
server (this information is usually provided by the WMS server).

For instance,

http://wms.jpl.nasa.gov/wms.cgi?request=GetCapabilities

or

http://wms.jpl.nasa.gov/wms.cgi

Click OK to return to server list, where you can select the newly added server.

3. Select a map in the left pane to display the corresponding features in the Features
tab, and then select the features you want to display in the Feature Choice pane.

4. Use the Select All button to select all the features or the Deselect All button if you
want to remake your selection.

5. Click the Capabilities tab to display the Capabilities pane. The Capabilities pane
shows the response from the server to the capabilities request. This pane is for
information only and displays the layers that are available in the WMS data.

The following figure shows the Capabilities pane.
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Capabilities pane

6. Select Use Advanced Options, to activate the Options tab and then click the tab to
display the Request Options pane. The Request Options pane contains a number
of options that you can set.

The following figure shows the Options tab.
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Options pane

7. In the Limits pane, set the limits manually for the Lat/Lon properties or click the
button and then draw a rectangle in the Map View to set the limits.

8. To use load-on-demand, select the Use Tiling check box and specify the number and
lines and columns of tiles you want to divide the limits region (specified above) into.
Given that WMS servers usually limit the image size of a request, this helps improve
the overall region resolution by using the specified request image size per tile (one
image request per tile load instead of a unique image request for the whole area of
interest).

9. If you know the scale you want to display the image at, click Compute best tiling
for scale. An Enter Scale input window then pops up in which you can enter the
desired scale with which the tiling parameters will be computed. According to the
image size specified in the advanced Options tab, the Map Builder will compute the
tile and column counts so that the overall image will have the desired resolution. The
scale should be entered either in decimal format or with the 1/xxx notation.

You can click the Get the view scale button to choose the current view scale.
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Enter scale pop-up window

10. Set the image format by selecting from the list displayed in the Image Format pane.

11. If you want the layers to be transparent, check the Transparent box in the Layer
Transparency pane.

Transparency is only supported for .gif and .png images. Specifying
transparency for other image formats may lead to strange results.

Note:

12. Select the Available SRS from the list displayed in the Available SRS pane. The Available
SRSs are the available Spatial Reference Systems in which a layer can be displayed.
You can only display a layer using one of the SRSs in this list. The list is retrieved from
the capabilities request.

13. Set the version number you want in the Version pane. This property allows you to
specify the version number as an attribute in the request to the server. Some servers
only respond to requests with specific version numbers and reject the request if the
version does not match the number they are expecting.

14. In the Image Size pane, set the size of the image by dragging the slider to the required
position. This is the size of the image requested on the server and not the size of the
image displayed in the Map View. Once read, the image is displayed in the Map View.
However, the size of the displayed image does not depend on the size of the requested
image since it is georeferenced, but specifying an image size in the request can be
useful for tuning the precision versus load time ratio.

15. Check the Flatten box in the Flatten Layers pane to display only one layer for all the
selected features. If this option is not checked and you select more than one feature
in the Feature pane, a map layer is created for each feature selected.

16. To change the layer order, select a layer in the Layer Order pane and click on the

or button to move the layer up or down one position. Note that to carry out this
operation, you must have the Flatten option checked, because the layer order specifies
how the features selected in the Features Choice pane are stacked in this single map
layer.

17. Click Open.
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Importing layers from an Oracle spatial database

If the data source is a Oracle® spatial database, there are specific parameters that you can
set.

The following figure shows the options available when importing from an Oracle Spatial
database.

Select Data Sources pane for an Oracle spatial database

1. Choose File>Add Map Data to display the Select Data Sources pane.

2. Choose Oracle Layer in the Files of Type list.

3. Fill in the parameters to create a connection to the database. You need a login and a
password for the Host machine hosting the database. You will also need the port
number and the Spatial ID of the database, that is, the "name" of the database.

4. Select the model type of your your database. In recent Oracle spatial databases, object
model is the standard.

5. Click connect.

6. If you intend to load data on demand, enable Use Tiling, then specify the column and
line count defining the tiling.

7. Click Open to perform data loading.

I B M ®  I L O G ®  J V I E W S  M A P S  F O R  D E F E N S E  8 . 6 147



before using this functionality, you must install an Oracle driver to be able to import
Oracle layers within the Map Builder. For information on how to do this, refer to Importing

Note:

Oracle Layers within Map Builder in the help file found at  <installdir> /
jviews-maps86/samples/mapbuilder/index.html.
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Importing an SVG file

If the data source is a SVG file, there are additional options that you can set.

The following figure shows the options available when importing an SVG file.

Select Data Sources pane for an SVG file

1. Choose File>Add Map Data to display the Select Data Sources pane.

2. In the top part of the pane click the gray rectangle to preview the image and use the
toolbar to pan, zoom in/out, and fit the image to the view.

3. By default the SVG Calibration pane is displayed in "bounds mode". In bounds mode
you can set the latitude and longitude of the image manually. Click the row and enter

the coordinates. You can also click on the button to interactively select the
boundaries.

4. To switch to "control point" mode, click the button. This adds two columns: Pixel
Column and Pixel Line. In this mode you can set the position of the image manually
using the pixel properties or the latitude\longitude properties. In addition, you
can drag the red crosses to the point you want; this automatically sets the property
values in the SVG Calibration pane. The red cross associated with a selected row is
contained in a rectangle.

I B M ®  I L O G ®  J V I E W S  M A P S  F O R  D E F E N S E  8 . 6 149



5. Click the button to add another row and another red cross in the Image pane.

6. Click the button again to return to bounds mode.

7. To remove a row from the Image Calibration pane, select the row and click the
button.

8. Select Use Tiling, if you want to use this option, and set the number of rows and
columns.

9. Click Open.
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Importing any file type using menus

You can choose to import from files from any data source type by selecting the generic filter
“All Known Files” for the file type in the Select Data Sources pane.

The following figure shows the generic filter “All Known Files” for importing any type of
file.

The Select Data Sources pane for any known file

To import a file of any known type:

1. Choose File>Add Map Data, the Select Data Sources pane appears.

2. Select one or more file(s).

Depending on the type of file selected, a pane will appear at the right of the Select
Data Sources pane.

3. Enter any additional information necessary to open the file.

4. Click Open. After loading, the data source appears in a separate layer of your current
map.
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Using drag-and-drop

To import a file using drag-and-drop:

♦ Drag a file from your file explorer into the main view window.

If more information is needed to open the file, a specific dialog will appear to allow
for this data.

The following figure shows an example of dropping a shape file (.shp) into the main
window. You are prompted to specify a projection.

Opening any known file using drag-and-drop

when you drag and drop IVL files, the Map Builder treats the file as a
prepared map.The file is opened and replaces the map currently displayed.

Note:
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Exporting data sources

To enable you to use data sources with other software, you can export map layers in Shape,
GeoTIFF, and KML format to an Oracle® database or to a folder of your choice.

The following figure shows an example of exporting a map layer in Shape format.

Exporting data sources

To export a data source:

1. Select File>Export to open the Export Map window.
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2. Select the area of the map you want to export in the Limits pane. Set the limits manually

for the Lat/Lon properties or click the button and then draw a rectangle in the
Map View to set the limits.

All graphical components that intersect with this area will be entirely
exported. If an image intersects with the rectangle, the whole image will
be exported and will neither be cropped nor resized.

Note:

3. Select the Vector Exporter to be used (if any) from the values in the list: Do Not
Export, Export to Shape, Export to Oracle, or Export to KML.

4. Select the Raster Exporter to be used (if any) from the values in the list: Do Not
Export, Export to GeoTIFF, or Export to KML.

5. The Do Not Export option can be used in the case where you select all the layers in
the map window, but want to export only the vector or only the raster data sources.

6. Click the Settings button to open the Choose Shape or GeoTIFF Folder window, or
the KML Export File window. Select the folder to which the files must be exported for
each of the Exporters and then click Open.

The following figure shows an example of the Choose Shape Export Folder window.

Choose Shape Export Folder window
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The Save DBF check box saves the attributes of each geographic object
(for example, those displayed on the map tool tips) in a separate DBF
(shape file database) file.

Note:

7. If you select the Export to Oracle option, a message window appears that enables
you to connect to the database. Enter the connection parameters, click Connect and
then click OK.

The following figure shows the message window for connecting to a database.

Connecting to the database

8. Select the layers to export in the Map Layers pane.

9. Click the Export button to export the files to the selected folder(s) or to the database

.

If you forget to set the destination folders, the Choose Shape or Choose
GeoTIFF export folder window opens up automatically for you to set them.
In the case of an Oracle export, the connection dialog box is opened.

Note:
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Map Layers

Explains how to manage and display map layers

In this section

Managing map layers
Describes the various options available for managing map layers.

Setting dynamic styles
Explains how to set the dynamic styles.

Using the map style property sheet
Explains how to set different types of properties in the map style property sheet.

Setting sublayer properties
Explains how to set sublayer inheritance and independence from parent layers.

Creating a map layer hierarchy
Explains how to create a new map layer or sublayer.

Populating a new layer or sublayer
Explains how to populate a new map layer or sublayer.

Deleting a map layer
Explains how to delete a new map layer or sublayer.

Hiding and showing a map layer in the tree
Explains how to hide/show map layers or sublayers in the map layer tree.
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Displaying and concealing a map layer
Explains how to display/hide map layers or sublayers in a map.

Positioning layers in the map hierarchy
Explains how to position map layers or sublayers.

Renaming a map layer
Explains how to rename map layers.

Splitting or filtering a map layer
Explains how to split or filter maps layers in the Map Layer pane.

Simplifying the polygons in a layer
Explains how to add a simplified layer in the Map Layers pane.

Adding layer styling based on metadata
Describes the layer styling that can be applied based on metadata.
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Managing map layers

A map layer is created automatically each time you import a data source using the File>Add
Map Data command, or when you add a new orthodromy measure, terrain analysis, label,
or grid. The layer is created automatically and placed in the Map Layers pane. For details
of how to import a data source, see Importing a simple data source

The following figure shows an example of the Map Layers pane.

Map Layers pane

In the Map Layers pane you can carry out the following operations:

♦ Expand/collapse the map layer hierarchy: select or deselect the Expand/Collapse button.

♦ Drag and drop a layer or layers to another position in the list. Note that the layer at the
bottom of the list is displayed at the top of the stack in the Map View.

♦ Make a layer visible or invisible in the Map View: select or clear the layer check box.

♦ Populate a layer in the Map Layers pane, see Populating a new layer or sublayer.

♦ Set the dynamic styles for each layer, see Setting dynamic styles.
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♦ Set the properties for each layer, see Using the map style property sheet.

Short cut menu
The following figure shows the shortcut menu available in the Map Layers pane.

Map Layers pane shortcut menu

You can use this shortcut menu to:

♦ Create and name a new empty layer in the Map Layers pane, see Creating a map layer
hierarchy.

♦ Delete a layer from the Map Layers pane, see Deleting a map layer.

♦ Hide/Show a layer or sublayer in the Map Layers pane, see Hiding and showing a map
layer in the tree.

♦ Display/Conceal a layer or sublayer in theMap Layers pane, seeDisplaying and concealing
a map layer.

♦ Position layers in the map hierarchy, see Positioning layers in the map hierarchy.

♦ Rename a layer in the Map Layers pane, see Renaming a map layer.

♦ Split a layer according to parameters chosen from a list, see Splitting or filtering a map
layer.

♦ Create a simplified version of an existing layer, see Simplifying the polygons in a layer

♦ Set the styling attributes for a layer containing metadata in a map, see Adding layer
styling based on metadata.
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If an operation is unavailable, some of the menu items may be unavailable.Note:
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Setting dynamic styles

To set dynamic styles in the Dynamic Style Setting pane:

1. Set the map to the scale that you want and define the map property values for this
zoom level.

2. Click the button to associate these styles with the current zoom level. A new
section is added to the bar in the Dynamic Style Setting pane.

3. Repeat these two steps to create as many dynamic styles as you want. A new section
is added to the bar in the Dynamic Style Setting pane each time you create a new
style.

4. Either zoom in and out to see the changes of style take place when each threshold is
crossed, or click one of the sections of the bar to immediately change the scale of the
map to the corresponding level (displayed as a tool tip).

The following figure shows the map scale displayed as a tool tip.

Setting Dynamic Styles

The position you are at in the overall scale range is indicated by the two arrow heads
on the bar.

5. Click the button to remove the current dynamic style setting from the Dynamic
Style Setting pane.
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Using the map style property sheet

The map style property sheet appears automatically when you select a layer in the Map
Layers pane. The property sheet displayed depends on the type of layer selected, for example,
the property sheet displayed for a Measures or Labels layer is different to that of a map
layer. Each property sheet displays the properties of the selected map layer.

The properties correspond to Boolean values, lists, free text, and a set of editors.

To set Boolean values:

♦ Click to the right of the corresponding property and select True or False.

To set a value from a list:

♦ Click to the right of the corresponding property and select an item in the list.

To set a value with free text:

♦ Click to the right of the corresponding property and enter a text string.

To set a value from an editor:

♦ Click to the right of the corresponding property, click the button, and set
your values using the editor displayed.

To register property values:

♦ Either click away from the property you have just set, or press the ENTER key.

The following figure shows an example of a map style property sheet.

Map layer property sheet
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Setting sublayer properties

To set a sublayer property to inherit from its parent layer:

1. Select a sublayer in the Map Layers pane to display the map style property sheet.

2. Click the Right Arrow head next to the property you want to inherit. The Right Arrow
changes to an Up Arrow and the value is automatically set to that of the parent layer.
You can no longer change the value without first changing the Up Arrow.

To set a sublayer property to be independent of its parent layer:

1. Select a sublayer in the Map Layers pane to display the map style property sheet.

2. Click the Up Arrow head next to the property you want to set independently. The
Up Arrow changes to a Right Arrow and you can set the corresponding property value.

I B M ®  I L O G ®  J V I E W S  M A P S  F O R  D E F E N S E  8 . 6164



Creating a map layer hierarchy

To create a new layer:

♦ Right-click in the Map Layers pane and select New Layer from the shortcut menu.

To create a new sublayer:

♦ Select a layer or sublayer in the Map Layers pane, right-click, and select New Layer
from the shortcut menu.

I B M ®  I L O G ®  J V I E W S  M A P S  F O R  D E F E N S E  8 . 6 165



Populating a new layer or sublayer

To populate a new layer or sublayer:

♦ In the Map Layers pane, drag and drop the required layer (or layers) into the new
layer or sublayer.
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Deleting a map layer

To delete a layer:

♦ Select the layer and press the Delete key

or

Right-click and select Delete from the shortcut menu.
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Hiding and showing a map layer in the tree

To hide a layer in the Map Layers pane:

♦ Point to the parent layer, right-click and select Hide Layer from Tree from the shortcut
menu. The parent layer and all its sublayers are removed from the Map Layers pane.

To hide a sublayer in the Map Layers pane:

♦ Point to the sublayer, right-click and select Hide Layer from Tree from the shortcut
menu. The sublayer is removed from the Map Layers pane.

To show all the hidden sublayers of a parent layer in the Map Layers pane:

♦ Point to the parent layer then right-click and select Unhide Sublayers from Tree from
the shortcut menu. All the sublayer(s) of the parent layer are redisplayed in the Map
Layers pane.

To show all the hidden sublayers in the Map Layers pane:

♦ Right-click in the Map Layers pane away from the layers listed and select Unhide
Sublayers from Tree from the shortcut menu. All the hidden layers are redisplayed in
the Map Layers pane.

Developers can suppress this feature if, for example, a subset of layers
must always be invisible to the final user.

Note:
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Displaying and concealing a map layer

To conceal a layer or sublayer in a map:

♦ Point to the layer, right-click and select Do not Display Layer from the shortcut
menu. The layer is concealed in the map and remains in the Map Layers pane.

To display a layer in the Map Layers pane:

♦ Point to the layer then right-click and select Display Layer from the shortcut menu.
The layer is redisplayed in the Map.

Displaying/Concealing a layer only works for the current layer selected. For example,
concealing a layer will not conceal its sublayers.

Note:
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Positioning layers in the map hierarchy

Several options exist that allow you to organize the hierarchy of layers and sublayers.

Note: 1. The layer at the bottom of the list in the Map Layers pane is displayed at the top
of the stack in the Map View.

2. You can move a parent layer up or down in the hierarchy and you can do the same
with sublayers in relation to their parent, however, you cannot move sublayers
between different parents.

To raise a layer one level in the hierarchy:

♦ Right-click the layer or sublayer in the Map Layers pane and select Raise Layer from
the shortcut menu.

To lower a layer one level in the hierarchy:

♦ Right-click the layer or sublayer in the Map Layers pane and select Lower Layer from
the shortcut menu.

To bring a layer to the front of the hierarchy:

♦ Right-click the layer or sublayer in the Map Layers pane and select Layer to Front
from the shortcut menu.

To send a layer to the back of the hierarchy:

♦ Right-click the layer or sublayer in the Map Layers pane and select Layer to Back
from the shortcut menu.
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Renaming a map layer

To rename a layer:

♦ Right-click the layer or sublayer in the Map Layers pane and select Rename Layer
from the shortcut menu.

or

Press the CTRL key and double-click the New Layer in the Map Layers pane. Enter the
new name and press the ENTER key.

or

Select the layer, press the F2 key and enter the new name.
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Splitting or filtering a map layer

To split or filter a layer in the Map Layers pane:

1. Right click a layer in the Map Layers pane and select Create Filtered Layer from
the shortcut menu. The Select Layer Filter window opens.

The following figure shows an example of the Select Layer Filter window.

Select Layer Filter window

2. In the Select Layer Filter window, select the filter you want to apply from the list
displayed in the Select Objects Where: dialog box.

The list displayed depends on the metadata contained in the map layer
you have selected.

Note:

3. Select an operator from the list displayed on the left and then enter a value for the
operator on the right.

You can filter an already filtered map layer
again.

Note:

4. If you want to split a layer by grouping the objects that do not match the filter, check
the Create a layer for non matching objects box. In this case, you create two filtered
layers: one that matches the filter and one that does not match the filter.

You can split a map layer more than
once.

Note:
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5. Click OK.
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Simplifying the polygons in a layer

To add a simplified layer in the Map Layers pane:

1. Right click a layer in the Map Layers pane and select Create Simplified Layer from
the shortcut menu. The Simplified Polygons window opens.

The following figure shows an example of the Simplified Polygons window.

The Simplified Polygons window

2. In the Simplified Polygons window, set the distance threshold.

3. Click OK. A new layer appears in the Map Layers pane.
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Adding layer styling based on metadata

Describes the layer styling that can be applied based on metadata.

In this section

Selecting the data to be used for styling
Explains how to select data to be styled in a layer.

Setting the color model for numerical data
Explains how to set the color styling based on numerical data.

Setting the color model for non-numerical data
Explains how to set color styling based on non-numeric data.

Remove layer styling
Explains how to remove layer styling.
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Selecting the data to be used for styling

To select the data to be styled in a layer containing values of meta data:

1. Open the Map Builder with the default map.

2. In the Map Layers tab, open the ESRI/Shape layer. The ESRI/Shape
(data/World_Countries.shp) sublayer opens.

3. Right-click the data/World_Countries.shp layer, then select Style Layer from the
shortcut menu. The Select Layer Attribute window opens.

The following figure shows an example of the Select Layer Attribute window.

The Select Layer Attribute window

4. In the Meta Data Used for Color Coding list, select the data to be used for styling.
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Setting the color model for numerical data

For numerical data, an interval color model is used to style ranges of values with color
interpolation.

To set the color model for numerical data:

1. Open the Select Layer Attributes window for the default map. For more information,
see Selecting the data to be used for styling.

2. Select POP_1994 in the Meta Data Used for Color Coding list.

The following figure shows an example of the Select Layer Attribute pane with
POP_1994 selected.

Styling numeric data

IBM® ILOG®  JViews Maps automatically computes the minimum and
maximum values and assigns them to black and white shading. Any value

Note:

between the minimum and maximum values is displayed with an
interpolated color.

3. Select 1,175,731,064 from the Values list and set the color to red using the Swatches
tab.

4. Select 0 from the Values list and set the color to pale yellow in the Swatches tab.

to add or remove color steps, or change the value associated to each step,
right-click on an element in Values and select Insert Limit from the shortcut

Note:

menu. Using this technique you can use multiple colored steps to present
ranges in the data.

5. Click OK. The color styling is now visible in the map.
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If the styling does not appear in the map, check that the Filled option is set to true
in the style property sheet.

The following figure shows the resulting map with red and pale yellow colors styling
set on population data.

Styling for population metadata
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Setting the color model for non-numerical data

For non-numerical, each possible value can be associated to a separate color.

To set the color model for non-numerical data:

1. Open the Select Layer Attributes window for the default map. For more information,
see Selecting the data to be used for styling.

2. Select CONTINENT from the Meta Data Used for Color Coding list.

The following figure shows an example of the Select Layer Attribute pane with
CONTINENT selected.

Styling non-numeric data

3. Select Australia from the list.

4. Set the color associated to Australia to pale pink using the Swatches tab.

5. Click OK. The meta data is presented in the map using the new color scheme.

If the styling does not appear in the map, check that the Filled option is set to true
in the style property sheet.
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The following figure shows the resulting map with the Australia displayed in pale pink.

Custom styling applied to map metadata
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Remove layer styling

To remove layer styling:

1. In the Map Layer tab, right-click the styled layer, then select Style Layer from the
shortcut menu. The Select Layer Attributes window opens.

2. Click the Remove Color Coding button. The Select Layer Attributes window closes
and all custom styling is removed from the layer.

Remove layer styling
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Managing annotations

Describes the options available for annotating maps.

In this section

Annotations
Explains the use of annotations.

Creating annotations
Explains how to create annotations for polylines, polygons and points.

Making annotations visible or invisible
Explains how to set annotation visibility options.

Editing annotation labels
Explains how to edit annotation labels.

Repositioning annotations
Explains how to reposition annotations.

Changing the shape of an annotation
Explains how to change the shape of annotations.

Adding and removing points to/from an annotation
Explains how to add or remove points in annotations.

Changing the style of an annotation
Explains how to change the style of an annotation.
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Deleting annotations
Explains how to delete an annotation.
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Annotations

You can annotate maps using predefined annotations. These annotations are created using
the buttons supplied as an annotation toolbar in the main window. This toolbar can be used
to interactively add a point, polyline, or polygon annotation.

For details of how to show and hide annotation layers and create a new annotation layer or
sublayer, see Managing map layers.
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Creating annotations

To create an annotation:

Polyline

1. Set the map to the position and zoom level you require.

2. Click the button in the main window and then click the map and draw a line that
represents the origin and end of the first part of the polyline you want to draw.

3. Click to create a point and then draw the second part of the polyline. Click again to
create a second point and draw the third part and so on. Double-click to end the
polyline.

The polyline is added to the annotations layer in the Map Layers pane.

Polygon

1. Set the map to the position and zoom level you require.

2. Click the button in the main window and then click the map and draw a line that
represents the origin and end of the first part of the polygon you want to draw.

3. Click to create a point and then draw the second part of the polygon. Click again to
create a second point and draw the third part and so on. Double-click to end the
polygon.

If the polygon is not closed when you double-click to end it, the origin and
end points are automatically joined.

Note:

The polygon is added to the annotations layer in the Map Layers pane.

Point

1. Set the map to the position and zoom level you require.

2. Click the button in the main window.

3. Click the map at the point where you want to place the point, and then click again.
The point is displayed at the selected point.

The point is added to the annotations layer in the Map Layers pane.

Link

1. Set the map to the position and zoom level you require.

2. Click the button in the Map Builder main window.
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3. Click the map on the annotation where you want the link to start from, and then click
again to the end location. The link is displayed between the selected annotations.

The link is added to the annotations layer in the Map Layers pane.
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Making annotations visible or invisible

To set the annotation visibility:

1. To make invisible annotations visible, select the appropriate annotation check box in
the Map Layers pane; the annotations are redisplayed in the Map View.

2. To make annotations invisible, clear the appropriate annotation check box in the Map
Layers pane; the annotations are removed from the Map View.
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Editing annotation labels

To edit an annotation label:

1. Select the annotation in the Map View, right-click, and choose Edit Label from the
shortcut menu. The Label Attribute window appears.

The following figure shows the Label Attribute window.

The Label Attribute window

2. Edit the Label Attribute value and then add a Description value for the annotation.
The description can be multiline, formatted in HTML, and can take the form of a tool
tip.

3. Click OK.

To display the description when the mouse is held over an annotation in
a Map View, select Options>Show Tool Tips on the Map.

Note:
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Repositioning annotations

To reposition an annotation:

For a point:

1. First, choose the Select interactor on the map toolbar.

2. Click to select the point, and with the mouse button held down, drag it to the new
position, and then release the button.

For a polyline:

1. First, choose the Select interactor on the map toolbar.

2. Click part of the line to select it (not on a point), and with the mouse button still held
down, drag it to the new position, and then release the button.

For a polygon:

1. First, choose the Select interactor on the map toolbar.

2. Either click part of the line to select it (not on a point) or click in the area encompassed
by the polygon, and with the mouse button still held down, drag it to the new position,
and then release the button.

For a link:

1. First, choose the Select interactor on the map toolbar.

2. Click part of the link to select it (not on a point), and with the mouse button still held
down, drag it to the new position, and then release the button.

The link will automatically reshape whenever you reposition one of the start and end
annotations.
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Changing the shape of an annotation

To change the shape of an annotation (polylines, polygons and links only):

1. First, choose the Select interactor on the map toolbar.

2. Click to select the annotation and drag the chosen point to the new position. The shape
is automatically updated.
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Adding and removing points to/from an annotation

To add or remove points to/from an annotation (polylines , polygons and links only):

1. To add a point to the annotation, place the mouse pointer on the part of the line where
you want to add the point, press CTRL and click. A new point is added.

2. To remove a point from the annotation, place the mouse pointer on the point you want
to remove, press CTRL and click. The point is removed.
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Changing the style of an annotation

To change the style of an annotation:

1. Select the annotation in the Map View, right-click, and choose Change Style from the
shortcut menu. The Change Style window appears.

The following figure shows an example of a Change Style window.

Change Style window

2. If you want to change the style of all the annotations, choose the styles you want and
then click OK.

3. If you want to change the style of an individual annotation, click the Create New Style
box, choose the styles you want, and then click OK.

You can also set the properties in the map style property sheet after the layer has been
created.

For a detailed description of the properties, see Programming with JViews Maps
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Deleting annotations

To delete an annotation:

♦ Right-click an annotation in the Map Layers pane and select Delete Layer from the
shortcut menu.

or

Right-click an annotation in the Map View and select Delete Annotation from the
shortcut menu.

or

Select the annotation in the Map Layers pane and press Delete on your keyboard.
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Managing Terrain Analysis

Describes options available for Terrain Analysis.

In this section

Terrain Analysis
Describes the purpose of Terrain Analysis.

Creating a Line of Sight
Explains how to create a Line of Sight.

Creating a Terrain Cut
Explains how to create a Terrain Cut.

3D Views
Describes available options for 3D Views.

Fly Through paths
Describes available options for Fly Through paths.

Creating a gradient computation
Explains how to create a gradient computation.

Creating a valley computation
Explains how to create a valley computation.

Creating an area of sight
Explains how to create an area of sight.
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Terrain Analysis

Terrain analysis enables you to plan the defense of towns, facilities, or terrain contained in
your data sources.
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Creating a Line of Sight

To create a Line of Sight you must first import a data source containing elevation data, see
Importing a simple data source for more information.

To create a Line of Sight:

1. Set the map to the position and zoom level you require.

2. Click the button on the toolbar and then draw a line on the map that represents
the origin and end of the Line of Sight you want to analyze.

A Line of Sight pane is displayed below the map in the main window and a Lines of
Sight layer is added to the Map Layers pane.

3. To change the length or direction of the Line of Sight, click to select it and drag the
point at either end of the line to the new position. The Line of Sight is automatically
updated.

4. To delete a Line of Sight you can do one of the following:

a. Select the Line of Sight in the Map Layers pane and press the Delete key on your
keyboard.

b. Select the Line of Sight in the Map Layers pane, right-click and select Delete Layer
from the shortcut menu.

c. Click the button in the Line of Sight tab to dismiss the Line of Sight and remove
the corresponding layer.

5. Set the properties for the Lines of Sight layer in the Map Style property sheet.

The following figure shows the Map Style property sheet for a Line of Sight.

Lines of Sight Layer properties
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Creating a Terrain Cut

To create a Terrain Cut you must first import a data source containing elevation data, see
Importing a simple data source for more information.

To create a Terrain Cut:

1. Set the map to the position and zoom level you require.

2. Click the button on the toolbar and then click the map and draw a line that
represents the origin and end of the first part of the polyline you want to draw.

3. Click the mouse button to create a point and start the second part of the polyline, then
click again to create a third part and so on. Double-click to end the polyline.

A Line of View pane is displayed below the map in the Map Builder main window and
a Terrain Cut layer is added to the Map Layers pane.

4. To reposition the polyline, click to select it and drag the whole line as a unit to the
new position. The Line of View is automatically updated.

5. To change the shape of the polyline, click to select it and drag the chosen point to the
new position. The Line of View is automatically updated.

6. To add a point to the polyline, place the mouse pointer on the part of the line where
you want to add the point, press CTRL and click. A new point is added to the polyline.

7. To remove a point from the polyline, place the mouse pointer on the point you want
to remove, press CTRL and click. The point is removed from the polyline.

8. To delete the Terrain Cut layer you can do one of the following:

a. Select the Terrain Cut in the Map Layers pane and press the Delete key on your
keyboard.

b. Select the Terrain Cut in the Map Layers pane, right-click and select Delete Layer
from the shortcut menu.

c. Click the button in the Terrain Cut tab to dismiss the Terrain Cut and remove
the corresponding layer.

9. Set the properties for the Terrain Cut layer in the map style property sheet

The following figure shows the Map Style property sheet for a Terrain Cut.
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Terrain Cut layer properties

For a detailed description of the properties, see Programming with JViews Maps for
Defense
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3D Views

Describes available options for 3D Views.

In this section

Creating a 3D View
Explains how to create a 3D view.

Panning a 3D View
Explains how to pan a 3D View.

Zooming in/out of a 3D View
Explains how to zoom in and out of a 3D View.

Changing the 3D View angle and tilt
Explains how to change the 3D View angle and tilt.

Changing Terrain Style and Performance
Explains how to change terrain style and performance of the 3D View.

Changing the 3D View Symbol Style
Explains how to change the style of symbols.

Changing the 3D Bounds
Explains how to change the 3D bounds.

Resetting the 3D View
Explains how to reset the 3D View
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Rotating the 3D View
Explains how to rotate the 3D View.

Deleting a 3D View
Explains how to delete a 3D View.

Setting the 3D View properties
Explains how to set 3D View properties.

I B M ®  I L O G ®  J V I E W S  M A P S  F O R  D E F E N S E  8 . 6202



Creating a 3D View

To create a 3D View:

1. Set the map to the position and zoom level you require.

2. Click the button in the Map Builder main window.

3. Draw a rectangle in the Map View to encompass the area you want to look at. A red
rectangle is displayed.

4. A 3D View pane is displayed below the map in the main window and a 3D layer is
added to the Terrain Analysis layer in the Map Layers pane.

5. If the 3D view is not visible, select Options>Show Advanced Properties and then
select the layer containing the elevation data and set Visible in 3D View to true in
the map style property sheet.

To access the property, you must have the Show Advanced Properties
option active (Options>Show Advanced Properties).

Note:
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Panning a 3D View

The Pan function is automatically activated in the 3D View pane.

To change the position of the 3D View:

♦ Click it and drag it to the new position. In this operation you move both the camera
and the point that you are looking at.

To move the 3D View a preset distance:

1. Click the button or the button to move the 3D View to the left or right.

2. Click the button or the button to move the 3D View up or down.
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Zooming in/out of a 3D View

To zoom in and out of a 3D View

♦ Rotate the mouse wheel backwards or forwards to zoom in and out of the 3D View.

or

Use the Zoom In/Out slider.

The following figure shows the Zoom In/Out slider.

Zoom In/Out slider
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Changing the 3D View angle and tilt

To change the angle and tilt of the 3D View:

♦ Right-click the image and move the image to the view angle you want. In this operation
you change the camera position about the point you are looking at. You can rotate the
3D View through 360 degrees and tilt the image in the same operation.

or

Use the rotate buttons and in conjunction with the tilt slider to set the angle
and tilt individually.

The following figure shows the Zoom In/Out slider when used with rotate buttons.

Tilt slider
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Changing Terrain Style and Performance

To change the terrain style and performance of the 3D View:

♦ Click the button in the 3D View or right-click in the 3D View and select Change
Terrain Style & Performance in the shortcut menu. The 3D View Terrain Style &
Performance window appears.

The following figure shows an example of a 3D View Terrain Style & Performance
window.

Change Terrain Style and Performance window

To set the number of Frames per Second (FPS):

♦ Drag the slider to the position that corresponds to the FPS you want to set. This sets
the number of 3D View refresh operations per second. The lower the value the less
the graphics card has to work. If set too high, the graphics card may be overwhelmed
and then the CPU will try to help the card, raising the CPU usage to perhaps 100%.
If set correctly (depending on the graphics card capabilities), the CPU should remain
at around 0% because the graphics card should be able to manage alone. If you want
to leave most of the CPU capacity for other tasks, move this slider to the extreme left.

To show the 3D View as a terrain mesh:

♦ SelectWireframe.

To activate bilinear filtering:

♦ Select Bilinear Filtering (selected by default). This smooths the texture of the 3D
image.
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To activate terrain texture options:

1. Select Terrain Texture (selected by default).

2. Select the Use 2D view as texture: the texture applied on top of the 3D terrain mesh
is generated by rendering a set of layers belonging to the map. This allows you to
display roads on the 3D View. All the layers that have the attribute Visible in 3D
View set to true in their map style are drawn as part of the texture.

To activate light computation on a 3D scene:

♦ Select Enable Lighting.

To use a Gouraud algorithm to compute the shading:

♦ Select Smooth Shading (otherwise flat shading is applied).

To change the horizontal direction of the light:

♦ Drag the Orientation slider to the position you want. For example, 'N' means that
light is directed towards the north, 'S' towards the south and so on.

To change the vertical direction of the light:

♦ Drag the Elevation slider to the position you want. You can set the elevation between
0˚ (the light is horizontal) and 90˚ (the light is vertical, descending).

To set Texture Oversampling:

♦ Drag the slider to the position that corresponds to the value you want to set. This value
forces the 3D engine to compute higher resolution textures for the terrain. For example,
a factor of 4 for leads to generation of a texture 4x4=16 times bigger. Use this slider
if you feel that the precision of the default texture does not suit your needs.

To set the Height Exaggeration:

♦ Drag the slider to the position that corresponds to the value you want to set to bring
the 3D View into relief. You can set the Height Exaggeration factor to between 1 and
30. By default the exaggeration factor value is 2, which means that all altitudes appear
twice as high as they are in reality.

or

Click on the 3D View to activate it and press the A key to increase the Height
Exaggeration factor of the 3D image or the Z key to decrease it. This brings the 3D
View into or out of relief.

To set the Terrain Precision:

♦ Drag the slider to the position that corresponds to the value you want to set. You can
choose between 3D View precision and CPU usage by increasing or decreasing this
option. When set to minimum, very few 3D points are used to create the terrain mesh,
so the terrain is less precise but the display is faster.

When set to maximum, more 3D squares are created, so the terrain is more precise,
but the display much slower. In this case, the sooner the zoom level is reached at
which each terrain data point has its own mesh rectangle. The more powerful the
graphics card, the higher the setting can be.

This is the only option you can use to set the terrain precision. The dynamic more/less
detail behavior is hard coded and depends only on the zoom level.
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The following figure shows an example of a 3D View (in Wireframe mode), showing a
low and high setting for the terrain precision.

Low and high terrain precision settings
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Changing the 3D View Symbol Style

To change the style of any symbols you have created in the 3D View:

1. Click the button in the 3D View or right-click in the 3D View and select Change
Symbol Style in the shortcut menu. The 3D View Symbol Style window appears.

The following figure shows the 3D View Symbol Style window.

The 3D View Symbol Style window

2. Set the styles you want and click OK.

The following table shows useful properties that you can set.

Style properties
DescriptionProperty

Provides high resolution icons in the 3D View.Double
Resolution

The color used for the dotted line that shows the ground position of symbols at
altitude, such as aeroplanes and missiles.

Ground Imprint

The color of the point that shows the true position of the symbol.Point Color

Symbols can be displayed with or without respect to the terrain. .Symbol Z
Order

If set to true, symbols could be hidden by the terrain, for example, behind a
mountain. If set to false, symbols are always drawn on top of the terrain

For a detailed description of the properties, see Programming with JViews Maps for
Defense
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Changing the 3D Bounds

To change the bounds of the selection rectangle:

♦ In the Map View, select the rectangle and drag a side or corner of it to reset the
bounds.

or

Change the 3D View Bounds parameter in the 3D View layer properties, see Setting
the 3D View properties.
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Resetting the 3D View

To return the 3D View and the camera to their original state:

♦ Click the button in the 3D View, or right-click in the 3D View and select Reset
Camera from the shortcut menu.
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Rotating the 3D View

To rotate the selected terrain in the 3D View:

1. Click the button to rotate the 3D View clockwise.

2. Click the button to rotate the 3D View anticlockwise.
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Deleting a 3D View

To delete a 3D View you can do one of the following:

♦ Select the 3D View in theMap Layers pane and press the Delete key on your keyboard.

or

Select the 3D View in the Map Layers pane, right-click and select Delete Layer from
the shortcut menu.

or

Click the button in the 3D View tab to dismiss the 3D View and remove the
corresponding layer.
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Setting the 3D View properties

To set the properties for the 3D View:

♦ Select the 3D View layer and set properties in the map style property sheet.

The following figure shows an example of the map style property sheet for a 3D View.

3D View layer properties

Note that when you set the 3D View Bounds property, the Bounds window is displayed
for you to set the coordinates of the bounds.

The following figure shows an example of the Bounds window.

Setting the 3D View bounds property
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Fly Through paths

Describes available options for Fly Through paths.

In this section

Creating a Fly Through
Explains how to create a Fly Through.

Deleting a Fly Through
Explains how to delete a Fly Through.

Setting properties for Fly Through paths
Explains how to set Fly Through properties.
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Creating a Fly Through

To create a Fly Through you must first import a data source containing elevation data, see
Importing a simple data source for more information.

To create a Fly Through:

1. Set the map to the position and zoom level you require.

2. If you have not already created a 3D View, click the button in the main window.
Refer to Creating a 3D View for details of how to create the 3D View.

3. Click the button on the toolbar and then click the map and draw a line that
represents the origin and end of the first part of the Fly Through trajectory.

4. Click the mouse button to create a point and start the second part of the trajectory,
then click again to create a third part and so on. Double-click to end the trajectory.

A Fly Through layer is added to the Map Layers pane. The trajectory represents a
route that you can follow visually when the Fly Through is started. The trajectory is
displayed in the Fly Through in relief, and a Fly Through button is added to all the
currently open 3D View toolbars.
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Deleting a Fly Through

♦ Select the Fly Through in the Map Layers pane and press the Delete key on your
keyboard.

or

Select the Fly Through in the Map Layers pane, right-click and select Delete Layer
from the shortcut menu.

or

Click the button in the Fly Through tab to dismiss the Fly Through and remove
the corresponding layer.
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Setting properties for Fly Through paths

1. Set the properties for the Fly Through layer in the map style property sheet.

The following figure shows an example of a map style property sheet for a Fly Through
layer.

Fly Through layer properties

The height you set for the Altitude Above Sea Level property
remains constant throughout the Fly Through. If the setting is not high

Note:

enough to clear the mountains, there may be a collision, depending on the
trajectory.

2. To start or stop the Fly Through, click the button in the 3D View or right-click
and select Start/Stop Fly Through in the shortcut menu.
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Creating a gradient computation

To create a gradient computation:

1. Set the map to the position and zoom level you require.

2. Click the button on the toolbar and then draw a rectangle on the map where you
want to compute the gradient.

3. Set the gradient properties in the Gradient Style Settings pane and click OK

The following figure shows an example of the Gradient Style Settings.

Gradient Style Settings pane

4. The color-coded gradient is displayed in the rectangle you have drawn and a Gradient
layer is added to the Map Layers pane. You can change the colors of the Slope data
displayed using the Color Model property.

To access the Color Model property, you must have the Show Advanced
Properties option active (Options>Show Advanced Properties).

Note:

5. To delete a Gradient Layer, see Deleting a map layer.

6. You can also set the properties in the map style property sheet after the layer has
been created
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Creating a valley computation

To create a valley computation:

1. Set the map to the position and zoom level you require.

2. Click the button on the toolbar and then draw a rectangle on the map where you
want to compute the valleys.

3. Set the valley properties in the Valley Style Settings pane and click OK.

The following figure shows an example of the Valley Style Settings pane.

Valley Style Settings pane

4. The color-coded valley/summit information is displayed in the rectangle you have
drawn and a Valley layer is added to the Map Layers pane. You can change the colors
of the Elevation and Valley data displayed using the Color Model property.

.

To access the Color Model property, you must have the Show Advanced
Properties option active (Options>Show Advanced Properties).

Note:

5. To delete a Valley Layer, see Deleting a map layer.

6. You can also set the properties in the map style property sheet after the layer has
been created.

For a detailed description of the properties, see Programming with JViews Maps for
Defense
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Creating an area of sight

To create an area of sight:

1. Set the map to the position and zoom level you require.

2. Click the button on the toolbar and then move the mouse over the map. A circular
image is created around the mouse that gives an approximation of the visible area.
The visible area changes according to the terrain as you move the mouse over the
map.

3. Click at any point in the map where you want to permanently display the visible and
invisible areas. The Area of Sight Style Settings window opens for you to set the styles
you want.

The following figure shows an example of the Area of Sight Settings pane.

Area of Sight Style Settings window

4. Useful properties that you can set are:

Color Model:You can use this property to change the color
of the visible and invisible terrain.

Color Model
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Note: To access the Color Model property, you must have
the Show Advanced Properties option active
(Options>Show Advanced Properties).

You can use this property to change the point of view from
ground level to a given altitude (for example, an aeroplane
flying at 3000m).

Point of View Height

You can use this property to increase or decrease the
precision of the terrain displayed, but note that the lower the
value, the higher the precision but the higher the CPU usage.

Precision

Set the styles you want and click OK. A detailed Area of Sight
is displayed in the Map View.

5. An Area of Sight layer is added to the Map Layers pane. You can add as many Areas
of Sight as you like.

6. To delete an Area of Sight layer, see Deleting a map layer.

7. You can also set the properties in the map style property sheet after the layer has
been created.
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Managing Symbols

Describes the operations you can carry out in the Symbols pane.

In this section

Overview
Explains how symbols are managed.

Adding a new group
Explains how to add new group of symbols.

Adding a new APP-6a symbol
Explains how to add a new APP-6a symbol to a group.

Adding a new symbol from a palette
Explains how to add a new symbol from a palette

Editing a symbol from a palette
Explains how to edit a symbol from a palette.

Editing an APP-6a Symbol
Explains how to edit an APP-6a symbol from a palette.

Symbol operations
Explains how to edit, delete, duplicate, hide and move symbols.

Setting symbol layer properties
Explains how to set properties for a symbol layer.
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Removing symbol clutter
Explains how to remove clutter from a set of overlapping symbols.
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Overview

Symbols are managed using the buttons in the Symbols pane and the other panes that appear
when you click a button.

Most of these operations can also be carried out using the shortcut menu, displayed
when you click the right mouse button on a group or symbol.

Note:
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Adding a new group

To add a new group:

1. Click the Symbols tab on the left of the main window.

2. Click the button and enter a name for the new group in the Group Name window.

3. The following figure shows an example of the Group Name window.

Adding a new group
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Adding a new APP-6a symbol

To add a new APP-6a symbol to a group:

1. Click the Symbols tab on the left of the main window.

2. Click the button, to open the symbol type selection menu.

3. Select APP-6a Symbol and the NATO Symbol Manager pane opens.

The following figure shows the NATO Symbol Manager pane.

NATO Symbol Manager pane

4. Fill in the pane as follows:

a. Descend the warfighting hierarchy in the left pane and select the symbol to add.

The symbol is displayed in the Icon area of the NATO Symbol Manager, and the
ID is displayed as the ID property.

b. From the lists displayed select the values for Affiliation, Size, Mobility, Country
code and Order of battle, or accept the defaults.

c. Select the Status as either Anticipated/Planned or Present.
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d. Enter the Location or click the button and click the map at the point where
you want the symbol to be placed.

The coordinates appear as the Lat/Lon properties.

e. Optionally, you can use the other properties in the Modifiers dialog box to enter
text values.

f. Click OK.

The Symbol is added at the designated location in the Map View and in the
symbology tree. The identifiers entered in the NATO Symbol Manager are used
to refine the Symbol and to label it in the view area.
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Adding a new symbol from a palette

To add a new symbol from a palette of symbols to a group:

1. Click the Symbols tab on the left of the Map Builder main window.

2. Click the button, top open the symbol type selection menu.

3. Choose Symbol from a Palette, this makes the symbol palette selection panel appear.

4. 4. You can select an element in the tree here and

♦ Drag and drop it on the map

♦ Drag & drop it somewhere in the tree

♦ Click Add. The symbol will be added in the selected group

5. You can also open a custom palette, through the Load a Palette button which allows
you to select a palette jar file.

6. When you have finished using this panel, you can hide it with the Hide button.
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Editing a symbol from a palette

Once you have created a symbol from a palette, it is very simple to change its properties.

To edit a symbol from a palette:

♦ You can either

♦ double click in the tree view, or

♦ click the edit symbol button on the tree view toolbar.

This will display a property sheet where you can modify the symbol parameters,
according to the way they have been defined in the palette, but also change their
coordinates on the map or their SDM ID.

Sample property sheet
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Editing an APP-6a Symbol

Once you have created a symbol from a palette, it is very simple to change its properties.

To edit a symbol from a palette:

♦ You can either

♦ double click in the tree view, or

♦ click the edit symbol button on the tree view toolbar.

This will display the NATO Symbol Manager as described in Adding a new APP-6a
symbol
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Symbol operations

To edit an existing symbol:

♦ Select the symbol you want to edit and click the button. The NATO Symbol Manager
pane opens up directly for you to edit the symbol.

To delete a symbol:

♦ Select the symbol you want to delete and click the button. You are asked to
confirm the deletion.

To duplicate a symbol:

♦ Select a symbol and click the button.

To hide or show a symbol or group:

♦ Select a symbol or group and click the or button. When hidden the symbol
or group is unavailable in the symbology tree.

To move symbols

1. You can drag and drop (move) groups and symbols from one group to another.

2. You can also drag and drop a symbol from the symbol palette to the map (see Adding
a new symbol from a palette.)
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Setting symbol layer properties

To set the symbol layer properties:

♦ Enter the property values in the map style property sheet.

The following figure shows the map style property sheet for a symbol layer

Setting symbol layer properties

The property values you set are applied to all the symbols in the current layer.
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Removing symbol clutter

To remove clutter from a set of overlapping symbols:

1. Click the button in the main toolbar and then click in the Map View to display a
rectangle.

2. Drag the rectangle over the symbols from which you want to remove the clutter. The
symbols are displaced so that their true position (anchor point) can be seen more
clearly and a red line is displayed from each symbol to its anchor point. Note that if
a symbol does not need to be moved, only the anchor point is displayed.

3. Release the mouse button to return to the normal Map View.

I B M ®  I L O G ®  J V I E W S  M A P S  F O R  D E F E N S E  8 . 6236



Managing areas of interest

Explains how areas of interest can be managed.

In this section

Overview
Explains the purpose of the Area of Interest pane.

Creating a new area of interest
Explains how to create a new area of interest.

Renaming an area of interest
Explains how to rename an area of interest.

Deleting an area of interest
Explains how to delete an area of interest.

Refreshing an area of interest
Explains how to refresh an area of interest.

Moving an area of interest up or down
Explains how to move an area of interest in the list.

Zooming In on an area of interest
Explains how to zoom in on an area of interest.
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Overview

The Areas of Interest pane displays the areas of interest chosen by you. This enables you to
move quickly from one area of interest to another. You can also zoom in directly on an area
of interest in the pane. The Areas of Interest pane has a number of buttons that you can use
to manage the areas in the list.
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Creating a new area of interest

To create a new area of interest:

1. Set the Map View to the area of interest you want to create and then click the
button.

2. Enter an area name and click OK. The new area of interest is displayed in the Areas
of Interest pane.
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Renaming an area of interest

To rename an area of interest:

1. Select an area of interest in the list, click the button.

2. Enter a new area name and click OK. The new area name is displayed in the Areas of
Interest pane.
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Deleting an area of interest

To delete an area of interest:

♦ Select an area of interest in the list and click the button or press the Delete key
on your keyboard.
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Refreshing an area of interest

To refresh an area of interest:

♦ Select an area of interest in the list and click the button or press the ENTER key.
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Moving an area of interest up or down

To move an area of interest up or down one position in the list:

♦ Select an area of interest in the list and click the or button.
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Zooming In on an area of interest

To zoom in on an area of interest:

♦ Double-click the Area of Interest

or

Select an area of interest in the list and click the button or press the ENTER
key.
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Setting the map scale

To set the scale of the map interactively:

♦ Click the button at the bottom right corner of the Map View and enter a new scale
setting

or

Double-click the Scale Control pane and enter a new scale setting.

You can also change the scale using the bar in the Dynamic Style Setting
pane, see Map Dynamic Styles.

Note:
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Setting preferences

To set preferences:

1. Click the Preferences tab to open the pane.

2. Set the units of your choice for the Distances and Altitudes properties and choose
the coordinates type for the Coordinates property.

3. Select Date Line Wrapping if you want to cut polylines that go completely around
the Earth.

Date Line Wrapping requires a reload of the map. This is necessary to
recompute each polygon in the map to ensure that they do not cover a

Note:

large distance on the map, and also to "cut" any such areas into two or
more subareas. This is carried out only when the coordinate system
changes.
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Setting coordinate systems

Explains how coordinate systems can be set.

In this section

Overview
Summarizes the different ways coordinate systems can be set.

Coordinate system tab
Explains how to set the coordinate system using the Coordinate System tab.

Predefined coordinate systems
Explains how to set the coordinate system using the Predefined Coordinate Systems pane.
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Overview

There are two ways of setting the coordinate system, using the Coordinate System tab or
using the Predefined Coordinate Systems pane.
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Coordinate system tab

To set the coordinate system from the Coordinate System tab:

1. Click the Coordinate System tab to display the Projection pane.

2. Click the Down Arrow button and select a projection from the list.

3. If you want to change the position of the central meridians and parallels, enter the

values for the parameters, or click the button and then click the position in the
Map View where you want the new projection center to be.

4. Select Advanced, if you want to use the advanced options.

5. Set the properties of the selected projection, if required.

6. If the coordinate system you have chosen allows it, click the Down Arrow button and
select a datum from the list.

7. Click the button to display the datum properties and set them as required.

8. If the coordinate system you have chosen allows it, click the Down Arrow button and
select an ellipsoid from the list.

9. Click the button to display the ellipsoid properties and set them as required.
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Predefined coordinate systems

To set the coordinate system from the Predefined Coordinate Systems pane:

1. Choose Options>Predefined Coordinate Systems to display the Projection pane.

2. In the left of the pane select a coordinate system from the list.

The information for the Projection, Datum, and Ellipsoid properties is for information
only and cannot be changed in this pane.
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Displaying labels

To display labels:

1. Select a map layer in the Map Layers pane to display its map style property sheet.

2. Click the Labeling property and select the type of labeling you want from the list.

The labels are displayed on the map in the Map View and a Labels layer is added to
the Map Layers pane.

3. Set the label properties for this layer in the map style property sheet.

The following figure shows an example of a map style property sheet for a labels layer.

Label layer properties

4. To set the priority of the Labels sublayers, drag and drop the sublayers in the Labels
layer to the position in the hierarchy that you want, remembering that the sublayer
at the bottom of the hierarchy has the greatest priority.

I B M ®  I L O G ®  J V I E W S  M A P S  F O R  D E F E N S E  8 . 6 251



Displaying a grid

To display a grid:

1. Click the Grid Settings tab to open the pane.

2. Click the down arrow and select a grid type from the list.

3. Select the option Use Delayed Drawing, if you want to delay the redrawing of the grid
to improve performance on fast moving maps.

The grid is displayed in the Map View and a Grid layer is added to the Map Layers
pane.

4. Set the grid properties for this layer in the map style property sheet.

The following figure shows an example of a map style property sheet for a grid layer.

Grid layer properties
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Creating an orthodromy measure

To create an orthodromy measure:

1. Click the button in the main window.

2. Click the map at the point where you want the origin of the line to be, drag the mouse
across the map to where you want the end of the line to be, and then click again.

A Measures layer is added to the Map Layers pane.

3. Set the properties for the Measures layer in the map style property sheet.

The following figure shows an example of a map style property sheet for a measures
layer.

Measures layer properties

For a detailed description of the properties, see Programming with JViewsMaps for Defense.
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Deleting an orthodromy measure

Explains how orthodromy measures can be deleted.

In this section

Overview
Summarizes the different ways an orthodromy measure can be deleted.

Deleting all orthodromy measures in a layer
Explains how to delete all measures in a layer.

Deleting a single orthodromy measure
Explains how to delete a single measure.
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Overview

You can delete all the orthodromy measures contained in a layer or delete each measure
individually.
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Deleting all orthodromy measures in a layer

To delete all measures in a layer:

♦ Right-click a measure in theMap Layers pane and select Delete Layer from the shortcut
menu.

Delete all orthodromy measures
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Deleting a single orthodromy measure

To delete an individual orthodromy measure:

♦ Right-click a measure in the Map View and select Delete Measure from the shortcut
menu.

Delete an individual orthodromy layer
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Magnifying part of a map

To magnify a part of a map:

1. Click the button on the toolbar and then click the part of the map you want to
magnify.

A magnified, circular area is created around the mouse at the point where you click.

2. Hold the mouse button down and move the mouse over any part of the map to magnify
that part. The magnification is maintained until you release the mouse button.

I B M ®  I L O G ®  J V I E W S  M A P S  F O R  D E F E N S E  8 . 6 259



Rotating a map

To rotate a map:

1. Click the button on the toolbar and then move the mouse pointer to the map.
The mouse pointer changes to a circular arrow.

2. Click and move the mouse pointer either left or right in a circular fashion to rotate
the map. A small overlay compass is displayed with the angle of rotation shown below.
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Using the Compass

To display a compass that always points to the north:

♦ Click the Compass tab on the left of the main window.
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Using the Data Sources pane

To set the properties of a data source:

♦ Select the property and enter a value.

Data source properties

To delete a data source from the list:

♦ Select the data source and press the Delete key.

For more information, see Using the map style property sheet.

For a detailed description of the properties, see Programming with JViewsMaps for Defense.
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Using Advanced Settings

The Advanced Settings pane is mainly for use by developers for debugging purposes.Note:

To set the Tile Release Mode:

1. Click the Down Arrow button to display the list of tile release modes and select from:
Default Tile Release, No Tile Release, and Aggressive Tile Release.

2. If you select Default Tile Release, you can keep the current default value or set a new
default value for the number of tiles released (kept in memory). Click the Up or Down
Arrow head on the right of the pane to increase or decrease the number of tiles to be
released.

Select the Limit Overview Repaints, Show Tile Debugging View and\or Activate Garbage
Collection options according to your choice by selecting or clearing the corresponding check
box.

The memory used and refresh time are automatically displayed.
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Using the Multithread Monitor

You can display the tasks in progress in the Multithread Monitor pane and cancel a task if
you no longer want the currently loading data source.

To display the tasks in the Multithread Monitor pane:

♦ Double-click the pane at the bottom right corner of the Map View.

The following figure shows an example of the Multithread Monitor pane.

The Multithread Monitor pane

To stop the task in progress:

♦ Click the button in the top left corner of the Map View.
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Setting thin client parameters

To set thin client parameters:

1. Choose Options>Thin Client Settings to display the Thin Client Settings pane.

2. In the Tile Size pane enter a value for the size of the tiles in pixels (the default value
is 256).

3. Use the zoom functions to set a map scale for which you want to generate tiles and

then click the button in the Scales pane.

4. Repeat this operation until you have set all the scales for which you want to generate
tiles.

5. To display the map at a given scale, select the scale in the Scales pane and then click

the button.

6. To remove a scale from the list, select it in the Scales pane, and then click the
button.

7. Click OK.
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Printing a map

To print a map:

1. Click the Printing tab to open the pane.

2. Click the Page Setup button to set up the page parameters; select Print Preview to
see a preview before you print the page, or Print to print the page directly.

3. If you want to print a particular part of the map, click the Set Area button and draw
a rectangle around the part of the map you want to print, and then click Print.

4. Click the Clear Area button to remove the set area.
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Saving a map

To save a map:

1. Choose File>Save Map As to open the Save pane.

2. Select a directory in which to save the file and give the file a name. The file must have
the .ivl suffix.

3. Select the Save Theme Only option, if you want to save the theme without the map
data.

4. Choose Save.
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Writing an application

Explains how to integrate a map component developed in the Map Builder into a Java™
application and how to prepare an application to accept and deploy a map component as a
Swing application.

In this section

Preparing to deploy a map component
Describes preparation needed to deploy a map component and lists possible applications.

Creating a read-only map application
Explains how to load and display a previously saved read-only map.

Creating a Simple Map Application
Explains how to create a map GUI and load data.

Creating a map application with APP-6a symbols
Explains how to create a map GUI, load data and create an APP-6a symbol manager.
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Preparing to deploy a map component

To build and deploy a JViews Maps for Defense map component, you must first consider the
manner of deployment and the functional type of the application:

♦ A Swing application

♦ An Eclipse® RCP application

♦ A thin client (browser base deployed)

♦ An applet

♦ A Java™ Web Start application

This section discusses deployment as a Swing application.
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Creating a read-only map application

The following application is provided in the directory <installdir> /jviews-maps86/
samples/loadmap/index.html as part of the JViews Maps for Defense demonstration
software. This is a simple case where the application loads a previously saved, read-only
map in.ivl format, and displays it in the Map Builder main window. A map of this type can
be built using the Map Builder or the JViews Maps for Defense API:

1. Import the required packages and classes:

import ilog.views.IlvManagerView;
import ilog.views.maps.IlvCoordinateSystemProperty;
import ilog.views.maps.beans.IlvJMouseCoordinateViewer;
import ilog.views.maps.beans.IlvMapLegend;
import ilog.views.maps.srs.coordsys.IlvGeographicCoordinateSystem;
import ilog.views.swing.IlvJManagerViewControlBar;
import ilog.views.swing.IlvJScrollManagerView;
import java.awt.BorderLayout;
import java.awt.Dimension;
import java.io.File;
import javax.swing.JFrame;

2. Create the basic building blocks of the Map Builder: create a frame containing the
map beans, set it to exit when the Close button is pressed, set up the beans, and
arrange the main window layout:

public class LoadMapDemo extends JFrame {
IlvManagerView view=new IlvManagerView();
IlvJScrollManagerView viewScroll=new IlvJScrollManagerView(view);
IlvJManagerViewControlBar viewToolbar = new IlvJManagerViewControlBar

();
IlvJMouseCoordinateViewer locator=new IlvJMouseCoordinateViewer();
IlvMapLegend legend=new IlvMapLegend();

public LoadMapDemo() {
super();
setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
viewToolbar.setView(view);
locator.setView(view);
legend.setView(view);
view.setSize(new Dimension(900, 450));
view.setKeepingAspectRatio(true);
viewScroll.setPreferredSize(view.getSize());
view.getManager().setNamedProperty(new

IlvCoordinateSystemProperty(IlvGeographicCoordinateSystem.WGS84));

getContentPane().add(viewToolbar,BorderLayout.NORTH);
getContentPane().add(viewScroll,BorderLayout.CENTER);
getContentPane().add(locator,BorderLayout.SOUTH);
getContentPane().add(legend,BorderLayout.LINE_START);
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loadFile("data/county.ivl"); //$NON-NLS-1$
}

3. Load the file into the manager of the view:

public void loadFile(String filename){
try {

IlvMapInputStream mapInput = new IlvMapInputStream(filename);
mapInput.read(view.getManager());
view.fitTransformerToContent();
pack();

} catch(Exception ex){
ex.printStackTrace();

}
}

4. Write the main method:

static public void main(String args[]) {
javax.swing.SwingUtilities.invokeLater(
new Runnable() {
public void run() {
final JFrame frame = new LoadMapDemo();
frame.pack();
frame.setVisible(true);

}
);

}
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Creating a Simple Map Application

The application example given in this section is the JViews Maps for Defense application
provided in <installdir> /jviews-maps86/samples/buildmap/index.html as part of the
IBM® ILOG® JViews Maps for Defense demonstration software.

The application:

♦ Creates a map GUI.

♦ Loads a shape file, an image file (a raster), and two data sources.

To create the application:

1. Import the following Java™ packages and classes:

import ilog.views.*;
import ilog.views.maps.*;
import ilog.views.maps.beans.*;
import ilog.views.maps.datasource.*;
import ilog.views.maps.format.image.IlvRasterBasicImageReader;
import ilog.views.maps.graphic.style.IlvPolylineStyle;
import ilog.views.maps.raster.datasource.IlvRasterDataSourceFactory;
import ilog.views.maps.srs.coordsys.IlvCoordinateSystem;
import ilog.views.maps.srs.coordsys.IlvGeographicCoordinateSystem;
import ilog.views.swing.IlvJManagerViewControlBar;
import ilog.views.swing.IlvJScrollManagerView;
import java.awt.*;
import java.beans.PropertyChangeEvent;
import java.beans.PropertyChangeListener;
import java.io.File;
import java.net.URL;
import javax.swing.JFrame;
import javax.swing.JTabbedPane;

2. Declare the public class BuildMapDemo, which defines the basic building blocks of the
Map Builder:

public class BuildMapDemo extends JFrame {

IlvManagerView view;// Map View
IlvJScrollManagerView viewScroll;// scroll arond the Map View
IlvJManagerViewControlBar viewToolbar; // zoom & selection toolbar
IlvLayerTreePanel layerTreePanel = new IlvLayerTreePanel(); // layer

visibility and properties control
IlvJCoordinateSystemEditorPanel csPanel;// coordinate system choice.

IlvJMouseCoordinateViewer locator;// coordinate information

3. Create a main frame and set it to exit when the Close button is pressed:
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public BuildMapDemo() {
super();
setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);

4. Create the main components of this example and set them up:

view=new IlvManagerView();
view.setManager(new IlvGrapher());
viewScroll=new IlvJScrollManagerView(view);
viewToolbar = new IlvJManagerViewControlBar();
csPanel=new IlvJCoordinateSystemEditorPanel();
viewToolbar.setView(view);
locator=new IlvJMouseCoordinateViewer();
locator.setView(view);
viewToolbar.add(locator);
view.setKeepingAspectRatio(true);
view.setBackground(new Color(80, 180, 240));
view.setAntialiasing(false);
view.setSize(new Dimension(900, 450));
viewScroll.setPreferredSize(view.getSize());
layerTreePanel.setView(view);

5. Georeference the view:

view.getManager().setNamedProperty(new
IlvCoordinateSystemProperty(IlvGeographicCoordinateSystem.WGS84));

6. Set up the Coordinate System panel to change projection according to panel selection
and to reload the map data:

csPanel.setCoordinateSystem(IlvCoordinateSystemProperty.GetCoordinateSystem

(view.getManager()));
csPanel.addCoordinateSystemChangeListener(new PropertyChangeListener(){

public void propertyChange(PropertyChangeEvent evt) {
IlvCoordinateSystem system = (IlvCoordinateSystem) evt.getNewValue

();
view.getManager().setNamedProperty(new IlvCoordinateSystemProperty(system)
);
clearManager();
loadData();
}
});

7. Build the map and configure the main window:

loadData();
getContentPane().add(viewToolbar,BorderLayout.NORTH);
getContentPane().add(viewScroll,BorderLayout.CENTER);
JTabbedPane tabPane=new JTabbedPane();
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tabPane.addTab("Map layers",layerTreePanel);
tabPane.addTab("Coordinate System",csPanel);
getContentPane().add(tabPane,BorderLayout.LINE_START);
getContentPane().add(locator,BorderLayout.SOUTH);
}

8. Load the sample map data into the application:

private void loadData() {
URL shpFile = findURL("data/world.shp");
URL gifFile = findURL("data/world.gif");
try {

// Create a data source for the shape file.
IlvShapeDataSource shpDataSource = new

IlvShapeDataSource(shpFile.getFile(), true);
shpDataSource.setCoordinateSystem(IlvGeographicCoordinateSystem.

WGS84);
// Create a raster reader for the .gif file (necessary to create the

datasource that follows).
IlvRasterBasicImageReader imageReader = new

IlvRasterBasicImageReader();
imageReader.loadImage(gifFile.getFile());
// Georeference this image (it covers the whole earth).
imageReader.setImageBounds(0,-Math.PI,Math.PI/2,Math.PI,-Math.PI/2)

;
// Create a datasource for the .gif file.

IlvMapDataSource imageDataSource =
IlvRasterDataSourceFactory.buildImageDataSource(
view.getManager(),imageReader,true,true,true,null);

// Insert it in the data source tree of the manager.
IlvMapDataSourceModel dataSourceModel =

IlvMapDataSourceProperty.GetMapDataSourceModel(view.getManager()
);

dataSourceModel.insert(shpDataSource);
dataSourceModel.insert(imageDataSource);
// Start reading the model (recursively start all data sources of

this
model).

dataSourceModel.start();
// Get the shape map layer used to display the data source.
IlvMapLayer shpLayer = shpDataSource.getInsertionLayer();
shpLayer.setName("ESRI layer (world.shp)");
IlvMapLayer imageLayer = imageDataSource.getInsertionLayer();
// Insert it in the Map layer tree of the manager.
IlvMapLayerTreeModel ltm =

IlvMapLayerTreeProperty.GetMapLayerTreeModel(view.getManager());

ltm.addChild(null, shpLayer);
ltm.addChild(null, imageLayer);
// Set up the shape layer style.
shpLayer.getStyle().setAttribute(IlvPolylineStyle.FOREGROUND,Color.
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black);
shpLayer.getStyle().setAttribute(IlvPolylineStyle.BACKGROUND,new

Color(1,1,1,0.25f));
imageLayer.setName("Image layer (world.gif)");

} catch (Exception e1) {
e1.printStackTrace();

}

9. Fit the data source to the size of the application view:

view.fitTransformerToContent();
view.repaint();
}

10. Write the main method:

static public void main(String args[]) {
javax.swing.SwingUtilities.invokeLater(
new Runnable() {
public void run() {
final JFrame frame = new BuildMapDemo();
frame.setTitle("Simple map building demo");
frame.pack();
frame.setVisible(true);

}
);

}

11. Remove all the layers from the manager and clear the associated model when the
coordinate system changes:

private void clearManager() {
IlvManager manager = view.getManager();
IlvMapLayerTreeModel model =

IlvMapLayerTreeProperty.GetMapLayerTreeModel(manager);
model.clearAllObjects();
while (manager.getLayersCount() > 0) {
IlvManagerLayer layer = manager.getManagerLayer(0);
manager.removeLayer(0, false);

}
manager.removeNamedProperty(IlvMapLayerTreeProperty.NAME);
manager.removeNamedProperty(IlvMapDataSourceProperty.NAME);
manager.removeNamedProperty(IlvAreasOfInterestProperty.NAME);
}

}
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Creating a map application with APP-6a symbols

The application example given in this section is the JViews Maps for Defense application
provided in <installdir> /jviews-maps-defense86/samples/app6a/index.html as part
of the IBM® ILOG® JViews Maps for Defense demonstration software.

The application:

♦ Creates a map GUI

♦ Loads a shape file

♦ Creates an APP-6a symbol manager

To create the application:

1. Import the following Java™ packages and classes:

import ilog.views.IlvGrapher;
import ilog.views.IlvManagerView;
import ilog.views.IlvPoint;
import ilog.views.maps.*;
import ilog.views.maps.beans.*;
import ilog.views.maps.projection.IlvCoordinatePanelFactory;
import ilog.views.maps.datasource.*;
import ilog.views.maps.symbology.swing.IlvSymbologyTreeView;
import ilog.views.maps.graphic.style.IlvPolylineStyle;
import ilog.views.maps.srs.coordsys.*;
import ilog.views.sdm.IlvSDMEngine;
import ilog.views.sdm.IlvSDMModel;
import ilog.views.sdm.renderer.*;
import ilog.views.swing.IlvJManagerViewControlBar;
import ilog.views.swing.IlvJScrollManagerView;
import java.awt.BorderLayout;
import java.awt.Color;
import java.awt.Dimension;
import java.beans.PropertyChangeEvent;
import java.beans.PropertyChangeListener;
import java.net.URL;
import javax.swing.BorderFactory;
import javax.swing.JFrame;
import javax.swing.JTabbedPane;
import simulation.SimulationController;

2. Declare the public class App6aDemo, which defines the basic building blocks of the
Map Builder:

public class App6aDemo extends JFrame {
IlvManagerView view;// Map view.
IlvJScrollManagerView viewScroll;// Scroll around the Map View.
IlvSymbologyTreeView symbPanel;// Symbology control panel.
IlvJManagerViewControlBar viewToolbar; // Zoom & selection toolbar.
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IlvJCoordinateSystemEditorPanel csPanel;// Coordinate system choice.
IlvJMouseCoordinateViewer locator;// Coordinate information.

3. Create a main frame and set it to exit when the Close button is pressed:

public App6aDemo() {
super();
setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);

4. Create the main components of the Map Builder and set them up:

view=new IlvManagerView();
view.setManager(new IlvGrapher());
viewScroll=new IlvJScrollManagerView(view);
viewToolbar = new IlvJManagerViewControlBar();
csPanel=new IlvJCoordinateSystemEditorPanel();
viewToolbar.setView(view);
locator=new IlvJMouseCoordinateViewer();
locator.setView(view);
viewToolbar.add(locator);
view.setKeepingAspectRatio(true);
view.setBackground(new Color(80, 180, 240));
view.setAntialiasing(false);
view.setSize(new Dimension(900, 450));
viewScroll.setPreferredSize(view.getSize());

5. Create and set up the symbology:

final IlvSDMEngine symbology = new IlvSDMEngine();
URL symbolCss = App6aDemo.class.getResource("data/app6.css");
symbology.setReferenceView(view);
symbology.setGrapher((IlvGrapher) view.getManager());

try {
symbology.setStyleSheets(new String[] { symbolCss.toString()});
}

catch (IlvSDMException e) {e.printStackTrace();
}

/* show this symbology on the GUI */
symbPanel = new IlvSymbologyTreeView(symbology);
IlvApp6aSymbologyTreeViewActions app6Actions = new

IlvApp6aSymbologyTreeViewActions();
app6Actions.setLatLonPicker(new IlvCoordinatePanelFactory.

CoordPointInputPanel(view,IlvDisplayPreferencesProperty.
GetDisplayPreferences(view.getManager()).getCoordinateFormatter()));

symbPanel.setSymbologyTreeViewActions(app6Actions);

6. Georeference the view:

view.getManager().setNamedProperty(new
IlvCoordinateSystemProperty(IlvGeographicCoordinateSystem.WGS84));
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7. Set up the Coordinate System pane to reload symbols:

csPanel.setCoordinateSystem(IlvCoordinateSystemProperty.
GetCoordinateSystem(view.getManager()));

csPanel.addCoordinateSystemChangeListener(new PropertyChangeListener(){
public void propertyChange(PropertyChangeEvent evt) {

IlvCoordinateSystem system = (IlvCoordinateSystem) evt.getNewValue();

view.getManager().setNamedProperty(new
IlvCoordinateSystemProperty(system));
symbology.loadData();

}
});

8. Show the symbology in the Map Builder:

symbPanel.setSymbology(symbology);

9. Load the “world” shape file:

loadInitialData();

10. Configure the Map Builder main window:

getContentPane().add(viewToolbar,BorderLayout.NORTH);
getContentPane().add(symbPanel,BorderLayout.LINE_END);
getContentPane().add(viewScroll,BorderLayout.CENTER);
JTabbedPane tabPane=new JTabbedPane();
tabPane.addTab("Coordinate System",csPanel);
getContentPane().add(tabPane,BorderLayout.LINE_START);
getContentPane().add(locator,BorderLayout.SOUTH);
}

11. Load the sample raw data into the application:

private void loadInitialData() {
URL shpFile = App6aDemo.class.getResource("data/World_Countries.shp")

;
try {

// Create a data source for the shape file.
IlvShapeDataSource reader = new IlvShapeDataSource(shpFile.getFile(),
true);
reader.setCoordinateSystem(IlvGeographicCoordinateSystem.WGS84);
// Insert it in the data source tree of the manager. This optional step
is

necessary to retrieve the data when, for example, a coordinate system

change occurs.
IlvMapDataSourceModel dsm =

IlvMapDataSourceProperty.GetMapDataSourceModel(view.getManager());
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dsm.insert(reader);
// Get the Map Layer used to display the data source and insert it in the

Map Layer tree of the manager.
IlvMapLayer layer = reader.getInsertionLayer();
layer.setName("World data");
IlvMapLayerTreeModel ltm =

IlvMapLayerTreeProperty.GetMapLayerTreeModel(view.getManager());
ltm.addChild(null, layer);
// Start reading.
reader.start();
// Set up the layer style.
layer.getStyle().setAttribute(IlvPolylineStyle.FOREGROUND,Color.black);
layer.getStyle().setAttribute(IlvPolylineStyle.BACKGROUND,new

Color(1,1,0.8f));
} catch (Exception e1)
{e1.printStackTrace();

}

12. Fit the data source to the size of the Map Builder view:

view.fitTransformerToContent();
}

13. Write the main method:

static public void main(String args[]) {
javax.swing.SwingUtilities.invokeLater(
new Runnable() {
public void run() {
final JFrame frame = new App6aDemo();
frame.pack();
frame.setVisible(true);

}
);

}

Instead of loading raw data (the shape file in the above example), you can build your map
and save it as an IVL file using theMap Builder. Refer to Creating a read-only map application
for further details.

Refer to the samples provided with IBM® ILOG® JViews Maps for Defense for examples of
how to create applications that use maps.
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