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P R E F A C E
About This Manual

This manual describes the Prototypes package of IBM® ILOG® Views.

What You Need to Know

This manual assumes that you are familiar with the PC or UNIX® environment in which you 
are going to use IBM® ILOG® Views, including its particular windowing system. Since 
ILOG Views is written for C++ developers, the documentation also assumes that you can 
write C++ code and that you are familiar with your C++ development environment so as to 
manipulate files and directories, use a text editor, and compile and run C++ programs.

Manual Organization

The manual contains the following chapters:

◆ Chapter 1 introduces the concepts of prototypes.

◆ Chapter 2 descibes the windows, panels, and the commands of IBM® ILOG® Views 
Studio with the Prototypes extension.

◆ Chapter 3 explains how to use IBM ILOG Views Studio to create your prototypes by 
composing graphic objects and assigning behaviors to them.
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◆ Chapter 4 describes the classes and methods used to manipulate prototypes and shows 
how to structure your application to benefit fully from BGOs. It then shows how to use 
prototypes created in IBM ILOG Views Studio in your C++ applications.

◆ Chapter 5 lists the behaviors that are predefined in the Prototypes library.

Notation

Typographic Conventions

The following typographic conventions apply throughout this manual:

◆ Code extracts and file names are written in courier typeface.

◆ Entries to be made by the user are written in courier italics.

◆ Some words in italics, when seen for the first time, may be found in the glossary at the 
end of this manual.

Naming Conventions

Throughout this manual, the following naming conventions apply to the API.

◆ The names of types, classes, functions, and macros defined in the IBM® ILOG® Views 
libraries begin with Ilv.

◆ The names of classes as well as global functions are written as concatenated words with 
each initial letter capitalized. 

class IlvDrawingView;

◆ The names of virtual and regular methods begin with a lowercase letter; the names of 
static methods start with an uppercase letter. For example:

virtual IlvClassInfo* getClassInfo() const;

static IlvClassInfo* ClassInfo*() const;
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C H A P T E R
1

Introducing the Prototypes Package

The Prototypes package lets you create custom domain-specific graphic objects called 
Business Graphic Objects (BGOs). These objects are created interactively, without writing 
C++ code, using the Prototypes extension of IBM ILOG Views Studio.

This section introduces the concepts of BGOs and explains the classes and methods used to 
manipulate the prototypes created with IBM ILOG Views Studio.

An Overview of the Prototypes Package

This section provides an overview of how to use the Prototypes package of 
IBM® ILOG® Views to create BGOs. Because IBM ILOG Views BGOs are based on the 
prototype design pattern, they are often referred to as prototypes.

The following items are described in this section as an introduction to the Prototypes 
package:

◆ Business Graphic Objects

◆ Creating BGOs Using the Prototypes Extension of IBM ILOG Views Studio

◆ Using Prototypes in Applications

◆ When Should You Use Prototypes?
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◆ The Prototype Design Pattern

◆ Specifying Graphic and Interactive Behavior Using Accessors

Business Graphic Objects 

Application developers often need to define custom graphic objects to represent domain-
specific application objects that the user is able to interact with. The IBM® ILOG® Views 
Prototypes package provides a simple and efficient solution for building such business 
graphic objects (BGOs). BGOs are created using the Prototypes extension of 
IBM ILOG Views Studio. Creating a BGO requires no coding. It is created by performing 
three basic steps:

1. Define the application interface of the BGO as a set of typed attributes that represent the 
domain of your object. For example, a boiler object representing a power plant boiler can 
have Temperature, Capacity, Level, Input valve, and Output valve attributes.

2. Define the look of your objects using basic IBM ILOG Views graphic objects, such as 
lines, text, and images. You can also include other BGOs to build structured objects. For 
example, the boiler object could be represented by a rectangle, the temperature and level 
by gauges inside the rectangle, and input and output valves by toggle buttons inside the 
rectangle. 

3. Attach behaviors to your graphic objects to define how they should represent the state of 
an application object and how they should react to user events. You can dynamically 
change the attributes of a shape, animate the object, and connect BGOs together to 
reflect the state of the objects in the user interface. For example, attaching a Fill behavior 
to the Level attribute ensures that the level of the boiler is kept synchronized with its 
graphic representation.

You can then create instances of your BGOs and use them in managers or containers just as 
you would do with basic IBM ILOG Views graphic objects. You can link application objects 
to their corresponding BGO. The display, synchronization, and user interaction is handled 
by the Prototypes package. You can edit and modify a BGO at any time: its instances will be 
automatically updated.

Creating a powerful, direct-manipulation interface for domain-specific objects becomes as 
easy as creating a form-based interface for the same objects, but the resulting interface is 
much more appealing and explicit to the user.

Figure 1.1 shows examples of application panels built with prototypes.
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An Overview of the Prototypes Package
Figure 1.1

Figure 1.1  Examples of Prototype Applications

Creating BGOs Using the Prototypes Extension of IBM ILOG Views Studio 

When you use IBM ILOG Views Studio to create your BGOs, you can:

◆ Design the graphic appearance of your BGOs by assembling basic graphic objects.

◆ Define the graphic behavior and interactive aspects of your BGOs by attaching 
predefined behaviors to them, or by writing scripts.

◆ Store the BGOs in libraries as prototype objects that can be reused, modified, and 
instantiated in panels. Since BGOs are mostly used as prototypes, the terms prototype 
and BGOs are used interchangeably.

◆ Add instances of your prototypes to managers or containers.

◆ Test the behavior of your prototypes and the panels that contain them.

All these operations are performed in WYSIWYG (what you see is what you get) mode 
without coding in C++.

Using Prototypes in Applications 

You can load IBM® ILOG® Views files containing instances of your prototypes into a 
manager or a container the same way you load files containing basic IBM ILOG Views 
graphic objects. You can also create instances of prototypes, attach them to application 
objects, and place them in managers or containers.

Prototypes are not subclasses of IlvGraphic. They are groups of graphic objects contained 
in an object of the IlvGroup class. The definition of a prototype is stored in a file so you do 
not need to recompile your application if you modify a prototype.
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To place prototype instances in an IlvManager or an IlvContainer you must embed 
them in a specific subclass of IlvGraphic called IlvProtoGraphic. When you use 
IBM ILOG Views Studio to place the prototypes in the manager or container, 
IBM ILOG Views Studio creates the encapsulating IlvProtoGraphic for you. You can 
manipulate IlvProtoGraphic the same way as an IlvGraphic. You can use the 
IlvGroupHolder class to retrieve the prototype instances of a given view (container or 
manager) and modify the properties of your prototype instances according to the application 
values you want to display.

When Should You Use Prototypes?

To define a BGO, you can either use prototypes or write the C++ code for a subclass of 
IlvGraphic using direct calls to the IBM ILOG Views methods to draw your object. The 
use of prototypes is therefore an alternative to direct coding. 

The prototype approach has the following advantages:

◆ Very short development time that permits an iterative GUI design process. 

◆ Easy maintenance and debugging, since there is a clear separation between the 
implementation of the application and the implementation of the user interface.

◆ Complete integration in ILOG Views Studio. The user interface designer draws instead 
of programming.

◆ Few C++ programming skills required.

As a result, the task of designing the graphical appearance of your objects can be delegated 
to non-programmers. For example, graphic designers may be more suited to the task and will 
find in IBM ILOG Views Studio a drawing program comparable to the graphic tools they are 
accustomed to.

Prototypes have been designed and implemented with a strong emphasis on efficiency. 
Although prototypes may not always be as efficient as direct C++ coding (because they are 
based on composition rather than derivation), applications can create thousands of prototype 
instances without encountering performance problems.

The Prototype Design Pattern

The process of creating BGOs is based on the prototype design pattern. You can group basic 
objects and use the group as a model (or prototype) from which you can create clones (or 
instances). When the prototype is modified, all its instances are automatically updated with 
this modification.

Using the prototype design pattern, it is possible to create complex graphic objects using a 
WYSIWYG editor and to use the objects immediately to build application panels.
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An Overview of the Prototypes Package
Specifying Graphic and Interactive Behavior Using Accessors 

BGOs define a set of public attributes. These attributes correspond to the application 
programming interface of the BGO. You can change the appearance of the BGO by setting 
its attributes to given values. You can also query any of these attributes at any time. 

You can attach several behaviors to each of these attributes. A behavior defines a side effect 
that is executed each time the attribute is changed or queried. For example, you can attach a 
Condition behavior to a Temperature attribute. Each time the temperature is changed, the 
condition is evaluated and the graphic appearance of the object changes. The Condition 
behavior can set the color of an object to red if the temperature is above a predefined 
threshold. You can also attach interactive behaviors to your BGO— for example, you can 
specify that the temperature should be adjusted when the user clicks on the thermometer.

Attributes and behaviors are implemented by means of accessors (objects of the class 
IlvAccessor). Accessors can be attached to graphic objects and can:

◆ Store attribute values

◆ Perform side effects

◆ Track user events

The accessor mechanism allows you to define complex behaviors. You can combine 
accessors to re-create the logic of an entire application. However, it is strongly 
recommended that you use the accessor mechanism only to specify the graphic and 
interactive behaviors of your objects. Do not use the accessor mechanism to implement 
features of the application domain. By doing this, you maintain the sound modular aspects of 
your program.

Taken as a whole, the accessors of a BGO define a data flow graphic program. Data flow 
programming is as powerful as the more classical control flow model used in programming 
languages such as C++ or Java. However, data flow programming is better adapted to the 
definition of small, graphic oriented programs.

To facilitate the definition of complex graphic behaviors, the Script accessor allows you to 
define graphic or interactive behavior as an IBM ILOG Script program. This allows more 
complex computations to be performed and gives access to the entire suite of 
IBM ILOG Script features.
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C H A P T E R
2

The User Interface and Commands

This chapter introduces you to the Prototypes extension of IBM® ILOG® Views Studio, an 
extension designed to facilitate the development of fully interactive graphical user interfaces 
of domain-specific application objects.

You can find information on the following topics:

◆ Overview

◆ The Main Window

◆ The Palettes Panel

◆ Group Inspector Panel

◆ Prototypes Extension Commands

Overview

The Prototypes extension of IBM® ILOG® Views Studio allows you to define complex 
graphic objects, called prototypes, by interactively assembling IBM® ILOG® Views 

Note: The chapters concerning the use of the Prototypes extension of IBM ILOG Views 
Studio assume that you are familar with the information in the IBM ILOG Views Studio 
User’s Manual.
I B M  I L O G  V I E W S  P R O T O T Y P E S  V 5 . 3  —  U S E R ’ S  M A N U A L 13



graphic objects. Behaviors can be attached to these prototypes to define the whole graphical 
and interactive part of your application.

The prototypes can be instantiated and used as basic building blocks for application 
windows, object inspectors, or direct-manipulation interfaces, that is, when each application 
object is directly tied to an interactive graphical representation.

IBM ILOG Views Studio with the Prototypes extension defines a new workflow to build 
highly interactive user interfaces: you develop the interactive part of your application in a 
graphical editor, store it in libraries, and then link it with your core functionality written in 
C++.

Launching IBM ILOG Views Studio With the Prototypes Extension

If you have installed the 2D Graphics Pro package, the Prototypes extension is automatically 
loaded when IBM ILOG Views Studio is launched. The extension is called smproto in the 
configuration file. A compatibility extension enabling now deprecated features can also be 
used: smoldpro. This manual describes only the features of the smproto extension. To 
install or uninstall these extensions, see the section on Loading Plug-Ins in Introducing 
IBM ILOG Views Studio.

The Main Window

When you launch the application, the Main window of IBM® ILOG® Views Studio appears 
as follows:
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The Main Window
Figure 2.1        

Figure 2.1  IBM ILOG Views Studio Main Window with Prototypes Extension at Start-up

The Main window appears much as it does when only the IBM ILOG Views Studio 
Foundation package is installed. However, you will notice that with the Protoypes package 
you have access to additional buffer windows, additional palettes in the Palettes panel, and 
additional items in the menu bar and toolbars of the interface. These are now briefly 
presented.

Buffer Windows

Applications and panels are created in the buffer windows displayed in the Main window. 
The current buffer type is shown at the bottom of the Main window.
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With the Prototypes extension of IBM ILOG Views Studio, you can edit the following types 
of buffers:

◆ 2D Graphics

◆ Grapher

◆ Prototypes

An empty 2D Graphics buffer is displayed by default when you launch IBM ILOG Views 
Studio. 

As you switch between the buffers currently loaded in the Main window, you will notice that 
each buffer type has its own set of editing modes. When you change the current buffer, the 
editing modes available as icons in the toolbar change accordingly. 

The 2D Graphics Buffer Window

The 2D Graphics buffer is the default for the Foundation package. It allows you to edit the 
contents of an IlvManager or an IlvContainer. It uses an IlvManager to load, edit, and 
save objects. 

To create a new 2D Graphics buffer window:

1. Choose New from the File menu.

2. Then choose 2D Graphics from the submenu that appears. 

To open this window, you can also execute the NewGraphicBuffer command from the 
Commands panel, which you can display by choosing Commands from the Tools menu.

When you open a .ilv file that was generated by an IlvManager, a 2D Graphics buffer 
window is automatically opened.

The Grapher Buffer Window

The Grapher buffer window lets you edit the contents of an IlvGrapher. It uses an 
IlvGrapher to load, edit, and save nodes and links.

To create a new Grapher buffer window:

1. Choose New from the File menu.

2. Then choose Grapher from the submenu that appears. 

To open this window, you can also execute the NewGrapherBuffer command from the 
Commands panel, which you can display by choosing Commands from the Tools menu.

When you open a .ilv file that was generated by an IlvGrapher, a Grapher buffer 
window is automatically opened.
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The Main Window
The Prototypes Buffer Window

The Prototypes buffer window is used to create and manipulate your prototypes. Graphic 
objects, and Prototypes, can be dragged from a Palettes panel to an active Prototypes buffer 
window.

To open a new Prototypes buffer window:

1. Choose New from the File menu.

2. Then choose Prototype from the submenu that appears. 

Alternatively, when you double-click a Prototype in a Prototypes palette, a Prototypes buffer 
window is automatically opened to allow you to modify it or inspect its attributes and 
behaviors.

The Menu Bar

When the Prototypes package is installed, additional commands are available through the 
menu bar in the Main window.

Figure 2.2

Figure 2.2  IBM ILOG Views Studio Prototypes Extension Menu Bar

The following tables summarize the additional commands that you can execute through the 
menu bar. For details on these commands, see Prototypes Extension Commands, where they 
are listed in alphabetical order.
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File Menu Commands 

Draw Menu Commands

Tools Menu Command

View Menu Command

The Action Toolbar

The Action toolbar remains unchanged from the Foundation package. 

Menu Item Command

New > Prototype NewPrototypeEditionBuffer

New > Prototype Library... NewProtoLibrary

New > Prototype Grapher NewPrototypeGrapherBuffer
Note: This is a deprecated command and is 
provided purely for compatibility with earlier 
versions.

Save Prototype Library as... SaveProtoLibraryAs

Close Prototype Library CloseProtoLibrary

Menu Item Command

Group GroupIntoGroup

Edit Prototype EditPrototype

Delete Prototype DeletePrototype

Menu Item Description 

Group Inspector This opens the Group Inspector of the currently 
selected prototype instance or IlvGroup object.

Menu Item Command 

Toggle Animation Timers ToggleTimers
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The Palettes Panel
The Editing Modes Toolbar

    

The Prototypes extension of IBM ILOG Views Studio contains an editing mode in addition 
to the regular IBM ILOG Views Studio editing modes:

Group Connection Mode 

Use the Group Connection mode for connecting the values of prototype instances. 
The Connection mode is used to define connections between prototype 

instances.See Connecting Prototype Instances.

The Palettes Panel

The Prototypes palette is included in the Palettes panel, as shown in Figure 2.3. It shows the 
various prototype libraries that you have defined or loaded, and allows you to instantiate 
prototypes by dragging their icons to Prototype buffers. Prototypes are manipulated like 
other graphic objects. Each library defines its own panel in the Palettes panel.
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Figure 2.3

Figure 2.3  The Palettes Panel Showing the samples Prototype Library

When the Prototypes extension is installed, IBM ILOG Views Studio loads the following 
libraries at start-up:  

To open one of these prototype libraries, go to the upper pane of the Palettes panel and click 
the name in the Prototypes palette.

Library Description

samples Sample library loaded at start-up.

sources Prototypes containing value sources.

output Prototypes containing gadgets and defining output values.

lcd LCD displays (one digit and four digits).

operations Prototypes that can be used to connect prototypes and execute 
operations on their values.

script Prototypes that use script accessors.
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Group Inspector Panel
You can look at any prototype definition by double-clicking the prototype icon. This will 
load the prototype into a Prototype buffer window and open a Group Inspector panel.

The <ILVHOME>/samples/protos directory provides other samples of how to use 
prototypes.

Group Inspector Panel

The Prototypes extension provides an additional panel to let you define the interface and the 
graphic and interactive behaviors of your prototypes, as shown in Figure 2.4. It can also be 
used to customize groups and prototype instances.

Figure 2.4 

Figure 2.4  The Group Inspector Panel

Access to Panel

The panel is accessed by one of the following methods:

◆ Choosing Group Inspector from the Tools menu.

◆ Creating a new Prototype buffer window.

◆ Double-clicking a prototype in a Prototypes buffer window.

◆ Choosing Commands from the Tools menu, selecting the ShowGroupInspector 
command in the list, and clicking Apply. 

Group Inspector Elements

The Group Inspector panel has four notebook pages: 

Note: When you load a panel file that contains prototype instances, the required prototype 
libraries are automatically loaded in the Prototypes palette.
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◆ The Attributes page is used to define the attributes of a prototype and to customize 
prototype instances.

◆ The Graphics page is used to display and edit the graphic objects composing a prototype. 

◆ The Behavior page is used to define the graphic behavior of a prototype.

◆ The Interaction page is used to define the interactive behaviors of a prototype.

Full context-sensitive hypertext help is available when you click Help on the inspector. This 
help page can be hidden by clicking the Close Help button. 

The features of the Group Inspector panel are detailed in Creating and Using Prototypes.

 Prototypes Extension Commands

This section presents an alphabetical listing of the additional, predefined commands that are 
available in the Prototypes extension of IBM® ILOG® Views Studio. (All of the 
IBM ILOG Views Studio Foundation commands are available as well.) For each command, 
it indicates its label, how to access it if it is accessible other than through the Commands 
panel, the category to which it belongs, and what it is used for.

To display the Commands panel, choose Commands from the Tools menu in the Main 
window or click the Commands icon  in the Action toolbar.

CloseProtoLibrary 

ConvertProtoManager 

Label Close Prototype Library

Path Main window: File menu

Category prototypes

Action Closes the prototype library currently displayed in the Palettes panel.

Label Convert ProtoManager

Path Convert ProtoManager: Edit menu
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Prototypes Extension Commands
DeletePrototype 

EditPrototype 

GroupIntoGroup 

Category prototypes

Action Creates a new regular Studio buffer that copies the content of the currently 
active Prototype instance buffer. This command uses the 
IlvPrConvertProtoManager function to perform the conversion. It is 
meant to help in switching from Views 3.1 prototypes to the more recent API.

Label Delete Prototype

Path Main window: Edit menu

Category prototypes

Action Removes the selected prototype from its library.

Label Edit Prototype

Path Main window: Edit menu

Category prototypes

Action Edits the selected prototype in a new Prototype buffer window, and opens the 
Group Inspector panel for the prototype instance.

Label IlvGroup

Path Main window: Draw menu > Group

Category prototypes

Action Groups the selected objects into an IlvGroup.
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NewProtoLibrary 

NewPrototype

NewPrototypeEditionBuffer 

NewPrototypeGrapherBuffer 

Label Prototype Library...

Path Main window: File menu > New

Category prototypes

Action Creates a new prototype library. This library is visible in the Palettes panel. 
A file selector dialog box is opened to choose the library file (.ipl).

Label New Prototype

Path Main Window: File menu > New

Category prototypes

Action Creates a buffer window used to draw and edit prototypes.

Note: This is a deprecated command and is provided purely for compatibility with earlier 
versions.

Label Prototype

Path Main window: File menu > New

Category prototypes

Action Creates a buffer window used to draw and edit prototypes.

Label Prototype Grapher

Path Main window: File menu > New
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Prototypes Extension Commands
OpenProtoLibrary 

SaveProtoLibraryAs 

SelectGroupConnectionMode 

Category prototypes

Action Allows you to create an instance of an IlvProtoGrapher class. 

Note: This is a deprecated command and is provided purely for compatibility with earlier 
versions.

Label Open Prototype Library...

Path Main window: File menu > Open 

Category prototypes

Action Opens a prototype library file. A selection dialog box is opened to choose the 
.ipl file to open.

Label Save Prototype Library As...

Path Main window: File menu

Category prototypes

Action Saves a copy of the currently selected prototype library to a different file.

Label Group Connection

Path Editing Modes toolbar

Category prototypes

Action Selects the Group Connection mode.
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SelectGroupSelectionMode 

SelectNodeSelectionMode 

ShowGroupEditor 

ToggleTimers 

Label Group Selection

Path Editing Modes toolbar

Category prototypes

Action Selects the Group Selection mode.

Label Node Selection

Path Editing Modes toolbar

Category prototypes

Action Selects the Node Selection mode in a Prototype buffer. This mode lets users 
select and inspect graphic nodes while editing a prototype.

Label Group Inspector

Path Tools menu

Category prototypes

Action Shows/hides the Group Inspector panel.

Label Toggle Animation Timers

Path View menu
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Prototypes Extension Commands
UngroupIlvGroups 

Category prototypes

Action Turns on or off the animation timers of the prototype's animation accessors, 
thereby allowing you to edit the prototype and then test its behavior.

Label Ungroup

Path Main window: Draw menu

Category prototypes

Action This command replaces the generic Ungroup command to take into account 
IlvGroup objects.
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C H A P T E R
3

Using IBM ILOG Views Studio to Create
BGOs

This chapter describes how the Prototypes extension lets you create composite graphic 
objects and assign them an application interface, a graphic behavior, and an interactive 
behavior through interactive, point-and-click editing. These graphic objects can then be 
linked to domain-specific objects following the application interface, providing full 
WYSIWYG, direct-manipulation editing of the domain objects.

You can find information on the following topics:

◆ Creating and Using Prototypes

◆ Loading and Saving Prototype Libraries

◆ Creating and Editing Prototype Instances in Panels

◆ Connecting Prototype Instances

Note: The chapters concerning the use of the Prototypes extension of IBM ILOG Views 
Studio assume that you are familar with the information in the IBM ILOG Views Studio 
User’s Manual.
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Creating and Using Prototypes

The following topics related to creating and using prototypes are presented in this section:

◆ Creating a Prototype Library

◆ Creating a Prototype

◆ Defining the Attributes

◆ Drawing the Prototype

◆ Defining Graphic Behaviors

◆ Defining Interactive Behaviors

◆ Testing Your Prototype

◆ Saving a Prototype

Creating a Prototype Library

You will probably want to create your BGOs in libraries so that you can retrieve and 
manipulate them all together. 

To create a new prototype library, do the following:

1. From the File menu in the Main window, choose the command New > Prototype Library.

A file selector appears.

2. Select a directory for which you have write permission and enter the name of the new 
library (it must have a .ipl extension). Click Save. 

A new page, corresponding to the library you have just created, appears in the Palettes 
panel.

Creating a Prototype

These are the tasks involved in creating a prototype:

◆ Defining the attributes of your prototype in the Interface page of the Group Inspector 
panel.

◆ Drawing the graphic elements that make up the prototype in the Prototype buffer 
window.

◆ Defining the graphic behavior of the prototype using the Group Inspector panel

◆ Defining the interactive behavior of the prototype using the Group Inspector panel.
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Creating and Using Prototypes
These tasks can be interleaved: at any point you can add, edit, or remove attributes, graphic 
elements, or behaviors of the prototype.

Your prototype is created in a prototype buffer window. Before beginning these tasks: 

1. Open a Prototype buffer window by selecting New > Prototype from the File menu. 

2. Display the Group Inspector panel by selecting the Group Inspector from the Tools 
menu.

Defining the Attributes

Use the following procedure to define and edit the external attributes (or “properties”) of 
your prototype or group. (Properties determine how you will access your prototype or group 
from your application or from other objects.)

1. Open the Interface page of the Group Inspector Panel. This page allows you to define a 
set of attributes, giving each of them a type and a default value:

2. Choose Edit > New Attribute or Ctrl+N to add an attribute.

A new row "Unnamed" appears in the table.

3. To specify the name of the attribute, click the box Unnamed. Enter a name for this 
attribute. This name must be unique to avoid ambiguities; it is used to access the 
behavior of this attribute.

4. To specify the type of the attribute, click twice on the adjacent Type combo box (or press 
F2 if using only the keyboard). Select the pull-down menu, which will let you specify a 
type.

All attributes are typed: each type indicates the kind of values that can be assigned to the 
attribute, which helps determine its meaning. The types available are: 
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● Value - The attribute holds a value that can be set or queried directly (a string, a color, 
an integer, and so on). When you set an attribute to a given value type, the combo box 
will display this type directly.

● Reference - A reference to another internal attribute of the group. For instance, 
creating an attribute named "temperature", and having it reference the "value" 
attribute of a "slider" graphic object allows you to access the "value" internal attribute 
of the slider under the more appropriate name of "temperature", which is helpful if the 
group is to represent a thermometer. This is equivalent to a pointer or an alias in a 
programming language. When you have set the type to reference, the referenced 
attribute, prefixed with “^”, appears in the combo box that describes the attribute type.

● Grouping of attributes - All subattributes in the group bearing the name of the 
attribute will be addressed collectively and assigned the same value. For instance, 
creating an attribute named "foreground" and giving it the type "group" creates an 
attribute that will set the foreground of all objects contained in the group to the same 
value.

● Script - A script is executed. This script should return a value, which defines the 
attribute. Use the Behavior page to change the name of the function that defines the 
value. The name of the function, followed by “()”, appears when you choose this type 
of attribute.

● NoType - Some attributes can be purely functional, and therefore untyped.

5. Enter a default value for the attribute in the Value column of the attribute.

6. To set other parameters of the attribute, use the buttons on the right side of the page. 
When the button is released, the property is set:

● Public (button P in the inspector) - The attribute is visible by outside objects. 
Attributes are public by default, but you can hide those attributes that are only used to 
perform internal computations.

● Persistent (button R in the inspector) - The attribute value will be stored when the 
group is saved, allowing the last value set by the user to be maintained. By default, 
attributes are persistent. To optimize reading and writing, or to always restore the 
attributes to the original state of the prototype when a file is read, you can set them to 
non-persistent.

● Notifying (button N in the inspector) - When this is set, the attribute can notify other 
attributes that it has changed its value and, therefore, enable other attributes to update 
themselves. See section Notify.

Note: If an attribute has neither a type nor a behavior, it cannot exist. Therefore, setting 
a type of "none" to an attribute after creating it is equivalent to deleting the attribute. 
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Creating and Using Prototypes
7. Repeat steps 2 through 6 for each attribute you wish to add to provide a description of the 
interface for your prototype.

Using the Edit Menu on the Interface Page

When specifying the interface of your prototype, you can also: 

◆ Import the interface of another Prototype to add predefined attributes and behaviors from 
that prototype: 

Select Edit > Delegate To Prototype and choose from the available list the prototype 
whose attributes you want to inherit. 

A new attribute is created with the inherited attributes shown grayed-out in the table. 
You cannot directly edit these inherited attributes, but you can reference them through 
other attributes. 

Some inherited attributes may already reference other attributes or graphic nodes, and 
therefore you may find that not every prototype can be imported into another prototype. 

◆ Order the attributes:

Select an attribute and choose Edit > Move Item Up or Edit > Move Item Down.

◆ Delete an attribute:

Select the attribute and choose Edit > Delete.

◆ Cut/Copy/Paste: You can copy or cut a whole attribute and its behavior by selecting the 
first line of an attributes tree and selecting Edit > Copy or Edit > Cut. You can paste the 
content of the attribute's clipboard by first selecting a line where you want the attribute to 
be inserted, and then selecting Edit > Paste.

Using the View Menu on the Interface Page

This menu on the Interface page presents alternative views of the attributes of your group or 
prototype, and allows you to select which types of attributes you want to edit for a given 
group or prototype:

◆ Interface - Lets you access and edit all the attributes defined for the group or prototype. 
This is the default presentation.

◆ Public Attributes - Shows only the public attributes of the prototype, those that can be 
seen by other objects and by the application.

◆ Modified Values - Lists the values of a prototype instance that differ from its prototype. 
These values will be saved together with the prototype instance.

◆ All Values - Lists all the prototype values and subvalues. These values can be modified, 
but this does not mean that the modifications will be saved with the prototype if some 
other behaviors override the new settings.
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Drawing the Prototype

Define the graphic presentation of your prototype using the Prototype buffer window: 

◆ You can drag and drop graphic objects into the buffer and use the editing modes to create 
lines, polygons, and so on: a Prototype buffer window has all the properties of the 
IBM ILOG Views Studio 2D Graphics buffer window.

◆ As you draw your prototype, you can see its structure in the Graphics page of the Group 
Inspector panel, shown in addition to the Main window. Figure 3.1 shows an example of 
this. The list of graphic nodes appears organized from bottom to top. As you add graphic 
objects to the prototype, the tree structure is updated. You can select graphic nodes either 
directly in the Prototypes buffer window (as you do in IBM ILOG Views Studio) or in 
the tree that appears in the Group Inspector panel.

Figure 3.1 

Figure 3.1  The Graphics Notebook Page of the Group Inspector Panel
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Creating and Using Prototypes
Editing Prototype Nodes

You can use the fields on the Graphics page of the Group Inspector (see Figure 3.2) to 
change a number of properties associated with the elements (or nodes) in your prototypes:

Figure 3.2 

Figure 3.2  The Graphics Notebook Page of the Group Inspector Panel

◆ If the selected node is a graphic node, the properties only apply to this particular node.

◆ If the selected node is a group node—that is, the root node of the prototype, a subgroup 
of the prototype, or a prototype instance—the properties apply to all the child graphic 
nodes of the selected group.

The following table describes the fields found on the Graphics notebook page: 

Table 3.1 Fields of the Graphics Notebook Page of the Group Inspector Panel

Field Description

Node name This text field is used to change the name of the node. You 
can also use the Name field of the Generic Inspector in the 
IBM ILOG Views Studio Main window.
Note: Nodes should contain only alpha-numeric 
characters (A-Z, a-z, 0-9).

(V) Visible This toggle controls the visibility of the graphic object in the 
prototype.

(H) Hidden in application If this button is set, the selected graphic object is visible only 
while editing the prototype or its instances in 
IBM ILOG Views Studio. The object is hidden in the final 
application. This property can be used to create 
intermediate “computing” prototype instances such as those 
of the “operations” prototype library.
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Structuring Prototype Nodes

To structure your prototype, you can group graphic nodes into subgroups. This may be 
useful when you define your prototype accessors; for example, when you want to rotate a 
group of objects or change their color. To create a subgroup:

1. In the Prototype buffer window, select the graphic objects you want to group. 

(N) Grapher node If this button is set, the graphic object is added as a grapher 
node when the prototype is instantiated in a grapher. This 
allows you to use prototype instances as grapher nodes. 
(This button is deprecated and included for compatibility 
reasons.)

(T) Transformed This button controls whether a transformer is associated 
with the graphic node to ensure that the graphic object can 
be transformed arbitrarily without distortions. Without a local 
transformer, some IBM ILOG Views objects lose their 
original geometry when they are resized. Using a local 
transformer ensures that the geometry of objects is not 
modified by geometric transformations. On the other hand, 
using a local transformer consumes more memory. 
If you select this button, remember that you must use the 
standard Selection mode to inspect the graphic object of the 
node. If you use the Group Selection mode, the selected 
object is an instance of a subclass of 
IlvTransformedGraphic and cannot be inspected.

(B) Bounded Size If set, this flag restricts the zoomability of the objects. Setting 
this flag and leaving mZ and MZ to 0 is equivalent to setting 
both of them to 1. It is, however, more efficient. If Bounded 
Size is set, and mZ or MZ are not 0, this flag makes the 
objects disappear if the zoom factor of the view of the 
instance is greater than MZ or less than mZ. 

(mZ) Min. Zoom If not zero, this attribute limits the minimum size an object 
can have. When the scaling factor of the view holding the 
object is below this value, the object does not get any larger. 
If Min. Zoom and Max. Zoom are set to the same value, the 
object never grows or shrinks in size. If they are set to 1, 
they stay at the size at which they were created.

(MZ) Max. Zoom If not zero, this attribute limits the maximum size an object 
can have. When the scaling factor of the view holding the 
object is above this value, the object does not get any larger.

Table 3.1 Fields of the Graphics Notebook Page of the Group Inspector Panel (Continued)

Field Description
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Creating and Using Prototypes
2. From the Draw menu select Group. 

The objects are grouped into an instance of the class IlvGroup and a subgroup node is 
created in the prototype. The node tree shows the structure change.

Using the Group Selection mode, subgroups can be selected and moved as a whole. This 
mode shows the selected group by drawing a dashed-line frame around the group. You are 
still able to select individual graphic objects inside subgroups with the standard Selection 
mode. 

To include instances of other prototypes in the prototype you are editing:

1. If not already open, activate the Prototypes palette by choosing Palettes from the Tools 
menu. 

2. Select the desired prototype library. 

3. Drag and drop the prototype into the Prototype buffer window. The Nodes page of the 
Prototype Inspector will show a new node, similar to a subgroup node, for the prototype 
instance.

Having added objects, you may return to the Interface page to define new attributes that 
reference the internal nodes, or go to the Behavior page to define dynamic behaviors for the 
prototype.

Defining Graphic Behaviors

Define the graphic behaviors of your prototype using the Behavior page of the Group 
Inspector (see Figure 3.3). The graphic behaviors determine how the modification of an 
attribute affects the visual aspect of your prototype. For each attribute, you can add 
behaviors: these are instructions that will be performed each time the value is modified.

Figure 3.3

Figure 3.3  The Behavior Notebook Page of the Group Inspector

To add a behavior:

1. Select an attribute in the list. 
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2. From the Control, Display, or Misc menus, select a behavior to be added:

● Control behaviors enable the change of one attribute to trigger changes of other 
attributes, conditionally or not. For instance, if you want a thermometer to appear red 
when the temperature is above a given threshold, add a Condition accessor on the 
temperature attribute that assigns red to the foreground value of the gauge.

● Display behaviors enable you to change graphic properties of objects, such as 
rotation, zoom, and visibility, or perform animations of objects.

In addition, you can have attributes notify others of their changes, so that the graphic 
appearance of the group or prototype can be fully adjusted when one attribute changes its 
value. The Notify behavior, from the Control menu, can tell other attributes watching it that 
they should execute their behavior, while the Watch behavior, from the Misc menu, allows 
one attribute to indicate that it observes another attribute.

The exact effects of all predefined behaviors are described in Predefined Accessors.

Alternatively, you can access this page via online help. Select Help from the menu bar. 
Select a behavior in the Control, Display, or Misc menus and a help page describing the 
effect of the behavior will appear in the left-hand pane of the panel.

Using the Edit Menu of the Behavior Page

From the Behavior page, you can also:

◆ Add intermediate or hidden attributes that will be used in intermediate states of the 
computation: 

1. Select Edit > New Attribute to add an attribute. 

A new unnamed attribute appears. 

2. Set its name and type, as on the Interface page. 

3. When the attribute is selected, one or more behaviors can be added to it.

◆ Cut/Copy/Paste behaviors. You can copy or cut a whole attribute and its behaviors by 
selecting the first line of an attributes tree and selecting Edit > Copy or Edit > Cut, or 
copy or cut a single behavior only by selecting the behavior's line and then Edit > Copy 
or Edit > Cut. You can paste the content of the attribute's clipboard by first selecting a 
line where you want the attribute to be inserted, and then selecting Edit > Paste.

◆ Delete selected attributes, behaviors, or parameters with Edit > Delete.

◆ Move behaviors up or down. Behaviors are triggered from the top to the bottom. You can 
decide in which order they are to be triggered.

Setting Accessor Parameters

Depending on its class, a behavior may require additional parameters to be fully defined. 
Behavior parameters are edited in the matrix to the right of the Attributes Tree:
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Creating and Using Prototypes
        

The Group Inspector is designed so that you can define complex behaviors for your 
prototypes by simply selecting parameter values in combo boxes or dialog boxes.

Each matrix row corresponds to a parameter: 

◆ The left column contains the parameter label.

◆ The right column contains the parameter values.

When a behavior is added, a parameter matrix is initialized with default or empty values that 
may need to be filled with appropriate values. 

To edit a parameter value, click twice on the corresponding item in the matrix. This creates 
an editing field on top of the value item, which is either a combo box or a text field (see 
Figure 3.4). The combo box is initialized with relevant values for this parameter.

Figure 3.4

Figure 3.4  A Combo Box With an Example of a Default Value
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There are four types of parameter, as shown in the following table: 

For input parameters, the editing field is a combo box that contains a tree of accessors, as 
well as two special items at the beginning of the tree:

Table 3.2 Behavior Parameters 

Parameter Type Description Symbol

Literal/Explicit The value is a string or an enumerated type that must 
be specified explicitly. 

(e)

Input The value is queried when the accessor is evaluated. 
These values can be a constant (a string or a 
number), a reference to other attributes, or an 
expression that is a combination of constants and 
references.

Output The value is changed when the behavior is evaluated. 
(A call to the changeValue method is made.) Hence, 
the value must be a name that references either an 
existing attribute of the prototype.

Object/Node The value of the parameter must be the name of an 
existing node. Some accessors accept only certain 
kinds of objects as a parameter. For instance, display 
behaviors act only on graphic nodes.
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Creating and Using Prototypes
◆ [Immediate value] - When this item is selected, the editing field is set up to edit an 
immediate parameter value. If the value type can be determined, a value selector (that is, 
either a combo box or a resource selector) is created. You can also type the immediate 
value directly. If the value is not a number or a Boolean value, the value can be in double 
quotes (for example, you must enter a color as "red"). The value can also be an 
expression.

◆ [All types / Matching types] - This item toggles between the two values. [All 
types] lists all the accessors, even those whose type does not match the expected type. 
[Matching types]lists only the accessors whose type matches the expected type for 
the value. It is generally better to edit parameter values from top to bottom, because the 
editing field is often initialized using information available from the preceding fields.

Input parameters expressions can contain:

◆ Constants: numeric or strings literals (to be placed between quotation marks)

◆ Variables: prototype values or node attributes

◆ Arithmetic operators and parentheses: (+, -, *, **, /, %, ==, !=, >, >=, <, <=, &&, ||)
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◆ Predefined functions: abs, acos, asin, atan, ceil, cos, exp, floor, log, rand, rint, round, sin, 
sqrt, tan. (See your standard C/C++ library user’s manual to get the meaning of these 
functions.) 

Notifying behaviors have the side effect of propagating the value of the attributes to their 
watching attributes instead of simply setting it. In this case, the behaviors of the watching 
attributes are evaluated in sequence. Such behaviors (Trigger accessors) show an outward 
arrow on top of their Output parameter, and the values they are connected to show an inward 
arrow:

         

Some behaviors can have a variable number of parameters. These accessors are identified by 
their last row of the parameters column, which indicates “<<Click to add item>>”. To create 
a new row in the editing matrix of the Group Inspector for these behaviors, press the Enter 
key in the value field of the last parameter or simply click in the indicated field.

Defining Interactive Behaviors

Add user behaviors using the Interaction page of the Group Inspector, to determine how user 
actions affect the attributes of your prototype:

Note: Unlike its C / C++ equivalent, rand takes an integer argument. A non-zero 
argument is used by the random number generator as a seed when producing a random 
number. Otherwise, rand(0) returns the next integer in the random sequence started the 
last time the random generator was initialized.
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Creating and Using Prototypes
Figure 3.5

Figure 3.5  The Interaction Page of the Group Inspector.

This page works the same way as the Behaviors page and displays a list of behaviors. The 
page starts blank, as only the behaviors that are triggered by user actions are displayed in 
this page.

For each attribute, you can add behaviors, which are instructions to be performed each time 
the value is modified:

1. Choose an item in the Events menu to add an interactive behavior:

● If the user action comes from a callback, select Events > Callback to add a behavior 
that will be triggered by some object interactor and callback.

● Otherwise, to directly handle user events such as button clicks, select Events > Event 
to add a behavior that will be triggered by simple user events. 

2. Enter the parameters for each added behavior.

3. Once you have added the triggering accessor, you can add behaviors that will be 
triggered by the user action by adding Control > item or Display > item behaviors, just as 
you did for the graphic behaviors.

It is generally a good idea to have the interaction accessors modify only the public attributes 
of your prototype, relying on that modification to update all the display behaviors.

Editing a Prototype

Once you have created and saved a prototype, you can edit it again by selecting the 
prototype in the palette, and choosing View > Edit Group (Ctrl+E). All the changes you 
make will be propagated to the instances you have created when you save it. 
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For instance, you can select the “bulb” prototype in the “samples” palette, and double click 
on its icon: the Prototype edition buffer is opened, and the group inspector allows you to edit 
its interface and behaviors.

Testing Your Prototype

Once you have defined behaviors for a prototype, you can test them by changing the 
prototype attributes:

1. Select the Interface page in the Group Inspector.

2. To set an attribute value, click the matrix item. 

3. Depending on the type of value, a combo box, a resource selector, or a simple text field is 
created. Clicking with the right mouse button displays the list or the selector (if any) in a 
single click. 

4. The prototype value is changed through a call to the changeValue method when you 
press the Enter key after editing the field, or when you move to another field after editing 
the value.

This allows you to test how the graphic representation of your prototype changes as you set 
its attributes to different values.

To test the interactive behavior of your prototype:

1. Switch to the active mode, as is possible for all panels. 

2. By clicking and dragging on various items of your prototypes, you can see in the Group 
Inspector panel how the attributes are affected by the interactions you define.

Saving a Prototype

To add a prototype to an existing library: 

1. Choose the Save As command from the File menu. 

2. If the prototype was not already part of a library, Prototypes Studio asks if you want to 
add your prototype to a prototype library. Click Yes.

3. From the dialog box displayed, select the library to which you want to add the prototype. 

4. In the subsequent dialog box enter the name of the prototype.

To save your prototype elsewhere than in a prototype library:

1. Choose the Save As command from the File menu.

2. Answer No to the question ‘Save the prototype in a library?’
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Loading and Saving Prototype Libraries
3. A file selector dialog box appears and asks for a file name. Specify a name with a .ivp 
extension.

If you make additional changes to your prototype, you can save it again in the same 
prototype library or to the same file using the Save command from the File menu. 

You can move the prototype to a different library, give it a different name, or remove it from 
its library with the Save As command.

When a prototype is saved, all the panels containing instances of that prototype are updated 
with the new prototype definition.

Loading and Saving Prototype Libraries

To load a prototype library:

1. Choose Open from the File menu.

2. Select Prototype libraries (*.ipl) in the box for file type. 

3. Browse to find the name of the library file you want to load.

Once the library is loaded, it is added as a new palette in the Prototypes palette of the 
Palettes panel.

You do not need to save a prototype library each time you create or edit a prototype. A 
prototype library is saved automatically as necessary while you edit your prototypes.

To change the name of the current prototype library (that is, the library name that is 
displayed in the visible page of the Prototypes Palette):

1. Use the command Save Prototype Library As... from the File menu.

2. Select the new directory and name of the prototype library file (with a .ipl extension).

The prototype library name changes accordingly and all the prototypes of the library are 
saved in the new directory.

Note: A prototype which is not contained in a prototype library does not appear in the 
Prototypes Palette, so you cannot create instances of this prototype in panels from within 
IBM ILOG Views Studio. It is strongly suggested that you use prototype libraries instead of 
saving each prototype in its own file.
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You can close a prototype library that you no longer need by choosing Close Prototype 
Library from the File menu. This command removes the library currently displayed in the 
Prototypes palette.

Creating and Editing Prototype Instances in Panels

This section explains how to instantiate the prototypes that you have defined or loaded, in 
order to create panels.

Choosing a Buffer Type

Prototypes Studio has 2 types of buffer windows that can be made into panels: 2D Graphics 
and Grapher. When the Gadgets extension is installed, a Gadget buffer window is also 
available.

◆ Use a 2D Graphics buffer window for graphics-intensive applications: that is, if your 
prototypes contain 2D graphic objects such as lines, rectangles, and splines.

◆ Use a Grapher buffer window if you need Grapher features to connect graphic objects in 
prototype instances, using Grapher links.

◆ If you have the IBM ILOG Views Controls package and your prototypes contain gadgets, 
use a Gadget buffer window.

To create a panel in which to use prototype instances, choose the appropriate buffer type 
from the menu File > New.

Creating a Prototype Instance

To create a prototype instance: 

1. Select a prototype library in the upper pane of the Palettes panel. 

2. Drag the icon of the desired prototype to the buffer window. 

OR:

1. Click the icon representing a prototype to select it.

2. Click and drag a rectangle in a buffer window. An instance of the prototype whose 
bounding box is defined by the rectangle you just drew will be created.

The prototype is instantiated in the form of an IlvProtoGraphic object encapsulating the 
prototype instance.

Note: The prototypes contained in the library are not actually deleted in memory; they can 
still be referenced in panels or in other prototypes.
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Connecting Prototype Instances
Editing Prototype Instances

Prototype instances are edited using the Group Inspector. To display the Group Inspector, 
choose Group Inspector from the Tools menu or double-click a prototype instance. When an 
instance is selected, its attributes are displayed in the Attributes notebook page of the Group 
Inspector.

Loading and Saving Panels

Panels containing prototype instances are loaded and saved as standard .ilv files using the 
Open, Save, and Save As commands from the File menu.

Connecting Prototype Instances

Prototypes can define notifying attributes that can be connected to the attributes of instances 
of other prototypes. This means that when a notifying attribute is modified, its value is 
assigned to the attributes of the objects it is connected to.

To connect attributes of prototype instances:

1. Select the Group Connection mode from the Editing Modes toolbar:

      

2. Click in the prototype instance that defines the notifying attribute (the value that you 
want to be sent).

3. Drag the connection line to the instance to which you want to connect this attribute (the 
instance that you want to be notified of attribute modifications).

The Connect two values dialog box is displayed:

Note: The Behavior and Interaction pages are disabled for prototype instances. They can 
only be used when editing prototypes. See Defining Graphic Behaviors for an explanation 
on how to edit accessor values with the Group Inspector.
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4. In the left hand pane, select the notifying attribute from the first instance.

5. In the right hand pane, select the input attribute for the second instance.

There can be several connections between the same two objects. When the Group 
Connection mode is active, existing connections are displayed as green lines. If you click a 
green line, the connection details (that is, the names of the output and input values) are 
displayed. 

To delete a connection:

1. Double-click the connection line. 

A Delete Connection dialog box appears. 

2. Select the connection you want to delete, and click Apply.

The next chapter will describe how to link protoypes to application objects, defined in C++ 
code.
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C H A P T E R
4

Using Prototypes in C++ Applications

This chapter explains how to use prototypes in your C++ applications. It is divided as 
follows:

◆ Architecture

◆ Writing C++ Applications Using Prototypes

◆ Linking Prototypes to Application Objects

◆ Advanced Uses of Prototypes

Architecture

The Prototypes package is defined on top of the IBM® ILOG® Views Foundation package 
and allows you to perform the following tasks:

◆ Assemble elementary graphic objects into groups (class IlvGroup).

◆ Specify the behavior of your groups using predefined accessor objects or scripts.

◆ Define prototypes and create prototype instances in managers. Prototypes are instances 
of a subclass of IlvGroup called IlvPrototype.

◆ Connect properties between prototype instances.
I B M  I L O G  V I E W S  P R O T O T Y P E S  V 5 . 3  —  U S E R ’ S  M A N U A L 49



◆ Link application objects and prototype instances.

The architecture of the Prototypes package is shown in Figure 4.1:

Figure 4.1            

Figure 4.1  Architecture of the Prototypes Package

Groups

Groups are the basic components of the Prototypes package. 

To create a BGO with the Prototypes package, you must first assemble basic 
IBM ILOG Views graphic objects to build a group. You can use any IBM ILOG Views 
graphic object in a group. You can also create subgroups to build structured objects.

A group is represented in C++ by the IlvGroup class. An IlvGroup object contains a 
hierarchy of nodes, represented by the following subclasses of the IlvGroupNode class:

◆ An IlvGraphicNode is a node that holds a graphic object (an instance of a subclass of 
IlvGraphic). A group contains one graphic node for each of its graphic elements.
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◆ An IlvSubGroupNode holds a subgroup, that is, a group contained in another group. 
This class is used to create object hierarchies.

Attributes and Accessor Objects

The Prototypes package lets you define not only the graphic appearance of your objects, but 
also their behavior. The behavior of a group is controlled by its attributes (also called 
properties). These attributes bear distinct names and represent the external interface of the 
group, that is, how its appearance will be controlled from your application.

The attributes of a group and their behaviors are defined in accessor objects. Each accessor 
object has a name and a type and implements the effect of setting and/or retrieving the value 
for the group. Several accessor objects can have the same name, which means they belong to 
the same attribute. This means that setting an attribute value can have several side effects.

Accessors can be linked to other attributes of objects or to application data. They define state 
or appearance changes in response to user events or application instructions and, by 
extension, specify the graphic and interactive behavior of objects. Accessor objects are 
instances of subclasses of IlvAccessor. 

In other words, the relationship between accessor objects and values is the following:

◆ You interact with a group through its attributes.

◆ A group has a set of accessor objects attached to it. Each accessor object is associated 
with a name, which defines an attribute (or facet) of the BGO.

◆ The IlvGroup::changeValue method calls the changeValue methods of all the 
accessor objects of a given name, thereby setting the attribute value.

◆ The IlvGroup::queryValue method calls the queryValue methods of all the 
accessor objects of a given name, thereby getting the attribute value.

◆ The effect of each behavior class is defined by the implementation of its changeValue 
and queryValue methods.

◆ Some accessors can be set through user interaction or by the application, thereby 
triggering other behaviors in a chain.

Notes: IlvGroup objects are different from IlvGraphicSet objects. An IlvGroup is a 
logical hierarchy of graphic objects that are contained in a manager. Unlike 
IlvGraphicSet, IlvGroup is not a subclass of IlvGraphic. An IlvProtoGraphic is 
a subclass of IlvGraphic intended to encapsulate an IlvGroup to place it in a manager 
or container.

A third class of IlvGroupNode, called IlvValueSourceNode, is still present in the 
package, but its use is deprecated.
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The relationship between accessor objects and attributes/behaviors in a group is shown in 
Figure 4.2:

Figure 4.2          

Figure 4.2  Relationship Between Accessor Objects, Attributes, and Behaviors

This example shows a group representing a gauge. The gauge has two attributes: speed and 
max. 

◆ The speed attribute is implemented by two accessor objects, each having a graphic 
behavior:

● A Rotation accessor object—when the speed attribute is changed, this accessor 
object rotates the needle of the gauge.

● A Condition accessor object—when the speed attribute is changed, this accessor 
object changes the color of the circle if the value is greater than 30.

◆ The max attribute is implemented by a Reference accessor object, which references a 
property of a basic graphic object at the group level. When the max attribute is changed, 
this accessor object changes the maximum speed of the scale graphic object.

The following types of accessors can be attached to an attribute:

◆ Data accessors - State how a data item is to be stored (locally or in a node) and what its 
type is. They are comparable to variable declarations in a regular programming 
language. Only one of these accessors should be present for each attribute.

◆ Control accessors - Perform conditional instructions, evaluations, and assignments 
based on other attributes. They take input parameters and can have output effects on 
other parameters. Typical examples are the Condition accessor, for the conditional 
assignment, and the Toggle accessor.

◆ Notifying accessors - Define the entry points of evaluation cycles. Either the application 
(when it does a pushValue) or the user (when a callback triggers a Callback accessor) 
can “push” values, forcing the accessors to handle them. Connections between attributes 
can be made to propagate the evaluation to other values by means of the Watch and 
Notify accessors.
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◆ Display accessors - Define a side effect of the attribute on the visual presentation of the 
nodes of the group. They correspond to calls to the drawing library in a programming 
language. When they are set, they change graphic properties, such as rotating a node or 
changing the visibility of a graphic component. 

◆ Animation accessors - A special case of display accessors that periodically change a 
graphic attribute.

◆ Miscellaneous accessors - Consist of two accessors that do not fit into the previous 
categories: the Debug accessor and the Delegate to Prototype accessor.

You will find a full description of all the predefined accessor classes in the section 
Predefined Accessors.

Accessor Parameters

Accessors define a side effect that is performed on another object or attribute when a given 
attribute is set. This means that, as with a function in a programming language, an accessor 
has to take parameters to customize its effects. A description of the four types of parameters 
that accessors can have is presented in Table 4.1. 

Input parameter expressions can contain:

Table 4.1 Accessor Parameters

Parameter Type Description

Direct parameters The value is a string or an enumerated type that 
must be specified explicitly.

Input parameters The value is queried when the accessor is 
evaluated. These values can be a constant (a 
string or a number), a reference to other values 
(attributes of nodes or prototype values), or an 
expression that is a combination of constants and 
references.

Output parameters The value is changed when the accessor is 
evaluated (A call to the changeValue method is 
made). Hence, the value must be a name that 
references either an existing attribute of a node or 
a prototype value.

Object/Node 
parameters

The value of the parameter must be the name of 
an existing node. Some accessors accept only 
certain kinds of objects as a parameter. For 
instance, display accessors act only on graphic 
nodes.
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◆ Constants: numeric or string literals

◆ Variables: prototype values or node attributes

◆ Arithmetic operators and parentheses: (+, -, *, **, /, %, ==, !=, >, >=, <, <=, &&, ||)

◆ Predefined functions: abs, acos, asin, atan, ceil, cos, exp, floor, log, rand, rint, round, 
sin, sqrt, tan

Prototypes and Instances 

Once you have defined the graphic contents and the behavior of a group, you can save it as a 
prototype. A prototype is the model of a BGO. Usually, you create prototypes with 
IBM ILOG Views Studio, although you can also create prototypes directly by coding. See 
Creating Prototypes by Coding.

Prototypes are stored, loaded, and saved using prototype libraries, represented by the class 
IlvProtoLibrary.You can create prototype instances from a prototype. A prototype 
instance is a full copy of its prototype. 

Prototypes are represented by the IlvPrototype class and prototype instances are 
represented by the IlvProtoInstance class. Both of these classes are subclasses of 
IlvGroup.

When a prototype instance is saved to a file, the manager writes only the values of the 
properties that have been modified for that instance. The graphic objects that compose the 
prototype instance are not saved to the file. This means that you can completely change the 
definition of the prototype, add or remove graphic objects, and so on. Instances of the 
modified prototype will be automatically updated with the new definition.

Displaying Groups and Instances in Managers and Containers

To display groups, prototypes, and instances in a panel of your application (an IlvManager 
or IlvContainer), you need to place them in an IlvProtoGraphic object and add this 
object to the manager or container. IlvProtoGraphic is a subclass of IlvGraphic 
designed to encapsulate all the graphic objects of a group. You may also add group objects to 
a manager using an IlvGroupHolder, which is a class that extends the properties of a 
container or manager and lets you directly add or retrieve groups through convenience 

Note: Contrary to its C/C++ equivalent, rand() takes an integer argument. If this argument 
is non-zero, it is used as a seed for the random generator before a random number is 
generated. Otherwise, rand(0) returns the next integer in the random sequence started the 
last time the random generator was initialized.
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functions.This class will create the IlvProtoGraphic itself to wrap it around the 
IlvGroup.  

Connecting Attributes

A group has readable and writable attributes that are defined by the accessor objects attached 
to it. It can also have notifying attributes, which are similar to events generated by the group 
or by one of its elements.

A notifying attribute can be connected to an attribute of another group. When the attribute is 
modified, the changes are propagated to the groups connected to it. This is referred to as the 
value of the notifying attribute being pushed to its connected attributes.

Linking Application Objects to Prototypes

Once you have defined your prototypes and your panels, you may want to connect these to 
real application data and processes defined in C++.

There are three methods available to link prototypes to application objects, depending on the 
type of interface you want to produce:

◆ When the display is graphics-rich but represents only a few application objects and 
values, you may want to link the application objects by directly feeding values to the 
prototype instances of a given panel. 

This is typically used in static synoptic displays composed of only predefined graphic 
components. It is convenient to use feed values directly when the application is not 
expecting user input to modify application values through a prototype instance. The 
base_feed sample in <ILVHOME>/samples/protos shows how to use this approach 
for a simple control panel.

◆ To build WYSIWYG, direct-manipulation application object editors, you may want to 
use an IlvGroupMediator. With this class, you can link an application object to a 
given IlvGroup (or prototype instance) in a panel, allowing interactive editing of its 
attributes. A group mediator allows you to bind and unbind application objects 
dynamically to a given prototype that serves as an editor for the object.

A typical application of this type is a WYSIWYG inspector such as the Guides inspector 
in Prototypes Studio. The inspector sample in <ILVHOME>/samples/protos is an 
example of this kind of editor. It shows how to build a 2D transformation matrix editor 
controlling the viewpoint of a view interactively.

Note: Special manager and container classes IlvProtoManager, 
IlvProtoContainer, and IlvProtoGrapher have been added to allow direct 
handling of IlvGroup objects in a container or manager. These classes are provided for 
compatibility reasons. Their use is obsolete and should be avoided.
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◆ To create many instances of a prototype dynamically, with each instance linked to a 
given application object, you should use an IlvProtoMediator. This class instantiates 
the prototype and links it to an application object of a given class as it is created. This 
allows clear separation of interface design from the application design, each being able 
to evolve separately from a commonly agreed upon application interface.

A typical application of this type allows you to view panels where many objects of many 
classes are represented and edited at the same time. Each application class is linked to a 
prototype and each instance of the class to an instance of the prototype.

Cartographic displays and all graph displays are examples of applications that can 
benefit from prototypes using IlvProtoMediators. <ILVHOME>/samples/protos/
interact_synoptic is an example of this type of application, showing a very simple 
air-traffic simulator, where each flight and each airport are represented by prototype 
instances. The simulator only deals with changing the attributes of the flight, whereas the 
prototypes can be incrementally refined in the drawing editor to present the best display.

Writing C++ Applications Using Prototypes

As a general rule, you create your prototypes in IBM® ILOG® Views Studio and then use 
them in your application. The following section explains the C++ API that you use to add 
prototypes to your application and how to manipulate these prototypes.

The following items are described in this section:

◆ Header Files

◆ Loading a Panel Containing Prototype Instances

◆ Loading Prototypes

◆ Creating Prototype Instances

◆ Deleting Prototype Instances

◆ Retrieving Groups and Prototype Instances

◆ Getting and Setting Attributes

◆ User-Defined and Predefined Attributes

Note: Although it is not the general rule, it is possible to create prototypes through direct 
coding. For these situations, see the section Creating Prototypes by Coding.
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Header Files

To make sure that your application is linked with the necessary library packages, you must 
first include the header files corresponding to the graphic objects, the accessors (subclasses 
of IlvUserAccessor), and the interactors used in the prototypes that you will load.

To include all the predefined accessor classes, use the header file <ILVHOME>/include/
ilviews/protos/allaccs.h.

Here is a typical set of header files to include in order to build an application that can load 
prototypes containing any type of graphic object:

#include <ilviews/protos/protogr.h> // for IlvProtoGraphic.
#include <ilviews/protos/allaccs.h>  // for all accessors.
#include <ilviews/graphics/all.h> // for all graphic objects.
#include <ilviews/gadgets/gadgets.h> // if you use gadgets in your prototypes.
#include <ilviews/graphics/inter.h> // for all object interactors.

You may also want to add the following header files:

#include <ilviews/protos/groupholder.h> // to get the groups attached
                                        // to a given container or manager.

#include <ilviews/protos/proto.h> // to manipulate prototypes and
                                  // their libraries.

#include <ilviews/protos/grouplin.h> // to attach prototypes to
                                     // application objects.

If you know in advance the Prototypes that you will use, you can reduce the size of your 
application by including only the necessary header files instead of allaccs.h, 
graphics.h, and gadgets.h.

To compile applications that use the prototypes package, you must compile them with the 
library ilvproto. This library also requires the following libraries: ilvgrapher, ilvmgr, 
and the usual IBM ILOG Views libraries for your platform. The ilvgdpro library may be 
needed for applications that use old features of prototypes.

Loading a Panel Containing Prototype Instances

To load a.ilv file containing prototype instances, you simply use the read or readFile 
methods of IlvManager or IlvContainer:

Container->readFile("protoSample.ilv");

All the prototypes used in the file will be loaded automatically from their prototype libraries. 
Prototype libraries are searched for in the file system using the display path. For example, if 
the panel contains prototypes from a prototype library called mylib located in /usr/home/
yourdir/protolibs/mylib.ipl, you should include /usr/home/yourdir/
protolibs/ in your ILVPATH environment variable.
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To allow handling of groups in a container or manager, the IlvGroupHolder class provides 
all the necessary interface. Instances of the IlvGroupHolder class are automatically 
attached to containers or managers containing prototype instances. This class provides the 
methods for adding, removing, and retrieving groups (and thus prototype instances). You 
can retrieve the group holder attached to a container, manager, or graphic holder with the 
global methods:

◆ IlvGroupHolder* groupHolder = IlvGroupHolder::Get(manager);

◆ IlvGroupHolder* groupHolder2 = IlvGroupHolder::Get(manager

                                             ->getHolder());

◆ IlvGroupHolder* groupHolder3 = IlvGroupHolder::Get(container);

Loading Prototypes

You may need to create instances of your prototypes by coding. To create instances of your 
prototypes, you must first load them. You can load a whole prototype library and then load 
one or more of the prototypes it contains. To do this, create an instance of the 
IlvProtoLibrary class and call its load method:

IlvProtoLibrary* lib = new IlvProtoLibrary(display, "mylib");
if(!lib->load())
    IlvFatalError("Could not load prototype library");

If you want to load a prototype library that is not located in the display path, you can specify 
the directory where the library is located in the call to the constructor:

IlvProtoLibrary* lib = new IlvProtoLibrary(display, "mylib",
                                                    "/usr/somewhere/protos");
if(!lib->load())
    IlvFatalError("Could not load prototype library");

Once you have loaded a prototype library, you can retrieve all its prototypes or a particular 
prototype with the following methods:

IlUInt count;
IlvPrototype** protos = lib->getPrototypes(count);

or:

IlvPrototype* proto = lib->getPrototype("myproto");

The array returned by the getPrototypes method is allocated with the new[] operator and 
must be released with the delete[] operator when it is no longer needed.

Alternatively, you can load each prototype individually with the global function 
IlvLoadPrototype:

IlvPrototype* proto = IlvLoadPrototype("mylib.myproto", display);
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The first argument specifies the name of the prototype library and the name of the prototype 
(separated by a period). The second argument is the instance of IlvDisplay that your 
application has created. The prototype library file and the prototype files are searched for in 
the file system using the display path.

Creating Prototype Instances

To create an instance of a prototype, use the clone method:

IlvPrototypeInstance* instance = proto->clone("myinstance");

The argument of the clone method is the name of the new instance. You can pass 0, which 
means that a name is generated automatically.

Instances of the IlvGroupHolder class are automatically attached to containers or 
managers containing prototype instances. This class provides the methods for adding, 
removing, and retrieving groups (and thus prototype instances).

To add the new prototype instance to a manager or a container, you can use the addGroup 
methods of the IlvGroupHolder attached to manager/container classes:

IlvGroupHolder* groupHolder = IlvGroupHolder::Get(manager);
groupHolder->addGroup(instance);

Alternatively, you can create an IlvProtoGraphic object and directly place it in the 
manager.

IlvPrototype* proto;
// Create an instance of the prototype proto and places it
IlvProtoGraphic* protoGraphic1 = new IlvProtoGraphic(proto);
// Create an instance of a prototype
IlvProtoInstance* protoInstance = proto->clone(“instance2”);
IlvProtoGraphic* protoGraphic2 = new IlvProtoGraphic(protoInstance);
manager->addObject(protoGraphic1);
manager->addObject(protoGraphic2);

Often, you will set the position of the prototype instance when you add it to a manager or 
container. You can do this by either:

◆ Moving the IlvProtoGraphic:

manager->moveObject(protoGraphic1, 100, 100).

◆ Setting the x and y attributes of the prototype instance. See Getting and Setting 
Attributes for an explanation on how to set several values in a single call.

Deleting Prototype Instances

To remove a prototype instance from its container or its manager, you can use the 
removeGroup methods of the IlvGroupHolder class:

groupHolder->removeGroup(instance);
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You can also remove its embedding IlvProtoGraphic from its container or manager:

manager->removeObject(protoGraphic);

To completely delete a prototype instance, simply call the delete operator. You can also 
delete its encapsulating protoGraphic.

Retrieving Groups and Prototype Instances

To get all the groups contained in a manager or container, use the getGroups method of its 
attached group holder:

IlUInt count;
IlvGroup** instances = groupHolder->getGroups(count);

To retrieve a group by its name, use the getGroup method:

IlvProtoInstance* pump = (IlvProtoInstance*)groupHolder->getGroup("pump");

This method returns 0 if the specified group does not exist.

Getting and Setting Attributes

Prototype instances are manipulated through a uniform API based on named attributes (also 
called properties or accessors). This API is the same as the one provided by the class 
IlvGraphic and basically consists of the IlvGraphic::changeValue and 
IlvGraphic::queryValue methods.

A named attribute is represented by an instance of the IlvValue class and is defined by the 
following:

◆ The attribute name, “label” for example, to access the label of a button. 

◆ A value, which can be of different types (for example, a character string, an integer, or a 
pointer).

◆ A type that corresponds to the type of the data.

The type of the value is set automatically by the IlvValue class. You use constructors to 
initialize values of predefined types (such as IlInt, const char*, IlvColor*, and so 
on). You can also change a value using the assignment operator = or by casting an 
IlvValue to a predefined type. The IlvValue class handles all conversions automatically. 
For more details, see the IlvValue class. 

Note: The array of pointers returned by the getGroups method is allocated using the 
new[] operator and must be deleted with the delete[] operator when it is no longer 
needed.
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To set a value for a prototype instance, you must create an IlvValue and call the 
IlvGraphic::changeValue method:

IlvValue xval("x", (IlInt)100);
instance->changeValue(xval);

You do not need to create a new IlvValue every time you want to change a value. You can 
use an existing IlvValue and change its data with the assignment operator:

xval = (IlInt)200;
instance->changeValue(xval);

You can set several values in a single call. To do this, you must create and initialize an array 
of IlvValue objects and call the changeValues method. The following example shows 
how to set the position of an object in a single call:

IlvValue vals[] = {
                IlvValue("x", (IlInt)100),
                IlvValue("y", (IlInt)200)
};
instance->changeValues(vals, 2);

To retrieve a value, use the queryValue method:

IlvValue xval("x");
IlInt x = instance->queryValue(xval);

The queryValue method takes an IlvValue reference as parameter. The IlvValue must 
be initialized with the name of the value to retrieve. The queryValue method stores the 
retrieved value in its argument and returns a reference to it. In the example, assigning the 
result of queryValue to the integer variable x calls the IlvValue to the IlInt cast 
operator.

To retrieve several values in a single call, create an array of IlvValue objects and call the 
queryValues method:

IlvValue vals[] = { "x", "y", "width", "height" };
instance->queryValues(vals, 4);
IlInt x = vals[0];
IlInt y = vals[1];
IlUInt width = vals[2];
IlUInt height = vals[3];

Note: The explicit cast of the value 100 to the type IlInt is necessary because an 
ambiguity exists between the integer and Boolean types. Without the cast, the compiler 
might (on some platforms) call the constructor that creates an IlvValue of type 
IlBoolean. It is recommended that you always use explicit casts when using constants to 
initialize an IlvValue.
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The IlvValue class converts values automatically as required. This means that you do not 
need to know the exact type of a value that you set or retrieve. For example, you could set 
the position of an object using a string value as follows:

IlvValue xval("x", "100");
instance->changeValue(xval);

Conversely, when you retrieve a value, you can convert it to the type you need as follows:

IlvValue xval("x");
instance->queryValue(xval);
float x = xval;

User-Defined and Predefined Attributes

A prototype and its instances have three kinds or attributes: user-defined attributes, 
predefined attributes, and sub-attributes.

User-Defined Attributes

The user-defined attributes are the attributes defined by the accessors that you attached to 
the prototype when you designed it in IBM ILOG Views Studio. They vary from one 
prototype to another. The effect of setting or retrieving a user-defined attribute is determined 
by the accessor objects that compose it.

For example, suppose that you have created a prototype representing a thermometer. You 
defined a temperature attribute by adding a reference accessor that maps the temperature 
to the value attribute of a gauge. To change the temperature displayed by an instance of 
your prototype, use the changeValue method as follows:

IlvValue tempVal("temperature");
tempVal = 22.5;
instance->changeValue(tempVal);

Predefined Attributes

The predefined attributes of a group let you modify or retrieve common properties that all 
prototypes have, such as the position, the size, the visibility, and so on.

Most predefined attributes take effect only when a group is added to a manager or a 
container, but they can be set before that. They are stored in the graphic node but only take 
effect when the group is added.
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The predefined attributes are listed in Table 4.2. 

Table 4.2 Predefined Attributes of Prototypes and Prototype Instances

Attribute Type Description

layer IlInt Set this attribute to move all the nodes of the group 
to a given layer. Retrieving this attribute returns the 
layer where the nodes of the group are contained. If 
all nodes are not in the same layer, the result is 
undefined.

visible IlBoolean Set this attribute to hide or show a group. Retrieving 
this attribute returns IlTrue if all the graphic 
nodes of the group are visible and IlFalse if they 
are all invisible. The result is undefined if some 
nodes are visible and other nodes are invisible.

x IlInt This attribute is the horizontal coordinate of the 
upper-left corner (in manager coordinates) of the 
group bounding box, without applying any view 
transformers.

y IlInt This attribute is the vertical coordinate of the upper-
left corner (in manager coordinates) of the group 
bounding box, without applying any view 
transformers.

width IlUInt This attribute is the width of the group bounding box 
(in manager coordinates), without applying any 
view transformers.

height IlUInt This attribute is the height of the group bounding 
box (in manager coordinates), without applying any 
view transformers.

centerX IlInt This attribute is the horizontal coordinate of the 
center of the group bounding box (in manager 
coordinates), without applying any view 
transformers.
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Sub-attributes

The sub-attributes of prototypes let you directly access the attributes of the objects contained 
in your prototypes. The names of sub-attributes are built by concatenating the path of the 
object and the attribute name. The components of a sub-attribute name are separated by a 
period. For example, if your prototype contains an IlvLabel named title, you can set or 
retrieve its label using the attribute name title.label.

All the predefined properties listed in Table 4.2 can also be accessed for a particular graphic 
node.

Linking Prototypes to Application Objects

This section describes the three methods that can be used to link prototypes to application 
objects: 

◆ Setting Values Directly: This is the easiest way if you simply want to feed values from 
your application to the views.

◆ Using Group Mediators: This allows the application to both drive the interface and be 
notified of value changes produced by the user.

◆ Using Proto Mediators: This enables you to build object factories that will link 
application classes with prototypes, thereby creating the interface of a dynamic 
application automatically.

Setting Values Directly

The sample base_feed (contained in the <ILVHOME>/samples/protos directory) shows 
how to drive your interface from your application. Once you have downloaded a panel 

centerY IlInt This attribute is the vertical coordinate of the center 
of the group bounding box (in manager 
coordinates), without applying any view 
transformers.

interactor const char* Set this attribute to associate an interactor with all 
the graphic nodes of the group. The value of the 
attribute is the interactor name (for example, 
“Button”). Retrieving this attribute returns the 
name of the interactor associated with the graphic 
nodes of the group. If all nodes do not have the 
same interactor, the result is undefined.

Table 4.2 Predefined Attributes of Prototypes and Prototype Instances (Continued)

Attribute Type Description
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containing instances of prototypes, or created your instances in a manager or container, you 
retrieve the instances that you want to edit:

IlvGroupHolder* groupHolder= IlvGroupHolder::Get(manager);
IlvGroup* myThermometer= groupHolder->getGroup(“thermometer”);

Then, you change its values with the IlvGroup::changeValue method:

if (myThermometer)
   myThermometer->changeValue(IlvValue(“temperature”,(IlUInt) 20)));

Using Group Mediators

A group mediator (class IlvGroupMediator) is used to connect an object of the 
application to a prototype and serves as an interactive graphic editor for the object (also 
called an object inspector). The samples inspector and synoptic (contained in the 
<ILVHOME>/samples/protos directory) implement a group mediator and can be used as a 
baseline.

The following code sample shows how to develop an application that cleanly separates the 
user interface from the application code. Assume that you have an application that includes a 
Machine base class and a Boiler specialization class:

class Machine { // The base class of most application objects.
protected:
     list<MachineObserver* > observers;
};
class MachineObserver { // A notification mechanism serving as a
                        // generic communication means between objects.
public:
     void observe(Machine* m) { m->observers.append(this); }
     virtual void notify (Machine*);
};
class Boiler : public Machine { // The class for which you want
                                // to create an object inspector.
public: 
// Temperature is an attribute you want the user to have control of.
     void set_temperature(float) { ... 
             for each observer in observers
                      observer->notify(this);
     } 
     float get_temperature();
};

These classes perform a simulation, a process control, or any computational activity 
independent of any kind of interactive or graphic behavior. A group mediator allows you to 
implement a graphical user interface for the Boiler without introducing any dependencies 
in the application classes, which are assumed to be much more complex.

For this, you want to create a subclass of IlvGroupMediator that will handle the graphic 
representation and the user interaction of a machine of class Boiler:

class BoilerUI : public IlvGroupMediator,  public MachineObserver {
public:
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     BoilerUI(IlvGroup* ui, Boiler* b) : IlvGroupMediator(ui, b) { 
          MachineObserver::observe(b); 
          if (!temperatureSymbol) 
            temperatureSymbol=IlvGetSymbol(“temperature”);
     }
     Boiler* boiler() { return (Boiler*) getObject(); }
     void queryValues(IlvValue* vals, IlUInt) const {
            if (vals[0].getName() == temperatureSymbol))
                 vals[0] = boiler()->get_temperature();
     }
     void changeValues(const IlvValue* vals, IlUInt) {
            if (vals[0].getName() == temperatureSymbol))
                  boiler->set_temperature(vals[0]);
     }
     void notify(Machine*) { update(); }
static IlvSymbol* temperatureSymbol;
};

This class serves as a bridge between a prototype instance and an application object. It 
defines four methods:

◆ The constructor establishes a link and the observe(b) statement declares to the 
application that it wants to be notified of internal changes occurring to the boiler.

◆ The changeValue() method, which is called whenever the user changes an attribute of 
the object. It notifies the object that it should update its temperature value. It can handle 
other attributes as well.

◆ The queryValue() method, which is called whenever the prototype needs to update its 
values. It queries the internal values of the object and transfers them to the user interface.

◆ The notify() method, which must be called explicitly from within the application 
whenever an internal attribute of the object changes in order for these changes to be 
reflected in the user interface. Any call to Boiler::set_temperature() 
automatically notifies all observers, which means that the notify() method does not 
need to be called explicitly. Other applications that do not implement an observable/
observer design pattern such as this may want to call notify() from other parts of the 
internal code.

Once the mediator class has been defined, you can dynamically link an object of the 
application to a prototype instance that is used as a boiler inspector:

IlvGroup* myBoilerInspector = groupHolder->getGroup("BoilerInspector");
BoilerUI* myBoilerUI = new BoilerUI(myBoilerInspector, myBoiler);

You can change the application object being inspected by the prototype at any time:

myBoilerUI->setObject(myOtherBoiler);

Even though this mechanism requires some application-specific coding, it is very generic—
any application data structure can be adapted to use it. Once the mediator class has been 
designed, the user interface and the application become completely independent entities. 
Each can be developed and maintained separately. The user interface is developed using 
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IBM ILOG Views Studio and the application using any application development 
environment.

The group mediator also has a lock mechanism that can be used to prevent unnecessary 
refreshes of the user interface. In the above example, the boiler set_temperature method 
calls the notify() method of the BoilerUI to refresh the user interface. Since the change 
of values comes from the UI, it may be unnecessary to perform this last refresh. Testing the 
locked flag prevents such refreshes:

void BoilerUI::changeValues(const IlvValue* vals, IlUInt) {
    if (locked()) return;
    if (vals[0].getName() == temperatureSymbol))
           boiler->set_temperature(vals[0]);
}

Using Proto Mediators

A proto mediator (class IlvProtoMediator) is a subclass of IlvGroupMediator and is 
used to dynamically create prototype instances of a given class and place them in a manager 
or container. The idea is to design a specific prototype for each main application class. When 
an object is created by the application, a corresponding prototype is instantiated and placed 
in the manager. This allows you to create a graphical user interface for a complete 
application, separating the user interface design from the functional core of the application. 
The following samples from the <ILVHOME>/samples/protos directory implement this 
design pattern: interact_synoptic to build an air-traffic control simulator, and 
synoptic to build a simulator for a manufacturing plant.

For example, assuming the same base application (Machines and Boilers), you want each 
Boiler instance to be represented and edited at the same time by the user. Create a subclass 
of IlvProtoMediator:

class BoilerUI: public IlvProtoMediator, public MachineObserver {
public:
    BoilerUI(IlvManager*m,Boiler*b)
             :IlvProtoMediator(m,"BoilerPrototype",b) 
        {
          observe(b);
          IlvSymbol* vals[2] = {
              IlvGetSymbol( "x"), IlvGetSymbol("y") };
          update(vals); // Sets the position of the current instance.
          // The application must have a way of specifying where to place
          // the object. Alternatively, you can handle the placement by
          // explicitly setting the x and y values of the BGO.
          install(m); // Place the prototype in the manager
        }
// Other methods are the same as the BoilerUI using the GroupMediator.
};

Now, the application can have a global “user interface factory” responsible for generating 
prototype instances as soon as it creates its internal objects. The code of this factory may 
look like the following pseudo-code:
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class myApplication {
      list<Boiler*> boilers;
      void initUI (IlvManager* m) {
           for each machine in boilers
               new BoilerUI(m, machine);
      }
      void add_boiler(Boiler* b) { 
          boilers.append(b); 
          new BoilerUI(getManager(), b); 
      }
};

Advanced Uses of Prototypes

This section describes the following advanced topics on using prototypes:

◆ Writing New Accessor Classes

◆ Creating Prototypes by Coding

◆ Customizing IBM ILOG Views Studio With the Prototypes Extension

Writing New Accessor Classes

The Prototypes package contains many predefined accessor classes that allow you to define 
complex behaviors in your prototypes. You may, however, wish to implement specific 
behaviors for your particular needs. This section explains how you can extend the set of 
accessor classes you use to build your prototypes. It also explains how your new accessor 
classes are integrated into IBM® ILOG® Views Studio.

To add a class of accessors, you simply have to write two classes:

◆ A subclass of IlvUserAccessor that defines the effect of your new accessor.

◆ A subclass of IlvAccessorDescriptor that defines the way your accessor will be 
edited in IBM ILOG Views Studio.

The <ILVHOME>/samples directory of the IBM ILOG Views distribution contains an 
example of a new accessor class (the gpacc.h and gpacc.cpp files). See the README file 
in that directory for more information.

Subclassing IlvUserAccessor

To define a new accessor class, you can either write a direct subclass of IlvUserAccessor 
or derive from an existing subclass that implements the features you want to extend. You 
may also want to make this class persistent.

Defining the Subclass

The declaration of a subclass of IlvUserAccessor will typically appear as follows:

class MyAccessor: public IlvUserAccessor {
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public:
    MyAccessor(const char* name,
               const IlvValueTypeClass* type,
               const char* param1,
               const char* param2);
    DeclareUserAccessorInfo();
    DeclareUserAccessorIOConstructors(MyAccessor);
protected:
    IlvSymbol* _param1;
    IlvSymbol* _param1;
    virtual IlBoolean changeValue(IlvAccessorHolder* object,
                                   const IlvValue& val);
    virtual IlvValue& queryValue(const IlvAccessorHolder* object,
                                 IlvValue& val) const;
}

The following methods must be redefined to create a new accessor class:

◆ MyAccessor

MyAccessor(const char* name,
           const IlvValueTypeClass* type,
           const char* param1,
           const char* param2);

This constructor is used to create an instance of your accessor by code. In 
IBM ILOG Views Studio, only the input constructor will be used. The name parameter 
defines the name of the attribute that will be handled by the accessor and the type 
parameter defines the type of the attribute. Your constructor will probably have 
additional parameters, such as param1. These parameters are often character strings that 
correspond to the parameters that the user can input in IBM ILOG Views Studio and that 
are evaluated at runtime.

◆ changeValue

virtual IlBoolean changeValue(IlvAccessorHolder* object,
                               const IlvValue& val);

The changeValue method is called when the attribute handled by the accessor is 
changed using a call to changeValue on the prototype or one of its instances. You use 
this method to define the effect of changing the value of your accessor. If your accessor 
uses parameters, you must evaluate these parameters. This can be done using the 
getValue method that evaluates a string containing either an immediate value or the 
name of another accessor.

The object parameter is the prototype or the prototype instance to which the accessor is 
attached. The val parameter contains the new value. The changeValue method must 
return IlTrue if the value was successfully changed, or IlFalse if an error occurred 
(for example, if one of the parameters could not be evaluated).

◆ queryValue

virtual IlvValue& queryValue(const IlvAccessorHolder* object,
                             IlvValue& val) const;
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The queryValue method is called when the attribute handled by the accessor is 
retrieved using a call to queryValue on the prototype or one of its instances. This 
method must store the “current” value of the accessor in its val parameter (if doing so is 
appropriate). Some accessors store their current value, while others do not (for example, 
Condition accessors do not store their value). The current value is stored in the val 
parameter using the assignment operator of IlvValue. The method must return its val 
parameter.

◆ initialize

virtual void initialize(const IlvAccessorHolder* object);

The initialize method is called when the accessor object is associated with its 
prototype or prototype instance. You can redefine this method to perform any kind of 
initialization.

Making the IlvUserAccessor Subclass Persistent

Like graphic objects, accessor objects need to be persistent, which means they are saved to 
the prototype definition file and are read when the prototype is loaded. The persistence 
mechanism for accessor objects is very similar to the mechanism used for graphic objects.

First, in the .h file of your accessor class, you must call the following macros in the public 
section of the class declaration:

DeclareUserAccessorInfo();
DeclareUserAccessorIOConstructors(MyAccessor);

This automatically creates the IBM ILOG Views runtime type information for your subclass 
and declares the persistence and copy methods.

In the .cpp file, you then have to write the following methods:

◆ MyAccessor(IlvDisplay* display, IlvGroupInputFile& f)

◆ MyAccessor::MyAccessor(const MyAccessor& source)

◆ MyAccessor::write(IlvGroupOututFile& f) const

This constructor reads the description of your accessor object from an input stream. The 
IlvGroupInputFile class is similar to IlvInputFile. Typically, you use only its 
getStream method. This returns a reference to an istream object from which you can 
read the description of your accessor object. However, the convenience method readValue 
can be used. The writeValue method puts quotation marks around strings containing 
spaces, and the readValue method checks for these quotation marks and reads the string 
correctly. Combined use of these methods avoids input/output errors. For example, the 
implementation of the method could be as follows:

MyAccessor::MyAccessor(IlvDisplay* display, IlvGroupInputFile& f)
: IlvUserAccessor(display, f)
{
        _param1 = f.readValue();
        _param2 = f.readValue();
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}

Next, you have to write a copy constructor that will be called when the prototype is copied 
or when an instance of the prototype is created:

MyAccessor::MyAccessor(const MyAccessor& source)
: IlvUserAccessor(source)
{
        _param1 = source._param1;
        _param2 = source._param2;
}

The write method must be redefined to save the description of the accessor. The format 
used to save the parameters must match the format defined by the input constructor:

MyAccessor::write(IlvGroupOututFile& f) const
{
        IlvUserAccessor::write(f);
        f.writeValue(_param1); f << IlvSpc();
        f.writeValue(_param2); f << endl;
}

Finally, the following macros must be called in the .cpp file:

IlvPredefinedUserAccessorIOMembers(MyAccessor)
IlvRegisterUserAccessorClass(MyAccessor,IlvUserAccessor);

Subclassing IlvAccessorDescriptor

Once you have written your subclass of IlvUserAccessor, you need to write another 
class, a subclass of IlvAccessorDescriptor. This class provides the information needed 
by the Group Inspector of IBM ILOG Views Studio to edit the parameters of your accessor 
class.

The name of the IlvAccessorDescriptor subclass must match the name of the subclass 
of IlvUserAccessor. For example, if your accessor class is MyAccessor, the descriptor 
class must be called MyAccessorDescriptorClass.

You only need to declare the accessor descriptor class. An instance of it will be 
automatically created and associated with your user accessor subclass by the 
IlvRegisterUserAccessorClass macro.

Here is a typical example of a descriptor class:

class MyAccessorDescriptorClass :
public IlvAccessorDescriptor {
public:
    MyAccessorDescriptorClass()
        : IlvAccessorDescriptor("MyAccessor: an example",
                Miscellaneous,
                "example %s %s...",
                IlFalse,
                &IlvValueIntType,
                0,
                2,
I B M  I L O G  V I E W S  P R O T O T Y P E S  V 5 . 3  —  U S E R ’ S  M A N U A L 71



                "Parameter #1", &IlvValueParameterTypeString,
                "Parameter #2", &IlvNodeNameParameterType) {}
};

The accessor descriptor class only requires a constructor with no arguments. It must call the 
IlvAccessorDescriptor constructor. For a detailed explanation of the parameters of this 
constructor, see the description of the IlvAccessorDescriptor class.

Creating Prototypes by Coding

Prototypes are meant to be designed graphically using IBM® ILOG® Views Studio. In 
some cases, however, you may need to create prototypes or to modify existing prototypes 
from a C++ program. This section explains how you can create prototypes by coding in C++ 
instead of designing them with IBM ILOG Views Studio.

Creating a New Prototype

A prototype is represented by an instance of the IlvPrototype class. To create a new 
prototype, use the following constructor:

IlvPrototype* proto = new IlvPrototype("myPrototype");

Adding Graphic Nodes

The first step is to define the graphic appearance of the prototype. This is done by adding 
nodes containing graphic objects. For this, you create instances of the IlvGraphicNode 
class and add them to the prototype using the addNode method.

IlvLabel* label = new IlvLabel(display, 100, 100, "Hello");
IlvGraphicNode* node = new IlvGraphicNode(label, "label", IlTrue);
proto->addNode(node);

The IlvGraphicNode constructor has three parameters:

◆ An IlvGraphic: the graphic object to include in the prototype.

◆ A string: the name of the node.

◆ A Boolean: specifies whether a local transformer should be associated with the graphic 
node. (See the IlvGraphicNode class for details.)

You must give different names to the graphic nodes of your prototype if you need to 
reference them in accessor parameters.

Adding Subgroups

You can create hierarchical objects by adding a subgroup to your prototype. To do this, you 
must add a node that is an instance of the IlvSubGroupNode class. This subgroup can be 
an IlvGroup that you build yourself by adding graphic nodes to it, or it can be an instance 
of another prototype:

// Add a sub-group:
IlvGroup* subgroup = new IlvGroup("subgroup");
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IlvLine* line1 = new IlvLine(display, IlvPoint(100, 100),
                                      IlvPoint(200, 200));
subgroup->addNode(new IlvGraphicNode(line1, "line1"));
IlvLine* line2 = new IlvLine(display, IlvPoint(100, 200),
                                      IlvPoint(200, 100));
subgroup->addNode(new IlvGraphicNode(line2, "line2"));
proto->addNode(new IlvSubGroupNode(subgroup));
// Add a prototype instance as a sub-group:
IlvPrototype* proto = IlvLoadPrototype("samples.pump", display);
IlvProtoInstance* instance = proto->clone();
proto->addNode(new IlvSubGroupNode(instance));

Adding Accessor Objects

Once you have “drawn” your prototype by adding graphic objects to it, you can define its 
properties and specify the effect of changing these properties. To do this, you add accessor 
objects to your prototype. Accessor objects are instances of subclasses of 
IlvUserAccessor.

To add an accessor object to your prototype, create an instance of the appropriate subclass of 
IlvUserAccessor and call the addAccessor method. For example, the following code 
adds two accessor objects to a prototype: an IlvValueAccessor that stores a value and an 
IlvConditionAccessor that tests a condition and changes a attribute according to the 
result.

proto->addAccessor(new IlvValueAccessor("v", IlvValueFloatType));
proto->addAccessor(new IlvConditionAccessor("v", IlvValueFloatType,
                       display,
                       IlvConditionAccessor::IlvCondGreaterThan,
                       "100",
                       "label.label",
                       "Greater than 100",
                       "Smaller than 100"));

See the section Predefined Accessors and the IBM ILOG Views Prototypes Reference 
Manual for a complete description of each accessor class.

Adding the Prototype to a Library

Prototypes must be stored in a prototype library so that they can be saved and reloaded later.

To create a new prototype library, use the IlvProtoLibrary class:

IlvProtoLibrary* protoLib = new IlvProtoLibrary(display,
                                "myLib",
                                "/usr/home/myhome/protos");

A prototype library stores its prototypes in a file system directory ("/usr/home/myhome/
protos" in the previous example). You can change this directory later using the setPath 
method.

To add your prototype to the new library, call the addPrototype method:

protoLib->addPrototype(proto);
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Saving the Prototype

To save your prototype, call the IlvAbstractProtoLibrary::save method:

myLib->save(0, IlTrue);

The first parameter is an optional output stream where the library description file is saved. 
Set it to 0 so that the description file is saved to its default location ("/usr/home/myhome/
protos/myLib.ipl" in the previous example). The second parameter is set to IlTrue to 
specify that all the prototypes must be saved.

Customizing IBM ILOG Views Studio With the Prototypes Extension

This section describes the most important classes that you can derive to extend 
IBM® ILOG® Views Studio with the Prototypes extension.

Extension Class

The IBM ILOG Views Studio extension is represented by the 
IlvStPrototypeExtension class, which is declared in <ILVHOME>/studio/
ivstudio/protos/stproto.h:

class ILVSTPRCLASS IlvStPrototypeExtension 
  : public IlvStExtension {
public:
    IlvStPrototypeExtension(IlvStudio* editor);
    static IlvStPrototypeExtension* Get(IlvStudio* editor);
};  

An instance of this class (or a subclass) must be created after the IlvStudio object is 
created and before the initialize method is called. The static Get method returns the 
(unique) instance of IlvStPrototypeExtension. 

Buffer Classes

IBM ILOG Views Studio defines four subclasses of IlvStBuffer. These classes are also 
declared in  <ILVHOME>/studio/ivstudio/protos/stproto.h.

IlvStPrototypeManagerBuffer

The IlvStPrototypeManagerBuffer class represents a buffer of the “Prototype 
Instances (2D)” type. The NewPrototypeManagerBuffer command creates an instance of 
this class. The manager controlled by an IlvStPrototypeManagerBuffer is an instance 
of IlvManager:

class ILVSTPRCLASS IlvStPrototypeManagerBuffer 
  : public IlvStBuffer
{
public:
    IlvStPrototypeManagerBuffer(IlvStudio*,
                                const char* name,
                                IlvManager* = 0);
};
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IlvStPrototypeEditionBuffer

The IlvStPrototypeEditionBuffer class represents a buffer of the “Prototype” type, 
that is, a buffer used to edit a prototype. The NewPrototypeEditionBuffer command 
creates an instance of this class. The manager controlled by an 
IlvStPrototypeEditionBuffer is an instance of IlvGadgetManager:

class ILVSTPRCLASS IlvStPrototypeEditionBuffer 
  : public IlvStPrototypeManagerBuffer
{
public:
    IlvStPrototypeEditionBuffer(IlvStudio*,
                                const char* name,
                                IlvManager* = 0);
    void editPrototype(IlvPrototype* prototype,
                       IlBoolean fromLib = IlTrue,
    const char* filename = 0);
    IlvPrototype* getPrototype();
    IlvPrototype* getEditedPrototype();
   };

The editPrototype method initializes the buffer so that it can edit the prototype specified 
by prototype. A copy of the prototype is made and is stored in the associated manager. 
The fromLib argument specifies whether the edited prototype is stored in a prototype 
library contained in the Prototypes palette or if the prototype is a “standalone” prototype 
loaded from a .ivp file. In the second case, the optional filename argument can contain 
the full path name of the .ivp file.

The getPrototype() method returns the prototype contained in the buffer. The 
getEditedPrototype() method returns the “original” prototype if the buffer is currently 
editing a prototype from a library. Otherwise, it returns 0.
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C H A P T E R
5

Predefined Accessors

Accessors are basic building blocks that define the value and behaviors of a BGO 
(IlvGroup or IlvPrototype). An attribute usually consists of a Data accessor and one or 
more Control accessors that define its side effects when the attribute is set. This section lists 
the accessor classes that are predefined in the Prototypes library, and is divided as follows:

◆ Overview

◆ Data Accessors

◆ Control Accessors

◆ Display Accessors

◆ Animation Accessors

◆ Trigger Accessors

◆ Miscellaneous Accessors

Overview

Each accessor class is illustrated by one or more sample prototypes. Most of these samples 
are contained in one of the prototype libraries included in the IBM® ILOG® Views 
distribution:
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◆ <ILVHOME>/data/ivprotos/libs

◆ <ILVHOME>/samples/protos/*/data/*.ipl subdirectories

To look at a sample prototype:

1. Launch IBM ILOG Views Studio with the Prototypes extension.

2. Open the .ipl file containing the corresponding prototype library.

3. Double-click on the prototype in the palette.

Graphic Representation of the Behavior of a Prototype

In the examples that illustrate each behavior class, the data flow defined by the accessors of 
a prototype is represented using the following graphic vocabulary:

◆ A rectangle represents an accessor (elementary piece of behavior).

◆ An attribute is represented by a stack of accessors with a given name. In such a stack, the 
accessors are evaluated from top to bottom when the value of the attribute is changed or 
queried.

◆ The order of evaluation is represented by the relative position of an accessor in its stack.

◆ An inset rectangle is used to represent the type of the given attribute.

A graphic representing these items is shown here:

    

Also:

◆ Slots on the sides of accessors represent the parameters of the accessor.

◆ A round slot represents a value parameter.

◆ A square slot represents an object parameter.

◆ Slots at the top represent the input access to a value.

◆ Slots at the bottom represent its output.

◆ Slots on the left side represent input parameters of the accessors (the accessors will query 
their value when they are evaluated).

◆ Slots on the right side represent output parameters (the accessors will change the values).

◆ Finally, slots with an arrow indicate that the value will be pushed instead of simply set. 
The arrow is used to indicate Trigger accessors.
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Data Accessors
A graphic representing these items is shown here:

                   

To complete the model, links or direct values are used to connect the accessor output to other 
input attributes. The following diagram shows a Condition accessor with these conditions. If 
Temperature is set to above 30, the foreground of the Gauge object will be set to Red. 
Otherwise, it will be set to Blue.

            

Data Accessors

Data accessors hold a value or a pointer to values. They define the type of a given attribute. 
They are similar to variable declarations in a programming language such as C++. All 
attributes should contain one of these accessors and no more.

The different Data accessors are described as follows:

◆ Value

◆ Reference

◆ Group

◆ Script

Value 

The Value accessor (class IlvValueAccessor) lets you attach an attribute holding a value 
to a prototype. When the value is modified, it is simply stored. When the value is queried, 
the last value stored is returned.

Note: Some accessors also hold a value (Rotate for instance), which means values that 
hold them do not need an extra Data accessor.
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Parameters

◆ No parameters, but the type of the value must be specified since it cannot be deduced.

Example:

The invertedColor attribute in the pump prototype of the samples prototype library 
stores a color name as a temporary variable.

        

Reference 

The Reference accessor (class IlvNodeAccessor) is used to reference an attribute of one 
of the prototype nodes (also called sub-attributes) at the prototype level. When the 
corresponding attribute is changed, the new value is forwarded to the specified sub-accessor. 
Conversely, when the attribute is queried, it is first queried from the node and forwarded to 
the prototype. A Reference accessor is similar to a reference (a pointer or an alias) in a 
programming language.

Parameters

◆ Accessor: Node attribute or prototype value that holds the value. The type of the value is 
determined by what the accessor points to.

Example

The steps attribute in the thermo prototype of the samples library points directly to the 
steps attribute of the scale object. When the attribute steps is set, it is assigned to the 
scale.step attribute. If the scale.step attribute is changed by the program, any query 
of the attribute returns the new value.

               

Group 

The Group accessor (class IlvGroupUserAccessor) defines an attribute that will 
collectively reference all the sub-attributes of the same name in all group nodes. For 
example, you can use this accessor with the name foreground and the type Color to 
change the foreground color of all the prototype elements in one single assignment. 
80 I B M  I L O G  V I E W S  P R O T O T Y P E S  V 5 . 3  —  U S E R ’ S  M A N U A L



Data Accessors
Parameters

◆ No parameters. The name of the attribute is used to determine the subattribute that will 
be referenced by this accessor. The type of the accessor is implicitly determined.

Example

In the pump prototype of the samples prototype library, a lineWidth attribute can be 
added. The attribute should be of type UInt. Changing this attribute from the Group 
Inspector (using the Attributes notebook page) changes the line width of all the graphic 
objects that have a lineWidth defined.

              

Script 

The Script accessor (IlvJavaScriptAccessor) class lets you program the behavior of 
your prototypes using the scripting language interpreter included in IBM ILOG Views 
Studio.

A Script accessor has two parameters, which are the names of script functions:

◆ The set function is called when the value of the accessor is changed. It must be of the 
form:

function SetX(obj, newval)
{
   ...
}

The obj argument is the prototype associated with the accessor. The newval argument 
is the new value that has been assigned to the attribute.

◆ The get function is called when the value of the accessor is queried. It must be of the 
form:

function GetX(obj)
{
   ...
   return(val);
}

The obj argument is the prototype associated with the accessor. The function must 
return a value, which becomes the new value of the attribute.

In the functions associated with a Script accessor, you can access and modify any prototype 
attribute or a prototype node. Either one of the two function names of the Script accessors 
can be none, in which case no function is called.
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The functions associated with a Script accessor can be edited using the IBM ILOG Views 
Studio Script Editor. They will be saved in a file with a .ijs suffix in the same directory and 
with the same file name as the prototype. Otherwise, they are saved in the prototype file or 
its library file.

Parameters

◆ Script function (set): The name of the script function to execute when the attribute is 
changed.

◆ Script function (get): The name of the script function to execute when the attribute is 
queried.

◆ The type is determined by the value returned from the set function or taken as a 
parameter by the get function. It can, therefore, change dynamically.

Examples

The following function can be used to perform an action similar to a Condition accessor:

function SetTemperature(obj, temperature)
{
    if(temperature > obj. threshold) {
         obj.gauge.foreground = "red";
    } else {
         obj.gauge.foreground = "blue";
    }
}

function GetTemperature(obj)
{
    return obj.gauge.foreground;
}

          

Note: Naming conflicts can occur if you load several prototype instances with the same 
function names in the same panel. Therefore, it is a good idea to prefix the names of all 
the prototype script functions with the prototype name they belong to. For instance, in the 
samples.thermo prototype, if the Temp value has a Script accessor, its functions should 
be called SamplesThermoTempGet() and SamplesThermoTempSet().
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Control Accessors

Control accessors perform side effects on other attributes when they are evaluated. They 
represent the control structures and instructions of a programming language. In the Group 
Inspector, you can view them from the “Behaviors” and “Interaction” notebook pages, under 
the “do” clause attached to each attribute. 

The different Control accessors are described as follows:

◆ Assign

◆ Condition

◆ Format

◆ Increment

◆ Min/Max

◆ Multiple

◆ Notify

◆ Script

◆ Switch

◆ Toggle

Assign 

The Assign accessor (class IlvTriggerAccessor) is used to assign a value to another 
attribute or sub-attribute. When the attribute is set, the target attribute specified by the 
target parameter is assigned the specified value.

Parameters

◆ Attribute: Attribute that is modified when this accessor is evaluated.

◆ Send: Attribute or expression that is assigned to Attribute.

◆ The type of the accessor is undetermined and irrelevant.

Example

The lcd2 prototype of the lcd library uses the Assign accessor.

Note: These accessors are write-only. They do not record the last value tested. If you only 
define a Control accessor for a value, you will not be able to read this value back. To store 
the value associated with an accessor, you must define a Value accessor with the same 
name. 
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Condition 

The Condition accessor (class IlvConditionAccessor) is used to perform a conditional 
assignment of another attribute when the attribute is changed. 

The first parameter defines a condition operator that is applied to the new value of the 
attribute. For example, if the value of the attribute is changed to 10, the operator parameter 
is >, and the operand is 5, the condition tested is 10 > 5. If the operator is 
[Operand_value], the condition tested is only the value of the operand parameter (that is, 
the new value passed to changeValue is ignored).

Depending on the test result, the attribute specified by the Attribute parameter is set to one 
of two values: Value if True or Value if False. The parameters Operand, Value if True, or 
Value if False can be either immediate values (such as 1 or "red"), the names of other 
attributes that will be queried to get the values used, or an expression containing these 
immediate values or attribute names.

Parameters

◆ Operator: The operator used to test the conditions. It can be one of the following: ==, 
!=, >=, <, <=, or [Operand_value].

◆ Operand: The operand value.

◆ Attribute: Prototype value or node attribute that will be set to true or false, depending on 
the condition.

◆ Value if True: Value to which the output is set if the condition is true (or non 0).

◆ Value if False: Value to which the output is set if the condition is false (or 0).

◆ The type of the accessor is undetermined and irrelevant. However, it needs to be 
compatible with the operand type.

Example

The following example shows the thermo prototype in the samples prototype library. If 
the temperature attribute is above 30, the gauge is drawn in red. Otherwise, it is drawn in 
blue.
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Control Accessors
                 

Format

The Format accessor (class IlvFormatAccessor) can be used to convert a numeric value 
of type Double to a character string using a user-specified format. The formatted string is 
then copied to another accessor. The format of the value is specified by the Format 
parameter, which is defined in the C library function printf. The numeric value is passed 
to the conversion function as an IlDouble, so the format should contain a %g specifier. 

Parameters

◆ Format (printf-style): Format string as defined by the printf C library function and 
must be a String value. This string must contain at least one %g, since this accessor can 
only convert values of type Double.

◆ Max # of chars: Maximum length of the string after the conversion. If this length is 
exceeded, the value is replaced by * characters. It must be an Integer value.

◆ Attribute: Attribute to which the formatted value is assigned.

Example

In the display prototype in the samples prototype library, the Format accessor allows you 
to change in NumberField.label the way the value is displayed.

           

Increment 

The Increment accessor (class IlvCounterAccessor) is used to increment another 
attribute. Each time the attribute containing this attribute is set, another attribute, called a 
counter, is increased by one until a specified maximum value is reached. When this value is 
reached, the counter is reset to zero.
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Parameters

◆ Maximum: Maximum value. The value to increase is reset to 0 if it is equal to the 
maximum value.

◆ Attribute: Attribute to increment.

◆ The type of the accessor is undetermined and irrelevant.

Example

A three-state button can be implemented by using a Counter accessor linked to a MultiRep 
accessor. The following accessor has been added to the symbol prototype of the samples 
prototype library. Changing the state_incr value in the Attributes notebook page of the 
Group Inspector increments the state and switches its representation.

              

Min/Max 

The Min/Max accessor (class IlvMinMaxAccessor) is similar to the Condition accessor 
but handles common cases when an attribute must be tested against a minimum and a 
maximum threshold. When the attribute is changed, another attribute is set. The assigned 
value depends on whether the value of the current attribute is less than the minimum, 
between the minimum and the maximum, or greater than the maximum. In addition, an 
exception condition can be specified: if the exception condition is true, no value is changed.

Parameters

◆ Minimum: Defines the minimum value.

◆ Maximum: Defines the maximum value.

◆ Except if: If this value is true, the value is ignored and the output value or attribute is not 
set. The expression must result in a Boolean value.

◆ Attribute: Attribute that is set to one of the following three values.

◆ If x < min: Value to which the attribute is set if the value is less than the minimum.

◆ If min < x < max: Value to which the attribute is set if the value is between the minimum 
and the maximum.

◆ If x > max: Value to which the attribute is set if the value is greater than the maximum.
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Control Accessors
Example 1

This accessor is attached to a Temperature attribute. When Temperature is set, if 
Nobody’s at Home is true, nothing is done. If the Temperature is below 15, HeatOn is 
assigned to ClimateControl. If Temperature is above 25, CoolingOn is assigned to 
ClimateControl. If the temperature is between 15 and 25, AllOff is assigned to 
ClimateControl.

                        

Example 2

This example shows the vertGauge prototype in the sample library.

             

Multiple

The Multiple accessor (class IlvCompositeAccessor) assigns the value of the attribute to 
multiple other attributes or sub-attributes. It can be used, for example, to change the colors 
of two graphic nodes using a single public value of the prototype.

Parameters

◆ This accessor has a variable number of parameters. Each of these parameters is an 
attribute or subattribute, to which the value is assigned.

◆ All parameters must have compatible types.
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Example

This example shows the Color accessor in the thermo prototype.

              

Notify 

The Notify accessor (class IlvOutputAccessor) turns changeValue calls on the 
attribute to which it is attached into pushValue calls. Values that are watching the given 
attribute will execute all their behaviors.

This accessor triggers behaviors of other attributes that depend on the notifying value. For 
example, you can make a change in the Threshold attribute to also re-evaluate the 
Temperature attribute. This can be done by attaching a Notify accessor to the Threshold 
attribute, and a Watch (Threshold) behavior to the Temperature attribute.

Parameters

◆ No parameters.

Example

The following example shows the X_Scale attributes of the transformer prototype in the 
samples library.

              

Script 

This accessor is described in Data accessors under Script.

Switch

The Switch accessor (class IlvSwitchAccessor) implements a switch statement.
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Parameters

◆ Switch: An expression that should return an integer. Depending on its result, the attribute 
0...N will be assigned the value of the parameter.

◆ case 0: Must be an attribute of the prototype or the value "". If Switch evaluates to 0, 
the behaviors of the attribute named in this parameter will be executed.

◆ case 1: If Switch evaluates to 1, the behaviors of the attribute named in this parameter 
will be executed.

◆ ... 

◆ case N: If Switch evaluates to a value equal to or greater than N, the behaviors of the 
attribute named in this parameter will be executed.

Example

A traffic light with varying settings can be implemented like this: 

Value    Integer
do
  Switch Value
  case 0 doRed
  case 1 doOrange
  case 2 doGreen
  case 3 Anomaly

doRed
do 
  greenEllipse.visible=False
  orangeellipse.visible=False
  redEllipse.visible=True
  doBlink=False

doOrange
do 
  greenEllipse.visible=False
  orangeellipse.visible=True
  redEllipse.visible=False
  doBlink=False

doGreen
do 
  greenEllipse.visible=True
  orangeellipse.visible=False
  redEllipse.visible=False
  doBlink=False

Anomaly 
do
  greenEllipse.visible=False
  orangeellipse.visible=True
  redEllipse.visible=False
  doBlink=true

doBlink Boolean
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do
  blink orangeEllipse.visible 150

Toggle

The Toggle accessor (class IlvToggleAccessor) switches another attribute between true 
and false each time the attribute is set. The value assigned to the attribute containing a toggle 
behavior is ignored.

Parameters

◆ Boolean Attribute: Attribute that is switched when the behavior is evaluated. It must be 
a Boolean type (for example, the visibility attribute of the object).

Example

The following example shows the random prototype in the sources prototype library with 
the value toggle.

         

Display Accessors

Display accessors change the graphic appearance of a node. Ultimately, all accessor 
networks end up modifying the appearance of the object and, thus, use some kind of Display 
accessor. General Display accessors such as Rotation, Scale, or Translation change the size 
and position of a graphic node. One accessor, MultiRep, controls the visibility of nodes, and 
other accessors, such as Fill, control object-specific properties.

The different Display accessors are described as follows:

◆ Fill

◆ MultiRep

◆ Rotation

◆ ScaleX

◆ ScaleY

◆ TranslateX

◆ TranslateY
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Display Accessors
Fill  

The Fill accessor operates on two polygon objects contained in a prototype: a filled polygon 
and a filler polygon. The value of the attribute represents a fill level. When the attribute is 
changed, the points of the filler polygon are modified to fill the polygon to the specified 
level. An angle can be specified to fill the polygon in any direction.

Parameters

◆ Filled Graphic Node: Must be an IlvPolygon graphic node.

◆ Filler Graphic Node: Must be an IlvPolygon graphic node.

◆ Angle: A float that indicates the angle at which the fill will be done.

Example

The following is a bottle prototype that contains two polygons: the glass and the wine. A 
Fill accessor is used to define the level property. The filled polygon is the glass and the 
filler polygon is the wine.

            

MultiRep 

The MultiRep accessor (class IlvMultiRepAccessor) is used to switch between different 
representations of a part of your prototype, depending on an integer value. The parameters 
specify a list of nodes that define the different representations. When the value is changed to 
n, the accessor shows the n-th node in the list and hides all the other nodes.

This accessor accepts a variable number of parameters. There are as many representation 
states as you define rows in the parameter editing matrix. A new row is automatically 
created in the matrix when you validate the value of the last parameter.

Parameters

◆ Graphic Node: Defines the node that is shown when the value is 0. Must be a graphic 
node.

◆ Graphic Node: Defines the node that is shown when the value is 1. Must be a graphic 
node.

◆ The type of this value is Int (Integer).
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Example

The symbol prototype of the samples prototype library uses two lines, open and closed, to 
display a two-state switch.

          

Rotation 

The Rotation accessor (class IlvRotationAccessor) lets you set the rotation angle of an 
object to a given value. The value defined by this accessor is the angle (in degrees) to which 
the rotation must be set. The angle is stored every time it is set so resetting the value rotates 
the object by the angle corresponding to the delta between the old and new angles.

The Minimum Angle, Angle Range, Minimum Value, and Value Range parameters are used 
to compute the new rotation angle given to the input value. The new rotation is computed 
from the value assigned to the Rotation accessor using the following formula:

angle = minAngle + (value - minimum)* Anglerange / range

The initial value of the rotation angle is assumed to be the value of the Minimum Angle 
parameter so the initial position of the rotating object must correspond to this value.

Parameters

◆ Graphic Node: Name of the node to rotate. It must be a graphic node.

◆ Center X: X-coordinate of the rotation center. You can use the centerX accessor for this 
parameter (Float or Integer).

◆ Center Y: Y-coordinate of the rotation center. You can use the centerY accessor for this 
parameter (Float or Integer).

◆ Minimum Angle: Minimum angle used to compute the rotation (Float or Integer).

◆ Angle Range: Angle range used to compute the rotation (Float or Integer).

◆ Minimum: Minimum value used to compute the rotation (Float or Integer).

◆ Range: Value range used to compute the rotation (Float or Integer).

Note: Not all graphic objects are sensitive to rotation. Rectangles, ellipses, and text 
objects do not rotate. It is recommended to use polygons and splines instead.
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◆ Handle Interaction: Boolean specifying whether the accessor should behave like an 
Event accessor when the user clicks on the node to rotate it. If it is set to true, the user 
can rotate the node and the accessor value is updated accordingly.

◆ The type of this value is Float (the angle of rotation).

Example

The following example shows a Rotation accessor attached to the transformer prototype 
in the samples library. 

             

ScaleX 

The ScaleX accessor (class IlvZoomXAccessor) lets you set the horizontal scaling factor 
of an object. When the value of this accessor is changed, the object is scaled based on the 
new value. The scaling factor is stored every time it is set so resetting the scale to a different 
value scales the object by the delta of the old and new scaling factors.

Parameters

◆ Graphic Node: Name of the graphic node to scale. It must be a graphic node.

◆ Center X: X-coordinate of the center of the scale (Float or Integer).

◆ The type of this value is Float.

Example

This example shows a Scale accessor attached to a transformer object. The full prototype 
using this accessor is the transformer prototype in the samples library. 

Note:  Not all graphic objects are sensitive to the scaling factor. For example, text objects 
cannot be scaled.
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ScaleY 

The ScaleY accessor (class IlvZoomYAccessor) lets you set the vertical scaling factor of 
an object. When the value of this is changed, the object is scaled based on the new value. 
The scale is stored every time it is set, so resetting the scaling factor to a different value 
changes the size of the object by the delta of the old and new scaling factors.

Parameters

◆ Graphic Node: Name of the graphic node to scale. It must be a graphic node.

◆ Center Y: Y-coordinate of the center of the scale.

◆ The type of this value is Float.

Example

This example shows a Scale accessor attached to a transformer object. The full prototype 
using this accessor is the transformer prototype in the samples library. 

          

TranslateX 

The TranslateX accessor (class IlvSlideXAccessor) moves a node horizontally to a 
position determined by a minimum position, a position range, a minimum value, and a value 
range. The new position is computed from the value assigned to the TranslateX accessor 
using the following formula: 

x = xmin + (v - minimum) * xrange / range

Parameters

◆ Graphic Node: Name of the node to move. It must be a graphic node.

◆ Minimum X: Name of the minimum position (Float or Integer).
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◆ X range: Name of the position range (Float or Integer).

◆ Minimum: Name of the minimum value (Float or Integer).

◆ Range: Name of the value range (Float or Integer).

◆ Handle Interaction: Boolean specifying whether the accessor should behave like an 
Event accessor when the user clicks on the node to rotate it. If it is set to true, the user 
can rotate the node and the accessor value is updated accordingly.

◆ The type of the value is Float.

Example

The use of Translate accessors is similar to the use of Scale accessors, except that Translate 
accessors change the position instead of the size of an object. See the transformer 
prototype in the samples library.

         

TranslateY 

The TranslateY accessor (class IlvSlideYAccessor) moves a node vertically to a position 
determined by a minimum position, a position range, a minimum value, and a value range. 
The new position is computed from the value assigned to the TranslateY accessor using the 
following formula: 

y = ymin + (v - minimum) * yrange / range

Parameters 

◆ Graphic Node: Name of the node to move. It must be a graphic node.

◆ MinimumY: Minimum position (Float or Integer).

◆ Y range: Position range (Float or Integer).

◆ Minimum: Minimum value (Float or Integer).

◆ Range: Value range (Float or Integer).
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◆ Handle Interaction: Boolean specifying whether the accessor should behave like an 
Event accessor when the user clicks on the node to rotate it. If it is set to true, the user 
can rotate the node and the accessor value will be updated accordingly.

◆ The type of the value is Float (the distance of translation).

Example

The use of TranslateX and TranslateY is similar to the use of scaleX and scaleY accessors.

        

Animation Accessors

Animation accessors (class IlvAnimationAccessor) are a category of the Display 
accessors that change the appearance of an object periodically. Animation accessors hold a 
value of a Boolean type indicating whether the animation is on.

For efficiency reasons, the Animation accessors do not reevaluate their attributes at each 
count of the timer. Thus, if you change one of the attributes of the accessor, you must 
reassign the value to itself to force an update of the parameters, using the Assign accessor 
for instance. See the pump prototype in the samples library for an example.

The different Animation accessors are described as follows:

◆ Blink

◆ Invert

◆ Rotate

Blink

The Blink accessor (class IlvBlinkAccessor) makes an object of your prototype blink, 
that is, it causes the object to appear and disappear at brief, regular intervals. When the 
attribute is set to IlTrue, the object starts blinking. When the attribute is set to IlFalse, 
the blinking stops.
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Parameters

◆ Boolean Attribute: Object attribute that controls the object visibility.

◆ Period (ms): The interval in milliseconds between two blinks (Float or Integer).

◆ The type of this value is Boolean. 

Example

The following example shows the file prototype in the sources library with a blink value.

        

Invert

The Invert accessor (class IlvInvertAccessor) inverts the color of an element of your 
prototype periodically. When the property is set to IlTrue, the color inversion begins. 
When the attribute is set to IlFalse, the color inversion stops.

While the colors are designated as the foreground and background colors, any colors defined 
by the prototype or one of its nodes can be used.

Parameters

◆ Fg Col. Attribute: Node attribute or prototype value that contains the foreground color.

◆ Bg Col. Attribute: Node attribute or prototype value that contains the background color.

◆ Period (ms): The interval, in milliseconds, between two inversions of the object colors 
(Float or Integer).

◆ Type: Boolean (whether the accessors are exchanging their values).

Example

This example is presented in the pump prototype of the samples prototype library. When 
invert is set to true, the values of rotorColor and invertedColor are exchanged 
periodically. The period is defined by the invert attribute.

Note: The invertPeriod value has an Assign behavior: invert = invert. This forces 
the accessors to be reevaluated and the internal timer to update its period whenever the 
period is changed.
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Rotate

The Rotate accessor (class IlvRotateAccessor) defines a behavior that, when set to 
IlTrue, makes an object rotate periodically.

The Angle parameter specifies the number of degrees by which the object rotates at every 
timer tick. The Center X and Center Y parameters define the rotation center. You should not 
use the center of the rotating node itself for these parameters because the rounding problems 
that occur while rotating an object might move it slightly. Instead, you should use the center 
of another fixed object of the prototype. You can make this reference object invisible if 
necessary.

Parameters

◆ Graphic Node: Name of the node to rotate. Can be a graphic node or a subgroup node.

◆ Angle: Angle in degrees by which the object is rotated at each step (Float or Integer).

◆ Center X: X-coordinate of the rotation center. You can use the centerX accessor for this 
parameter (Float or Integer).

◆ Center Y: Y-coordinate of the rotation center. You can use the centerY accessor for this 
parameter (Float or Integer).

◆ Period (ms): The interval in milliseconds at which the object rotates. It must be an 
Integer.

Example

This example is presented in the pump prototype of the samples prototype library. When 
the Rotate accessor is set to true, the nodes will turn by 20 degrees every 10 ms.
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Trigger Accessors

Trigger accessors define the entry points of evaluation sequences in the graph of accessors. 
Triggers are accessors that can react to a user event (callback and event), a change in a node 
by the application (by means of the pushValue method), or some other node change (a 
combination of Trigger and Connect).

The different Trigger accessors are described as follows:

◆ Callback

◆ Clock

◆ Watch

◆ Event

Callback

This accessor (class IlvCallbackAccessor) attaches a trigger that is set when the given 
callback is called from a user action on the specified graphic node. For a callback to be 
called, the node must be either an IlvGadget or an IlvGraphic to which an interactor has 
been attached.

Parameters

◆ Graphic Node: The name of the graphic node whose callback is triggered.

◆ Callback Name: The name of the callback.

◆ Input: The value that is sent when the callback is triggered.

Example

The following example shows the random prototype in the sources library with the 
clicked value. The clicked value pushes 0 to its output when the button is pressed by the 
user. This output is connected to the toggle value, which in turn switches the running 
value.
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Clock

The Clock accessor (class IlvAnimationAccessor) triggers its attribute periodically, 
executing the attached behaviors. When set to 0, this accessor has no behavior. When set to 
another value, this value is used as the period of an internal timer that triggers the behavior 
periodically.

Parameters

◆ The type of this value is UInt. If non-zero, the attribute will not have any effect. 
Otherwise, its value is interpreted as a timer period.

Watch

The Watch accessor (class IlvLoopbackAccessor) makes its attached attribute observe 
another notifying attribute.

This accessor class is often used with the Callback accessor to change a value of the 
prototype when a callback is triggered. The Watch accessor connects the triggering attribute 
containing the callback to the watching attribute that must be changed.

Parameters

◆ Notifying Attribute: Attribute that is observed. This attribute must be one of the 
attributes that has a Notify or a Callback accessor.

Example

The Watch clicked accessor links the clicked value to the toggle value, which allows the 
running attribute to be switched whenever the user presses the button attached to the 
clicked value.
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Event 

The Event accessor (class IlvEventAccessor) is used to trigger a behavior in response to 
user or other application events. When an event of a given type occurs while the mouse 
pointer is over a node of the prototype, the attribute to which the accessor is attached is 
evaluated, that is, all its behaviors are set.

While the callback pushes its value to another attribute of the prototype, the event notifies its 
own attached attribute. The event is thus similar to attaching a Watch accessor to itself after 
attaching a callback.

Parameters

◆ Graphic Node: The name of a graphic node. Events received from the input devices are 
sent to the accessor over this graphic node to trigger a behavior. The special value 
[All Nodes] indicates that this value is triggered when any event of the given type 
reaches any of the graphic nodes of the prototype.

◆ Event Type: The event type that triggers the accessor. The type can be any of the 
standard IBM ILOG Views event types: AnyEvent, KeyUp, KeyDown, ButtonDown, 
ButtonUp, EnterWindow, LeaveWindow, PointerMoved, ButtonDragged, 
Repaint, ModifyWindow, Visibility, MapWindow, UnMapWindow, Reparent, 
KeyboardFocusIn, KeyboardFocusOut, DestroyWindow, ClientMessage, and 
DoubleClick.

◆ Detail: The detail of the event. This parameter indicates additional filtering of the events 
and depends on the event type. For example, for a ButtonDown event, the detail can be: 
AnyButton, LeftButton, RightButton, MiddleButton, Button4, or Button5. 
For a KeyDown event, the detail parameter indicates the key, or AnyKey that triggers the 
accessor. See the IlvEvent class for a list of the valid keys.

◆ Modifiers: Indicates which modifiers should be pressed. Possible values are: 
AnyModifier, NoModifier, Shift, Ctrl, Meta, Alt, Num, Lock, Alt+G, or any 
combination of the previous modifiers such as Shift+Crtl, Ctrl+Shift+Alt, and so 
on.
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◆ Event data to send: The Event attribute that is pushed to the current value. It can be the 
Type, Detail, X (the horizontal position of the mouse relative to the window), Y (the 
vertical position of the mouse relative to the window), GlobalX, or GlobalY (the position 
of the mouse relative to the screen).

Example

The following example shows the transformer prototype with an EventScaleY value in 
the samples library:

     

Miscellaneous Accessors

These accessors do not fit current existing categories.

The different Miscellaneous accessors are described as follows:

◆ Debug

◆ Prototype

Debug

The Debug accessor (class IlvDebugAccessor) is used to debug prototypes. It prints a 
message to the console or the output window when the corresponding value is modified or 
queried.

Example

When the following doTranslateY accessor is queried or changed, a message is printed to the 
output console, displaying the current value:
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Prototype

The Prototype accessor (class IlvPrototypeAccessor) allows a new prototype to inherit 
from all the accessors of an existing prototype. The new prototype behaves as if all the 
accessors of an existing prototype were added to it. This is useful when building libraries of 
complex behaviors and in reusing them in other prototypes. The prototype library containing 
the prototype must be open in order for any instance using this accessor to work properly. 
From the Group Inspector in IBM ILOG Views Studio, you can add a Prototype accessor to 
a prototype by selecting the Attributes tab and choosing the Edit>Delegate to Prototype 
item.

Parameters

◆ Prototype name: Name of the prototype that you want to inherit accessors from.

Example

This accessor is represented as a subgraph showing all the values exported in the context of 
the current accessor graph.

The diclock prototype of the sources library encapsulates and exports all the accessors of 
the clock prototype. It behaves exactly like the clock prototype but has a different graphic 
representation.
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