WebSphere Business Integration Server

Express and Express Plus

Quick Start Guide

Version 4.3

<|ll






WebSphere Business Integration Server

Express and Express Plus

Quick Start Guide

Version 4.3

<|ll



Note!
FBefore using this information and the product it supports, read the information in|“Notices” on page 9/

14May2004

This edition of this document applies to IBM WebSphere Business Integration Server Express, version, 4.3, IBM
WebSphere Business Integration Server Express Plus, version 4.3, and to all subsequent releases and modifications
until otherwise indicated in new editions.

To send us your comments about this document, e-mail doc-comments@us.ibm.com. We look forward to hearing
from you.

When you send information to IBM, you grant IBM a nonexclusive right to use or distribute the information in any
way it believes appropriate without incurring any obligation to you.

© Copyright International Business Machines Corporation 2004. All rights reserved.
US Government Users Restricted Rights — Use, duplication or disclosure restricted by GSA ADP Schedule Contract
with IBM Corp.




Contents

About this document .
Audience ..

Related documents . ..
Conventions used in this guide .
New in this release.

Quick Start Guide
Contacting product support

Validating your system after installation .

Next steps .
Notices .

Programming interface information
Trademarks and service marks .

© Copyright IBM Corp. 2004

. . .
_

<

. vi
. vii

.
g = = =k

- o O

iii



1V Quick Start Guide



About this document

The products IBM® WebSphere® Business Integration Server Express and IBM®
WebSphere™ Business Integration Server Express Plus consist of the following
components: InterChange Server Express, the associated Toolset Express,
CollaborationFoundation, and a set of software integration adapters. The tools in
Toolset Express help you to create, modify, and manage business processes. You
can choose from among the prepackaged adapters for your business processes that
span applications. The standard processes template, CollaborationFoundation,
allows you to quickly create customized processes.

The SystemTest samples are provided as a means of validating the IBM WebSphere
Business Integration Server Express V4.3 and IBM WebSphere Business Integration
Server Express Plus V4.3 systems after installation.

This document describes how to use these samples to validate your system.

Except where noted, all the information in this guide applies to both IBM
WebSphere Business Integration Server Express and IBM WebSphere Business
Integration Server Express Plus. The term WebSphere Business Integration Server
Express and its variants refer to both products.

Audience

This document is for consultants and system administrators who install, deploy,
and administer WebSphere Business Integration Express.

Related documents

© Copyright IBM Corp. 2004

The complete set of documentation available with this product describes the
features and components common to all WebSphere Business Integration Server
Express and WebSphere Business Integration Server Express Plus installations, and
includes reference material on specific components.

You can install the documentation on your machine or read it directly online at the
following site: |http://www.ibm.com/websphere/wbiserver/express/infocenter|

After completing the instructions provided in this document for validating your
product installation, refer to the documents listed below to learn more about these
specific tasks.

* For information about the IBM WebSphere Business Integration Server Express
and Express Plus products and the steps necessary to implement a solution, refer
to the System Implementation Guide.

* For information about installing the optional Adapter or Collaboration Capacity
Packs, available only with the IBM WebSphere Business Integration Server
Express Plus product, refer to the WebSphere Business Integration Server Express
Installation Guide.

* For information about performing the final configuration tasks for your
implementation, including configuration of the adapters installed with IBM
WebSphere Business Integration Server Express and Express Plus and the
optional Adapter Capacity Pack, refer to the System Implementation Guide.


http://www.ibm.com/websphere/wbiserver/express/infocenter

For your convenience, the reference list shown above is also provided at the end of

this document in the section entitled * "

Notes:

1.

In the SystemTest samples, the adapters have been configured to use IDL as
the transport mechanism. These samples do not test an implementation using
JMS as the transport mechanism. For information about configuring adapters to
use JMS as the transport mechanism, see the System Implementation Guide.

Important information about this product may be available in Technical
Support Technotes and Flashes issued after this document was published.
These can be found on the WebSphere Business Integration Support Web site,
[http:/ /www.ibm.com /software/integration/websphere /support/} Select the
component area of interest and browse the Technotes and Flashes sections. The
site contains simple directions for downloading, installing, and viewing the
documentation.

Conventions used in this guide
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This document uses these abbreviations and style conventions:

Abbreviations are used for some words and some variables in syntax statements.
These abbreviations are used:

BO* = business object (prefix to a BO file) ICS = InterChange Server Express

ObjectName* = variable name for business
object

* B0 is the prefix to a BO file; the term BO generally refers to the business object
definition text files. ObjectName refers to the variables used to represent business
objects.

The term “camelcase,” used in this document, refers to a style of capitalization
whereby the spaces between words are eliminated, and the first letter of each
word (or more than one letter if using acronyms) is capitalized. For example, the
term SystemTest is in camelcase.

In addition, this document uses some or all of the following typographical
conventions:

Bold Indicates a literal value, such as a command name, filename,

information that you type, or information that the system
prints on the screen.

italic Indicates a variable name, a cross-reference, or a new term

the first time it appears.

blue outline A blue outline, which is visible only when you view the

manual online, indicates a cross-reference hyperlink. Click
inside the outline to jump to the object of the reference.

In a syntax line, curly braces surround a set of options from
which you must choose one and only one.

In a syntax line, square brackets surround an optional
parameter.

In a syntax line, ellipses indicate a repetition of the previous
parameter. For example, option][,...] means that you can enter
multiple, comma-separated options.

<> In a naming convention, angle brackets surround individual

elements of a name to distinguish them from each other, as
in <server_name><connector_name>tmp.log.



http://www.ibm.com/software/integration/websphere/support/

/. \ In this document, backslashes (\) are used as the convention
for directory paths. All WebSphere Business Integration
Server Express system product pathnames are relative to the
directory where the product is installed on your system.

Y%text% and $text Text within percent (%) signs indicates the value of the
Windows text system variable or user variable.
ProductDir Represents the directory where the product is installed.

New in this release

This is the first release of this guide.

About this document Vil
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Quick Start Guide

This document describes how to use the SystemTest samples to validate the system
after installing the IBM®™ WebSphere™® Integration Server Express V4.3 or the
IBM® WebSphere® Integration Server Express Plus V4.3 product.

Note: This document assumes that you have successfully installed the WebSphere
Business Integration Server Express or Express Plus product, selected and
installed Samples from the feature screen during installation to install the
System Test samples, and registered InterChange Server Express using
System Manager. If you have not yet installed the WebSphere Business
Integration Server Express or Express Plus product, the System Test samples,
and registered InterChange Server Express, see WebSphere Business Integration
Server Express Installation Guide

Except where noted, all the information in this guide applies to both IBM
WebSphere Business Integration Server Express and IBM WebSphere Business
Integration Server Express Plus. The term WebSphere Business Integration Server
Express and its variants refer to both products.

This chapter includes the following sections:

+ |“Contacting product support’|

+ [“Validating your system after installation”]

+ |“Starting InterChange Server Express” on page 2|

* [“Starting System Manager” on page 2|

* [“Verifying that all necessary components are working correctly” on page 2|

+ |[“Using Test Connector to view business data” on page 2|

* [“Using Test Connector with the SystemTest interface” on page 6

Contacting product support

For support issues relating to the WebSphere Business Integration Server Express
product, contact IBM Customer Support either online or by telephone:

* Visit the IBM WebSphere Business Integration Server Express technical support
Web site, [http:/ /www.ibm.com /software/integration/websphere /support /|

* Contact IBM WebSphere Business Integration Server Express support by
telephone within the USA or Canada at 1-800-IBM-SERV. For all other countries,
go to Ihttp: / /techsupport.services.ibm.com/guides/ contacts.html| to find the
correct telephone number for your geographic location.

Validating your system after installation

This section provides a high-level overview of the procedures required to validate
your system after you have successfully installed the IBM WebSphere Business
Integration Server Express product.

» |“Starting InterChange Server Express” on page 2|

* |“Starting System Manager” on page 2|

G

* |“Verifying that all necessary components are working correctly” on page 2

. "’Using Test Connector to view business data” on page 2|

© Copyright IBM Corp. 2004 1
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* |"Using Test Connector with the SystemTest interface” on page 6§

Note: If you have already started InterChange Server Express and System
Manager, begin with the section [“Verifying that all necessary components|
[are working correctly.”|

Starting InterChange Server Express

To start InterChange Server Express, click Start > Programs > IBM WebSphere
Business Integration Express > InterChange Server Express. InterChange Server
Express automatically starts the Persistent Naming server.

Starting System Manager

After you have started InterChange Server Express, start WebSphere Workbench
and System Manager.

Click Start > Programs > IBM WebSphere Business Integration Express > Toolset
Express > Administrative > System Manager.

For information about System Manager, see the System Implementation Guide.

Verifying that all necessary components are working correctly

After starting System Manager, verify that all the connector and collaboration
objects are working correctly.

1. Expand the WebSphereICS server instance.

2. Expand the Connectors folder. Each active connector has a green-arrow icon
displayed beside it. Verify that each of the following connectors are active
(marked by a green-arrow icon):

e DestinationConnector
* SourceConnector
* SystemTestConnector

3. If a connector is not active, right-click it, and then click Start connector_name in
the context menu.

4. Expand the Collaboration Objects folder. Each active collaboration object has a
green-arrow icon displayed beside it. Verify that each of the following
collaboration objects are active (marked by a green-arrow icon).

¢ CustomerSynchronization_SourceToDestination
* SystemTestObject

5. If a connector is not active, right-click it, and then click Start collaboration_name
in the context menu.

Using Test Connector to view business data

2 Quick Start Guide

Test Connector is a graphical interface that presents the structure of a business
object in a tabular view. Connectors exchange data with applications through
business logic and so do not have a graphical interface. Test Connector emulates
connectors using a graphical view, making it easier to understand the role of a
connector in an interface, while removing the complexity of running actual
connectors.

The CustomerSynchronization_SourceToDestination collaboration object tests the
IBM WebSphere Business Integration Server Express system by sending business
objects from one instance of Test Connector to another. The Customer business



object is flat rather than hierarchical. It does not contain any other business objects.
The CustomerSynchronization collaboration template sends business objects, sent
by the source connector in the interface, to the destination connector, and does not
apply any noteworthy business logic. The SourceConnector and
DestinationConnector definitions represent the server-side component of a
connector. They do not represent executable connectors. These definitions are
sufficient to validate the subsystems of IBM WebSphere Business Integration Server
Express.

The following instructions use Test Connector to emulate connectors exchanging
data through the WebSphere Business Integration Server Express system.

Note: For the purpose of these instructions, it is assumed that you have started
InterChange Server Express|and [System Manager,| and verified that the
connectors and collaboration objects|are active.

1. Click Start > Programs > IBM WebSphere Business Integration Express >
Development > Test Connector to start Test Connector.

2. Click File > Create/Select Profile in the Test Connector menu bar.

3. Click to select the SourceConnector profile, and then click OK. The Connector
Profile dialog is shown below with the SourceConnector profile selected.

Connector Profile ' |
File Edi

%ﬁlwl ® |

Connector | Server | Configuration File |

SourceConnector ‘WebSpherelCS CIBM|WebSphereServer .,

DestinationConnector ‘WebspherelZ5 CHIBMYwebSphereServer. ..

I Ok, II Cance| I

4. Click File > Connect in the Test Connector menu bar. This action connects the
current instance of Test Connector with the SourceConnector profile loaded to
the server.

Note: Steps 1 through 4, shown above, launched the first instance of Test
Connector and specified the SourceConnector profile. Steps 5 through 8, shown
below, launch a second instance of Test Connector and specify the
DestinationConnector profile.

5. Click Start > Programs > IBM WebSphere Business Integration Express >
Toolset Express > Development > Test Connector to start Test Connector.

6. Click File > Create/Select Profile in the Test Connector menu bar.

7. Click to select the DestinationConnector profile, and then click OK. The
Connector Profile dialog is shown below with the DestinationConnector

Quick Start Guide 3
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profile selected.

Connector Profile EI

Fil= Edit

%‘ﬂ'lm :|

Connector | Server | Configuration File |
SourceConneckar \WebSphereICS CHAIEMYWebSphereServer, ..
DestinationConnector WwebhSphereICS CH TR

ebSphereSeryer, .,

| ok Il Cancel I

8. Click File > Connect in the Test Connector menu bar. This action connects the
current instance of Test Connector with the DestinationConnector profile
loaded to the server.

9. In the instance of Test Connector that has the DestinationConnector profile
loaded, click Edit > Load BO in the menu bar.

10. In the Look in list within the Open dialog, select \ProductDir
\Samples\SystemTest, and then click to select the Customer.bo folder.

The Open dialog is shown below.

_ldata
[:I repositary

Customer,bo

File name: I j Open |
Filzs of type: |E|usiness Ohjects(* ba) j Cancel |

)

11. Click Open to open the Customer.bo file and display the New Instance dialog.

12. Type Customer_0 in the Enter Name field, and then click OK. The new
Instance dialog, with Customer_0 typed in the Enter Name field, is shown



below.

New Instance x|

Entet Mane Cugtnmer_lil|

(0] 4 Cance! I

13. Note the values, for example FirstName, String, Tom, in the fields of the
Customer business object, as shown below.

Tame | Type | alue |
CustomerId Skring 1000324
FirstMarme Skring Tom
LaskMarme Skring Barrymore
Skatus Skring Ackive
CreatedOnD...  String 100912003
OhjectEventId  String SourceConne. ..

14. Click Request > Send in the menu bar to send the business object.

15. Give focus to the instance of Test Connector that has the DestinationConnector
profile loaded. If the BO Request List pane contains Customer.Create, as
shown below, the Customer business object has been received.

B Request Lisk
Customer, Create

Quick Start Guide 5



16.

17.

18.

19.

Double-click the Customer.create event to view it as a response business
object. The Response BO dialog is shown below.

i Response BO ﬂ
& 7| &

BO Twpe I Customer
erb: ICreate 'I BOLDcaIe:I 'I

Mare | Tyvpe | Walue |
CustamerId Skring 1000324
FirskMane Skring Tarm
LastMame Skring Earrymare
Status Skring Active
CreatedOnD... String 10/09/2003
ObjectEventId  String SourceCanne. ..

Cancel |

Optional: Double-click in each of the fields to edit the data in the way that a
destination application typically assigns its own unique values to events that
it processes. Click Ok when you have finished editing the fields.

Click Request > Reply > Success in the menu bar to simulate the destination
application successfully processing the business object and returning it to
InterChange Server Express.

When you have finished sending and replying to events, click File > Exit in
the Test Connector menu bar, and then click Yes when prompted to shut
down Test Connector.

Using Test Connector with the SystemTest interface

The following instructions use Test Connector to process text files through a pair of
interfaces in the system.

Note: For the purpose of these instructions, it is assumed that you have started

oo~ 0D
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InterChange Server Express|and [System Manager,|and verified that the
connectors and collaboration objects|are active.

Click Start > Programs > IBM WebSphere Business Integration Express >
Toolset Express > Development > Test Connector to start Test Connector.

Click File > Create/Select Profile in the Test Connector menu bar.
Select the SystemTestConnector profile, and then click OK.

Click File > Connect in the Test Connector menu bar.

Click Edit > Load BO in the Test Connector menu bar.

In the Open dialog, select the \ProductDir \Samples\SystemTest folder, and
then open the file named Employee.bo.

In the New Instance dialog, type Employee_0 in the Enter Name field, and
then click OK.

Note the values specified for the fields of the Employee business object.
Click Request > Send in the menu bar to send the business object.

Note that the BO Request List pane shows that the Employee business object
has been received.



1.

12.

13.

14.

15.

Double-click the Employee.create event to view it as a response business
object.

Optional: Double-click in each of the fields to edit the data, and then click OK

when you are finished.

Click Request > Reply > Success in the menu bar to simulate the destination
application successfully processing the business object and returning it to
InterChange Server Express.

Repeat steps 9 through 13 to send more events. The interface is designed to
fail approximately one of out of every sixteen events to provide you with a
supply of failed events that you can use to learn about Flow Manager. If an
event you send does not appear in the BO Request List pane, the interface ha
failed to process it. For information about Flow Manager, see the System
Implementation Guide.

When you have finished sending and replying to events, click File > Exit in
the Test Connector menu bar, and then click Yes when prompted to shut
down Test Connector.

S

Next steps

After completing the instructions provided in this document to validate your
product installation, see the documents listed below to learn more about these
specific tasks.

* For information about the IBM WebSphere Business Integration Server Express
and Express Plus products and the steps necessary to implement a solution, see
the System Implementation Guide.

* For information about installing the optional Adapter or Collaboration Capacity
Packs, available only with the IBM WebSphere Business Integration Server
Express Plus product, see the WebSphere Business Integration Server Express
Installation Guide.

* For information about performing the final configuration tasks for your
implementation, including configuration of the adapters installed with IBM
WebSphere Business Integration Server Express and Express Plus and the
optional Adapter Capacity Pack, see the System Implementation Guide.

Quick Start Guide
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Notices

IBM may not offer the products, services, or features discussed in this document in
all countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or program(s) described in this publication
at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Burlingame Laboratory Director
IBM Burlingame Laboratory
577 Airport Blvd., Suite 800

© Copyright IBM Corp. 2004 9



Burlingame, CA 94010
US.A

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurement may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not necessarily tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

This information may contain examples of data and reports used in daily business

operations. To illustrate them as completely as possible, the examples may include

the names of individuals, companies, brands, and products. All of these names are

fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

COPYRIGHT LICENSE

This information may contain sample application programs in source language,
which illustrates programming techniques on various operating platforms. You
may copy, modify, and distribute these sample programs in any form without
payment to IBM, for the purposes of developing, using, marketing or distributing
application programs conforming to the application programming interface for the
operating platform for which the sample programs are written. These examples
have not been thoroughly tested under all conditions. IBM, therefore, cannot
guarantee or imply reliability, serviceability, or function of these programs.

Programming interface information

10  Quick Start Guide

Programming interface information, if provided, is intended to help you create
application software using this program.

General-use programming interfaces allow you to write application software that
obtain the services of this program’s tools.



However, this information may also contain diagnosis, modification, and tuning
information. Diagnosis, modification and tuning information is provided to help
you debug your application software.

Warning: Do not use this diagnosis, modification, and tuning information as a
programming interface because it is subject to change.

Trademarks and service marks

The following terms are trademarks or registered trademarks of International
Business Machines Corporation in the United States or other countries, or both:

IBM

the IBM logo
AIX
CrossWorlds
DB2

DB2 Universal Database
Domino
Lotus

Lotus Notes
MQIntegrator
MQSeries
Tivoli
WebSphere

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

MMX, Pentium, and ProShare are trademarks or registered trademarks of Intel
Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

Other company, product or service names may be trademarks or service marks of
others.

System Manager includes software developed by the Eclipse Project
(http:/ /www.eclipse.org/)

e
JAVA.

WebSphere Business Integration Server Express V4.3 and WebSphere Business
Integration Server Express Plus V4.3

Notices 11
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