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About this document

The products IBM® WebSphere® Business Integration Server Express and IBM®
WebSphere™ Business Integration Server Express Plus include the following
components: Interchange Server Express, the associated Toolset Express,
CollaborationFoundation, and a set of software integration adapters. The tools in
Toolset Express help you to create, modify, and manage business processes. You
can choose from among the prepackaged adapters for your business processes that
span applications. The standard processes template--CollaborationFoundation--
allows you to quickly create customized processes.

This document provides an introduction to the use of maps and relationships and
describes how to use Map Designer Express and Relationship Designer Express for
creating and modifying maps and relationships.

Except where noted, all the information in this guide applies to both IBM
WebSphere Business Integration Server Express and IBM WebSphere Business
Integration Server Express Plus. The term "WebSphere Business Integration Server
Express” and its variants refer to both products.

Audience

This document is for connector developers, collaboration developers, and IBM
WebSphere consultants who create or modify business object definitions or maps.

How to use this manual

This manual is organized as follows.

Part I: Maps
[Chapter 1, “Introduction to map development”| Is an overview of maps and the WebSphere
Business Integration Express mapping tools.
[Chapter 2, “Creating maps”| Provides an introduction to the use of Map

Designer Express for the creation and
modification of maps.

[Chapter 3, “Working with maps”| Describes some advanced features of Map
Designer Express that you might use after
creating maps.

[Chapter 4, “Compiling and testing maps”| Describes how to compile a map into its
executable form and how to run a test run to
verify the map’s correctness.

[Chapter 5, “Customizing a map’]| Describes how to implement maps.
Part II: Relationships
[Chapter 6, “Introduction to Relationships”] Provides an introduction to relationships,

including the kinds of relationships that
WebSphere Business Integration Express
supports and the way the system implements a
relationship.

[Chapter 7, “Creating relationship definitions”] Provides an introduction to the use of
Relationship Designer Express for the creation
and modification of relationship definitions.

[Chapter 8, “Implementing relationships’] Describes how to implement relationships.

Part III: Mapping API Reference

© Copyright IBM Corp. 2004 ix



Chapter 9, “BaseDLM class’]

Chapter 10, “BusObj class”|

Chapter 11, “BusObjArray class”]

Chapter 12, “CwDBConnection class”|

Chapter 13, “CwDBStored ProcedureParam class”]
Chapter 14, “DtpConnection class”|

Chapter 15, “DtpDataConversion class”|
Chapter 17, “DtpMapService class”|

Chapter 18, “DtpSplitString class’|

Chapter 19, “DtpUtils class”|

Chapter 20, “IdentityRelationship class’]
Chapter 21, “MapExeContext class”|

Chapter 22, “Participant class”|

Chapter 23, “Relationship class”]

Chapter 24, “UserStoredProcedureParam class”|
[Appendix A, “Message files”|

[Appendix B, “Attribute properties”|

Contain reference pages for methods of classes in
the Mapping APL

Related documents

The complete set of documentation describes the features and components
common to all WebSphere Business Integration Server Express and WebSphere
Business Integration Server Express Plus installations, and includes reference

material on specific components.

You can download, install, and view the documentation at the following site:
http:/ /www.ibm.com /websphere /wbiserverexpress/infocenter

Note: Important information about this product may be available in Technical
Support Technotes and Flashes issued after this document was published.
These can be found on the WebSphere Business Integration Support Web

site, |http:/ /www.ibm.com /software/integration /websphere /support/|

Select the component area of interest and browse the Technotes and Flashes

sections.

Typographic conventions

This document uses the following conventions:

courier font

Indicates a literal value, such as a command name,

information that you type, or information that the system
prints on the screen.

italic or italic

Indicates a variable name, title name, or new term the first

time that it appears

blue outline

A blue outline, which is visible only when you view the

manual online, indicates a cross-reference hyperlink. Click
inside the outline to jump to the object of the reference.

ProductDir

Represents the directory where the product is installed.

X  Map Development Guide


http://www.ibm.com/software/integration/websphere/support/

New in this release

This section describes the new and changed features of IBM WebSphere Business
Integration Server Express and IBM WebSphere Business Integration Server Express
Plus and their associated tools for map and relationship development, which are
covered in this document.

New in release 4.3

This is the first release of this guide.
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Chapter 1. Introduction to map development

This chapter provides an overview of data mapping, introduces the tools you use
to implement maps, and describes map and relationship definitions.

This chapter covers the following topics:

* [“About data mapping” on page 3|

* ["Maps: A closer look” on page 5

» [“Tools for map development” on page 7

+ [“Overview of map development” on page 11|

About data mapping

Data mapping is the process of transforming (or mapping) data from one
application-specific format to another. Mapping is central to the process of
transferring information between different applications, and for providing
collaborations (business processes) that are independent of specific applications. By
mapping data between application-specific business objects and generic business
objects, WebSphere creates the environment that allows for the use of “best of
breed” applications. The WebSphere business integration system provides a
modular and extensible architecture for easy maintenance of your maps.

The WebSphere map development system provides comprehensive support for
mapping between business objects, including the following capabilities:

* Transforming data values from one or more attributes in a source business object
to one or more attributes in a destination business object

* Establishing and maintaining relationships between data entities that are
equivalent but are represented differently and cannot be directly transformed

* Enabling access to external mapping resources, such as third-party mapping
products and databases for performing queries

When data mapping is set up among differing applications, an event occurrence in
one application is performed in any other application to which it is mapped. An
event occurrence can be when data is created, retrieved, updated, or deleted.

Mapping uses maps that define the transfer (or transformation) of data between the
source and destination business objects. In the map development environment,
data is mapped from an application-specific business object to a generic business
object or from a generic business object to an application-specific business object.
lists the types of mapping required.

Table 1. Mapping requirements

Destination business

Direction of business object Source business object  object Type of map
Connector to collaboration Application-specific Generic Inbound map
Collaboration to connector Generic Application-specific Outbound map

© Copyright IBM Corp. 2004 3



Example: illustrates how mapping occurs at run time, using a fictionalized
Employee Management collaboration as an example.

InterChange Server Express
Map Map
App A Generic Generic App B
Employee [>| Employee Collaboration1 Employee [—| Employee
App A App B
Connector Controller Connector Controller
App A App B
1 Employee Employee 8
Business Object Business Object
App A App B
Connector Connector
App A App B

Figure 1. Data mapping at run time

The Employee Management collaboration (Collaborationl) receives an Employee
business object from the source connector (App A), then sends an Employee business
object to the destination connector (App B). illustrates the following
sequence occurs (the numbers here correspond to the numbers in the figure):

1. An event occurs in App A. The App A connector produces an App A Employee
business object and sends it to the App A connector controller.

2. The App A connector controller sends the App A Employee business object to the
Employee Management collaboration (Collaborationl), which resides on
InterChange Server Express, for mapping. The request includes the name of the
data map that the server must use, based on the map name specified in the
connector configuration.

3. The inbound map returns the generic Employee business object to the App A
connector controller.

4. The App A connector controller checks the collaborations that have subscriptions
to the generic Employee business object. In this case, Collaborationl has a
subscription, so the connector controller hands the business object to
Collaborationl.

5. The collaboration performs some processing, then produces another generic
Employee business object as output, which it sends to the App B connector
controller.

6. The App B connector controller sends the generic business object to InterChange
Server Express, requesting mapping to the App B Employee business object.

4 Map Development Guide



7. The outbound map returns the application-specific EmpToyee business object to
the App B connector controller.

8. The App B connector controller passes the App B Employee object to the App B
connector, which can then pass the data in the business object into App B.

The figure shows two types of maps in use:

¢ One inbound map from the App A Employee business object to the generic
EmpTloyee business object used by the collaboration

* One outbound map from the generic Employee business object to the App B
Employee business object

The Employee data moves in only one direction—from Application A toward
Application B. If you want to exchange the Employee data in both directions
between both applications, two more maps are required:

* An inbound map from the application-specific business object of Application B
to the generic business object

* An outbound map from the generic business object to the application-specific
business object of Application A

Maps: A closer look

As shows, a map is a two-part entity, consisting of a map definition and a
run-time object.

Map definition
You define a map to the map development system with a map definition. Map
definitions are stored in projects in System Manager. The Map Designer Express
tool provides dialogs to assist in the creation of the map definitions (often referred
to simply as maps). It also handles storing the completed map definition in
projects in System Manager.

For more information on how to use Map Designer Express to create map
definitions, see [“Creating a map: Basic steps” on page 31].

The map definition provides the following information about the map:
¢ The map name

* The source and destination objects of the map

* The map transformations

Map definition name

A map definition is simply a template or description of the map. It provides
information on how to transform attributes of one business object to another.
Therefore, the name of the map definition should identify the direction of the map
and the business objects it transforms.

Source and destination business objects

Maps consist of one or more source business objects and one or more destination
business objects. The source business objects are the ones to be transformed; the
destination business objects are the ones that are generated with data from the source
business objects.

Map transformations
The rest of the map consists of a series of transformation steps. A transformation
step is a segment of Java code that returns the value of a destination attribute. A

Chapter 1. Introduction to map development 5



map contains one transformation step for each destination attribute that is
transformed. Transformations are implemented as Java code and are therefore
stored in a Java source (.java) file.

shows some of the transformations you can perform on a destination
business object. Standard transformations include Set Value, Move, Join, Split,
Submap, and Cross-Reference. You can create custom transformations with
graphical function blocks, as well as with Java code for "Relationships,”
"Content-based logic,” "Date Conversion,” and "String transformations.”

Table 2. Transformations of a map

Transformation

Standard transformations
Set Value
Move (Copy)
Join
Split
Submap
Cross-Reference

Custom transformations

Relationship

Content-based logic

Date conversion

String

Description

Transformations for which Map Designer
Express can autogenerate code
Specifying a value for a destination
attribute

Copying a source attribute to a
destination attribute

Joining two or more source attributes into
a single destination attribute

Splitting a source attribute into two or
more destination attributes

Calling a map for a child business object

Maintaining identity relationships for the
business objects

Creating a transformation other than one
of the standard transformations listed
above

Associating business objects that cannot
be directly mapped because each
application maintains the data in its own
format

Transforming a destination attribute
based on the content of the source
attribute

Converting a date from its format in the
source attribute to its format in the
destination attribute

Performing basic transforms on a string,
such as case conversion and obtaining
substrings

For more information

“Specifying a value for an attribute” on|
page 38

“Copying a source attribute to a|
destination attribute” on page 39|
“Joining attributes” on page 40|

[“Splitting attributes” on page 42|

“Transforming with a submap” on page
4
“Cross-referencing identity relationships’]
on page 4§

“Creating a Custom transformation” on|

[page 4§|

Chapter 8, “Implementing relationships,”|

on page 251]

[“Content-based logic” on page 168

|“Date formatting” on page 173|

“Using Expression Builder for string|
transformations” on page 176

When a clear correspondence exists between the source attribute and destination
attribute, the transformation step simply copies the source value to the destination
attribute. Other transformations can involve calculations, string manipulations,
data type conversions, and any other logic that you can code using Java.
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illustrates some typical kinds of attribute transformations:

I
Key: CustomerName FirstName
2
1 Move Address | LastName
2 i 3
Split Address2 Address
3 Join 1 _
City City
StateProv 1 State_Prov
ZipPostal ! ZipCode
District
Source Destination

Figure 2. Typical attribute transformations

As shows, attributes from the source business object are typically:

* Copied to a destination attribute (City, StateProv, ZipPostal).

* Split into multiple destination attributes (CustomerName).

* Joined into one destination attribute (Address1, Address2).

* Ignored when the destination object has no equivalent attribute (District).

For simple transformations such as copying a value into an attribute, splitting a
value into two or more attributes, or joining two or more values into one attribute,
you can specify the step graphically and Map Designer Express generates the Java
code. For more complex transformations, you can customize the transformation
with a graphical editor or write your own Java code.

Map instance

The map definition is a template for the run-time instantiation of the map, the map
instance. During map execution, the Map Development system creates instances of
the map based on the map definition and the transformation code.

Each map instance provides the following information:

* Basic functionality such as logging, tracing, connections, and exception handling
through methods of the BaseDLM class

* The map execution context

For more information, see[“Understanding map execution contexts” on page 184

A map instance is represented in the Mapping API by an instance of the BaseDLM
class.

Tools for map development
shows the two graphical design tools of mapping.

Chapter 1. Introduction to map development 7



Table 3. Principal components of data mapping system

Design tool Mapping component Description

Map Designer Express Map Uses Java code to specify how to transform attributes
from one or more source business objects to one or
more destination business objects. You typically create
one map for each source business object you want to
transform, though you can also break up a map into
several submaps.

Relationship Designer Relationship Establishes an association between two or more data

Express entities in the Map Development system. Relationship
definitions most often associate two or more business
objects. You use relationship definitions to transform
data that is equivalent across business objects but is
represented differently. For example, a state code for the
state of Michigan might be represented as MI in one
application and MICH in another. This data is equivalent
but is represented differently in each application. Most
maps use one, or a few, relationship definitions.

These graphical tools run on Windows 2000 and Windows XP. Therefore, these
platforms are for map development.

lists the additional tools that are supported for map development.

Table 4. Tools for map development

Tool Description

Mapping API Set of Java classes with which you can
customize the generated mapping code.

System Manager Provides graphical windows to configure a
map instance as well as configure a
relationship object.

Map Designer Express
Map Designer Express creates and compiles maps. You can launch Map Designer
Express from System Manager by selecting Map Designer Express from the Tools
menu. For other ways to launch Map Designer Express, see
[Designer Express” on page 15. Map Designer Express provides a tab window to

view map information. This window displays one of four tabs: Table tab, Diagram
tab, Messages tab, or Test tab.
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shows a map displayed in the Diagram tab of Map Designer Express.
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Figure 3. Map Designer Express

For information on how to use Map Designer Express to create a map, see
[Chapter 2, “Creating maps,” on page 15/

Relationship Designer Express

Relationship Designer Express creates relationship definitions that store the
run-time relationship instance data. You can launch Relationship Designer Express
from System Manager by selecting Relationship Designer Express from the Tools
menu. shows several relationships displayed in Relationship Designer

Chapter 1. Introduction to map development 9
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Figure 4. Relationship Designer Express

For

more information on how to use Relationship Designer Express, see [Chapter 7,

[“Creating relationship definitions,” on page 231

Mapping

API

Many transformation steps can be programmed using standard Java methods. To
make writing transformation steps easier, the map development system provides a
mapping API (described in detail in [Part 3, “Mapping API Reference,” on page|

), with methods to handle the most common data transformation situations. The

mapping API includes the following classes:

e DTP (Data Transformation Package) classes provide methods for string
manipulation, data type conversion, date manipulation, submap calling, and
SQL query execution. The classes are:

DtpConnection (deprecated)
DtpDataConversion
DtpDate

DtpMapService
DtpSplitString

DtpUtils

* Business object classes are used for both collaboration development and
mapping. The classes are:

BusObj
BusObjArray

* Relationship management classes provide methods for creating and managing
relationship instances. The classes are:

10 Map Development Guide
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* Database connection classes provide methods for SQL query execution. These
classes are:

— CwDBConnection

— CwDBStoredProcedureParam

— DtpConnection (deprecated)

— UserStoredProcedureParam (deprecated)

» Utility classes assist with error handling and debugging, and setting important
run-time values for maps. The classes are:

— BaseDLM
— MapExeContext

System Manager

System Manager is a graphical tool that provides an interface to InterChange
Server Express and the repository. System Manager provides the means to manage
maps and configure a map definition. You can:

* Set some general properties of a map definition, including its trace level and
data validation level.

* Display the source and destination business objects of a map.
* Compile a map definition.

Note: System Manager provides ways to start up Map Designer Express. For more
information, see [‘Starting Map Designer Express” on page 15|

System Manager also provides the means to manage relationships. You can:

* Set some general properties of a relationship, including the location of its
relationship tables.

 Display the participants of the relationship.

Note: System Manager also provides ways to start up Relationship Designer
Exi ress. For more information, see[’Starting Relationship Designer Express”]|

Overview of map development

This section provides an overview of map development, which includes the
following high-level tasks:

1. Installing and setting up the map development software and installing the Java
Development Kit.

2. Designing and implementing the map.

Setting up the development environment

Requirements: Before you start the development process, the following must be
true:

* The map development software is installed on a machine that you can access.

For information on how to install and start up the map development software
system, see your system installation guide.

¢ The IBM Java Development Kit (JDK) is installed from the product CD.

Be sure to update the PATH environment variable to include the installed Java
directory. Restart InterChange Server Express after you have updated the path.

* System Manager is running.

Chapter 1. Introduction to map development 11



For information on starting up System Manager, see your system installation
guide.

Map Designer Express is open and connected to System Manager.

For information on how to start Map Designer Express, see|’Overview of Map|

[Designer Express” on page 15

Designing and implementing the map

To design and implement maps you need to do the following:

1.

2.
3.
4

o o

8.

Learn the data formats used by all business objects involved in the map.
Create the map within Map Designer Express.
Customize any required transformation rule.

Define any relationships within Relationship Designer Express that the map
needs.

Customize the mapping transformation to perform relationship management.
Implement error and message handling, if appropriate.

Generate the .java file and compiled code. The compiled code is an executable
Java class. For more information, see [“Map development files” on page 13

Test and debug the map, recoding as necessary.

provides a visual overview of map development and provides a quick
reference to chapters where you can find information on specific topics.

Tip: If a team of people is available for map development, the major tasks of
developing a map can be done in parallel by different members of the
development team.

Task Steps: Refer to:

Create the map || * Create the map definition
. S Chapter 2
¢ Create the simple transformations

¢ Use custom transformation rules to
meet your transformation requirements

¢ Validate and compile the map
¢ Implement error and message handling

Customize the map

« Add any required complex
transformatons Chapter 3

v

* Recompile the map

Chapter 5

Add the relationships o Create the relationship definiton - Chapter 7
(if needed) ) .
e Customize the map by adding Chaoter 8
relationship-management transformation apte
* Recompile the map
Test and debug | Test.map ------- Chapter 2
* Modify the map as needed
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Figure 5. Overview of the map development task

Map development files
The following information forms the basis of the map:

* When you compile a map, Map Designer Express generates two types of files
(.Java, .class) or an optional message file (.txt) if map-specified messages are
defined in the map. These files are saved in the project in System Manager.

* Map Designer Express generates a map definition when you save a map to the
project in System Manager. This map definition contains general information
about the map (such as map properties) as well as information about how the
destination attributes are mapped.

Attention: Do not modify the mapname.java file. If you do, your changes are not
reflected in the map design, which is stored in the project in System
Manager. Therefore, these changes are not editable in Map Designer
Express. Map Designer Express reads only the map definition.

Relationship Designer Express also stores relationship definitions in XML format in
System Manager. At deployment, System Manager creates table schemas in the
relationship database to contain the relationship run-time instance data. For each
relationship, you can specify the location of all its relationship tables. The default
location for these tables is the IBM WebSphere Business Integration Server Express
repository.

lists the file types that Map Designer Express can generate (.java, .class,
.cwm, .bo, .txt) and their locations relative to the System Manager workplace.

Table 5. Map file types

Location relative to System Manager

File type  Description workspace

.java Generated Java code, created by Map Stored in ProjectName\Maps\Src.
Designer Express when you compile a
map.

.class Compiled Java code, created by Map Stored in ProjectName\Maps\Classes.
Designer Express when you compile a
map.

.cwm Map definition file, generated by Map  Saved to ProjectName\Maps when
Designer Express when you save a map "Saved” to System Manager.
definition.

.bo Plain text file, used to save and load You can save these files to any
test run data and to save test run location.
results.

.txt Message file, created by Map Designer ~ Stored in
Express from information in the ProjectName\Maps\Messages.

Messages tab when it compiles the map.
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Chapter 2. Creating maps

This chapter provides an overview of Map Designer Express and describes how to
use Map Designer Express to create maps.

Note: This chapter frequently uses the terms map and map definition
interchangeably. When the term map is used, it refers to the map definition

(what is accessed through Map Designer Express).

This chapter covers the following topics:

* |“Overview of Map Designer Express” on page 15

* |“Creating a map: Basic steps” on page 31|

. "’Mapping standards” on page 52|

For background information on how the WebSphere business integration system
uses maps, see [Chapter 1, “Introduction to map development,” on page 3/

Overview of Map Designer Express

Map Designer Express is a graphical development tool for creating and modifying
maps. A map is made up of a series of transformation steps that define how to
calculate the value for each attribute in the destination business object. Creating a
map is the process of specifying the transformation steps for each destination
attribute that you want to transform.

Using Map Designer Express, you can specify simple transformation steps, such as
copying a source attribute to a destination attribute of the same data type,
interactively using drag-and-drop. Map Designer Express automatically generates
the Java code necessary to perform the transformation.

To assist with other common transformations, such as splitting a source attribute
into multiple destination attributes or joining multiple source attributes into a
single destination attribute, Map Designer Express prompts you for information,
such as the delimiter on which to split or join, then generates the necessary Java
code. To specify more complex transformations, you can define activities
graphically using Activity Editor in a custom transformation rule, modify the Java
code directly in the Activity Editor window, or write your own transformation
steps from scratch.

This section covers the following topics to introduce you to Map Designer Express:

* |[“Starting Map Designer Express” on page 15|

* |“Working in projects” on page 16

» |“Layout of Map Designer Express” on page 16|

* [“Assigning preferences” on page 21

» [“Customizing the main window” on page 24|

» |"Using Map Designer Express functionality” on page 26

Starting Map Designer Express
To launch Map Designer Express, do one of the following;:
* From System Manager, perform one of these actions:
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— From the Tools menu, select Map Designer Express.

— Click a map folder in a project to enable the Map Designer Express icon in
the System Manager toolbar. Then click the Map Designer Express icon.

— Right-click the map folder in a project and select Create New Map from the
Context menu.

— Right-double-click a map to start Map Designer Express with the selected
map opened.

* From a development tool, such as Business Object Designer Express,
Relationship Designer Express, or Process Designer Express, perform one of
these actions:

— From the Tools menu, select Map Designer Express.
— In the Programs toolbar, click the Map Designer Express button.

Restriction: Process Designer Express is a development tool that is only
available in WebSphere Business Integration Express Plus.

¢ Use a system shortcut:

Start > Programs > IBM WebSphere Business Integration
Express > Toolset Express > Development > Map Designer Express

Important: For Map Designer Express to be able to access maps stored in System
Manager, Map Designer Express must be connected to an instance of
System Manager. The preceding steps assume that you have already
started System Manager. If System Manager is already running, Map
Designer Express will automatically connect to it.

Map Designer Express displays in its own application window. You can launch
more than one instance of Map Designer Express at a time to edit more than one
map.

Working in projects
Map Designer Express views, edits, and modifies maps stored in System Manager

on a project basis. A project is simply a logical grouping of entities for management
and deployment purposes. System Manager allows you to create multiple projects.

When Map Designer Express establishes a connection to System Manager, it
obtains a list of business objects that are defined in the current project. If you add
or delete a business object using Business Object Designer Express, System
Manager notifies Map Designer Express, which dynamically updates the list of
business object definitions.

Before you can work on a map, you need to select which project the map is in by
entering the name of the project in the Open a Map from a Project dialog. Before
you switch to another project, you need to save the maps you modified in the
current project. For more information on opening a map from a project and saving
a map in a project, see |”Steps for opening a map from a project in System|
[Manager” on page 56/and [“Saving a map to a project” on page 50| respectively.

Layout of Map Designer Express

When you first open Map Designer Express without specifying a map, the Map
Designer Express tab window is empty and the output window does not display.
When you open an existing map, the Map Designer Express window displays the
Map tabs in the tab window.
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describes each of the components in the Map Designer Express main
window.

Table 6. Components of the Map Designer Express window

Window area

Menus

Toolbar

Map Designer
Express tab window

Output Window

Status Bar

Description For more information

Provide options to access Map Designer Express [‘Map Designer Express pull-down menus’]
functionality. on page 2
Actually contains three separate toolbars, each of [“Map Designer Express toolbars” on page 28|
which provides a set of buttons to access Map
Designer Express functionality.

Displays map information for an open map in  [“Table tab” on page 17|“Diagram tab” on|
one of four Map tabs. age 19]|"Messages tab” on page 20||"Test|
tab” on page 21
Displays results from the compilation of a map N/A

and other status messages. If the output window

is not currently displaying when Map Designer

Express generates a status message, it opens this

window automatically. You can clear the

contents of the output window with the Clear

Output option of the View menu.

Tip: You can control whether the output

window pane displays as part of the main

window of Map Designer Express with the

Output Window option of the View menu.

Displays Map Designer Express status messages. N/A

Tip: You can control whether the status bar
displays as part of the Map Designer Express
window with the Status Bar option of the View
menu.

The following sections describe the general layout of each of the tabs that display
in Map Designer Express’s tab window.

Table tab

The Table tab of Map Designer Express displays mapping information in a tabular
format that lists all mapping attributes and transformations.

The Table tab consists of the following areas:
* Attribute Transformation Table
* Business Objects Pane

Attribute Transformation Table: The attribute transformation table presents in a

tabular format all transformations associated with the map. shows the
columns that make up this table.
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Table 7. Columns of the Attribute Transformation Table

Column name Description

Exec. Order The execution order for the destination attribute.

When you add a transformation to the end of this table, Map Designer Express
automatically assigns its execution order as the last in the table. You can change the
execution order of an attribute by typing the desired order number in the Exec. Order field.

Note: You can specify how Map Designer Express handles the execution order of destination
attributes with the option Defining Map: automatically adjust execution order. By
default, this option is disabled. When the option is enabled, Map Designer Express
automatically adjusts the execution order of other attributes. You can change the setting of
this option on the General tab of the Preferences dialog. For more information, see
|“Specifying General Preferences” on page 22|

Source Attribute The name of the source attribute for the transformation.

This field provides a combo box that contains a list of all source and destination business
objects with their attributes listed under them. Click the appropriate source attribute from
this list. You can select multiple source attributes by clicking the Multiple Attributes entry in
the combo box list. Map Designer Express displays the Multiple Attributes dialog from
which you can select the attributes.

Note: You can specify how Map Designer Express displays the source attribute name with
the option Defining Map: show full attribute path. By default, this option is disabled and
Map Designer Express displays all source attribute names as ...AttrName. When the option
is enabled, Map Designer Express displays the full attribute path: 0bjSrcBus0Obj .AttrName.
You can change the setting of this option on the General tab of the Preferences dialog. For
more information, see [“Specifying General Preferences” on page 22|

Source Type The data type of the source attribute.

This field is read-only.
Destination Attribute The name of the destination attribute for the transformation.

This field provides a combo box that contains a list of all source and destination business
objects with their attributes listed under them. Click the appropriate destination attribute
from this list.

Note: You can specify how Map Designer Express displays the destination attribute name

with the option Defining Map: show full attribute path. By default, this option is disabled

and Map Designer Express displays all destination attribute names as ...AttrName. When the

option is enabled, Map Designer Express displays the full attribute path:

ObjDestBusObj .AttrName. You can change the setting of this option on the General tab of the

Preferences dialog. For more information, see [’Specifying General Preferences” on page 22|
Dest. Type The data type of the destination attribute.

This field is read-only.
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Table 7. Columns of the Attribute Transformation Table (continued)

Column name

Transformation Rule

Comment

Description

The transformation rule and code for this attribute’s transformation step.

This field provides a combo box that contains a list of standard transformations:
* None (no transformation)

* Join

* Move

* Split

e Set Value

* Submap

* Cross-Reference

e Custom

Click the appropriate transformation from this list to enter it in the field. For more
information, see|“Specifying standard attribute transformations” on page 37|
An informational description of the attribute’s transformation.

See |“Setting comments in the comment field of the attribute” on page 53

Steps for defining a map from the Table tab: To define a map from the Table tab,
follow these general steps:

1. Click in an empty cell in the Source Attribute column. From the available
combo box, click the source attribute to transform.

2. Click in the corresponding cell in the Destination Attribute column. Click the
destination attribute from the available combo box.

3. Click in the corresponding cell in the Transformation Rule column. This column
provides a combo box:

* For a standard transformation (Join, Move, Split, Set Value, Submap, or
Cross-Reference), select the associated option from the list. Map Designer
Express generates code for these standard transformations. You can
customize this code as needed. For more information, see
[standard attribute transformations” on page 37}

* For a transformation that is not in this combo box, select Custom from the
list and add the custom Java code in Activity Editor. For more information,
see [“Creating a Custom transformation” on page 48}

4. Click in the corresponding cell in the Comment column. For more information,
see [‘Setting comments in the comment field of the attribute” on page 53|

Business Objects Pane: The business objects pane presents in a list all source and
destination business objects associated with the map. Its left area displays the
source business objects; its right area displays the destination business objects. If
the map contains a temporary business object, the business objects pane contains
three areas: Source Business Object, Temporary Business Object, and Destination
Business Object.

Tip: You can control whether the business objects pane displays as part of the
Table tab with the Business Objects Pane option of the View menu.

Diagram tab

The Diagram tab of Map Designer Express provides a drag-and-drop interface for
defining and reviewing the transformations. You view and design maps in the map
workspace, which displays on the right side of the window.
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The Diagram tab consists of the following areas:

* Business object browser, which displays in the project pane, on the leftmost part
of the window. This browser uses a hierarchical format to list the business
objects in the project in System Manager when Map Designer Express is
connected to System Manager. To refresh the list of business objects in the
business object browser, right-click in the business object browser and select
Refresh All from the Context menu. Map Designer Express queries System
Manager and updates the business object browser with the current business
objects.

Note: If you add or delete a business object from the project in System Manager,
System Manager dynamically updates the list of business object
definitions.

Tip: You can control whether the business object browser displays as part of the
Diagram view with the Project Pane option of the View pull-down menu.

* Map workspace, which always displays the information about the current map.

When you open a map, the map workspace displays a business object window
for each source and destination business object used in the map. Each business
object window lists some or all attributes defined in the business object,
depending on what viewing mode is currently selected. In the case of a
destination business object or temporary business object, the business object
window also lists the transformation rule and comments associated with the
attribute. In the map workspace, you can add, delete, or modify transformations
in the map. Lines connecting attributes represent the transformations between
the attributes.

Tip: You can control which attributes display in the source and destination
business objects in the Diagram tab with the options of the View > Diagram
submenu. This submenu allows you to select whether to display all attributes,
only linked (mapped) attributes, or only unlinked (unmapped) attributes.

Messages tab
The Messages tab displays the map’s messages. A message consists of a message
ID and its associated message text.

The Messages tab is divided into two panes. The top pane is the message grid,
which consists of three columns: Message ID column, Message column, and
Explanation column (for comments for the entire message file). The bottom or
Description pane is for entering plain text. When you enter text into the
Description pane, the text is added to the top of the generated message file as
comments. Map Designer Express saves any change made to the map’s messages
in the project of System Manager.

For more information on messages and how to use them, see

“Message files,” on page 485.|For information about the format of messages, see
“Format for map messages” on page 488.|

When you compile a new map, Map Designer Express generates an external
message file, based on the information entered in the Messages tab. This message
file is saved in the message directory.

Attention: You must make all changes to a map’s messages through the Messages
tab of Map Designer Express. Do 1ot use an external text editor to
make changes to the generated message file. Any changes made from
the external editor will not be visible to Map Designer Express because
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they will not be stored in the map definition of the project.
Furthermore, such changes will be overwritten the next time you
compile the map.

Test tab

The Test tab provides an interface for testing maps and viewing the results. In this
tab, you can run tests to verify that transformations are working properly.

The Test tab consists of the following areas:
* Test path diagram

The test path diagram at the top of the window shows the map test as a series
of icons:

— The Source Testing Data arrow indicates the direction of the map
transformation and is labeled with the business object type for the source
business object that is participating in the map test.

— The Map icon represents the currently open map, which is used in the test.

— The Destination Testing Data arrow indicates the direction of the map
transformation and is labeled with the business object type for the destination
business object that results from the map test.

* Source Testing Data pane

The source testing data area in the lower left window uses a hierarchical format
to list the attributes of the source business object that participates in the map.
Click the plus symbol (+) next to a source business object to expand it. In this
area, you enter test data for the source business object.

* Destination Testing Data pane

The destination testing data area in the lower right window uses a hierarchical
format to list the attributes of the destination business object that results from
the map. Click the plus symbol (+) next to a business object to expand it. In this
area, you view test results data for the destination business object.

Note: Map Designer Express displays results from the test run of the map in the
output window.

For more information on how to use the Test tab, see|*Testing maps” on page 85].

Assigning preferences

The Preferences dialog allows you to customize the behavior of the Map Designer
Express tool. To display the Preferences dialog:

* From the View menu, select Preferences.
* Use the keyboard shortcut of Ctr1+U.
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shows the Preferences dialog.
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— Delete Map

¥ close map before delete

IV always display warning message

r— Compile Map
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V¥ show business object instance name

o |

Cancel Apply

Figure 6. Preferences dialog

Map Designer Express saves preference settings in the Windows registry. Therefore,
they remain in effect for the current Map Designer Express session and future
sessions. The Preferences dialog provides the following tabs:

* General

* Validation

* Key Mapping

* Automatic Mapping

Specifying General Preferences

The General tab of the Preferences dialog displays the general preferences you can
specify for how Map Designer Express manages maps.

Table 8. General Map Designer Express Preferences

General Preference Description

Open Map
validate map when open ~ When this option is enabled, Map Designer

Express validates the map when it opens it.

Recommendation: If a map uses business
objects with many attributes, that is, more
than a thousand attributes, enabling this
option may result in the map taking a long

time to open. If that is the case, and it is not

desirable, you should disable this option.
Delete Map
close map before delete When this option is enabled, Map Designer
Express always closes the currently open
map before displaying the Delete Map

dialog.

For more information

[“Opening a map” on page 55|

“Steps for deleting maps” on page

7
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Table 8. General Map Designer Express Preferences (continued)

General Preference Description For more information

always display warning When this option is enabled, Map Designer  [“Steps for deleting maps” on page|

message

Compile Map

Express always displays a confirmation 75
before deleting a map.

save map before compile ~ When this option is enabled, Map Designer [|’Compiling a map” on page 82|

Defining Map

Express always saves the current map to the
project in System Manager before compiling
it.

automatically adjust When this option is enabled, Map Designer  [“Using execution order” on page 77

execution order

Express automatically renumbers the
execution order of destination attributes in
the Table tab when execution order of an
existing attribute changes.

show full attribute path When this option is enabled, Map Designer  |“Table tab” on page 17

Express shows the full attribute path for the
names of source and destination attributes in
the Table tab.

show business object When this option is enabled, Map Designer  [|“Steps for modifying business|

instance name

Express displays the names of the source object variables” on page 164
and destination business object and their

variable names. When this option is

disabled, Map Designer Express omits the

names of the business object variables in

both the Table and Diagram tabs.

Specifying Validation

The Validation tab of the Preferences dialog provides options you can select for
Map Designer Express to perform validations on the map when you save the map.
The options are as follows:

¢ Show warning if verb not mapped

* Show warning if key attribute not mapped

* Show warning if required attribute not mapped

¢ Show warning if child business object not mapped

Map Designer Express will do the selected validation as deep as there are other
transformation rules in that level.

Example: If path a.b.c is mapped, then Map Designer Express will perform these
validations on business objects level a, a.b, and a.b.c.

For more information, see [“Validating a map” on page 82.|

Specifying Key Mapping
The Key Mapping tab of the Preferences dialog displays the key mappings for
several standard transformations in the Diagram tab.

Table 9. Key Mapping Map Designer Express Preferences

Key map
Move/Join/Submap

Description For more information

Key map to use when creating a Move, Join, or Submap transformation. Map Designer
Express distinguishes between the transformations by the type and number of source
attributes:
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Table 9. Key Mapping Map Designer Express Preferences (continued)

Key map

Split/Cross-Reference

Custom

Description For more information

+ Move—one source attribute that is ot a child [[Copying a source attribute to B
business object destination attribute” on page 39|

* Join—more than one source attribute that is [Joining attributes” on page 40|

not a child business object

+ Submap—one or more source attributes that | Lransforming with a submap” on|
are a child business object page 44]

Key map to use when creating a Split ‘Splitting attributes” on page 42}

transformation or for maintaining identity ‘Cross-referencing identity]|

relationships relationships” on page 48|

Key map to use when creating a Custom ‘Creating a Custom transformation”]

transformation. on page 48|

The Key Mapping tab provides the following functionality:

* To change a key mapping, click in the appropriate transformation field and
select the desired key map for this transformation from the combo box. Click
OK.

* To return key mappings to their default values, click Use Default and then click
OK.

Specifying Automatic Mapping

The Automatic Mapping tab of the Preferences dialog provides options you can
select for Map Designer Express to use when searching for matching attribute
names in business objects for map automation. The options are as follows:

* Ignore Case--to perform case-insensitive name matches on the search string

* Ignore Incompatible Data types--to perform name matches with incompatible
data types on the search string

Note: Selecting this option may result in data loss.

For more information, see [“Using map automation” on page 64|

Customizing the main window

Map Designer Express allows you to customize its main window by:

+ |“Selecting how windows display”]

+ [“Floating a dockable window” on page 25|

Selecting how windows display

When you first open Map Designer Express without specifying a map, the main
window is empty with the toolbars and status bar visible. When you open a map,
Map Designer Express displays the Diagram tab in the tab window and opens the
output window. By default, Map Designer Express displays each of the map tabs
as follows:

* Table tab—the business objects pane displays under the attribute transformation
table.

e Diagram tab—the map workspace area displays and is empty.

* Messages and Test tabs—as described in [‘Messages tab” on page 20| and |“Test|
[tab” on page 21 respectively.
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You can customize the appearance of the main window and the Map tabs with
options from the View menu. [Table 10| describes the options of the View pull-down
menu and how they affect the appearance of the Map Designer Express window.

Table 10. View menu options for Map Designer Express window customization

View menu option Element displayed

Toolbars A submenu with options for each of the Map Designer
Express toolbars:
» Standard toolbar
* Designer toolbar

* Programs toolbar

Status Bar A single-line pane in which Map Designer Express displays
status information.

Business Objects Pane A pane that displays the source and destination business
objects in the Table tab of Map Designer Express.

Project Pane A pane that displays the business object browser in the

Diagram tab of Map Designer Express.

Diagram A submenu with options for which attributes to display in the
source and destination business objects in the business object
windows of the Diagram tab:

* All Attributes
* Linked Attributes

¢ Unlinked Attributes

The Designer toolbar also provides icons for displaying these
attributes.

Output Window A small window across the bottom of the Map Designer
Express window. The Clear Output option of the View menu
clears all text in the output window.

Tip: When a menu option appears with a check mark to the left, the associated
element displays. To turn off display of the element, select the associated menu
option. The check mark disappears to indicate that the element does not currently
display. Conversely, you can turn on the display of an undisplayed element by
selecting the associated menu option. In this case, the check mark appears beside
the displaying element.

Floating a dockable window
Map Designer Express supports the following features as dockable windows:

e Toolbars in the main window:
— Standard toolbar
— Designer toolbar

— Programs toolbar

For more information about the features of these toolbars, see

[Express toolbars” on page 28
¢ Output Window
+ Find Control pane. For more information, see|“Finding information in a map’]

Tip: By default, a dockable window is usually placed along the edge of the main
window and moves as part of the main window. When you float a dockable
window, you detach it from the main window, allowing it to function as an
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independent window. To float a dockable window, hold down the left mouse
button, grab the border of the window and drag it onto the main window or

desktop.

Using Map Designer Express functionality
You can access Map Designer Express’s functionality using any of the following:

¢ Pull-down menus

¢ Context menu

¢ Toolbar buttons

* Keyboard shortcuts

Map Designer Express pull-down menus
Map Designer Express provides the following pull-down menus:

¢ File menu

¢ Edit menu

* View menu

* Debug menu

¢ Tools menu

* Help menu

The following sections describe the options of each of these menus.

Functions of the File menu: The File
provides the options shown in |Table 11

Table 11. Options of the File menu in Map Designer Express

pull-down menu of Map Designer Express

File menu option

New

Open

Close
Save

Save As

Delete

Validate Map

Compile

Compile with Submap(s)
Compile All

Create Map Document
View Map Document

Print Setup, Print Preview, Print

Exit

Description

Creates a new map file, clearing any
existing map from the map
workspace

Opens an existing map From Project
or From File

Closes the current map

Saves the current map to the same
name To Project or To File

Saves the current map to a name
different from the map To Project or
To File

Deletes a specified map

Validates the current map

Compiles the current map

Compiles the current map and its
submaps

Compiles all or a subset of maps
defined

Creates HTML files that describe the
map between business objects
Displays the HTML map-document
file in your HTML browser
Provides options for previewing,
printing, and configuring a print job
Exits Map Designer Express

For more information

“Creating a map: Basic steps” on|

[page 31|

|“Opening a map” on page 55

“Closing a map” on page 57
“Saving maps” on page 49|

[“Saving maps” on page 49|

“Deleting objects” on page 74|

“Validating a map” on page 82|
“Compiling a map” on page 82
“Compiling a map” on page 82

“Compiling a set of maps” on page]
8
“Steps for creating a map document”
on page 62|

“Viewing a map document” on page|
63

“Printing a map” on page 73|

N/A
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Functions of the Edit menu: The Edit pull-down menu of Map Designer Express
provides the following options:

* Standard Windows edit options—Cut, Copy, and Paste
* Delete Current Selection—Deletes the currently selected object

 Select All—In the Diagram tab, selects all transformations between the source
and destination business objects

e Insert Row—Inserts a row before the current row in the attribute transformation
table of the Table tab

* Add Business Object—Displays the Add Business Object dialog to add business
objects (source, destination, and temporary) to the map

* Delete Business Object—Displays the Delete Business Object dialog to delete a
business object

e Find—Searches an attribute name or transformation code for text or
transformation code for unmapped attributes

¢ Replace—Searches and replaces in custom Java code or comments
* Map Properties—Displays the Map Properties window

Functions of the View menu: The View pull-down menu of Map Designer
Express provides the following display options:

* Business Objects Pane—When enabled, displays the source and destination
business objects at the bottom pane of the Table tab in the Map Designer Express
window

* Diagram—Provides options for displaying attributes in the business object
windows of the Diagram tab

¢ Project Pane—Always enabled, displays the business object browser as the left
pane of the Diagram tab in the Map Designer Express window

¢ Clear Output—Clears the contents of the output window

* Output Window—When enabled, displays status messages, including messages
about opening, validating, saving, compiling, and test running the map

* Toolbars—Provides options for displaying the Map Designer Express toolbars:
Standard, Designer, and Programs

 Status Bar—When enabled, displays a single-line status message at the bottom of
the main window

* Preferences—Displays the Preferences dialog, from which you can set Map
Designer Express preferences

For information on View menu options that control display, see [“Selecting ho

fwindows display” on page 24}

Functions of the Debug menu: The Debug pull-down menu provides access to

the debugging facilities of Map Designer Express. It provides the following

options:

* Run Test—Connects to a server and starts the test run of a map that is opened
from a project

* Continue—Continues execution after it stops at a breakpoint

+ Step Over—Continues execution after it stops at a breakpoint, but stops
execution before executing the next attribute

* Stop Test Run--Stops the test run of a map

* Advanced--Provides options for connecting to a server for testing a map that
resides in the server (Attach) and disconnecting from a server and closing a map
(Detach)
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* Toggle Breakpoint—Sets a breakpoint in a map, which pauses execution just
before the selected attribute’s transformation

* Breakpoints—Displays all breakpoints for the map
* Clear All Breakpoints—Clears all breakpoints in the map

For more information about the use of Map Designer Express testing and
debugging facilities, see [“Testing maps” on page 85/

Functions of the Tools menu: The Tools pull-down menu of Map Designer
Express provides options to start each of the tools, including the Map Automation
tools:

* Automatic Mapping
* Reverse Map
* Process Designer Express

Restriction: This tool is only available in WebSphere Business Integration
Express Plus.

* Map Designer Express
* Business Object Designer Express

* Relationship Designer Express

Functions of the Help Menu: The Help menu provides the standard Windows
Help options:

* Help Topics

* Documentation

* About Map Designer Express

Context menu

The Context menu is a shortcut menu that is available, by right-clicking, from
numerous places, such as the transformation rule column, row header in the Table
view, child business object in the source testing pane, or edit box in a dialog. A
menu opens that contains useful commands, which change depending on where
you click.

Example: Clicking in the transformation rule column opens a Context menu that
provides the following options:

* Open—Opens the corresponding dialog box for the transformation rule, such as
Join, Split, and Submap. For custom transformations, opens Activity Editor.

* Open in New Window—For custom transformations, opens a new instance of
Activity Editor to show the detail of the transformation rule.

* View Source—Shows the transformation’s corresponding Java code in Activity
Editor. Depending on the nature of the transformation, the code may be
read-only.

Note: The default action when you double-click the transformation cell is Open. If
Open is not available for that transformation, then a message saying that the
action is not available is displayed in the status bar.

Map Designer Express toolbars
Map Designer Express provides three toolbars for common tasks you need to
perform:

* Standard toolbar
* Designer toolbar
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¢ Programs toolbar

These toolbars are dockable; that is, you can detach them from the palette of the
main window and float them over the main window or the desktop.

Tip: To identify the purpose of each toolbar button, roll over each button with
your mouse Cursor.

Standard toolbar: shows the Standard toolbar.

Ded SH #HS »2@X ?

Figure 7. Standard toolbar

The following list provides the function of each Standard toolbar button, left to

right:

1. New map

2. Open

3. Save to project
4. Open from file
5. Save to file

6. Find in map
7. Print map

8. Cut

9. Copy

10. Paste

11. Delete

12. Help

Designer toolbar: shows the Designer toolbar.
B |»eE T O |6k b

Figure 8. Designer toolbar

The following list provides the function of each Designer toolbar button, left to
right:

1.

Add Business Object

2. Validate

—_ -

oo 0 XN oA

Compile

Run Test

Continue

Step over

Toggle Breakpoints
Clear All Breakpoints
All Attributes

Linked Attributes
Unlinked Attributes
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Programs: shows the Programs toolbar.

o9

Figure 9. Programs toolbar

The following list provides the function of each Programs toolbar button, left to

right:
1. Process Designer Express

Restriction: This toolbar button is only available in WebSphere Business

Integration Express Plus.
2. Map Designer Express
3. Business Object Designer Express
4. Relationship Designer Express

Keyboard shortcuts

Map Designer Express provides the keyboard shortcuts shown in [Table 12| for

many of the menu options.

Table 12. Keyboard shortcuts for Map Designer Express

Keyboard shortcut
Ctrl+E

Ctrl+F

Ctrl+H

Ctrl+l

Ctr1+M
Ctr1+N

Ctr1+0
Ctrl1+P
Ctrl1+S
Ctr1+U
Ctr1+Alt+F

Ctr1+ATt+S

Ctr1+Shift+P
Ctrl+Enter
F7

A1t+F4
Del

Description

Save the current map definition to a map
definition file

Display Find control panel to locate text or
unlinked attributes in the map (use Ctr1+H for
replace)

Display Replace dialog to find and replace text
in customized Java Code and comments of
transformation rules.

Open a map definition file

View a map document

Display the New Map wizard to create a new
map

Open a map definition from the project in
System Manager

Print the map definition

In Map Designer Express main window—Save
the current map definition to the project in
System Manager

Display the Preferences dialog to set Map
Designer Express preferences

Save the current map definition to a map
definition file with a different name (Save As)
Save the current map definition to the project in
System Manager with a different name (Save
As)

Display the Print Setup dialog to specify
information for printing the map definition
Display the Map Properties dialog, from which
you can set general and business object
properties for the map

Compile the current map

Close the current map

Delete the currently selected entity

For more information

[‘Saving a map to a file” on page 51|

[‘Finding information in a map” on page 71|

['Finding and replacing text” on page 73|

‘Steps for opening a map from a file” on|
age 57|

‘Viewing a map document” on page 63|
‘Creating a map: Basic steps” on page 3|

‘Steps for opening a map from a project in|
System Manager” on page 56|

‘Printing a map” on page 73|

‘Saving a map to a project” on page 50|

| Assiening preferences” on page 21

['Saving a map to a file” on page 51|

['Saving a map to a project” on page 50|

[“Printing a map” on page 73|

“Specifying map property information” on

page 58|

‘Compiling a map” on page 82|
‘Closing a map” on page 57|
N/A
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Table 12. Keyboard shortcuts for Map Designer Express (continued)

Keyboard shortcut
F1

Ctrl+F7

F8

F9

F10

Description

Display context-sensitive help for the current
dialog or window

Compile all or a subset of maps defined in
System Manager

During a test run, continue a paused map by
executing until the end of the map or another
active breakpoint

Toggle the state of a breakpoint for a
transformation rule

During a test run, continue a paused map by
executing the next single step

For more information

N/A

[’Compiling a set of maps” on page 84

‘Steps for processing breakpoints” on page]
01

['Setting breakpoints” on page 88|

‘Steps for processing breakpoints” on page]
p1

Creating a map: Basic steps
provides an overview of the basic steps for creating a new map.

Table 13. Steps for creating a new map

Creation step

1. Create a new map file with the New Map wizard.

For more information

[‘Steps for creating the map definition” on page 31}

Specify the project, the source and destination
business objects, and the name for the new map.

2. Set the verb for each destination business object. In

‘Setting the destination business object verb” on pagd

most cases, destination business objects have the B7]

same verb as source business objects. You can also set
the value of the verb always to be a specific value.

3. Specify the transformation steps for each destination
attribute that you want to map. How you do this
depends on what kind of transformation is required.

4. Specify the comment for the destination attribute.
Although this information is optional, it greatly
improves readability of the map information in Map
Designer Express.

5. Save the map.

6. Check completion, validate, and compile the map.

7. Test and debug the map.

‘Specifying standard attribute transformations” on|

page 37|

‘Setting comments in the comment field of the|

httribute” on page 53

‘Saving maps” on page 49|

‘Checking completion” on page 52 || Validating al

map” on page 82) and [“Compiling a map” on page 82|

‘“Testing maps” on page 85|

Steps for creating the map definition

Map Designer Express provides a New Map wizard to assist you in creating a map
definition. Perform the following steps to create a map definition using the New

Map wizard:

1. Start the New Map wizard in one of the following ways:

* From the File menu, select New to create a new map.

¢ Use the keyboard shortcut of Ctr1+N.

* In the Standard toolbar, click the New Map button.
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Result: Map Designer Express displays the first window of the New Map
wizard.

Welcome to the Create Mew Map Wizard.

Flease select the Project that will contain this map:

I

.|:| OracleFroject
® S4P4Project

< Back I Mest » I Cancel

Figure 10. Welcome window of New Map wizard

2. From the list box, select the name of the project for which you want to create
the map.

3. Select the business object you will use as the source business object for the
map. You can select one or more source business objects by clicking in the Use
column of each desired business object. Then click Next to continue.

Choose source business objects
Choose the business objects that you will use as sources for the map.

Fin | 2] =

lse | Buziness Object | -

alevelllnput
alevell Output
alevel2lnput
alevel20utput
alevel3lnput
alevel30utput
aTopLevelnput
aTopLevelJutput
Simpleln

Simple0ut LI

< Back I Mext > I Cancel |

joooooooxOO
iy

Figure 11. Selecting source business objects

Tip: To locate a particular business object, enter its name in the Find field. The
up and down arrows scroll through the business object list. Click Next to
continue.
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The New Map wizard does not require that you specify the source business
object. You can click Next without selecting the source business object to
postpone specifying this business object definition. You can specify it at a later
time in the map workspace of the Diagram tab. For more information, see
[“Creating the source and destination business objects” on page 34,

Note: If you add or delete a business object from System Manager, it
dynamically updates the list of business object definitions.

4. Select the business object type you will use as the destination business object
for the map. You can select one or more destination business objects by clicking
in the Use column of each desired business object. Then click Next to continue.

Choose destination business objects
Choose the business objects that you will use as destinations for the map.

o]
=3
o

=]
e | Buziness Object |A
B alevellinput
=] alevell Output
B alevelZinput
8 alevelZ0utput
B aleveldinput
B alevel30utput
8 aloplevelnput
B aTopleveldutput
B Simpleln

S skl =l

o

1jo0do0oorOoOoOono

< Back I Mest > I Cancel |

Figure 12. Selecting destination business objects

Tip: To locate a particular business object, enter its name in the Find field. The
up and down arrows scroll through the business object list. Click Next to
continue.

The New Map wizard does not require that you specify the destination
business object. You can click Next without selecting the destination business
object to postpone specifying this business object definition. You can specify it
at a later time in the map workspace of the Diagram tab. For more information,
see [‘Creating the source and destination business objects” on page 34

Note: If you add or delete a business object from System Manager, it
dynamically updates the list of business object definitions.
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5.

Figure 13. Saving new map

Creating

Specify the name to associate with the map.

Save map
Specify a name for the map.

Mame: |Customer_to_CICustomer

Mapping Direction:

™ Application-S pecific to Generic

& Generic to Application-5 pecific

™ Other

< Back I Firish I Cancel

Rule: Map names can be up to 80 alphanumeric characters and underscores (_).
Map Designer Express does enforce some naming restrictions. For example, it
does not allow certain punctuation symbols, such as a period, a left brace ([), a
right brace (]), a single quotation mark, a double quotation mark, or a space in
the map name.

The New Map wizard does not require that you specify the map name. You can
click Finish without entering the map name to postpone naming this map
definition. When you save the map, Map Designer Express prompts you with
the Save Map As dialog for you to specify the required map name. For more
information, see [“Saving a map to a project” on page 50}

Specify whether the map is an inbound or outbound map. This map role is
needed for automatically generating relationship codes.

Click Finish to save the new map definition with the specified source and
destination business objects.

Result: Map Designer Express displays the new map’s information in its
Diagram tab.

the source and destination business objects

If you do not specify the map’s source and destination business objects from the
New Map wizard, you can specify them from the Add Business Object dialog or
the Diagram tab in the business object browser.

Steps for specifying business objects from the Add Business
Object dialog

Perform the following steps to add a source or destination business object to a map
from the General tab of the Add Business Object dialog.

1.
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Display the Add Business Object dialog in one of the following ways:
* From the Edit menu of Map Designer Express, select Add Business Object.
* In the Designer toolbar, click the Add Business Object button.



¢ From the Table tab, right-click in the empty area of the business objects pane
and select Add Business Object from the Context menu.

¢ From the Diagram tab, right-click in the map workspace and select Add
Business Object from the Context menu.

2. To specify a source business object:
* Click the business object in the business object list.
* Click the Add to Source button.

Tip: To locate a particular business object, enter its name in the Find field. The
up and down arrows scroll through the business object list.

3. To specify a destination business object:
¢ Click the business object in the business object list.
* Click the Add to Destination button.

Tip: To locate a particular business object, enter its name in the Find field. The
up and down arrows scroll through the business object list.

4. To close the dialog, click Done.

Steps for specifying business objects from the Diagram tab in

the business object browser

From the Diagram tab, you can add a source or destination business object to a

map. Perform the following steps to do this:

1. Drag the source business object from the business object browser to the left side
of the map workspace. The business object displays and its title starts with Src.

2. Drag the destination business object from the business object browser to the
right side of the map workspace. The business object displays and its title starts
with Dest.

Note: A dotted-line boundary divides the left and right halves of the workspace

and identifies the source and destination portions of the map workspace. Be
sure to carefully drop objects in the appropriate place.
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shows the source and destination business objects in the map workspace.
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Figure 14. Defining Source and Destination business objects

Tip: Alternatively, you can create the source and destination business objects by
right-clicking the business object in the business object browser; selecting Copy
from the Context menu; then right-clicking in the map workspace and selecting
Paste As Input Object or Paste As Output Object.

Map Designer Express creates a window, called a business object window, for the
source and destination objects. The title bar of this window displays the business
object instance name. For help interpreting the title bar of the business object
window, see [‘Using generated business object variables and attributes” on page|
m. The business object window for the source business object contains columns
for the name and data type of each source attribute. The business object window
for the destination business object contains columns for the name, data type,
transformation rule (which identifies the transformation step), and an optional
comment.

Guideline: If you make a mistake by dragging the wrong business object or
making it an output object instead of input, you can delete the object from the map
workspace and try again. To delete a business object from the map workspace, you
can either:

* Select the business object to delete and from the Edit menu select Delete Current
Selection (or press the Del key).

 Right-click the title bar of the business object’s window and select Delete from
the Context menu.
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Setting the destination business object verb

The verb indicates how the system should process the business object’s data. When
a map executes, the system needs to know what verb to assign to each destination
business object it creates.

If a map has only one source business object and one destination business object,
the verb for the destination business object is usually the same as the verb for the
source business object.

In this case, you need to copy the verb from the source business object to the
destination business object (see [Figure 14 on page 36)), by defining a Move
transformation rule with the source attribute as the source business object’s verb
and the destination attribute as the destination business object’s verb. For more
information, see [’Copying a source attribute to a destination attribute” on page 39/

Tip: You can also drag-and-drop the verb from the source business object to the
destination business object to define the value of the verb.

If a map has a destination business object with a verb that is not found in the
source business object, you need to set the verb to a constant value, by defining a
Set Value transformation rule with the destination attribute as the destination
business object’s verb. In the Set Value dialog box, enter the constant verb value.
For more information, see [“Specifying a value for an attribute” on page 38

Maps sometimes have more than one source or destination business object, and
these objects can have several child business objects. In these cases, you must
consider carefully which verb to assign to each destination business object. Some
destination business objects might require some custom logic to set the verb based
on the verbs of one or more source business objects.

Specifying standard attribute transformations

You can specify several standard attribute transformations interactively in Map
Designer Express while writing little or no Java code. shows the standard
transformations that you can specify in Map Designer Express.

Table 14. Common attribute transformations

Name Transformation step Purpose

Set Value [’Specifying a value for an attribute” on page 3§ For an attribute in the destination business
object that is not found in the source business
object but is required in the destination

application
Move "Copying a source attribute to a destination| For an attribute that is the same in both the
attribute” on page 39 source and destination business objects
Join ‘Joining attributes” on page 40| For an attribute in the destination business

object that is a combination of several attributes
in the source business object

Split ['Splitting attributes” on page 42| For an attribute in the destination business
object that is either:

* Only one part of an attribute in the source
business object

* Made up of several fields, but with different
delimiters from those in the source business
object
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Table 14. Common attribute transformations (continued)

Name Transformation step Purpose

Submap ['Transforming with a submap” on page 44| For attributes in the source and destination
business objects that contain child business
objects

Cross-Reference ‘Cross-referencing identity relationships” on| For maintaining the identity relationships for

age 48| the business objects

Custom ‘Creating a Custom transformation” on page 4§ For an attribute that requires transformations
not provided by the automatically generated
transformations

For information on additional transformations you can perform, see
lattribute transformation methods” on page 168

In the Diagram tab, you can select which attributes display in the business object
windows with the options of the View > Diagram menu. You can choose to display
all attributes, only linked (mapped) attributes, or only unlinked (unmapped)
attributes.

Tip: Attributes appear in the same order that they appear in the business object
definition. To locate a particular attribute in a long list of attributes, select
Find from the Edit menu (or use the keyboard shortcut of Ctr1+F). For more
information, see [“Finding information in a map” on page 71].

Specifying a value for an attribute

Some destination attribute values do not depend on a source attribute and can be
filled in with a constant value. This is especially true if the destination business
object contains many attributes that are not found in the source business object but
are required in the destination application. Some examples of default values for
attributes are CustomerStatus = "active" or AddressType = "business".

This type of transformation is called a Set Value transformation. You set the value
of a destination attribute with the Set Value dialog, shown in .

Steps for specifying a Set Value transformation: Perform the following steps to
specify a Set Value transformation:

1. Display the Set Value dialog in one of the following ways:
¢ From the Table tab, perform the following steps:
a. Select the destination attribute whose value you want to set.
b. Click Set Value from the list in the Transformation Rule column.
* From the Diagram tab, perform the following steps:
a. Select the destination attribute whose value you want to set.

b. Click Set Value from the list in the Rule column of the destination
business object.

 If a Set Value transformation is already defined, you can display the Set
Value dialog to reconfigure the transformation, including modifying its
transformation code in either of the following ways:

— Double-click the corresponding cell of the transformation rule column.

— Click the Set Value bitmap icon contained in the transformation rule
column.
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Figure 15. Set Value dialog
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2. Through the Set Value dialog, you set the constant value to assign to the

destination attribute. The Set Value dialog provides the following functionality:
* To specify the constant value, enter it in the Value field. For numeric values,

simply enter the number and make sure that the String Value check box is
not selected. For string values, enter the string value in the Value field and
select the String Value check box.

Note: The Set Value dialog uses the Examples area to show how the
resulting destination attribute will look.

To modify the value you have entered, click in the Value field and edit as
appropriate.

To customize the generated code, click the View Code push button.

Result: Map Designer Express opens Activity Editor in Java view, containing
a sample of the transformation code in read-only mode for the destination
attribute. To make changes to the transformation code, click Edit Code in

Activiti Editor. For more information, see [“Overview of Activity Editor” on|

Note: When you save the changes in Activity Editor, they are communicated
to Map Designer Express. When you save the map, they are saved too.

¢ To confirm the transformation setting, click OK.

Copying a source attribute to a destination attribute

The simplest kind of transformation step is a copy of one source attribute into a
corresponding destination attribute. This type of transformation is called a Move
transformation.

Steps for specifying a Move transformation: Perform the steps from one of these
map tabs to specify a Move transformation:

e From the Table tab:

1.

Select the source attribute.

2. Select the destination attribute.

3. Click Move from the list in the Transformation Rule column.

¢ From the Diagram tab:

1.

Select the source attribute.
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2. Use Ctrl+Drag to move to the destination attribute; that is, hold down the
Ctrl key and drag the attribute onto the destination attribute in the
destination business object window. Continue to hold down the Ctrl key
until after you release the mouse button; otherwise, the operation does not
succeed.

Result: Map Designer Express creates a blue arrow from the source to the
destination object. If the transformation involves a single source attribute that
is not a child business object, Map Designer Express assumes that the
transformation is a Move and automatically assigns Move to the Rule
column of the destination attribute.

Tip: You can customize the key sequence used to initiate a Move transformation
in the Diagram tab from the Key Mapping tab of the Preferences dialog. For
more information, see [“Specifying Key Mapping” on page 23|

Result: Map Designer Express generates the code to copy the value of the source
attribute to the destination attribute. If the source and destination attributes are of
different data types, Map Designer Express determines whether a type conversion
is possible, and if so, generates the code to convert the source type to the
destination type. If a type conversion is not possible, or might result in data loss,
Map Designer Express displays a dialog box for you to confirm or cancel the
operation.

If you want to see a sample of the generated code for the Move transformation, in
the Context menu of the rule column, select View Source.

Joining attributes

You can concatenate, or join, the values from more than one source attribute into a
single destination attribute. This type of transformation is called a Join
transformation. For instance, the source business object might store the area code,
telephone number, and extension in separate attributes, while the destination
business object stores these values together in one attribute.

In addition to joining the attributes, you can reorder them and insert delimiters,
parentheses, or other characters. For instance, when joining separate area code and
telephone number attributes into a single attribute, you might want to insert
parentheses around the area code.

Tip: The attributes you want to join can sometimes be located in more than one
source business object, such as in a parent business object and one of its child
business objects. You can also join an attribute with a variable you have
defined. (To learn about defining variables, see |“Creating temporaryl
[variables” on page 165.)

You join multiple source attributes into one destination attribute with the Join
dialog, shown in

Steps for specifying a Join transformation: Perform the following steps to specify
a Join transformation:

1. Display the Join dialog in one of the following ways:
¢ From the Table tab:
a. Select the source attributes to join.

Tip: You can click Multiple Attributes in the combo box to display the
Multiple Attributes dialog. In this dialog, you can select multiple source
attributes. To locate a particular business object, enter its name in the
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Find field. The up and down arrows scroll through the business object
list. Once you have selected the source attributes, click OK to close the
dialog.
b. Select the single destination attribute.
c. Click Join from the list in the Transformation Rule column.
¢ From the Diagram tab:
a. Select two or more source attributes.

b. Use Ctrl+Drag to move to the destination attribute; that is, hold down the
Ctrl key and drag the selected source attributes to the destination
attribute. Continue to hold down the Ctr1 key until after you release the
mouse button; otherwise, the operation does not succeed.

Result: If the transformation involves more than one source attribute,
Map Designer Express assumes that the transformation is a Join. It
automatically assigns Join to the Rule column of the destination attribute
and displays the Join dialog.
Tip: You can customize the key sequence used to initiate a Join
transformation in the Diagram tab from the Key Mapping tab of the
Preferences dialog. For more information, see [“Specifying Key Mapping” on|
* If a Join transformation is already defined, you can use the Join dialog to
reconfigure the transformation, including modifying its transformation code,
in either of the following ways:

— Double-click the corresponding cell of the transformation rule column.
— Click the Join bitmap icon contained in the transformation rule column.

Attribute Delimiter

ChiClarify_Contact LastMame
ChiClarify_Contact FirstMame

fove Up I | MDVEQDWHI

Example

QbiClanify_Contact LaztH ame ObjClarnfy_Contact.Firsth ame

Figure 16. Join dialog

2. Through the Join dialog, you build an expression to concatenate the source
attributes by adding delimiters, grouping with parentheses, and reordering the
attributes if necessary. The Join dialog provides the following functionality:
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* To insert a delimiter or parenthesis, enter it in the Delimiter field associated
with the attribute. Do not put quotation marks around delimiters. The
delimiter you enter is appended to the associated attribute. For leading
delimiters, enter the delimiters in the Delimiters field of the initial blank line.

Note: The Join dialog uses the Examples area to show how the resulting
string will look after the join.

¢ To modify a delimiter or parenthesis you have entered, click in the Delimiter
field and edit as appropriate.

e To reorder a delimiter or the attributes, click the left-most column to select
the row, then click Move Up or Move Down to move the whole row up or
down.

* To customize the generated code, click the View Code push button.
Result: Map Designer Express opens Activity Editor in Java view, containing
a sample of the transformation code in read-only mode for the destination
attribute. To make changes to the transformation code, click Edit Code in
Activiti Editor. For more information, see [“Overview of Activity Editor” on|

Note: When you save the changes in Activity Editor, they are communicated
to Map Designer Express. When you save the map, they are saved too.

¢ To confirm the transformation setting, click OK.

Result: Map Designer Express generates the code to join the source attributes. If
any source attribute is of a different data type from the destination attribute, Map
Designer Express makes the necessary calls to methods in the DtpDataConversion
class to convert the types.

Splitting attributes

To split a source attribute into two or more destination attributes, you specify the
transformation for each destination attribute separately. This type of transformation
is called a Split transformation. For instance, to split a source attribute, such as
phone_number, into three separate destination attributes, such as area_code,
tel_number, and extension, you specify the transformations for area_code,
tel_number, and extension separately.

You split a source attribute into multiple destination attributes with the Split
dialog, shown in

Steps for specifying a Split transformation: Perform the following steps to
specify a Split transformation:

1. Display the Split dialog in one of the following ways:
* From the Table tab, perform the following steps:
a. Select the single source attribute to split.
b. Select one of the desired destination attributes.
c. Click Split from the list in the Transformation Rule column.
d

Repeat these steps for each destination attribute that receives a segment
of the source attribute.

* From the Diagram tab, perform the following steps:
a. Select the single source attribute to split.

b. Use Alt+Drag to move to one of the destination attributes; that is, hold
down the A1t key and drag the source attribute to one of the destination
attributes.
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Figure 17. Split dialog

Result: If the transformation involves more than one destination attribute,
Map Designer Express assumes that the transformation is a Split. It
automatically assigns Split to the Rule column of the destination attribute
and displays the Split dialog.

C. Repeat these steps for each destination attribute that receives a segment
of the source attribute.

Tip: You can customize the key sequence used to initiate a Split
transformation in the Diagram tab from the Key Mapping tab of the
Preferences dialog. For more information, see [“Specifying Key Mapping” on

* If a Split transformation is already defined, you can use the Split dialog to
reconfigure the transformation, including modifying its transformation code,
in either of the following ways:

— Double-click the corresponding cell of the transformation rule column.

— Click the Split bitmap icon contained in the transformation rule column.
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2. Through the Split dialog, you split an expression into segments that are
separated by a delimiter. Each segment is identified with an index number,
with the first segment having an index number of zero (0). The Split dialog
provides the following functionality:

 To identify the delimiter by which to parse the source attribute, enter it in
the Delimiter field. Do not put quotation marks around delimiters. You can
specify one or more delimiters in this field. The transformation uses each of
the specified delimiters to parse the string into segments. For example, to

split LastName,FirstName, specify “,” as the delimiter, LastName as segment 0
(the first segment) and FirstName as segment 1 (the second segment).

Note: The Split dialog uses the Examples area to show how the source
attribute string looks and to indicate which segment is currently being
accessed. The accessed segment displays in bold and red.

* To modify a delimiter or parenthesis you have entered, click in the Delimiter
field and edit as appropriate.

* To identify the segment of the source attribute that is copied to the
destination attribute, enter its index number in the Sub-string Index field.

* To customize the generated code, click the View Code push button.
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Result: Map Designer Express opens Activity Editor in Java view, containing
a sample of the transformation code in read-only mode for the destination
attribute. To make changes to the transformation code, click Edit Code in

Activity Editor. For more information, see ["Overview of Activity Editor” on|
ﬂ

Note: When you save the changes in Activity Editor, they are communicated
to Map Designer Express. When you save the map, they are saved too.

* To confirm the transformation setting, click OK.

Result: Map Designer Express generates the transformation code for the
destination attribute. The generated code uses methods from the DtpSp1itString()
class to parse the source attribute into segments.

Transforming with a submap
A submap is a map that is called from within another map, called the main map.
This section provides the following information about submaps:

+ |[“Uses for submaps”|

+ [“Steps for specifying a Submap transformation” on page 46|

Uses for submaps: You can call a submap to obtain a value for any destination
attribute, but submaps are most commonly used for the following:

* To modularize a map
* To specify transformations between child business objects

Improving map modularity: Using submaps can improve the modularity of your
maps by isolating common transformations that can be reused in more than one
map. For example, a Customer business object might have an Address child
business object that is also a child of an Order business object. If you create a
submap for the Address business object, you can reuse the submap in both the
Customer and Order business object maps.

illustrates how a submap, MyAddrToGenAddr, can be reused by two
different maps.

MyApp_Customer | Map: MyCust ToGenCust Customer
hyapp_sddress Submap: MyAddrTeGenaddr Address

Miyapp_Order ) Map: MyOrder ToGenZust Order
MyApp_sddress Submap: MyaddrToGenAddr Address

Figure 18. Using submaps for modularity

Transforming child business objects: When the source and destination attributes
contain multiple-cardinality child business objects, it is useful to use a submap to
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specify their transformations. Typical examples of multiple-cardinality child
business objects are the multiple addresses of a customer or the multiple line items
in an order.

In the simplest case, you transform each source child business object into a single
destination child business object, in a one-to-one relationship. illustrates

the use of submaps for an Employee business object and its child business array
that contains instances of EmployeeAddress.

App_Empl

Employee

Address[2] |

41 Address[1] | >
Address[0] AppAddr(0]

Figure 19. One-to-one transformation of child business object arrays

v

A submap can be associated with a conditional statement that governs whether it
executes. For example, consider the Order business object has an
OrderLine attribute that contains a multiple-cardinality child business object,
OrderLine. The OrderLine business object has a DeliverySchedule attribute that
contains a multiple-cardinality child business object, De1Sched.

Order

\ OrderLine[2]

OrderLine[1]
OrderLine[0]

ched
ched (|
DeliverSched
DeliverSched[2] DeliverSched|2] DeliverSched[2]
DeliverSched[1] DeliverSched[1] DeliverSched[1]
DeliverSched[0] DeliverSched[0] DeliverSched[0]

Figure 20. Source business object with multiple-cardinality child business object

Some conditions that can be written in the map for Order can:

* Execute the submap that transforms the OrderLine attribute in Order only if a
different attribute in Order has a particular value.
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* Execute the submap that transforms the DeliverSched attribute in OrderLine
only if a different attribute in OrderLine has a particular value.

* Execute the submap that transforms the DeliverSched attribute in OrderLine
only if an attribute in Order has a particular value.

Steps for specifying a Submap transformation: Perform the following steps to
specify a Submap transformation:

1. Create the map that you want to use as a submap.

Recommendation: You do this in the same way that you create and save any
other map. IBM naming conventions suggest that submap names begin with
the string “Sub_".

2. Save the submap to the project in System Manager and compile the submap.

3. Specify the Submap transformation on the attribute in the parent business
object that needs to call the submap. This source attribute contains a child
business object that is mapped to a destination attribute that contains a child
business object.

You specify that a submap needs to be called with the Submap dialog, shown
in .. Display the Submap dialog in one of the following ways:

* From the Table tab, perform the following steps:

a. In the parent map, select a source attribute (which is a child business
object).

b. Select the desired destination attribute (which is also a child business
object).

c. Click Submap from the list in the Transformation Rule column.

d. Repeat these steps for each source attribute that is a source business
object for the submap and each destination attribute that is a destination
business object for this submap.

* From the Diagram tab, perform the following steps:

a. In the parent map, select the source attribute (which is a child business
object).

b. Use Ctrl+Drag to move to the destination attribute; that is, hold down the
Ctrl key and drag the source attribute onto the destination attribute.
Continue to hold down the Ctr1 key until after you release the mouse
button; otherwise, the operation does not succeed.

If the transformation involves a source attribute that is a child business
object, Map Designer Express assumes that the transformation is a
Submap. It automatically assigns Submap to the Rule column of the
destination attribute and displays the Submap dialog.

Tip: You can customize the key sequence used to initiate a Submap
transformation in the Diagram tab from the Key Mapping tab of the
Preferences dialog. For more information, see [“Specifying Key Mapping” on|

* If a Submap transformation is already defined, you can use the Submap
dialog to reconfigure the transformation, including modifying its
transformation code, in either of the following ways:

— Double-click the corresponding cell of the transformation rule column.
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— Click the Submap bitmap icon contained in the transformation rule
column.

Condition:

ak I Cancel

g
7

Figure 21. Submap dialog

4. Through the Submap dialog, you specify the name of the submap to call. The
Submap dialog provides the following functionality:

* To identify the submap to call, select its name from the list in the Map area.
The map list displays maps that meet the following condition: The submap
has the same business object definitions for its source and destination
business objects as the source and destination attribute you have selected.

Tip: To locate a particular submap, enter its name in the Find field. The up
and down arrows scroll through the business object list.

* To specify a condition for the submap, enter it in the Condition area of the
Submap dialog. You can enter the condition now or simply dismiss the
dialog and enter the condition in the destination attribute’s generated code.

* To customize the generated code, click the View Code push button.

Result: Map Designer Express opens Activity Editor in Java view, containing
a sample of the transformation code in read-only mode for the destination

attribute. To make changes to the transformation code, click Edit Code in
Activiti Editor. For more information, see [“Overview of Activity Editor” on|

Note: When you save the changes in Activity Editor, they are communicated
to Map Designer Express. When you save the map, they are saved too.

¢ To confirm the transformation setting, click OK.

Result: Map Designer Express generates the Java code to call the specified submap.
It automatically creates a call to the runMap() method to call the submap.

Note: In any attribute’s code, you can use Expression Builder to insert a map
execution call. For more information, see [“Using Expression Builder to call af
[submap” on page 195,
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Cross-referencing identity relationships

In some cases, the source attribute may need to reference a relationship table to
find out what value to set in the destination attribute. This can be done using a

Cross-Reference transformation.

Steps for specifying a Cross-Reference transformation: Perform the following

steps to specify a Cross-Reference transformation:

1.

Select the source and destination attributes in any of the ways previously
described for other transformations. Both have to be business objects.

Select Cross-Reference in the corresponding transformation cell.

Result: The Cross-Reference dialog appears:

Cross Reference x|

Relationzhip:

Mame I

Participatit: I%ﬂ OutlPre j
[ Buziness Objects q
Genaric: Iﬂ Objalewvell Input j
Application Specific: IE Objalevel Output j

Wiew Code... | oK I Cancel |

Figure 22. Cross-Reference dialog

3.

In this dialog, select the relationship name from the list.

Result: The Participant combo box will be populated with all participants from
the selected relationship. The Business Object combo box, by default, will be
populated according to the mapping role defined in the map property. You can

change the combo boxes.

Creating a Custom transformation

In a Custom transformation, you use Activity Editor to customize the activity for
the transformation graphically or to enter the Java code to transform the source

attribute to the destination attribute.

Steps for specifying a Custom transformation: Perform the steps from one of

these map tabs to define a Custom transformation:
* From the Table tab:

1.

Select the source attribute.

2. Select the desired destination attribute.

3. Click Custom from the list in the Transformation Rule column.

* From the Diagram tab:

1.
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2. Select the desired destination attribute.

3. Drag the source attribute onto the destination attribute in the destination

business object window.

 If a custom transformation is already defined, you can modify its transformation
code in either of the following ways:

— Double-click the corresponding cell of the transformation rule column.

— Click the Custom bitmap icon contained in the transformation rule column.

Tip: You can customize the key sequence used to initiate a Custom transformation
from the Key Mapping tab of the Preferences dialog. For more information, see

[“Specifying Key Mapping” on page 23

Result: Map Designer Express displays Activity Editor with a graphical view. For
more information on Activity Editor, see [“Overview of Activity Editor” on page]

101.

lists information in this guide that is useful in defining a custom

transformation.

Table 15. Defining custom transformations

Information provided

For more information

How to use Activity Editor to customize transformation code |Chapter 5, “Customizing a map,” on page 101]

How to create relationships for relationship attributes

1. Use Map Designer Express to create the map for the
business objects that contain relationships.

2. Use Relationship Designer Express to define the
relationship.

3. Return to Map Designer Express to code the

relationship between the attributes.
More complex transformations you can perform:
Content-based logic
Date formatting
String processing

For a general introduction to relationships, see

Chapter 6, “Introduction to Relationships,” on page|

217 |

Chapter 2, “Creating maps,” on page 15|

Chapter 7, “Creating relationship definitions,” on page|

231

Chapter 8, “Implementing relationships,” on page 25|

“More attribute transformation methods” on page 168|

"“Content-based logic” on page 168

"“Date formatting” on page 173)|

"“Using Expression Builder for string transformations’]

on page 176|

Note: You can also customize an existing transformation by modifying the
generated code from Activity Editor. If you modify code in auto-update
mode, Activity Editor prompts for a confirmation. If you confirm the
change, Activity Editor saves the customized code. The label of the
transformation icon in the Transformation Rule column of the Table or
Diagram tab changes from displaying in black, normal text to displaying in
blue, italic text. These blue icon labels help you distinguish between code
that is in auto-update mode (generated by Map Designer Express) and code

you have customized.

You can tell Activity Editor not to confirm by changing the setting in the

Preferences dialog.

Saving maps

To preserve the map definition for use at a later time, you must save the map.
Before Map Designer Express saves a map, it first validates the map. For more

information, see [“Validating a map” on page 82|
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Map Designer Express provides two ways to save the current map:

* [“Saving a map to a project” on page 50|

« |"Saving a map to a file” on page 51|

Important: For Map Designer Express to be able to save a map, a map must
currently be open.

Saving a map to a project
A map definition stores map information in a project in System Manager. This map
definition contains the following information for a map:

* The general map information, which includes map properties
* The map design, which includes the transformation mappings
¢ The custom transformation code

To save a map to a project in System Manager, you can perform any of the actions
shown in [Table 16

Table 16. Saving a map to the project

If you want to . . . Then . ..

Save the map definition to the name Do one of the following:
of the currently open map. * Select To Project from the File > Save submenu.
* Use the keyboard shortcut of Ctr1+S.
* In the Standard toolbar, click the Save Map to
Project button).
Save the map definition to a name Do one of the following:

different from the currently open
map.

* Select To Project from the File > Save As submenu.
* Use the keyboard shortcut of Ctr1+ATt+S.

Result: Map Designer Express displays the Save Map
As dialog in which you can specify the map name.

b ap I

= ClarifyContact_to_Contact
= ClarifyContact_to_Order
= ClarifyContactRole_to_CuztomerRole

M ame; [ClanifyCantact_to_Order

Cancel

i
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Figure 23. Save As dialog

When you save the map, Map Designer Express saves the map definition and map
content to the project in System Manager. It saves the map content as XML data.

Note: You can specify whether Map Designer Express automatically saves a map
to the project in System Manager before compiling the map with the option
Compile Map: save map before compile. By default, this option is enabled.
You can change the setting of this option on the General tab of the
Preferences dialog. For more information, see [‘Specifying Generall
[Preferences” on page 22|

Tip: To rename an existing map, select To Project from the File > Save As
submenu.

Saving a map to a file

A map definition can be stored as text in an operating-system file, called a map
definition file. A map definition file contains the complete map definition; that is,
this file uses Extended Markup Language (XML) format to represent the following
parts of a map definition:

¢ The general map information, which includes map properties

* The map content, which includes the transformation mappings in an
uncompressed format

Recommendation: Map Designer Express creates a map definition file with a .cwm
extension. You should follow a naming convention for your map definition files,
such as. using the file extension (.cwm) to distinguish them.

You import a map definition into Map Designer Express by opening an existing
map definition file. For more information, see [‘Steps for opening a map from al
ffile” on page 57.|

You can save the currently open map to a map definition file in any of the ways

shown in .

Table 17. Saving a map to a map definition File

If you want to . . . Then ...

Save the map to the name of the Do one of the following;:

currently open map in the format: . gelect To File from the File > Save submenu.
MapName . cwm ¢ Use the keyboard shortcut of Ctr1+E.

(where MapName is the name of the * In the Standard toolbar, click the Save Map to File
currently open map) button (see.

Note: Map Designer Express will

always open the File Save dialog if

you do not open the currently

opened map from file.

Save the map to a specified map Do one of the following;:

definition file. Map Designer » Select To File from the File > Save As submenu.

Express displays a dlalog boxto * Use the keyboard shortcut of CtrT1+ATt+F.
allow you to select the file name.

Chapter 2. Creating maps 51



Note: When you select the To File option from the File > Save or File > Save As
menus, Map Designer Express displays a dialog box to allow you to select
the file name. This file name identifies the file. It is not necessarily the name
of the map.

Example: You can save MapA in a file named fileA.cwm. This fileA file contains the
map definition for MapA. When Map Designer Express opens the fileA map
definition file, it displays the MapA map definition.

Tip: Exporting a map copies only the map.

Checking completion

When you are mapping two large business objects, it is easy to overlook some
required attributes. You can search for attributes that are not yet mapped to make
sure that you have specified all desired transformations. Such attributes are called
unlinked attributes.

Perform the following step to check completion:

* From the Edit menu Select Find; and click the Unlinked attributes option in the
Find control pane.

Result: Map Designer Express displays a list of attributes for which there is no
transformation code. For more information, see|“Finding information in a map”]

Note: Once the code is completed, you must compile and test it. For information
on compiling a map, see [“Compiling a map” on page 82| For information on
testing a map, see|“Testing maps” on page 85|.

Mapping standards

52

This section provides the following procedural standards for maps:

* |"Tips on mapping individual attributes”|

* |“Setting comments in the comment field of the attribute” on page 53|

Tips on mapping individual attributes

The following points provide a general approach to mapping individual attributes:

* If the attribute mapping does not include relationship management, start by
copying the source attribute to the destination attribute (see [“Copying a source|
[attribute to a destination attribute” on page 39), then modify the generated code,
as needed.

* If the attribute mapping requires a call to a method in the Mapping API, write
the code without copying the attribute.

e If the destination attribute requires a default when the source attribute is null,
copy the attribute and note that the generated code includes two if statements
for checking the source attribute. You can either:

— Provide the default in an else statement for both of the if statements.

— Add another if statement at the beginning of the code that checks the source
attribute for null and adds a default value. Place the rest of the code in the
else statement.
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Important: Do not map the ObjectEventid attribute. InterChange Server Express
reserves the ObjectEventId for its own processing purposes. Any
custom code that has ObjectEventId as destination attribute will not

execute properly.

Setting comments in the comment field of the attribute

Attribute comments can improve the readability of your map. However, Map
Designer Express does not automatically generate a comment for an attribute.
provides some suggested standards for attribute comments based on the
type of transformation associated with the destination attribute.

Table 18. Settings for the Attribute Comment

Situation

If the child business object is not mapped

Set Value transformation

Move transformation

Join transformation

Split transformation

For child business objects, when the mapping is done without calling a

submap to indicate the object has to be expanded to see its attributes

If the code to call the submap is generated

If the attribute’s mapping contains Mapping API calls that implement

relationships, such as:

* retrievelnstances()

* retrieveParticipants()

e maintainSimpleldentityRelationship()

* maintainCompositeRelationship()

* All other methods in the IdentityRelationship class except
foreignKeyLookup() and foreignKeyXref ()

If the attribute’s mapping contains foreignKeyLookup ()

If the attribute’s mapping contains foreignKeyXref ()

Custom transformation that is not one of those listed above

(relationship or foreign key)

If the attribute’s code does not contain anything except setting the verb

Setting for Attribute Comment

=No mapping

=SET VALUE(value)

=MOVE

=JOIN(srcAttrl, srcAttr2, ...)
=SPLIT(srcAttr[index])
=Mapping here

=SUBMAP (mapName )
=Relationship(type)

where type can be:
e identity

* Tookup

* custom

=foreignKeyLookup()
=foreignKeyXref ()
=CUSTOM(summary)

=SET VERB

Chapter 2. Creating maps
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Chapter 3. Working with maps

This chapter describes some advanced features of Map Designer Express that you
might use after creating maps.

The chapter covers the following tasks:

» |“Opening and closing a map” on page 55|

* |“Specifying map property information” on page 5§

* [“Using map documents” on page 60

. "’Using map automation” on page 64]

* ["Finding information in a map” on page 71

. :”Finding and replacing text” on page 7—3|

. "’Printing a map” on page 73

+ |“Deleting objects” on page 74|

+ |[“Using execution order” on page 77

+ |“Creating polymorphic maps” on page 78|

* [“Importing and exporting maps from InterChange Server Express” on page 79|

Opening and closing a map

Map Designer Express displays one map at a time within the tab window. This
map is called the current map (sometimes called the “currently open map”). You
can control which map is the current map with the following Map Designer
Express procedures:

* [“Opening a map”]

+ |“Closing a map” on page 57

Opening a map
A map must be open in Map Designer Express before you can view its information
in a Map tab or modify this information. When Map Designer Express opens a
map, if the validate map when open preference is enabled, it first performs a set of
validations on this map.

Note: You can specify whether Map Designer Express validates a map when it
opens it, with the option Open Map: validate map when open. By default,
this option is enabled.

If this preference is enabled when a map that uses big business objects (that
is, thousands of attributes) is opened, Map Designer Express may take a
long time to open the map. You can change the setting of this option on the
General tab of the Preferences dialog. For more information, see
[General Preferences” on page 22|

The validations that Map Designer Express performs on the map are as follows:

* Ensures that each business object definition that the map uses is defined in the
project in System Manager.

* Ensures that every attribute in the map exists in the specified business object
definition, as defined in the project in System Manager.
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* Ensures that the type of each attribute in the map matches its type in the
specified business object definition, as defined in the project in System Manager.

e Validates transformations:

— Ensures execution order is correct; that is, that execution order is unique,

positive, and consecutive.

Ensures that no attributes have cyclic dependencies on each other. If any
cyclic transformations are found, Map Designer Express displays the cyclic
rules in the output window.

Checks transformation information:
Move transformation—only one source attribute is involved.
Join transformation—more than one source attribute is involved.

Split transformation—only one source attribute is involved; split index is
greater than or equal to zero; split delimiter is not empty.

Set Value transformation—no source attribute is involved; a value has been
specified.

Submap transformation—at least one source attribute is involved; submap
name is specified.

Cross-Reference transformation—only one source attribute is involved.

Map Designer Express provides the following ways to open a map:

+ |“Steps for opening a map from a project in System Manager” on page 56|

* |“Steps for opening a map from a file” on page 57|

Steps for opening a map from a project in System Manager
Perform the following steps to open a map from a project in System Manager:

1.
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Open the Open a Map from a Project dialog in one of the following ways:
* Click File > Open > From Project.

¢ Use the keyboard shortcut of Ctr1+0.

¢ In the Standard toolbar, click the Open Map from Project button.
Result: Map Designer Express displays the Open Map dialog.

Froject;

)

Fint | - =

b ap |
= ClarityContact_to_Contact

= ClarifyContact_to_Order

= ClarifyContactRole_to_CustomerRole

Qpen I Cancel




Figure 24. Open Map dialog

4.

Select the project.

Select the map’s name from the list of maps currently defined in the project in
System Manager.

Tip: To locate a particular map name, enter its name in the Find field. The up
and down arrows scroll through the map list.

Click the Open button to open the map from the project.

Steps for opening a map from a file
A map definition can be stored in XML format in an operating-system file called a

map definition file. To create a map definition file, you save the map as a map
design file (.cwm) in Map Designer Express. For more information, see

fmap to a file” on page 51|

When you open a map definition file, you open the map in Map Designer Express.

Perform the following steps to open a map definition file:

1.

Open the Open a Map from a File dialog in one of the following ways:
* Click File > Open > From File.

* Use the keyboard shortcut of Ctri+I.

* In the Standard toolbar, click the Open Map from File button.
Result: The Open file with Map dialog box appears.

Select the map definition file you want to open. The file must be a .cwm file
created by Map Designer Express.

Result: Map Designer Express opens the map definition file. The map
information appears in the Map tabs.

Important: Opening the map in Map Designer Express does not automatically
save the map to the project. To save this map to the project,
continue to step (3].

Save the map to the project in System Manager. For more information, see
[“Saving a map to a project” on page 50}.

Rule: You must save the map to the project in System Manager for it to be
compiled. To compile the map, select Compile from the File menu. For more
information, see [“Testing maps” on page 85)

Closing a map

Perform one of the following actions to close the current map, which is displaying
in the tab window:

Open a new map in any of the ways discussed in [‘Opening a map” on page 55

Result: Map Designer Express closes the current map before it opens a new one.
From the File menu, select Close.

Result: Map Designer Express closes the current map and clears the tab window.
To make a new map current, you can either create a new map or open an
existing map.

Exit from Map Designer Express in one of the following ways:

— From the File menu, select Exit.

— Use the keyboard shortcut of ATt+F4.
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Result: Map Designer Express automatically closes the current map before it
exits.

Note: If you have changed the current map since it was last saved, Map Designer
Express displays a confirmation box to confirm the map closure.

Specifying map property information

Use the Map Properties dialog (see to display and specify property
information for a map. To display the Map Properties dialog, perform any of the

following actions:
* From the Edit menu, select Map Properties.
¢ Use the keyboard shortcut of Ctrl+Enter.

* In the map workspace of the Diagram tab, right-click and select Map Properties
from the Context menu.

The Map Properties dialog provides the following tabs:
* General tab

* Business Objects tab

shows the General tab of the Map Properties dialog.

Map Properties :_ ﬁl

General | Business Objects |

Map pame: |Elaﬂ}’13t:ntw_lo_l.3ariad

Mapping Direction: I.ﬂ-.npication-Speciic to Genenc j
Trace level m W Implicit D atabase Transaction

kel Lk m [~ Eail on invalid data
Map file declaration block: Espression Builder. ..
import java utils.*; ]

4 _l_I
Map local declaration block: Expression Builder... I

int gSettings = 1] ]

’ £

Figure 25. General tab of Map properties dialog
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Defining General Property information

information shown in

The General tab of the Map Properties dialog displays the general property

Table 19. General Map Property Information

General Map Property

Map name

Mapping role

Run-time properties

Trace level

Data validation level

Implicit Database

transaction

Fail on invalid data
Variable declarations

Map file declaration block

Map local declaration
block

Description

Identifies the map whose properties the
dialog displays. This field is initialized when
you create a new map and is not an editable
field.

Identifies the purpose of the map. Possible
values of mapping roles are:

* Application-specific to generic
* Generic to application-specific

* Other (for maps that do not have a
specific mapping direction associated with
them)

Note: For previously defined maps that do
not have this property information, the
combo box will be empty. This is permissible
as long as you do not use any Relationship
transformation rules. When you first create a
Relationship transformation rule and this
value is empty, Map Designer Express will
prompt you for this value.

For more information

N/A

Specifies the map properties (trace level, data validation level, implicit database
transaction, and fail on invalid data) that apply to the map instance at run time.
You can specify these properties here in the General tab of Map Designer Express’s
Map Properties dialog or from the Map Properties window that System Manager
provides. The changes are made to the local file system. Deploying the map to the

server will not update the run-time instance.

Note: You can update these map properties dynamically from the server
component management view by right-clicking on a map and selecting the
properties from the Context menu. The changes will be automatically updated to

the server.
Sets the trace level for the map.

Allows you to check each operation in a map
and log an error when data in the incoming
business object cannot be transformed.
Determines whether InterChange Server
Express uses implicit transaction bracketing
for transactions over its connections.
Determines whether map execution fails if
data is invalid.

“Adding trace messages” on page]

492

“Creating custom data validation|

levels” on page 182

“Creating custom data validation|

levels” on page 182

You can declare your own Java variables to use in your transformation code. For

more information, see[“Using variables” on pa

e 163

Allows you to import Java packages (such as
MapUtils) into a map for use within
transformation code.

Allows you to import custom Java code
developed outside of Map Designer Express
into a map for use within transformation
code.

“Importing Java packages and other|

custom code” on page 154|

“Importing Java packages and other|

custom code” on page 154|
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Defining business objects

The Business Objects tab of the Map Properties dialog displays information about
the map’s business objects. It lists the source and destination business objects as
well as any temporary business object that might be defined. For more
information, see [“Steps for modifying business object variables” on page 164

Using map documents

You can create a map document to see all transformations in a single map or
between two maps. While checking a map, you might want to view all of its
transformations in a single operation, rather than opening and viewing each
attribute separately. To do so, you can create a map document that contains all
transformations. A map document provides you with an automated way to
document native-map transformations.

This section provides the following information:

* A description of the two HTML files that make up a map document
* How to create a new map document

* How to view a map document

* How to print out a map document

What is a map document?

A map document consists of two HTML files that describe all transformations of a
map (or set of maps):

* A map-table file that describes the map transformations in a tabular format.
The map-table file has the name mapDoc .HTM.

* AJava-code file that contains the code of the map transformations.
The Java-code file has the name mapDocJavaCode.HTM.

In both these HTML files, mapDoc is the user-specified name of the map document.

The map document can include information for all attributes, only those attributes
that have map transformations, or only those attributes that do not have map
transformations (unlinked attributes). If you specify all attributes, the map
document also contains a list of unlinked attributes in the source and destination
business objects.

The following sections describe the format of the two HTML files of a map
document.

Map-table file format
The map-table file, mapDoc .HTM, describes the map transformations in a tabular
format:

* If the map document describes only one map, Map Designer Express creates a
single-map map table.

e If the map document describes two maps, Map Designer Express creates a
multiple-map map table.

Single-map map table: A single-map map table describes the mapping flow in a
single map; that is, it describes the transformations between a source and
destination business object. The single-map map table has the following columns:

* Source Attribute shows the names of the source business object’s attributes.
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* Transformation Rule describes the kind of mapping transformation between the
attribute in the source business object (in the column to the left) and the
attribute in the destination business object (in the column to the right). The
transformations listed in this column are hypertext links to the location of the
attribute in the mapDocJavaCode.HTM Java-code file for the map.

e Destination Attribute shows the names of the destination business object’s
attributes.

shows the HTML file that contains a single-map map table.

W ClarifyContact_to_Contact - Microsalt Internet Explorer _dnl!l
Bl Edt Yew Favories Took beb

oo - Q| Qewch Gt e 3D IE-HBR

ihess [ B FrempiClarfyCortact_to_Contoct HTM 7] @G0 |Lnis ®

ClarifyContact_to_Contact

Linked Attributes:

Ob;C'JarlIy Contact ContactlD |Dlowe EObJConI..an:I: Con:an:t[d |
[ObiContact | -

Ob;C‘Imfy_Comacl .T-ame'ber M - -E'ObJCDnIMl OEcePhon.eCm.
ObyClanfy_Contact Phone Move [ObsContact HomePhone |
ObjClarify_Contact Salutation _[Move |ObjContact, Salutation [

[ObjClarify_Contact Lastbame
Clarify Contact Frstlame - ObjContact FirsthV
OlClarify_Contact Firstllame [ jContact Firsthame

OboyClanfy_Contact Firstiame [Spht |ObyContact MiddleInbal |

The tahle shews how an sttribute of 3 source business shject ls mapped 1o am atoribute of s destinathon business bject. To display Jwvs code fora
particular attribute, click its transformation rule hyperlink.

Unlinked attributes in map ‘ClarifyContact_to_Contact':

ObyContact
» Lasttlame =
& 0we [T Ewems

Figure 26. Single-map map table

Note: If you enabled the Comment check box Create Map Document dialog, the
map table contains a fourth column called Comment, which shows the
comment for each of the destination attributes in the table.

Multiple-map map table: A multiple-map map table describes the mapping flow
between two maps; that is, it describes the transformations in the inbound map
(between the application-specific and generic business object) and an outbound
map (between the generic and application-specific business object). The
multiple-map map table has the following columns:

* Source Attribute shows the names of the application-specific business object’s
attributes.

* The first Transformation Rule column describes the kind of mapping
transformation between the attribute in the application-specific business object
(in the column to the left) and the attribute in the generic business object (in the
column to the right). The transformations listed in this column are hypertext
links to the location of the attribute in the mapDocJavaCode.HTM Java-code file for
the inbound (application-specific to generic) map.
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* Common Attribute shows the names of the generic business object’s attributes.

* The second Transformation Rule column describes the kind of mapping
transformation between the attribute in the generic business object (in the
column to the left) and the attribute in the application-specific business object (in
the column to the right). The transformations listed in this column are hypertext
links to the location of the attribute in the mapDocJavaCode.HTM Java-code file for
the outbound (generic to application-specific) map.

e Destination Attribute shows the names of the application-specific business
object’s attributes.

shows the HTML file that contains a multiple-map map table.
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+ LastMame
o Sffix - =

Figure 27. Multiple-map map table

Java-Code file format

The Java-code file, mapDocJavaCode.HTM, provides more detailed information about
the map. It contains the Java code that performs the transformations. This code is
in standard program format. The Java-code file is useful when you want to view
all map transformations in a single operation, rather than opening and viewing
each attribute separately.

Steps for creating a map document
Perform the following steps to create a map document:
1. From the File menu, select Create Map Documents.
Result: Map Designer Express displays the Create Map Document dialog (see

Figure 28).

2. Select the map-document configuration options from the Create Map Document
dialog;:
* Specify the project.
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* Specify the maps that are involved in the map document.

Guideline: If you do not select the “Show mapping flow with two maps”
check box, you can select only one map from the drop-down list. The
drop-down list includes all maps currently defined. If a map is currently
open, its name appears by default.

If you select the “Show mapping flow with two maps” check box, the second
drop-down list is enabled. This second drop-down list provides only those
maps that share the same generic business object as the first map. From this
list, you can select the name of the second map to include in the map
document.

* Specify the attributes in the destination business object to include in the map
document.

Click the appropriate radio button to indicate whether to include all
attributes, only mapped attributes, or only unmapped attributes in the map
document.

* Specify a name for the new map document.

Guideline: You can click the Browse button to find a location for the
map-document file. Map Designer Express automatically appends the suffix
.HTM to the map-document name you enter. Therefore, you do not need to
specify a file extension.

3. To initiate creation of the map document, select one of the following options:
* Click Save to save the selected maps in a map document.

* Click Save/View to save the selected maps in a map document and view this
new map document in an HTML browser.

shows the Create Map Document dialog.

Create Map Document x|
[~ Map Hames
: Save
Progect J'. ClasiyPropect d
Map Name: | [57] CiariyCorract_to_Cortact | S_I' sV
[ Show Comment
I Show Mapping flow with bwao maps
| IE]
Show Dectination Business Object Aftibubss with
AN Attribaites
" Linked Atributes Oniy
" Uninked Aftrbutes Onk
HTML Map D ocumerd Hame
[F-\WemeAClasiyCortact_to_Cortact HTM

Figure 28. Create Map Document dialog

When you create a map document, Map Designer Express creates the map
document as a Hypertext Markup Language (HTML) file (mapDoc .HTM) and a
related Java code file (mapDocJavaCode.HTM) where mapDoc is the map-document
name you specified in the Map Document Configuration dialog.

Viewing a map document

You can view a map document in any of the following ways:

* Open an existing map document in either of the following ways:
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— From the File menu, select View Map Document.
— Use the keyboard shortcut of Ctr1+M.

Result: The Open dialog displays the available map-document files. Specify the
HTML map document to read and click Open.

* Open a new map document by clicking Save/View on the Map Document
Configuration dialog.

* Go into the directory that contains the map document files and double-click the
desired file.

Result: Map Designer Express invokes your browser to display the HTML
map-document file that you selected.

Guideline: In addition, you can view the Java code associated with a particular
transformation by clicking the entry in the Mapping Action column of the map
table. Your browser displays the corresponding Java code segments that implement
the mapping between the associated source and destination attributes.

Printing a map document

Perform the following steps to print a map-document file:
1. View the desired file in your HTML browser.

For more information, see[“Viewing a map document” on page 63

2. Print the displaying HTML file from the browser by doing one of the following:
¢ Select Print from the browser’s File menu.
* Use the keyboard shortcut of Ctr1+P.
* Click the Print button in the Standard tool bar.

Using map automation

Map automation allows you to create maps automatically between business objects
with similar attributes. You can also generate reverse maps for any given maps.

This section covers the following tasks:

* |"Creating maps automatically”|

* |“Creating reverse maps automatically” on page 68

* |“Using synonyms for automation” on page 70|

Creating maps automatically

Map Designer Express can generate maps automatically between business objects
having source and destination attributes with the same names. Even if the business
objects are different, they may have certain elements in common. For example, a
customer business object usually has the attributes First name, Last name, Address,
and Zip code to maintain customer data.

To map business objects automatically, Map Designer Express looks for attributes
with matching names between the source and destination business objects and uses
a Move transformation. The mapping happens only at corresponding levels, that is,
the top-level attributes in the source business objects are mapped with the top-level
attributes in the destination business objects, not any other level. Similarly, the
child business objects on the source side are considered for map automation only if
corresponding child objects are found in the destination business objects at the
same level.
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Steps for creating maps automatically

Before you begin: You need to have a map definition file with the source and
destination business objects specified. For information on creating a new map

definition file with the New Map wizard, see [‘Steps for creating the map|

[definition” on page 31|

Perform the following steps to create maps automatically:

1. From the Tools menu, select Automatic Mapping.

Result: The Automatic Mapping dialog appears, giving you the ability to
provide a prefix or suffix for Map Designer Express to use for searching

attributes.
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Figure 29. Prefix and Suffix Setting dialog

2. To use this option, do the following in the Automatic Mapping dialog;:
a. Select the check box Add Prefix or Suffix to attributes during search.

Note: This option is disabled, by default.

b. Select Prefix or Suffix; and in the space provided, type a prefix or suffix to

add to the search string for the particular session.
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Restriction: At any given instance, the choice can only be a suffix or a
prefix. You cannot use both at the same time for searching.

c. Click OK.
Note: Map Designer Express will also use the preferences you have set for
case and data types in the Automatic Mapping tab of the Preferences
dialog.

Preferances |g|

General | didation | Key Mapping  Autamatic Mapping l

Automnatic Map

I larare Incompahble O ata types

(n].4 | Cancel

Figure 30. Automatic Mapping tab in Preferences dialog

For information on setting these preferences, seq”Specifying Automatid
Mapping” on page 24]

Result: Map Designer Express will perform a search on every attribute on the
source side with the prefix or suffix added to the search string on the destination
side. Every time a matching attribute is found on the destination business object,
automatic mapping will take place between the source attribute and the prefixed
destination attribute.

Example of automatic mapping
The following illustration of automatic mapping includes adding a prefix.

Suppose a source business object has the following attributes:
1. FirstName

2. LastName

3. Address

4. Zip

The destination business object has these attributes:
1. ORCL_FirstName

2. ORCL_LastName

3. ORCL_Address
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4. Pin
5. State
6. Country

In the Automatic Mapping dialog, we select the check box Add Prefix or Suffix to
attributes during search. We type ORCL in the Prefix space and click OK.

Note: This example presumes we have previously set the preference to Ignore
Case in the Automatic Mapping tab of the Preferences dialog to perform a
case-insensitive search on the names.

Result: Map Designer Express performs a case-insensitive search on the attributes
on the source side (FirstName, LastName, and Address) with the prefix ORCL added
to the search string on the destination side (ORCL_FirstName, ORCL_LastName,
ORCL_Address). Every time a matching attribute is found on the destination
business object, automatic mapping takes place between the source attribute and
the prefixed destination attribute using a Move transformation. In our example, the
mapping will occur between FirstName and ORCL_FirstName, LastName and
ORCL_LastName, Address and ORCL_Address. The other attributes do not match
up, so no mapping takes place between them.

illustrates this example.
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Figure 31. Example of adding a prefix in automatic mapping
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Creating reverse maps automatically

Typically, maps are used in pairs. In most places where a map is used, a map is
also needed in the opposite direction. Using Reverse Map, automates the steps
required to create a reverse map. The following table shows the standard
transformation rules that Map Designer Express currently supports (Current map
column) and the transformation rules that Reverse Map currently includes (Reverse
map column).

Table 20. Transformation rules used for current map to reverse map

Current map Reverse map

Move Move

Split Join

Join Split

Set Value No mapping

Custom No mapping
Cross-Reverence No mapping

Submap Submap if there is one

As [Table 20| shows, reverse mapping presently includes the Move, Split, Join, and
Submap transformations. The Set Value, Cross-Reference, and Custom
transformation rules are left untouched during a reverse map creation.

Restriction: For a Join to Split reverse mapping to take place delimiters must be
provided. For a Split to Join reverse mapping, however, delimiters are optional.

Steps for creating reverse maps automatically
Perform the following steps to create a reverse map automatically.

1. Open the map for which you need a reverse map.

2. From the Tools menu, select Reverse Map.
Result: The Save As dialog appears.

3. Type a name for the reverse map and click Save.

Result: Map Designer Express creates a reverse map for the currently open
map and opens the reverse map in a new instance of Map Designer Express.

Example of reverse mapping
The following example shows a before and after map reversal scenario.
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shows a map that needs a reverse map. It uses the Move, Custom, Join,
Split, and Set Value transformations.
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Figure 32. Map that needs a reverse map
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After you perform the steps for automatically creating a reverse map (see
ffor creating reverse maps automatically” on page 68), the following map opens.
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Figure 33. Map created automatically as a result of reversal

As you can see in the Move transformation becomes a Move again in the
reverse map. The Split and Join transformations are reversed. The Custom (Pay)
and Set Value (Shift) transformations are left untouched. You need to do these
manually with Activity Editor. The transformations that cannot be made in the
reverse direction will be listed as warnings in the output window.

For information on using Activity Editor, see [Chapter 5, “Customizing a map,” on|

Using synonyms for automation

To enhance the basic matching process, you can create multiple synonyms for an
attribute name. For example, you can match an attribute name not only with one
matching name but also with several possible equivalent names.

Example: Suppose we have a CR as an attribute name on the source side. It could
be matched to the following attribute names on the destination side:

* Defect
* Change request
* Bug number

¢ Defect number
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« CR

You add these synonyms at the project level in the Synonyms window of System
Manager. You can edit the entries here and add more comma separated strings to
help in map automation. You can also create global synonyms that apply to all the
business objects in the project.

For the procedure for creating synonyms for map automation in System Manager,
see the System Implementation Guide.

System Manager will search for all the synonyms for a given attribute and perform
automatic mapping when it finds the matches. For example, a CR on the source
side will match up to Defect, Change request, Bug number, and CR if you have added
these as synonyms in the Synonyms window. When any of these words is
encountered, a mapping will be performed automatically.

Finding information in a map

You can use Map Designer Express’s search facility to perform the following
searches:

e Search for text in an attribute name or in the attribute’s transformation code.

¢ Search for unlinked attributes.

Steps for finding information in a map
Perform the following steps to find information in a map.
1. Initiate a find in one of the following ways:
e From the Edit menu, select Find.
* Use the keyboard shortcut of Ctri+F.
e In the Standard toolbar, click the Find button.
Result: Map Designer Express displays the Find control pane (see .
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Figure 34. Find Control Pane

2. From the Find control pane, select one of the radio buttons in the What to find?
area to indicate which kind of search you want to perform:

e To search for text:
a. Select the Text radio button.

b. Enter the text to search for in the Find field. You can enter multiple

words and spaces if necessary.

c. Indicate where to search for the text by selecting one or more options in

the Find area:

Attribute—search the attribute names for the specified text.

Code—search the attributes’ transformation code for the specified text.
You can select either Attribute or Code, or both of those options.

Case Sensitive—make the text search case sensitive. To find only instances
of the text that have the same case that you typed, select Case Sensitive.

Restriction: You cannot search on data types or comments.
d. Click Find to initiate the search.

¢ To search for unlinked attributes:

a. Select the Unlinked Attributes radio button. The Find control pane
deactivates the fields in the Find area.

b. Click Find to initiate the search.

Result: Map Designer Express displays the search results in the Find Results
area. You can click any attribute name to automatically select that attribute in

the map.

3. Click Close to close the Find control pane.
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Finding and replacing text

Using Map Designer Express’s Find and Replace capability, you can search for
specified text in any customized Java Code or in the comments of a transformation
rule (or in both) and replace it with other specified text.

Steps for finding and replacing text
Perform the following steps to find and replace text.

1.

Figure 35. Replace dialog

2.

Initiate a find and replace in one of the following ways:

¢ From the Edit menu, select Replace.

* Use the keyboard shortcut of Ctr1+H.

Result: Map Designer Express displays the Replace dialog.

|x

Find what: IString Eind Mext I
Replace with: I Beplace |
Replacein——— Replace Al |

¥ Code Cancel |

Iv¥' Comment

[ Match case

In the Replace dialog, enter the text to search for in the Find what field and the
text to replace it in the Replace with field. Select Match case, as necessary.

Indicate where to Replace in by selecting either Code or Comment or both.
Click Find Next to initiate the search.
Result: One of the following results takes place:

* If you specified Replace in Code, when text is found in the customized Java
code of a transformation rule, Activity Editor will display with the
customized Java code in Quick view mode.

* If you specified Replace in Comment, the Table view will be activated and
the text will appear in the comment column in the Table view.

Click Replace to replace the match with the new text.

Guideline: You can replace all similar matches with one action by clicking
Replace AlL

To continue finding and replacing the specified text, instance by instance,
repeat steps 4 and 5.

Printing a map

Map Designer Express allows you to print a map. It creates a tabular
representation of the map, much like the map appears in the Table tab. You can
print a map in any of the following ways:

* From the File menu, select Print to print the current map.
* Use the keyboard shortcut of Ctr1+P.
¢ In the Standard toolbar, click the Print button.

Map Designer Express also supports the following standard print tasks:
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Print Preview—select Print Preview from the File menu to preview the page
layout for the current map.
Print Setup

— From the File menu select Print Setup to display the Print Setup dialog,
where you can configure information such as printer setting, paper size and
orientation.

— Use the keyboard shortcut of Ctr1+Shift+P.

Guideline: When Map Designer Express performs the print or print-preview task,
it copies the attribute transformation table in the Table tab. Before you print, you
can adjust the width of the individual columns and height of individual rows in
the attribute transformation table to make the whole map fit on one page or to
customize the print result.

Deleting objects

This section provides information on how to delete the following objects:

* |“Steps for deleting map transformation steps”|

+ |“Steps for deleting business objects”|

+ |“Steps for deleting maps” on page 75

Steps for deleting map transformation steps
Deleting a map transformation step includes three components:

Deleting the transformation code
Deleting the comment
Deleting the data flow arrow

Perform the following steps to delete the transformation step from one of these
map tabs.

From the Table tab: Select the attribute line to delete by clicking in the leftmost
column (the column to the left of Exec. Order) and doing one of the following
actions:

— Right-click and select Delete Row from the Context menu.
— From the Edit menu, select Delete Current Selection.
— Use the keyboard shortcut of Del.

Result: Map Designer Express automatically deletes any incomplete
transformations when you save the map.

From the Diagram tab: Select the data flow arrow and do one of the following
actions:

— From the Edit menu, select Delete Current Selection.
— Use the keyboard shortcut of Del.
— Right-click and select Delete from the map workspace’s Context menu.

Result: A dialog asks you whether to delete the associated data flow arrow.
Click Yes and Map Designer Express displays a second confirmation asking if
you want to delete the associated code. Click Yes and all three items are deleted.

Steps for deleting business objects

Perform the following steps to delete a business object from a map:

1.

Display the Delete Business Object dialog in one of the following ways:
e From the Edit menu, select Delete Business Object.

74 Map Development Guide



¢ From the Table tab, perform either of the following actions:

— Right-click in the empty area of the business objects pane and select
Delete Business Object from the Context menu.

— Right-click the business object in the business objects pane (click the name
in the cell) and select Delete <BusObjName> (where BusObjName is the
name of the selected business object.)

Result: The Delete Business Object dialog displays.

Delete Business Dbjects : x|
Fin | =] 2]
Buziness Object:
Del... | Buziness Object | Type |
O B Objalevellnput alevelllnput
O B Objalevell Output alevell Output

Delete I Cancel

Figure 36. Delete Business Object dialog

2. Through the Delete Business Object dialog, you specify which business objects
you want to delete from the map. The Delete Business Object dialog provides
the following functionality:

* To delete a business object:
— Select the business object in the business object list.
— Click the Delete button.

* To locate a particular business object, enter its name in the Find field. The up
and down arrows scroll through the business object list.

* To close the dialog, click Done.

Steps for deleting maps
Perform the following steps to delete a map from the project in System Manager:
1. From the File menu, select Delete.
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Result: Map Designer Express displays the Delete Map dialog, as
shows.

Delete Map x|
Froject;
I'. ClarifyProject j

Fird: | - =

b ap I
el ClanifyContact_to_Contact
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Delete I Cancel

Figure 37. Delete Map dialog
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Note: If a map is currently open, Map Designer Express closes this map before

it displays the Delete Map dialog. You can specify whether Map

Designer Express closes any currently open map with the option Delete
Map: close map before delete. By default, this option is enabled. If the

option is disabled, Map Designer Express provides a confirmation

prompt if you select the currently open map from the Delete Map dialog.

You can change the setting of this option on the General tab of the
Preferences dialog. For more information, see|“Specifying Generall
[Preferences” on page 22.|

Enter the project name.

Select the map or maps you want to delete.

From the Delete Map dialog, you can:

* Select a single map by clicking on the map name in the list.

* Select multiple maps by holding down the Ctr1 or Shift key and clicking on

the map names.

¢ Locate a particular business object by entering its name in the Find field. The

up and down arrows scroll through the business object list.
Click the Delete button to delete the maps.
Result: Map Designer Express displays a confirmation box for the delete.

Note: You can specify whether Map Designer Express confirms the deletion of
a map with the option Delete Map: always display warning message. By
default, this option is enabled. You can change the setting of this option
on the General tab of the Preferences dialog. For more information, see

[“Specifying General Preferences” on page 22)




Using execution order

By default, map execution occurs in the order that the destination attributes appear
in the Table tab. Only destination attributes that have transformations are executed.
Often, the execution order is the order in which the destination attributes are
defined in the destination business object. shows an execution order of
the map A-to-B in which destination attributes are executed in the order they are

defined.
Execution Order
Src-A Dest - B
B Attr1
Attrd B Attr2
Attr1 ttr B Atir3
Attr2 Attr2 B Attr4
Attr3 Attr3 B AttrS
B Attr6
Attrd — | Attr4 B Attr7
Attr5 Attrs
Attré Attré
Attr7 Attr7

Figure 38. Default execution order
Note: assume that all destination attributes have transformation code.

However, certain attributes might have dependencies in their execution order. To
ensure that the transformation code of certain attributes is executed before the
transformation code of other ones, you can specify the order of their execution.
You can change the execution order to specify data flow. For example, suppose in
the map A-to-B that Attr7 needs to execute immediately after Attr3 (in other
words, Attr7 needs to execute before Attr4). shows how a sequence
specification in the destination business operation changes the sequence.

Execution Order
Src-A Dest-B

B Attr1

A B Attr2

Adtrl it B Atr3
Attr2 Attr2 B Attr7
Attr3 Attr3 B Attr4

B Attr5
Attrd — Attr4 B Attr6
Attr5 Attr5
Attré Attré
Attr7 Attr7

Figure 39. Changing execution order
You can specify an explicit execution sequence that overrides the default order

from the Table tab of Map Designer Express. To specify the sequence of
transformations between two destination attributes in the Table tab, click in the
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Exec. Order field for the destination attribute whose execution order you want to
change and enter the desired execution order value.

Note: You can specify whether Map Designer Express renumbers the execution
order for any attributes affected by this change with the option Defining
Map: automatically adjust execution order. By default, this option is
disabled. When the option is enabled, Map Designer Express automatically
adjusts the execution order of other attributes. You can change the setting of
this option on the General tab of the Preferences dialog. For more
information, see [“Specifying General Preferences” on page 22|

By default, the Table tab displays attributes in the order their transformations are
defined. You can then choose to display these mapped attributes by their execution
order, their attribute names, or ordered by any other column of the attribute
transformation table. Just click the heading of the column to order the attributes by
that column’s value.

Important: If you click the row header of the transformation and drag-and-drop
the transformation to a new position, you change the order in which
the transformation rule is displayed. However, this action does not
affect its execution order.

Creating polymorphic maps

Polymorphic mapping allows a single source business object to map to one of
many potential destination business objects. To do this form of mapping, you must:

1. Create a separate map (one source object and one destination object) for each
possible outcome.

2. Create a main polymorphic map that has a single source business object and
multiple destination objects.

3. Within the first attribute of each destination business object, check some
condition that dictates which destination business object is to be populated. If
the condition is true, run the appropriate map to accomplish the desired results
using the runMap () method.

Example: Below is sample code from the first attribute in one of the destination
business objects in a main polymorphic map. In this example, ObjInput is the
Instance variable for the source business object, 0bjOutputl is the Instance variable
for the output object which contains this code, and InputToOutputl is the submap
which performs the actual mapping from 0bjInput to ObjOutputl. In this case, the
condition which dictates whether this mapping occurs is based on the value of the
Attrl attribute within the source business object. Your condition will obviously
vary.

BusObj[] rSrcBO
BusObj[] rDstBO

new BusObj[1];
new BusObj[1];

rSrcBO[0] = ObjInput;
String AttrlVal = ObjInput.getString("Attrl");

if (AttrlvVal.equals("Polyl"))

{
try

{
rDstBO = DtpMapService.runMap("InputToOutputl",

DtpMapService.CWMAPTYPE, rSrcBO, cwExecCtx) ;

ObjOutputl.setContent(rDstBO[0]);
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}
catch (MapFailureException e)

{

e.toString();
e.printStackTrace();
raiseException(e);

}
catch (MapNotFoundException e)
raiseException("MapNotFoundException",
"runMap did not find map");
}

catch (Exception e)

e.printStackTrace();
}
}

Importing and exporting maps from InterChange Server Express

With the repos_copy utility, you can load and unload specified map definitions in
the repository with the -e option. A map repository file is the file that the
repos_copy utility creates when it extracts a map definition from the repository
into a .jar file. This file contains a map definition in an IBM WebSphere Business
Integration Server Express-defined .jar format.

Recommendation: You should use the .jar file extension for the map repository
file.

Example: The following repos_copy command unloads (exports) the C1CwCustomer
(ClarifyBusOrg to generic Customer) map definition from the repository of an
InterChange Server Express named WebSphereICS into a map repository file:

repos_copy -eMap:C1CwCustomer+BusObj:Customer+BusObj:Clarify Customer
-oNM_C1CwCustomer.jar -sWebSphereICS -pnull -uadmin

You can create one repository file that contains all map definition files, including:
* Main map definitions

* Submap definitions

* Files for both directions, if applicable.

Example: To copy all related map definitions for the ClarifyBusOrg/Customer
mapping into a map repository file, use the following repos_copy command:

repos_copy -eMap:C1CwCustomer+Map:CwC1Customer
-oNM_C1CwCustomer_and_CwC1Customer.jar -sWebSphereICS -pnull -uadmin

If you are reusing a submap in several maps, create a separate repos_copy file for
it instead of putting it in the main text file.

You can also use repos_copy to load (import) a map definition into the repository
from a map repository file.

Example: The following repos_copy command loads the C1CwCustomer map
definition into the repository of an InterChange Server Express named
WebSpherelCS:

repos_copy -iNM_CI1CwCustomer.jar -sWebSphereICS -uadmin -pnull
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This repos_copy command assumes that the C1CwCustomer and CwC1Customer map
definitions do not currently exist in the repository. If they do exist, this command
fails to load these new map definitions. You can use one of the -a options of
repos_copy to choose how to handle duplicate map definitions:

-ai Skip over duplicate map definitions during the load

-ar Overwrite any duplicate map definitions with the map definition in the
map repository file.

-arp Interactively query the user whether to overwrite any duplicate map

definitions with the map definition in the map repository file.

Note: In Production mode, the maps will be automatically compiled.

You can also use repos_copy to load and unload relationship definitions in the

repository. For more information, see [‘Loading and unloading relationships” on|
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Chapter 4. Compiling and testing maps

This chapter describes how to validate, compile, and test maps using Map
Designer Express.

The chapter covers the following tasks:

» [“Checking the transformation code” on page 81|

* |“Validating a map” on page 82

+ |“Compiling a map” on page 82|

7

* [“Compiling a set of maps” on page 84|
* [“Testing maps” on page 85

* [“Doing advanced debugging" on page 92|

+ |“Testing maps that contain relationships” on page 93|

[“Debugging maps” on page 98|

Checking the transformation code

When you have finished writing the transformation code associated with a
destination attribute, you can perform a limited syntax check on the code. By
checking as you proceed, you reduce debugging time required at the end of the
map development process. You can check attribute code using the technique of
finding unmatched delimiters.

Note: This technique is also useful when you have a compilation error whose
cause you cannot immediately determine from the error message.

Finding unmatched delimiters

Map Designer Express provides the Check for Unmatched Delimiters feature to
help you resolve one of the errors in a program that is most difficult to identify.
This feature checks for unmatched delimiters in an attribute’s transformation code.
Map Designer Express checks for these paired tokens: (), [ ], {}, “”, and *".

Steps for finding unmatched delimiters
Perform the following steps to do a syntax check on an attribute’s transformation
code:

1. Invoke Activity Editor in Java mode.

For information on how to display Activity Editor, see [“Starting Activity|
[Editor” on page 101]

2. Use the Check for Unmatched Delimiters option in Activity Editor. Right-click
and select Check for Unmatched Delimiters from the Context menu.

Note: If an unpaired instance of one of the delimiters exists, Activity Editor
displays a message in the output window, providing the line number
where the error was unable to be resolved. This line number might not
be the actual line of the missing delimiter.

3. To go to the source of the unmatched delimiter, note the line number displayed
at the bottom of the window.
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Tip: To move to this line, use the Goto Line option from either the Edit menu
or the Context menu of Activity Editor. Enter a line number to navigate to the
line where the problem occurred.

Note: If the problem is caused by unmatched quotation marks at one end of a

string literal, the string does not appear pink as it should. When you add
the missing quotation mark, the entire string turns pink.

Validating a map

Map Designer Express’s validation process verifies the accuracy of the map’s data
flow by performing the following checks:

Ensures that the map has no incomplete transformation steps.

Ensures that indexes to business object arrays are properly sequenced, starting
from zero (0).

Provides a warning if any transformation step maps to the ObjectEventId
attribute.

Validates transformations:
— Makes sure execution order is correct; that is, that execution order is unique,

positive, and consecutive.

Ensures that no attributes have cyclic dependencies on each other. If any
cyclic transformations are found, Map Designer Express displays the cyclic
rules in the output window.

Checks transformation information:
Move transformation—only one source attribute is involved.
Join transformation—more than one source attribute is involved.

Split transformation—only one source attribute is involved; split index is
greater than or equal to zero; split delimiter is not empty.

Set Value transformation—no source attribute is involved; a value has been
specified.

Submap transformation—at least one source attribute is involved; submap
name is specified.

Cross-Reference transformation—only one source attribute is involved.

Map Designer Express automatically validates a map when you save it. You can
also choose to validate the map by performing either of the following actions:

e From the File menu, select Validate Map.
* In the Designer toolbar, click the Validate button.

At this point, if you have specified any options on the Validation tab of the
Preferences dialog, Map Designer Express will issue a warning if the specific
condition is not mapped.

For more information on setting dependencies between attributes, see

lexecution order” on page 77}

Compiling a map

When it compiles a map, Map Designer Express generates a .class file from the
.java file that holds Java code for the map’s transformations. It generates this
.java file from the transformation code stored as part of the map definition in the
project.
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Important: To be able to compile a map, the Java compiler (javac) must exist on

your system and its path must be on your PATH system variable. For
more information, see [’Setting up the development environment” on|

age 11,

Steps for compiling a map from Map Designer Express

From within Map Designer Express, you can initiate compilation of a map in
several ways:

To compile the current map, do one of the following;:

— From the File menu, select Compile.

— Use the keyboard shortcut of F7.

— In the Designer toolbar, click the Compile button.

To compile the current map and any submaps that this map is using:
— From the File menu, Select Compile with Submap(s).

To compile all or a subset of maps defined in System Manager, do one of the
following:

— From the File menu, select Compile All
— Use the keyboard shortcut of Ctrl1+F7.
For more information, see[“Compiling a set of maps” on page 84|

By default, Map Designer Express saves the map in the project before it begins the
compile and generates the Java code in the .java file and .class file. If any
message file is needed, Map Designer Express will also generate the message file.

Note: You can specify whether Map Designer Express automatically saves a map

to the project before compiling the map with the option Compile Map: save
map before compile. By default, this option is enabled. You can change the
setting of this option on the General tab of the Preferences dialog. For more
information, see [“Specifying General Preferences” on page 22|

To compile, Map Designer Express calls the Java compiler on the map’s Java source
code (.java file). The actions it then takes depend upon whether the compilation is
successful.

Steps for compiling a map from System Manager

System Manager also provides several ways to compile a map:

To compile a single map, do one of the following:

— Highlight the desired map and select Compile from the Component menu.
- Right-click the desired map and select Compile from the Context menu.
To compile a map and its submaps:

— Right-click the desired map and select Compile with Submap(s) from the
Context menu.

To compile all maps defined in the project:
- Highlight the Maps folder and select Compile All from the Component menu.

Note: You will need to select which map folder in the project to compile all

maps for by right-clicking on the map folder and selecting Compile All
from the Context menu.
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A successful map compilation

When the map successfully compiles, Map Designer Express takes the following
steps:
* Compiles the Java code into a .java file.

* Displays the following message in the output window at the bottom of each
Map tab to indicate that there are no errors during compilation:

Compilation is successful.

An unsuccessful map compilation

If an error occurs during compilation, Map Designer Express generates error
messages and displays them in the output window at the bottom of the screen.
Unless an output window is already open, Map Designer Express opens one at the
bottom of the Map tab to display these compilation messages.

When a compile error occurs, the output window displays the error message with
the problematic attribute name and line number in blue. Click the hyperlink to

navigate to the problematic area in the Java view in Activity Editor.

Tip: You can clear the output window of messages by selecting Clear Output from
the View menu.

Some errors are easy to detect, while others are not.

Compiling a set of maps

Using the Compile All option on the File menu, you can compile all maps in your
System Manager, or a subset of maps.

Steps for compiling a set of maps
Perform the following steps to compile a set of maps:
1. From the File menu, select Compile AlL
Result: Map Designer Express displays the Compile All Maps window.
2. Select the project for the map compile.
3. Select the maps to compile.

Guideline: Selecting any check box at the root will automatically check all its
child check boxes. Thus, when you select a project, all maps in that project are
selected. To select only a subset of maps, deselect the appropriate Compile
check boxes.
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illustrates the Compile All Maps window.
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dltem_to [temB azic

| [
| ok I Cancel |

Figure 40. Compile All Maps window

Result: Map Designer Express displays the success or failure of each map’s
compilation in the output window. You might want to enlarge the size of the
output window before starting the compilation process so you can see more of the
compilation status messages.

Testing maps

You can test a map’s transformation steps by providing sample data for the source
business object and executing a test run of the map. A test run is map execution
that does not involve an event sent by a connector or a call sent by an access
client; the map executes within Map Designer Express. Map Designer Express
provides a separate tab, the Test tab in the Map Designer Express window to test
maps and view test results.

Note: When a map is selected from Testing Environment for further debugging,
Testing Environment will launch Map Designer Express, giving Map

Designer Express the input business objects to the map under testing.

This section describes how to set up and execute a test run, using these main steps:

« |“Steps for preparing to run the test” on page 8¢

* [“Creating test data” on page 86

* |“Setting breakpoints” on page 88|

* |"Running the test map” on page 90|
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* |"Viewing test run results” on page 92|

* |“Steps for changing the map and re-executing” on page 92|

Tip: An alternative testing strategy, which is not covered in detail, is to set
breakpoints in the map and to send a triggering event from the connector, which
causes the map to execute.

Steps for preparing to run the test
Before running the test, perform the following steps:
1. Open the map to debug from the project.

2. If the map has not been compiled since the last modification, compile it b
selecting Compile from the File menu. For more information, see

[map” on page 82}

3. If the Test tab of Map Designer Express is not currently displaying in the tab
window, select the Test tab.

Creating test data

Every time you test a map, you must load data into the source business object. To
do this, use the Source Testing Data pane in the Test tab (see Ficure 41). The Source
Testing Data pane allows you to specify the following test information:

* The calling context—indicates the map execution context for the map run.

* The generic business object—provides test data for the generic business object
when testing the SERVICE_CALL_RESPONSE calling context for an identity
relationship.

* The test data—data for the attributes of the source business object.

Important: The calling context and generic business object are required only for
testing relationships within maps. For more information, see

[maps that contain relationships” on page 93|

Testing the map for the first time
When you test the map for the first time, you must manually enter the values of
the attributes in the Source Testing Data pane.

The following sections provide information about how to enter this data:

* |"Guidelines for creating test data for the source business object” on page 86|

* |“Steps for creating test data for a child business object” on page 87|

Guidelines for creating test data for the source business object: To create source
business object data for the first time, follow these rules:

* To set the verb, select it from the verb combo box in the verb row.

* To assign a value to a source attribute, type it into the attribute’s Value column.
You do not have to provide values for all attributes.

* To assign a value to a relationship attribute, specify the appropriate value in the
Value column and make sure you also specify the correct calling context. For
more information, see [“Testing maps that contain relationships” on page 93|

* To assign values to a child business object, right-click the child object and select

Add Instance from the Context menu. For more information, see
[creating test data for a child business object” on page 87|

* To assign default values to the source attributes attribute, select the source
business object and select Reset from the Context menu.
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If you are testing relationships, make sure to set the ObjectEventIds of the
source parent object and all child objects that participate in the relationships.

To save the values you have entered for future test runs, create a business object
(.bo) file by selecting the source business object and performing either of the
following actions:

— Click the Save To button in the Source Testing Data pane.

— Select Save To from the Context menu. When prompted, enter a file name
where these values will be stored.

Result: The next time you test this map, you can click the Load From button
and the attributes will be filled in automatically from the business object file.

é Source Testing Data Laliing Context: |ACCESS_REQUEST _'J
Generic businesz object. | <Mone: ;l
Mame Type YWalue
=l ObjaLevellInput alevelllnput

Ilerbi Create

String1 String

Boolean1 Boolean

Float1 Float

Integer1 Integer

Date1 Date

alevel2lnput alevelZinput

OhjectEventld String

Beset I Load From... Save To...

Figure 41. Source Testing Data pane of the Test tab

Steps for creating test data for a child business object: If the source business
object has child business objects and you want to specify test data for the child
attributes, you must first create an instance for each child object you need. To do
this, perform the following steps:

1.

Right-click the child business object name and select Add Instance from the
Context menu. When you expand the object, you see the instance that Map
Designer Express has created.

Guideline: The first instance you add has an index number of zero. You can
have as many instances as you want (as long as the child attribute has
multiple-cardinality).

Click the plus symbol (+) beside the instance index number to expand the child
business object.

Result: When you expand the object, you see the child attributes for this
instance.

To create data for the child business object instance, follow these guidelines:

* To set the verb for the child business object, select it from the verb combo
box in the verb row.
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* To specify a value for a child attribute, select it and enter the value in the
Value column.

* If the name of the attribute is followed by (N), the attribute contains a
multiple-cardinality child business object and you can add more instances.

To add a child business object to the end of the array, right-click the last
index and select Add Instance from the Context menu.

* Modify the values of as many instances as you want. Add and remove
instances as follows:

— To add an instance, right-click the child instance name and select Add
Instance.

— To delete an instance, right-click the instance name of the child instance
you want to delete and select Remove Instance.

— To delete all instances, right-click the child instance name and select
Remove All Instances. This option is only enabled if the child business
object has multiple-cardinality.

Testing the map in subsequent runs
For subsequent test runs, Map Designer Express reuses the previously specified
test data. You can perform any of the following actions on this data:

e Leave all test data as it is.

* Modify values for any individual attributes by changing the appropriate entries
of the Values column.

Tip: If you modify the data, remember to resave any business object (.bo) file.
* Load a set of values from a business object (.bo) file.

To load attribute values from a business object file, select the source business
object and perform either of the following actions:

— Click the Load From button in the Source Testing Data pane.
— Select Load From from the Context menu.
When prompted, enter the name of the business object file to be loaded.

* Return all source destination values to their defined default values by selecting
the source business object and selecting the Reset option from the Context menu.

Setting breakpoints

When you set a breakpoint, map execution pauses just before the transformation of
the destination attribute on which the breakpoint is set. The use of breakpoints lets
you step through map execution and check the sequence and the results of
individual operations. You can set as many breakpoints as you like.

Guideline: Breakpoints are not part of the map’s definition. You set breakpoints on
the map after the map is opened in Map Designer Express, and when the map is
debugged (either with Debug > Run Test or Debug > Advanced > Attach).
Breakpoints have no effect on the map when the map is not debugged from Map
Designer Express.

Note: You can only set a breakpoint on a destination attribute that has a
transformation defined for it.

Steps for setting breakpoints
Perform the following steps to set a breakpoint.

1. Use one of the following methods:
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Figure 42. Breakpoint set

* Right-click a destination attribute in the Destination Testing Data pane and
select Set Breakpoint from the Context menu. If the destination source
attribute is not yet expanded, you can expand it with either of the following
commands:

— Click the plus symbol (+) next to the destination business object.
— Select the destination business object and select Expand from the Context
menu.

Note: The Context menu of the destination business object also provides a
Collapse option.

* Select Toggle Breakpoint from the Debug menu.
* Use the keyboard shortcut of F9.
* In the Designer toolbar, click the Toggle Breakpoint button.

Note: The Toggle Breakpoint option toggles a breakpoint definition on and off.
If the breakpoint is not currently set, Toggle Breakpoint sets it. If the
breakpoint is currently set, Toggle Breakpoint removes it.

Result: Map Designer Express displays a dark circle next to the destination
attribute on which the breakpoint is set, as shown in .
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Once you set the breakpoint, the execution of the map instance pauses at this
breakpoint and you can see the current status of the map. Unless you specify at
least one breakpoint, the map executes and finishes with the message:

Test run finished

Rule: You must always provide values for the source data associated with the
destination attributes where you set the breakpoints. Otherwise, the
transformation rule will run normally and the breakpoints will execute
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normally, but the destination value will usually be empty, depending on what
transformation rule is defined. For more information, see [“Creating test data”|

To view all breakpoints for the map, select Breakpoints from the Debug menu.

Result: Map Designer Express displays the Breakpoints dialog (see Figure 43).

Breakpoints

Find: I :_' LI
Breakpoints I

#® Objdddiess AddressLine

Delete I Clear Al l
Cancel l

Figure 43. Breakpoints dialog of the test tab

2. From the Breakpoints dialog, you can perform any of the following actions:

* Locate a destination attribute on which a breakpoint is set—double-click the
breakpoint name.

Tip: To locate a particular breakpoint, enter its name in the Find field. The
up and down arrows scroll through the business object list. In the
Destination Testing Data pane, Map Designer Express highlights the
destination attribute.

* Remove a breakpoint—in the Breakpoints area, select the breakpoint to
remove and click the Delete button.

You can also remove a breakpoint by performing any of the following
actions:

— Right-click a destination attribute in the Destination Testing Data pane and
select Clear Breakpoint from the Context menu.

— Use any of the commands for the Toggle Breakpoint option on an existing
breakpoint. For more information, seel”Setting breakpoints” on page 88l

* Clear all breakpoints that display in the Breakpoints area—click the Clear All
button.

You can also clear all breakpoints by performing any of the following actions:
— From the Debug menu, select Clear All Breakpoints.
— In the Designer toolbar, click the Clear All Breakpoints button.

Running the test map

Once you have entered the source test data and set any desired breakpoints, you
are ready to test the map. To run a map test involves:

1. |“Steps for starting the test run” on page 91|

2. [“Steps for processing breakpoints” on page 91| (if any breakpoints have been
set)
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Steps for starting the test run
To start the test run, perform the following steps:

1.

Perform one of the following actions:
¢ From the Debug menu, select Run Test.
* In the Designer toolbar, click the Run Test button.

Result: The Connect to IBM WebSphere Business Integration Server Express
dialog box will display and allow you to connect to the server for testing.

In the dialog, enter the server name, user name, and password.

Specify whether you want to deploy the map and dependent business objects
for the test run.

Guideline: Deploying a minimum set of business objects to the server for
testing will minimize debugging initialization time.

Result: Execution of the map starts. Map Designer Express displays the following
message in the output window:

Starting test run...

Steps for processing breakpoints

Map execution pauses when it reaches a destination attribute where you have set a
breakpoint. When the breakpoint is reached, Map Designer Express takes the
following actions:

1.

Highlights the destination attribute on which the breakpoint was set and
displays a dark circle with a yellow arrow next to it.

Displays the following message in the output window:
Test Run stopped at attribute AttrName (next transformation > "Rule").

Tip: With map execution paused, you can examine the values of the destination
attributes that have been processed so far by looking in the Value column of
the Destination Testing Data pane.

Processes the breakpoint and continues map execution, when you do either of
the following actions:

* Proceed to the next breakpoint or the end of the map, whichever comes first.
To continue map execution, perform one of the following actions:
— From the Debug menu, select Continue.
— Use the keyboard shortcut of F8.
— In the Designer toolbar, click the Continue button.

* Execute this destination attribute, then stop before executing the next
attribute.

To continue map execution for only one more step, perform one of the
following actions:

— From the Debug menu, select Step Over.

Tip: Select this option to watch the code execute attribute by attribute.
— Use the keyboard shortcut of F10.
— In the Designer toolbar, click the Step Over button.

Result: When the execution of the test run is finished without any run-time
errors, Map Designer Express displays the following message in the output
window:

Test run finished.
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Viewing test run results

Test run results display in the destination business object, which is in the
Destination Testing Data pane. Values resulting from the map transformations are
visible in the Values column of this table. You can view test run results by either:

+ |[“Watching the process”|

» |“Viewing results after execution”|

Watching the process

During a test run that has test data and breakpoints, you can watch as the
destination business object fills with values. Values appear in the Values column in
the Destination Testing Data pane as they are processed. When map execution is
paused on a breakpoint, all destination attributes before that attribute in the
execution order have values displayed.

To view the transformations as they occur:

* Set a breakpoint on the second destination attribute and step through map
execution with the Step Over option. The map will be read-only.

Viewing results after execution
To view test run results when the map has already executed, examine the
destination business object in the Destination Testing Data pane.

To save the test results:

* Highlight the destination business object and select Save To from the Context
menu.

Result: Map Designer Express saves the values of the destination attributes in a
business object (.bo) file.

Steps for changing the map and re-executing

As you test the map, you might discover the need to change the map. To edit the
map and then continue the test, perform the following steps:

Switch to either the Table or Diagram tab to view the map transformations.
Make the edits to fix the errors.

Recompile the map.

Continue the testing process by switching back to the Test tab.

ok

Begin a new test run.

Important:

1. Make sure you complete the test run, either with success or failure, before you
attempt to recompile the map.

2. After you modify the map, be sure to deploy the map to the server for the
change to be reflected in the server.

Doing advanced debugging
Besides debugging maps that are stored in local projects, you can also directly
debug a map that resides in the server. Perform the following steps to do this:
1. Select Debug > Advanced > Attach.
Result: The Connect to WebSphere Business Integration Server Express dialog
displays.
2. Enter the Server name, User name, and Password; and click Connect.

Result: Map Designer Express displays a list of new maps on that server.
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3. Select the map you want to attach to.
Result: The map opens in Map Designer Express in Read-only mode.

4. Set breakpoints in the map to have the server pause map execution at a certain
transformation rule.

Result: When a breakpoint is hit on the server, you can step over or continue
map execution, as usual. The resulting business object values will display in the
Destination Test Data pane.

5. Stop the debugging session at any time using Debug > Advanced > Detach.
Result: Map Designer Express will close the map.

Testing maps that contain relationships

When you test a map that contains a relationship transformation, you need to
provide the following information in addition to the test data:

* The calling context

Part of a map’s execution context includes a calling context. Many of the
relationship methods in the Mapping API use this calling context to determine
what action to take during the mapping. For this reason, if you are testing a
relationship attribute in a map, you usually must specify the appropriate calling
context for the transformation.

* The generic business object definition

When you test the SERVICE_CALL_RESPONSE calling context for an identity
relationship, you need to specify the maps generic business object so that the
test run can locate the generic key value in the relationship.

You specify this information in the Source Testing Data pane of the Test tab.

Tip: If the width of the Source Testing Data pane is not enough to let you see the
complete menu options of the Calling Context combo box, you can expand the size
of this area by putting the cursor over the right-hand boundary until you see the
following symbol <-1 |-> and drag the boundary to the right.

If you are testing Relationships, select the appropriate generic object from the list
of business objects, select Calling Context, and set the ObjectEventIds for the
parent and child objects that match the ones you already set in the Test Data
screen. The calling context you need to provide and whether you need to specify a
generic business object depend on the type of relationship you are testing. This
section provides information on the following:

* |"Testing an identity relationship”]

* |“Testing a lookup relationship” on page 96|

Testing an identity relationship

To test point-to-point mapping (from Application 1 to Application 2) for an identity
relationship you use three maps:

* An inbound map from Application 1’s application-specific business object to a
generic business object—Appl_to_Generic

¢ An outbound map from the generic business object to Application 2’s
application-specific business object—Generic_to_App2

* An inbound map from Application 2’s application-specific business object to the
generic business object—App2_to_Generic
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Example: shows an example of a point-to-point communication of
customer data between a Clarify application and an SAP application. If each
application uses a unique key value to identify customers, these three business
objects can be related with an identity relationship. Therefore, each map includes a
cross-reference transformation rule. As each of these maps executes, these
relationship methods access the calling context to determine the actions to take.

Inbound Map Outbound Map
Clarify_Site Customer
to to
Customer SAP_Customer

EVENT_DELIVERY

or
ACCESS. REQUEST SERVICE_CALL_REQUEST
Clarify_Site Customer SAP_Customer
Application-Specific Generic Application-Specific
Business Object Business Business Object

Object SERVICE_CALL_RESPONS

SAP_Customer
to
Generic

Inbound Map

Figure 44. Maps involved in point-to-point testing of an identity relationship

To test the Create verb, you need to verify that a new application-specific key
value in Application 1 (Clarify application in causes a new generic key
value to be added for the generic business object and a new application-specific
key value in Application 2 (SAP application in . Therefore, testing
involves three steps:

1. Testing the inbound map, Appl_to_Generic, to send in a new key value from

Application 1 and ensuring that a new key value is generated for the generic
business object. Follow the steps in [Table 21

Table 21. Testing the App1-to-Generic map for an identity relationship

To set up test run To verify test run

1. Set the calling context to EVENT DELIVERY 4 Read the resulting generic key value in the
or ACCESS_REQUEST by selecting the destination business object, which has been
appropriate calling context from the added to the relationship table for the
Calling Context combo box. Appl/Generic identity relationship.

5. Save the destination business object data in
a .bo file (e.g. Appl_to_Generic.bo) by
selecting the destination business object and
selecting Save To from the Context menu.

2. Enter the application-specific value in the
key of the source business object. This
value is unique for the key attribute(s) in
Application 1.

3. Run the test.
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2. Testing the outbound map, Generic_to_App2, to ensure that the new generic

key value is sent to Application 2.

To test an identify relationship in the outbound Generic_to_App2 map, you
must provide the generic key value in your source Test Data. You might want
to do either of the following, but they are both wrong:

* Put an arbitrary number into the generic business object’s primary key
attribute, then run the map.

* Create the record directly in the relationship table.

In both cases, Map Designer Express generates the
RelationshipRuntimeException or NulTPointerException. The error occurs
because the generic key value has to be in the system for the
SERVICE_CALL_REQUEST to work properly, and the relationship table is not the
only place the generic key value is stored.

The correct solution is to first run an inbound EVENT DELIVERY (or
ACCESS_REQUEST) map that uses the same identity relationship (as described in
step . Follow the steps in [Table 22| to test the outbound Generic_to_App2 map.

Table 22. Testing the generic-to-app2 map for an identity relationship

To set up test run To verify test run

1.

Set the calling context to 4. Read the resulting application-specific key
SERVICE_CALL_REQUEST by selecting this value in the destination business object,

calling context from the Calling Context which is empty because Application 2 has
combo box. not generated its key value yet.

5. Save the destination business object data in

2. Load the generic business object with the . .
. a .bo file (e.g. Generic_to_App2.bo) by
test results from the previous step (e.g. lecti he destination busi bi d
Appl_to_Generic.bo) selecting the destination business object an
PpL_to_ T selecting Save To from the Context menu.
3. Run the test.
3. Testing the inbound map, app2_to_generic, to verify that the new key value

from Application 2 is associated with the new generic key value.
When the calling context is SERVICE_CALL_RESPONSE, an identity relationship
must cross-reference the ID in the application-specific business object to the ID

in the generic business object. Therefore, for this test, you must specify the
generic business object definition. Follow the steps in [Table 23
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Table 23. Testing the App2_to_Generic map for an identity relationship

To set up test run To verify test run

1. Set the calling context to 7. Read the resulting generic key value in the
SERVICE_CALL_RESPONSE by selecting this destination business object, which should be
. 0 the same value you entered in the generic
source business object.
8. You can use Relationship Manager to
verify that the correct application-specific key
values are associated with this generic key
value for this identity relationship.

calling context from the Calling Context
combo box.

2. Set the generic business object by
selecting the name of the appropriate
generic business object from the Generic
Business Object combo box. Map
Designer Express adds the specified
generic business object to the Source
Testing Data pane.

3. Load the application-specific business
object with the test results from the
previous step (e.g. Generic_to_App2.bo).

4. In the application-specific business object,
enter an application-specific value in the
key of the business object.

5. In the generic business object, enter the
generic key value associated with the
Application 1 key. This value should be
the same key value generated for the
generic business object in the
EVENT_DELIVERY/ACCESS_REQUEST test (step

.

6. Run the test.

Testing for other verbs involves similar steps. For more detailed information on the
actions of relationship methods for an identity relationship, see
[“Implementing relationships,” on page 251/

Testing a lookup relationship

To test point-to-point mapping (from Application 1 to Application 2) for a lookup
relationship you use two maps:

* From Application 1’s application-specific business object to a generic business
object—Appl_to_Generic

* From the generic business object to Application 2’s application-specific business
object—Generic_to_App2

Example: shows an example of a point-to-point communication of
customer data between a Clarify application and an SAP application. If each
application uses a special static code to identify geographic states, these three
business objects can be related with a lookup relationship. Therefore, each map
includes Custom transformations that do static lookups. For more information, see
the "Static Lookup” activity example in [“Example 3: Using Static Lookup for]
fconversion” on page 152] As each of these maps executes, these relationship
methods access the calling context to determine the actions to take.
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Inbound Map Outbound Map

Clarify_Site Customer
to to
Customer SAP_Customer

EVENT_DELIVERY
or

ACCESS_REQUEST SERVICE_CALL_REQUEST

Clarify_Site Customer SAP_Customer

Generic
Business Object

Application-Specific
Business Object

Application-Specific
Business Object

Figure 45. Maps involved in point-to-point testing of a lookup relationship

To test the Create verb, you need to verify that an existing application-specific
lookup value in Application 1 (Clarify application in [Figure 45) causes the

associated generic lookup value to be added to the generic business object and the
associated application-specific lookup value in Application 2 (SAP application in
to be added to its business object. Therefore, testing involves two steps:

1. Testing the inbound map, Appl_to_Generic, to send in an existing lookup value

from Applicationl and ensuring that the associated generic lookup value is
obtained for the generic business object. Follow the steps in [Table 24

Table 24. Testing the App1-to-Generic map for a lookup relationship

To set up test run To verify test run

4. Read the resulting generic lookup value in
the destination business object, which has
been obtained to the relationship table for
the Appl/Generic lookup relationship.

5. Save the business object data in a .bo file
(e.g. Appl_to_Generic.bo) by highlighting the
destination business object and selecting Save
To from the Context menu.

1. Set the calling context to EVENT_DELIVERY
or ACCESS_REQUEST by selecting the
appropriate calling context from the
Calling Context combo box.

2. Enter the application-specific value in the
lookup field of the source business object.
This value is an existing lookup value
whose data is already loaded in the
Appl/Generic relationship table.

3. Run the test.

2. Testing the outbound map, Generic_to_App2, to send in the generic lookup
value and ensuring that the associated lookup value is obtained for Application
2. Follow the steps in [Table 25

Table 25. Testing the Generic-to-App2 Map for a lookup relationship

To set up test run To verify test run

1. Set the calling context to
SERVICE_CALL_REQUEST by selecting this
calling context from the Calling Context
combo box.

2. Load the generic business object with the
test results from the previous step (e.g.
Appl_to_Generic.bo).

3. Run the test.

4. Read the resulting application-specific key
value in the destination business object,
which contains the Application 2 lookup
value.

5. Save the business object data in a .bo file
(e.g. Generic_to_App2.bo) by highlighting the
destination business object and selecting Save
To from the Context menu.
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Note: A lookup relationship can be tested for the SERVICE_CALL_RESPONSE calling
context. However, this case usually only is required if the map is doing
something else that requires the lookup data. The relationship methods for a
lookup relationship in the Mapping API never write data to a relationship
table.

Debugging maps

This section provides the following information about debugging a map:

* [“Resolving run-time errors”

* [“Debugging tips’]

For information on how to test relationships, see|“Testing maps that containl
frelationships” on page 93|

Resolving run-time errors

Even if your map compiled successfully, you can get a run-time error during the
map execution in the Debugger.

Example 1: You have an outbound map with the generic business object on one
side and an application specific business object on the other side. Let us assume
that this map has an identity relationship in it.

1. Go to the Test tab and select the calling context SERVICE_CALL_REQUEST.
2. Select the verb "Update.”
3. Run the test.

Result: An error message like the one below displays:

Exception at step 17,
attribute <attribute name>,
java.lang.nullpointerexception

This exception is happening because the map is trying to update an entry in the
repository that is not created in the first place. Ideally, you should ensure that the
sequence of steps is correct. You should look at the database for relationship
entries pertaining to the map in question. You should then draw the conclusions
based on whether it is ready for SERVICE_CALL_REQUEST or not.

Example 2: You have the following line of the mapping code for
Customer.CustomerId:

_cw_CpBTBSourceValue = ObjSAP_CustomerMaster.get("CustomerIdd");

Clearly, it contains a typo (an extra letter 4 in the name of the attribute).
Unfortunately, the compiler does not catch this error because the error is in a string
constant. There is no way for the compiler to verify what a “correct” constant
value should be. However, when you run the map, the following ICS Express error
dialog displays:

ICS Error: Exception at step 3, attribute CustomerId, Exception msg

number - 11030, Errorll1030 Attribute CustomerIdd doesn't exist in business
object SAP_CustomerMaster.

When you get this run-time error, leave the Test tab and fix the map.

Debugging tips

This section provides the following tips for making the debugging of a map easier:

* [“Using logging messages” on page 99|
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* |"Writing safe mapping code’]

Using logging messages

Use the TogInfo() method for tracking the map execution. It takes a String as an
argument, which is sent on the InterChange Server Express log. You need to type it
in Activity Editor for the attribute whose execution needs to be tracked. To make
sure that the submap is executed, create a custom transformation rule and use the
"Log Information” function block to customize the activity or write the code
directly.

Example: The code can be as simple as the following:
TogInfo("in submap");

Put it on the first line of code of the destination object’s first attribute in the
submap.

Example: If you need to track the value of the specific attribute SAP.CustomerName,
use:

TogInfo(ObjSAP_CustomerMaster.getString("CustomerName"));

You might not always want to see this message. If this is the case, change the
DataValidationlLevel property of the map.

To set the DataValidationLevel, select the Map Properties option from the Edit
menu of Map Designer Express and change 0 to 1 or a greater number. The
settings are as follows:

0 No data validation
1 IBM data validation level
2 or greater User-defined data validation

To ensure that the TogInfo message is not displayed, set DataValidationLevel to 1.
In your code, before calling the TogInfo() method, check for a data validation
level. Here is the code:

if (dataValidationLevel > 1)
TogInfo(ObjSAP_CustomerMaster.getString("CustomerName"));

This ensures that TogInfo is executed only if the data validation level is set to a
number greater than 1. If you decide to display the message, change the data
validation level setting in the Map Properties to 2.

Writing safe mapping code

If you customize your transformation rule in Activity Editor or write your own
mapping code, you are not guaranteed that it will work properly during run time.
To make sure that the map continues executing when an error occurs and you get
a notification of an error, use the "Catch Error” function block in Activity Editor or
follow Java’s way of handling exceptions.

Example: Put your code inside the try block, for example:

try

{
BusObj temp = new BusObj("SAP_Order");
// rest of your code
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Then use a catch block to catch whatever exceptions might occur when the code
runs:

catch (Exception e)

{
logInfo(e.toString());
}

The TogInfo() method can be used to send system-generated error messages to the
InterChange Server Express log.
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Chapter 5. Customizing a map

This chapter provides describes two ways to generate Java code: using Activity
Editor to define transformation rules graphically and writing Java code directly.

This chapter covers the following topics:

+ [“Overview of Activity Editor” on page 101|

» |"Working with activity definitions” on page 109|

* [“Importing Java packages and other custom code” on page 154]

* ["Exporting Web Services into Activity Editor” on page 15_9|

* [“Using variables” on page 163

« ["More attribute transformation methods” on page 168|

* [“Reusing map instances” on page 180

+ [“Handling exceptions” on page 180}

+ |“Creating custom data validation levels” on page 182

* [“Understanding map execution contexts” on page 184|

+ [“Mapping child business objects” on page 188

+ [“More on using submaps” on page 192

+ |“Executing database queries” on page 198|

Overview of Activity Editor

Using Activity Editor, you can specify the flow of activities for a specific
transformation rule graphically, without knowing programming or Java code. For
each transformation rule in Map Designer Express, you can display one activity
and its subactivities. You can view the associated attribute’s transformation code
graphically, modify it, and have the tool generate the corresponding Java code.

You launch Activity Editor directly from Map Designer Express (see
[Activity Editor” on page 101). At startup, Activity Editor communicates with
System Manager to discover the set of activities allowed. After you have finished
designing the activity for a particular transformation rule, you save the changes in
Activity Editor, and they are communicated to Map Designer Express.

This section covers the following topics to introduce you to Activity Editor:

* |“Starting Activity Editor” on page 101

« [“Layout of Activity Editor” on page 102

+ [“Using Activity Editor functionality” on page 106|

Starting Activity Editor

You launch Activity Editor through the transformation rule column of the Table or
Diagram tabs of Map Designer Express. Perform the following steps to do this:

1. Select the attribute you want to work with.
2. Do one of the following:

* Double-click the attribute’s corresponding cell of the transformation rule
column.

* Click the bitmap icon in the corresponding cell of the transformation rule
column.
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Result: Map Designer Express’ response to these actions depends on the following:
* Whether the code is still in auto-upgrade mode

Transformation code is in auto-upgrade mode if Map Designer Express has
generated it, and you have not customized it in any way. When you customize
auto-upgrade code, Activity Editor displays a confirmation prompt notifying you
that saving this code takes it out of auto-update mode. For code not in
auto-update mode, Map Designer Express displays the transformation rule in
blue italic font in the transformation rule column.

If the transformation code is not in auto-update mode (that is, you have
modified the autogenerated code), Map Designer Express opens Activity Editor
in Java view when you double-click the attribute’s transformation rule cell or
click the mapping rule icon.

* The type of transformation defined

Transformation code that is in auto-update mode is generated from one of the
standard transformations that Map Designer Express provides on the combo box
of the transformation rule column. When you double-click the attribute’s
transformation rule cell or click the mapping rule icon, the type of
transformation determines what Map Designer Express displays:

— For the Custom transformation, Map Designer Express opens Activity Editor
on the transformation code.

— For all other standard transformations (Set Value, Join, Split, Submap, and
Cross-Reference), Map Designer Express displays the transformation’s dialog.
Click the View Code push-button on this dialog to open Activity Editor in a
new window with the attribute name in the title bar. You can open multiple
instances of Activity Editor at the same time.

Layout of Activity Editor

Activity Editor has two main views: Graphical view and Java view. Depending on
the nature of the activity, at any given time, only one view is visible. Thus, if Map
Designer Express invokes Activity Editor to display a graphical activity, Activity
Editor will startup with the Graphical view. If you choose to translate this
graphical activity into Java code, the Java view will display in place of the
Graphical view.

Restriction: Once the activity has changed to Java code, it will not be converted
back to the graphical nature.

Both views have common Window elements in their Design and Quick view

modes, as described in|Table 26|

Table 26. Common Window elements

Window element Description

Title Bar Contains the name of the application
(Activity Editor), application icon, and the
main activity’s name.

Menu Contains the primary menus (Design mode
only).

Toolbar Contains dockable toolbars with shortcuts to
various functions and tools (Design mode
only).

Document Display Area Displays the representation of the activity
definition. It is organized with a workbook
look.
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Table 26. Common Window elements (continued)

Window element Description
Status Bar Displays status information and some handy
shortcuts.

Working in Graphical view

If Map Designer Express opens Activity Editor with an activity definition that has
a graphical nature, Activity Editor will display the activity definition in Graphical
view in one of two available display modes: Design mode or Quick view mode.

* Design mode: In Design mode, Activity Editor resembles a regular
application--in addition to the main editing window, it has a menu bar, toolbars,
and the Library, Content, and Properties windows that support your editing
needs during the design stage of the activity definition.

shows the Graphical view in Design mode.
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Figure 46. Graphical view in Design mode

The Graphical view has four main windows: the Activity Workbook window, the
Library window, the Content window, and the Properties window.

— Activity workbook window--This window is the main activity editing area,
and is usually referred to as the editing canvas. It is also known as the
activity canvas or graphical canvas. This area is where you drag and drop the
function blocks.

— Library window--This window contains a tree view of the available function
blocks, and optionally, the named groups. The function blocks are arranged in
folders according to their purpose (see [“Identifying supported function|
[blocks” on page 112), and you can expand them to show the actual function
blocks. You can also view the function blocks as icons in the Content window.

In addition, the Library window contains the following folders:
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- System--This folder contains system elements that can be added to the

editing canvas. System elements include comments, descriptions, labels,
to-do tags, and constants.

- Library--This folder enables you to customize the Library window. It

contains any user-defined function blocks that have been specified in the
Activity Settings view in System Manager.

- My Collection--This folder enables you to create a collection of the

components you use most often. You can place regular function blocks in
this folder, or you can create your own reusable component group.

- Variables--this folder contains global variables accessible to the current

activity. It typically contains the port’s business object variables, all of the
other business objects and variables defined in the scenario, and the global
variable cwExecCtx.

Content window--This window contains a large icon list of the available
function blocks under the currently selected folder in the Library window.
You can select a function block to view its description and properties in the
Properties window, or drag-and-drop a function block onto the editing canvas
to create part of the activity flow.

Properties window--This window displays the properties of the currently
selected function block in a gridlike layout. Some properties are editable;
others are read-only.

* Quick view mode: In Quick view mode, Activity Editor only displays the main
editing canvas; all other supporting windows (Library, Content, and Properties);
the menu bar; and the toolbars are hidden.

shows the Graphical view in Quick view mode.
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Figure 47. Graphical view in Quick view mode

Initially, when an activity definition that has a graphical nature opens, Activity
Editor displays the top-level view of the definition in a tabbed window. Inside the
tab window is the editing canvas. For information on working with activity
definitions on the editing canvas, see [“Working with activity definitions” on page]
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Working in Java view

If Map Designer Express opens Activity Editor with an activity definition that
contains only custom Java code, Activity Editor displays the activity definition in
Java view. Similar to Graphical view, Activity Editor is available in Java view in
two display modes: Design mode and Quick view mode.
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* Design mode: In Design mode, the Java view of Activity Editor contains the
main Java WordPad for viewing and editing custom Java code to provide the
definition for the activity. The WordPad is contained in a tabbed window area.
In addition to the regular editing options in a WordPad (Cut, Copy, Paste,
Delete, Select All, Undo, Redo), the Java WordPad provides syntax highlighting
for the Java Programming language.

By default, comments are green, string literals are pink, and keywords are blue.

Tip: You can customize the syntax highlighting schemes in the Preferences
dialog.
shows the Java view in Design mode.
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Figure 48. Java view in Design mode

* Quick view mode: In Quick view mode, the Java view only displays the
WordPad. shows the Java view in Quick view mode.
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Figure 49. Java view in Quick view mode

Tip: To change from Quick view mode to Design mode, click the >> button on the
status bar. If you do not see the >> button, resize the Quick view window
horizontally until the button appears.

Note: Initially, the Java view will be in read-only mode. To enter customized Java
code, click the Edit Code toolbar button, or select Edit Code from the Tools
menu.

Using Activity Editor functionality
You can access Activity Editor’s functionality using any of the following:
¢ Pull-down menus
* Context menu
* Toolbar buttons
* Keyboard shortcuts

Activity Editor pull-down menus and keyboard shortcuts
Activity Editor provides the following pull-down menus:

* File menu
* Edit menu
* View menu
* Tools menu
* Help menu

The following sections describe the options of each of these menus and their
associated keyboard shortcuts.

Functions of the File menu: The File pull-down menu of Activity Editor provides
the following options:

* Save [Ctrl+S]--Saves the activity to Map Designer Express.

* Print Setup [Ctrl+Shift+P]--Opens the Print Setup dialog box for specifying print
options.

* Print Preview--Switches Activity Editor to print preview mode.
* Print [Ctrl+P]--Opens the Print dialog box for printing the current activity.
* Close --Closes Activity Editor.

Functions of the Edit menu: The Edit pull-down menu of Activity Editor provides
the following options:

* Undo [Ctrl+A]--Undoes the last action.

* Redo [Ctrl+Y]--Redoes the last undone action .

* Cut [Ctrl+X]--Deletes the selected item and copies it to the clipboard.
* Copy [Ctrl+C]--Copies the selected item to the clipboard.

* Paste [Ctrl+P]--Pastes the object in the clipboard to the cursor position if they are
compatible.

e Delete [Del]--Deletes the selected item.

» Select All [Ctrl+A]--Selects all items.

 Find [Crtl+F]--Finds the specific text in the editing area.

* Replace [Ctrl+H]--Replaces specific text with different text in the editing area.
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* Goto Line [Ctrl+G]--Goes to a specific line.

Functions of the View menu: The View pull-down menu of Activity Editor
provides the following options:

* Design mode--Toggles between Design mode and Quick view mode. (Only one
mode is enabled at a single time.)

* Quick view mode--Toggles between Quick view mode and Design mode. (Only
one mode is enabled at a single time.)

* Go To--Provides the following options:

— Back [Alt+Left Arrow]--Moves backward in the navigation history in the
Graphical view.

— Forward [Alt+Right Arrow]--Moves forward in the navigation history in the
Graphical view.

— Up One Level--Displays the diagram from one higher level.

— Home [Alt+Home]--Goes to the top-level diagram in Graphical view.
* Zoom In [Ctrl++]--Magnifies content in Activity Editor.
e Zoom Out [Ctrl+-]--Minimizes content in Activity Editor.

* Zoom To [Crtl+M]--Opens the Zoom dialog box for specifying a particular zoom
level.

* Library window--Toggles the Library window on and off.
* Content window--Toggles the Content window on and off.
* Properties window--Toggles the Properties window on and off.

¢ Toolbars--Opens a submenu for displaying toolbars (Standard, Graphics, and
Java) that toggle on and off.

* Status Bar--Toggles the status bar on and off.

* Preferences... {Ctrl+U]--Opens the Preferences dialog box for specifying the
default behavior of Activity Editor.

Functions of the Tools menu: The Tools pull-down menu of Activity Editor
provides the following option:

* Translate [Ctrl+T]--Translates the current activity to Java code and opens the
Java view.

+ Edit Code--Allows you to edit code in Java.

* Check for Unmatched Delimiters--Checks for unmatched delimiters in the Java
code.

* Expression Builder--Opens the Expression Builder utility.

Functions of the Help menu: The Help pull-down menu of Activity Editor
provides the following options:

* Help Topics [F1]--Opens the context-sensitive Help topics
* Documentation--Opens the InterChange Server Express documentation.

Context menu

Activity also provides a context menu for performing many tasks on the editing
canvas. You access the Context menu by right-clicking the editing canvas. The
Context menu provides the following options:

* New Constant--Creates a new Constant container on the editing canvas.
¢ Add Label--Creates a new label component on the editing canvas.
* Add Description--Creates a new description component on the editing canvas.

¢ Add Comment--Creates a new comment component on the editing canvas.
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* Add To do--Creates a new reminder component in the activity.

* Add To My Collection--Creates a new group component for reuse in the Library
window.

Activity Editor toolbars

Activity Editor provides three toolbars for common tasks you need to perform.
* Standard toolbar

* Graphics toolbar

* Java toolbar

The functions of the toolbar buttons are the same as their corresponding menu
items.

Tip: To identify the function of each toolbar button, roll over each button with
your mouse Cursor.

Standard toolbar: shows the Standard toolbar.

|@|2/«mas|? ]|

Figure 50. Activity Editor Standard toolbar

provides the function of each Standard toolbar button (left to right) and
the corresponding menu command.

Table 27. Functions of Standard toolbar buttons

Function Corresponding menu command
Save Activity File > Save

Print Activity File > Print

Cut Edit > Cut

Copy Edit > Copy

Paste Edit > Paste

Delete Edit > Delete

Help Help > Help Topics

Graphics toolbar: shows the Graphics toolbar.
a9 R|aa

Figure 51. Activity Editor Graphics toolbar

provides the function of each Graphics toolbar button (left to right) and
the corresponding menu command.

Table 28. Functions of Graphics toolbar buttons

Function Corresponding menu command
Back View > Go To > Back

Forward View > Go To > Forward

Up One Level View > Go To > Up One Level
Home View > Go To > Home

Zoom In View > Zoom In

Zoom Out View > Zoom Out
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shows the Java toolbar.
B|e s (B[

Figure 52. Activity Editor Java toolbar

provides the function of each Java toolbar button (left to right) and the

corresponding menu command.

Table 29. Functions of Java toolbar buttons

Function Corresponding menu command
Edit Code Tools > Edit Code

Undo Edit > Undo

Redo Edit > Redo

Find Text Edit > Find

Goto Line Edit > Goto Line

Expression Builder Tools > Expression Builder

Status bar elements: Activity Editor also provides a Status bar, as shown in
- igure 53

Zoom: 100% Ready 2:23 <« él

Figure 53. Activity Editor Status bar

describes the functionality of each Status bar element, left to right.

Table 30. Functions of Status bar elements

Element Function

Zoom: 100% Edit box for specifying a zooming percentage

Ready Status message

10.9 Navigation pane showing the current
position of the I-bar in the Java editor

>> (Shown in Quick view mode) Toggle between Design mode and quick view
mode

<< (Shown in Design mode)

Working with activity definitions

Activity Editor is used to define and modify activity definitions for transformation
rules. This is done on the editing canvas using the canvas components:

* Function blocks--An activity definition is built with function blocks, which
represent discrete parts of the activity definition, such as a constant, a variable
or a programming method. Many of the function blocks in Activity Editor
correspond to individual methods in the Mapping API. You place function
blocks on the editing canvas by dragging and dropping them from either the
Library or Content window. Once you drop a function block on the editing
canvas, you can move it around, by clicking it to select it and dragging it to the
desired location.

Function blocks can have inputs, outputs, or both. The inputs and outputs for
each function block are predefined and accept only the specified value type.
When the function block is dropped on the editing canvas, its input and output
ports are represented by arrows. These ports serve as connecting points for
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linking between the function block and other components. By default, the name
of each input and output is displayed next to its connection port (you can use
the View > Preferences option to hide the names).

For a description of supported function blocks in the Map Designer Express and
Relationship Designer Express contexts, seq“Identifying supported function|
[plocks” on page 112}

Note: In addition to the standard function blocks that Activity Editor provides,
you can import your own Java library for use as function blocks in
Activity Editor. Importing custom Jar libraries into activity settings will
enable any public methods in the Jar library to be used as function blocks
in Activity Editor. For more information, see|“Importing Java packages|
land other custom code” on page 154/

* Connection links--Function blocks are connected by connection links. The
connection links define the flow of activity between the various components in
the activity definition. They connect the output port of one function block to the
input port of another function block.

Note: Outgoing ports can connect to multiple connection links, but incoming
ports can only connect to one connection link.

Tip: When you drag-and-drop to connect function blocks together, Activity
Editor uses the option set in the Validation tab of the Preferences dialog to
determine if it needs to validate and check whether the "from” parameter type is
the same as the "to” parameter type.

— By default, this preference is set to "Warning,” meaning that when you create
a link between two parameters that are of different types, Activity Editor will
show a message warning you that this may lead to a compile error.

— Setting the option to "Ignore” tells Activity Editor not to do any validation.

— Setting the option to "Error” tells Activity Editor not to allow you to create
links between different types.

Example: To specify that the output of function block A should go to the input
of function block B, perform the following steps:

1. Click and hold down the left mouse button on the outgoing port of function
block A.

2. While continuing to hold down the left mouse button, move the cursor onto
the incoming port of function block B.

3. Release the left mouse button.

Result: The connection link is placed between function block A’s out-port and
function block B’s in-port. Graphically, the connection link will appear as a
right-angled line between components. If function block B’s in-port is already
connected with another connection link, the newer connection link will replace
the existing connection link.

e Label, Description, Comment, and To Do tags--The System folder (located in the
Library and Content windows) contains function blocks for adding comment,
description, label, and to-do tags to the activity definitions. These tags help
identify each activity or subactivity, or serve as a reminder of something that
needs to be done. You drag and drop these function blocks onto the editing
canvas as you would any other function block. However, there are no input and
output ports.

To edit a new tag, single click in the center of the tag. The cursor changes to an
I-beam, and you can enter your text. The tags automatically wrap lines of text
that are too long. If you want to start a new line, press enter.
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To resize a tag, left-click the lower right-hand corner of the tag and hold down
the left mouse button while dragging the tag to the desired size.

shows resizing a label tag and entering multiple lines of text.
Label

line 1
line 2

Figure 54. Resizing a label and entering multiple lines of text

Restriction: Each of these editing components has a minimize size, so the
components cannot be resized to be smaller than a certain size.

To move the tag around the canvas, click the edge of the component and
drag-and-drop it.

New Constant icon--Activity Editor has a New Constant function block that you
can drag and drop onto the editing canvas to define a constant value that you
set and use as input to other function blocks. The New Constant function block
is located in the System folder in the Library window and Content window.
Activity Editor displays a text edit box on top of the function block icon for you
to enter the value of the Constant. To revise this value, double-click the Constant
icon and enter the new value. Constants contain one outgoing port.

Note: The Constant is the only activity definition component that accepts only a
single line for the value. This is because the constant is translated to a
Java code String, and the system cannot translate a multi-line constant
value. If multi-line input is required, use the "\n" value to separate
between lines in the Constant.

Example: The value "linel\nline2” will tell the system to output the text
in two lines.

Steps for grouping components

Once you have defined an activity flow with a set of function blocks on the editing
canvas, you can select and save the whole or part of this activity flow as a named
group. Then later on, you can reuse this named group in another activity definition
just like a regular function block. The following procedure describes the steps to
take.

Before you begin: You need to enable "Show child functions in Library window”
in the Preference dialog to display the added group.

Perform the following steps:

1.

Select the function blocks you want to group together on the editing canvas. To
select multiple function blocks, hold down the Ctrl key and click each function
block

Right-click the canvas to open the Context menu. Then select Add to My
Collection.

Result: The Add to My Collection dialog box is displayed.

Chapter 5. Customizing a map 111



3. In the Add to My collection dialog type a name and a description (optional) for
the component group you are creating; select an icon to represent this group.

Then click OK.

Result: The added group will appear in Library window and the Content
window in the My Collection folder. You can drag and drop the icon onto the
editing canvas for any activity definition.

Identifying supported function blocks

The supported function blocks, in the Map Designer Express context, are organized
into the categories shown in the following table. These categories correspond to
folders in the Library window and the Content window.

Table 31. Organization of function blocks

Function block folder

Description

For more information

General / APIs/Business Object

Function blocks for working
with business objects.

[Table 32 on page 113]

BusObj class.

General / APIs/Business Function blocks for working [Table 33 on page 117
Object/ Array with Java arrays in the BusObj

class.
General/ APIs/Business Function blocks for working [Table 34 on page 117]
Object/Constants with Java constants in the

General / APIs/Business Object
Array

Function blocks for working
with business object arrays.

[Table 35 on page 117]

General / APIs/Database
Connection

Function blocks for creating
and maintaining a database
connection.

[Table 36 on page 119

General/ APIs/Identity

Function blocks for working

[Table 37 on page 120|

map.

Relationship with identity relationships.
General / APIs/Maps Function blocks for querying |[Table 38 on page 122|
and setting run-time values
needed for map execution.
General / APIs\Maps/ Function block constants. [Table 39 on page 122|
Constants
General /APIs/Maps/ Function blocks for creating [Table 40 on page 123|
Exception new exception objects in a

General/ APIs/Participant

Function blocks for setting and
retrieving values for
participants in identity
relationships.

[Table 41 on page 124

General/ APIs/Participant/
Array

Function blocks for creating
and working with participant
arrays.

able 42 on page 126
pag

General/ APIs/Participant/
Constants

Function block constants for
use with participants.

[Table 43 on page 126|

General/ APIs/Relationship

Function blocks for
manipulating run-time
instances of relationships.

[Table 44 on page 126|

General/Date

Function blocks for working
with dates.

[Table 45 on page 129|
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Table 31. Organization of function blocks (continued)

Function block folder

Description

For more information

General /Date/Formats

Function blocks for specifying
different date formats.

[Table 46 on page 131|

General/Logging and Tracing

Function blocks for handling
log and trace messages.

[Table 47 on page 131]

General/Logging and
Tracing/Log Error

Function blocks for formatting
error messages.

[Table 48 on page 131|

General/Logging and
Tracing/Log Information

Function blocks for formatting
informational messages.

[Table 49 on page 132

General/Logging and
Tracing/Log Warning

Function blocks for formatting
warning messages.

|Table 50 on page 132

General/Logging and

Function blocks for formatting

|Table 51 on page 133|

and catching exceptions, as
well as looping, moving
attributes, and setting
conditions.

Tracing/Trace trace messages.

General /Mapping Function blocks for executing |Table 52 on page 134|
maps within a specified
context.

General /Math Function blocks for basic |Table 53 on page 134
mathematical tasks.

General /Properties Function blocks for retrieving |Table 54 on page 134
configuration property values.

General /Relationship Function blocks for [Table 55 on page 134
maintaining and querying
identity relationships.

General/String Function blocks for [Table 56 on page 134
manipulating String objects.

General /Utilities Function blocks for throwing ||Table 57 on page 139

General \ Utilities / Vector

Function blocks for working
with Vector objects.

[Table 58 on page 139

The following tables describe the function blocks in each category, including the
acceptable values for their inputs and outputs.

Note: In WebSphere Business Integration Express Plus, Activity Editor is also used
with Process Designer Express. For information on using the function blocks,
including the collaboration function blocks, with Process Designer Express,
see the Collaboration Development Guide.

Table 32. General/APIs/Business Object

Name Description Inputs and outputs with acceptable values
Copy Copies all attribute values from the input Inputs:

business object. « copy to--BusObj

APL: BusObj.copy() * copy from--BusObj
Duplicate Creates a business object exactly like the Inputs:original--BusObj

original one.

API: BusObj.duplicate()

Outputs: duplicate--BusObj
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Table 32. General/APIs/Business Object (continued)

attribute with a specified name.

API: BusObj.exists()

Name Description Inputs and outputs with acceptable values
Equal Keys Compares business object 1’s and business Inputs:
object 2’s values, to determine whether they are |. pysiness object 1--BusObj
equal. * business object 2--BusObj
API: B j- 1K
usObj.equalKeys() Outputs: key values equal?-- boolean
Equals Compares business object 1’s and business Inputs:
object 2’s values, including child business « business object 1--BusObj
j i hether th L
objects, to determine whether they are equa + business object 2--BusObj
API: B j- 1
usObj.equals() Outputs: equal?-- boolean
Exists Checks for the existence of a business object Inputs:

* business object--BusObj
* attribute--String

Outputs: exists?-- boolean

Get Boolean

Retrieves the value of a single attribute, as a
boolean, from a business object.

API: BusObj.getBoolean()

Inputs:
* business object--BusObj
* attribute--String

Outputs: value-- boolean

Get Business Object

Retrieves the value of a single attribute, as a
BusObj, from a business object.

API: BusObj.getBusObj()

Inputs:
* business object--BusObj
* attribute--String

Outputs: value--BusObj

Get Business Object
Array

Retrieves the value of a single attribute, as a
BusObj Array, from a business object.

API: BusObj.getBusObjArray()

Inputs:
* business object--BusObj
* attribute--String

Outputs: value--BusObjArray

Get Business Object
Type

Retrieves the name of the business object
definition on which this business object was
based.

API: BusObj.getType()

Inputs: business object--BusObj

Outputs: type--String

integer, from a business object.

API: BusObj.getInt()

Get Double Retrieves the value of a single attribute, as a Inputs:
double, from a business object. * business object--BusObj
APIL: BusObj.getDouble() * attribute--String
Outputs: value--double
Get Float Retrieves the value of a single attribute, as a Inputs:
float, from a business object. + business object--BusObj
API: BusObj.getFloat() * attribute--String
Outputs: value--float
Get Int Retrieves the value of a single attribute, as an Inputs:

* business object--BusObj

e attribute--String

Outputs: value—-int
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Table 32. General/APIs/Business Object (continued)

Name

Description

Inputs and outputs with acceptable values

Get Long

Retrieves the value of a single attribute, as a
long, from a business object.

APT: BusObj.getLong()

Inputs:
* business object--BusObj
* attribute--String

Outputs: value--long

Get Long Text

Retrieves the value of a single attribute, as a
long text, from a business object.

API: BusObj.getLongText()

Inputs:
* business object--BusObj
* attribute--String

Outputs: value--String

Get Object Retrieves the value of a single attribute, as an | Inputs:
object, from a business object.The attribute can |. pysiness object--BusObj
be specified as either the attribute name or the . L
. . * attribute--String, int
attribute position.
APL BusObj.get() Outputs: value--Object
Get String Retrieves the value of a single attribute, as a Inputs:
string, from a business object. « business object--BusObj
API: BusObj.getString() * attribute--String
Outputs: value--String
Get Verb Retrieves this business object’s verb. Inputs: business object--BusObj
API: BusObj.getVerb() Outputs: verb--String
Is Blank Finds out whether the value of an attribute is Inputs:

set to a zero-length string.

API: BusObj.isBlank()

* business object--BusObj

e attribute--String

Outputs: blank?--boolean

Is Business Object

Tests whether the value is a business object
(BusObyj).

Inputs: value--Object

Outputs: result--boolean

Is Key Finds out whether a business object’s attribute | Inputs:
is defined as a key attribute. « business object--BusObj
APIL: BusObj.isKey() * attribute--String
Outputs: key?--boolean
Is Null Finds out whether the value of a business Inputs:

object’s attribute is null.

API: BusObj.isNull()

* business object--BusObj

* attribute--String

Outputs: null?--boolean

Is Required

Finds out whether a business object’s attribute
is defined as a required attribute.

API: BusObj.isRequired ()

Inputs:
* business object--BusObj

* attribute--String

Outputs: required?--boolean
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Table 32. General/APIs/Business Object (continued)

Name

Description

Inputs and outputs with acceptable values

Iterate Children

Iterates through the child business object array.

Inputs:

business object--BusObj
attribute--String
current index--int

current element--BusObj

Key to String

Retrieves the values of a business object’s
primary key attributes as a string.

API: BusObj.keysToString()

Inputs: business object--BusObj

Outputs: key string--String

New Business
Object

Creates a new business object instance (BusObj)
of the specified type.

API: Collaboration.BusODbj()

Inputs: type--String

Outputs: business object--BusObj

Set Content

Sets the contents of this business object to
another business object. The two business
objects will own the content together. Changes
made to one business object will be reflected in
the other business object.

API: BusObj.setContent()

Inputs:

business object--BusObj
content--BusObj

Set Default
Attribute Values

Sets all attributes to their default values.

API: BusObj.setDefaultAttrValues()

Inputs: business object--BusObj

Set Keys

Sets the values of the "to” business object’s key
attributes to the values of the key attributes in
"from” business object.

API: BusObj.setKeys()

Inputs:

from business object--BusObj

to business object--BusObj

Set Value with
Create

Sets the business object’s attribute to a specified
value of a particular data type, creating an
object for the value if one does not already
exist.

API: BusObj.setWithCreate()

Inputs:

business object--BusObj
attribute--String
value--BusObj, BusObjArray, Object

Set Verb

Sets the verb of a business object.

API: BusObj.setVerb()

Inputs:

business object--BusObj
verb--String

Set Verb with
Create

Sets the verb of a child business object, creating
the child business object if one does not already
exist.

API: BusObj.setVerbWithCreate()

Inputs:

business object--BusObj
attribute--String
verb--String

Set Value

Sets a business object’s attribute to a specified
value of a particular data type.

API: BusObj.set()

Inputs:

business object--BusObj
attribute--String

value--boolean, double, float, int, long,
Object, String, BusObj
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Table 32. General/APIs/Business Object (continued)

Name

Description

Inputs and outputs with acceptable values

Shallow Equals

Compares business object 1 and business object
2’s values, excluding child business objects, to
determine whether they are equal.

API: BusObj.equalsShallow ()

Inputs:
* business object 1--BusObj
* business object 2--BusObj

Outputs: equal?--boolean

To String Gets the values of all attributes in a business Inputs: business object--BusObj
object as string.
Outputs: string--String
API: BusODbj.toString()
Valid Data Checks whether the specified value is a valid Inputs:

type for a specified attribute.

API: BusObj.validData()

* business object--BusObj
* attribute--String

* value--Object, BusObj, BusObjArray,
String, long, int, double, float, boolean

Outputs: valid?--boolean

Table 33. General/APIs/Business Object/Array

Name

Description

Inputs and outputs with acceptable values

Get BusObj At

Retrieves the element at the specified index in
the business object array.

Inputs:
* array--BusObj[]

e index--int

Outputs: business object--BusObj

New Business
Object Array

Creates a new business object array.

Inputs: size--int

Outputs: array--BusObj[]

Set BusObj At

Sets the element at the specified index in the
business object array.

Inputs:
* array--BusObj[]
e index--int

* business object--BusObj

Size

Retrieves the size of the business object array

Inputs: array--BusODbj][]

Outputs: size--int

Table 34. General/APIs/Business Object/Constants

Name

Description

Inputs and outputs with acceptable values

Verb: Create

Business object verb "Create”.

Outputs: Create--String

Verb: Delete

Business object verb "Delete”.

Outputs: Delete--String

Verb: Retrieve

Business object verb "Retrieve”.

Outputs: Retrieve--String

Verb: Update

Business object verb "Update”.

Outputs: Update--String

Table 35. General/APls/Business Object Array

Name

Description

Inputs and outputs with acceptable values

Add Element

Adds a business object to this business object

API: BusObjArray.addElement()

Inputs:
* business object array--BusObjArray

* element--BusObj
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Table 35. General/APIs/Business Object Array (continued)

object array 2’s values, to determine whether
they are equal.

API: BusObjArray.equals()

Name Description Inputs and outputs with acceptable values
Duplicate Creates a business object array exactly like the |Inputs: original--BusObjArray
original one.
Outputs: duplicate--BusObjArray
API: BusObjArray.duplicate()
Equals Compares business object array 1’s and business | Inputs:

e array 1--BusObjArray
e array 2--BusObjArray

Outputs: equal?-- boolean

Get Element At

Retrieves a single business object by specifying
its position in the business object array.

API: BusObjArray.elementAt()

Inputs:
* business object array--BusObjArray

¢ index--int

Outputs: element--BusObj

Get Elements

Retrieves the contents of this business object
array.

API: BusObjArray.getElements()

Inputs: business object array--BusObjArray

Outputs: element--BusODbjl[]

Get Last Index

Retrieves the last available index from a
business object array.

API: BusObjArray.getLast Index()

Inputs: business object array--BusObjArray

Outputs: last index--int

Is Business Object
Array

Tests whether value is a business object array
(BusObjArray).

Inputs: value--Object

Outputs: result--boolean

Max attribute value

Retrieves the maximum values for the specified
attribute among all elements in this business
object array.

API: BusObjArray.max()

Inputs:
* business object array--BusObjArray

* attribute--String

Outputs: max--String

Min attribute value

Retrieves the minimum value for the specified
attribute among all elements in this business
object array.

API: BusObjArray.min()

Inputs:
* business object array--BusObjArray
* attribute--String

Outputs: min--String

Remove All
Elements

Removes all elements from the business object
array.

API: BusObjArray.removeAllElements()

Inputs: business object array--BusObjArray

Remove Element

Removes a business object element from a
business object array.

API: BusObjArray.removeElement()

Inputs:
* business object array--BusObjArray
* element--BusObj

Remove Element At

Removes an element at a particular position in
this business object array.

API: BusObjArray.removeElementAt()

Inputs:
* business object array--BusObjArray

¢ index--int

Set Element At

Sets the value of a business object in the
business object array.

API: BusObjArray.setElementAt()

Inputs:
* business object array--BusObjArray
* index--int

* element--BusObj
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Table 35. General/APIs/Business Object Array (continued)

Name Description Inputs and outputs with acceptable values
Size Gets the number of elements in this business Inputs: business object array--BusObjArray
object array.
Outputs: size—-int
API: BusObjArray.size()
Sum Adds the values of the specified attribute for all | Inputs:
business objects in this business object array. * business object array--BusObjArray
API: BusObjArray.sum() * attribute--String
Outputs: sum--double
Swap Reverses the positions of two business objects | Inputs:
in this business object array. * business object array--BusObjArray
APL: BusObjArray.swap() * index 1--int
* index 2--int
To String Retrieves the values in this business object array | Inputs: business object array--BusObjArray

as a single string.

API: BusObjArray.to String|()

Outputs: string--String

Table 36. General/APIs/Database Connection

Name

Description

Inputs and outputs with acceptable values

Begin Transaction

Begins an explicit transaction for the current
connection.

API: CwDBConnection.beginTransaction()

Inputs: database connection--
CwDBConnection

Commit Commits the active transaction associated with |Inputs: database connection--
the current connection. CwDBConnection
API: CwDBConnection.commit()

Execute Prepared Executes a prepared SQL Query by specifying | Inputs:

SQL

its syntax.

API: CwDBConnection.executePreparedSQL()

* database connection--CwDBConnection

* query--String

Outputs: equal?-- boolean

Execute Prepared
SQL with Parameter

Executes a prepared SQL query by specifying
its syntax with the specified parameters.

APL:CwDBConnection.executePreparedSQL()

Inputs:

* database connection--CwDBConnection
* query--String

* parameters—java.util.Vector

Execute SQL

Executes a static SQL query by specifying its
syntax.

APIL: CwDBConnection.executeSQL()

Inputs:
* database connection--CwDBConnection
* query--String

Execute SQL with
Parameter

Executes a static SQL query by specifying its
syntax with the specified parameters.

API: CwDBConnection.executeSQL()

Inputs:
e database connection--CwDBConnection
* query--String

* parameters--java.util.Vector

Execute Stored
Procedure

Executes an SQL stored procedure by specifying
its name and parameter array.

API: CwDBConnection.executeStored
Procedure()

Inputs:
e database connection--CwDBConnection
* query--String

* parameters--java.util. Vector
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Table 36. General/APIs/Database Connection (continued)

Name Description Inputs and outputs with acceptable values
Get Database Establishes a connection to a database and Inputs: connection pool name--String
Connection returns a CwDBConnection() object.

Outputs: database connection--

Connection with
Transaction

returns a CwDBConnection() object.

API: BaseDLM.getDBConnection() or
BaseCollaboration.getDBConnection()

API: BaseDLM.getDBConnection() or CwDBConnection
BaseCollaboration.getDBConnection()
Get Database Establishes a connection to a database and Inputs:

* connection pool name--String

* implicit transaction--boolean

Outputs: database connection--
CwDBConnection

Get Next Row

Gets the next row from the query result.

API: CwDBConnection.nextRow()

Inputs: database connection--
CwDBConnection

Outputs: row--java.util. Vector

Get Update Count

Gets the number of rows affected by the last
write operation to the database.

API: CwDBConnection.getUpdateCount()

Inputs: database connection--
CwDBConnection

Outputs: count--int

Has More Rows

Determines whether the query result has more
rows to process.

APIL: CwDBConnection.hasMoreRows()

Inputs: database connection--
CwDBConnection

Outputs: more rows?--boolean

In Transaction

Determines whether a transaction is in progress
in the current connection.

APIL: CwDBConnection.inTransaction()

Inputs: database connection--
CwDBConnection

Outputs: in transaction?--boolean

the current connection.

APIL: CwDBConnection.rollback()

Is Active Determines whether the current connection is Inputs: database connection--
active. CwDBConnection
API: CwDBConnection.isActive() Outputs: is active?--boolean
Release Releases use of the current connection, Inputs: database connection--
returning it to its connection pool. CwDBConnection
APIL: CwDBConnection.release()
Roll Back Rolls back the active transaction associated with |Inputs: database connection--

CwDBConnection

Table 37. General/APIs/Identity Relationship

Name

Description

Inputs and outputs with acceptable values

Add My Children

Adds the specified child instances to a
parent/child relationship for an identity
relationship.

API: IdentityRelationship.addMyChildren()

Inputs:

* map--BaseDLM
 parentChildRelDefName--String

* parentParticipantDefName--String

* parentBusObj--BusObj

* childParticipantDefName--String

* childBusObjList--BusObj,BusObjArray
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Table 37. General/APIs/Identity Relationship (continued)

Name Description Inputs and outputs with acceptable values
Delete All My Removes all child instances from a parent/child | Inputs:
Children relationship for an identity relationship .

belonging to the specified parent.

API: IdentityRelationship.deleteMyChildren()

map--BaseDLM
parentChildRelDefName--String
parentParticipantDefName--String
parentBusObj--BusObj
childParticipantDefName--String

Delete My Children

Removes the specified child instances from a
parent/child relationship for an identity
relationship belonging to the specified parent.

API: IdentityRelationship.deleteMyChildren()

Inputs:

map--BaseDLM

* parentChildRelDefName--String

parentParticipantDefName--String
parentBusObj--BusObj
childParticipantDefName--String
childBusObjList--BusObj,BusObjArray

Foreign Key
Cross-Reference

Performs a lookup in the relationship table in
the relationship database based on the foreign
key of the source business object, adding a new
relationship instance in the foreign relationship
table if the foreign key does not exist.

API: IdentityRelationship.foreignKeyXref()

Inputs:

map--BaseDLM

* RelDefName--String

appParticipantDefName--String
genParticipantDefName--String

* appSpecificBusObj--BusObj

appForeignAttr--String
genericBusObj--BusObj
genForeignAttr--String

Foreign Key
Lookup

Performs a lookup in a foreign relationship
table based on the foreign key of the source
business object, failing to find a relationship
instance if the foreign key does not exist in the
foreign relationship table.

API: IdentityRelationship.foreignKeyLookup()

Inputs:

map--BaseDLM
relDefName--String
appParticipantDefName--String
appSpecificBusObj--BusObj

* appForeignAttr--String

genericBusObj--BusObj
genForeignAttr--String

Maintain Child
Verb

Sets the child business object verb based on the
map execution context and the verb of the
parent business object.

API: IdentityRelationship.maintainChild Verb()

Inputs:

map--BaseDLM
relDefName--String
appSpecificParticipantName--String
genericParticipantName--String
appSpecificObj--BusObj
appSpecificChildObj--String
genericObj--BusObj
genericChildObj--String
to_Retrieve--boolean
Is_Composite--boolean
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Table 37. General/APIs/Identity Relationship (continued)

Name

Description

Inputs and outputs with acceptable values

Maintain Composite
Relationship

Maintains a composite identity relationship
from within the parent map.

API: IdentityRelationship.maintain
CompositeRelationship()

Inputs:

* map--BaseDLM

* relDefName--String

* participantDefName--String

* appSpecificBusObj--BusObj

* genericBusObjList--BusObj, BusObjArray

Maintain Simple
Identity

Maintains a simple identity relationship from
within either a parent or child map.

Inputs:
* map--BaseDLM

relationship, as necessary.

API: IdentityRelationship.updateMyChildren()

Relationship .
APT: IdentityRelationship.maintain * relDefName--String
Simple Identity Relationship() * participantDefName--String
* appSpecificBusObj--BusObj
* genericBusObj--BusObj
Update My Adds and deletes child instances in a specified |Inputs:
Children parent/child relationship of an identity

* map--BaseDLM

* parentChildRelDefName--String

* parentParticipantDef--String

* parentBusObj--BusObj

* childParticipantDef--String

* childAttrName--String

* childldentityRelDefName--String

* childldentityParticipantDefName--String

Table 38. General/APlIs/Maps

Name

Description

Inputs and outputs with acceptable values

Get Adapter Name

Retrieves the adapter name associated with the
current map instance.

API: MapExeContext.getConnName()

Inputs: map--BaseDLM

Outputs: adapter name--String

Get Calling Context

Retrieves the calling context associated with the
current map instance.

API: MapExeContext.getInitiator()

Inputs: map--BaseDLM

Outputs: calling context--String

Get Original
Request Business
Object

Retrieves the original-request business object
associated with the current map instance.

API: MapExeContext.getOriginalRequestBO()

Inputs: map--BaseDLM

Outputs: original business object--BusObj

Table 39. General/APls/Maps/Constants

Name

Description

Inputs and outputs with acceptable values

Calling Context:
ACCESS
_REQUEST

An access client has sent an access request from
an external application to InterChange Server
Express.

APIL: MapExeContext. ACCESS_REQUEST

Outputs: ACCESS_REQUEST--String
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Table 39. General/APIs/Maps/Constants (continued)

Name

Description

Inputs and outputs with acceptable values

Calling Context:
ACCESS
_RESPONSE

The source business object is sent back to the
source access client in response to a
subscription delivery request.

APIL: MapExeContext. ACCESS_RESPONSE

Outputs: ACCESS_RESPONSE--String

Calling Context:
EVENT
_DELIVERY

A connector has sent an event from the
application to InterChange Server Express
(event-triggered flow).

APIL: MapExeContext. EVENT_DELIVERY

Outputs: EVENT_DELIVERY--String

Calling Context:
SERVICE_CALL
_FAILURE

A collaboration’s service call request has failed.
As such, corrective action might need to be
performed.

APIL: MapExeContext.SERVICE_CALL_FAILURE

Outputs: SERVICE_CALL_FAILURE
--String

Calling Context:
SERVICE_CALL
_REQUEST

A collaboration is sending a business object
down to the application through a service call
request.

APIL:
MapExeContext.SERVICE_CALL_REQUEST

Outputs: SERVICE_CALL_REQUEST
--String

Calling Context:
SERVICE_CALL
_RESPONSE

A business object was received from the
application as a result of a successful response
to a collaboration service call request.

APIL: MapExeContext.SERVICE_CALL
_RESPONSE

Outputs: SERVICE_CALL_RESPONSE
--String

Table 40. General/APls/Maps/Exception

Name Description Inputs and outputs with acceptable values
Raise Map Raises a map run-time exception. Inputs:
Frception API: raiseException() * map-BaseDLM
* exception type--String
° message--String
Raise Map Raises a map run-time exception. Inputs:

Exception 1

API: raiseException()

* map--BaseDLM
* exception type--String
° message--String

* parameter 1--String

Raise Map
Exception 2

Raises a map run-time exception.

API: raiseException()

Inputs:

* map--BaseDLM

* exception type--String
* message--String

* parameter 1--String

° parameter 2--String
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Table 40. General/APIs/Maps/Exception (continued)

Name

Description

Inputs and outputs with acceptable values

Raise Map
Exception 3

Raises a map run-time exception.

API: raiseException()

Inputs:

* map--BaseDLM

* exception type--String
° message--String

* parameter 1--String

* parameter 2--String

* parameter 3--String

Raise Map
Exception 4

Raises a map run-time exception.

API: raiseException()

Inputs:

* map--BaseDLM

* exception type--String
° message--String

* parameter 1--String

* parameter 2--String

e parameter 3--String

e parameter 4--String

Raise Map
Exception 5

Raises a map run-time exception.

API: raiseException()

Inputs:

* map--BaseDLM

* exception type--String
° message--String

* parameter 1--String

° parameter 2--String

* parameter 3--String

* parameter 4--String

* parameter 5--String

Raise Map
RunTimeEntity
Exception

Raises a map run-time exception.

API: raiseException()

Inputs:
* map--BaseDLM
* exception--RunTimeEntityException

Table 41. General/APIs/Participant

Name

Description

Inputs and outputs with acceptable values

Get Boolean Data

Retrieves the data associated with the
Participant object.

API: Participant.getBoolean()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: data--boolean

Get Business Object
Data

Retrieves the data associated with the
Participant object.

API: Participant.getBusODbj()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: data--BusObj

Get Double Data

Retrieves the data associated with the
Participant object.

API: Participant.getDouble()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: data--double

Get Float Data

Retrieves the data associated with the
Participant object.

API: Participant.getFloat()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: data--float
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Table 41. General/APIs/Participant (continued)

Name

Description

Inputs and outputs with acceptable values

Get Instance ID

Retrieves the relationship instance ID of the
relationship in which the participant instance is
participating.

API: Participant.getInstanceld()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: instance ID--int

Get Int Data

Retrieves the data associated with the
Participant object.

API: Participant.getInt()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: data--int

Get Long Data

Retrieves the data associated with the
Participant object.

API: Participant.getLong()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: data--long

Get Participant
Name

Retrieves the participant definition name from
which the participant instance is created.

API: Participant.getParticipantDefinition()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: name--String

Get Relationship
Name

Retrieves the name of the relationship definition
in which the participant instance is
participating.

API: Participant.getRelationshipDefinition()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: name--String

Get String Data

Retrieves the data associated with the
Participant object.

API: Participant.getString()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: data--String

New Participant

Creates a new participant instance with no
relationship instance.

API: Participant()

Inputs:

* relDefName--String

* partDefName--String

* partData--BusObj, String, long, int,
double, float, boolean

Output: participant--

Server.RelationshipServices.Participant

New Participant in

Creates a new participant instance for adding to

Inputs:

Relationship an existing participant in a relationship + relDefName--String
instance. .
* partDefName--String
API: RelationshipServices.Participant() * instanceld--int
* partData--BusObj, String, long, int,
double, float, boolean
Output: participant--
Server.RelationshipServices.Participant
Set Data Sets the data associated with the participant Inputs:

instance.

API: Participant.set()

* participant--
Server.RelationshipServices.Participant

* partData--BusObj, String, long, int,
double, float, boolean

Set Instance ID

Sets the instance ID of the relationship in which
the participant instance is participating.

API: Participant.setInstanceld()

Inputs:
* participant--
Server.RelationshipServices.Participant

e id--int
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Table 41. General/APIs/Participant (continued)

Name

Description

Inputs and outputs with acceptable values

Set Participant
Definition

Sets the participant definition name from which
the participant instance is created.

API: Participant.setParticipantDefinition()

Inputs:
* participant--
Server.RelationshipServices.Participant

* partDefName--String

Set Relationship
Definition

Sets the relationship definition in which the
participant instance is participating.

API: Participant.setRelationshipDefinition()

Inputs:
* participant--
Server.RelationshipServices.Participant

* relDefName--String

Table 42. General/APls/Participant/Array

Name

Description

Inputs and outputs with acceptable values

Get Participant At

Retrieves the element at the specified index in
the participant array.

Inputs:

* array--
Server.RelationshipServices.Participant]]

¢ index--int

Outputs: participant--
Server.RelationshipServices.Participant

New Participant
Array

Creates a new participant array with the
specified size.

Inputs: size--int

Outputs: array--
Server.RelationshipServices.Participant[]

Set Participant At

Sets the element at the specified index in the
participant array.

Inputs:

* array--
Server.RelationshipServices.Participant]]

¢ index--int
* participant--
Server.RelationshipServices.Participant

Size

Retrieves the size of the participant array.

Inputs: array--
Server.RelationshipServices.Participant[]

Outputs: size--int

Table 43. General/APIs/Participant/Constants

_INSTANCE_ID

API: Participant.INVALID_INSTANCE_ID

Name Description Inputs and outputs with acceptable values
Participant: Participant constant indicating the participant | Outputs: INVALID_INSTANCE_ID--int
INVALID ID is invalid.

Table 44. General/APIs/Relationship

Name

Description

Inputs and outputs with acceptable values

Add Participant

Adds an existing participant object to a
relationship instance.

API: Relationship.addParticipant()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: result instance ID--int
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Table 44. General/APlIs/Relationship (continued)

Name

Description

Inputs and outputs with acceptable values

Add Participant
Data

Adds a new participant to an existing
relationship instance.

API: Relationship.addParticipant()

Inputs:

* relDefName--String
* partDefName--String
* instanceld--int

* partData--BusObj, String, long, int,
double, float, boolean

Outputs: result instance ID--int

Add Participant
Data to New
Relationship

Adds a participant to a new relationship
instance.

API: Relationship.addParticipant()

Inputs:
* relDefName--String
* partDefName--String

* partData--BusObj, String, long, int,
double, float, boolean

Outputs: result instance ID--int

Create Relationship

Creates a new relationship instance.

API: Relationship.create()

Inputs:
* relDefName--String
* partDefName--String

* partData--BusObj, String, long, int,
double, float, boolean

Outputs: instance ID--int

Create Relationship
with Participant

Creates a new relationship instance.

API: Relationship.create()

Inputs: participant--
Server.RelationshipServices.Participant

Outputs: instance ID--int

Deactivate Deactivates a participant from one or more Inputs: participant--

Participant relationship instances. Server.RelationshipServices.Participant
API: Relationship.deactivate Participant()

Deactivate Deactivates a participant from one or more Inputs:

Participant By Data

relationship instances.

API: Relationship.deactivate Participant()

* relDefName--String
* partDefName--String

* partData--BusObj, String, long, int,
double, float, boolean

Deactivate Deactivates a participant from a specific Inputs:

Participant By relationship instance. + relDefName--String

Instance i
API: Relationship.deactivate * partDefName--String
ParticipantBylInstance() * instanceld--int

Deactivate Deactivates a participant from a specific Inputs:

Participant By
Instance Data

relationship instance with the data associated
with the participant.

API: Relationship.deactivate
ParticipantBylInstance()

* relDefName--String
* partDefName--String
* instanceld--int

* partData--BusObj, String, long, int,
double, float, boolean

Delete Participant

Removes a participant instance from one or
more relationship instances.

API: Relationship.deleteParticipant()

Inputs: participant--
Server.RelationshipServices.Participant
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Table 44. General/APlIs/Relationship (continued)

Name

Description

Inputs and outputs with acceptable values

Delete Participant
By Instance

Removes a participant from a specific
relatio