WebSphere Business Integration Server

Express and Express Plus

Quick Start Guide

Version 4.3.1

<|ll



Note!
FBefore using this information and the product it supports, read the information in|“Notices” on page 35|

30July2004

This edition of this document applies to IBM WebSphere Business Integration Server Express, version 4.3.1 and IBM
WebSphere Business Integration Server Express Plus, version 4.3.1.

To send us your comments about IBM WebSphere Business Integration documentation, e-mail doc-
comments@us.ibm.com. We look forward to hearing from you.

When you send information to IBM, you grant IBM a nonexclusive right to use or distribute the information in any
way it believes appropriate without incurring any obligation to you.

© Copyright International Business Machines Corporation 2004. All rights reserved.
US Government Users Restricted Rights — Use, duplication or disclosure restricted by GSA ADP Schedule Contract
with IBM Corp.



Contents

About this document .
Audience .

Related documents .
Conventions used in this gulde
New in release 4.3.1

New in release 4.3 .

Chapter 1. Quick Start Guide Overview
Contacting product support

Chapter 2. Validating your Windows installation
Supported Windows platforms

Starting InterChange Server Express

Starting System Manager . . .
Registering an InterChange Server Express mstance

Verifying that all necessary components are working correctly .

Using Test Connector to view business data .
Using the Adapter for JText to process text files.
Taking the next step e

Chapter 3. Validating your OS/400 installation .
Starting InterChange Server Express .

Starting System Manager . .

Registering an InterChange Server Express 1nstance

Verifying that all necessary components are working correctly
Using Test Connector to view business data

Using the Adapter for JText to process text files

Taking the next step .

Chapter 4. Validating your Linux installation
Installing Toolset Express . .

Starting InterChange Server Express .

Starting System Manager . .
Registering an InterChange Server Express 1nstance

Verifying that all necessary components are working correctly
Using Test Connector to view business data

Using the Adapter for JText to process text files

Taking the next step e

Chapter 5. Cleaning up the business objects
Importing the BIA_BO_BaseCollabBOs.jar package file .

Deploying the Customer and Employee business objects to the server .

Taking the next steps .

Notices
Notices .

© Copyright IBM Corp. 2004

[uny

<

. vi
. Vil
. vii

— ok

w

= O Q1 = = s W

—
— = =
o W

—_
S

N = =
S 0o Ul

.21
.21
.24
.24
.24
.25
. 25
.29
.32

. 33
.33
.34
.34

. 35
. 35

iii



1V Quick Start Guide



About this document

The products IBM® WebSphere® Business Integration Server Express and IBM®
WebSphere® Business Integration Server Express Plus are made up of the
following components: InterChange Server Express, the associated Toolset Express,
CollaborationFoundation, and a set of software integration adapters. The tools in
Toolset Express help you to create, modify, and manage business processes. You
can choose from among the prepackaged adapters for your business processes that
span applications. The standard processes template, CollaborationFoundation,
allows you to quickly create customized processes.

Except where noted, all the information in this guide applies to both IBM
WebSphere Business Integration Server Express and IBM WebSphere Business
Integration Server Express Plus. The term “WebSphere Business Integration Server
Express” and its variants refer to both products.

The SystemTest samples are provided as a means of validating the IBM WebSphere
Business Integration Server Express V4.3.1 and IBM WebSphere Business

Integration Server Express Plus V4.3.1 systems after installation.

This document describes how to use these samples to validate your system.

Audience

This document is for consultants and system administrators who install, deploy,
and administer IBM WebSphere Business Integration Express.

Related documents

© Copyright IBM Corp. 2004

The complete set of documentation available with this product describes the
features and components common to all IBM WebSphere Business Integration
Server Express installations, and includes reference material on specific
components.

You can download, install, and view the documentation at the following site:
http:/ /www.ibm.com/software/integration/wbiserverexpress/library/infocenter

After completing the instructions provided in this document for validating your
product installation, refer to the documents listed below to learn more about these
specific tasks.

* For information about the IBM WebSphere Business Integration Server Express
and Express Plus products and the steps necessary to implement a solution, refer
to the System Implementation Guide.

* For information about installing the optional Adapter or Collaboration Capacity
Packs, available only with the IBM WebSphere Business Integration Server
Express Plus product, refer to the WebSphere Business Integration Server Express
Installation Guide for Windows, WebSphere Business Integration Server Express
Installation Guide for OS/400, or the WebSphere Business Integration Server Express
Installation Guide for Linux.

* For information about performing the final configuration tasks for your
implementation, including configuration of the adapters installed with IBM


http://www.ibm.com/software/integration/wbiserverexpress/library/infocenter

WebSphere Business Integration Server Express and Express Plus and the
optional Adapter Capacity Pack, refer to the System Implementation Guide.

Notes:

1.

In the SystemTest samples, the adapters have been configured to use IDL as
the transport mechanism. These samples do not test an implementation using
JMS as the transport mechanism. For information about configuring adapters to
use JMS as the transport mechanism, see the Systemn Implementation Guide.

Important information about this product may be available in Technical
Support Technotes and Flashes issued after this document was published.
These can be found on the WebSphere Business Integration Support Web site,
[http:/ /www.ibm.com /software/integration/websphere /support/} Select the
component area of interest and browse the Technotes and Flashes sections.

Conventions used in this guide

vi
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This document uses these abbreviations and style conventions:

Abbreviations are used for some words and some variables in syntax statements.
These abbreviations are used:

BO = business object (prefix to a BO file) ip_address = variable name for an IP address

collaboration_name = variable name for a ObjectName = variable name for business object
collaboration

connector_name = variable name for a 0s400Name = variable for name of OS/400
connector system or its IP address

ICS = InterChange Server Express

* BO is the prefix to a BO file; the term BO generally refers to the business object
definition text files. ObjectName refers to the variables used to represent business
objects.

The term “camelcase,” used in this document, refers to a style of capitalization
whereby the spaces between words are eliminated, and the first letter of each
word (or more than one letter if using acronyms) is capitalized. For example, the
term SystemTest is in camelcase.

In addition, this document uses some or all of the following typographical

conventions:

Bold Indicates a literal value, such as a command name, filename,
information that you type, or information that the system
prints on the screen.

italic Indicates a variable name, a cross-reference, or a new term
the first time it appears.

blue outline A blue outline, which is visible only when you view the

manual online, indicates a cross-reference hyperlink. Click
inside the outline to jump to the object of the reference.

In a syntax line, curly braces surround a set of options from
which you must choose one and only one.

In a syntax line, square brackets surround an optional
parameter.

In a syntax line, ellipses indicate a repetition of the previous
parameter. For example, option],...] means that you can enter
multiple, comma-separated options.



http://www.ibm.com/software/integration/websphere/support/

<> In a naming convention, angle brackets surround individual
elements of a name to distinguish them from each other, as
in <server_name><connector_name>tmp.log.

/, \ In this document, slashes (/, \) are used as the convention
for directory paths. All IBM WebSphere Business Integration
Server Express system product pathnames are relative to the
directory where the product is installed on your system.

Y%text% and $text Text within percent (%) signs indicates the value of the text
system variable or user variable.
ProductDir Represents the directory where the product is installed.

New in release 4.3.1

This release adds support for InterChange Server Express on the following
operating systems:

« IBM OS/400 V5R2, V5R3
* Red Hat Enterprise AS Linux 3.0, Update 1
e SuSE Linux Enterprise Server 8.1 with SP3
* Microsoft Windows 2003

New in release 4.3

This is the first release of this guide.

About this document Vil
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Chapter 1. Quick Start Guide Overview

This document describes how to use the SystemTest samples to validate the system
after installing the Windows, OS/400, or Linux editions of the IBM® WebSphere(R)
Business Integration Server Express V4.3.1 or the IBM® WebSphere™ Business
Integration Server Express Plus V4.3.1 products.

Except where noted, all the information in this guide applies to both IBM
WebSphere Business Integration Server Express and IBM WebSphere Business
Integration Server Express Plus. The term WebSphere Business Integration Server
Express and its variants refer to both products.

The “Validating your Windows Installation,” “Validating your OS/400 installation.
and “Validating your Linux installation” chapters each end with a section entitled
"Taking the next step.” These sections summarize what you have accomplished so
far and instruct you to proceed to the “Cleaning up the business objects” chapter
to import the BIA_BO_BaseCollabBOs jar package file into the WBIExpressLibrary
integration component library, and then deploy the Customer and Employee
business objects to the server before using your IBM WebSphere Business
Integration Server Express product. The “Taking the next steps” section at the end
of the “Cleaning up the business object” chapter provides you with suggestions
concerning what you should do after completing the instructions in this document.

Contacting product support

For support issues relating to the IBM WebSphere Business Integration Server
Express products, contact IBM Customer Support either online or by telephone:

» Visit the IBM WebSphere Business Integration Server Express technical support
Web site, [http:/ /www.ibm.com /software /integration/websphere /support /|

¢ Contact IBM WebSphere Business Integration Server Express support by
telephone within the USA or Canada at 1-800-IBM-SERV. For all other countries,
go to |http:/ /techsupport.services.ibm.com/guides/contacts.html to find the
correct telephone number for your geographic location.

© Copyright IBM Corp. 2004 1
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Chapter 2. Validating your Windows installation

This chapter describes how to use the SystemTest samples to validate the system
after installing the Windows edition of the IBM®™ WebSphere™® Business
Integration Server Express V4.3.1 product.

Note: It is assumed that you have successfully installed the Windows edition of
the IBM WebSphere Business Integration Server Express product and have
installed the Samples component from the Install Samples screen during
installation, which installs the SystemTest samples. If you have not yet
installed the IBM WebSphere Business Integration Server Express product
and the SystemTest samples, see the WebSphere Business Integration Server
Express Installation Guide for Windows.

Before using the samples, as described in “Using Test Connector to view business
data being processed” and “Using the Adapter for JText to process text files
through the system”, you must first start InterChange Server Express, start System
Manager and connect InterChange Server to it, register an InterChange Server
Express instance, and make sure that all the necessary components are working

properly.

This chapter includes the following sections:

+ |“Supported Windows platforms”|

* [“Starting InterChange Server Express” on page 4|

+ |“Starting System Manager” on page 4|

+ |“Registering an InterChange Server Express instance” on page 4|

« [“Verifying that all necessary components are working correctly” on page 4|

+ |[“Using Test Connector to view business data” on page 5|

* [“Using the Adapter for JText to process text files” on page 9|

Note: If you have already started InterChange Server Express and System
Manager, and registered an InterChange Server Express instance, begin with
the section [“Verifying that all necessary components are working correctly”]

|on page 4.|

Supported Windows platforms

WebSphere Business Integration Server Express can be installed on

Windows 2000, Windows XP, and Windows 2003. There are, however, some
important distinctions between these versions of Windows in regard to product
component support and Windows menu selections.

Important Windows platform information

¢ The instructions provided in this document are based on a Windows 2000
installation of IBM WebSphere Business Integration Server Express.

* If you are running IBM WebSphere Business Integration Server Express on a
Windows XP machine, some of the startup and other menu selections may be
slightly different than the selections used in these instructions. Please take these
minor differences into consideration when following the instructions provided in

© Copyright IBM Corp. 2004 3



this document to validate your system after installing the Windows edition of
the IBM® WebSphere®™ Business Integration Server Express V4.3.1 product.

* The IBM WebSphere Business Integration Server Express tools are not supported
on Windows 2003 with the following two exceptions: Failed Event Manager and
System Monitor. Since only InterChange Server Express, the adapters (in
production mode only), Failed Event Manager, and System Monitor are
supported, you must run System Manager on a dedicated Windows 2000 or
Windows XP machine.

Starting InterChange Server Express

To start InterChange Server Express, click Start > Programs > IBM WebSphere
Business Integration Express > InterChange Server Express. InterChange Server
Express automatically starts the Persistent Naming server.

Starting System Manager

After you have started InterChange Server Express, start WebSphere Workbench
and System Manager.

Click Start > Programs > IBM WebSphere Business Integration Express > Toolset
Express > Administrative > System Manager.

For information about System Manager, see the System Implementation Guide.

Registering an InterChange Server Express instance

After starting System Manager, register an InterChange Server Express instance.

1. Right-click InterChange Server Instances in the “InterChange Server
Component Management” view, and then click Register Server.

Type WebSpherelCS in the “Server name” field.
Type admin in the “User name” field.

Type null in the “Password” field.

Click Save User ID and Password.

Click OK.

o ok wD

Verifying that all necessary components are working correctly

4 Quick Start Guide

After starting System Manager, verify that all the connector and collaboration
objects are working correctly.

1. Expand the WebSpherelCS server instance.

2. Expand the Connectors folder. Each active connector has a green-arrow icon
displayed beside it. Verify that each of the following connectors are active
(marked by a green-arrow icon):

¢ DestinationConnector
* SourceConnector
* SystemTestConnector

3. If a connector is not active, right-click it, and then click Start connector_name in
the context menu.

4. Expand the Collaboration Objects folder. Each active collaboration object has a

green-arrow icon displayed beside it. Verify that each of the following
collaboration objects are active (marked by a green-arrow icon).



¢ CustomerSynchronization_SourceToDestination
* SystemTestObject

5. If a connector is not active, right-click it, and then click Start collaboration_name
in the context menu.

Using Test Connector to view business data

Test Connector is a graphical interface that presents the structure of a business
object in a tabular view. Connectors exchange data with applications through
business logic and so do not have a graphical interface. Test Connector emulates
connectors using a graphical view, making it easier to understand the role of a
connector in an interface, while removing the complexity of running actual
connectors.

The CustomerSynchronization_SourceToDestination collaboration object tests the
IBM WebSphere Business Integration Server Express system by sending business
objects from one instance of Test Connector to another. The Customer business
object is flat rather than hierarchical. It does not contain any other business objects.
The CustomerSynchronization collaboration template sends business objects, sent
by the source connector in the interface, to the destination connector, and does not
apply any noteworthy business logic. The SourceConnector and
DestinationConnector definitions represent the server-side component of a
connector. They do not represent executable connectors. These definitions are
sufficient to validate the subsystems of IBM WebSphere Business Integration Server
Express.

The following instructions use Test Connector to emulate connectors exchanging
data through the IBM WebSphere Business Integration Server Express system.

Note: For the purpose of these instructions, it is assumed that you have started
InterChange Server Express|and [System Manager,|and verified that the
connectors and collaboration objects|are active.

1. Click Start > Programs > IBM WebSphere Business Integration Express >
Toolset > Development > Test Connector to start Test Connector.

2. Click File > Create/Select Profile in the “Test Connector” menu bar.

3. Click to select the SourceConnector profile, and then click OK. The
“Connector Profile” dialog is shown below with the “SourceConnector” profile

Chapter 2. Validating your Windows installation 5
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selected.

Connector Profile x|

Fil= Edit

%‘ﬂ'lm :|

Connector | Server | Canfiguration File |
SoupceConneckar \ebSphereICS C A TER

DestinationConnector WehspheraICs CHhIBMwWebsphereserver, ..

ebSphereServer, .,

| ok Il Cancel I

4. Click File > Connect in the “Test Connector” menu bar. This action connects

the current instance of Test Connector with the “SourceConnector” profile
loaded to the server.

Repeat steps Elthrough El to launch another instance of Test Connector. Specify
the DestinationConnector profile instead of SourceConnector in step EI The
“Connector Profile” dialog is shown below with the DestinationConnector
profile selected.

Connector Profile x|

Fil=  Edit

%‘*l@ﬂ :|

Connector | Server | Configuration File |
SourceConneckar \WwebSphereICS CAIBMWebSphereServer. ..

DestinationConnector pherelCs CAIBMYWebSphereServer, .

Wigl t| S

I Ok ” Cancel I

6. Click File > Connect in the “Test Connector” menu bar. This action connects

the current instance of Test Connector with the DestinationConnector profile
loaded to the server.

In the instance of Test Connector that has the SourceConnector profile loaded,
click Edit > Load BO in the menu bar.



8.

10.

In the the “Open” dialog, click \ProductDir \Samples\SystemTest, and then
click to select the Customer.bo folder.

The “Open” dialog is shown below.
2l

_ldata
[:I repositary

Customer,bo

File name: I j Cpen I
Files of type: IElusiness Chjects* ha) j Cancel |

i

Click Open to open the Customer.bo file and display the “New Instance”
dialog.

Type Customer_0 in the “Enter Name” field, and then click OK. The “New
Instance” dialog, with Customer_0 typed in the “Enter Name” field, is shown
below.

New Instance x|

Enter MNanne Custl:umer_lil|

0 4 Cancel I

Chapter 2. Validating your Windows installation
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11. Note the values, for example FirstName, String, Tom, in the fields of the
Customer business object, as shown below.

Marne | Type | Yalue |
Customerld Skring 1000324
FirstMarme Skring Torm
LastMarme Skring Barrymore
Skatus Skring Active
CreatedOnD,..  String 10/09f2003
OhjectEventId  String SourceConne. ..

12. Click Request > Send in the menu bar to send the business object.

13. Give focus to the instance of Test Connector that has the
“DestinationConnector” profile loaded. If the “BO Request List” pane contains
Customer.Create, as shown below, the Customer business object has been
received.

B Request Lisk
Customer, Create

8  Quick Start Guide



14. Double-click the Customer.create event to view it as a response business
object. The “Response BO” dialog is shown below.

i Response BO x|
@ 4| &

BO Twpe I Customer
erb: ICreate 'I BOLDcaIe:I 'I

Mare | Tyvpe | Walue |
CustamerId Skring 1000324
FirskMane Skring Tarm
LastMame Skring Earrymare
Status Skring Active
CreatedOnD... String 10/09/2003
ObjectEventId  String SourceCanne. ..

Cancel |

15. Optional: Double-click in each of the fields to edit the data in the way that a
destination application typically assigns its own unique values to events that
it processes. Click Ok when you have finished editing the fields.

16. Click Request > Reply > Success in the menu bar to simulate the destination
application successfully processing the business object and returning it to
InterChange Server Express.

17. When you have finished sending and replying to events, click File > Exit in
the “Test Connector” menu bar, and then click Yes when prompted to shut
down Test Connector.

Using the Adapter for JText to process text files

The Adapter for JText connector can convert business object data into text files, and
text files into business object data, which allows it to exchange business objects
between InterChange Server Express and file-based applications, such as
mainframes. Although many applications manage their business data through
application-programming interfaces, some do not. Almost all applications,
however, are capable of processing text files, which makes the Adapter for JText a
popular and powerful integration component.

The SystemTestObject collaboration object exchanges data using an instance of the
Adapter for JText. This instance is named SystemTestConnector in this SystemTest
sample. This sample does not represent a typical integration interface since the
exchange of Enterprise data occurs between separate applications. It does,
however, provide an application-independent means of validating most of the
types of components that are typically involved in an IBM WebSphere Business
Integration Server Express server exchange.

The SystemTestConnector polls the data directory within the \\Samples\System
folder of the IBM WebSphere Business Integration Server Express installation. This
installation folder contains the Employee.in folder, which contains a number of

records for an Employee business entity.

The following data represents a single record of this type:

Chapter 2. Validating your Windows installation 9
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* BusinessObject = Employee

* Verb = Create

 AttributeCount = 10

* Employeeld = 14963840

* FirstName = Frank

e LastName = Jones

* SocialSecurityNumber = 142-72-4050
 Salary = 15.00

* Hours = 40

* Comments = Hired for chip design initiative
* Revenue = 1000000

* PhoneNumber = 744-289-5848

*  ObjectEventld = 0123456789

This type of record is referred to as a name/value pair, delimited. Metadata names,
such as Employeeld, identify the data that they represent. Individual fields are
identified by special characters such as paragraph returns. Individual records are
identified by special characters such as semicolons.

The JText connector processes the Employee.in file, converting the records
contained within it to business objects, and then sends these business objects to
InterChange Server Express. The business objects are processed by a collaboration,
which applies a small amount of business logic to the objects. The collaboration
sends the objects back to SystemTestConnector, which converts each business object
to a file in the data folder. SystemTestConnector uses the same data folder to poll
for new events and to output the business objects it processes.
SystemTestConnector recursively processes its own output, providing a consistent
flow of data through the system.

The SystemTest collaboration template, upon which the collaboration objects are
based, is designed to attempt an illegal Java number-formatting operation on a
field in some of the business objects processed by the collaboration. This illegal
operation generates failed flows so that you can use Flow Manager to experiment
with resolving failures in the system. For more information about Flow Manager,
see the IBM WebSphere Business Integration Server Express and Express Plus System
Administration Guide.

The following instructions use the Adapter for JText to process text files through a
pair of interfaces in the system.

Note: For the purpose of these instructions, it is assumed that you have started
InterChange Server Express|and [System Manager] and verified that the
connectors and collaboration objects|are active.

1. In the InterChange Server Component Management view in System Manager,
right-click the SystemTestObject collaboration object, and then click Statistics
in the menu bar to open the “Statistics” view.

Note: The “Statistics” view shows information about the events being
processed by a collaboration. The information in this view is very helpful
when you are testing a business process interface.

2. Click Start > Programs > IBM WebSphere Business Integration Express >
Samples > System Test > Run SystemTest Sample to run the SystemTest



sample batch file. This batch file starts JTextConnector and copies a file
containing sample data into the folder polled by the connector.

The information displayed within the SystemTest sample console window
scrolls rapidly as JTextConnector starts, and then polls and processes events. To
read the logged information, click in the console window to mark it, which
pauses the process.

3. Press Enter to unmark the console window, which restarts the process.

4. If the “System Manager” window is not maximized, right-click the title bar of
the “System Manager” window, and then click Maximize in the context menu
to fully expand it.

5. The Statistics view, which you opened previously for the SystemTestObject
collaboration object in System Manager, displays the counters for the total
number of events processed, how many events were successful, and how many
events failed. The interface is designed to occasionally fail an event so you can
view failed flows as well as successful ones.

6. Open the \\IBM\ WebSphereServer\Samples\SystemTest\data folder, which is the
default installation path for IBM WebSphere Business Integration Server
Express on your machine, to view the files created by the connector as it
processes the data.

7. After allowing the interface to run for several minutes, right-click
SystemTestConnector in the InterChange Server Component Management view
in System Manager, and then click Shut Down SystemTestConnector.

Taking the next step

After completing the instructions provided in this chapter, you have verified that
InterChange Server Express starts and that the major components of the integration
system can deploy, start, process business data, and can be shut down. This
indicates that the system is installed correctly and can support subsequent
development, testing, and production.

You must, however, clean up the business objects in your installation before using
IBM WebSphere Business Integration Server Express. Go to [Chapter 5, “Cleaning]
lup the business objects,” on page 33| and follow the instructions provided for
importing the BIA_BO_BaseCollabBOs.jar package file into the WBIExpressLibrary
integration component library, and then deploying the Customer and Employee
business objects to the server.

Chapter 2. Validating your Windows installation 11
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Chapter 3. Validating your 0S/400 installation

This chapter describes how to use the SystemTest samples to validate the system
after installing the OS/400 edition of the IBM™ WebSphere® Business Integration
Server Express V4.3.1 product.

Note: For the purpose of the instructions in this chapter, it is assumed that you
have successfully installed the OS/400 edition of the IBM WebSphere
Business Integration Server Express product and have installed the Samples
component from the Install Samples screen during installation, which
installs the SystemTest samples. If you have not yet installed the IBM
WebSphere Business Integration Server Express product and the SystemTest
samples, see the WebSphere Business Integration Server Express Installation
Guide for 0S/400.

Before using the samples, as described in “Using Test Connector to view business
data being processed” and “Using the Adapter for JText to process text files
through the system”, you must first start InterChange Server Express, start System
Manager and connect InterChange Server to it, register an InterChange Server
Express instance, and make sure that all the necessary components are working

properly.

This chapter includes the following sections:

+ |“Starting InterChange Server Express”]

* [“Starting System Manager” on page 14

* [“Registering an InterChange Server Express instance” on page 14|

+ |“Verifying that all necessary components are working correctly” on page 14|

* [“Using Test Connector to view business data” on page 15|

+ |“Using the Adapter for JText to process text files” on page 18|

Note: If you have already started InterChange Server Express and System
Manager, and registered an InterChange Server Express instance, begin with
the section [“Verifying that all necessary components are working correctly”]

|0n page 14'.

Starting InterChange Server Express

If you have installed WebSphere Business Integration Console, start the server
using the OS/400 console provided on the Windows client.

1. Click Start > Programs > IBM WebSphere Business Integration Console >
Console.

2. Type the OS/400 information, system name or IP address, and user profile and
password.

Important: The user profile must have *JOBCTL special authority.
3. Click Start Server, which is next to Instance QWBIDFT.

If you did not install WebSphere Business Integration Console, start the
“QWBISVR43 subsystem” on your OS/400 system using the:

* STRSBS SBSD(QWBISVR43/QWBISVR43) CL command
or

© Copyright IBM Corp. 2004 13



* run the submit_ics_server.sh script.

Note: After installing IBM WebSphere Business Integration Server Express, the

qwbisvr43 subsystem is up by default. When you run the STRSBS
command, the system will tell you if the subsystem is already up. If it is, the
QWBIDFT server instance might not start with the strsbs command because
it is up already. As a result, QWBIDFT might have to be started through the:

e console
or

* submit_ics_server.sh QWBIDEFT script.

Starting System Manager

After you have started InterChange Server Express, start WebSphere Workbench
and System Manager.

Click Start > Programs > IBM WebSphere Business Integration Express > Toolset

Express > Administrative > System Manager to start WebSphere Workbench.

For information about System Manager, see the System Implementation Guide.

Registering an

InterChange Server Express instance

After starting System Manager, register an InterChange Server Express instance.

1. Click Window > Open Perspective > Other in the WebSphere Workbench
menu bar.

A

Double-click System Manager.

w

Right-click InterChange Server Instances in the “InterChange Server
Component Management” view, and then click Register Server.

Type QWBIDFT in the “Server name” field.
Type admin in the “User name” field.

Type null in the “Password” field.

Click Save User ID and Password.

Click OK.

© N o oA

Verifying that all necessary components are working correctly

14  Quick Start Guide

After starting System Manager, verify that all the connector and collaboration
objects are working correctly.

1. Expand the QWBIDEFT server instance.

2. Expand the Connectors folder. Each active connector has a green-arrow icon
displayed beside it. Verify that each of the following connectors are active
(marked by a green-arrow icon):

¢ DestinationConnector
e SourceConnector
¢ SystemTestConnector

3. If a connector is not active, right-click it, and then click Start connector_name in
the context menu.

4. Expand the “Collaboration Objects” folder. Each active collaboration object has
a green-arrow icon displayed beside it. Verify that each of the following
collaboration objects are active (marked by a green-arrow icon).



¢ CustomerSynchronization_SourceToDestination
* SystemTestObject

5. If a collaboration is not active, right-click it, and then click Start
collaboration_name in the context menu.

Using Test Connector to view business data

Test Connector is a graphical interface that presents the structure of a business
object in a tabular view. Connectors exchange data with applications through
business logic and so do not have a graphical interface. Test Connector emulates
connectors using a graphical view, making it easier to understand the role of a
connector in an interface, while removing the complexity of running actual
connectors.

The CustomerSynchronization_SourceToDestination collaboration object tests the
IBM WebSphere Business Integration Server Express system by sending business
objects from one instance of Test Connector to another. The Customer business
object is flat rather than hierarchical. It does not contain any other business objects.
The CustomerSynchronization collaboration template sends business objects, sent
by the source connector in the interface, to the destination connector, and does not
apply any noteworthy business logic. The SourceConnector and
DestinationConnector definitions represent the server-side component of a
connector. They do not represent executable connectors. These definitions are
sufficient to validate the subsystems of IBM WebSphere Business Integration Server
Express.

The following instructions use Test Connector to emulate connectors exchanging
data through the IBM WebSphere Business Integration Server Express system.

Note: For the purpose of these instructions, it is assumed that you have started
InterChange Server Express|and [System Manager} [“Registering an|
InterChange Server Express instance” on page 14)|and verified that the |’&st|
connectors and collaboration objects|are active.

1. Map a network drive to your OS/400 system (\\OS400system\root).

2. Click Start > Programs > IBM WebSphere Business Integration Express >
Toolset Express > Development > Test Connector to start Test Connector.

3. C(lick File > Create/Select Profile in the “Test Connector” menu bar.
4. Select File > New Profile in the “Connector Profile” menu bar.

5. Click Browse, and then navigate to the mapped drive that you set up in ste
Navigate to the \QIBM\UserData\WBIServer43\QWBIDFT\ directory, click
to select the “InterchangeSystem.cfg” file, and then clickOpen.

Note: If you are doing this for an instance that you created with the
create_instance.sh script, use that instance name instead of QWBIDFT.

6. In the “Connector Name” field, type SourceConnector.

7. In the “Server” field, type the server name QWBIDEFT or the name you used
with the create_instance.sh script.

8. In the “Password” field, type the password for the ICS admin user. This is the
word null if you did not change this password after installation.

9. Click to select the SourceConnector profile, and then click OK. The
“Connector Profile” dialog is shown below with the “SourceConnector” profile
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10.

11.

12.

13.

14.

Quick Start Guide

selected.

Connector Profile

File Edit

|| n]

Connectar | Server | Configuration File |
EourosCormmdior | WebSpherelcs ;
DestinationConnector WebSpherelCS CHATEMWebSphereServer ...
SourceConneckar QWEIDFT O \QIBM| UserDatalWwBIS. ..

Click File > Connect in the “Test Connector” menu bar. This action connects
the current instance of Test Connector with the SourceConnector profile
loaded to the server.

Repeat steps through to launch another instance of
Test Connector. Use DestinationConnector instead of SourceConnector in
steps |§| and EI

Click File > Connect in the “Test Connector” menu bar. This action connects

the current instance of Test Connector with the DestinationConnector profile
loaded to the server.

In the instance of Test Connector that has the SourceConnector profile loaded,
click Edit > Load BO in the menu bar.

In the “Open” dialog, navigate to
\QIBM\UserData\WBIServer43\QWBIDFT\Samples\SystemTest\ on your

mapped drive, and then click to select the Customer.bo folder. The “Open”
dialog is shown below.

Look in: I (25 SystemTest

\)data
arepository
Customer.bo

Employee.bo

by it
Documents

Deskiop

ty Documents

by Ec&nputer
w
by Netwaork.  BEEIEEEES IEuslamerAhn j Open I
Places
Files of type: |Eusiness Obijects(*.ba) j Cancel /l
%




15. Click Open to open the Customer.bo file and display the “New Instance”
dialog.
16. Type Customer_0 in the “Enter Name” field, and then click OK.

17. Note the values, for example FirstName, String, Tom, in the fields of the
Customer business object, as shown below.

Tame | Type | alue |
Customerld Skring 1000324
FirstMame Skring Tam
LastMarme Skring Barrymore
Status Skring Active
CreatedOnD...  String 100912003
ObjectEventld  String SourceConne. ..

18. Click Request > Send in the menu bar to send the business object.

19. Give focus to the instance of Test Connector that has the DestinationConnector
profile loaded. If the “BO Request List” pane contains Customer.Create, as
shown below, the Customer business object has been received.

B Request Lisk
Customer, Create
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20. Double-click the “Customer.create” event to view it as a response business
object. The Response BO dialog is shown below.

i Response BO ﬂ
& 7| &

BO Twpe I Customer
erb: ICreate 'I BOLDcaIe:I 'I

Mare | Tyvpe | Walue |
CustamerId Skring 1000324
FirskMane Skring Tarm
LastMame Skring Earrymare
Status Skring Active
CreatedOnD... String 10/09/2003
ObjectEventId  String SourceCanne. ..

Cancel |

21. Optional: Double-click in each of the fields to edit the data in the way that a
destination application typically assigns its own unique values to events that
it processes. Click Ok when you have finished editing the fields.

22. Click Request > Reply > Success in the menu bar to simulate the destination
application successfully processing the business object and returning it to
InterChange Server Express.

23. When you have finished sending and replying to events, click File > Exit in
the Test Connector menu bar, and then click Yes when prompted to shut
down Test Connector.

Using the Adapter for JText to process text files

18  Quick Start Guide

The Adapter for JText connector can convert business object data into text files, and
text files into business object data, which allows it to exchange business objects
between InterChange Server Express and file-based applications, such as
mainframes. Although many applications manage their business data through
application-programming interfaces, some do not. Almost all applications,
however, are capable of processing text files, which makes the Adapter for JText a
popular and powerful integration component.

The SystemTestObject collaboration object exchanges data using an instance of the
Adapter for JText. This instance is named SystemTestConnector in this SystemTest
sample. This sample does not represent a typical integration interface since the
exchange of Enterprise data occurs between separate applications. It does,
however, provide an application-independent means of validating most of the
types of components that are typically involved in an IBM WebSphere Business
Integration Server Express server exchange.

The SystemTestConnector polls the data directory within the \\Samples\System
folder of the IBM WebSphere Business Integration Server Express installation. This
installation folder contains the Employee.in folder, which contains a number of
records for an Employee business entity.

The following data represents a single record of this type:



* BusinessObject = Employee

* Verb = Create

 AttributeCount = 10

* Employeeld = 14963840

* FirstName = Frank

e LastName = Jones

* SocialSecurityNumber = 142-72-4050
* Salary = 15.00

* Hours = 40

* Comments = Hired for chip design initiative
* Revenue = 1000000

¢ PhoneNumber = 744-289-5848

*  ObjectEventld = 0123456789

This type of record is referred to as a name/value pair, delimited. Metadata names,
such as Employeeld, identify the data that they represent. Individual fields are
identified by special characters such as paragraph returns. Individual records are
identified by special characters such as semicolons.

The JText connector processes the Employee.in file, converting the records
contained within it to business objects, and then sends these business objects to
InterChange Server Express. The business objects are processed by a collaboration,
which applies a small amount of business logic to the objects. The collaboration
sends the objects back to SystemTestConnector, which converts each business object
to a file in the data folder. SystemTestConnector uses the same data folder to poll
for new events and to output the business objects it processes.
SystemTestConnector recursively processes its own output, providing a consistent
flow of data through the system.

The SystemTest collaboration template, upon which the collaboration objects are
based, is designed to attempt an illegal Java number-formatting operation on a
field in some of the business objects processed by the collaboration. This illegal
operation generates failed flows so you can use Flow Manager to experiment with
resolving failures in the system. For more information about Flow Manager, see the
IBM WebSphere Business Integration Server Express and Express Plus System
Administration Guide.

The following instructions use the Adapter for JText to process text files through a
pair of interfaces in the system.

Note: For the purpose of these instructions, it is assumed that you have started
InterChange Server Expressl and |System Manager] fregistered an InterChange|
Server Express instance| and verified that the [test connectors and|
collaboration obijects|are active.

1. In the InterChange Server Component Management view in System Manager,
right-click the
CustomerSynchronization_SourceToDestination::CustomerSynchronization
collaboration object, and then click Statistics in the menu bar to open the
Statistics view.

Note: The Statistics view shows information about the events being processed
by a collaboration. The information in this view is very helpful when
you are testing a business process interface.
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2. Repeat step [lfabove for the “SystemTestObject::SystemTest collaboration” object.

3. From the “OS/400 command entry, run CL command QSH. Then type
/QIBM/UserData/WBIServer43/QWBIDFT/Samples/SystemTest/start_SystemTest.sh
to run a shell script. The shell script starts JTextConnector, and then copies a
file of sample data into the directory polled by the connector.

The information displayed within the “SystemTest sample” console window
scrolls rapidly as JTextConnector starts, and then polls and processes events.

4. If the System Manager window is not maximized, right-click the title bar of the
System Manager window, and then click Maximize in the context menu, if that
menu choice is available. If System Manager is not maximized, the graph
display referenced in the next step is not initially in view.

5. The Statistics view, which you opened for the SystemTestObject collaboration
object in System Manager, displays the counters for the total number of events
processed, how many events were successful, and how many events failed. The
interface is designed to occasionally fail an event so you can view failed flows
as well as successful ones.

6. Navigate to the
/QIBM/UserData/WBIServer43/QWBIDFT /Samples/SystemTest/data folder
within your installation to view the files created by the connector as it
processes the data.

7. After allowing the interface to run for several minutes, right-click
SystemTestConnector in the InterChange Server Component Management view
in System Manager, and then click Shut Down SystemTestConnector.

Taking the next step
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After completing the instructions provided in this chapter, you have verified that
InterChange Server Express starts and that the major components of the integration
system can deploy, start, process business data, and can be shut down. This
indicates that the system is installed correctly and can support subsequent
development, testing, and production.

You must, however, clean up the business objects in your installation before using
IBM WebSphere Business Integration Server Express. Go to [Chapter 5, “Cleaning]
lup the business objects,” on page 33| and follow the instructions provided for
importing the BIA_BO_BaseCollabBOs.jar package file into the WBIExpressLibrary
integration component library, and then deploying the Customer and Employee
business objects to the server.




Chapter 4. Validating your Linux installation

This chapter describes how to use the SystemTest samples to validate the system
after installing the Linux edition of the IBM®™ WebSphere™® Business Integration
Server Express V4.3.1 product.

Note: This document assumes that you have successfully installed the Linux
edition of the IBM WebSphere Business Integration Server Express product
and have installed the Samples component from the Install Samples screen
during installation, which installs the SystemTest samples. If you have not
yet installed the IBM WebSphere Business Integration Server Express
product and the SystemTest samples, see the WebSphere Business Integration
Server Express Installation Guide for Linux.

Before using the samples, as described in “Using Test Connector to view business
data being processed” and “Using the Adapter for JText to process text files
through the system”, you must first start InterChange Server Express, start System
Manager and connect InterChange Server to it, register an InterChange Server
Express instance, and make sure that all the necessary components are working

properly.

This chapter includes the following sections:

+ |“Installing Toolset Express”]

* [“Starting InterChange Server Express” on page 24|

+ |“Starting System Manager” on page 24|

+ |“Registering an InterChange Server Express instance” on page 24|

* [“Verifying that all necessary components are working correctly” on page 25|

+ |[“Using Test Connector to view business data” on page 25|

* [“Using the Adapter for JText to process text files” on page 29|

Note: If you have already installed Toolset Express, and started InterChange
Server Express and System Manager, and registered an InterChange Server
Express instance, begin with the section |"Verifying that all necessaryl
[components are working correctly” on page 25.|

Installing Toolset Express

Before using the SystemTest samples to validate the system, you must install
Toolset Express on the Windows client.

During the Toolset Express installation process, you must specify your InterChange
Server Express IP address. Navigate to the
%CROSSWORLDS%\bin\CWSharedEnv.bat file and check the entry
ORB_HOST=SERVER_HOST_IP to find the IP address where your server is
located.

1. On a Windows client machine, double-click launchpad.exe to start
Launchpad.

Note: Development tools are only available on Windows 2000 and Windows
XP. If you want to install the complete toolset, you must install Toolset
Express on Windows 2000 or Windows XP.
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2. In the “Welcome” panel, click Install Product. The “Welcome panel” is shown

below.

t# IBM WebSphere Business Integration Server Express Launchpad

IBM WebSphere Business Integration Server Express Plus V4.3.1

Welcome Welcome to the IBM WebSphere Business
Integration Server Express Launchpad

Install Product

1B WebSphere Business Integration Server Exprees is a core component of IBR
WebSphere Business Integration Serwver for process automation that manages multiple
discrete business applications as one. The IBM WebSphere Business Integration Server
UEEIRE RV Fapress Launchpad will help prepare your computer for the installation of the [BIM

Web3phere Pusiness Integration Server Express product and then install the product.

@ The IBM logo and WebhSphere are trademarks or registered trademarks of IBM Corporation in the US| other countries, or both. 417 rights
reserved 2004,

On the “Install Server” page, make sure that the InterChange Server Express
checkbox is not checked, and then click Next.

On the “Install Tools” page, select administrative tools and development
tools, and then click Next. The “Install Tools” page is shown below.

i IBM WebSphere Business Integration Server Express Launchpad

L IBM WebSphere Business Integration Server Express Plus ¥4.3.1

Install Tools

Toolset Express can be installed to this machine. The following checkboxes have been
Install Product preselected to install the Administrative and Development Tools. Unselect these
checkbozes if you do not want to install Toolset Express components.
[ Administrative Tools @

Install Capacity Pack
W Developmert Tools 5]

@ The IBM logo and YWebSphere are trademarks of registered trademsrks of IBM Corporstion in the US| other countries, or both. AN rights
resenved 2004,

Nest = [zl el |

On the “Install Adapter” page, make sure that you do not select any adapter,
and then click Next.

Important: If you have installed IBM WebSphere Business Integration Express
on Windows XD, skip this step as the “Install Adapter” page does not appear
on a Windows XP installation.

On the “Install Samples” page, make sure that samples are not selected, and
then click Next.



7. On the “Software Prerequisites” page, install third-party software as required.
The “Software Prerequisites” page is shown below.

t@ IBM WebSphere Business Integration Server Express Launchpad

IBM WebSphere Business Integration Server Express Plus V4.3.1

Software Prerequisites

The [BM WebSphere Business Integration Server Express Plus Launchpad will help prepare
Install Product your computer for the installation of the IBM WebSphere Business Integration Server
Express Plus product and then install the product.

Prerequisites
Install Capacity Pack

» IBM Java Developrent Kit1.3.1_05 OK &
b IEMWebSphere MG 5.3.0.2 CSDOB Client 0K
b IBM WehSphere Application Server - Express V5.1 0K

¥ Weh Browser 0K i

@ The IBM logo and YWehSphere are trademarks or registered trademarks of IBM Corporstion in the US, other countries, or both. A# rights
resepved 2004,

= Back [HEXE= In=tall Product |

8. Click Install Product to start the installer.
9. On the “Software License Agreement” panel, accept the license, and then click
Next.

10. On the “Destination” panel, specify the folder where you want to install
Toolset Express, and then click Next.

11. On the “Naming Server” panel, specify the IP address of the IBM WebSphere
Business Integration Server Express server, and then click Next to start the
installation of Toolset Express. The “Naming Server” panel is shown below.

t@ IBM WebSphere Business Integration Server Express Plus v4.3.1 Installer

; Kame Server Configuration

‘You have selected to install the Toolset Express or Adapter components without the InterChange
Server Express. Specify the IP address ofthe InterChange Server Exprass you wish to connectta.

InterChange Server Express IP address {e.g. 32.108.230.121):
|202.112.58.200]

= Back Next = Cancel
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12. Once the installation is complete, click Finish. The “finish installation” panel
is shown below.

3 IBM WebSphere Business Integration Server Express Plus v4.3.1 Installer

| Please read the summary information below.

Please referto the First Steps document. You can access itvia the First Steps icon located in the Jalf
WeabSphare Sener Express Plusfolder in the start menus Programs folder,

- The InstallShield Wizard has successfully installed 1IBM YWebSphere Business Integration Server
| |Expresg Plugvd. 3.1, Chooge Finigh to exitthe wizard.

= Back [HEx=

Starting InterChange Server Express

Run the following scripts to start InterChange Server Express.

1. $cd/home/USER/IBM/WebSphereServer/bin or $cd/ProductDir/bin
2. $/ics_manager -start

Notes: In the scripts shown above:
* "$" is the Linux command line prompt
e "cd” is a command used to change directories

* "bin” is a folder within the product installation directory

InterChange Server Express automatically starts the Persistent Naming server.

Starting System Manager

After you have started InterChange Server Express, start WebSphere Workbench
and System Manager.

On the Windows client, click Start > Programs > IBM WebSphere Business

Integration Express > Toolset Express > Administrative > System Manager to
start WebSphere Workbench.

For information about System Manager, see the System Implementation Guide.

Registering an InterChange Server Express instance

After starting System Manager, register the InterChange Server Express.
1. Verify the following settings:

a. Make sure the Windows client can access the name server correctly. Check

that ORB_HOST is set correctly in the Windows client CWSharedEnv.bat file
as follows: set ORB_HOST=ip_address
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Note: Alternatively, you can set ORB_HOST=smb-redhat, and then add
the line ip_address smb-redhat in the
%windir%\system32\drivers\etc\hosts file.

b. Make sure that the name server can retrieve the linux server IP by name.
Navigate to the file/etc/hosts file, open it, and then check for entries
similar to the following lines:

ip_address localhost.localdomain localhost
ip_address smb-redhat.cn.ibm.com smb-redhat

o

Right-click InterChange Server Instances in the InterChange Server
Component Management view, and then click Register Server.

Type WebSpherelCS in the “Server name” field.
Type admin in the “User name” field.

Type null in the “Password” field.

Click Save User ID and Password.

Click OK.

No ook~

Verifying that all necessary components are working correctly

After starting System Manager, verify that all the connector and collaboration
objects are working correctly.

1. Expand the WebSphereICS server instance.

2. Expand the Connectors folder. Each active connector has a green-arrow icon
displayed beside it. Verify that each of the following connectors are active
(marked by a green-arrow icon):

e DestinationConnector
* SourceConnector
* SystemTestConnector

3. If a collaboration is not active, right-click it, and then click Start connector_name
in the context menu.

4. Expand the Collaboration Objects folder. Each active collaboration object has a
green-arrow icon displayed beside it. Verify that each of the following
collaboration objects are active (marked by a green-arrow icon).

* CustomerSynchronization_SourceToDestination
+ SystemTestObject

5. If a connector is not active, right-click it, and then click Start collaboration_name
in the context menu.

Using Test Connector to view business data

Test Connector is a graphical interface that presents the structure of a business
object in a tabular view. Connectors exchange data with applications through
business logic and so do not have a graphical interface. Test Connector emulates
connectors using a graphical view, making it easier to understand the role of a
connector in an interface, while removing the complexity of running actual
connectors.

The CustomerSynchronization_SourceToDestination collaboration object tests the
IBM WebSphere Business Integration Server Express system by sending business
objects from one instance of Test Connector to another. The Customer business
object is flat rather than hierarchical. It does not contain any other business objects.
The CustomerSynchronization collaboration template sends business objects, sent
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by the source connector in the interface, to the destination connector, and does not
apply any noteworthy business logic. The SourceConnector and
DestinationConnector definitions represent the server-side component of a
connector. They do not represent executable connectors. These definitions are
sufficient to validate the subsystems of IBM WebSphere Business Integration Server
Express.

The following instructions use Test Connector to emulate connectors exchanging
data through the IBM WebSphere Business Integration Server Express system.

Note: For the purpose of these instructions, it is assumed that you have started
InterChange Server Expressl [System Managed [registered an InterChange|
Server Express instance| and [verified that the test connectors and|
collaboration obijects|are active.

1. Click Start > Programs > IBM WebSphere Business Integration Express >
Development > Test Connector to start Test Connector.
2. Click File > Create/Select Profile in the Test Connector menu bar.

3. Click to select the SourceConnector profile, and then click OK. The
“Connector Profile” dialog is shown below with the SourceConnector profile
selected.

Connector Profile EI
File Edi

%?l@ﬂ :|

Connector | Server | Configuration File |
Solrce_onneckar WwebSphere[CS CIBM W ebSphereServer

DestinationConnector WWwebSpherelCS CHAIBMYwWebSphereServer. ..

I Ok Il Cancel I

4. Click File > Connect in the “Test Connector” menu bar. This action connects
the current instance of Test Connector with the SourceConnector profile
loaded to the server.

5. Repeat steps EI through to launch another instance of Test

Connector. Specify the DestinationConnector profile instead of
SourceConnector in step EI The “Connector Profile” dialog is shown below
with the DestinationConnector profile selected.



Connector Profile EI

File Edit

%1}-'?' % |

Connector | Setver | Configuration File |
SourceConneckar ‘WebSpherelZ5 CAIBMYWebSphereServer. ..

CIBM

herelCs

DestinationConnector ‘Weh WebSphereSeryer, .,

=p

| ok II Cancel I

6. Click File > Connect in the “Test Connector” menu bar. This action connects
the current instance of Test Connector with the DestinationConnector profile
loaded to the server.

7. In the instance of Test Connector that has the SourceConnector profile loaded,
click Edit > Load BO in the menu bar.

8. In the “Open” dialog, navigate to \ProductDir \Samples\SystemTest, and
then open the Customer.bo folder. The “Open” dialog is shown below.

21

x| = @ ek E-

_ldata
[:I repositary

Customer,bo

File name: I j Cpen I
Files of type: IElusiness Chjects* ha) j Cancel |
g

9. Click Open to open the Customer.bo file and display the “New Instance”
dialog.

10. Type Customer_0 in the “Enter Name” field, and then click OK. The “New
Instance” dialog, with Customer_0 typed in the “Enter Name” field, is shown
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below.

New Instance x|

Entet Mane Custumer_[l|

(0] 4 Cancel I

11. Note the values, for example FirstName, String, Tom, in the fields of the
Customer business object, as shown below.

Tame | Type | alue |
CustomerId Skring 1000324
FirstMarme Skring Torm
LaskMame Skring Batryrmore
Skatus Skring Active
CreatedOnD...  String 1000912003
OhjectEventId  String SourceConne. ..

12. Click Request > Send in the menu bar to send the business object.

13. Give focus to the instance of Test Connector that has the DestinationConnector
profile loaded. If the “BO Request List” pane contains Customer.Create, as
shown below, the Customer business object has been received.

B Request Lisk
Customer, Create
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14. Double-click the Customer.create event to view it as a response business
object. The “Response BO” dialog is shown below.

i Response BO x|
@ 4| &

BO Twpe I Customer
erb: ICreate 'I BOLDcaIe:I 'I

Mare | Tyvpe | Walue |
CustamerId Skring 1000324
FirskMane Skring Tarm
LastMame Skring Earrymare
Status Skring Active
CreatedOnD... String 10/09/2003
ObjectEventId  String SourceCanne. ..

Cancel |

15. Optional: Double-click in each of the fields to edit the data in the way that a
destination application typically assigns its own unique values to events that
it processes. Click Ok when you have finished editing the fields.

16. Click Request > Reply > Success in the menu bar to simulate the destination
application successfully processing the business object and returning it to
InterChange Server Express.

17. When you have finished sending and replying to events, click File > Exit in
the Test Connector menu bar, and then click Yes when prompted to shut
down Test Connector.

Using the Adapter for JText to process text files

The Adapter for JText connector can convert business object data into text files, and
text files into business object data, which allows it to exchange business objects
between InterChange Server Express and file-based applications, such as
mainframes. Although many applications manage their business data through
application-programming interfaces, some do not. Almost all applications,
however, are capable of processing text files, which makes the Adapter for JText a
popular and powerful integration component.

The SystemTestObject collaboration object exchanges data using an instance of the
Adapter for JText. This instance is named SystemTestConnector in this SystemTest
sample. This sample does not represent a typical integration interface since the
exchange of enterprise data occurs between separate applications. It does, however,
provide an application-independent means of validating most of the types of
components that are typically involved in an IBM WebSphere Business Integration
Server Express server exchange.

The SystemTestConnector polls the data folder within the
/ProductDir/Samples/SystemTest folder of the IBM WebSphere Business
Integration Server Express installation. This installation folder contains the
Employee.in folder, which contains a number of records for an Employee business
entity.
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The following data represents a single record of this type:
* BusinessObject = Employee

* Verb = Create

* AttributeCount = 10

* Employeeld = 14963840

* FirstName = Frank

* LastName = Jones

* SocialSecurityNumber = 142-72-4050
 Salary = 15.00

* Hours = 40

* Comments = Hired for chip design initiative
* Revenue = 1000000

* PhoneNumber = 744-289-5848

* ObjectEventld = 0123456789

This type of record is referred to as a name/value pair, delimited. Metadata names,
such as Employeeld, identify the data that they represent. Individual fields are
identified by special characters such as paragraph returns. Individual records are
identified by special characters such as semicolons.

The JText connector processes the Employee.in file, converting the records
contained within it to business objects, and then sends these business objects to
InterChange Server Express. The business objects are processed by a collaboration,
which applies a small amount of business logic to the objects. The collaboration
sends the objects back to SystemTestConnector, which converts each business object
to a file in the data folder. SystemTestConnector uses the same data folder to poll
for new events and to output the business objects it processes.
SystemTestConnector recursively processes its own output, providing a consistent
flow of data through the system.

The SystemTest collaboration template, upon which the collaboration objects are
based, is designed to attempt an illegal Java number-formatting operation on a
field in some of the business objects processed by the collaboration. This illegal
operation generates failed flows so you can use Flow Manager to experiment with
resolving failures in the system. For more information about Flow Manager, see the
IBM WebSphere Business Integration Server Express and Express Plus System
Administration Guide.

The following instructions use the Adapter for JText to process text files through a
pair of interfaces in the system.

Note: For the purpose of these instructions, it is assumed that you have started

InterChange Server Express|[System Manager [registered an InterChange
Server Express instance} and verified that the [test connectors and
collaboration objects|are active.

1. Run the /ProductDir/Samples/SystemTest/start_SystemTest.sh shell file on the

Linux InterChange server to start the JTextConnector and copy a file of sample
data into the folder polled by the connector.

The information displayed within the “SystemTest sample” console window
scrolls rapidly as JTextConnector starts, and then polls and processes events. An



example of the logged information is shown below.

File Edit View Terminal Go Help
[Time: 2004/07/09 19:39:46.522] [System: ConnectorAgent] [SS: SystemTestConnector] [Thread: WT=1 (#1209690911)] [T|=I
ype: Trace] [Mesg: :class com.crossworlds.DataHandlers.text.namevalue :Exiting setAttrList(BusinessObjectInterface
) for business object Employee]
[Time: 2004/07/09 19:39:46.522] [System: ConnectorAgent] [SS: SystemTestConnector] [Thread: WT=1 (#1209690911)] [T
ype: Trace] [Mesg: :class com.crossworlds.DataHandlers.text.namevalue :Exiting serializeBO(BusinessObjectInterface
, boolean) for business object Employee main BO flag true]
[Time: 2004/07/09 19:89:46.522] [System: ConnectorAgent] [SS: SystemTestConnector] [Thread: WI=1 (#1209690911)] [T
ype: Trace] [Mesg: :class com.crossworlds.DataHandlers.text.namevalue :Exiting getStringFromBO(BusinessObjectInter
face) for business object Employee]
[Time: 2004/07/09 19:39:46.522] [System: ConnectorAgent] [SS: SystemTestConnector] [Thread: WI=1 (#1209690911)] [T
ype: Trace] [Mesg: : JTextBOStringHandler: :handleBOEvent() : Created the string= { BusinessObject = Employee

Verb = Create

AttributeCount = 10

EmployeeId = 14963840

FirstName = Frank

LastName = Jones

SocialSecurityNumber = 142-72-4051

Salary = 15.00

Hours = 40

Comments = Hired for chip design initiative.

Revenue = 1000000

PhoneNumber = 744-289-5848

ObjectEventId = Fri Jul 09 19:39:22 CST 20041
} from BO= {Employee } successfully]
[Time: 2004/07/09 19:39:46.528] [System: ConnectorAgent] [SS: SystemTestConnector] [Thread: WI=1 (#1209690911)] [T
ype: Trace] [Mesg: :
| FileRecordwWriter :: Updating FileSegNo.]
;[Time: 2004/07/09 19:39:49.994] [System: ConnectorAgent] [SS: SystemTestConnector] [Thread: WI=1 (#1209690911)] [T
vpe: Trace] [Mesg: :
| FileRecordwriter :: Updating OutputLog.]
i[Time: 2004/07/09 19:39:49.994] [System: ConnectorAgent] [SS: SystemTestConnector] [Thread: WI=1 (#1209690911)] [T
ype: Trace] [Mesg: :
| JTextBOStringHandler:: Leaving handleBOEvent()] 55|
i{Time: 2004/07/09 19:39:49.994] [System: ConnectorAgent] [SS: SystemTestConnector] [Thread: WT=1 (#1209690911)] [T
lype: Trace] [Mesg: :JTExtBOHandler::doVerbFor() : Processing successful for BO = {Employee.Create}]

In the InterChange Server Component Management view in System Manager,
right-click the SystemTestObject collaboration object, and then click Statistics
in the menu bar to open the Statistics view.

Note: The Statistics view shows information about the events being processed
by a collaboration. The information in this view is very helpful when
you are testing a business process interface.

If the System Manager window is not maximized, right-click the title bar of the

System Manager window, and then click Maximize in the context menu to fully

expand it.

The Statistics view, which you opened for the SystemTestObject collaboration

object in System Manager in step @, displays the counters for the total number

of events processed, how many events were successful, and how many events
failed. The interface is designed to occasionally fail an event so you can view
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failed flows as well as successful ones. The Statistics view is shown below.

Q%SystemTestObject - WebSpherelCs X i
! Calls i Events
: Total 0 142
FT"'“E | | Successful 0 134
| Start: 2004.07.09 19:33:56 , C5T | | Faled o 8
‘ Total up: O hrs, 37 mins, 5 secs 1
| L
—Flow Status
Flows with duration greater than the time ID ﬁ hts !D :j mins Detailsi

Flows Initistor ID | Duration

SystemTestConnector_Fri Jul 09 20:08:03 C5T 2004129 0 hrs, 0 mins, 3 secs
~Flows Control

Buffered Events: O Blocked Status: false

Max Event Capacity: 2147483647 Events Pending in DE: O
1m Tl
|
;!
el
2 1
Queued Current ratefeventsiming - Max number of concurrent events configured: 1
1 0 6.0 Mean service time (sec): 12.156323943661972

5. Navigate to and open the /ProductDir/Samples/SystemTest/data folder, which is
the default installation path for IBM WebSphere Business Integration Server
Express on your machine, to view the files created by the connector as it
processes the data.

6. After allowing the interface to run for several minutes, right-click
SystemTestConnector in the InterChange Server Component Management view
in System Manager, and then click Shut Down SystemTestConnector.

After you have completed these instructions, you have verified that InterChange
Server Express starts and that the major components of the integration system can
deploy, start, process business data, and be shut down. This indicates that the
system is installed correctly and can support subsequent development, testing, and
production

Taking the next step
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You must, however, clean up the business objects in your installation before using
IBM WebSphere Business Integration Server Express. Go to [Chapter 5, “Cleaning]
fup the business objects,” on page 33 and follow the instructions provided for
importing the BIA_BO_BaseCollabBOs.jar package file into the WBIExpressLibrary
integration component library, and then deploying the Customer and Employee
business objects to the server.




Chapter 5. Cleaning up the business objects

After successfully validating your system, you must “clean up” the business
objects. To do this, import the BIA_BO_BaseCollabBOs jar package file into the
WBIExpressLibrary integration component library, and then deploy the Customer
and Employee business objects to the server.

This chapter includes the following sections:

“Importing the BIA_BO_BaseCollabBOs.jar package file”|

“Deploying the Customer and Employee business objects to the server” on page|

“Taking the next steps” on page 34|

Importing the BIA_BO_BaseCollabBOs.jar package file

Do the following to import the BIA_BO_BaseCollabBOs jar file into the
WBIExpressLibrary integration component library:

Important: If there are components with the same name as those in the package
you are importing, System Manager overwrites the existing components without a
warning.

1.

4.

© Copyright IBM Corp. 2004

In System Manager, right-click the WBIExpressLibrary integration component
library, and then click Importfrom Repository File in the context menu

System Manager displays the “Import Repository File” wizard.
At the “Import Repository File” screen, ensure that the “Integration Component

Library Name” drop-down menu contains the name of the library into which
you want to import the components.

If you launched the “Import from Repository File” wizard from a library other
than the one into which you want to import the components, you can change
the destination this way instead of closing the wizard and launching it again.
Windows platforms: Click Browse next to the “InterChange server repository
file” field, and then select the BIA_BO_BaseCollabBOs.jar file in the
ProductDir\repository folder.

Linux platform: Click Browse next to the “InterChange server repository file”
field, and then select the BIA_BO_BaseCollabBOs.jar file in the
ProductDir/repository folder.

0S/400 platform:
a. Map a drive to the OS/400 system.

b. Right-click My Computer on your desktop, and then select Map Network
Drive.

c. From the “Map Network Drive” graphical user interface, select a drive
letter, and then type the following in the folder field: \\o0s400Name\root
where 0s400Name is the name of the OS/400 system or its IP address.

d. Click Browse next to the “InterChange server repository file” field, and
then navigate to the mapped drive and select the
BIA_BO_BaseCollabBOs.jar file in the
\QIBM\ProdData\WBIServer43\ product\repository\ directory.

Click Finish.
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Important: Do not use the File > Import menu item in the Workbench to import a
package file. Although the “Zip file” wizard works with archives with the jar
extension, and InterChange Server Express package files have a jar extension, the
“Zip file” wizard does not work properly with package files.

Deploying the Customer and Employee business objects to the server

You can deploy components to an InterChange Server Express instance using

drag-and-drop.

1. Make sure that InterChange Server Express is started and that System Manager
is connected to it.

2. In System Manager, expand Integration Component Libraries >
WBIExpressLibrary > Business Objects. Select the Customer business object.

3. Press and hold Ctrl.

4. Scroll down and select the Employee business object.

5. Drag-and-drop the selected business objects onto the WebSpherelCS instance of
InterChange Server in the InterChange Server Component Management view,
to deploy them.

Taking the next steps
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After completing the instructions provided in this document, see the documents
listed below to learn more about what to do next.

* For information about the IBM WebSphere Business Integration Server Express
product and the steps necessary to implement a solution, see the System
Implementation Guide.

 For information about installing the optional Adapter or Collaboration Capacity
Packs, available only with the IBM WebSphere Business Integration Server
Express Plus product, see the installation guide for your platform: WebSphere
Business Integration Server Express Installation Guide for Windows, WebSphere
Business Integration Server Express Installation Guide for OS/400, or WebSphere
Business Integration Server Express Installation Guide for Linux.

* For information about performing the final configuration tasks for your
implementation, including configuration of the adapters installed with IBM
WebSphere Business Integration Server Express and the optional Adapter
Capacity Pack, see the installation guide for your platform: WebSphere Business
Integration Server Express Installation Guide for Windows, WebSphere Business
Integration Server Express Installation Guide for OS/400, or WebSphere Business
Integration Server Express Installation Guide for Linux.
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Notices

IBM may not offer the products, services, or features discussed in this document in
all countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing IBM Corporation North Castle Drive Armonk, NY
10504-1785 U.S.A.

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or program(s) described in this publication
at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Burlingame Laboratory Director IBM Burlingame Laboratory 577 Airport
Blvd., Suite 800 Burlingame, CA 94010 U.S.A
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Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurement may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not necessarily tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

This information may contain examples of data and reports used in daily business

operations. To illustrate them as completely as possible, the examples may include

the names of individuals, companies, brands, and products. All of these names are

fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

COPYRIGHT LICENSE

This information may contain sample application programs in source language,
which illustrates programming techniques on various operating platforms. You
may copy, modify, and distribute these sample programs in any form without
payment to IBM, for the purposes of developing, using, marketing or distributing
application programs conforming to the application programming interface for the
operating platform for which the sample programs are written. These examples
have not been thoroughly tested under all conditions. IBM, therefore, cannot
guarantee or imply reliability, serviceability, or function of these programs.

Programming interface information

Programming interface information, if provided, is intended to help you create
application software using this program

General-use programming interfaces allow you to write application software that
obtain the services of this program’s tools.

However, this information may also contain diagnosis, modification, and tuning
information. Diagnosis, modification and tuning information is provided to help
you debug your application software.



Note: Do not use this diagnosis, modification, and tuning information as a
programming interface because it is subject to change.

Trademarks and service marks

The following terms are trademarks or registered trademarks of International
Business Machines Corporation in the United States or other countries, or both:

IBM

the IBM logo
AIX
CrossWorlds
DB2

DB2 Universal Database
Domino

Lotus

Lotus Notes
MQIntegrator
MQSeries
Tivoli
WebSphere

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

MMX, Pentium, and ProShare are trademarks or registered trademarks of Intel
Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Linux is a trademark of Linus Torvalds in the United States, other countries, or
both.

Other company, product or service names may be trademarks or service marks of
others.

This product includes software developed by the Eclipse Project
(http:/ /www.eclipse.org/).

Faw
JAVA,

WebSphere Business Integration Server Express V4.3.1 and WebSphere Business
Integration Server Express Plus V4.3.1
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