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About this document

The IBM® WebSphere™ Business Integration Express for Item Synchronization
product includes InterChange Server Express, the associated Toolset Express
product, the Item Synchronization collaboration, and a set of software integration
adapters. Together they provide business process integration and connectivity
among leading e-business technologies and enterprise applications as well as
integration with the UCCnet GLOBALregistry.

This document provide an overview of the configuration procedures required after
you have installed WebSphere Business Integration Express for Item
Synchronization.

Audience

This document is for anyone who develops components for WebSphere Business
Integration Express for Item Synchronization system.

Related documents

The complete set of documentation describes the features and components
common to all WebSphere Business Integration Express for Item Synchronization
installations, and includes reference material on specific components.

You can install the documentation or read it directly online at one of the following
site:
http://www.ibm.com/websphere/wbiitemsync/express/infocenter

The site contains simple directions for downloading, installing, and viewing the
documentation.

Conventions used in this guide

This document uses these abbreviations and style conventions:

* Abbreviations are used for some words and some variables in syntax statements.
These abbreviations are used:

App = name of application Gen = generic

Attr = name of attribute ICS = InterChange Server Express

BO* = business object (prefix to a BO file) ObjectName* = variable name for business
object

Collab = collaboration Src = source

Dest = destination application

* B0 is the prefix to a BO file; the term BO generally refers to the business object
definition text files. ObjectName refers to the variables used to represent business
objects.

¢ The term “camelcase,” used in this document, refers to a style of capitalization
whereby the spaces between words are eliminated, and the first letter of each
word (or more than one letter if using acronyms) is capitalized. For example, the
collaboration template name DemandForecastVer?2 is in camelcase.
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In addition, this document uses the following typographical conventions:

courier font Indicates a literal value, such as a command name, filename,
information that you type, or information that the system
prints on the screen.

italic Indicates a variable name or a cross-reference.

blue outline A blue outline, which is visible only when you view the
manual online, indicates a cross-reference hyperlink. Click
inside the outline to jump to the object of the reference.




Quick Start Guide

Important: Before you begin using this guide, be certain that you have
downloaded the most recent version of this guide from the WebSphere
Business Integration Express for Item Sync InfoCenter:
http:/ /www.ibm.com/websphere /wbiitemsync/express/infocenter

You should be using a version dated 100ctober2003 or later.

This document provides a roadmap of the required procedures for configuring
your WebSphere Business Integration Express for Item Synchronization system.
This document assumes that you have successfully installed the WebSphere
Business Integration Express for Item Synchronization product. If you have not yet
installed the WebSphere Business Integration Express for Item Synchronization
product, see Installing WebSphere Business Integration Express for Item Synchronization.

This chapter includes the following sections:

+ |“Contacting IBM WebSphere Business Integration Express for Item|
Synchronization Support”|

* [“Finding help”

+ |[“Configuration required after installation” on page 2|

+ |“Administration” on page 38|

Contacting IBM WebSphere Business Integration Express for ltem
Synchronization Support

For support issues relating to the WebSphere Business Integration Express for Item
Synchronization product, you can contact IBM Customer Support in one of the
following ways:

* Visit the IBM WebSphere Business Integration Express for Item Synchronization
technical support Web site at: www.ibm.com/software/support/.

* To contact IBM WebSphere Business Integration Express for Item
Synchronization support via phone, call: 1-800-IBM-SERV (USA /Canada) or (for
non-USA) refer to http://techsupport.services.ibm.com/guides/contacts.html for
number in your geographic area.

Finding help

If you need more information regarding your WebSphere Business Integration
Express for Item Synchronization system, refer to:

. f’Tools help,”l or

» |“WebSphere Business Integration Express for Item Synchronization|
documentation” on page 2|

Tools help

To access context sensitive help for any of the Express tools, click F1.
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WebSphere Business Integration Express for Item
Synchronization documentation

To access both the documentation and the content-sensitive help for WebSphere
Business Integration Express for Item Synchronization, you must download the
document viewer, and the documentation files, and the help from the IBM
InfoCenter. If you have not already done so, go and download that documentation
from the following Web site:

http://www.ibm.com/websphere/wbiitemsync/express/infocenter

The IBM WebSphere Business Integration Express for Item Synchronization
documentation set includes:

Table 1. WebSphere Business Integration Express for Item Synchronization documentation set

Title

Description

Map Development Guide

Business Object Development Guide
User Guide for WebSphere Business
Integration Express for Item
Synchronization

Installing WebSphere Business
Integration Express for Item
Synchronization

Quick Start Guide

Adapter for JDBC User Guide
Adapter for JText User Guide
Adapter for JMS User Guide
Adapter for WebSphere MQ User
Guide

Adapter for XML User Guide
Adapter for Web Services User Guide
Adapter for iSoft/MQ User Guide

Adapter for e-Mail User Guide

Describes how to use Map Designer Express and Relationship Designer
Express for creating and modifying maps and relationships.

Describes how to use Business Object Designer Express to create business
object definitions, both manually and using an Object Discovery Agent
(ODA).

Provides an overview of the product and describes how to monitor and
operate WebSphere Business Integration Express for Item Synchronization.

Describes the installation process for WebSphere Business Integration Express
for Item Synchronization.

Describes the required procedures for configuring your WebSphere Business
Integration Express for Item Synchronization system.

Describes the configuration and business object development for the adapter
for JDBC.

Describes the configuration and business object development for the adapter
for JText.

Describes the configuration and business object development for the adapter
for JMS.

Describes the configuration and business object development for the adapter
for WebSphere MQ.

Describes the configuration and business object development for the adapter
for XML.

Describes the configuration and business object development for the adapter
for Web Services.

Describes the configuration and business object development for the adapter
for iSoft.

Describes the configuration and business object development for the adapter
for e-Mail.

Configuration required after installation

This section provides a high-level overview of the configuration procedures
required after you have successfully installed WebSphere Business Integration
Express for Item Synchronization software:

* [‘Starting System Manager” on page 3|
o [“Verifying your components” on page ﬂ

+ [“Creating the logging table” on page 4|

+ |[“Configuring the XML data handler” on page 6|
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« |"Configuring other business objects” on page 10|

+ |"Developing business objects” on page 13|

* |"Modifying an existing business object” on page 15|

+ |“Configuring the connectors” on page 16|

+ |“Creating collaboration objects” on page 24

» |“Deploying the solution” on page 35|

» |“Populating the relationships after deployment” on page 37|

+ |“Restarting ICS Express and starting your Adapter” on page 3§

Starting System Manager

After you have finished running the Installer, you are ready to perform the final
tasks for setting up your business integration system.

1. Start System Manager

The System Manager interface is the starting point for most of the tasks needed
to complete the setup of your business integration system. To begin, do this:

a. Choose Start > Programs > IBM WebSphere Business Integration for Item
Sync Express. v4.3 > InterChange Server Express to start InterChange Server
Express. In order for System Manager to move data into and out of the
repository that defines your business integration components, InterChange
Server Express must be running, and System Manager must connect to it.

b. After InterChange Server Express has started, choose Start > Programs >
IBM WebSphere Business Integration for Item Sync Express. v4.3 > Tools >
Administrative > System Manager.

The System Manager environment displays.

Note: The first time you start up, you might see the Resource environment
displayed, instead of System Manager. If this happens, in the
Resource menu choose Window > Open Perspective > Other, and
choose System Manager from the Select Perspective dropdown list.

In the InterChange Server Express panel at the lower left portion of the
display, right-click on the displayed InterChange Server Express to verify
that it is connected. If it is not connected, you may need to register the
server (by choosing Server > Register Servers from the menu) and then
connect to it. By default, the server you are using is named WebSpherelCS,
and the username/password combination for registering and connecting to
it is:

admin/null

For more information regarding System Manager, see the following: User Guide
for WebSphere Business Integration Express for Item Synchronization.

Verifying your components

Most of the components necessary for implementing the ItemSync solution have
already been created for you and are loaded into InterChange Server Express and
imported into System Manager when you run the Installer. There are some
additional components that you must create.

After you have connected to InterChange Server Express, you can view the
integration components that the Installer has already made available to you. To do
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so, in the upper left panel of System Manager, expand the icon for the
ItemSyncLibrary integration component library, which resides under the
Integration Component Libraries folder.

Three types of content are provided for you in ItemSyncLibrary: business objects,
collaboration templates, and maps. To complete the setup of your business
integration system, you will create some additional components, save them in
ItemSyncLibrary, and then create a System Manager user project that contains the
components. Then you will deploy that user project to InterChange Server Express.

In addition to the components already visible in ItemSyncLibrary, several
connector configuration templates are provided to you. These include the
templates for the iSoft connector (used for sending data to and receiving data from
a UCCnet-compliant trading partner), the eMail connector (used primarily for
administrative and error messages), and the JText connector (typically used for
extracting data from and sending data to your legacy application). Icons for these
connectors will become visible in the Integration Components Library after you
have configured them, as described in [‘Configuring the connectors” on page 16/
later in this chapter.

You will need to create or configure some additional components. These tasks are
described later in this guide.

Creating the logging table

4 Quick Start Guide

The WebSphere Business Integration Express for Item Sync system uses a database
table called audit_Tog to track events associated with UCCnet activities. For more
information on the use of this table, see the Collaboration for UCCnet Item
Synchronization.

To create the audit_log table, complete the following steps:

1. Create the audit_log table in the ICS repository. Use the script appropriate to
your database server.

DB2 Database Server

a. Move to the following directory:
ProductDir\collaborations\dependencies\UCCnet\db2

b. Start a DB2 session by entering the following command:
db2

C. At the prompt, enter the following comment
connect to SMB_DB

d. After you are connected, enter the following command to run the script that
creates the audit_log table:

audit_Tlog.sql

Microsoft SQL Server

a. Start the Query Analyzer with Start > Programs > Microsoft SQL Server >
Query Analyzer. Query Analyzer displays the Connect to SQL Server dialog.

b. Make sure that the SQL Server authentication radio button is selected and
log into the ICS database server with the following default account
information:

Account: smbadmin

Password: smbP4$$word



e.

f.

Note: This account information is the default database user account that the
WebSphere Business Integration Express for Item Sync Installer
creates. If you have modified this account since it was created, use
the current account information.

Select the ICS repository database by selecting the SMB_DB database from
the dropdown menu in the Query Analyzer toolbar.

Load the audit_Tog.sql SQL script into the Query Analyzer with File >
Open. This script is located in the following directory:

ProductDir\collaborations\dependencies\UCCnet\mss
Run the audit_Tlog.sql script with Query > Execute.

Leave Query Analyzer open for use in a later step.

2. Add the UCCnet property to the ICS configuration file, InterchangeSystem.cfg.
The audit_log feature requires that these properties exist and have values for it
to execute correctly.

a.

f.

Table 2. UCCnet subproperties

Create a backup copy of your InterchangeSystem.cfg file, which resides in
the ProductDir directory. A suggested name for the backup copy is:

InterchangeSystem orig.cfg
Bring up the following file in an editor:
ProductDir\samples\UCCnet\InterchangeSystem.UCCnet

Note: You can use a text editor or an XML editor to edit this file. However,
do not use the Notepad editor.

Copy the entire contents of this InterchangeSystem.UCCnet file into an

editor buffer. This file contains the XML definition of the UCCnet property

and its subproperties.

Bring up the InterchangeSystem.cfg file into the editor.

Move to the bottom of the InterchangeSystem.cfg file and paste the contents

of the editor buffer (the definition of the UCCnet property) into this file, just

before the </cw:ServerConfig> tag near the end of the file.

Modify the values for the UCCnet subproperties as shown in to

identify your ICS repository.

UCCnet subproperty Value
USER_NAME smbadmin
PASSWORD smbP4$$word
DRIVER For a DB2

DATA_SOURCE_NAME

database:COM.ibm.db2.jdbc.app.DB2Driver

For a MicrosoftSQL Server database:

com.ibm.jdbc.sqlserver.SQLServerDriver
For a DB2 database:

jdbc:db2:SMB_DB

For a Microsoft SQL Server database:

jdbc_ibm.crossworlds:sqlserver://machine_name:1433;
DatabaseName=SMB_DB

(where machine_name is the name of the host machine on which your ICS
repository resides)

g.

Save the InterchangeSystem.cfg file and exit the editor.
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Note: The new UCCnet properties do not take effect until you reboot your

InterChange Server.

Configuring the XML data handler

To enable the WebSphere Business Integration Express for Item Sync system to
properly process UCCnet XML messages, you must configure meta-objects for the
Data Handler for XML (the XML data handler). Several components of the system
use the XML data handler. This data handler uses a meta-object, which is a kind of
business object, to hold its configuration information.

To configure use of the XML data handler, complete the following steps:

1. Create the meta-object for the UCCnet version of the XML data handler,
MO DataHandler_UCCnetXMLConfig:

a.

f.

Within Windows Explorer, navigate to the following folder on your system:
ProductDir\repository\DataHandlers

Copy the text representation of the meta-object file for the XML data
handler (MO_DataHandler_XML.txt) and rename it to:
MO_DataHandler_UCCnetXML.txt

Bring up the MO_DataHandler_UCCnetXML.txt file into a text editor and
change the second line (the line after "[BusinessObject Definition]”) from:
MO_DataHandTer_DefaultXMLConfig

to

MO_DataHandTer_UCCnetXMLConfig

Launch Business Object Designer. If the New Business Object Definition
dialog appears, click Cancel.

Import the meta-object file for the UCCnet XML data handler into Business
Object Designer with File > Open From File. For information on how to
import a text representation of a business object into Business Object
Designer, see ["Developing business objects” on page 13/

Once you import this text file, Business Object Designer displays the
MO_DataHandler_UCCnetXMLConfig business object definition.

Edit the MO_DataHandler_UCCnetXMLConfig meta-object by setting the
Default values of the attributes shown in

Table 3. Default values for properties in MO_DataHandler_UCCnetXMLConfig

Attribute name

Default value

BOPrefix

For DTD support:
UCCnetDTD

For schema-document support:
UCCnetXSD
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Table 3. Default values for properties in MO_DataHandler_UCCnetXMLConfig (continued)

Attribute name Default value

DTDPath Full path to the XML-structure document: For DTD XML
definition type:
Envelope.dtd

For schema-document support XML definition type:
Envelope.xsd

The Envelope structure document is available from the UCCnet
web site. To download these files, you must have a valid
UCCnet user ID and password.

Validation false
DefaultEscapeBehavior true
IgnoreUndefinedElements true

g. Save the MO_DataHandler_UCCnetXMLConfig meta-object with File >
Save.

h. Close the MO_DataHandler_UCCnetXMLConfig meta-object with File >
Close. However do not exit Business Object Designer.

2. Create the meta-object for the UCCnet XML configuration,
MO_DataHandler_UCCnet_envelope:
a. Within Windows Explorer, navigate to the following folder on your system:
ProductDir\repository\DataHandlers
b. Copy the text representation of the meta-object file for the all data handlers

(MO_DataHandler_Default.txt) and rename it to:
MO_DataHandler_ UCCnet.txt

¢. Bring up the MO_DataHandler_UCCnet.txt file into a text editor and change
the second line (the line after "[BusinessObject Definition]”) from:
MO_DataHandler_ Default

to
MO_DataHandler_UCCnet_envelope

d. In Business Object Designer, import the meta-object file for the UCCnet
XML data handler with File > Open From File. For information on how to
import a text representation of a business object into Business Object
Designer, see [‘Developing business objects” on page 13,Once you import
this text file, Business Object Designer displays the
MO_DataHandler_UCCnet_envelope business object definition.

e. Edit the MO_DataHandler_UCCnet_envelope meta-object by setting the
Type value text_xml of the attribute, as shown in

Table 4. Attribute type for MO_DataHandler_UCCnet_envelope

Attribute name Type value
text_xml MO_DataHandler_UCCnetXMLConfig

f. Remove all other attributes in the MO_DataHandler_UCCnet_envelope
meta-object. The only attribute remaining should be text_xml.

g. Save the MO_DataHandler_UCCnet_envelope meta-object with File > Save.

h. Close the MO_DataHandler_UCCnet_envelope meta-object with File >
Close. However, do not exit Business Object Designer.
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3. Create the meta-object for the JTextRWL XML configuration,

MO_JTextRWLConnector_Default:

a. Within Windows Explorer, navigate to the following folder on your system:
ProductDir\repository\JText

b. Copy the text representation of the meta-object file for the JText data
handler (MO_JText_Default.txt) and rename it to:
MO_JTextRWLConnector.txt

c. Bring up the MO_JTextRWLConnector.txt file into a text editor and change
the second line (the line after "[BusinessObject Definition]”) from:
MO_JTextConnector Default

to
MO _JTextRWLConnector Default

d. In Business Object Designer, import the meta-object file for the JTextRWL
XML data handler with File > Open From File. For information on how to
import a text representation of a business object into Business Object
Designer, see [“Developing business objects” on page 13 Once you import
this text file, Business Object Designer displays the
MO_]JTextRWLConnector_Default business object definition.

e. Edit the MO_]JTextRWLConnector_Default meta-object by setting the Type
value of the attributes shown in .

Table 5. Attribute types for MO_JTextRWLConnector_Default

Attribute name Type value
EventDataHandler MO_DataHandler_UCCnetXMLConfig
OutputDataHandler MO_DataHandler_UCCnetXMLConfig

f. Edit the MO_]TextISoftConnector_Default meta-object by setting the Default
values of the attributes shown in the following table.

Table 6. Default property values for MO_JTextRWLConnector_Default

Attribute name Default value

OutputDir Name of the directory where the JTextRWLConnector is to write the XML files it
generates. For example:

C:\IBM\WebSphereltemSync\UCCnet\JTextRWL\out

If the output directory you specify does not already exist, create it.

OutputExt xml
ArchiveDir Name of the directory where the JTextRWLConnector archives events (XML files). For
example:

C:\IBM\WebSphereltemSync\UCCnet\JTextRWL\archive

If the archive directory you specify does not already exist, create it.
Name of the directory from which the JTextRWLConnector obtains input events (XML

EventDir
files). For example:
C:\IBM\WebSphereltemSync\UCCnet\JTextRWL\event
If the event directory you specify does not already exist, create it.
EventExt xml
EndBODelimiter EOF

g. Save the MO_]JTextRWLConnector_Default meta-object with File > Save.
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h. Close the MO_JTextRWLConnector_Default meta-object with File > Close.
However, do not exit Business Object Designer.

i. Save the MO_]JTextISoftConnector_Default meta-object with File > Save.

j. Close the MO_JTextISoftConnector_Default meta-object with File > Close.
However, do not close Business Object Designer.

4. If you are exchanging messages through the UCCnet CLU or testing your
installation, you must create a meta-object for the JTextISoft XML configuration,
MO_]JTextISoftConnector_Default:

a. Within Windows Explorer, navigate to the following folder on your system:
ProductDir\repository\JText

b. Copy the text representation of the meta-object file for the JTextRWL data
handler (MO_JTextRWLConnector.txt) and rename it to:

MO_JTextISoftConnector.txt

c. Bring up the MO_JTextISoftConnector.txt file into a text editor and change
the second line (the line after "[BusinessObject Definition]”) from:

MO_JTextRWLConnector_Default

to
MO JTextISoftConnector Default

d. In Business Object Designer, import the meta-object file for the JTextISoft
XML data handler with File > Open From File.
Once you import this text file, Business Object Designer displays the
MO_]JTextISoftConnector_Default business object definition.

e. Edit the MO_]TextISoftConnector_Default meta-object by setting the Type
value of the attributes shown in [Table 5 on page 8

f. Edit the MO_]JTextISoftConnector_Default meta-object by setting the Default
values of the attributes shown in

Table 7. Default property values for MO_JTextISoftConnector

Attribute name Default value

OutputDir Name of the directory where the JTextISoftConnector is to write the XML files it
generates. For example:

C:\IBM\WebSphereItemSync\UCCnet\JTextISoft\out

If the output directory you specify does not already exist, create it.

OutputExt xml
ArchiveDir Name of the directory where the JTextISoftConnector archives events (XML files). For
example:

C:\IBM\WebSphereItemSync\UCCnet\JTextISoft\archive

If the archive directory you specify does not already exist, create it.
EventDir Name of the directory from which the JTextISoftConnector obtains input events (XML
files). For example:

C:\IBM\WebSphereltemSync\UCCnet\JTextISoft\event

If the event directory you specify does not already exist, create it.
EventExt xml
EndBODelimiter EOF

g. Save the MO_JTextISoftConnector_Default meta-object with File > Save.
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h. Close the MO_JTextISoftConnector_Default meta-object with File > Close.
However, do not close Business Object Designer.

Configuring other business objects

In addition to the creation and configuration of business objects for the XML
data-handler meta-objects, you also need to configure business objects for the
following other components:

* SoftConnector

¢ EMailConnector

Configuring a business object for iSoftConnector

If you are exchanging messages with UCCnet through an AS2/EDIINT interface
protocol, you must create a meta-object called MO_ISoftAdapterConfig for the iSoft
connector:

1. In Business Object Designer, create the new meta-object for the iSoft adapter
with File > New. In the Business Object Name field, enter
MO_ISoftAdapter Config and click OK.

2. Add the attributes in to the MO_ISoftAdapter_Config meta-object:
Table 8. Attributes in MO_ISoftAdapter_Config

Attribute name Type Key Application-specific information

Default String Yes The output queue, where messages derived from the business
object definitions listed in this meta-object are delivered. For
example:

OutputQueue=queue://crossworlds. queue.manager/
outbox_queue_name; DataEncoding=Text

(where outbox_queue_name identifies where these messages
are delivered)

The output queue specified in this Default attribute applies to
all business-object conversions.

UCCnet_envelope_ String No If the application-specific information that you provided for
Create the Default attribute (above) is insufficient to identify the
business-object configuration properties for the
UCCnet_envelope business object, you can provide any
additional information that might be required here. For more
information about the format of this application-specific
information, see the Adapter Guide for iSoft.

For more information on how to create a new business object definition in
Business Object Designer, see [“Developing business objects” on page 13}

3. Save the MO_ISoftAdapterConfig meta-object with File > Save.

4. Close the MO_ISoftAdapterConfig meta-object with File > Close. However, do
not exit Business Object Designer.

Configuring a business object for EMailConnector
The EmailConnector handles messages for events that occur during the execution

of the Item Sync collaboration. It uses a business object definition called
EmailNotification to hold its configuration information.

To configure the EmailConnector, complete the following steps:

1. Bring up the EmailNotification business object definition in Business Object
Designer. For information on how to edit an existing business object definition,
sed“Developing business objects” on page 13
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2. Set the Default Values for the following attributes to identify where the Item
Sync collaboration directs email messages during its execution.

Table 9. Default property values for EmailNotification

Attribute name Default value Required
RecipientName Email address of recipient Yes. For information on how to specify the
message recipients, see the Adapter Guide for
e-Mail.
FromAddress Email address of undelivered No
messages

3. Save the business object definition to the ItemSyncLibrary project with the File
> Save menu option.

4. Close the EmailNotification business object definition with File > Close.
However, do not exit Business Object Designer.

Creating the ERP-source components

Your item information originates from your Enterprise Resource Planning (ERP)
application. As the first step to sending this item information to UCCnet, an
ERP-source connector receives information from your ERP application and takes
the following steps:

1. It formats this information into the appropriate application-specific business
object. For this step to be possible, a business object definition for this
application-specific business object must exist and must define the item
information that the ERP-source connector receives.

2. It converts the data in the application-specific business object to its equivalent
format in the generic business object, ItemBasic. For this step to be possible, a
map must exist to define the data transformations necessary.

Note: As part of creating ERP-source components, you must also create an
ERP-source connector. For more information, see [‘Creating the ERP-source|

components.”

Creating ERP-source business objects

The ERP-source business object is an application-specific business object that
contains the item information your ERP application needs sent to UCCnet. For the
ERP-source connector to create such a business object, it must be able to locate an
associated business object definition, which the connector uses as a template for
the business object creation. Therefore, as part of the Item Sync configuration
process, you must create business object definitions to represent the item
information that your ERP application must send to UCCnet.

To create a business object definition, use the Business Object Designer tool. This
tool provides a graphical interface that assists you in naming the business object
definition and defining its attributes. When you design your ERP-source business
object definition, you must determine which item information needs to be sent to
UCCnet. To assist in this determination, you can examine the information in the
generic item-information business object, ItemBasic.

The basic steps to creating the business object definition for your
application-specific business object are as follows:

Quick Start Guide 11
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1. Launch Business Object Designer to create a new business object definition. In
System Manager, you can right-click on the Business Objects folder under the
ItemSyncLibrary project. Alternatively, you can select the Tools > Business
Object Designer menu option.

2. Specify the name of the business object definition in Business Object Name
field and click OK. Business Object Designer displays a template for you to
define the attributes of the business object definition.

3. Define the required attributes, including their names, types, and any
application-specific information. One attribute with the business object
definition must be designated as the key, whose value contains information to
uniquely identify one business object of this type from another.

4. Save the business object definition with File > Save.

5. If your business object definition requires child business objects, repeat these
steps to define each of the child business objects.

For a more complete description of Business Object Designer and how to create a
business object definition, see [“Developing business objects” on page 13/

Creating ERP-source maps

Once the ERP-source connector has created the application-specific business object,
the item information is ready to be sent to InterChange Server Express. There, any
application-specific formats of data in this business object are converted to the data
format used the associated generic business object, ItemBasic. It is the generic
business object that InterChange Server Express routes to various components of
the Item Sync system. To provide this data conversion, you must create a map that
describes the data transformations necessary to convert the data from any
application-specific formats to their generic equivalents.

To create a map, use the Map Designer tool. This tool provides a graphical
interface that assists you in naming the map and defining its transformation. When
you design your ERP-source map, you must determine which item information is
currently in an application-specific format; that is, which data is in a format
different from its equivalent in the generic business object. To assist in this
determination, you can examine the information in the generic item-information
business object, ItemBasic.

The basic steps to creating the map from your application-specific business object

to the ItemBasic generic business object are as follows:

1. Launch Map Designer to create a new map. In System Manager, you can
right-click on the Maps folder under the ItemSyncLibrary project. Alternatively,
you can select the Tools > Map Designer menu option.

2. Select ItemSyncLibrary as the project in which to store the map and click Next.

3. Choose the name of the business object definition that is the source for the map
and Click Next. This source business object definition is the name of the
application-specific business object that holds your ERP item information.

4. Choose the name of the business object definition that is the destination for the
map and Click Next. For the top-level ERP-source map, the destination
business object definition is ItemBasic.

5. In the Save map dialog, take the following steps:

a. Specify a name for the map in the Name field. Map names usually identify
both the source and destination business objects in the following format:

CwSource_to_CwDestination



where Source and Destination are the names of your source and destination
business object definitions, respectively. For example, if your
application-specific business object was named JDBC_ERPItem, the
associated ERP-source map name could be:

CwJDBC_ERPItem to_CwItemBasic

b. Make sure that the Mapping Direction box has the Application-Specific to
Generic radio button selected.

c. Click Finish. Map Designer displays the working area, with your source
business object definition on the left and your destination business object
definition (ItemBasic) on the right.

d. To define the data transformations between attributes in the source and
destination business objects, you can use the basic transformations (such as
Move, Split, and Join). You can also perform transformations on dates and
times. If you need to perform a transformation for which there is no
existing transformation, you can define a custom transformation.

e. When you have completed the definition of transformations, save the map
to the ItemSyncLibrary project with File > Save > To Project.

—h

Answer Yes to the prompt that asks if you want to compile the map.

g. If your application-specific business object definition contains child business
objects, you must create a map for each of the child business objects. Repeat
these steps to define maps for each of the child business objects. Map
names for child business objects usually start with the "Sub” prefix to
indicate a submap.

For a more complete description of Map Designer and how to create a map, see
the Map Development Guide.

Developing business objects

This section provides a roadmap of the basic steps for creating a business object
definition. For complete details about developing a business object definition, see
the Business Object Development Guide.

Creating a business object definition

In the WebSphere business integration system, information sent or received
between components is packaged in the form of a business object. For data that is
transferred between a connector and an integration broker, you design
application-specific business objects that model the appropriate application entities.
Application-specific business objects are modeled during design-time as business
object definitions, which are stored in the business integration system, specifically in
the System Manager Integration Component Library (ICL). At runtime, data is
populated in a business object instance (often just called a “business object”) that is
based on the proper definition, and is moved through the business integration
system as dictated by its routing and business logic rules.

For details about the business object requirements of your specific adapter, refer to
your adapter’s user guide.

There are two ways to create a business object definition:

* Manually—Useful when creating a simple business object, or when modifying a
definition generated by an Object Discovery Agent. Business Object Designer
Express provides a graphic interface for manually creating a business object
definition.

* Using an Object Discovery Agent—Useful when creating an application-specific
business object. The Object Discovery Agent examines specified entities in the
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application, “discovers” the elements of those objects that correspond to business
object attributes and the properties of each attribute, and generates the business
object definition.

Creating a business object manually

1. Launch Business Object Designer Express from System Manager, using a
Windows shortcut, or from another development tool. For details, see Business
Object Development Guide.

2. From the File menu, select New. Business Object Designer Express displays the
New Business Object dialog.

3. Enter the name for the new business object definition.

4. Click OK. Business Object Designer Express displays the business object
definition dialog.

5. Add attributes for each piece of information in the business object.

6. Click the General tab of the business object definition dialog to display the
screen in which you specify the verbs.

7. Specify the verbs that this business object will support. These verbs represent
the triggering events that the business object sends to the integration broker.

8. When you finish defining the business object, click File > Save from the menu
bar to save your changes to the ICL.

Using an Object Discovery Agent to create a business object
definition

An Object Discovery Agent (ODA) is an optional component of an adapter. When
you install a pre-defined adapter that has an ODA, its ODA is installed
automatically. Business Object Designer Express provides a graphical interface in
the form of a wizard, called Business Object Wizard, to interact with the ODA. The
purpose of Business Object Wizard is to display a series of dialogs to the user.
These dialogs obtain information from the user that the ODA needs to generate the
business object content. The ODA is the component that “discovers” objects in the
data source and generates the content. The ODA receives information that the user
provides in the dialogs of Business Object Wizard. It then sends information (such
as the generated content) to the ODA runtime, the intermediary component
between Business Object Wizard and the ODA.

Before using an ODA: Before you run an ODA, verify that the following steps
have occurred (for details, see Business Object Development Guide):

* System startup files (the ODA startup script: start_0DAname.bat and the ODA
environment file: CWODAEnv.bat) are available and correct.

* The ODA has been launched (run start_srcDataNameODA.bat).
* Business Object Designer Express has been launched.

Using the ODA to create business object definitions:
1. Open Business Object Designer Express.
2. From the File menu, click the “New Using ODA” menu item.

Business Object Designer Express invokes Business Object Wizard, which
displays the first dialog in the wizard, Select Agent.

3. Select the ODA to which Business Object Wizard connects.
4. Click Next. Business Object Wizard attempts to connect to the specified ODA.

5. Once Business Object Wizard is connected to the ODA, it displays the second
wizard dialog, Configure Agent.



6. Specify ODA configuration values or select a profile to display previously
saved values.

7. Click Next. Business Object Wizard displays the third wizard dialog, Select
Source.

8. Select objects in the source-code hierarchy for which you want the ODA to
generate business object definitions.

9. After you select the source nodes for which business object definitions are to
be generated, click Next. Business Object Wizard displays the fourth wizard
dialog, which allows you to confirm your selection of source nodes.

10. After confirming your selection, click Next. Business Object Wizard displays
the wizard’s fifth screen, Generating Business Objects.

After the ODA completes the generation of business object definitions,
Business Object Wizard displays the final dialog in the wizard, Save Business
Objects.

11. Click Finish to save the business object definitions to the ICL-based project

For more detailed information, see the following:WebSphere Business Integration
Express for Item Synchronization Business Object Development Guide.

Modifying an existing business object

Some application-specific business objects are provided to you. In some
implementations, you may need to modify them.

You can open a business object definition provided by the adapter and modify it as
needed using Business Object Designer Express. You can also modify any business
object definition you have created. New objects are created in Business Object
Designer Express, with or without the assistance of the ODA. To modify an
existing object, use Business Object Designer Express directly (the ODA cannot be
used to modify an existing business object).

To modify a business object definition:

1. From the list of business object definitions in the project, highlight the name of
the definition you want to open.

2. To select multiple business object definitions in the project, do one of the
following:

* When selecting consecutive names, select the first name and, while pressing
the Shift key, click the last name.

* When selecting non-consecutive names, press the Ctrl key and click as you
select each name.

3. After selecting the definitions to be opened, right-click and then click Open.

Business Object Designer Express displays a window for each selected
definition.

4. Edit the business object definition as needed. For details about the business
object definitions provided with your adapter and the modifications you make
to each, see the documentation of the specific adapter.

5. Save the business object definition:

¢ If the project is ICL-based, the business object definition is saved in the
project where it originated.

e If the project is local, the business object definition is saved to its existing file
(where it was saved when it was created).
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Connector Configurator Express allows you to configure the connector component
of your adapter for use with InterChange Server Express.

You use Connector Configurator Express to:

* Create a connector configuration file -- you must create one configuration file for
each of required connector.

* Set properties in a configuration file -- you may need to modify the default
values that are set for properties in this file. You must also specify supported
business object definitions and, optionally, maps for use with the Item
Synchronization Collaboration.

You use Connector Configurator Express to create this configuration file and to
modify its settings.

Creating required connector configuration files
Your WebSphere Business Integration Express for Item Synchronization system
may require that you install and configure the following connector components:

Table 10. Connectors in the Item Sync solution

Connector Adapter Required?
JTextRWLConnector Based on the Adapter for JText | Yes

iSoftConnector Adapter for iSoft Yes

JTextISoftConnector Based on the Adapter for JText | Yes, if you are using UCCNet

Command Line Utility (CLU)
to communicate with the iSoft
Peer-to-Peer Agent

ERP-source connector One of the following adapters: | Yes
* Adapter for JText

* Adapter for ]MS

» Adapter for JDBC

» Adapter for XML

» Adapter for Web Services

* Adapter for WebSphere MQ

EmailConnector Adapter for e-Mail Yes, if your UCCnet Item
Synchronization collaboration
uses the "notify by email”
feature

PortConnector None Yes

You use Connector Configurator Express to create these files. You start and run
Connector Configurator Express from System Manager. For information on how to
launch, run, and use this tool, see the Connector Configurator Express appendix in
your adapter user guide. If you are configuring files for other connectors, see the
corresponding adapter user guides.

Configuring the JTextRWLConnector

The JTextRWLConnector is the input connector for a UCCnet_requestWorklist
collaboration object. The UCCnet_requestWorklist collaboration object passes a
UCCnet worklist request to UCCnet from a filesystem folder. To poll for the
worklist, a scheduler operation (which the operating system performs) must be
configured to periodically drop a fresh copy of the request XML file into the event
file-system folder for the JTextRWLConnector.



1.

To create the JTextRWLConnector, complete the following steps:

a.
b.

f.

In the Windows taskbar, right-click Start and select Open All Users

Navigate to the folder on your system that contains the installed adapters:
Programs > IBM WebSphere Business Integration Express for Item Sync
v4.3 > Adapters > Connectors

Copy the startup shortcut for the JText connector (JText Connector) and
rename it to: JTextRWL Connector

Right-click the new JTextRWL connector’s startup shortcut and select
Properties

Click the Shortcut tab, edit the Target field to set the first command-line
argument to JTextRWL. The following line shows the JText target before you
edit the argument:

ProductDir\connectors\JText\start_JText.bat JText WebSphereICS

For example, if WebSphere Business Express for Item Sync is installed in
your C: partition, then the initial text for the new startup shortcut would be:

C:\IBM\WebSphereItemSync\connectors\JText\start_JText.bat JText WebSphereICS

In this case, you would change the shortcut so it reads:

C:\IBM\WebSphereItemSync\connectors\JText\
start_JText.bat JTextRWL WebSphereICS

Click OK.

Create the connector configuration file for the JTextRWLConnector using
Connector Configurator Express. For general information on how to launch and
use this tool to create a connector configuration file, see the Connector
Configurator Express appendix in your adapter user guide.

a.

b.

f.

Open System Manager (for further information, see |“Starting System|
[Manager” on page 3)

In the System Manager window, expand the Integration Component
Libraries icon and highlight Connectors.

From the System Manager menu bar, click Tools > Connector Configurator
Express. The Connector Configurator Express window opens and displays a
New Connector dialog box.

In the New Connector dialog, specify JTextRWLConnector in the Name
field. To select the JText connector template, highlight the entry for JText in
the Template Name table. The properties from the JText connector template
display in the Property Template Preview section. When you click OK,
Connector Configurator Express displays the configuration tabs.

In the Standard Properties tab, verify that the ApplicationName property is
set to JTextRWLConnector.

In the Supported Business Objects tab, add the business object definitions
listed in [Table 11

Table 11. Supported business objects for JTextRWLConnector

Agent support
Business object definition required?
MO_JTextRWLConnector_Default Yes
MO_DataHandler_UCCnet_envelope Yes
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Table 11. Supported business objects for JTextRWLConnector (continued)

Agent support
Business object definition required?
The UCCnet envelope: Yes
¢ For DTD XML definition type: UCCnetDTD_envelope
* For schema-document support XML definition type:
UCCnetXSD_envelope
UCCnetGBO_envelope No

g. Save the connector configuration file to the ItemSyncLibrary project with the
File > Save > To Project menu option.

h. In the Associated Maps tab, add the maps listed in|Table 12| to the specified
business object definitions.

Table 12. Associated maps for JTextRWLConnector

Business object definition

Name of map

UCCnetDTD_envelope
UCCnetXSD_envelope
UCCnetGBO_envelope

UCCnetDTD_envelope_to_UCCnetGBO_envelope
UCCnetXSD_envelope_to_UCCnetGBO_envelope
For DTD XML definition type:

RouterMap _UCCnetGBO envelope to UCCnetDTD_
envelope

For schema-document XML definition type:

RouterMap_UCCnetGBO_envelope_to_
UCCnetXSD_envelope

3. Save the connector configuration file to the ItemSyncLibrary ICL project with
File > Save > To Project. Close Connector Configurator Express.

Configuring the iSoft Connector
The iSoftConnector is the connector that exchanges messages with UCCnet through

an AS2/EDIINT interface protocol. You need to create a connector configuration
file for the iSoftConnector and configure it to include the appropriate business

objects.

To create the iSoftConnector, complete the following steps:

1. Create the connector configuration file for the iSoftConnector using Connector
Configurator Express. For general information on how to use this tool to create
a connector configuration file, see the Connector Configurator Express
appendix in your adapter guide.

a. In the New Connector dialog, specify iSoftConnector in the Name field. To
select the iSoft connector template, highlight the entry for iSoft in the
Template Name table. The properties from the iSoft connector template
display in the Property Template Preview section. When you click OK,
Connector Configurator Express displays the configuration tabs.

b. In the Connector-Specific Properties tab, verify that the connector-specific
properties are set as shown in [Table 13 on page 19}




Table 13. Connector-specific properties for iSoftConnector

Connector-specific property

Value

ArchiveQueue

Channel

ConfigurationMetaObject
DataHandlerConfigMO
DefaultVerb

ErrorQueue

HostName

InputQueue

InProgressQueue

Port

ReplyToQueue

UnsubscribedQueue

UseDefaults

Queue to which copies of successfully processed
messages are sent. For example:
queue://crossworlds.queue.manager/
MQCONN.ARCHIVE

WebSphere MQ server connector channel for
your iSoft Peer-to-Peer Agent queue manager

MO_ISoftAdapterConfig

MO_DataHandler_UCCnet_envelope

Create

Note: If this connector-specific property does not
appear in the list, add it.

Queue to which messages that could not be
processed are sent. For example:

queue://crossworlds.queue.manager/

MQCONN. ERROR

The name of the host on which the iSoft
Peer-to-Peer Agent WebSphere MQ queue
manager is running

List of queues that the connector polls for new
messages. Queue names are delimited with a
semicolon (;). For example:
queue://crossworlds.queue.manager/
MQCONN.IN1;
queue://crossworlds.queue.manager/MQCONN. IN2
Queue where messages are held during
processing. For example:
queue://crossworlds.queue.manager/

MQCONN. IN_PROGRESS

The port established for the WebSphere MQ
Listener of the iSoft Peer-to-Peer Agent’s queue
manager

Queue to which replies are sent. For example:
queue://crossworlds.queue.manager/
MQCONN.REPLY

Queue to which messages that are not
subscribed are sent. For example:
queue://crossworlds.queue.manager/
MQCONN.UNSUBSCRIBED

True

Note: If this connector-specific property does not
appear in the list, add it.

c. In the Supported Business Objects tab, add the business object definitions
listed in [Table 14

Table 14. Supported business objects for iSoftConnector

Agent support
Business object definition required?
MO_ISoftAdapterConfig Yes
MO_DataHandler_UCCnet_envelope Yes.
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Table 14. Supported business objects for iSoftConnector (continued)

Agent support
Business object definition required?

The UCCnet envelope: Yes
¢ For DTD XML definition type: UCCnetDTD_envelope

* For schema-document support XML definition type:
UCCnetXSD_envelope

UCCnetGBO_envelope No

ItemBasic No

d. Save the connector configuration file to the ItemSyncLibrary project with the
File > Save > To Project menu option.

e. In the Associated Maps tab, add the maps listed in|Table 15 to the specified
business object definitions.

Table 15. Associated maps for iSoftConnector

Business object definition Name of map

UCCnetDTD_envelope UCCnetDTD_envelope_to_UCCnetGBO_envelope
UCCnetXSD_envelope UCCnetXSD_envelope_to_UCCnetGBO_envelope
UCCnetGBO_envelope For DTD XML definition type:

RouterMap_UCCnetGBO_envelope_to_
UCCnetDTD_enveTlope

For schema-document XML definition type:

RouterMap_UCCnetGBO_envelope_to
_UCCnetXSD_envelope

ItemBasic For DTD XML definition type:

RouterMap_CwItemBasic_to_
UCCnetDTD_envelope

For schema-document XML definition type:

CwItemBasic_to_UCCnetXSD_envelope_
registerCommand_itemAddChange

2. Save the connector configuration file to the ItemSyncLibrary ICL project with
File > Save > To Project. Close Connector Configurator Express.

For further information, see the Adapter for iSoft Peer-to-Peer Agent User Guide.

Configuring the JTextlSoftConnector

If you are using the UCCnet Command Line Utility (CLU) to communicate with
UCCnet, you must create and configure the JTextISoftConnector. This connector is
a copy of the JTextConnector that simulates the iSoftConnector. Like the
iSoftConnector, the JTextISoftConnector uses the IBM WebSphere Business
Integration Data Handler for XML and generates the same XML output.

To create the JTextISoftConnector, complete the following steps:
1. Create the Windows shortcut to start up this connector, as follows:
a. In the Windows taskbar, right-click Start and select Open All Users

b. Navigate to the folder on your system that contains the installed adapters:
Programs > IBM WebSphere Business Integration Express for Item Sync
v4.3 > Adapters > Connectors

c. Copy the startup shortcut for the JText connector (JText Connector) and
rename it to: JTextISoftConnector
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d. Right-click the new JTextISoft connector’s startup shortcut and select
Properties

e. Click the Shortcut tab, edit the Target field to set the first command-line
argument to JTextISoft. The following line shows the JText target before you
edit the argument:

ProductDir\connectors\JText\start_JText.bat JText WebSphereICS

where ProductDir is the name of the directory in which WebSphere Business
Integration Express for Item Sync is installed. For example, if WebSphere
Business Express for Item Sync is installed in your C: partition, then the
initial text for the new startup shortcut would be:

C:\IBM\WebSphereItemSync\connectors\JText\
start_JText.bat JText WebSphereICS

In this case, you would change the shortcut so it reads:

C:\IBM\WebSphereItemSync\connectors\JText\
start_JText.bat JTextISoft WebSphereICS

f. Click OK.

2. Create the connector configuration file for the JTextISoftConnector using
Connector Configurator Express. For general information on how to use this
tool to create a connector configuration file, see the Connector Configurator
Express appendix in your adapter guide.

a. In the New Connector dialog, specify JTextISoftConnector in the Name
field. To select the JText connector template, highlight the entry for JText in
the Template Name table. The properties from the JText connector template
display in the Property Template Preview section. When you click OK,
Connector Configurator Express displays the configuration tabs.

b. In the Standard Properties tab, verify that the ApplicationName property is
set to JTextISoftConnector.

c. In the Supported Business Objects tab, add the business object definitions
listed in [Table 16

Table 16. Supported business objects for JTextISoftConnector

Agent support

Business object definition required?
MO_JTextISoftConnector_Default Yes
MO_DataHandler_UCCnet_envelope Yes
The UCCnet envelope: Yes

* For DTD XML definition type: UCCnetDTD_envelope

* For schema-document support XML definition type:
UCCnetXSD_envelope

UCCnetGBO_envelope No

ItemBasic No

d. Save the connector configuration file to the ItemSyncLibrary project with the
File > Save > To Project menu option.

e. In the Associated Maps tab, add the maps listed in|Table 17] to the specified
business object definitions.

Table 17. Associated maps for JTextISoftConnector

Business object definition Name of map

UCCnetDTD_envelope UCCnetDTD_envelope_to_UCCnetGBO_envelope
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Table 17. Associated maps for JTextlSoftConnector (continued)

Business object definition Name of map
UCCnetXSD_envelope UCCnetXSD_envelope_to_UCCnetGBO_envelope
UCCnetGBO_envelope For DTD XML definition type:

RouterMap_UCCnetGBO_envelope_to_
UCCnetDTD_envelope

For schema-document XML definition type:

RouterMap UCCnetGBO_envelope to_
UCCnetXSD_envelope

ItemBasic For DTD XML definition type:
RouterMap_CwItemBasic_to_
UCCnetDTD_envelope

For schema-document XML definition type:

CwItemBasic_to_UCCnetXSD_envelope_
registerCommand_itemAddChange

f. Save the connector configuration file to the ItemSyncLibrary ICL project with
File > Save > To Project. Close Connector Configurator Express.

Configuring the ERP-source connector

The ERP-source connector is the input connector for the UCCnet_ItemSync
collaboration object. This connector receives information from your Enterprise
Resource Planning (ERP) application and formats this information in the
appropriate application-specific business object. It converts this application-specific
business object to an ItemBasic business object, passing the ItemBasic business
object to the UCCnet_ItemSync collaboration. The UCCnet_ItemSync collaboration
delivers the ItemBasic business object to UCCnet through either the iSoftConnector
or JTextISoftConnector.

You choose the ERP-source connector based on the format that application-specific
information can be obtained from your ERP application. WebSphere Business
Integration Express for Item Sync provides the following adapters for use as
possible ERP-source connectors:

Adapter Purpose

Adapter for JDBC Handles application-specific information
using the Java Database Connectivity (JDBC)
and converts between this format and an
application-specific business object

Adapter for JMS Handles application-specific information
using the Java Message Service (JMS) and
converts between this format and an
application-specific business object

Adapter for JText Handles application-specific information in
file-system files and converts between this
format and an application-specific business
object

Adapter for WebSphere MQ Handles application-specific information
using WebSphere MQ queues and converts
between this format and an
application-specific business object

Adapter for XML Handles application-specific information in
XML and converts between this format and
an application-specific business object




Adapter Purpose

Adapter for Web Services Handles application-specific information in
SOAP and converts between this format and
an application-specific business object

Once you have selected the appropriate ERP-source connector, you must create and
configure it with the following steps:

Note: These steps assume that you have already created the application-specific
business object definition and map for your ERP-source item information, as
described in|“Creating the ERP-source components” on page 11]If you have
not yet completed these steps, you must do so before continuing with the
creation of the ERP-source connector.

1. Create the connector configuration file for the ERP-source connector using
Connector Configurator Express. For general information on how to use this
tool to create a connector configuration file, see the Connector Configurator
Express appendix in your adapter guide.

a. In the New Connector dialog, specify the name of your ERP-source
connector in the Name field in the form ERPSourceConnector, where
ERPSource can either be the literal string "ERPSource” or a string that
identifies the format or source application of your ERP-source information.
For example, if your ERP item information is obtained using the JDBC
interface, you could use the JDBC connector and name this connector
JDBCsourceERPConnector.

b. In the New Connector dialog, select the appropriate connector template
from the Template Name table. For example, if your ERP-source connector
is the Adapter for JDBC, highlight the entry for JDBC in the Template Name
table. The properties from the JDBC connector template display in the
Property Template Preview section. When you click OK, Connector
Configurator Express displays the configuration tabs.

c. For the Standard Properties and Connector-Specific Properties tabs, provide
the necessary values for the configuration properties. For information on the
configuration properties for your ERP-source connector, see the associated
adapter guide.

d. In the Supported Business Objects tab, add the business object definitions
listed in [Table 18

Table 18. Supported business objects for ERP-source connector

Agent support
Business object definition required?

ERP-source application-specific business object definition (This is the Yes
business object definition that you created for the ERP-source connector.
For more information, see [“Creating ERP-source business objects” on|

ItemBasic No

e. Save the connector configuration file to the ItemSyncLibrary project with the
File > Save > To Project menu option.

f. In the Associated Maps tab, add the maps listed in [Table 19 on page 24| to
the specified business object definitions.
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Table 19. Associated maps for ERP-source connector

Business object definition Name of map

ERP-source application-specific UCCnet_CwERPsource_to_CwItemBasic
business object (This is the map

that you created for the ERP-source
connector. For more
information}“Creating ERP-source]

[maps” on page 12))

UCCnet_CwItemBasic_to_CwERPsource

2. Save the connector configuration file to the ItemSyncLibrary ICL project with
File > Save > To Project. Close Connector Configurator Express.

Configuring the PortConnector
The PortConnector is a “dummy” connector to bind to collaboration ports that do

not send a business object to a connector during the Item Sync business process. To
create the PortConnector, you create a connector configuration file using Connector
Configurator Express. For general information on how to use this tool to create a
connector configuration file, see the Connector Configurator Express appendix in
your adapter guide.

1. In the Name field of the New Connector dialog, specify PortConnector. To
select the Port connector template, highlight the entry for Port in the Template
Name table. When you click OK, Connector Configurator Express displays the
configuration tabs.

2. For the Standard Properties and Connector-Specific Properties tabs, you need
not set any properties.

3. In the Supported Business Objects tab, you need not add any business object
definitions.

4. In the Associated Maps tab, you need not add any maps.

5. Save the connector configuration file to the ItemSyncLibrary ICL project with
File > Save > To Project. Do not close Connector Configurator Express.

Configuring the EmailConnector
You create the connector configuration file for the EmailConnector using Connector

Configurator Express. For general information on how to use this tool to create a
connector configuration file, see the Connector Configurator Express appendix in
your adapter user guide.

1. In the New Connector dialog, specify EmailConnector in the Name field. To
select the e-Mail connector template, highlight the entry for eMail in the
Template Name table. The properties from the e-Mail connector template
display in the Property Template Preview section. When you click OK,
Connector Configurator Express displays the configuration tabs.

2. In the Connector-Specific Properties tab, set the SMTP_MailHost property to
the hostname (or IP address) of the SMTP server in your system.

3. Save the connector configuration file to the ItemSyncLibrary project with the
File > Save > To Project menu option.

Creating collaboration objects

The WebSphere Business Integration Express for Item Sync system requires
runtime objects, called collaboration objects, for its collaboration templates. The
following table lists the collaboration objects you must create, based on their
associated collaboration template.
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Table 20. Collaboration objects for Item Sync

Collaboration template

Collaboration object

UCCnet_ItemSync

For schema-document XML definition type:
* ItemCommandRouter

¢ UCCnetXSD_CIN_DISPATCHER
UCCnet_requestWorklist
UCCnet_processWorklist

Notify_by_eMail

UCCnet_ItemSyncObject
UCCnetXSD_CIN_DISPATCHER_forICS_Obj
UCCnetXSD_CIN_DISPATCHER_forRWL_Obj

UCCnet_requestWorklistObject
UCCnet_processWorklistObject
UCCnet_processWorklist_
UNKNOWN_RESPONSEObject

UCCnet_processWorklist_
AUTHORIZATION_RESPONSEODbject

UCCnet_processWorklist_
DEAD_LETTER_PUB_RECEIPTObject

UCCnet_processWorklist_
CATEGORY_ADD_CHANGEODbject

UCCnet_processWorklist_
UNKNOWN_MESSAGESObject

UCCnet_processWorklist_
SIMPLE_RESPONSEObject

You create collaboration objects in the System Manager tool. Before beginning the
steps in the subsequent sections, start up System Manager and connect to the
WebSpherelCS instance of InterChange Server Express. For information on how to
start up System Manager, see [‘Starting System Manager” on page 3.|

Creating the collaboration for UCCnet_ltemSync
The collaboration object for the UCCnet_ItemSync collaboration template is called

UCCnet_ItemSyncObject. You create a collaboration object from System Manager.

To configure this collaboration object, complete the following steps:

1. Right-click on the Collaboration objects folder of the ItemSyncLibrary project
(in System Manager). From the context menu, choose Create New Collaboration
Object. System Manager displays the Create New Collaboration dialog.

2. In the Create New Collaboration dialog, enter the following information:

a. Highlight UCCnet_ItemSync in the Template name column of the table.

b. In the Collaboration object name field at the bottom of the dialog, enter the
name of this collaboration object: UCCnet_ItemSyncObject

c. Click Next to display the Bind ports dialog. Bind the ports of this
collaboration object as shown in the following table.

Table 21. Port Bindings for UCCnet_ItemSync

Collaboration port Type Bind to

DestinationAppRetrieve | Connector PortConnector

From Connector Your ERP-source connector (for
example, JDBCsourceERPConnector)
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Table 21. Port Bindings for UCCnet_ItemSync (continued)

Collaboration port

Type

Bind to

To (For DTD XML
definition type)

To (For schema-document
XML definition type)

Connector

Collaboration

The connector that sends the
ItemBasic business object to UCCnet
(though the iSoft Peer-to-Peer Agent):
* If you are using the iSoft
connector: specify iSoftConnector
* If you are using UCCnet CLU:
specify JTextISoftConnector

ItemCommandRouter_Obj.
From

Note: If you are configuring the ItemSync collaboration to work with
schema-document XML definitions, you cannot bind the To port of
this UCCnet_ItemSync collaboration object at this time. The
collaboration object that contains the port to which this port is bound
has not yet been created. You can bind this port later, once the
ItemCommandRouter_Obj collaboration object exists. Continue with
the steps outlined in this section. When you reach |”Creating tha

[collaboration objects for schema-based XML” on page 27",

instructions are provided for finishing the port binding for the
UCCnet_ItemSyncObject collaboration object.

d. Click Next to display the Collaboration General Properties dialog. Set any
general properties for this collaboration object. If you want to set a tracing
level, specify a value for the system trace level or the collaboration trace
level in this dialog.

e. Click Next again to display the Properties dialog, which shows the
collaboration-specific properties. Set the collaboration-specific properties for
this collaboration object as shown in the following table.

Table 22. Collaboration-specific properties for UCCnet_ItemSync

Property name Property description Required?
GtinDB_User smbadmin Yes
GtinDB_PASSWORD smbP4$$word Yes

JDBC_DRIVER

JDBC_URL

SEND_EMAIL

SEND_EMAIL_TO

The name of the JDBC driver used to
connect to the ICS repository database.

For more information, see the description

of the DRIVER property in|“Creating th

[logging table” on page 4

The JDBC URL that corresponds to the
driver that JDBC_DRIVER specifies. For
more information, see the description of
the DATA_SOURCE_NAME property in
|“Creating the logging table” on page 4.|
Determines whether the Item Sync
collaboration sends email when it
generates certain messages To send
email, set this property to the value "all”.
Otherwise, set it to "none”.

Specifies the email address where the
Item Sync sends email messages,
assuming that the SEND_EMAIL
property is set.

Yes, if InterChange Server Express does
not register the driver in the Java Virtual
Machine (JVM). The Microsoft SQL
driver, for example, is already registered
in the JVM.

Yes

Yes, if you want the Item Sync
collaboration to send email

No. Requires:
* the EmailConnector

e The SEND_EMAIL property set to
Uallﬂ
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Table 22. Collaboration-specific properties for UCCnet_ItemSync (continued)

Property name

Property description

Required?

AUDITLOG_INSTANCE_
NAME
SUPPLIER_NAME

UCCnet

entries.

Yes

Specifies the name of the partner thatis | No
synchronizing item information with
UCCnet. This value is logged in audit

f. Click Finish to complete the definition of this collaboration object. System

Manager displays the Graphical View of this collaboration object. Do not
close this Graphical View of the UCCnet_ItemSyncObject collaboration

object.

Creating the collaboration objects for schema-based XML
If your Item Sync solution uses the UCCnet Envelope that is based on the
schema-document XML definition type (Envelope.xsd), you must create two special
collaboration objects to handle routing of information:

* A collaboration object for the ItemCommandRouter collaboration template
* A collaboration object for the UCCnetXSD_CIN_DISPATCHER collaboration

template

Note: If your Item Sync collaboration uses the UCCnet Envelope that is based on
the DTD XML definition type (Envelope.dtd), you do not have to create the
collaboration objects described in this section. You can skip this section and
continue to the creation of the collaboration object for the
UCCnet_processWorklist collaboration template.

Creating the collaboration object for ItemCommandRouter: The collaboration
object for the [temCommandRouter collaboration template is called
ItemCommandRouter_Obj. You create a collaboration object from System Manager.

To configure this collaboration object, complete the following steps:

1.

Right-click on the Collaboration objects folder of the ItemSyncLibrary project

(in System Manager). From the context menu, choose Create New Collaboration
Object. System Manager displays the Create New Collaboration dialog.

In the Create New Collaboration dialog, enter the following information:

a. Highlight ItemCommandRounter in the Template name column of the table.

b. In the Collaboration object name field at the bottom of the dialog, enter the
name of this collaboration object: ItemCommandRouter_Obj

Click Next to display the Bind ports dialog. Bind the ports of this collaboration
object as shown in the following table.

Table 23. Port bindings for ltemCommandRouter

Collaboration port Type Bind to

From Collaboration UCCnet_ItemSyncObject.To

TO_RCIR Connector iSoftConnector

TO_CIN Collaboration UCCnetXSD_CIN_DISPATCHER_forICR
_Obj.From

Note: You cannot bind the TO_CIN port of this ItemRouterCommand_Obj
collaboration object at this time. The collaboration object that contains
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the port to which this port is bound has not yet been created. You can
bind this port later, once the

UCCnetXSD_CIN_DISPATCHER _forICR_Obj collaboration object exists.
Continue with the steps outlined in this section. When you reach
[“Creating the collaboration object for UCCnet_XSD_CIN_DISPATCHER,”|
instructions are provided for finishing the port binding for the
ItemCommandRouter_Obj collaboration object.

Click Next to display the Collaboration General Properties dialog. Set any
general properties for this collaboration object. If you want to set a tracing
level, specify a value for the system trace level or the collaboration trace level
in this dialog.

Click Finish to complete the definition of this collaboration object. The
ItemCommandRouter collaboration template does not have any
collaboration-specific properties. Therefore, you can skip the Properties dialog.

System Manager displays in the Graphical View tab the

ItemCommandRouter_Obj collaboration object. Do not close this collaboration

object so you can return to it later.

Complete the binding for the UCCnet_ItemSyncObject with the following steps:

a. Open the collaboration object for UCCnet_ItemSyncObject in the Graphical
View tab by clicking on its name in the heading of the tab. If you have
already closed UCCnet_ItemSyncObject, double-click on its name in the
Collaboration objects folder of System Manager to display it in the
Graphical View tab.

b. Switch to the Tree View for the collaboration object and right-click on the To
port. From the context menu, select Bind Port.

c. From the Configure Port dialog:
1) Select Collaboration for BindWith

2) Select ItemCommandRouter_Obj.From from the list of collaboration
object ports.

d. Click OK to save the new binding.
e. Close the UCCnet_ItemSyncObject collaboration object.

Creating the collaboration object for UCCnet_XSD_CIN_DISPATCHER: When
you are using the schema-document XML definition type, you need to create two
collaboration objects for the UCCnetXSD_CIN_DISPATCHER collaboration
template.

Complete the following steps:

1.

Right-click on the Collaboration objects folder of the ItemSyncLibrary project
(in System Manager). From the context menu, choose Create New
Collaboration Object. System Manager displays the Create New Collaboration
dialog.

In the Create New Collaboration dialog, enter the following information:

a. Highlight UCCnetXSD_CIN_DISPATCHER in the Template name column
of the table.

b. In the Collaboration object name field at the bottom of the dialog, enter
the name of this collaboration object:
UCCnetXSD_CIN_DISPATCHER_forIRC_Obj

Click Next to display the Bind ports dialog. Bind the ports of this

collaboration object as shown in [Table 24 on page 29




Table 24. Port bindings for UCCnetXSD_CIN_DISPATCHER_forIRC_Obj

Collaboration port Type Bind to

DestinationAppReceive Connector PortConnector

From Collaboration ItemCommandRouter_Obj.TO_CIN
To Connector iSoftConnector

4. Click Next to display the Collaboration General Properties dialog. Set any

general properties for this collaboration object. If you want to set a tracing
level, specify a value for the system trace level or the collaboration trace level
in this dialog.

. Click Next again to display the Properties dialog, which shows the

collaboration-specific properties. Set the collaboration-specific properties for
this collaboration object as shown in the following table.

Table 25. Collaboration-specific properties for UCCnetXSD_CIN_DISPATCHER_forlRC_Obj

Property name

Property description Required?

CIN_DISPATCHER_GLN_FILE The fully qualified name of the file that holds the Yes

GLNs subscribed to each category code.

TO_UCCNETGBO_PROCESSING_MAP By the UCCnet_CIN_DISPATCHER object to map Yes

SUPPLIER_NAME

incoming ItemBasic objects to the outgoing
CATALOGUE_ITEM_NOTIFICATIONMessage.
The name of the partner responsible for No
synchronizing item information with UCCnet. This
value is included in audit log entries.

6. Click Finish to complete the definition of this collaboration object. System

Manager displays this collaboration object in the Graphical View. You can
close the UCCnetXSD_CIN_DISPATCHER_forIRC_Obj collaboration object in
the Graphical View.

. Complete the binding for the ItemCommandRouter_Obj with the following

steps:

a. Open the collaboration object for ItemCommandRouter_Obj in the
Graphical View tab by clicking on its name in the heading of the tab. If
you have already closed ItemCommandRouter_Obj, double-click on its
name in the Collaboration objects folder of System Manager to display it
in the Graphical View tab.

b. Switch to the Tree View for the collaboration object and right-click on the
TO_CIN port. From the context menu, select Bind Port.

c. From the Configure Port dialog:
1) Select Collaboration for BindWith.

2) Select UCCnetXSD_CIN_DISPATCHER_forICR_Obj.From from the list
of collaboration object ports.

d. Click OK to save the new binding.
e. Close the ItemCommandRouter_Obj collaboration object.

. Repeat steps 1 and 2 to begin creation of the second collaboration object for

UCCnetXSD_CIN_DISPATCHER,
UCCnetXSD_CIN_DISPATCHER_forRWL_Obj:

a. Select UCCnetXSD_CIN_DISPATCHER as the collaboration template to
use.

b. Name the collaboration object
UCCnetXSD_CIN_DISPATCHER_forRWL_Obj.
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9.

Click Next to display the Bind ports dialog. Bind the ports of this
collaboration object as shown in the following table.

Table 26. Port bindings for UCCnetXSD_CIN_DISPATCHER_forRWL_Obj

Collaboration port Type Bind to

DestinationAppReceive Connector PortConnector

From Collaboration UCCnet_processWorklist. CIN_DISPATCHER
To Connector iSoftConnector

10.

11.

12.

Note: You cannot bind the From port of this
UCCnetXSD_CIN_DISPATCHER_forRWL_ODbj collaboration object at
this time. The collaboration object that contains the port to which this
port is bound has not yet been created. You can bind this port later,
once the UCCnet_processWorklistObject collaboration object exists.
Continue with the steps outlined in this section. When you reach
[‘Creating the collaboration object for UCCnet_processWorklist,”|
instructions are provided for finishing the port binding for the
UCCnetXSD_CIN_DISPATCHER_forRWL_Obj collaboration object.

Click Next to display the Collaboration General Properties dialog. Set any
general properties for this collaboration object. If you want to set a tracing
level, specify a value for the system trace level or the collaboration trace level
in this dialog.

Click Next again to display the Properties dialog, which shows the
collaboration-specific properties. Set the collaboration-specific properties for
this collaboration object the same as those shown in the table for
UCCnetXSD_CIN_DISPATCHER_forIRC_Ob;.

Click Finish to complete the definition of this collaboration object. System
Manager displays this collaboration object in the Graphical View. Do not close
this Graphical View of the UCCnetXSD_CIN_DISPATCHER_forRWL_Obj
collaboration object so you can return to it later.

Creating the collaboration object for UCCnet_processWorklist
The collaboration object for the UCCnet_processWorklist collaboration template is

called UCCnet_processWorklistObject.

To configure this collaboration object, complete the following steps:

1.

3.

Right-click on the Collaboration objects folder of the ItemSyncLibrary project
(in System Manager). From the context menu, choose Create New Collaboration
Object. System Manager displays the Create New Collaboration dialog.

In the Create New Collaboration dialog, enter the following information:

a. Highlight UCCnet_processWorklist in the Template name column of the
table.

b. In the Collaboration object name field at the bottom of the dialog, enter the
name of this collaboration object: UCCnet_processWorklistObject

Click Next to display the Bind ports dialog. Bind only the ports of this
collaboration object that are shown in the following table.

Table 27. Initial port bindings for UCCnet_processWorklist

Collaboration port Type Bind to
From Connector iSoftConnector or JTextISoftConnector
ITEM_ADD_CHANGE Connector iSoftConnector or JTextISoftConnector
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Table 27. Initial port bindings for UCCnet_processWorklist (continued)

Collaboration port Type Bind to
NEW_ITEM_PUBLICATION_REQUEST Connector iSoftConnector or JTextISoftConnector
INITIAL_ITEM_LOAD_REQUEST Connector iSoftConnector or JTextISoftConnector
CIN_DISPATCHER Connector UCCnetXSD_CIN_DISPATCHER _
forRWL_Obj.From
DestinationAppReceive Connector PortConnector

Note: The table above lists only those ports of the
UCCnet_processWorklistObject collaboration object that you can bind at
this time. You cannot bind the following ports of this collaboration

object:

* CATEGORY_ADD_CHANGE

* DEAD_LETTER_PUB_RECEIPT
* AUTHORIZATION_RESPONSES
* UNKNOWN_RESPONSE

* UNKNOWN_MESSAGE

* SIMPLE_RESPONSE

* CATALOGUE_ITEM_CONFIRMATION

All of these ports must be bound to a collaboration object based on the
Notify_by_eMail collaboration template. You can bind these ports later,
once these Notify_by_eMail collaboration objects exist. Continue with the
steps outlined in this section. When you reach |”Creating tha

[collaboration objects for Notify_by_eMail” on page 32/ instructions are

provided for finishing the port binding for the
UCCnet_processWorklistObject collaboration object.

4. Click Next to display the Collaboration General Properties dialog. Set any

general properties for this collaboration object. If you want to set a tracing
level, specify a value for the system trace level or the collaboration trace level

in this dialog.

Click Next again to display the Properties dialog, which shows the
collaboration-specific properties. Set the collaboration-specific properties for this

collaboration object as shown in [Table 2§

Table 28. Collaboration-specific properties for UCCnet_processWorklistObject

Property name Property description Required?
DB_USER smbadmin Yes
DB_PASSWORD smbP4$$word Yes

JDBC_DRIVER

JDBC_URL

The name of the JDBC driver used to connect
to the ICS repository database. For more
information, see the description of the
DRIVER property in [“Creating the logging]
|tab1e” on page 4.|

The JDBC URL that corresponds to the driver
that JDBC_DRIVER specifies. For more
information, see the description of the

DATA_SOURCE_NAME property in [Creating

[the logging table” on page 4

Yes, if InterChange Server Express
does not register the driver in the
Java Virtual Machine (JVM). The
Microsoft SQL driver, for example,
is already registered in the JVM.
Yes
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Table 28. Collaboration-specific properties for UCCnet_processWorklistObject (continued)

Property name Property description Required?

SEND_EMAIL_TO Specifies the email address where the Item No.Requires: the EmailConnector
Sync sends email messages, assuming that the | The SEND_EMAIL property set to
SEND_EMAIL property is set. "all”

SEND_EMAIL Determines whether the Item Sync Yes, if you want the Item Sync
collaboration sends email when it generates collaboration to send email
certain messages To send email, set this
property to the value "all”. Otherwise, set it to
"none”.

AUDITLOG_INSTANCE_ UCCnet Yes

NAME

SUPPLIER_NAME The name of the partner responsible for No

DTD_URL

AUTO_RESPOND

synchronizing item information with UCCnet.
This value is included in audit log entries.
Specifies the value for the DOCTYPE line in No, unless the default value is
outgoing XML. The default value is: incorrect for the environment
DOCTYPE envelope SYSTEM
http://www.uccnet.net/xmlschema/2.2/
envelope_file

For the DTD XML definition type, replace
envelope_file with: Envelope.dtd

For the schema-document XML definition

type, replace envelope_file with: Envelope.xsd
Controls whether an automatic response is set | Yes
to UCCnet
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6. Click Finish to complete the definition of this collaboration object. System
Manager displays the collaboration object in the Graphical View. Do not close
this Graphical View of the UCCnet_processWorklistObject collaboration object
so you can return to it later.

7. If you are using the schema-document XML definition type for your UCCnet
Envelope, complete the binding for the
UCCnetXSD_CIN_DISPATCHER_forRWL_Obj with the following steps:

a. Open the collaboration object for
UCCnetXSD_CIN_DISPATCHER_forRWL_Obj in the Graphical View tab by
clicking on its name in the heading of the tab. If you have already closed
UCCnetXSD_CIN_DISPATCHER_forRWL_Obj, double-click on its name in
the Collaboration objects folder of System Manager to display it in the
Graphical View tab.

b. Switch to the Tree View for the collaboration object and right-click on the
From port. From the context menu, select Bind Port.

c. From the Configure Port dialog:
1) Select Collaboration for BindWith.
2) Select UCCnet_processWorklistObject. CIN_DISPATCHER from the list of
collaboration object ports.
d. Click OK to save the new binding.
e. Close the UCCnetXSD_CIN_DISPATCHER_forRWL_ODbj collaboration object.

Creating the collaboration objects for Notify_by_eMail
The Item Sync collaboration requires several collaboration objects for the
Notify_by_eMail collaboration template.



To configure these collaboration objects, complete the following steps:
1. Right-click on the Collaboration objects folder of the ItemSyncLibrary project

(in System Manager). From the context menu, choose Create New Collaboration

Object. System Manager displays the Create New Collaboration dialog.
2. In the Create New Collaboration dialog, enter the following information:
a. Highlight Notify_by_eMail in the Template name column of the table.

b. In the Collaboration object name field at the bottom of the dialog, enter the

name of this collaboration object and click Next. The following table lists
the names of all collaboration objects based on the Notify_by_eMail
collaboration template.
3. In the Bind ports dialog, bind the From port of each Notify_by_eMail
collaboration object to a Collaboration, as shown in the following table.

Table 29. Port bindings for Notify_by_eMail

Collaboration object Bind to collaboration object port
UCCnet_processWorklist_ UCCnet_processWorklistObject:
CATEGORY_ADD_CHANGEODbject CATEGORY_ADD_CHANGE
UCCnet_processWorklist_ UCCnet_processWorklistObject.
DEAD_LETTER_PUB_RECEIPT DEAD_LETTER_PUB_RECEIPT
UCCnet_processWorklist_ UCCnet_processWorklistObject.
AUTHORIZATION_ AUTHORIZATION_RESPONSES
RESPONSES

UCCnet_processWorklist_ UCCnet_processWorklistObject.
UNKNOWN_RESPONSE UNKNOWN_RESPONSE
UCCnet_processWorklist_ UCCnet_processWorklistObject.
UNKNOWN_MESSAGES UNKNOWN_MESSAGES
UCCnet_processWorklist_ UCCnet_processWorklistObject.
SIMPLE_RESPONSE SIMPLE_RESPONSE
UCCnet_processWorklist_ UCCnet_processWorklistObject.
CATALOGUE_ITEM_ CATALOGUE_ITEM_CONFIRMATION
CONFIRMATION

4. Click Next to display the Collaboration General Properties dialog. Set any
general properties for this collaboration object. If you want to set a tracing

level, specify a value for the system trace level or the collaboration trace level

in this dialog.
5. Click Next again to display the Properties dialog, which shows the

collaboration-specific properties. For each of the Notify_by_eMail collaboration

objects, set the collaboration-specific properties for this collaboration object as
shown in the following table.

Table 30. Collaboration-specific properties for Notify_by_eMail

Property name Property description Required
EMAIL_NOTIFICATION_RCPTS Lists the email address of the message recipient Yes
EMAIL_SUBJECT Specifies the format of the subject line of the email Yes

EMAIL_MESSAGE

message. For more information on the syntax that this
property supports, see the description of this property
in the reference page for the UCCnet Item
Synchronization Collaboration.

Specifies the format body of the email message. For Yes
more information on the syntax that this property
supports, see the description of this property in the
reference page for the UCCnet Item Synchronization
Collaboration.
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Table 30. Collaboration-specific properties for Notify_by_eMail (continued)

Property name Property description Required

DOCTYPE Specifies the value for the DOCTYPE line in outgoing | Yes
XML. The default value is:

DOCTYPE envelope SYSTEM
http://www.uccnet.net/xmlschema/2.2/
envelope_file

For the DTD XML definition type, replace envelope_file
with: Envelope.dtd For the schema-document XML
definition type, replace envelope_file with:
Envelope.xsd

6. Click Finish to complete the definition of the collaboration object. System
Manager displays the Graphical View of this collaboration object. Close the
Graphical View for each of the Notify_by_eMail collaboration objects.

7. Complete the binding for the UCCnet_processWorklistObject with the following
steps:
a. Open the collaboration object for UCCnet_processWorklistObject in the
Graphical View tab by clicking on its name in the heading of the Graphical
View tab. If you have already closed UCCnet_processWorklistObject,
double-click on its name in the Collaboration objects folder of System
Manager to display it in the Graphical View tab.

b. Switch to the Tree View for the collaboration object. For each of the ports
listed in the following table, right-click on the port and select Bind Port
from the context menu. Provide the information in the Configure Port
dialog as listed in the following table.

Table 31. Final port bindings for UCCnet_processWorklist

Collaboration object port Bind to collaboration object port
CATEGORY_ADD_CHANGE UCCnet_processWorklist_
CATEGORY_ADD_CHANGEObject.From
DEAD_LETTER_PUB_RECEIPT UCCnet_processWorklist_
DEAD_LETTER_PUB_RECEIPTODbject.From
AUTHORIZATION_RESPONSES UCCnet_processWorklist_
AUTHORIZATION_RESPONSESObject.From
UNKNOWN_RESPONSE UCCnet_processWorklist_
UNKNOWN_RESPONSEODbject.From
UNKNOWN_MESSAGES UCCnet_processWorklist_
UNKNOWN_MESSAGESObject.From
SIMPLE_RESPONSE UCCnet_processWorklist_
SIMPLE_RESPONSEODbject.From
CATALOGUE_ITEM_ UCCnet_processWorklist_
CONFIRMATION CATALOGUE_ITEM_
CONFIRMATIONODbject.From

¢. Once you have completed the port bindings for all the collaboration objects
in the preceding table, you can close the UCCnet_processWorklistObject
collaboration object.

Creating the collaboration object for UCCnet_requestWorklist
The collaboration object for the UCCnet_requestWorklist collaboration template is
called UCCnet_requestWorklistObject. You create a collaboration object from
System Manager.
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To configure this collaboration object, complete the following steps:

1. Right-click on the Collaboration objects folder of the ItemSyncLibrary project
(in System Manager). From the context menu, choose Create New Collaboration
Object. System Manager displays the Create New Collaboration dialog.

2. In the Create New Collaboration dialog, enter the following information:

a. Highlight UCCnet_requestWorklist in the Template name column of the
table.

b. In the Collaboration object name field at the bottom of the dialog, enter the
name of this collaboration object: UCCnet_requestWorklistObject

3. Click Next to display the Bind ports dialog. Bind the ports of this collaboration
object as shown in the following table.

Table 32. Port bindings for UCCnet_requestWorklist

Collaboration port Type Bind to
From Connector JTextRWLConnector
To Connector iSoftConnector or JTextISoftConnector

4. Click Next again to display the Properties dialog, which shows the
collaboration-specific properties. Set the collaboration-specific properties for this
collaboration object as shown in the following table.

Table 33. Collaboration-specific properties for UCCnet_requestWorklist

Property name Property description Required
DTD_URL Specifies the value for the DOCTYPE line in No, unless the default value is
outgoing XML. The default value is: incorrect for the environment

DOCTYPE envelope SYSTEM
http://www.uccnet.net/xmlschema/2.2/
envelope file

For the DTD XML definition type, replace
envelope_file with: Envelope.dtd For the
schema-document XML definition type, replace
envelope_file with: Envelope.xsd
SET_UNIQUE_IDS Controls whether unique IDs (messageldentifier No
and uniqueCreateorldentification) are set in the
output XML messages. Possible values are:

e ALL: set all three unique IDs (default)

* NONE

* BLANK: set unique ID only if it is blank in the
input

5. Click Finish to complete the definition of this collaboration object. System
Manager displays this collaboration object in the Graphical View. You can close
the UCCnet_requestWorklistObject collaboration object in the Graphical View.

Deploying the solution

Once you have created all the components in the ItemSyncLibrary ICL project, you
are ready to create a user project and deploy this project to the WebSpherelCS
instance of InterChange Server Express.

To deploy the solution, complete these steps:

1. Create a user project from System Manager:
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a. Right-click on the User Projects folder and select New User Project.

b. From the New User Project dialog, enter the name of your user project in
the Project name field and click in the box next to the ItemSyncLibrary in
the Available Integration Component Libraries box.

c. Click Finish. Once System Manager creates your user project, you will see a
plus sign ("+") appear next to the User Projects folder. Under this folder you
will find a folder called InterChange Server Projects, and under that folder
will be the folder for your new user project.

2. Make sure your InterChange Server instance is in Design mode. You can check

the InterChange Server view in System Manager to determine the mode of your
ICS instance. If your instance does not list "Design” in its Mode column, you
must bring down the ICS instance and bring it back up in Design mode. For
information on how to bring up ICS in the different modes, see the User Guide
for WebSphere Business Integration Express for Item Synchronization.

. Deploy the user project to the WebSpherelCS ICS instance with the Deploy

wizard.

a. Right-click on the WebSpherelCS instance and select Add user project. Click
on the new user project that you created.

b. The newly added user project appears under the WebSpherelCS instance.
Right-click on the WebSpherelCS instance and select Deploy Project. The
Deploy Wizard dialog displays.

c. Expand the user project that you are deploying, to see a list of project
components.

d. Deploy the business object definitions by clicking in the box beside the
Business Objects folder. Click Next and then click Finish to start the
deployment of business object definitions.

e. Start the Deploy wizard again and deploy the maps by clicking in the box
beside the Maps folder and checking the Compile option. Click Next, then
click Finish to start the deployment of maps.

f. Start the Deploy wizard again and deploy the relationships by clicking in
the box beside the Relationships folder and checking the Create schema
option. Click Next, then click Finish to start the deployment of relationships.

g. Start the Deploy wizard again and deploy the connectors by clicking in the
box beside the Connectors folder. Click Next, then click Finish to start the

deployment of connectors.

h. Start the Deploy wizard again and deploy the collaboration templates by
clicking in the box beside the Collaboration Templates folder. Click Finish to
start the deployment of collaboration templates.

. At this point, all components of the Item Sync solution except the collaboration

objects should be deployed to your WebSpherelCS instance. Before you deploy
collaboration objects, you must restart InterChange Server:

a. Right-click on your WebSpherelCS instance in the InterChange Server view
of System Manager. Select the Shutdown > Gracefully option.

b. Restart your ICS instance with the Start > Programs > IBM WebSphere
Business Integration Item Sync Express v4.3 > InterChange Server Express >
InterChange Server.

C. Reconnect to your WebSpherelCS instance in System Manager.

. Launch System Monitor and start the relationships.
. Start the Deploy wizard again and deploy the collaboration objects by clicking

in the box beside the Collaboration Objects folder. Click Finish to start the
deployment of collaboration objects.



Populating the relationships after deployment

After the relationships have been deployed, you must then populate them with
default values and make any necessary modifications to the default schemas. To
populate the relationships, complete the steps appropriate for your database server.

DB2 Database Server

1.

Move to the following directory:
ProductDir\collaborations\dependencies\UCCnet\db2

Start a DB2 session by opening a DB2 command window with the following
menu option: Start > Programs > IBMDB2 > Command Line Tools > Command
Window.

At the prompt, enter the following comment: db2 connect to SMB_DB USER
smbadmin USING smbP4$$word

After you are connected, enter the following command to run the script that
creates the audit_log table: audit_log.sql

After you are connected, run one of the following SQL scripts:

* For solutions that use the DTD XML definition type, enter the command:
InitializeRelationshipTables.sql

¢ For solutions that use the schema-document XML definition type, enter the
command: InitializeRelationshipTablesForXSD.sql

Microsoft SQL Server

1.

If you have not left the Query Analyzer open from earlier configuration steps,
start the Query Analyzer with Start > Programs > Microsoft SQL Server >
Query Analyzer and enter the following information in the Connect to SQL
Server dialog:

a. Make sure that the SQL Server authentication radio button is selected.

b. Log into the ICS database server with the following default account
information:

Account: smbadmin
Password: smbP4$$word

Note: This account information is the default database user account that the
WebSphere Business Integration Express for Item Sync Installer
creates. If you have modified this account since it was created, use
the current account information.

c. Select the ICS repository database by selecting the SMB_DB database from
the dropdown menu in the Query Analyzer toolbar.

Load the appropriate relationship-table script into the Query Analyzer with File
> Open.

* For solutions that use the DTD XML definition type, enter the command:
InitializeRelationshipTables.sql

* For solutions that use the schema-document XML definition type, enter the
command: InitializeRelationshipTablesForXSD.sql

This script is located in the following directory:
ProductDir\collaborations\dependencies\ UCCnet\mss

Run the relationship-table script with Query > Execute.
Exit Query Analyzer.
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Restarting ICS Express and starting your Adapter

After you have deployed the project, you will need to restart ICS Express. In
addition, you will have to start your adapter.

1. To start ICS Express, choose Start > Programs > IBM WebSphere Business
Integration for Item Sync Express v4.3 > InterChange Server Express.

2. To start the adapter, choose Start > Programs > IBM WebSphere Business
Integration for Item Sync Express v4.3 >Adapters > Connectors > name of your
adapter.

For more information, see the following: User Guide for WebSphere Business
Integration Express for Item Synchronization.

Administration

Administration tasks for WebSphere Business Integration Express for Item
Synchronization includes the following:

* Monitoring the system
* Operating ICS Express
* Operating connectors

* Operating maps

* Operating relationships

For detailed information regarding Administration, see the following: User Guide
for WebSphere Business Integration Express for Item Synchronization.

38  Quick Start Guide



Notices

IBM may not offer the products, services, or features discussed in this document in
all countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or program(s) described in this publication
at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Burlingame Laboratory Director
IBM Burlingame Laboratory
577 Airport Blvd., Suite 800
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Burlingame, CA 94010
US.A

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurement may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not necessarily tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

This information may contain examples of data and reports used in daily business

operations. To illustrate them as completely as possible, the examples may include

the names of individuals, companies, brands, and products. All of these names are

fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

Programming interface information

Programming interface information, if provided, is intended to help you create
application software using this program.

General-use programming interfaces allow you to write application software that
obtain the services of this program’s tools.

However, this information may also contain diagnosis, modification, and tuning
information. Diagnosis, modification and tuning information is provided to help
you debug your application software.

Warning: Do not use this diagnosis, modification, and tuning information as a
programming interface because it is subject to change.

Trademarks and service marks

The following terms are trademarks or registered trademarks of International
Business Machines Corporation in the United States or other countries, or both:
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IBM

the IBM logo
AIX
CrossWorlds
DB2

DB2 Universal Database
Domino
Lotus

Lotus Notes
MQIntegrator
MQSeries
Tivoli
WebSphere

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

MMX, Pentium, and ProShare are trademarks or registered trademarks of Intel
Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

Other company, product or service names may be trademarks or service marks of
others.

JAVA
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